Intersoft WebScheduler

Intersoft WebScheduler Documentation
Intersoft WebScheduler
Send Feedback

Glossary Item Box

This section contains information about WebScheduler.

In This Section

Getting Started

What's New in WebScheduler

Walkthrough Topics

How-to Topics

Overview

Features and Concepts

Server-side References

Client-side References

Product Support

Licensing

©2013 Intersoft Solutions Corp. All Rights Reserved.


Getting Started

Getting Started
See Also Send Feedback
Intersoft WebScheduler > Getting Started

Glossary Item Box

This section is designated to help you quickly getting started with WebScheduler.NET. You can use all links below to become familiar with WebScheduler.

Installation

The following topics will guide you how to install WebScheduler.NET and what the system requirements you need to have in order to run WebScheduler.NET in your PC.

  • Installation Guide
  • Manually installing WebScheduler to Visual Studio 2005 ToolBox
  • Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox
  • System Requirements

Deployment

This section will help you to configure and set the application in deploying the project to server. It also provides a Deployment Checklist which contains the essential things you need to manage before proceeding to deployment.

  • Deployment Guide
  • Application Wide Configurations

Samples and Walkthroughs

This section will provide you information to locate the sample and tutorial files of WebScheduler.NET.

  • Locating Sample Files
  • More Walkthrough Topics

Getting Started with WebScheduler from scratch

This section will help you to set and configure WebScheduler for the first time.

  • Step 1: Binding database to WebScheduler
  • Step 2: Configuring WebScheduler to displayvariety View settings
  • Step 3: Setting WebScheduler for data editing
  • Step 4: Using Calendar in WebScheduler

    • See Also

    Tasks
    {How-to Topics}

    Other Resources
    WebScheduler Overview
    {Features and Concepts}


Installation

Installation
See Also Send Feedback
Intersoft WebScheduler > Getting Started > Installation

Glossary Item Box

This section contains information on installing WebScheduler.NET and specifying the system requirements needed by the component.

In This Section

Installation Guide
Information about installing WebScheduler.NET on your PC.

Manually installing WebScheduler to Visual Studio 2005 ToolBox
Information about installing WebScheduler control to Visual Studio 2005 ToolBox manually.

Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox
Information about installing WebScheduler control to Visual Studio ToolBox using Toobox Utility tool.

System Requirements
Read about the Windows version, Visual Studio application, WebUI.NET Framework and other software requirements for installing WebScheduler.NET.

See Also

Other Resources
{Deployment}
{Samples and Walkthroughs}


Installation Guide

Installation Guide
See Also Send Feedback
Intersoft WebScheduler > Getting Started > Installation > Installation Guide

Glossary Item Box

Installation Requirement

For system requirement, please see the System Requirements section.

Installing WebScheduler 3

Intersoft has released the new setup installer which includes WebUI Framework 3, WebGrid Enterprise 7, WebCombo 4, WebInput 4, WebDesktop 3, WebTreeView, ISDataSource, WebScheduler 3, WebAqua 2, WebTextEditor, WebEssentials and ClientUI components.

Here are the step-by-step instructions to install WebScheduler 3:

  1. Double click on the "intersoft webui studio 2010 r1.exe" icon to start the installation process. Read the instructions, and click next.

  2. Please read the license agreement. You must accept the terms in the license agreement in order to install WebScheduler 3.

  3. Fill in your details such as User Name and Organization. Click Next to proceed.

  4. You can select the product edition and setup type that you would like to install and perform.

    The product contains three editions such as WebUI Studio for ASP.NET, WebUI Studio for Silverlight and WebUI Studio for WPF.

  5. You can select the target environment for the samples, either Microsoft Visual Studio 2008 or Microsoft Visual Studio 2010.

  6. You can also customize the Start Menu group and choose to create shortcuts for all users or just for yourself.

  7. Click Next to proceed with the installation process.

  8. The wizard is installing WebUI Studio 2010 R1.

  9. A window showing the installation progress appears. It will list the status of components that are being installed.

  10. After the installation process has been finished, you will see a confirmation window. Click Finish to close the window. At this rate, you have successfully installed the Intersoft WebUI Studio 2010 R1.

  11. To install the full version of WebScheduler 2, proceed by using License Manager that can be triggered from Start menu >> All Programs >> Intersoft WebUI Studio 2010 R1 >> License Manager.

  12. Intersoft License Manager window will appear. Click "Add License" to proceed to the next step.

  13. Now, Select a product from the combo box. In this case, select WebScheduler Version 3.0.1000 and enter the license according to the component.

  14. Click Add and it will automatically check the license with the server through internet connection. If it is correct, then you have successfully installed the full version of WebScheduler 3.

See Also

Other Resources
{Manually installing WebScheduler to Visual Studio 2005 Toolbox}
Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox
{System Requirements}


Manually installing WebScheduler to Visual Studio 2005 Toolbox

Manually installing WebScheduler to Visual Studio 2005 Toolbox
See Also Send Feedback
Intersoft WebScheduler > Getting Started > Installation > Manually installing WebScheduler to Visual Studio 2005 Toolbox

Glossary Item Box

This document provides a step-by-step guidance on how to manually install WebScheduler to Visual Studio 2005 ToolBox.

Step-By Step Instructions

To manually install WebScheduler to Visual Studio 2005 ToolBox

  1. Open Visual Studio 2005 application.
  2. Create a new WebSite application.
  3. In the Designer view, refer to the ToolBox on the left side.
  4. Right-click on the ToolBox and choose Add Tab.
  5. Named the Tab as "WebUI Studio.NET".
  6. Right-click on the created Tab and select Choose Items.
  7. Browse and Add ISNet.WebUI.WebScheduler.dll from C:\Program Files\Intersoft Solutions\WebUI Studio for ASP.NET\WebScheduler.NET 3.0\Bin.
  8. Finally, your ToolBox will look like the following:

    ToolBox

See Also

Other Resources
Installation Guide
{System Requirements}
Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox


Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox

Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox
See Also Send Feedback
Intersoft WebScheduler > Getting Started > Installation > Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox

Glossary Item Box

This topic provides a step-by-step instruction on how to manually add Intersoft products to Visual Studio Toolbox using Toolbox Utility tool.

To add Intersoft products to Visual Studio Toolbox

  1. Run Intersoft ToolBox Utility for Visual Studio from Start Menu >> All Programs >> Intersoft WebUI Studio 2010 R1 >> Intersoft ToolBox Utility for Visual Studio or you can access ToolBoxUtility.exe from [Installation Folder]\Intersoft Solutions\Intersoft WebUI Studio 2010 R1\ToolBoxUtility
  2. Select on the Visual Studio platform you want Intersoft products to be installed. By default, it will automatically select all Visual Studio versions installed on your PC.

  3. Click Register to run the tool and wait until the process is finished.

  4. Finally, open your project and you will notice that Intersoft products has been installed successfully into Visual Studio Toolbox.

See Also

Other Resources
{Installation Guide}
{System Requirements}
{Manually installing WebScheduler to Visual Studio 2005 Toolbox}


System Requirements

System Requirements
See Also Send Feedback
Intersoft WebScheduler > Getting Started > Installation > System Requirements

Glossary Item Box

Development Machine Requirements

  • Microsoft Windows Vista
  • Microsoft Windows 2000/2003/2008 Server family
  • Microsoft Windows XP Professional or Home Edition
  • Microsoft .NET Framework v2.0 or higher
  • Microsoft Visual Studio 2005 Professional/Team Studio/Express Edition
  • Microsoft Visual Studio 2008
  • Intersoft WebUI.NET Framework v3.0 or higher

Server Machine Requirements

  • Windows Server 2003 Enterprise
  • Windows Server 2003 Web Edition
  • Windows Server 2008
  • Internet Information Services 6.0 or later
  • Microsoft .NET Framework Version 2.0 or later
  • Intersoft WebUI.NET Framework v3.0 or higher

Client Machine Requirements

  • Microsoft Internet Explorer 5.5 or higher
  • Mozilla V1.7 +for Windows/Mac/Linux/Solaris
  • Firefox V1.0+ for Windows/Mac/Linux/Solaris
  • Netscape V7.0+ for Windows/Mac/Linux/Solaris
  • Opera 9.5+ for Windows/Mac/Linux/Solaris/FreeBSD/BeOS/QNX
  • Apple Safari 3+ for Windows/Mac

See Also

Other Resources
{Installation Guide}
{System Requirements}
{Manually installing WebScheduler to Visual Studio 2005 Toolbox}
Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox


Deployment

Deployment
See Also Send Feedback
Intersoft WebScheduler > Getting Started > Deployment

Glossary Item Box

This section contains information on configuring the application and guiding user with a step-by-step Checklist instructions for deployment purposes.

In This Section

Deployment Guide
Information about Deployment Checklist that will list all the important tasks you need to do before deploying the project.

Application Wide Configurations
Read about the WebScheduler's ability to configure deployment-related properties via web.config, such as ScriptDirectory and many others.

See Also

Other Resources
{Installation}
{Samples and Walkthroughs}


Deployment Guide

Deployment Guide
Send Feedback
Intersoft WebScheduler > Getting Started > Deployment > Deployment Guide

Glossary Item Box

This section continues to guide you on how to deploy the project by using Deployment Manager and SmartWebResources™.

In This Section

Using Deployment Manager
Learn how to use deployment manager to set the web.config.

Deploying project that uses SmartWebResources™
Information about deploying project using SmartWebResources™.

Deploying project that does not use SmartWebResources�?�
Information about deploying project without using SmartWebResources™. In other words, you need to copy CommonLibrary, project's directory and assemblies.


Using Deployment Manager
See Also Send Feedback
Intersoft WebScheduler > Getting Started > Deployment > Deployment Guide > Using Deployment Manager

Glossary Item Box

Intersoft comes up with a new hassle-free Deployment Manager that is designated to help developers to easily manage configurations during deployment phase.

Now, you can quickly configure the common settings required in deployment such as entering runtime license keys, view state configurations and others through user-friendly Windows GUI application.

Using Deployment Manager

Here are the step-by-step instructions to use Deployment Manager:

  1. Open Deployment Manager from Start menu >> All Programs >> Intersoft WebUI Studio.NET 2008 R2 >> ASP.NET >> WebUI.NET Framework 3.0 >> Deployment Manager.
  2. Click Browse and select the project's directory of your web application to be configured. Click Next afterwards.

  3. Tick WebScheduler.NET 2.0.1000 and put the Runtime License key according to the component. Click Next to proceed to the next step.

  4. In this step, there are many settings you can configure such as View State Storage, Optimization, Client Resources and Advanced sections.

    View State Storage Section

    View State Storage section lets you configure how ViewState is stored, specify how ViewState items are going to be saved in ViewState and determine the priority and duration of items stored in Cache object.

    Optimization Section

    Optimization section lets you choose whether to enable CSS Optimization and XML compression.

    Client Resources Section

    This section contains information on how to enable WebResources and set its mode.

    If you have applied SmartWebResources™ in your project, this option will be automatically selected with its default mode set to Auto.

    Advanced Section

    Advances section allows you to add necessary keys such as SharedScriptDirectory, ImagesDirectory or custom keys.

    In this section, you will learn how to assign the keys and values needed when you deploy the project.
    - In Advances section, click the ">" sign to move the available keys to the applied keys.
    - In Applied Keys table, Set the values like following:

    Key | Value
    ScriptDirectory | ~/CommonLibrary/WebScheduler/V2_0_1000
    SharedScriptDirectory | ~/CommonLibrary/Shared/
    ImagesDirectory | ~/CommonLibrary/Images/WebScheduler/

    This section is very critical to be applied when you copy the CommonLibrary folder to the project's directory in development machine. However, if you have enabled SmartWebResources™, you no longer need to configure the directory settings.

  5. Click Next or Apply to save the configuration. Finally, the web.config has been updated successfully. Click Close to apply the settings.

See Also

Other Resources
{Deploying project that uses SmartWebResources™}
{Deploying project that does not use SmartWebResources™}
{Application Wide Configurations}

WebUI.NET Framework Reference
New SmartWebResources Framework


Deploying project that uses SmartWebResources™
See Also Send Feedback
Intersoft WebScheduler > Getting Started > Deployment > Deployment Guide > Deploying project that uses SmartWebResources™

Glossary Item Box

Intersoft Solutions constantly conduct extensive research and development to deliver new innovations that help developers become more productive by reducing the efforts and overwhelming complexity in both development and deployment stage.

SmartWebResources™ Framework is one of the great technology offered by Intersoft, which is used to eliminate the external physical resources such as scripts, images, etc.

WebScheduler.NET Deployment Checklist

  1. RuntimeLicenseKey
    This is a key required in order to license the components for deployment purpose in production environment.

    Runtime license key is different with design-time license key that you get during purchase. Please obtain each licensed component's RuntimeLicenseKey from Intersoft Developer Network under My Component section. You only need to obtain once and reuse it in multiple projects. The login detail is provided in your purchase receipt. If you purchased from our resellers, it may take 24-48 hours for the verification and account creation process.
  2. Resources Assembly
    Ensure that you have copied the resources assemblies to your project's bin folder. The resources assembly can be found in C:\Program Files\Intersoft Solutions\WebScheduler.NET 1.0\Bin. The resources assemblies are:
    * ISNet.WebUI.WebScheduler.Resources.dll
  3. Framework Assemblies
    You are required to copy framework assemblies to your project's bin folder. The framework assemblies can be found in C:\Program Files\Intersoft Solutions\WebUI.NET Framework 3.0\Bin (Default installation directory). The framework assemblies are:
    * ISNet.dll
    * ISNet.WebUI.dll
  4. Component Assembly
    Component assembly is required to be copied to your project's bin folder. The component assembly can be found in C:\Program Files\Intersoft Solutions\WebScheduler.NET 1.0\Bin. The component assembly is:
    * ISNet.WebUI.WebScheduler.dll

Deploying project that uses SmartWebResources™

Here are step-by-step instructions to deploy the project using SmartWebResources™:

  1. Before deploying the project, you have to configure SmartWebResources after you created a new web application. Click here for guidance.
  2. Next, you need to use Deployment Manager in order to set the web.config of your web application, such as defining Runtime License key. Please read Using Deployment Manager for more information.
  3. Finally, you simply need to XCopy all required web application files along with the bin folder (i.e. your project's directory) to a destination folder in your web server.

See Also

Other Resources
{Using Deployment Manager}
{Deploying project that does not use SmartWebResources™}
{Application Wide Configurations}

WebUI.NET Framework Reference
New SmartWebResources Framework


Deploying project that does not use SmartWebResources�?�

Deploying project that does not use SmartWebResources�?�
See Also Send Feedback
Intersoft WebScheduler > Getting Started > Deployment > Deployment Guide > Deploying project that does not use SmartWebResources�?�

Glossary Item Box

General

WebScheduler.NET is built on the top of WebUI.NET Framework. It includes the common concept, functionalities and features implemented in the framework level.

WebScheduler.NET Deployment Checklist

  1. RuntimeLicenseKey.
    This is a key required in order to license the components for deployment purpose in production environment.

    Runtime license key is different with design-time license key that you get during purchase.

    Use Deployment Manager to set the project's Web.config. There are 2 important things you need to notice:

    - If you set CommonLibrary folder as IIS Virtual Directory in development machine, you may refer to Using Deployment Manager topic for guidance.

    - If you copy the CommonLibrary folder to the project's directory in development machine, you may refer to Using Deployment Manager topic under Advanced section for guidance.

    Please obtain each licensed component's RuntimeLicenseKey from Intersoft Developer Network under My Component section. You only need to obtain once and reuse it in multiple projects. The login detail is provided in your purchase receipt. If you purchased from our resellers, it may take 24-48 hours for the verification and account creation process.
  2. CommonLibrary
    All subfolders and files inside CommonLibrary folder is required.
  3. Framework Assemblies.
    You are required to copy framework assemblies to your project's bin folder. The framework assemblies can be found in C:\Program Files\Intersoft Solutions\WebUI.NET Framework 3.0\Bin (Default installation directory). The framework assemblies are as following:
    * ISNet.dll
    * ISNet.WebUI.dll
  4. Component Assembly
    Component assembly is required to be copied to your project's bin folder. The component assembly can be found in C:\Program Files\Intersoft Solutions\WebScheduler.NET 1.0\Bin. The component assembly is:
    * ISNet.WebUI.WebScheduler.dll

WebScheduler.NET Deployment Guide

  1. If you set CommonLibrary folder as IIS Virtual Directory in development machine
    - XCopy all your required web application files along with the bin folder (i.e. your project's directory) to a destination folder in your web server.
    - XCopy the CommonLibrary folder to your web server. It is recommended to place it under wwwroot folder (usually c:\inetpub\wwwroot). You need to map the destination folder to IIS Virtual Directory with name "CommonLibrary".
  2. If you copy the CommonLibrary folder to the project's directory in development machine
    - XCopy all your required web application files along with the bin and CommonLibrary folders (i.e. your project's directory) to a destination folder in your web server.

    Creating CommonLibrary as IIS Virtual Directory is not required in this case.

See Also

Other Resources
{Using Deployment Manager}
{Deploying project that uses SmartWebResources™}
{Application Wide Configurations}

WebUI.NET Framework Reference
New SmartWebResources Framework


Application Wide Configurations

Application Wide Configurations
See Also Send Feedback
Intersoft WebScheduler > Getting Started > Deployment > Application Wide Configurations

Glossary Item Box

One of the unique features introduced since the initial products is the ability to configure specific deployment-related properties via web.config. WebUI.NET Framework further enhanced this capability by adding more properties which are configurable through web.config. Now, it also supports relative application path by using ~ character. The application-wide configurations feature allows centralized configuration for common deployment properties such as ScriptDirectory etc, which dramatically increase effectiveness and efficiency particularly for maintenance purpose.

Following is the list of properties that are configurable through web.config:

  • SharedScriptDirectory
  • ScriptDirectory
  • ImagesDirectory

The settings specified in web.config will only be applied to instances' properties that have Default value (unchanged).
The format of the key used for the configuration is AssemblyFullName.vProductVersion.Properties.

Examples:

The sample configuration in web.config below will change the property value of ScriptDirectory, ImagesDirectory, SharedScriptDirectory and LocalizationDirectory to all WebScheduler V4.0.1000 instances in the application.

<configuration>

<appSettings>

<add key="ISNet.WebUI.WebScheduler.v4_0_1000.ScriptDirectory" value ="~/CommonLibrary/WebScheduler/V4_0_1000/" />

<add key="ISNet.WebUI.WebScheduler.v4_0_1000.ImagesDirectory" value ="~/CommonLibrary/Images/WebScheduler/" />

<add key="ISNet.WebUI.WebScheduler.v4_0_1000.SharedScriptDirectory" value ="/CommonLibrary/Shared/" />

</appSettings>

... other settings

</configuration>

Additional application-wide configurations may be available specifically per product. Please refer to the Application-wide Configurations topic in the product's help file.

See Also

Other Resources
{Using Deployment Manager}
{Deploying project that uses SmartWebResources™}
{Deploying project that does not use SmartWebResources™}

WebUI.NET Framework Reference
How-to: Use file server for an instance of control


Samples and Walkthroughs

Samples and Walkthroughs
See Also Send Feedback
Intersoft WebScheduler > Getting Started > Samples and Walkthroughs

Glossary Item Box

This section contains information about location of sample and tutorial files, example codes and how to use WebScheduler in both Visual Studio 2005 and 2008.

In This Section

Locating Sample Files
Discover the locations where sample files are stored on your computer or the installation source.

More Walkthrough Topics
Lists complete walkthrough topics available in WebScheduler.

See Also

Tasks
{How-to Topics}

Other Resources
{Installation}
{Deployment}


Locating Sample Files

Locating Sample Files
See Also Send Feedback
Intersoft WebScheduler > Getting Started > Samples and Walkthroughs > Locating Sample Files

Glossary Item Box

The default locations for Sample files in this release are listed below. %install% represents the location where Intersoft's components are installed, such as \Program Files\Intersoft Solutions\.

Product | Sample Location
WebScheduler.NET C# Samples (Visual Studio 2005 Solution) | C:\%install%\Intersoft WebUI Studio.NET 2008 R2\ISNet.WebUI.Samples\cs

See Also

Tasks
{How-to Topics}


More Walkthrough Topics

More Walkthrough Topics
See Also Send Feedback
Intersoft WebScheduler > Getting Started > Samples and Walkthroughs > More Walkthrough Topics

Glossary Item Box

To learn more about WebScheduler's advanced features, please see Complete Walkthrough Topics.

See Also

Tasks
{How-to Topics}


Getting Started with WebScheduler from scratch

Getting Started with WebScheduler from scratch
See Also Send Feedback
Intersoft WebScheduler > Getting Started > Getting Started with WebScheduler from scratch

Glossary Item Box

In this section, you will be guided on how to get started with WebScheduler for the first time.

Starting from how to bind database to WebScheduler, then configuring view settings, data editing and calendar.

  • Step 1: Binding database to WebScheduler
  • Step 2: Configuring WebScheduler to display variety View settings
  • Step 3: Setting WebScheduler for data editing
  • Step 4: Using Calendar in WebScheduler

See Also

Other Resources
{Installation}
{Deployment}
{Samples and Walkthroughs}


Step 1: Binding database to WebScheduler

Step 1: Binding database to WebScheduler
See Also Send Feedback
Intersoft WebScheduler > Getting Started > Getting Started with WebScheduler from scratch > Step 1: Binding database to WebScheduler

Glossary Item Box

First of all, we are going to bind database to WebScheduler. In this step, we have 2 methods of binding architecture such as following:

  • Walkthrough: Binding SQL database to WebScheduler using ISDataSource
  • Walkthrough: Binding Access database to WebScheduler using ISDataSource

See Also

Related Topics
{Step 2: Configuring WebScheduler to variety View settings}
{Step 3: Setting WebScheduler for data editing}
{Step 4: Using Calendar in WebScheduler}

Other Resources
{Elegant Databinding Architecture}
{Data Binding}


Walkthrough: Binding SQL database to WebScheduler using ISDataSource

Walkthrough: Binding SQL database to WebScheduler using ISDataSource
See Also Send Feedback
Intersoft WebScheduler > Getting Started > Getting Started with WebScheduler from scratch > Step 1: Binding database to WebScheduler > Walkthrough: Binding SQL database to WebScheduler using ISDataSource

Glossary Item Box

This walkthrough shows you how to bind SQL database to WebScheduler using ISDataSource.

During this walkthrough, you will learn how to do the following:

  • Use ISDataSource.
  • Use SmartTag to set DataSource.
  • Use Data Source Configuration Wizard to set the Database and table.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Intersoft SQL database.
  • Visual Studio 2008 Application.

Step-By-Step Instructions

To create new web application and bind ISDataSource to WebScheduler

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag and drop WebScheduler and ISDataSource instances from toolbar to WebForm.
  8. Right click on WebScheduler control and choose WebScheduler Database Wizard.
  9. Provide Server name and create Database name. In this case, Server name is set to server1\sqlexpress and Database name is set to Intersoft. Click Create button afterwards.

  10. Open Server Explorer and choose Connect to Database. A dialog box will appear.
  11. Set Server name to server1\sqlexpress and Database name to Intersoft. Click OK to continue.

  12. In the Solution Explorer, right-click on App_Code and select Add New Item.
  13. Add a Dataset and named it Intersoft_DataSet.xsd.
  14. Drag and drop the tables from server explorer to the dataset then save the dataset.

  15. In the Solution Explorer, right-click on App_Code and select Add New Item.
  16. Add a new class and named it Intersoft_DataSet.cs.
  17. Here is the IntersoftDataSet.cs content.

    C# Copy Code
    using System.Data.SqlClient;

    namespace Intersoft_DataSetTableAdapters
    {
       public partial class EventsTableAdapter : global::System.ComponentModel.Component
        {
            [global::System.Diagnostics.DebuggerNonUserCodeAttribute()]
            [global::System.ComponentModel.Design.HelpKeywordAttribute("vs.data.TableAdapter")]
            [global::System.ComponentModel.DataObjectMethodAttribute(global::System.ComponentModel.DataObjectMethodType.Insert, true)]
         public virtual int Insert(int EventID, string CategoryID, global::System.Nullable<int> ResourceID, global::System.Nullable<int> Mode, string Subject,
           string Description, string Location, bool AllDayEvent, global::System.Nullable<global::System.DateTime> StartTime,
                global::System.Nullable<global::System.DateTime> EndTime, global::System.Nullable<int> ReminderTimeSpan)
            {
                this.Connection.Open();

                try
                {
                    this.Insert(CategoryID, ResourceID, Mode, Subject, Description, Location, AllDayEvent, StartTime, EndTime, ReminderTimeSpan);

                    SqlCommand command = new SqlCommand();
                     command.CommandText = "SELECT @@IDENTITY";
                     command.Connection = this.Connection;

                    return int.Parse(command.ExecuteScalar().ToString());
                }
               finally
                {
                     this.Connection.Close();
                }
            }
        }

        public partial class RecurringEventsTableAdapter : global::System.ComponentModel.Component
        {
        [global::System.Diagnostics.DebuggerNonUserCodeAttribute()]
        [global::System.ComponentModel.Design.HelpKeywordAttribute("vs.data.TableAdapter")]
        [global::System.ComponentModel.DataObjectMethodAttribute(global::System.ComponentModel.DataObjectMethodType.Insert, true)]
       public virtual int Insert(int EventID, global::System.Nullable<int> RecurrenceID, string CategoryID, global::System.Nullable<int> ResourceID,
             global::System.Nullable<int> ParentID, global::System.Nullable<int> Mode, string Subject, string Description, string Location, bool AllDayEvent,
             global::System.Nullable<global::System.DateTime> StartTime, global::System.Nullable<global::System.DateTime> EndTime,
             global::System.Nullable<global::System.DateTime> ExceptionDate, global::System.Nullable<int> ExceptionInfo, global::System.Nullable<int> ReminderTimeSpan)
        {
         this.Connection.Open();

         try
            {
                this.Insert(RecurrenceID, CategoryID, ResourceID, ParentID, Mode, Subject, Description, Location, AllDayEvent, StartTime, EndTime, ExceptionDate, ExceptionInfo, ReminderTimeSpan);

                SqlCommand command = new SqlCommand();
                 command.CommandText = "SELECT @@IDENTITY";
                 command.Connection = this.Connection;

                return int.Parse(command.ExecuteScalar().ToString());
            }
           finally
            {
                this.Connection.Close();
            }
        }
    }
    public partial class RecurrenceInfoTableAdapter : global::System.ComponentModel.Component
    {
       [global::System.Diagnostics.DebuggerNonUserCodeAttribute()]
       [global::System.ComponentModel.Design.HelpKeywordAttribute("vs.data.TableAdapter")]
       [global::System.ComponentModel.DataObjectMethodAttribute(global::System.ComponentModel.DataObjectMethodType.Insert, true)]
      public virtual int Insert(int RecurrenceID, global::System.Nullable<int> Mode, global::System.Nullable<int> RangeMode,
             global::System.Nullable<global::System.DateTime> StartDate, global::System.Nullable<global::System.DateTime> EndDate,
             global::System.Nullable<int> TotalRecurrences, global::System.Nullable<int> NDay, global::System.Nullable<int> NWeek,
             global::System.Nullable<int> NMonth, global::System.Nullable<int> NYear, string WeekDays)
      {
         this.Connection.Open();

         try
            {
              this.Insert(Mode, RangeMode, StartDate, EndDate, TotalRecurrences, NDay, NWeek, NMonth, NYear, WeekDays);

                 SqlCommand command = new SqlCommand();
                  command.CommandText = "SELECT @@IDENTITY";
                  command.Connection = this.Connection;

                 return int.Parse(command.ExecuteScalar().ToString());
            }
        finally
           {
               this.Connection.Close();
           }
       }
    }

    public partial class CategoriesTableAdapter : global::System.ComponentModel.Component
    {
    [global::System.Diagnostics.DebuggerNonUserCodeAttribute()]
    [global::System.ComponentModel.Design.HelpKeywordAttribute("vs.data.TableAdapter")]
    [global::System.ComponentModel.DataObjectMethodAttribute(global::System.ComponentModel.DataObjectMethodType.Insert, true)]
     public virtual int Insert(int CategoryID, string CategoryName, string Description, string CategoryColor)
     {
       this.Connection.Open();

         try
         {
           this.Insert(CategoryName, Description, CategoryColor);

            SqlCommand command = new SqlCommand();
             command.CommandText = "SELECT @@IDENTITY";
             command.Connection = this.Connection;

            return int.Parse(command.ExecuteScalar().ToString());
         }
       finally
        {
            this.Connection.Close();
        }
      }
    }

     public partial class ResourcesTableAdapter : global::System.ComponentModel.Component
    {
         [global::System.Diagnostics.DebuggerNonUserCodeAttribute()]
         [global::System.ComponentModel.Design.HelpKeywordAttribute("vs.data.TableAdapter")]
         [global::System.ComponentModel.DataObjectMethodAttribute(global::System.ComponentModel.DataObjectMethodType.Insert, true)]
       public virtual int Insert(int ResourceID, string ResourceName, string Description, string Location, string ResourceColor)
        {
             this.Connection.Open();

          try
             {
                 this.Insert(ResourceName, Description, Location, ResourceColor);

                 SqlCommand command = new OleDbCommand();
                  command.CommandText = "SELECT @@IDENTITY";
                  command.Connection = this.Connection;

                 return int.Parse(command.ExecuteScalar().ToString());
             }
            finally
             {
                  this.Connection.Close();
             }
         }
      }
    }

  18. Build the solution.
  19. Click the SmartTag and select Configure Data Source on the upper right of the ISDataSource control.
  20. Select SchemaType to DataSet and Schema Name to IntersoftDataSet then click Next.

  21. Make sure the Select, Insert, Update and Delete tab for each table is not empty then click Finish.

  22. Select WebScheduler instance and press F4 to show the WebScheduler's properties.
  23. Set the following properties:

    Property | Value
    DataSourceID | ISDataSource1
    CategoriesDataMember | Categories
    RecurrenceDataMember | RecurrenceInfo
    EventsDataMember | Events
    RecurringEventsDataMember | RecurringEvents
    ResourcesDataMember | Resources

  24. Go to DataBinding and specify the field of CategoryBinding, EventsBinding, RecurrenceBinding, RecurrenceEventsBinding, and ResourcesBinding based on the database field.

  25. WebScheduler binding is done. Now you are able to run the project.

    The database is empty so the current WebScheduler will not show any event or resources.

See Also

Tasks
{Walkthrough: Binding Access database to WebScheduler using ISDataSource}
{Walkthrough Topics}
{How-to Topics}


Walkthrough: Binding Access database to WebScheduler using ISDataSource

Walkthrough: Binding Access database to WebScheduler using ISDataSource
See Also Send Feedback
Intersoft WebScheduler > Getting Started > Getting Started with WebScheduler from scratch > Step 1: Binding database to WebScheduler > Walkthrough: Binding Access database to WebScheduler using ISDataSource

Glossary Item Box

This walkthrough shows you how to bind Access database to WebScheduler using ISDataSource.

During this walkthrough, you will learn how to do the following:

  • Use ISDataSource.
  • Use SmartTag to set DataSource.
  • Use Data Source Configuration Wizard to set the Database and table.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and bind ISDataSource to WebScheduler

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag and drop WebScheduler and ISDataSource instances from toolbar to WebForm.
  8. Right click on WebScheduler control and choose WebScheduler Database Wizard.
  9. Click Get SQL Script to automatically generate SQL queries. Note that you are required to select the option MS Access Compatible for the query.

  10. Open Microsoft Office Access and create a database named WebScheduler_Movies.mdb.
  11. Create Query Design and switch to SQL View like following:

  12. Copy all queries from SQLScriptDialog box from WebScheduler Database Wizard. Note that copying multiple queries at a time is not possible in Microsoft Access Database. Therefore, you need to copy each query to Microsoft Access and run them respectively.

  13. In the solution Explorer, right click on App_Data and select Add Existing Item. Find and add WebScheduler_Movies.mdb that you just created.
  14. In the Solution Explorer, right-click on App_Code and select Add New Item.
  15. Add a Dataset and named it WebScheduler_Movies.xsd.
  16. Drag and drop the tables from server explorer to the dataset then save the dataset.

  17. In the Solution Explorer, right-click on App_Code and select Add New Item.
  18. Add a new class and named it WebScheduler_Movies.cs.
  19. Here is the WebScheduler_Movies.cs content.

    C# Copy Code
    using System.Data.OleDb;
namespace WebScheduler_MoviesTableAdapters
{
   public partial class EventsTableAdapter : global::System.ComponentModel.Component
   {
      [global::System.Diagnostics.DebuggerNonUserCodeAttribute()]
      [global::System.ComponentModel.Design.HelpKeywordAttribute("vs.data.TableAdapter")]
      [global::System.ComponentModel.DataObjectMethodAttribute(global::System.ComponentModel.DataObjectMethodType.Insert, true)]
      public virtual int Insert(int EventID, string CategoryID, global::System.Nullable<int> ResourceID, global::System.Nullable<int> Mode, string Subject,
         string Description, string Location, bool AllDayEvent,
         global::System.Nullable<global::System.DateTime> StartTime,
         global::System.Nullable<global::System.DateTime> EndTime, global::System.Nullable<int> ReminderTimeSpan)
      {
         this.Connection.Open();
         try
         {
            this.Insert(CategoryID, ResourceID, Mode, Subject, Description, Location, AllDayEvent, StartTime, EndTime, ReminderTimeSpan);
            OleDbCommand command = new OleDbCommand();
            command.CommandText = "SELECT @@IDENTITY";
            command.Connection = this.Connection;
            return (int)command.ExecuteScalar();
         }
         finally
         {
            this.Connection.Close();
         }
      }
   }

   public partial class RecurringEventsTableAdapter : global::System.ComponentModel.Component
   {
      [global::System.Diagnostics.DebuggerNonUserCodeAttribute()]
      [global::System.ComponentModel.Design.HelpKeywordAttribute("vs.data.TableAdapter")]
      [global::System.ComponentModel.DataObjectMethodAttribute(global::System.ComponentModel.DataObjectMethodType.Insert, true)]
      public virtual int Insert(int EventID, global::System.Nullable<int> RecurrenceID, string CategoryID, global::System.Nullable<int> ResourceID,
         global::System.Nullable<int> ParentID, global::System.Nullable<int> Mode, string Subject, string Description, string Location, bool AllDayEvent,
         global::System.Nullable<global::System.DateTime> StartTime, global::System.Nullable<global::System.DateTime> EndTime,
         global::System.Nullable<global::System.DateTime> ExceptionDate, global::System.Nullable<int> ExceptionInfo, global::System.Nullable<int> ReminderTimeSpan)
      {
         this.Connection.Open();
         try
         {
            this.Insert(RecurrenceID, CategoryID, ResourceID, ParentID, Mode, Subject, Description, Location, AllDayEvent, StartTime, EndTime, ExceptionDate, ExceptionInfo, ReminderTimeSpan);
            OleDbCommand command = new OleDbCommand();
            command.CommandText = "SELECT @@IDENTITY";
            command.Connection = this.Connection;
            return (int)command.ExecuteScalar();
         }
         finally
         {
            this.Connection.Close();
         }
      }
   }

   public partial class RecurrenceInfoTableAdapter : global::System.ComponentModel.Component
   {
      [global::System.Diagnostics.DebuggerNonUserCodeAttribute()]
      [global::System.ComponentModel.Design.HelpKeywordAttribute("vs.data.TableAdapter")]
      [global::System.ComponentModel.DataObjectMethodAttribute(global::System.ComponentModel.DataObjectMethodType.Insert, true)]
      public virtual int Insert(int RecurrenceID, global::System.Nullable<int> Mode, global::System.Nullable<int> RangeMode,
         global::System.Nullable<global::System.DateTime> StartDate, global::System.Nullable<global::System.DateTime> EndDate,
         global::System.Nullable<int> TotalRecurrences, global::System.Nullable<int> NDay, global::System.Nullable<int> NWeek,
         global::System.Nullable<int> NMonth, global::System.Nullable<int> NYear, string WeekDays)
      {
         this.Connection.Open();
         try
         {
            this.Insert(Mode, RangeMode, StartDate, EndDate, TotalRecurrences, NDay, NWeek, NMonth, NYear, WeekDays);
            OleDbCommand command = new OleDbCommand();
            command.CommandText = "SELECT @@IDENTITY";
            command.Connection = this.Connection;
            return (int)command.ExecuteScalar();
         }
         finally
         {
            this.Connection.Close();
         }
      }
   }

   public partial class CategoriesTableAdapter : global::System.ComponentModel.Component
   {
      [global::System.Diagnostics.DebuggerNonUserCodeAttribute()]
      [global::System.ComponentModel.Design.HelpKeywordAttribute("vs.data.TableAdapter")]
      [global::System.ComponentModel.DataObjectMethodAttribute(global::System.ComponentModel.DataObjectMethodType.Insert, true)]
      public virtual int Insert(int CategoryID, string CategoryName, string Description, string CategoryColor)
      {
         this.Connection.Open();
         try
         {
            this.Insert(CategoryName, Description, CategoryColor);
            OleDbCommand command = new OleDbCommand();
            command.CommandText = "SELECT @@IDENTITY";
            command.Connection = this.Connection;
            return (int)command.ExecuteScalar();
         }
         finally
         {
            this.Connection.Close();
         }
      }
   }

   public partial class ResourcesTableAdapter : global::System.ComponentModel.Component
   {
      [global::System.Diagnostics.DebuggerNonUserCodeAttribute()]
      [global::System.ComponentModel.Design.HelpKeywordAttribute("vs.data.TableAdapter")]
      [global::System.ComponentModel.DataObjectMethodAttribute(global::System.ComponentModel.DataObjectMethodType.Insert, true)]
      public virtual int Insert(int ResourceID, string ResourceName, string Description, string Location, string ResourceColor)
      {
         this.Connection.Open();
         try
         {
            this.Insert(ResourceName, Description, Location, ResourceColor);
            OleDbCommand command = new OleDbCommand();
            command.CommandText = "SELECT @@IDENTITY";
            command.Connection = this.Connection;
            return (int)command.ExecuteScalar();
         }
         finally
         {
            this.Connection.Close();
         }
      }
   }
}

  20. Build the solution.
  21. Click the SmartTag and select Configure Data Source™ on the upper right of the ISDataSource.
  22. Select SchemaType to DataSet and Schema Name to WebScheduler_Movies then click Next.

  23. Make sure the Select, Insert, Update and Delete tab for each table is not empty then click Finish.

  24. Select WebScheduler instance and press F4 to show the WebScheduler's properties.
  25. Set the following properties:

    Property | Value
    DataSourceID | ISDataSource1
    CategoriesDataMember | Categories
    RecurrenceDataMember | RecurrenceInfo
    EventsDataMember | Events
    RecurringEventsDataMember | RecurringEvents
    ResourcesDataMember | Resources

  26. Go to DataBinding and specify the field of CategoryBinding, EventsBinding, RecurrenceBinding, RecurrenceEventsBinding, and ResourcesBinding based on the database field.

  27. WebScheduler binding is done. Now you are able to run the project.

    The database is empty so the current WebScheduler will not show any event or resources.

See Also

Tasks
{How-to: Enable AllowCollapse in calendar}
{How-to: AllowEdit in WebScheduler}
{How-to Topics}

Concepts
{Data Binding}

Other Resources
{Data Operation}
{Single load vs Triple load}


Step 2: Configuring WebScheduler to display variety View settings

Step 2: Configuring WebScheduler to display variety View settings
See Also Send Feedback
Intersoft WebScheduler > Getting Started > Getting Started with WebScheduler from scratch > Step 2: Configuring WebScheduler to display variety View settings

Glossary Item Box

There are 7 view settings provided by WebScheduler to be customized according to user needs. All views are accessible in ViewSettings section.

These are the basic things needed to be configured to get started with WebScheduler.

Agenda View

Property | Description | Value
SelectedViewMode | Specifies the initial WebScheduler's view mode. | Agenda
NumberOfDays | Specifies Agenda view number of days. | 10
Enabled | Indicates whether Agenda View should be enabled. | True

Day View

Property | Description | Value
SelectedViewMode | Specifies the initial WebScheduler's view mode. | Day
VisibleStartTime | Specifies the visible start time in Day and Week view. | t0000
VisibleEndTime | Specifies the visible end time in Day and Week. | t2330
Enabled | Indicates whether Day View should be enabled. | True

Month View

Property | Description | Value
SelectedViewMode | Specifies the initial WebScheduler's view mode. | Month
Enabled | Indicates whether Month View should be enabled. | True

Quarter View

Property | Description | Value
SelectedViewMode | Specifies the initial WebScheduler's view mode. | Quarter
Enabled | Indicates whether Quarter View should be enabled. | True

Timeline View

Property | Description | Value
SelectedViewMode | Specifies the initial WebScheduler's view mode. | Timeline
SelectedTimelineViewMode | Specifies Timeline view mode (Quarter, Month, Week, etc) | DayHourly
EnableClientPaging | Indicates whether client paging is enabled in Timeline View. | True
ClientPagingMode | Specifies Timeline's client paging mode (EventPageSize, ViewPort) | EventPageSize
Enabled | Indicates whether Timeline view should be enabled | True

Week View

Property | Description | Value
SelectedViewMode | Specifies the initial WebScheduler's view mode. | Week
Enabled | Indicates whether Week View should be enabled. | True

Year View

Property | Description | Value
SelectedViewMode | Specifies the initial WebScheduler's view mode. | Year
Enabled | Indicates whether Year View should be enabled. | True

The following screenshot shows that Week view is set as the initial selected view mode and the other views are enabled.

SelectedViewMode and Enabled are the basic properties to be set in order to use the View Settings. For example: To use Day View in WebScheduler, you are required to set SelectedViewMode to Day and Enabled to True.

See Also

Related Topics
{Step 1: Binding database to WebScheduler}
{Step 3: Setting WebScheduler for data editing}
{Step 4: Using Calendar in WebScheduler}

Other Resources
{Includes 6 Built-in Scheduler View}


Step 3: Setting WebScheduler for data editing

Step 3: Setting WebScheduler for data editing
See Also Send Feedback
Intersoft WebScheduler > Getting Started > Getting Started with WebScheduler from scratch > Step 3: Setting WebScheduler for data editing

Glossary Item Box

After configuring view settings in WebScheduler, we are going to take a further step which is data editing. Using FlyPostBack™ technology, WebScheduler.NET performs data editing with less resource consumption and there is no need to wait so long for page refresh or Postback in order to manipulate or update information to the database, even WebScheduler does not perform FullPostBack at all.

Setting WebScheduler for data editing

  1. Expand DataEditing section.
  2. In DataEditing, set AllowAdd, AllowDelete, AllowEdit, AllowMove and AllowResize to Yes.
  3. When you set AllowEdit to Yes, the WebScheduler Editing Wizard box will appear.
  4. Specify the folder name where the Editing Form is placed. For example: WebScheduler.
  5. It will automatically generate the link in EditingUrl property. For instance: ./WebScheduler/EditingForm.aspx.

See Also

Related Topics
{Step 1: Binding database to WebScheduler}
{Step 2: Configuring WebScheduler to variety View settings}
{Step 4: Using Calendar in WebScheduler}

Other Resources
{Out-of-the-box Editing Experience}


Step 4: Using Calendar in WebScheduler

Step 4: Using Calendar in WebScheduler
See Also Send Feedback
Intersoft WebScheduler > Getting Started > Getting Started with WebScheduler from scratch > Step 4: Using Calendar in WebScheduler

Glossary Item Box

The Calendar is one of the fundamental subcomponent of WebScheduler which plays important roles in the overall features such as navigation, view highlighting and selection. There is no code needed to synchronize between calendar and WebScheduler.

Here are basic things you can set in calendar:

  1. Expand CalendarSettings.
  2. Set AllowCollapse to True and FirstDayOfWeek to Monday.

See Also

Related Topics
{Step 1: Binding database to WebScheduler}
{Step 2: Configuring WebScheduler to variety View settings}
{Step 3: Setting WebScheduler for data editing}

Other Resources
{Natural Calendaring and Scheduling Integration}
{Advanced Calendaring Function}


What's New in WebScheduler

What's New in WebScheduler
Send Feedback
Intersoft WebScheduler > What's New in WebScheduler

Glossary Item Box

This section summarizes features and enhancements that have been added or modified in the latest versions of WebScheduler.NET.

In This Section

What's New in WebScheduler V2.0
Describes the latest features in version 2.0.

What's New in WebScheduler V3.0
Describes the latest features in version 3.0.

What's New in WebScheduler V4.0
Describes the latest features in version 4.0.


V4.0

V4.0
Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V4.0

Glossary Item Box

WebScheduler.NET extends its version 4.0 with new features and improvements to existing features. This section provides information about the key additions and modifications.

In This Section

New Features V4.0
Describes new features, such as Neat UI Rendering, Daylight Saving Time Adjustment, View Header Enhancement and etc.


New Features V4.0

New Features V4.0
Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V4.0 > New Features V4.0

Glossary Item Box

WebScheduler represents the next generation of enterprise scheduling components that is designed to deliver interactive data scheduling and planning right in your web browser. With many features offered including built-in API, WebScheduler promise a low usage time in development of scheduling website. WebScheduler also puts the performance issue as a serious matter by implementing many ways of UI rendering and data collection. With all of these, WebScheduler is your answer to build your critical business application.

In version 4, WebScheduler fully supports for latest web standards and latest style sheet language, which is HTML5 and CSS3. WebScheduler also allows you to use many cutting-edge technologies, which are HTML5 and CSS3 and powerful WebScheduler features in you next-generation web applications.

This is the following detail of enhancements and new features that have been implemented in WebScheduler:

Neat UI Rendering

By using HTML5, WebScheduler has proved its consistency in rendering for each modern browser. It also implement new standard for style sheet, which is CSS3. With these latest web standards, WebScheduler becomes more consistent and compatible for each modern web browser.

  • To learn how to enable HTML5 rendering mode in WebScheduler, see How-to: Enable HTML5 Rendering Mode.

Daylight Saving Time Adjustment

In version 4, WebScheduler had fixed some scenarios regarding daylight saving time. Daylight saving time feature assigned automatically to adapt WebScheduler with some countries that apply daylight saving time as time zone standard. WebScheduler will detect the value of daylight saving time from deployment PC date time configuration.

View Header Enhancement

WebScheduler in version 4 implements new property to change the View Header content. Now, View Header text can be switched with icon and text by changing ViewHeaderType property. The image itself can be replaced by image that you want to define in ImagesSettings.

  • For more information, see How-to: Change View Header Type.

Resources Table Enhancements

In version 4, WebScheduler also provides many enhancements in resource table. By changing DisplayResourcesDescriptionInToolTip property, WebScheduler will show resource’s description as tooltip if you hover the resource’s subject in resource table. By changing ApplyResourcesColorInText property, WebScheduler will apply the color that you defined in database in resource’s subject text instead of making block that shows resource color.

  • For more information, see How-to: Change ResourcesTable Function and Appearance.

New Default Style

WebScheduler 4 also enhances its default style. WebScheduler 4 presents new default style, which is Modern Style. By changing the DefaultStyle to Modern, WebScheduler will appear like Outlook 2013. Although by using this default style, some rendering will be changed to new structure, the style itself can be inherited from other property style in WebScheduler.


How-to: Enable HTML5 Rendering Mode

How-to: Enable HTML5 Rendering Mode
Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V4.0 > New Features V4.0 > How-to: Enable HTML5 Rendering Mode

Glossary Item Box

This topic explains how to configure WebScheduler to emit HTML5 compliance output.

Configure Doc Type

Each doctype declaration in HTML specification produces different results and behaviors, mostly in the layout and rendering aspects. WebScheduler supports most commonly used doctype and automatically adjust the behaviors and rendering results by detecting the doctype declaration of the HTML page.

In version 4, WebScheduler has been significantly enhanced to deliver consistent behaviors and layout in HTML5 pages. All features should work exactly as in other doctype.

To enable HTML5 support in WebScheduler, make sure you have configured the HTML pages to use the proper doctype. The standard doctype for HTML5 is <!DOCTYPE html>.

The following code example shows how to use WebScheduler in a simple WebForm using HTML5 doctype.

ASPX Copy Code
<%@ Page Language="C#" AutoEventWireup="true" CodeFile="Default.aspx.cs" Inherits="Default" %>
<%@ Register Assembly="ISNet.WebUI.WebScheduler" Namespace="ISNet.WebUI.WebScheduler" TagPrefix="ISWebScheduler" %>

<!DOCTYPE html>
<html>
<head runat="server">
    <title></title>
</head>
<body>
    <form id="form1" runat="server">
    <div>
         <ISWebScheduler:WebScheduler ID="WebScheduler1" runat="server" Height="100%" Width="100%">
         </ISWebScheduler:WebScheduler>
    </div>
    </form>
</body>
</html>

Note that the xmlns attribute is no longer necessary to be defined in the <html> tag. If you upgraded your existing pages, make sure the xmlns attribute is removed from the <html> tag.

Also, to enable percentage height in HTML5, you must define its height in body and html element. Here's the example

ASPX Copy Code
<head runat="server">
    <title></title>
    <style type="text/css">
    html, body
    {
        height: 100%;
        width: 100%;
        margin: 0;
        padding: 0;
    }
    </style>
</head>

In HTML5, height of an element is refer to its parent's height so this is necessary to define its parent element.

Configure Rendering Mode

To provide the best HTML5 support, WebScheduler needs to adjust several features that are commonly processed in the server-side such as markup rendering and AJAX callback response. Unfortunately, the HTML5 doctype cannot be automatically detected by the server-side browser capability. As such, WebScheduler introduces a new property called RenderingMode which you must set explicitly in order to activate HTML5 compliance output.

You can set the rendering mode in a WebScheduler instance individually by setting the RenderingMode property to HTML5 value, such as shown in the example below.

ASPX Copy Code
<ISWebScheduler:WebScheduler ID="WebScheduler1" runat="server" Height="100%" Width="100%" RenderingMode="HTML5">
</ISWebScheduler:WebScheduler>

Alternatively, you can also apply the rendering mode globally through the application-wide configuration, see the following example.

Web.config Copy Code
<add key="ISNet.WebUI.WebScheduler.v4_0_1000.RenderingMode" value="HTML5"/>
If your project is exclusively targeting HTML5, it's recommended to use application-wide configuration to apply the rendering mode to all WebScheduler instances in the project.

For more information about application-wide settings in WebScheduler, see Application Wide Configurations.


How-to: Change ResourcesTable Function and Appearance

How-to: Change ResourcesTable Function and Appearance
Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V4.0 > New Features V4.0 > How-to: Change ResourcesTable Function and Appearance

Glossary Item Box

WebScheduler 4 already implemented new features to change appearance and function of ResourceTable. Now, it can change the color of each resource in the text and also it can show the description as tooltip.

In this topic, you will learn how to change ResourcesTable function and appearance.

To change ResourceTable appearance

  1. Go to property window of WebScheduler.
  2. Set ApplyResourcesColorInText property to True.

To change ResourceTable function

  1. Go to property window of WebScheduler.
  2. Set DisplayResourcesDescriptionInToolTip property to True.


How-to: Change View Header Type

How-to: Change View Header Type
Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V4.0 > New Features V4.0 > How-to: Change View Header Type

Glossary Item Box

In WebScheduler 4, ViewHeader content can be modified into image and text instead of text.

In this topic, you will learn how to change ViewHeader type

To change ViewHeader type

  1. Go to property window of WebScheduler.
  2. Set ViewHeaderType to ImageAndText instead of Text.
  3. To modify list of icon that will appear in ViewHeader, change these property on ImagesSettings property in WebScheduler:
    • DayViewHeaderIcon
    • WeekViewHeaderIcon
    • MonthViewHeaderIcon
    • YearQuarterViewHeaderIcon
    • TimelineViewHeaderIcon


V3.0

V3.0
Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0

Glossary Item Box

WebScheduler.NET extends its version 3.0 with new features and improvements to existing features. This section provides information about the key additions and modifications.

In This Section

New Features
Describes new features, such as customizable Timeline's date header, disabled time, Timeline exporting and etc.


New Features

New Features
Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features

Glossary Item Box

This section describes the new features and technologies added in WebScheduler V3.0. Here are the following list of new features supported by WebScheduler V3.0:

Full XHTML Support

WebScheduler offers precise rendering capability by supporting XHTML standards.

  • For more information, see Full XHTML Support.

Performance Improvement

WebScheduler boosts up its performance to be able to display large datasets,

  • For more information, see Performance Improvement.

Client Paging

WebScheduler elegantly addresses the scalability issue with its sophisticated client paging feature.

  • For more information, see Client Paging.

Detail Box Paging

WebScheduler provides a detail box when client paging is enabled.

  • For more information, see Detail Box Paging.

Time Interval

WebScheduler introduces various time interval options that can be specified by user.

  • For more information, see Time Interval.

Visible Hours

Visible Hours is possible to be customized by specifying start time and end time.

For more information, see Visible Hours.

Disabled Time

WebScheduler provides a unique feature which enables developer to specify a portion of time when event creation is disabled without requiring complex efforts or codes.

  • For more information, see Disabled Time.

Overwrite Changes Support

WebScheduler now supports both CompareAllValues and OverwriteChange conflict detection options.

  • For more information, see Overwrite Changes Support.

Several Enhancements in Timeline view

There are several enhancements made in Timeline view, such as Real time operation editing, exporting and others.

  • For more information, see Several Enhancements in Timeline view.

Customizable number of days in Agenda

WebScheduler enhances its feature to let the user customize number of days in Agenda.

  • For more information, see Customizable number of days in Agenda.

Customizable maximum height of all-day area

The all-day area has been restructured to have a maximum height.

  • For more information, see Customizable maximum height of all-day area.

Client-side function to retrieve cell element(s)

GetCellElement() and GetCellElements() client side functions have been added to WebScheduler.

  • For more information, see Client-side function to retrieve cell element(s).

WebScheduler Database Wizard

WebScheduler Database Wizard is an automatic tool for WebScheduler's database creation.

  • For more information, see WebScheduler Database Wizard.


Full XHTML Support

Full XHTML Support
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Full XHTML Support

Glossary Item Box

With the comprehensive W3C XHTML standard support, WebScheduler offers precise rendering capability in every modern application. This substantial enhancement gives you the power to develop a new XHTML enterprise solution or adding a scheduling module to your classic HTML application - even it means a thorough enhancement in WebScheduler's core engine has to be made. Its smart detection engine automatically tracks the document type used and applied the necessary adjustment to its entire styles and behaviors without developer's intervention.

Following are the enhanced and optimized features for efficient XHTML output.

  • Core User Interface, including the complete layout management on the scheduler and navigation interface.
  • UX Components, including all user interaction elements, such as calendar, callout, dialog box, drop shadow, list box and many more.
  • Scheduler views, including Day, Week, Month, Agenda, Quarter, Year, Timeline, and Split view.
  • Built-in Editing form.

The extensive XHTML support is designed and thoroughly tested to work on all future-proof browsers.

  • Microsoft Internet Explorer 7 Standards Mode
  • Microsoft Internet Explorer 8 Standards Mode
  • Mozilla Firefox 3+
  • Apple Safari 4+
  • Opera 10+
  • Google Chrome

Timeline View

Agenda View

Month View

Week View

Built-in Editing Form

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Performance Improvement}
{Client Paging}
{Detail Box Paging}
{Time Interval}
{Visible Hours}
{Disabled Time}
{Overwrite Changes Support}
{Several Enhancements in Timeline view}
{Customizable maximum height of all-day area}
{Customizable number of days in Agenda}
{Client-side function to retrieve cell element(s)}
{WebScheduler Database Wizard}


Performance Improvement

Performance Improvement
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Performance Improvement

Glossary Item Box

WebScheduler supports advanced enterprise scheduling scenarios such as displaying thousands of data in a single load. In this new release, WebScheduler is finely tuned to display large datasets without significant performance hits enabling developers to achieve rich scheduling solution with great scalability and extensibility.

Key performance improvements include:

Data Transfer

WebScheduler 3 incorporates JSON technology to reduce the amount of data being transferred for each AJAX callback, making the data transfer faster and more efficient.

In large data scenario, the overall performance is improved by 50% - 70% when EnableFastJsonSerialization property is enabled.

If fast JSON serialization is implemented and extensibility feature is used in WebScheduler, additional implementation is required to process the custom fields during serialization process. Simply add the custom fields to DataDictionary object.

C# Copy Code
protected void WebScheduler_OnJsonSerialization(object sender, WebSchedulerJsonSerializationArgs e)
{
   switch (e.Type)
   {
      case WebSchedulerObjectType.Event:
         Dictionary eventDict = (Dictionary)e.DataDictionary;
         EOEvent obj = (EOEvent)e.DataObject;

         eventDict["Notes"] = (string)obj.Notes;
         eventDict["TotalAttendees"] = (int)obj.TotalAttendees;

         break;

      case WebSchedulerObjectType.RecurringEvent:
         Dictionary recDict = (Dictionary)e.DataDictionary;
         EORecurringEvent obj1 = (EORecurringEvent)e.DataObject;

         recDict["Notes"] = (string)obj1.Notes;
         recDict["TotalAttendees"] = (int)obj1.TotalAttendees;

         break;
   }
}

Rendering

The rendering process in WebScheduler 3 has been further optimized to meet high performance standards in enterprise scheduling scenarios. Combined with the new client paging feature, WebScheduler performs 4x faster compared to its previous version. The client paging will display only certain number of data in the first load and load the rest of data when users demand it - making efficient use of resources and screen real estate.

Timeline (Gant Chart) View

WebScheduler 3 takes the performance in Timeline View to the next level by introducing advanced paging mechanism. Thanks to the innovative ViewPort™ paging technology, the Timeline view is now able to display several thousands of events in a fraction of second, which significantly increasing application responsiveness and delivering superior user experiences.

Script Modularization

WebScheduler 3 now loads 2x faster with improved script modularization. When certain views or features are disabled, WebScheduler automatically excludes the scripts associated with those features from being loaded, thus reducing the time and resources required to instantiate the WebScheduler control.

Server Paging in Timeline view

Designed as an enterprise-ready scheduling component, WebScheduler 3 provides an option to control the data retrieval mechanism. Server Paging is an innovative feature built to eliminate sluggish performance due to large data download in Timeline view mode. To learn more about server paging, see Server Paging in Timeline view.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Full XHTML Support}
{Several Enhancements in Timeline view}


Server Paging in Timeline view

Server Paging in Timeline view
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Server Paging in Timeline view

Glossary Item Box

Concept

Designed as an enterprise-ready scheduling component, WebScheduler 3 provides an option to control the data retrieval mechanism. Server Paging is an innovative feature built to eliminate sluggish performance due to large data download in Timeline view mode. With server paging, WebScheduler downloads only a small chunk of data based on the viewport during initial load and intelligently requests more data as users scroll downward. This translates to reduced page load time and increased overall application responsiveness. Combined with the smart client paging rendering technology, powerful JSON response format, and script modularization, WebScheduler is the world's fastest and most advanced scheduling solution.

Implementation

Simply enable EnableServerPaging property in ViewSettings >> TimelineView.

Server paging feature is only applicable when the client paging is set to ViewPort or Both. For certain scenarios with smaller data (less than a thousand of records in a month view), the server paging may not be necessary enabled so that the complete data can be transmitted in a single page load. In such scenarios, the client paging will perform data rendering immediately.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Full XHTML Support}
{Performance Improvement}
{Client Paging}
{Detail Box Paging}


How-to: Enable Server Paging in Timeline view

How-to: Enable Server Paging in Timeline view
Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Server Paging in Timeline view > How-to: Enable Server Paging in Timeline view

Glossary Item Box

WebScheduler provides server paging feature in Timeline view.

In this topic, you will learn how to enable Client paging in Timeline view.

To enable Server Paging in Timeline view

  1. Right click on the WebScheduler's control and choose Properties.
  2. In Properties box, expand ViewSettings >> TimelineView.
  3. Set SelectedViewMode to Timeline and EnableClientPaging to True.
  4. Set EnableServerPaging to True and set ClientPagingMode to either Both or ViewPort.
Server paging feature is only applicable when the client paging is set to ViewPort or Both. For certain scenarios with smaller data (less than a thousand of records in a month view), the server paging may not be necessary enabled so that the complete data can be transmitted in a single page load. In such scenarios, the client paging will perform data rendering immediately.


Client Paging

Client Paging
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Client Paging

Glossary Item Box

Sleek performance and snappy user interface never goes hand in hand with large data. This is the challenge that every enterprise scheduling solution has to face. WebScheduler 3 elegantly addresses the scalability issue with its sophisticated client paging feature significantly improving overall application response regardless of the data size.

Client paging can be enabled in Day, Week, Timeline, and Split view. In Month view, it is enabled by default, since the layout structure requires it to be implemented when large data is used.

In This Section

Day view, Week view, and Split view

Timeline view

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
Full XHTML Support
{Disabled Time}
{Detail Box Paging}
{Time Interval}
{Visible Hours}


Day view, Week view, and Split view

Day view, Week view, and Split view
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Client Paging > Day view, Week view, and Split view

Glossary Item Box

To enable client paging in Day view, ViewSettings >> DayView >> EnableClientPaging property needs to be set to True. Since Split view uses the same configuration as Day view, client paging will be enabled in Split view if it is enabled in Day view.

To enable client paging in Week view, ViewSettings >> Week View >> EnableClientPaging property needs to be set to True.

Both configurations are independently implemented, means client paging can be enabled in one view and disabled in other view.

In these views, there are two sections where events are rendered: all-day area and hour area. All-day events and switch events are rendered in all-day area, while time-based events are rendered in hour area. Client paging is implemented in both areas, using the following properties:

  1. AllDayEventPageSize
    AllDayEventPageSize property determines the maximum number of row in all-day area where all-day events are rendered. By default it is set to 3, which means only events rendered in the first three rows will be displayed. The other events will be hidden and a paging arrow indicator will be displayed in areas that contain hidden events. All events will be displayed when the paging indicator is clicked.

    To specify all-day event page size, the custom page size can be set as the value of ViewSettings >> [DayView | WeekView] >> AllDayEventPageSize. If AllDayEventPageSize is set to -1, client paging will not be applied and all events will be displayed.

    All-day events are paged in Week view

    All-day events are displayed when paging arrow indicator is clicked

    In the above picture, AllDayEventPageSize is set to 5, so only events rendered in the first 5 rows will be displayed. When the paging arrow indicator is clicked all, all-day events in the active view will be displayed.

  2. EventBlockSize
    EventBlockSize property determines the maximum number of overlapping blocks rendered in each event block. By default it is set to 3, which means only events included in the first three blocks in an overlapping time block will be rendered.
    The other events will be hidden and a paging arrow indicator will be displayed in blocks that contain hidden events. When the paging indicator is clicked, all events will be displayed in a detail box.

    To specify all-day event page size, the custom page size can be set as the value of ViewSettings >> [DayView | WeekView] >> EventBlockSize. If EventBlockSize is set to -1, client paging will not be applied and all events will be displayed.

    All time-based events displayed in Week view

    Time-based events are paged in Week view

    As seen in above screenshots, in the 3rd of September 2008 8:15 AM - 11: 00 AM there are 5 events rendered in 4 overlapping blocks. When EventBlockSize property is set to 2, those 5 events will be paged and thus will be rendered as 3 events in 2 overlapping blocks. A paging arrow indicator will be displayed in the paged blocks indicating that there are hidden events in the related block.

    When paging arrow indicator is clicked, the hidden events will be rendered in the Detail Box.

In This Section

How-to: Enable Client Paging in Day view

How-to: Enable Client Paging in Week view

How-to: Set EventBlockSize in Week view

How-to: Set AllDayEventPageSize in Week view

See Also

Tasks
Walkthrough Topics
How-to Topics

Other Resources
{Client Paging}
{Detail Box Paging}
{Show all Timeline events in client-side}
{Data editing when Client paging is enabled}


How-to: Enable Client Paging in Day view

How-to: Enable Client Paging in Day view
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Client Paging > Day view, Week view, and Split view > How-to: Enable Client Paging in Day view

Glossary Item Box

In this topic, you will learn how to enable client paging in Day view using EnableClientPaging.

To enable client paging in Day view

  1. Right click on WebScheduler control and choose Properties.
  2. In Properties box, expand ViewSettings >> DayView.
  3. Set EnableClientPaging to True.

See Also

Tasks
How-to: Enable Client Paging in Week view
{How-to: Set EventBlockSize in Week view}
{Walkthrough Topics}
{How-to Topics}
{How-to: Set AllDayEventPageSize in Week view}

Other Resources
{Day view, Week view, and Split view}


How-to: Enable Client Paging in Week view

How-to: Enable Client Paging in Week view
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Client Paging > Day view, Week view, and Split view > How-to: Enable Client Paging in Week view

Glossary Item Box

In this topic, you will learn how to enable client paging in Week view using EnableClientPaging.

To enable client paging in Week view

  1. Right click on WebScheduler control and choose Properties.
  2. In Properties box, expand ViewSettings >> WeekView.
  3. Set SelectedViewMode to Week and EnableClientPaging to True.

See Also

Tasks
{How-to: Enable Client Paging in Day view}
{How-to: Set EventBlockSize in Week view}
{How-to: Set AllDayEventPageSize in Week view}
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Day view, Week view, and Split view}


How-to: Set EventBlockSize in Week view

How-to: Set EventBlockSize in Week view
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Client Paging > Day view, Week view, and Split view > How-to: Set EventBlockSize in Week view

Glossary Item Box

In this topic, you will learn how to set EventBlockSize in Week view.

To set EventBlockSize in Week view

  1. Right click on WebScheduler control and choose Properties.
  2. In Properties box, expand ViewSettings >> WeekView.
  3. Set SelectedViewMode to Week, EnableClientPaging to True and EventBlockSize to 2.

See Also

Tasks
{How-to: Enable Client Paging in Day view}
{How-to: Enable Client Paging in Week view}
{How-to: Set AllDayEventPageSize in Week view}
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Day view, Week view, and Split view}


How-to: Set AllDayEventPageSize in Week view

How-to: Set AllDayEventPageSize in Week view
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Client Paging > Day view, Week view, and Split view > How-to: Set AllDayEventPageSize in Week view

Glossary Item Box

In this topic, you will learn how to set AllDayEventPageSize in Week view.

To set AllDayEventPageSize in Week view

  1. Right click on WebScheduler control and choose Properties.
  2. In Properties box, expand ViewSettings >> WeekView.
  3. Set SelectedViewMode to Week, EnableClientPaging to True and AllDayEventPageSize to 5.

See Also

Tasks
{How-to: Enable Client Paging in Day view}
{How-to: Enable Client Paging in Week view}
{How-to: Set EventBlockSize in Week view}
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Day view, Week view, and Split view}


Timeline View

Timeline View
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Client Paging > Timeline View

Glossary Item Box

To enable client paging in Timeline view, ViewSettings >> TimelineView >> EnableClientPaging property needs to be set to True.

There are three client paging modes introduced in Timeline view:

  1. EventPageSize
    The EventPageSize mode restricts numbers of event displayed in each Timeline cell. If the total number of events exceeds the value of the EventPageSize property, paging arrow indicator will appear signifying that some events are hidden. A simple click will reveals the complete events in the Timeline cell.

    To enable this mode, set ViewSettings >> TimelineView >> ClientPagingMode property to EventPageSize.

    Events are paged in Timeline view

    Timeline events are displayed when paging arrow indicator is clicked

  2. ViewPort
    When activated, ViewPort™ paging mode will render all events based on the visible viewport. This advanced paging mode intelligently detects the screen's real estate and display the events as user scroll down the page. The previously displayed events will also be cached to improve the overall user experiences.

    For instance, when WebScheduler is loaded and only Resources A and Resources B are visible, it will only display all Resources A's and Resources B's visible events. The events for other resources will be displayed on demand as the viewport is scrolled.

    Set the EnableClientPaging to true and ClientPagingMode to ViewPort. Both properties are located in ViewSettings > TimelineView.

    Events are not yet rendered in initial load.

    Events are rendered when users scroll down.

    ViewPort Client Paging Mode

  3. Both
    This mode combines the best of both EventPageSize™ and ViewPort™ client paging for the most efficient event rendering. This concept renders events based on visible viewport and restricts them when exceeding the numbers of allowed event.

    To enable this mode, set ViewSettings >> TimelineView >> ClientPagingMode property to Both.

    Both client paging mode implemented in Timeline view

In This Section

How-to: Enable client paging in Timeline view

How-to: Enable Client Paging EventPageSize mode

How-to: Enable Client Paging ViewPort mode

How-to: Enable Client Paging Both mode

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Day view, Week view, and Split view}
{Show all Timeline events in client-side}
{Data editing when Client paging is enabled}


How-to: Enable client paging in Timeline view

How-to: Enable client paging in Timeline view
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Client Paging > Timeline View > How-to: Enable client paging in Timeline view

Glossary Item Box

WebScheduler provides client paging feature in Timeline view.

In this topic, you will learn how to enable Client paging in Timeline view.

To enable Client Paging in Timeline view

  1. Right click on the WebScheduler's control and choose Properties.
  2. In Properties box, expand ViewSettings >> TimelineView.
  3. Set SelectedViewMode to Timeline and EnableClientPaging to True.

See Also

Tasks
{How-to: Enable Client Paging EventPageSize mode}
{How-to: Enable Client Paging ViewPort mode}
{How-to: Enable Client Paging Both mode}
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Timeline View}


How-to: Enable Client Paging EventPageSize mode

How-to: Enable Client Paging EventPageSize mode
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Client Paging > Timeline View > How-to: Enable Client Paging EventPageSize mode

Glossary Item Box

The concept of EventPageSize client paging is to limit each of Timeline's cell event rendering with EventPageSize. If the events in Timeline-s cell are more than the EventPageSize, there will be paging arrow indicator that indicate that there are more events in the cell. User can see all of the events in Timeline's cell when this more icon is clicked.

In this topic, you will learn how to enable Client paging EventPageSize mode.

To enable Client Paging EventPageSize mode

  1. Right click on the WebScheduler's control and choose Properties.
  2. In Properties box, expand ViewSettings >> TimelineView.
  3. Set EnableClientPaging to True and ClientPagingMode to EventPageSize.

    Initial view

    After "more icon" is clicked

See Also

Tasks
{How-to: Enable Client Paging ViewPort mode}
{How-to: Enable Client Paging Both mode}
{How-to: Enable client paging in Timeline view}
{Walkthrough Topics}
{How-to Topics}

Other Resources
Timeline View


How-to: Enable Client Paging ViewPort mode

How-to: Enable Client Paging ViewPort mode
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Client Paging > Timeline View > How-to: Enable Client Paging ViewPort mode

Glossary Item Box

The concept of ViewPort client paging is to render events in Timeline based on view port. For example, if the ViewPort only show Resource A and Resource B, then event rendering only happen on Resource A and Resource B.

In this topic, you will learn how to enable client paging ViewPort mode.

To enable Client Paging ViewPort mode

  1. Right click on the WebScheduler's control and choose Properties.
  2. In Properties box, expand ViewSettings >> TimelineView.
  3. Set EnableClientPaging to True and ClientPagingMode to ViewPort.

    Initial view

    After "more icon" is clicked

See Also

Tasks
{How-to: Enable Client Paging EventPageSize mode}
{How-to: Enable Client Paging Both mode}
{How-to: Enable client paging in Timeline view}
{Walkthrough Topics}
{How-to Topics}

Other Resources
Timeline View


How-to: Enable Client Paging Both mode

How-to: Enable Client Paging Both mode
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Client Paging > Timeline View > How-to: Enable Client Paging Both mode

Glossary Item Box

The concept of Both client paging is to combine client paging EventPageSize and ViewPort so the rendering will based on view port and the events that will be rendered will be based on EventPageSize.

In this topic, you will learn how to enable client paging both mode.

To enable Client Paging Both mode

  1. Right click on the WebScheduler's control and choose Properties.
  2. In Properties box, expand ViewSettings >> TimelineView.
  3. Set EnableClientPaging to True and ClientPagingMode to Both.

See Also

Tasks
{How-to: Enable Client Paging EventPageSize mode}
{How-to: Enable Client Paging ViewPort mode}
{How-to: Enable client paging in Timeline view}
{Walkthrough Topics}
{How-to Topics}

Other Resources
Timeline View


Show all Timeline events in client-side

Show all Timeline events in client-side
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Client Paging > Show all Timeline events in client-side

Glossary Item Box

When client paging is enabled in Timeline view and EventPageSize mode is applied, ShowAllEvents client-side function can be used to show all resources hidden events.

Javascript Copy Image Copy Code
<script language="javascript">
function ShowAllEvents()
{
   var s = ISGetObject("WebScheduler1");
   s.ShowAllEvents();
}
</script>

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
Day view, Week view, and Split view
{Timeline View}
{Data editing when Client paging is enabled}


Data editing when Client paging is enabled

Data editing when Client paging is enabled
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Client Paging > Data editing when Client paging is enabled

Glossary Item Box

When client paging is enabled in WebScheduler, there are hidden events in paged cells or blocks. When new event is added to paged cells or blocks, the events in the cells or blocks will be re-rendered. The newly-added event might be included as hidden events if the total events in the cell have exceeded the maximum allowed events. This behavior is also implemented when update action is performed.

When an event is deleted from paged cells or blocks, only the event block will be re-rendered. During re-rendering process, the paging indicator will be removed when the total events has not exceed the maximum allowed events.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Day view, Week view, and Split view}
{Timeline View}
{Show all Timeline events in client-side}


Detail Box Paging

Detail Box Paging
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Detail Box Paging

Glossary Item Box

When client paging is enabled in Day, Week, and Split view, detail box will be displayed when users click on paging arrow indicator in the paged block. If the block contains many events, paging for events displayed in detail box can be enabled. The date range of the paged block will be rendered in detail box's header.

To enable this feature, set LayoutSettings >> EnableDetailBoxPaging to True.

When paging is enabled in detail box, by default the page size is set to 5. In that case, five events will be displayed per page in detail box. Custom page size can be specified in LayoutSettings >> DetailBoxPageSize property.

These configurations will be applied in global, so when enabled, it will be applied to detail box in Day, Week, Month, and Split view.

Detail Box Paging with Page Size set to 4

In This Section

How-to: Enable Detail Box Paging in WebScheduler

How-to: Set Detail Box Page Size in WebScheduler

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Client Paging}
{Time Interval}
{Visible Hours}
{Disabled Time}


How-to: Enable Detail Box Paging in WebScheduler

How-to: Enable Detail Box Paging in WebScheduler
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Detail Box Paging > How-to: Enable Detail Box Paging in WebScheduler

Glossary Item Box

When client paging is enabled in Day, Week, and Split view, detail box will be displayed when users click on paging arrow indicator in the paged block.

In this topic, you will learn how to enable detail box paging using WebScheduler's property.

To enable Detail Box Paging

  1. Right click on the WebScheduler's control and choose Properties.
  2. In Properties box, expand LayoutSettings.
  3. Set EnableDetailBoxPaging to True.

See Also

Tasks
{How-to: Set Detail Box Page Size in WebScheduler}
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Detail Box Paging}


How-to: Set Detail Box Page Size in WebScheduler

How-to: Set Detail Box Page Size in WebScheduler
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Detail Box Paging > How-to: Set Detail Box Page Size in WebScheduler

Glossary Item Box

When paging is enabled in detail box, by default the page size is set to 5. In that case, five events will be displayed per page in detail box.

In this topic, you will learn how to customize detail box page size.

To set Detail Box Page Size

  1. Right click on the WebScheduler's control and choose Properties.
  2. In Properties box, expand LayoutSettings.
  3. Set EnableDetailBoxPaging to True and set DetailBoxPageSize to 3.

See Also

Tasks
{How-to: Enable Detail Box Paging in WebScheduler}
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Detail Box Paging}


Time Interval

Time Interval
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Time Interval

Glossary Item Box

Day, Week, and Split view have two areas: all-day area and hour area. In previous version, hour area is displayed in 30-minutes interval. In current version, various time interval options can be specified in these views.

In This Section

Various Time Interval Options

Include in Context Menu

Set Time Interval Programmatically

Integrated Multiple Cell Selection Support

How-to: Set Time Interval in Week view

How-to: Include Time Interval Options in Context Menu

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Disabled Time}
{Client Paging}
{Detail Box Paging}


Various Time Interval Options

Various Time Interval Options
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Time Interval > Various Time Interval Options

Glossary Item Box

To specify a specific time interval in Day view, ViewSettings >> DayView >> TimeInterval needs to be specified to one of available options. To specify time interval in Week view, ViewSettings >> WeekView >> TimeInterval needs to be specified to one of available options, which are: Minutes10, Minutes15, Minutes30, and Minutes60. Since Split view uses the same configuration as Day view, the time interval applied to Day view will also be applied to Split view. On the other hand, Day and Week view can use different time interval configurations.

15-minutes Time Interval in Week view

If the time interval is set to 60-minutes duration, the row height will be multiplied by 2. This layout is applied to allow users to see events with short durations more clearly; otherwise the events will overlap above other events causing messed layout. Besides the view, events UI are also adjusted to the active time interval.

See Also

Tasks
{How-to: Set Time Interval in Week view}
{How-to: Include Time Interval Options in Context Menu}
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Include in Context Menu}
{Set Time Interval Programmatically}
{Integrated Multiple Cell Selection Support}


Include in Context Menu

Include in Context Menu
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Time Interval > Include in Context Menu

Glossary Item Box

Additionally, the time interval can be changed at runtime. Users can select one of the time interval options in context menu. When changed, the scheduler view and its events will be re-rendered. To include time interval options in context menu, IncludeTimeIntervalInMenu property can be set to True.

Time interval options included in context menu

See Also

Tasks
{How-to: Set Time Interval in Week view}
{How-to: Include Time Interval Options in Context Menu}
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Various Time Interval Options}
{Set Time Interval Programmatically}
{Integrated Multiple Cell Selection Support}


Set Time Interval Programmatically

Set Time Interval Programmatically
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Time Interval > Set Time Interval Programmatically

Glossary Item Box

Time interval can also be set using client-side API, SetTimeInterval function. The following code snippet will change the time interval to 15 minutes interval.

JavaScript Copy Code
function SetInterval()
{
   var s = ISGetObject("WebScheduler1");
   s.SetTimeInterval("Minutes15");
}

See Also

Tasks
{How-to: Set Time Interval in Week view}
{How-to: Include Time Interval Options in Context Menu}
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Various Time Interval Options}
{Include in Context Menu}
{Integrated Multiple Cell Selection Support}


Integrated Multiple Cell Selection Support

Integrated Multiple Cell Selection Support
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Time Interval > Integrated Multiple Cell Selection Support

Glossary Item Box

Users can select multiple cells and create a new event within the selected date range. With the new time interval options, the duration of multiple selected cells is adjusted to the active time range. Similar to previous version, the duration can be seen in the callout header and new event can be added within the selected range.

Date range of selected multiple cell adjusted with 10-minutes time interval

See Also

Tasks
{How-to: Set Time Interval in Week view}
{How-to: Include Time Interval Options in Context Menu}
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Various Time Interval Options}
{Include in Context Menu}
{Set Time Interval Programmatically}


How-to: Set Time Interval in Week view

How-to: Set Time Interval in Week view
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Time Interval > How-to: Set Time Interval in Week view

Glossary Item Box

WebScheduler enables user to use various time interval options in this current version.

In this topic, you will learn how to set Time Interval in week view.

To set Time Interval in Week view

  1. Right click on WebScheduler control and choose Properties.
  2. In Properties box, expand ViewSettings >> WeekView.
  3. Set SelectedViewMode to Week and TimeInterval to Minutes15. You can choose either Minutes10, Minutes15, Minutes30 or Minutes60.

See Also

Tasks
{How-to: Include Time Interval Options in Context Menu}
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Time Interval}


How-to: Include Time Interval Options in Context Menu

How-to: Include Time Interval Options in Context Menu
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Time Interval > How-to: Include Time Interval Options in Context Menu

Glossary Item Box

WebScheduler enables user to use various time interval options in this current version.

In this topic, you will learn how to set Time Interval in week view.

To include Time Interval options in Context Menu

  1. Right click on WebScheduler control and choose Properties.
  2. In Properties box, set IncludeTimeIntervalInMenu to True.

See Also

Tasks
{How-to: Set Time Interval in Week view}
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Time Interval}


Visible Hours

Visible Hours
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Visible Hours

Glossary Item Box

By default in Day, Week, and Split view, hour area starts from 00:00 AM to 11:30 PM. In this version, it is possible to specify visible hours where the start time and end time are customized.

Visible start time can be set in ViewSettings >> VisibleStartTime property and visible end time can be set in ViewSettings >> VisibleEndTime property. The scheduler view will starts from the visible start time specified and ends at the visible end time specified.

Events will be rendered based on the visible hours. If the visible start time is set to 06:00 AM and visible end time is set to 07:00 PM, only events that occur in the date range will be rendered. Event that starts at 04:00 AM and ends at 12:00 AM, will be rendered from 06:00 AM to 12:00 AM, however the original date range of the event can still be seen in the detail callout.

Week view starts from 06:00 AM and ends at 07:00 PM

Although only events within the visible hours are rendered, the bold indicator in calendar dates will still count events that are not visible in the visible hours. This allows users to see the summary of all events in the active month.

Event indicator in calendar counts all events in the active month

In This Section

How-to: Set Visible Hours in Week view

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Disabled Time}
{Client Paging}
{Detail Box Paging}
{Time Interval}


How-to: Set Visible Hours in Week view

How-to: Set Visible Hours in Week view
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Visible Hours > How-to: Set Visible Hours in Week view

Glossary Item Box

In this current version, WebScheduler enables user to specify visible hours where the start time and end time are customized.

In this topic, you will learn how to set Visible Hours in week view.

To set Visible Hours in week view

  1. Right click on WebScheduler control and choose Properties.
  2. In Properties box, expand ViewSettings.
  3. Set VisibleStartTime to t1000 and VisibleEndTime to t1600. The hour area can be customized from 00:00 AM to 11.30 PM. In this sample, the visible hours starts from 10:00 to 16:00.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Visible Hours}


Disabled Time

Disabled Time
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Disabled Time

Glossary Item Box

Disabled time is a unique feature which enables developer to specify a portion of time when event creation is disabled without requiring complex efforts or codes. When the disabled time is specified, user will not be able to add a new or edit an existing event and set it within the range of specified disabled time period.

Since data operation cannot be performed in Quarter and Year view and Agenda view is text-based event information, disabled time feature is not implemented in these 3 views.

In This Section

Styles and Behavior

Disabled Time Options

Disabled Time Validation Concept

Custom Disabled Time Validation

Create Disabled Time in Client-side

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Full XHTML Support}
{Client Paging}
{Detail Box Paging}
{Time Interval}


Styles and Behavior

Styles and Behavior
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Disabled Time > Styles and Behavior

Glossary Item Box

The disabled time feature affects the following features:

  1. Cell styles in scheduler view
    In addition to blocked new event creation and editing, cells where the time is disabled will have different background color to indicate the disabled time indicator. Several styles properties are exposed for further customization on disabled time styles:

      • Day, Week, and Split view: DisabledAllDayEventAreaStyle, DisabledWorkHourStyle, and DisabledNonWorkHourStyle.

        Disabled time style in Day, Week, and Split view
      • Month view: DisabledMonthOutboundCellStyle and DisabledMonthInboundCellStyle.

        Disabled time style in Day, Week, and Split view

      • Timeline view: TimelineDisabledTimeCellStyle.

        Disabled time style in Timeline view

  2. Editing Form and CallOut
    CallOut or Editing Form will not appear when clicking on disabled time cell - preventing user from inserting a new event. Additionally, upon saving the event, an alert box will pop out.

  3. Context Menu
    New event, New Recurring Event and New All Day Event options in context menu will be disabled when clicking on disabled time cell.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Disabled Time Options}
{Disabled Time Validation Concept}
{Custom Disabled Time Validation}
{Create Disabled Time in Client-side}


Disabled Time Options

Disabled Time Options
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Disabled Time > Disabled Time Options

Glossary Item Box

There are 3 disabled time options.

  1. Global Disabled Time
  2. Resource Disabled Time
  3. Partial Disabled Time

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Styles and Behavior}
{Disabled Time Validation Concept}
{Custom Disabled Time Validation}
{Create Disabled Time in Client-side}


Global Disabled Time

Global Disabled Time
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Disabled Time > Disabled Time Options > Global Disabled Time

Glossary Item Box

As the name implies, Global disabled time is applied to certain date and time and applied to all views. In Timeline view, the disabled time will be applied to all resources.

<DisabledTime >
         <ISWebScheduler:WebSchedulerDisabledTime EndTime="2009-06-04" StartTime="2009-06-03">
         </ISWebScheduler:WebSchedulerDisabledTime>
</DisabledTime >
In Month and Timeline view, the following configuration will set 3rd of June 2009 as disabled time. Note that 4th of June 2009 are not included because the date range ends at that date.

Global disabled time in Timeline View mode

Day, Week, and Split view contain two scheduler areas: the all-day area and hour area. The start time and end time of each disabled time will be used to indicate whether the all day area or hour area will be disabled.

The following configuration will set the 12th - 13th of March 2008 as disabled time. The start time and end time definition does not include time part, thus all-day area will be disabled.

<DisabledTime>
         <ISWebScheduler:WebSchedulerDisabledTime StartTime="2008-03-12" EndTime="2008-03-13">
         </ISWebScheduler:WebSchedulerDisabledTime>
</DisabledTime>

Global disabled all-day area in Week view

To disable the hour area, the complete date and time range must specified as disabled time collection. Below is an example on how to disable 10:00 AM - 12:00 PM on March 12th 2008.

<DisabledTime>
      <ISWebScheduler:WebSchedulerDisabledTime StartTime="2008-03-12 10:00:00" EndTime="2008-03-12 12:00:00">
      </ISWebScheduler:WebSchedulerDisabledTime>
</DisabledTime>

Global disabled hour area in Week view

In This Section

How-to: Add Global Disabled Time in Timeline view

How-to: Add Global Disabled Time for All Day Area in Week view

How-to: Add Global Disabled Time for Hour Area in Week view

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Resource Disabled Time}
{Partial Disabled Time}


How-to: Add Global Disabled Time in Timeline view

How-to: Add Global Disabled Time in Timeline view
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Disabled Time > Disabled Time Options > Global Disabled Time > How-to: Add Global Disabled Time in Timeline view

Glossary Item Box

Global Disabled Time will affect all of the resources in Timeline. Global Disabled Time can be defined in design time or runtime.

In this topic, you will learn how to perform global disabled time using WebScheduler's properties.

To add Global Disabled Time in Timeline View

  1. Right click on WebScheduler's control and choose Properties.
  2. Expand ViewSettings and set SelectedViewMode to Timeline.
  3. In Properties box, Select DisabledTime and open its Collection.
  4. Set StartTime and EndTime according to your needs. In this sample, StartTime is set to "3/1/2008" and EndTime is set to "3/2/2008".

See Also

Tasks
How-to: Add Global Disabled Time for All Day Area in Week view
How-to: Add Global Disabled Time for Hour Area in Week view
{Walkthrough Topics}
{How-to Topics}

Other Resources
Global Disabled Time


How-to: Add Global Disabled Time for All Day Area in Week view

How-to: Add Global Disabled Time for All Day Area in Week view
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Disabled Time > Disabled Time Options > Global Disabled Time > How-to: Add Global Disabled Time for All Day Area in Week view

Glossary Item Box

Global Disabled Time will affect all of the resources in Timeline. Global Disabled Time can be defined in design time or runtime.

In this topic, you will learn how to perform global disabled time using WebScheduler's properties.

To add Global Disabled Time for All Day Area in Week view

  1. Right click on WebScheduler's control and choose Properties.
  2. Expand ViewSettings and set SelectedViewMode to Week.
  3. In Properties box, Select DisabledTime and open its Collection.
  4. Set StartTime and EndTime according to your needs. In this sample, StartTime is set to "3/12/2008" and EndTime is set to "3/13/2008".

See Also

Tasks
{How-to: Add Global Disabled Time in Timeline view}
{How-to: Add Global Disabled Time for Hour Area in Week view}
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Global Disabled Time}


How-to: Add Global Disabled Time for Hour Area in Week view

How-to: Add Global Disabled Time for Hour Area in Week view
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Disabled Time > Disabled Time Options > Global Disabled Time > How-to: Add Global Disabled Time for Hour Area in Week view

Glossary Item Box

Global Disabled Time will affect all of the resources in Timeline. Global Disabled Time can be defined in design time or runtime.

In this topic, you will learn how to perform global disabled time using WebScheduler's properties.

To add Global Disabled Time for Hour Area in Week view

  1. Right click on WebScheduler's control and choose Properties.
  2. Expand ViewSettings and set SelectedViewMode to Week.
  3. In Properties box, Select DisabledTime and open its Collection.
  4. Set StartTime and EndTime according to your needs. In this sample, StartTime is set to "3/12/2008 10:00 AM" and EndTime is set to "3/12/2008 1:00 PM".

See Also

Tasks
{How-to: Add Global Disabled Time in Timeline view}
{How-to: Add Global Disabled Time for All Day Area in Week view}
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Global Disabled Time}


Resource Disabled Time

Resource Disabled Time
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Disabled Time > Disabled Time Options > Resource Disabled Time

Glossary Item Box

Resource Disabled Time is a resource specific disabled time. This option lets developer specify a specific rule for each resource. Resource disabled time can only be set from code behind in OnDataBound server-side event. The disabled time collection will then be populated to each resource object using PopulateDisabledTime server-side method.

A code snippet on how to create resource disabled time in OnDataBound server side event.

C# Copy Code
protected void WebScheduler1_DataBound(object sender, ISNet.WebUI.WebScheduler.WebSchedulerDataBoundDataArgs e)
{
   if (e.Type == ISNet.WebUI.WebScheduler.WebSchedulerObjectType.Resource)
   {
      WebSchedulerResource data = e.DataObject as WebSchedulerResource;
      if (data.ResourceID == 1)
      {
         DataTable dt = new DataTable("DisabledTime");
         DataColumn dc = new DataColumn("StartTime", Type.GetType("System.DateTime"));
         DataColumn dc2 = new DataColumn("EndTime", Type.GetType("System.DateTime"));
         DataColumn dc3 = new DataColumn("ResourceID", Type.GetType("System.Int32"));

         dt.Columns.Add(dc);
         dt.Columns.Add(dc2);
         dt.Columns.Add(dc3);

         DataRow dr = dt.NewRow();
         dr["StartTime"] = new DateTime(2009, 6, 1);
         dr["EndTime"] = new DateTime(2009, 6, 2);
         dt.Rows.Add(dr);

         dr = dt.NewRow();
         dr["StartTime"] = new DateTime(2009, 6, 10);
         dr["EndTime"] = new DateTime(2009, 6, 11);
         dr["ResourceID"] = 1;
         dt.Rows.Add(dr);

         WebSchedulerResource schedulerResource = e.DataObject as WebSchedulerResource;
         schedulerResource.PopulateDisabledTime(dt, "StartTime", "EndTime");
      }
   }
}

Resource specific Disabled Time in Timeline View mode

Resource disabled time can also be specified in Split view.

In This Section

How-to: Add Resource Disabled Time in Timeline view

See Also

Tasks
{Walkthrough Topics}
How-to Topics

Other Resources
{Global Disabled Time}


How-to: Add Resource Disabled Time in Timeline view

How-to: Add Resource Disabled Time in Timeline view
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Disabled Time > Disabled Time Options > Resource Disabled Time > How-to: Add Resource Disabled Time in Timeline view

Glossary Item Box

Resource Disabled Time will only affect the resource itself; the effect will not influence other resources in Timeline.

In this topic, you will learn how to set Resource disabled time in runtime using OnDataBound server-side event and populate to WebScheduler using PopulateDisabledTime server side method.

To create Resource Disabled Time

Place the following code under DataBound server side event:

C# Copy Image Copy Code
protected void WebScheduler1_DataBound(object sender, ISNet.WebUI.WebScheduler.WebSchedulerDataBoundDataArgs e)
{
   if (e.Type == ISNet.WebUI.WebScheduler.WebSchedulerObjectType.Resource)
   {
      WebSchedulerResource data = e.DataObject as WebSchedulerResource;

      if (data.ResourceID == 1)
      {
         DataTable dt = new DataTable("DisabledTime");
         DataColumn dc = new DataColumn("StartTime", Type.GetType("System.DateTime"));
         DataColumn dc2 = new DataColumn("EndTime", Type.GetType("System.DateTime"));
         dt.Columns.Add(dc);
         dt.Columns.Add(dc2);

         DataRow dr = dt.NewRow();
         dr["StartTime"] = new DateTime(2008, 3, 2);
         dr["EndTime"] = new DateTime(2008, 3, 3);
         dt.Rows.Add(dr);

         dr = dt.NewRow();
         dr["StartTime"] = new DateTime(2008, 3, 10);
         dr["EndTime"] = new DateTime(2008, 3, 11);
         dt.Rows.Add(dr);

         WebSchedulerResource schedulerResource = e.DataObject as WebSchedulerResource;
         schedulerResource.PopulateDisabledTime(dt, "StartTime", "EndTime");
      }
   }
}

In Timeline, the cell that include in the disabled time's date time will use TimelineDisabledTimeCellStyle. Same with other style in WebScheduler, TimelineDisabledTimeCellStyle is also customizable.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
Resource Disabled Time


Partial Disabled Time

Partial Disabled Time
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Disabled Time > Disabled Time Options > Partial Disabled Time

Glossary Item Box

Partial disabled time is an extension of the disabled time concept in which not the entire day is disabled. Unlike the standard disabled time behavior, the Partial disabled time allows developer to specify certain disabled hours. To differentiate it from the global disabled time, a small padlock is added as a visual hint, which can be customized using ImagesSettings >> PartialTimelineDisabledTimeIcon property.

In the following screenshot, 9th of March 2009 01:00 PM to 02:00 PM is set as disabled time. Since only some part of the whole day is disabled, partial indicator is displayed at the bottom of the cell and the cell is considered as partial disabled cell.

Partial disabled time in Timeline view

In Timeline view, the partial disabled time range can be displayed as tooltip when user hovers a disabled cell. To enable this feature, ViewSettings >> TimelineView >> DisplayDisabledTimeTooltip property needs to be set to true.

Disabled time range is displayed as tooltip when disabled cell is hovered

In This Section

How-to: Add Partial Disabled Time in Timeline view

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}
{Resource Disabled Time}

Other Resources
{Global Disabled Time}


How-to: Add Partial Disabled Time in Timeline view

How-to: Add Partial Disabled Time in Timeline view
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Disabled Time > Disabled Time Options > Partial Disabled Time > How-to: Add Partial Disabled Time in Timeline view

Glossary Item Box

Partial disabled time is a combination between global and resource disabled time. For partial disabled time cell, WebScheduler will give differentiate on the Timeline cell by put a small "padlock" icon in the top right of the cell.

In this topic, you will learn how to create partial disabled time using both global and resource disabled time.

To create Partial Disabled Time

Global Partial Disabled Time

  1. Right click on the WebScheduler's control and choose Properties.
  2. In Properties box, Select DisabledTime and open its Collection.
  3. Set StartTime and EndTime according to your needs. In this sample, StartTime is set to "3/9/2008 1:00PM" and EndTime is set to "3/9/2008 2:00PM".

Resource Partial Disabled Time

Put the following code under DataBound server side event:

C# Copy Image Copy Code
protected void WebScheduler1_DataBound(object sender, ISNet.WebUI.WebScheduler.WebSchedulerDataBoundDataArgs e)
{
   if (e.Type == ISNet.WebUI.WebScheduler.WebSchedulerObjectType.Resource)
   {
      WebSchedulerResource data = e.DataObject as WebSchedulerResource;
      if (data.ResourceID == 5)
      {
         DataTable dt = new DataTable("DisabledTime");
         DataColumn dc = new DataColumn("StartTime", Type.GetType("System.DateTime"));
         DataColumn dc2 = new DataColumn("EndTime", Type.GetType("System.DateTime"));
         DataColumn dc3 = new DataColumn("ResourceID", Type.GetType("System.Int32"));
         dt.Columns.Add(dc);
         dt.Columns.Add(dc2);
         dt.Columns.Add(dc3);

         DataRow dr = dt.NewRow();
         dr["StartTime"] = new DateTime(2008, 3, 3, 8, 0, 0);
         dr["EndTime"] = new DateTime(2008, 3, 3, 9, 0, 0);
         dt.Rows.Add(dr);

         WebSchedulerResourceschedulerResource = e.DataObject as WebSchedulerResource;
         schedulerResource.PopulateDisabledTime(dt, "StartTime", "EndTime");
      }
   }
}

See Also

Tasks
Walkthrough Topics
{How-to Topics}

Other Resources
Partial Disabled Time


How-to: Use Disabled Time

How-to: Use Disabled Time
Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Disabled Time > Disabled Time Options > How-to: Use Disabled Time

Glossary Item Box

Disabled time is a unique feature which enables developer to specify a portion of time when event creation is disabled without requiring complex efforts or codes.

There are 3 options available in using Disabled Time:

  • Global Disabled Time
  • Resource Disabled Time
  • Partial Disabled Time

In this topic, you will learn how to use Disabled Time with these 3 options.

Global Disabled Time will affect all of the resources in Timeline. Global Disabled Time can be defined in design time or runtime.

In this topic, you will learn how to perform global disabled time using WebScheduler's properties.

To create Global Disabled Time in Timeline View

  1. Right-click on WebScheduler's control and choose Properties.
  2. Expand ViewSettings and set SelectedViewMode to Timeline.
  3. In Properties box, Select DisabledTime and open its Collection.
  4. Set StartTime and EndTime according to your needs. In this sample, StartTime is set to "3/1/2008" and EndTime is set to "3/2/2008".

Resource Disabled Time will only affect the resource itself; the effect will not influence other resources in Timeline.

In this topic, you will learn how to set Resource disabled time in runtime using OnDataBound server-side event and populate to WebScheduler using PopulateDisabledTime server side method.

To create Resource Disabled Time

Place the following code under DataBound server side event:

C# Copy Image Copy Code
protected void WebScheduler1_DataBound(object sender, ISNet.WebUI.WebScheduler.WebSchedulerDataBoundDataArgs e)
{
   if (e.Type == ISNet.WebUI.WebScheduler.WebSchedulerObjectType.Resource)
   {
      WebSchedulerResource data = e.DataObject as WebSchedulerResource;

      if (data.ResourceID == 1)
      {
         DataTable dt = new DataTable("DisabledTime");
         DataColumn dc = new DataColumn("StartTime", Type.GetType("System.DateTime"));
         DataColumn dc2 = new DataColumn("EndTime", Type.GetType("System.DateTime"));
         dt.Columns.Add(dc);
         dt.Columns.Add(dc2);

         DataRow dr = dt.NewRow();
         dr["StartTime"] = new DateTime(2008, 3, 2);
         dr["EndTime"] = new DateTime(2008, 3, 3);
         dt.Rows.Add(dr);

         dr = dt.NewRow();
         dr["StartTime"] = new DateTime(2008, 3, 10);
         dr["EndTime"] = new DateTime(2008, 3, 11);
         dt.Rows.Add(dr);

         WebSchedulerResource schedulerResource = e.DataObject as WebSchedulerResource;
         schedulerResource.PopulateDisabledTime(dt, "StartTime", "EndTime");
      }
   }
}

In Timeline, the cell that include in the disabled time's date time will use TimelineDisabledTimeCellStyle. Same with other style in WebScheduler, TimelineDisabledTimeCellStyle is also customizable.

Partial disabled time is a combination between global and resource disabled time. For partial disabled time cell, WebScheduler will give differentiate on the Timeline cell by put a small "padlock" icon in the top right of the cell.

In this topic, you will learn how to create partial disabled time using both global and resource disabled time.

To create Partial Disabled Time

Global Partial Disabled Time

  1. Right click on the WebScheduler's control and choose Properties.
  2. In Properties box, Select DisabledTime and open its Collection.
  3. Set StartTime and EndTime according to your needs. In this sample, StartTime is set to "3/9/2008 1:00PM" and EndTime is set to "3/9/2008 2:00PM".

Resource Partial Disabled Time

Put the following code under DataBound server side event:

C# Copy Image Copy Code
protected void WebScheduler1_DataBound(object sender, ISNet.WebUI.WebScheduler.WebSchedulerDataBoundDataArgs e)
{
   if (e.Type == ISNet.WebUI.WebScheduler.WebSchedulerObjectType.Resource)
   {
      WebSchedulerResource data = e.DataObject as WebSchedulerResource;
      if (data.ResourceID == 5)
      {
         DataTable dt = new DataTable("DisabledTime");
         DataColumn dc = new DataColumn("StartTime", Type.GetType("System.DateTime"));
         DataColumn dc2 = new DataColumn("EndTime", Type.GetType("System.DateTime"));
         DataColumn dc3 = new DataColumn("ResourceID", Type.GetType("System.Int32"));
         dt.Columns.Add(dc);
         dt.Columns.Add(dc2);
         dt.Columns.Add(dc3);

         DataRow dr = dt.NewRow();
         dr["StartTime"] = new DateTime(2008, 3, 3, 8, 0, 0);
         dr["EndTime"] = new DateTime(2008, 3, 3, 9, 0, 0);
         dt.Rows.Add(dr);

         WebSchedulerResourceschedulerResource = e.DataObject as WebSchedulerResource;
         schedulerResource.PopulateDisabledTime(dt, "StartTime", "EndTime");
      }
   }
}


How-to: Use Disabled Time in Month View

How-to: Use Disabled Time in Month View
Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Disabled Time > Disabled Time Options > How-to: Use Disabled Time in Month View

Glossary Item Box

You can use Global and Partial Disabled Time in Month view.

This topic will show you how to perform the above scenario.

To use Global Disabled Time in Month View

  1. Right click WebScheduler control and choose Properties.
  2. Expand ViewSettings and set SelectedViewMode to Month.
  3. In Properties box, Select DisabledTime and open its Collection.
  4. Set StartTime and EndTime according to your needs. In this sample, StartTime is set to "3/9/2008" and EndTime is set to "3/10/2008".

To use Partial Disabled Time in Month View

  1. Right click on the WebScheduler's control and choose Properties.
  2. In Properties box, Select DisabledTime and open its Collection.
  3. Set StartTime and EndTime according to your needs. In this sample, StartTime is set to "3/9/2008 1:00PM" and EndTime is set to "3/9/2008 2:00PM".


Disabled Time Validation Concept

Disabled Time Validation Concept
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Disabled Time > Disabled Time Validation Concept

Glossary Item Box

The validation process of disabled time is the key strength of DisabledTime feature in WebScheduler. Using this validation process, the date and time range of disabled time are translated to the scheduler UI and data operation actions.

Cells will be disabled if its date and time ranges within disabled time range. When a cell is disabled, editing functionalities, including interactive callout, will be disabled. Update, move, and resize actions will also be prevented if the new date and time ranges within the disabled time range.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Styles and Behavior}
{Disabled Time Options}
{Custom Disabled Time Validation}
{Create Disabled Time in Client-side}


Custom Disabled Time Validation

Custom Disabled Time Validation
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Disabled Time > Custom Disabled Time Validation

Glossary Item Box

The built-in disabled time validation engine prevents event insertion that starts and ends within the disable time area. If the new event start at non-disabled cells and ends inside the disabled time area, the new event will be created and saved. The same thing applies to an event that starts before the disabled time range and ends after the disabled time range.

Developer is also given a complete freedom to manually code the validation logic. This process must be done in OnValidateDisabledTime client-side event. The return must be Boolean value, determining the custom validation result.

The parameters are controlId, startTime, endTime, resourceID and elementType. An event that returns true means that it is set within the disabled time range, and vice versa.

When OnValidateDisabledTime client-side event is implemented, WebScheduler will ignore the built-in disabled time validation and use the custom validation instead.

In This Section

How-to: Implement custom disabled time validation

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Styles and Behavior}
{Disabled Time Options}
{Disabled Time Validation Concept}
{Create Disabled Time in Client-side}


How-to: Implement custom disabled time validation

How-to: Implement custom disabled time validation
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Disabled Time > Custom Disabled Time Validation > How-to: Implement custom disabled time validation

Glossary Item Box

Besides the built-in validation process, developers are allowed to implement custom validation process to meet the requirements in their applications. The custom validation process can be implemented in OnValidateDisabledTime client-side event. The event should return boolean value to determine the result of the custom validation process, which will be used in rendering and data operation process.

In this topic, you will learn how to implement custom disabled time validation.

To implement custom disabled time validation

Using OnValidateDisabledTime client-side event, place the following code:

JavaScript Copy Image Copy Code
function OnValidateDisabledTime(controlId, startTime, endTime, resourceID, elementType)
{
   var s = ISGetObject(controlId);

   var globalDisabledTime = s.DisabledTime;
   var resource = s.GetResourceById(resourceID);

   var loopLength = 1;

   var resourceDisabledTime;
   if (s.ViewSettings.SelectedViewMode == "Timeline")
   {
      loopLength = 2;
      resourceDisabledTime = resource.DisabledTime;
   }

   var result = false;
   for (var i = 0; i < loopLength; i++)
   {
      var disabledTimeCollection;
      if (i == 0)
         disabledTimeCollection = globalDisabledTime;
      else if (i == 1)
         disabledTimeCollection = resourceDisabledTime;

      for (var j = 0; j < disabledTimeCollection.length; j++)
      {
         result = ValidateDisabledTime(s, startTime, endTime, disabledTimeCollection[i], elementType);
         if (result)
            return result;
      }
   }
      return result;
}

function ValidateDisabledTime(s, startTime, endTime, disabledTime, elementType)
{
   var result = false;

   var dtInfoStartTime = disabledTime.StartTime;
   var dtInfoEndTime = disabledTime.EndTime;

   var viewSettings = s.ViewSettings;
   var viewMode = viewSettings.SelectedViewMode;
   var timelineMode = viewSettings.SelectedTimelineViewMode;

   if (endTime.getTime() <= dtInfoEndTime.getTime())
   {
      if (startTime.getTime() >= dtInfoStartTime.getTime())
      {
         if (elementType == "Event" && endTime.getTime() >= dtInfoEndTime.getTime())
            result = false;
         else
            result = true;
      }
      else
      {
         if (startTime.getTime() < dtInfoStartTime.getTime())
         {
            if (elementtype == "Cell" && endTime.getTime() > dtInfoStartTime.getTime())
               result = true;
            else if (elementType == "Event" && endTime.getTime() >= dtInfoStartTime.getTime())
               result = true;
         }
      }
   }
   else if (endTime.getTime() > dtInfoEndTime.getTime() && dtInfoEndTime.getTime() > startTime.getTime() &&
      endTime.getTime() > dtInfoStartTime.getTime())
      result = true;

   return result;
}

The OnValidateDisabledTime() function should return boolean value to indicate the result of DisabledTime validation. Return true, if the event's dateTime in DisabledTime range. Return false, if the event's dateTime is not in DisabledTime range.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Custom Disabled Time Validation}


Create Disabled Time in Client-side

Create Disabled Time in Client-side
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Disabled Time > Create Disabled Time in Client-side

Glossary Item Box

Besides defining disabled time in source view, they can be specified at runtime. In client-side, WebSchedulerDisabledTime object should be created and added to DisabledTime collection. After the disabled time collection is added, WebScheduler needs to be refreshed using Refresh function.

The following code will add disabled time at 1st - 2nd of March 2010 and 7th - 8th of March 2010.

Javascript Copy Image Copy Code
function CreateDisabledTime()
{
   var s = ISGetObject("WebScheduler1");

   //add to global DisabledTime
   var dt = new WebSchedulerDisabledTime();
   dt.StartTime = new Date(2010, 2, 1);
   dt.EndTime = new Date(2010, 2, 2);
   s.DisabledTime.Add(dt);

   //add to resource DisabledTime
   var dt2 = new WebSchedulerDisabledTime();
   dt2.StartTime = new Date(2010, 2, 7);
   dt2.EndTime = new Date(2010, 2, 8);

   var resource = s.GetResourceById("1");
   resource.DisabledTime.Add(dt2);

   s.Refresh();
}

In This Section

How-to: Create Disabled Time in Client-side

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Styles and Behavior}
{Disabled Time Options}
{Disabled Time Validation Concept}
{Custom Disabled Time Validation}


How-to: Create Disabled Time in Client-side

How-to: Create Disabled Time in Client-side
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Disabled Time > Create Disabled Time in Client-side > How-to: Create Disabled Time in Client-side

Glossary Item Box

In client-side, WebSchedulerDisabledTime object should be created and added to DisabledTime collection. After the disabled time collection is added, WebScheduler needs to be refreshed using Refresh function.

In this topic, you will learn how to create disabled time in client side.

To Create Disabled Time in client side

Global Disabled Time

Add the following code in client side:

JavaScript Copy Code
function CreateDisabledTime()
{
   var s = ISGetObject("WebScheduler1");

   //add to global DisabledTime
   var dt = new WebSchedulerDisabledTime();
   dt.StartTime = new Date(2010, 2, 1);
   dt.EndTime = new Date(2010, 2, 2);
   s.DisabledTime.Add(dt);

   s.Refresh();
}

Resource Disabled Time

JavaScript Copy Code
functionCreateDisabledTime()
{
   var s = ISGetObject("WebScheduler1");

   //add to resource DisabledTime
   var dt2 = new WebSchedulerDisabledTime();
   dt2.StartTime = new Date(2010, 2, 7);
   dt2.EndTime = new Date(2010, 2, 8);
   dt.IsAllDayArea = true;

   var resource = s.GetResourceById("1");
   resource.DisabledTime.Add(dt2);

   s.Refresh();
}

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Create Disabled Time in Client-side}


Overwrite Changes Support

Overwrite Changes Support
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Overwrite Changes Support

Glossary Item Box

Concurrency control is a technique that data stores use to control how data is read and changed in the store when multiple clients are accessing and manipulating the same data. ConflictDetection property determines whether or not just the new values are passed to the data operation method or both the old and new values are passed to the method, thus determines which conflict detection approach is used when conflict occurs.

There are two types of ConflictDetection: CompareAllValues and OverwriteChanges. When developers create a new DataSet in Visual Studio 2005, CompareAllValues conflict detection is used by default. On the contrary, OverwriteChanges conflict detection is used by default when developers create a new DataSet in Visual Studio 2008.

WebScheduler 3.0 now supports both CompareAllValues and OverwriteChanges conflict detection options.

In This Section

Walkthrough: Implementing OverwriteChanges conflict detection in WebScheduler

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Full XHTML Support}
{Client Paging}
{Disabled Time}


Walkthrough: Implementing OverwriteChanges conflict detection in WebScheduler

Walkthrough: Implementing OverwriteChanges conflict detection in WebScheduler
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Overwrite Changes Support > Walkthrough: Implementing OverwriteChanges conflict detection in WebScheduler

Glossary Item Box

This walkthrough shows you how to implement OverwriteChanges conflict detection in WebScheduler.

During this walkthrough, you will learn how to do the following:

  • Use ISDataSource.
  • Use SmartTag to set DataSource.
  • Use Data Source Configuration Wizard to set the Database and table.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Intersoft SQL database.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and bind SQL database to WebScheduler

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag and drop WebScheduler and ISDataSource instances from toolbar to WebForm.
  8. Right click on WebScheduler control and choose WebScheduler Database Wizard.
  9. Provide Server name and create Database name. In this case, Server name is set to server1\sqlexpress and Database name is set to Intersoft. Click Create button afterwards.

  10. Open Server Explorer and choose Connect to Database. A dialog box will appear.
  11. Set Server name to server1\sqlexpress and Database name to Intersoft. Click OK to continue.

  12. In the Solution Explorer, right-click on App_Code and select Add New Item.
  13. Add a Dataset and named it Intersoft_DataSet.xsd.
  14. Drag and drop the tables from server explorer to the dataset then save the dataset.

  15. In the Solution Explorer, right-click on App_Code and select Add New Item.
  16. Add a new class and named it IntersoftDataSet.cs.
  17. Here is the IntersoftDataSet.cs content.

    C# Copy Code
    using System.Data.SqlClient;
namespace IntersoftDataSetTableAdapters
{
   public partial class EventsTableAdapter : global::System.ComponentModel.Component
   {
      [global::System.Diagnostics.DebuggerNonUserCodeAttribute()]
      [global::System.ComponentModel.Design.HelpKeywordAttribute("vs.data.TableAdapter")]
      [global::System.ComponentModel.DataObjectMethodAttribute(global::System.ComponentModel.DataObjectMethodType.Insert, true)]
      public virtual int Insert(int EventID, string CategoryID, global::System.Nullable ResourceID, global::System.Nullable Mode, string Subject,
         string Description, string Location, bool AllDayEvent, global::System.Nullable StartTime,
         global::System.Nullable EndTime, global::System.Nullable ReminderTimeSpan)
      {
         this.Connection.Open();
         try
         {
            this.Insert(CategoryID, ResourceID, Mode, Subject, Description, Location, AllDayEvent, StartTime, EndTime, ReminderTimeSpan);
            OleDbCommand command = new OleDbCommand();
            command.CommandText = "SELECT @@IDENTITY";
            command.Connection = this.Connection;
            return (int)command.ExecuteScalar();
         }
         finally
         {
            this.Connection.Close();
         }
      }
   }

   public partial class RecurringEventsTableAdapter : global::System.ComponentModel.Component
   {
      [global::System.Diagnostics.DebuggerNonUserCodeAttribute()]
      [global::System.ComponentModel.Design.HelpKeywordAttribute("vs.data.TableAdapter")]
      [global::System.ComponentModel.DataObjectMethodAttribute(global::System.ComponentModel.DataObjectMethodType.Insert, true)]
      public virtual int Insert(int EventID, global::System.Nullable RecurrenceID, string CategoryID, global::System.Nullable ResourceID,
         global::System.Nullable ParentID, global::System.Nullable Mode, string Subject, string Description, string Location, bool AllDayEvent,
         global::System.Nullable StartTime, global::System.Nullable EndTime,
         global::System.Nullable ExceptionDate, global::System.Nullable ExceptionInfo, global::System.Nullable ReminderTimeSpan)
      {
         this.Connection.Open();
         try
         {
            this.Insert(RecurrenceID, CategoryID, ResourceID, ParentID, Mode, Subject, Description, Location, AllDayEvent, StartTime, EndTime, ExceptionDate, ExceptionInfo, ReminderTimeSpan);
            OleDbCommand command = new OleDbCommand();
            command.CommandText = "SELECT @@IDENTITY";
            command.Connection = this.Connection;
            return (int)command.ExecuteScalar();
         }
         finally
         {
            this.Connection.Close();
         }
      }
   }

   public partial class RecurrenceInfoTableAdapter : global::System.ComponentModel.Component
   {
      [global::System.Diagnostics.DebuggerNonUserCodeAttribute()]
      [global::System.ComponentModel.Design.HelpKeywordAttribute("vs.data.TableAdapter")]
      [global::System.ComponentModel.DataObjectMethodAttribute(global::System.ComponentModel.DataObjectMethodType.Insert, true)]
      public virtual int Insert(int RecurrenceID, global::System.Nullable Mode, global::System.Nullable RangeMode,
         global::System.Nullable StartDate, global::System.Nullable EndDate,
         global::System.Nullable TotalRecurrences, global::System.Nullable NDay, global::System.Nullable NWeek,
         global::System.Nullable NMonth, global::System.Nullable NYear, string WeekDays)
      {
         this.Connection.Open();
         try
         {
            this.Insert(Mode, RangeMode, StartDate, EndDate, TotalRecurrences, NDay, NWeek, NMonth, NYear, WeekDays);
            OleDbCommand command = new OleDbCommand();
            command.CommandText = "SELECT @@IDENTITY";
            command.Connection = this.Connection;
            return (int)command.ExecuteScalar();
         }
         finally
         {
            this.Connection.Close();
         }
      }
   }

   public partial class CategoriesTableAdapter : global::System.ComponentModel.Component
   {
      [global::System.Diagnostics.DebuggerNonUserCodeAttribute()]
      [global::System.ComponentModel.Design.HelpKeywordAttribute("vs.data.TableAdapter")]
      [global::System.ComponentModel.DataObjectMethodAttribute(global::System.ComponentModel.DataObjectMethodType.Insert, true)]
      public virtual int Insert(int CategoryID, string CategoryName, string Description, string CategoryColor)
      {
         this.Connection.Open();
         try
         {
            this.Insert(CategoryName, Description, CategoryColor);
            OleDbCommand command = new OleDbCommand();
            command.CommandText = "SELECT @@IDENTITY";
            command.Connection = this.Connection;
            return (int)command.ExecuteScalar();
         }
         finally
         {
            this.Connection.Close();
         }
      }
   }

   public partial class ResourcesTableAdapter : global::System.ComponentModel.Component
   {
      [global::System.Diagnostics.DebuggerNonUserCodeAttribute()]
      [global::System.ComponentModel.Design.HelpKeywordAttribute("vs.data.TableAdapter")]
      [global::System.ComponentModel.DataObjectMethodAttribute(global::System.ComponentModel.DataObjectMethodType.Insert, true)]
      public virtual int Insert(int ResourceID, string ResourceName, string Description, string Location, string ResourceColor)
      {
         this.Connection.Open();
         try
         {
            this.Insert(ResourceName, Description, Location, ResourceColor);
            OleDbCommand command = new OleDbCommand();
            command.CommandText = "SELECT @@IDENTITY";
            command.Connection = this.Connection;
            return (int)command.ExecuteScalar();
         }
         finally
         {
            this.Connection.Close();
         }
      }
   }
}

  18. Build the solution.
  19. Click the SmartTag and select Configure Data Source on the upper right of the ISDataSource control.
  20. Select SchemaType to DataSet and Schema Name to IntersoftDataSet then click Next.

  21. Make sure the Select, Insert, Update and Delete tab for each table is not empty then click Finish.

  22. Select WebScheduler instance and press F4 to show the WebScheduler's properties.
  23. Set the following properties:

    Property | Value
    DataSourceID | ISDataSource1
    CategoriesDataMember | Categories
    RecurrenceDataMember | RecurrenceInfo
    EventsDataMember | Events
    RecurringEventsDataMember | RecurringEvents
    ResourcesDataMember | Resources

  24. Go to DataBinding and specify the field of CategoryBinding, EventsBinding, RecurrenceBinding, RecurrenceEventsBinding, and ResourcesBinding based on the database field.

  25. WebScheduler binding is done. Now you are able to run the project.

    The database is empty so the current WebScheduler will not show any event or resources.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Overwrite Changes Support}


Several Enhancements in Timeline view

Several Enhancements in Timeline view
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Several Enhancements in Timeline view

Glossary Item Box

Several enhancements are provided in Timeline view:

  • Real Time Operation Editing
  • Exporting
  • New Quarter view in Timeline View mode
  • Customizable Timeline's date header
  • Keep date header always visible in Timeline
  • Zoom-in and Zoom-out functions in Context Menu

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Full XHTML Support}
{Disabled Time}
{Client Paging}
{Detail Box Paging}
{Time Interval}


Real Time Operation editing

Real Time Operation editing
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Several Enhancements in Timeline view > Real Time Operation editing

Glossary Item Box

WebScheduler 3 includes numerous enhancements in the "real time operation" technology such as optimized data editing operation and faster transaction performance. With these enhancements, the events rendering in Timeline now applies only to the affected resource's events during update, thus minimizing the time and overhead required for data updating.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Exporting}
{New Quarter view in Timeline View mode}
{Customizable Timeline's date header}
{Keep date header always visible in Timeline}
{Zoom-in and Zoom-out functions in Context Menu}


Exporting

Exporting
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Several Enhancements in Timeline view > Exporting

Glossary Item Box

WebScheduler's exceptional exporting feature lets you easily disseminate your information in PDF format or syncing group calendars to every team member's Microsoft Outlook 2007. In version 3, WebScheduler improves its exporting functionality to support Timeline view. This comprehensive exporting covers all Timeline View modes, such as Day15Minutes, DayHourly, Week, Month, and Quarter.

Timeline export to PDF format using DayHourly View mode

In This Section

Timeline exporting customization

How-to: Enable Export in Timeline

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Customizable number of days in Agenda}
{Zoom-in and Zoom-out functions in Context Menu}
{Real Time Operation editing}
{New Quarter view in Timeline View mode}
{Customizable Timeline's date header}
{Keep date header always visible in Timeline}


Timeline exporting customization

Timeline exporting customization
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Several Enhancements in Timeline view > Exporting > Timeline exporting customization

Glossary Item Box

Customization on the Timeline exporting behavior is added to cover wider business scenarios, for example: customize the exported Timeline column's length.

This feature is very handy in certain scenarios that have many columns. Let's say we have 30 columns in Timeline Month view. While this won't be any problem when viewed in WebScheduler, exporting it will be a problem due to the paper size. To address this issue, WebScheduler allows developer to manually alter the column's length.

Below are properties that can be used to customize Timeline column's length in exporting.

  1. QuarterExportColumnLength , to customize Timeline Quarter view column's length.
  2. MonthExportColumnLength, to customize Timeline Month view column's length.
  3. WeekExportColumnLength, to customize Timeline Week view column's length.
  4. DayHourlyExportColumnLength, to customize Timeline DayHourly view column's length.
  5. Day15MinutesExportColumnLength, to customize Timeline Day15Minutes view column's length.

Timeline export customization properties can be found in ViewSettings > TimelineView.

Manually specifying the column's length when exporting a Timeline mode WebScheduler

In This Section

How-to: Perform Timeline Export Customization

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Exporting}


How-to: Perform Timeline Export Customization

How-to: Perform Timeline Export Customization
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Several Enhancements in Timeline view > Exporting > Timeline exporting customization > How-to: Perform Timeline Export Customization

Glossary Item Box

Exporting in Timeline allows user to customize the exported Timeline column's length.

In this topic, you will learn how to customize Timeline Export.

To perform Timeline Export customization

  1. Right click on WebScheduler's control and choose Properties.
  2. In Properties box, set EnableExport to True.
  3. Expand ViewSettings >> TimelineView.
  4. You can find these properties that can be used to customize exporting Timeline column's length:
      • QuarterExportColumnLength , to customize Timeline Quarter view column length.
      • MonthExportColumnLength, to customize Timeline Month view column length.
      • WeekExportColumnLength, to customize Timeline Week view column length.
      • DayHourlyExportColumnLength, to customize Timeline DayHourly view column length.
      • Day15MinutesExportColumnLength, to customize Timeline Day15Minutes view column length.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Timeline exporting customization}


How-to: Enable Export in Timeline

How-to: Enable Export in Timeline
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Several Enhancements in Timeline view > Exporting > How-to: Enable Export in Timeline

Glossary Item Box

WebScheduler provides additional feature that allows user to perform exporting in Timeline View. It also allows user to customize the exported Timeline column's length.

In this topic, you will learn how to enable export in Timeline and customize Timeline Export.

To enable Export in Timeline

  1. Right click on WebScheduler's control and choose Properties.
  2. In Properties box, set EnableExport to True.

To perform Timeline Export customization

  1. Right click on WebScheduler's control and choose Properties.
  2. In Properties box, set EnableExport to True.
  3. Expand ViewSettings >> TimelineView.
  4. You can find these properties that can be used to customize exporting Timeline column's length:
      • QuarterExportColumnLength , to customize Timeline Quarter view column length.
      • MonthExportColumnLength, to customize Timeline Month view column length.
      • WeekExportColumnLength, to customize Timeline Week view column length.
      • DayHourlyExportColumnLength, to customize Timeline DayHourly view column length.
      • Day15MinutesExportColumnLength, to customize Timeline Day15Minutes view column length.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Exporting}


New Quarter view in Timeline View mode

New Quarter view in Timeline View mode
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Several Enhancements in Timeline view > New Quarter view in Timeline View mode

Glossary Item Box

The new Quarter View adds the broad view selections in WebScheduler's Timeline View. It lets users see their schedule in quarter-to-quarter period - providing larger perspective of event in a quarter.

In This Section

How-to: Enable Quarter mode in Timeline view on load

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Customizable Timeline's date header}
{Full XHTML Support}
{Keep date header always visible in Timeline}
{Disabled Time}
{Client Paging}


How-to: Enable Quarter mode in Timeline view on load

How-to: Enable Quarter mode in Timeline view on load
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Several Enhancements in Timeline view > New Quarter view in Timeline View mode > How-to: Enable Quarter mode in Timeline view on load

Glossary Item Box

WebScheduler introduces a new Timeline view called Quarter view. This view will range from quarter to quarter.

In this topic, you will learn how to run Timeline Quarter view.

To run Timeline Quarter View

  1. Right click on WebScheduler's control and choose Properties.
  2. In Properties box, expand ViewSettings.
  3. Set SelectedTimelineViewMode to Quarter.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{New Quarter view in Timeline View mode}


Customizable Timeline's date header

Customizable Timeline's date header
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Several Enhancements in Timeline view > Customizable Timeline's date header

Glossary Item Box

WebScheduler 3 now introduces several different date header modes in Timeline view.

  1. DateNumber

  2. DayName

  3. ShortestDayName

  4. DateNumberAndDayName

  5. DateNumberAndShortestDayName

  6. DayNameAndDateNumber

  7. ShortestDayNameAndDateNumber

In This Section

How-to: Customize Timeline Header Mode

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Full XHTML Support}
{New Quarter view in Timeline View mode}
{Keep date header always visible in Timeline}
{Disabled Time}
{Client Paging}
{Customizable number of days in Agenda}
{Zoom-in and Zoom-out functions in Context Menu}
{Exporting}
{WebScheduler Database Wizard}


How-to: Customize Timeline Header Mode

How-to: Customize Timeline Header Mode
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Several Enhancements in Timeline view > Customizable Timeline's date header > How-to: Customize Timeline Header Mode

Glossary Item Box

WebScheduler adds a new feature called DateHeaderMode. This feature enables user to customize the da te format display in the header area based on your needs. Note that this feature is only supported in TimelineView.

Timeline View provides a new property called KeepHeaderVisible. When it is enabled, WebScheduler fixes the date header, enabling user to scroll all the way to the right while keeping the zooming button on their sight.

In this topic, you will learn how to customize Timeline Header Mode and set KeepHeaderVisible using WebScheduler's properties.

To customize Timeline Header Mode

  1. Right click on WebScheduler's control and choose Properties.
  2. In Properties box, expand ViewSettings >> TimelineView.
  3. Customize DateHeaderMode property. There are several new options for Timeline's date header:

    1. DateNumber

    2. DayName
    3. ShortestDayName
    4. DateNumberAndDayName
    5. DateNumberAndShortestDayName
    6. DayNameAndDateNumber
    7. ShortestDayNameAndDateNumber

To keep Timeline's date header visible

  1. Right click on WebScheduler's control and choose Properties.
  2. In Properties box, expand ViewSettings >> Timeline View.
  3. Set KeepHeaderVisible to True.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Customizable Timeline's date header}


Keep date header always visible in Timeline

Keep date header always visible in Timeline
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Several Enhancements in Timeline view > Keep date header always visible in Timeline

Glossary Item Box

Timeline View is a powerful feature for displaying multiple progressive events - keeping track on every schedule and meeting the deadline in time fashion way. With its zooming feature, user can easily zoom-in/out using the +/- sign next to the date header.

Due to the nature of Timeline data presentation, user will need to scroll horizontally to browse all events. When it's scrolled all the way to the right, the date header will be hidden - making it difficult for user to perform zoom-in/out.

WebScheduler resolves this usability issue by introducing a new property, ViewSettings >> TimelineView >> KeepHeaderVisible. When enabled, the date header position will be displayed in fixed position - enabling users to scroll all the way to the right while keeping the zooming button on their sight.

Keep date header visible in Timeline View mode

In This Section

How-to: Keep Timeline's date header visible

See Also

Tasks
Walkthrough Topics
{How-to Topics}

Other Resources
{Customizable Timeline's date header}
{Full XHTML Support}
{New Quarter view in Timeline View mode}
{Disabled Time}
{Client Paging}


How-to: Keep Timeline's date header visible

How-to: Keep Timeline's date header visible
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Several Enhancements in Timeline view > Keep date header always visible in Timeline > How-to: Keep Timeline's date header visible

Glossary Item Box

Timeline View provides a new property called KeepHeaderVisible. When it is enabled, WebScheduler fixes the date header, enabling user to scroll all the way to the right while keeping the zooming button on their sight.

In this topic, you will learn how to set KeepHeaderVisible from the properties.

To keep Timeline's date header visible

  1. Right click on WebScheduler's control and choose Properties.
  2. In Properties box, expand ViewSettings >> Timeline View.
  3. Set KeepHeaderVisible to True.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Keep date header always visible in Timeline}


Zoom-in and Zoom-out functions in Context Menu

Zoom-in and Zoom-out functions in Context Menu
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Several Enhancements in Timeline view > Zoom-in and Zoom-out functions in Context Menu

Glossary Item Box

Context-menu provides hassle-free access to the most basic features in WebScheduler. WebScheduler 3 is enhanced further to support Timeline's zooming feature. In addition to the default zooming buttons on the date header, user can now access the zooming functions through context-menu.

Zooming in and out via context-menu

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Customizable number of days in Agenda}
{Exporting}
{New Quarter view in Timeline View mode}
{Customizable Timeline's date header}


How-to: Customize Day Time Allocation in Timeline

How-to: Customize Day Time Allocation in Timeline
Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Several Enhancements in Timeline view > How-to: Customize Day Time Allocation in Timeline

Glossary Item Box

By default, the number of days displayed in Timeline - DayHourly view is one. For flexibility and support for advanced scenario customization, WebScheduler allows you to customize this setting.

This topic will show you how to customize Day Time Allocation in Timeline.

To customize Day Time Allocation in Timeline

  1. Right click on WebScheduler control and choose Properties.
  2. Expand ViewSettings. Set SelectedViewMode to Timeline and SelectedTimelineViewMode to DayHourly.
  3. Expand TimelineView and set NumberOfDays to 7. This property will be used in DayHourly view only.
  4. Run the project. In this case, the NumberOfDays property is set to 7 days.


How-to: Adjust Event layout

How-to: Adjust Event layout
Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Several Enhancements in Timeline view > How-to: Adjust Event layout

Glossary Item Box

One of the unique strengths in WebScheduler is its sophisticated management in the Event Layout, which handles the layouting automatically without any user interventions or additional coding. The event layout is based on MinimumEventHeight and TotalEventInCell properties.

Each event in the cell will have MinimumEventHeight value as its minimum height. When the total event in the cell exceed TotalEventInCell value, the row's height will be adjusted automatically to accommodate the exceeding events.

In this topic, you will learn how to customize minimum event height and total event displayed in cell.

To adjust event layout

  1. Right click on WebScheduler control and choose Properties.
  2. Expand ViewSettings. Set SelectedTimelineViewMode to Month and SelectedViewMode to Timeline.
  3. Expand TimelineView. Set MinimumEventHeight to 48 and TotalEventInCell to 3.
  4. Run the project.


Customizable number of days in Agenda

Customizable number of days in Agenda
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Customizable number of days in Agenda

Glossary Item Box

This new enhancement gives developer more control in Agenda view mode to set the number of days.

By default the number of days included in the Agenda view is 10. Events that occur within the date ranges will be displayed in text-based information. The number of days selected in Agenda view can be customized in ViewSettings >> AgendaView >> NumberOfDays property.

In This Section

How-to: Customize Agenda's Number of Days

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Zoom-in and Zoom-out functions in Context Menu}
{Exporting}
{Customizable Timeline's date header}
{Full XHTML Support}
{New Quarter view in Timeline View mode}
{Keep date header always visible in Timeline}
{Disabled Time}
{Client Paging}
{WebScheduler Database Wizard}


How-to: Customize Agenda's Number of Days

How-to: Customize Agenda's Number of Days
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Customizable number of days in Agenda > How-to: Customize Agenda's Number of Days

Glossary Item Box

WebScheduler provides customization in Agenda view to set the number of days.

In this topic, you will learn how to set number of days in Agenda view.

To customize Agenda's Number of Days

  1. Right click on WebScheduler's control and choose Properties.
  2. In Properties box, expand ViewSettings >> AgendaView.
  3. Set NumberOfDays to 5.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Customizable number of days in Agenda}


Customizable maximum height of all-day area

Customizable maximum height of all-day area
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Customizable maximum height of all-day area

Glossary Item Box

All-day events are displayed in all-day area. The height of all-day area is adjusted to the number of events in all-day area. If a lot of all-day event occurs in the active view, the all-day area will be enlarged to the show all events, often exceed the visible view port.

In current version, the all-day area has been restructured to have a maximum height. If the total number of events has exceeded the maximum height specified, vertical scrollbar will appear.

This configuration can be customized in LayoutSettings >> MaxAllDayEventAreaHeight property.

In This Section

How-to: Customize the maximum height of all-day-area

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
Customizable number of days in Agenda
{Full XHTML Support}
{Disabled Time}
{Client Paging}


How-to: Customize the maximum height of all-day area

How-to: Customize the maximum height of all-day area
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Customizable maximum height of all-day area > How-to: Customize the maximum height of all-day area

Glossary Item Box

WebScheduler now supports customization of maximum height of the all-day area. When the total events exceed the maximum height value, vertical scrollbar will be used.

In this topic, you will learn how to configure the maximum height of all-day area.

To customize the maximum height of all-day area

  1. Right click on WebScheduler's control and choose Properties..
  2. In Properties box, expand LayoutSettings.
  3. Set MaxAllDayEventAreaHeight to 150. You can customize the height based on your needs.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Customizable maximum height of all-day area}


Client-side function to retrieve cell element(s)

Client-side function to retrieve cell element(s)
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Client-side function to retrieve cell element(s)

Glossary Item Box

In scenarios where specific cell(s) need to be retrieved, specific client side functions are added to WebScheduler.

In This Section

Retrieve a cell element

Retrieve multiple cell elements

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Customizable maximum height of all-day area}
{Customizable number of days in Agenda}
{Full XHTML Support}
{Client Paging}
{Disabled Time}


Retrieve a cell element

Retrieve a cell element
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Client-side function to retrieve cell element(s) > Retrieve a cell element

Glossary Item Box

To retrieve a single cell element, use GetCellElement client-side function. Three parameters used in the function are:

  • date
    The date of the cell to be retrieved.

  • resourceId (optional)
    Specifies the resource id of the cell to be retrieved. This parameter is used in Split and Timeline view in particular. When specified, the cell of the specified row only will be retrieved.

  • getAllDayArea (optional)
    Determines whether hour area or all-day area should be retrieved. This parameter is used in Day, Week, and Split view only.

The following code will set red background color to 18th of March 2008 cell element. In Split and Timeline view, the cell of resourceId 2 will be set.

Javascript Copy Code
function GetCellElementByDate()
{
   var s = ISGetObject("WebScheduler1");
   var el = s.GetCellElement(new Date(2008, 2, 18, 9, 10, 10), 2, true);

   if (el != null)
      el.style.backgroundColor = "red";
}

The following code will set red background color to 18th of March 2008 06:00 AM cell element. In Split view and Timeline view, the cell of resourceId 2 will be set.

Javascript Copy Image Copy Code
function GetCellElementByDateTime()
{
   var s = ISGetObject("WebScheduler1");
   var el = s.GetCellElement(new Date(2008, 2, 18, 6, 0, 0), 2, false);

   if (el != null)
   {
      if (s.ViewSettings.SelectedViewMode == "Timeline")
         el.style.backgroundColor = "red";
      else
         el.children[0].style.backgroundColor = "red";
   }
}

In This Section

How-to: Retrieve a cell element using GetCellElement client-side API

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Retrieve multiple cell elements}


How-to: Retrieve a cell element using GetCellElement client-side API

How-to: Retrieve a cell element using GetCellElement client-side API
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Client-side function to retrieve cell element(s) > Retrieve a cell element > How-to: Retrieve a cell element using GetCellElement client-side API

Glossary Item Box

A new client side function has been added to WebScheduler in order to retrieve a cell element.

In this topic, you will learn how to retrieve a cell element.

To retrieve a cell element

The following code will set red background color to 18th of March 2008 cell element. In Split and Timeline view, the cell of resourceId 2 will be set.

Javascript Copy Code
function GetCellElementByDate()
{
   var s = ISGetObject("WebScheduler1");
   var el = s.GetCellElement(new Date(2008, 2, 18, 9, 10, 10), 2, true);
   if (el != null)
      el.style.backgroundColor = "red";
}

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Retrieve a cell element}


Retrieve multiple cell elements

Retrieve multiple cell elements
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Client-side function to retrieve cell element(s) > Retrieve multiple cell elements

Glossary Item Box

To retrieve multiple cell elements, you can use GetCellElements([WebSchedulerDateRange collection]) client-side function. You can specify multiple date range as WebSchedulerDateRange collection and GetCellElements will return the cell elements of the date range collection.

WebSchedulerDateRange has 4 properties:

  • StartTime
    Specifies the start time of the date range

  • EndTime
    Specifies the end time of the date range

  • ResourceID
    Specifies the resource id of the cell to be retrieved. This parameter is used in Split and Timeline view in particular. When specified, the cell of the specified row only will be retrieved.

  • DatePartType
    Specifies which part of the date should be used to retrieve the cell elements. The value options of this property are Date, DateTime, and Time.

When Date type is used, only the date part will be used to retrieve the cells. In Day, Week, and Split view, this indicates that all-day area cells will be retrieved. The following code will retrieve cell elements that start from 18th of March 2008 to 20th of March 2008. Although the start time and end time includes time part, only the date part will be used in the retrieving process.

Javascript Copy Image Copy Code
function GetCellElementsByDate()
{
   var s = ISGetObject("WebScheduler1");

   var arr = new ISArray();
   arr.Add(new WebSchedulerDateRange(new Date(2008, 2, 18, 6, 0, 0), new Date(2008, 2, 20, 7, 0, 0), 2, "Date"));

   var elements = s.GetCellElements(arr);
   SetBackgroundColor(elements);
}

When DateTime type is used, the date and time part will be used to retrieve the cells. In Day, Week, and Split view, this indicates that hour area cells will be retrieved. The following code will retrieve cell elements that start from 19th of March 2008 06:00 AM to 20th of March 2008 08:00 AM.

Javascript Copy Image Copy Code
function GetCellElementsByDateTime()
{
   var s = ISGetObject("WebScheduler1");

   var arr = new ISArray();
   arr.Add(new WebSchedulerDateRange(new Date(2008, 2, 19, 6, 0, 0), new Date(2008, 2, 20, 8, 0, 0), 2, "DateTime"));

   var elements = s.GetCellElements(arr);
   SetBackgroundColor(elements);
}

When Time type is used, only the time part will be used to retrieve the cells. In Day, Week, and Split view, cell elements of all dates in the active view within the date range will be retrieved. The following code will set the background color of cell elements that starts from 10:00 AM to 12: 00 PM, no matter what the date are. This is especially useful when you want to retrieve cells of specific time range regardless of its date.

Javascript Copy Image Copy Code
function GetCellElementsByTime()
{
   var s = ISGetObject("WebScheduler1");

   var arr = new ISArray();
   arr.Add(new WebSchedulerDateRange(new Date(2008, 2, 19, 10, 0, 0), new Date(2008, 2, 20, 12, 0, 0), 2, "Time"));

   var elements = s.GetCellElements(arr);
   SetBackgroundColor(elements);
}

In This Section

Timeline view

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Retrieve a cell element}


Timeline view

Timeline view
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Client-side function to retrieve cell element(s) > Retrieve multiple cell elements > Timeline view

Glossary Item Box

In Timeline view, DatePartType parameter will not be included in the cell retrieval process. The date range input will be adjusted to the active Timeline view mode. For example: when Week, Month, or Quarter mode in Timeline view is active, only the date part will be used to retrieve the cell elements.

Javascript Copy Image Copy Code
function GetCellElementsByTime()
{
   var s = ISGetObject("WebScheduler1");

   var arr = new ISArray();
   arr.Add(new WebSchedulerDateRange(new Date(2008, 2, 19, 10, 0, 0), new Date(2008, 2, 20, 12, 0, 0), 2));

   var elements = s.GetCellElements(arr);
   SetBackgroundColor(elements);
}

However, when DayHourly or Day15Minutes mode in Timeline view is active, the date and time part will be used to retrieve the cell elements.

In This Section

How-to: Retrieve cell elements using GetCellElements client-side API

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Retrieve multiple cell elements}
{Retrieve a cell element}


How-to: Retrieve cell elements using GetCellElements client-side API

How-to: Retrieve cell elements using GetCellElements client-side API
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Client-side function to retrieve cell element(s) > Retrieve multiple cell elements > Timeline view > How-to: Retrieve cell elements using GetCellElements client-side API

Glossary Item Box

A new client function has been added to WebScheduler in order to retrieve multiple cell elements.

In this topic, you will learn how to retrieve cell elements.

To retrieve cell elements

The following code will retrieve cell elements that start from 18th of March 2008 to 20th of March 2008. Although the start time and end time includes time part, only the date part will be used in the retrieving process.

Javascript Copy Image Copy Code
function GetCellElementsByDateTime()
{
   var s = ISGetObject("WebScheduler1");

   var arr = new ISArray();
   arr.Add(new WebSchedulerDateRange(new Date(2008, 2, 19, 6, 0, 0), new Date(2008, 2, 20, 8, 0, 0), 2, "DateTime"));

   var elements = s.GetCellElements(arr);
   SetBackgroundColor(elements);
}

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Timeline view}
{Retrieve multiple cell elements}


WebScheduler Database Wizard

WebScheduler Database Wizard
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > WebScheduler Database Wizard

Glossary Item Box

Stepping-up to version 3, WebScheduler introduces "WebScheduler Database Wizard", an automatic tool for WebScheduler's database creation. By simply specifying the SQL Server name and the database name, the wizard automatically generates the database. Next is to bind it to a WebScheduler instance in Visual Studio.

Right click on a WebScheduler instance and select "WebScheduler Database Wizard" option to use this embedded tool.

Follow the onscreen instruction and you'll get your database in no time.

Database name drop down list

When a successful connection to the designated SQL Server has been made, you specify a new database by typing the name on the textbox - or you can select one of the existing database from the drop down list. Press "Create" and all required tables for WebScheduler will be defined automatically.

"Get SQL Script" button

A more advanced option to obtain SQL script for the table definition is also provided. Developer can use the Get SQL Script button to obtain the complete SQL statements and apply it in their own database, for example a Microsoft Access database.

Below is a sample when developer clicks the "Get SQL Script" button

There are 2 options: "MS SQL Compatible" and "MS Access Compatible". User can choose the one that suits them best.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
Customizable Timeline's date header
{Customizable number of days in Agenda}
{Full XHTML Support}
{New Quarter view in Timeline View mode}
{Keep date header always visible in Timeline}
{Disabled Time}
Client Paging
{Zoom-in and Zoom-out functions in Context Menu}
{Exporting}


Theme and Style

Theme and Style
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Theme and Style

Glossary Item Box

In addition to existing default style modes, new themes are added to WebScheduler, Win7 and OliveGreen. When selected, Win7 theme will be applied to all elements of WebScheduler.

Windows 7 Default Style Mode

Win 7 Default Style in Week View

Olive Green Default Style in Month view

Editing Form Style

When data editing feature is enabled in WebScheduler, users are able to insert, update, and delete events, using callout or built-in editing form. In this version, WebScheduler introduces a new property, EditingFormStyle, which determines the styles applied to built-in editing form. Three style options for built-in editing form are: Standard style, Minimalist style, and Win7 style.

Standard editing form style

Minimalist editing form style

Win 7 editing form style

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Full XHTML Support}
{Customizable number of days in Agenda}
{Disabled Time}
{Client Paging}
{WebScheduler Database Wizard}


How-to: Apply Visual Themes

How-to: Apply Visual Themes
Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V3.0 > New Features > Theme and Style > How-to: Apply Visual Themes

Glossary Item Box

WebScheduler provides several default styles for visualizing themes. The new added themes are Win7 and OliveGreen.

This topic will show you how to apply Visual Themes.

To apply Visual Themes

  1. Right click on WebScheduler control and choose Properties.
  2. Set UseDefaultStyle to True and set DefaultStyleMode to Win7.
  3. Run the project. In this case, Win7 theme will be applied to all elements of WebScheduler.


V2.0

V2.0
Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0

Glossary Item Box

WebScheduler.NET extends its version 2.0 with new features and improvements to existing features. This section provides information about the key additions and modifications.

In This Section

New Features
Describes new technologies, such as Timeline view and extensibility.

Enhancements
Describes new enhancements on Calendar tooltip and etc.


New Features

New Features
Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features

Glossary Item Box

This section describes the new features and technologies added in WebScheduler V2.0. Here are the following list of new features supported by WebScheduler V2.0:

Timeline View

WebScheduler 2.0 comes with the new feature called Timeline view to allow users to view the event information in a unique way.

  • For more information, see Timeline View.

TrueSplitView™

WebScheduler introduces the latest innovative view called TrueSplitView™, so that end user can easily view the events based on the date range as the view name implies.

  • For more information, see TrueSplitView™.

Extensibility

WebScheduler 2.0 introduces a new extensibility support to take Scheduling functionalities to the enterprise level.

  • For more information, see Extensibility.

Exporting

WebScheduler is now able to perform exporting data to provide high end scheduler data presentation.

  • For more information, see Exporting.


Timeline View

Timeline View
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Timeline View

Glossary Item Box

Intersoft WebScheduler.NET® is a full-featured Scheduling and Calendaring component for ASP.NET that mixes the beauty of User Interface and rock-solid architecture, allowing you to extend the functionalities and behaviors to the way you need it in your business scenarios.

In this second generation, WebScheduler takes Scheduling functionality to the enterprise level by providing innovative Timeline View feature, which is required in most enterprise Web application such as ERP and CRM. The Timeline View feature is designed to allow users to view the event information in a unique way - where resources are listed in the rows and the time in the columns.

This mode enables users to easily look at the event information in a side-by-side manner, while easily compare it with other resources in the top-down manner.

See Also

Other Resources
Extensibility
TrueSplitView™
{Exporting}


User Interface

User Interface
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Timeline View > User Interface

Glossary Item Box

Timeline view has 4 types of view.

  1. Month view
    Month view enables user to have clearer and more readable information in a month by showing it on daily basis.

  2. Week view
    Week view enables user to see all events in a week on daily basis. There are two week views options, FirstDay and WeekNumber.

    In FirstDay option, all days in a month will be broken into 7 days instantly. The first week always starts from day 1 and each week will have 7 days, which means 28 days in total for 4 weeks. As for the remaining days, it will be included in the fifth week. For example: September 2008 has 30 days total. The first week starts from day 1 to day 7 and so on. In the end, there will be two days left, day 29 and day 30. These two days will be included in the fifth week.

  3. DayHourly
    In this view, user can see the details for all events in a day by hourly basis.

    The default NumberOfDays value is 1. You can also customize the total number of days via the NumberOfDays property to meet your requirement. Dayhourly is one of the most flexible views to work with in TimelineView™.

  4. Day15Minutes
    In this view, all events in a day are shown in 15 minutes duration. This is feature is important for user whose events are mostly under 1 hour.

Time view flexibility and customization based on user scenario

Targeting the enterprise business usage, TimelineView also offers various properties, so you can easily customize the look-and-feel and behaviors. This collection of properties is located under ViewSettings >> TimelineView.

For example in Timeline DayHourly, you only need to show the scheduler activity from 09.00 to 12.00 for 10 days. Simple set the StartTime to "t0900", EndTime to "t1200" and NumberOfDays to "10".

Tooltip information

Date and time information from ContentCell's will be provided with tooltip when user hovers on Timeline ContentCell.

See Also

Other Resources
Timeline View
{Styles}


Timeline Features

Timeline Features
Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Timeline View > Timeline Features

Glossary Item Box

This section contains all features available in Timeline View.

In This Section

Flexible customization in Timeline view

Sophisticated Event Layout

Moving and Resizing Event

Customizing the Resources Content

One-click View Switching


Flexible customization in Timeline view

Flexible customization in Timeline view
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Timeline View > Features > Flexible customization in Timeline view

Glossary Item Box

  • Flexible customization in Timeline view
    WebScheduler.NET® 2.0 is designed with strong customizability in mind, giving full flexibility for developers to customize the Timeline View's behaviors, look and feels, appearances and styles.

    Here is the list of properties that you can customize in order to achieve your unique Timeline view configuration: ContentCellWidth, EndTime, MinimumEventHeight, NumberOfDays, ResourceCellWidth, ResourceRowHeight, StartTime, and TotalEventInCell. You can find all of the properties in ViewSettings >> TimelineView.

    The above screen shot settings are using the following properties:
    ContentCellWidth = 100;
    StartTime = t0800;
    EndTime = t1200;
    MinimumEventHeight = 48;
    ResourceCellWidth = 100;
    ResourceRowHeight = 40;

In This Section

How-to: Customize ContentCellWidth

How-to: Customize MinimumEventHEight

How-to: Customize ResourceCellWidth

How-to: Customize ResourceRowHeight

See Also

Other Resources
{Sophisticated Event Layout}
{Moving and Resizing Event}
{Customizing the Resources Content}
{One-click View Switching}


How-to: Customize ContentCellWidth

How-to: Customize ContentCellWidth
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Timeline View > Features > Flexible customization in Timeline view > How-to: Customize ContentCellWidth

Glossary Item Box

WebScheduler gives you flexibility to customize ContentCellWidth.

In this topic, you will learn how to ContentCellWidth using WebScheduler's properties.

To customize ContentCellWidth

  1. Right click on WebScheduler's control and choose Properties.
  2. Expand ViewSettings >> TimelineView.
  3. By default, Timeline's ContentCellWidth is set to 100px. Now, try to set ContentCellWidth to 70px.
  4. Save and run the project.

See Also

Tasks
How-to: Customize MinimumEventHeight
{How-to: Customize ResourceCellWidth}
How-to: Customize ResourceRowHeight
{Walkthrough Topics}
{How-to Topics}

Concepts
{Flexible customization in Timeline view}


How-to: Customize MinimumEventHeight

How-to: Customize MinimumEventHeight
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Timeline View > Features > Flexible customization in Timeline view > How-to: Customize MinimumEventHeight

Glossary Item Box

WebScheduler gives you flexibility to customize MinimumEventHeight.

In this topic, you will learn how to customize MinimumEventHeight using WebScheduler's properties.

To customize MinimumEventHeight

  1. Right click on WebScheduler's control and choose Properties.
  2. Expand ViewSettings >> TimelineView.
  3. By default, Timeline's MinimumEventHeight is set to 24px. Now, try to set MinimumEventHeight to 20px.
  4. Save and run the project.

See Also

Tasks
{How-to: Customize ContentCellWidth}
{How-to: Customize ResourceCellWidth}
How-to: Customize ResourceRowHeight
{Walkthrough Topics}
{How-to Topics}

Concepts
{Flexible customization in Timeline view}


How-to: Customize ResourceCellWidth

How-to: Customize ResourceCellWidth
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Timeline View > Features > Flexible customization in Timeline view > How-to: Customize ResourceCellWidth

Glossary Item Box

WebScheduler gives you flexibility to customize ResourceCellWidth.

In this topic, you will learn how to customize ResourceCellWidth using WebScheduler's properties.

To customize ResourceCellWidth

  1. Right click on WebScheduler's control and choose Properties.
  2. Expand ViewSettings >> TimelineView.
  3. By default, Timeline's ResourceCellWidth is set to 100px. Now, try to set ResourceCellWidth to 200px.
  4. Save and run the project.

See Also

Tasks
{How-to: Customize ContentCellWidth}
{How-to: Customize MinimumEventHeight}
How-to: Customize ResourceRowHeight
{Walkthrough Topics}
{How-to Topics}

Concepts
{Flexible customization in Timeline view}


How-to: Customize ResourceRowHeight

How-to: Customize ResourceRowHeight
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Timeline View > Features > Flexible customization in Timeline view > How-to: Customize ResourceRowHeight

Glossary Item Box

WebScheduler gives you flexibility to customize ResourceRowHeight.

In this topic, you will learn how to customize ResourceRowHeight using WebScheduler's properties.

To customize ResourceRowHeight

  1. Right click on WebScheduler's control and choose Properties.
  2. Expand ViewSettings >> TimelineView.
  3. By default, Timeline's ResourceRowHeight is set to 40px. Now, try to set ResourceRowHeight to 60px.
  4. Save and run the project.

See Also

Tasks
{How-to: Customize ContentCellWidth}
{How-to: Customize MinimumEventHeight}
{How-to: Customize ResourceCellWidth}
{Walkthrough Topics}
{How-to Topics}

Concepts
{Flexible customization in Timeline view}


Sophisticated Event Layout

Sophisticated Event Layout
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Timeline View > Features > Sophisticated Event Layout

Glossary Item Box

A Timeline Cell has capability to show several event(s) in it. The maximum events that will be shown in the cell are based on TotalEventInCell property (Default value is 5). There are many scenarios in Timeline View where the number of events can be various based on the application's usage.

One of the unique strengths in Intersoft WebScheduler 2.0 is its sophisticated management in the Event Layout, which handles the layouting automatically without any user interventions or additional coding. The Event Layout is based on MinimumEventHeight and TotalEventInCell property. Each event in the cell will have MinimumEventHeight as the minimum height, when the events in the cell are more than TotalEventInCell, the cell will then automatically adjust to accommodate the exceeding events.

To get a big picture on the Event Layout management in WebScheduler 2.0, please take a look at the following illustration.

In This Section

How-to: Customize TotalEventInCell

See Also

Other Resources
{Flexible customization in Timeline view}
{Moving and Resizing Event}
{Customizing the Resources Content}
{One-click View Switching}


How-to: Customize TotalEventInCell

How-to: Customize TotalEventInCell
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Timeline View > Features > Sophisticated Event Layout > How-to: Customize TotalEventInCell

Glossary Item Box

WebScheduler creates a new feature, which is a sophisticated event layout. The Event Layout is based on MinimumEventHeight property and TotalEventInCell property. Each event in the cell will have MinimumEventHeight as its minimum height. When the total events in the cell exceed TotalEventInCell, it will be adjusted automatically to accommodate the exceeding events.

In this topic, you will learn how to customize TotalEventInCell using WebScheduler's properties.

To customize TotalEventInCell

  1. Right click on WebScheduler's control and choose Properties.
  2. Expand ViewSettings >> TimelineView.
  3. Set TotalEventInCell to 2 and MinimumHeight to 48px.
  4. Save and run the project.
  5. The screenshot below shows there are 2 total events in a cell.

  6. The screenshow below shows the total events in a cell are 3 total events in a cell. It exceeds the TotalEventInCell that has been set to 2. Therefore, the MinimumHeight will be adjusted automatically to accommodate the exceeding events.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Concepts
{Sophisticated Event Layout}


Moving and Resizing Event

Moving and Resizing Event
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Timeline View > Features > Moving and Resizing Event

Glossary Item Box

As the other views in WebScheduler support moving and resizing event by using drag-drop, so does Timeline View as one of WebScheduler views. In order to be able to do moving and resize event, you should enable AllowMove and AllowResize property in DataEditing.

You can perform the moving and resizing events in the following scenarios:

  • Moving event from 1 cell to other cell on the same resource.
  • Moving event from 1 cell to other cell on the different resource.
  • Resize event to the left on the same resource.
  • Resize event to the right on the same resource.

Thanks to the revolutionary RealTimeOperation™ technology in WebScheduler, the updating process in Timeline View is as fast as one tick of second, by taking advantage of the high performance and state-of-the-art rendering architecture. For more information about this feature, please read RealTimeOperation™ concept.

In This Section

How-to: AllowAdd in WebScheduler

How-to: AllowEdit in WebScheduler

How-to: AllowDelete in WebScheduler

How-to: Move and Resize event in Timeline

See Also

Other Resources
{Flexible customization in Timeline view}
{Sophisticated Event Layout}
{Customizing the Resources Content}
{One-click View Switching}


How-to: AllowAdd in WebScheduler

How-to: AllowAdd in WebScheduler
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Timeline View > Features > Moving and Resizing Event > How-to: AllowAdd in WebScheduler

Glossary Item Box

AllowAdd property is used to add an event in WebScheduler.

In this topic, you will learn how to set AllowAdd from WebScheduler's properties.

To set AllowAdd

  1. Right click on WebScheduler's control and choose Properties.
  2. Expand DataEditing property.
  3. Set AllowAdd to Yes.

See Also

Tasks
{How-to: AllowEdit in WebScheduler}
{How-to: AllowDelete in WebScheduler}
{How-to: AllowMove in WebScheduler}
{How-to: AllowResize in WebScheduler}
{How-to: Move and Resize event in Timeline view}
{Walkthrough Topics}
{How-to Topics}

Concepts
{Editing}


How-to: AllowEdit in WebScheduler

How-to: AllowEdit in WebScheduler
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Timeline View > Features > Moving and Resizing Event > How-to: AllowEdit in WebScheduler

Glossary Item Box

AllowEdit property is used to edit an event in WebScheduler.

In this topic, you will learn how to set AllowEdit from WebScheduler's properties.

To set AllowEdit

  1. Right click on WebScheduler's control and choose Properties.
  2. Expand DataEditing property.
  3. Set AllowEdit to Yes.

See Also

Tasks
{How-to: AllowAdd in WebScheduler}
{How-to: AllowDelete in WebScheduler}
{How-to: AllowMove in WebScheduler}
{How-to: AllowResize in WebScheduler}
{How-to: Move and Resize event in Timeline view}
{Walkthrough Topics}
{How-to Topics}

Concepts
{Editing}


How-to: AllowDelete in WebScheduler

How-to: AllowDelete in WebScheduler
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Timeline View > Features > Moving and Resizing Event > How-to: AllowDelete in WebScheduler

Glossary Item Box

AllowDelete property is used to delete an event in WebScheduler.

In this topic, you will learn how to set AllowDelete from WebScheduler's properties.

To set AllowDelete

  1. Right click on WebScheduler's control and choose Properties.
  2. Expand DataEditing property.
  3. Set AllowDelete to Yes.

See Also

Tasks
{How-to: AllowEdit in WebScheduler}
{How-to: AllowAdd in WebScheduler}
{How-to: AllowMove in WebScheduler}
{How-to: AllowResize in WebScheduler}
{How-to: Move and Resize event in Timeline view}
{Walkthrough Topics}
{How-to Topics}

Concepts
{Editing}


How-to: Move and Resize event in Timeline view

How-to: Move and Resize event in Timeline view
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Timeline View > Features > Moving and Resizing Event > How-to: Move and Resize event in Timeline view

Glossary Item Box

WebScheduler allows user to move and resize event in Timeline view.

In this topic, you will learn how to set AllowMove and AllowResize from WebScheduler's properties.

To set AllowMove

  1. Right click on WebScheduler's control and choose Properties.
  2. Expand DataEditing property.
  3. Set AllowMove to Yes and AllowResize to Yes.

See Also

Tasks
{How-to: AllowAdd in WebScheduler}
{How-to: AllowEdit in WebScheduler}
{How-to: AllowDelete in WebScheduler}


Customizing the Resources Content

Customizing the Resources Content
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Timeline View > Features > Customizing the Resources Content

Glossary Item Box

By default, the Timeline View will list the resources at the most left side, which show each resource by its specified ResourceName field. However, developers often require customization on the resource content to adapt their business requirements, for instance showing a multiple columns table in the resource list, instead of a simple ResourceName list.

WebScheduler.NET™ 2.0 provides an elegant way for developers to customize the resources content. Developers can create their own template and assign it to WebScheduler via ResourceContentTemplate property. Simply set ResourceContentMode to Custom value and assign your own template design to achieve your own look and feel.

The following screenshot shows WebScheduler in Timeline View mode. Notice the Resources description is using a two-column table, instead of the default simple text.

In This Section

How-to: Customize Resources Content using ResourceContentTemplate

See Also

Other Resources
{Flexible customization in Timeline view}
{Sophisticated Event Layout}
{Moving and Resizing Event}
{One-click View Switching}


How-to: Customize Resources Content using ResourceContentTemplate

How-to: Customize Resources Content using ResourceContentTemplate
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Timeline View > Features > Customizing the Resources Content > How-to: Customize Resources Content using ResourceContentTemplate

Glossary Item Box

WebScheduler allows user to customize resources content.

In this topic, you will learn how to configure resources content using ResourceContentTemplate.

To customize resources content

  1. Right click on WebScheduler's control and choose Properties.
  2. Set ResourcesContentMode to Custom.
  3. You will find <ResourcesContentTemplate> tag in the source code. You can freely customize the content template according to your needs. The sample below is using two ASP.NET Label controls to be added into the content template:
    <ResourcesContentTemplate>
   <table cellpadding="0" cellspacing="0" style="padding:2 2 2 2; width: 100%; height: 100%; font-family:Segoe UI; font-size:8pt;">
      <tr>
         <td style=" border-right:solid 1px #9199a4; width:50%;">
              <asp:Label ID="Label1" runat="server" Text="Resource Name"></asp:Label>
         </td>
         <td>
              <asp:Label ID="Label2" runat="server" Text="Location"></asp:Label>
         </td>
      </tr>
   </table>
</ResourcesContentTemplate>

See Also

Tasks
Walkthrough Topics
{How-to Topics}

Concepts
{Customizing the Resources Content}


One-click View Switching

One-click View Switching
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Timeline View > Features > One-click View Switching

Glossary Item Box

Users often need to be able to see different view using the same data. In order to accommodate this requirement, WebScheduler implements "click to switch" feature for the Timeline. By simply clicking on the Timeline's Date header, users can conveniently switch among all of Timeline view.

To support more complex and advanced scenarios, TimelineView is equipped with Timline Quarter capability which enables users to view all event information per quarterly basis. Simply click on the "ZoomOut" icon from Timeline Month view to switch to Timeline Quarter View.

This feature is enabled by default. You can set EnableNavigateToOtherView to False to disable this feature.

See Also

Other Resources
{Flexible customization in Timeline view}
{Sophisticated Event Layout}
{Moving and Resizing Event}
{Customizing the Resources Content}


Styles

Styles
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Timeline View > Styles

Glossary Item Box

As a family member of WebUI Studio.NET®, WebScheduler is consistent in its rich and strong customizable nature. The following is the list of styles that you can customize in Timeline view.

  • TimelineContentCellStyle.
  • TimelineDateCellStyle
  • TimelineResourceCellStyle
  • TimelineResourceHeaderTextCellStyle
  • TimelineTimeCellStyle

Please refer to the following illustration for a better picture on the correlation between UI elements and styles.

See Also

Other Resources
{Overview}
{User Interface}


How-to: Enable Timeline View

How-to: Enable Timeline View
Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Timeline View > How-to: Enable Timeline View

Glossary Item Box

The Timeline View feature is designed to allow users to view the event information in a unique way - where resources are listed in the rows and the time in the columns.

This topic will show you how to enable Timeline View.

Enable Timeline View in Week Mode

  1. Right click on WebScheduler control and choose Properties.
  2. Expand ViewSettings. Set SelectedTimelineViewMode to Week and SelectedViewMode to Timeline.
  3. Expand TimelineView and set Enabled to True.
  4. Run the project.

Enable Timeline View in Quarter Mode

  1. Right click on WebScheduler control and choose Properties.
  2. Expand ViewSettings. Set SelectedTimelineViewMode to Quarter and SelectedViewMode to Timeline.
  3. Expand TimelineView and set Enabled to True.
  4. Run the project.

Enable Timeline View in Month Mode

  1. Right click on WebScheduler control and choose Properties.
  2. Expand ViewSettings. Set SelectedTimelineViewMode to Month and SelectedViewMode to Timeline.
  3. Expand TimelineView and set Enabled to True.
  4. Run the project.

Enable Timeline View in Day Hourly Mode

  1. Right click on WebScheduler control and choose Properties.
  2. Expand ViewSettings. Set SelectedTimelineViewMode to DayHourly and SelectedViewMode to Timeline.
  3. Expand TimelineView and set Enabled to True.
  4. Run the project.

Enable Timeline View in Day15Minutes Mode

  1. Right click on WebScheduler control and choose Properties.
  2. Expand ViewSettings. Set SelectedTimelineViewMode to Day15Minutes and SelectedViewMode to Timeline.
  3. Expand TimelineView and set Enabled to True.
  4. Run the project.


TrueSplitView™

TrueSplitView™
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > TrueSplitView™

Glossary Item Box

Back in the initial version of WebScheduler.NET, we introduced the innovative 6 views: Day, Week, Month, Quarter, Year, and Agenda view. End user can easily view the events based on the date range as the view name implies. And in the 2.0 version of WebScheduler.NET, we once again introduce you to the latest view, TrueSplitView™, to complement the existing 6 views.

In This Section

Concept

User Interface and Styles

Features

See Also

Other Resources
{Timeline View}
{Extensibility}
{Exporting}


Concept

Concept
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > TrueSplitView™ > Concept

Glossary Item Box

The previous behavior is that end user can only view the events grouped by date of the selected view. In TrueSplitView™, mode, the event information is grouped by resources. In the current 2.0 version, only Day View mode is supported in TrueSplitView™. As one of the key innovative features in WebScheduler.NET, we will constantly enhance this feature with more views and functionalities to support greater and more advanced enterprise scenarios.

To add TrueSplitView option in context menu and header menu, simply set the IncludeSplitViewInMenu property to True.

When this property is enabled, users can easily switch between normal view and split view using the context menu or header menu.

To enable split view on load, simply set EnableSplitViewInitially property to True. Note that when this property is enabled, TrueSplitView™, will be enabled initially.

See Also

Other Resources
Overview
{User Interface and Styles}
{Features}


User Interface and Styles

User Interface and Styles
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > TrueSplitView™ > User Interface and Styles

Glossary Item Box

The content area is divided according to the total number of resources. By taking the resources color as the base color for resources column coloring, By taking resources color as the base color and diverse it as the coloring for the resources column and the element inside, WebScheduler.NET is not-only a superior performer, but also chic and beautiful in style. There are indeed many properties to control the Day Style, but when in TrueSplitView™ mode, you have full control over all styling, but not for the coloring.

Thanks to state-of-the-art rendering, when user uncheck a resource in the resources table, the unchecked resource column will be hidden and the layout will automatically adjust to the new total visible resources. And when user checks on a resource, the checked resources column will be visible and the layout will be resized automatically to hold the total visible resources.

See Also

Other Resources
Overview
{Concept}
{Features}


Features

Features
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > TrueSplitView™ > Features

Glossary Item Box

Powered by rock-solid drag-and-drop framework, you can easily drag and drop an event to the other resources columns easily without any breakings. Just drag an event, drop on the other resources column and the resource of the event will be changed automatically according to the resources of the drop column. To modify the other event information, simply use the elegant built-in editing form and modify the information as modifying an event in any time-based views. One thing that you should note is that all day event cannot be resized or dragged-and-dropped.

The innovative TrueSplitView™ works flawlessly with the existing advanced features, such as built-in Editing Form, RealTimeOperation™, navigation, and many more.

See Also

Other Resources
Overview
{Concept}
{User Interface and Styles}


How-to: Initially enable TrueSplitView

How-to: Initially enable TrueSplitView
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > TrueSplitView™ > How-to: Initially enable TrueSplitView

Glossary Item Box

TrueSplitView is one of the new features in WebScheduler 2.0. TrueSplitView enables user to view the event information grouped by resources. This feature exists when Day view is selected as WebScheduler's SelectedViewMode.

In this topic, you will learn how to initially enable TrueSplitView using WebScheduler's properties.

To initially enable TrueSplitView

  1. Right click on WebScheduler's control and choose Properties.
  2. Set EnableSplitViewInitially to True.

Please note that if EnableSplitViewInitially is True and IncludeSplitViewInMenu is False then user can only view TrueSplitView.

See Also

Tasks
{How-to: Include TrueSplitView in WebScheduler}
{Walkthrough Topics}
{How-to Topics}

Concepts
{TrueSplitView™}


How-to: Include TrueSplitView in WebScheduler

How-to: Include TrueSplitView in WebScheduler
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > TrueSplitView™ > How-to: Include TrueSplitView in WebScheduler

Glossary Item Box

TrueSplitView is one of the new features in WebScheduler 2.0. TrueSplitView enables user to view the event information grouped by resources. This feature exists when Day view is selected as WebScheduler's SelectedViewMode.

In this topic, you will learn how to include TrueSplitView in WebScheduler using WebScheduler's properties.

To include TrueSplitView in WebScheduler

  1. Right click on WebScheduler's control and choose Properties.
  2. Set IncludeSplitViewInMenu to True. This setting will enable user to use context menu or header menu to switch between normal view and TrueSplitView.

See Also

Tasks
{How-to: Initially enable TrueSplitViewnable TrueSplitView}
{Walkthrough Topics}
{How-to Topics}

Concepts
{TrueSplitView™}


Extensibility

Extensibility
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Extensibility

Glossary Item Box

WebScheduler.NET provides built-in editing form and editing processes such as add, edit and delete are done automatically without additional codes or efforts. However, in the previous version of WebScheduler.NET, developers are unable to bind custom fields to the objects in WebScheduler.NET.

WebScheduler.NET™ 2.0 is designed specifically to address this issue by introducing an elegant approach and concept toward extensibility. With comprehensive extensibility support, WebScheduler.NET 2.0 takes Scheduling functionalities to the enterprise level where developers can add as much fields as they require while still be able to reuse existing assets such as built-in editing form.

This whitepaper discusses the Extensibility concept of WebScheduler 2.0 in details.

See Also

Other Resources
Timeline View
{TrueSplitView™}
{Exporting}


Concept

Concept
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Extensibility > Concept

Glossary Item Box

WebScheduler is designed with full Object-Oriented (OO) approach. Some of main objects that heavily utilized in WebScheduler are WebSchedulerEvent, WebSchedulerRecurringEvent, WebSchedulerResource, and WebSchedulerCategory. For instance, WebSchedulerEvent represents an event that displayed in the WebScheduler view.

These primary objects are now extensible in WebScheduler 2.0 by using elegant inheritance (OOP) approach, allowing developers to add as many custom properties/fields as their business scenarios require. However, when using built-in editing form, Resource and Category custom fields cannot be reflected to the related controls, although the custom fields are populated in the object.

The extended class must be inherited from one of the above objects. Custom fields can then be added in the extended class. The custom properties should have XmlSerializable and BinarySerializable attributes. Note that the custom field's property has to be the same name as the custom field's name in the physical database.

The following C# sample codes demonstrate a new event class named EOEvents, which is derived from WebSchedulerEvent class.

C# Copy Code
public class EOEvents : WebSchedulerEvent
{
   private string _notes = "";
   private int _totalAttendees = -1;

   [XmlSerializable(), BinarySerializable()]
   public string Notes
   {
      get { return this._notes; }
      set { this._notes = value; }
   }

   [XmlSerializable(), BinarySerializable()]
   public int TotalAttendees
   {
      get { return this._totalAttendees; }
      set { this._totalAttendees = value; }
   }
}

The extended class must be specified as the extended type name. There are four types of extended type name, which are ExendedEventTypeName, ExtendedRecurringEventTypeName, ExtendedResourceTypeName, and ExtendedCategoryTypeName.

The data of the custom field need to be bound in the DataBound server side event of WebScheduler instance. The e argument consisted of two child arguments: Type and DataObject. The type argument indicates the type of object while the DataObject argument is the extended object (in object type). To access the extended object's properties, DataObject argument has to be casted to the related extended class.

The following C# codes show how developer can handle the databinding of custom properties in DataBound event.

C# Copy Code

protected void WebScheduler1_DataBound(object sender, ISNet.WebUI.WebScheduler.WebSchedulerDataBoundDataArgs e)

    {

        switch (e.Type)

        {

            case WebSchedulerObjectType.Event:

                EOEvent evt = e.DataObject as EOEvent;

                evt.Notes = e.DataRow["Notes"].ToString();

                if (e.DataRow["TotalAttendees"] != System.DBNull.Value)

                    evt.TotalAttendees = int.Parse(e.DataRow["TotalAttendees"].ToString());

                break;

            case WebSchedulerObjectType.RecurringEvent:

                EORecurringEvent recurringEvent = e.DataObject as EORecurringEvent;

                recurringEvent.Notes = e.DataRow["Notes"].ToString();

                if (e.DataRow["TotalAttendees"] != System.DBNull.Value)

                    recurringEvent.TotalAttendees = int.Parse(e.DataRow["TotalAttendees"].ToString());

                break;

        }

    }

In runtime, the extended class will be serialized to the client side. In order to be recognized, the extended class has to be initialized in client side.

Javascript Copy Code

<script type="text/javascript">

function EOEvent()

{

      // required codes

WebSchedulerEvent.call(this);

      this._Type = "EOEvent";

      // custom properties start here

      this.Notes = "";

      this.TotalAttendees = 0;

}

function EORecurringEvent()

{

      // required codes

WebSchedulerRecurringEvent.call(this);

      this._Type = "EORecurringEvent";

      // custom properties start here

      this.Notes = "";

      this.TotalAttendees = 0;

}

</script>

To indicate that the class is inherited from WebScheduler object, use the following code format: [WebScheduler base object].call(this);this._Type = "[extended class name]". For example: the above code describes that EOEvent class is inherited from WebSchedulerEvent class and EORecurringEvent class is inherited from WebSchedulerRecurringEvent class.

You can then modify the editing form and add controls for the extended fields.Before saving the changes, the values of extended fields need to be saved to the OriginalObject and MasterObject (for RecurringEvent object). It's recommended to implement OnBeforeAdd and OnBeforeEdit client side events for this purpose. For example:

Javascript Copy Code

function WebScheduler1_OnBeforeAdd(controlId, evt)

{

      var s = ISGetObject(controlId);

      SetFields(s, evt.Parent);

      return true;

}

function WebScheduler1_OnBeforeEdit(controlId, evt)

{

var s = ISGetObject(controlId);

      SetFields(s, evt.Parent);

      return true;

}

function SetFields(s, eventView)

{

var editWindow = s.GetEditingFormWindow();

      var notes = "";

      var totalAttendees = 0;

      if (editWindow != null)

      {

            notes = editWindow.ISGetObject("wiNotes").GetValueData();

            totalAttendees = editWindow.ISGetObject("wiTotalAttendees").GetValueData();

      }

eventView.SetProperty("Notes", notes);

eventView.SetProperty("TotalAttendees", totalAttendees);

}

So, now custom fields can be added to WebScheduler and the changes can be saved to physical database. This extensibility feature makes it possible to implement custom scheduling functionality with more advanced scenarios using WebScheduler.NET.

See Also

Other Resources
Extensibility Overview


Walkthrough: Adding custom fields in WebScheduler using Extensibility feature

Walkthrough: Adding custom fields in WebScheduler using Extensibility feature
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Extensibility > Walkthrough: Adding custom fields in WebScheduler using Extensibility feature

Glossary Item Box

This walkthrough shows how to add custom fields in WebScheduler using Extensibility feature.

During this walkthrough, you will learn how to do the following:

  • Bind WebScheduler.NET using ISDataSource.NET
  • Add custom fields using Extensibility feature
  • Enable editing in WebScheduler.NET
  • Modify EditingForm_Extended.aspx
  • Enable editing for custom fields

Prerequisites

In order to complete this walkthrough, you will need to do the following:

  • Access to the Microsoft Access WebScheduler_EventOrganizer.mdb.
  • Visual Studio 2005 application.
  • WebUI Studio.NET 2008 R2

Step-By-Step Instructions

To add custom fields in WebScheduler using Extensibility feature

Bind WebScheduler.NET using ISDataSource.NET

  1. Create WebScheduler_EventOrganizer.mdb (access database).
  2. Here are the tables that should exist in the database.

    Categories
    FieldName | DataType
    CategoryID | AutoNumber
    CategoryName | Text
    CategoryDescription | Text
    CategoryColor | Text

    Resources
    FieldName | DataType
    IResourceD | AutoNumber
    ResourceName | Text
    ResourceDescription | Text
    ResourceColor | Text

    Events
    FieldName | DataType
    EventID | AutoNumber
    CategoryID | Text
    ResourceID | Number
    Mode | Number
    ClientName | Text
    EventDescription | Text
    AllDayEvent | Yes/No
    StartTime | Date/Time
    EndTime | Date/Time
    ReminderTimeSpan | Number
    Location | Text
    Notes | Text
    TotalAttendees | Number
    Note: The highlighted columns (Notes and TotalAttendees) are custom fields.

    RecurrenceEvents
    FieldName | DataType
    EventID | AutoNumber
    RecurrenceID | Number
    CategoryID | Text
    ResourceID | Number
    ParentID | Number
    Mode | Number
    ClientName | Text
    EventDescription | Text
    AllDayEvent | Yes/No
    StartTime | Date/Time
    EndTime | Date/Time
    ExceptionDate | Date/Time
    ExceptionInfo | Number
    ReminderTimeSpan | Number
    Location | Text
    Notes | Text
    TotalAttendees | Number
    Note: The highlighted columns (Notes and TotalAttendees) are custom fields.

    RecurrenceInfo
    FieldName | DataType
    RecurrenceID | AutoNumber
    Mode | Number
    RangeMode | Number
    StartDate | Date/Time
    EndDate | Date/Time
    TotalRecurrences | Number
    NDay | Number
    NWeek | Number
    NMonth | Number
    NYear | Number
    WeekDays | Text

  3. Launch Visual Studio.NET 2005.
  4. Click on File menu, then select New and click Web Site.
  5. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  6. Named the Web Site and click OK.
  7. Right-click on Project's name and select Add New Item.
  8. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  9. Drag and drop WebScheduler instance from toolbar to WebForm.
  10. Drag and drop ISDataSource instance from toolbar to WebForm.
  11. In the Solution Explorer, right-click on App_Data and select Add Existing Item.
  12. Browse and add WebScheduler_EventOrganizer.mdb (the database that you have created).
  13. In the Solution Explorer, right-click on App_Code and select Add New Item.
  14. Add a Dataset and named itWebScheduler_EventOrganizer.xsd.
  15. Drag and drop the tables from server explorer to the dataset then save the dataset.

  16. In the Solution Explorer, right-click on App_Code and select Add New Item.
  17. Add a new class and named it WebScheduler_EventOrganizer.cs.
  18. Add the following code to the WebScheduler_EventOrganizer.cs.

    C# Copy Code
    namespace EventOrganizerTableAdapters
{
   public partial class ResourcesTableAdapter : global::System.ComponentModel.Component
   {
      [global::System.Diagnostics.DebuggerNonUserCodeAttribute()]
      [global::System.ComponentModel.Design.HelpKeywordAttribute("vs.data.TableAdapter")]
      [global::System.ComponentModel.DataObjectMethodAttribute(global::System.ComponentModel.DataObjectMethodType.Insert, true)]
      public virtual int Insert(int ResourceID, string ResourceName, string ResourceDescription, string ResourceColor)
      {
         this.Connection.Open();
         try
         {
            this.Insert(ResourceName, ResourceDescription, ResourceColor);
            OleDbCommand command = new OleDbCommand();
            command.CommandText = "SELECT @@IDENTITY";
            command.Connection = this.Connection;
            return (int)command.ExecuteScalar();
         }
         finally
         {
            this.Connection.Close();
         }
   }
}
   public partial class CategoriesTableAdapter : global::System.ComponentModel.Component
   {
      [global::System.Diagnostics.DebuggerNonUserCodeAttribute()]
      [global::System.ComponentModel.Design.HelpKeywordAttribute("vs.data.TableAdapter")]
      [global::System.ComponentModel.DataObjectMethodAttribute(global::System.ComponentModel.DataObjectMethodType.Insert, true)]
      public virtual int Insert(int CategoryID, string CategoryName, string CategoryDescription, string CategoryColor)
      {
         this.Connection.Open();
         try
         {
            this.Insert(CategoryName, CategoryDescription, CategoryColor);
            OleDbCommand command = new OleDbCommand();
            command.CommandText = "SELECT @@IDENTITY";
            command.Connection = this.Connection;
            return (int)command.ExecuteScalar();
         }
         finally
         {
            this.Connection.Close();
         }
      }
   }
   public partial class RecurrenceInfoTableAdapter : global::System.ComponentModel.Component
   {
      [global::System.Diagnostics.DebuggerNonUserCodeAttribute()]
      [global::System.ComponentModel.Design.HelpKeywordAttribute("vs.data.TableAdapter")]
      [global::System.ComponentModel.DataObjectMethodAttribute(global::System.ComponentModel.DataObjectMethodType.Insert, true)]
      public virtual int Insert(int RecurrenceID, global::System.Nullable Mode, global::System.Nullable RangeMode,
      global::System.Nullable StartDate, global::System.Nullable EndDate,
      global::System.Nullable TotalRecurrences, global::System.Nullable NDay, global::System.Nullable NWeek,
      global::System.Nullable NMonth, global::System.Nullable NYear, string WeekDays)
      {
         this.Connection.Open();
         try
         {
            this.Insert(Mode, RangeMode, StartDate, EndDate, TotalRecurrences, NDay, NWeek, NMonth, NYear, WeekDays);
            OleDbCommand command = new OleDbCommand();
            command.CommandText = "SELECT @@IDENTITY";
            command.Connection = this.Connection;
            return (int)command.ExecuteScalar();
         }
         finally
         {
            this.Connection.Close();
         }
      }
   }
   public partial class RecurringEventsTableAdapter : global::System.ComponentModel.Component
   {
      [global::System.Diagnostics.DebuggerNonUserCodeAttribute()]
      [global::System.ComponentModel.Design.HelpKeywordAttribute("vs.data.TableAdapter")]
      [global::System.ComponentModel.DataObjectMethodAttribute(global::System.ComponentModel.DataObjectMethodType.Insert, true)]
      public virtual int Insert(int EventID, global::System.Nullable RecurrenceID, string CategoryID,
      global::System.Nullable ResourceID, global::System.Nullable ParentID, global::System.Nullable Mode,
      string ClientName, string EventDescription, bool AllDayEvent, global::System.Nullable StartTime,
      global::System.Nullable EndTime, global::System.Nullable ExceptionDate,
      global::System.Nullable ExceptionInfo, global::System.Nullable ReminderTimeSpan, string Location, string Notes, global::System.Nullable TotalAttendees)
      {
         this.Connection.Open();
         try
         {
            this.Insert(RecurrenceID, CategoryID, ResourceID, ParentID, Mode, ClientName, EventDescription,
AllDayEvent, StartTime, EndTime, ExceptionDate, ExceptionInfo, ReminderTimeSpan, Location, Notes, TotalAttendees);
            OleDbCommand command = new OleDbCommand();
            command.CommandText = "SELECT @@IDENTITY";
            command.Connection = this.Connection;
            return (int)command.ExecuteScalar();
         }
         finally
         {
            this.Connection.Close();
         }
      }
   }
   public partial class EventsTableAdapter : global::System.ComponentModel.Component
   {
      [global::System.Diagnostics.DebuggerNonUserCodeAttribute()]
      [global::System.ComponentModel.Design.HelpKeywordAttribute("vs.data.TableAdapter")]
      [global::System.ComponentModel.DataObjectMethodAttribute(global::System.ComponentModel.DataObjectMethodType.Insert, true)]
      public virtual int Insert(int EventID, string CategoryID, global::System.Nullable ResourceID,
      global::System.Nullable Mode, string ClientName, string EventDescription, bool AllDayEvent,
      global::System.Nullable StartTime, global::System.Nullable EndTime,
      global::System.Nullable ReminderTimeSpan, string Location, string Notes, global::System.Nullable TotalAttendees)
      {
         this.Connection.Open();
         try
         {
            this.Insert(CategoryID, ResourceID, Mode, ClientName, EventDescription, AllDayEvent, StartTime, EndTime, ReminderTimeSpan, Location, Notes, TotalAttendees);
            OleDbCommand command = new OleDbCommand();
            command.CommandText = "SELECT @@IDENTITY";
            command.Connection = this.Connection;
            return (int)command.ExecuteScalar();
         }
         finally
         {
            this.Connection.Close();
         }
      }
   }
}

The custom fields are added to the architecture and UI of WebScheduler. You can try to run the page and add/edit the custom fields' value. The process will be updated to physical database.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Concepts
{Extensibility}


Exporting

Exporting
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Exporting

Glossary Item Box

WebScheduler exporting is an extensible feature of WebScheduler.NET 2.0. The exporting feature complements WebScheduler.NET as a very powerful web scheduling component from Intersoft Solutions. Built to provide high-end scheduler data presentation, WebScheduler exporting feature allows user to export events data which maximizes the user interface and experience for your Web applications. Like any other technologies invented by Intersoft Solutions, WebScheduler exporting has some essential features and concepts.

In This Section

Exporting to PDF

Exporting to iCal

Optimize reporting process

Flexible output with physical path and relative path in server

Automatic caching and cleaning output file

DPI support

See Also

Other Resources
{Timeline View}
{Extensibility}
{TrueSplitView™}


Exporting View

Exporting View
Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Exporting > Exporting View

Glossary Item Box

This section contains all features in Timeline View's exporting.

In This Section

Exporting to PDF

Exporting to iCal

Optimize reporting process

Output Path in Server

Automatic caching and cleaning output file

DPI support

Enable WebScheduler Exporting Feature


Exporting to PDF

Exporting to PDF
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Exporting > Features > Exporting to PDF

Glossary Item Box

In current web wide world, PDF has become an open standard for electronic document. It is commonly used for almost any application (documentation), on any computer system. Individuals, businesses, and government agencies around the world trust and rely on PDF to communicate their ideas and vision.

With WebScheduler 2.0, scheduler data and appearance can be exported to PDF similar to the current active view. Undoubtedly, with exporting to PDF enable feature, WebScheduler provides richer user experience and gives more benefits for enterprise users. For instance, sharing and offline viewing of the events information are now possible with the exporting feature.

Exporting WebScheduler data to PDF have many advantages:

    • User can save and use the documented version of WebScheduler later.
    • User is able to utilize all PDF functionality such as advanced document viewing, zooming, printing pages, selecting, and snapshot a part or whole of document.
    • User can exchange PDF file easily for any applications and to any computer systems.
PDF exporting is not only useful to save electronic document but also for printing purposes. In previous version of WebScheduler, there is no way to save and print scheduler except from browser itself. The saved html document or mht document is available, but text showed data is truncated and the functionally is not run perfectly. The browser printed version has a very rough layout and inconsistent scheduler data, so it is unreadable and somewhat useless.

PDF exporting has slightly different GUI behavior than its web. PDF exporting flows any text so there is no truncated data. It makes sure that all data in header and content of the scheduler is shown, so user is able to read, print, mark, scratched, remark, clip, adhere, etc.

Text flowing basically is an adjusting layout so that any text will not be truncated. It is done by wrapping the text, adjust the dimension of text and parent text container according to the dimension of the printing paper. So the exported PDF file of WebScheduler will have useful, meaningful, and complete scheduler data as well as its layout.

WebScheduler PDF exporting supports WebScheduler layout views, such as Day view, Week view, Month view, Quarter view, Year view and Agenda view. Timeline view and Split view are not supported yet, but some enhancement will be made and it will be supported later in the future.

Text flowing feature is usable when showing events in some scheduler views, as follows:

  • Day view - flows AllDayEvent header text, flows Event header text and flows Event description text
  • Week view - flows AllDayEvent header text, flows Event header text and flows Event description text
  • Month view - flows AllDayEvent and Event header text

WebScheduler PDF exporting also supports any WebScheduler styles in any layout views, including SchedulerFrameStyle, SchedulerHeaderStyle, SchedulerTodayHourStyle, WorkHourStyle, CalendarHeaderStyle, etc.

Styles support makes exporting more intuitive, attractive, and easier to view. When user changed styles in WebScheduler, it will also reflect in WebScheduler exporting, hence user will have the same representation between the web and the PDF version of the WebScheduler.

See Also

Other Resources
{Exporting to iCal}
{Optimize reporting process}
{Flexible output with physical path and relative path in server}
{Automatic caching and cleaning output file}
{DPI support}
{Enable WebScheduler Exporting Feature}
{Deployment}


Exporting to iCal

Exporting to iCal
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Exporting > Features > Exporting to iCal

Glossary Item Box

iCalendar is a standard (RFC 2445) for calendar data exchange. It is sometimes referred to as "iCal", which is also named after Apple, Inc. Calendar program (see iCal) provides one of the implementations of the standard.

iCalendar allows users to send meeting requests and tasks to other users through email. Recipients of the iCalendar email (with supported software) are able to respond to the sender easily or counter propose another meeting date/time.

iCalendar is implemented / supported by a large number of products. Its data is typically exchanged using traditional email, but the standard is designed to be independent to the transport protocol. For instance, iCalendar can be shared and edited by using a WebDav server, or SyncML.

The filename extension of "ics" is to be used to designate a file containing (an arbitrary set of) calendaring and scheduling information consistent with this MIME content type. And ics file consists of one or more scheduler event.

By exporting to ics format, WebScheduler data is able to be used, edited, or customized in any of your favorite calendar mail programs that support ics scheduler data format. With exporting to ics capability, WebScheduler data is now reusable, customizable and extensible for other programs. Just open an iCal file with your favorite scheduler program and the data will be presented in an elegant way.

WebScheduler is built to fulfill current scheduler data standard and enhance it with various custom scheduling data. Therefore, exporting to ics is seamlessly easy from WebScheduler.

Scheduler data format, use by WebScheduler for exporting, are:

  • A "VEVENT" component - provides a grouping of component properties that describe an event to represent a scheduled amount of time on a calendar. This component represents WebScheduler event and WebScheduler all day event.
  • A "SUMMARY" component property - defines a short summary or subject for the calendar component. This property represents WebScheduler event subject.
  • A "DTSTART" component property - specifies when the calendar component begins. This property represents WebScheduler event start time.
  • A "DTEND" component property - specifies when the calendar component ends. This property represents WebScheduler event end time.
  • A "DESCRIPTION" component property - provides a more complete description of the calendar component, than that provided by the "SUMMARY" property. This property represents WebScheduler event description.
  • A "LOCATION" component property - defines the intended venue for the activity defined by a calendar component. This property represents WebScheduler event location.
  • A "CATEGORIES" component property - defines the categories for a calendar component. This property represents WebScheduler event CategoryId.
  • A "RRULE" component property - defines a rule or repeating pattern for recurring events, to-dos, or time zone definitions. This property represents WebScheduler event recurrence info. Some sub-properties of "RRULE" are also supported, like: "FREQ" property, "INTERNAL" property, "BYDAY" property, and "BYMONTHDAY" property.
  • A "PRIORITY" component property - defines the relative priority for a calendar component. This property represents WebScheduler event mode (WebSchedulerImportanceMode).
  • A "VALARM" component property - provides a grouping of component properties that define an alarm. This property represents WebScheduler reminder time span event.

See Also

Other Resources
{Exporting to PDF}
{Optimize reporting process}
{Flexible output with physical path and relative path in server}
{Automatic caching and cleaning output file}
{DPI support}
{Enable WebScheduler Exporting Feature}
{Deployment}


Optimize reporting process

Optimize reporting process
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Exporting > Features > Optimize reporting process

Glossary Item Box

Exporting process can be cached, so whenever a report is created, it uses cached document in file instead of creating a new document again in memory. When you need to export several report data continuously, this will optimizes reporting process as it will run faster than usual mechanism.

See Also

Other Resources
{Exporting to PDF}
{Exporting to iCal}
{Flexible output with physical path and relative path in server}
{Automatic caching and cleaning output file}
{DPI support}
{Enable WebScheduler Exporting Feature}
{Deployment}


Output Path in Server

Output Path in Server
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Exporting > Features > Output Path in Server

Glossary Item Box

Exporting always creates a physical exported file. In pdf or ics format, these files locate in server and can be downloaded later by user. By default, these exported files are placed inside a sub directory named "TempReports", below root website application path.

The report path can be specified using WebSchedulerReportInfo.IISReportPath property. The default value is "~/TempReports". WebScheduler will translate the relative path specified in IISReportPath property to a physical path to store the report files.

See Also

Other Resources
{Exporting to PDF}
{Exporting to iCal}
{Optimize reporting process}
{Automatic caching and cleaning output file}
{DPI support}
{Enable WebScheduler Exporting Feature}
{Deployment}


Automatic caching and cleaning output file

Automatic caching and cleaning output file
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Exporting > Features > Automatic caching and cleaning output file

Glossary Item Box

When WebScheduler exports data, it will create a temporary physical file in the TempReports folder.

Temporary files will gradually become large, as more files are exported. Logically, it is always good to use the data only when it is needed and dispose when it is no longer useful. Hence, an automated delete process is created to keep the folder free of space.

By default, the temporary physical files will be disposed after 20 minutes. However, this value can be changed in ReportInfo.DeleteOutputTime.

See Also

Other Resources
{Exporting to PDF}
{Exporting to iCal}
{Optimize reporting process}
{Flexible output with physical path and relative path in server}
{DPI support}
{Enable WebScheduler Exporting Feature}
{Deployment}


DPI support

DPI support
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Exporting > Features > DPI support

Glossary Item Box

In today's computer world, presentation is one of the most important things. There are so many computer systems with their own presentation mechanism and hardware specification, for instance, Windows, Apple, Linux, UNIX, and etc.

Standardization is needed to provide a consistent way of presenting a document in various computer systems. DPI is one mechanism to achieve this scenario. Dots per inch (DPI) are a measure of spatial printing or video dot density, in particular the number of individual dots that can be placed within the span of one linear inch (2.54 cm.) The value of DPI tends to correlate with image resolution, but it is related only indirectly.

Printers with higher DPI produce clearer and more detailed output. A printer does not necessarily have a single DPI measurement; it is dependent on print mode, which is usually influenced by driver settings. The range of DPI supported by a printer is most dependent on the print head technology it uses. A dot matrix printer, for example, applies ink via tiny rods striking on ink ribbon, and has a relatively low resolution, typically in the range of 60 to 90 DPI. An inkjet printer sprays ink through tiny nozzles, and is typically capable of 300-600 DPI. A laser printer applies toner through a controlled electrostatic charge, and may be in the range of 600 to 1800 DPI.

With WebScheduler exporting, you can set your own DPI setting according to your customer's printer setting. The default value of WebScheduler report is 96 dots per inch.

See Also

Other Resources
{Exporting to PDF}
{Exporting to iCal}
{Optimize reporting process}
Output Path in Server
{Automatic caching and cleaning output file}
{Enable WebScheduler Exporting Feature}
{Deployment}


Enable WebScheduler Exporting Feature

Enable WebScheduler Exporting Feature
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Exporting > Features > Enable WebScheduler Exporting Feature

Glossary Item Box

To enable exporting, simply set EnableExport property to True.

When this property is enabled, end user can export the active view to PDF or iCal format using the header menu.

You can also export the scheduler view programmatically using ExportScheduler method.

In This Section

Exporting in Server Side

Exporting in Client Side

See Also

Other Resources
{Exporting to PDF}
{Exporting to iCal}
{Optimize reporting process}
{Flexible output with physical path and relative path in server}
{Automatic caching and cleaning output file}
{DPI support}
{Deployment}


Exporting in Server Side

Exporting in Server Side
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Exporting > Features > Enable WebScheduler Exporting Feature > Exporting in Server Side

Glossary Item Box

Default export settings will be used when you use ExportScheduler method. The default settings will export the active view in PDF format and Landscape orientation. You can also specify WebSchedulerReportInfo object to specify custom report info that will be used in exporting.

The following code will export the active view in iCal format and Portrait page orientation, using the file name "WebSchedulerToiCal.ics". The ExportScheduler method will return the physical path of the exported file.

C# Copy Code
protected void Button1_Click(object sender, EventArgs e)
{
   WebSchedulerReportInfo info = new WebSchedulerReportInfo();
   info.FileName = "WebSchedulerToiCal.ics";
   info.PageOrientation = DataDynamics.ActiveReports.Document.PageOrientation.Portrait;
   info.Type = WebSchedulerReportType.ICal;
   string file = ws1.ExportScheduler(info);
}

See Also

Other Resources
Exporting in Client Side


How-to: Export from server side

How-to: Export from server side
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Exporting > Features > Enable WebScheduler Exporting Feature > Exporting in Server Side > How-to: Export from server side

Glossary Item Box

Besides export WebScheduler from client-side, you also can export from server side. WebScheduler's export supports scheduler exporting to PDF and iCal.

In this topic, you will learn how to perform exporting from server-side.

To export from server-side

  1. Simply use ExportScheduler method from server-side.
  2. Here is the server-side snippet code:

    C# Copy Code
    protected void Button1_Click(object sender, EventArgs e)
{
   WebSchedulerReportInfo info = new WebSchedulerReportInfo();
   info.FileName = "WebSchedulerToPdf.pdf";
   ws1.ExportScheduler(info);  //ws1 is WebScheduler
}

See Also

Tasks
{How-to: Export from client side}
{Walkthrough Topics}
{How-to Topics}

Concepts
Exporting in Server Side


Exporting in Client Side

Exporting in Client Side
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Exporting > Features > Enable WebScheduler Exporting Feature > Exporting in Client Side

Glossary Item Box

ExportScheduler method in client side requires two parameters: export type and page orientation. The export type options are "PDF" and "iCal", while the page orientation options are "Landscape" and "Portrait". The following code will export the active view to PDF format and Landscape page orientation. The exported file will be opened in a new window.

C# Copy Code
function button1_click()
{
   var s = ISGetObject("WebScheduler1");
   s.ExportScheduler("PDF", "Landscape");
}

See Also

Other Resources
Exporting in Server Side


How-to: Export from client side

How-to: Export from client side
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Exporting > Features > Enable WebScheduler Exporting Feature > Exporting in Client Side > How-to: Export from client side

Glossary Item Box

Exporting is one of the new features in WebScheduler.NET. WebScheduler's export supports scheduler exporting to PDF and iCal.

In this topic, you will learn how to perform exporting from client-side.

To export from client-side

  1. Simply use ExportScheduler method from client-side. ExportScheduler requires two parameters (report type and page orientation).
  2. Here is the client-side snippet code:

    JavaScript Copy Code
    function Button1_onclick()
{
   //retrieve WebsScheduler object
   var s = ISGetObject("ws1");
   s.ExportScheduler("PDF", "Landscape");   // export scheduler to PDF
}

See Also

Tasks
{How-to: Export from server side}
{Walkthrough Topics}
{How-to Topics}

Concepts
Exporting in Client Side


Deployment

Deployment
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Exporting > Deployment

Glossary Item Box

Exporting assembly is required to be copied to your project's bin folder if the web application utilizes exporting feature in WebScheduler. The exporting assembly can be found in C:\Program Files\Intersoft Solutions\WebScheduler.NET 2.0\Bin. The exporting assembly is: ISNet.ActiveReports.Exporting.dll.

See Also

Other Resources
{Exporting to PDF}
{Exporting to iCal}
{Optimize reporting process}
{Flexible output with physical path and relative path in server}
{Automatic caching and cleaning output file}
{DPI support}
{Enable WebScheduler Exporting Feature}


How-to: Enable Export in WebScheduler

How-to: Enable Export in WebScheduler
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > New Features > Exporting > How-to: Enable Export in WebScheduler

Glossary Item Box

Exporting is one of the new features in WebScheduler 2.0. WebScheduler's export supports scheduler exporting to PDF and iCal.

In this topic, you will learn how to enable export in WebScheduler using WebScheduler's properties.

To enable export in WebScheduler

  1. Right click on WebScheduler's control and choose Properties.
  2. Set EnableExport to True. The export options will be displayed in WebScheduler's header menu.

See Also

Tasks
Exporting in Server Side
{Exporting in Client Side}
{Walkthrough Topics}
{How-to Topics}

Concepts
{Exporting}


Enhancements

Enhancements
Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > Enhancements

Glossary Item Box

We hereby present to you the enhancements of WebScheduler.NET based on the top feature requests submitted by you. There are several properties added to cover this feature requests which will be described in the following section.

Hide Calendar ToolTip

WebScheduler enhances its feature to let the user hide the calendar tooltip by simply setting a property called DisplayCalendarCellToolTip.

  • For more information, see Hide Calendar ToolTip.

Display Event Count Only In ToolTip

WebScheduler is now able to set the tooltip for displaying the total number of events even though there is only one event on that date.

  • For more information, see Display Event Count Only In ToolTip

Show Editing Form When Empty Cell is clicked

In the latest WebScheduler's version, you are able to show editing form when you click an empty cell.

  • For more information, see Show Editing Form When Empty Cell is clicked.

Hide Resources Area

You can hide the resources area that is usually displayed below the calendar.

  • For more information, see Hide Resources Area.

Show Event Subject Only In Month View

In the latest enhancement, you can freely display the event subject instead of start time event.

  • For more information, see Show Event Subject Only In Month View.

Customize Week Number

One of the top requested features is the ability to customize the week number elements.

  • For more information, see Customize Week Number.


Hide Calendar ToolTip

Hide Calendar ToolTip
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > Enhancements > Hide Calendar ToolTip

Glossary Item Box

By default, tooltip is displayed when you hover a date or range of dates (when you switch to Week View) in the Calendar. The tooltip will show the event's subject if you hover on a date which holds only one event and it will display the total numbers of event if you hover through a date which holds more than one event.

In this latest WebScheduler.NET version, you can actually hide the calendar tooltip simply by setting the DisplayCalendarCellToolTip property to False.

See Also

Other Resources
{Display Event Count Only In ToolTip}
{Show Editing Form When Empty Cell is clicked}
Hide Resources Area
{Show Event Subject Only In Month View}
{Customize Week Number}


How to: Hide calendar tooltip

How to: Hide calendar tooltip
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > Enhancements > Hide Calendar ToolTip > How to: Hide calendar tooltip

Glossary Item Box

The default behavior in WebScheduler's calendar is a tooltip will appear when you hover to the bold date of WebScheduler's calendar.

In this topic, you will learn how to hide calendar tooltip using WebScheduler's properties.

To hide calendar tooltip

  1. Right click on WebScheduler's control and choose Properties.
  2. Go to CalendarSettings.
  3. Set DisplayCalendarCellToolTip to False.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Concepts
Hide Calendar ToolTip


Display Event Count Only In ToolTip

Display Event Count Only In ToolTip
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > Enhancements > Display Event Count Only In ToolTip

Glossary Item Box

In Year and Quarter view, the event is displayed based on its resource color and the tooltip displays the total number of events for the resource in the specified date. If there is only one event in the resource, the subject of the event will be displayed in the tooltip. The same thing applies to the tooltip of calendar's date.

Now, you can actually set the tooltip to display the total number of events even though there is only one event on that date. This can be achieved by setting the DisplayEventCountOnlyInToolTip property to True.

See Also

Other Resources
{Hide Calendar ToolTip}
{Show Editing Form When Empty Cell is clicked}
{Hide Resources Area}
{Show Event Subject Only In Month View}
{Customize Week Number}


How-to: Display sum of the event only in tooltip

How-to: Display sum of the event only in tooltip
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > Enhancements > Display Event Count Only In ToolTip > How-to: Display sum of the event only in tooltip

Glossary Item Box

In Year view, Quarter view and calendar, tooltip will display the sum of the events for the resource in the specific date. If sum of the events in the resource is only one, then by default the tooltip will show the subject of the event instead of sum of the events.

In this topic, you will learn how to display sum of the event only in tooltip using WebScheduler's property.

To display sum of the event only in tooltip

  1. Right click on WebScheduler's control and choose Properties.
  2. Set DisplayEventCountOnlyInTooltip to True.

Please note that this feature applicable only in Year view, Quarter view and calendar tooltip.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Concepts
{Display Event Count Only In ToolTip}


Show Editing Form When Empty Cell is clicked

Show Editing Form When Empty Cell is clicked
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > Enhancements > Show Editing Form When Empty Cell is clicked

Glossary Item Box

By default when editing is enabled, WebCallOut is displayed if an empty cell is clicked. User can use WebCallOut as direct shortcut to add a new event. However, in certain scenarios where more detailed information is required, user must use the Editing Form to add a new event.

Simply set EmptyCellClickAction property to ShowEditingForm to skip the WebCallOut and display the Editing Form instead.

See Also

Other Resources
{Hide Calendar ToolTip}
{Display Event Count Only In ToolTip}
{Hide Resources Area}
{Show Event Subject Only In Month View}
{Customize Week Number}


How-to: Display EditingForm instead of Callout when empty cell is clicked.

How-to: Display EditingForm instead of Callout when empty cell is clicked.
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > Enhancements > Show Editing Form When Empty Cell is clicked > How-to: Display EditingForm instead of Callout when empty cell is clicked.

Glossary Item Box

When an empty cell in WebScheduler is clicked then a Callout will appear then you can input the event's information that you want. In Callout the information is not detail, in order to input more detail information, you should display the EditingForm.

In this topic, you will learn how to display EditingForm directly without Callout when an empty cell is clicked in WebScheduler.

To display EditingForm instead of CallOut when empty cell is clicked

  1. Right click on WebScheduler's control and choose Properties.
  2. Set EmptyCellClickAction to ShowEditingForm.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Show Editing Form When Empty Cell is clicked}


Hide Resources Area

Hide Resources Area
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > Enhancements > Hide Resources Area

Glossary Item Box

Resource lists are usually displayed below Calendar. To hide the resources area, simply set DisplayResourcesTable to False. Note that you can still navigate between views and dates without any issues.

See Also

Other Resources
{Hide Calendar ToolTip}
{Display Event Count Only In ToolTip}
{Show Editing Form When Empty Cell is clicked}
{Show Event Subject Only In Month View}
{Customize Week Number}


How-to: Hide resources area in WebScheduler

How-to: Hide resources area in WebScheduler
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > Enhancements > Hide Resources Area > How-to: Hide resources area in WebScheduler

Glossary Item Box

By default WebScheduler will show the resources area under WebScheduler's calendar(s).

In this topic, you will learn how to hide resources area using WebScheduler's property.

To hide resources area

  1. Right click on WebScheduler's control and choose Properties.
  2. Set DisplayResourcesTable to False.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Concepts
{Hide Resources Area}


Show Event Subject Only In Month View

Show Event Subject Only In Month View
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > Enhancements > Show Event Subject Only In Month View

Glossary Item Box

In order to differ between all-day event and time-based event in Month view, the start time of the event is displayed in time-based event. In certain scenarios, this default behavior is not suitable; especially under a scenario which only requires the subject and the time must be invisible.

To achieve the above scenarios, simply set the ViewSettings-MonthView-TimeBasedEventDisplay to ShowSubject, to display only the subject in time-based event.

See Also

Other Resources
Hide Calendar ToolTip
{Display Event Count Only In ToolTip}
{Show Editing Form When Empty Cell is clicked}
{Hide Resources Area}
{Customize Week Number}


How-to: Hide time information of TimeBasedEvent in Month View

How-to: Hide time information of TimeBasedEvent in Month View
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > Enhancements > Show Event Subject Only In Month View > How-to: Hide time information of TimeBasedEvent in Month View

Glossary Item Box

To differentiate AllDayEvent and TimeBasedEvent in MonthView, the event's start time will be displayed in TimeBasedEvent. However, if you would like TimeBasedEvent to hide the time part then this scenario is achievable.

In this topic, you will learn how to hide TimeBasedEvent's time information in Month view using WebScheduler's properties.

To hide time information of TimeBasedEvent in Month View

  1. Right click on WebScheduler's control and choose Properties.
  2. Go to ViewSettings >> MonthView.
  3. Set TimebasedEventDisplay to ShowSubject.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Concepts
{Show Event Subject Only In Month View}


Customize Week Number

Customize Week Number
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > Enhancements > Customize Week Number

Glossary Item Box

One of the top requested features is the ability to customize the week number elements.

The customizable Week Number elements are the one in Month view and in Calendar. Two client side events are added for this purpose, OnAfterRenderView and OnAfterRenderCalendar events.

To customize the Week Number element in Month view, GetSchedulerWeekNumber([row index]) function can be used in OnAfterRenderView client side event. To customize the Week Number element in Calendar, GetCalendarWeekNumber([calendar index], [row index]) function can be used in OnAfterRenderCalendar client side event.

Please browse to Customize Week Number sample for further information.

See Also

Other Resources
{Hide Calendar ToolTip}
{Display Event Count Only In ToolTip}
{Show Editing Form When Empty Cell is clicked}
{Hide Resources Area}
{Show Event Subject Only In Month View}


How to: Customize Week Number

How to: Customize Week Number
See Also Send Feedback
Intersoft WebScheduler > What's New in WebScheduler > V2.0 > Enhancements > Customize Week Number > How to: Customize Week Number

Glossary Item Box

WebScheduler allows user to customize the week number based on your scenario. You can customize calendar(s) and month view week number.

In this topic, you will learn how to customize week number to always display 1-6.

OnAfterRenderCalendar is used to customize Calendar's week number.

To customize week number

  1. Bind ISDataSource to WebScheduler.
  2. Implement OnAfterRenderView client side event. OnAfterRenerView is used to customize Month view's week number.

    Javsascript Copy Code
    function WebScheduler1_OnAfterRenderView(controlId, viewMode)
{
   var WebScheduler1 = ISGetObject(controlId);
   if (viewMode == "Month")
   {
      for (var i = 0; i < 6; i++)
      {
         //get week number based on the week number row in scheduler
         var weekNumberData = WebScheduler1.GetSchedulerWeekNumber(i);
         if (typeof(weekNumberData) == 'undefined')
            break;
         else
         {
            //set the new value to the week number element.
            weekNumberData[2].innerText = i+1;
         }
      }
   }
   return true;
}

  3. Implement OnAfterRenderCalendar client side event. OnAfterRenderCalendar is used to customize Calendar's week number.

    Javascript Copy Code
    //calendarType = Month, Quarter, Year
function WebScheduler1_OnAfterRenderCalendar(controlId, calendarType)
{
   var WebScheduler1 = ISGetObject(controlId);
   if (calendarType == "Month")
   {
      for (var i = 0; i < 3; i++)
      {
         for (var j = 0; j < 6; j++)
         {
            //get week number based on calendar index and the week number row in calendar
            var weekNumberData = WebScheduler1.GetCalendarWeekNumber(i, j);
            if (typeof(weekNumberData) == 'undefined')
               break;
            else
            {
               //set the new value to the week number element.
               weekNumberData[2].innerText = j+1;
            }
         }
      }
   }
   return true;
}

Please note that GetSchedulerWeekNumber and GetCalendarWeekNumber method will return an array. The array starts from index 0.

The first index of the array is the start date in the row.

The second index of the array is the end date in the row.

The third index of the array is the week number element.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Concepts
{Customize Week Number}


Walkthrough Topics

Walkthrough Topics
See Also Send Feedback
Intersoft WebScheduler > Walkthrough Topics

Glossary Item Box

The following list of walkthrough topics demonstrates how to use all features in WebScheduler and how to manipulate WebScheduler into some complex structures.

Data Binding

The topics in this category provide information about binding database to WebScheduler using ISDataSource.

  • Walkthrough: Binding Access database to WebScheduler using ISDataSource
  • Walkthrough: Binding SQL database to WebScheduler using ISDataSource

Extensibility

The topic in this category provides information about adding custom fields using extensibility feature.

  • Walkthrough: Adding custom fields in WebScheduler using Extensibility feature

Overwrite Changes Support

The topic in this category provides information about implementing OverwriteChanges conflict detection in WebScheduler.

  • Walkthrough: Implementing OverwriteChanges conflict detection in WebScheduler

See Also

Tasks
{How-to Topics}

Other Resources
{Getting Started}
{Features and Concepts}


How-to Topics

How-to Topics
See Also Send Feedback
Intersoft WebScheduler > How-to Topics

Glossary Item Box

The following list of How-to topics describes how to implement various features and enhancements in WebScheduler.

Detail Box Paging

The topics in this category provide direct instructions on how to enable Detail Box Paging.

  • How-to: Enable Detail Box Paging in WebScheduler
  • How-to: Set Detail Box Page Size in WebScheduler

Time Interval

The topics in this category provide direct instructions on how to set Time Interval.

  • How-to: Set Time Interval in Week view
  • How-to: Include Time Interval Options in Context Menu

Visible Hours

The topic in this category provides a direct instructions on how to set Visible Hours in Week view.

  • How-to: Set Visible Hours in Week view

Customizable maximum height of all-day area

The topic in this category provides a direct instruction on how to customize maximum height of all-day area.

  • How-to: Customize the maximum height of all-day area

Client-side function - Timeline view

The topic in this category provides a direct instruction on how to retrieve cell elements.

  • How-to: Retrieve cell elements using GetCellElements client-side API

Client-side function - Retrieve a cell element

The topic in this category provides a direct instruction on how to retrieve a cell element.

  • How-to: Retrieve a cell element using GetCellElement client-side API

Customizable Timeline's date header

The topic in this category provides a direct instruction on how to customize Timeline Header Mode.

  • How-to: Customize Timeline's Header Mode

New Quarter view in Timeline View mode

The topic in this category provides a direct instruction on how to run Timeline Quarter View.

  • How-to: Enable Quarter mode in Timeline view on load

Keep date header always visible in Timeline

The topic in this category provides a direct instruction on how to keep Timeline's date header visible.

  • How-to: Keep Timeline's date header visible

Disabled Time

The topics in this category provide direct instructions on how to create global, resource and partial disabled time.

  • How-to: Add Global Disabled Time in Timeline view
  • How-to: Add Global Disabled Time for All Day Area in Week view
  • How-to: Add Global Disabled Time for Hour Area in Week view
  • How-to: Add Resource Disabled Time in Timeline view
  • How-to: Add Partial Disabled Time in Timeline view

Client Paging - Day view, Week view and Split view

The topics in this category provide direct instructions on how to enable client paging in several views.

  • How-to: Enable Client Paging in Day view
  • How-to: Enable Client Paging in Week view
  • How-to: Set EventBlockSize in Week view
  • How-to: Set AllDayEventPageSize in Week view

Client Paging - Timeline view

The topics in this category provide direct instructions on how to enable client paging in Timeline view.

  • How-to: Enable Client Paging in Timeline view
  • How-to: Enable Client Paging EventPageSize mode
  • How-to: Enable Client Paging ViewPort mode
  • How-to: Enable Client Paging Both mode

Customizable number of days in Agenda

The topic in this category provides a direct instruction on how to customize Agenda's number of days.

  • How-to: Customize Agenda's Number of Days

Exporting - Timeline exporting customization

The topic in this category provides a direct instruction on how to enable export in Timeline.

  • How-to: Enable Export in Timeline
  • How-to: Perform Timeline Export Customization

TrueSplitView™

The topics in this category provide direct instructions on how to enable TrueSplitView and include it in WebScheduler.

  • How-to: Initially enable TrueSplitView
  • How-to: Include TrueSplitView in WebScheduler

Exporting

The topics in this category provide direct instructions on how to enable exporting in WebScheduler and many more.

  • How-to: Enable Export in WebScheduler
  • How-to: Export from server side
  • How-to: Export from client side

EditingForm

The topic in this category provides a direct instruction on how to display EditingForm when empty cell is clicked.

  • How-to: Display EditingForm instead of CallOut when empty cell is clicked

Calendar

The topic in this category provides a direct instruction on how to hide calendar tooltip.

  • How-to: Hide calendar tooltip

Resources

The topic in this category provides a direct instruction on how to hide resources area in WebScheduler.

  • How-to: Change ResourcesTable Function and Appearance
  • How-to: Hide resources area in WebScheduler

Timeline View - Flexible customization in Timeline view

The topics in this category provide direct instructions on how to customize the Timeline View's behaviors, look and feels, appearances and styles.

  • How-to: Customize ContentCellWidth
  • How-to: Customize MinimumEventHeight
  • How-to: Customize ResourceCellWidth
  • How-to: Customize ResourceRowHeight

Timeline View - Sophisticated Event Layout

The topic in this category provides direct instruction on how to customize the event cell.

  • How-to: Customize TotalEventInCell

Timeline View - Moving and Resizing Event

The topics in this category provide direct instructions on how to add, edit, delete, move and resize event.

  • How-to: AllowEdit in WebScheduler
  • How-to: AllowAdd in WebScheduler
  • How-to: AllowDelete in WebScheduler
  • How-to: Move and resize event in Timeline view

Timeline View - Customizing the Resources Content

The topic in this category provides direct instruction on how to customize resources content.

  • How-to: Customize Resources Content using ResourceContentTemplate

Data Binding - Single load vs Triple load

The topic in this category provides direct instruction on how to implement SingleLoadOnDemand property.

  • How-to: Use SingleLoadOnDemand

Calendar Features

The topics in this category provide direct instructions on how to customize the features available in calendar.

  • How-to: Enable AllowCollapse in calendar
  • How-to: Customize FirstDayOfWeek property
  • How-to: Customize FirstWeekOfYear property
  • How-to: Hide calendar initially
  • How-to: Customize NumberOfMonthsDisplayed property
  • How-to: Customize MarkedDayWithEvents property

Holiday

The topic in this category provides a direct instruction on how to customize holiday using Holiday property.

  • How-to: Specify holiday(s) in WebScheduler

MonthView

The topic in this category provides a direct instruction on how to show range of month.

  • How-to: Show range of month instead of week numbers in month view

YearView

The topic in this category provides a direct instruction on how to set minimum height in year view.

  • How-to: Set minimum height in Year View

WorkWeekSettings

The topic in this category provides a direct instruction on how to enable workweek.

  • How-to: Enable and specify work week in WebScheduler

General Features

The topics in this category provide direct instructions on how to customize some general features in WebScheduler.NET.

  • How-to: Change View Header Type
  • How-to: Display sum of the event only in tooltip
  • How-to: Hide time information of TimeBasedEvent in Month View
  • How-to: Customize Week Number
  • How-to: Enable animation in WebScheduler
  • How-to: Enable context menu in WebScheduler
  • How-to: Show week number in WebScheduler
  • How-to: Refresh view in WebScheduler at runtime
  • How-to: Print in WebScheduler at runtime
  • How-to: Show/hide Day view in WebScheduler's ViewHeader
  • How-to: Show/hide Week view tab in WebScheduler's ViewHeader
  • How-to: Show/hide Month view tab in WebScheduler's ViewHeader
  • How-to: Show/hide Quarter view tab in WebScheduler's ViewHeader
  • How-to: Show/hide Year view tab in WebScheduler's ViewHeader
  • How-to: Show/hide Agenda view tab in WebScheduler's ViewHeader
  • How-to: Enable/disable HighlightTodayDate in WebScheduler's view
  • How-to: Enable/disable AllowCreateEventHoliday

Editing

The topics in this category provide direct instructions on how to customize editing feature in WebScheduler.NET.

  • How-to: AllowEdit in WebScheduler
  • How-to: AllowAdd in WebScheduler
  • How-to: AllowDelete in WebScheduler
  • How-to: AllowMove in WebScheduler
  • How-to: AllowResize in WebScheduler
  • How-to: Customize EditingField
  • How-to: Set EditingUrl in WebScheduler

Culture - Text Settings

The topics in this category provide direct instructions on how to set and customize the culture in WebScheduler.NET.

  • How-to: Customize WebScheduler's TextSettings
  • How-to: Set culture in WebScheduler

See Also

Tasks
{Walkthrough Topics}

Other Resources
{Getting Started}
{Features and Concepts}


Overview

Overview
See Also Send Feedback
Intersoft WebScheduler > Overview

Glossary Item Box

Intersoft WebScheduler.NET™ is designed for ease-of-use and out-of-the-box Scheduling experience, yet providing advanced level of customization and innovative features. WebScheduler.NET™ allows you to build professional calendaring and scheduling application with very minimal efforts and time.

You can create a fully functional Scheduling application that similar to Microsoft Outlook 2007® with simple drag-drop and several properties set. The calendar and scheduler view is naturally integrated and automatically synchronized as you navigate on. The result is obvious - hassles free Scheduling development, significantly reduced complexity with out-of-the-box integration and advanced feature-sets.

WebScheduler.NET™ combines the best of industry's Scheduling features and Intersoft's own unique features such as SplitView mode and AgendaView mode. One of the key features of Intersoft's WebScheduler is its built-in six Scheduler Views - from Day, Week to Year - while other similar components commonly provide only four views.

WebScheduler.NET™ extensively takes advantage of FlyPostBack™ (the Intersoft's proprietary AJAX technology) to deliver high performance and responsive user experience. The TripleLoad™ feature - a unique load-on-demand mechanism invented for WebScheduler - enables end users to switch between several views instantly. The overall experience while navigating different date or month is almost seamless - as raw data is retrieved asynchronously and perform smart data fetching for nearest view.

Several key features and unique innovations of WebScheduler:

    • Hassles free development with built-in calendar and integrated scheduler views.
    • Supports 6 Scheduler Views as well as defining your own Custom View.
    • Out-of-the-box data editing and manipulation with Google-style Callout form.
    • Advanced two-ways data binding with flexible database structure support.
    • All textual elements related to Calendar are fully localizable to any cultures supported by .NET.
    • Innovative AgendaView™.
    • Over dozens of customizable styles and hundreds of customizable behaviors.

See Also

Other Resources
{Features Highlight}


Features and Concepts

Features and Concepts
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts

Glossary Item Box

WebScheduler is Intersoft's flagship product in Calendaring, Scheduling and Planning functionality, offering over hundreds of advanced features and numerous unique innovations designated for enterprise-grade Scheduling application.

In This Section

State-of-the-Art Rendering and Appealing User Interface
Read about WebScheduler and calendar user interface.

Natural Calendaring and Scheduling Integration
Read about the integration between calendar and scheduler without writing any single line of codes.

Includes 6 Built-in Scheduler View
Discover the 6 built-in views in WebScheduler.

Elegant Databinding Architecture
Read about using multiple-table databinding architecture to deliver a more robust and elegant database design.

Superior User Experience
Read about the best and the most appealing design of WebScheduler for user interface and user experience.

Out-of-the-box Editing Experience
Read about built-in Editing Webform in WebScheduler.

Advanced Calendaring Function
Read about advanced calendaring function that adopts vista style behavior for view range selection.

Multiple Resources
Read about built-in multiple resources support in WebScheduler.

Comprehensive Recurrence Support
Read about WebScheduler's ability to create new recurring event or convert a standard event to recurring event.

Super-fast View Switching and Navigation with TripleLoad™
Read about TripleLoad™ which enables WebScheduler to load and switch to different view instantly.

Rich Design-time rendering and deep integration with Visual Studio
WebScheduler supports both Visual Studio® 2005 and Visual Studio® 2008 design time environment.

Tight integration with WebDesktop.NET™
Read about WebScheduler's ability to integrate with WebDesktop.

See Also

Tasks
{How-to: Enable AllowCollapse in calendar}
How-to: Hide calendar initially
{How-to: Enable animation in WebScheduler}
{How-to: Specify holiday(s) in WebScheduler}
{How-to: AllowEdit in WebScheduler}
{How-to: Customize EditingField}
{How-to Topics}

Other Resources
{Overview}


State-of-the-Art Rendering and Appealing User Interface

State-of-the-Art Rendering and Appealing User Interface
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > State-of-the-Art Rendering and Appealing User Interface

Glossary Item Box

WebScheduler.NET is the world's first Calendaring and Scheduling component for ASP.NET that provide the deepest details of visual interface which processed with high performance, state-of-the-art rendering architecture.

As illustrated in the above screenshot, WebScheduler provides you with elegant and minimalist styles to enhance user experience while working with the Scheduling application.

WebScheduler comes with detailed visual elements to bring you the most sophisticated Scheduling functions, such as:

    • Calendar with built-in Expandable/Collapsible function. The Calendar provides comprehensive visual details, such as Orange colored highlight to indicate the current active Scheduler view and bold effect to indicate days which have more than one event. The Calendar also gives you visual hint for holidays and inactive days.
    • Scheduler with built-in Back and Forward (navigation) function. The Scheduler includes every visual detail with such sophisticated styling to deliver visually appealing Scheduling functionality. Notice that every cell is accurately separated with proper border lines and color. The Scheduler contains All Day Event zone, Hour zone, Day zone, Header zone and Event zone.
    • The Resources list allows you to conveniently show or hide a set of events that belong to that resource with a simple click. The resources will be refreshed in real-time fraction, without any callback operation.
    • The built-in Callout facilitates the user interface to show more details and information about an event. With the Callout visual interface, user can conveniently discover the event's information in smooth and rich look and feel. The Callout interface is also extensively used in many other scenarios such as in New Event action.
    • The View Navigator enables you to switch between views simply with a mouse click. More actions related to the Scheduler functionality are also available by clicking on the down arrow in the View Navigator.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Natural Calendaring and Scheduling Integration}
{Includes 6 Built-in Scheduler View}
{Elegant Databinding Architecture}
{Superior User Experience}
{Out-of-the-box Editing Experience}
{Advanced Calendaring Function}
{Multiple Resources}
{Comprehensive Recurrence Support}
{Super-fast View Switching and Navigation with TripleLoad™
{Rich Design-time rendering and deep integration with Visual Studio}
{Tight integration with WebDesktop.NET™}


Natural Calendaring and Scheduling Integration

Natural Calendaring and Scheduling Integration
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Natural Calendaring and Scheduling Integration

Glossary Item Box

Unlike many other similar components, WebScheduler doesn't require you to write any single line of codes to perform synchronization between the Calendar and the Scheduler, and therefore significantly increases developer's productivity.

See Also

Other Resources
{State-of-the-Art Rendering and Appealing User Interface}
{Includes 6 Built-in Scheduler View}
{Elegant Databinding Architecture}
{Superior User Experience}
{Out-of-the-box Editing Experience}
{Advanced Calendaring Function}
{Multiple Resources}
{Comprehensive Recurrence Support}
{Super-fast View Switching and Navigation with TripleLoad™}
{Rich Design-time rendering and deep integration with Visual Studio}
{Tight integration with WebDesktop.NET™}

Tasks
{Walkthrough Topics}
{How-to Topics}


Includes 6 Built-in Scheduler View

Includes 6 Built-in Scheduler View
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Includes 6 Built-in Scheduler View

Glossary Item Box

Intersoft's WebScheduler.NET™ is the industry's first Scheduling component providing six built-in view modes. In addition to the standard -Day, Week and Month™ views, WebScheduler provides three additional innovative views.

Day View

The Day view lists your "All Day", Recurring and Standard Events based on the Start Hour and Duration.

Week View

The Week view displays all the week days in the selected date range. You can choose to show between full week or work week in the Scheduler's interface.

Month View

The Month view lists your events in a month range. Similar to Day and Week view, you can perform editing, move the event around and create new event directly from the interface.

Quarter View

The Quarter view is similar to the Year view, except it only displays 3 months in the row. It is designed to give you a quick look on your events in quarterly range.

Year View

The Year view is designed to give you an instant overview of your events in a year. It displays the number of events inside the day cell and colored according to the resource color. You can hover to the event to see the event's description.

Agenda View

The Agenda view is a unique and innovative mode that allows you to view your events in personalized agenda listing. Your events will be automatically sorted and displayed starting from the Selected Date.

You can also customize which views that you would like to enable in WebScheduler. For instance, you may want to restrict WebScheduler to display only Day and Week view. The View settings are available in ViewSettings object, and each View has its own object such as QuarterViewSettings, YearViewSettings and so on.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{State-of-the-Art Rendering and Appealing User Interface}
{Natural Calendaring and Scheduling Integration}
{Elegant Databinding Architecture}
{Superior User Experience}
{Out-of-the-box Editing Experience}
{Advanced Calendaring Function}
{Multiple Resources}
{Comprehensive Recurrence Support}
{Super-fast View Switching and Navigation with TripleLoad™}
{Rich Design-time rendering and deep integration with Visual Studio}
{Tight integration with WebDesktop.NET™}


Elegant Databinding Architecture

Elegant Databinding Architecture
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Elegant Databinding Architecture

Glossary Item Box

Intersoft's WebScheduler.NET is designed to use multiple-table databinding architecture to deliver a more robust and elegant database design. The databinding architecture in WebScheduler is one of the most important aspects in addition to user experience and functions, which allows you to have greater flexibility and extensibility in your database structure.

As shown in the above illustration, WebScheduler integrates natively into ISDataSource control (Intersoft's flagship datasource control) to provide you with multiple tables binding capability.
With ISDataSource, the WebScheduler databinding experience is almost seamless and codeless. You simply need to connect the WebScheduler to an instance of ISDataSource through its DataSourceID control. Once connected, the data members will automatically be available in the dropdown selection, enabling you to bind the data member quickly with simply a mouse click.
The databinding in WebScheduler consisted of 5 fundamental tables. All these tables are required to be bound in order to take advantage of all WebScheduler functionality.
  • Categories
    This datamember includes binding to Categories-specific fields, such as the CategoryName, CategoryColor, etc - which is linked to Events table.

  • Events
    This datamember is the core member which includes binding to Events fields, such as the event's Subject, Description, Location, StartTime, EndTime and so on.

  • Recurring Events
    This datamember is required if you would like to take advantage of recurring events functionality in WebScheduler. This datamember includes binding to core recurring events fields.

  • Recurrence Info
    Similar to Recurring Events, this datamember is required to enable recurring events functionality in WebScheduler.

  • Resources
    This datamember is required if you would like to take advantage of multiple resources feature of WebScheduler. A resource contains a collection of events, which determine the main color of the events.

Despite the advanced databinding architecture as described above, WebScheduler can also be used for simpler scenario. In the most basic Scheduling functionality, you will need to bind only the Events table.

When the other tables are not bound, the related features will be gracefully degraded. For instance, if Categories datamember is not bound, you will not be able to specify Category in the Editing form. If Recurring Events datamember is not bound, then you will not be able to display or create a new recurring event, and so on.
For more details about WebScheduler's databinding concept, please read Databinding Concepts topic.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{State-of-the-Art Rendering and Appealing User Interface}
{Natural Calendaring and Scheduling Integration}
{Includes 6 Built-in Scheduler View}
{Superior User Experience}
{Out-of-the-box Editing Experience}
{Advanced Calendaring Function}
{Multiple Resources}
{Comprehensive Recurrence Support}
{Super-fast View Switching and Navigation with TripleLoad™}
{Rich Design-time rendering and deep integration with Visual Studio}
{Tight integration with WebDesktop.NET™}


Superior User Experience

Superior User Experience
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Superior User Experience

Glossary Item Box

WebScheduler.NET™ includes only the best and the most appealing design for user interface and user experience. Take a look at the following image for more details.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{State-of-the-Art Rendering and Appealing User Interface}
{Natural Calendaring and Scheduling Integration}
{Includes 6 Built-in Scheduler View}
{Elegant Databinding Architecture}
{Out-of-the-box Editing Experience}
{Advanced Calendaring Function}
{Multiple Resources}
{Comprehensive Recurrence Support}
{Super-fast View Switching and Navigation with TripleLoad™}
{Rich Design-time rendering and deep integration with Visual Studio}
{Tight integration with WebDesktop.NET™}


Out-of-the-box Editing Experience

Out-of-the-box Editing Experience
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Out-of-the-box Editing Experience

Glossary Item Box

Intersoft WebScheduler.NET™ does not come only with beautiful user interface and elegant databinding architecture; it also comes with built-in Editing Webform which takes advantage of all WebScheduler functionality such as Resource selection, multiple Categories, as well as Recurrence editing.

WebScheduler's Editing Form is entirely powered by the company's flagship WebUI Studio.NET components to deliver the most sophisticated user interface for editing experience. From the design, look and feel perspective, WebScheduler's Editing Form sports a very unique and innovative neutral theme which dramatically enhances user experience. By default, it casted deep alpha blended drop- shadow to strengthen the focus of the editing dialog box and its features.
WebScheduler's Editing Form adopts "open architecture" model, which means you can edit the Form and customize it according to your needs.
The key objectives of the "open architecture" Editing Form is:
  • Enable you to conveniently customize the styles, appearance, and layout of the Editing Form to suit your needs, as long as the controls and ID are not modified.
  • Enable you to easily localize the textual elements used in the Form.
  • Enable you to add more fields and custom validations according to your business scenario.
  • Enable you to add more controls and possibility to use other third party controls in the Form.
  • Enable you to control and customize the behaviors of existing controls, for example, disable an input field.

Built-in Editing Form - This feature heavily utilizes Intersoft's own WebUI components to deliver the best editing experience. Therefore, the licenses to these WebUI components are not included in WebScheduler. The components are WeCombo.NET, WebInput.NET and WebDesktop.NET. Hence, users have to purchase these components separately if they want to use Built-in Editing Form.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{State-of-the-Art Rendering and Appealing User Interface}
{Natural Calendaring and Scheduling Integration}
{Includes 6 Built-in Scheduler View}
{Elegant Databinding Architecture}
{Superior User Experience}
{Advanced Calendaring Function}
{Multiple Resources}
{Comprehensive Recurrence Support}
{Super-fast View Switching and Navigation with TripleLoad™}
{Rich Design-time rendering and deep integration with Visual Studio}


Advanced Calendaring Function

Advanced Calendaring Function
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Advanced Calendaring Function

Glossary Item Box

WebScheduler.NET™ won't be a breakthrough Scheduling component without an advanced Calendaring functionality. The Calendar is one of the fundamental subcomponent of WebScheduler which plays important roles in the overall features such as navigation, view highlighting and selection.

The Calendar is adopting Vista style behavior for view range selection. You can click on the calendar'?s header to change the view to Month selection, and click one more time to change the view to Year selection.
In addition to the above behaviors, the Calendar also includes several enterprise-grade features such as:
  • Customizable FirstDayOfWeek. By default, FirstDayOfWeek is Sunday. However, the value might be different in some countries. The Calendar supports any day to be used as FirstDayOfWeek.
  • Customizable FirstWeekOfYear. The default value is following US Standard, which is First4DayWeek. However, in British and some other countries, the standard is different. The Calendar supports 3 options to cover this requirement. The options are First4DayWeek, FirstFullWeek and StartsOnJanuary1.
  • Customizable Culture. The default value is US English Culture. With this setting, you can use any of the .NET supported culture for the Calendar�??s culture. The following screenshot demonstrates the WebScheduler which Culture is set to Chinese.

Three of the above advanced features control the core rendering behaviors of the Calendar, such as the week number calculation, day sequence, full week and work week view, and many other features.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{State-of-the-Art Rendering and Appealing User Interface}
{Natural Calendaring and Scheduling Integration}
{Includes 6 Built-in Scheduler View}
{Elegant Databinding Architecture}
{Superior User Experience}
{Out-of-the-box Editing Experience}
{Multiple Resources}
{Comprehensive Recurrence Support}
{Super-fast View Switching and Navigation with TripleLoad™}
{Rich Design-time rendering and deep integration with Visual Studio}
{Tight integration with WebDesktop.NET™}


Multiple Resources

Multiple Resources
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Multiple Resources

Glossary Item Box

Intersoft's WebScheduler.NET™ is the one of its kind that comes with built-in multiple resources support, as well as complete Resources Management in the Editing Form.

The resources can be seen as groups that divide a set of events. The data is not restricted by WebScheduler and can contain anything that suitable to your needs and application scenarios. For more information about resources, please read Resources Concept topic.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{State-of-the-Art Rendering and Appealing User Interface}
{Natural Calendaring and Scheduling Integration}
{Includes 6 Built-in Scheduler View}
{Elegant Databinding Architecture}
{Superior User Experience}
{Out-of-the-box Editing Experience}
{Advanced Calendaring Function}
{Comprehensive Recurrence Support}
{Super-fast View Switching and Navigation with TripleLoad™}
{Rich Design-time rendering and deep integration with Visual Studio}
{Tight integration with WebDesktop.NET™}


Comprehensive Recurrence Support

Comprehensive Recurrence Support
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Comprehensive Recurrence Support

Glossary Item Box

Intersoft's WebScheduler.NET™ is a breakthrough Scheduling component providing advanced functionality beyond normal Event. WebScheduler lets you create a Standard Event, All Day Event and Switch Day Event.

In addition to the above types, WebScheduler also supports a wide range of Recurrence Event functionality, such as ability to create new Recurring Event with various recurrence patterns. WebScheduler is also capable to convert a Standard Event into Recurring Event, and vice versa.
Several key designs and concepts of Recurrence Support in WebScheduler are:
  • Recurrence Pattern
    The patterns supported in WebScheduler are:
      • Daily. The options are every [x] days, or every week days.
      • Weekly. The event will recur on every [x] weeks on any specified days.
      • Monthly. The event will recur on day [n] of every [x] months.
      • Yearly. The event will recur on every [month] of day [n].

  • Recurrence Range.
    The recurrence range specifies when and how long a recurring event should last. WebScheduler provides you with Start date, and several End date options such as:
      • No end date. The event will recur indefinitely.
      • End after [n] occurrences. The event will stop recurring after it has recurred for certain specified number.
      • End by [date]. The event will stop recurring when it reaches the specified date.

  • Recurrence Editing
    WebScheduler's sophisticated Editing Form fully supports all Recurrence features that provided by WebScheduler, such as the Recurrence Pattern and the Recurrence Range.

  • Recurrence Exception
    By default, Recurrence event is an event that recurring consistently from the specified Start Date by using the configured Recurrence Pattern within Recurrence Range.

    WebScheduler supports an advanced Recurrence concept called Recurrence Exception. Recurrence Exception occurred when an instance of the recurring event is broken from the original recurring series.

    For a simple illustration, let's say a recurring event is configured to run on weekly basis every Friday starting from February 29th, 2008 until April 4th, 2008. In the WebScheduler, this recurring event will be displayed on 02/29/2008, 03/07/2008, 03/14/2008, 03/21/2008, 03/28/2008, and 04/04/2008. When you would like to change an instance of the running recurring event, for instance, on 03/28/2008, then that recurring event will become exception.

    When a recurring event is broken from its original series, it is called Recurrence Exception.
      • When a recurring event is resized by using drag and drop, or when it is about to be edited (from either context menu or Callout interface), a prompt dialog box such as shown in the following will appear to ask the feedback from user.

      • When a recurring event is moved by using drag and drop, it will be automatically become an exception.
      • When a recurring event is about to be deleted (from either context menu or Callout interface), a prompt dialog box such as shown in the following will appear to ask the feedback from user.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{State-of-the-Art Rendering and Appealing User Interface}
{Natural Calendaring and Scheduling Integration}
{Includes 6 Built-in Scheduler View}
{Elegant Databinding Architecture}
{Superior User Experience}
{Out-of-the-box Editing Experience}
{Advanced Calendaring Function}
{Multiple Resources}
{Super-fast View Switching and Navigation with TripleLoad™}
{Rich Design-time rendering and deep integration with Visual Studio}
{Tight integration with WebDesktop.NET™}


Super-fast View Switching and Navigation with TripleLoad�?�

Super-fast View Switching and Navigation with TripleLoad�?�
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Super-fast View Switching and Navigation with TripleLoad�?�

Glossary Item Box

Thanks to the state-of-the-art rendering architecture, it enables WebScheduler to load and switch to different view instantly. This is made possible because WebScheduler does not need to perform AJAX operation to perform server-side rendering. Instead, it fetches the aggregated data from database directly which is 70 percent smaller than the usual server-side rendering.

WebScheduler is designed with high performance as one of its key objectives. It invented a new data retrieval mechanism - called TripleLoad™ technology - as its core data management solution.

Combining the high-performance TripleLoad™ technology along with the sophisticated rendering architecture, WebScheduler delivers smooth and confident user experience as it enables user to works and interacts seamlessly with the WebScheduler interface.

The TripleLoad™ technology itself is taking advantage of delta-based caching in order to determine the validity of the loaded data. See the following illustration for better understanding on the TripleLoad™ concept.
TripleLoad™ is a patent-pending technology by Intersoft Solutions and filed in US and International.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{State-of-the-Art Rendering and Appealing User Interface}
{Natural Calendaring and Scheduling Integration}
{Includes 6 Built-in Scheduler View}
{Elegant Databinding Architecture}
{Superior User Experience}
{Out-of-the-box Editing Experience}
{Advanced Calendaring Function}
{Multiple Resources}
{Comprehensive Recurrence Support}
{Rich Design-time rendering and deep integration with Visual Studio}
{Tight integration with WebDesktop.NET�?�}


Rich Design-time rendering and deep integration with Visual Studio

Rich Design-time rendering and deep integration with Visual Studio
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Rich Design-time rendering and deep integration with Visual Studio

Glossary Item Box

WebScheduler supports both Visual Studio® 2005 and Visual Studio® 2008 design time environment. You can conveniently customize and control the WebScheduler's behaviors, styles, and appearance through Intersoft's Component Editor 2.0 - which is part of the WebUI.NET Framework™, the foundation of Intersoft WebUI components.

Time-saving Component Editor significantly increases developer's productivity with quick access and logically categorized settings.
In conjunction with Open Architecture Editing Form, WebScheduler provides a time-saving designer feature to help you easily integrate the WebForm into your existing Web project. This designer feature seamlessly copies the Editing Form source and adds it to your Web project, as well as configuring WebScheduler to use the newly added Editing Form as the source.
When you set AllowEdit property to Yes from the Visual Studio's property window, the Editing Wizard will be launched to help you configure the Editing experience.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{State-of-the-Art Rendering and Appealing User Interface}
{Natural Calendaring and Scheduling Integration}
{Includes 6 Built-in Scheduler View}
{Elegant Databinding Architecture}
{Superior User Experience}
{Out-of-the-box Editing Experience}
{Advanced Calendaring Function}
{Multiple Resources}
{Comprehensive Recurrence Support}
{Super-fast View Switching and Navigation with TripleLoad™}
{Tight integration with WebDesktop.NET™}


Tight integration with WebDesktop.NET™

Tight integration with WebDesktop.NET™
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Tight integration with WebDesktop.NET™

Glossary Item Box

Intersoft WebScheduler's user interface and visual experience is built upon the expertise of the company's flagship WebUI technology.

The tight integration between WebScheduler and the rest of WebUI Studio.NET UI components ensures users to have the same and consistent rich user interface that they already become familiar with. At the developer end, this feature also maximizes the value of existing investments on Intersoft's WebUI technology, and at the same time increasing productivity by reducing the steep learning curves.
The following image shows WebScheduler hosted inside WebDesktopManager. The Editing API automatically detects the existence of the WebDesktopManager, and seamlessly integrate into the WebDesktopManager instance. Notice that the Dialog theme as well as the button is using the main WebDesktopManager theme, instead of its own default style.
In addition to the styles, you can also notice that the Dialog is naturally integrated into WebDesktopManager. This means that the Dialog can now be moved out from the original page. You can perform moving and resizing as it is a WebDesktopWindow object.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{State-of-the-Art Rendering and Appealing User Interface}
{Natural Calendaring and Scheduling Integration}
{Includes 6 Built-in Scheduler View}
{Elegant Databinding Architecture}
{Superior User Experience}
{Out-of-the-box Editing Experience}
{Advanced Calendaring Function}
{Multiple Resources}
{Comprehensive Recurrence Support}
{Super-fast View Switching and Navigation with TripleLoad™}
{Rich Design-time rendering and deep integration with Visual Studio}


How-to: Integrate with DesktopManager

How-to: Integrate with DesktopManager
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Tight integration with WebDesktop.NET™ > How-to: Integrate with DesktopManager

Glossary Item Box

WebScheduler has a strong integration with WebDesktop.NET. The WebScheduler itself is using the same WebDesktop runtime components for several user interface such as context menu, dialog box, button and more. The tight integration produces consistent look and feel across the entire Web application to deliver sophisticated and stunning user experience.

In this topic, you will learn how to integrate WebScheduler with DesktopManager.

To integrate with DesktopManager

  1. Create a page containing WebScheduler application and named it IntegratedScheduler.aspx.
  2. Create a page containing WebDesktopManager along with its desktop window.
  3. In WebDesktop's properties, set ContentMode to UseIFrame and ContentURL to ./IntegratedScheduler.aspx.

    <ISWebDesktop:WebDesktopWindow ContentMode="UseIFrame" ContentURL="./IntegratedScheduler.aspx">
    </ISWebDesktop:WebDesktopWindow>

  4. Run the project.

See Also

Tasks
How-to: Integrate with WebCallOut


How-to: Integrate with WebCallOut

How-to: Integrate with WebCallOut
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Tight integration with WebDesktop.NET™ > How-to: Integrate with WebCallOut

Glossary Item Box

WebScheduler has tight integration with WebCallOut (part of WebDesktop.NET®). By using WebCallOut, the information of each location of the resources can be shown.
It uses CustomTemplate with FlyPostBack technology to retrieve the information from server-side. This topic will show you how to integrate WebScheduler with WebCallOut.

To integrate with WebCallOut

  1. Drag WebScheduler and WebCallOut controls to the WebForm.
  2. Create a custom resource using OnTimelineCustomResource WebScheduler's client-side events. In the following code, it will create resource and location template.
    JavaScript Copy Code
    function WebScheduler1_OnTimelineCustomResource(controlId, resourcesId)
{
   var WebScheduler1 = ISGetObject(controlId);

   var labelHeader1 = WebScheduler1.ClientFindResourceCustomControl("Header", "Label1");
   var labelHeader2 = WebScheduler1.ClientFindResourceCustomControl("Header", "Label2");

   labelHeader1.innerText = "Resource";
   labelHeader2.innerText = "Location";

   var resources = WebScheduler1.Resources;

   for (var i = 0; i < resourcesId.length; i++)
   {
      var label1 = WebScheduler1.ClientFindResourceCustomControl(resourcesId[i], "Label1");
      var label2 = WebScheduler1.ClientFindResourceCustomControl(resourcesId[i], "Label2");

      for (var j = 0; j < resources.length; j++)
      {
         if (resources[j].Resourceid == resourcesId[i])
         {
            label1.innertext = resources[j].ResourceName;
            label2.innerText = resources[j].Location;
            break;
         }
      }
   }
   return true;
}

  3. Create the following table in WebCallOut's content template.
    JavaScript Copy Code
    <ContentTemplate>
   <table style="width: 100%; height: 100%;" cellspacing="0" cellpadding="0">
      <tbody>
         <tr>
            <td style="vertical-align: middle; padding-right: 5px;">
               <asp:Image ID="imgPicture" runat="server" Width="50px" BorderColor="Black" BorderStyle="Solid"
                  BorderWidth="1px" Height="40px" />
            </td>
            <td>
               <table style="width: 100%; height: 100%; font-family: Segoe UI; font-size: 8pt;"
                  cellspacing="0" cellpadding="0">
                  <tr>
                     <td style="width: 60px;">
                        Country
                     </td>
                     <td>
                        :<asp:Label ID="lblCountry" runat="server" Text="Label"></asp:Label>
                     </td>
                  </tr>
                  <tr>
                     <td style="width: 60px;">
                        Capital
                     </td>
                     <td>
                        :<asp:Label ID="lblCapital" runat="server" Text="Label"></asp:Label>
                        <tr>
                           <td style="width: 60px;">
                              Time zone
                            </td>
                            <td>
                               :<asp:Label ID="lblTimeZone" runat="server" Text="Label"></asp:Label>
                            </td>
                         </tr>
               </table>
            </td>
         </tr>
      </tbody>
   </table>
</ContentTemplate>

  4. Use WebScheduler's Show server-side event to provide the information in WebCallOut when OnTheFlyPostBack is invoked.
    C# Copy Image Copy Code
    protected void WebCallOut1_Show(object sender, ISNet.WebUI.WebDesktop.WebCallOutEventDataArgs e)
{
   string selectedControlText = Request.Form["selectedControlText"].ToString();

   switch (selectedControlText)
   {
      case "London":
         imgPicture.ImageUrl = "./Images/england.jpg";
         lblCountry.Text = "England";
         lblCapital.Text = "London";
         lblTimeZone.Text = "GMT (UTC0)";
         break;
      case "Toronto":
         imgPicture.ImageUrl = "./Images/canada.jpg";
         lblCountry.Text = "Canada";
         lblCapital.Text = "Ottawa";
         lblTimeZone.Text = "Eastern (EST)(UTC-5)";
         break;
      case "Milan":
         imgPicture.ImageUrl = "./Images/italy.jpg";
         lblCountry.Text = "Italy";
         lblCapital.Text = "Rome";
         lblTimeZone.Text = "CET (UTC+1)";
         break;
   }
}

  5. Create WebCallOut's OnBeforeShow client-side event to invoke OnTheFlyPostBack, so that WebCallOut will retrieve the information from server-side.
    JavaScript Copy Image Copy Code
    function WebCallOut1_OnBeforeShow(controlId)
{
   var WebCallOut1 = ISGetObject(controlId);

   var selectedControl = WebCallOut1.TargetControlElement;

   WebCallOut1.AddInput("selectedControlText", selectedControl.innerText);
   return true;
}

  6. Create ShowWebCallOut and HideWebCallOut methods to show/hide WebCallOut.
    JavaScript Copy Image Copy Code
    function ShowWebCallOut(labelScheduler)
{
   var callOut = ISGetObject("WebCallOut1");
   var targetId = document.getElementById(labelScheduler.id);

   if (targetId.innerText != "Location")
   {
      callOut.TargetControlId = targetId.id;
      window.setTimeout(function() { callOut.ShowAutoDetect(targetId, true); }, 10);
   }
}

function HideCallOut(labelScheduler)
{
   var callOut = ISGetObject("WebCallOut1");
   callOut.Hide();
}

  7. Finally, invoke ShowWebCallOut() and HideWebCallOut() in ResourcesContentTemplate like following.
    JavaScript Copy Image Copy Code
    <ResourcesContentTemplate>
   <table cellpadding="0" cellspacing="0" style="padding: 2 2 2 2; width: 100%; height: 100%;
      font-family: Segoe UI; font-size: 8pt;">
      <tr>
         <td style="border-right: solid 1px #9199a4; width: 50%;">
            <asp:Label ID="Label1" runat="server" Text="Resource Name"></asp:Label>
         </td>
         <td>
            <asp:Label ID="Label2" runat="server" Text="Location" onmouseover="return ShowWebCallOut(this)"
               onmouseout="return HideCallOut(this)"></asp:Label>
         </td>
      </tr>
   </table>
</ResourcesContentTemplate>

  8. Run the project. The WebCallOut will appear with location's information when user hover to London, Toronto or Milan.

See Also

Tasks
How-to: Integrate with DesktopManager


Data Binding

Data Binding
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Data Binding

Glossary Item Box

Data Binding in WebScheduler.NET requires ISDataSource.NET a proprietary data source control from Intersoft Solutions.

This is the complete schema that must be available for WebScheduler.NET to work.

However the nice thing about WebScheduler.NET is that you can bind it to only Events table, removing all other tables if necessary. Follows are the list of tables and its usage in WebScheduler.NET processes:

  • Events Table
    A mandatory table, a must have even for the simplest case. This table holds all events that don't recur. You can change the field name and bind it properly as follows. If your table doesn't have some field, e.g. doesn't have Location, simply leave the LocationField to empty string.
<DataBinding>
    <EventsBinding AllDayEventField="AllDayEvent"
       CategoryIDField="CategoryID" DescriptionField="Description"
       EndTimeField="EndTime" EventIDField="ID" LocationField="Location"
       ModeField="Mode" ResourceIDField="ResourceID"
       StartTimeField="StartTime" SubjectField="Subject"
       ReminderTimeSpanField="ReminderTimeSpan"/>
</DataBinding>
  • Categories Table
    A master table that hold categories that can be applied to events, used to categorizing events.
    If this table isn't used (isn't bound) the categorizing events feature will be disabled.
<DataBinding>
   <CategoryBinding CategoryColorField="CategoryColor"
      CategoryIDField="ID" CategoryNameField="CategoryName"
      DescriptionField="Description" />
</DataBinding>
  • Resources Table
    A master table that hold resources of events. All events in WebScheduler.NET must resides in a resource. If this table isn't used (isn't bound), WebScheduler.NET will use a default resource to hold all the events.
<DataBinding>
   <ResourcesBinding DescriptionField="Description" LocationField="Location"
      ResourceColorField="ResourceColor"
      ResourceIDField="ID" ResourceNameField="ResourceName" />
</DataBinding>
  • Recurring Events & Recurrence Info
    Tables that used to store recurring events and its recurring info. Recurring Events table is basically the same as Events table, except for some new important fields such as Exception Info and Exception Date. This fields are used for supporting recurrence data processing concept.
<DataBinding>
   <RecurringEventsBinding AllDayEventField="AllDayEvent"
      CategoryIDField="CategoryID"
      DescriptionField="Description" EndTimeField="EndTime"
      EventIDField="ID" LocationField="Location"
      ModeField="Mode" ParentIDField="ParentID"
      RecurrenceIDField="RecurrenceID" ResourceIDField="ResourceID"
      StartTimeField="StartTime" SubjectField="Subject"
      ExceptionDateField="ExceptionDate"
      ExceptionInfoField="ExceptionInfo"
      ReminderTimeSpanField="ReminderTimeSpan"/>
   <RecurrenceBinding EndDateField="EndDate" ModeField="Mode"
      NYearField="NYear" NDayField="NDay"
      NMonthField="NMonth" NWeekField="NWeek" RangeModeField="RangeMode"
      RecurrenceIDField="ID"
      StartDateField="StartDate" TotalRecurrencesField="TotalRecurrences"
      WeekDaysField="WeekDays" />
</DataBinding>

In This Section

Data Operation

Single load vs Triple load

See Also

Tasks
{Walkthrough: Binding ISDataSource to WebScheduler}
{How-to Topics}

Other Resources
{Calendar Features}
General Feature
EditingForm


Data Operation

Data Operation
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Data Binding > Data Operation

Glossary Item Box

WebScheduler.NET requires ISDataSource.NET; therefore all data operation must go through ISDataSource.NET first. It is advisable to use the DataSet designer from Visual Studio.NET 2005 and Visual Studio.NET 2008 to produce a quick data source control.

Things that need to be noted are during insert operation. WebScheduler.NET requires an insert operation that returns the identity.

For example:

namespace DataTableAdapters
{
   public partial class EventsTableAdapter : Component
   {
      public virtual int Insert(int EventID, string CategoryID,
      Nullable<int> ResourceID, Nullable<int> Mode, string Subject,
      string Description, string Location, bool AllDayEvent,
      Nullable< DateTime> StartTime, Nullable< DateTime> EndTime,
      Nullable<int> ReminderTimeSpan)
      {
         this.Connection.Open();
         try
         {
            this.Insert(CategoryID, ResourceID, Mode, Subject,
            Description, Location, AllDayEvent, StartTime, EndTime,
            ReminderTimeSpan);

            OleDbCommand command = new OleDbCommand();
            command.CommandText = "SELECT @@IDENTITY";
            command.Connection = this.Connection;
            return (int)command.ExecuteScalar();
         }
         finally
         {
            this.Connection.Close();
         }
      }
   }
}

This code snippet a partial class from a DataSet auto generated code, where we can utilize all the methods that already auto generated from DataSets designer.

This approach is needed for all tables that included in data binding, and the code should be put in App_Code.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Single load vs Triple load}


Single load vs Triple load

Single load vs Triple load
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Data Binding > Single load vs Triple load

Glossary Item Box

There are two types of data retrieval in WebScheduler.NET, Triple load and Single load.

The Triple-load mode will pre-load the next and previous data along with the current data. With this approach user can see the data directly when they go to previous data and/or next data.

Unlike the Triple-load mode, the Single-load mode will only load the current data, this will reduce the traffic for first time load, but when user navigate to previous data and / or next data, they will need to wait for the data to be loaded prior the rendering process.

In This Section

How-to: Use singleLoadOnDemand

See Also

Tasks
{Walkthrough: Binding ISDataSource to WebScheduler}
{How-to: Enable AllowCollapse in calendar}
{How-to: AllowEdit in WebScheduler}
How-to Topics

Other Resources
Data Operation


How-to: Use SingleLoadOnDemand

How-to: Use SingleLoadOnDemand
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Data Binding > Single load vs Triple load > How-to: Use SingleLoadOnDemand

Glossary Item Box

By default, WebScheduler will use TripleLoad LoadOnDemand instead of SingleLoad. Unlike the TripleLoad, SingleLoad mode will only load the current data. The Triple-load mode will pre-load the next and previous data along with the current data.

In this topic, you will learn how to use both mode.

To use SingleLoadOnDemand

  1. Right click on WebScheduler's control and choose Properties.
  2. Set LoadOnDemandMode to SingleLoad.

To use TripleLoadOnDemand

  1. Right click on WebScheduler's control and choose Properties.
  2. Set LoadOnDemandMode to TripleLoad.
All the data will be cached temporaryly up to 12 slot using FIFO (First IN First OUT) concept. This applied to all views including calendar.

See Also

Tasks
{How-to: AllowEdit in WebScheduler}
How-to: Enable AllowCollapse in calendar
{Walkthrough: Binding ISDataSource to WebScheduler}
{How-to Topics}

Concepts
{Single load vs Triple load}


Calendar

Calendar
Send Feedback
Intersoft WebScheduler > Features and Concepts > Calendar

Glossary Item Box

This section contains information about built-in calendar in WebScheduler.NET.

In This Section

General Navigation

Navigation on each WebScheduler's view

Calendar Features

Holiday

Styles


General Navigation

General Navigation
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Calendar > General Navigation

Glossary Item Box

  • Back and forward
    Back and forward button will perform navigation according to the selected view.

  • Change calendar view
    Beside �??Month�?� calendar view, you can change the calendar view by clicking on the calendar header. There are 3 calendar views (�??Month�?�, �??Year�?�, and �??YearRange�?�). By default, if the SelectedViewMode (ViewSettings property) is Day, Week, Month or Agenda then the calendar�??s view will be �??Month�?� view. However, if the SelectedViewMode is Quarter, then the calendar�??s view will be �??Year�?� and if the SelectedViewMode is Year, the calendar�??s view will be �??YearRange�?�. You can change the calendar view by clicking on the calendar header. The exception for clicking the calendar header is when the SelectedViewMode in Quarter and Year view. In Quarter view, you cannot change the calendar�??s view to �??Month�?� and in Year view, you cannot change the calendar�??s view to �??Month�?� and �??Year�?�.

  • Change scheduler view from calendar
    In �??Month�?� calendar view, if you click the calendar�??s number, WebScheduler�??s view will automatically change to �??Day�?� view.

See Also

Other Resources
{Navigation on each WebScheduler's view}
{Calendar Features}
{Holiday}
Styles
{Categories}
{CallOut}
{General Feature}
{EditingForm}


Navigation on each WebScheduler's view

Navigation on each WebScheduler's view
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Calendar > Navigation on each WebScheduler's view

Glossary Item Box

  • Day View

      • Back
        Back calendar button in Day view will navigate to the previous day.

      • Forward
        Forward calendar button in Day view will navigate to the next day.

      • Change calendar view
        Clicking the calendar's header once will change the calendar's view to Year, clicking it twice will change the calendar's view to YearRange view, and the third click will change the calendar's view back to Month view.

  • Week View
        • Back
          Back calendar button in Week view will navigate to the previous week.

        • Forward
          Forward calendar button in Week view will navigate to the next week.

        • Change calendar view
          Clicking the calendar's header once will change the calendar's view to Year, clicking it twice will change the calendar's view to YearRange view, and the third click will change the calendar's view back to Month view.

  • Month View
        • Back
          Back calendar button in Month view will navigate to the previous month.

        • Forward
          Forward calendar button in Month view will navigate to the next month.

        • Change calendar view
          Clicking the calendar's header once will change the calendar's view to Year, clicking it twice will change the calendar's view to YearRange view, and the third click will change the calendar's view back to Month view.

  • Quarter View
        • Back
          Back calendar button in Quarter view will navigate to the previous quarter.

        • Forward
          Forward calendar button in Quarter view will navigate to the next quarter.

        • Change calendar view
          Clicking the calendar's header once will change the calendar's view to YearRange, and clicking it twice will change the calendar's view back to Year view.

  • Year View
        • Back
          Back calendar button will navigate to the previous 10 years.

        • Forward
          Forward calendar button will navigate to the next 10 years.

        • Change calendar view
          In Year view, you cannot change the calendar view.

  • Agenda View
        • Back
          Back calendar button will navigate to the previous month.

        • Forward
          Forward calendar button will navigate to the next month.

        • Change calendar view
          Clicking the calendar's header once will change the calendar's view to Year, clicking it twice will change the calendar's view to YearRange view, and the third will change the calendar's view back to Month view.

See Also

Other Resources
{General Navigation}
{Calendar Features}
{Holiday}
{Styles}
{Categories}
{CallOut}
{General Feature}
{EditingForm}


Calendar Features

Calendar Features
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Calendar > Calendar Features

Glossary Item Box

  • AllowCollapse
    WebScheduler allows you to determine whether or not you want to show the calendar(s) within a single mouse click.

  • FirstDayOfWeek
    One of the flexibility in WebScheduler's calendar is that you can specify your own first day of week. For instance, you want the calendar's first day of week is Monday instead of Sunday (the default behavior).

  • FirstWeekOfYear
    This feature is another flexibility of WebScheduler's calendar. You can determine when the first week should be counted. For instance, the first week of the year should be January, 1st.

  • HideCalendarInitially
    You can hide the calendar(s) from WebScheduler. With this property, you can show or hide the calendar on first load and at runtime. In order to achieve this scenario, you need to set HideCalendarInitially to True and AllowCollapse to True in CalendarSettings.

  • NumberOfMonthDisplayed
    By default, WebScheduler will show 3 calendars in the view. However, WebScheduler provides a way for you to determine the number of calendars that you wish to display. The maximum number of calendars in WebScheduler are 3.

  • MarkedDayWithEvents
    WebScheduler provides a friendly and interactive user interface. By looking at the calendars, you will know which day contains an event as it will be marked with bold style.

See Also

Tasks
How-to: Enable AllowCollapse in calendar
{How-to: Customize FirstDayOfWeek property}
{How-to: Customize FirstWeekOfYear property}
{How-to: Hide calendar initially}
{How-to: Customize NumberOfMonthDisplayed property}
{How-to: Customize MarkedDayWithEvents property}

Other Resources
{General Navigation}
{Navigation on each WebScheduler's view}
{Holiday}
{Styles}
{Categories}
{CallOut}
{General Feature}
{EditingForm}


How-to: Enable AllowCollapse in calendar

How-to: Enable AllowCollapse in calendar
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Calendar > Calendar Features > How-to: Enable AllowCollapse in calendar

Glossary Item Box

WebScheduler allows you to determine whether or not you want to show the calendar(s) within a single mouse click.

In this topic, you will learn how to enable AllowCollapse using WebScheduler's Properties.

To enable AllowCollapse

  1. Right click on WebScheduler's control and choose Properties.
  2. Expand CalendarSettings property.
  3. Set AllowCollapse to True and collapse calendar button will appear in view header.

See Also

Tasks
{How-to: Customize FirstDayOfWeek property}
{How-to: Customize FirstWeekOfYear property}
{How-to: Hide calendar initially}
{How-to: Customize NumberOfMonthDisplayed property}
{How-to: Customize MarkedDayWithEvents property}


How-to: Customize FirstDayOfWeek property

How-to: Customize FirstDayOfWeek property
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Calendar > Calendar Features > How-to: Customize FirstDayOfWeek property

Glossary Item Box

WebScheduler allows you to specify your own first day of week. For instance, you want the calendar's first day of week is Monday instead of Sunday (the default behavior).

In this topic, you will learn how to set FirstDayOfWeek from WebScheduler's Properties.

To customize FirstDayOfWeek property

  1. Right click on WebScheduler's control and choose Properties.
  2. Expand CalendarSettings property.
  3. Set FirstDayOfWeek to Thursday.

See Also

Tasks
{How-to: Enable AllowCollapse in calendar}
{How-to: Customize FirstWeekOfYear property}
{How-to: Hide calendar initially}
{How-to: Customize NumberOfMonthDisplayed property}
{How-to: Customize MarkedDayWithEvents property}


How-to: Customize FirstWeekOfYear property

How-to: Customize FirstWeekOfYear property
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Calendar > Calendar Features > How-to: Customize FirstWeekOfYear property

Glossary Item Box

WebScheduler allows you to determine when the first week should be counted.

In this topic, you will learn how to set FirstWeekOfYear from WebScheduler's properties.

To customize FirstWeekOfYear

  1. Right click on WebScheduler's control and choose Properties.
  2. Expand CalendarSettings property.
  3. Set FirstWeekOfYear to FirstFullWeek.

See Also

Tasks
{How-to: Enable AllowCollapse in calendar}
{How-to: Customize FirstDayOfWeek property}
{How-to: Hide calendar initially}
{How-to: Customize NumberOfMonthDisplayed property}
{How-to: Customize MarkedDayWithEvents property}


How-to: Hide calendar initially

How-to: Hide calendar initially
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Calendar > Calendar Features > How-to: Hide calendar initially

Glossary Item Box

You can show or hide the calendar in WebScheduler on first load and at runtime.

In this topic, you will learn how to show/hide calendar initially.

To hide calendar initially

  1. Right click on WebScheduler's control and choose Properties.
  2. Expand CalendarSettings property.
  3. Set HideCalendarInitially to True.

See Also

Tasks
{How-to: Enable AllowCollapse in calendar}
{How-to: Customize FirstDayOfWeek property}
{How-to: Customize FirstWeekOfYear property}
How-to: Customize NumberOfMonthDisplayed property
{How-to: Customize MarkedDayWithEvents property}


How-to: Customize NumberOfMonthDisplayed property

How-to: Customize NumberOfMonthDisplayed property
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Calendar > Calendar Features > How-to: Customize NumberOfMonthDisplayed property

Glossary Item Box

WebScheduler provides a way for you to determine the number of calendars that you wish to display.

In this topic, you will learn how to customize NumberOfMonthDisplayed from WebScheduler's property.

To customize NumberOfMonthDisplayed

  1. Right click on WebScheduler's control and choose Properties.
  2. Expand CalendarSettings property.
  3. Set NumberOfMonthDisplayed to 2.

See Also

Tasks
{How-to: Enable AllowCollapse in calendar}
{How-to: Customize FirstDayOfWeek property}
{How-to: Customize FirstWeekOfYear property}
{How-to: Hide calendar initially}
{How-to: Customize MarkedDayWithEvents property}


How-to: Customize MarkedDayWithEvents property

How-to: Customize MarkedDayWithEvents property
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Calendar > Calendar Features > How-to: Customize MarkedDayWithEvents property

Glossary Item Box

WebScheduler provides a way for user to know which day contains an event, so that it can be marked with bold style.

In this topic, you will learn how to customize MarkedDayWithEvents from WebScheduler's property.

To customize MarkedDayWithEvents property

  1. Right click on WebScheduler's control and choose Properties.
  2. Set MarkedDayWithEvents to True.

See Also

Tasks
{How-to: Enable AllowCollapse in calendar}
{How-to: Customize FirstDayOfWeek property}
{How-to: Customize FirstWeekOfYear property}
{How-to: Hide calendar initially}
{How-to: Customize NumberOfMonthDisplayed property}


How-to: Use Calendar in Custom Container

How-to: Use Calendar in Custom Container
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Calendar > Calendar Features > How-to: Use Calendar in Custom Container

Glossary Item Box

Calendar in the WebScheduler is tightly integrated, in the layout, functionality and behavior aspects, but it is actually a sub-component that is built upon loosely-coupled architecture, which can be easily taken out and even used independently.

In this topic, you will learn how to use calendar in custom container.

To use calendar in custom container

  1. Drag WebPaneManager control and create 2 panes which are Left and Right.
  2. Right click on the Left pane and choose Edit Template >> Content.
  3. Drag WebScheduler control into the content template.
  4. Bind WebScheduler to Access database. Right click on the pane and choose End Template Editing.
  5. On the Right pane, create a Div container (dvCalendarContainer) inside the content template.
    <ISWebDesktop:WebPane Name="Right" Text="Calendar" Width="Custom" WidthValue="170px">
   <ContentTemplate>
      <div id="dvCalendarContainer" style="height: 100%; width: 100%">
      </div>
   </ContentTemplate>
</ISWebDesktop:WebPane>
  6. Right click on WebScheduler control and choose Properties.
  7. Expand CalendarSettings. Set CustomContainerID to dvCalendarContainer and NumberOfMonthDisplayed to 2.
  8. Run the project.

See Also

Tasks
Walkthrough Topics
How-to Topics
How to: Hide calendar tooltip


Holiday

Holiday
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Calendar > Holiday

Glossary Item Box

By default, days will be considered as non-holiday. However, you can specify which day(s) in the calendar(s) that you would mark as holiday in Holidays property (this is a collection). If Holidays is specified then WebScheduler will automatically mark the day(s) as holiday according to the data collection that you have specified in the Holidays.

Holiday on WebScheduler's calendar will be set with HolidayStyle.

See Also

Other Resources
{General Navigation}
{Navigation on each WebScheduler's view}
{Calendar Features}
{Styles}
{Categories}
{CallOut}
{General Feature}
{EditingForm}


How-to: Specify holiday(s) in WebScheduler

How-to: Specify holiday(s) in WebScheduler
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Calendar > Holiday > How-to: Specify holiday(s) in WebScheduler

Glossary Item Box

WebScheduler allows you to specify which day in the calendar that you would mark as holiday.

In this topic, you will learn how to set holiday using WebScheduler's properties.

To specify holiday

  1. Right click on WebScheduler's control and choose Properties.
  2. Specify the holiday in Holidays property.

  3. Click OK.
IsGeneral property indicates whether the holiday will appear on the same date and same month, even though it is not the same year.

See Also

Tasks
{How-to: Enable animation in WebScheduler}
{How-to: Enable context menu in WebScheduler}
{How-to: Enable AllowCollapse in calendar}
{How-to Topics}

Concepts
{Holiday}


Styles

Styles
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Calendar > Styles

Glossary Item Box

Here are the styles in WebScheduler's Calendar:

  • CalendarFrameStyle
  • CalendarHeaderStyle
  • CalendarInboundCellStyle
  • CalendarOutboundCellStyle
  • CalendarSelectedCellStyle
  • CalendarTableStyle
  • CalendarTodayStyle
  • CalendarWeekNameStyle
  • CalendarWeekNumberStyle
  • HolidayStyle

See Also

Other Resources
{General Navigation}
{Navigation on each WebScheduler's view}
{Calendar Features}
{Holiday}
{Categories}
{CallOut}
{General Feature}
{EditingForm}


View

View
Send Feedback
Intersoft WebScheduler > Features and Concepts > View

Glossary Item Box

This section contains information about view modes in WebScheduler.NET.

In This Section

Day View

Week View

Month View

Quarter View

Year View

Agenda View


Day View

Day View
Send Feedback
Intersoft WebScheduler > Features and Concepts > View > Day View

Glossary Item Box

This section contains layout, styles and concept related to day view.

In This Section

Layout

Styles

Concept


Layout

Layout
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > View > Day View > Layout

Glossary Item Box

The day view shows one day at a time.

The areas in Day view are:

  • Header area
    The selected date will be displayed according to the DateFormatString property specified in ViewSettings-DayView category.

  • Day Header area, consists of two sections:
      1. Day Header
      2. All Day Event Area, where the all-day events of the day are displayed. User can easily add an all-day event using the callout that will be displayed when user selects this area. Note that the callout will only be displayed if adding event feature is enabled.

  • Content area
      1. Hour area
        This area is divided into 24 areas which indicate the hour of the area. The hour starts from 12 AM to 11 PM. The time format (12 hour or 24 hour) can be specified in TimeFormat property of ViewSettings category.
      2. Hour content area
        This area is divided into 48 areas that represent 30 minutes time interval area where time-based events are displayed according to its start time and duration. User can easily add a time-based event using the callout that will be displayed when user selects an hour content area. Note that the callout will only be displayed if adding event feature is enabled.
        If work days and work hours are specified, the hour content area will be rendered in different style according to the work hours.

See Also

Tasks
{How-to: Show/hide Day view tab in WebScheduler's ViewHeader}
{How-to: Customize FirstDayOfWeek property}
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Styles}
{Concept}


Styles

Styles
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > View > Day View > Styles

Glossary Item Box

Here are the styles in Day view:

  • SchedulerFrameStyle
  • SchedulerHeaderStyle
  • SchedulerTodayHeaderStyle
  • DayHeaderStyle
  • AllDayEventAreaStyle
  • SchedulerTodayAllDayEventAreaStyle
  • HourAreaStyle
  • GridLineStyle
      1. SoftLineStyle
      2. SolidLineStyle
      3. FrameLineStyle
      4. TodayFrameLineStyle
  • WorkHourStyle
  • NonWorkHourStyle
  • SelectedHourStyle
  • SchedulerTodayHourStyle

See Also

Tasks
{How-to: Show/hide Day view tab in WebScheduler's ViewHeader}
How-to: Customize FirstDayOfWeek property
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Layout}
{Concept}


Concept

Concept
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > View > Day View > Concept

Glossary Item Box

TaskTo navigate to the next day or previous day, Back and Forward navigation buttons can be used.

In Day view, only time-based event can be moved and resized. Due to the original concept of Day view where only one day is displayed, all-day events cannot be resized. The resize indicators are not displayed in all-day events, while it is displayed in time-based events. Note that the indicator will be displayed when the resizing and moving feature is enabled.

In Day view, the calendar will display Month calendar view. When user chooses a date in Calendar, the scheduler will navigate to the selected date. User can also click the calendar header to view Year and YearRange calendar views to easily navigate and select a date in calendar. User can only view Year and YearRange calendar views in the first calendar. The other calendars will be disabled.

See Also

Tasks
{How-to: Customize FirstDayOfWeek property}
{How-to: Show/hide Day view tab in WebScheduler's ViewHeader}
Walkthrough Topics
How-to Topics

Other Resources
{Layout}
{Styles}


Week View

Week View
Send Feedback
Intersoft WebScheduler > Features and Concepts > View > Week View

Glossary Item Box

This section contains layout, styles and concept related to week view.

In This Section

Layout

Styles

Concept


Layout

Layout
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > View > Week View > Layout

Glossary Item Box

The areas in Week view are:

  • Header area
    The selected date will be displayed according to the DateFormatString property specified in ViewSettings-WeekView category.

  • Day Header area, consists of two section:
      1. Day Header
      2. All Day Event Area, where the all-day events of the day are displayed. User can easily add an all-day event using the callout that will be displayed when user selects this area. Note that the callout will only be displayed if adding event feature is enabled.

  • Content area
      1. Hour area
        This area is divided into 24 areas which indicate the hour of the area. The hour starts from 12 AM to 11 PM. The time format (12 hour or 24 hour) can be specified in TimeFormat property of ViewSettings category.
      2. Hour content area
        This area is divided into 48 areas that represent 30 minutes time interval area where time-based events are displayed according to its start time and duration. User can easily add a time-based event using the callout that will be displayed when user selects an hour content area. Note that the callout will only be displayed if adding event feature is enabled.
        If work days and work hours are specified, the hour content area will be rendered in different style according to the work hours.

See Also

Tasks
{How-to: Show/hide Week view tab in WebScheduler's ViewHeader}
{How-to: Show week number in WebScheduler}
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Styles}
{Concept}


Styles

Styles
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > View > Week View > Styles

Glossary Item Box

Here are the styles in Week view:

  • SchedulerFrameStyle
  • SchedulerHeaderStyle
  • SchedulerTodayHeaderStyle
  • WeekOptionFrameStyle
  • DayHeaderStyle
  • AllDayEventAreaStyle
  • SchedulerTodayAllDayEventAreaStyle
  • HourAreaStyle
  • GridLineStyle
      1. SoftLineStyle
      2. SolidLineStyle
      3. FrameLineStyle
      4. TodayFrameLineStyle
  • WorkHourStyle
  • NonWorkHourStyle
  • SelectedHourStyle
  • SchedulerTodayHourStyle

See Also

Tasks
{How-to: Show week number in WebScheduler}
{How-to: Show/hide Week view tab in WebScheduler's ViewHeader}
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Layout}
{Concept}


Concept

Concept
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > View > Week View > Concept

Glossary Item Box

There are two options in Week view: Full week and Work week.

In Full week, user is able to view events in the full seven-day week.

In Work week, only the work days and the related events are displayed. User can choose whether to show work week or full week by clicking the week radio button. The work days can be specified in WorkWeekSettings property.

In Week view, only time-based events can be moved. However, both all-day events and time-based events can be resized. The resize indicators of all-day event will be displayed when the event�??s start date and end date is within the week range. Note that the indicator will be displayed when the resizing and moving feature is enabled.

In Week view, the calendar will display Month calendar view. Unlike Day view, when user selects a date, the week row will be highlighted and the scheduler will navigate to the selected date�??s week. Note that in Work week, only the work days are highlighted in calendar. User can also select the week by clicking on the week number.

User can click the calendar header to view Year and YearRange calendar views to easily navigate and select a date in the calendar. User can only view Year and YearRange calendar views in the first calendar. The other calendars will be disabled.

When Back and Forward button is clicked, the previous and the next week will be rendered according to the week options mode. User can also click the Day Header columns to navigate to that day in Day view.

See Also

Tasks
{How-to: Customize FirstWeekOfYear property}
{How-to: Show/hide Week view tab in WebScheduler's ViewHeader}
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Layout}
{Styles}


Month View

Month View
Send Feedback
Intersoft WebScheduler > Features and Concepts > View > Month View

Glossary Item Box

This section contains Navigation, styles and moving event related to month view.

In This Section

Navigation

Styles

Moving Event


Navigation

Navigation
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > View > Month View > Navigation

Glossary Item Box

  • Back
    Back button in WebScheduler will navigate WebScheduler to the previous month.

  • Forward
    Forward button in WebScheduler will navigate WebScheduler to the next month.

  • WebScheduler "Day" views
    When you click on DayHeader in MonthView, WebScheduler will switch to "Day" view.

  • WebScheduler "Week" views
    When you click on RowHeader (WeekNumber) in MonthView, WebScheduler will switch to "Week" view.

  • More event
    "More" link will appear in the day's cell in MonthView if the events of that day are more than 2. When you click "More" link, you will be provided with detail view about the events in that day.

See Also

Tasks
{How-to: Show range of month instead of week numbers in month view}
{How-to: Customize NumberOfMonthDisplayed property}
{How-to: Show/hide Month view tab in WebScheduler's ViewHeader}
{Walkthrough Topics}
{How-to Topics}

Other Resources
Moving Event
Styles


Moving Event

Moving Event
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > View > Month View > Moving Event

Glossary Item Box

WebScheduler also includes drag and drop ability. In MonthView, you can move the non- AllDayEvent event(s) only by dragging and dropping it to the other day.

See Also

Tasks
{How-to: Show range of month instead of week numbers in month view}
{How-to: Customize NumberOfMonthDisplayed property}
{How-to: Show/hide Month view tab in WebScheduler's ViewHeader}
{Walkthrough Topics}
{How-to Topics}

Other Resources
Navigation
Styles


Styles

Styles
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > View > Month View > Styles

Glossary Item Box

Here are the styles in WebScheduler"s Calendar:

  • MonthInboundCellStyle
  • MonthInboundDateHeaderStyle
  • MonthOutboundCellStyle
  • MonthOutboundDateHeaderStyle
  • MonthSelectedCellStyle
  • SchedulerTodayCellStyle
  • SchedulerTodayHeaderStyle
  • SchedulerFrameStyle
  • SchedulerHeaderStyle
  • YearMonthRowHeaderStyle

See Also

Tasks
{How-to: Show range of month instead of week numbers in month view}
How-to: Customize NumberOfMonthDisplayed property
{How-to: Show/hide Month view tab in WebScheduler's ViewHeader}
{Walkthrough Topics}
{How-to Topics}

Related Topics
{Navigation}
{Moving Event}


More links

More links
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > View > Month View > More links

Glossary Item Box

More links will be displayed in the day's cell if the events of that day can not be fully displayed due to the limited space of Month view layout. When the link is clicked, all the events of that day will be displayed in a detail view.

When clicked, the event will still be selected and the detail information of that event will be displayed in the callout.

See Also

Tasks
{How-to: Show range of month instead of week numbers in month view}
{Walkthrough Topics}
{How-to Topics}

Related Topics
Navigation
Moving Event
Styles


How-to: Show range of month instead of week numbers in month view

How-to: Show range of month instead of week numbers in month view
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > View > Month View > How-to: Show range of month instead of week numbers in month view

Glossary Item Box

WebScheduler allows you to show range of month instead of week numbers.

In this topic, you will learn how to show range of month in month view.

To show range of month

  1. Right click on WebScheduler's control and choose Properties.
  2. Set ShowWeekNumbers to False.

See Also

Tasks
{How-to: Customize NumberOfMonthDisplayed property}
{How-to: Show/hide Month view tab in WebScheduler's ViewHeader}
{Walkthrough Topics}
How-to Topics

Concepts
Navigation Month View
Moving Event Month View
Styles Month View


Quarter View

Quarter View
Send Feedback
Intersoft WebScheduler > Features and Concepts > View > Quarter View

Glossary Item Box

This section contains Navigation, styles and User Interface related to quarter view.

In This Section

Navigation

Styles

User Interface


Navigation

Navigation
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > View > Quarter View > Navigation

Glossary Item Box

  • Back
    Back button in quarter view will navigate to the previous quarter.

  • Forward
    Forward button in quarter view will navigate to the next quarter.

  • WebScheduler "Day" view
    When you click on DayHeader in QuarterView, WebScheduler will switch to "Day" view.

  • WebScheduler "Month" view
    When you click on RowHeader (month) in QuarterView, WebScheduler will switch to "Month" view.

See Also

Tasks
How-to: Show/hide Quarter view tab in WebScheduler's ViewHeader
{Walkthrough Topics}
{How-to Topics}

Other Resources
User Interface
SelectedWeekViewMode
Styles


User Interface

User Interface
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > View > Quarter View > User Interface

Glossary Item Box

Each event in Quarter view will have:

    • Event's background color
      The event's background color is using the resource's color. For instance, "Michael" (resource's color is green) then the event(s) that related to "Michael" will be green.

    • Event's Text
      The event's text describes how many event(s) that belong to 1 resource has on that day. For example, "Michael" has 2 events on March, 31th then the event will has 2 as the text.

    • Event's tooltip
      There are 2 behaviors in event's tooltip:
        1. The tooltip is set with the event's description.
          This behavior will be used if the amount of the event that belongs to 1 resource in that day is only 1.

        2. The tooltip is set with the event's amount
          This behavior will be used if the amount of the event that belongs to 1 resource in that day is more than 1.

In the above screen shot, the mouse hovered event is using the 2nd behavior.

See Also

Tasks
{How-to: Show/hide Quarter view tab in WebScheduler's ViewHeader}
{Walkthrough Topics}
{How-to Topics}

Other Resources
SelectedWeekViewMode
Navigation
Styles


SelectedWeekViewMode

SelectedWeekViewMode
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > View > Quarter View > SelectedWeekViewMode

Glossary Item Box

With a friendly and interactive user interface, WebScheduler provides a way to identify whether the days in the scheduler's view is either WorkHour or NonWorkHour by only looking at the scheduler's view.

By default, the SelectedWeekViewMode is set to FullWeek, this means that WebScheduler will set the days to work hour day initially, therefore all of the day will use WorkHourStyle. In order to activate the NonWorkHour on the day, you need to set SelectedWeekViewMode to WorkWeek. WebScheduler will determine whether or not the day should be worked hour day based on WorkWeekSettings.

See Also

Tasks
{How-to: Show/hide Quarter view tab in WebScheduler's ViewHeader}
{Walkthrough Topics}
{How-to Topics}

Other Resources
Navigation
User Interface
Styles


Styles

Styles
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > View > Quarter View > Styles

Glossary Item Box

Here are the styles in YearView and QuarterView

  • YearDayOfWeekStyle
  • SchedulerTodayCellStyle
  • SchedulerTodayHeaderStyle
  • SchedulerFrameStyle
  • SchedulerHeaderStyle
  • YearMonthRowHeaderStyle
  • WorkHourStyle
  • NonWorkHourStyle

See Also

Tasks
{How-to: Show/hide Quarter view tab in WebScheduler's ViewHeader}
{Walkthrough Topics}
{How-to Topics}

Other Resources
Navigation
User Interface
SelectedWeekViewMode


Year View

Year View
Send Feedback
Intersoft WebScheduler > Features and Concepts > View > Year View

Glossary Item Box

This section contains layout, styles and concept related to year view.

In This Section

Navigation

Styles

User Interface


Navigation

Navigation
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > View > Year View > Navigation

Glossary Item Box

  • Back
    In YearView, back button will navigate to the previous year.

  • Forward
    In YearView, forward button will navigate to the next year.

  • WebScheduler "Day" view
    When you click on DayHeader in YearView, WebScheduler will switch to "Day" view.

  • WebScheduler "Month" view
    When you click on RowHeader (month) in YearView, WebScheduler will switch to "Month" view.

See Also

Tasks
{How-to: Show/hide Year view tab in WebScheduler's ViewHeader}
{How-to: Set minimum height in Year View}
{Walkthrough Topics}
{How-to Topics}

Other Resources
User Interface
SelectedWeekViewMode
Styles


User Interface

User Interface
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > View > Year View > User Interface

Glossary Item Box

Each event in Year view will have:

  • Event's background color
    The event's background color is using the resource's color. For example, "Michael" (resource's color is green) then the event(s) that is related to "Michael" will be green.

  • Event's Text
    The event's text describes how many event(s) that belong to 1 resource has on that day. For example, "Michael" has 2 events on March, 31th then the event will has 2 as the text.

  • Event's tooltip
    There are 2 behaviors in event's tooltip:
      1. The tooltip is set with the event's description.
        This behavior will be used if the amount of the event that belongs to 1 resource in that day is only 1.

      2. The tooltip is set with the event's amount
        This behavior will be used if the amount of the event that belongs to 1 resource in that day is more than 1.

In the above screen shot, the mouse hovered event is using the 1st behavior.

See Also

Tasks
{How-to: Show/hide Year view tab in WebScheduler's ViewHeader}
{How-to: Set minimum height in Year View}
{Walkthrough Topics}
{How-to Topics}

Other Resources
Navigation
SelectedWeekViewMode
Styles


SelectedWeekViewMode

SelectedWeekViewMode
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > View > Year View > SelectedWeekViewMode

Glossary Item Box

With a friendly and interactive user interface, WebScheduler provides a way to identify whether the days in the scheduler's view is either WorkHour or NonWorkHour by only looking at the scheduler's view.

By default, the SelectedWeekViewMode is set to FullWeek, this means that WebScheduler will set the days to work hour day, therefore all of the day will use WorkHourStyle. In order to activate NonWorkHour on the day, you need to set SelectedWeekViewMode to WorkWeek. WebScheduler will determine whether or not the day should be worked hour day based on WorkWeekSettings.

See Also

Tasks
{How-to: Show/hide Year view tab in WebScheduler's ViewHeader}
{How-to: Set minimum height in Year View}
{Walkthrough Topics}
{How-to Topics}

Other Resources
Navigation
User Interface
Styles


Styles

Styles
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > View > Year View > Styles

Glossary Item Box

Here are the styles in YearView and QuarterView

  • YearDayOfWeekStyle
  • SchedulerTodayCellStyle
  • SchedulerTodayHeaderStyle
  • SchedulerFrameStyle
  • SchedulerHeaderStyle
  • YearMonthRowHeaderStyle
  • WorkHourStyle
  • NonWorkHourStyle

See Also

Tasks
{How-to: Show/hide Year view tab in WebScheduler's ViewHeader}
{How-to: Set minimum height in Year View}
{Walkthrough Topics}
{How-to Topics}

Other Resources
Navigation
User Interface
SelectedWeekViewMode


How-to: Set minimum height in Year View

How-to: Set minimum height in Year View
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > View > Year View > How-to: Set minimum height in Year View

Glossary Item Box

WebScheduler allows you to set minimum height in Year view.

In this topic, you will learn how to set minimum to 100px.

To set minimum height

  1. Right click on WebScheduler's control and choose Properties.
  2. Expands ViewSettings >> YearView.
  3. Set MinimumHeight to 100px.

See Also

Tasks
{How-to: Show/hide Year view tab in WebScheduler's ViewHeader}
{Walkthrough Topics}
{How-to Topics}

Concepts
Navigation Quater View
User Interface
{SelectedWeekViewMode}
Styles Quarter View


Agenda View

Agenda View
Send Feedback
Intersoft WebScheduler > Features and Concepts > View > Agenda View

Glossary Item Box

This section contains layout, styles and concept related to agenda view.

In This Section

Layout

Styles

Concept


Layout

Layout
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > View > Agenda View > Layout

Glossary Item Box

The areas in Agenda view are:

  • Header area
    The selected date will be displayed according to the DateFormatString property specified in ViewSettings - AgendaView category.
    The Agenda Action area consists of Expand All and Collapse All buttons. By default, the first three events will be expanded. If user clicks Expand All button, all the events will be expanded and when user clicks Collapse All button, all the events will be collapsed.

  • Content area
    1. Event date area, which displays the event date. The event date will use date format specified in ItemDateFormatString property.
    2. Event type area, which displays the event type. All-day event is indicated by a box, while time-based event is indicated by the event's start time. Both types will be rendered using the event's resource color.
    3. Event detail area, which displays the event detail, such as subject, start and end time, location, description, and other details.

See Also

Tasks
{How-to: Show/hide Agenda view tab in WebScheduler's ViewHeader}
{Walkthrough Topics}
{How-to Topics}

Other Resources
Styles
Concept


Styles

Styles
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > View > Agenda View > Styles

Glossary Item Box

Here are the styles in Week view:

  • SchedulerFrameStyle
  • SchedulerHeaderStyle
  • AgendaActionStyle
  • AgendaAlternativeRowStyle
  • AgendaRowStyle
  • AgendaDateColumnStyle

See Also

Tasks
{How-to: Show/hide Agenda view tab in WebScheduler's ViewHeader}
{Walkthrough Topics}
{How-to Topics}

Other Resources
Layout
Concept


Concept

Concept
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > View > Agenda View > Concept

Glossary Item Box

Agenda view lists the events detail in paging mode. Each page will display max 10 events. When Back and Forward button is clicked, the selected date will be modified to the previous or the next date and 10 events starting from the selected date will be displayed.

In Agenda view, the calendar will display Month calendar view. When user chooses a date in Calendar, the scheduler will navigate to the selected date. User can also click the calendar header to view Year and YearRange calendar views to easily navigate and select a date in calendar. User can only view Year and YearRange calendar views in the first calendar. The other calendars will be disabled.

When user clicks the event's date, WebScheduler will navigate to the selected date in Day view. When user clicks the event's subject, the event detail at the bottom will either be collapsed or expanded.

Due to the original purpose of Agenda view, which is to list the events detail, the events cannot be moved or resized. User can edit or delete the event by clicking Edit Event or Delete Event buttons respectively. User can also click View on my calendar button to navigate to the event's date in Day view. Note that Edit Event and Delete Event buttons will be displayed when the features are enabled.

See Also

Tasks
{How-to: Show/hide Agenda view tab in WebScheduler's ViewHeader}
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Layout}
{Styles}


WorkWeekSettings

WorkWeekSettings
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > WorkWeekSettings

Glossary Item Box

User can define the work days and work hour in WebScheduler. When specified, the non work hours will be rendered using different styles.

In WorkWeekSettings, user can specify the start time and end time of work hours. By default, the start time is set to 8 AM and end time is set to 5 PM. Using this configuration, the hours which is not included as work hours, will be considered as non work hours. This configuration can be seen in Day view and Week view. Note the difference between the following two screenshots to show how WebScheduler differentiate between work hour and non work hour.

The above screenshot shows the work hours in full week mode of Week view.

The above screenshot shows the work hours in work week mode of Week view. In Work week view mode, only the work days are displayed.

In WorkWeekSettings, user can specify which days are work days and vice versa. By default, Sunday and Saturday are set to non work days. In Default style, the non work hours will be rendered in darker color compared to work hours. This configuration can be seen in Day view, Week view, Quarter view and Year view.

The styles can be configured in WorkHourStyle and NonWorkHourStyle.

In This Section

How-to: Enable and specify work week in WebScheduler

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}


How-to: Enable and specify work week in WebScheduler

How-to: Enable and specify work week in WebScheduler
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > WorkWeekSettings > How-to: Enable and specify work week in WebScheduler

Glossary Item Box

WebScheduler allows user to define the work days and work hour.

In this topic, you will learn how to enable and specify work week.

To enable work week

  1. Right click on WebScheduler's control and choose Properties.
  2. Modify WebScheduler's work week in WorkWeekSettings property.

  3. To enable the new work week setting, set SelectedWeekViewMode to WorkWeek. You can find SelectedWeekViewMode property in ViewSettings.
  4. The result is like following:

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Concepts
{WorkWeekSettings}


Events

Events
Send Feedback
Intersoft WebScheduler > Features and Concepts > Events

Glossary Item Box

This section contains events in WebScheduler.NET.

In This Section

Time-based event vs All-day Event

Recurring Events

Overlapping Concept

Caching Mechanism

Styles


Time-based Event vs All-day Event

Time-based Event vs All-day Event
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Events > Time-based Event vs All-day Event

Glossary Item Box

Events in WebScheduler can be divided into two types:

  • Time-based Event
  • All-day Event

Time-based Event

Events that fall into this category are events that have start time and end time within the same day.

For example:
[Time-based Event]
Start Time : February 5th 2008, 7.30 AM
End Time : February 5th 2008, 8.30 AM

In Day View and Week View

In Day View and Week View, a time-based event will be placed in the hour content area. User can move a time-based event to a specific day and / or time by dragging the item into a specific position.

When the item is being drag, the opacity of the item will be lower like the picture above, indicating where the position will be when it is dropped.
User can also resize the item to controls its time-range / duration, by dragging the resize-indicator at the bottom of the item.

When the item is being resized, the opacity of the item will be lowered too as in the picture above, indicating the time-range / duration when it is dropped.

In Month View

In Month View due to the nature of month view, user can't resize the time-range / duration of an item. However user can still move the item from one day to another day by drag-drop from one cell to another cell as follows.

We move item from February 5th 2008 to February 12th 2008. The start time and time-range / duration remain the same, only the date is changed.

In Agenda View

In Agenda View, user will see something like the picture above (the item is in expanded mode). User can collapse or expand the item by clicking the event's subject.

In collapse mode it will look as follows:

For time-based event, the item will show the start-time of that item in the header. In this case it show 07:30 AM, because the start time of the event is 07:30 AM.

As you can see there are three action buttons at the bottom of the item (when the item is expanded), they are:

  • Delete Event button
    Delete the event from all views
  • Edit Event button
    Edit the event (showing the editing form)
  • View on my calendar
    Go to Day-View mode that contains the item

All-day Event

Events that fall into this category are events that marked as an all-day event or an event that has end date larger than start date.

For example:
[All-day Event 1]
Start Time : February 6th 2008
End time : February 6th 2008
AllDayEvent : true
[All-day Event 2]
Start Time : February 6th 2008, 05.30 AM
End Time : February 7th 2008, 08.30 AM
AllDayEvent : false

In Day View and Week View

In Day View and Week View, an all-day event will be placed in the all-day event area. However, only in Week view, user can resize all-day event. User can resize the time-range or duration of specific event by dragging the left and / or right indicator of the event.

If the event's start time is beyond the current view's date range, the indicator will not be displayed. Therefore user will not be able to resize it. The same thing applied when the event's end time is beyond the current view's date range, the indicator will not be displayed too.

In Month View

In Month View user can't perform any action to an all-day event. When the time-range is quite large it will be expanded to other rows as follow.

In Agenda View

In Agenda View, user will see something like the picture above (the item is in expanded mode). User can collapse or expand the item by clicking the header of the item.

In collapse mode, it will look as follows:

For all-day event, the item will show a square indicating that the item is an all day event item.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Recurring Events}
{Overlapping Concept}
{Caching Mechanism}
{Styles}


Recurring Events

Recurring Events
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Events > Recurring Events

Glossary Item Box

WebScheduler.NET also supports a recurring event. There are five types of recurrence that supported by WebScheduler.NET:

  • Daily [Every x days]
  • Daily [Every week days]
  • Weekly
  • Monthly
  • Yearly

Daily [Every x days]

In Daily [Every x days], the event will recur every x days starting from the original event's start time.

Daily [Every week days]

In Daily [Every week days], the event will recur every week day starting from the original event's start time. Days that are categorized as week days are Monday, Tuesday, Wednesday, Thursday and Friday.

Weekly

In Weekly recurrence pattern, you can determine on what day that the event will recur. You can also specify when it will recur (every x weeks).

Monthly

In Monthly recurrence pattern, you can determine on what day and every what month the event will recur.

Yearly

In Yearly recurrence pattern, you can determine on what specific day and month the event will recur every year.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Time-based Event vs All-day Event}
{Overlapping Concept}
{Caching Mechanism}
{Styles}


Overlapping Concept

Overlapping Concept
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Events > Overlapping Concept

Glossary Item Box

WebScheduler.NET offers sophisticated overlapping resolution. When some events overlapped each other, WebScheduler.NET�??s rendering engine will sort-out an overlapping resolution so all the events can still be visible.

Day View and Week View

This is a sample result when we placed some events that overlapped each other in day view.

Month View

In month view, all the events in a specific day will be placed in one cell. If the events is quite large (larger than the space available, there will be a more button where user can use to show all the events.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Time-based Event vs All-day Event}
{Recurring Events}
{Caching Mechanism}
{Styles}


Caching Mechanism

Caching Mechanism
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Events > Caching Mechanism

Glossary Item Box

When a data is loaded, it will be saved in temporary cache. The cache is differentiated per view, and each cache per-view will hold up to twelve block of data as illustrated below.

Day View | [2008.01.01] [2008.01.02] [2008.05.05] [2008.05.06] [2008.07.07] [2008.07.11] [2008.08.15] [2008.09.20] [2008.11.21] [2008.11.22] [2008.11.23] [2008.11.24]
Week View | {Empty}
Month View | [2008.03] [2008.04] [2008.05]
Quarter View | {Empty}
Year View | {Empty}
Agenda View | {Empty}

When a new event is loaded up and the cache is already full (12 items already), the first item in the cache will be discarded, following a concept of FIFO (First In First Out).

During some data editing process, there will be a smart cache validation that will also update the data on other cache or will invalidate the caches.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Recurring Events}
{Time-based Event vs All-day Event}
{Overlapping Concept}
{Styles}


Styles

Styles
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Events > Styles

Glossary Item Box

The style used in All-day event is AllDayEventStyle.
Here are the styles used in time-based event (TimeBasedEventStyle):

  • HeaderStyle
  • ContentStyle

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Time-based Event vs All-day Event}
{Recurring Events}
{Overlapping Concept}
{Caching Mechanism}


Categories

Categories
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Categories

Glossary Item Box

You can specify a single category or multiple categories of each event in WebScheduler. The category exception is in Quarter and Year view, in both of the views the event(s) will not be visible.

No Category

Single Category

Multiple Categories

Manage category

The category management (add, edit and delete) is accessed through WebScheduler's EditingForm. You can also set category to the event through context menu (right click on event).

Before setting category to the event that you want, you should specify / add your desired category as WebScheduler does not provide initial / default category.

Set multiple categories
In order to set multiple categories to the event, simply select more than 1 category in the EditingForm categories'combo or alternatively, you can select the category one by one through context menu.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
General Navigation
{Navigation on each WebScheduler's view}
{Calendar Features}
{Holiday}
{Styles}
{Categories}
{CallOut}
{General Feature}
{EditingForm}


CallOut

CallOut
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > CallOut

Glossary Item Box

One of the essential things in WebScheduler is CallOut. WebScheduler is using CallOut for displaying detail information and data editing (add, edit and delete).

  • AutoDetect
    CallOut has the ability to automatically determine its position base on user click position. Developer will not need to worry about where the CallOut should appear, is there an enough space to show the CallOut, etc.

  • EditingField
    The flexibility of this CallOut is that you can specify / modify the CallOut's field and text through EditingField property.

  • When CallOut will be shown
      • Clicking on WebScheduler's cell in Day, Week and Month view.
        In this situation, you can add a new event or open EditingForm through CallOut.
      • Clicking on WebScheduler's event in Day, Week and Month view.
        In this situation, you can edit or delete the event.

  • Styles
    Here are the styles uses in CallOut
      • EditingButtonStyle
      • EditingTextStyle

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{General Navigation}
{Navigation on each WebScheduler's view}
{Calendar Features}
{Holiday}
{Styles}
{Categories}
{General Feature}
{EditingForm}


General Feature

General Feature
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > General Feature

Glossary Item Box

  • EnableAnimation
    This is another flexibility of CallOut, instead of having fade-in and fade-out animation. You can disable the animation, simply by setting the EnableAnimation property to False.

  • EnableContextMenu
    With ContextMenu, you can have another way of navigation to add, edit or delete event(s), go to the "selected day" event in Day view, go to "today" event in Day view and set category(s) to the selected event. Simply by setting the EnableContextMenu to True and right click on WebScheduler cell / event in Day, Week and Month view, the ContextMenu will appear.

  • ShowWeekNumber
    This feature provides you a way to determine whether or not you want to show the WeekNumbers in calendar(s) and scheduler.

  • General Styles
    Note:
    • Today's cell in Day and Week view is using TodayFrameLineStyle (GridLineStyle).
    • SchedulerTodayCellStyle is applied for Month, Quarter and Year's today cell only.
    • YearMonthRowHeaderStyle is applied for Month, Quarter and Year's RowHeader only.

      MonthRowHeader

      QuarterRowHeader

      YearRowHeader

  • ImagesSettings
    In WebScheduler, ImagesSettings property provides a way for developer to design virtually any kind of image(s) or styles as a significant added value for end user experience.

  • Note:
      • BlackReminder, BlackRecurrence and BlackRecurrenceException images are used in Agenda view only.
      • Reminder, Recurrence and RecurrenceException images are used in Day, Week and Month view's event only.

In This Section

How-to: Enable animation in WebScheduler

How-to: Enable context menu in WebScheduler

How-to: Show week number in WebScheduler

How-to: Refresh view in WebScheduler at runtime

How-to: Print in WebScheduler at runtime

How-to: Show/hide Day view tab in WebScheduler's ViewHeader

How-to: Show/hide Week view tab in WebScheduler's ViewHeader

How-to: Show/hide Month view tab in WebScheduler's ViewHeader

How-to: Show/hide Quarter view tab in WebScheduler's ViewHeader

How-to: Show/hide Year view tab in WebScheduler's ViewHeader

How-to: Show/hide Agenda view tab in WebScheduler's ViewHeader

How-to: Enable/disable HighlightTodayDate in WebScheduler's view

How-to: Enable/disable AllowCreateEventInHoldiay

See Also

Other Resources
{General Navigation}
{Navigation on each WebScheduler's view}
{Calendar Features}
{Holiday}
{Styles}
{Categories}
{CallOut}
{EditingForm}


How-to: Enable animation in WebScheduler

How-to: Enable animation in WebScheduler
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > General Feature > How-to: Enable animation in WebScheduler

Glossary Item Box

WebScheduler's CallOut provides a fade-in and fade-out animation.

In this topic, you will learn how to enable animation using WebScheduler's properties.

To Enable animation

  1. Right click on WebScheduler's control and choose Properties.
  2. Set EnableAnimation to True.

See Also

Tasks
{How-to: Enable contect menu in WebScheduler}
{How-to: Show week number in WebScheduler}
{How-to: Refresh view in WebScheduler at runtime}
{How-to: Print in WebScheduler at runtime}
{Walkthrough Topics}
{How-to Topics}

Concepts
{General Feature}


How-to: Enable context menu in WebScheduler

How-to: Enable context menu in WebScheduler
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > General Feature > How-to: Enable context menu in WebScheduler

Glossary Item Box

With WebScheduler's context menu, you can have another way of navigation to add, edit or delete event(s), go to the "selected day" event in Day view, go to "today" event in Day view and set category(s) to the selected event.

In this topic, you will learn how to enable context menu using WebScheduler's properties.

To enable context menu

  1. Right click on WebScheduler's control and choose Properties.
  2. Set EnableContextMenu to True.

See Also

Tasks
{How-to: Enable animation in WebScheduler}
{How-to: Show week number in WebScheduler}
{How-to: Refresh view in WebScheduler at runtime}
{How-to: Print in WebScheduler at runtime}
{Walkthrough Topics}
{How-to Topics}

Concepts
{General Feature}


How-to: Show week number in WebScheduler

How-to: Show week number in WebScheduler
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > General Feature > How-to: Show week number in WebScheduler

Glossary Item Box

WebScheduler provides a way to determine whether the WeekNumbers in calendar(s) and scheduler are displayed.

In this topic, you will learn how to show week number using WebScheduler's properties.

To show week number

  1. Right click on WebScheduler's control and choose Properties.
  2. Set ShowWeekNumbers to True.

See Also

Tasks
{How-to: Enable animation in WebScheduler}
{How-to: Enable context menu in WebScheduler}
{How-to: Refresh view in WebScheduler at runtime}
{How-to: Print in WebScheduler at runtime}
{Walkthrough Topics}
How-to Topics

Concepts
{General Feature}


How-to: Refresh view in WebScheduler at runtime

How-to: Refresh view in WebScheduler at runtime
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > General Feature > How-to: Refresh view in WebScheduler at runtime

Glossary Item Box

WebScheduler allows you to refresh during runtime.

In this topic, you will learn how to resfresh WebScheduler's view at runtime.

To refresh WebScheduler's view

  1. During runtime, you can click on WebScheduler's menu.
  2. Click on "Refresh View" to refresh WebScheduler's view.

See Also

Tasks
{How-to: Enable animation in WebScheduler}
{How-to: Enable context menu in WebScheduler}
{How-to: Show week number in WebScheduler}
{How-to: Print in WebScheduler at runtime}
{Walkthrough Topics}
{How-to Topics}

Concepts
{General Feature}


How-to: Print in WebScheduler at runtime

How-to: Print in WebScheduler at runtime
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > General Feature > How-to: Print in WebScheduler at runtime

Glossary Item Box

WebScheduler allows you to print during runtime.

In this topic, you will learn how to print WebScheduler.

To print WebScheduler's view in runtime

  1. In runtime, you can click on WebScheduler's menu
  2. Click on "Print" to print the WebScheduler's view in that time.

See Also

Tasks
{How-to: Enable animation in WebScheduler}
{How-to: Enable context menu in WebScheduler}
{How-to: Show week number in WebScheduler}
{How-to: Refresh view in WebScheduler at runtime}
{Walkthrough Topics}
{How-to Topics}

Concepts
{General Feature}


How-to: Show/hide Day view tab in WebScheduler's ViewHeader

How-to: Show/hide Day view tab in WebScheduler's ViewHeader
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > General Feature > How-to: Show/hide Day view tab in WebScheduler's ViewHeader

Glossary Item Box

WebScheduler allows you to show/hide day view tab in WebScheduler's ViewHeader.

In this topic, you will learn how to hide day view tab.

To hide Day view

  1. Right click on WebScheduler's control and choose Properties.
  2. Expands ViewSettings >> DayView.
  3. Set Enabled to False.

See Also

Tasks
{How-to: Show/hide Week view tab in WebScheduler's ViewHeader}
{How-to: Show/hide Month view tab in WebScheduler's ViewHeader}
{How-to: Show/hide Quarter view tab in WebScheduler's ViewHeader}
{How-to: Show/hide Year view tab in WebScheduler's ViewHeader}
{How-to: Show/hide Agenda view tab in WebScheduler's ViewHeader}
{Walkthrough Topics}
{How-to Topics}

Concepts
{General Feature}


How-to: Show/hide Week view tab in WebScheduler's ViewHeader

How-to: Show/hide Week view tab in WebScheduler's ViewHeader
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > General Feature > How-to: Show/hide Week view tab in WebScheduler's ViewHeader

Glossary Item Box

askWebScheduler allows you to show/hide week view tab in WebScheduler's ViewHeader.

In this topic, you will learn how to hide week view tab.

To hide Week view

  1. Right click on WebScheduler's control and choose Properties.
  2. Expands ViewSettings >> WeekView.
  3. Set Enabled to False.

See Also

Tasks
{How-to: Show/hide Day view tab in WebScheduler's ViewHeader}
{How-to: Show/hide Month view tab in WebScheduler's ViewHeader}
{How-to: Show/hide Quarter view tab in WebScheduler's ViewHeader}
{How-to: Show/hide Year view tab in WebScheduler's ViewHeader}
{How-to: Show/hide Agenda view tab in WebScheduler's ViewHeader}
{Walkthrough Topics}
{How-to Topics}

Concepts
{General Feature}


How-to: Show/hide Month view tab in WebScheduler's ViewHeader

How-to: Show/hide Month view tab in WebScheduler's ViewHeader
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > General Feature > How-to: Show/hide Month view tab in WebScheduler's ViewHeader

Glossary Item Box

WebScheduler allows you to show/hide month view tab in WebScheduler's ViewHeader.

In this topic, you will learn how to hide month view tab.

To hide Month view

  1. Right click on WebScheduler's control and choose Properties.
  2. Expands ViewSettings >> MonthView.
  3. Set Enabled to False.

See Also

Tasks
How-to: Show/hide Day view tab in WebScheduler's ViewHeader
{How-to: Show/hide Week view tab in WebScheduler's ViewHeader}
{How-to: Show/hide Quarter view tab in WebScheduler's ViewHeader}
{How-to: Show/hide Year view tab in WebScheduler's ViewHeader}
{How-to: Show/hide Agenda view tab in WebScheduler's ViewHeader}
{Walkthrough Topics}
{How-to Topics}

Concepts
{General Feature}


How-to: Show/hide Quarter view tab in WebScheduler's ViewHeader

How-to: Show/hide Quarter view tab in WebScheduler's ViewHeader
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > General Feature > How-to: Show/hide Quarter view tab in WebScheduler's ViewHeader

Glossary Item Box

WebScheduler allows you to show/hide quarter view tab in WebScheduler's ViewHeader.

In this topic, you will learn how to hide quarter view tab.

To hide Quarter view

  1. Right click on WebScheduler's control and choose Properties.
  2. Expands ViewSettings >> QuarterView.
  3. Set Enabled to False.

See Also

Tasks
{How-to: Show/hide Day view tab in WebScheduler's ViewHeader}
{How-to: Show/hide Week view tab in WebScheduler's ViewHeader}
{How-to: Show/hide Month view tab in WebScheduler's ViewHeader}
{How-to: Show/hide Year view tab in WebScheduler's ViewHeader}
{How-to: Show/hide Agenda view tab in WebScheduler's ViewHeader}
{Walkthrough Topics}
{How-to Topics}

Concepts
{General Feature}


How-to: Show/hide Year view tab in WebScheduler's ViewHeader

How-to: Show/hide Year view tab in WebScheduler's ViewHeader
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > General Feature > How-to: Show/hide Year view tab in WebScheduler's ViewHeader

Glossary Item Box

WebScheduler allows you to show/hide year view tab in WebScheduler's ViewHeader.

In this topic, you will learn how to hide year view tab.

To hide Year view

  1. Right click on WebScheduler's control and choose Properties.
  2. Expands ViewSettings >> YearView.
  3. Set Enabled to False.

See Also

Tasks
{How-to: Show/hide Day view tab in WebScheduler's ViewHeader}
{How-to: Show/hide Week view tab in WebScheduler's ViewHeader}
{How-to: Show/hide Month view tab in WebScheduler's ViewHeader}
{How-to: Show/hide Quarter view tab in WebScheduler's ViewHeader}
{How-to: Show/hide Agenda view tab in WebScheduler's ViewHeader}
{Walkthrough Topics}
{How-to Topics}

Concepts
{General Feature}


How-to: Show/hide Agenda view tab in WebScheduler's ViewHeader

How-to: Show/hide Agenda view tab in WebScheduler's ViewHeader
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > General Feature > How-to: Show/hide Agenda view tab in WebScheduler's ViewHeader

Glossary Item Box

WebScheduler allows you to hide agenda view tab in WebScheduler's ViewHeader.

In this topic, you will learn how to hide agenda view tab.

To hide Agenda view

  1. Right click on WebScheduler's control and choose Properties.
  2. Expands ViewSettings >> AgendaView.
  3. Set Enabled to False.

See Also

Tasks
{How-to: Show/hide Day view tab in WebScheduler's ViewHeader}
{How-to: Show/hide Week view tab in WebScheduler's ViewHeader}
{How-to: Show/hide Month view tab in WebScheduler's ViewHeader}
{How-to: Show/hide Quarter view tab in WebScheduler's ViewHeader}
{How-to: Show/hide Year view tab in WebScheduler's ViewHeader}
{Walkthrough Topics}
{How-to Topics}

Concepts
{General Feature}


How-to: Enable/disable HighlightTodayDate in WebScheduler's view

How-to: Enable/disable HighlightTodayDate in WebScheduler's view
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > General Feature > How-to: Enable/disable HighlightTodayDate in WebScheduler's view

Glossary Item Box

WebScheduler allows you to enable/disable HighlightTodayDate in WebScheduler's ViewHeader.

In this topic, you will learn how to disable HighlightTodayDate.

To disable HighlightTodayDate

  1. Right click on WebScheduler's control and choose Properties.
  2. Expands ViewSettings.
  3. Set HighlightTodayDate to False.

See Also

Tasks
{How-to: Enable/disable AllowCreateEventInHoliday}
Walkthrough Topics
{How-to Topics}

Concepts
{General Feature}


How-to: Enable/disable AllowCreateEventInHoliday

How-to: Enable/disable AllowCreateEventInHoliday
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > General Feature > How-to: Enable/disable AllowCreateEventInHoliday

Glossary Item Box

WebScheduler allows you to enable/disable AllowCreateEventHoliday in WebScheduler.

In this topic, you will learn how to hide AllowCreateEventHoliday.

To hide AllowCreateEventHoliday

  1. Right click on WebScheduler's control and choose Properties.
  2. Set AllowCreateEventHoliday to False.

See Also

Tasks
{How-to: Enable/disable HighlightTodayDate in WebScheduler's view}
{Walkthrough Topics}
{How-to Topics}

Concepts
{General Feature}


How-to: Set initial date and time

How-to: Set initial date and time
Send Feedback
Intersoft WebScheduler > Features and Concepts > General Feature > How-to: Set initial date and time

Glossary Item Box

WebScheduler allows user to specify the initial WebScheduler's date and time.

This topic will show you how to set initial date and time.

Set initial date and time

  1. Right click on WebScheduler control and choose Properties.
  2. Expand ViewSettings. Set SelectedDate to any date you want to display initially when WebScheduler loads.
  3. Set TimeFormat to either Format24Hours or Format12Hours.
  4. Run the project.


How-to: Customize DateTime Format in specific view

How-to: Customize DateTime Format in specific view
Send Feedback
Intersoft WebScheduler > Features and Concepts > General Feature > How-to: Customize DateTime Format in specific view

Glossary Item Box

Every view settings in WebScheduler has the ability to customize DateTime Format.

This topic will show you how to customize DateTime Format in specific view.

To customize DateTime Format

  1. Right click on WebScheduler control and choose Properties.
  2. Expand ViewSettings. We have AgendaView, DayView, MonthView, QuarterView and many others.
  3. Expand each view and set DateFormatString to any date format you want.
  4. Run the project.


How-to: Select Multiple Cells

How-to: Select Multiple Cells
Send Feedback
Intersoft WebScheduler > Features and Concepts > General Feature > How-to: Select Multiple Cells

Glossary Item Box

Multiple cell selection is supported in various views, such as Day (normal and Split view), Week, Month, and Timeline view. When enabled, you can block a range of cells and add a new event within the date range.

This topic will show you how to select multiple cells.

To select multiple cells

  1. Right click on WebScheduler control and choose Properties.
  2. Set EnableMultipleCellSelection to True.
  3. Run the project. In this case, you will be able to select multiple cells and add a new event within the date range.


Editing

Editing
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Editing

Glossary Item Box

WebScheduler's editing function is performed using FlyPostBack™ architecture which invented by Intersoft Solutions. Using FlyPostBack™ technology, WebScheduler.NET performs editing with less resource consumption and we do not need to wait so long for page refresh or Postback in order to manipulate or update information to the database, even WebScheduler does not perform FullPostBack at all.

WebScheduler renders only the added or modified information or event and updates to the physical database transparently. The editing in WebScheduler is using the FlyPostBack™.

The editing functionality can be easily activated by setting:

  1. AllowAdd
    Indicate whether WebScheduler can add an event.

  2. AllowEdit
    Indicate whether WebScheduler can edit an event.

  3. AllowDelete
    Indicate whether WebScheduler can delete an event.

  4. AllowMove
    Indicate whether WebScheduler can move an event.

  5. AllowResize
    Indicate whether WebScheduler can add an event.

In This Section

How-to: AllowEdit in WebScheduler

How-to: AllowAdd in WebScheduler

How-to: AllowDelete in WebScheduler

How-to: AllowMove in WebScheduler

How-to: AllowResize in WebScheduler

How-to: Customize EditingField

How-to: Set EditingUrl in WebScheduler

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{EditingForm}


EditingForm

EditingForm
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Editing > EditingForm

Glossary Item Box

WebScheduler's EditingForm is an independent form integrated to WebScheduler. Therefore, in order to be recognized, you should specify the EditingForm's url in EditingUrl property.

WebScheduler's Editing Form is entirely powered by the company's flagship WebUI Studio.NET components to deliver the most sophisticated user interface for editing experience. From the design, look and feel perspective, WebScheduler's Editing Form is modeled in a very unique and innovative neutral theme which dramatically enhances user experience. By default, it casted deep alpha blended drop- shadow to strengthen the focus of the editing dialog box and its features. WebScheduler's Editing Form adopts "open architecture" model, which means you can edit the Form and customize it according to your needs.

The key objectives of the "open architecture" Editing Form is:

    • Enable you to conveniently customize the styles, appearance, and layout of the Editing Form to suit your needs, as long as the controls and ID are not modified.
    • Enable you to easily localize the textual elements used in the Form.
    • Enable you to add more fields and custom validations according to your business scenario.
    • Enable you to add more controls and possibility to use other third party controls in the Form.
    • Enable you to control and customize the behaviors of existing controls, for example: to disable an input field.

Currently, WebScheduler's EditingForm is designed using WebDesktop (WebDialogBox, WebContextMenu, WebCallOut), WebCombo and WebInput. WebScheduler's editing form is controlled by WebScheduler_Edit.js.

  • Specify the EditingForm's url.
    In order to be integrated with WebScheduler, you should specify the EditingForm's url.

    There are 2 way to specify the EditingForm's url :
    1. Get the EditingForm.aspx from 'C:\Program Files\Intersoft Solutions\WebScheduler.NET 1.0'and put it to your project then set the EditingForm's url directly in EditingUrl property.

    2. Set AllowEdit to Yes and EditingForm wizard will appear. You can specify the EditingForm's folder in this wizard and EditingForm.aspx will be automatically added in this folder.

  • Field that should not be empty in EditingForm.
    Here are the fields that should not be empty in EditingForm :
      • General section.
          • Resource
          • Subject
          • StartTime
          • StartTimeInfo
          • EndTime
          • EndTimeInfo
          • Important

      • Recurrence section.
          • Daily recurrence.
              • NDay field if the daily's option 1 is selected.
          • Weekly recurrence.
              • NWeek field.
                Should check at least 1 of the day's checkbox.
          • Monthly recurrence.
              • NDay field.
              • NMonth field.
          • Yearly recurrence
              • Month field
              • NDay field

  • Disable Recurrence section.
    Recurrence section will be disabled if you would like to edit the recurrence's event however the edit only applied for the selected event only.

See Also

Tasks
{How-to: AllowEdit in WebScheduler}
{How-to: AllowAdd in WebScheduler}
{How-to: AllowDelete in WebScheduler}
{How-to: AllowMove in WebScheduler}
{How-to: AllowResize in WebScheduler}
{How-to: Customize EditingField}
{How-to: Set EditingUrl in WebScheduler}
{Walkthrough Topics}
{How-to Topics}

Other Resources
{General Navigation}
{Navigation on each WebScheduler's view}
{Calendar Features}
{Holiday}
{Styles}
{Categories}
{CallOut}
{General Feature}


How-to: AllowMove in WebScheduler

How-to: AllowMove in WebScheduler
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Editing > How-to: AllowMove in WebScheduler

Glossary Item Box

AllowMove property is used to add an event in WebScheduler.

In this topic, you will learn how to set AllowMove from WebScheduler's properties.

To set AllowMove

  1. Right click on WebScheduler's control and choose Properties.
  2. Expand DataEditing property.
  3. Set AllowMove to Yes.

See Also

Tasks
{How-to: AllowEdit in WebScheduler}
{How-to: AllowAdd in WebScheduler}
{How-to: AllowDelete in WebScheduler}
{How-to: AllowResize in WebScheduler}
{Walkthrough Topics}
{How-to Topics}

Concepts
{Editing}


How-to: AllowResize in WebScheduler

How-to: AllowResize in WebScheduler
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Editing > How-to: AllowResize in WebScheduler

Glossary Item Box

AllowResize property is used to add an event in WebScheduler.

In this topic, you will learn how to set AllowResize from WebScheduler's properties.

To set AllowResize

  1. Right click on WebScheduler's control and choose Properties.
  2. Expand DataEditing property.
  3. Set AllowResize to Yes.

See Also

Tasks
{How-to: AllowEdit in WebScheduler}
{How-to: AllowAdd in WebScheduler}
{How-to: AllowDelete in WebScheduler}
{How-to: AllowMove in WebScheduler}
Walkthrough Topics
{How-to Topics}

Concepts
{Editing}


How-to: Customize EditingField

How-to: Customize EditingField
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Editing > How-to: Customize EditingField

Glossary Item Box

WebScheduler allows you to specify your own EditingField in callout.

In this topic, you will learn how to customize EditingField.

To customize EditingField

  1. Right click on WebScheduler's control and choose Properties.
  2. Find EditingField property.
  3. In the EditingField's window, you can specify the EditingField that you want.

  4. The result will look like following:

See Also

Tasks
{How-to: Set EditingUrl in WebScheduler}
{Walkthrough Topics}
{How-to Topics}

Concepts
{EditingForm}


How-to: Set EditingUrl in WebScheduler

How-to: Set EditingUrl in WebScheduler
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Editing > How-to: Set EditingUrl in WebScheduler

Glossary Item Box

WebScheduler allows you to set EditingUrl. There are 2 ways to implement this feature, which are through DataEditing and EditingUrl.

In this topic, you will learn how to set EditingUrl using 2 ways respectively.

To set EditingUrl through DataEditing >> AllowEdit

  1. Right click on WebScheduler's control and choose Properties.
  2. Expands DataEditing.
  3. Set AllowEdit to True and WebScheduler Editing Wizard will appear.
  4. Specify the folder name where you would like the EditingForm to be added in WebScheduler Editing Wizard then click OK.
  5. EditingForm.aspx will automatically add to this folder.

Through EditingUrl

  1. Get EditingForm.aspx from "C:\Program Files\Intersoft Solutions\WebScheduler.NET 1.0".
  2. Put the EditingForm.aspx to your project.
  3. Finds EditingUrl property.
  4. Set the EditingForm's url to EditingUrl.

See Also

Tasks
{How-to: Set EditingUrl in WebScheduler}
Walkthrough Topics
{How-to Topics}

Concepts
{EditingForm}


Culture

Culture
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Culture

Glossary Item Box

WebScheduler.NET supports various cultures, which can be specified in Culture properties. If the culture is not specified, WebScheduler.NET will use the default culture in the server.

In addition to culture feature, user can specify DateFormatString that will be used in every view as the header text.

In all view except Quarter view, user can use .NET date format as the value DateFormatString.

In Day view, the default value of DateFormatString is D, which will display the header date in dddd, dd MMM yyyy format.

In Week view, the default value of DateFormatString is also D. Since the week view displays dates in weekly period, the header text format will be [StartDate] - [EndDate]. The dates will use the DateFormatString value specified.

In Month view, the default value of DateFormatString is MMM yyy.

Quarter view displays dates within a quarter periods. The default value of DateFormatString is [quarter] [year]. The [quarter] text will be replaced with the active quarter value. The [year] text will be replaced with the active year value. Custom text settings can be added in this property so user can have custom header text for Quarter view.

In Year view, the default value of DateFormatString is yyyy.

In Agenda view, the default value of DateFormatString is D, which will display the header date in dddd, dd MMM yyyy format. User can also specify the event's DateFormatString using ItemDateFormatString, which default value is also D.

In This Section

Text Settings

How-to: Customize WebScheduler's TextSettings

How-to: Set culture in WebScheduler

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{General Feature}
{Editing}
{Resources}


Text Settings

Text Settings
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Culture > Text Settings

Glossary Item Box

User can customize WebScheduler text areas to use custom text according to their needs.

Various text settings that can be customized in view header area are:

  • DayText: the text for Day view header
  • WeekText: the text for Week view header
  • MonthText: the text for Month view header
  • QuarterText: the text for Quarter view header
  • YearText: the text for Year view header
  • AgendaText: the text for Agenda view header
  • DayTabView: the tooltip text for Day view header
  • WeekTabView: the tooltip text for Week view header
  • MonthTabView: the tooltip text for Month view header
  • QuarterTabView: the tooltip text for Quarter view header
  • YearTabView: the tooltip text for Year view header
  • AgendaTabView: the tooltip text for Agenda view header
  • ExpandCalendarText: the tooltip text for ExpandCalendar button
  • CollapseCalendarText: the tooltip text for CollapseCalendar button
  • MenuTabViewText: the tooltip text for menu tab view
  • ShowFullWeekText: the text for Show full week radio button
  • ShowWorkWeekText: the text for Show work week radio button

User can customize the tooltip text of date header in Week view using WeekViewDateHeaderText property.

Various text settings that can be customized in Month view are:

  • MonthDateHeaderText: the tooltip text for date header
  • YearMonthRowHeaderMonthViewText: the tooltip text for row header

Various text settings that can be customized in Quarter view are:

  • Quarter1Text: the text for Quarter 1 header text
  • Quarter2Text: the text for Quarter 2 header text
  • Quarter3Text: the text for Quarter 3 header text
  • Quarter4Text: the text for Quarter 4 header text

The above text settings will replace the [quarter] value in DateFormatString property of Quarter view. The replacement depends on the active quarter viewed by user.

Various text settings that can be customized in Year view are:

  • YearDayOfWeekText: the tooltip text for date header
  • YearMonthRowHeaderYearQuarterViewText: the tooltip text for row header

Various text settings that can be customized in Agenda view are:

  • ExpandAllText: the text for Expand All link in header
  • CollapseAllText: the text for Collapse All link in header
  • EditEventText: the text for Edit Event link in event detail
  • DeleteEventText: the text for Delete Event link in event detail
  • ViewOnMyCalendarText: the text for View On My Calendar link in event detail

Various text settings that can be customized in event element are:

  • ReminderToolTipText: the tooltip text for reminder icon
  • ExceptionToolTipText: the tooltip text for recurrence exception icon
  • Recurrence ToolTip
    The following text settings is used as the tooltip text of recurrence image according to its recurrence pattern:
    1. DailyNDayToolTipText: the tooltip text for events which recurs every n day
    2. DailyWeekDayToolTipText: the tooltip text for events which recurs every weekday
    3. WeeklyToolTipText: the tooltip text for events which recurs every week
    4. MonthlyToolTipText: the tooltip text for events which recurs every month
    5. YearlyToolTipText: the tooltip text for events which recurs every year

The following text settings will be combined with previous text settings if and end is specified for the recurring event:

    1. EndAfterNRecurrenceToolTipText: the tooltip text for events that ends after n recurrence
    2. EndByDateToolTipText: the tooltip text for events that have end date

Various text settings that can be customized in CallOut are:

  • SubjectText: the text for Subject field
  • DescriptionText: the text for Description field
  • LocationText: the text for Location field
  • AddEventText: the text for AddEvent button
  • EditEventText: the text for EditEvent button
  • DeleteEventText: the text for DeleteEvent button
  • EditDetailText: the text for Detail link

Various text settings that can be customized in calendar are:

  • CalendarHeaderText: the tooltip text for calendar header
  • CalendarPrevArrowText: the tooltip text for previous arrow
  • CalendarNextArrowText: the tooltip text for next arrow

User can customize the Manage Resource text in Resources section using ManageResourcesText property.

In This Section

How-to: Customize WebScheduler's TextSettings

How-to: Set culture in WebScheduler

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
Culture
{General Feature}


How-to: Customize WebScheduler's TextSettings

How-to: Customize WebScheduler's TextSettings
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Culture > Text Settings > How-to: Customize WebScheduler's TextSettings

Glossary Item Box

WebScheduler allows you to customize Text settings.

In this topic, you will learn how to modify each of tab's text in ViewHeader.

To customize text settings

  1. Right click on WebScheduler's control and choose Properties.
  2. Expands TextSettings property.
  3. Set AgendaText property to "Agenda view".
  4. Set DayText property to "Day view".
  5. Set MonthText property to "Month view".
  6. Set WeekText property to "Week view".
  7. Set YearText property to "Year view".

See Also

Tasks
{How-to: Set culture in WebScheduler}
{Walkthrough Topics}
{How-to Topics}

Concepts
{Text Settings}


How-to: Set culture in WebScheduler

How-to: Set culture in WebScheduler
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Culture > How-to: Set culture in WebScheduler

Glossary Item Box

WebScheduler allows you to customize culture and Text settings.

In this topic, you will learn how to set culture and modify each of tab's text in ViewHeader.

To set culture

  1. Right click on WebScheduler's control and choose Properties.
  2. Set Culture to any culture you want to visualize. For Example: French (France).

To customize text settings

  1. Right click on WebScheduler's control and choose Properties.
  2. Expands TextSettings property.
  3. Set AgendaText property to "Agenda view".
  4. Set DayText property to "Day view".
  5. Set MonthText property to "Month view".
  6. Set WeekText property to "Week view".
  7. Set YearText property to "Year view".

See Also

Tasks
{How-to: Customize WebScheduler's TextSettings}
{Walkthrough Topics}
{How-to Topics}

Concepts
{Culture}


Resources

Resources
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Resources

Glossary Item Box

Every event belongs to a resource. The list of resources will be displayed in the Resources section under Calendar section.

Here are the styles used in Resources section:

  • ResourcesFrameStyle
  • ResourcesHeaderStyle

In This Section

Concepts

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{General Feature}
{Culture}
{Editing}
{Resources}


Concept

Concept
See Also Send Feedback
Intersoft WebScheduler > Features and Concepts > Resources > Concept

Glossary Item Box

WebScheduler.NET supports multiple resources, means that user can specify more than one resource. Every event will be displayed using its resource color so user can easily differentiate which events with different resources.

If the resources are not bound, default resource will be used. All events will be added to the default resources. User will not be able to add new resource if the resources are not bound.

If the resources are bound to a table or a collection but there are no resources specified, default resource will not be used. At least one resource has to be added before user can add an event.

User can hide or show resource's events simply by clicking the resource's checkbox. When it's checked, the resource's events will be displayed, and when it's unchecked, the resource's events will be hidden.

User can manage the resources using the provided editing form. User can click the plus button to add new resource, click the edit button to edit a resource, or click the delete button to delete a resource.

User can add new resource or edit existing resource using the resource callout.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Editing}
{Culture}
{General Feature}


Server-side References

Server-side References
Send Feedback
Intersoft WebScheduler > Server-side References

Glossary Item Box

This section is designated to help user working with server-side references in WebScheduler.NET.


ISNet.WebUI.WebScheduler Namespace

ISNet.WebUI.WebScheduler Namespace
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

Classes

 | Class | Description
Class | WebScheduler | WebScheduler.NET™ is designed for ease-of-use and out-of-the-box Scheduling experience, yet providing advanced level of customization and innovative features. WebScheduler.NET™ allows you to build professional calendaring and scheduling application with very minimal efforts and time.
Class | WebSchedulerActiveDayStyle | A collection of interactive styles used for WebScheduler's active day.
Class | WebSchedulerAgendaView | A collection of styles used for WebScheduler's agenda view.
Class | WebSchedulerBinding | A collection of settings used for WebScheduler's data binding.
Class | WebSchedulerCalendarSettings | A collection of WebSchedyler's calendar settings.
Class | WebSchedulerCategoriesBinding | A collection of settings used for WebScheduler's categories binding.
Class | WebSchedulerCategory | A collection of members in WebScheduler's category.
Class | WebSchedulerCategoryCollection | A collection of settings used for WebScheduler's category.
Class | WebSchedulerClientSideEvents | A collection of WebScheduler's client side events.
Class | WebSchedulerDataArgs | The argument which is called when an event handler is in process.
Class | WebSchedulerDataBoundDataArgs | Provides data for data bound related data.
Class | WebSchedulerDataEditing | A collection of setting used for WebScheduler's data editing.A collection of settings used for WebScheduler's data editing.
Class | WebSchedulerDateTimeConverter | A collection of settings used for WebScheduler's date time converter.
Class | WebSchedulerDayView | A collection of settings used for WebScheduler's day view.
Class | WebSchedulerDetailInfoStyle | A collection of styles used for WebScheduler's detail info.
Class | WebSchedulerDisabledTime | A collection of members in WebScheduler's DisabledTime.
Class | WebSchedulerDisabledTimeCollection | The data collection of DisabledTime used by WebScheduler.
Class | WebSchedulerEditingField | A collection of members in WebScheduler's editing field.
Class | WebSchedulerEditingFieldCollection | The data collection used by webscheduler as the callout's editing field.
Class | WebSchedulerEvent | A collection of members in WebScheduler's event.
Class | WebSchedulerEventBase | Base class of WebSchedulerEvent and WebSchedulerRecurringEvent.
Class | WebSchedulerEventCollection | A collection of events used by WebScheduler.
Class | WebSchedulerEventsBinding | A collection of settings used for events binding in WebScheduler.
Class | WebSchedulerEventsBindingBase | Base class of the entire data binding events, such as CategoryBinding, EventsBinding, RecurrenceBinding, RecurringEventsBinding and ResourcesBinding.
Class | WebSchedulerExportEventArgs | Class that allows users to use their own exporting codes or module to handle exporting functionality.
Class | WebSchedulerGridLineStyle | A collection of styles used for grid line.
Class | WebSchedulerHoliday | A collection of members in WebScheduler's holiday.
Class | WebSchedulerHolidayCollection | The data collection used by WebScheduler to determine holiday(s).
Class | WebSchedulerImagesSettings | A collection of image settings for WebScheduler's object.
Class | WebSchedulerJsonSerializationArgs |
Class | WebSchedulerLayoutSettings | A collection of layout settings for WebScheduler's object.
Class | WebSchedulerMonthView | A collection of styles used for WebScheduler's month view.
Class | WebSchedulerPrepareExportExecuteEventArgs | Provides data for export action.
Class | WebSchedulerQuarterView | A collection of styles used for WebScheduler's quarter view.
Class | WebSchedulerRecurrence | A collection of members in WebScheduler's recurrence.
Class | WebSchedulerRecurrenceCollection | The data collection used by WebScheduler to determine recurrence.
Class | WebSchedulerRecurrencesBinding | A collection of settings used for recurrence binding.
Class | WebSchedulerRecurrenceTextSettings | A collection of tooltip text used for recurrence text settings.
Class | WebSchedulerRecurringEvent | A collection of recurring events used by WebScheduler.
Class | WebSchedulerRecurringEventBinding | A collection of settings used for RecurringEvents binding.
Class | WebSchedulerResource | A collection of members in WebScheduler's resource.
Class | WebSchedulerResourceCollection | The data collection used by WebScheduler to determine resources..
Class | WebSchedulerResourceDataEditing | A collection of settings used for resource's data editing.
Class | WebSchedulerResourcesBinding | A collection of settings used for resources binding.
Class | WebSchedulerTextSettings | A collection of settings which controls the text shown in WebScheduler.
Class | WebSchedulerTimeBasedEventStyle | A collection of interactive styles used for TimeBasedEvent.
Class | WebSchedulerTimelineView | A collection of settings used for Timeline in WebScheduler.
Class | WebSchedulerViewSettings | A collection of settings used for view in WebScheduler.
Class | WebSchedulerWeekView | A collection of settings used for week in WebScheduler.
Class | WebSchedulerWorkWeekSettings | A collection of interactive styles used for work week in WebScheduler.
Class | WebSchedulerYearView | A collection of interactive styles used for year view in WebScheduler.

Delegates

 | Delegate | Description
Delegate | WebSchedulerDataBoundEventHandler | Delegates that handles the DataBound event.
Delegate | WebSchedulerDataOperationEventHandler | Delegates that handles the DataOperation event.
Delegate | WebSchedulerExportEventHandler | Delegates that handles the export event.
Delegate | WebSchedulerJsonSerializationEventHandler | Delegates that handles Json serialization event.
Delegate | WebSchedulerPrepareExportExecuteEventHandler | Delegates that handles prepare export execute event.

Enumerations

 | Enumeration | Description
Enumeration | WebSchedulerAllowMode | Indicates whether allow mode is enabled or disabled.
Enumeration | WebSchedulerCustomViewMode | Specifies which custom view mode is used.
Enumeration | WebSchedulerDailyRecurrenceMode | Determines which recurrence mode is used.
Enumeration | WebSchedulerDatePrefix | Determines which date prefix is used.
Enumeration | WebSchedulerDefaultStyleMode | Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.
Enumeration | WebSchedulerEditingFormStyle |
Enumeration | WebSchedulerEmptyCellClickAction | Determines which empty cell click action is used.
Enumeration | WebSchedulerExceptionInfo | Determines which exception info is used.
Enumeration | WebSchedulerFieldType | Determines which field type is used.
Enumeration | WebSchedulerFirstWeekOfYear | Determines which first week of year is used.
Enumeration | WebSchedulerImportanceMode | Determines which importance mode is used.
Enumeration | WebSchedulerLoadOnDemandMode | Gets or sets a value that determines the mode of LoadOnDemand.
Enumeration | WebSchedulerObjectType | Determines which object type is used.
Enumeration | WebSchedulerRecurrenceMode | Determines which recurrence mode is used.
Enumeration | WebSchedulerRecurrenceRangeMode | Determines which recurrence range mode is used.
Enumeration | WebSchedulerReportOutputPathType | Determines the output path for report type.
Enumeration | WebSchedulerTime | Determines which time is used.
Enumeration | WebSchedulerTimeBasedEventDisplay | Determines which interactive style is used for TimeBasedEvent.
Enumeration | WebSchedulerTimeFormat | Determines the time format.
Enumeration | WebSchedulerTimeline | Determines the Timeline.
Enumeration | WebSchedulerTimelineClientPagingMode | Determines which client paging mode is used in Timeline view.
Enumeration | WebSchedulerTimelineDateHeaderMode | Determines which date header mode is used in Timeline view.
Enumeration | WebSchedulerTimelineResourceContentMode | Determines which Timeline resource content mode is used.
Enumeration | WebSchedulerTimelineViewMode | Determines which Timeline view mode is used.
Enumeration | WebSchedulerTimelineWeekMode | Determines which Timeline week mode is used.
Enumeration | WebSchedulerTimeMode | Determines which time mode is used.
Enumeration | WebSchedulerTimeScale | Determines the time scale.
Enumeration | WebSchedulerViewMode | Determines which view mode is used.
Enumeration | WebSchedulerViewRecurrenceType | Determines which view recurrence type is used.
Enumeration | WebSchedulerWeekDay | Determines which week day is used.
Enumeration | WebSchedulerWeekViewMode | Determines which week view mode is used.

See Also

Reference

ISNet.WebUI.WebScheduler Assembly


WebScheduler Class

[image]
Intersoft WebScheduler Documentation
WebScheduler Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebScheduler Class

Glossary Item Box

WebScheduler.NET™ is designed for ease-of-use and out-of-the-box Scheduling experience, yet providing advanced level of customization and innovative features. WebScheduler.NET™ allows you to build professional calendaring and scheduling application with very minimal efforts and time.

Object Model

WebScheduler Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.ToolboxDataAttribute("<{0}:WebScheduler runat=server Width="800px" Height="600px"></{0}:WebScheduler>")>
<System.ComponentModel.DefaultPropertyAttribute("DataSourceID")>
<System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDesigner, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebScheduler.js;WebScheduler_Calendar.js;WebScheduler_CallOut.js;WebScheduler_Scheduler.js;WebScheduler_Data.js;Shared\CultureInfo.js;Shared\CoreValidator.js", Type=XmlSerializationType.ClientAndLayout)>
<System.SerializableAttribute()>
<System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
<System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Public Class WebScheduler
   Inherits ISNet.WebUI.ISNetControl
   Implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
C#
[System.Web.UI.ToolboxDataAttribute("<{0}:WebScheduler runat=server Width="800px" Height="600px"></{0}:WebScheduler>")]
[System.ComponentModel.DefaultPropertyAttribute("DataSourceID")]
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDesigner, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebScheduler.js;WebScheduler_Calendar.js;WebScheduler_CallOut.js;WebScheduler_Scheduler.js;WebScheduler_Data.js;Shared\CultureInfo.js;Shared\CoreValidator.js", Type=XmlSerializationType.ClientAndLayout)]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public class WebScheduler : ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Delphi
public class WebScheduler = class(ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings)
JScript
System.Web.UI.ToolboxDataAttribute("<{0}:WebScheduler runat=server Width="800px" Height="600px"></{0}:WebScheduler>")
System.ComponentModel.DefaultPropertyAttribute("DataSourceID")
System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDesigner, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebScheduler.js;WebScheduler_Calendar.js;WebScheduler_CallOut.js;WebScheduler_Scheduler.js;WebScheduler_Data.js;Shared\CultureInfo.js;Shared\CoreValidator.js", Type=XmlSerializationType.ClientAndLayout)
System.SerializableAttribute()
System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
public class WebScheduler extends ISNet.WebUI.ISNetControl implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Managed Extensions for C++
[System.Web.UI.ToolboxDataAttribute("<{0}:WebScheduler runat=server Width="800px" Height="600px"></{0}:WebScheduler>")]
[System.ComponentModel.DefaultPropertyAttribute("DataSourceID")]
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDesigner, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebScheduler.js;WebScheduler_Calendar.js;WebScheduler_CallOut.js;WebScheduler_Scheduler.js;WebScheduler_Data.js;Shared\CultureInfo.js;Shared\CoreValidator.js", Type=XmlSerializationType.ClientAndLayout)]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public __gc class WebScheduler : public ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
C++/CLI
[System.Web.UI.ToolboxDataAttribute("<{0}:WebScheduler runat=server Width="800px" Height="600px"></{0}:WebScheduler>")]
[System.ComponentModel.DefaultPropertyAttribute("DataSourceID")]
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDesigner, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebScheduler.js;WebScheduler_Calendar.js;WebScheduler_CallOut.js;WebScheduler_Scheduler.js;WebScheduler_Data.js;Shared\CultureInfo.js;Shared\CoreValidator.js", Type=XmlSerializationType.ClientAndLayout)]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public ref class WebScheduler : public ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebScheduler.WebScheduler

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Members
ISNet.WebUI.WebScheduler Namespace


WebScheduler Class Members

[image]
Intersoft WebScheduler Documentation
WebScheduler Class Members
See Also Properties Methods Events Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebScheduler Class

Glossary Item Box

The following tables list the members exposed by WebScheduler.

Public Constructors

 | Name | Description
Public Constructor | WebScheduler Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ActiveDayStyle | Contains interactive style for Active Day.
Public Property | AgendaActionStyle | Contains interactive style for Agenda Action.
Public Property | AgendaAlternativeRowStyle | Contains interactive style for Agenda AlternativeRow.
Public Property | AgendaDateColumnStyle | Contains interactive style for Agenda DateColumn.
Public Property | AgendaRowStyle | Contains interactive style for Agenda Row.
Public Property | AllDayEventAreaStyle | Contains interactive style for AllDayEvent Area.
Public Property | AllDayEventStyle | Contains interactive style for AllDayEvent.
Public Property | AllowCreateEventInHoliday | Specifies whether the event(s) is allowed to be created when the day is holiday.
Public Property | AllowDropFromExtender | Specifies whether drag object of WebDragDropExtender is allowed to be dropped in WebScheduler.
Public Property | BackColor | Background's color of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderColor | Color of the border around the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderStyle | Style of the border around the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderWidth | Width of the border around the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | CalendarFrameStyle | Contains interactive style for Calendar Frame.
Public Property | CalendarHeaderStyle | Contains interactive style for Calendar Header.
Public Property | CalendarInboundCellStyle | Contains interactive style for Calendar InboundCell.
Public Property | CalendarOutboundCellStyle | Contains interactive style for Calendar OutboundCell.
Public Property | CalendarSelectedCellStyle | Contains interactive style for Calendar SelectedCell.
Public Property | CalendarSettings | Provides the settings that control the behaviors of the calendar in WebScheduler.
Public Property | CalendarTableStyle | Contains interactive style for Calendar Table.
Public Property | CalendarTodayStyle | Contains interactive style for Calendar Today.
Public Property | CalendarWeekNameStyle | Contains interactive style for Calendar WeekNumberName.
Public Property | CalendarWeekNumberStyle | Contains interactive style for Calendar WeekNumber.
Public Property | Categories | The data collection used by WebScheduler as the categories.
Public Property | CategoriesDataMember | Sets the categories data member.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains client side events supported by WebScheduler.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | CssClass | CSS Class name applied to the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Culture | Specifies the culture setting for current WebScheduler instance.
Public Property | DataBinding | Provides the settings for WebScheduler's data binding.
Public Property | DataEditing | Provides the settings that control the behaviors of the data editing in WebScheduler.
Public Property | DataSourceID | Gets or sets the ID of the control from which the WebScheduler control retrieves its datasource.
Public Property | DataSourceManager | Overridden.
Public Property | DayHeaderStyle | Contains interactive style for Day Header.
Public Property | DefaultResource | Gets or sets the default resource when Resources is not defined.
Public Property | DefaultStyleMode | Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.
Public Property | DisabledAllDayEventAreaStyle | Contains interactive style for disabled cells in AllDayEvent Area.
Public Property | DisabledMonthInboundCellStyle | Contains interactive style for disabled inbound cells in Month view.
Public Property | DisabledMonthOutboundCellStyle | Contains interactive style for disabled outbound cells in Month view.
Public Property | DisabledNonWorkHourStyle | Contains interactive style for non work hour cells that are set as disabled.
Public Property | DisabledTime | The data collection used by WebScheduler as the disabled time.
Public Property | DisabledWorkHourStyle | Contains interactive style for work hour cells that are set as disabled.
Public Property | DisplayEventCountOnlyInTooltip | Indicates whether the calendar's tooltip should show event count only or not.
Public Property | DisplayResourcesTable | Indicates whether the resources table is visible or not.
Public Property | EditingButtonStyle | Contains interactive style for the EditingButton.
Public Property | EditingField | The data collection used by WebScheduler as the CallOut's EditingField.
Public Property | EditingFormStyle | Determines which style mode is used in built-in editing form.
Public Property | EditingTextStyle | Contains interactive style for the text of EditingField.
Public Property | EditingUrl | Sets the EditingForm's url
Public Property | EmptyCellClickAction | Specifies Specifies the behavior when empty cell is clicked.
Public Property | EnableAnimation | Specifies whether animation of WebScheduler's CallOut should be enabled or disabled.
Public Property | EnableContextMenu | Specifies whether ContextMenu should appear when right clicking on event(s) or not.
Public Property | Enabled | Enables state of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableExport | Specifies whether or not scheduler export should be enabled in UI.
Public Property | EnableFastJsonSerialization | Gets or sets a value that determines whether or not fast JSON serialization is enabled.
Public Property | EnableManagedTheming | Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableMultipleCellSelection | Gets or sets a value that determines whether or not multiple cell selection is enabled.
Public Property | EnableSplitViewInitially | Specifies whether or not SplitView should be enabled initially.
Public Property | EnableTheming | Indicates whether the control can be themed. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Indicates whether control automatically saves its state for use in round-trips. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EventsDataMember | Sets the events data member.
Public Property | ExtendedCategoryTypeName | Gets or sets the extended category type name.
Public Property | ExtendedEventTypeName | Gets or sets the extended event type name.
Public Property | ExtendedRecurringEventTypeName | Gets or sets the extended event type name.
Public Property | ExtendedResourceTypeName | Gets or sets the extended resource type name.
Public Property | FlyPostBackSettings | Configures the settings used by the control when performing OnTheFly postback.
Public Property | Font | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ForeColor | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | GridLineStyle | Contains interactive style for Grid Line.
Public Property | Height | The height of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Holidays | The data collection used by WebScheduler to determine holiday(s).
Public Property | HolidayStyle | Contains interactive style for Holiday.
Public Property | HourAreaStyle | Contains interactive style for Hour Area.
Public Property | ID | Programmatic name of the control. (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the images directory for ImagesSettings.
Public Property | ImagesSettings | Provides the settings that control the images in WebScheduler.
Public Property | IncludeSplitViewInMenu | Specifies whether or not SplitView option should be included in context menu and More menu.
Public Property | IncludeTimeIntervalInMenu | Specifies whether time interval options should be included in menu.
Public Property | LayoutSettings | Provides the settings that control the behaviors of the layout in WebScheduler.
Public Property | LoadOnDemandMode | Gets or sets a value that determines the mode of LoadOnDemand.
Public Property | MarkedDayWithEvents | Specifies whether Calendar's number of WebScheduler that contain event(s) should be marked with bold style or not.
Public Property | MonthDayHeaderStyle | Contains interactive style for for day header in Month view.
Public Property | MonthInboundCellStyle | Contains interactive style for MonthInboundCell.
Public Property | MonthInboundDateHeaderStyle | Contains interactive style for MonthInboundDateHeader.
Public Property | MonthOutboundCellStyle | Contains interactive style for MonthOutboundCell.
Public Property | MonthOutboundDateHeaderStyle | Contains interactive style for MonthOutboundDateHeader.
Public Property | MonthSelectedCellStyle | Contains interactive style for MonthSelectedCell.
Public Property | NonWorkHourStyle | Contains interactive style for Non WorkHour.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RecurrenceDataMember | Sets the recurrence data member.
Public Property | RecurringEventsDataMember | Sets the recurring events data member.
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ResourcesContentMode | Specifies Timeline Resource container mode.
Public Property | ResourcesDataMember | Sets the resources data member.
Public Property | ResourcesFrameStyle | Contains interactive style for Resources Frame.
Public Property | ResourcesHeaderStyle | Contains interactive style for Resources Header.
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | SchedulerFrameStyle | Contains interactive style for Scheduler Frame.
Public Property | SchedulerHeaderStyle | Contains interactive style for Scheduler Header.
Public Property | SchedulerTodayAllDayEventAreaStyle | Contains interactive style for Scheduler TodayAllDayEventArea.
Public Property | SchedulerTodayCellStyle | Contains interactive style for Scheduler TodayCell.
Public Property | SchedulerTodayHeaderStyle | Contains interactive style for Scheduler TodayHeader.
Public Property | SchedulerTodayHourStyle | Contains interactive style for Scheduler TodayHour.
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SelectedHourStyle | Contains interactive style for Selected Hour.
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all required framework scripts for the control are stored.
Public Property | ShowWeekNumbers | Specifies whether WebScheduler should show week number or not.
Public Property | SkinID | The id of the control skin. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | The tab order of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TextSettings | Provides settings that control text that shown in WebScheduler.
Public Property | TimeBasedEventStyle | Contains interactive style for TimeBasedEvent.
Public Property | TimelineContentCellStyle | Contains interactive style for Timeline ContentCell.
Public Property | TimelineDateCellStyle | Contains interactive style for Timeline DateCell.
Public Property | TimelineDisabledTimeCellStyle | Contains interactive style for Timeline DisabledTime cell.
Public Property | TimelineResourceCellStyle | Contains interactive style for Timeline ResouceCell.
Public Property | TimelineResourceHeaderTextCellStyle | Contains interactive style for Timeline ResourceCellText.
Public Property | TimelineTimeCellStyle | Contains interactive style for Timeline TimeCell.
Public Property | ToolTip | The tooltip displayed when the mouse is over the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | UseDefaultStyle | Specifies whether WebScheduler should apply embedded default style for its appearance.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewHeaderFrameStyle | Contains interactive style for ViewHeader Frame.
Public Property | ViewHeaderStyle | Contains interactive style for ViewHeader.
Public Property | ViewSettings | Provides the settings that control the behaviors of the view in WebScheduler.
Public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | Indicates whether the control is visible and rendered. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | WebDesktopScriptDirectory | Gets or sets the IIS path to locate WebDesktop's script directory. This property is only applicable when SmartWebResources is not enabled.
Public Property | WeekOptionFrameStyle | Contains interactive style for WeekOption Frame.
Public Property | Width | The width of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | WorkHourStyle | Contains interactive style for Work Hour.
Public Property | WorkWeekSettings | Provides the settings that control the behaviors of the WorkWeek in WebScheduler.
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for client side state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | YearDayOfWeekStyle | Contains interactive style for YearDayOfWeek.
Public Property | YearFrameStyle | Contains interactive style for Year Frame.
Public Property | YearMonthRowHeaderStyle | Contains interactive style for the Year, Quarter and Month row header.
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | ExportScheduler | Overloaded.
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction |
Public Method | GetCulture |
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetStartDateOfMonth |
Public Method | GetStartDateOfWeek |
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | GetXMLCultureInfo | Overridden.
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnDataBound |
Public Method | OnExport |
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnJsonSerialization |
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPrepareExportExecute | Invokes when export action is about to be performed.
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | Overridden.
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | DataBound |
Public Event | Delete |
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Export |
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Insert |
Public Event | JsonSerialization |
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PrepareExportExecute |
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Public Event | Update |
Top

See Also

Reference

WebScheduler Class
ISNet.WebUI.WebScheduler Namespace


WebScheduler Constructor

[image]
Intersoft WebScheduler Documentation
WebScheduler Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : WebScheduler Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebScheduler()
C#
public WebScheduler()
Delphi
public WebScheduler();
JScript
public function WebScheduler();
Managed Extensions for C++
public: WebScheduler();
C++/CLI
public:
WebScheduler();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


WebScheduler Class Methods

[image]
Intersoft WebScheduler Documentation
WebScheduler Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebScheduler Class

Glossary Item Box

For a list of all members of this type, see WebScheduler members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | ExportScheduler | Overloaded.
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction |
Public Method | GetCulture |
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetStartDateOfMonth |
Public Method | GetStartDateOfWeek |
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | GetXMLCultureInfo | Overridden.
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnDataBound |
Public Method | OnExport |
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnJsonSerialization |
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPrepareExportExecute | Invokes when export action is about to be performed.
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | Overridden.
Top

See Also

Reference

WebScheduler Class
ISNet.WebUI.WebScheduler Namespace


CheckConstrains Method

[image]
Intersoft WebScheduler Documentation
CheckConstrains Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : CheckConstrains Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub CheckConstrains()
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler

instance.CheckConstrains()
C#
public override void CheckConstrains()
Delphi
public procedure CheckConstrains(); override;
JScript
public override function CheckConstrains();
Managed Extensions for C++
public: void CheckConstrains(); override
C++/CLI
public:
void CheckConstrains(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ExportScheduler Method

[image]
Intersoft WebScheduler Documentation
ExportScheduler Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ExportScheduler Method

Glossary Item Box

Overload List

Overload | Description
ExportScheduler() |
ExportScheduler(WebSchedulerReportInfo) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ExportScheduler() Method

[image]
Intersoft WebScheduler Documentation
ExportScheduler() Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class > ExportScheduler Method : ExportScheduler() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ExportScheduler() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.String

value = instance.ExportScheduler()
C#
public System.string ExportScheduler()
Delphi
public function ExportScheduler(): System.String;
JScript
public function ExportScheduler() : System.String;
Managed Extensions for C++
public: System.string* ExportScheduler();
C++/CLI
public:
System.String^ ExportScheduler();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members
Overload List


ExportScheduler(WebSchedulerReportInfo) Method

[image]
Intersoft WebScheduler Documentation
ExportScheduler(WebSchedulerReportInfo) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class > ExportScheduler Method : ExportScheduler(WebSchedulerReportInfo) Method

reportInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ExportScheduler( _
   ByVal reportInfo As WebSchedulerReportInfo _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim reportInfo As WebSchedulerReportInfo
Dim value As System.String

value = instance.ExportScheduler(reportInfo)
C#
public System.string ExportScheduler(
   WebSchedulerReportInfo reportInfo
)
Delphi
public function ExportScheduler(
    reportInfo: WebSchedulerReportInfo
): System.String;
JScript
public function ExportScheduler(
   reportInfo : WebSchedulerReportInfo
) : System.String;
Managed Extensions for C++
public: System.string* ExportScheduler(
   WebSchedulerReportInfo* reportInfo
)
C++/CLI
public:
System.String^ ExportScheduler(
   WebSchedulerReportInfo^ reportInfo
)

Parameters

reportInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members
Overload List


GetClientAction Method

[image]
Intersoft WebScheduler Documentation
GetClientAction Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : GetClientAction Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetClientAction() As ISNet.WebUI.BaseClientSideAction
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.BaseClientSideAction

value = instance.GetClientAction()
C#
public ISNet.WebUI.BaseClientSideAction GetClientAction()
Delphi
public function GetClientAction(): ISNet.WebUI.BaseClientSideAction;
JScript
public function GetClientAction() : ISNet.WebUI.BaseClientSideAction;
Managed Extensions for C++
public: ISNet.WebUI.BaseClientSideAction* GetClientAction();
C++/CLI
public:
ISNet.WebUI.BaseClientSideAction^ GetClientAction();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


GetCulture Method

[image]
Intersoft WebScheduler Documentation
GetCulture Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : GetCulture Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCulture() As System.Globalization.CultureInfo
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Globalization.CultureInfo

value = instance.GetCulture()
C#
public System.Globalization.CultureInfo GetCulture()
Delphi
public function GetCulture(): System.Globalization.CultureInfo;
JScript
public function GetCulture() : System.Globalization.CultureInfo;
Managed Extensions for C++
public: System.Globalization.CultureInfo* GetCulture();
C++/CLI
public:
System.Globalization.CultureInfo^ GetCulture();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


GetStartDateOfMonth Method

[image]
Intersoft WebScheduler Documentation
GetStartDateOfMonth Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : GetStartDateOfMonth Method

selectedDate

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetStartDateOfMonth( _
   ByVal selectedDate As System.Date _
) As System.Date
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim selectedDate As System.Date
Dim value As System.Date

value = instance.GetStartDateOfMonth(selectedDate)
C#
public System.DateTime GetStartDateOfMonth(
   System.DateTime selectedDate
)
Delphi
public function GetStartDateOfMonth(
    selectedDate: System.DateTime
): System.DateTime;
JScript
public function GetStartDateOfMonth(
   selectedDate : System.DateTime
) : System.DateTime;
Managed Extensions for C++
public: System.DateTime GetStartDateOfMonth(
   System.DateTime selectedDate
)
C++/CLI
public:
System.DateTime GetStartDateOfMonth(
   System.DateTime selectedDate
)

Parameters

selectedDate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


GetStartDateOfWeek(DateTime) Method

[image]
Intersoft WebScheduler Documentation
GetStartDateOfWeek(DateTime) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : GetStartDateOfWeek(DateTime) Method

selectedDate

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetStartDateOfWeek( _
   ByVal selectedDate As System.Date _
) As System.Date
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim selectedDate As System.Date
Dim value As System.Date

value = instance.GetStartDateOfWeek(selectedDate)
C#
public System.DateTime GetStartDateOfWeek(
   System.DateTime selectedDate
)
Delphi
public function GetStartDateOfWeek(
    selectedDate: System.DateTime
): System.DateTime;
JScript
public function GetStartDateOfWeek(
   selectedDate : System.DateTime
) : System.DateTime;
Managed Extensions for C++
public: System.DateTime GetStartDateOfWeek(
   System.DateTime selectedDate
)
C++/CLI
public:
System.DateTime GetStartDateOfWeek(
   System.DateTime selectedDate
)

Parameters

selectedDate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


GetXMLCultureInfo Method

[image]
Intersoft WebScheduler Documentation
GetXMLCultureInfo Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : GetXMLCultureInfo Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function GetXMLCultureInfo() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Object

value = instance.GetXMLCultureInfo()
C#
public override System.object GetXMLCultureInfo()
Delphi
public function GetXMLCultureInfo(): System.TObject; override;
JScript
public override function GetXMLCultureInfo() : System.Object;
Managed Extensions for C++
public: System.Object* GetXMLCultureInfo(); override
C++/CLI
public:
System.Object^ GetXMLCultureInfo(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


OnDataBound Method

[image]
Intersoft WebScheduler Documentation
OnDataBound Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : OnDataBound Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnDataBound( _
   ByVal e As WebSchedulerDataBoundDataArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim e As WebSchedulerDataBoundDataArgs

instance.OnDataBound(e)
C#
public virtual void OnDataBound(
   WebSchedulerDataBoundDataArgs e
)
Delphi
public procedure OnDataBound(
    e: WebSchedulerDataBoundDataArgs
); virtual;
JScript
public function OnDataBound(
   e : WebSchedulerDataBoundDataArgs
);
Managed Extensions for C++
public: virtual void OnDataBound(
   WebSchedulerDataBoundDataArgs* e
)
C++/CLI
public:
virtual void OnDataBound(
   WebSchedulerDataBoundDataArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


OnExport Method

[image]
Intersoft WebScheduler Documentation
OnExport Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : OnExport Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnExport( _
   ByVal e As WebSchedulerExportEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim e As WebSchedulerExportEventArgs

instance.OnExport(e)
C#
public virtual void OnExport(
   WebSchedulerExportEventArgs e
)
Delphi
public procedure OnExport(
    e: WebSchedulerExportEventArgs
); virtual;
JScript
public function OnExport(
   e : WebSchedulerExportEventArgs
);
Managed Extensions for C++
public: virtual void OnExport(
   WebSchedulerExportEventArgs* e
)
C++/CLI
public:
virtual void OnExport(
   WebSchedulerExportEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


OnJsonSerialization Method

[image]
Intersoft WebScheduler Documentation
OnJsonSerialization Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : OnJsonSerialization Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnJsonSerialization( _
   ByVal e As WebSchedulerJsonSerializationArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim e As WebSchedulerJsonSerializationArgs

instance.OnJsonSerialization(e)
C#
public virtual void OnJsonSerialization(
   WebSchedulerJsonSerializationArgs e
)
Delphi
public procedure OnJsonSerialization(
    e: WebSchedulerJsonSerializationArgs
); virtual;
JScript
public function OnJsonSerialization(
   e : WebSchedulerJsonSerializationArgs
);
Managed Extensions for C++
public: virtual void OnJsonSerialization(
   WebSchedulerJsonSerializationArgs* e
)
C++/CLI
public:
virtual void OnJsonSerialization(
   WebSchedulerJsonSerializationArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


OnPrepareExportExecute Method

[image]
Intersoft WebScheduler Documentation
OnPrepareExportExecute Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : OnPrepareExportExecute Method

e

Glossary Item Box

Invokes when export action is about to be performed.

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnPrepareExportExecute( _
   ByVal e As WebSchedulerPrepareExportExecuteEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim e As WebSchedulerPrepareExportExecuteEventArgs

instance.OnPrepareExportExecute(e)
C#
public virtual void OnPrepareExportExecute(
   WebSchedulerPrepareExportExecuteEventArgs e
)
Delphi
public procedure OnPrepareExportExecute(
    e: WebSchedulerPrepareExportExecuteEventArgs
); virtual;
JScript
public function OnPrepareExportExecute(
   e : WebSchedulerPrepareExportExecuteEventArgs
);
Managed Extensions for C++
public: virtual void OnPrepareExportExecute(
   WebSchedulerPrepareExportExecuteEventArgs* e
)
C++/CLI
public:
virtual void OnPrepareExportExecute(
   WebSchedulerPrepareExportExecuteEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


RaisePostBackEvent Method

[image]
Intersoft WebScheduler Documentation
RaisePostBackEvent Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : RaisePostBackEvent Method

eventArgument

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RaisePostBackEvent( _
   ByVal eventArgument As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim eventArgument As System.String

instance.RaisePostBackEvent(eventArgument)
C#
public void RaisePostBackEvent(
   System.string eventArgument
)
Delphi
public procedure RaisePostBackEvent(
    eventArgument: System.String
);
JScript
public function RaisePostBackEvent(
   eventArgument : System.String
);
Managed Extensions for C++
public: void RaisePostBackEvent(
   System.string* eventArgument
)
C++/CLI
public:
void RaisePostBackEvent(
   System.String^ eventArgument
)

Parameters

eventArgument

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


RecreateChildControls Method

[image]
Intersoft WebScheduler Documentation
RecreateChildControls Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : RecreateChildControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RecreateChildControls()
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler

instance.RecreateChildControls()
C#
public void RecreateChildControls()
Delphi
public procedure RecreateChildControls();
JScript
public function RecreateChildControls();
Managed Extensions for C++
public: void RecreateChildControls();
C++/CLI
public:
void RecreateChildControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


RegisterScript Method

[image]
Intersoft WebScheduler Documentation
RegisterScript Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : RegisterScript Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RegisterScript()
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler

instance.RegisterScript()
C#
public override void RegisterScript()
Delphi
public procedure RegisterScript(); override;
JScript
public override function RegisterScript();
Managed Extensions for C++
public: void RegisterScript(); override
C++/CLI
public:
void RegisterScript(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


RenderEndTag Method

[image]
Intersoft WebScheduler Documentation
RenderEndTag Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : RenderEndTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
C#
public override void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderEndTag(
    writer: System.Web.UI.HtmlTextWriter
); override;
JScript
public override function RenderEndTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: void RenderEndTag(
   System.Web.UI.HtmlTextWriter* writer
) override
C++/CLI
public:
void RenderEndTag(
   System.Web.UI.HtmlTextWriter^ writer
) override

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ShouldReturnJson Method

[image]
Intersoft WebScheduler Documentation
ShouldReturnJson Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ShouldReturnJson Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ShouldReturnJson() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

value = instance.ShouldReturnJson()
C#
public override System.bool ShouldReturnJson()
Delphi
public function ShouldReturnJson(): System.Boolean; override;
JScript
public override function ShouldReturnJson() : System.boolean;
Managed Extensions for C++
public: System.bool ShouldReturnJson(); override
C++/CLI
public:
System.bool ShouldReturnJson(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


WebScheduler Class Properties

[image]
Intersoft WebScheduler Documentation
WebScheduler Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebScheduler Class

Glossary Item Box

For a list of all members of this type, see WebScheduler members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ActiveDayStyle | Contains interactive style for Active Day.
Public Property | AgendaActionStyle | Contains interactive style for Agenda Action.
Public Property | AgendaAlternativeRowStyle | Contains interactive style for Agenda AlternativeRow.
Public Property | AgendaDateColumnStyle | Contains interactive style for Agenda DateColumn.
Public Property | AgendaRowStyle | Contains interactive style for Agenda Row.
Public Property | AllDayEventAreaStyle | Contains interactive style for AllDayEvent Area.
Public Property | AllDayEventStyle | Contains interactive style for AllDayEvent.
Public Property | AllowCreateEventInHoliday | Specifies whether the event(s) is allowed to be created when the day is holiday.
Public Property | AllowDropFromExtender | Specifies whether drag object of WebDragDropExtender is allowed to be dropped in WebScheduler.
Public Property | BackColor | Background's color of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderColor | Color of the border around the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderStyle | Style of the border around the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderWidth | Width of the border around the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | CalendarFrameStyle | Contains interactive style for Calendar Frame.
Public Property | CalendarHeaderStyle | Contains interactive style for Calendar Header.
Public Property | CalendarInboundCellStyle | Contains interactive style for Calendar InboundCell.
Public Property | CalendarOutboundCellStyle | Contains interactive style for Calendar OutboundCell.
Public Property | CalendarSelectedCellStyle | Contains interactive style for Calendar SelectedCell.
Public Property | CalendarSettings | Provides the settings that control the behaviors of the calendar in WebScheduler.
Public Property | CalendarTableStyle | Contains interactive style for Calendar Table.
Public Property | CalendarTodayStyle | Contains interactive style for Calendar Today.
Public Property | CalendarWeekNameStyle | Contains interactive style for Calendar WeekNumberName.
Public Property | CalendarWeekNumberStyle | Contains interactive style for Calendar WeekNumber.
Public Property | Categories | The data collection used by WebScheduler as the categories.
Public Property | CategoriesDataMember | Sets the categories data member.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains client side events supported by WebScheduler.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | CssClass | CSS Class name applied to the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Culture | Specifies the culture setting for current WebScheduler instance.
Public Property | DataBinding | Provides the settings for WebScheduler's data binding.
Public Property | DataEditing | Provides the settings that control the behaviors of the data editing in WebScheduler.
Public Property | DataSourceID | Gets or sets the ID of the control from which the WebScheduler control retrieves its datasource.
Public Property | DataSourceManager | Overridden.
Public Property | DayHeaderStyle | Contains interactive style for Day Header.
Public Property | DefaultResource | Gets or sets the default resource when Resources is not defined.
Public Property | DefaultStyleMode | Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.
Public Property | DisabledAllDayEventAreaStyle | Contains interactive style for disabled cells in AllDayEvent Area.
Public Property | DisabledMonthInboundCellStyle | Contains interactive style for disabled inbound cells in Month view.
Public Property | DisabledMonthOutboundCellStyle | Contains interactive style for disabled outbound cells in Month view.
Public Property | DisabledNonWorkHourStyle | Contains interactive style for non work hour cells that are set as disabled.
Public Property | DisabledTime | The data collection used by WebScheduler as the disabled time.
Public Property | DisabledWorkHourStyle | Contains interactive style for work hour cells that are set as disabled.
Public Property | DisplayEventCountOnlyInTooltip | Indicates whether the calendar's tooltip should show event count only or not.
Public Property | DisplayResourcesTable | Indicates whether the resources table is visible or not.
Public Property | EditingButtonStyle | Contains interactive style for the EditingButton.
Public Property | EditingField | The data collection used by WebScheduler as the CallOut's EditingField.
Public Property | EditingFormStyle | Determines which style mode is used in built-in editing form.
Public Property | EditingTextStyle | Contains interactive style for the text of EditingField.
Public Property | EditingUrl | Sets the EditingForm's url
Public Property | EmptyCellClickAction | Specifies Specifies the behavior when empty cell is clicked.
Public Property | EnableAnimation | Specifies whether animation of WebScheduler's CallOut should be enabled or disabled.
Public Property | EnableContextMenu | Specifies whether ContextMenu should appear when right clicking on event(s) or not.
Public Property | Enabled | Enables state of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableExport | Specifies whether or not scheduler export should be enabled in UI.
Public Property | EnableFastJsonSerialization | Gets or sets a value that determines whether or not fast JSON serialization is enabled.
Public Property | EnableManagedTheming | Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableMultipleCellSelection | Gets or sets a value that determines whether or not multiple cell selection is enabled.
Public Property | EnableSplitViewInitially | Specifies whether or not SplitView should be enabled initially.
Public Property | EnableTheming | Indicates whether the control can be themed. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Indicates whether control automatically saves its state for use in round-trips. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EventsDataMember | Sets the events data member.
Public Property | ExtendedCategoryTypeName | Gets or sets the extended category type name.
Public Property | ExtendedEventTypeName | Gets or sets the extended event type name.
Public Property | ExtendedRecurringEventTypeName | Gets or sets the extended event type name.
Public Property | ExtendedResourceTypeName | Gets or sets the extended resource type name.
Public Property | FlyPostBackSettings | Configures the settings used by the control when performing OnTheFly postback.
Public Property | Font | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ForeColor | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | GridLineStyle | Contains interactive style for Grid Line.
Public Property | Height | The height of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Holidays | The data collection used by WebScheduler to determine holiday(s).
Public Property | HolidayStyle | Contains interactive style for Holiday.
Public Property | HourAreaStyle | Contains interactive style for Hour Area.
Public Property | ID | Programmatic name of the control. (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the images directory for ImagesSettings.
Public Property | ImagesSettings | Provides the settings that control the images in WebScheduler.
Public Property | IncludeSplitViewInMenu | Specifies whether or not SplitView option should be included in context menu and More menu.
Public Property | IncludeTimeIntervalInMenu | Specifies whether time interval options should be included in menu.
Public Property | LayoutSettings | Provides the settings that control the behaviors of the layout in WebScheduler.
Public Property | LoadOnDemandMode | Gets or sets a value that determines the mode of LoadOnDemand.
Public Property | MarkedDayWithEvents | Specifies whether Calendar's number of WebScheduler that contain event(s) should be marked with bold style or not.
Public Property | MonthDayHeaderStyle | Contains interactive style for for day header in Month view.
Public Property | MonthInboundCellStyle | Contains interactive style for MonthInboundCell.
Public Property | MonthInboundDateHeaderStyle | Contains interactive style for MonthInboundDateHeader.
Public Property | MonthOutboundCellStyle | Contains interactive style for MonthOutboundCell.
Public Property | MonthOutboundDateHeaderStyle | Contains interactive style for MonthOutboundDateHeader.
Public Property | MonthSelectedCellStyle | Contains interactive style for MonthSelectedCell.
Public Property | NonWorkHourStyle | Contains interactive style for Non WorkHour.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RecurrenceDataMember | Sets the recurrence data member.
Public Property | RecurringEventsDataMember | Sets the recurring events data member.
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ResourcesContentMode | Specifies Timeline Resource container mode.
Public Property | ResourcesDataMember | Sets the resources data member.
Public Property | ResourcesFrameStyle | Contains interactive style for Resources Frame.
Public Property | ResourcesHeaderStyle | Contains interactive style for Resources Header.
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | SchedulerFrameStyle | Contains interactive style for Scheduler Frame.
Public Property | SchedulerHeaderStyle | Contains interactive style for Scheduler Header.
Public Property | SchedulerTodayAllDayEventAreaStyle | Contains interactive style for Scheduler TodayAllDayEventArea.
Public Property | SchedulerTodayCellStyle | Contains interactive style for Scheduler TodayCell.
Public Property | SchedulerTodayHeaderStyle | Contains interactive style for Scheduler TodayHeader.
Public Property | SchedulerTodayHourStyle | Contains interactive style for Scheduler TodayHour.
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SelectedHourStyle | Contains interactive style for Selected Hour.
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all required framework scripts for the control are stored.
Public Property | ShowWeekNumbers | Specifies whether WebScheduler should show week number or not.
Public Property | SkinID | The id of the control skin. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | The tab order of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TextSettings | Provides settings that control text that shown in WebScheduler.
Public Property | TimeBasedEventStyle | Contains interactive style for TimeBasedEvent.
Public Property | TimelineContentCellStyle | Contains interactive style for Timeline ContentCell.
Public Property | TimelineDateCellStyle | Contains interactive style for Timeline DateCell.
Public Property | TimelineDisabledTimeCellStyle | Contains interactive style for Timeline DisabledTime cell.
Public Property | TimelineResourceCellStyle | Contains interactive style for Timeline ResouceCell.
Public Property | TimelineResourceHeaderTextCellStyle | Contains interactive style for Timeline ResourceCellText.
Public Property | TimelineTimeCellStyle | Contains interactive style for Timeline TimeCell.
Public Property | ToolTip | The tooltip displayed when the mouse is over the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | UseDefaultStyle | Specifies whether WebScheduler should apply embedded default style for its appearance.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewHeaderFrameStyle | Contains interactive style for ViewHeader Frame.
Public Property | ViewHeaderStyle | Contains interactive style for ViewHeader.
Public Property | ViewSettings | Provides the settings that control the behaviors of the view in WebScheduler.
Public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | Indicates whether the control is visible and rendered. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | WebDesktopScriptDirectory | Gets or sets the IIS path to locate WebDesktop's script directory. This property is only applicable when SmartWebResources is not enabled.
Public Property | WeekOptionFrameStyle | Contains interactive style for WeekOption Frame.
Public Property | Width | The width of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | WorkHourStyle | Contains interactive style for Work Hour.
Public Property | WorkWeekSettings | Provides the settings that control the behaviors of the WorkWeek in WebScheduler.
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for client side state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | YearDayOfWeekStyle | Contains interactive style for YearDayOfWeek.
Public Property | YearFrameStyle | Contains interactive style for Year Frame.
Public Property | YearMonthRowHeaderStyle | Contains interactive style for the Year, Quarter and Month row header.
Top

See Also

Reference

WebScheduler Class
ISNet.WebUI.WebScheduler Namespace


ActiveDayStyle Property

[image]
Intersoft WebScheduler Documentation
ActiveDayStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ActiveDayStyle Property

Glossary Item Box

Contains interactive style for Active Day.

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Active Day")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.CategoryAttribute("Style - Day / Week View")>
Public Property ActiveDayStyle As WebSchedulerActiveDayStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As WebSchedulerActiveDayStyle

instance.ActiveDayStyle = value

value = instance.ActiveDayStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Active Day")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Style - Day / Week View")]
public WebSchedulerActiveDayStyle ActiveDayStyle {get; set;}
Delphi
public read-write property ActiveDayStyle: WebSchedulerActiveDayStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for Active Day")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.CategoryAttribute("Style - Day / Week View")
public function get,set ActiveDayStyle : WebSchedulerActiveDayStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Active Day")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Style - Day / Week View")]
public: __property WebSchedulerActiveDayStyle* get_ActiveDayStyle();
public: __property void set_ActiveDayStyle(
   WebSchedulerActiveDayStyle* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Active Day")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Style - Day / Week View")]
public:
property WebSchedulerActiveDayStyle^ ActiveDayStyle {
   WebSchedulerActiveDayStyle^ get();
   void set (    WebSchedulerActiveDayStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


AgendaActionStyle Property

[image]
Intersoft WebScheduler Documentation
AgendaActionStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : AgendaActionStyle Property

Glossary Item Box

Contains interactive style for Agenda Action.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Style - Agenda View")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for the Agenda Action.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AgendaActionStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.DynamicStyle

instance.AgendaActionStyle = value

value = instance.AgendaActionStyle
C#
[System.ComponentModel.CategoryAttribute("Style - Agenda View")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the Agenda Action.")]
[System.ComponentModel.DefaultValueAttribute()]
public ISNet.WebUI.DynamicStyle AgendaActionStyle {get; set;}
Delphi
public read-write property AgendaActionStyle: ISNet.WebUI.DynamicStyle;
JScript
System.ComponentModel.CategoryAttribute("Style - Agenda View")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for the Agenda Action.")
System.ComponentModel.DefaultValueAttribute()
public function get,set AgendaActionStyle : ISNet.WebUI.DynamicStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Style - Agenda View")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the Agenda Action.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.DynamicStyle* get_AgendaActionStyle();
public: __property void set_AgendaActionStyle(
   ISNet.WebUI.DynamicStyle* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Style - Agenda View")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the Agenda Action.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.DynamicStyle^ AgendaActionStyle {
   ISNet.WebUI.DynamicStyle^ get();
   void set (    ISNet.WebUI.DynamicStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


AgendaAlternativeRowStyle Property

[image]
Intersoft WebScheduler Documentation
AgendaAlternativeRowStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : AgendaAlternativeRowStyle Property

Glossary Item Box

Contains interactive style for Agenda AlternativeRow.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Style - Agenda View")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Agenda AlternativeRow.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property AgendaAlternativeRowStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.AgendaAlternativeRowStyle = value

value = instance.AgendaAlternativeRowStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style - Agenda View")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Agenda AlternativeRow.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ISNet.WebUI.WebStyle AgendaAlternativeRowStyle {get; set;}
Delphi
public read-write property AgendaAlternativeRowStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Style - Agenda View")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Contains interactive style for Agenda AlternativeRow.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set AgendaAlternativeRowStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style - Agenda View")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Agenda AlternativeRow.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ISNet.WebUI.WebStyle* get_AgendaAlternativeRowStyle();
public: __property void set_AgendaAlternativeRowStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style - Agenda View")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Agenda AlternativeRow.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ISNet.WebUI.WebStyle^ AgendaAlternativeRowStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


AgendaDateColumnStyle Property

[image]
Intersoft WebScheduler Documentation
AgendaDateColumnStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : AgendaDateColumnStyle Property

Glossary Item Box

Contains interactive style for Agenda DateColumn.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Agenda DateColumn.")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Style - Agenda View")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AgendaDateColumnStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.AgendaDateColumnStyle = value

value = instance.AgendaDateColumnStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Agenda DateColumn.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Agenda View")]
[System.ComponentModel.DefaultValueAttribute()]
public ISNet.WebUI.WebStyle AgendaDateColumnStyle {get; set;}
Delphi
public read-write property AgendaDateColumnStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.DescriptionAttribute("Contains interactive style for Agenda DateColumn.")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Style - Agenda View")
System.ComponentModel.DefaultValueAttribute()
public function get,set AgendaDateColumnStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Agenda DateColumn.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Agenda View")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.WebStyle* get_AgendaDateColumnStyle();
public: __property void set_AgendaDateColumnStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Agenda DateColumn.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Agenda View")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.WebStyle^ AgendaDateColumnStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


AgendaRowStyle Property

[image]
Intersoft WebScheduler Documentation
AgendaRowStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : AgendaRowStyle Property

Glossary Item Box

Contains interactive style for Agenda Row.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Style - Agenda View")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Agenda Row.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property AgendaRowStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.AgendaRowStyle = value

value = instance.AgendaRowStyle
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Agenda View")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Agenda Row.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ISNet.WebUI.WebStyle AgendaRowStyle {get; set;}
Delphi
public read-write property AgendaRowStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Style - Agenda View")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DescriptionAttribute("Contains interactive style for Agenda Row.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set AgendaRowStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Agenda View")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Agenda Row.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ISNet.WebUI.WebStyle* get_AgendaRowStyle();
public: __property void set_AgendaRowStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Agenda View")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Agenda Row.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ISNet.WebUI.WebStyle^ AgendaRowStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


AllDayEventAreaStyle Property

[image]
Intersoft WebScheduler Documentation
AllDayEventAreaStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : AllDayEventAreaStyle Property

Glossary Item Box

Contains interactive style for AllDayEvent Area.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Style - Day / Week View")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for AllDayEvent Area.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
Public Property AllDayEventAreaStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.AllDayEventAreaStyle = value

value = instance.AllDayEventAreaStyle
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Style - Day / Week View")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for AllDayEvent Area.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public ISNet.WebUI.WebStyle AllDayEventAreaStyle {get; set;}
Delphi
public read-write property AllDayEventAreaStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Style - Day / Week View")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for AllDayEvent Area.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
public function get,set AllDayEventAreaStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Style - Day / Week View")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for AllDayEvent Area.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public: __property ISNet.WebUI.WebStyle* get_AllDayEventAreaStyle();
public: __property void set_AllDayEventAreaStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Style - Day / Week View")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for AllDayEvent Area.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public:
property ISNet.WebUI.WebStyle^ AllDayEventAreaStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


AllDayEventStyle Property

[image]
Intersoft WebScheduler Documentation
AllDayEventStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : AllDayEventStyle Property

Glossary Item Box

Contains interactive style for AllDayEvent.

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for AllDayEvent.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.CategoryAttribute("Style - Event")>
Public Property AllDayEventStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.AllDayEventStyle = value

value = instance.AllDayEventStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for AllDayEvent.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Style - Event")]
public ISNet.WebUI.WebStyle AllDayEventStyle {get; set;}
Delphi
public read-write property AllDayEventStyle: ISNet.WebUI.WebStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for AllDayEvent.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.CategoryAttribute("Style - Event")
public function get,set AllDayEventStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for AllDayEvent.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Style - Event")]
public: __property ISNet.WebUI.WebStyle* get_AllDayEventStyle();
public: __property void set_AllDayEventStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for AllDayEvent.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Style - Event")]
public:
property ISNet.WebUI.WebStyle^ AllDayEventStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


AllowCreateEventInHoliday Property

[image]
Intersoft WebScheduler Documentation
AllowCreateEventInHoliday Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : AllowCreateEventInHoliday Property

Glossary Item Box

Specifies whether the event(s) is allowed to be created when the day is holiday.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether the event(s) is allowed to be created when the day is holiday")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AllowCreateEventInHoliday As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

instance.AllowCreateEventInHoliday = value

value = instance.AllowCreateEventInHoliday
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether the event(s) is allowed to be created when the day is holiday")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool AllowCreateEventInHoliday {get; set;}
Delphi
public read-write property AllowCreateEventInHoliday: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether the event(s) is allowed to be created when the day is holiday")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set AllowCreateEventInHoliday : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether the event(s) is allowed to be created when the day is holiday")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_AllowCreateEventInHoliday();
public: __property void set_AllowCreateEventInHoliday(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether the event(s) is allowed to be created when the day is holiday")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool AllowCreateEventInHoliday {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


AllowDropFromExtender Property

[image]
Intersoft WebScheduler Documentation
AllowDropFromExtender Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : AllowDropFromExtender Property

Glossary Item Box

Specifies whether drag object of WebDragDropExtender is allowed to be dropped in WebScheduler.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Specifies whether drag object of WebDragDropExtender is allowed to be dropped in WebScheduler.")>
Public Property AllowDropFromExtender As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

instance.AllowDropFromExtender = value

value = instance.AllowDropFromExtender
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies whether drag object of WebDragDropExtender is allowed to be dropped in WebScheduler.")]
public System.bool AllowDropFromExtender {get; set;}
Delphi
public read-write property AllowDropFromExtender: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Specifies whether drag object of WebDragDropExtender is allowed to be dropped in WebScheduler.")
public function get,set AllowDropFromExtender : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies whether drag object of WebDragDropExtender is allowed to be dropped in WebScheduler.")]
public: __property System.bool get_AllowDropFromExtender();
public: __property void set_AllowDropFromExtender(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies whether drag object of WebDragDropExtender is allowed to be dropped in WebScheduler.")]
public:
property System.bool AllowDropFromExtender {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


CalendarFrameStyle Property

[image]
Intersoft WebScheduler Documentation
CalendarFrameStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : CalendarFrameStyle Property

Glossary Item Box

Contains interactive style for Calendar Frame.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Style - Calendar")>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar Frame.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
Public Property CalendarFrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.CalendarFrameStyle = value

value = instance.CalendarFrameStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Calendar")]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar Frame.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public ISNet.WebUI.WebStyle CalendarFrameStyle {get; set;}
Delphi
public read-write property CalendarFrameStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Style - Calendar")
System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar Frame.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
public function get,set CalendarFrameStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Calendar")]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar Frame.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public: __property ISNet.WebUI.WebStyle* get_CalendarFrameStyle();
public: __property void set_CalendarFrameStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Calendar")]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar Frame.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public:
property ISNet.WebUI.WebStyle^ CalendarFrameStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


CalendarHeaderStyle Property

[image]
Intersoft WebScheduler Documentation
CalendarHeaderStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : CalendarHeaderStyle Property

Glossary Item Box

Contains interactive style for Calendar Header.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar Header.")>
<System.ComponentModel.CategoryAttribute("Style - Calendar")>
Public Property CalendarHeaderStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.CalendarHeaderStyle = value

value = instance.CalendarHeaderStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar Header.")]
[System.ComponentModel.CategoryAttribute("Style - Calendar")]
public ISNet.WebUI.WebStyle CalendarHeaderStyle {get; set;}
Delphi
public read-write property CalendarHeaderStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar Header.")
System.ComponentModel.CategoryAttribute("Style - Calendar")
public function get,set CalendarHeaderStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar Header.")]
[System.ComponentModel.CategoryAttribute("Style - Calendar")]
public: __property ISNet.WebUI.WebStyle* get_CalendarHeaderStyle();
public: __property void set_CalendarHeaderStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar Header.")]
[System.ComponentModel.CategoryAttribute("Style - Calendar")]
public:
property ISNet.WebUI.WebStyle^ CalendarHeaderStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


CalendarInboundCellStyle Property

[image]
Intersoft WebScheduler Documentation
CalendarInboundCellStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : CalendarInboundCellStyle Property

Glossary Item Box

Contains interactive style for Calendar InboundCell.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar InboundCell.")>
<System.ComponentModel.CategoryAttribute("Style - Calendar")>
Public Property CalendarInboundCellStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.CalendarInboundCellStyle = value

value = instance.CalendarInboundCellStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar InboundCell.")]
[System.ComponentModel.CategoryAttribute("Style - Calendar")]
public ISNet.WebUI.WebStyle CalendarInboundCellStyle {get; set;}
Delphi
public read-write property CalendarInboundCellStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar InboundCell.")
System.ComponentModel.CategoryAttribute("Style - Calendar")
public function get,set CalendarInboundCellStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar InboundCell.")]
[System.ComponentModel.CategoryAttribute("Style - Calendar")]
public: __property ISNet.WebUI.WebStyle* get_CalendarInboundCellStyle();
public: __property void set_CalendarInboundCellStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar InboundCell.")]
[System.ComponentModel.CategoryAttribute("Style - Calendar")]
public:
property ISNet.WebUI.WebStyle^ CalendarInboundCellStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


CalendarOutboundCellStyle Property

[image]
Intersoft WebScheduler Documentation
CalendarOutboundCellStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : CalendarOutboundCellStyle Property

Glossary Item Box

Contains interactive style for Calendar OutboundCell.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar OutboundCell.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Style - Calendar")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CalendarOutboundCellStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.CalendarOutboundCellStyle = value

value = instance.CalendarOutboundCellStyle
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar OutboundCell.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - Calendar")]
[System.ComponentModel.DefaultValueAttribute()]
public ISNet.WebUI.WebStyle CalendarOutboundCellStyle {get; set;}
Delphi
public read-write property CalendarOutboundCellStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar OutboundCell.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Style - Calendar")
System.ComponentModel.DefaultValueAttribute()
public function get,set CalendarOutboundCellStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar OutboundCell.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - Calendar")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.WebStyle* get_CalendarOutboundCellStyle();
public: __property void set_CalendarOutboundCellStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar OutboundCell.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - Calendar")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.WebStyle^ CalendarOutboundCellStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


CalendarSelectedCellStyle Property

[image]
Intersoft WebScheduler Documentation
CalendarSelectedCellStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : CalendarSelectedCellStyle Property

Glossary Item Box

Contains interactive style for Calendar SelectedCell.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar SelectedCell.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Style - Calendar")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property CalendarSelectedCellStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.CalendarSelectedCellStyle = value

value = instance.CalendarSelectedCellStyle
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar SelectedCell.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Calendar")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ISNet.WebUI.WebStyle CalendarSelectedCellStyle {get; set;}
Delphi
public read-write property CalendarSelectedCellStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar SelectedCell.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Style - Calendar")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set CalendarSelectedCellStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar SelectedCell.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Calendar")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ISNet.WebUI.WebStyle* get_CalendarSelectedCellStyle();
public: __property void set_CalendarSelectedCellStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar SelectedCell.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Calendar")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ISNet.WebUI.WebStyle^ CalendarSelectedCellStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


CalendarSettings Property

[image]
Intersoft WebScheduler Documentation
CalendarSettings Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : CalendarSettings Property

Glossary Item Box

Provides the settings that control the behaviors of the calendar in WebScheduler.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setCalendarSettings")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the calendar in WebScheduler.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property CalendarSettings As WebSchedulerCalendarSettings
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As WebSchedulerCalendarSettings

value = instance.CalendarSettings
C#
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setCalendarSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the calendar in WebScheduler.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public WebSchedulerCalendarSettings CalendarSettings {get;}
Delphi
public read-only property CalendarSettings: WebSchedulerCalendarSettings;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setCalendarSettings")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the calendar in WebScheduler.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get CalendarSettings : WebSchedulerCalendarSettings
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setCalendarSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the calendar in WebScheduler.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebSchedulerCalendarSettings* get_CalendarSettings();
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setCalendarSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the calendar in WebScheduler.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebSchedulerCalendarSettings^ CalendarSettings {
   WebSchedulerCalendarSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


CalendarTableStyle Property

[image]
Intersoft WebScheduler Documentation
CalendarTableStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : CalendarTableStyle Property

Glossary Item Box

Contains interactive style for Calendar Table.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar Table.")>
<System.ComponentModel.CategoryAttribute("Style - Calendar")>
Public Property CalendarTableStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.CalendarTableStyle = value

value = instance.CalendarTableStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar Table.")]
[System.ComponentModel.CategoryAttribute("Style - Calendar")]
public ISNet.WebUI.WebStyle CalendarTableStyle {get; set;}
Delphi
public read-write property CalendarTableStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar Table.")
System.ComponentModel.CategoryAttribute("Style - Calendar")
public function get,set CalendarTableStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar Table.")]
[System.ComponentModel.CategoryAttribute("Style - Calendar")]
public: __property ISNet.WebUI.WebStyle* get_CalendarTableStyle();
public: __property void set_CalendarTableStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar Table.")]
[System.ComponentModel.CategoryAttribute("Style - Calendar")]
public:
property ISNet.WebUI.WebStyle^ CalendarTableStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


CalendarTodayStyle Property

[image]
Intersoft WebScheduler Documentation
CalendarTodayStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : CalendarTodayStyle Property

Glossary Item Box

Contains interactive style for Calendar Today.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar Today.")>
<System.ComponentModel.CategoryAttribute("Style - Calendar")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property CalendarTodayStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.CalendarTodayStyle = value

value = instance.CalendarTodayStyle
C#
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar Today.")]
[System.ComponentModel.CategoryAttribute("Style - Calendar")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ISNet.WebUI.WebStyle CalendarTodayStyle {get; set;}
Delphi
public read-write property CalendarTodayStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar Today.")
System.ComponentModel.CategoryAttribute("Style - Calendar")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set CalendarTodayStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar Today.")]
[System.ComponentModel.CategoryAttribute("Style - Calendar")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ISNet.WebUI.WebStyle* get_CalendarTodayStyle();
public: __property void set_CalendarTodayStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar Today.")]
[System.ComponentModel.CategoryAttribute("Style - Calendar")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ISNet.WebUI.WebStyle^ CalendarTodayStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


CalendarWeekNameStyle Property

[image]
Intersoft WebScheduler Documentation
CalendarWeekNameStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : CalendarWeekNameStyle Property

Glossary Item Box

Contains interactive style for Calendar WeekNumberName.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar WeekNumberName.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Style - Calendar")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CalendarWeekNameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.CalendarWeekNameStyle = value

value = instance.CalendarWeekNameStyle
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar WeekNumberName.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - Calendar")]
[System.ComponentModel.DefaultValueAttribute()]
public ISNet.WebUI.WebStyle CalendarWeekNameStyle {get; set;}
Delphi
public read-write property CalendarWeekNameStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar WeekNumberName.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Style - Calendar")
System.ComponentModel.DefaultValueAttribute()
public function get,set CalendarWeekNameStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar WeekNumberName.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - Calendar")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.WebStyle* get_CalendarWeekNameStyle();
public: __property void set_CalendarWeekNameStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar WeekNumberName.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - Calendar")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.WebStyle^ CalendarWeekNameStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


CalendarWeekNumberStyle Property

[image]
Intersoft WebScheduler Documentation
CalendarWeekNumberStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : CalendarWeekNumberStyle Property

Glossary Item Box

Contains interactive style for Calendar WeekNumber.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Style - Calendar")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar WeekNumber.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CalendarWeekNumberStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.CalendarWeekNumberStyle = value

value = instance.CalendarWeekNumberStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Calendar")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar WeekNumber.")]
[System.ComponentModel.DefaultValueAttribute()]
public ISNet.WebUI.WebStyle CalendarWeekNumberStyle {get; set;}
Delphi
public read-write property CalendarWeekNumberStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Style - Calendar")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar WeekNumber.")
System.ComponentModel.DefaultValueAttribute()
public function get,set CalendarWeekNumberStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Calendar")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar WeekNumber.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.WebStyle* get_CalendarWeekNumberStyle();
public: __property void set_CalendarWeekNumberStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Calendar")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Calendar WeekNumber.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.WebStyle^ CalendarWeekNumberStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


Categories Property

[image]
Intersoft WebScheduler Documentation
Categories Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : Categories Property

Glossary Item Box

The data collection used by WebScheduler as the categories.

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("The data collection used by WebScheduler as the categories.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setCategories")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Data")>
Public ReadOnly Property Categories As WebSchedulerCategoryCollection
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As WebSchedulerCategoryCollection

value = instance.Categories
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("The data collection used by WebScheduler as the categories.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setCategories")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Data")]
public WebSchedulerCategoryCollection Categories {get;}
Delphi
public read-only property Categories: WebSchedulerCategoryCollection;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("The data collection used by WebScheduler as the categories.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setCategories")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Data")
public function get Categories : WebSchedulerCategoryCollection
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("The data collection used by WebScheduler as the categories.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setCategories")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Data")]
public: __property WebSchedulerCategoryCollection* get_Categories();
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("The data collection used by WebScheduler as the categories.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setCategories")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Data")]
public:
property WebSchedulerCategoryCollection^ Categories {
   WebSchedulerCategoryCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


CategoriesDataMember Property

[image]
Intersoft WebScheduler Documentation
CategoriesDataMember Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : CategoriesDataMember Property

Glossary Item Box

Sets the categories data member.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Sets the categories data member.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Data")>
Public Property CategoriesDataMember As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.String

instance.CategoriesDataMember = value

value = instance.CategoriesDataMember
C#
[System.ComponentModel.DescriptionAttribute("Sets the categories data member.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
public System.string CategoriesDataMember {get; set;}
Delphi
public read-write property CategoriesDataMember: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Sets the categories data member.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Data")
public function get,set CategoriesDataMember : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Sets the categories data member.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
public: __property System.string* get_CategoriesDataMember();
public: __property void set_CategoriesDataMember(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Sets the categories data member.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
public:
property System.String^ CategoriesDataMember {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ClientSideEvents Property

[image]
Intersoft WebScheduler Documentation
ClientSideEvents Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ClientSideEvents Property

Glossary Item Box

Contains client side events supported by WebScheduler.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebScheduler.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property ClientSideEvents As WebSchedulerClientSideEvents
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As WebSchedulerClientSideEvents

value = instance.ClientSideEvents
C#
[System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebScheduler.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public WebSchedulerClientSideEvents ClientSideEvents {get;}
Delphi
public read-only property ClientSideEvents: WebSchedulerClientSideEvents;
JScript
System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebScheduler.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get ClientSideEvents : WebSchedulerClientSideEvents
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebScheduler.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property WebSchedulerClientSideEvents* get_ClientSideEvents();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebScheduler.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property WebSchedulerClientSideEvents^ ClientSideEvents {
   WebSchedulerClientSideEvents^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


Culture Property

[image]
Intersoft WebScheduler Documentation
Culture Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : Culture Property

Glossary Item Box

Specifies the culture setting for current WebScheduler instance.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the culture setting for current WebScheduler instance.")>
Public Property Culture As System.Globalization.CultureInfo
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Globalization.CultureInfo

instance.Culture = value

value = instance.Culture
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the culture setting for current WebScheduler instance.")]
public System.Globalization.CultureInfo Culture {get; set;}
Delphi
public read-write property Culture: System.Globalization.CultureInfo;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the culture setting for current WebScheduler instance.")
public function get,set Culture : System.Globalization.CultureInfo
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the culture setting for current WebScheduler instance.")]
public: __property System.Globalization.CultureInfo* get_Culture();
public: __property void set_Culture(
   System.Globalization.CultureInfo* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the culture setting for current WebScheduler instance.")]
public:
property System.Globalization.CultureInfo^ Culture {
   System.Globalization.CultureInfo^ get();
   void set (    System.Globalization.CultureInfo^ value);
}

Property Value

The default culture setting for current WebScheduler is English (United States).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


DataBinding Property

[image]
Intersoft WebScheduler Documentation
DataBinding Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : DataBinding Property

Glossary Item Box

Provides the settings for WebScheduler's data binding.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute("setDataBinding")>
<System.ComponentModel.DescriptionAttribute("Provides the settings for WebScheduler's data binding.")>
<System.ComponentModel.CategoryAttribute("Data")>
Public ReadOnly Property DataBinding As WebSchedulerBinding
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As WebSchedulerBinding

value = instance.DataBinding
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setDataBinding")]
[System.ComponentModel.DescriptionAttribute("Provides the settings for WebScheduler's data binding.")]
[System.ComponentModel.CategoryAttribute("Data")]
public WebSchedulerBinding DataBinding {get;}
Delphi
public read-only property DataBinding: WebSchedulerBinding;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute("setDataBinding")
System.ComponentModel.DescriptionAttribute("Provides the settings for WebScheduler's data binding.")
System.ComponentModel.CategoryAttribute("Data")
public function get DataBinding : WebSchedulerBinding
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setDataBinding")]
[System.ComponentModel.DescriptionAttribute("Provides the settings for WebScheduler's data binding.")]
[System.ComponentModel.CategoryAttribute("Data")]
public: __property WebSchedulerBinding* get_DataBinding();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setDataBinding")]
[System.ComponentModel.DescriptionAttribute("Provides the settings for WebScheduler's data binding.")]
[System.ComponentModel.CategoryAttribute("Data")]
public:
property WebSchedulerBinding^ DataBinding {
   WebSchedulerBinding^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


DataEditing Property

[image]
Intersoft WebScheduler Documentation
DataEditing Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : DataEditing Property

Glossary Item Box

Provides the settings that control the behaviors of the data editing in WebScheduler.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the data editing in WebScheduler.")>
<System.ComponentModel.CategoryAttribute("Data Editing")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute("setDataEditing")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public ReadOnly Property DataEditing As WebSchedulerDataEditing
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As WebSchedulerDataEditing

value = instance.DataEditing
C#
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the data editing in WebScheduler.")]
[System.ComponentModel.CategoryAttribute("Data Editing")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setDataEditing")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebSchedulerDataEditing DataEditing {get;}
Delphi
public read-only property DataEditing: WebSchedulerDataEditing;
JScript
System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the data editing in WebScheduler.")
System.ComponentModel.CategoryAttribute("Data Editing")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute("setDataEditing")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get DataEditing : WebSchedulerDataEditing
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the data editing in WebScheduler.")]
[System.ComponentModel.CategoryAttribute("Data Editing")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setDataEditing")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebSchedulerDataEditing* get_DataEditing();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the data editing in WebScheduler.")]
[System.ComponentModel.CategoryAttribute("Data Editing")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setDataEditing")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebSchedulerDataEditing^ DataEditing {
   WebSchedulerDataEditing^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


DataSourceID Property

[image]
Intersoft WebScheduler Documentation
DataSourceID Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : DataSourceID Property

Glossary Item Box

Gets or sets the ID of the control from which the WebScheduler control retrieves its datasource.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.DataSourceControl)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the ID of the control from which the WebScheduler control retrieves its datasource.")>
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property DataSourceID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.String

instance.DataSourceID = value

value = instance.DataSourceID
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.DataSourceControl)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the ID of the control from which the WebScheduler control retrieves its datasource.")]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string DataSourceID {get; set;}
Delphi
public read-write property DataSourceID: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.DataSourceControl)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the ID of the control from which the WebScheduler control retrieves its datasource.")
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.DefaultValueAttribute()
public function get,set DataSourceID : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.DataSourceControl)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the ID of the control from which the WebScheduler control retrieves its datasource.")]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_DataSourceID();
public: __property void set_DataSourceID(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.DataSourceControl)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the ID of the control from which the WebScheduler control retrieves its datasource.")]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ DataSourceID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


DataSourceManager Property

[image]
Intersoft WebScheduler Documentation
DataSourceManager Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : DataSourceManager Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property DataSourceManager As ISNet.WebUI.DataSourceInfo
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.DataSourceInfo

value = instance.DataSourceManager
C#
public override ISNet.WebUI.DataSourceInfo DataSourceManager {get;}
Delphi
public read-only property DataSourceManager: ISNet.WebUI.DataSourceInfo; override;
JScript
public override function get DataSourceManager : ISNet.WebUI.DataSourceInfo
Managed Extensions for C++
public: __property ISNet.WebUI.DataSourceInfo* get_DataSourceManager() override;
C++/CLI
public:
property ISNet.WebUI.DataSourceInfo^ DataSourceManager {
   ISNet.WebUI.DataSourceInfo^ get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


DayHeaderStyle Property

[image]
Intersoft WebScheduler Documentation
DayHeaderStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : DayHeaderStyle Property

Glossary Item Box

Contains interactive style for Day Header.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Day Header.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Style - Day / Week View")>
Public Property DayHeaderStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.DynamicStyle

instance.DayHeaderStyle = value

value = instance.DayHeaderStyle
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Day Header.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Day / Week View")]
public ISNet.WebUI.DynamicStyle DayHeaderStyle {get; set;}
Delphi
public read-write property DayHeaderStyle: ISNet.WebUI.DynamicStyle;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for Day Header.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Style - Day / Week View")
public function get,set DayHeaderStyle : ISNet.WebUI.DynamicStyle
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Day Header.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Day / Week View")]
public: __property ISNet.WebUI.DynamicStyle* get_DayHeaderStyle();
public: __property void set_DayHeaderStyle(
   ISNet.WebUI.DynamicStyle* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Day Header.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Day / Week View")]
public:
property ISNet.WebUI.DynamicStyle^ DayHeaderStyle {
   ISNet.WebUI.DynamicStyle^ get();
   void set (    ISNet.WebUI.DynamicStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


DefaultResource Property

[image]
Intersoft WebScheduler Documentation
DefaultResource Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : DefaultResource Property

Glossary Item Box

Gets or sets the default resource when Resources is not defined.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Data Editing")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the default resource when Resources is not defined.")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute("setDefaultResources")>
Public ReadOnly Property DefaultResource As WebSchedulerResource
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As WebSchedulerResource

value = instance.DefaultResource
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Data Editing")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default resource when Resources is not defined.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setDefaultResources")]
public WebSchedulerResource DefaultResource {get;}
Delphi
public read-only property DefaultResource: WebSchedulerResource;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Data Editing")
System.ComponentModel.DescriptionAttribute("Gets or sets the default resource when Resources is not defined.")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute("setDefaultResources")
public function get DefaultResource : WebSchedulerResource
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Data Editing")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default resource when Resources is not defined.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setDefaultResources")]
public: __property WebSchedulerResource* get_DefaultResource();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Data Editing")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default resource when Resources is not defined.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setDefaultResources")]
public:
property WebSchedulerResource^ DefaultResource {
   WebSchedulerResource^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


DefaultStyleMode Property

[image]
Intersoft WebScheduler Documentation
DefaultStyleMode Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : DefaultStyleMode Property

Glossary Item Box

Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property DefaultStyleMode As WebSchedulerDefaultStyleMode
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As WebSchedulerDefaultStyleMode

instance.DefaultStyleMode = value

value = instance.DefaultStyleMode
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public WebSchedulerDefaultStyleMode DefaultStyleMode {get; set;}
Delphi
public read-write property DefaultStyleMode: WebSchedulerDefaultStyleMode;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set DefaultStyleMode : WebSchedulerDefaultStyleMode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebSchedulerDefaultStyleMode get_DefaultStyleMode();
public: __property void set_DefaultStyleMode(
   WebSchedulerDefaultStyleMode value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebSchedulerDefaultStyleMode DefaultStyleMode {
   WebSchedulerDefaultStyleMode get();
   void set (    WebSchedulerDefaultStyleMode value);
}

Property Value

There are two default styles in WebScheduler, Outlook2007Blue and Outlook2007Black.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


DisabledAllDayEventAreaStyle Property

[image]
Intersoft WebScheduler Documentation
DisabledAllDayEventAreaStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : DisabledAllDayEventAreaStyle Property

Glossary Item Box

Contains interactive style for disabled cells in AllDayEvent Area.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Style - Day / Week View")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for disabled cells in AllDayEvent Area.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
Public Property DisabledAllDayEventAreaStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.DisabledAllDayEventAreaStyle = value

value = instance.DisabledAllDayEventAreaStyle
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Day / Week View")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for disabled cells in AllDayEvent Area.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public ISNet.WebUI.WebStyle DisabledAllDayEventAreaStyle {get; set;}
Delphi
public read-write property DisabledAllDayEventAreaStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Style - Day / Week View")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for disabled cells in AllDayEvent Area.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
public function get,set DisabledAllDayEventAreaStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Day / Week View")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for disabled cells in AllDayEvent Area.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public: __property ISNet.WebUI.WebStyle* get_DisabledAllDayEventAreaStyle();
public: __property void set_DisabledAllDayEventAreaStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Day / Week View")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for disabled cells in AllDayEvent Area.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public:
property ISNet.WebUI.WebStyle^ DisabledAllDayEventAreaStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


DisabledMonthInboundCellStyle Property

[image]
Intersoft WebScheduler Documentation
DisabledMonthInboundCellStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : DisabledMonthInboundCellStyle Property

Glossary Item Box

Contains interactive style for disabled inbound cells in Month view.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for disabled inbound cells in Month view.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.CategoryAttribute("Style - Month View")>
Public Property DisabledMonthInboundCellStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.DisabledMonthInboundCellStyle = value

value = instance.DisabledMonthInboundCellStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for disabled inbound cells in Month view.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Style - Month View")]
public ISNet.WebUI.WebStyle DisabledMonthInboundCellStyle {get; set;}
Delphi
public read-write property DisabledMonthInboundCellStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for disabled inbound cells in Month view.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.CategoryAttribute("Style - Month View")
public function get,set DisabledMonthInboundCellStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for disabled inbound cells in Month view.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Style - Month View")]
public: __property ISNet.WebUI.WebStyle* get_DisabledMonthInboundCellStyle();
public: __property void set_DisabledMonthInboundCellStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for disabled inbound cells in Month view.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Style - Month View")]
public:
property ISNet.WebUI.WebStyle^ DisabledMonthInboundCellStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


DisabledMonthOutboundCellStyle Property

[image]
Intersoft WebScheduler Documentation
DisabledMonthOutboundCellStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : DisabledMonthOutboundCellStyle Property

Glossary Item Box

Contains interactive style for disabled outbound cells in Month view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Style - Month View")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for disabled outbound cells in Month view.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
Public Property DisabledMonthOutboundCellStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.DisabledMonthOutboundCellStyle = value

value = instance.DisabledMonthOutboundCellStyle
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Month View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for disabled outbound cells in Month view.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public ISNet.WebUI.WebStyle DisabledMonthOutboundCellStyle {get; set;}
Delphi
public read-write property DisabledMonthOutboundCellStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Style - Month View")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for disabled outbound cells in Month view.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
public function get,set DisabledMonthOutboundCellStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Month View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for disabled outbound cells in Month view.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public: __property ISNet.WebUI.WebStyle* get_DisabledMonthOutboundCellStyle();
public: __property void set_DisabledMonthOutboundCellStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Month View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for disabled outbound cells in Month view.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public:
property ISNet.WebUI.WebStyle^ DisabledMonthOutboundCellStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


DisabledNonWorkHourStyle Property

[image]
Intersoft WebScheduler Documentation
DisabledNonWorkHourStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : DisabledNonWorkHourStyle Property

Glossary Item Box

Contains interactive style for non work hour cells that are set as disabled.

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for non work hour cells that are set as disabled.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.CategoryAttribute("Style - General")>
Public Property DisabledNonWorkHourStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.DisabledNonWorkHourStyle = value

value = instance.DisabledNonWorkHourStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for non work hour cells that are set as disabled.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Style - General")]
public ISNet.WebUI.WebStyle DisabledNonWorkHourStyle {get; set;}
Delphi
public read-write property DisabledNonWorkHourStyle: ISNet.WebUI.WebStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for non work hour cells that are set as disabled.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.CategoryAttribute("Style - General")
public function get,set DisabledNonWorkHourStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for non work hour cells that are set as disabled.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Style - General")]
public: __property ISNet.WebUI.WebStyle* get_DisabledNonWorkHourStyle();
public: __property void set_DisabledNonWorkHourStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for non work hour cells that are set as disabled.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Style - General")]
public:
property ISNet.WebUI.WebStyle^ DisabledNonWorkHourStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


DisabledTime Property

[image]
Intersoft WebScheduler Documentation
DisabledTime Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : DisabledTime Property

Glossary Item Box

The data collection used by WebScheduler as the disabled time.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The data collection used by WebScheduler as the disabled time.")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute("setDisabledTime")>
Public ReadOnly Property DisabledTime As WebSchedulerDisabledTimeCollection
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As WebSchedulerDisabledTimeCollection

value = instance.DisabledTime
C#
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The data collection used by WebScheduler as the disabled time.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setDisabledTime")]
public WebSchedulerDisabledTimeCollection DisabledTime {get;}
Delphi
public read-only property DisabledTime: WebSchedulerDisabledTimeCollection;
JScript
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("The data collection used by WebScheduler as the disabled time.")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute("setDisabledTime")
public function get DisabledTime : WebSchedulerDisabledTimeCollection
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The data collection used by WebScheduler as the disabled time.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setDisabledTime")]
public: __property WebSchedulerDisabledTimeCollection* get_DisabledTime();
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The data collection used by WebScheduler as the disabled time.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setDisabledTime")]
public:
property WebSchedulerDisabledTimeCollection^ DisabledTime {
   WebSchedulerDisabledTimeCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


DisabledWorkHourStyle Property

[image]
Intersoft WebScheduler Documentation
DisabledWorkHourStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : DisabledWorkHourStyle Property

Glossary Item Box

Contains interactive style for work hour cells that are set as disabled.

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Style - General")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for work hour cells that are set as disabled.")>
Public Property DisabledWorkHourStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.DisabledWorkHourStyle = value

value = instance.DisabledWorkHourStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - General")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for work hour cells that are set as disabled.")]
public ISNet.WebUI.WebStyle DisabledWorkHourStyle {get; set;}
Delphi
public read-write property DisabledWorkHourStyle: ISNet.WebUI.WebStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Style - General")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DescriptionAttribute("Contains interactive style for work hour cells that are set as disabled.")
public function get,set DisabledWorkHourStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - General")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for work hour cells that are set as disabled.")]
public: __property ISNet.WebUI.WebStyle* get_DisabledWorkHourStyle();
public: __property void set_DisabledWorkHourStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - General")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for work hour cells that are set as disabled.")]
public:
property ISNet.WebUI.WebStyle^ DisabledWorkHourStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


DisplayEventCountOnlyInTooltip Property

[image]
Intersoft WebScheduler Documentation
DisplayEventCountOnlyInTooltip Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : DisplayEventCountOnlyInTooltip Property

Glossary Item Box

Indicates whether the calendar's tooltip should show event count only or not.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Indicates whether the calendar's tooltip should show event count only or not.")>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property DisplayEventCountOnlyInTooltip As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

instance.DisplayEventCountOnlyInTooltip = value

value = instance.DisplayEventCountOnlyInTooltip
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether the calendar's tooltip should show event count only or not.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool DisplayEventCountOnlyInTooltip {get; set;}
Delphi
public read-write property DisplayEventCountOnlyInTooltip: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Indicates whether the calendar's tooltip should show event count only or not.")
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set DisplayEventCountOnlyInTooltip : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether the calendar's tooltip should show event count only or not.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_DisplayEventCountOnlyInTooltip();
public: __property void set_DisplayEventCountOnlyInTooltip(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether the calendar's tooltip should show event count only or not.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool DisplayEventCountOnlyInTooltip {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


DisplayResourcesTable Property

[image]
Intersoft WebScheduler Documentation
DisplayResourcesTable Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : DisplayResourcesTable Property

Glossary Item Box

Indicates whether the resources table is visible or not.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Indicates whether the resources table is visible or not.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property DisplayResourcesTable As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

instance.DisplayResourcesTable = value

value = instance.DisplayResourcesTable
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Indicates whether the resources table is visible or not.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool DisplayResourcesTable {get; set;}
Delphi
public read-write property DisplayResourcesTable: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Indicates whether the resources table is visible or not.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set DisplayResourcesTable : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Indicates whether the resources table is visible or not.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_DisplayResourcesTable();
public: __property void set_DisplayResourcesTable(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Indicates whether the resources table is visible or not.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool DisplayResourcesTable {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


EditingButtonStyle Property

[image]
Intersoft WebScheduler Documentation
EditingButtonStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : EditingButtonStyle Property

Glossary Item Box

Contains interactive style for the EditingButton.

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for the EditingButton.")>
<System.ComponentModel.CategoryAttribute("Style - Editing")>
Public Property EditingButtonStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.EditingButtonStyle = value

value = instance.EditingButtonStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the EditingButton.")]
[System.ComponentModel.CategoryAttribute("Style - Editing")]
public ISNet.WebUI.WebStyle EditingButtonStyle {get; set;}
Delphi
public read-write property EditingButtonStyle: ISNet.WebUI.WebStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for the EditingButton.")
System.ComponentModel.CategoryAttribute("Style - Editing")
public function get,set EditingButtonStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the EditingButton.")]
[System.ComponentModel.CategoryAttribute("Style - Editing")]
public: __property ISNet.WebUI.WebStyle* get_EditingButtonStyle();
public: __property void set_EditingButtonStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the EditingButton.")]
[System.ComponentModel.CategoryAttribute("Style - Editing")]
public:
property ISNet.WebUI.WebStyle^ EditingButtonStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


EditingField Property

[image]
Intersoft WebScheduler Documentation
EditingField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : EditingField Property

Glossary Item Box

The data collection used by WebScheduler as the CallOut's EditingField.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("The data collection used by WebScheduler as the CallOut's EditingField.")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerEditingFieldCollectionEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Data Editing")>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property EditingField As WebSchedulerEditingFieldCollection
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As WebSchedulerEditingFieldCollection

value = instance.EditingField
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("The data collection used by WebScheduler as the CallOut's EditingField.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerEditingFieldCollectionEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Data Editing")]
[System.ComponentModel.DefaultValueAttribute()]
public WebSchedulerEditingFieldCollection EditingField {get;}
Delphi
public read-only property EditingField: WebSchedulerEditingFieldCollection;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("The data collection used by WebScheduler as the CallOut's EditingField.")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerEditingFieldCollectionEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Data Editing")
System.ComponentModel.DefaultValueAttribute()
public function get EditingField : WebSchedulerEditingFieldCollection
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("The data collection used by WebScheduler as the CallOut's EditingField.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerEditingFieldCollectionEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Data Editing")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebSchedulerEditingFieldCollection* get_EditingField();
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("The data collection used by WebScheduler as the CallOut's EditingField.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerEditingFieldCollectionEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Data Editing")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebSchedulerEditingFieldCollection^ EditingField {
   WebSchedulerEditingFieldCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


EditingFormStyle Property

[image]
Intersoft WebScheduler Documentation
EditingFormStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : EditingFormStyle Property

Glossary Item Box

Determines which style mode is used in built-in editing form.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Data Editing")>
<System.ComponentModel.DescriptionAttribute("Determines which style mode is used in built-in editing form.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property EditingFormStyle As WebSchedulerEditingFormStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As WebSchedulerEditingFormStyle

instance.EditingFormStyle = value

value = instance.EditingFormStyle
C#
[System.ComponentModel.CategoryAttribute("Data Editing")]
[System.ComponentModel.DescriptionAttribute("Determines which style mode is used in built-in editing form.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebSchedulerEditingFormStyle EditingFormStyle {get; set;}
Delphi
public read-write property EditingFormStyle: WebSchedulerEditingFormStyle;
JScript
System.ComponentModel.CategoryAttribute("Data Editing")
System.ComponentModel.DescriptionAttribute("Determines which style mode is used in built-in editing form.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set EditingFormStyle : WebSchedulerEditingFormStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Data Editing")]
[System.ComponentModel.DescriptionAttribute("Determines which style mode is used in built-in editing form.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebSchedulerEditingFormStyle get_EditingFormStyle();
public: __property void set_EditingFormStyle(
   WebSchedulerEditingFormStyle value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Data Editing")]
[System.ComponentModel.DescriptionAttribute("Determines which style mode is used in built-in editing form.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebSchedulerEditingFormStyle EditingFormStyle {
   WebSchedulerEditingFormStyle get();
   void set (    WebSchedulerEditingFormStyle value);
}

Property Value

The default value is Standard

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


EditingTextStyle Property

[image]
Intersoft WebScheduler Documentation
EditingTextStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : EditingTextStyle Property

Glossary Item Box

Contains interactive style for the text of EditingField.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for the text of EditingField.")>
<System.ComponentModel.CategoryAttribute("Style - Editing")>
Public Property EditingTextStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.EditingTextStyle = value

value = instance.EditingTextStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the text of EditingField.")]
[System.ComponentModel.CategoryAttribute("Style - Editing")]
public ISNet.WebUI.WebStyle EditingTextStyle {get; set;}
Delphi
public read-write property EditingTextStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for the text of EditingField.")
System.ComponentModel.CategoryAttribute("Style - Editing")
public function get,set EditingTextStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the text of EditingField.")]
[System.ComponentModel.CategoryAttribute("Style - Editing")]
public: __property ISNet.WebUI.WebStyle* get_EditingTextStyle();
public: __property void set_EditingTextStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the text of EditingField.")]
[System.ComponentModel.CategoryAttribute("Style - Editing")]
public:
property ISNet.WebUI.WebStyle^ EditingTextStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


EditingUrl Property

[image]
Intersoft WebScheduler Documentation
EditingUrl Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : EditingUrl Property

Glossary Item Box

Sets the EditingForm's url

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Sets the EditingForm's url")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Data Editing")>
Public Property EditingUrl As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.String

instance.EditingUrl = value

value = instance.EditingUrl
C#
[System.ComponentModel.DescriptionAttribute("Sets the EditingForm's url")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Data Editing")]
public System.string EditingUrl {get; set;}
Delphi
public read-write property EditingUrl: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Sets the EditingForm's url")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Data Editing")
public function get,set EditingUrl : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Sets the EditingForm's url")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Data Editing")]
public: __property System.string* get_EditingUrl();
public: __property void set_EditingUrl(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Sets the EditingForm's url")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Data Editing")]
public:
property System.String^ EditingUrl {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is empty string

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


EmptyCellClickAction Property

[image]
Intersoft WebScheduler Documentation
EmptyCellClickAction Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : EmptyCellClickAction Property

Glossary Item Box

Specifies Specifies the behavior when empty cell is clicked.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the behavior when empty cell is clicked")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property EmptyCellClickAction As WebSchedulerEmptyCellClickAction
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As WebSchedulerEmptyCellClickAction

instance.EmptyCellClickAction = value

value = instance.EmptyCellClickAction
C#
[System.ComponentModel.DescriptionAttribute("Specifies the behavior when empty cell is clicked")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebSchedulerEmptyCellClickAction EmptyCellClickAction {get; set;}
Delphi
public read-write property EmptyCellClickAction: WebSchedulerEmptyCellClickAction;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the behavior when empty cell is clicked")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set EmptyCellClickAction : WebSchedulerEmptyCellClickAction
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the behavior when empty cell is clicked")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebSchedulerEmptyCellClickAction get_EmptyCellClickAction();
public: __property void set_EmptyCellClickAction(
   WebSchedulerEmptyCellClickAction value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the behavior when empty cell is clicked")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebSchedulerEmptyCellClickAction EmptyCellClickAction {
   WebSchedulerEmptyCellClickAction get();
   void set (    WebSchedulerEmptyCellClickAction value);
}

Property Value

The default value is ShowCallOut.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


EnableAnimation Property

[image]
Intersoft WebScheduler Documentation
EnableAnimation Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : EnableAnimation Property

Glossary Item Box

Specifies whether animation of WebScheduler's CallOut should be enabled or disabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether animation of WebScheduler's CallOut should be enabled or disabled.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property EnableAnimation As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

instance.EnableAnimation = value

value = instance.EnableAnimation
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether animation of WebScheduler's CallOut should be enabled or disabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool EnableAnimation {get; set;}
Delphi
public read-write property EnableAnimation: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether animation of WebScheduler's CallOut should be enabled or disabled.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set EnableAnimation : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether animation of WebScheduler's CallOut should be enabled or disabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_EnableAnimation();
public: __property void set_EnableAnimation(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether animation of WebScheduler's CallOut should be enabled or disabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool EnableAnimation {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


EnableContextMenu Property

[image]
Intersoft WebScheduler Documentation
EnableContextMenu Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : EnableContextMenu Property

Glossary Item Box

Specifies whether ContextMenu should appear when right clicking on event(s) or not.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether ContextMenu should appear when right clicking on event(s) or not")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property EnableContextMenu As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

instance.EnableContextMenu = value

value = instance.EnableContextMenu
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether ContextMenu should appear when right clicking on event(s) or not")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool EnableContextMenu {get; set;}
Delphi
public read-write property EnableContextMenu: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether ContextMenu should appear when right clicking on event(s) or not")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set EnableContextMenu : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether ContextMenu should appear when right clicking on event(s) or not")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_EnableContextMenu();
public: __property void set_EnableContextMenu(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether ContextMenu should appear when right clicking on event(s) or not")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool EnableContextMenu {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


EnableExport Property

[image]
Intersoft WebScheduler Documentation
EnableExport Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : EnableExport Property

Glossary Item Box

Specifies whether or not scheduler export should be enabled in UI.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether or not scheduler export should be enabled in UI")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property EnableExport As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

instance.EnableExport = value

value = instance.EnableExport
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether or not scheduler export should be enabled in UI")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool EnableExport {get; set;}
Delphi
public read-write property EnableExport: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether or not scheduler export should be enabled in UI")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set EnableExport : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether or not scheduler export should be enabled in UI")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_EnableExport();
public: __property void set_EnableExport(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether or not scheduler export should be enabled in UI")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool EnableExport {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


EnableFastJsonSerialization Property

[image]
Intersoft WebScheduler Documentation
EnableFastJsonSerialization Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : EnableFastJsonSerialization Property

Glossary Item Box

Gets or sets a value that determines whether or not fast JSON serialization is enabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines whether or not fast JSON serialization is enabled.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property EnableFastJsonSerialization As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

instance.EnableFastJsonSerialization = value

value = instance.EnableFastJsonSerialization
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines whether or not fast JSON serialization is enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool EnableFastJsonSerialization {get; set;}
Delphi
public read-write property EnableFastJsonSerialization: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines whether or not fast JSON serialization is enabled.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set EnableFastJsonSerialization : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines whether or not fast JSON serialization is enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_EnableFastJsonSerialization();
public: __property void set_EnableFastJsonSerialization(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines whether or not fast JSON serialization is enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool EnableFastJsonSerialization {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


EnableMultipleCellSelection Property

[image]
Intersoft WebScheduler Documentation
EnableMultipleCellSelection Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : EnableMultipleCellSelection Property

Glossary Item Box

Gets or sets a value that determines whether or not multiple cell selection is enabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property EnableMultipleCellSelection As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

instance.EnableMultipleCellSelection = value

value = instance.EnableMultipleCellSelection
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool EnableMultipleCellSelection {get; set;}
Delphi
public read-write property EnableMultipleCellSelection: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set EnableMultipleCellSelection : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_EnableMultipleCellSelection();
public: __property void set_EnableMultipleCellSelection(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool EnableMultipleCellSelection {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


EnableSplitViewInitially Property

[image]
Intersoft WebScheduler Documentation
EnableSplitViewInitially Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : EnableSplitViewInitially Property

Glossary Item Box

Specifies whether or not SplitView should be enabled initially.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not SplitView should be enabled initially")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property EnableSplitViewInitially As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

instance.EnableSplitViewInitially = value

value = instance.EnableSplitViewInitially
C#
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not SplitView should be enabled initially")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool EnableSplitViewInitially {get; set;}
Delphi
public read-write property EnableSplitViewInitially: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not SplitView should be enabled initially")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set EnableSplitViewInitially : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not SplitView should be enabled initially")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_EnableSplitViewInitially();
public: __property void set_EnableSplitViewInitially(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not SplitView should be enabled initially")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool EnableSplitViewInitially {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


EventsDataMember Property

[image]
Intersoft WebScheduler Documentation
EventsDataMember Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : EventsDataMember Property

Glossary Item Box

Sets the events data member.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Sets the events data member.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Data")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property EventsDataMember As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.String

instance.EventsDataMember = value

value = instance.EventsDataMember
C#
[System.ComponentModel.DescriptionAttribute("Sets the events data member.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Data")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string EventsDataMember {get; set;}
Delphi
public read-write property EventsDataMember: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Sets the events data member.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Data")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set EventsDataMember : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Sets the events data member.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Data")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_EventsDataMember();
public: __property void set_EventsDataMember(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Sets the events data member.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Data")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ EventsDataMember {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ExtendedCategoryTypeName Property

[image]
Intersoft WebScheduler Documentation
ExtendedCategoryTypeName Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ExtendedCategoryTypeName Property

Glossary Item Box

Gets or sets the extended category type name.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the type name to extend the category object.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ExtendedCategoryTypeName As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.String

instance.ExtendedCategoryTypeName = value

value = instance.ExtendedCategoryTypeName
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the type name to extend the category object.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string ExtendedCategoryTypeName {get; set;}
Delphi
public read-write property ExtendedCategoryTypeName: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Gets or sets the type name to extend the category object.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ExtendedCategoryTypeName : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the type name to extend the category object.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_ExtendedCategoryTypeName();
public: __property void set_ExtendedCategoryTypeName(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the type name to extend the category object.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ ExtendedCategoryTypeName {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ExtendedEventTypeName Property

[image]
Intersoft WebScheduler Documentation
ExtendedEventTypeName Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ExtendedEventTypeName Property

Glossary Item Box

Gets or sets the extended event type name.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the type name to extend the event object.")>
<System.ComponentModel.CategoryAttribute("General")>
Public Property ExtendedEventTypeName As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.String

instance.ExtendedEventTypeName = value

value = instance.ExtendedEventTypeName
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the type name to extend the event object.")]
[System.ComponentModel.CategoryAttribute("General")]
public System.string ExtendedEventTypeName {get; set;}
Delphi
public read-write property ExtendedEventTypeName: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the type name to extend the event object.")
System.ComponentModel.CategoryAttribute("General")
public function get,set ExtendedEventTypeName : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the type name to extend the event object.")]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.string* get_ExtendedEventTypeName();
public: __property void set_ExtendedEventTypeName(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the type name to extend the event object.")]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.String^ ExtendedEventTypeName {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ExtendedRecurringEventTypeName Property

[image]
Intersoft WebScheduler Documentation
ExtendedRecurringEventTypeName Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ExtendedRecurringEventTypeName Property

Glossary Item Box

Gets or sets the extended event type name.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the type name to extend the recurring event object.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ExtendedRecurringEventTypeName As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.String

instance.ExtendedRecurringEventTypeName = value

value = instance.ExtendedRecurringEventTypeName
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the type name to extend the recurring event object.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string ExtendedRecurringEventTypeName {get; set;}
Delphi
public read-write property ExtendedRecurringEventTypeName: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the type name to extend the recurring event object.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ExtendedRecurringEventTypeName : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the type name to extend the recurring event object.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_ExtendedRecurringEventTypeName();
public: __property void set_ExtendedRecurringEventTypeName(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the type name to extend the recurring event object.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ ExtendedRecurringEventTypeName {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ExtendedResourceTypeName Property

[image]
Intersoft WebScheduler Documentation
ExtendedResourceTypeName Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ExtendedResourceTypeName Property

Glossary Item Box

Gets or sets the extended resource type name.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the type name to extend the resource object.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ExtendedResourceTypeName As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.String

instance.ExtendedResourceTypeName = value

value = instance.ExtendedResourceTypeName
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the type name to extend the resource object.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string ExtendedResourceTypeName {get; set;}
Delphi
public read-write property ExtendedResourceTypeName: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Gets or sets the type name to extend the resource object.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ExtendedResourceTypeName : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the type name to extend the resource object.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_ExtendedResourceTypeName();
public: __property void set_ExtendedResourceTypeName(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the type name to extend the resource object.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ ExtendedResourceTypeName {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


FlyPostBackSettings Property

[image]
Intersoft WebScheduler Documentation
FlyPostBackSettings Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : FlyPostBackSettings Property

Glossary Item Box

Configures the settings used by the control when performing OnTheFly postback.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property FlyPostBackSettings As ISNet.WebUI.FlyPostBackSettings
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.FlyPostBackSettings

value = instance.FlyPostBackSettings
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ISNet.WebUI.FlyPostBackSettings FlyPostBackSettings {get;}
Delphi
public read-only property FlyPostBackSettings: ISNet.WebUI.FlyPostBackSettings;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get FlyPostBackSettings : ISNet.WebUI.FlyPostBackSettings
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ISNet.WebUI.FlyPostBackSettings* get_FlyPostBackSettings();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ISNet.WebUI.FlyPostBackSettings^ FlyPostBackSettings {
   ISNet.WebUI.FlyPostBackSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


GridLineStyle Property

[image]
Intersoft WebScheduler Documentation
GridLineStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : GridLineStyle Property

Glossary Item Box

Contains interactive style for Grid Line.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Style - Day / Week View")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Grid Line.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
Public ReadOnly Property GridLineStyle As WebSchedulerGridLineStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As WebSchedulerGridLineStyle

value = instance.GridLineStyle
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Style - Day / Week View")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Grid Line.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public WebSchedulerGridLineStyle GridLineStyle {get;}
Delphi
public read-only property GridLineStyle: WebSchedulerGridLineStyle;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Style - Day / Week View")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for Grid Line.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
public function get GridLineStyle : WebSchedulerGridLineStyle
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Style - Day / Week View")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Grid Line.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public: __property WebSchedulerGridLineStyle* get_GridLineStyle();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Style - Day / Week View")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Grid Line.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public:
property WebSchedulerGridLineStyle^ GridLineStyle {
   WebSchedulerGridLineStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


Holidays Property

[image]
Intersoft WebScheduler Documentation
Holidays Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : Holidays Property

Glossary Item Box

The data collection used by WebScheduler to determine holiday(s).

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setHolidays")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("The data collection used by WebScheduler to determine holiday(s)")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property Holidays As WebSchedulerHolidayCollection
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As WebSchedulerHolidayCollection

value = instance.Holidays
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setHolidays")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("The data collection used by WebScheduler to determine holiday(s)")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public WebSchedulerHolidayCollection Holidays {get;}
Delphi
public read-only property Holidays: WebSchedulerHolidayCollection;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute("setHolidays")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("The data collection used by WebScheduler to determine holiday(s)")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get Holidays : WebSchedulerHolidayCollection
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setHolidays")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("The data collection used by WebScheduler to determine holiday(s)")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebSchedulerHolidayCollection* get_Holidays();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setHolidays")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("The data collection used by WebScheduler to determine holiday(s)")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebSchedulerHolidayCollection^ Holidays {
   WebSchedulerHolidayCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


HolidayStyle Property

[image]
Intersoft WebScheduler Documentation
HolidayStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : HolidayStyle Property

Glossary Item Box

Contains interactive style for Holiday.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Holiday.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.CategoryAttribute("Style - Calendar")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property HolidayStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.HolidayStyle = value

value = instance.HolidayStyle
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Holiday.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.CategoryAttribute("Style - Calendar")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ISNet.WebUI.WebStyle HolidayStyle {get; set;}
Delphi
public read-write property HolidayStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DescriptionAttribute("Contains interactive style for Holiday.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.CategoryAttribute("Style - Calendar")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set HolidayStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Holiday.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.CategoryAttribute("Style - Calendar")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ISNet.WebUI.WebStyle* get_HolidayStyle();
public: __property void set_HolidayStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Holiday.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.CategoryAttribute("Style - Calendar")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ISNet.WebUI.WebStyle^ HolidayStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


HourAreaStyle Property

[image]
Intersoft WebScheduler Documentation
HourAreaStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : HourAreaStyle Property

Glossary Item Box

Contains interactive style for Hour Area.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Style - Day / Week View")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Hour Area.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
Public Property HourAreaStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.HourAreaStyle = value

value = instance.HourAreaStyle
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Style - Day / Week View")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Hour Area.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public ISNet.WebUI.WebStyle HourAreaStyle {get; set;}
Delphi
public read-write property HourAreaStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Style - Day / Week View")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for Hour Area.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
public function get,set HourAreaStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Style - Day / Week View")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Hour Area.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public: __property ISNet.WebUI.WebStyle* get_HourAreaStyle();
public: __property void set_HourAreaStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Style - Day / Week View")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Hour Area.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public:
property ISNet.WebUI.WebStyle^ HourAreaStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ImagesDirectory Property

[image]
Intersoft WebScheduler Documentation
ImagesDirectory Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ImagesDirectory Property

Glossary Item Box

Gets or sets the images directory for ImagesSettings.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the images directory for ImagesSetting.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
Public Property ImagesDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.String

instance.ImagesDirectory = value

value = instance.ImagesDirectory
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory for ImagesSetting.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public System.string ImagesDirectory {get; set;}
Delphi
public read-write property ImagesDirectory: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the images directory for ImagesSetting.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set ImagesDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory for ImagesSetting.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.string* get_ImagesDirectory();
public: __property void set_ImagesDirectory(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory for ImagesSetting.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.String^ ImagesDirectory {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ImagesSettings Property

[image]
Intersoft WebScheduler Documentation
ImagesSettings Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ImagesSettings Property

Glossary Item Box

Provides the settings that control the images in WebScheduler.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebScheduler.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public ReadOnly Property ImagesSettings As WebSchedulerImagesSettings
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As WebSchedulerImagesSettings

value = instance.ImagesSettings
C#
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebScheduler.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebSchedulerImagesSettings ImagesSettings {get;}
Delphi
public read-only property ImagesSettings: WebSchedulerImagesSettings;
JScript
System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebScheduler.")
ISNet.Serialization.XmlSerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get ImagesSettings : WebSchedulerImagesSettings
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebScheduler.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebSchedulerImagesSettings* get_ImagesSettings();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebScheduler.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebSchedulerImagesSettings^ ImagesSettings {
   WebSchedulerImagesSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


IncludeSplitViewInMenu Property

[image]
Intersoft WebScheduler Documentation
IncludeSplitViewInMenu Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : IncludeSplitViewInMenu Property

Glossary Item Box

Specifies whether or not SplitView option should be included in context menu and More menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not SplitView option should be included in context menu and More menu")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property IncludeSplitViewInMenu As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

instance.IncludeSplitViewInMenu = value

value = instance.IncludeSplitViewInMenu
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not SplitView option should be included in context menu and More menu")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool IncludeSplitViewInMenu {get; set;}
Delphi
public read-write property IncludeSplitViewInMenu: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Specifies whether or not SplitView option should be included in context menu and More menu")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set IncludeSplitViewInMenu : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not SplitView option should be included in context menu and More menu")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_IncludeSplitViewInMenu();
public: __property void set_IncludeSplitViewInMenu(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not SplitView option should be included in context menu and More menu")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool IncludeSplitViewInMenu {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


IncludeTimeIntervalInMenu Property

[image]
Intersoft WebScheduler Documentation
IncludeTimeIntervalInMenu Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : IncludeTimeIntervalInMenu Property

Glossary Item Box

Specifies whether time interval options should be included in menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Specifies whether time interval options should be included in menu.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property IncludeTimeIntervalInMenu As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

instance.IncludeTimeIntervalInMenu = value

value = instance.IncludeTimeIntervalInMenu
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies whether time interval options should be included in menu.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool IncludeTimeIntervalInMenu {get; set;}
Delphi
public read-write property IncludeTimeIntervalInMenu: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Specifies whether time interval options should be included in menu.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set IncludeTimeIntervalInMenu : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies whether time interval options should be included in menu.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_IncludeTimeIntervalInMenu();
public: __property void set_IncludeTimeIntervalInMenu(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies whether time interval options should be included in menu.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool IncludeTimeIntervalInMenu {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


LayoutSettings Property

[image]
Intersoft WebScheduler Documentation
LayoutSettings Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : LayoutSettings Property

Glossary Item Box

Provides the settings that control the behaviors of the layout in WebScheduler.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setLayoutSettings")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the layout in WebScheduler.")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property LayoutSettings As WebSchedulerLayoutSettings
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As WebSchedulerLayoutSettings

value = instance.LayoutSettings
C#
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setLayoutSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the layout in WebScheduler.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public WebSchedulerLayoutSettings LayoutSettings {get;}
Delphi
public read-only property LayoutSettings: WebSchedulerLayoutSettings;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setLayoutSettings")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the layout in WebScheduler.")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get LayoutSettings : WebSchedulerLayoutSettings
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setLayoutSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the layout in WebScheduler.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebSchedulerLayoutSettings* get_LayoutSettings();
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setLayoutSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the layout in WebScheduler.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebSchedulerLayoutSettings^ LayoutSettings {
   WebSchedulerLayoutSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


LoadOnDemandMode Property

[image]
Intersoft WebScheduler Documentation
LoadOnDemandMode Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : LoadOnDemandMode Property

Glossary Item Box

Gets or sets a value that determines the mode of LoadOnDemand.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the mode of LoadOnDemand")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property LoadOnDemandMode As WebSchedulerLoadOnDemandMode
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As WebSchedulerLoadOnDemandMode

instance.LoadOnDemandMode = value

value = instance.LoadOnDemandMode
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the mode of LoadOnDemand")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public WebSchedulerLoadOnDemandMode LoadOnDemandMode {get; set;}
Delphi
public read-write property LoadOnDemandMode: WebSchedulerLoadOnDemandMode;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the mode of LoadOnDemand")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set LoadOnDemandMode : WebSchedulerLoadOnDemandMode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the mode of LoadOnDemand")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebSchedulerLoadOnDemandMode get_LoadOnDemandMode();
public: __property void set_LoadOnDemandMode(
   WebSchedulerLoadOnDemandMode value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the mode of LoadOnDemand")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebSchedulerLoadOnDemandMode LoadOnDemandMode {
   WebSchedulerLoadOnDemandMode get();
   void set (    WebSchedulerLoadOnDemandMode value);
}

Property Value

The default value is TripleLoad.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


MarkedDayWithEvents Property

[image]
Intersoft WebScheduler Documentation
MarkedDayWithEvents Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : MarkedDayWithEvents Property

Glossary Item Box

Specifies whether Calendar's number of WebScheduler that contain event(s) should be marked with bold style or not.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether Calendar's number of WebScheduler that contain event(s) should be marked with bold style or not.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property MarkedDayWithEvents As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

instance.MarkedDayWithEvents = value

value = instance.MarkedDayWithEvents
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether Calendar's number of WebScheduler that contain event(s) should be marked with bold style or not.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool MarkedDayWithEvents {get; set;}
Delphi
public read-write property MarkedDayWithEvents: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether Calendar's number of WebScheduler that contain event(s) should be marked with bold style or not.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set MarkedDayWithEvents : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether Calendar's number of WebScheduler that contain event(s) should be marked with bold style or not.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_MarkedDayWithEvents();
public: __property void set_MarkedDayWithEvents(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether Calendar's number of WebScheduler that contain event(s) should be marked with bold style or not.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool MarkedDayWithEvents {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


MonthDayHeaderStyle Property

[image]
Intersoft WebScheduler Documentation
MonthDayHeaderStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : MonthDayHeaderStyle Property

Glossary Item Box

Contains interactive style for for day header in Month view.

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.CategoryAttribute("Style - Month View")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for day header in Month view.")>
Public Property MonthDayHeaderStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.MonthDayHeaderStyle = value

value = instance.MonthDayHeaderStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Style - Month View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for day header in Month view.")]
public ISNet.WebUI.WebStyle MonthDayHeaderStyle {get; set;}
Delphi
public read-write property MonthDayHeaderStyle: ISNet.WebUI.WebStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.CategoryAttribute("Style - Month View")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for day header in Month view.")
public function get,set MonthDayHeaderStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Style - Month View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for day header in Month view.")]
public: __property ISNet.WebUI.WebStyle* get_MonthDayHeaderStyle();
public: __property void set_MonthDayHeaderStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Style - Month View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for day header in Month view.")]
public:
property ISNet.WebUI.WebStyle^ MonthDayHeaderStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


MonthInboundCellStyle Property

[image]
Intersoft WebScheduler Documentation
MonthInboundCellStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : MonthInboundCellStyle Property

Glossary Item Box

Contains interactive style for MonthInboundCell.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for MonthInboundCell.")>
<System.ComponentModel.CategoryAttribute("Style - Month View")>
Public Property MonthInboundCellStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.MonthInboundCellStyle = value

value = instance.MonthInboundCellStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for MonthInboundCell.")]
[System.ComponentModel.CategoryAttribute("Style - Month View")]
public ISNet.WebUI.WebStyle MonthInboundCellStyle {get; set;}
Delphi
public read-write property MonthInboundCellStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for MonthInboundCell.")
System.ComponentModel.CategoryAttribute("Style - Month View")
public function get,set MonthInboundCellStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for MonthInboundCell.")]
[System.ComponentModel.CategoryAttribute("Style - Month View")]
public: __property ISNet.WebUI.WebStyle* get_MonthInboundCellStyle();
public: __property void set_MonthInboundCellStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for MonthInboundCell.")]
[System.ComponentModel.CategoryAttribute("Style - Month View")]
public:
property ISNet.WebUI.WebStyle^ MonthInboundCellStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


MonthInboundDateHeaderStyle Property

[image]
Intersoft WebScheduler Documentation
MonthInboundDateHeaderStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : MonthInboundDateHeaderStyle Property

Glossary Item Box

Contains interactive style for MonthInboundDateHeader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for MonthInboundDateHeader.")>
<System.ComponentModel.CategoryAttribute("Style - Month View")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Property MonthInboundDateHeaderStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.DynamicStyle

instance.MonthInboundDateHeaderStyle = value

value = instance.MonthInboundDateHeaderStyle
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for MonthInboundDateHeader.")]
[System.ComponentModel.CategoryAttribute("Style - Month View")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ISNet.WebUI.DynamicStyle MonthInboundDateHeaderStyle {get; set;}
Delphi
public read-write property MonthInboundDateHeaderStyle: ISNet.WebUI.DynamicStyle;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for MonthInboundDateHeader.")
System.ComponentModel.CategoryAttribute("Style - Month View")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get,set MonthInboundDateHeaderStyle : ISNet.WebUI.DynamicStyle
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for MonthInboundDateHeader.")]
[System.ComponentModel.CategoryAttribute("Style - Month View")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ISNet.WebUI.DynamicStyle* get_MonthInboundDateHeaderStyle();
public: __property void set_MonthInboundDateHeaderStyle(
   ISNet.WebUI.DynamicStyle* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for MonthInboundDateHeader.")]
[System.ComponentModel.CategoryAttribute("Style - Month View")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ISNet.WebUI.DynamicStyle^ MonthInboundDateHeaderStyle {
   ISNet.WebUI.DynamicStyle^ get();
   void set (    ISNet.WebUI.DynamicStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


MonthOutboundCellStyle Property

[image]
Intersoft WebScheduler Documentation
MonthOutboundCellStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : MonthOutboundCellStyle Property

Glossary Item Box

Contains interactive style for MonthOutboundCell.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for MonthOutboundCell.")>
<System.ComponentModel.CategoryAttribute("Style - Month View")>
Public Property MonthOutboundCellStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.MonthOutboundCellStyle = value

value = instance.MonthOutboundCellStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for MonthOutboundCell.")]
[System.ComponentModel.CategoryAttribute("Style - Month View")]
public ISNet.WebUI.WebStyle MonthOutboundCellStyle {get; set;}
Delphi
public read-write property MonthOutboundCellStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for MonthOutboundCell.")
System.ComponentModel.CategoryAttribute("Style - Month View")
public function get,set MonthOutboundCellStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for MonthOutboundCell.")]
[System.ComponentModel.CategoryAttribute("Style - Month View")]
public: __property ISNet.WebUI.WebStyle* get_MonthOutboundCellStyle();
public: __property void set_MonthOutboundCellStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for MonthOutboundCell.")]
[System.ComponentModel.CategoryAttribute("Style - Month View")]
public:
property ISNet.WebUI.WebStyle^ MonthOutboundCellStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


MonthOutboundDateHeaderStyle Property

[image]
Intersoft WebScheduler Documentation
MonthOutboundDateHeaderStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : MonthOutboundDateHeaderStyle Property

Glossary Item Box

Contains interactive style for MonthOutboundDateHeader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Style - Month View")>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for MonthOutboundDateHeader.")>
Public Property MonthOutboundDateHeaderStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.DynamicStyle

instance.MonthOutboundDateHeaderStyle = value

value = instance.MonthOutboundDateHeaderStyle
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style - Month View")]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for MonthOutboundDateHeader.")]
public ISNet.WebUI.DynamicStyle MonthOutboundDateHeaderStyle {get; set;}
Delphi
public read-write property MonthOutboundDateHeaderStyle: ISNet.WebUI.DynamicStyle;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Style - Month View")
System.ComponentModel.DescriptionAttribute("Contains interactive style for MonthOutboundDateHeader.")
public function get,set MonthOutboundDateHeaderStyle : ISNet.WebUI.DynamicStyle
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style - Month View")]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for MonthOutboundDateHeader.")]
public: __property ISNet.WebUI.DynamicStyle* get_MonthOutboundDateHeaderStyle();
public: __property void set_MonthOutboundDateHeaderStyle(
   ISNet.WebUI.DynamicStyle* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style - Month View")]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for MonthOutboundDateHeader.")]
public:
property ISNet.WebUI.DynamicStyle^ MonthOutboundDateHeaderStyle {
   ISNet.WebUI.DynamicStyle^ get();
   void set (    ISNet.WebUI.DynamicStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


MonthSelectedCellStyle Property

[image]
Intersoft WebScheduler Documentation
MonthSelectedCellStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : MonthSelectedCellStyle Property

Glossary Item Box

Contains interactive style for MonthSelectedCell.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Style - Month View")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for MonthSelectedCell.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
Public Property MonthSelectedCellStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.MonthSelectedCellStyle = value

value = instance.MonthSelectedCellStyle
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Month View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for MonthSelectedCell.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public ISNet.WebUI.WebStyle MonthSelectedCellStyle {get; set;}
Delphi
public read-write property MonthSelectedCellStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Style - Month View")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for MonthSelectedCell.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
public function get,set MonthSelectedCellStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Month View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for MonthSelectedCell.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public: __property ISNet.WebUI.WebStyle* get_MonthSelectedCellStyle();
public: __property void set_MonthSelectedCellStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Month View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for MonthSelectedCell.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public:
property ISNet.WebUI.WebStyle^ MonthSelectedCellStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


NonWorkHourStyle Property

[image]
Intersoft WebScheduler Documentation
NonWorkHourStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : NonWorkHourStyle Property

Glossary Item Box

Contains interactive style for Non WorkHour.

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.CategoryAttribute("Style - General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Non WorkHour.")>
Public Property NonWorkHourStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.NonWorkHourStyle = value

value = instance.NonWorkHourStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Style - General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Non WorkHour.")]
public ISNet.WebUI.WebStyle NonWorkHourStyle {get; set;}
Delphi
public read-write property NonWorkHourStyle: ISNet.WebUI.WebStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.CategoryAttribute("Style - General")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for Non WorkHour.")
public function get,set NonWorkHourStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Style - General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Non WorkHour.")]
public: __property ISNet.WebUI.WebStyle* get_NonWorkHourStyle();
public: __property void set_NonWorkHourStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Style - General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Non WorkHour.")]
public:
property ISNet.WebUI.WebStyle^ NonWorkHourStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


RecurrenceDataMember Property

[image]
Intersoft WebScheduler Documentation
RecurrenceDataMember Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : RecurrenceDataMember Property

Glossary Item Box

Sets the recurrence data member.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Sets the recurrence data member.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Data")>
Public Property RecurrenceDataMember As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.String

instance.RecurrenceDataMember = value

value = instance.RecurrenceDataMember
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the recurrence data member.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
public System.string RecurrenceDataMember {get; set;}
Delphi
public read-write property RecurrenceDataMember: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Sets the recurrence data member.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Data")
public function get,set RecurrenceDataMember : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the recurrence data member.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
public: __property System.string* get_RecurrenceDataMember();
public: __property void set_RecurrenceDataMember(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the recurrence data member.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
public:
property System.String^ RecurrenceDataMember {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


RecurringEventsDataMember Property

[image]
Intersoft WebScheduler Documentation
RecurringEventsDataMember Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : RecurringEventsDataMember Property

Glossary Item Box

Sets the recurring events data member.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Sets the recurring events data member.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property RecurringEventsDataMember As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.String

instance.RecurringEventsDataMember = value

value = instance.RecurringEventsDataMember
C#
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the recurring events data member.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string RecurringEventsDataMember {get; set;}
Delphi
public read-write property RecurringEventsDataMember: System.String;
JScript
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Sets the recurring events data member.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set RecurringEventsDataMember : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the recurring events data member.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_RecurringEventsDataMember();
public: __property void set_RecurringEventsDataMember(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the recurring events data member.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ RecurringEventsDataMember {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ResourcesContentMode Property

[image]
Intersoft WebScheduler Documentation
ResourcesContentMode Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ResourcesContentMode Property

Glossary Item Box

Specifies Timeline Resource container mode.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the container mode of Timeline's Resource.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ResourcesContentMode As WebSchedulerTimelineResourceContentMode
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As WebSchedulerTimelineResourceContentMode

instance.ResourcesContentMode = value

value = instance.ResourcesContentMode
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the container mode of Timeline's Resource.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public WebSchedulerTimelineResourceContentMode ResourcesContentMode {get; set;}
Delphi
public read-write property ResourcesContentMode: WebSchedulerTimelineResourceContentMode;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the container mode of Timeline's Resource.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ResourcesContentMode : WebSchedulerTimelineResourceContentMode
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the container mode of Timeline's Resource.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property WebSchedulerTimelineResourceContentMode get_ResourcesContentMode();
public: __property void set_ResourcesContentMode(
   WebSchedulerTimelineResourceContentMode value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the container mode of Timeline's Resource.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property WebSchedulerTimelineResourceContentMode ResourcesContentMode {
   WebSchedulerTimelineResourceContentMode get();
   void set (    WebSchedulerTimelineResourceContentMode value);
}

Property Value

The default value is Default. Default means WebScheduler Timeline View Mode will only show the Resource's Name as the container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ResourcesDataMember Property

[image]
Intersoft WebScheduler Documentation
ResourcesDataMember Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ResourcesDataMember Property

Glossary Item Box

Sets the resources data member.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Sets the resources data member.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ResourcesDataMember As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.String

instance.ResourcesDataMember = value

value = instance.ResourcesDataMember
C#
[System.ComponentModel.DescriptionAttribute("Sets the resources data member.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string ResourcesDataMember {get; set;}
Delphi
public read-write property ResourcesDataMember: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Sets the resources data member.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ResourcesDataMember : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Sets the resources data member.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_ResourcesDataMember();
public: __property void set_ResourcesDataMember(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Sets the resources data member.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ ResourcesDataMember {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ResourcesFrameStyle Property

[image]
Intersoft WebScheduler Documentation
ResourcesFrameStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ResourcesFrameStyle Property

Glossary Item Box

Contains interactive style for Resources Frame.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Style - Resources")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Resources Frame.")>
Public Property ResourcesFrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.ResourcesFrameStyle = value

value = instance.ResourcesFrameStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style - Resources")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Resources Frame.")]
public ISNet.WebUI.WebStyle ResourcesFrameStyle {get; set;}
Delphi
public read-write property ResourcesFrameStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Style - Resources")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DescriptionAttribute("Contains interactive style for Resources Frame.")
public function get,set ResourcesFrameStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style - Resources")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Resources Frame.")]
public: __property ISNet.WebUI.WebStyle* get_ResourcesFrameStyle();
public: __property void set_ResourcesFrameStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style - Resources")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Resources Frame.")]
public:
property ISNet.WebUI.WebStyle^ ResourcesFrameStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ResourcesHeaderStyle Property

[image]
Intersoft WebScheduler Documentation
ResourcesHeaderStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ResourcesHeaderStyle Property

Glossary Item Box

Contains interactive style for Resources Header.

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Style - Resources")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Resources Header.")>
Public Property ResourcesHeaderStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.ResourcesHeaderStyle = value

value = instance.ResourcesHeaderStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - Resources")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Resources Header.")]
public ISNet.WebUI.WebStyle ResourcesHeaderStyle {get; set;}
Delphi
public read-write property ResourcesHeaderStyle: ISNet.WebUI.WebStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Style - Resources")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DescriptionAttribute("Contains interactive style for Resources Header.")
public function get,set ResourcesHeaderStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - Resources")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Resources Header.")]
public: __property ISNet.WebUI.WebStyle* get_ResourcesHeaderStyle();
public: __property void set_ResourcesHeaderStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - Resources")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Resources Header.")]
public:
property ISNet.WebUI.WebStyle^ ResourcesHeaderStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


SchedulerFrameStyle Property

[image]
Intersoft WebScheduler Documentation
SchedulerFrameStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : SchedulerFrameStyle Property

Glossary Item Box

Contains interactive style for Scheduler Frame.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Scheduler Frame.")>
<System.ComponentModel.CategoryAttribute("Style - General")>
Public Property SchedulerFrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.SchedulerFrameStyle = value

value = instance.SchedulerFrameStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Scheduler Frame.")]
[System.ComponentModel.CategoryAttribute("Style - General")]
public ISNet.WebUI.WebStyle SchedulerFrameStyle {get; set;}
Delphi
public read-write property SchedulerFrameStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for Scheduler Frame.")
System.ComponentModel.CategoryAttribute("Style - General")
public function get,set SchedulerFrameStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Scheduler Frame.")]
[System.ComponentModel.CategoryAttribute("Style - General")]
public: __property ISNet.WebUI.WebStyle* get_SchedulerFrameStyle();
public: __property void set_SchedulerFrameStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Scheduler Frame.")]
[System.ComponentModel.CategoryAttribute("Style - General")]
public:
property ISNet.WebUI.WebStyle^ SchedulerFrameStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


SchedulerHeaderStyle Property

[image]
Intersoft WebScheduler Documentation
SchedulerHeaderStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : SchedulerHeaderStyle Property

Glossary Item Box

Contains interactive style for Scheduler Header.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Scheduler Header.")>
<System.ComponentModel.CategoryAttribute("Style - General")>
Public Property SchedulerHeaderStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.SchedulerHeaderStyle = value

value = instance.SchedulerHeaderStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Scheduler Header.")]
[System.ComponentModel.CategoryAttribute("Style - General")]
public ISNet.WebUI.WebStyle SchedulerHeaderStyle {get; set;}
Delphi
public read-write property SchedulerHeaderStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for Scheduler Header.")
System.ComponentModel.CategoryAttribute("Style - General")
public function get,set SchedulerHeaderStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Scheduler Header.")]
[System.ComponentModel.CategoryAttribute("Style - General")]
public: __property ISNet.WebUI.WebStyle* get_SchedulerHeaderStyle();
public: __property void set_SchedulerHeaderStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Scheduler Header.")]
[System.ComponentModel.CategoryAttribute("Style - General")]
public:
property ISNet.WebUI.WebStyle^ SchedulerHeaderStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


SchedulerTodayAllDayEventAreaStyle Property

[image]
Intersoft WebScheduler Documentation
SchedulerTodayAllDayEventAreaStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : SchedulerTodayAllDayEventAreaStyle Property

Glossary Item Box

Contains interactive style for Scheduler TodayAllDayEventArea.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Style - General")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Scheduler TodayAllDayEventArea.")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Property SchedulerTodayAllDayEventAreaStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.SchedulerTodayAllDayEventAreaStyle = value

value = instance.SchedulerTodayAllDayEventAreaStyle
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Scheduler TodayAllDayEventArea.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ISNet.WebUI.WebStyle SchedulerTodayAllDayEventAreaStyle {get; set;}
Delphi
public read-write property SchedulerTodayAllDayEventAreaStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Style - General")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for Scheduler TodayAllDayEventArea.")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get,set SchedulerTodayAllDayEventAreaStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Scheduler TodayAllDayEventArea.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ISNet.WebUI.WebStyle* get_SchedulerTodayAllDayEventAreaStyle();
public: __property void set_SchedulerTodayAllDayEventAreaStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Scheduler TodayAllDayEventArea.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ISNet.WebUI.WebStyle^ SchedulerTodayAllDayEventAreaStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


SchedulerTodayCellStyle Property

[image]
Intersoft WebScheduler Documentation
SchedulerTodayCellStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : SchedulerTodayCellStyle Property

Glossary Item Box

Contains interactive style for Scheduler TodayCell.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Style - General")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Scheduler TodayCell.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
Public Property SchedulerTodayCellStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.SchedulerTodayCellStyle = value

value = instance.SchedulerTodayCellStyle
C#
[System.ComponentModel.CategoryAttribute("Style - General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Scheduler TodayCell.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ISNet.WebUI.WebStyle SchedulerTodayCellStyle {get; set;}
Delphi
public read-write property SchedulerTodayCellStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.CategoryAttribute("Style - General")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DescriptionAttribute("Contains interactive style for Scheduler TodayCell.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
public function get,set SchedulerTodayCellStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Style - General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Scheduler TodayCell.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public: __property ISNet.WebUI.WebStyle* get_SchedulerTodayCellStyle();
public: __property void set_SchedulerTodayCellStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Style - General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Scheduler TodayCell.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public:
property ISNet.WebUI.WebStyle^ SchedulerTodayCellStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


SchedulerTodayHeaderStyle Property

[image]
Intersoft WebScheduler Documentation
SchedulerTodayHeaderStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : SchedulerTodayHeaderStyle Property

Glossary Item Box

Contains interactive style for Scheduler TodayHeader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Scheduler TodayHeader.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Style - General")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property SchedulerTodayHeaderStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.DynamicStyle

instance.SchedulerTodayHeaderStyle = value

value = instance.SchedulerTodayHeaderStyle
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Scheduler TodayHeader.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Style - General")]
[ISNet.Serialization.XmlSerializableAttribute()]
public ISNet.WebUI.DynamicStyle SchedulerTodayHeaderStyle {get; set;}
Delphi
public read-write property SchedulerTodayHeaderStyle: ISNet.WebUI.DynamicStyle;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for Scheduler TodayHeader.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Style - General")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set SchedulerTodayHeaderStyle : ISNet.WebUI.DynamicStyle
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Scheduler TodayHeader.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Style - General")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property ISNet.WebUI.DynamicStyle* get_SchedulerTodayHeaderStyle();
public: __property void set_SchedulerTodayHeaderStyle(
   ISNet.WebUI.DynamicStyle* value
);
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Scheduler TodayHeader.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Style - General")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property ISNet.WebUI.DynamicStyle^ SchedulerTodayHeaderStyle {
   ISNet.WebUI.DynamicStyle^ get();
   void set (    ISNet.WebUI.DynamicStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


SchedulerTodayHourStyle Property

[image]
Intersoft WebScheduler Documentation
SchedulerTodayHourStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : SchedulerTodayHourStyle Property

Glossary Item Box

Contains interactive style for Scheduler TodayHour.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Style - General")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Scheduler TodayHour.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Property SchedulerTodayHourStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.SchedulerTodayHourStyle = value

value = instance.SchedulerTodayHourStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - General")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Scheduler TodayHour.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ISNet.WebUI.WebStyle SchedulerTodayHourStyle {get; set;}
Delphi
public read-write property SchedulerTodayHourStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Style - General")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DescriptionAttribute("Contains interactive style for Scheduler TodayHour.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get,set SchedulerTodayHourStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - General")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Scheduler TodayHour.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ISNet.WebUI.WebStyle* get_SchedulerTodayHourStyle();
public: __property void set_SchedulerTodayHourStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - General")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Scheduler TodayHour.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ISNet.WebUI.WebStyle^ SchedulerTodayHourStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ScriptDirectory Property

[image]
Intersoft WebScheduler Documentation
ScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required scripts for the control are stored.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
Public Overrides Property ScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.String

instance.ScriptDirectory = value

value = instance.ScriptDirectory
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
public override System.string ScriptDirectory {get; set;}
Delphi
public read-write property ScriptDirectory: System.String; override;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Client Script Directory")
public override function get,set ScriptDirectory : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
public: __property System.string* get_ScriptDirectory() override;
public: __property void set_ScriptDirectory(
   System.string* value
) override;
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
public:
property System.String^ ScriptDirectory {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


SelectedHourStyle Property

[image]
Intersoft WebScheduler Documentation
SelectedHourStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : SelectedHourStyle Property

Glossary Item Box

Contains interactive style for Selected Hour.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Style - Day / Week View")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Selected Hour.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
Public Property SelectedHourStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.SelectedHourStyle = value

value = instance.SelectedHourStyle
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Day / Week View")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Selected Hour.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public ISNet.WebUI.WebStyle SelectedHourStyle {get; set;}
Delphi
public read-write property SelectedHourStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Style - Day / Week View")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for Selected Hour.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
public function get,set SelectedHourStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Day / Week View")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Selected Hour.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public: __property ISNet.WebUI.WebStyle* get_SelectedHourStyle();
public: __property void set_SelectedHourStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Day / Week View")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Selected Hour.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public:
property ISNet.WebUI.WebStyle^ SelectedHourStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


SharedScriptDirectory Property

[image]
Intersoft WebScheduler Documentation
SharedScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : SharedScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required framework scripts for the control are stored.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
Public Overrides Property SharedScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.String

instance.SharedScriptDirectory = value

value = instance.SharedScriptDirectory
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
public override System.string SharedScriptDirectory {get; set;}
Delphi
public read-write property SharedScriptDirectory: System.String; override;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Script Directory")
public override function get,set SharedScriptDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
public: __property System.string* get_SharedScriptDirectory() override;
public: __property void set_SharedScriptDirectory(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
public:
property System.String^ SharedScriptDirectory {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ShowWeekNumbers Property

[image]
Intersoft WebScheduler Documentation
ShowWeekNumbers Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ShowWeekNumbers Property

Glossary Item Box

Specifies whether WebScheduler should show week number or not.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether WebScheduler should show week number or not.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ShowWeekNumbers As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

instance.ShowWeekNumbers = value

value = instance.ShowWeekNumbers
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether WebScheduler should show week number or not.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool ShowWeekNumbers {get; set;}
Delphi
public read-write property ShowWeekNumbers: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether WebScheduler should show week number or not.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set ShowWeekNumbers : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether WebScheduler should show week number or not.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_ShowWeekNumbers();
public: __property void set_ShowWeekNumbers(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether WebScheduler should show week number or not.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool ShowWeekNumbers {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


TextSettings Property

[image]
Intersoft WebScheduler Documentation
TextSettings Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : TextSettings Property

Glossary Item Box

Provides settings that control text that shown in WebScheduler.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setTextSettings")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Provides the settings that control the text that shown in WebScheduler.")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public ReadOnly Property TextSettings As WebSchedulerTextSettings
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As WebSchedulerTextSettings

value = instance.TextSettings
C#
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setTextSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the text that shown in WebScheduler.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebSchedulerTextSettings TextSettings {get;}
Delphi
public read-only property TextSettings: WebSchedulerTextSettings;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setTextSettings")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Provides the settings that control the text that shown in WebScheduler.")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get TextSettings : WebSchedulerTextSettings
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setTextSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the text that shown in WebScheduler.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebSchedulerTextSettings* get_TextSettings();
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setTextSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the text that shown in WebScheduler.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebSchedulerTextSettings^ TextSettings {
   WebSchedulerTextSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


TimeBasedEventStyle Property

[image]
Intersoft WebScheduler Documentation
TimeBasedEventStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : TimeBasedEventStyle Property

Glossary Item Box

Contains interactive style for TimeBasedEvent.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for TimeBasedEvent.")>
<System.ComponentModel.CategoryAttribute("Style - Event")>
Public Property TimeBasedEventStyle As WebSchedulerTimeBasedEventStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As WebSchedulerTimeBasedEventStyle

instance.TimeBasedEventStyle = value

value = instance.TimeBasedEventStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for TimeBasedEvent.")]
[System.ComponentModel.CategoryAttribute("Style - Event")]
public WebSchedulerTimeBasedEventStyle TimeBasedEventStyle {get; set;}
Delphi
public read-write property TimeBasedEventStyle: WebSchedulerTimeBasedEventStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for TimeBasedEvent.")
System.ComponentModel.CategoryAttribute("Style - Event")
public function get,set TimeBasedEventStyle : WebSchedulerTimeBasedEventStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for TimeBasedEvent.")]
[System.ComponentModel.CategoryAttribute("Style - Event")]
public: __property WebSchedulerTimeBasedEventStyle* get_TimeBasedEventStyle();
public: __property void set_TimeBasedEventStyle(
   WebSchedulerTimeBasedEventStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for TimeBasedEvent.")]
[System.ComponentModel.CategoryAttribute("Style - Event")]
public:
property WebSchedulerTimeBasedEventStyle^ TimeBasedEventStyle {
   WebSchedulerTimeBasedEventStyle^ get();
   void set (    WebSchedulerTimeBasedEventStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


TimelineContentCellStyle Property

[image]
Intersoft WebScheduler Documentation
TimelineContentCellStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : TimelineContentCellStyle Property

Glossary Item Box

Contains interactive style for Timeline ContentCell.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Style - Timeline")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Timeline ContentCell.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Property TimelineContentCellStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.TimelineContentCellStyle = value

value = instance.TimelineContentCellStyle
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Timeline")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Timeline ContentCell.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ISNet.WebUI.WebStyle TimelineContentCellStyle {get; set;}
Delphi
public read-write property TimelineContentCellStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Style - Timeline")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for Timeline ContentCell.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get,set TimelineContentCellStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Timeline")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Timeline ContentCell.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ISNet.WebUI.WebStyle* get_TimelineContentCellStyle();
public: __property void set_TimelineContentCellStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Timeline")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Timeline ContentCell.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ISNet.WebUI.WebStyle^ TimelineContentCellStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


TimelineDateCellStyle Property

[image]
Intersoft WebScheduler Documentation
TimelineDateCellStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : TimelineDateCellStyle Property

Glossary Item Box

Contains interactive style for Timeline DateCell.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Timeline DateCell.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Style - Timeline")>
Public Property TimelineDateCellStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.TimelineDateCellStyle = value

value = instance.TimelineDateCellStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Timeline DateCell.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - Timeline")]
public ISNet.WebUI.WebStyle TimelineDateCellStyle {get; set;}
Delphi
public read-write property TimelineDateCellStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DescriptionAttribute("Contains interactive style for Timeline DateCell.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Style - Timeline")
public function get,set TimelineDateCellStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Timeline DateCell.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - Timeline")]
public: __property ISNet.WebUI.WebStyle* get_TimelineDateCellStyle();
public: __property void set_TimelineDateCellStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Timeline DateCell.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - Timeline")]
public:
property ISNet.WebUI.WebStyle^ TimelineDateCellStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


TimelineDisabledTimeCellStyle Property

[image]
Intersoft WebScheduler Documentation
TimelineDisabledTimeCellStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : TimelineDisabledTimeCellStyle Property

Glossary Item Box

Contains interactive style for Timeline DisabledTime cell.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Style - Timeline")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Timeline DisabledTime cell.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property TimelineDisabledTimeCellStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.TimelineDisabledTimeCellStyle = value

value = instance.TimelineDisabledTimeCellStyle
C#
[System.ComponentModel.CategoryAttribute("Style - Timeline")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Timeline DisabledTime cell.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public ISNet.WebUI.WebStyle TimelineDisabledTimeCellStyle {get; set;}
Delphi
public read-write property TimelineDisabledTimeCellStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.CategoryAttribute("Style - Timeline")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DescriptionAttribute("Contains interactive style for Timeline DisabledTime cell.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set TimelineDisabledTimeCellStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Style - Timeline")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Timeline DisabledTime cell.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property ISNet.WebUI.WebStyle* get_TimelineDisabledTimeCellStyle();
public: __property void set_TimelineDisabledTimeCellStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Style - Timeline")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Timeline DisabledTime cell.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property ISNet.WebUI.WebStyle^ TimelineDisabledTimeCellStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


TimelineResourceCellStyle Property

[image]
Intersoft WebScheduler Documentation
TimelineResourceCellStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : TimelineResourceCellStyle Property

Glossary Item Box

Contains interactive style for Timeline ResouceCell.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Style - Timeline")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Timeline ResourceCell.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Property TimelineResourceCellStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.TimelineResourceCellStyle = value

value = instance.TimelineResourceCellStyle
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Timeline")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Timeline ResourceCell.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ISNet.WebUI.WebStyle TimelineResourceCellStyle {get; set;}
Delphi
public read-write property TimelineResourceCellStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Style - Timeline")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for Timeline ResourceCell.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get,set TimelineResourceCellStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Timeline")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Timeline ResourceCell.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ISNet.WebUI.WebStyle* get_TimelineResourceCellStyle();
public: __property void set_TimelineResourceCellStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Timeline")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Timeline ResourceCell.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ISNet.WebUI.WebStyle^ TimelineResourceCellStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


TimelineResourceHeaderTextCellStyle Property

[image]
Intersoft WebScheduler Documentation
TimelineResourceHeaderTextCellStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : TimelineResourceHeaderTextCellStyle Property

Glossary Item Box

Contains interactive style for Timeline ResourceCellText.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Style - Timeline")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Timeline ResourceCellText.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Property TimelineResourceHeaderTextCellStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.TimelineResourceHeaderTextCellStyle = value

value = instance.TimelineResourceHeaderTextCellStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - Timeline")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Timeline ResourceCellText.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ISNet.WebUI.WebStyle TimelineResourceHeaderTextCellStyle {get; set;}
Delphi
public read-write property TimelineResourceHeaderTextCellStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Style - Timeline")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DescriptionAttribute("Contains interactive style for Timeline ResourceCellText.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get,set TimelineResourceHeaderTextCellStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - Timeline")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Timeline ResourceCellText.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ISNet.WebUI.WebStyle* get_TimelineResourceHeaderTextCellStyle();
public: __property void set_TimelineResourceHeaderTextCellStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - Timeline")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Timeline ResourceCellText.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ISNet.WebUI.WebStyle^ TimelineResourceHeaderTextCellStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


TimelineTimeCellStyle Property

[image]
Intersoft WebScheduler Documentation
TimelineTimeCellStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : TimelineTimeCellStyle Property

Glossary Item Box

Contains interactive style for Timeline TimeCell.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Timeline TimeCell.")>
<System.ComponentModel.CategoryAttribute("Style - Timeline")>
Public Property TimelineTimeCellStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.TimelineTimeCellStyle = value

value = instance.TimelineTimeCellStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Timeline TimeCell.")]
[System.ComponentModel.CategoryAttribute("Style - Timeline")]
public ISNet.WebUI.WebStyle TimelineTimeCellStyle {get; set;}
Delphi
public read-write property TimelineTimeCellStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for Timeline TimeCell.")
System.ComponentModel.CategoryAttribute("Style - Timeline")
public function get,set TimelineTimeCellStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Timeline TimeCell.")]
[System.ComponentModel.CategoryAttribute("Style - Timeline")]
public: __property ISNet.WebUI.WebStyle* get_TimelineTimeCellStyle();
public: __property void set_TimelineTimeCellStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Timeline TimeCell.")]
[System.ComponentModel.CategoryAttribute("Style - Timeline")]
public:
property ISNet.WebUI.WebStyle^ TimelineTimeCellStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


UseDefaultStyle Property

[image]
Intersoft WebScheduler Documentation
UseDefaultStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : UseDefaultStyle Property

Glossary Item Box

Specifies whether WebScheduler should apply embedded default style for its appearance.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies whether WebScheduler should apply embedded default style for its appearance.")>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property UseDefaultStyle As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

instance.UseDefaultStyle = value

value = instance.UseDefaultStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether WebScheduler should apply embedded default style for its appearance.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool UseDefaultStyle {get; set;}
Delphi
public read-write property UseDefaultStyle: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether WebScheduler should apply embedded default style for its appearance.")
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set UseDefaultStyle : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether WebScheduler should apply embedded default style for its appearance.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_UseDefaultStyle();
public: __property void set_UseDefaultStyle(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether WebScheduler should apply embedded default style for its appearance.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool UseDefaultStyle {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ViewHeaderFrameStyle Property

[image]
Intersoft WebScheduler Documentation
ViewHeaderFrameStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ViewHeaderFrameStyle Property

Glossary Item Box

Contains interactive style for ViewHeader Frame.

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for ViewHeader Frame.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.CategoryAttribute("Style - General")>
Public Property ViewHeaderFrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.ViewHeaderFrameStyle = value

value = instance.ViewHeaderFrameStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for ViewHeader Frame.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Style - General")]
public ISNet.WebUI.WebStyle ViewHeaderFrameStyle {get; set;}
Delphi
public read-write property ViewHeaderFrameStyle: ISNet.WebUI.WebStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for ViewHeader Frame.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.CategoryAttribute("Style - General")
public function get,set ViewHeaderFrameStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for ViewHeader Frame.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Style - General")]
public: __property ISNet.WebUI.WebStyle* get_ViewHeaderFrameStyle();
public: __property void set_ViewHeaderFrameStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for ViewHeader Frame.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Style - General")]
public:
property ISNet.WebUI.WebStyle^ ViewHeaderFrameStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ViewHeaderStyle Property

[image]
Intersoft WebScheduler Documentation
ViewHeaderStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ViewHeaderStyle Property

Glossary Item Box

Contains interactive style for ViewHeader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Style - General")>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for ViewHeader.")>
Public Property ViewHeaderStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.DynamicStyle

instance.ViewHeaderStyle = value

value = instance.ViewHeaderStyle
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style - General")]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for ViewHeader.")]
public ISNet.WebUI.DynamicStyle ViewHeaderStyle {get; set;}
Delphi
public read-write property ViewHeaderStyle: ISNet.WebUI.DynamicStyle;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Style - General")
System.ComponentModel.DescriptionAttribute("Contains interactive style for ViewHeader.")
public function get,set ViewHeaderStyle : ISNet.WebUI.DynamicStyle
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style - General")]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for ViewHeader.")]
public: __property ISNet.WebUI.DynamicStyle* get_ViewHeaderStyle();
public: __property void set_ViewHeaderStyle(
   ISNet.WebUI.DynamicStyle* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style - General")]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for ViewHeader.")]
public:
property ISNet.WebUI.DynamicStyle^ ViewHeaderStyle {
   ISNet.WebUI.DynamicStyle^ get();
   void set (    ISNet.WebUI.DynamicStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ViewSettings Property

[image]
Intersoft WebScheduler Documentation
ViewSettings Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ViewSettings Property

Glossary Item Box

Provides the settings that control the behaviors of the view in WebScheduler.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the view in WebScheduler.")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute("setViewSettings")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public ReadOnly Property ViewSettings As WebSchedulerViewSettings
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As WebSchedulerViewSettings

value = instance.ViewSettings
C#
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the view in WebScheduler.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setViewSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebSchedulerViewSettings ViewSettings {get;}
Delphi
public read-only property ViewSettings: WebSchedulerViewSettings;
JScript
System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the view in WebScheduler.")
ISNet.Serialization.XmlSerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute("setViewSettings")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get ViewSettings : WebSchedulerViewSettings
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the view in WebScheduler.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setViewSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebSchedulerViewSettings* get_ViewSettings();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the view in WebScheduler.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setViewSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebSchedulerViewSettings^ ViewSettings {
   WebSchedulerViewSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


WebDesktopScriptDirectory Property

[image]
Intersoft WebScheduler Documentation
WebDesktopScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : WebDesktopScriptDirectory Property

Glossary Item Box

Gets or sets the IIS path to locate WebDesktop's script directory. This property is only applicable when SmartWebResources is not enabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the IIS path to locate WebDesktop's script directory. This property is only applicable when SmartWebResources is not enabled.")>
Public Property WebDesktopScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.String

instance.WebDesktopScriptDirectory = value

value = instance.WebDesktopScriptDirectory
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the IIS path to locate WebDesktop's script directory. This property is only applicable when SmartWebResources is not enabled.")]
public System.string WebDesktopScriptDirectory {get; set;}
Delphi
public read-write property WebDesktopScriptDirectory: System.String;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Script Directory")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the IIS path to locate WebDesktop's script directory. This property is only applicable when SmartWebResources is not enabled.")
public function get,set WebDesktopScriptDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the IIS path to locate WebDesktop's script directory. This property is only applicable when SmartWebResources is not enabled.")]
public: __property System.string* get_WebDesktopScriptDirectory();
public: __property void set_WebDesktopScriptDirectory(
   System.string* value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the IIS path to locate WebDesktop's script directory. This property is only applicable when SmartWebResources is not enabled.")]
public:
property System.String^ WebDesktopScriptDirectory {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


WeekOptionFrameStyle Property

[image]
Intersoft WebScheduler Documentation
WeekOptionFrameStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : WeekOptionFrameStyle Property

Glossary Item Box

Contains interactive style for WeekOption Frame.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for WeekOption Frame.")>
<System.ComponentModel.CategoryAttribute("Style - General")>
Public Property WeekOptionFrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.WeekOptionFrameStyle = value

value = instance.WeekOptionFrameStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WeekOption Frame.")]
[System.ComponentModel.CategoryAttribute("Style - General")]
public ISNet.WebUI.WebStyle WeekOptionFrameStyle {get; set;}
Delphi
public read-write property WeekOptionFrameStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for WeekOption Frame.")
System.ComponentModel.CategoryAttribute("Style - General")
public function get,set WeekOptionFrameStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WeekOption Frame.")]
[System.ComponentModel.CategoryAttribute("Style - General")]
public: __property ISNet.WebUI.WebStyle* get_WeekOptionFrameStyle();
public: __property void set_WeekOptionFrameStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WeekOption Frame.")]
[System.ComponentModel.CategoryAttribute("Style - General")]
public:
property ISNet.WebUI.WebStyle^ WeekOptionFrameStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


WorkHourStyle Property

[image]
Intersoft WebScheduler Documentation
WorkHourStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : WorkHourStyle Property

Glossary Item Box

Contains interactive style for Work Hour.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Work Hour.")>
<System.ComponentModel.CategoryAttribute("Style - General")>
Public Property WorkHourStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.WorkHourStyle = value

value = instance.WorkHourStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Work Hour.")]
[System.ComponentModel.CategoryAttribute("Style - General")]
public ISNet.WebUI.WebStyle WorkHourStyle {get; set;}
Delphi
public read-write property WorkHourStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for Work Hour.")
System.ComponentModel.CategoryAttribute("Style - General")
public function get,set WorkHourStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Work Hour.")]
[System.ComponentModel.CategoryAttribute("Style - General")]
public: __property ISNet.WebUI.WebStyle* get_WorkHourStyle();
public: __property void set_WorkHourStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Work Hour.")]
[System.ComponentModel.CategoryAttribute("Style - General")]
public:
property ISNet.WebUI.WebStyle^ WorkHourStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


WorkWeekSettings Property

[image]
Intersoft WebScheduler Documentation
WorkWeekSettings Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : WorkWeekSettings Property

Glossary Item Box

Provides the settings that control the behaviors of the WorkWeek in WebScheduler.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("setWorkWeekSettings")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the WorkWeek in WebScheduler.")>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property WorkWeekSettings As WebSchedulerWorkWeekSettings
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As WebSchedulerWorkWeekSettings

value = instance.WorkWeekSettings
C#
[ISNet.Serialization.BinarySerializableAttribute("setWorkWeekSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the WorkWeek in WebScheduler.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public WebSchedulerWorkWeekSettings WorkWeekSettings {get;}
Delphi
public read-only property WorkWeekSettings: WebSchedulerWorkWeekSettings;
JScript
ISNet.Serialization.BinarySerializableAttribute("setWorkWeekSettings")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the WorkWeek in WebScheduler.")
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get WorkWeekSettings : WebSchedulerWorkWeekSettings
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("setWorkWeekSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the WorkWeek in WebScheduler.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebSchedulerWorkWeekSettings* get_WorkWeekSettings();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("setWorkWeekSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the WorkWeek in WebScheduler.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebSchedulerWorkWeekSettings^ WorkWeekSettings {
   WebSchedulerWorkWeekSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


YearDayOfWeekStyle Property

[image]
Intersoft WebScheduler Documentation
YearDayOfWeekStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : YearDayOfWeekStyle Property

Glossary Item Box

Contains interactive style for YearDayOfWeek.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Style - Year / Quarter View")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for YearDayOfWeek.")>
Public Property YearDayOfWeekStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.DynamicStyle

instance.YearDayOfWeekStyle = value

value = instance.YearDayOfWeekStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - Year / Quarter View")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for YearDayOfWeek.")]
public ISNet.WebUI.DynamicStyle YearDayOfWeekStyle {get; set;}
Delphi
public read-write property YearDayOfWeekStyle: ISNet.WebUI.DynamicStyle;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Style - Year / Quarter View")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Contains interactive style for YearDayOfWeek.")
public function get,set YearDayOfWeekStyle : ISNet.WebUI.DynamicStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - Year / Quarter View")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for YearDayOfWeek.")]
public: __property ISNet.WebUI.DynamicStyle* get_YearDayOfWeekStyle();
public: __property void set_YearDayOfWeekStyle(
   ISNet.WebUI.DynamicStyle* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - Year / Quarter View")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for YearDayOfWeek.")]
public:
property ISNet.WebUI.DynamicStyle^ YearDayOfWeekStyle {
   ISNet.WebUI.DynamicStyle^ get();
   void set (    ISNet.WebUI.DynamicStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


YearFrameStyle Property

[image]
Intersoft WebScheduler Documentation
YearFrameStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : YearFrameStyle Property

Glossary Item Box

Contains interactive style for Year Frame.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Style - Year View")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Year Frame.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
Public Property YearFrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebStyle

instance.YearFrameStyle = value

value = instance.YearFrameStyle
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Year View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Year Frame.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public ISNet.WebUI.WebStyle YearFrameStyle {get; set;}
Delphi
public read-write property YearFrameStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Style - Year View")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for Year Frame.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
public function get,set YearFrameStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Year View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Year Frame.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public: __property ISNet.WebUI.WebStyle* get_YearFrameStyle();
public: __property void set_YearFrameStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Year View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Year Frame.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public:
property ISNet.WebUI.WebStyle^ YearFrameStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


YearMonthRowHeaderStyle Property

[image]
Intersoft WebScheduler Documentation
YearMonthRowHeaderStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : YearMonthRowHeaderStyle Property

Glossary Item Box

Contains interactive style for the Year, Quarter and Month row header.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Style - General")>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for the Year, Quarter and Month row header.")>
Public Property YearMonthRowHeaderStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.DynamicStyle

instance.YearMonthRowHeaderStyle = value

value = instance.YearMonthRowHeaderStyle
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style - General")]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the Year, Quarter and Month row header.")]
public ISNet.WebUI.DynamicStyle YearMonthRowHeaderStyle {get; set;}
Delphi
public read-write property YearMonthRowHeaderStyle: ISNet.WebUI.DynamicStyle;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Style - General")
System.ComponentModel.DescriptionAttribute("Contains interactive style for the Year, Quarter and Month row header.")
public function get,set YearMonthRowHeaderStyle : ISNet.WebUI.DynamicStyle
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style - General")]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the Year, Quarter and Month row header.")]
public: __property ISNet.WebUI.DynamicStyle* get_YearMonthRowHeaderStyle();
public: __property void set_YearMonthRowHeaderStyle(
   ISNet.WebUI.DynamicStyle* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style - General")]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the Year, Quarter and Month row header.")]
public:
property ISNet.WebUI.DynamicStyle^ YearMonthRowHeaderStyle {
   ISNet.WebUI.DynamicStyle^ get();
   void set (    ISNet.WebUI.DynamicStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


WebScheduler Class Events

[image]
Intersoft WebScheduler Documentation
WebScheduler Class Events
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebScheduler Class

Glossary Item Box

For a list of all members of this type, see WebScheduler members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | DataBound |
Public Event | Delete |
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Export |
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Insert |
Public Event | JsonSerialization |
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PrepareExportExecute |
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Public Event | Update |
Top

See Also

Reference

WebScheduler Class
ISNet.WebUI.WebScheduler Namespace


DataBound Event

[image]
Intersoft WebScheduler Documentation
DataBound Event
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : DataBound Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.DescriptionAttribute("Fires when event data bound process occurs")>
Public Event DataBound As WebSchedulerDataBoundEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim handler As WebSchedulerDataBoundEventHandler

AddHandler instance.DataBound, handler
C#
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Fires when event data bound process occurs")]
public event WebSchedulerDataBoundEventHandler DataBound
Delphi
public event DataBound: WebSchedulerDataBoundEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Fires when event data bound process occurs")]
public: __event WebSchedulerDataBoundEventHandler* DataBound
C++/CLI
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Fires when event data bound process occurs")]
public:
event WebSchedulerDataBoundEventHandler^ DataBound

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


Delete Event

[image]
Intersoft WebScheduler Documentation
Delete Event
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : Delete Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Fires when event deletion process occurs")>
<System.ComponentModel.CategoryAttribute("Data")>
Public Event Delete As WebSchedulerDataOperationEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim handler As WebSchedulerDataOperationEventHandler

AddHandler instance.Delete, handler
C#
[System.ComponentModel.DescriptionAttribute("Fires when event deletion process occurs")]
[System.ComponentModel.CategoryAttribute("Data")]
public event WebSchedulerDataOperationEventHandler Delete
Delphi
public event Delete: WebSchedulerDataOperationEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Fires when event deletion process occurs")]
[System.ComponentModel.CategoryAttribute("Data")]
public: __event WebSchedulerDataOperationEventHandler* Delete
C++/CLI
[System.ComponentModel.DescriptionAttribute("Fires when event deletion process occurs")]
[System.ComponentModel.CategoryAttribute("Data")]
public:
event WebSchedulerDataOperationEventHandler^ Delete

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


Export Event

[image]
Intersoft WebScheduler Documentation
Export Event
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : Export Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.DescriptionAttribute("Fires when exporting process occurs")>
Public Event Export As WebSchedulerExportEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim handler As WebSchedulerExportEventHandler

AddHandler instance.Export, handler
C#
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Fires when exporting process occurs")]
public event WebSchedulerExportEventHandler Export
Delphi
public event Export: WebSchedulerExportEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Fires when exporting process occurs")]
public: __event WebSchedulerExportEventHandler* Export
C++/CLI
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Fires when exporting process occurs")]
public:
event WebSchedulerExportEventHandler^ Export

Event Data

The event handler receives an argument of type WebSchedulerExportEventArgs containing data related to this event. The following WebSchedulerExportEventArgs properties provide information specific to this event.

Property | Description
EventsDataSource | DataSource events containing raw data which is going to be exported.
RecurringEventsDataSource | DataSource RecurringEvents containing raw data which is going to be exported.
ReportInfo | The WebSchedulerReportInfo that is obtained from the data which is going to be exported.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


Insert Event

[image]
Intersoft WebScheduler Documentation
Insert Event
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : Insert Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Fires when event insertion process occurs")>
<System.ComponentModel.CategoryAttribute("Data")>
Public Event Insert As WebSchedulerDataOperationEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim handler As WebSchedulerDataOperationEventHandler

AddHandler instance.Insert, handler
C#
[System.ComponentModel.DescriptionAttribute("Fires when event insertion process occurs")]
[System.ComponentModel.CategoryAttribute("Data")]
public event WebSchedulerDataOperationEventHandler Insert
Delphi
public event Insert: WebSchedulerDataOperationEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Fires when event insertion process occurs")]
[System.ComponentModel.CategoryAttribute("Data")]
public: __event WebSchedulerDataOperationEventHandler* Insert
C++/CLI
[System.ComponentModel.DescriptionAttribute("Fires when event insertion process occurs")]
[System.ComponentModel.CategoryAttribute("Data")]
public:
event WebSchedulerDataOperationEventHandler^ Insert

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


JsonSerialization Event

[image]
Intersoft WebScheduler Documentation
JsonSerialization Event
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : JsonSerialization Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Fires when WebScheduler objects are serialized to client and EnableFastJsonSerialization enabled")>
<System.ComponentModel.CategoryAttribute("Data")>
Public Event JsonSerialization As WebSchedulerJsonSerializationEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim handler As WebSchedulerJsonSerializationEventHandler

AddHandler instance.JsonSerialization, handler
C#
[System.ComponentModel.DescriptionAttribute("Fires when WebScheduler objects are serialized to client and EnableFastJsonSerialization enabled")]
[System.ComponentModel.CategoryAttribute("Data")]
public event WebSchedulerJsonSerializationEventHandler JsonSerialization
Delphi
public event JsonSerialization: WebSchedulerJsonSerializationEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Fires when WebScheduler objects are serialized to client and EnableFastJsonSerialization enabled")]
[System.ComponentModel.CategoryAttribute("Data")]
public: __event WebSchedulerJsonSerializationEventHandler* JsonSerialization
C++/CLI
[System.ComponentModel.DescriptionAttribute("Fires when WebScheduler objects are serialized to client and EnableFastJsonSerialization enabled")]
[System.ComponentModel.CategoryAttribute("Data")]
public:
event WebSchedulerJsonSerializationEventHandler^ JsonSerialization

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


PrepareExportExecute Event

[image]
Intersoft WebScheduler Documentation
PrepareExportExecute Event
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : PrepareExportExecute Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.DescriptionAttribute("Fires when exporting process is about to occur")>
Public Event PrepareExportExecute As WebSchedulerPrepareExportExecuteEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim handler As WebSchedulerPrepareExportExecuteEventHandler

AddHandler instance.PrepareExportExecute, handler
C#
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Fires when exporting process is about to occur")]
public event WebSchedulerPrepareExportExecuteEventHandler PrepareExportExecute
Delphi
public event PrepareExportExecute: WebSchedulerPrepareExportExecuteEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Fires when exporting process is about to occur")]
public: __event WebSchedulerPrepareExportExecuteEventHandler* PrepareExportExecute
C++/CLI
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Fires when exporting process is about to occur")]
public:
event WebSchedulerPrepareExportExecuteEventHandler^ PrepareExportExecute

Event Data

The event handler receives an argument of type WebSchedulerPrepareExportExecuteEventArgs containing data related to this event. The following WebSchedulerPrepareExportExecuteEventArgs properties provide information specific to this event.

Property | Description
ReportObject |
ReportType |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


Update Event

[image]
Intersoft WebScheduler Documentation
Update Event
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : Update Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.DescriptionAttribute("Fires when event update process occurs")>
Public Event Update As WebSchedulerDataOperationEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim handler As WebSchedulerDataOperationEventHandler

AddHandler instance.Update, handler
C#
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Fires when event update process occurs")]
public event WebSchedulerDataOperationEventHandler Update
Delphi
public event Update: WebSchedulerDataOperationEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Fires when event update process occurs")]
public: __event WebSchedulerDataOperationEventHandler* Update
C++/CLI
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Fires when event update process occurs")]
public:
event WebSchedulerDataOperationEventHandler^ Update

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


WebSchedulerActiveDayStyle Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerActiveDayStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerActiveDayStyle Class

Glossary Item Box

A collection of interactive styles used for WebScheduler's active day.

Object Model

WebSchedulerActiveDayStyle Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerActiveDayStyle
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerActiveDayStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerActiveDayStyle : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSchedulerActiveDayStyle = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerActiveDayStyle extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerActiveDayStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerActiveDayStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebScheduler.WebSchedulerActiveDayStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerActiveDayStyle Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerActiveDayStyle Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerActiveDayStyle Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerActiveDayStyle Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerActiveDayStyle.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerActiveDayStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | BackgroundImage | Determines the file name of an image to be displayed in the background of ActiveDay. Determines the file name of an image to be displayed in the background of ActiveDay.
Public Property | BorderHeight | Border height of ActiveDay. Border height of ActiveDay.
Public Property | Color | Color of ActiveDay. Determines color of ActiveDay.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerActiveDayStyle Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerActiveDayStyle Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerActiveDayStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerActiveDayStyle Class : WebSchedulerActiveDayStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerActiveDayStyle()
C#
public WebSchedulerActiveDayStyle()
Delphi
public WebSchedulerActiveDayStyle();
JScript
public function WebSchedulerActiveDayStyle();
Managed Extensions for C++
public: WebSchedulerActiveDayStyle();
C++/CLI
public:
WebSchedulerActiveDayStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerActiveDayStyle Class
WebSchedulerActiveDayStyle Members


WebSchedulerActiveDayStyle Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerActiveDayStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerActiveDayStyle Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerActiveDayStyle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerActiveDayStyle Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerActiveDayStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerActiveDayStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerActiveDayStyle Class
WebSchedulerActiveDayStyle Members


WebSchedulerActiveDayStyle Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerActiveDayStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerActiveDayStyle Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerActiveDayStyle members.

Public Properties

 | Name | Description
Public Property | BackgroundImage | Determines the file name of an image to be displayed in the background of ActiveDay. Determines the file name of an image to be displayed in the background of ActiveDay.
Public Property | BorderHeight | Border height of ActiveDay. Border height of ActiveDay.
Public Property | Color | Color of ActiveDay. Determines color of ActiveDay.
Top

See Also

Reference

WebSchedulerActiveDayStyle Class
ISNet.WebUI.WebScheduler Namespace


BackgroundImage Property

[image]
Intersoft WebScheduler Documentation
BackgroundImage Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerActiveDayStyle Class : BackgroundImage Property

Glossary Item Box

Determines the file name of an image to be displayed in the background of ActiveDay. Determines the file name of an image to be displayed in the background of ActiveDay.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Determines the file name of an image to be displayed in the background of ActiveDay.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Active Day Style")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property BackgroundImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerActiveDayStyle
Dim value As System.String

instance.BackgroundImage = value

value = instance.BackgroundImage
C#
[System.ComponentModel.DescriptionAttribute("Determines the file name of an image to be displayed in the background of ActiveDay.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Active Day Style")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string BackgroundImage {get; set;}
Delphi
public read-write property BackgroundImage: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Determines the file name of an image to be displayed in the background of ActiveDay.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Active Day Style")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set BackgroundImage : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Determines the file name of an image to be displayed in the background of ActiveDay.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Active Day Style")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_BackgroundImage();
public: __property void set_BackgroundImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Determines the file name of an image to be displayed in the background of ActiveDay.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Active Day Style")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ BackgroundImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerActiveDayStyle Class
WebSchedulerActiveDayStyle Members


BorderHeight Property

[image]
Intersoft WebScheduler Documentation
BorderHeight Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerActiveDayStyle Class : BorderHeight Property

Glossary Item Box

Border height of ActiveDay. Border height of ActiveDay.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Active Day Style")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Border height of ActiveDay.")>
Public Property BorderHeight As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerActiveDayStyle
Dim value As System.Web.UI.WebControls.Unit

instance.BorderHeight = value

value = instance.BorderHeight
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Active Day Style")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Border height of ActiveDay.")]
public System.Web.UI.WebControls.Unit BorderHeight {get; set;}
Delphi
public read-write property BorderHeight: System.Web.UI.WebControls.Unit;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Active Day Style")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Border height of ActiveDay.")
public function get,set BorderHeight : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Active Day Style")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Border height of ActiveDay.")]
public: __property System.Web.UI.WebControls.Unit get_BorderHeight();
public: __property void set_BorderHeight(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Active Day Style")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Border height of ActiveDay.")]
public:
property System.Web.UI.WebControls.Unit BorderHeight {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerActiveDayStyle Class
WebSchedulerActiveDayStyle Members


Color Property

[image]
Intersoft WebScheduler Documentation
Color Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerActiveDayStyle Class : Color Property

Glossary Item Box

Color of ActiveDay. Determines color of ActiveDay.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Determines color of ActiveDay.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Active Day Style")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Color As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerActiveDayStyle
Dim value As System.Drawing.Color

instance.Color = value

value = instance.Color
C#
[System.ComponentModel.DescriptionAttribute("Determines color of ActiveDay.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Active Day Style")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.Drawing.Color Color {get; set;}
Delphi
public read-write property Color: System.Drawing.Color;
JScript
System.ComponentModel.DescriptionAttribute("Determines color of ActiveDay.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Active Day Style")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Color : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Determines color of ActiveDay.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Active Day Style")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.Drawing.Color get_Color();
public: __property void set_Color(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Determines color of ActiveDay.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Active Day Style")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.Drawing.Color Color {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerActiveDayStyle Class
WebSchedulerActiveDayStyle Members


WebSchedulerAgendaView Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerAgendaView Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerAgendaView Class

Glossary Item Box

A collection of styles used for WebScheduler's agenda view.

Object Model

WebSchedulerAgendaView Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerAgendaView
   Inherits WebSchedulerBaseView
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerAgendaView
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerAgendaView : WebSchedulerBaseView, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSchedulerAgendaView = class(WebSchedulerBaseView, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerAgendaView extends WebSchedulerBaseView implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerAgendaView : public WebSchedulerBaseView, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerAgendaView : public WebSchedulerBaseView, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebScheduler.WebSchedulerAgendaView

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerAgendaView Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerAgendaView Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerAgendaView Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerAgendaView Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerAgendaView.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerAgendaView Constructor |
Top

Public Properties

 | Name | Description
Public Property | DateFormatString | Overridden. Determines the DateFormatString in AgendaView. Determines the DateFormatString in AgendaView.
Public Property | DisplayViewOnMyCalendarLink | Determines whether or not view on my calendar link is displayed. Determines whether or not View on my calendar link displayed in Agenda actions row
Public Property | ItemDateFormatString | Determines the DateFormatString for Agenda's Item. Determines the DateFormatString in AgendaView's item.
Public Property | NumberOfDays | Specifies Agenda view number of days.
Public Property | UseAgendaDetailsCollection | Determines whether agenda view use user specified AgendaDetailsCollection or not. If Yes, then AgendaDetailsCollection should manually specified by user. If this property is enabled, AgendaDetailsCollection will be used as the detail fields in Agenda view.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerAgendaView Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerAgendaView Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerAgendaView Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerAgendaView Class : WebSchedulerAgendaView Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerAgendaView()
C#
public WebSchedulerAgendaView()
Delphi
public WebSchedulerAgendaView();
JScript
public function WebSchedulerAgendaView();
Managed Extensions for C++
public: WebSchedulerAgendaView();
C++/CLI
public:
WebSchedulerAgendaView();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerAgendaView Class
WebSchedulerAgendaView Members


WebSchedulerAgendaView Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerAgendaView Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerAgendaView Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerAgendaView members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerAgendaView Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerAgendaView Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerAgendaView
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerAgendaView Class
WebSchedulerAgendaView Members


WebSchedulerAgendaView Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerAgendaView Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerAgendaView Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerAgendaView members.

Public Properties

 | Name | Description
Public Property | DateFormatString | Overridden. Determines the DateFormatString in AgendaView. Determines the DateFormatString in AgendaView.
Public Property | DisplayViewOnMyCalendarLink | Determines whether or not view on my calendar link is displayed. Determines whether or not View on my calendar link displayed in Agenda actions row
Public Property | ItemDateFormatString | Determines the DateFormatString for Agenda's Item. Determines the DateFormatString in AgendaView's item.
Public Property | NumberOfDays | Specifies Agenda view number of days.
Public Property | UseAgendaDetailsCollection | Determines whether agenda view use user specified AgendaDetailsCollection or not. If Yes, then AgendaDetailsCollection should manually specified by user. If this property is enabled, AgendaDetailsCollection will be used as the detail fields in Agenda view.
Top

See Also

Reference

WebSchedulerAgendaView Class
ISNet.WebUI.WebScheduler Namespace


DateFormatString Property

[image]
Intersoft WebScheduler Documentation
DateFormatString Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerAgendaView Class : DateFormatString Property

Glossary Item Box

Determines the DateFormatString in AgendaView. Determines the DateFormatString in AgendaView.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Agenda View")>
<System.ComponentModel.DescriptionAttribute("Determines the DateFormatString in AgendaView.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Overrides Property DateFormatString As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerAgendaView
Dim value As System.String

instance.DateFormatString = value

value = instance.DateFormatString
C#
[System.ComponentModel.CategoryAttribute("Agenda View")]
[System.ComponentModel.DescriptionAttribute("Determines the DateFormatString in AgendaView.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public override System.string DateFormatString {get; set;}
Delphi
public read-write property DateFormatString: System.String; override;
JScript
System.ComponentModel.CategoryAttribute("Agenda View")
System.ComponentModel.DescriptionAttribute("Determines the DateFormatString in AgendaView.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public override function get,set DateFormatString : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Agenda View")]
[System.ComponentModel.DescriptionAttribute("Determines the DateFormatString in AgendaView.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_DateFormatString() override;
public: __property void set_DateFormatString(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.CategoryAttribute("Agenda View")]
[System.ComponentModel.DescriptionAttribute("Determines the DateFormatString in AgendaView.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ DateFormatString {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerAgendaView Class
WebSchedulerAgendaView Members


DisplayViewOnMyCalendarLink Property

[image]
Intersoft WebScheduler Documentation
DisplayViewOnMyCalendarLink Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerAgendaView Class : DisplayViewOnMyCalendarLink Property

Glossary Item Box

Determines whether or not view on my calendar link is displayed. Determines whether or not View on my calendar link displayed in Agenda actions row

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Determines whether or not view on my calendar link is displayed.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Agenda View")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property DisplayViewOnMyCalendarLink As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerAgendaView
Dim value As System.Boolean

instance.DisplayViewOnMyCalendarLink = value

value = instance.DisplayViewOnMyCalendarLink
C#
[System.ComponentModel.DescriptionAttribute("Determines whether or not view on my calendar link is displayed.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Agenda View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool DisplayViewOnMyCalendarLink {get; set;}
Delphi
public read-write property DisplayViewOnMyCalendarLink: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Determines whether or not view on my calendar link is displayed.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Agenda View")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set DisplayViewOnMyCalendarLink : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Determines whether or not view on my calendar link is displayed.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Agenda View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_DisplayViewOnMyCalendarLink();
public: __property void set_DisplayViewOnMyCalendarLink(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Determines whether or not view on my calendar link is displayed.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Agenda View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool DisplayViewOnMyCalendarLink {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerAgendaView Class
WebSchedulerAgendaView Members


ItemDateFormatString Property

[image]
Intersoft WebScheduler Documentation
ItemDateFormatString Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerAgendaView Class : ItemDateFormatString Property

Glossary Item Box

Determines the DateFormatString for Agenda's Item. Determines the DateFormatString in AgendaView's item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Determines the DateFormatString for Agenda's Item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Agenda View")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ItemDateFormatString As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerAgendaView
Dim value As System.String

instance.ItemDateFormatString = value

value = instance.ItemDateFormatString
C#
[System.ComponentModel.DescriptionAttribute("Determines the DateFormatString for Agenda's Item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Agenda View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string ItemDateFormatString {get; set;}
Delphi
public read-write property ItemDateFormatString: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Determines the DateFormatString for Agenda's Item.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Agenda View")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set ItemDateFormatString : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Determines the DateFormatString for Agenda's Item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Agenda View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_ItemDateFormatString();
public: __property void set_ItemDateFormatString(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Determines the DateFormatString for Agenda's Item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Agenda View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ ItemDateFormatString {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerAgendaView Class
WebSchedulerAgendaView Members


NumberOfDays Property

[image]
Intersoft WebScheduler Documentation
NumberOfDays Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerAgendaView Class : NumberOfDays Property

Glossary Item Box

Specifies Agenda view number of days.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Agenda View")>
<System.ComponentModel.DescriptionAttribute("Specifies Agenda view number of days.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property NumberOfDays As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerAgendaView
Dim value As System.Integer

instance.NumberOfDays = value

value = instance.NumberOfDays
C#
[System.ComponentModel.CategoryAttribute("Agenda View")]
[System.ComponentModel.DescriptionAttribute("Specifies Agenda view number of days.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.int NumberOfDays {get; set;}
Delphi
public read-write property NumberOfDays: System.Integer;
JScript
System.ComponentModel.CategoryAttribute("Agenda View")
System.ComponentModel.DescriptionAttribute("Specifies Agenda view number of days.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set NumberOfDays : System.int
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Agenda View")]
[System.ComponentModel.DescriptionAttribute("Specifies Agenda view number of days.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.int get_NumberOfDays();
public: __property void set_NumberOfDays(
   System.int value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Agenda View")]
[System.ComponentModel.DescriptionAttribute("Specifies Agenda view number of days.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.int NumberOfDays {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerAgendaView Class
WebSchedulerAgendaView Members


UseAgendaDetailsCollection Property

[image]
Intersoft WebScheduler Documentation
UseAgendaDetailsCollection Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerAgendaView Class : UseAgendaDetailsCollection Property

Glossary Item Box

Determines whether agenda view use user specified AgendaDetailsCollection or not. If Yes, then AgendaDetailsCollection should manually specified by user. If this property is enabled, AgendaDetailsCollection will be used as the detail fields in Agenda view.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Agenda View")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines whether agenda view use user specified AgendaDetailsCollection or not. If Yes, then AgendaDetailsCollection should manually specified by user.")>
Public Property UseAgendaDetailsCollection As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerAgendaView
Dim value As System.Boolean

instance.UseAgendaDetailsCollection = value

value = instance.UseAgendaDetailsCollection
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Agenda View")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether agenda view use user specified AgendaDetailsCollection or not. If Yes, then AgendaDetailsCollection should manually specified by user.")]
public System.bool UseAgendaDetailsCollection {get; set;}
Delphi
public read-write property UseAgendaDetailsCollection: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Agenda View")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether agenda view use user specified AgendaDetailsCollection or not. If Yes, then AgendaDetailsCollection should manually specified by user.")
public function get,set UseAgendaDetailsCollection : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Agenda View")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether agenda view use user specified AgendaDetailsCollection or not. If Yes, then AgendaDetailsCollection should manually specified by user.")]
public: __property System.bool get_UseAgendaDetailsCollection();
public: __property void set_UseAgendaDetailsCollection(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Agenda View")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether agenda view use user specified AgendaDetailsCollection or not. If Yes, then AgendaDetailsCollection should manually specified by user.")]
public:
property System.bool UseAgendaDetailsCollection {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerAgendaView Class
WebSchedulerAgendaView Members


WebSchedulerBinding Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerBinding Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerBinding Class

Glossary Item Box

A collection of settings used for WebScheduler's data binding.

Object Model

WebSchedulerBinding Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerBinding
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerBinding
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerBinding : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSchedulerBinding = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerBinding extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerBinding : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerBinding : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebScheduler.WebSchedulerBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerBinding Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerBinding Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerBinding Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerBinding Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerBinding.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerBinding Constructor |
Top

Public Properties

 | Name | Description
Public Property | CategoryBinding | Provides the settings that control the category binding. Provides the settings that control the category binding.
Public Property | EventsBinding | Provides the settings that control the events binding. Provides the settings that control the events binding.
Public Property | RecurrenceBinding | Provides the settings that control the recurrence binding. Provides the settings that control the recurrence binding.
Public Property | RecurringEventsBinding | Provides the settings that control the RecurringEvents binding. Provides the settings that control the RecurringEvents binding.
Public Property | ResourcesBinding | Provides the settings that control the resources binding. Provides the settings that control the resources binding.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerBinding Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerBinding Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerBinding Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerBinding Class : WebSchedulerBinding Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerBinding()
C#
public WebSchedulerBinding()
Delphi
public WebSchedulerBinding();
JScript
public function WebSchedulerBinding();
Managed Extensions for C++
public: WebSchedulerBinding();
C++/CLI
public:
WebSchedulerBinding();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerBinding Class
WebSchedulerBinding Members


WebSchedulerBinding Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerBinding Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerBinding Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerBinding members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerBinding Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerBinding Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerBinding
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerBinding Class
WebSchedulerBinding Members


WebSchedulerBinding Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerBinding Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerBinding Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerBinding members.

Public Properties

 | Name | Description
Public Property | CategoryBinding | Provides the settings that control the category binding. Provides the settings that control the category binding.
Public Property | EventsBinding | Provides the settings that control the events binding. Provides the settings that control the events binding.
Public Property | RecurrenceBinding | Provides the settings that control the recurrence binding. Provides the settings that control the recurrence binding.
Public Property | RecurringEventsBinding | Provides the settings that control the RecurringEvents binding. Provides the settings that control the RecurringEvents binding.
Public Property | ResourcesBinding | Provides the settings that control the resources binding. Provides the settings that control the resources binding.
Top

See Also

Reference

WebSchedulerBinding Class
ISNet.WebUI.WebScheduler Namespace


CategoryBinding Property

[image]
Intersoft WebScheduler Documentation
CategoryBinding Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerBinding Class : CategoryBinding Property

Glossary Item Box

Provides the settings that control the category binding. Provides the settings that control the category binding.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Binding")>
<ISNet.Serialization.BinarySerializableAttribute("setCategoryBinding")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Provides the settings that control the category binding.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
Public ReadOnly Property CategoryBinding As WebSchedulerCategoriesBinding
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerBinding
Dim value As WebSchedulerCategoriesBinding

value = instance.CategoryBinding
C#
[System.ComponentModel.CategoryAttribute("Binding")]
[ISNet.Serialization.BinarySerializableAttribute("setCategoryBinding")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the category binding.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public WebSchedulerCategoriesBinding CategoryBinding {get;}
Delphi
public read-only property CategoryBinding: WebSchedulerCategoriesBinding;
JScript
System.ComponentModel.CategoryAttribute("Binding")
ISNet.Serialization.BinarySerializableAttribute("setCategoryBinding")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Provides the settings that control the category binding.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute()
public function get CategoryBinding : WebSchedulerCategoriesBinding
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Binding")]
[ISNet.Serialization.BinarySerializableAttribute("setCategoryBinding")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the category binding.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public: __property WebSchedulerCategoriesBinding* get_CategoryBinding();
C++/CLI
[System.ComponentModel.CategoryAttribute("Binding")]
[ISNet.Serialization.BinarySerializableAttribute("setCategoryBinding")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the category binding.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public:
property WebSchedulerCategoriesBinding^ CategoryBinding {
   WebSchedulerCategoriesBinding^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerBinding Class
WebSchedulerBinding Members


EventsBinding Property

[image]
Intersoft WebScheduler Documentation
EventsBinding Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerBinding Class : EventsBinding Property

Glossary Item Box

Provides the settings that control the events binding. Provides the settings that control the events binding.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Binding")>
<System.ComponentModel.DescriptionAttribute("Provides the settings that control the events binding.")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setEventsBinding")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property EventsBinding As WebSchedulerEventsBinding
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerBinding
Dim value As WebSchedulerEventsBinding

value = instance.EventsBinding
C#
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the events binding.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setEventsBinding")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public WebSchedulerEventsBinding EventsBinding {get;}
Delphi
public read-only property EventsBinding: WebSchedulerEventsBinding;
JScript
System.ComponentModel.CategoryAttribute("Binding")
System.ComponentModel.DescriptionAttribute("Provides the settings that control the events binding.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute("setEventsBinding")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get EventsBinding : WebSchedulerEventsBinding
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the events binding.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setEventsBinding")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property WebSchedulerEventsBinding* get_EventsBinding();
C++/CLI
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the events binding.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setEventsBinding")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property WebSchedulerEventsBinding^ EventsBinding {
   WebSchedulerEventsBinding^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerBinding Class
WebSchedulerBinding Members


RecurrenceBinding Property

[image]
Intersoft WebScheduler Documentation
RecurrenceBinding Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerBinding Class : RecurrenceBinding Property

Glossary Item Box

Provides the settings that control the recurrence binding. Provides the settings that control the recurrence binding.

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Binding")>
<ISNet.Serialization.BinarySerializableAttribute("setRecurrenceBinding")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Provides the settings that control the recurrence binding.")>
Public ReadOnly Property RecurrenceBinding As WebSchedulerRecurrencesBinding
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerBinding
Dim value As WebSchedulerRecurrencesBinding

value = instance.RecurrenceBinding
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Binding")]
[ISNet.Serialization.BinarySerializableAttribute("setRecurrenceBinding")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the recurrence binding.")]
public WebSchedulerRecurrencesBinding RecurrenceBinding {get;}
Delphi
public read-only property RecurrenceBinding: WebSchedulerRecurrencesBinding;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Binding")
ISNet.Serialization.BinarySerializableAttribute("setRecurrenceBinding")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Provides the settings that control the recurrence binding.")
public function get RecurrenceBinding : WebSchedulerRecurrencesBinding
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Binding")]
[ISNet.Serialization.BinarySerializableAttribute("setRecurrenceBinding")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the recurrence binding.")]
public: __property WebSchedulerRecurrencesBinding* get_RecurrenceBinding();
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Binding")]
[ISNet.Serialization.BinarySerializableAttribute("setRecurrenceBinding")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the recurrence binding.")]
public:
property WebSchedulerRecurrencesBinding^ RecurrenceBinding {
   WebSchedulerRecurrencesBinding^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerBinding Class
WebSchedulerBinding Members


RecurringEventsBinding Property

[image]
Intersoft WebScheduler Documentation
RecurringEventsBinding Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerBinding Class : RecurringEventsBinding Property

Glossary Item Box

Provides the settings that control the RecurringEvents binding. Provides the settings that control the RecurringEvents binding.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Binding")>
<System.ComponentModel.DescriptionAttribute("Provides the settings that control the RecurringEvents binding.")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setRecurringEventsBinding")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property RecurringEventsBinding As WebSchedulerRecurringEventBinding
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerBinding
Dim value As WebSchedulerRecurringEventBinding

value = instance.RecurringEventsBinding
C#
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the RecurringEvents binding.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setRecurringEventsBinding")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public WebSchedulerRecurringEventBinding RecurringEventsBinding {get;}
Delphi
public read-only property RecurringEventsBinding: WebSchedulerRecurringEventBinding;
JScript
System.ComponentModel.CategoryAttribute("Binding")
System.ComponentModel.DescriptionAttribute("Provides the settings that control the RecurringEvents binding.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute("setRecurringEventsBinding")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get RecurringEventsBinding : WebSchedulerRecurringEventBinding
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the RecurringEvents binding.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setRecurringEventsBinding")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property WebSchedulerRecurringEventBinding* get_RecurringEventsBinding();
C++/CLI
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the RecurringEvents binding.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setRecurringEventsBinding")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property WebSchedulerRecurringEventBinding^ RecurringEventsBinding {
   WebSchedulerRecurringEventBinding^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerBinding Class
WebSchedulerBinding Members


ResourcesBinding Property

[image]
Intersoft WebScheduler Documentation
ResourcesBinding Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerBinding Class : ResourcesBinding Property

Glossary Item Box

Provides the settings that control the resources binding. Provides the settings that control the resources binding.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Binding")>
<System.ComponentModel.DescriptionAttribute("Provides the settings that control the resources binding.")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setResourcesBinding")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property ResourcesBinding As WebSchedulerResourcesBinding
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerBinding
Dim value As WebSchedulerResourcesBinding

value = instance.ResourcesBinding
C#
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the resources binding.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setResourcesBinding")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public WebSchedulerResourcesBinding ResourcesBinding {get;}
Delphi
public read-only property ResourcesBinding: WebSchedulerResourcesBinding;
JScript
System.ComponentModel.CategoryAttribute("Binding")
System.ComponentModel.DescriptionAttribute("Provides the settings that control the resources binding.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setResourcesBinding")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get ResourcesBinding : WebSchedulerResourcesBinding
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the resources binding.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setResourcesBinding")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property WebSchedulerResourcesBinding* get_ResourcesBinding();
C++/CLI
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the resources binding.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setResourcesBinding")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property WebSchedulerResourcesBinding^ ResourcesBinding {
   WebSchedulerResourcesBinding^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerBinding Class
WebSchedulerBinding Members


WebSchedulerCalendarSettings Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerCalendarSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerCalendarSettings Class

Glossary Item Box

A collection of WebSchedyler's calendar settings.

Object Model

WebSchedulerCalendarSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerCalendarSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCalendarSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerCalendarSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSchedulerCalendarSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerCalendarSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerCalendarSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerCalendarSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebScheduler.WebSchedulerCalendarSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCalendarSettings Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerCalendarSettings Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerCalendarSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerCalendarSettings Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerCalendarSettings.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerCalendarSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllowCollapse | Indicates whether the calendar can be collapsed. Indicates whether the calendar can be collapsed.
Public Property | CustomContainerID | Specifies calendar's custom container id. Specifies calendar's custom container id.
Public Property | DisplayCalendarCellTooltip | Indicates whether the calendar's tooltip is visible or not. Displays the calender cell tooltip.
Public Property | FirstDayOfWeek | Specifies the calendar's first day of week. Specifies the calendar's first day of week.
Public Property | FirstWeekOfYear | Specifies the calendar's first week of year. Specifies the calendar's first week of year.
Public Property | HideCalendarInitially | Indicates whether the calendar is visible initially. Indicates whether the calendar is visible initially.
Public Property | NumberOfMonthDisplayed | Sets or gets number of calendar displayed in WebScheduler. Sets or gets number of calendar displayed in WebScheduler.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerCalendarSettings Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerCalendarSettings Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerCalendarSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCalendarSettings Class : WebSchedulerCalendarSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerCalendarSettings()
C#
public WebSchedulerCalendarSettings()
Delphi
public WebSchedulerCalendarSettings();
JScript
public function WebSchedulerCalendarSettings();
Managed Extensions for C++
public: WebSchedulerCalendarSettings();
C++/CLI
public:
WebSchedulerCalendarSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCalendarSettings Class
WebSchedulerCalendarSettings Members


WebSchedulerCalendarSettings Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerCalendarSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerCalendarSettings Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerCalendarSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerCalendarSettings Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCalendarSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCalendarSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCalendarSettings Class
WebSchedulerCalendarSettings Members


WebSchedulerCalendarSettings Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerCalendarSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerCalendarSettings Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerCalendarSettings members.

Public Properties

 | Name | Description
Public Property | AllowCollapse | Indicates whether the calendar can be collapsed. Indicates whether the calendar can be collapsed.
Public Property | CustomContainerID | Specifies calendar's custom container id. Specifies calendar's custom container id.
Public Property | DisplayCalendarCellTooltip | Indicates whether the calendar's tooltip is visible or not. Displays the calender cell tooltip.
Public Property | FirstDayOfWeek | Specifies the calendar's first day of week. Specifies the calendar's first day of week.
Public Property | FirstWeekOfYear | Specifies the calendar's first week of year. Specifies the calendar's first week of year.
Public Property | HideCalendarInitially | Indicates whether the calendar is visible initially. Indicates whether the calendar is visible initially.
Public Property | NumberOfMonthDisplayed | Sets or gets number of calendar displayed in WebScheduler. Sets or gets number of calendar displayed in WebScheduler.
Top

See Also

Reference

WebSchedulerCalendarSettings Class
ISNet.WebUI.WebScheduler Namespace


AllowCollapse Property

[image]
Intersoft WebScheduler Documentation
AllowCollapse Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCalendarSettings Class : AllowCollapse Property

Glossary Item Box

Indicates whether the calendar can be collapsed. Indicates whether the calendar can be collapsed.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Indicates whether the calendar can be collapsed.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Calendar")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AllowCollapse As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCalendarSettings
Dim value As System.Boolean

instance.AllowCollapse = value

value = instance.AllowCollapse
C#
[System.ComponentModel.DescriptionAttribute("Indicates whether the calendar can be collapsed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Calendar")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool AllowCollapse {get; set;}
Delphi
public read-write property AllowCollapse: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Indicates whether the calendar can be collapsed.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Calendar")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set AllowCollapse : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Indicates whether the calendar can be collapsed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Calendar")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_AllowCollapse();
public: __property void set_AllowCollapse(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Indicates whether the calendar can be collapsed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Calendar")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool AllowCollapse {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCalendarSettings Class
WebSchedulerCalendarSettings Members


CustomContainerID Property

[image]
Intersoft WebScheduler Documentation
CustomContainerID Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCalendarSettings Class : CustomContainerID Property

Glossary Item Box

Specifies calendar's custom container id. Specifies calendar's custom container id.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies calendar's custom container id.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Calendar")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property CustomContainerID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCalendarSettings
Dim value As System.String

instance.CustomContainerID = value

value = instance.CustomContainerID
C#
[System.ComponentModel.DescriptionAttribute("Specifies calendar's custom container id.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Calendar")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string CustomContainerID {get; set;}
Delphi
public read-write property CustomContainerID: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies calendar's custom container id.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Calendar")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set CustomContainerID : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies calendar's custom container id.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Calendar")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_CustomContainerID();
public: __property void set_CustomContainerID(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies calendar's custom container id.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Calendar")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ CustomContainerID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCalendarSettings Class
WebSchedulerCalendarSettings Members


DisplayCalendarCellTooltip Property

[image]
Intersoft WebScheduler Documentation
DisplayCalendarCellTooltip Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCalendarSettings Class : DisplayCalendarCellTooltip Property

Glossary Item Box

Indicates whether the calendar's tooltip is visible or not. Displays the calender cell tooltip.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Indicates whether the calendar's tooltip is visible or not.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property DisplayCalendarCellTooltip As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCalendarSettings
Dim value As System.Boolean

instance.DisplayCalendarCellTooltip = value

value = instance.DisplayCalendarCellTooltip
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Indicates whether the calendar's tooltip is visible or not.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool DisplayCalendarCellTooltip {get; set;}
Delphi
public read-write property DisplayCalendarCellTooltip: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Indicates whether the calendar's tooltip is visible or not.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set DisplayCalendarCellTooltip : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Indicates whether the calendar's tooltip is visible or not.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_DisplayCalendarCellTooltip();
public: __property void set_DisplayCalendarCellTooltip(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Indicates whether the calendar's tooltip is visible or not.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool DisplayCalendarCellTooltip {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCalendarSettings Class
WebSchedulerCalendarSettings Members


FirstDayOfWeek Property

[image]
Intersoft WebScheduler Documentation
FirstDayOfWeek Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCalendarSettings Class : FirstDayOfWeek Property

Glossary Item Box

Specifies the calendar's first day of week. Specifies the calendar's first day of week.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the calendar's first day of week.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Calendar")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property FirstDayOfWeek As System.DayOfWeek
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCalendarSettings
Dim value As System.DayOfWeek

instance.FirstDayOfWeek = value

value = instance.FirstDayOfWeek
C#
[System.ComponentModel.DescriptionAttribute("Specifies the calendar's first day of week.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Calendar")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.DayOfWeek FirstDayOfWeek {get; set;}
Delphi
public read-write property FirstDayOfWeek: System.DayOfWeek;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the calendar's first day of week.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Calendar")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set FirstDayOfWeek : System.DayOfWeek
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the calendar's first day of week.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Calendar")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.DayOfWeek get_FirstDayOfWeek();
public: __property void set_FirstDayOfWeek(
   System.DayOfWeek value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the calendar's first day of week.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Calendar")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.DayOfWeek FirstDayOfWeek {
   System.DayOfWeek get();
   void set (    System.DayOfWeek value);
}

Property Value

The default value is Sunday.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCalendarSettings Class
WebSchedulerCalendarSettings Members


FirstWeekOfYear Property

[image]
Intersoft WebScheduler Documentation
FirstWeekOfYear Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCalendarSettings Class : FirstWeekOfYear Property

Glossary Item Box

Specifies the calendar's first week of year. Specifies the calendar's first week of year.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the calendar's first week of year.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Calendar")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property FirstWeekOfYear As WebSchedulerFirstWeekOfYear
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCalendarSettings
Dim value As WebSchedulerFirstWeekOfYear

instance.FirstWeekOfYear = value

value = instance.FirstWeekOfYear
C#
[System.ComponentModel.DescriptionAttribute("Specifies the calendar's first week of year.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Calendar")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public WebSchedulerFirstWeekOfYear FirstWeekOfYear {get; set;}
Delphi
public read-write property FirstWeekOfYear: WebSchedulerFirstWeekOfYear;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the calendar's first week of year.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Calendar")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set FirstWeekOfYear : WebSchedulerFirstWeekOfYear
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the calendar's first week of year.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Calendar")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebSchedulerFirstWeekOfYear get_FirstWeekOfYear();
public: __property void set_FirstWeekOfYear(
   WebSchedulerFirstWeekOfYear value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the calendar's first week of year.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Calendar")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebSchedulerFirstWeekOfYear FirstWeekOfYear {
   WebSchedulerFirstWeekOfYear get();
   void set (    WebSchedulerFirstWeekOfYear value);
}

Property Value

The default value is First4DayWeek.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCalendarSettings Class
WebSchedulerCalendarSettings Members


HideCalendarInitially Property

[image]
Intersoft WebScheduler Documentation
HideCalendarInitially Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCalendarSettings Class : HideCalendarInitially Property

Glossary Item Box

Indicates whether the calendar is visible initially. Indicates whether the calendar is visible initially.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Indicates whether the calendar is visible initially.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Calendar")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property HideCalendarInitially As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCalendarSettings
Dim value As System.Boolean

instance.HideCalendarInitially = value

value = instance.HideCalendarInitially
C#
[System.ComponentModel.DescriptionAttribute("Indicates whether the calendar is visible initially.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Calendar")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool HideCalendarInitially {get; set;}
Delphi
public read-write property HideCalendarInitially: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Indicates whether the calendar is visible initially.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Calendar")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set HideCalendarInitially : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Indicates whether the calendar is visible initially.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Calendar")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_HideCalendarInitially();
public: __property void set_HideCalendarInitially(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Indicates whether the calendar is visible initially.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Calendar")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool HideCalendarInitially {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCalendarSettings Class
WebSchedulerCalendarSettings Members


NumberOfMonthDisplayed Property

[image]
Intersoft WebScheduler Documentation
NumberOfMonthDisplayed Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCalendarSettings Class : NumberOfMonthDisplayed Property

Glossary Item Box

Sets or gets number of calendar displayed in WebScheduler. Sets or gets number of calendar displayed in WebScheduler.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Sets of gets number of calendar displayed in WebScheduler.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Calendar")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property NumberOfMonthDisplayed As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCalendarSettings
Dim value As System.Integer

instance.NumberOfMonthDisplayed = value

value = instance.NumberOfMonthDisplayed
C#
[System.ComponentModel.DescriptionAttribute("Sets of gets number of calendar displayed in WebScheduler.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Calendar")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.int NumberOfMonthDisplayed {get; set;}
Delphi
public read-write property NumberOfMonthDisplayed: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Sets of gets number of calendar displayed in WebScheduler.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Calendar")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set NumberOfMonthDisplayed : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Sets of gets number of calendar displayed in WebScheduler.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Calendar")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_NumberOfMonthDisplayed();
public: __property void set_NumberOfMonthDisplayed(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Sets of gets number of calendar displayed in WebScheduler.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Calendar")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int NumberOfMonthDisplayed {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 3.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCalendarSettings Class
WebSchedulerCalendarSettings Members


WebSchedulerCategoriesBinding Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerCategoriesBinding Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerCategoriesBinding Class

Glossary Item Box

A collection of settings used for WebScheduler's categories binding.

Object Model

WebSchedulerCategoriesBinding Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerCategoriesBinding
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoriesBinding
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerCategoriesBinding : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSchedulerCategoriesBinding = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerCategoriesBinding extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerCategoriesBinding : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerCategoriesBinding : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebScheduler.WebSchedulerCategoriesBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoriesBinding Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerCategoriesBinding Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerCategoriesBinding Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerCategoriesBinding Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerCategoriesBinding.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerCategoriesBinding Constructor |
Top

Public Properties

 | Name | Description
Public Property | CategoryColorField | Specifies the CategoryColor field. Specifies the CategoryColor field.
Public Property | CategoryIDField | Specifies the CategoryID field. Specifies the CategoryID field.
Public Property | CategoryNameField | Specifies the CategoryName field. Specifies the CategoryName field.
Public Property | DescriptionField | Specifies the Description field of Category. Specifies the Description field of Category.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerCategoriesBinding Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerCategoriesBinding Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerCategoriesBinding Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoriesBinding Class : WebSchedulerCategoriesBinding Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerCategoriesBinding()
C#
public WebSchedulerCategoriesBinding()
Delphi
public WebSchedulerCategoriesBinding();
JScript
public function WebSchedulerCategoriesBinding();
Managed Extensions for C++
public: WebSchedulerCategoriesBinding();
C++/CLI
public:
WebSchedulerCategoriesBinding();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoriesBinding Class
WebSchedulerCategoriesBinding Members


WebSchedulerCategoriesBinding Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerCategoriesBinding Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerCategoriesBinding Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerCategoriesBinding members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerCategoriesBinding Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoriesBinding Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoriesBinding
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoriesBinding Class
WebSchedulerCategoriesBinding Members


WebSchedulerCategoriesBinding Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerCategoriesBinding Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerCategoriesBinding Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerCategoriesBinding members.

Public Properties

 | Name | Description
Public Property | CategoryColorField | Specifies the CategoryColor field. Specifies the CategoryColor field.
Public Property | CategoryIDField | Specifies the CategoryID field. Specifies the CategoryID field.
Public Property | CategoryNameField | Specifies the CategoryName field. Specifies the CategoryName field.
Public Property | DescriptionField | Specifies the Description field of Category. Specifies the Description field of Category.
Top

See Also

Reference

WebSchedulerCategoriesBinding Class
ISNet.WebUI.WebScheduler Namespace


CategoryColorField Property

[image]
Intersoft WebScheduler Documentation
CategoryColorField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoriesBinding Class : CategoryColorField Property

Glossary Item Box

Specifies the CategoryColor field. Specifies the CategoryColor field.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.DescriptionAttribute("Specifies the CategoryColor field.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Binding")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property CategoryColorField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoriesBinding
Dim value As System.String

instance.CategoryColorField = value

value = instance.CategoryColorField
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DescriptionAttribute("Specifies the CategoryColor field.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string CategoryColorField {get; set;}
Delphi
public read-write property CategoryColorField: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.DescriptionAttribute("Specifies the CategoryColor field.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Binding")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set CategoryColorField : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DescriptionAttribute("Specifies the CategoryColor field.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_CategoryColorField();
public: __property void set_CategoryColorField(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DescriptionAttribute("Specifies the CategoryColor field.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ CategoryColorField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoriesBinding Class
WebSchedulerCategoriesBinding Members


CategoryIDField Property

[image]
Intersoft WebScheduler Documentation
CategoryIDField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoriesBinding Class : CategoryIDField Property

Glossary Item Box

Specifies the CategoryID field. Specifies the CategoryID field.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the CategoryID field.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.CategoryAttribute("Binding")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CategoryIDField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoriesBinding
Dim value As System.String

instance.CategoryIDField = value

value = instance.CategoryIDField
C#
[System.ComponentModel.DescriptionAttribute("Specifies the CategoryID field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CategoryIDField {get; set;}
Delphi
public read-write property CategoryIDField: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the CategoryID field.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.CategoryAttribute("Binding")
System.ComponentModel.DefaultValueAttribute()
public function get,set CategoryIDField : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the CategoryID field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CategoryIDField();
public: __property void set_CategoryIDField(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the CategoryID field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CategoryIDField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoriesBinding Class
WebSchedulerCategoriesBinding Members


CategoryNameField Property

[image]
Intersoft WebScheduler Documentation
CategoryNameField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoriesBinding Class : CategoryNameField Property

Glossary Item Box

Specifies the CategoryName field. Specifies the CategoryName field.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Binding")>
<System.ComponentModel.DescriptionAttribute("Specifies the CategoryName field.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property CategoryNameField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoriesBinding
Dim value As System.String

instance.CategoryNameField = value

value = instance.CategoryNameField
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Specifies the CategoryName field.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string CategoryNameField {get; set;}
Delphi
public read-write property CategoryNameField: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Binding")
System.ComponentModel.DescriptionAttribute("Specifies the CategoryName field.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set CategoryNameField : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Specifies the CategoryName field.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_CategoryNameField();
public: __property void set_CategoryNameField(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Specifies the CategoryName field.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ CategoryNameField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoriesBinding Class
WebSchedulerCategoriesBinding Members


DescriptionField Property

[image]
Intersoft WebScheduler Documentation
DescriptionField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoriesBinding Class : DescriptionField Property

Glossary Item Box

Specifies the Description field of Category. Specifies the Description field of Category.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the Description field of Category.")>
<System.ComponentModel.CategoryAttribute("Binding")>
Public Property DescriptionField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoriesBinding
Dim value As System.String

instance.DescriptionField = value

value = instance.DescriptionField
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the Description field of Category.")]
[System.ComponentModel.CategoryAttribute("Binding")]
public System.string DescriptionField {get; set;}
Delphi
public read-write property DescriptionField: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the Description field of Category.")
System.ComponentModel.CategoryAttribute("Binding")
public function get,set DescriptionField : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the Description field of Category.")]
[System.ComponentModel.CategoryAttribute("Binding")]
public: __property System.string* get_DescriptionField();
public: __property void set_DescriptionField(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the Description field of Category.")]
[System.ComponentModel.CategoryAttribute("Binding")]
public:
property System.String^ DescriptionField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoriesBinding Class
WebSchedulerCategoriesBinding Members


WebSchedulerCategory Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerCategory Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerCategory Class

Glossary Item Box

A collection of members in WebScheduler's category.

Object Model

WebSchedulerCategory Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerCategory
   Inherits ISNet.WebUI.NamedObjectBase2
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategory
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerCategory : ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Delphi
public class WebSchedulerCategory = class(ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerCategory extends ISNet.WebUI.NamedObjectBase2 implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerCategory : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerCategory : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase2
ISNet.WebUI.WebScheduler.WebSchedulerCategory

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategory Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerCategory Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerCategory Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerCategory Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerCategory.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerCategory Constructor |
Top

Public Properties

 | Name | Description
Public Property | CategoryColor | Specifies the color of the category. Specifies the CategoryColor.
Public Property | CategoryID | Specifies the CategoryID. Specifies the CategoryID.
Public Property | CategoryName | Specifies the CategoryName. Specifies the CategoryName.
Public Property | Collection |
Public Property | Description | Specifies the Description of the category. Specifies the Description.
Public Property | Name | Overridden.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerCategory Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerCategory Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerCategory Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategory Class : WebSchedulerCategory Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerCategory()
C#
public WebSchedulerCategory()
Delphi
public WebSchedulerCategory();
JScript
public function WebSchedulerCategory();
Managed Extensions for C++
public: WebSchedulerCategory();
C++/CLI
public:
WebSchedulerCategory();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategory Class
WebSchedulerCategory Members


WebSchedulerCategory Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerCategory Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerCategory Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerCategory members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerCategory Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategory Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategory
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategory Class
WebSchedulerCategory Members


WebSchedulerCategory Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerCategory Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerCategory Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerCategory members.

Public Properties

 | Name | Description
Public Property | CategoryColor | Specifies the color of the category. Specifies the CategoryColor.
Public Property | CategoryID | Specifies the CategoryID. Specifies the CategoryID.
Public Property | CategoryName | Specifies the CategoryName. Specifies the CategoryName.
Public Property | Collection |
Public Property | Description | Specifies the Description of the category. Specifies the Description.
Public Property | Name | Overridden.
Top

See Also

Reference

WebSchedulerCategory Class
ISNet.WebUI.WebScheduler Namespace


CategoryColor Property

[image]
Intersoft WebScheduler Documentation
CategoryColor Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategory Class : CategoryColor Property

Glossary Item Box

Specifies the color of the category. Specifies the CategoryColor.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Category")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the color of the category.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("ISNet.WebUI.WebScheduler.ISColorConverter, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property CategoryColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategory
Dim value As System.Drawing.Color

instance.CategoryColor = value

value = instance.CategoryColor
C#
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Category")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the color of the category.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("ISNet.WebUI.WebScheduler.ISColorConverter, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.Drawing.Color CategoryColor {get; set;}
Delphi
public read-write property CategoryColor: System.Drawing.Color;
JScript
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Category")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the color of the category.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("ISNet.WebUI.WebScheduler.ISColorConverter, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set CategoryColor : System.Drawing.Color
Managed Extensions for C++
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Category")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the color of the category.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("ISNet.WebUI.WebScheduler.ISColorConverter, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.Drawing.Color get_CategoryColor();
public: __property void set_CategoryColor(
   System.Drawing.Color value
);
C++/CLI
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Category")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the color of the category.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("ISNet.WebUI.WebScheduler.ISColorConverter, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.Drawing.Color CategoryColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategory Class
WebSchedulerCategory Members


CategoryID Property

[image]
Intersoft WebScheduler Documentation
CategoryID Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategory Class : CategoryID Property

Glossary Item Box

Specifies the CategoryID. Specifies the CategoryID.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the CategoryID.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
<System.ComponentModel.CategoryAttribute("Category")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CategoryID As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategory
Dim value As System.Integer

instance.CategoryID = value

value = instance.CategoryID
C#
[System.ComponentModel.DescriptionAttribute("Specifies the CategoryID.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.CategoryAttribute("Category")]
[System.ComponentModel.DefaultValueAttribute()]
public System.int CategoryID {get; set;}
Delphi
public read-write property CategoryID: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the CategoryID.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
System.ComponentModel.CategoryAttribute("Category")
System.ComponentModel.DefaultValueAttribute()
public function get,set CategoryID : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the CategoryID.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.CategoryAttribute("Category")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_CategoryID();
public: __property void set_CategoryID(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the CategoryID.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.CategoryAttribute("Category")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int CategoryID {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategory Class
WebSchedulerCategory Members


CategoryName Property

[image]
Intersoft WebScheduler Documentation
CategoryName Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategory Class : CategoryName Property

Glossary Item Box

Specifies the CategoryName. Specifies the CategoryName.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the CategoryName.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Category")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CategoryName As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategory
Dim value As System.String

instance.CategoryName = value

value = instance.CategoryName
C#
[System.ComponentModel.DescriptionAttribute("Specifies the CategoryName.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Category")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CategoryName {get; set;}
Delphi
public read-write property CategoryName: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the CategoryName.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Category")
System.ComponentModel.DefaultValueAttribute()
public function get,set CategoryName : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the CategoryName.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Category")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CategoryName();
public: __property void set_CategoryName(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the CategoryName.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Category")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CategoryName {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategory Class
WebSchedulerCategory Members


Collection Property

[image]
Intersoft WebScheduler Documentation
Collection Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategory Class : Collection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.JsonSerialization.ScriptIgnoreAttribute()>
Public Shadows Property Collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategory
Dim value As ISNet.WebUI.ISCollectionBase(Of INamedObject2)

instance.Collection = value

value = instance.Collection
C#
[ISNet.Serialization.JsonSerialization.ScriptIgnoreAttribute()]
public new ISNet.WebUI.ISCollectionBase<INamedObject2> Collection {get; set;}
Delphi
public read-write property Collection: ISNet.WebUI.ISCollectionBase;
JScript
ISNet.Serialization.JsonSerialization.ScriptIgnoreAttribute()
public hide function get,set Collection : ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[ISNet.Serialization.JsonSerialization.ScriptIgnoreAttribute()]
public: __property new ISNet.WebUI.ISCollectionBase<INamedObject2*>* get_Collection();
public: __property new void set_Collection(
   ISNet.WebUI.ISCollectionBase<INamedObject2*>* value
);
C++/CLI
[ISNet.Serialization.JsonSerialization.ScriptIgnoreAttribute()]
public:
new property ISNet.WebUI.ISCollectionBase<INamedObject2^>^ Collection {
   ISNet.WebUI.ISCollectionBase<INamedObject2^>^ get();
   void set (    ISNet.WebUI.ISCollectionBase<INamedObject2^>^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategory Class
WebSchedulerCategory Members


Description Property

[image]
Intersoft WebScheduler Documentation
Description Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategory Class : Description Property

Glossary Item Box

Specifies the Description of the category. Specifies the Description.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Category")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the Description of the category.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Description As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategory
Dim value As System.String

instance.Description = value

value = instance.Description
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Category")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the Description of the category.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string Description {get; set;}
Delphi
public read-write property Description: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Category")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the Description of the category.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Description : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Category")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the Description of the category.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_Description();
public: __property void set_Description(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Category")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the Description of the category.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ Description {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategory Class
WebSchedulerCategory Members


Name Property

[image]
Intersoft WebScheduler Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategory Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
Public Overrides Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategory
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public override System.string Name {get; set;}
Delphi
public read-write property Name: System.String; override;
JScript
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
public override function get,set Name : System.String
Managed Extensions for C++
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public: __property System.string* get_Name() override;
public: __property void set_Name(
   System.string* value
) override;
C++/CLI
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public:
property System.String^ Name {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategory Class
WebSchedulerCategory Members


WebSchedulerCategoryCollection Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerCategoryCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerCategoryCollection Class

Glossary Item Box

A collection of settings used for WebScheduler's category.

Object Model

WebSchedulerCategoryCollection Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerCategoryCollection
   Inherits ISNet.WebUI.ISGenericCollectionBase(Of WebSchedulerCategory)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoryCollection
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerCategoryCollection : ISNet.WebUI.ISGenericCollectionBase<WebSchedulerCategory>
Delphi
public class WebSchedulerCategoryCollection = class(ISNet.WebUI.ISGenericCollectionBase)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerCategoryCollection extends ISNet.WebUI.ISGenericCollectionBase
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerCategoryCollection : public ISNet.WebUI.ISGenericCollectionBase<WebSchedulerCategory>
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerCategoryCollection : public ISNet.WebUI.ISGenericCollectionBase<WebSchedulerCategory>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
ISNet.WebUI.ISCollectionBase<T>
ISNet.WebUI.ISGenericCollectionBase<T>
ISNet.WebUI.WebScheduler.WebSchedulerCategoryCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoryCollection Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerCategoryCollection Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerCategoryCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerCategoryCollection Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerCategoryCollection.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerCategoryCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerCategory>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerCategory>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerCategory>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebSchedulerCategoryCollection Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerCategoryCollection Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerCategoryCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoryCollection Class : WebSchedulerCategoryCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerCategoryCollection()
C#
public WebSchedulerCategoryCollection()
Delphi
public WebSchedulerCategoryCollection();
JScript
public function WebSchedulerCategoryCollection();
Managed Extensions for C++
public: WebSchedulerCategoryCollection();
C++/CLI
public:
WebSchedulerCategoryCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoryCollection Class
WebSchedulerCategoryCollection Members


WebSchedulerClientSideEvents Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerClientSideEvents Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerClientSideEvents Class

Glossary Item Box

A collection of WebScheduler's client side events.

Object Model

WebSchedulerClientSideEvents Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerClientSideEvents
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerClientSideEvents : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSchedulerClientSideEvents = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerClientSideEvents extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerClientSideEvents : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerClientSideEvents : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebScheduler.WebSchedulerClientSideEvents

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerClientSideEvents Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerClientSideEvents Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerClientSideEvents Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerClientSideEvents.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerClientSideEvents Constructor |
Top

Public Properties

 | Name | Description
Public Property | OnAfterAdd | Gets or sets the event handler when insert is completed. Gets or sets the event handler when insert is completed.
Public Property | OnAfterDelete | Gets or sets the event handler after delete is completed. Gets or sets the event handler when delete is completed.
Public Property | OnAfterEdit | Gets or sets the event handler after update is completed. Gets or sets the event handler when update is completed.
Public Property | OnAfterRenderCalendar | Gets or sets the event handler after render calendar is completed. Gets or sets the event handler when calendar rendereing is completed.
Public Property | OnAfterRenderView | Gets or sets the event handler after render view is completed. Gets or sets the event handler when calendar viewing is completed.
Public Property | OnAfterTimelineViewSwitch | Gets or sets the event handler after Timeline view switch.
Public Property | OnAfterViewSwitched | Gets or sets the event handler after scheduler view switch action.
Public Property | OnBackNavigation | Gets or sets the event handler when back navigation action, in scheduler view and calendar, is about to be performed.
Public Property | OnBeforeAdd | Gets or sets the event handler before insert is executed. Gets or sets the event handler before update is executed.
Public Property | OnBeforeDelete | Gets or sets the event handler when delete is executed. Gets or sets the event handler when delete is executed.
Public Property | OnBeforeEdit | Gets or sets the event handler when update is executed. Gets or sets the event handler when update is executed.
Public Property | OnBeforeRequest | Gets or sets the event handler before request is posted. Gets or sets the event handler before request is posted.
Public Property | OnBeforeTimelineViewSwitch | Gets or sets the event handler before Timeline view switch.
Public Property | OnBeforeViewSwitched | Gets or sets the event handler before scheduler view switch action.
Public Property | OnCalendarCellClicked | Gets or sets the event handler when calendar cell is clicked.
Public Property | OnCallOutClose | Gets or sets the event handler when WebScheduler CallOut is closed. Gets or sets the event handler when WebScheduler callout is closed.
Public Property | OnCallOutInitialize | Gets or sets the event handler when initialize WebScheduler CallOut. Gets or sets the event handler when initialize WebScheduler callout.
Public Property | OnCallOutShow | Gets or sets the event handler when WebScheduler CallOut is shown. Gets or sets the event handler when WebScheduler callout is shown.
Public Property | OnCellDoubleClicked | Gets or sets the event handler when a cell is double clicked.
Public Property | OnCellSelected | Gets or sets the event handler when a cell is selected.
Public Property | OnConfirmationFormShow | Gets or sets the event handler when the editing form is being shown.
Public Property | OnContextMenu | Gets or sets the event handler when the context menu is about to be displayed. Gets or sets the event handler when the the context menu is being shown.
Public Property | OnEditingFormCancel | Gets or sets the event handler when the cancel button in editing form is clicked. Gets or sets the event handler when the cancel button in editing form is clicked.
Public Property | OnEditingFormClose | Gets or sets the event handler when the editing form is being closed. Gets or sets the event handler when the editing form is being closed.
Public Property | OnEditingFormInitialize | Gets or sets the event handler when the editing form is being initialized. Gets or sets the event handler when the editing form is being initialized.
Public Property | OnEditingFormSave | Gets or sets the event handler when the save button in editing form is clicked. Gets or sets the event handler when the save button in editing form is clicked.
Public Property | OnEditingFormShow | Gets or sets the event handler when the editing form is being shown. Gets or sets the event handler when the editing form is being shown.
Public Property | OnEventBound | Gets or sets the event handler when Event is bound. Gets or sets the event handler when Event is bound.
Public Property | OnEventDoubleClicked | Gets or sets the event handler when an event is double clicked.
Public Property | OnEventSelected | Gets or sets the event handler when an event is selected.
Public Property | OnForwardNavigation | Gets or sets the event handler when forward navigation action, in scheduler view and calendar, is about to be performed.
Public Property | OnInitialize | Gets or sets the event handler when WebScheduler is initialized.
Public Property | OnMultipleCellSelected | Gets or sets the event handler when multiple dates are selected.
Public Property | OnResourceClicked | Gets or sets the event handler when resource checkbox is clicked.
Public Property | OnResponse | Gets or sets the event handler on response. Gets or sets the event handler on response.
Public Property | OnResponseError | Gets or sets the event handler that will be invoked when the callback action returns error response..
Public Property | OnTimelineCustomResource | Gets or sets the event handler on Timeline's Custom Resource. Gets or sets the event handler when the custom resources is being implemented in Timeline.
Public Property | OnValidateDisabledTime | Gets or sets the event handler to validate DisabledTime manually. Validation should return true or false. True if the the range of time inside DisabledTime range, and False if the range of time outside DisabledTime range.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerClientSideEvents Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerClientSideEvents Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerClientSideEvents Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : WebSchedulerClientSideEvents Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerClientSideEvents()
C#
public WebSchedulerClientSideEvents()
Delphi
public WebSchedulerClientSideEvents();
JScript
public function WebSchedulerClientSideEvents();
Managed Extensions for C++
public: WebSchedulerClientSideEvents();
C++/CLI
public:
WebSchedulerClientSideEvents();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


WebSchedulerClientSideEvents Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerClientSideEvents Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerClientSideEvents members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerClientSideEvents Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


WebSchedulerClientSideEvents Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerClientSideEvents Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerClientSideEvents members.

Public Properties

 | Name | Description
Public Property | OnAfterAdd | Gets or sets the event handler when insert is completed. Gets or sets the event handler when insert is completed.
Public Property | OnAfterDelete | Gets or sets the event handler after delete is completed. Gets or sets the event handler when delete is completed.
Public Property | OnAfterEdit | Gets or sets the event handler after update is completed. Gets or sets the event handler when update is completed.
Public Property | OnAfterRenderCalendar | Gets or sets the event handler after render calendar is completed. Gets or sets the event handler when calendar rendereing is completed.
Public Property | OnAfterRenderView | Gets or sets the event handler after render view is completed. Gets or sets the event handler when calendar viewing is completed.
Public Property | OnAfterTimelineViewSwitch | Gets or sets the event handler after Timeline view switch.
Public Property | OnAfterViewSwitched | Gets or sets the event handler after scheduler view switch action.
Public Property | OnBackNavigation | Gets or sets the event handler when back navigation action, in scheduler view and calendar, is about to be performed.
Public Property | OnBeforeAdd | Gets or sets the event handler before insert is executed. Gets or sets the event handler before update is executed.
Public Property | OnBeforeDelete | Gets or sets the event handler when delete is executed. Gets or sets the event handler when delete is executed.
Public Property | OnBeforeEdit | Gets or sets the event handler when update is executed. Gets or sets the event handler when update is executed.
Public Property | OnBeforeRequest | Gets or sets the event handler before request is posted. Gets or sets the event handler before request is posted.
Public Property | OnBeforeTimelineViewSwitch | Gets or sets the event handler before Timeline view switch.
Public Property | OnBeforeViewSwitched | Gets or sets the event handler before scheduler view switch action.
Public Property | OnCalendarCellClicked | Gets or sets the event handler when calendar cell is clicked.
Public Property | OnCallOutClose | Gets or sets the event handler when WebScheduler CallOut is closed. Gets or sets the event handler when WebScheduler callout is closed.
Public Property | OnCallOutInitialize | Gets or sets the event handler when initialize WebScheduler CallOut. Gets or sets the event handler when initialize WebScheduler callout.
Public Property | OnCallOutShow | Gets or sets the event handler when WebScheduler CallOut is shown. Gets or sets the event handler when WebScheduler callout is shown.
Public Property | OnCellDoubleClicked | Gets or sets the event handler when a cell is double clicked.
Public Property | OnCellSelected | Gets or sets the event handler when a cell is selected.
Public Property | OnConfirmationFormShow | Gets or sets the event handler when the editing form is being shown.
Public Property | OnContextMenu | Gets or sets the event handler when the context menu is about to be displayed. Gets or sets the event handler when the the context menu is being shown.
Public Property | OnEditingFormCancel | Gets or sets the event handler when the cancel button in editing form is clicked. Gets or sets the event handler when the cancel button in editing form is clicked.
Public Property | OnEditingFormClose | Gets or sets the event handler when the editing form is being closed. Gets or sets the event handler when the editing form is being closed.
Public Property | OnEditingFormInitialize | Gets or sets the event handler when the editing form is being initialized. Gets or sets the event handler when the editing form is being initialized.
Public Property | OnEditingFormSave | Gets or sets the event handler when the save button in editing form is clicked. Gets or sets the event handler when the save button in editing form is clicked.
Public Property | OnEditingFormShow | Gets or sets the event handler when the editing form is being shown. Gets or sets the event handler when the editing form is being shown.
Public Property | OnEventBound | Gets or sets the event handler when Event is bound. Gets or sets the event handler when Event is bound.
Public Property | OnEventDoubleClicked | Gets or sets the event handler when an event is double clicked.
Public Property | OnEventSelected | Gets or sets the event handler when an event is selected.
Public Property | OnForwardNavigation | Gets or sets the event handler when forward navigation action, in scheduler view and calendar, is about to be performed.
Public Property | OnInitialize | Gets or sets the event handler when WebScheduler is initialized.
Public Property | OnMultipleCellSelected | Gets or sets the event handler when multiple dates are selected.
Public Property | OnResourceClicked | Gets or sets the event handler when resource checkbox is clicked.
Public Property | OnResponse | Gets or sets the event handler on response. Gets or sets the event handler on response.
Public Property | OnResponseError | Gets or sets the event handler that will be invoked when the callback action returns error response..
Public Property | OnTimelineCustomResource | Gets or sets the event handler on Timeline's Custom Resource. Gets or sets the event handler when the custom resources is being implemented in Timeline.
Public Property | OnValidateDisabledTime | Gets or sets the event handler to validate DisabledTime manually. Validation should return true or false. True if the the range of time inside DisabledTime range, and False if the range of time outside DisabledTime range.
Top

See Also

Reference

WebSchedulerClientSideEvents Class
ISNet.WebUI.WebScheduler Namespace


OnAfterAdd Property

[image]
Intersoft WebScheduler Documentation
OnAfterAdd Property
See Also Example Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnAfterAdd Property

Glossary Item Box

Gets or sets the event handler when insert is completed. Gets or sets the event handler when insert is completed.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, evt")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when insert is completed.")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnAfterAdd As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnAfterAdd = value

value = instance.OnAfterAdd
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, evt")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when insert is completed.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnAfterAdd {get; set;}
Delphi
public read-write property OnAfterAdd: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, evt")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when insert is completed.")
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DefaultValueAttribute()
public function get,set OnAfterAdd : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, evt")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when insert is completed.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnAfterAdd();
public: __property void set_OnAfterAdd(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, evt")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when insert is completed.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnAfterAdd {
   System.String^ get();
   void set (    System.String^ value);
}

Remarks

controlID
The ID of the WebScheduler calling the function.

evt
The event which has been added.

Example

The following is the example of the javascript function that is assigned in above event.
JScript Copy Code
function WebScheduler1_OnAfterAdd(controlId, evt)
{
    var WebScheduler1 = ISGetObject(controlId);

    return true;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnAfterDelete Property

[image]
Intersoft WebScheduler Documentation
OnAfterDelete Property
See Also Example Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnAfterDelete Property

Glossary Item Box

Gets or sets the event handler after delete is completed. Gets or sets the event handler when delete is completed.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, evt")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after delete is completed.")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnAfterDelete As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnAfterDelete = value

value = instance.OnAfterDelete
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, evt")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after delete is completed.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnAfterDelete {get; set;}
Delphi
public read-write property OnAfterDelete: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, evt")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after delete is completed.")
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DefaultValueAttribute()
public function get,set OnAfterDelete : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, evt")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after delete is completed.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnAfterDelete();
public: __property void set_OnAfterDelete(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, evt")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after delete is completed.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnAfterDelete {
   System.String^ get();
   void set (    System.String^ value);
}

Remarks

controlID
The ID of the WebScheduler calling the function.

evt
The event which has been deleted.

Example

The following is the example of the javascript function that is assigned in above event.
JScript Copy Code
function WebScheduler1_OnAfterDelete(controlId, evt)
{
    var WebScheduler1 = ISGetObject(controlId);

    return true;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnAfterEdit Property

[image]
Intersoft WebScheduler Documentation
OnAfterEdit Property
See Also Example Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnAfterEdit Property

Glossary Item Box

Gets or sets the event handler after update is completed. Gets or sets the event handler when update is completed.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after update is completed.")>
<ISNet.EventParameterAttribute("controlId, evt")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnAfterEdit As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnAfterEdit = value

value = instance.OnAfterEdit
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after update is completed.")]
[ISNet.EventParameterAttribute("controlId, evt")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnAfterEdit {get; set;}
Delphi
public read-write property OnAfterEdit: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after update is completed.")
ISNet.EventParameterAttribute("controlId, evt")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DefaultValueAttribute()
public function get,set OnAfterEdit : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after update is completed.")]
[ISNet.EventParameterAttribute("controlId, evt")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnAfterEdit();
public: __property void set_OnAfterEdit(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after update is completed.")]
[ISNet.EventParameterAttribute("controlId, evt")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnAfterEdit {
   System.String^ get();
   void set (    System.String^ value);
}

Remarks

controlID
The ID of the WebScheduler calling the function.

evt
The event which has been modified.

Example

The following is the example of the javascript function that is assigned in above event.
JScript Copy Code
function WebScheduler1_OnAfterEdit(controlId, evt)
{
    var WebScheduler1 = ISGetObject(controlId);

    return true;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnAfterRenderCalendar Property

[image]
Intersoft WebScheduler Documentation
OnAfterRenderCalendar Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnAfterRenderCalendar Property

Glossary Item Box

Gets or sets the event handler after render calendar is completed. Gets or sets the event handler when calendar rendereing is completed.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after render view is completed.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.EventParameterAttribute("controlId, calendarType")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnAfterRenderCalendar As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnAfterRenderCalendar = value

value = instance.OnAfterRenderCalendar
C#
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after render view is completed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, calendarType")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnAfterRenderCalendar {get; set;}
Delphi
public read-write property OnAfterRenderCalendar: System.String;
JScript
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after render view is completed.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.EventParameterAttribute("controlId, calendarType")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnAfterRenderCalendar : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after render view is completed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, calendarType")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnAfterRenderCalendar();
public: __property void set_OnAfterRenderCalendar(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after render view is completed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, calendarType")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnAfterRenderCalendar {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnAfterRenderView Property

[image]
Intersoft WebScheduler Documentation
OnAfterRenderView Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnAfterRenderView Property

Glossary Item Box

Gets or sets the event handler after render view is completed. Gets or sets the event handler when calendar viewing is completed.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after render view is completed.")>
<ISNet.EventParameterAttribute("controlId, viewMode")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OnAfterRenderView As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnAfterRenderView = value

value = instance.OnAfterRenderView
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after render view is completed.")]
[ISNet.EventParameterAttribute("controlId, viewMode")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string OnAfterRenderView {get; set;}
Delphi
public read-write property OnAfterRenderView: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after render view is completed.")
ISNet.EventParameterAttribute("controlId, viewMode")
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OnAfterRenderView : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after render view is completed.")]
[ISNet.EventParameterAttribute("controlId, viewMode")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_OnAfterRenderView();
public: __property void set_OnAfterRenderView(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after render view is completed.")]
[ISNet.EventParameterAttribute("controlId, viewMode")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ OnAfterRenderView {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnAfterTimelineViewSwitch Property

[image]
Intersoft WebScheduler Documentation
OnAfterTimelineViewSwitch Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnAfterTimelineViewSwitch Property

Glossary Item Box

Gets or sets the event handler after Timeline view switch.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after Timeline view switch.")>
<ISNet.EventParameterAttribute("controlId, action")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OnAfterTimelineViewSwitch As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnAfterTimelineViewSwitch = value

value = instance.OnAfterTimelineViewSwitch
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after Timeline view switch.")]
[ISNet.EventParameterAttribute("controlId, action")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string OnAfterTimelineViewSwitch {get; set;}
Delphi
public read-write property OnAfterTimelineViewSwitch: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after Timeline view switch.")
ISNet.EventParameterAttribute("controlId, action")
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OnAfterTimelineViewSwitch : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after Timeline view switch.")]
[ISNet.EventParameterAttribute("controlId, action")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_OnAfterTimelineViewSwitch();
public: __property void set_OnAfterTimelineViewSwitch(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after Timeline view switch.")]
[ISNet.EventParameterAttribute("controlId, action")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ OnAfterTimelineViewSwitch {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnAfterViewSwitched Property

[image]
Intersoft WebScheduler Documentation
OnAfterViewSwitched Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnAfterViewSwitched Property

Glossary Item Box

Gets or sets the event handler after scheduler view switch action.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after scheduler view switch action.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.EventParameterAttribute("controlId, previousViewMode, nextViewMode")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
Public Property OnAfterViewSwitched As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnAfterViewSwitched = value

value = instance.OnAfterViewSwitched
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after scheduler view switch action.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, previousViewMode, nextViewMode")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public System.string OnAfterViewSwitched {get; set;}
Delphi
public read-write property OnAfterViewSwitched: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after scheduler view switch action.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.EventParameterAttribute("controlId, previousViewMode, nextViewMode")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
public function get,set OnAfterViewSwitched : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after scheduler view switch action.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, previousViewMode, nextViewMode")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public: __property System.string* get_OnAfterViewSwitched();
public: __property void set_OnAfterViewSwitched(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after scheduler view switch action.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, previousViewMode, nextViewMode")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public:
property System.String^ OnAfterViewSwitched {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnBackNavigation Property

[image]
Intersoft WebScheduler Documentation
OnBackNavigation Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnBackNavigation Property

Glossary Item Box

Gets or sets the event handler when back navigation action, in scheduler view and calendar, is about to be performed.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler back navigation action, in scheduler view and calendar, is about to be performed.")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId, viewMode, previousDate, nextDate, isCalendarNavigation")>
Public Property OnBackNavigation As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnBackNavigation = value

value = instance.OnBackNavigation
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler back navigation action, in scheduler view and calendar, is about to be performed.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, viewMode, previousDate, nextDate, isCalendarNavigation")]
public System.string OnBackNavigation {get; set;}
Delphi
public read-write property OnBackNavigation: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler back navigation action, in scheduler view and calendar, is about to be performed.")
System.ComponentModel.CategoryAttribute("Client Side Events")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId, viewMode, previousDate, nextDate, isCalendarNavigation")
public function get,set OnBackNavigation : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler back navigation action, in scheduler view and calendar, is about to be performed.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, viewMode, previousDate, nextDate, isCalendarNavigation")]
public: __property System.string* get_OnBackNavigation();
public: __property void set_OnBackNavigation(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler back navigation action, in scheduler view and calendar, is about to be performed.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, viewMode, previousDate, nextDate, isCalendarNavigation")]
public:
property System.String^ OnBackNavigation {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnBeforeAdd Property

[image]
Intersoft WebScheduler Documentation
OnBeforeAdd Property
See Also Example Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnBeforeAdd Property

Glossary Item Box

Gets or sets the event handler before insert is executed. Gets or sets the event handler before update is executed.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before insert is executed.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<ISNet.EventParameterAttribute("controlId, evt")>
Public Property OnBeforeAdd As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnBeforeAdd = value

value = instance.OnBeforeAdd
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before insert is executed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId, evt")]
public System.string OnBeforeAdd {get; set;}
Delphi
public read-write property OnBeforeAdd: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before insert is executed.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
ISNet.EventParameterAttribute("controlId, evt")
public function get,set OnBeforeAdd : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before insert is executed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId, evt")]
public: __property System.string* get_OnBeforeAdd();
public: __property void set_OnBeforeAdd(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before insert is executed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId, evt")]
public:
property System.String^ OnBeforeAdd {
   System.String^ get();
   void set (    System.String^ value);
}

Remarks

controlID
The ID of the WebScheduler calling the function.

evt
The event before it is being added.

Example

The following is the example of the javascript function that is assigned in above event.
JScript Copy Code
function WebScheduler1_OnBeforeAdd(controlId, evt)
{
    var WebScheduler1 = ISGetObject(controlId);

    return true;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnBeforeDelete Property

[image]
Intersoft WebScheduler Documentation
OnBeforeDelete Property
See Also Example Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnBeforeDelete Property

Glossary Item Box

Gets or sets the event handler when delete is executed. Gets or sets the event handler when delete is executed.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when delete is executed.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.EventParameterAttribute("controlId, evt")>
Public Property OnBeforeDelete As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnBeforeDelete = value

value = instance.OnBeforeDelete
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when delete is executed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, evt")]
public System.string OnBeforeDelete {get; set;}
Delphi
public read-write property OnBeforeDelete: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when delete is executed.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DefaultValueAttribute()
ISNet.EventParameterAttribute("controlId, evt")
public function get,set OnBeforeDelete : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when delete is executed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, evt")]
public: __property System.string* get_OnBeforeDelete();
public: __property void set_OnBeforeDelete(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when delete is executed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, evt")]
public:
property System.String^ OnBeforeDelete {
   System.String^ get();
   void set (    System.String^ value);
}

Remarks

controlID
The ID of the WebScheduler calling the function.

evt
The event before it is being deleted.

Example

The following is the example of the javascript function that is assigned in above event.
JScript Copy Code
function WebScheduler1_OnBeforeDelete(controlId, evt)
{
    var WebScheduler1 = ISGetObject(controlId);

    return true;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnBeforeEdit Property

[image]
Intersoft WebScheduler Documentation
OnBeforeEdit Property
See Also Example Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnBeforeEdit Property

Glossary Item Box

Gets or sets the event handler when update is executed. Gets or sets the event handler when update is executed.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when update is executed.")>
<ISNet.EventParameterAttribute("controlId, evt")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnBeforeEdit As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnBeforeEdit = value

value = instance.OnBeforeEdit
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when update is executed.")]
[ISNet.EventParameterAttribute("controlId, evt")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnBeforeEdit {get; set;}
Delphi
public read-write property OnBeforeEdit: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when update is executed.")
ISNet.EventParameterAttribute("controlId, evt")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DefaultValueAttribute()
public function get,set OnBeforeEdit : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when update is executed.")]
[ISNet.EventParameterAttribute("controlId, evt")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnBeforeEdit();
public: __property void set_OnBeforeEdit(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when update is executed.")]
[ISNet.EventParameterAttribute("controlId, evt")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnBeforeEdit {
   System.String^ get();
   void set (    System.String^ value);
}

Remarks

controlID
The ID of the WebScheduler calling the function.

evt
The event before it is being modified.

Example

The following is the example of the javascript function that is assigned in above event.
JScript Copy Code
function WebScheduler1_OnBeforeEdit(controlId, evt)
{
    var WebScheduler1 = ISGetObject(controlId);

    return true;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnBeforeRequest Property

[image]
Intersoft WebScheduler Documentation
OnBeforeRequest Property
See Also Example Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnBeforeRequest Property

Glossary Item Box

Gets or sets the event handler before request is posted. Gets or sets the event handler before request is posted.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before request is posted.")>
<ISNet.EventParameterAttribute("controlId, action")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnBeforeRequest As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnBeforeRequest = value

value = instance.OnBeforeRequest
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before request is posted.")]
[ISNet.EventParameterAttribute("controlId, action")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnBeforeRequest {get; set;}
Delphi
public read-write property OnBeforeRequest: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before request is posted.")
ISNet.EventParameterAttribute("controlId, action")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DefaultValueAttribute()
public function get,set OnBeforeRequest : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before request is posted.")]
[ISNet.EventParameterAttribute("controlId, action")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnBeforeRequest();
public: __property void set_OnBeforeRequest(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before request is posted.")]
[ISNet.EventParameterAttribute("controlId, action")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnBeforeRequest {
   System.String^ get();
   void set (    System.String^ value);
}

Remarks

controlID
The ID of the WebScheduler calling the function.

action
The action name of the request.

Example

The following is the example of the javascript function that is assigned in above event.
JScript Copy Code
function WebScheduler1_OnBeforeRequest(controlId, action)
{
    var WebScheduler1 = ISGetObject(controlId);

    return true;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnBeforeTimelineViewSwitch Property

[image]
Intersoft WebScheduler Documentation
OnBeforeTimelineViewSwitch Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnBeforeTimelineViewSwitch Property

Glossary Item Box

Gets or sets the event handler before Timeline view switch.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before Timeline view switch.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId, action")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnBeforeTimelineViewSwitch As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnBeforeTimelineViewSwitch = value

value = instance.OnBeforeTimelineViewSwitch
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before Timeline view switch.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, action")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnBeforeTimelineViewSwitch {get; set;}
Delphi
public read-write property OnBeforeTimelineViewSwitch: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before Timeline view switch.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId, action")
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DefaultValueAttribute()
public function get,set OnBeforeTimelineViewSwitch : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before Timeline view switch.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, action")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnBeforeTimelineViewSwitch();
public: __property void set_OnBeforeTimelineViewSwitch(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before Timeline view switch.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, action")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnBeforeTimelineViewSwitch {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnBeforeViewSwitched Property

[image]
Intersoft WebScheduler Documentation
OnBeforeViewSwitched Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnBeforeViewSwitched Property

Glossary Item Box

Gets or sets the event handler before scheduler view switch action.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before scheduler view switch action.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.EventParameterAttribute("controlId, previousViewMode, nextViewMode")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnBeforeViewSwitched As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnBeforeViewSwitched = value

value = instance.OnBeforeViewSwitched
C#
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before scheduler view switch action.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, previousViewMode, nextViewMode")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnBeforeViewSwitched {get; set;}
Delphi
public read-write property OnBeforeViewSwitched: System.String;
JScript
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before scheduler view switch action.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.EventParameterAttribute("controlId, previousViewMode, nextViewMode")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnBeforeViewSwitched : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before scheduler view switch action.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, previousViewMode, nextViewMode")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnBeforeViewSwitched();
public: __property void set_OnBeforeViewSwitched(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before scheduler view switch action.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, previousViewMode, nextViewMode")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnBeforeViewSwitched {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnCalendarCellClicked Property

[image]
Intersoft WebScheduler Documentation
OnCalendarCellClicked Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnCalendarCellClicked Property

Glossary Item Box

Gets or sets the event handler when calendar cell is clicked.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, element, newDate")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when calendar cell is clicked.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property OnCalendarCellClicked As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnCalendarCellClicked = value

value = instance.OnCalendarCellClicked
C#
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, element, newDate")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when calendar cell is clicked.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string OnCalendarCellClicked {get; set;}
Delphi
public read-write property OnCalendarCellClicked: System.String;
JScript
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, element, newDate")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when calendar cell is clicked.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set OnCalendarCellClicked : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, element, newDate")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when calendar cell is clicked.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_OnCalendarCellClicked();
public: __property void set_OnCalendarCellClicked(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, element, newDate")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when calendar cell is clicked.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ OnCalendarCellClicked {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnCallOutClose Property

[image]
Intersoft WebScheduler Documentation
OnCallOutClose Property
See Also Example Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnCallOutClose Property

Glossary Item Box

Gets or sets the event handler when WebScheduler CallOut is closed. Gets or sets the event handler when WebScheduler callout is closed.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebScheduler CallOut is closed.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnCallOutClose As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnCallOutClose = value

value = instance.OnCallOutClose
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebScheduler CallOut is closed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnCallOutClose {get; set;}
Delphi
public read-write property OnCallOutClose: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebScheduler CallOut is closed.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DefaultValueAttribute()
public function get,set OnCallOutClose : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebScheduler CallOut is closed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnCallOutClose();
public: __property void set_OnCallOutClose(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebScheduler CallOut is closed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnCallOutClose {
   System.String^ get();
   void set (    System.String^ value);
}

Remarks

controlID
The ID of the WebScheduler calling the function.

Example

The following is the example of the javascript function that is assigned in above event.
JScript Copy Code
function WebScheduler1_OnCallOutClose(controlId)
{
    var WebScheduler1 = ISGetObject(controlId);

    return true;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnCallOutInitialize Property

[image]
Intersoft WebScheduler Documentation
OnCallOutInitialize Property
See Also Example Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnCallOutInitialize Property

Glossary Item Box

Gets or sets the event handler when initialize WebScheduler CallOut. Gets or sets the event handler when initialize WebScheduler callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when initialize WebScheduler CallOut.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.EventParameterAttribute("controlId")>
Public Property OnCallOutInitialize As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnCallOutInitialize = value

value = instance.OnCallOutInitialize
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when initialize WebScheduler CallOut.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId")]
public System.string OnCallOutInitialize {get; set;}
Delphi
public read-write property OnCallOutInitialize: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when initialize WebScheduler CallOut.")
System.ComponentModel.DefaultValueAttribute()
ISNet.EventParameterAttribute("controlId")
public function get,set OnCallOutInitialize : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when initialize WebScheduler CallOut.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId")]
public: __property System.string* get_OnCallOutInitialize();
public: __property void set_OnCallOutInitialize(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when initialize WebScheduler CallOut.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId")]
public:
property System.String^ OnCallOutInitialize {
   System.String^ get();
   void set (    System.String^ value);
}

Remarks

controlID
The ID of the WebScheduler calling the function.

Example

The following is the example of the javascript function that is assigned in above event.
JScript Copy Code
function WebScheduler1_OnCallOutInitialize(controlId)
{
    var WebScheduler1 = ISGetObject(controlId);

    return true;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnCallOutShow Property

[image]
Intersoft WebScheduler Documentation
OnCallOutShow Property
See Also Example Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnCallOutShow Property

Glossary Item Box

Gets or sets the event handler when WebScheduler CallOut is shown. Gets or sets the event handler when WebScheduler callout is shown.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebScheduler CallOut is shown.")>
<ISNet.EventParameterAttribute("controlId, action")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OnCallOutShow As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnCallOutShow = value

value = instance.OnCallOutShow
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebScheduler CallOut is shown.")]
[ISNet.EventParameterAttribute("controlId, action")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string OnCallOutShow {get; set;}
Delphi
public read-write property OnCallOutShow: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebScheduler CallOut is shown.")
ISNet.EventParameterAttribute("controlId, action")
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OnCallOutShow : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebScheduler CallOut is shown.")]
[ISNet.EventParameterAttribute("controlId, action")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_OnCallOutShow();
public: __property void set_OnCallOutShow(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebScheduler CallOut is shown.")]
[ISNet.EventParameterAttribute("controlId, action")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ OnCallOutShow {
   System.String^ get();
   void set (    System.String^ value);
}

Remarks

controlID
The ID of the WebScheduler calling the function.

Example

The following is the example of the javascript function that is assigned in above event.
JScript Copy Code
function WebScheduler1_OnCallOutShow(controlId)
{
    var WebScheduler1 = ISGetObject(controlId);

    return true;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnCellDoubleClicked Property

[image]
Intersoft WebScheduler Documentation
OnCellDoubleClicked Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnCellDoubleClicked Property

Glossary Item Box

Gets or sets the event handler when a cell is double clicked.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when a cell is double clicked.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId, startDate, endDate, isAllDay, resource")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnCellDoubleClicked As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnCellDoubleClicked = value

value = instance.OnCellDoubleClicked
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when a cell is double clicked.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, startDate, endDate, isAllDay, resource")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnCellDoubleClicked {get; set;}
Delphi
public read-write property OnCellDoubleClicked: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when a cell is double clicked.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId, startDate, endDate, isAllDay, resource")
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DefaultValueAttribute()
public function get,set OnCellDoubleClicked : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when a cell is double clicked.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, startDate, endDate, isAllDay, resource")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnCellDoubleClicked();
public: __property void set_OnCellDoubleClicked(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when a cell is double clicked.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, startDate, endDate, isAllDay, resource")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnCellDoubleClicked {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnCellSelected Property

[image]
Intersoft WebScheduler Documentation
OnCellSelected Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnCellSelected Property

Glossary Item Box

Gets or sets the event handler when a cell is selected.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when a cell is selected.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<ISNet.EventParameterAttribute("controlId, startDate, endDate, isAllDay, resource")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OnCellSelected As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnCellSelected = value

value = instance.OnCellSelected
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when a cell is selected.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId, startDate, endDate, isAllDay, resource")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string OnCellSelected {get; set;}
Delphi
public read-write property OnCellSelected: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when a cell is selected.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
ISNet.EventParameterAttribute("controlId, startDate, endDate, isAllDay, resource")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OnCellSelected : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when a cell is selected.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId, startDate, endDate, isAllDay, resource")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_OnCellSelected();
public: __property void set_OnCellSelected(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when a cell is selected.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId, startDate, endDate, isAllDay, resource")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ OnCellSelected {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnConfirmationFormShow Property

[image]
Intersoft WebScheduler Documentation
OnConfirmationFormShow Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnConfirmationFormShow Property

Glossary Item Box

Gets or sets the event handler when the editing form is being shown.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the editing form is being shown.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<ISNet.EventParameterAttribute("controlId, action, lastObjectContext, caption")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OnConfirmationFormShow As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnConfirmationFormShow = value

value = instance.OnConfirmationFormShow
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the editing form is being shown.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId, action, lastObjectContext, caption")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string OnConfirmationFormShow {get; set;}
Delphi
public read-write property OnConfirmationFormShow: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the editing form is being shown.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.CategoryAttribute("Client Side Events")
ISNet.EventParameterAttribute("controlId, action, lastObjectContext, caption")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OnConfirmationFormShow : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the editing form is being shown.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId, action, lastObjectContext, caption")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_OnConfirmationFormShow();
public: __property void set_OnConfirmationFormShow(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the editing form is being shown.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId, action, lastObjectContext, caption")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ OnConfirmationFormShow {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnContextMenu Property

[image]
Intersoft WebScheduler Documentation
OnContextMenu Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnContextMenu Property

Glossary Item Box

Gets or sets the event handler when the context menu is about to be displayed. Gets or sets the event handler when the the context menu is being shown.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, type, menuObj, el, eventView")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the context menu  is about to be displayed.")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnContextMenu As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnContextMenu = value

value = instance.OnContextMenu
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, type, menuObj, el, eventView")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the context menu  is about to be displayed.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnContextMenu {get; set;}
Delphi
public read-write property OnContextMenu: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, type, menuObj, el, eventView")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the context menu  is about to be displayed.")
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DefaultValueAttribute()
public function get,set OnContextMenu : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, type, menuObj, el, eventView")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the context menu  is about to be displayed.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnContextMenu();
public: __property void set_OnContextMenu(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, type, menuObj, el, eventView")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the context menu  is about to be displayed.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnContextMenu {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnEditingFormCancel Property

[image]
Intersoft WebScheduler Documentation
OnEditingFormCancel Property
See Also Example Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnEditingFormCancel Property

Glossary Item Box

Gets or sets the event handler when the cancel button in editing form is clicked. Gets or sets the event handler when the cancel button in editing form is clicked.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<ISNet.EventParameterAttribute("controlId")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the cancel button in editing form is clicked.")>
Public Property OnEditingFormCancel As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnEditingFormCancel = value

value = instance.OnEditingFormCancel
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the cancel button in editing form is clicked.")]
public System.string OnEditingFormCancel {get; set;}
Delphi
public read-write property OnEditingFormCancel: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
ISNet.EventParameterAttribute("controlId")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the cancel button in editing form is clicked.")
public function get,set OnEditingFormCancel : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the cancel button in editing form is clicked.")]
public: __property System.string* get_OnEditingFormCancel();
public: __property void set_OnEditingFormCancel(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the cancel button in editing form is clicked.")]
public:
property System.String^ OnEditingFormCancel {
   System.String^ get();
   void set (    System.String^ value);
}

Remarks

controlID
The ID of the WebScheduler calling the function.

Example

The following is the example of the javascript function that is assigned in above event.
JScript Copy Code
function WebScheduler1_OnEditingFormCancel(controlId)
{
    var WebScheduler1 = ISGetObject(controlId);

    return true;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnEditingFormClose Property

[image]
Intersoft WebScheduler Documentation
OnEditingFormClose Property
See Also Example Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnEditingFormClose Property

Glossary Item Box

Gets or sets the event handler when the editing form is being closed. Gets or sets the event handler when the editing form is being closed.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the editing form is being closed.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OnEditingFormClose As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnEditingFormClose = value

value = instance.OnEditingFormClose
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the editing form is being closed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string OnEditingFormClose {get; set;}
Delphi
public read-write property OnEditingFormClose: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the editing form is being closed.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OnEditingFormClose : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the editing form is being closed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_OnEditingFormClose();
public: __property void set_OnEditingFormClose(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the editing form is being closed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ OnEditingFormClose {
   System.String^ get();
   void set (    System.String^ value);
}

Remarks

controlID
The ID of the WebScheduler calling the function.

Example

The following is the example of the javascript function that is assigned in above event.
JScript Copy Code
function WebScheduler1_OnEditingFormClose(controlId)
{
    var WebScheduler1 = ISGetObject(controlId);

    return true;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnEditingFormInitialize Property

[image]
Intersoft WebScheduler Documentation
OnEditingFormInitialize Property
See Also Example Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnEditingFormInitialize Property

Glossary Item Box

Gets or sets the event handler when the editing form is being initialized. Gets or sets the event handler when the editing form is being initialized.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the editing form is being initialized.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.EventParameterAttribute("controlId, action, eventView, eventType, newType")>
Public Property OnEditingFormInitialize As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnEditingFormInitialize = value

value = instance.OnEditingFormInitialize
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the editing form is being initialized.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, action, eventView, eventType, newType")]
public System.string OnEditingFormInitialize {get; set;}
Delphi
public read-write property OnEditingFormInitialize: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the editing form is being initialized.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DefaultValueAttribute()
ISNet.EventParameterAttribute("controlId, action, eventView, eventType, newType")
public function get,set OnEditingFormInitialize : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the editing form is being initialized.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, action, eventView, eventType, newType")]
public: __property System.string* get_OnEditingFormInitialize();
public: __property void set_OnEditingFormInitialize(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the editing form is being initialized.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, action, eventView, eventType, newType")]
public:
property System.String^ OnEditingFormInitialize {
   System.String^ get();
   void set (    System.String^ value);
}

Remarks

controlID
The ID of the WebScheduler calling the function.

action
The action name of the request.

eventView
The event which is initialized.

eventType
The type of events in WebScheduler. When action is set to edit, there will be 3 events available which are AllDayEvent, RecurringEvent and Event. Otherwise, the value will be null.

newType
The new type of events in WebScheduler. When action is set to new, there will be 3 events available which are 0 (NewEvent), 1 (NewAllDayEvent), 2 (NewRecurringEvent). Otherwise, the value will be null.

Example

The following is the example of the javascript function that is assigned in above event.
JScript Copy Code
function WebScheduler1_OnEditingFormInitialize(controlId, action, eventView, eventType, newType)
{
    var WebScheduler1 = ISGetObject(controlId);

    return true;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnEditingFormSave Property

[image]
Intersoft WebScheduler Documentation
OnEditingFormSave Property
See Also Example Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnEditingFormSave Property

Glossary Item Box

Gets or sets the event handler when the save button in editing form is clicked. Gets or sets the event handler when the save button in editing form is clicked.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the save button in editing form is clicked.")>
<ISNet.EventParameterAttribute("controlId, action, eventView")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnEditingFormSave As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnEditingFormSave = value

value = instance.OnEditingFormSave
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the save button in editing form is clicked.")]
[ISNet.EventParameterAttribute("controlId, action, eventView")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnEditingFormSave {get; set;}
Delphi
public read-write property OnEditingFormSave: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the save button in editing form is clicked.")
ISNet.EventParameterAttribute("controlId, action, eventView")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DefaultValueAttribute()
public function get,set OnEditingFormSave : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the save button in editing form is clicked.")]
[ISNet.EventParameterAttribute("controlId, action, eventView")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnEditingFormSave();
public: __property void set_OnEditingFormSave(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the save button in editing form is clicked.")]
[ISNet.EventParameterAttribute("controlId, action, eventView")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnEditingFormSave {
   System.String^ get();
   void set (    System.String^ value);
}

Remarks

controlID
The ID of the WebScheduler calling the function.

action
The action name of the request.

eventView
The event which is being saved.

Example

The following is the example of the javascript function that is assigned in above event.
JScript Copy Code
function WebScheduler1_OnEditingFormSave(controlId, action, eventView)
{
    var WebScheduler1 = ISGetObject(controlId);

    return true;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnEditingFormShow Property

[image]
Intersoft WebScheduler Documentation
OnEditingFormShow Property
See Also Example Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnEditingFormShow Property

Glossary Item Box

Gets or sets the event handler when the editing form is being shown. Gets or sets the event handler when the editing form is being shown.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the editing form is being shown.")>
<ISNet.EventParameterAttribute("controlId, action, eventView, eventType, newType")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnEditingFormShow As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnEditingFormShow = value

value = instance.OnEditingFormShow
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the editing form is being shown.")]
[ISNet.EventParameterAttribute("controlId, action, eventView, eventType, newType")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnEditingFormShow {get; set;}
Delphi
public read-write property OnEditingFormShow: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the editing form is being shown.")
ISNet.EventParameterAttribute("controlId, action, eventView, eventType, newType")
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set OnEditingFormShow : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the editing form is being shown.")]
[ISNet.EventParameterAttribute("controlId, action, eventView, eventType, newType")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnEditingFormShow();
public: __property void set_OnEditingFormShow(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the editing form is being shown.")]
[ISNet.EventParameterAttribute("controlId, action, eventView, eventType, newType")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnEditingFormShow {
   System.String^ get();
   void set (    System.String^ value);
}

Remarks

controlID
The ID of the WebScheduler calling the function.

action
The action name of the request.

eventView
The event which is being shown.

eventType
The type of events in WebScheduler. When action is set to edit, there will be 3 events available which are AllDayEvent, RecurringEvent and Event. Otherwise, the value will be null.

newType
The new type of events in WebScheduler. When action is set to new, there will be 3 events available which are 0 (NewEvent), 1 (NewAllDayEvent), 2 (NewRecurringEvent). Otherwise, the value will be null.

Example

The following is the example of the javascript function that is assigned in above event.
JScript Copy Code
function WebScheduler1_OnEditingFormShow(controlId, action, eventView, eventType, newType)
{
    var WebScheduler1 = ISGetObject(controlId);

    return true;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnEventBound Property

[image]
Intersoft WebScheduler Documentation
OnEventBound Property
See Also Example Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnEventBound Property

Glossary Item Box

Gets or sets the event handler when Event is bound. Gets or sets the event handler when Event is bound.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when Event is bound.")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId, evt")>
Public Property OnEventBound As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnEventBound = value

value = instance.OnEventBound
C#
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when Event is bound.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, evt")]
public System.string OnEventBound {get; set;}
Delphi
public read-write property OnEventBound: System.String;
JScript
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when Event is bound.")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId, evt")
public function get,set OnEventBound : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when Event is bound.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, evt")]
public: __property System.string* get_OnEventBound();
public: __property void set_OnEventBound(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when Event is bound.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, evt")]
public:
property System.String^ OnEventBound {
   System.String^ get();
   void set (    System.String^ value);
}

Remarks

controlID
The ID of the WebScheduler calling the function.

evt
The event which is being bound.

Example

The following is the example of the javascript function that is assigned in above event.
JScript Copy Code
function WebScheduler1_OnEventBound(controlId, evt)
{
    var WebScheduler1 = ISGetObject(controlId);

    return true;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnEventDoubleClicked Property

[image]
Intersoft WebScheduler Documentation
OnEventDoubleClicked Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnEventDoubleClicked Property

Glossary Item Box

Gets or sets the event handler when an event is double clicked.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when an event is double clicked.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId, clickedEvent")>
Public Property OnEventDoubleClicked As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnEventDoubleClicked = value

value = instance.OnEventDoubleClicked
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when an event is double clicked.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, clickedEvent")]
public System.string OnEventDoubleClicked {get; set;}
Delphi
public read-write property OnEventDoubleClicked: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when an event is double clicked.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId, clickedEvent")
public function get,set OnEventDoubleClicked : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when an event is double clicked.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, clickedEvent")]
public: __property System.string* get_OnEventDoubleClicked();
public: __property void set_OnEventDoubleClicked(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when an event is double clicked.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, clickedEvent")]
public:
property System.String^ OnEventDoubleClicked {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnEventSelected Property

[image]
Intersoft WebScheduler Documentation
OnEventSelected Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnEventSelected Property

Glossary Item Box

Gets or sets the event handler when an event is selected.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when an event is selected.")>
<ISNet.EventParameterAttribute("controlId, selectedEvent")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OnEventSelected As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnEventSelected = value

value = instance.OnEventSelected
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when an event is selected.")]
[ISNet.EventParameterAttribute("controlId, selectedEvent")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string OnEventSelected {get; set;}
Delphi
public read-write property OnEventSelected: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when an event is selected.")
ISNet.EventParameterAttribute("controlId, selectedEvent")
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OnEventSelected : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when an event is selected.")]
[ISNet.EventParameterAttribute("controlId, selectedEvent")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_OnEventSelected();
public: __property void set_OnEventSelected(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when an event is selected.")]
[ISNet.EventParameterAttribute("controlId, selectedEvent")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ OnEventSelected {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnForwardNavigation Property

[image]
Intersoft WebScheduler Documentation
OnForwardNavigation Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnForwardNavigation Property

Glossary Item Box

Gets or sets the event handler when forward navigation action, in scheduler view and calendar, is about to be performed.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when forward navigation action, in scheduler view and calendar, is about to be performed.")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<ISNet.EventParameterAttribute("controlId, viewMode, previousDate, nextDate, isCalendarNavigation")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OnForwardNavigation As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnForwardNavigation = value

value = instance.OnForwardNavigation
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when forward navigation action, in scheduler view and calendar, is about to be performed.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId, viewMode, previousDate, nextDate, isCalendarNavigation")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string OnForwardNavigation {get; set;}
Delphi
public read-write property OnForwardNavigation: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when forward navigation action, in scheduler view and calendar, is about to be performed.")
System.ComponentModel.CategoryAttribute("Client Side Events")
ISNet.EventParameterAttribute("controlId, viewMode, previousDate, nextDate, isCalendarNavigation")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OnForwardNavigation : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when forward navigation action, in scheduler view and calendar, is about to be performed.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId, viewMode, previousDate, nextDate, isCalendarNavigation")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_OnForwardNavigation();
public: __property void set_OnForwardNavigation(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when forward navigation action, in scheduler view and calendar, is about to be performed.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId, viewMode, previousDate, nextDate, isCalendarNavigation")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ OnForwardNavigation {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnInitialize Property

[image]
Intersoft WebScheduler Documentation
OnInitialize Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnInitialize Property

Glossary Item Box

Gets or sets the event handler when WebScheduler is initialized.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebScheduler is initialized.")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
Public Property OnInitialize As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnInitialize = value

value = instance.OnInitialize
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebScheduler is initialized.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public System.string OnInitialize {get; set;}
Delphi
public read-write property OnInitialize: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebScheduler is initialized.")
System.ComponentModel.CategoryAttribute("Client Side Events")
public function get,set OnInitialize : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebScheduler is initialized.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public: __property System.string* get_OnInitialize();
public: __property void set_OnInitialize(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebScheduler is initialized.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public:
property System.String^ OnInitialize {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnMultipleCellSelected Property

[image]
Intersoft WebScheduler Documentation
OnMultipleCellSelected Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnMultipleCellSelected Property

Glossary Item Box

Gets or sets the event handler when multiple dates are selected.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when multiple dates are selected.")>
<ISNet.EventParameterAttribute("controlId, startDate, endDate, isAllDay, resource")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnMultipleCellSelected As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnMultipleCellSelected = value

value = instance.OnMultipleCellSelected
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when multiple dates are selected.")]
[ISNet.EventParameterAttribute("controlId, startDate, endDate, isAllDay, resource")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnMultipleCellSelected {get; set;}
Delphi
public read-write property OnMultipleCellSelected: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when multiple dates are selected.")
ISNet.EventParameterAttribute("controlId, startDate, endDate, isAllDay, resource")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DefaultValueAttribute()
public function get,set OnMultipleCellSelected : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when multiple dates are selected.")]
[ISNet.EventParameterAttribute("controlId, startDate, endDate, isAllDay, resource")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnMultipleCellSelected();
public: __property void set_OnMultipleCellSelected(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when multiple dates are selected.")]
[ISNet.EventParameterAttribute("controlId, startDate, endDate, isAllDay, resource")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnMultipleCellSelected {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnResourceClicked Property

[image]
Intersoft WebScheduler Documentation
OnResourceClicked Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnResourceClicked Property

Glossary Item Box

Gets or sets the event handler when resource checkbox is clicked.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, checkBoxEl, selectedResource")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when resource checkbox is clicked.")>
Public Property OnResourceClicked As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnResourceClicked = value

value = instance.OnResourceClicked
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, checkBoxEl, selectedResource")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when resource checkbox is clicked.")]
public System.string OnResourceClicked {get; set;}
Delphi
public read-write property OnResourceClicked: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, checkBoxEl, selectedResource")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when resource checkbox is clicked.")
public function get,set OnResourceClicked : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, checkBoxEl, selectedResource")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when resource checkbox is clicked.")]
public: __property System.string* get_OnResourceClicked();
public: __property void set_OnResourceClicked(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, checkBoxEl, selectedResource")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when resource checkbox is clicked.")]
public:
property System.String^ OnResourceClicked {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnResponse Property

[image]
Intersoft WebScheduler Documentation
OnResponse Property
See Also Example Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnResponse Property

Glossary Item Box

Gets or sets the event handler on response. Gets or sets the event handler on response.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on response.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, action")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OnResponse As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnResponse = value

value = instance.OnResponse
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on response.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, action")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string OnResponse {get; set;}
Delphi
public read-write property OnResponse: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on response.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, action")
System.ComponentModel.CategoryAttribute("Client Side Events")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OnResponse : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on response.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, action")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_OnResponse();
public: __property void set_OnResponse(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on response.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, action")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ OnResponse {
   System.String^ get();
   void set (    System.String^ value);
}

Remarks

controlID
The ID of the WebScheduler calling the function.

action
The action name of the request.

Example

The following is the example of the javascript function that is assigned in above event.
JScript Copy Code
function WebScheduler1_OnResponse(controlId, action)
{
    var WebScheduler1 = ISGetObject(controlId);

    return true;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnResponseError Property

[image]
Intersoft WebScheduler Documentation
OnResponseError Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnResponseError Property

Glossary Item Box

Gets or sets the event handler that will be invoked when the callback action returns error response..

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when the callback action returns error response.")>
<ISNet.EventParameterAttribute("controlId, action, errorMessage")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnResponseError As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnResponseError = value

value = instance.OnResponseError
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when the callback action returns error response.")]
[ISNet.EventParameterAttribute("controlId, action, errorMessage")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnResponseError {get; set;}
Delphi
public read-write property OnResponseError: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when the callback action returns error response.")
ISNet.EventParameterAttribute("controlId, action, errorMessage")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DefaultValueAttribute()
public function get,set OnResponseError : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when the callback action returns error response.")]
[ISNet.EventParameterAttribute("controlId, action, errorMessage")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnResponseError();
public: __property void set_OnResponseError(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when the callback action returns error response.")]
[ISNet.EventParameterAttribute("controlId, action, errorMessage")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnResponseError {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnTimelineCustomResource Property

[image]
Intersoft WebScheduler Documentation
OnTimelineCustomResource Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnTimelineCustomResource Property

Glossary Item Box

Gets or sets the event handler on Timeline's Custom Resource. Gets or sets the event handler when the custom resources is being implemented in Timeline.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on Timeline's Custom Resource.")>
<ISNet.EventParameterAttribute("controlId, resourcesId")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnTimelineCustomResource As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnTimelineCustomResource = value

value = instance.OnTimelineCustomResource
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on Timeline's Custom Resource.")]
[ISNet.EventParameterAttribute("controlId, resourcesId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnTimelineCustomResource {get; set;}
Delphi
public read-write property OnTimelineCustomResource: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on Timeline's Custom Resource.")
ISNet.EventParameterAttribute("controlId, resourcesId")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DefaultValueAttribute()
public function get,set OnTimelineCustomResource : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on Timeline's Custom Resource.")]
[ISNet.EventParameterAttribute("controlId, resourcesId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnTimelineCustomResource();
public: __property void set_OnTimelineCustomResource(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on Timeline's Custom Resource.")]
[ISNet.EventParameterAttribute("controlId, resourcesId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnTimelineCustomResource {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


OnValidateDisabledTime Property

[image]
Intersoft WebScheduler Documentation
OnValidateDisabledTime Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : OnValidateDisabledTime Property

Glossary Item Box

Gets or sets the event handler to validate DisabledTime manually. Validation should return true or false. True if the the range of time inside DisabledTime range, and False if the range of time outside DisabledTime range.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<ISNet.EventParameterAttribute("controlId, startTime, endTime, resourceID, elementType")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler to validate DisabledTime manually. Validation should return true or false. True if the the range of time inside DisabledTime range, and False if the range of time outside DisabledTime range.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OnValidateDisabledTime As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

instance.OnValidateDisabledTime = value

value = instance.OnValidateDisabledTime
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId, startTime, endTime, resourceID, elementType")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler to validate DisabledTime manually. Validation should return true or false. True if the the range of time inside DisabledTime range, and False if the range of time outside DisabledTime range.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string OnValidateDisabledTime {get; set;}
Delphi
public read-write property OnValidateDisabledTime: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
ISNet.EventParameterAttribute("controlId, startTime, endTime, resourceID, elementType")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler to validate DisabledTime manually. Validation should return true or false. True if the the range of time inside DisabledTime range, and False if the range of time outside DisabledTime range.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OnValidateDisabledTime : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId, startTime, endTime, resourceID, elementType")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler to validate DisabledTime manually. Validation should return true or false. True if the the range of time inside DisabledTime range, and False if the range of time outside DisabledTime range.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_OnValidateDisabledTime();
public: __property void set_OnValidateDisabledTime(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId, startTime, endTime, resourceID, elementType")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler to validate DisabledTime manually. Validation should return true or false. True if the the range of time inside DisabledTime range, and False if the range of time outside DisabledTime range.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ OnValidateDisabledTime {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


WebSchedulerDataArgs Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerDataArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDataArgs Class

Glossary Item Box

The argument which is called when an event handler is in process.

Object Model

WebSchedulerDataArgs Class

Syntax

Visual Basic (Declaration)
Public Class WebSchedulerDataArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDataArgs
C#
public class WebSchedulerDataArgs : System.EventArgs
Delphi
public class WebSchedulerDataArgs = class(System.EventArgs)
JScript
public class WebSchedulerDataArgs extends System.EventArgs
Managed Extensions for C++
public __gc class WebSchedulerDataArgs : public System.EventArgs
C++/CLI
public ref class WebSchedulerDataArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebScheduler.WebSchedulerDataArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDataArgs Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerDataArgs Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerDataArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDataArgs Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerDataArgs.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerDataArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Cancel |
Public Property | Type |
Public Property | Values |
Top

See Also

Reference

WebSchedulerDataArgs Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerDataArgs Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerDataArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDataArgs Class : WebSchedulerDataArgs Constructor

values
type

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal values As System.Collections.Generic.Dictionary(Of String,Object), _
   ByVal type As WebSchedulerObjectType _
)
Visual Basic (Usage) Copy Code
Dim values As System.Collections.Generic.Dictionary(Of String,Object)
Dim type As WebSchedulerObjectType

Dim instance As New WebSchedulerDataArgs(values, type)
C#
public WebSchedulerDataArgs(
   System.Collections.Generic.Dictionary<string,object> values,
   WebSchedulerObjectType type
)
Delphi
public WebSchedulerDataArgs(
    values: System.Collections.Generic.Dictionary;
    type: WebSchedulerObjectType
);
JScript
public function WebSchedulerDataArgs(
   values : System.Collections.Generic.Dictionary,
   type : WebSchedulerObjectType
);
Managed Extensions for C++
public: WebSchedulerDataArgs(
   System.Collections.Generic.Dictionary<string*,Object*>* values,
   WebSchedulerObjectType type
)
C++/CLI
public:
WebSchedulerDataArgs(
   System.Collections.Generic.Dictionary<String^,Object^>^ values,
   WebSchedulerObjectType type
)

Parameters

values
type

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDataArgs Class
WebSchedulerDataArgs Members


WebSchedulerDataArgs Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerDataArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDataArgs Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerDataArgs members.

Public Properties

 | Name | Description
Public Property | Cancel |
Public Property | Type |
Public Property | Values |
Top

See Also

Reference

WebSchedulerDataArgs Class
ISNet.WebUI.WebScheduler Namespace


Cancel Property

[image]
Intersoft WebScheduler Documentation
Cancel Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDataArgs Class : Cancel Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Cancel As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDataArgs
Dim value As System.Boolean

instance.Cancel = value

value = instance.Cancel
C#
public System.bool Cancel {get; set;}
Delphi
public read-write property Cancel: System.Boolean;
JScript
public function get,set Cancel : System.boolean
Managed Extensions for C++
public: __property System.bool get_Cancel();
public: __property void set_Cancel(
   System.bool value
);
C++/CLI
public:
property System.bool Cancel {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDataArgs Class
WebSchedulerDataArgs Members


Type Property

[image]
Intersoft WebScheduler Documentation
Type Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDataArgs Class : Type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As WebSchedulerObjectType
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDataArgs
Dim value As WebSchedulerObjectType

value = instance.Type
C#
public WebSchedulerObjectType Type {get;}
Delphi
public read-only property Type: WebSchedulerObjectType;
JScript
public function get Type : WebSchedulerObjectType
Managed Extensions for C++
public: __property WebSchedulerObjectType get_Type();
C++/CLI
public:
property WebSchedulerObjectType Type {
   WebSchedulerObjectType get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDataArgs Class
WebSchedulerDataArgs Members


Values Property

[image]
Intersoft WebScheduler Documentation
Values Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDataArgs Class : Values Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Values As System.Collections.Generic.Dictionary(Of String,Object)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDataArgs
Dim value As System.Collections.Generic.Dictionary(Of String,Object)

value = instance.Values
C#
public System.Collections.Generic.Dictionary<string,object> Values {get;}
Delphi
public read-only property Values: System.Collections.Generic.Dictionary;
JScript
public function get Values : System.Collections.Generic.Dictionary
Managed Extensions for C++
public: __property System.Collections.Generic.Dictionary<string*,Object*>* get_Values();
C++/CLI
public:
property System.Collections.Generic.Dictionary<String^,Object^>^ Values {
   System.Collections.Generic.Dictionary<String^,Object^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDataArgs Class
WebSchedulerDataArgs Members


WebSchedulerDataBoundDataArgs Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerDataBoundDataArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDataBoundDataArgs Class

Glossary Item Box

Provides data for data bound related data.

Object Model

WebSchedulerDataBoundDataArgs Class

Syntax

Visual Basic (Declaration)
Public Class WebSchedulerDataBoundDataArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDataBoundDataArgs
C#
public class WebSchedulerDataBoundDataArgs : System.EventArgs
Delphi
public class WebSchedulerDataBoundDataArgs = class(System.EventArgs)
JScript
public class WebSchedulerDataBoundDataArgs extends System.EventArgs
Managed Extensions for C++
public __gc class WebSchedulerDataBoundDataArgs : public System.EventArgs
C++/CLI
public ref class WebSchedulerDataBoundDataArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebScheduler.WebSchedulerDataBoundDataArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDataBoundDataArgs Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerDataBoundDataArgs Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerDataBoundDataArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDataBoundDataArgs Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerDataBoundDataArgs.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerDataBoundDataArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | DataObject |
Public Property | DataRow |
Public Property | Type |
Top

See Also

Reference

WebSchedulerDataBoundDataArgs Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerDataBoundDataArgs Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerDataBoundDataArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDataBoundDataArgs Class : WebSchedulerDataBoundDataArgs Constructor

dataObject
dataRow
type

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dataObject As System.Object, _
   ByVal dataRow As System.Data.DataRow, _
   ByVal type As WebSchedulerObjectType _
)
Visual Basic (Usage) Copy Code
Dim dataObject As System.Object
Dim dataRow As System.Data.DataRow
Dim type As WebSchedulerObjectType

Dim instance As New WebSchedulerDataBoundDataArgs(dataObject, dataRow, type)
C#
public WebSchedulerDataBoundDataArgs(
   System.object dataObject,
   System.Data.DataRow dataRow,
   WebSchedulerObjectType type
)
Delphi
public WebSchedulerDataBoundDataArgs(
    dataObject: System.TObject;
    dataRow: System.Data.DataRow;
    type: WebSchedulerObjectType
);
JScript
public function WebSchedulerDataBoundDataArgs(
   dataObject : System.Object,
   dataRow : System.Data.DataRow,
   type : WebSchedulerObjectType
);
Managed Extensions for C++
public: WebSchedulerDataBoundDataArgs(
   System.Object* dataObject,
   System.Data.DataRow* dataRow,
   WebSchedulerObjectType type
)
C++/CLI
public:
WebSchedulerDataBoundDataArgs(
   System.Object^ dataObject,
   System.Data.DataRow^ dataRow,
   WebSchedulerObjectType type
)

Parameters

dataObject
dataRow
type

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDataBoundDataArgs Class
WebSchedulerDataBoundDataArgs Members


WebSchedulerDataBoundDataArgs Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerDataBoundDataArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDataBoundDataArgs Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerDataBoundDataArgs members.

Public Properties

 | Name | Description
Public Property | DataObject |
Public Property | DataRow |
Public Property | Type |
Top

See Also

Reference

WebSchedulerDataBoundDataArgs Class
ISNet.WebUI.WebScheduler Namespace


DataObject Property

[image]
Intersoft WebScheduler Documentation
DataObject Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDataBoundDataArgs Class : DataObject Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataObject As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDataBoundDataArgs
Dim value As System.Object

value = instance.DataObject
C#
public System.object DataObject {get;}
Delphi
public read-only property DataObject: System.TObject;
JScript
public function get DataObject : System.Object
Managed Extensions for C++
public: __property System.Object* get_DataObject();
C++/CLI
public:
property System.Object^ DataObject {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDataBoundDataArgs Class
WebSchedulerDataBoundDataArgs Members


DataRow Property

[image]
Intersoft WebScheduler Documentation
DataRow Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDataBoundDataArgs Class : DataRow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataRow As System.Data.DataRow
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDataBoundDataArgs
Dim value As System.Data.DataRow

value = instance.DataRow
C#
public System.Data.DataRow DataRow {get;}
Delphi
public read-only property DataRow: System.Data.DataRow;
JScript
public function get DataRow : System.Data.DataRow
Managed Extensions for C++
public: __property System.Data.DataRow* get_DataRow();
C++/CLI
public:
property System.Data.DataRow^ DataRow {
   System.Data.DataRow^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDataBoundDataArgs Class
WebSchedulerDataBoundDataArgs Members


Type Property

[image]
Intersoft WebScheduler Documentation
Type Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDataBoundDataArgs Class : Type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As WebSchedulerObjectType
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDataBoundDataArgs
Dim value As WebSchedulerObjectType

value = instance.Type
C#
public WebSchedulerObjectType Type {get;}
Delphi
public read-only property Type: WebSchedulerObjectType;
JScript
public function get Type : WebSchedulerObjectType
Managed Extensions for C++
public: __property WebSchedulerObjectType get_Type();
C++/CLI
public:
property WebSchedulerObjectType Type {
   WebSchedulerObjectType get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDataBoundDataArgs Class
WebSchedulerDataBoundDataArgs Members


WebSchedulerDataEditing Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerDataEditing Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDataEditing Class

Glossary Item Box

A collection of setting used for WebScheduler's data editing.A collection of settings used for WebScheduler's data editing.

Object Model

WebSchedulerDataEditing Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerDataEditing
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDataEditing
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerDataEditing : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSchedulerDataEditing = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerDataEditing extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerDataEditing : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerDataEditing : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebScheduler.WebSchedulerDataEditing
ISNet.WebUI.WebScheduler.WebSchedulerResourceDataEditing

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDataEditing Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerDataEditing Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerDataEditing Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDataEditing Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerDataEditing.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerDataEditing Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllowAdd | Indicates whether WebScheduler can add a new event.
Public Property | AllowDelete | Indicates whether WebScheduler can delete an event.
Public Property | AllowEdit | Indicates whether WebScheduler can edit an event.
Public Property | AllowMove | Indicates whether an event can be moved.
Public Property | AllowResize | Indicates whether an event can be resized.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerDataEditing Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerDataEditing Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerDataEditing Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDataEditing Class : WebSchedulerDataEditing Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerDataEditing()
C#
public WebSchedulerDataEditing()
Delphi
public WebSchedulerDataEditing();
JScript
public function WebSchedulerDataEditing();
Managed Extensions for C++
public: WebSchedulerDataEditing();
C++/CLI
public:
WebSchedulerDataEditing();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDataEditing Class
WebSchedulerDataEditing Members


WebSchedulerDataEditing Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerDataEditing Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDataEditing Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerDataEditing members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerDataEditing Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDataEditing Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDataEditing
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDataEditing Class
WebSchedulerDataEditing Members


WebSchedulerDataEditing Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerDataEditing Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDataEditing Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerDataEditing members.

Public Properties

 | Name | Description
Public Property | AllowAdd | Indicates whether WebScheduler can add a new event.
Public Property | AllowDelete | Indicates whether WebScheduler can delete an event.
Public Property | AllowEdit | Indicates whether WebScheduler can edit an event.
Public Property | AllowMove | Indicates whether an event can be moved.
Public Property | AllowResize | Indicates whether an event can be resized.
Top

See Also

Reference

WebSchedulerDataEditing Class
ISNet.WebUI.WebScheduler Namespace


AllowAdd Property

[image]
Intersoft WebScheduler Documentation
AllowAdd Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDataEditing Class : AllowAdd Property

Glossary Item Box

Indicates whether WebScheduler can add a new event.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Data Editing")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Indicates whether WebScheduler can add a new event.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property AllowAdd As WebSchedulerAllowMode
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDataEditing
Dim value As WebSchedulerAllowMode

instance.AllowAdd = value

value = instance.AllowAdd
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Data Editing")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether WebScheduler can add a new event.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public WebSchedulerAllowMode AllowAdd {get; set;}
Delphi
public read-write property AllowAdd: WebSchedulerAllowMode;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Data Editing")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Indicates whether WebScheduler can add a new event.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set AllowAdd : WebSchedulerAllowMode
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Data Editing")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether WebScheduler can add a new event.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property WebSchedulerAllowMode get_AllowAdd();
public: __property void set_AllowAdd(
   WebSchedulerAllowMode value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Data Editing")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether WebScheduler can add a new event.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property WebSchedulerAllowMode AllowAdd {
   WebSchedulerAllowMode get();
   void set (    WebSchedulerAllowMode value);
}

Property Value

The default value is No.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDataEditing Class
WebSchedulerDataEditing Members


AllowDelete Property

[image]
Intersoft WebScheduler Documentation
AllowDelete Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDataEditing Class : AllowDelete Property

Glossary Item Box

Indicates whether WebScheduler can delete an event.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Data Editing")>
<System.ComponentModel.DescriptionAttribute("Indicates whether WebScheduler can delete an event.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property AllowDelete As WebSchedulerAllowMode
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDataEditing
Dim value As WebSchedulerAllowMode

instance.AllowDelete = value

value = instance.AllowDelete
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data Editing")]
[System.ComponentModel.DescriptionAttribute("Indicates whether WebScheduler can delete an event.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public WebSchedulerAllowMode AllowDelete {get; set;}
Delphi
public read-write property AllowDelete: WebSchedulerAllowMode;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Data Editing")
System.ComponentModel.DescriptionAttribute("Indicates whether WebScheduler can delete an event.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set AllowDelete : WebSchedulerAllowMode
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data Editing")]
[System.ComponentModel.DescriptionAttribute("Indicates whether WebScheduler can delete an event.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property WebSchedulerAllowMode get_AllowDelete();
public: __property void set_AllowDelete(
   WebSchedulerAllowMode value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data Editing")]
[System.ComponentModel.DescriptionAttribute("Indicates whether WebScheduler can delete an event.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property WebSchedulerAllowMode AllowDelete {
   WebSchedulerAllowMode get();
   void set (    WebSchedulerAllowMode value);
}

Property Value

The default value is No.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDataEditing Class
WebSchedulerDataEditing Members


AllowEdit Property

[image]
Intersoft WebScheduler Documentation
AllowEdit Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDataEditing Class : AllowEdit Property

Glossary Item Box

Indicates whether WebScheduler can edit an event.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Data Editing")>
<System.ComponentModel.DescriptionAttribute("Indicates whether WebScheduler can edit an event.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property AllowEdit As WebSchedulerAllowMode
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDataEditing
Dim value As WebSchedulerAllowMode

instance.AllowEdit = value

value = instance.AllowEdit
C#
[System.ComponentModel.CategoryAttribute("Data Editing")]
[System.ComponentModel.DescriptionAttribute("Indicates whether WebScheduler can edit an event.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebSchedulerAllowMode AllowEdit {get; set;}
Delphi
public read-write property AllowEdit: WebSchedulerAllowMode;
JScript
System.ComponentModel.CategoryAttribute("Data Editing")
System.ComponentModel.DescriptionAttribute("Indicates whether WebScheduler can edit an event.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set AllowEdit : WebSchedulerAllowMode
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Data Editing")]
[System.ComponentModel.DescriptionAttribute("Indicates whether WebScheduler can edit an event.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebSchedulerAllowMode get_AllowEdit();
public: __property void set_AllowEdit(
   WebSchedulerAllowMode value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Data Editing")]
[System.ComponentModel.DescriptionAttribute("Indicates whether WebScheduler can edit an event.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebSchedulerAllowMode AllowEdit {
   WebSchedulerAllowMode get();
   void set (    WebSchedulerAllowMode value);
}

Property Value

The default value is No.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDataEditing Class
WebSchedulerDataEditing Members


AllowMove Property

[image]
Intersoft WebScheduler Documentation
AllowMove Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDataEditing Class : AllowMove Property

Glossary Item Box

Indicates whether an event can be moved.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Indicates whether an event can be moved.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Data Editing")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property AllowMove As WebSchedulerAllowMode
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDataEditing
Dim value As WebSchedulerAllowMode

instance.AllowMove = value

value = instance.AllowMove
C#
[System.ComponentModel.DescriptionAttribute("Indicates whether an event can be moved.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data Editing")]
[ISNet.Serialization.XmlSerializableAttribute()]
public WebSchedulerAllowMode AllowMove {get; set;}
Delphi
public read-write property AllowMove: WebSchedulerAllowMode;
JScript
System.ComponentModel.DescriptionAttribute("Indicates whether an event can be moved.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Data Editing")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set AllowMove : WebSchedulerAllowMode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Indicates whether an event can be moved.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data Editing")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property WebSchedulerAllowMode get_AllowMove();
public: __property void set_AllowMove(
   WebSchedulerAllowMode value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Indicates whether an event can be moved.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data Editing")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property WebSchedulerAllowMode AllowMove {
   WebSchedulerAllowMode get();
   void set (    WebSchedulerAllowMode value);
}

Property Value

The default value is No.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDataEditing Class
WebSchedulerDataEditing Members


AllowResize Property

[image]
Intersoft WebScheduler Documentation
AllowResize Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDataEditing Class : AllowResize Property

Glossary Item Box

Indicates whether an event can be resized.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Indicates whether an event can be resized.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Data Editing")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property AllowResize As WebSchedulerAllowMode
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDataEditing
Dim value As WebSchedulerAllowMode

instance.AllowResize = value

value = instance.AllowResize
C#
[System.ComponentModel.DescriptionAttribute("Indicates whether an event can be resized.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data Editing")]
[ISNet.Serialization.XmlSerializableAttribute()]
public WebSchedulerAllowMode AllowResize {get; set;}
Delphi
public read-write property AllowResize: WebSchedulerAllowMode;
JScript
System.ComponentModel.DescriptionAttribute("Indicates whether an event can be resized.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Data Editing")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set AllowResize : WebSchedulerAllowMode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Indicates whether an event can be resized.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data Editing")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property WebSchedulerAllowMode get_AllowResize();
public: __property void set_AllowResize(
   WebSchedulerAllowMode value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Indicates whether an event can be resized.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data Editing")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property WebSchedulerAllowMode AllowResize {
   WebSchedulerAllowMode get();
   void set (    WebSchedulerAllowMode value);
}

Property Value

The default value is No.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDataEditing Class
WebSchedulerDataEditing Members


WebSchedulerDateTimeConverter Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerDateTimeConverter Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDateTimeConverter Class

Glossary Item Box

A collection of settings used for WebScheduler's date time converter.

Object Model

WebSchedulerDateTimeConverter Class

Syntax

Visual Basic (Declaration)
Public Class WebSchedulerDateTimeConverter
   Inherits System.ComponentModel.TypeConverter
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
C#
public class WebSchedulerDateTimeConverter : System.ComponentModel.TypeConverter
Delphi
public class WebSchedulerDateTimeConverter = class(System.ComponentModel.TypeConverter)
JScript
public class WebSchedulerDateTimeConverter extends System.ComponentModel.TypeConverter
Managed Extensions for C++
public __gc class WebSchedulerDateTimeConverter : public System.ComponentModel.TypeConverter
C++/CLI
public ref class WebSchedulerDateTimeConverter : public System.ComponentModel.TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
ISNet.WebUI.WebScheduler.WebSchedulerDateTimeConverter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerDateTimeConverter Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerDateTimeConverter Class Members
See Also Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDateTimeConverter Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerDateTimeConverter.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerDateTimeConverter Constructor |
Top

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CanConvertTo | Overloaded. Overridden.
Public Method | ConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden.
Public Method | ConvertToInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

WebSchedulerDateTimeConverter Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerDateTimeConverter Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerDateTimeConverter Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class : WebSchedulerDateTimeConverter Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerDateTimeConverter()
C#
public WebSchedulerDateTimeConverter()
Delphi
public WebSchedulerDateTimeConverter();
JScript
public function WebSchedulerDateTimeConverter();
Managed Extensions for C++
public: WebSchedulerDateTimeConverter();
C++/CLI
public:
WebSchedulerDateTimeConverter();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members


WebSchedulerDateTimeConverter Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerDateTimeConverter Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDateTimeConverter Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerDateTimeConverter members.

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CanConvertTo | Overloaded. Overridden.
Public Method | ConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden.
Public Method | ConvertToInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

WebSchedulerDateTimeConverter Class
ISNet.WebUI.WebScheduler Namespace


CanConvertTo Method

[image]
Intersoft WebScheduler Documentation
CanConvertTo Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class : CanConvertTo Method

Glossary Item Box

Overload List

Overload | Description
CanConvertTo(ITypeDescriptorContext,Type) |
CanConvertTo(Type) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members


CanConvertTo(ITypeDescriptorContext,Type) Method

[image]
Intersoft WebScheduler Documentation
CanConvertTo(ITypeDescriptorContext,Type) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > CanConvertTo Method : CanConvertTo(ITypeDescriptorContext,Type) Method

context
destinationType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function CanConvertTo( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal destinationType As System.Type _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim destinationType As System.Type
Dim value As System.Boolean

value = instance.CanConvertTo(context, destinationType)
C#
public override System.bool CanConvertTo(
   System.ComponentModel.ITypeDescriptorContext context,
   System.Type destinationType
)
Delphi
public function CanConvertTo(
    context: System.ComponentModel.ITypeDescriptorContext;
    destinationType: System.Type
): System.Boolean; override;
JScript
public override function CanConvertTo(
   context : System.ComponentModel.ITypeDescriptorContext,
   destinationType : System.Type
) : System.boolean;
Managed Extensions for C++
public: System.bool CanConvertTo(
   System.ComponentModel.ITypeDescriptorContext* context,
   System.Type* destinationType
) override
C++/CLI
public:
System.bool CanConvertTo(
   System.ComponentModel.ITypeDescriptorContext^ context,
   System.Type^ destinationType
) override

Parameters

context
destinationType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


ConvertTo Method

[image]
Intersoft WebScheduler Documentation
ConvertTo Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class : ConvertTo Method

Glossary Item Box

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) |
ConvertTo(Object,Type) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members


ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

[image]
Intersoft WebScheduler Documentation
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > ConvertTo Method : ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

context
culture
value
destinationType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ConvertTo( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal culture As System.Globalization.CultureInfo, _
   ByVal value As System.Object, _
   ByVal destinationType As System.Type _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim culture As System.Globalization.CultureInfo
Dim value As System.Object
Dim destinationType As System.Type
Dim value As System.Object

value = instance.ConvertTo(context, culture, value, destinationType)
C#
public override System.object ConvertTo(
   System.ComponentModel.ITypeDescriptorContext context,
   System.Globalization.CultureInfo culture,
   System.object value,
   System.Type destinationType
)
Delphi
public function ConvertTo(
    context: System.ComponentModel.ITypeDescriptorContext;
    culture: System.Globalization.CultureInfo;
    value: System.TObject;
    destinationType: System.Type
): System.TObject; override;
JScript
public override function ConvertTo(
   context : System.ComponentModel.ITypeDescriptorContext,
   culture : System.Globalization.CultureInfo,
   value : System.Object,
   destinationType : System.Type
) : System.Object;
Managed Extensions for C++
public: System.Object* ConvertTo(
   System.ComponentModel.ITypeDescriptorContext* context,
   System.Globalization.CultureInfo* culture,
   System.Object* value,
   System.Type* destinationType
) override
C++/CLI
public:
System.Object^ ConvertTo(
   System.ComponentModel.ITypeDescriptorContext^ context,
   System.Globalization.CultureInfo^ culture,
   System.Object^ value,
   System.Type^ destinationType
) override

Parameters

context
culture
value
destinationType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


WebSchedulerDayView Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerDayView Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDayView Class

Glossary Item Box

A collection of settings used for WebScheduler's day view.

Object Model

WebSchedulerDayView Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerDayView
   Inherits WebSchedulerBaseView
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDayView
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerDayView : WebSchedulerBaseView, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSchedulerDayView = class(WebSchedulerBaseView, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerDayView extends WebSchedulerBaseView implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerDayView : public WebSchedulerBaseView, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerDayView : public WebSchedulerBaseView, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebScheduler.WebSchedulerDayView

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDayView Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerDayView Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerDayView Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDayView Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerDayView.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerDayView Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllDayEventPageSize | Specifies the total number of all day events rendered when client paging is enabled.
Public Property | DateFormatString | Overridden. Specify the DateFormatString for Day view. Specifies the DateFormatString for day view.
Public Property | EnableClientPaging | Specifies whether or not client paging is enabled.
Public Property | EventBlockSize | Specifies the total number of overlapped block allowed when client paging is enabled.
Public Property | ShowAllDayEventArea | Indicates whether AllDayEvent area should be shown. Indicates whether AllDayEvent area should be shown.
Public Property | TimeInterval | Specifies the time interval used when rendering the hour areas.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerDayView Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerDayView Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerDayView Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDayView Class : WebSchedulerDayView Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerDayView()
C#
public WebSchedulerDayView()
Delphi
public WebSchedulerDayView();
JScript
public function WebSchedulerDayView();
Managed Extensions for C++
public: WebSchedulerDayView();
C++/CLI
public:
WebSchedulerDayView();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDayView Class
WebSchedulerDayView Members


WebSchedulerDayView Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerDayView Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDayView Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerDayView members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerDayView Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDayView Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDayView
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDayView Class
WebSchedulerDayView Members


WebSchedulerDayView Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerDayView Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDayView Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerDayView members.

Public Properties

 | Name | Description
Public Property | AllDayEventPageSize | Specifies the total number of all day events rendered when client paging is enabled.
Public Property | DateFormatString | Overridden. Specify the DateFormatString for Day view. Specifies the DateFormatString for day view.
Public Property | EnableClientPaging | Specifies whether or not client paging is enabled.
Public Property | EventBlockSize | Specifies the total number of overlapped block allowed when client paging is enabled.
Public Property | ShowAllDayEventArea | Indicates whether AllDayEvent area should be shown. Indicates whether AllDayEvent area should be shown.
Public Property | TimeInterval | Specifies the time interval used when rendering the hour areas.
Top

See Also

Reference

WebSchedulerDayView Class
ISNet.WebUI.WebScheduler Namespace


AllDayEventPageSize Property

[image]
Intersoft WebScheduler Documentation
AllDayEventPageSize Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDayView Class : AllDayEventPageSize Property

Glossary Item Box

Specifies the total number of all day events rendered when client paging is enabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the total number of all day events rendered when client paging is enabled.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Day View")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property AllDayEventPageSize As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDayView
Dim value As System.Integer

instance.AllDayEventPageSize = value

value = instance.AllDayEventPageSize
C#
[System.ComponentModel.DescriptionAttribute("Specifies the total number of all day events rendered when client paging is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Day View")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.int AllDayEventPageSize {get; set;}
Delphi
public read-write property AllDayEventPageSize: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the total number of all day events rendered when client paging is enabled.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Day View")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set AllDayEventPageSize : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the total number of all day events rendered when client paging is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Day View")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.int get_AllDayEventPageSize();
public: __property void set_AllDayEventPageSize(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the total number of all day events rendered when client paging is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Day View")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.int AllDayEventPageSize {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 3.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDayView Class
WebSchedulerDayView Members


DateFormatString Property

[image]
Intersoft WebScheduler Documentation
DateFormatString Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDayView Class : DateFormatString Property

Glossary Item Box

Specify the DateFormatString for Day view. Specifies the DateFormatString for day view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Day View")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specify the DateFormatString for Day view.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overrides Property DateFormatString As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDayView
Dim value As System.String

instance.DateFormatString = value

value = instance.DateFormatString
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Day View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specify the DateFormatString for Day view.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public override System.string DateFormatString {get; set;}
Delphi
public read-write property DateFormatString: System.String; override;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Day View")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specify the DateFormatString for Day view.")
ISNet.Serialization.BinarySerializableAttribute()
public override function get,set DateFormatString : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Day View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specify the DateFormatString for Day view.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_DateFormatString() override;
public: __property void set_DateFormatString(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Day View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specify the DateFormatString for Day view.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ DateFormatString {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Property Value

The default value is D.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDayView Class
WebSchedulerDayView Members


EnableClientPaging Property

[image]
Intersoft WebScheduler Documentation
EnableClientPaging Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDayView Class : EnableClientPaging Property

Glossary Item Box

Specifies whether or not client paging is enabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Day View")>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not client paging is enabled.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property EnableClientPaging As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDayView
Dim value As System.Boolean

instance.EnableClientPaging = value

value = instance.EnableClientPaging
C#
[System.ComponentModel.CategoryAttribute("Day View")]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not client paging is enabled.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool EnableClientPaging {get; set;}
Delphi
public read-write property EnableClientPaging: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Day View")
System.ComponentModel.DescriptionAttribute("Specifies whether or not client paging is enabled.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set EnableClientPaging : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Day View")]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not client paging is enabled.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_EnableClientPaging();
public: __property void set_EnableClientPaging(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Day View")]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not client paging is enabled.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool EnableClientPaging {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDayView Class
WebSchedulerDayView Members


EventBlockSize Property

[image]
Intersoft WebScheduler Documentation
EventBlockSize Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDayView Class : EventBlockSize Property

Glossary Item Box

Specifies the total number of overlapped block allowed when client paging is enabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the total number of overlapped block allowed when client paging is enabled.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Day View")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property EventBlockSize As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDayView
Dim value As System.Integer

instance.EventBlockSize = value

value = instance.EventBlockSize
C#
[System.ComponentModel.DescriptionAttribute("Specifies the total number of overlapped block allowed when client paging is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Day View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.int EventBlockSize {get; set;}
Delphi
public read-write property EventBlockSize: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the total number of overlapped block allowed when client paging is enabled.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Day View")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set EventBlockSize : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the total number of overlapped block allowed when client paging is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Day View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_EventBlockSize();
public: __property void set_EventBlockSize(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the total number of overlapped block allowed when client paging is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Day View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int EventBlockSize {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 3.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDayView Class
WebSchedulerDayView Members


ShowAllDayEventArea Property

[image]
Intersoft WebScheduler Documentation
ShowAllDayEventArea Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDayView Class : ShowAllDayEventArea Property

Glossary Item Box

Indicates whether AllDayEvent area should be shown. Indicates whether AllDayEvent area should be shown.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Indicates whether AllDayEvent area should be shown.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Day View")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ShowAllDayEventArea As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDayView
Dim value As System.Boolean

instance.ShowAllDayEventArea = value

value = instance.ShowAllDayEventArea
C#
[System.ComponentModel.DescriptionAttribute("Indicates whether AllDayEvent area should be shown.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Day View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool ShowAllDayEventArea {get; set;}
Delphi
public read-write property ShowAllDayEventArea: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Indicates whether AllDayEvent area should be shown.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Day View")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set ShowAllDayEventArea : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Indicates whether AllDayEvent area should be shown.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Day View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_ShowAllDayEventArea();
public: __property void set_ShowAllDayEventArea(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Indicates whether AllDayEvent area should be shown.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Day View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool ShowAllDayEventArea {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDayView Class
WebSchedulerDayView Members


TimeInterval Property

[image]
Intersoft WebScheduler Documentation
TimeInterval Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDayView Class : TimeInterval Property

Glossary Item Box

Specifies the time interval used when rendering the hour areas.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Day View")>
<System.ComponentModel.DescriptionAttribute("Specifies the time interval used when rendering the hour areas.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property TimeInterval As WebSchedulerTimeScale
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDayView
Dim value As WebSchedulerTimeScale

instance.TimeInterval = value

value = instance.TimeInterval
C#
[System.ComponentModel.CategoryAttribute("Day View")]
[System.ComponentModel.DescriptionAttribute("Specifies the time interval used when rendering the hour areas.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebSchedulerTimeScale TimeInterval {get; set;}
Delphi
public read-write property TimeInterval: WebSchedulerTimeScale;
JScript
System.ComponentModel.CategoryAttribute("Day View")
System.ComponentModel.DescriptionAttribute("Specifies the time interval used when rendering the hour areas.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set TimeInterval : WebSchedulerTimeScale
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Day View")]
[System.ComponentModel.DescriptionAttribute("Specifies the time interval used when rendering the hour areas.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebSchedulerTimeScale get_TimeInterval();
public: __property void set_TimeInterval(
   WebSchedulerTimeScale value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Day View")]
[System.ComponentModel.DescriptionAttribute("Specifies the time interval used when rendering the hour areas.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebSchedulerTimeScale TimeInterval {
   WebSchedulerTimeScale get();
   void set (    WebSchedulerTimeScale value);
}

Property Value

The default value is Minutes30.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDayView Class
WebSchedulerDayView Members


WebSchedulerDetailInfoStyle Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerDetailInfoStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDetailInfoStyle Class

Glossary Item Box

A collection of styles used for WebScheduler's detail info.

Object Model

WebSchedulerDetailInfoStyle Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerDetailInfoStyle
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDetailInfoStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerDetailInfoStyle : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSchedulerDetailInfoStyle = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerDetailInfoStyle extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerDetailInfoStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerDetailInfoStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebScheduler.WebSchedulerDetailInfoStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDetailInfoStyle Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerDetailInfoStyle Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerDetailInfoStyle Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDetailInfoStyle Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerDetailInfoStyle.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerDetailInfoStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | ContentStyle | Contains interactive style for detail info's content.
Public Property | HeaderStyle | Contains interactive styles for detail info's header.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerDetailInfoStyle Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerDetailInfoStyle Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerDetailInfoStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDetailInfoStyle Class : WebSchedulerDetailInfoStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerDetailInfoStyle()
C#
public WebSchedulerDetailInfoStyle()
Delphi
public WebSchedulerDetailInfoStyle();
JScript
public function WebSchedulerDetailInfoStyle();
Managed Extensions for C++
public: WebSchedulerDetailInfoStyle();
C++/CLI
public:
WebSchedulerDetailInfoStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDetailInfoStyle Class
WebSchedulerDetailInfoStyle Members


WebSchedulerDetailInfoStyle Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerDetailInfoStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDetailInfoStyle Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerDetailInfoStyle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerDetailInfoStyle Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDetailInfoStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDetailInfoStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDetailInfoStyle Class
WebSchedulerDetailInfoStyle Members


WebSchedulerDetailInfoStyle Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerDetailInfoStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDetailInfoStyle Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerDetailInfoStyle members.

Public Properties

 | Name | Description
Public Property | ContentStyle | Contains interactive style for detail info's content.
Public Property | HeaderStyle | Contains interactive styles for detail info's header.
Top

See Also

Reference

WebSchedulerDetailInfoStyle Class
ISNet.WebUI.WebScheduler Namespace


ContentStyle Property

[image]
Intersoft WebScheduler Documentation
ContentStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDetailInfoStyle Class : ContentStyle Property

Glossary Item Box

Contains interactive style for detail info's content.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.CategoryAttribute("Detail Info Style")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property ContentStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDetailInfoStyle
Dim value As ISNet.WebUI.WebStyle

value = instance.ContentStyle
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Detail Info Style")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public ISNet.WebUI.WebStyle ContentStyle {get;}
Delphi
public read-only property ContentStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.CategoryAttribute("Detail Info Style")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get ContentStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Detail Info Style")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.WebStyle* get_ContentStyle();
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Detail Info Style")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.WebStyle^ ContentStyle {
   ISNet.WebUI.WebStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDetailInfoStyle Class
WebSchedulerDetailInfoStyle Members


HeaderStyle Property

[image]
Intersoft WebScheduler Documentation
HeaderStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDetailInfoStyle Class : HeaderStyle Property

Glossary Item Box

Contains interactive styles for detail info's header.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Detail Info Style")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property HeaderStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDetailInfoStyle
Dim value As ISNet.WebUI.WebStyle

value = instance.HeaderStyle
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Detail Info Style")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ISNet.WebUI.WebStyle HeaderStyle {get;}
Delphi
public read-only property HeaderStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Detail Info Style")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get HeaderStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Detail Info Style")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ISNet.WebUI.WebStyle* get_HeaderStyle();
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Detail Info Style")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ISNet.WebUI.WebStyle^ HeaderStyle {
   ISNet.WebUI.WebStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDetailInfoStyle Class
WebSchedulerDetailInfoStyle Members


WebSchedulerDisabledTime Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerDisabledTime Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDisabledTime Class

Glossary Item Box

A collection of members in WebScheduler's DisabledTime.

Object Model

WebSchedulerDisabledTime Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerDisabledTime
   Inherits ISNet.WebUI.NamedObjectBase2
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDisabledTime
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerDisabledTime : ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Delphi
public class WebSchedulerDisabledTime = class(ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerDisabledTime extends ISNet.WebUI.NamedObjectBase2 implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerDisabledTime : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerDisabledTime : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase2
ISNet.WebUI.WebScheduler.WebSchedulerDisabledTime

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTime Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerDisabledTime Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerDisabledTime Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDisabledTime Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerDisabledTime.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerDisabledTime Constructor |
Top

Public Properties

 | Name | Description
Public Property | EndTime | Specifies the EndTime of DisabledTime.
Public Property | StartTime | Specifies the StartTime of DisabledTime.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerDisabledTime Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerDisabledTime Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerDisabledTime Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTime Class : WebSchedulerDisabledTime Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerDisabledTime()
C#
public WebSchedulerDisabledTime()
Delphi
public WebSchedulerDisabledTime();
JScript
public function WebSchedulerDisabledTime();
Managed Extensions for C++
public: WebSchedulerDisabledTime();
C++/CLI
public:
WebSchedulerDisabledTime();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTime Class
WebSchedulerDisabledTime Members


WebSchedulerDisabledTime Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerDisabledTime Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDisabledTime Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerDisabledTime members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerDisabledTime Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTime Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDisabledTime
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTime Class
WebSchedulerDisabledTime Members


WebSchedulerDisabledTime Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerDisabledTime Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDisabledTime Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerDisabledTime members.

Public Properties

 | Name | Description
Public Property | EndTime | Specifies the EndTime of DisabledTime.
Public Property | StartTime | Specifies the StartTime of DisabledTime.
Top

See Also

Reference

WebSchedulerDisabledTime Class
ISNet.WebUI.WebScheduler Namespace


EndTime Property

[image]
Intersoft WebScheduler Documentation
EndTime Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTime Class : EndTime Property

Glossary Item Box

Specifies the EndTime of DisabledTime.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.TwoWay)>
<System.ComponentModel.DescriptionAttribute("Specifies the EndTime of DisabledTime.")>
Public Property EndTime As System.Date
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDisabledTime
Dim value As System.Date

instance.EndTime = value

value = instance.EndTime
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.TwoWay)]
[System.ComponentModel.DescriptionAttribute("Specifies the EndTime of DisabledTime.")]
public System.DateTime EndTime {get; set;}
Delphi
public read-write property EndTime: System.DateTime;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.TwoWay)
System.ComponentModel.DescriptionAttribute("Specifies the EndTime of DisabledTime.")
public function get,set EndTime : System.DateTime
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.TwoWay)]
[System.ComponentModel.DescriptionAttribute("Specifies the EndTime of DisabledTime.")]
public: __property System.DateTime get_EndTime();
public: __property void set_EndTime(
   System.DateTime value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.TwoWay)]
[System.ComponentModel.DescriptionAttribute("Specifies the EndTime of DisabledTime.")]
public:
property System.DateTime EndTime {
   System.DateTime get();
   void set (    System.DateTime value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTime Class
WebSchedulerDisabledTime Members


StartTime Property

[image]
Intersoft WebScheduler Documentation
StartTime Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTime Class : StartTime Property

Glossary Item Box

Specifies the StartTime of DisabledTime.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.TwoWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Specifies the StartTime of DisabledTime.")>
Public Property StartTime As System.Date
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDisabledTime
Dim value As System.Date

instance.StartTime = value

value = instance.StartTime
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.TwoWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the StartTime of DisabledTime.")]
public System.DateTime StartTime {get; set;}
Delphi
public read-write property StartTime: System.DateTime;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.TwoWay)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Specifies the StartTime of DisabledTime.")
public function get,set StartTime : System.DateTime
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.TwoWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the StartTime of DisabledTime.")]
public: __property System.DateTime get_StartTime();
public: __property void set_StartTime(
   System.DateTime value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.TwoWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the StartTime of DisabledTime.")]
public:
property System.DateTime StartTime {
   System.DateTime get();
   void set (    System.DateTime value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTime Class
WebSchedulerDisabledTime Members


WebSchedulerDisabledTimeCollection Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerDisabledTimeCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDisabledTimeCollection Class

Glossary Item Box

The data collection of DisabledTime used by WebScheduler.

Object Model

WebSchedulerDisabledTimeCollection Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerDisabledTimeCollection
   Inherits ISNet.WebUI.ISGenericCollectionBase(Of WebSchedulerDisabledTime)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDisabledTimeCollection
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerDisabledTimeCollection : ISNet.WebUI.ISGenericCollectionBase<WebSchedulerDisabledTime>
Delphi
public class WebSchedulerDisabledTimeCollection = class(ISNet.WebUI.ISGenericCollectionBase)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerDisabledTimeCollection extends ISNet.WebUI.ISGenericCollectionBase
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerDisabledTimeCollection : public ISNet.WebUI.ISGenericCollectionBase<WebSchedulerDisabledTime>
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerDisabledTimeCollection : public ISNet.WebUI.ISGenericCollectionBase<WebSchedulerDisabledTime>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
ISNet.WebUI.ISCollectionBase<T>
ISNet.WebUI.ISGenericCollectionBase<T>
ISNet.WebUI.WebScheduler.WebSchedulerDisabledTimeCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTimeCollection Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerDisabledTimeCollection Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerDisabledTimeCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDisabledTimeCollection Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerDisabledTimeCollection.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerDisabledTimeCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerDisabledTime>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerDisabledTime>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerDisabledTime>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebSchedulerDisabledTimeCollection Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerDisabledTimeCollection Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerDisabledTimeCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTimeCollection Class : WebSchedulerDisabledTimeCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerDisabledTimeCollection()
C#
public WebSchedulerDisabledTimeCollection()
Delphi
public WebSchedulerDisabledTimeCollection();
JScript
public function WebSchedulerDisabledTimeCollection();
Managed Extensions for C++
public: WebSchedulerDisabledTimeCollection();
C++/CLI
public:
WebSchedulerDisabledTimeCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTimeCollection Class
WebSchedulerDisabledTimeCollection Members


WebSchedulerEditingField Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerEditingField Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerEditingField Class

Glossary Item Box

A collection of members in WebScheduler's editing field.

Object Model

WebSchedulerEditingField Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerEditingField
   Inherits ISNet.WebUI.NamedObjectBase2
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingField
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerEditingField : ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Delphi
public class WebSchedulerEditingField = class(ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerEditingField extends ISNet.WebUI.NamedObjectBase2 implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerEditingField : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerEditingField : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase2
ISNet.WebUI.WebScheduler.WebSchedulerEditingField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingField Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerEditingField Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerEditingField Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerEditingField Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerEditingField.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerEditingField Constructor |
Top

Public Properties

 | Name | Description
Public Property | Name | Overridden. Gets or sets the Name of EditingField. Specifies the name of editing field.
Public Property | ReminderTimeSpan | Gets or sets the ReminderTimeSpan of EditingField. Set the time span for reminder.
Public Property | Text | Gets or sets the Text of EditingField. Specifies the text of editing field.
Public Property | Type | Gets or sets the Type of EditingField. Specifies the type of editing field.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerEditingField Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerEditingField Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerEditingField Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingField Class : WebSchedulerEditingField Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerEditingField()
C#
public WebSchedulerEditingField()
Delphi
public WebSchedulerEditingField();
JScript
public function WebSchedulerEditingField();
Managed Extensions for C++
public: WebSchedulerEditingField();
C++/CLI
public:
WebSchedulerEditingField();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingField Class
WebSchedulerEditingField Members


WebSchedulerEditingField Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerEditingField Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerEditingField Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerEditingField members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerEditingField Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingField Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingField
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingField Class
WebSchedulerEditingField Members


WebSchedulerEditingField Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerEditingField Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerEditingField Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerEditingField members.

Public Properties

 | Name | Description
Public Property | Name | Overridden. Gets or sets the Name of EditingField. Specifies the name of editing field.
Public Property | ReminderTimeSpan | Gets or sets the ReminderTimeSpan of EditingField. Set the time span for reminder.
Public Property | Text | Gets or sets the Text of EditingField. Specifies the text of editing field.
Public Property | Type | Gets or sets the Type of EditingField. Specifies the type of editing field.
Top

See Also

Reference

WebSchedulerEditingField Class
ISNet.WebUI.WebScheduler Namespace


Name Property

[image]
Intersoft WebScheduler Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingField Class : Name Property

Glossary Item Box

Gets or sets the Name of EditingField. Specifies the name of editing field.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.BrowsableAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the Name of EditingField.")>
<System.ComponentModel.CategoryAttribute("Editing")>
Public Overrides Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingField
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the Name of EditingField.")]
[System.ComponentModel.CategoryAttribute("Editing")]
public override System.string Name {get; set;}
Delphi
public read-write property Name: System.String; override;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
System.ComponentModel.DescriptionAttribute("Gets or sets the Name of EditingField.")
System.ComponentModel.CategoryAttribute("Editing")
public override function get,set Name : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the Name of EditingField.")]
[System.ComponentModel.CategoryAttribute("Editing")]
public: __property System.string* get_Name() override;
public: __property void set_Name(
   System.string* value
) override;
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the Name of EditingField.")]
[System.ComponentModel.CategoryAttribute("Editing")]
public:
property System.String^ Name {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingField Class
WebSchedulerEditingField Members


ReminderTimeSpan Property

[image]
Intersoft WebScheduler Documentation
ReminderTimeSpan Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingField Class : ReminderTimeSpan Property

Glossary Item Box

Gets or sets the ReminderTimeSpan of EditingField. Set the time span for reminder.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the ReminderTimeSpan of EditingField.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Editing")>
Public Property ReminderTimeSpan As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingField
Dim value As System.String

instance.ReminderTimeSpan = value

value = instance.ReminderTimeSpan
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the ReminderTimeSpan of EditingField.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Editing")]
public System.string ReminderTimeSpan {get; set;}
Delphi
public read-write property ReminderTimeSpan: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the ReminderTimeSpan of EditingField.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Editing")
public function get,set ReminderTimeSpan : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the ReminderTimeSpan of EditingField.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Editing")]
public: __property System.string* get_ReminderTimeSpan();
public: __property void set_ReminderTimeSpan(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the ReminderTimeSpan of EditingField.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Editing")]
public:
property System.String^ ReminderTimeSpan {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingField Class
WebSchedulerEditingField Members


Text Property

[image]
Intersoft WebScheduler Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingField Class : Text Property

Glossary Item Box

Gets or sets the Text of EditingField. Specifies the text of editing field.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the Text of EditingField.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Editing")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Text As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingField
Dim value As System.String

instance.Text = value

value = instance.Text
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the Text of EditingField.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Editing")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string Text {get; set;}
Delphi
public read-write property Text: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the Text of EditingField.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Editing")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Text : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the Text of EditingField.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Editing")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_Text();
public: __property void set_Text(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the Text of EditingField.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Editing")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ Text {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingField Class
WebSchedulerEditingField Members


Type Property

[image]
Intersoft WebScheduler Documentation
Type Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingField Class : Type Property

Glossary Item Box

Gets or sets the Type of EditingField.

Specifies the type of editing field.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the Type of EditingField.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Editing")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Type As WebSchedulerFieldType
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingField
Dim value As WebSchedulerFieldType

instance.Type = value

value = instance.Type
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the Type of EditingField.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Editing")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public WebSchedulerFieldType Type {get; set;}
Delphi
public read-write property Type: WebSchedulerFieldType;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the Type of EditingField.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Editing")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Type : WebSchedulerFieldType
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the Type of EditingField.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Editing")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property WebSchedulerFieldType get_Type();
public: __property void set_Type(
   WebSchedulerFieldType value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the Type of EditingField.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Editing")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property WebSchedulerFieldType Type {
   WebSchedulerFieldType get();
   void set (    WebSchedulerFieldType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingField Class
WebSchedulerEditingField Members


WebSchedulerEditingFieldCollection Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerEditingFieldCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerEditingFieldCollection Class

Glossary Item Box

The data collection used by webscheduler as the callout's editing field.

Object Model

WebSchedulerEditingFieldCollection Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerEditingFieldCollection
   Inherits ISNet.WebUI.ISGenericCollectionBase(Of WebSchedulerEditingField)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingFieldCollection
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerEditingFieldCollection : ISNet.WebUI.ISGenericCollectionBase<WebSchedulerEditingField>
Delphi
public class WebSchedulerEditingFieldCollection = class(ISNet.WebUI.ISGenericCollectionBase)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerEditingFieldCollection extends ISNet.WebUI.ISGenericCollectionBase
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerEditingFieldCollection : public ISNet.WebUI.ISGenericCollectionBase<WebSchedulerEditingField>
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerEditingFieldCollection : public ISNet.WebUI.ISGenericCollectionBase<WebSchedulerEditingField>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
ISNet.WebUI.ISCollectionBase<T>
ISNet.WebUI.ISGenericCollectionBase<T>
ISNet.WebUI.WebScheduler.WebSchedulerEditingFieldCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingFieldCollection Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerEditingFieldCollection Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerEditingFieldCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerEditingFieldCollection Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerEditingFieldCollection.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerEditingFieldCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerEditingField>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerEditingField>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerEditingField>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebSchedulerEditingFieldCollection Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerEditingFieldCollection Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerEditingFieldCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingFieldCollection Class : WebSchedulerEditingFieldCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerEditingFieldCollection()
C#
public WebSchedulerEditingFieldCollection()
Delphi
public WebSchedulerEditingFieldCollection();
JScript
public function WebSchedulerEditingFieldCollection();
Managed Extensions for C++
public: WebSchedulerEditingFieldCollection();
C++/CLI
public:
WebSchedulerEditingFieldCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingFieldCollection Class
WebSchedulerEditingFieldCollection Members


WebSchedulerEvent Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerEvent Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerEvent Class

Glossary Item Box

A collection of members in WebScheduler's event.

Object Model

WebSchedulerEvent Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerEvent
   Inherits WebSchedulerEventBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEvent
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerEvent : WebSchedulerEventBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Delphi
public class WebSchedulerEvent = class(WebSchedulerEventBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerEvent extends WebSchedulerEventBase implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerEvent : public WebSchedulerEventBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerEvent : public WebSchedulerEventBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase2
ISNet.WebUI.WebScheduler.WebSchedulerEventBase
ISNet.WebUI.WebScheduler.WebSchedulerEvent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEvent Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerEvent Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerEvent Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerEvent Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerEvent.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerEvent Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllDayEvent | Indicates whether the event is AllDayEvent. Specifies the EventBase's AllDayEvent. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | CategoryID | Gets or sets the CategoryID. Specifies the EventBase's CategoryID. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | Collection | (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | Description | Gets or sets the Description of the event. Specifies the EventBase's description. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | EndTime | Gets or sets the EndTime of the event. Specifies the EventBase's EndTime. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | EventID | Gets or sets the EventID. Specifies the EventBase's EventID. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | Location | Gets or sets the Location of the event. Specifies the EventBase's location. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | Mode | Specifies the event's Mode. Specifies the EventBase's mode. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | Name | (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | ReminderTimeSpan | Specifies the event's ReminderTimeSpan. Specifies the EventBase's ReminderTimeSpan. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | ResourceID | Gets or sets the ResourceID. Specifies the EventBase's ResourceID. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | StartTime | Gets or sets the StartTime of the event. Specifies the EventBase's StartTime. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | Subject | Gets or sets the Subject of the event. Specifies the EventBase's subject. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | Tooltip | Specifies the event's ToolTip. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerEvent Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerEvent Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerEvent Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEvent Class : WebSchedulerEvent Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerEvent()
C#
public WebSchedulerEvent()
Delphi
public WebSchedulerEvent();
JScript
public function WebSchedulerEvent();
Managed Extensions for C++
public: WebSchedulerEvent();
C++/CLI
public:
WebSchedulerEvent();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEvent Class
WebSchedulerEvent Members


WebSchedulerEvent Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerEvent Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerEvent Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerEvent members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerEvent Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEvent Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEvent
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEvent Class
WebSchedulerEvent Members


WebSchedulerEventBase Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerEventBase Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerEventBase Class

Glossary Item Box

Base class of WebSchedulerEvent and WebSchedulerRecurringEvent.

Object Model

WebSchedulerEventBase Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerEventBase
   Inherits ISNet.WebUI.NamedObjectBase2
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventBase
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerEventBase : ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Delphi
public class WebSchedulerEventBase = class(ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerEventBase extends ISNet.WebUI.NamedObjectBase2 implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerEventBase : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerEventBase : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase2
ISNet.WebUI.WebScheduler.WebSchedulerEventBase
ISNet.WebUI.WebScheduler.WebSchedulerEvent
ISNet.WebUI.WebScheduler.WebSchedulerRecurringEvent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventBase Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerEventBase Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerEventBase Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerEventBase Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerEventBase.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerEventBase Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllDayEvent | Indicates whether the event is AllDayEvent. Specifies the EventBase's AllDayEvent.
Public Property | CategoryID | Gets or sets the CategoryID. Specifies the EventBase's CategoryID.
Public Property | Collection |
Public Property | Description | Gets or sets the Description of the event. Specifies the EventBase's description.
Public Property | EndTime | Gets or sets the EndTime of the event. Specifies the EventBase's EndTime.
Public Property | EventID | Gets or sets the EventID. Specifies the EventBase's EventID.
Public Property | Location | Gets or sets the Location of the event. Specifies the EventBase's location.
Public Property | Mode | Specifies the event's Mode. Specifies the EventBase's mode.
Public Property | Name | Overridden.
Public Property | ReminderTimeSpan | Specifies the event's ReminderTimeSpan. Specifies the EventBase's ReminderTimeSpan.
Public Property | ResourceID | Gets or sets the ResourceID. Specifies the EventBase's ResourceID.
Public Property | StartTime | Gets or sets the StartTime of the event. Specifies the EventBase's StartTime.
Public Property | Subject | Gets or sets the Subject of the event. Specifies the EventBase's subject.
Public Property | Tooltip | Specifies the event's ToolTip.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerEventBase Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerEventBase Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerEventBase Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventBase Class : WebSchedulerEventBase Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerEventBase()
C#
public WebSchedulerEventBase()
Delphi
public WebSchedulerEventBase();
JScript
public function WebSchedulerEventBase();
Managed Extensions for C++
public: WebSchedulerEventBase();
C++/CLI
public:
WebSchedulerEventBase();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventBase Class
WebSchedulerEventBase Members


WebSchedulerEventBase Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerEventBase Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerEventBase Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerEventBase members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerEventBase Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventBase Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventBase
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventBase Class
WebSchedulerEventBase Members


WebSchedulerEventBase Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerEventBase Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerEventBase Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerEventBase members.

Public Properties

 | Name | Description
Public Property | AllDayEvent | Indicates whether the event is AllDayEvent. Specifies the EventBase's AllDayEvent.
Public Property | CategoryID | Gets or sets the CategoryID. Specifies the EventBase's CategoryID.
Public Property | Collection |
Public Property | Description | Gets or sets the Description of the event. Specifies the EventBase's description.
Public Property | EndTime | Gets or sets the EndTime of the event. Specifies the EventBase's EndTime.
Public Property | EventID | Gets or sets the EventID. Specifies the EventBase's EventID.
Public Property | Location | Gets or sets the Location of the event. Specifies the EventBase's location.
Public Property | Mode | Specifies the event's Mode. Specifies the EventBase's mode.
Public Property | Name | Overridden.
Public Property | ReminderTimeSpan | Specifies the event's ReminderTimeSpan. Specifies the EventBase's ReminderTimeSpan.
Public Property | ResourceID | Gets or sets the ResourceID. Specifies the EventBase's ResourceID.
Public Property | StartTime | Gets or sets the StartTime of the event. Specifies the EventBase's StartTime.
Public Property | Subject | Gets or sets the Subject of the event. Specifies the EventBase's subject.
Public Property | Tooltip | Specifies the event's ToolTip.
Top

See Also

Reference

WebSchedulerEventBase Class
ISNet.WebUI.WebScheduler Namespace


AllDayEvent Property

[image]
Intersoft WebScheduler Documentation
AllDayEvent Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventBase Class : AllDayEvent Property

Glossary Item Box

Indicates whether the event is AllDayEvent. Specifies the EventBase's AllDayEvent.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Event Details")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Indicates whether the event is AllDayEvent.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
Public Property AllDayEvent As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventBase
Dim value As System.Boolean

instance.AllDayEvent = value

value = instance.AllDayEvent
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Event Details")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether the event is AllDayEvent.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public System.bool AllDayEvent {get; set;}
Delphi
public read-write property AllDayEvent: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Event Details")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Indicates whether the event is AllDayEvent.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
public function get,set AllDayEvent : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Event Details")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether the event is AllDayEvent.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public: __property System.bool get_AllDayEvent();
public: __property void set_AllDayEvent(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Event Details")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether the event is AllDayEvent.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public:
property System.bool AllDayEvent {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventBase Class
WebSchedulerEventBase Members


CategoryID Property

[image]
Intersoft WebScheduler Documentation
CategoryID Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventBase Class : CategoryID Property

Glossary Item Box

Gets or sets the CategoryID.

Specifies the EventBase's CategoryID.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Event Details")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the CategoryID.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
Public Property CategoryID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventBase
Dim value As System.String

instance.CategoryID = value

value = instance.CategoryID
C#
[System.ComponentModel.CategoryAttribute("Event Details")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the CategoryID.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public System.string CategoryID {get; set;}
Delphi
public read-write property CategoryID: System.String;
JScript
System.ComponentModel.CategoryAttribute("Event Details")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the CategoryID.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
public function get,set CategoryID : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Event Details")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the CategoryID.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public: __property System.string* get_CategoryID();
public: __property void set_CategoryID(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Event Details")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the CategoryID.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public:
property System.String^ CategoryID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventBase Class
WebSchedulerEventBase Members


Collection Property

[image]
Intersoft WebScheduler Documentation
Collection Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventBase Class : Collection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.JsonSerialization.ScriptIgnoreAttribute()>
Public Shadows Property Collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventBase
Dim value As ISNet.WebUI.ISCollectionBase(Of INamedObject2)

instance.Collection = value

value = instance.Collection
C#
[ISNet.Serialization.JsonSerialization.ScriptIgnoreAttribute()]
public new ISNet.WebUI.ISCollectionBase<INamedObject2> Collection {get; set;}
Delphi
public read-write property Collection: ISNet.WebUI.ISCollectionBase;
JScript
ISNet.Serialization.JsonSerialization.ScriptIgnoreAttribute()
public hide function get,set Collection : ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[ISNet.Serialization.JsonSerialization.ScriptIgnoreAttribute()]
public: __property new ISNet.WebUI.ISCollectionBase<INamedObject2*>* get_Collection();
public: __property new void set_Collection(
   ISNet.WebUI.ISCollectionBase<INamedObject2*>* value
);
C++/CLI
[ISNet.Serialization.JsonSerialization.ScriptIgnoreAttribute()]
public:
new property ISNet.WebUI.ISCollectionBase<INamedObject2^>^ Collection {
   ISNet.WebUI.ISCollectionBase<INamedObject2^>^ get();
   void set (    ISNet.WebUI.ISCollectionBase<INamedObject2^>^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventBase Class
WebSchedulerEventBase Members


Description Property

[image]
Intersoft WebScheduler Documentation
Description Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventBase Class : Description Property

Glossary Item Box

Gets or sets the Description of the event. Specifies the EventBase's description.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the Description of the event.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Event Details")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Description As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventBase
Dim value As System.String

instance.Description = value

value = instance.Description
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the Description of the event.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Event Details")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string Description {get; set;}
Delphi
public read-write property Description: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the Description of the event.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Event Details")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Description : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the Description of the event.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Event Details")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_Description();
public: __property void set_Description(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the Description of the event.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Event Details")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ Description {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventBase Class
WebSchedulerEventBase Members


EndTime Property

[image]
Intersoft WebScheduler Documentation
EndTime Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventBase Class : EndTime Property

Glossary Item Box

Gets or sets the EndTime of the event. Specifies the EventBase's EndTime.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Event Details")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the EndTime of the event.")>
Public Property EndTime As System.Date
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventBase
Dim value As System.Date

instance.EndTime = value

value = instance.EndTime
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Event Details")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the EndTime of the event.")]
public System.DateTime EndTime {get; set;}
Delphi
public read-write property EndTime: System.DateTime;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Event Details")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the EndTime of the event.")
public function get,set EndTime : System.DateTime
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Event Details")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the EndTime of the event.")]
public: __property System.DateTime get_EndTime();
public: __property void set_EndTime(
   System.DateTime value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Event Details")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the EndTime of the event.")]
public:
property System.DateTime EndTime {
   System.DateTime get();
   void set (    System.DateTime value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventBase Class
WebSchedulerEventBase Members


EventID Property

[image]
Intersoft WebScheduler Documentation
EventID Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventBase Class : EventID Property

Glossary Item Box

Gets or sets the EventID. Specifies the EventBase's EventID.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Event Details")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the EventID.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property EventID As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventBase
Dim value As System.Integer

instance.EventID = value

value = instance.EventID
C#
[System.ComponentModel.CategoryAttribute("Event Details")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the EventID.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.int EventID {get; set;}
Delphi
public read-write property EventID: System.Integer;
JScript
System.ComponentModel.CategoryAttribute("Event Details")
System.ComponentModel.DescriptionAttribute("Gets or sets the EventID.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set EventID : System.int
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Event Details")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the EventID.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.int get_EventID();
public: __property void set_EventID(
   System.int value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Event Details")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the EventID.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.int EventID {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventBase Class
WebSchedulerEventBase Members


Location Property

[image]
Intersoft WebScheduler Documentation
Location Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventBase Class : Location Property

Glossary Item Box

Gets or sets the Location of the event. Specifies the EventBase's location.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Event Details")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the Location of the event.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Location As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventBase
Dim value As System.String

instance.Location = value

value = instance.Location
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Event Details")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the Location of the event.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string Location {get; set;}
Delphi
public read-write property Location: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Event Details")
System.ComponentModel.DescriptionAttribute("Gets or sets the Location of the event.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Location : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Event Details")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the Location of the event.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_Location();
public: __property void set_Location(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Event Details")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the Location of the event.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ Location {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventBase Class
WebSchedulerEventBase Members


Mode Property

[image]
Intersoft WebScheduler Documentation
Mode Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventBase Class : Mode Property

Glossary Item Box

Specifies the event's Mode. Specifies the EventBase's mode.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the event's Mode.")>
<System.ComponentModel.CategoryAttribute("Event Details")>
Public Property Mode As WebSchedulerImportanceMode
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventBase
Dim value As WebSchedulerImportanceMode

instance.Mode = value

value = instance.Mode
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the event's Mode.")]
[System.ComponentModel.CategoryAttribute("Event Details")]
public WebSchedulerImportanceMode Mode {get; set;}
Delphi
public read-write property Mode: WebSchedulerImportanceMode;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the event's Mode.")
System.ComponentModel.CategoryAttribute("Event Details")
public function get,set Mode : WebSchedulerImportanceMode
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the event's Mode.")]
[System.ComponentModel.CategoryAttribute("Event Details")]
public: __property WebSchedulerImportanceMode get_Mode();
public: __property void set_Mode(
   WebSchedulerImportanceMode value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the event's Mode.")]
[System.ComponentModel.CategoryAttribute("Event Details")]
public:
property WebSchedulerImportanceMode Mode {
   WebSchedulerImportanceMode get();
   void set (    WebSchedulerImportanceMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventBase Class
WebSchedulerEventBase Members


Name Property

[image]
Intersoft WebScheduler Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventBase Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
Public Overrides Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventBase
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public override System.string Name {get; set;}
Delphi
public read-write property Name: System.String; override;
JScript
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
public override function get,set Name : System.String
Managed Extensions for C++
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public: __property System.string* get_Name() override;
public: __property void set_Name(
   System.string* value
) override;
C++/CLI
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public:
property System.String^ Name {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventBase Class
WebSchedulerEventBase Members


ReminderTimeSpan Property

[image]
Intersoft WebScheduler Documentation
ReminderTimeSpan Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventBase Class : ReminderTimeSpan Property

Glossary Item Box

Specifies the event's ReminderTimeSpan. Specifies the EventBase's ReminderTimeSpan.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the event's ReminderTimeSpan.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Event Details")>
Public Property ReminderTimeSpan As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventBase
Dim value As System.Integer

instance.ReminderTimeSpan = value

value = instance.ReminderTimeSpan
C#
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the event's ReminderTimeSpan.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Event Details")]
public System.int ReminderTimeSpan {get; set;}
Delphi
public read-write property ReminderTimeSpan: System.Integer;
JScript
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the event's ReminderTimeSpan.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Event Details")
public function get,set ReminderTimeSpan : System.int
Managed Extensions for C++
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the event's ReminderTimeSpan.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Event Details")]
public: __property System.int get_ReminderTimeSpan();
public: __property void set_ReminderTimeSpan(
   System.int value
);
C++/CLI
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the event's ReminderTimeSpan.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Event Details")]
public:
property System.int ReminderTimeSpan {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventBase Class
WebSchedulerEventBase Members


ResourceID Property

[image]
Intersoft WebScheduler Documentation
ResourceID Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventBase Class : ResourceID Property

Glossary Item Box

Gets or sets the ResourceID. Specifies the EventBase's ResourceID.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Event Details")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the ResourceID.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ResourceID As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventBase
Dim value As System.Integer

instance.ResourceID = value

value = instance.ResourceID
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Event Details")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the ResourceID.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.int ResourceID {get; set;}
Delphi
public read-write property ResourceID: System.Integer;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Event Details")
System.ComponentModel.DescriptionAttribute("Gets or sets the ResourceID.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ResourceID : System.int
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Event Details")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the ResourceID.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.int get_ResourceID();
public: __property void set_ResourceID(
   System.int value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Event Details")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the ResourceID.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.int ResourceID {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventBase Class
WebSchedulerEventBase Members


StartTime Property

[image]
Intersoft WebScheduler Documentation
StartTime Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventBase Class : StartTime Property

Glossary Item Box

Gets or sets the StartTime of the event. Specifies the EventBase's StartTime.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the StartTime of the event.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
<System.ComponentModel.CategoryAttribute("Event Details")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property StartTime As System.Date
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventBase
Dim value As System.Date

instance.StartTime = value

value = instance.StartTime
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the StartTime of the event.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.CategoryAttribute("Event Details")]
[System.ComponentModel.DefaultValueAttribute()]
public System.DateTime StartTime {get; set;}
Delphi
public read-write property StartTime: System.DateTime;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the StartTime of the event.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
System.ComponentModel.CategoryAttribute("Event Details")
System.ComponentModel.DefaultValueAttribute()
public function get,set StartTime : System.DateTime
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the StartTime of the event.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.CategoryAttribute("Event Details")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.DateTime get_StartTime();
public: __property void set_StartTime(
   System.DateTime value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the StartTime of the event.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.CategoryAttribute("Event Details")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.DateTime StartTime {
   System.DateTime get();
   void set (    System.DateTime value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventBase Class
WebSchedulerEventBase Members


Subject Property

[image]
Intersoft WebScheduler Documentation
Subject Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventBase Class : Subject Property

Glossary Item Box

Gets or sets the Subject of the event. Specifies the EventBase's subject.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the Subject of the event.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
<System.ComponentModel.CategoryAttribute("Event Details")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Subject As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventBase
Dim value As System.String

instance.Subject = value

value = instance.Subject
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the Subject of the event.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.CategoryAttribute("Event Details")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Subject {get; set;}
Delphi
public read-write property Subject: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the Subject of the event.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
System.ComponentModel.CategoryAttribute("Event Details")
System.ComponentModel.DefaultValueAttribute()
public function get,set Subject : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the Subject of the event.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.CategoryAttribute("Event Details")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Subject();
public: __property void set_Subject(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the Subject of the event.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.CategoryAttribute("Event Details")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Subject {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventBase Class
WebSchedulerEventBase Members


Tooltip Property

[image]
Intersoft WebScheduler Documentation
Tooltip Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventBase Class : Tooltip Property

Glossary Item Box

Specifies the event's ToolTip.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Event Details")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the event's Tooltip.")>
Public Property Tooltip As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventBase
Dim value As System.String

instance.Tooltip = value

value = instance.Tooltip
C#
[System.ComponentModel.CategoryAttribute("Event Details")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the event's Tooltip.")]
public System.string Tooltip {get; set;}
Delphi
public read-write property Tooltip: System.String;
JScript
System.ComponentModel.CategoryAttribute("Event Details")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the event's Tooltip.")
public function get,set Tooltip : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Event Details")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the event's Tooltip.")]
public: __property System.string* get_Tooltip();
public: __property void set_Tooltip(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Event Details")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the event's Tooltip.")]
public:
property System.String^ Tooltip {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventBase Class
WebSchedulerEventBase Members


WebSchedulerEventCollection Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerEventCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerEventCollection Class

Glossary Item Box

A collection of events used by WebScheduler.

Object Model

WebSchedulerEventCollection Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerEventCollection
   Inherits ISNet.WebUI.ISGenericCollectionBase(Of WebSchedulerEventBase)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventCollection
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerEventCollection : ISNet.WebUI.ISGenericCollectionBase<WebSchedulerEventBase>
Delphi
public class WebSchedulerEventCollection = class(ISNet.WebUI.ISGenericCollectionBase)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerEventCollection extends ISNet.WebUI.ISGenericCollectionBase
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerEventCollection : public ISNet.WebUI.ISGenericCollectionBase<WebSchedulerEventBase>
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerEventCollection : public ISNet.WebUI.ISGenericCollectionBase<WebSchedulerEventBase>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
ISNet.WebUI.ISCollectionBase<T>
ISNet.WebUI.ISGenericCollectionBase<T>
ISNet.WebUI.WebScheduler.WebSchedulerEventCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventCollection Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerEventCollection Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerEventCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerEventCollection Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerEventCollection.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerEventCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerEventBase>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerEventBase>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerEventBase>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebSchedulerEventCollection Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerEventCollection Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerEventCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventCollection Class : WebSchedulerEventCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerEventCollection()
C#
public WebSchedulerEventCollection()
Delphi
public WebSchedulerEventCollection();
JScript
public function WebSchedulerEventCollection();
Managed Extensions for C++
public: WebSchedulerEventCollection();
C++/CLI
public:
WebSchedulerEventCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventCollection Class
WebSchedulerEventCollection Members


WebSchedulerEventsBinding Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerEventsBinding Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerEventsBinding Class

Glossary Item Box

A collection of settings used for events binding in WebScheduler.

Object Model

WebSchedulerEventsBinding Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerEventsBinding
   Inherits WebSchedulerEventsBindingBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBinding
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerEventsBinding : WebSchedulerEventsBindingBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSchedulerEventsBinding = class(WebSchedulerEventsBindingBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerEventsBinding extends WebSchedulerEventsBindingBase implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerEventsBinding : public WebSchedulerEventsBindingBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerEventsBinding : public WebSchedulerEventsBindingBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase
ISNet.WebUI.WebScheduler.WebSchedulerEventsBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBinding Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerEventsBinding Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerEventsBinding Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerEventsBinding Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerEventsBinding.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerEventsBinding Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllDayEventField | Specifies the AllDayEvent Field. Specifies the AllDayEvent field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | CategoryIDField | Specifies the CategoryID Field. Specifies the CategoryID field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | DescriptionField | Specifies the Description Field. Specifies the Description field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | EndTimeField | Specifies the EndTime Field. Specifies the EndTime field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | EventIDField | Specifies the EventID Field. Specifies the EventID field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | LocationField | Specifies the Location Field. Specifies the Location field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | ModeField | Specifies the Mode Field. Specifies the Mode field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | ReminderTimeSpanField | Specifies the ReminderTimeSpan Field. Specifies the ReminderTimeSpan field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | ResourceIDField | Specifies the ResourceID Field. Specifies the ResourceID field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | StartTimeField | Specifies the StartTime Field. Specifies the StartTime field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | SubjectField | Specifies the Subject Field. Specifies the Subject field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerEventsBinding Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerEventsBinding Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerEventsBinding Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBinding Class : WebSchedulerEventsBinding Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerEventsBinding()
C#
public WebSchedulerEventsBinding()
Delphi
public WebSchedulerEventsBinding();
JScript
public function WebSchedulerEventsBinding();
Managed Extensions for C++
public: WebSchedulerEventsBinding();
C++/CLI
public:
WebSchedulerEventsBinding();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBinding Class
WebSchedulerEventsBinding Members


WebSchedulerEventsBinding Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerEventsBinding Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerEventsBinding Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerEventsBinding members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerEventsBinding Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBinding Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBinding
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBinding Class
WebSchedulerEventsBinding Members


WebSchedulerEventsBindingBase Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerEventsBindingBase Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerEventsBindingBase Class

Glossary Item Box

Base class of the entire data binding events, such as CategoryBinding, EventsBinding, RecurrenceBinding, RecurringEventsBinding and ResourcesBinding.

Object Model

WebSchedulerEventsBindingBase Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerEventsBindingBase
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBindingBase
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerEventsBindingBase : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSchedulerEventsBindingBase = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerEventsBindingBase extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerEventsBindingBase : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerEventsBindingBase : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase
ISNet.WebUI.WebScheduler.WebSchedulerEventsBinding
ISNet.WebUI.WebScheduler.WebSchedulerRecurringEventBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBindingBase Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerEventsBindingBase Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerEventsBindingBase Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerEventsBindingBase Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerEventsBindingBase.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerEventsBindingBase Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllDayEventField | Specifies the AllDayEvent Field. Specifies the AllDayEvent field.
Public Property | CategoryIDField | Specifies the CategoryID Field. Specifies the CategoryID field.
Public Property | DescriptionField | Specifies the Description Field. Specifies the Description field.
Public Property | EndTimeField | Specifies the EndTime Field. Specifies the EndTime field.
Public Property | EventIDField | Specifies the EventID Field. Specifies the EventID field.
Public Property | LocationField | Specifies the Location Field. Specifies the Location field.
Public Property | ModeField | Specifies the Mode Field. Specifies the Mode field.
Public Property | ReminderTimeSpanField | Specifies the ReminderTimeSpan Field. Specifies the ReminderTimeSpan field.
Public Property | ResourceIDField | Specifies the ResourceID Field. Specifies the ResourceID field.
Public Property | StartTimeField | Specifies the StartTime Field. Specifies the StartTime field.
Public Property | SubjectField | Specifies the Subject Field. Specifies the Subject field.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerEventsBindingBase Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerEventsBindingBase Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerEventsBindingBase Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBindingBase Class : WebSchedulerEventsBindingBase Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerEventsBindingBase()
C#
public WebSchedulerEventsBindingBase()
Delphi
public WebSchedulerEventsBindingBase();
JScript
public function WebSchedulerEventsBindingBase();
Managed Extensions for C++
public: WebSchedulerEventsBindingBase();
C++/CLI
public:
WebSchedulerEventsBindingBase();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBindingBase Class
WebSchedulerEventsBindingBase Members


WebSchedulerEventsBindingBase Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerEventsBindingBase Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerEventsBindingBase Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerEventsBindingBase members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerEventsBindingBase Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBindingBase Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBindingBase
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBindingBase Class
WebSchedulerEventsBindingBase Members


WebSchedulerEventsBindingBase Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerEventsBindingBase Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerEventsBindingBase Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerEventsBindingBase members.

Public Properties

 | Name | Description
Public Property | AllDayEventField | Specifies the AllDayEvent Field. Specifies the AllDayEvent field.
Public Property | CategoryIDField | Specifies the CategoryID Field. Specifies the CategoryID field.
Public Property | DescriptionField | Specifies the Description Field. Specifies the Description field.
Public Property | EndTimeField | Specifies the EndTime Field. Specifies the EndTime field.
Public Property | EventIDField | Specifies the EventID Field. Specifies the EventID field.
Public Property | LocationField | Specifies the Location Field. Specifies the Location field.
Public Property | ModeField | Specifies the Mode Field. Specifies the Mode field.
Public Property | ReminderTimeSpanField | Specifies the ReminderTimeSpan Field. Specifies the ReminderTimeSpan field.
Public Property | ResourceIDField | Specifies the ResourceID Field. Specifies the ResourceID field.
Public Property | StartTimeField | Specifies the StartTime Field. Specifies the StartTime field.
Public Property | SubjectField | Specifies the Subject Field. Specifies the Subject field.
Top

See Also

Reference

WebSchedulerEventsBindingBase Class
ISNet.WebUI.WebScheduler Namespace


AllDayEventField Property

[image]
Intersoft WebScheduler Documentation
AllDayEventField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBindingBase Class : AllDayEventField Property

Glossary Item Box

Specifies the AllDayEvent Field. Specifies the AllDayEvent field.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the AllDayEvent Field.")>
<System.ComponentModel.CategoryAttribute("Binding")>
Public Property AllDayEventField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBindingBase
Dim value As System.String

instance.AllDayEventField = value

value = instance.AllDayEventField
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the AllDayEvent Field.")]
[System.ComponentModel.CategoryAttribute("Binding")]
public System.string AllDayEventField {get; set;}
Delphi
public read-write property AllDayEventField: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the AllDayEvent Field.")
System.ComponentModel.CategoryAttribute("Binding")
public function get,set AllDayEventField : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the AllDayEvent Field.")]
[System.ComponentModel.CategoryAttribute("Binding")]
public: __property System.string* get_AllDayEventField();
public: __property void set_AllDayEventField(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the AllDayEvent Field.")]
[System.ComponentModel.CategoryAttribute("Binding")]
public:
property System.String^ AllDayEventField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBindingBase Class
WebSchedulerEventsBindingBase Members


CategoryIDField Property

[image]
Intersoft WebScheduler Documentation
CategoryIDField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBindingBase Class : CategoryIDField Property

Glossary Item Box

Specifies the CategoryID Field. Specifies the CategoryID field.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the CategoryID Field.")>
<System.ComponentModel.CategoryAttribute("Binding")>
Public Property CategoryIDField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBindingBase
Dim value As System.String

instance.CategoryIDField = value

value = instance.CategoryIDField
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the CategoryID Field.")]
[System.ComponentModel.CategoryAttribute("Binding")]
public System.string CategoryIDField {get; set;}
Delphi
public read-write property CategoryIDField: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the CategoryID Field.")
System.ComponentModel.CategoryAttribute("Binding")
public function get,set CategoryIDField : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the CategoryID Field.")]
[System.ComponentModel.CategoryAttribute("Binding")]
public: __property System.string* get_CategoryIDField();
public: __property void set_CategoryIDField(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the CategoryID Field.")]
[System.ComponentModel.CategoryAttribute("Binding")]
public:
property System.String^ CategoryIDField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBindingBase Class
WebSchedulerEventsBindingBase Members


DescriptionField Property

[image]
Intersoft WebScheduler Documentation
DescriptionField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBindingBase Class : DescriptionField Property

Glossary Item Box

Specifies the Description Field. Specifies the Description field.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Binding")>
<System.ComponentModel.DescriptionAttribute("Specifies the Description Field.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property DescriptionField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBindingBase
Dim value As System.String

instance.DescriptionField = value

value = instance.DescriptionField
C#
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Specifies the Description Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string DescriptionField {get; set;}
Delphi
public read-write property DescriptionField: System.String;
JScript
System.ComponentModel.CategoryAttribute("Binding")
System.ComponentModel.DescriptionAttribute("Specifies the Description Field.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set DescriptionField : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Specifies the Description Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_DescriptionField();
public: __property void set_DescriptionField(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Specifies the Description Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ DescriptionField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBindingBase Class
WebSchedulerEventsBindingBase Members


EndTimeField Property

[image]
Intersoft WebScheduler Documentation
EndTimeField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBindingBase Class : EndTimeField Property

Glossary Item Box

Specifies the EndTime Field. Specifies the EndTime field.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the EndTime Field.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.CategoryAttribute("Binding")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property EndTimeField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBindingBase
Dim value As System.String

instance.EndTimeField = value

value = instance.EndTimeField
C#
[System.ComponentModel.DescriptionAttribute("Specifies the EndTime Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string EndTimeField {get; set;}
Delphi
public read-write property EndTimeField: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the EndTime Field.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.CategoryAttribute("Binding")
System.ComponentModel.DefaultValueAttribute()
public function get,set EndTimeField : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the EndTime Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_EndTimeField();
public: __property void set_EndTimeField(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the EndTime Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ EndTimeField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBindingBase Class
WebSchedulerEventsBindingBase Members


EventIDField Property

[image]
Intersoft WebScheduler Documentation
EventIDField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBindingBase Class : EventIDField Property

Glossary Item Box

Specifies the EventID Field. Specifies the EventID field.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the EventID Field.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Binding")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property EventIDField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBindingBase
Dim value As System.String

instance.EventIDField = value

value = instance.EventIDField
C#
[System.ComponentModel.DescriptionAttribute("Specifies the EventID Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string EventIDField {get; set;}
Delphi
public read-write property EventIDField: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the EventID Field.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Binding")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.DefaultValueAttribute()
public function get,set EventIDField : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the EventID Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_EventIDField();
public: __property void set_EventIDField(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the EventID Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ EventIDField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBindingBase Class
WebSchedulerEventsBindingBase Members


LocationField Property

[image]
Intersoft WebScheduler Documentation
LocationField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBindingBase Class : LocationField Property

Glossary Item Box

Specifies the Location Field. Specifies the Location field.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the Location Field.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.CategoryAttribute("Binding")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property LocationField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBindingBase
Dim value As System.String

instance.LocationField = value

value = instance.LocationField
C#
[System.ComponentModel.DescriptionAttribute("Specifies the Location Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string LocationField {get; set;}
Delphi
public read-write property LocationField: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the Location Field.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.CategoryAttribute("Binding")
System.ComponentModel.DefaultValueAttribute()
public function get,set LocationField : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the Location Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_LocationField();
public: __property void set_LocationField(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the Location Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ LocationField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBindingBase Class
WebSchedulerEventsBindingBase Members


ModeField Property

[image]
Intersoft WebScheduler Documentation
ModeField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBindingBase Class : ModeField Property

Glossary Item Box

Specifies the Mode Field. Specifies the Mode field.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Binding")>
<System.ComponentModel.DescriptionAttribute("Specifies the Mode Field.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ModeField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBindingBase
Dim value As System.String

instance.ModeField = value

value = instance.ModeField
C#
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Specifies the Mode Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string ModeField {get; set;}
Delphi
public read-write property ModeField: System.String;
JScript
System.ComponentModel.CategoryAttribute("Binding")
System.ComponentModel.DescriptionAttribute("Specifies the Mode Field.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ModeField : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Specifies the Mode Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_ModeField();
public: __property void set_ModeField(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Specifies the Mode Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ ModeField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBindingBase Class
WebSchedulerEventsBindingBase Members


ReminderTimeSpanField Property

[image]
Intersoft WebScheduler Documentation
ReminderTimeSpanField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBindingBase Class : ReminderTimeSpanField Property

Glossary Item Box

Specifies the ReminderTimeSpan Field. Specifies the ReminderTimeSpan field.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the ReminderTimeSpan Field.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Binding")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ReminderTimeSpanField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBindingBase
Dim value As System.String

instance.ReminderTimeSpanField = value

value = instance.ReminderTimeSpanField
C#
[System.ComponentModel.DescriptionAttribute("Specifies the ReminderTimeSpan Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string ReminderTimeSpanField {get; set;}
Delphi
public read-write property ReminderTimeSpanField: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the ReminderTimeSpan Field.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Binding")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ReminderTimeSpanField : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the ReminderTimeSpan Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_ReminderTimeSpanField();
public: __property void set_ReminderTimeSpanField(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the ReminderTimeSpan Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ ReminderTimeSpanField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBindingBase Class
WebSchedulerEventsBindingBase Members


ResourceIDField Property

[image]
Intersoft WebScheduler Documentation
ResourceIDField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBindingBase Class : ResourceIDField Property

Glossary Item Box

Specifies the ResourceID Field. Specifies the ResourceID field.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Binding")>
<System.ComponentModel.DescriptionAttribute("Specifies the ResourceID Field.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ResourceIDField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBindingBase
Dim value As System.String

instance.ResourceIDField = value

value = instance.ResourceIDField
C#
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Specifies the ResourceID Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string ResourceIDField {get; set;}
Delphi
public read-write property ResourceIDField: System.String;
JScript
System.ComponentModel.CategoryAttribute("Binding")
System.ComponentModel.DescriptionAttribute("Specifies the ResourceID Field.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ResourceIDField : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Specifies the ResourceID Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_ResourceIDField();
public: __property void set_ResourceIDField(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Specifies the ResourceID Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ ResourceIDField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBindingBase Class
WebSchedulerEventsBindingBase Members


StartTimeField Property

[image]
Intersoft WebScheduler Documentation
StartTimeField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBindingBase Class : StartTimeField Property

Glossary Item Box

Specifies the StartTime Field. Specifies the StartTime field.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the StartTime Field.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.CategoryAttribute("Binding")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property StartTimeField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBindingBase
Dim value As System.String

instance.StartTimeField = value

value = instance.StartTimeField
C#
[System.ComponentModel.DescriptionAttribute("Specifies the StartTime Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string StartTimeField {get; set;}
Delphi
public read-write property StartTimeField: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the StartTime Field.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.CategoryAttribute("Binding")
System.ComponentModel.DefaultValueAttribute()
public function get,set StartTimeField : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the StartTime Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_StartTimeField();
public: __property void set_StartTimeField(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the StartTime Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ StartTimeField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBindingBase Class
WebSchedulerEventsBindingBase Members


SubjectField Property

[image]
Intersoft WebScheduler Documentation
SubjectField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBindingBase Class : SubjectField Property

Glossary Item Box

Specifies the Subject Field. Specifies the Subject field.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Binding")>
<System.ComponentModel.DescriptionAttribute("Specifies the Subject Field.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property SubjectField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBindingBase
Dim value As System.String

instance.SubjectField = value

value = instance.SubjectField
C#
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Specifies the Subject Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string SubjectField {get; set;}
Delphi
public read-write property SubjectField: System.String;
JScript
System.ComponentModel.CategoryAttribute("Binding")
System.ComponentModel.DescriptionAttribute("Specifies the Subject Field.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set SubjectField : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Specifies the Subject Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_SubjectField();
public: __property void set_SubjectField(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Specifies the Subject Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ SubjectField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBindingBase Class
WebSchedulerEventsBindingBase Members


WebSchedulerExportEventArgs Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerExportEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerExportEventArgs Class

Glossary Item Box

Class that allows users to use their own exporting codes or module to handle exporting functionality.

Object Model

WebSchedulerExportEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class WebSchedulerExportEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerExportEventArgs
C#
public class WebSchedulerExportEventArgs : System.EventArgs
Delphi
public class WebSchedulerExportEventArgs = class(System.EventArgs)
JScript
public class WebSchedulerExportEventArgs extends System.EventArgs
Managed Extensions for C++
public __gc class WebSchedulerExportEventArgs : public System.EventArgs
C++/CLI
public ref class WebSchedulerExportEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebScheduler.WebSchedulerExportEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerExportEventArgs Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerExportEventArgs Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerExportEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerExportEventArgs Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerExportEventArgs.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerExportEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | EventsDataSource | DataSource events containing raw data which is going to be exported.
Public Property | RecurringEventsDataSource | DataSource RecurringEvents containing raw data which is going to be exported.
Public Property | ReportInfo | The WebSchedulerReportInfo that is obtained from the data which is going to be exported.
Top

See Also

Reference

WebSchedulerExportEventArgs Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerExportEventArgs Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerExportEventArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerExportEventArgs Class : WebSchedulerExportEventArgs Constructor

eventsDataSource
recurringEventsDataSource
reportInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal eventsDataSource As System.Object, _
   ByVal recurringEventsDataSource As System.Object, _
   ByVal reportInfo As WebSchedulerReportInfo _
)
Visual Basic (Usage) Copy Code
Dim eventsDataSource As System.Object
Dim recurringEventsDataSource As System.Object
Dim reportInfo As WebSchedulerReportInfo

Dim instance As New WebSchedulerExportEventArgs(eventsDataSource, recurringEventsDataSource, reportInfo)
C#
public WebSchedulerExportEventArgs(
   System.object eventsDataSource,
   System.object recurringEventsDataSource,
   WebSchedulerReportInfo reportInfo
)
Delphi
public WebSchedulerExportEventArgs(
    eventsDataSource: System.TObject;
    recurringEventsDataSource: System.TObject;
    reportInfo: WebSchedulerReportInfo
);
JScript
public function WebSchedulerExportEventArgs(
   eventsDataSource : System.Object,
   recurringEventsDataSource : System.Object,
   reportInfo : WebSchedulerReportInfo
);
Managed Extensions for C++
public: WebSchedulerExportEventArgs(
   System.Object* eventsDataSource,
   System.Object* recurringEventsDataSource,
   WebSchedulerReportInfo* reportInfo
)
C++/CLI
public:
WebSchedulerExportEventArgs(
   System.Object^ eventsDataSource,
   System.Object^ recurringEventsDataSource,
   WebSchedulerReportInfo^ reportInfo
)

Parameters

eventsDataSource
recurringEventsDataSource
reportInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerExportEventArgs Class
WebSchedulerExportEventArgs Members


WebSchedulerExportEventArgs Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerExportEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerExportEventArgs Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerExportEventArgs members.

Public Properties

 | Name | Description
Public Property | EventsDataSource | DataSource events containing raw data which is going to be exported.
Public Property | RecurringEventsDataSource | DataSource RecurringEvents containing raw data which is going to be exported.
Public Property | ReportInfo | The WebSchedulerReportInfo that is obtained from the data which is going to be exported.
Top

See Also

Reference

WebSchedulerExportEventArgs Class
ISNet.WebUI.WebScheduler Namespace


EventsDataSource Property

[image]
Intersoft WebScheduler Documentation
EventsDataSource Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerExportEventArgs Class : EventsDataSource Property

Glossary Item Box

DataSource events containing raw data which is going to be exported.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EventsDataSource As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerExportEventArgs
Dim value As System.Object

value = instance.EventsDataSource
C#
public System.object EventsDataSource {get;}
Delphi
public read-only property EventsDataSource: System.TObject;
JScript
public function get EventsDataSource : System.Object
Managed Extensions for C++
public: __property System.Object* get_EventsDataSource();
C++/CLI
public:
property System.Object^ EventsDataSource {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerExportEventArgs Class
WebSchedulerExportEventArgs Members


RecurringEventsDataSource Property

[image]
Intersoft WebScheduler Documentation
RecurringEventsDataSource Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerExportEventArgs Class : RecurringEventsDataSource Property

Glossary Item Box

DataSource RecurringEvents containing raw data which is going to be exported.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RecurringEventsDataSource As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerExportEventArgs
Dim value As System.Object

value = instance.RecurringEventsDataSource
C#
public System.object RecurringEventsDataSource {get;}
Delphi
public read-only property RecurringEventsDataSource: System.TObject;
JScript
public function get RecurringEventsDataSource : System.Object
Managed Extensions for C++
public: __property System.Object* get_RecurringEventsDataSource();
C++/CLI
public:
property System.Object^ RecurringEventsDataSource {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerExportEventArgs Class
WebSchedulerExportEventArgs Members


ReportInfo Property

[image]
Intersoft WebScheduler Documentation
ReportInfo Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerExportEventArgs Class : ReportInfo Property

Glossary Item Box

The WebSchedulerReportInfo that is obtained from the data which is going to be exported.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportInfo As WebSchedulerReportInfo
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerExportEventArgs
Dim value As WebSchedulerReportInfo

value = instance.ReportInfo
C#
public WebSchedulerReportInfo ReportInfo {get;}
Delphi
public read-only property ReportInfo: WebSchedulerReportInfo;
JScript
public function get ReportInfo : WebSchedulerReportInfo
Managed Extensions for C++
public: __property WebSchedulerReportInfo* get_ReportInfo();
C++/CLI
public:
property WebSchedulerReportInfo^ ReportInfo {
   WebSchedulerReportInfo^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerExportEventArgs Class
WebSchedulerExportEventArgs Members


WebSchedulerGridLineStyle Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerGridLineStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerGridLineStyle Class

Glossary Item Box

A collection of styles used for grid line.

Object Model

WebSchedulerGridLineStyle Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerGridLineStyle
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerGridLineStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerGridLineStyle : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSchedulerGridLineStyle = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerGridLineStyle extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerGridLineStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerGridLineStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebScheduler.WebSchedulerGridLineStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerGridLineStyle Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerGridLineStyle Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerGridLineStyle Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerGridLineStyle Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerGridLineStyle.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerGridLineStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | FrameLineStyle | Contains interactive style for Day/Week view FrameLine. Contains interactive style for Day/Week view FrameLine.
Public Property | SoftLineStyle | Contains interactive style for Day/Week view SoftLine. Contains interactive style for Day/Week view SoftLine.
Public Property | SolidLineStyle | Contains interactive style for Day/Week view SolidLine. Contains interactive style for Day/Week view SolidLine.
Public Property | TodayFrameLineStyle | Contains interactive style for Day/Week view TodayFrameLine. Contains interactive style for Day/Week view TodayFrameLine.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerGridLineStyle Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerGridLineStyle Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerGridLineStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerGridLineStyle Class : WebSchedulerGridLineStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerGridLineStyle()
C#
public WebSchedulerGridLineStyle()
Delphi
public WebSchedulerGridLineStyle();
JScript
public function WebSchedulerGridLineStyle();
Managed Extensions for C++
public: WebSchedulerGridLineStyle();
C++/CLI
public:
WebSchedulerGridLineStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerGridLineStyle Class
WebSchedulerGridLineStyle Members


WebSchedulerGridLineStyle Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerGridLineStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerGridLineStyle Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerGridLineStyle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerGridLineStyle Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerGridLineStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerGridLineStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerGridLineStyle Class
WebSchedulerGridLineStyle Members


WebSchedulerGridLineStyle Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerGridLineStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerGridLineStyle Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerGridLineStyle members.

Public Properties

 | Name | Description
Public Property | FrameLineStyle | Contains interactive style for Day/Week view FrameLine. Contains interactive style for Day/Week view FrameLine.
Public Property | SoftLineStyle | Contains interactive style for Day/Week view SoftLine. Contains interactive style for Day/Week view SoftLine.
Public Property | SolidLineStyle | Contains interactive style for Day/Week view SolidLine. Contains interactive style for Day/Week view SolidLine.
Public Property | TodayFrameLineStyle | Contains interactive style for Day/Week view TodayFrameLine. Contains interactive style for Day/Week view TodayFrameLine.
Top

See Also

Reference

WebSchedulerGridLineStyle Class
ISNet.WebUI.WebScheduler Namespace


FrameLineStyle Property

[image]
Intersoft WebScheduler Documentation
FrameLineStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerGridLineStyle Class : FrameLineStyle Property

Glossary Item Box

Contains interactive style for Day/Week view FrameLine. Contains interactive style for Day/Week view FrameLine.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Day/Week view FrameLine.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Grid Line Style")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property FrameLineStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerGridLineStyle
Dim value As ISNet.WebUI.WebStyle

instance.FrameLineStyle = value

value = instance.FrameLineStyle
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Day/Week view FrameLine.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Grid Line Style")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ISNet.WebUI.WebStyle FrameLineStyle {get; set;}
Delphi
public read-write property FrameLineStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DescriptionAttribute("Contains interactive style for Day/Week view FrameLine.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Grid Line Style")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set FrameLineStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Day/Week view FrameLine.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Grid Line Style")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ISNet.WebUI.WebStyle* get_FrameLineStyle();
public: __property void set_FrameLineStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Day/Week view FrameLine.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Grid Line Style")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ISNet.WebUI.WebStyle^ FrameLineStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerGridLineStyle Class
WebSchedulerGridLineStyle Members


SoftLineStyle Property

[image]
Intersoft WebScheduler Documentation
SoftLineStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerGridLineStyle Class : SoftLineStyle Property

Glossary Item Box

Contains interactive style for Day/Week view SoftLine. Contains interactive style for Day/Week view SoftLine.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Day/Week SoftLine.")>
<System.ComponentModel.CategoryAttribute("Grid Line Style")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property SoftLineStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerGridLineStyle
Dim value As ISNet.WebUI.WebStyle

instance.SoftLineStyle = value

value = instance.SoftLineStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Day/Week SoftLine.")]
[System.ComponentModel.CategoryAttribute("Grid Line Style")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
public ISNet.WebUI.WebStyle SoftLineStyle {get; set;}
Delphi
public read-write property SoftLineStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.DescriptionAttribute("Contains interactive style for Day/Week SoftLine.")
System.ComponentModel.CategoryAttribute("Grid Line Style")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute()
public function get,set SoftLineStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Day/Week SoftLine.")]
[System.ComponentModel.CategoryAttribute("Grid Line Style")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property ISNet.WebUI.WebStyle* get_SoftLineStyle();
public: __property void set_SoftLineStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Day/Week SoftLine.")]
[System.ComponentModel.CategoryAttribute("Grid Line Style")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property ISNet.WebUI.WebStyle^ SoftLineStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerGridLineStyle Class
WebSchedulerGridLineStyle Members


SolidLineStyle Property

[image]
Intersoft WebScheduler Documentation
SolidLineStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerGridLineStyle Class : SolidLineStyle Property

Glossary Item Box

Contains interactive style for Day/Week view SolidLine. Contains interactive style for Day/Week view SolidLine.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Day/Week view SolidLine.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Grid Line Style")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property SolidLineStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerGridLineStyle
Dim value As ISNet.WebUI.WebStyle

instance.SolidLineStyle = value

value = instance.SolidLineStyle
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Day/Week view SolidLine.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Grid Line Style")]
[System.ComponentModel.DefaultValueAttribute()]
public ISNet.WebUI.WebStyle SolidLineStyle {get; set;}
Delphi
public read-write property SolidLineStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DescriptionAttribute("Contains interactive style for Day/Week view SolidLine.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Grid Line Style")
System.ComponentModel.DefaultValueAttribute()
public function get,set SolidLineStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Day/Week view SolidLine.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Grid Line Style")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.WebStyle* get_SolidLineStyle();
public: __property void set_SolidLineStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Day/Week view SolidLine.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Grid Line Style")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.WebStyle^ SolidLineStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerGridLineStyle Class
WebSchedulerGridLineStyle Members


TodayFrameLineStyle Property

[image]
Intersoft WebScheduler Documentation
TodayFrameLineStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerGridLineStyle Class : TodayFrameLineStyle Property

Glossary Item Box

Contains interactive style for Day/Week view TodayFrameLine. Contains interactive style for Day/Week view TodayFrameLine.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Grid Line Style")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Day/Week view TodayFrameLine.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property TodayFrameLineStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerGridLineStyle
Dim value As ISNet.WebUI.WebStyle

instance.TodayFrameLineStyle = value

value = instance.TodayFrameLineStyle
C#
[System.ComponentModel.CategoryAttribute("Grid Line Style")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Day/Week view TodayFrameLine.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public ISNet.WebUI.WebStyle TodayFrameLineStyle {get; set;}
Delphi
public read-write property TodayFrameLineStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.CategoryAttribute("Grid Line Style")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DescriptionAttribute("Contains interactive style for Day/Week view TodayFrameLine.")
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set TodayFrameLineStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Grid Line Style")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Day/Week view TodayFrameLine.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.WebStyle* get_TodayFrameLineStyle();
public: __property void set_TodayFrameLineStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Grid Line Style")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Day/Week view TodayFrameLine.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.WebStyle^ TodayFrameLineStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerGridLineStyle Class
WebSchedulerGridLineStyle Members


WebSchedulerHoliday Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerHoliday Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerHoliday Class

Glossary Item Box

A collection of members in WebScheduler's holiday.

Object Model

WebSchedulerHoliday Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerHoliday
   Inherits ISNet.WebUI.NamedObjectBase2
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHoliday
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerHoliday : ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Delphi
public class WebSchedulerHoliday = class(ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerHoliday extends ISNet.WebUI.NamedObjectBase2 implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerHoliday : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerHoliday : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase2
ISNet.WebUI.WebScheduler.WebSchedulerHoliday

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHoliday Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerHoliday Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerHoliday Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerHoliday Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerHoliday.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerHoliday Constructor |
Top

Public Properties

 | Name | Description
Public Property | Date | Specifies the Date of the Holiday. Sets the holiday's date.
Public Property | Description | Specifies the Description of the Holiday. Sets the holiday's description.
Public Property | IsGeneral | Indicates whether the holiday will appear on the same date and same month, eventhough it is not the same year. Indicates whether IsGeneral is applied.
Public Property | Name | Overridden. Specifies the Name of the Holiday. Sets the holiday's name.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerHoliday Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerHoliday Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerHoliday Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHoliday Class : WebSchedulerHoliday Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerHoliday()
C#
public WebSchedulerHoliday()
Delphi
public WebSchedulerHoliday();
JScript
public function WebSchedulerHoliday();
Managed Extensions for C++
public: WebSchedulerHoliday();
C++/CLI
public:
WebSchedulerHoliday();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHoliday Class
WebSchedulerHoliday Members


WebSchedulerHoliday Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerHoliday Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerHoliday Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerHoliday members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerHoliday Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHoliday Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHoliday
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHoliday Class
WebSchedulerHoliday Members


WebSchedulerHoliday Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerHoliday Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerHoliday Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerHoliday members.

Public Properties

 | Name | Description
Public Property | Date | Specifies the Date of the Holiday. Sets the holiday's date.
Public Property | Description | Specifies the Description of the Holiday. Sets the holiday's description.
Public Property | IsGeneral | Indicates whether the holiday will appear on the same date and same month, eventhough it is not the same year. Indicates whether IsGeneral is applied.
Public Property | Name | Overridden. Specifies the Name of the Holiday. Sets the holiday's name.
Top

See Also

Reference

WebSchedulerHoliday Class
ISNet.WebUI.WebScheduler Namespace


Date Property

[image]
Intersoft WebScheduler Documentation
Date Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHoliday Class : Date Property

Glossary Item Box

Specifies the Date of the Holiday. Sets the holiday's date.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the Date of the Holiday.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Holiday")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Date As System.Date
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHoliday
Dim value As System.Date

instance.Date = value

value = instance.Date
C#
[System.ComponentModel.DescriptionAttribute("Specifies the Date of the Holiday.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Holiday")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.DateTime Date {get; set;}
Delphi
public read-write property Date: System.DateTime;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the Date of the Holiday.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Holiday")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Date : System.DateTime
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the Date of the Holiday.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Holiday")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.DateTime get_Date();
public: __property void set_Date(
   System.DateTime value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the Date of the Holiday.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Holiday")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.DateTime Date {
   System.DateTime get();
   void set (    System.DateTime value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHoliday Class
WebSchedulerHoliday Members


Description Property

[image]
Intersoft WebScheduler Documentation
Description Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHoliday Class : Description Property

Glossary Item Box

Specifies the Description of the Holiday. Sets the holiday's description.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Holiday")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the Description of the Holiday.")>
Public Property Description As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHoliday
Dim value As System.String

instance.Description = value

value = instance.Description
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Holiday")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the Description of the Holiday.")]
public System.string Description {get; set;}
Delphi
public read-write property Description: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Holiday")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the Description of the Holiday.")
public function get,set Description : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Holiday")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the Description of the Holiday.")]
public: __property System.string* get_Description();
public: __property void set_Description(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Holiday")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the Description of the Holiday.")]
public:
property System.String^ Description {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHoliday Class
WebSchedulerHoliday Members


IsGeneral Property

[image]
Intersoft WebScheduler Documentation
IsGeneral Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHoliday Class : IsGeneral Property

Glossary Item Box

Indicates whether the holiday will appear on the same date and same month, eventhough it is not the same year. Indicates whether IsGeneral is applied.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Indicates whether the holiday will appear on the same date and same month, eventhough it is not the same year.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Holiday")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property IsGeneral As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHoliday
Dim value As System.Boolean

instance.IsGeneral = value

value = instance.IsGeneral
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Indicates whether the holiday will appear on the same date and same month, eventhough it is not the same year.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Holiday")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool IsGeneral {get; set;}
Delphi
public read-write property IsGeneral: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Indicates whether the holiday will appear on the same date and same month, eventhough it is not the same year.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Holiday")
System.ComponentModel.DefaultValueAttribute()
public function get,set IsGeneral : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Indicates whether the holiday will appear on the same date and same month, eventhough it is not the same year.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Holiday")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_IsGeneral();
public: __property void set_IsGeneral(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Indicates whether the holiday will appear on the same date and same month, eventhough it is not the same year.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Holiday")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool IsGeneral {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHoliday Class
WebSchedulerHoliday Members


Name Property

[image]
Intersoft WebScheduler Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHoliday Class : Name Property

Glossary Item Box

Specifies the Name of the Holiday. Sets the holiday's name.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BrowsableAttribute(True)>
<System.ComponentModel.CategoryAttribute("Holiday")>
<System.ComponentModel.DescriptionAttribute("Specifies the Name of the Holiday.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
Public Overrides Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHoliday
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.CategoryAttribute("Holiday")]
[System.ComponentModel.DescriptionAttribute("Specifies the Name of the Holiday.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
public override System.string Name {get; set;}
Delphi
public read-write property Name: System.String; override;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.CategoryAttribute("Holiday")
System.ComponentModel.DescriptionAttribute("Specifies the Name of the Holiday.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
public override function get,set Name : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.CategoryAttribute("Holiday")]
[System.ComponentModel.DescriptionAttribute("Specifies the Name of the Holiday.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
public: __property System.string* get_Name() override;
public: __property void set_Name(
   System.string* value
) override;
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.CategoryAttribute("Holiday")]
[System.ComponentModel.DescriptionAttribute("Specifies the Name of the Holiday.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
public:
property System.String^ Name {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHoliday Class
WebSchedulerHoliday Members


WebSchedulerHolidayCollection Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerHolidayCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerHolidayCollection Class

Glossary Item Box

The data collection used by WebScheduler to determine holiday(s).

Object Model

WebSchedulerHolidayCollection Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerHolidayCollection
   Inherits ISNet.WebUI.ISGenericCollectionBase(Of WebSchedulerHoliday)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHolidayCollection
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerHolidayCollection : ISNet.WebUI.ISGenericCollectionBase<WebSchedulerHoliday>
Delphi
public class WebSchedulerHolidayCollection = class(ISNet.WebUI.ISGenericCollectionBase)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerHolidayCollection extends ISNet.WebUI.ISGenericCollectionBase
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerHolidayCollection : public ISNet.WebUI.ISGenericCollectionBase<WebSchedulerHoliday>
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerHolidayCollection : public ISNet.WebUI.ISGenericCollectionBase<WebSchedulerHoliday>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
ISNet.WebUI.ISCollectionBase<T>
ISNet.WebUI.ISGenericCollectionBase<T>
ISNet.WebUI.WebScheduler.WebSchedulerHolidayCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHolidayCollection Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerHolidayCollection Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerHolidayCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerHolidayCollection Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerHolidayCollection.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerHolidayCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerHoliday>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerHoliday>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerHoliday>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebSchedulerHolidayCollection Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerHolidayCollection Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerHolidayCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHolidayCollection Class : WebSchedulerHolidayCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerHolidayCollection()
C#
public WebSchedulerHolidayCollection()
Delphi
public WebSchedulerHolidayCollection();
JScript
public function WebSchedulerHolidayCollection();
Managed Extensions for C++
public: WebSchedulerHolidayCollection();
C++/CLI
public:
WebSchedulerHolidayCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHolidayCollection Class
WebSchedulerHolidayCollection Members


WebSchedulerImagesSettings Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerImagesSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerImagesSettings Class

Glossary Item Box

A collection of image settings for WebScheduler's object.

Object Model

WebSchedulerImagesSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerImagesSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerImagesSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSchedulerImagesSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerImagesSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerImagesSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerImagesSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebScheduler.WebSchedulerImagesSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerImagesSettings Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerImagesSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerImagesSettings Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerImagesSettings.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerImagesSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | BlackRecurrence | Gets or sets the default image used for recurrence image. Gets or sets the default image used for recurrence image.
Public Property | BlackRecurrenceException | Gets or sets the default image used for recurrence exception image. Gets or sets the default image used for recurrence exception image.
Public Property | BlackReminder | Gets or sets the default image used for reminder image. Gets or sets the default image used for reminder image.
Public Property | CollapseAll | Gets or sets the default image used for collapse all. Gets or sets the default image used for collapse all.
Public Property | Delete | Gets or sets the default image used for delete image in Agenda view. Gets or sets the default image used for delete image in Agenda view.
Public Property | Edit | Gets or sets the default image used for edit event image in Agenda view. Gets or sets the default image used for edit event image in Agenda view.
Public Property | ExpandAll | Gets or sets the default image used for expand all. Gets or sets the default image used for expand all.
Public Property | HighImportance | Gets or sets the default image used for high importance image in editing form.
Public Property | InProgress | Gets or sets the default image used for in progress indicator.
Public Property | LowImportance | Gets or sets the default image used for low importance image in editing form.
Public Property | NextArrow | Gets or sets the default image used for next arrow. Gets or sets the default image used for next arrow.
Public Property | NextCalendarArrow | Gets or sets the default image used for next image in Calendar. Gets or sets the default image used for next image in Calendar.
Public Property | PartialTimelineDisabledTimeIcon | Gets or sets the default image used for Timeline view partial disabled time icon.
Public Property | PreviousArrow | Gets or sets the default image used for previous arrow. Gets or sets the default image used for previous row.
Public Property | PreviousCalendarArrow | Gets or sets the default image used for previous image in Calendar. Gets or sets the default image used for previous image in Calendar.
Public Property | Recurrence | Gets or sets the default image used for recurrence image. Gets or sets the default image used for recurrence image.
Public Property | RecurrenceException | Gets or sets the default image used for recurrence exception image. Gets or sets the default image used for recurrence exception image.
Public Property | Reminder | Gets or sets the default image used for reminder image. Gets or sets the default image used for reminder image.
Public Property | ResourcesDownArrow | Gets or sets the default image used for down image in Resources. Gets or sets the default image used for down image in Resources.
Public Property | SmallHighImportance | Gets or sets the default image used for high importance image in event.
Public Property | SmallLowImportance | Gets or sets the default image used for low importance image in event.
Public Property | TimelineMoreIcon | Gets or sets the default image used for Timeline view more icon.
Public Property | TimelineZoomIn | Gets or sets the default image used for plus sign in Timeline view.
Public Property | TimelineZoomOut | Gets or sets the default image used for minus sign in Timeline view.
Public Property | ViewOnMyCalendar | Gets or sets the default image used for view on my calendar image in Agenda view. Gets or sets the default image used for view on my calendar image in Agenda view.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerImagesSettings Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerImagesSettings Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerImagesSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : WebSchedulerImagesSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerImagesSettings()
C#
public WebSchedulerImagesSettings()
Delphi
public WebSchedulerImagesSettings();
JScript
public function WebSchedulerImagesSettings();
Managed Extensions for C++
public: WebSchedulerImagesSettings();
C++/CLI
public:
WebSchedulerImagesSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


WebSchedulerImagesSettings Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerImagesSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerImagesSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerImagesSettings Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


WebSchedulerImagesSettings Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerImagesSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerImagesSettings members.

Public Properties

 | Name | Description
Public Property | BlackRecurrence | Gets or sets the default image used for recurrence image. Gets or sets the default image used for recurrence image.
Public Property | BlackRecurrenceException | Gets or sets the default image used for recurrence exception image. Gets or sets the default image used for recurrence exception image.
Public Property | BlackReminder | Gets or sets the default image used for reminder image. Gets or sets the default image used for reminder image.
Public Property | CollapseAll | Gets or sets the default image used for collapse all. Gets or sets the default image used for collapse all.
Public Property | Delete | Gets or sets the default image used for delete image in Agenda view. Gets or sets the default image used for delete image in Agenda view.
Public Property | Edit | Gets or sets the default image used for edit event image in Agenda view. Gets or sets the default image used for edit event image in Agenda view.
Public Property | ExpandAll | Gets or sets the default image used for expand all. Gets or sets the default image used for expand all.
Public Property | HighImportance | Gets or sets the default image used for high importance image in editing form.
Public Property | InProgress | Gets or sets the default image used for in progress indicator.
Public Property | LowImportance | Gets or sets the default image used for low importance image in editing form.
Public Property | NextArrow | Gets or sets the default image used for next arrow. Gets or sets the default image used for next arrow.
Public Property | NextCalendarArrow | Gets or sets the default image used for next image in Calendar. Gets or sets the default image used for next image in Calendar.
Public Property | PartialTimelineDisabledTimeIcon | Gets or sets the default image used for Timeline view partial disabled time icon.
Public Property | PreviousArrow | Gets or sets the default image used for previous arrow. Gets or sets the default image used for previous row.
Public Property | PreviousCalendarArrow | Gets or sets the default image used for previous image in Calendar. Gets or sets the default image used for previous image in Calendar.
Public Property | Recurrence | Gets or sets the default image used for recurrence image. Gets or sets the default image used for recurrence image.
Public Property | RecurrenceException | Gets or sets the default image used for recurrence exception image. Gets or sets the default image used for recurrence exception image.
Public Property | Reminder | Gets or sets the default image used for reminder image. Gets or sets the default image used for reminder image.
Public Property | ResourcesDownArrow | Gets or sets the default image used for down image in Resources. Gets or sets the default image used for down image in Resources.
Public Property | SmallHighImportance | Gets or sets the default image used for high importance image in event.
Public Property | SmallLowImportance | Gets or sets the default image used for low importance image in event.
Public Property | TimelineMoreIcon | Gets or sets the default image used for Timeline view more icon.
Public Property | TimelineZoomIn | Gets or sets the default image used for plus sign in Timeline view.
Public Property | TimelineZoomOut | Gets or sets the default image used for minus sign in Timeline view.
Public Property | ViewOnMyCalendar | Gets or sets the default image used for view on my calendar image in Agenda view. Gets or sets the default image used for view on my calendar image in Agenda view.
Top

See Also

Reference

WebSchedulerImagesSettings Class
ISNet.WebUI.WebScheduler Namespace


BlackRecurrence Property

[image]
Intersoft WebScheduler Documentation
BlackRecurrence Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : BlackRecurrence Property

Glossary Item Box

Gets or sets the default image used for recurrence image. Gets or sets the default image used for recurrence image.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for recurrence image.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property BlackRecurrence As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim value As System.String

instance.BlackRecurrence = value

value = instance.BlackRecurrence
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for recurrence image.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string BlackRecurrence {get; set;}
Delphi
public read-write property BlackRecurrence: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for recurrence image.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set BlackRecurrence : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for recurrence image.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_BlackRecurrence();
public: __property void set_BlackRecurrence(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for recurrence image.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ BlackRecurrence {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


BlackRecurrenceException Property

[image]
Intersoft WebScheduler Documentation
BlackRecurrenceException Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : BlackRecurrenceException Property

Glossary Item Box

Gets or sets the default image used for recurrence exception image. Gets or sets the default image used for recurrence exception image.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for recurrence exception image.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property BlackRecurrenceException As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim value As System.String

instance.BlackRecurrenceException = value

value = instance.BlackRecurrenceException
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for recurrence exception image.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string BlackRecurrenceException {get; set;}
Delphi
public read-write property BlackRecurrenceException: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for recurrence exception image.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set BlackRecurrenceException : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for recurrence exception image.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_BlackRecurrenceException();
public: __property void set_BlackRecurrenceException(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for recurrence exception image.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ BlackRecurrenceException {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


BlackReminder Property

[image]
Intersoft WebScheduler Documentation
BlackReminder Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : BlackReminder Property

Glossary Item Box

Gets or sets the default image used for reminder image. Gets or sets the default image used for reminder image.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for reminder image.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property BlackReminder As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim value As System.String

instance.BlackReminder = value

value = instance.BlackReminder
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for reminder image.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string BlackReminder {get; set;}
Delphi
public read-write property BlackReminder: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for reminder image.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set BlackReminder : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for reminder image.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_BlackReminder();
public: __property void set_BlackReminder(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for reminder image.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ BlackReminder {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


CollapseAll Property

[image]
Intersoft WebScheduler Documentation
CollapseAll Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : CollapseAll Property

Glossary Item Box

Gets or sets the default image used for collapse all. Gets or sets the default image used for collapse all.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for collapse all.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property CollapseAll As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim value As System.String

instance.CollapseAll = value

value = instance.CollapseAll
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for collapse all.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string CollapseAll {get; set;}
Delphi
public read-write property CollapseAll: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for collapse all.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set CollapseAll : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for collapse all.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_CollapseAll();
public: __property void set_CollapseAll(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for collapse all.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ CollapseAll {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


Delete Property

[image]
Intersoft WebScheduler Documentation
Delete Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : Delete Property

Glossary Item Box

Gets or sets the default image used for delete image in Agenda view. Gets or sets the default image used for delete image in Agenda view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for delete image in Agenda view.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Delete As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim value As System.String

instance.Delete = value

value = instance.Delete
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for delete image in Agenda view.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string Delete {get; set;}
Delphi
public read-write property Delete: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for delete image in Agenda view.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Delete : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for delete image in Agenda view.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_Delete();
public: __property void set_Delete(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for delete image in Agenda view.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ Delete {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


Edit Property

[image]
Intersoft WebScheduler Documentation
Edit Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : Edit Property

Glossary Item Box

Gets or sets the default image used for edit event image in Agenda view. Gets or sets the default image used for edit event image in Agenda view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for edit event image in Agenda view.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Edit As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim value As System.String

instance.Edit = value

value = instance.Edit
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for edit event image in Agenda view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string Edit {get; set;}
Delphi
public read-write property Edit: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for edit event image in Agenda view.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Edit : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for edit event image in Agenda view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_Edit();
public: __property void set_Edit(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for edit event image in Agenda view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ Edit {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


ExpandAll Property

[image]
Intersoft WebScheduler Documentation
ExpandAll Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : ExpandAll Property

Glossary Item Box

Gets or sets the default image used for expand all. Gets or sets the default image used for expand all.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for expand all.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
Public Property ExpandAll As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim value As System.String

instance.ExpandAll = value

value = instance.ExpandAll
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for expand all.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public System.string ExpandAll {get; set;}
Delphi
public read-write property ExpandAll: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for expand all.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
public function get,set ExpandAll : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for expand all.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public: __property System.string* get_ExpandAll();
public: __property void set_ExpandAll(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for expand all.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public:
property System.String^ ExpandAll {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


HighImportance Property

[image]
Intersoft WebScheduler Documentation
HighImportance Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : HighImportance Property

Glossary Item Box

Gets or sets the default image used for high importance image in editing form.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for high importance image in editing form.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property HighImportance As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim value As System.String

instance.HighImportance = value

value = instance.HighImportance
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for high importance image in editing form.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string HighImportance {get; set;}
Delphi
public read-write property HighImportance: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for high importance image in editing form.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set HighImportance : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for high importance image in editing form.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_HighImportance();
public: __property void set_HighImportance(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for high importance image in editing form.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ HighImportance {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


InProgress Property

[image]
Intersoft WebScheduler Documentation
InProgress Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : InProgress Property

Glossary Item Box

Gets or sets the default image used for in progress indicator.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for in progress indicator.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property InProgress As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim value As System.String

instance.InProgress = value

value = instance.InProgress
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for in progress indicator.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string InProgress {get; set;}
Delphi
public read-write property InProgress: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for in progress indicator.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set InProgress : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for in progress indicator.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_InProgress();
public: __property void set_InProgress(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for in progress indicator.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ InProgress {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


LowImportance Property

[image]
Intersoft WebScheduler Documentation
LowImportance Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : LowImportance Property

Glossary Item Box

Gets or sets the default image used for low importance image in editing form.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for low importance image in editing form.")>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property LowImportance As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim value As System.String

instance.LowImportance = value

value = instance.LowImportance
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for low importance image in editing form.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string LowImportance {get; set;}
Delphi
public read-write property LowImportance: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for low importance image in editing form.")
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set LowImportance : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for low importance image in editing form.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_LowImportance();
public: __property void set_LowImportance(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for low importance image in editing form.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ LowImportance {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


NextArrow Property

[image]
Intersoft WebScheduler Documentation
NextArrow Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : NextArrow Property

Glossary Item Box

Gets or sets the default image used for next arrow. Gets or sets the default image used for next arrow.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for next arrow.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property NextArrow As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim value As System.String

instance.NextArrow = value

value = instance.NextArrow
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for next arrow.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string NextArrow {get; set;}
Delphi
public read-write property NextArrow: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for next arrow.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set NextArrow : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for next arrow.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_NextArrow();
public: __property void set_NextArrow(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for next arrow.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ NextArrow {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


NextCalendarArrow Property

[image]
Intersoft WebScheduler Documentation
NextCalendarArrow Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : NextCalendarArrow Property

Glossary Item Box

Gets or sets the default image used for next image in Calendar. Gets or sets the default image used for next image in Calendar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for next image in Calendar.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property NextCalendarArrow As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim value As System.String

instance.NextCalendarArrow = value

value = instance.NextCalendarArrow
C#
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for next image in Calendar.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string NextCalendarArrow {get; set;}
Delphi
public read-write property NextCalendarArrow: System.String;
JScript
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for next image in Calendar.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set NextCalendarArrow : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for next image in Calendar.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_NextCalendarArrow();
public: __property void set_NextCalendarArrow(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for next image in Calendar.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ NextCalendarArrow {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


PartialTimelineDisabledTimeIcon Property

[image]
Intersoft WebScheduler Documentation
PartialTimelineDisabledTimeIcon Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : PartialTimelineDisabledTimeIcon Property

Glossary Item Box

Gets or sets the default image used for Timeline view partial disabled time icon.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for Timeline view partial disabled time icon.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
Public Property PartialTimelineDisabledTimeIcon As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim value As System.String

instance.PartialTimelineDisabledTimeIcon = value

value = instance.PartialTimelineDisabledTimeIcon
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for Timeline view partial disabled time icon.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public System.string PartialTimelineDisabledTimeIcon {get; set;}
Delphi
public read-write property PartialTimelineDisabledTimeIcon: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for Timeline view partial disabled time icon.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
public function get,set PartialTimelineDisabledTimeIcon : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for Timeline view partial disabled time icon.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public: __property System.string* get_PartialTimelineDisabledTimeIcon();
public: __property void set_PartialTimelineDisabledTimeIcon(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for Timeline view partial disabled time icon.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public:
property System.String^ PartialTimelineDisabledTimeIcon {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


PreviousArrow Property

[image]
Intersoft WebScheduler Documentation
PreviousArrow Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : PreviousArrow Property

Glossary Item Box

Gets or sets the default image used for previous arrow. Gets or sets the default image used for previous row.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for previous arrow.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
Public Property PreviousArrow As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim value As System.String

instance.PreviousArrow = value

value = instance.PreviousArrow
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for previous arrow.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public System.string PreviousArrow {get; set;}
Delphi
public read-write property PreviousArrow: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for previous arrow.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
public function get,set PreviousArrow : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for previous arrow.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public: __property System.string* get_PreviousArrow();
public: __property void set_PreviousArrow(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for previous arrow.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public:
property System.String^ PreviousArrow {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


PreviousCalendarArrow Property

[image]
Intersoft WebScheduler Documentation
PreviousCalendarArrow Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : PreviousCalendarArrow Property

Glossary Item Box

Gets or sets the default image used for previous image in Calendar. Gets or sets the default image used for previous image in Calendar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for previous image in Calendar.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property PreviousCalendarArrow As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim value As System.String

instance.PreviousCalendarArrow = value

value = instance.PreviousCalendarArrow
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for previous image in Calendar.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string PreviousCalendarArrow {get; set;}
Delphi
public read-write property PreviousCalendarArrow: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for previous image in Calendar.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set PreviousCalendarArrow : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for previous image in Calendar.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_PreviousCalendarArrow();
public: __property void set_PreviousCalendarArrow(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for previous image in Calendar.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ PreviousCalendarArrow {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


Recurrence Property

[image]
Intersoft WebScheduler Documentation
Recurrence Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : Recurrence Property

Glossary Item Box

Gets or sets the default image used for recurrence image. Gets or sets the default image used for recurrence image.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for recurrence image.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Recurrence As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim value As System.String

instance.Recurrence = value

value = instance.Recurrence
C#
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for recurrence image.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string Recurrence {get; set;}
Delphi
public read-write property Recurrence: System.String;
JScript
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for recurrence image.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Recurrence : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for recurrence image.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_Recurrence();
public: __property void set_Recurrence(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for recurrence image.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ Recurrence {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


RecurrenceException Property

[image]
Intersoft WebScheduler Documentation
RecurrenceException Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : RecurrenceException Property

Glossary Item Box

Gets or sets the default image used for recurrence exception image. Gets or sets the default image used for recurrence exception image.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for recurrence exception image.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property RecurrenceException As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim value As System.String

instance.RecurrenceException = value

value = instance.RecurrenceException
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for recurrence exception image.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string RecurrenceException {get; set;}
Delphi
public read-write property RecurrenceException: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for recurrence exception image.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set RecurrenceException : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for recurrence exception image.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_RecurrenceException();
public: __property void set_RecurrenceException(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for recurrence exception image.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ RecurrenceException {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


Reminder Property

[image]
Intersoft WebScheduler Documentation
Reminder Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : Reminder Property

Glossary Item Box

Gets or sets the default image used for reminder image. Gets or sets the default image used for reminder image.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for reminder image.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Reminder As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim value As System.String

instance.Reminder = value

value = instance.Reminder
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for reminder image.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Reminder {get; set;}
Delphi
public read-write property Reminder: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for reminder image.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Reminder : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for reminder image.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Reminder();
public: __property void set_Reminder(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for reminder image.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Reminder {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


ResourcesDownArrow Property

[image]
Intersoft WebScheduler Documentation
ResourcesDownArrow Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : ResourcesDownArrow Property

Glossary Item Box

Gets or sets the default image used for down image in Resources. Gets or sets the default image used for down image in Resources.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for down image in Resources.")>
Public Property ResourcesDownArrow As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim value As System.String

instance.ResourcesDownArrow = value

value = instance.ResourcesDownArrow
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for down image in Resources.")]
public System.string ResourcesDownArrow {get; set;}
Delphi
public read-write property ResourcesDownArrow: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for down image in Resources.")
public function get,set ResourcesDownArrow : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for down image in Resources.")]
public: __property System.string* get_ResourcesDownArrow();
public: __property void set_ResourcesDownArrow(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for down image in Resources.")]
public:
property System.String^ ResourcesDownArrow {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


SmallHighImportance Property

[image]
Intersoft WebScheduler Documentation
SmallHighImportance Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : SmallHighImportance Property

Glossary Item Box

Gets or sets the default image used for high importance image in event.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for high importance image in event.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property SmallHighImportance As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim value As System.String

instance.SmallHighImportance = value

value = instance.SmallHighImportance
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for high importance image in event.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string SmallHighImportance {get; set;}
Delphi
public read-write property SmallHighImportance: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for high importance image in event.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set SmallHighImportance : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for high importance image in event.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_SmallHighImportance();
public: __property void set_SmallHighImportance(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for high importance image in event.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ SmallHighImportance {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


SmallLowImportance Property

[image]
Intersoft WebScheduler Documentation
SmallLowImportance Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : SmallLowImportance Property

Glossary Item Box

Gets or sets the default image used for low importance image in event.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for low importance image in event.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property SmallLowImportance As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim value As System.String

instance.SmallLowImportance = value

value = instance.SmallLowImportance
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for low importance image in event.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string SmallLowImportance {get; set;}
Delphi
public read-write property SmallLowImportance: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for low importance image in event.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set SmallLowImportance : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for low importance image in event.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_SmallLowImportance();
public: __property void set_SmallLowImportance(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for low importance image in event.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ SmallLowImportance {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


TimelineMoreIcon Property

[image]
Intersoft WebScheduler Documentation
TimelineMoreIcon Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : TimelineMoreIcon Property

Glossary Item Box

Gets or sets the default image used for Timeline view more icon.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for Timeline view more icon.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
Public Property TimelineMoreIcon As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim value As System.String

instance.TimelineMoreIcon = value

value = instance.TimelineMoreIcon
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for Timeline view more icon.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public System.string TimelineMoreIcon {get; set;}
Delphi
public read-write property TimelineMoreIcon: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for Timeline view more icon.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
public function get,set TimelineMoreIcon : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for Timeline view more icon.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public: __property System.string* get_TimelineMoreIcon();
public: __property void set_TimelineMoreIcon(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for Timeline view more icon.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public:
property System.String^ TimelineMoreIcon {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


TimelineZoomIn Property

[image]
Intersoft WebScheduler Documentation
TimelineZoomIn Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : TimelineZoomIn Property

Glossary Item Box

Gets or sets the default image used for plus sign in Timeline view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for ZoomIn in Timeline view.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property TimelineZoomIn As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim value As System.String

instance.TimelineZoomIn = value

value = instance.TimelineZoomIn
C#
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for ZoomIn in Timeline view.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string TimelineZoomIn {get; set;}
Delphi
public read-write property TimelineZoomIn: System.String;
JScript
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for ZoomIn in Timeline view.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set TimelineZoomIn : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for ZoomIn in Timeline view.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_TimelineZoomIn();
public: __property void set_TimelineZoomIn(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for ZoomIn in Timeline view.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ TimelineZoomIn {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


TimelineZoomOut Property

[image]
Intersoft WebScheduler Documentation
TimelineZoomOut Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : TimelineZoomOut Property

Glossary Item Box

Gets or sets the default image used for minus sign in Timeline view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for ZoomOut in Timeline view.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property TimelineZoomOut As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim value As System.String

instance.TimelineZoomOut = value

value = instance.TimelineZoomOut
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for ZoomOut in Timeline view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string TimelineZoomOut {get; set;}
Delphi
public read-write property TimelineZoomOut: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for ZoomOut in Timeline view.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set TimelineZoomOut : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for ZoomOut in Timeline view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_TimelineZoomOut();
public: __property void set_TimelineZoomOut(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for ZoomOut in Timeline view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ TimelineZoomOut {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


ViewOnMyCalendar Property

[image]
Intersoft WebScheduler Documentation
ViewOnMyCalendar Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : ViewOnMyCalendar Property

Glossary Item Box

Gets or sets the default image used for view on my calendar image in Agenda view. Gets or sets the default image used for view on my calendar image in Agenda view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for view on my calendar image in Agenda view.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ViewOnMyCalendar As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim value As System.String

instance.ViewOnMyCalendar = value

value = instance.ViewOnMyCalendar
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for view on my calendar image in Agenda view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string ViewOnMyCalendar {get; set;}
Delphi
public read-write property ViewOnMyCalendar: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for view on my calendar image in Agenda view.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ViewOnMyCalendar : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for view on my calendar image in Agenda view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_ViewOnMyCalendar();
public: __property void set_ViewOnMyCalendar(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for view on my calendar image in Agenda view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ ViewOnMyCalendar {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


WebSchedulerJsonSerializationArgs Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerJsonSerializationArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerJsonSerializationArgs Class

Glossary Item Box

Object Model

WebSchedulerJsonSerializationArgs Class

Syntax

Visual Basic (Declaration)
Public Class WebSchedulerJsonSerializationArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerJsonSerializationArgs
C#
public class WebSchedulerJsonSerializationArgs : System.EventArgs
Delphi
public class WebSchedulerJsonSerializationArgs = class(System.EventArgs)
JScript
public class WebSchedulerJsonSerializationArgs extends System.EventArgs
Managed Extensions for C++
public __gc class WebSchedulerJsonSerializationArgs : public System.EventArgs
C++/CLI
public ref class WebSchedulerJsonSerializationArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebScheduler.WebSchedulerJsonSerializationArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerJsonSerializationArgs Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerJsonSerializationArgs Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerJsonSerializationArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerJsonSerializationArgs Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerJsonSerializationArgs.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerJsonSerializationArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | DataDictionary |
Public Property | DataObject |
Public Property | Type |
Top

See Also

Reference

WebSchedulerJsonSerializationArgs Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerJsonSerializationArgs Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerJsonSerializationArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerJsonSerializationArgs Class : WebSchedulerJsonSerializationArgs Constructor

dataDictionary
dataObject
type

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dataDictionary As System.Collections.Generic.Dictionary(Of String,Object), _
   ByVal dataObject As System.Object, _
   ByVal type As WebSchedulerObjectType _
)
Visual Basic (Usage) Copy Code
Dim dataDictionary As System.Collections.Generic.Dictionary(Of String,Object)
Dim dataObject As System.Object
Dim type As WebSchedulerObjectType

Dim instance As New WebSchedulerJsonSerializationArgs(dataDictionary, dataObject, type)
C#
public WebSchedulerJsonSerializationArgs(
   System.Collections.Generic.Dictionary<string,object> dataDictionary,
   System.object dataObject,
   WebSchedulerObjectType type
)
Delphi
public WebSchedulerJsonSerializationArgs(
    dataDictionary: System.Collections.Generic.Dictionary;
    dataObject: System.TObject;
    type: WebSchedulerObjectType
);
JScript
public function WebSchedulerJsonSerializationArgs(
   dataDictionary : System.Collections.Generic.Dictionary,
   dataObject : System.Object,
   type : WebSchedulerObjectType
);
Managed Extensions for C++
public: WebSchedulerJsonSerializationArgs(
   System.Collections.Generic.Dictionary<string*,Object*>* dataDictionary,
   System.Object* dataObject,
   WebSchedulerObjectType type
)
C++/CLI
public:
WebSchedulerJsonSerializationArgs(
   System.Collections.Generic.Dictionary<String^,Object^>^ dataDictionary,
   System.Object^ dataObject,
   WebSchedulerObjectType type
)

Parameters

dataDictionary
dataObject
type

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerJsonSerializationArgs Class
WebSchedulerJsonSerializationArgs Members


WebSchedulerJsonSerializationArgs Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerJsonSerializationArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerJsonSerializationArgs Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerJsonSerializationArgs members.

Public Properties

 | Name | Description
Public Property | DataDictionary |
Public Property | DataObject |
Public Property | Type |
Top

See Also

Reference

WebSchedulerJsonSerializationArgs Class
ISNet.WebUI.WebScheduler Namespace


DataDictionary Property

[image]
Intersoft WebScheduler Documentation
DataDictionary Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerJsonSerializationArgs Class : DataDictionary Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataDictionary As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerJsonSerializationArgs
Dim value As System.Object

value = instance.DataDictionary
C#
public System.object DataDictionary {get;}
Delphi
public read-only property DataDictionary: System.TObject;
JScript
public function get DataDictionary : System.Object
Managed Extensions for C++
public: __property System.Object* get_DataDictionary();
C++/CLI
public:
property System.Object^ DataDictionary {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerJsonSerializationArgs Class
WebSchedulerJsonSerializationArgs Members


DataObject Property

[image]
Intersoft WebScheduler Documentation
DataObject Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerJsonSerializationArgs Class : DataObject Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataObject As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerJsonSerializationArgs
Dim value As System.Object

value = instance.DataObject
C#
public System.object DataObject {get;}
Delphi
public read-only property DataObject: System.TObject;
JScript
public function get DataObject : System.Object
Managed Extensions for C++
public: __property System.Object* get_DataObject();
C++/CLI
public:
property System.Object^ DataObject {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerJsonSerializationArgs Class
WebSchedulerJsonSerializationArgs Members


Type Property

[image]
Intersoft WebScheduler Documentation
Type Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerJsonSerializationArgs Class : Type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As WebSchedulerObjectType
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerJsonSerializationArgs
Dim value As WebSchedulerObjectType

value = instance.Type
C#
public WebSchedulerObjectType Type {get;}
Delphi
public read-only property Type: WebSchedulerObjectType;
JScript
public function get Type : WebSchedulerObjectType
Managed Extensions for C++
public: __property WebSchedulerObjectType get_Type();
C++/CLI
public:
property WebSchedulerObjectType Type {
   WebSchedulerObjectType get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerJsonSerializationArgs Class
WebSchedulerJsonSerializationArgs Members


WebSchedulerLayoutSettings Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerLayoutSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerLayoutSettings Class

Glossary Item Box

A collection of layout settings for WebScheduler's object.

Object Model

WebSchedulerLayoutSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerLayoutSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerLayoutSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerLayoutSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSchedulerLayoutSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerLayoutSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerLayoutSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerLayoutSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebScheduler.WebSchedulerLayoutSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerLayoutSettings Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerLayoutSettings Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerLayoutSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerLayoutSettings Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerLayoutSettings.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerLayoutSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllDayEventAreaHeight | Gets or sets the default all day event area height. Gets or sets the default all day event area height.
Public Property | AllDayEventHeight | Gets or sets the default row height for all day event. Get or sets the default row height for all day event
Public Property | DetailBoxPageSize | Gets or sets the page size of events displayed in detail box.
Public Property | EnableDetailBoxPaging | Gets or sets whether paging in detail box should be enabled.
Public Property | MaxAllDayEventAreaHeight | Gets or sets the maximum height of all day event area.
Public Property | RowHeight | Gets or sets the default row height for day or week view row. Gets or sets the default row height for day or week view row.
Public Property | ShowImportanceImage | Gets or sets whether importance image should be displayed in events.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerLayoutSettings Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerLayoutSettings Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerLayoutSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerLayoutSettings Class : WebSchedulerLayoutSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerLayoutSettings()
C#
public WebSchedulerLayoutSettings()
Delphi
public WebSchedulerLayoutSettings();
JScript
public function WebSchedulerLayoutSettings();
Managed Extensions for C++
public: WebSchedulerLayoutSettings();
C++/CLI
public:
WebSchedulerLayoutSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerLayoutSettings Class
WebSchedulerLayoutSettings Members


WebSchedulerLayoutSettings Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerLayoutSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerLayoutSettings Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerLayoutSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerLayoutSettings Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerLayoutSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerLayoutSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerLayoutSettings Class
WebSchedulerLayoutSettings Members


WebSchedulerLayoutSettings Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerLayoutSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerLayoutSettings Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerLayoutSettings members.

Public Properties

 | Name | Description
Public Property | AllDayEventAreaHeight | Gets or sets the default all day event area height. Gets or sets the default all day event area height.
Public Property | AllDayEventHeight | Gets or sets the default row height for all day event. Get or sets the default row height for all day event
Public Property | DetailBoxPageSize | Gets or sets the page size of events displayed in detail box.
Public Property | EnableDetailBoxPaging | Gets or sets whether paging in detail box should be enabled.
Public Property | MaxAllDayEventAreaHeight | Gets or sets the maximum height of all day event area.
Public Property | RowHeight | Gets or sets the default row height for day or week view row. Gets or sets the default row height for day or week view row.
Public Property | ShowImportanceImage | Gets or sets whether importance image should be displayed in events.
Top

See Also

Reference

WebSchedulerLayoutSettings Class
ISNet.WebUI.WebScheduler Namespace


AllDayEventAreaHeight Property

[image]
Intersoft WebScheduler Documentation
AllDayEventAreaHeight Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerLayoutSettings Class : AllDayEventAreaHeight Property

Glossary Item Box

Gets or sets the default all day event area height. Gets or sets the default all day event area height.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Layout Settings")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the default all day event area height.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AllDayEventAreaHeight As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerLayoutSettings
Dim value As System.Integer

instance.AllDayEventAreaHeight = value

value = instance.AllDayEventAreaHeight
C#
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default all day event area height.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.int AllDayEventAreaHeight {get; set;}
Delphi
public read-write property AllDayEventAreaHeight: System.Integer;
JScript
System.ComponentModel.CategoryAttribute("Layout Settings")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the default all day event area height.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AllDayEventAreaHeight : System.int
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default all day event area height.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.int get_AllDayEventAreaHeight();
public: __property void set_AllDayEventAreaHeight(
   System.int value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default all day event area height.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.int AllDayEventAreaHeight {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerLayoutSettings Class
WebSchedulerLayoutSettings Members


AllDayEventHeight Property

[image]
Intersoft WebScheduler Documentation
AllDayEventHeight Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerLayoutSettings Class : AllDayEventHeight Property

Glossary Item Box

Gets or sets the default row height for all day event. Get or sets the default row height for all day event

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Layout Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the default row height for all day event.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AllDayEventHeight As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerLayoutSettings
Dim value As System.Integer

instance.AllDayEventHeight = value

value = instance.AllDayEventHeight
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default row height for all day event.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.int AllDayEventHeight {get; set;}
Delphi
public read-write property AllDayEventHeight: System.Integer;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Layout Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the default row height for all day event.")
System.ComponentModel.DefaultValueAttribute()
public function get,set AllDayEventHeight : System.int
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default row height for all day event.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_AllDayEventHeight();
public: __property void set_AllDayEventHeight(
   System.int value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default row height for all day event.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int AllDayEventHeight {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerLayoutSettings Class
WebSchedulerLayoutSettings Members


DetailBoxPageSize Property

[image]
Intersoft WebScheduler Documentation
DetailBoxPageSize Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerLayoutSettings Class : DetailBoxPageSize Property

Glossary Item Box

Gets or sets the page size of events displayed in detail box.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Layout Settings")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the page size of events displayed in detail box.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property DetailBoxPageSize As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerLayoutSettings
Dim value As System.Integer

instance.DetailBoxPageSize = value

value = instance.DetailBoxPageSize
C#
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the page size of events displayed in detail box.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.int DetailBoxPageSize {get; set;}
Delphi
public read-write property DetailBoxPageSize: System.Integer;
JScript
System.ComponentModel.CategoryAttribute("Layout Settings")
System.ComponentModel.DescriptionAttribute("Gets or sets the page size of events displayed in detail box.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set DetailBoxPageSize : System.int
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the page size of events displayed in detail box.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.int get_DetailBoxPageSize();
public: __property void set_DetailBoxPageSize(
   System.int value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the page size of events displayed in detail box.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.int DetailBoxPageSize {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerLayoutSettings Class
WebSchedulerLayoutSettings Members


EnableDetailBoxPaging Property

[image]
Intersoft WebScheduler Documentation
EnableDetailBoxPaging Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerLayoutSettings Class : EnableDetailBoxPaging Property

Glossary Item Box

Gets or sets whether paging in detail box should be enabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets whether paging in detail box should be enabled.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Layout Settings")>
Public Property EnableDetailBoxPaging As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerLayoutSettings
Dim value As System.Boolean

instance.EnableDetailBoxPaging = value

value = instance.EnableDetailBoxPaging
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets whether paging in detail box should be enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
public System.bool EnableDetailBoxPaging {get; set;}
Delphi
public read-write property EnableDetailBoxPaging: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets whether paging in detail box should be enabled.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Layout Settings")
public function get,set EnableDetailBoxPaging : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets whether paging in detail box should be enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
public: __property System.bool get_EnableDetailBoxPaging();
public: __property void set_EnableDetailBoxPaging(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets whether paging in detail box should be enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
public:
property System.bool EnableDetailBoxPaging {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerLayoutSettings Class
WebSchedulerLayoutSettings Members


MaxAllDayEventAreaHeight Property

[image]
Intersoft WebScheduler Documentation
MaxAllDayEventAreaHeight Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerLayoutSettings Class : MaxAllDayEventAreaHeight Property

Glossary Item Box

Gets or sets the maximum height of all day event area.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the maximum height of all day event area.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Layout Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property MaxAllDayEventAreaHeight As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerLayoutSettings
Dim value As System.Integer

instance.MaxAllDayEventAreaHeight = value

value = instance.MaxAllDayEventAreaHeight
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the maximum height of all day event area.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.int MaxAllDayEventAreaHeight {get; set;}
Delphi
public read-write property MaxAllDayEventAreaHeight: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the maximum height of all day event area.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Layout Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set MaxAllDayEventAreaHeight : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the maximum height of all day event area.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_MaxAllDayEventAreaHeight();
public: __property void set_MaxAllDayEventAreaHeight(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the maximum height of all day event area.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int MaxAllDayEventAreaHeight {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerLayoutSettings Class
WebSchedulerLayoutSettings Members


RowHeight Property

[image]
Intersoft WebScheduler Documentation
RowHeight Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerLayoutSettings Class : RowHeight Property

Glossary Item Box

Gets or sets the default row height for day or week view row. Gets or sets the default row height for day or week view row.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the default row height for day or week view row.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Layout Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property RowHeight As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerLayoutSettings
Dim value As System.Integer

instance.RowHeight = value

value = instance.RowHeight
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the default row height for day or week view row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.int RowHeight {get; set;}
Delphi
public read-write property RowHeight: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the default row height for day or week view row.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Layout Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set RowHeight : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the default row height for day or week view row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_RowHeight();
public: __property void set_RowHeight(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the default row height for day or week view row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int RowHeight {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerLayoutSettings Class
WebSchedulerLayoutSettings Members


ShowImportanceImage Property

[image]
Intersoft WebScheduler Documentation
ShowImportanceImage Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerLayoutSettings Class : ShowImportanceImage Property

Glossary Item Box

Gets or sets whether importance image should be displayed in events.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Layout Settings")>
<System.ComponentModel.DescriptionAttribute("Gets or sets whether importance image should be displayed in events.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ShowImportanceImage As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerLayoutSettings
Dim value As System.Boolean

instance.ShowImportanceImage = value

value = instance.ShowImportanceImage
C#
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets whether importance image should be displayed in events.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool ShowImportanceImage {get; set;}
Delphi
public read-write property ShowImportanceImage: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Layout Settings")
System.ComponentModel.DescriptionAttribute("Gets or sets whether importance image should be displayed in events.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ShowImportanceImage : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets whether importance image should be displayed in events.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_ShowImportanceImage();
public: __property void set_ShowImportanceImage(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets whether importance image should be displayed in events.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool ShowImportanceImage {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerLayoutSettings Class
WebSchedulerLayoutSettings Members


WebSchedulerMonthView Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerMonthView Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerMonthView Class

Glossary Item Box

A collection of styles used for WebScheduler's month view.

Object Model

WebSchedulerMonthView Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerMonthView
   Inherits WebSchedulerBaseView
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerMonthView
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerMonthView : WebSchedulerBaseView, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSchedulerMonthView = class(WebSchedulerBaseView, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerMonthView extends WebSchedulerBaseView implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerMonthView : public WebSchedulerBaseView, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerMonthView : public WebSchedulerBaseView, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebScheduler.WebSchedulerMonthView

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerMonthView Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerMonthView Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerMonthView Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerMonthView Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerMonthView.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerMonthView Constructor |
Top

Public Properties

 | Name | Description
Public Property | DateFormatString | Overridden. Specifies DateFormatString for MonthView. Specifies DateFormatString for MonthView.
Public Property | TimeBasedEventDisplay | Specifies the fields to be displayed in time-based event. Specifies the fields to be displayed in time-based event.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerMonthView Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerMonthView Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerMonthView Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerMonthView Class : WebSchedulerMonthView Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerMonthView()
C#
public WebSchedulerMonthView()
Delphi
public WebSchedulerMonthView();
JScript
public function WebSchedulerMonthView();
Managed Extensions for C++
public: WebSchedulerMonthView();
C++/CLI
public:
WebSchedulerMonthView();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerMonthView Class
WebSchedulerMonthView Members


WebSchedulerMonthView Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerMonthView Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerMonthView Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerMonthView members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerMonthView Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerMonthView Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerMonthView
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerMonthView Class
WebSchedulerMonthView Members


WebSchedulerMonthView Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerMonthView Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerMonthView Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerMonthView members.

Public Properties

 | Name | Description
Public Property | DateFormatString | Overridden. Specifies DateFormatString for MonthView. Specifies DateFormatString for MonthView.
Public Property | TimeBasedEventDisplay | Specifies the fields to be displayed in time-based event. Specifies the fields to be displayed in time-based event.
Top

See Also

Reference

WebSchedulerMonthView Class
ISNet.WebUI.WebScheduler Namespace


DateFormatString Property

[image]
Intersoft WebScheduler Documentation
DateFormatString Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerMonthView Class : DateFormatString Property

Glossary Item Box

Specifies DateFormatString for MonthView. Specifies DateFormatString for MonthView.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Month View")>
<System.ComponentModel.DescriptionAttribute("Specifies DateFormatString for MonthView.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Overrides Property DateFormatString As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerMonthView
Dim value As System.String

instance.DateFormatString = value

value = instance.DateFormatString
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Month View")]
[System.ComponentModel.DescriptionAttribute("Specifies DateFormatString for MonthView.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public override System.string DateFormatString {get; set;}
Delphi
public read-write property DateFormatString: System.String; override;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Month View")
System.ComponentModel.DescriptionAttribute("Specifies DateFormatString for MonthView.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public override function get,set DateFormatString : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Month View")]
[System.ComponentModel.DescriptionAttribute("Specifies DateFormatString for MonthView.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_DateFormatString() override;
public: __property void set_DateFormatString(
   System.string* value
) override;
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Month View")]
[System.ComponentModel.DescriptionAttribute("Specifies DateFormatString for MonthView.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ DateFormatString {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Property Value

The default value is MMM yyyy.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerMonthView Class
WebSchedulerMonthView Members


TimeBasedEventDisplay Property

[image]
Intersoft WebScheduler Documentation
TimeBasedEventDisplay Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerMonthView Class : TimeBasedEventDisplay Property

Glossary Item Box

Specifies the fields to be displayed in time-based event. Specifies the fields to be displayed in time-based event.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Month View")>
<System.ComponentModel.DescriptionAttribute("Specifies the fields to be displayed in time-based event.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property TimeBasedEventDisplay As WebSchedulerTimeBasedEventDisplay
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerMonthView
Dim value As WebSchedulerTimeBasedEventDisplay

instance.TimeBasedEventDisplay = value

value = instance.TimeBasedEventDisplay
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Month View")]
[System.ComponentModel.DescriptionAttribute("Specifies the fields to be displayed in time-based event.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebSchedulerTimeBasedEventDisplay TimeBasedEventDisplay {get; set;}
Delphi
public read-write property TimeBasedEventDisplay: WebSchedulerTimeBasedEventDisplay;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Month View")
System.ComponentModel.DescriptionAttribute("Specifies the fields to be displayed in time-based event.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set TimeBasedEventDisplay : WebSchedulerTimeBasedEventDisplay
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Month View")]
[System.ComponentModel.DescriptionAttribute("Specifies the fields to be displayed in time-based event.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebSchedulerTimeBasedEventDisplay get_TimeBasedEventDisplay();
public: __property void set_TimeBasedEventDisplay(
   WebSchedulerTimeBasedEventDisplay value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Month View")]
[System.ComponentModel.DescriptionAttribute("Specifies the fields to be displayed in time-based event.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebSchedulerTimeBasedEventDisplay TimeBasedEventDisplay {
   WebSchedulerTimeBasedEventDisplay get();
   void set (    WebSchedulerTimeBasedEventDisplay value);
}

Property Value

The default value is ShowTimeAndSubject.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerMonthView Class
WebSchedulerMonthView Members


WebSchedulerPrepareExportExecuteEventArgs Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerPrepareExportExecuteEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerPrepareExportExecuteEventArgs Class

Glossary Item Box

Provides data for export action.

Object Model

WebSchedulerPrepareExportExecuteEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class WebSchedulerPrepareExportExecuteEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerPrepareExportExecuteEventArgs
C#
public class WebSchedulerPrepareExportExecuteEventArgs : System.EventArgs
Delphi
public class WebSchedulerPrepareExportExecuteEventArgs = class(System.EventArgs)
JScript
public class WebSchedulerPrepareExportExecuteEventArgs extends System.EventArgs
Managed Extensions for C++
public __gc class WebSchedulerPrepareExportExecuteEventArgs : public System.EventArgs
C++/CLI
public ref class WebSchedulerPrepareExportExecuteEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebScheduler.WebSchedulerPrepareExportExecuteEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerPrepareExportExecuteEventArgs Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerPrepareExportExecuteEventArgs Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerPrepareExportExecuteEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerPrepareExportExecuteEventArgs Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerPrepareExportExecuteEventArgs.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerPrepareExportExecuteEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | ReportObject |
Public Property | ReportType |
Top

See Also

Reference

WebSchedulerPrepareExportExecuteEventArgs Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerPrepareExportExecuteEventArgs Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerPrepareExportExecuteEventArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerPrepareExportExecuteEventArgs Class : WebSchedulerPrepareExportExecuteEventArgs Constructor

reportObject
reportType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal reportObject As DataDynamics.ActiveReports.ActiveReport3, _
   ByVal reportType As WebSchedulerReportType _
)
Visual Basic (Usage) Copy Code
Dim reportObject As DataDynamics.ActiveReports.ActiveReport3
Dim reportType As WebSchedulerReportType

Dim instance As New WebSchedulerPrepareExportExecuteEventArgs(reportObject, reportType)
C#
public WebSchedulerPrepareExportExecuteEventArgs(
   DataDynamics.ActiveReports.ActiveReport3 reportObject,
   WebSchedulerReportType reportType
)
Delphi
public WebSchedulerPrepareExportExecuteEventArgs(
    reportObject: DataDynamics.ActiveReports.ActiveReport3;
    reportType: WebSchedulerReportType
);
JScript
public function WebSchedulerPrepareExportExecuteEventArgs(
   reportObject : DataDynamics.ActiveReports.ActiveReport3,
   reportType : WebSchedulerReportType
);
Managed Extensions for C++
public: WebSchedulerPrepareExportExecuteEventArgs(
   DataDynamics.ActiveReports.ActiveReport3* reportObject,
   WebSchedulerReportType reportType
)
C++/CLI
public:
WebSchedulerPrepareExportExecuteEventArgs(
   DataDynamics.ActiveReports.ActiveReport3^ reportObject,
   WebSchedulerReportType reportType
)

Parameters

reportObject
reportType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerPrepareExportExecuteEventArgs Class
WebSchedulerPrepareExportExecuteEventArgs Members


WebSchedulerPrepareExportExecuteEventArgs Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerPrepareExportExecuteEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerPrepareExportExecuteEventArgs Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerPrepareExportExecuteEventArgs members.

Public Properties

 | Name | Description
Public Property | ReportObject |
Public Property | ReportType |
Top

See Also

Reference

WebSchedulerPrepareExportExecuteEventArgs Class
ISNet.WebUI.WebScheduler Namespace


ReportObject Property

[image]
Intersoft WebScheduler Documentation
ReportObject Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerPrepareExportExecuteEventArgs Class : ReportObject Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportObject As DataDynamics.ActiveReports.ActiveReport3
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerPrepareExportExecuteEventArgs
Dim value As DataDynamics.ActiveReports.ActiveReport3

value = instance.ReportObject
C#
public DataDynamics.ActiveReports.ActiveReport3 ReportObject {get;}
Delphi
public read-only property ReportObject: DataDynamics.ActiveReports.ActiveReport3;
JScript
public function get ReportObject : DataDynamics.ActiveReports.ActiveReport3
Managed Extensions for C++
public: __property DataDynamics.ActiveReports.ActiveReport3* get_ReportObject();
C++/CLI
public:
property DataDynamics.ActiveReports.ActiveReport3^ ReportObject {
   DataDynamics.ActiveReports.ActiveReport3^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerPrepareExportExecuteEventArgs Class
WebSchedulerPrepareExportExecuteEventArgs Members


ReportType Property

[image]
Intersoft WebScheduler Documentation
ReportType Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerPrepareExportExecuteEventArgs Class : ReportType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportType As WebSchedulerReportType
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerPrepareExportExecuteEventArgs
Dim value As WebSchedulerReportType

value = instance.ReportType
C#
public WebSchedulerReportType ReportType {get;}
Delphi
public read-only property ReportType: WebSchedulerReportType;
JScript
public function get ReportType : WebSchedulerReportType
Managed Extensions for C++
public: __property WebSchedulerReportType get_ReportType();
C++/CLI
public:
property WebSchedulerReportType ReportType {
   WebSchedulerReportType get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerPrepareExportExecuteEventArgs Class
WebSchedulerPrepareExportExecuteEventArgs Members


WebSchedulerQuarterView Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerQuarterView Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerQuarterView Class

Glossary Item Box

A collection of styles used for WebScheduler's quarter view.

Object Model

WebSchedulerQuarterView Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerQuarterView
   Inherits WebSchedulerBaseView
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerQuarterView
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerQuarterView : WebSchedulerBaseView, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSchedulerQuarterView = class(WebSchedulerBaseView, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerQuarterView extends WebSchedulerBaseView implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerQuarterView : public WebSchedulerBaseView, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerQuarterView : public WebSchedulerBaseView, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebScheduler.WebSchedulerQuarterView

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerQuarterView Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerQuarterView Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerQuarterView Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerQuarterView Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerQuarterView.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerQuarterView Constructor |
Top

Public Properties

 | Name | Description
Public Property | DateFormatString | Overridden. Specifies the DateFormatString for MonthView. Specifies DateFormatString for QuarterView.
Public Property | Enabled | Overridden. Indicates whether QuarterView should be enabled. Indicates whether QuarterView should be enabled.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerQuarterView Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerQuarterView Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerQuarterView Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerQuarterView Class : WebSchedulerQuarterView Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerQuarterView()
C#
public WebSchedulerQuarterView()
Delphi
public WebSchedulerQuarterView();
JScript
public function WebSchedulerQuarterView();
Managed Extensions for C++
public: WebSchedulerQuarterView();
C++/CLI
public:
WebSchedulerQuarterView();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerQuarterView Class
WebSchedulerQuarterView Members


WebSchedulerQuarterView Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerQuarterView Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerQuarterView Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerQuarterView members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerQuarterView Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerQuarterView Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerQuarterView
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerQuarterView Class
WebSchedulerQuarterView Members


WebSchedulerQuarterView Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerQuarterView Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerQuarterView Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerQuarterView members.

Public Properties

 | Name | Description
Public Property | DateFormatString | Overridden. Specifies the DateFormatString for MonthView. Specifies DateFormatString for QuarterView.
Public Property | Enabled | Overridden. Indicates whether QuarterView should be enabled. Indicates whether QuarterView should be enabled.
Top

See Also

Reference

WebSchedulerQuarterView Class
ISNet.WebUI.WebScheduler Namespace


DateFormatString Property

[image]
Intersoft WebScheduler Documentation
DateFormatString Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerQuarterView Class : DateFormatString Property

Glossary Item Box

Specifies the DateFormatString for MonthView. Specifies DateFormatString for QuarterView.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the DateFormatString for QuarterView.")>
<System.ComponentModel.CategoryAttribute("Quarter View")>
Public Overrides Property DateFormatString As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerQuarterView
Dim value As System.String

instance.DateFormatString = value

value = instance.DateFormatString
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the DateFormatString for QuarterView.")]
[System.ComponentModel.CategoryAttribute("Quarter View")]
public override System.string DateFormatString {get; set;}
Delphi
public read-write property DateFormatString: System.String; override;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the DateFormatString for QuarterView.")
System.ComponentModel.CategoryAttribute("Quarter View")
public override function get,set DateFormatString : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the DateFormatString for QuarterView.")]
[System.ComponentModel.CategoryAttribute("Quarter View")]
public: __property System.string* get_DateFormatString() override;
public: __property void set_DateFormatString(
   System.string* value
) override;
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the DateFormatString for QuarterView.")]
[System.ComponentModel.CategoryAttribute("Quarter View")]
public:
property System.String^ DateFormatString {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Property Value

The default value is [quarter] [year].

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerQuarterView Class
WebSchedulerQuarterView Members


Enabled Property

[image]
Intersoft WebScheduler Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerQuarterView Class : Enabled Property

Glossary Item Box

Indicates whether QuarterView should be enabled. Indicates whether QuarterView should be enabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Indicates whether QuarterView should be enabled.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Quarter View")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Overrides Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerQuarterView
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[System.ComponentModel.DescriptionAttribute("Indicates whether QuarterView should be enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Quarter View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public override System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean; override;
JScript
System.ComponentModel.DescriptionAttribute("Indicates whether QuarterView should be enabled.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Quarter View")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public override function get,set Enabled : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Indicates whether QuarterView should be enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Quarter View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_Enabled() override;
public: __property void set_Enabled(
   System.bool value
) override;
C++/CLI
[System.ComponentModel.DescriptionAttribute("Indicates whether QuarterView should be enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Quarter View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool Enabled {
   System.bool get() override;
   void set (    System.bool value) override;
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerQuarterView Class
WebSchedulerQuarterView Members


WebSchedulerRecurrence Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurrence Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerRecurrence Class

Glossary Item Box

A collection of members in WebScheduler's recurrence.

Object Model

WebSchedulerRecurrence Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerRecurrence
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrence
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerRecurrence : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSchedulerRecurrence = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerRecurrence extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerRecurrence : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerRecurrence : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebScheduler.WebSchedulerRecurrence

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrence Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerRecurrence Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurrence Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerRecurrence Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerRecurrence.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerRecurrence Constructor |
Top

Public Properties

 | Name | Description
Public Property | Collection |
Public Property | EndDate | Specifies the EndDate of Recurrence. Specifies the Recurrence's EndDate.
Public Property | Exceptions | The data collection used by WebScheduler to determine Recurrence exception. Specifies the Recurrence's Exceptions.
Public Property | Mode | Specifies the Mode of Recurrence. Specifies the Recurrence's mode.
Public Property | NDay | Specifies the TotalRecurrences of Recurrence. Specifies the Recurrence's NDay.
Public Property | NMonth | Specifies the NMonth of Recurrence. Specifies the Recurrence's NMonth.
Public Property | NWeek | Specifies the NWeek of Recurrence. Specifies the Recurrence's NWeek.
Public Property | NYear | Specifies the NYear of Recurrence. Specifies the Recurrence's NYear.
Public Property | RangeMode | Specifies the RangeMode of Recurrence. Specifies the Recurrence's RangeMode.
Public Property | RecurrenceID | Specifies the RecurenceID. Specifies the Recurrence's RecurrenceID.
Public Property | StartDate | Specifies the StartDate of Recurrence. Specifies the Recurrence's StartDate.
Public Property | TotalRecurrences | Specifies the TotalRecurrences of Recurrence. Specifies the Recurrence's TotalRecurrences.
Public Property | WeekDays | Specifies the WeekDays of Recurrence. Specifies the Recurrence's WeekDays.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerRecurrence Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerRecurrence Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurrence Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrence Class : WebSchedulerRecurrence Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerRecurrence()
C#
public WebSchedulerRecurrence()
Delphi
public WebSchedulerRecurrence();
JScript
public function WebSchedulerRecurrence();
Managed Extensions for C++
public: WebSchedulerRecurrence();
C++/CLI
public:
WebSchedulerRecurrence();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrence Class
WebSchedulerRecurrence Members


WebSchedulerRecurrence Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurrence Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerRecurrence Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerRecurrence members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerRecurrence Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrence Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrence
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrence Class
WebSchedulerRecurrence Members


WebSchedulerRecurrence Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurrence Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerRecurrence Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerRecurrence members.

Public Properties

 | Name | Description
Public Property | Collection |
Public Property | EndDate | Specifies the EndDate of Recurrence. Specifies the Recurrence's EndDate.
Public Property | Exceptions | The data collection used by WebScheduler to determine Recurrence exception. Specifies the Recurrence's Exceptions.
Public Property | Mode | Specifies the Mode of Recurrence. Specifies the Recurrence's mode.
Public Property | NDay | Specifies the TotalRecurrences of Recurrence. Specifies the Recurrence's NDay.
Public Property | NMonth | Specifies the NMonth of Recurrence. Specifies the Recurrence's NMonth.
Public Property | NWeek | Specifies the NWeek of Recurrence. Specifies the Recurrence's NWeek.
Public Property | NYear | Specifies the NYear of Recurrence. Specifies the Recurrence's NYear.
Public Property | RangeMode | Specifies the RangeMode of Recurrence. Specifies the Recurrence's RangeMode.
Public Property | RecurrenceID | Specifies the RecurenceID. Specifies the Recurrence's RecurrenceID.
Public Property | StartDate | Specifies the StartDate of Recurrence. Specifies the Recurrence's StartDate.
Public Property | TotalRecurrences | Specifies the TotalRecurrences of Recurrence. Specifies the Recurrence's TotalRecurrences.
Public Property | WeekDays | Specifies the WeekDays of Recurrence. Specifies the Recurrence's WeekDays.
Top

See Also

Reference

WebSchedulerRecurrence Class
ISNet.WebUI.WebScheduler Namespace


Collection Property

[image]
Intersoft WebScheduler Documentation
Collection Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrence Class : Collection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.JsonSerialization.ScriptIgnoreAttribute()>
Public Property Collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrence
Dim value As ISNet.WebUI.ISCollectionBase(Of INamedObject2)

instance.Collection = value

value = instance.Collection
C#
[ISNet.Serialization.JsonSerialization.ScriptIgnoreAttribute()]
public ISNet.WebUI.ISCollectionBase<INamedObject2> Collection {get; set;}
Delphi
public read-write property Collection: ISNet.WebUI.ISCollectionBase;
JScript
ISNet.Serialization.JsonSerialization.ScriptIgnoreAttribute()
public function get,set Collection : ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[ISNet.Serialization.JsonSerialization.ScriptIgnoreAttribute()]
public: __property ISNet.WebUI.ISCollectionBase<INamedObject2*>* get_Collection();
public: __property void set_Collection(
   ISNet.WebUI.ISCollectionBase<INamedObject2*>* value
);
C++/CLI
[ISNet.Serialization.JsonSerialization.ScriptIgnoreAttribute()]
public:
property ISNet.WebUI.ISCollectionBase<INamedObject2^>^ Collection {
   ISNet.WebUI.ISCollectionBase<INamedObject2^>^ get();
   void set (    ISNet.WebUI.ISCollectionBase<INamedObject2^>^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrence Class
WebSchedulerRecurrence Members


EndDate Property

[image]
Intersoft WebScheduler Documentation
EndDate Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrence Class : EndDate Property

Glossary Item Box

Specifies the EndDate of Recurrence. Specifies the Recurrence's EndDate.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the EndDate of Recurrence.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Recurrence Info")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
Public Property EndDate As System.Date
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrence
Dim value As System.Date

instance.EndDate = value

value = instance.EndDate
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the EndDate of Recurrence.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public System.DateTime EndDate {get; set;}
Delphi
public read-write property EndDate: System.DateTime;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the EndDate of Recurrence.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Recurrence Info")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
public function get,set EndDate : System.DateTime
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the EndDate of Recurrence.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public: __property System.DateTime get_EndDate();
public: __property void set_EndDate(
   System.DateTime value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the EndDate of Recurrence.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public:
property System.DateTime EndDate {
   System.DateTime get();
   void set (    System.DateTime value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrence Class
WebSchedulerRecurrence Members


Exceptions Property

[image]
Intersoft WebScheduler Documentation
Exceptions Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrence Class : Exceptions Property

Glossary Item Box

The data collection used by WebScheduler to determine Recurrence exception. Specifies the Recurrence's Exceptions.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("setExceptions")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The data collection used by WebScheduler to determine Recurrence exception.")>
<System.ComponentModel.CategoryAttribute("Recurrence Info")>
Public ReadOnly Property Exceptions As WebSchedulerEventCollection
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrence
Dim value As WebSchedulerEventCollection

value = instance.Exceptions
C#
[ISNet.Serialization.BinarySerializableAttribute("setExceptions")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The data collection used by WebScheduler to determine Recurrence exception.")]
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
public WebSchedulerEventCollection Exceptions {get;}
Delphi
public read-only property Exceptions: WebSchedulerEventCollection;
JScript
ISNet.Serialization.BinarySerializableAttribute("setExceptions")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The data collection used by WebScheduler to determine Recurrence exception.")
System.ComponentModel.CategoryAttribute("Recurrence Info")
public function get Exceptions : WebSchedulerEventCollection
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("setExceptions")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The data collection used by WebScheduler to determine Recurrence exception.")]
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
public: __property WebSchedulerEventCollection* get_Exceptions();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("setExceptions")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The data collection used by WebScheduler to determine Recurrence exception.")]
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
public:
property WebSchedulerEventCollection^ Exceptions {
   WebSchedulerEventCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrence Class
WebSchedulerRecurrence Members


Mode Property

[image]
Intersoft WebScheduler Documentation
Mode Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrence Class : Mode Property

Glossary Item Box

Specifies the Mode of Recurrence. Specifies the Recurrence's mode.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Recurrence Info")>
<System.ComponentModel.DescriptionAttribute("Specifies the Mode of Recurrence.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
Public Property Mode As WebSchedulerRecurrenceMode
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrence
Dim value As WebSchedulerRecurrenceMode

instance.Mode = value

value = instance.Mode
C#
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
[System.ComponentModel.DescriptionAttribute("Specifies the Mode of Recurrence.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public WebSchedulerRecurrenceMode Mode {get; set;}
Delphi
public read-write property Mode: WebSchedulerRecurrenceMode;
JScript
System.ComponentModel.CategoryAttribute("Recurrence Info")
System.ComponentModel.DescriptionAttribute("Specifies the Mode of Recurrence.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
public function get,set Mode : WebSchedulerRecurrenceMode
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
[System.ComponentModel.DescriptionAttribute("Specifies the Mode of Recurrence.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public: __property WebSchedulerRecurrenceMode get_Mode();
public: __property void set_Mode(
   WebSchedulerRecurrenceMode value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
[System.ComponentModel.DescriptionAttribute("Specifies the Mode of Recurrence.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public:
property WebSchedulerRecurrenceMode Mode {
   WebSchedulerRecurrenceMode get();
   void set (    WebSchedulerRecurrenceMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrence Class
WebSchedulerRecurrence Members


NDay Property

[image]
Intersoft WebScheduler Documentation
NDay Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrence Class : NDay Property

Glossary Item Box

Specifies the TotalRecurrences of Recurrence. Specifies the Recurrence's NDay.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the TotalRecurrences of Recurrence.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Recurrence Info")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property NDay As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrence
Dim value As System.Integer

instance.NDay = value

value = instance.NDay
C#
[System.ComponentModel.DescriptionAttribute("Specifies the TotalRecurrences of Recurrence.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
[System.ComponentModel.DefaultValueAttribute()]
public System.int NDay {get; set;}
Delphi
public read-write property NDay: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the TotalRecurrences of Recurrence.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Recurrence Info")
System.ComponentModel.DefaultValueAttribute()
public function get,set NDay : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the TotalRecurrences of Recurrence.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_NDay();
public: __property void set_NDay(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the TotalRecurrences of Recurrence.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int NDay {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrence Class
WebSchedulerRecurrence Members


NMonth Property

[image]
Intersoft WebScheduler Documentation
NMonth Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrence Class : NMonth Property

Glossary Item Box

Specifies the NMonth of Recurrence. Specifies the Recurrence's NMonth.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Recurrence Info")>
<System.ComponentModel.DescriptionAttribute("Specifies the NMonth of Recurrence.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
Public Property NMonth As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrence
Dim value As System.Integer

instance.NMonth = value

value = instance.NMonth
C#
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
[System.ComponentModel.DescriptionAttribute("Specifies the NMonth of Recurrence.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public System.int NMonth {get; set;}
Delphi
public read-write property NMonth: System.Integer;
JScript
System.ComponentModel.CategoryAttribute("Recurrence Info")
System.ComponentModel.DescriptionAttribute("Specifies the NMonth of Recurrence.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
public function get,set NMonth : System.int
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
[System.ComponentModel.DescriptionAttribute("Specifies the NMonth of Recurrence.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public: __property System.int get_NMonth();
public: __property void set_NMonth(
   System.int value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
[System.ComponentModel.DescriptionAttribute("Specifies the NMonth of Recurrence.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public:
property System.int NMonth {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrence Class
WebSchedulerRecurrence Members


NWeek Property

[image]
Intersoft WebScheduler Documentation
NWeek Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrence Class : NWeek Property

Glossary Item Box

Specifies the NWeek of Recurrence. Specifies the Recurrence's NWeek.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Recurrence Info")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the NWeek of Recurrence.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
Public Property NWeek As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrence
Dim value As System.Integer

instance.NWeek = value

value = instance.NWeek
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the NWeek of Recurrence.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public System.int NWeek {get; set;}
Delphi
public read-write property NWeek: System.Integer;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Recurrence Info")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the NWeek of Recurrence.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
public function get,set NWeek : System.int
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the NWeek of Recurrence.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public: __property System.int get_NWeek();
public: __property void set_NWeek(
   System.int value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the NWeek of Recurrence.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public:
property System.int NWeek {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrence Class
WebSchedulerRecurrence Members


NYear Property

[image]
Intersoft WebScheduler Documentation
NYear Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrence Class : NYear Property

Glossary Item Box

Specifies the NYear of Recurrence. Specifies the Recurrence's NYear.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Recurrence Info")>
<System.ComponentModel.DescriptionAttribute("Specifies the NYear of Recurrence.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property NYear As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrence
Dim value As System.Integer

instance.NYear = value

value = instance.NYear
C#
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
[System.ComponentModel.DescriptionAttribute("Specifies the NYear of Recurrence.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.int NYear {get; set;}
Delphi
public read-write property NYear: System.Integer;
JScript
System.ComponentModel.CategoryAttribute("Recurrence Info")
System.ComponentModel.DescriptionAttribute("Specifies the NYear of Recurrence.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set NYear : System.int
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
[System.ComponentModel.DescriptionAttribute("Specifies the NYear of Recurrence.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.int get_NYear();
public: __property void set_NYear(
   System.int value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
[System.ComponentModel.DescriptionAttribute("Specifies the NYear of Recurrence.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.int NYear {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrence Class
WebSchedulerRecurrence Members


RangeMode Property

[image]
Intersoft WebScheduler Documentation
RangeMode Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrence Class : RangeMode Property

Glossary Item Box

Specifies the RangeMode of Recurrence. Specifies the Recurrence's RangeMode.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Recurrence Info")>
<System.ComponentModel.DescriptionAttribute("Specifies the RangeMode of Recurrence.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
Public Property RangeMode As WebSchedulerRecurrenceRangeMode
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrence
Dim value As WebSchedulerRecurrenceRangeMode

instance.RangeMode = value

value = instance.RangeMode
C#
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
[System.ComponentModel.DescriptionAttribute("Specifies the RangeMode of Recurrence.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public WebSchedulerRecurrenceRangeMode RangeMode {get; set;}
Delphi
public read-write property RangeMode: WebSchedulerRecurrenceRangeMode;
JScript
System.ComponentModel.CategoryAttribute("Recurrence Info")
System.ComponentModel.DescriptionAttribute("Specifies the RangeMode of Recurrence.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
public function get,set RangeMode : WebSchedulerRecurrenceRangeMode
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
[System.ComponentModel.DescriptionAttribute("Specifies the RangeMode of Recurrence.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public: __property WebSchedulerRecurrenceRangeMode get_RangeMode();
public: __property void set_RangeMode(
   WebSchedulerRecurrenceRangeMode value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
[System.ComponentModel.DescriptionAttribute("Specifies the RangeMode of Recurrence.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public:
property WebSchedulerRecurrenceRangeMode RangeMode {
   WebSchedulerRecurrenceRangeMode get();
   void set (    WebSchedulerRecurrenceRangeMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrence Class
WebSchedulerRecurrence Members


RecurrenceID Property

[image]
Intersoft WebScheduler Documentation
RecurrenceID Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrence Class : RecurrenceID Property

Glossary Item Box

Specifies the RecurenceID. Specifies the Recurrence's RecurrenceID.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Event Details")>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the RecurenceID.")>
Public Property RecurrenceID As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrence
Dim value As System.Integer

instance.RecurrenceID = value

value = instance.RecurrenceID
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Event Details")]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the RecurenceID.")]
public System.int RecurrenceID {get; set;}
Delphi
public read-write property RecurrenceID: System.Integer;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Event Details")
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the RecurenceID.")
public function get,set RecurrenceID : System.int
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Event Details")]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the RecurenceID.")]
public: __property System.int get_RecurrenceID();
public: __property void set_RecurrenceID(
   System.int value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Event Details")]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the RecurenceID.")]
public:
property System.int RecurrenceID {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrence Class
WebSchedulerRecurrence Members


StartDate Property

[image]
Intersoft WebScheduler Documentation
StartDate Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrence Class : StartDate Property

Glossary Item Box

Specifies the StartDate of Recurrence. Specifies the Recurrence's StartDate.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Recurrence Info")>
<System.ComponentModel.DescriptionAttribute("Specifies the StartDate of Recurrence.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property StartDate As System.Date
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrence
Dim value As System.Date

instance.StartDate = value

value = instance.StartDate
C#
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
[System.ComponentModel.DescriptionAttribute("Specifies the StartDate of Recurrence.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.DateTime StartDate {get; set;}
Delphi
public read-write property StartDate: System.DateTime;
JScript
System.ComponentModel.CategoryAttribute("Recurrence Info")
System.ComponentModel.DescriptionAttribute("Specifies the StartDate of Recurrence.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set StartDate : System.DateTime
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
[System.ComponentModel.DescriptionAttribute("Specifies the StartDate of Recurrence.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.DateTime get_StartDate();
public: __property void set_StartDate(
   System.DateTime value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
[System.ComponentModel.DescriptionAttribute("Specifies the StartDate of Recurrence.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.DateTime StartDate {
   System.DateTime get();
   void set (    System.DateTime value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrence Class
WebSchedulerRecurrence Members


TotalRecurrences Property

[image]
Intersoft WebScheduler Documentation
TotalRecurrences Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrence Class : TotalRecurrences Property

Glossary Item Box

Specifies the TotalRecurrences of Recurrence. Specifies the Recurrence's TotalRecurrences.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the TotalRecurrences of Recurrence.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Recurrence Info")>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
Public Property TotalRecurrences As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrence
Dim value As System.Integer

instance.TotalRecurrences = value

value = instance.TotalRecurrences
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the TotalRecurrences of Recurrence.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public System.int TotalRecurrences {get; set;}
Delphi
public read-write property TotalRecurrences: System.Integer;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the TotalRecurrences of Recurrence.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Recurrence Info")
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
public function get,set TotalRecurrences : System.int
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the TotalRecurrences of Recurrence.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public: __property System.int get_TotalRecurrences();
public: __property void set_TotalRecurrences(
   System.int value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the TotalRecurrences of Recurrence.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public:
property System.int TotalRecurrences {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrence Class
WebSchedulerRecurrence Members


WeekDays Property

[image]
Intersoft WebScheduler Documentation
WeekDays Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrence Class : WeekDays Property

Glossary Item Box

Specifies the WeekDays of Recurrence. Specifies the Recurrence's WeekDays.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the WeekDays of Recurrence.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Recurrence Info")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property WeekDays As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrence
Dim value As System.String

instance.WeekDays = value

value = instance.WeekDays
C#
[System.ComponentModel.DescriptionAttribute("Specifies the WeekDays of Recurrence.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string WeekDays {get; set;}
Delphi
public read-write property WeekDays: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the WeekDays of Recurrence.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Recurrence Info")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set WeekDays : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the WeekDays of Recurrence.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_WeekDays();
public: __property void set_WeekDays(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the WeekDays of Recurrence.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Recurrence Info")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ WeekDays {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrence Class
WebSchedulerRecurrence Members


WebSchedulerRecurrenceCollection Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurrenceCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerRecurrenceCollection Class

Glossary Item Box

The data collection used by WebScheduler to determine recurrence.

Object Model

WebSchedulerRecurrenceCollection Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerRecurrenceCollection
   Inherits ISNet.WebUI.ISGenericCollectionBase(Of WebSchedulerRecurrence)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceCollection
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerRecurrenceCollection : ISNet.WebUI.ISGenericCollectionBase<WebSchedulerRecurrence>
Delphi
public class WebSchedulerRecurrenceCollection = class(ISNet.WebUI.ISGenericCollectionBase)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerRecurrenceCollection extends ISNet.WebUI.ISGenericCollectionBase
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerRecurrenceCollection : public ISNet.WebUI.ISGenericCollectionBase<WebSchedulerRecurrence>
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerRecurrenceCollection : public ISNet.WebUI.ISGenericCollectionBase<WebSchedulerRecurrence>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
ISNet.WebUI.ISCollectionBase<T>
ISNet.WebUI.ISGenericCollectionBase<T>
ISNet.WebUI.WebScheduler.WebSchedulerRecurrenceCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceCollection Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerRecurrenceCollection Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurrenceCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerRecurrenceCollection Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerRecurrenceCollection.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerRecurrenceCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerRecurrence>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerRecurrence>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerRecurrence>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebSchedulerRecurrenceCollection Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerRecurrenceCollection Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurrenceCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceCollection Class : WebSchedulerRecurrenceCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerRecurrenceCollection()
C#
public WebSchedulerRecurrenceCollection()
Delphi
public WebSchedulerRecurrenceCollection();
JScript
public function WebSchedulerRecurrenceCollection();
Managed Extensions for C++
public: WebSchedulerRecurrenceCollection();
C++/CLI
public:
WebSchedulerRecurrenceCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceCollection Class
WebSchedulerRecurrenceCollection Members


WebSchedulerRecurrencesBinding Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurrencesBinding Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerRecurrencesBinding Class

Glossary Item Box

A collection of settings used for recurrence binding.

Object Model

WebSchedulerRecurrencesBinding Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerRecurrencesBinding
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrencesBinding
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerRecurrencesBinding : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSchedulerRecurrencesBinding = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerRecurrencesBinding extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerRecurrencesBinding : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerRecurrencesBinding : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebScheduler.WebSchedulerRecurrencesBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrencesBinding Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerRecurrencesBinding Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurrencesBinding Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerRecurrencesBinding Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerRecurrencesBinding.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerRecurrencesBinding Constructor |
Top

Public Properties

 | Name | Description
Public Property | EndDateField | Specifies the EndDate Field. Specifies the EndDate field.
Public Property | ModeField | Specifies the Mode Field. Specifies the mode field.
Public Property | NDayField | Specifies the NDay Field. Specifies the NDay field.
Public Property | NMonthField | Specifies the NMonth Field. Specifies the NMonth field.
Public Property | NWeekField | Specifies the NWeek Field. Specifies the NWeek field.
Public Property | NYearField | Specifies the NYear Field. Specifies the NYear field.
Public Property | RangeModeField | Specifies the RangeMode Field. Specifies the RangeMode field.
Public Property | RecurrenceIDField | Specifies the RecurrenceID Field. Specifies the RecurrenceID field.
Public Property | StartDateField | Specifies the StartDate Field. Specifies the StartDate field.
Public Property | TotalRecurrencesField | Specifies the TotalRecurrences Field. Specifies the TotalRecurrence field.
Public Property | WeekDaysField | Specifies the WeekDays Field. Specifies the WeekDays field.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerRecurrencesBinding Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerRecurrencesBinding Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurrencesBinding Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrencesBinding Class : WebSchedulerRecurrencesBinding Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerRecurrencesBinding()
C#
public WebSchedulerRecurrencesBinding()
Delphi
public WebSchedulerRecurrencesBinding();
JScript
public function WebSchedulerRecurrencesBinding();
Managed Extensions for C++
public: WebSchedulerRecurrencesBinding();
C++/CLI
public:
WebSchedulerRecurrencesBinding();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrencesBinding Class
WebSchedulerRecurrencesBinding Members


WebSchedulerRecurrencesBinding Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurrencesBinding Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerRecurrencesBinding Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerRecurrencesBinding members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerRecurrencesBinding Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrencesBinding Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrencesBinding
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrencesBinding Class
WebSchedulerRecurrencesBinding Members


WebSchedulerRecurrencesBinding Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurrencesBinding Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerRecurrencesBinding Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerRecurrencesBinding members.

Public Properties

 | Name | Description
Public Property | EndDateField | Specifies the EndDate Field. Specifies the EndDate field.
Public Property | ModeField | Specifies the Mode Field. Specifies the mode field.
Public Property | NDayField | Specifies the NDay Field. Specifies the NDay field.
Public Property | NMonthField | Specifies the NMonth Field. Specifies the NMonth field.
Public Property | NWeekField | Specifies the NWeek Field. Specifies the NWeek field.
Public Property | NYearField | Specifies the NYear Field. Specifies the NYear field.
Public Property | RangeModeField | Specifies the RangeMode Field. Specifies the RangeMode field.
Public Property | RecurrenceIDField | Specifies the RecurrenceID Field. Specifies the RecurrenceID field.
Public Property | StartDateField | Specifies the StartDate Field. Specifies the StartDate field.
Public Property | TotalRecurrencesField | Specifies the TotalRecurrences Field. Specifies the TotalRecurrence field.
Public Property | WeekDaysField | Specifies the WeekDays Field. Specifies the WeekDays field.
Top

See Also

Reference

WebSchedulerRecurrencesBinding Class
ISNet.WebUI.WebScheduler Namespace


EndDateField Property

[image]
Intersoft WebScheduler Documentation
EndDateField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrencesBinding Class : EndDateField Property

Glossary Item Box

Specifies the EndDate Field. Specifies the EndDate field.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.CategoryAttribute("Binding")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the EndDate Field.")>
Public Property EndDateField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrencesBinding
Dim value As System.String

instance.EndDateField = value

value = instance.EndDateField
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the EndDate Field.")]
public System.string EndDateField {get; set;}
Delphi
public read-write property EndDateField: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.CategoryAttribute("Binding")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the EndDate Field.")
public function get,set EndDateField : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the EndDate Field.")]
public: __property System.string* get_EndDateField();
public: __property void set_EndDateField(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the EndDate Field.")]
public:
property System.String^ EndDateField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrencesBinding Class
WebSchedulerRecurrencesBinding Members


ModeField Property

[image]
Intersoft WebScheduler Documentation
ModeField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrencesBinding Class : ModeField Property

Glossary Item Box

Specifies the Mode Field. Specifies the mode field.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Binding")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the Mode Field.")>
Public Property ModeField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrencesBinding
Dim value As System.String

instance.ModeField = value

value = instance.ModeField
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the Mode Field.")]
public System.string ModeField {get; set;}
Delphi
public read-write property ModeField: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Binding")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the Mode Field.")
public function get,set ModeField : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the Mode Field.")]
public: __property System.string* get_ModeField();
public: __property void set_ModeField(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the Mode Field.")]
public:
property System.String^ ModeField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrencesBinding Class
WebSchedulerRecurrencesBinding Members


NDayField Property

[image]
Intersoft WebScheduler Documentation
NDayField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrencesBinding Class : NDayField Property

Glossary Item Box

Specifies the NDay Field. Specifies the NDay field.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.CategoryAttribute("Binding")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the NDay Field.")>
Public Property NDayField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrencesBinding
Dim value As System.String

instance.NDayField = value

value = instance.NDayField
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the NDay Field.")]
public System.string NDayField {get; set;}
Delphi
public read-write property NDayField: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.CategoryAttribute("Binding")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the NDay Field.")
public function get,set NDayField : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the NDay Field.")]
public: __property System.string* get_NDayField();
public: __property void set_NDayField(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the NDay Field.")]
public:
property System.String^ NDayField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrencesBinding Class
WebSchedulerRecurrencesBinding Members


NMonthField Property

[image]
Intersoft WebScheduler Documentation
NMonthField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrencesBinding Class : NMonthField Property

Glossary Item Box

Specifies the NMonth Field. Specifies the NMonth field.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Binding")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the NMonth Field.")>
Public Property NMonthField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrencesBinding
Dim value As System.String

instance.NMonthField = value

value = instance.NMonthField
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the NMonth Field.")]
public System.string NMonthField {get; set;}
Delphi
public read-write property NMonthField: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Binding")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the NMonth Field.")
public function get,set NMonthField : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the NMonth Field.")]
public: __property System.string* get_NMonthField();
public: __property void set_NMonthField(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the NMonth Field.")]
public:
property System.String^ NMonthField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrencesBinding Class
WebSchedulerRecurrencesBinding Members


NWeekField Property

[image]
Intersoft WebScheduler Documentation
NWeekField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrencesBinding Class : NWeekField Property

Glossary Item Box

Specifies the NWeek Field. Specifies the NWeek field.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Binding")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the NWeek Field.")>
Public Property NWeekField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrencesBinding
Dim value As System.String

instance.NWeekField = value

value = instance.NWeekField
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the NWeek Field.")]
public System.string NWeekField {get; set;}
Delphi
public read-write property NWeekField: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Binding")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the NWeek Field.")
public function get,set NWeekField : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the NWeek Field.")]
public: __property System.string* get_NWeekField();
public: __property void set_NWeekField(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the NWeek Field.")]
public:
property System.String^ NWeekField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrencesBinding Class
WebSchedulerRecurrencesBinding Members


NYearField Property

[image]
Intersoft WebScheduler Documentation
NYearField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrencesBinding Class : NYearField Property

Glossary Item Box

Specifies the NYear Field. Specifies the NYear field.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Binding")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the NYear Field.")>
Public Property NYearField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrencesBinding
Dim value As System.String

instance.NYearField = value

value = instance.NYearField
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the NYear Field.")]
public System.string NYearField {get; set;}
Delphi
public read-write property NYearField: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Binding")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the NYear Field.")
public function get,set NYearField : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the NYear Field.")]
public: __property System.string* get_NYearField();
public: __property void set_NYearField(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the NYear Field.")]
public:
property System.String^ NYearField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrencesBinding Class
WebSchedulerRecurrencesBinding Members


RangeModeField Property

[image]
Intersoft WebScheduler Documentation
RangeModeField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrencesBinding Class : RangeModeField Property

Glossary Item Box

Specifies the RangeMode Field. Specifies the RangeMode field.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.CategoryAttribute("Binding")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the RangeMode Field.")>
Public Property RangeModeField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrencesBinding
Dim value As System.String

instance.RangeModeField = value

value = instance.RangeModeField
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the RangeMode Field.")]
public System.string RangeModeField {get; set;}
Delphi
public read-write property RangeModeField: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.CategoryAttribute("Binding")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the RangeMode Field.")
public function get,set RangeModeField : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the RangeMode Field.")]
public: __property System.string* get_RangeModeField();
public: __property void set_RangeModeField(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the RangeMode Field.")]
public:
property System.String^ RangeModeField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrencesBinding Class
WebSchedulerRecurrencesBinding Members


RecurrenceIDField Property

[image]
Intersoft WebScheduler Documentation
RecurrenceIDField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrencesBinding Class : RecurrenceIDField Property

Glossary Item Box

Specifies the RecurrenceID Field. Specifies the RecurrenceID field.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the RecurrenceID Field.")>
<System.ComponentModel.CategoryAttribute("Binding")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property RecurrenceIDField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrencesBinding
Dim value As System.String

instance.RecurrenceIDField = value

value = instance.RecurrenceIDField
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the RecurrenceID Field.")]
[System.ComponentModel.CategoryAttribute("Binding")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string RecurrenceIDField {get; set;}
Delphi
public read-write property RecurrenceIDField: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the RecurrenceID Field.")
System.ComponentModel.CategoryAttribute("Binding")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set RecurrenceIDField : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the RecurrenceID Field.")]
[System.ComponentModel.CategoryAttribute("Binding")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_RecurrenceIDField();
public: __property void set_RecurrenceIDField(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the RecurrenceID Field.")]
[System.ComponentModel.CategoryAttribute("Binding")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ RecurrenceIDField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrencesBinding Class
WebSchedulerRecurrencesBinding Members


StartDateField Property

[image]
Intersoft WebScheduler Documentation
StartDateField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrencesBinding Class : StartDateField Property

Glossary Item Box

Specifies the StartDate Field. Specifies the StartDate field.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Binding")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the StartDate Field.")>
Public Property StartDateField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrencesBinding
Dim value As System.String

instance.StartDateField = value

value = instance.StartDateField
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the StartDate Field.")]
public System.string StartDateField {get; set;}
Delphi
public read-write property StartDateField: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Binding")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the StartDate Field.")
public function get,set StartDateField : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the StartDate Field.")]
public: __property System.string* get_StartDateField();
public: __property void set_StartDateField(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the StartDate Field.")]
public:
property System.String^ StartDateField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrencesBinding Class
WebSchedulerRecurrencesBinding Members


TotalRecurrencesField Property

[image]
Intersoft WebScheduler Documentation
TotalRecurrencesField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrencesBinding Class : TotalRecurrencesField Property

Glossary Item Box

Specifies the TotalRecurrences Field. Specifies the TotalRecurrence field.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Binding")>
<System.ComponentModel.DescriptionAttribute("Specifies the TotalRecurrences Field.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property TotalRecurrencesField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrencesBinding
Dim value As System.String

instance.TotalRecurrencesField = value

value = instance.TotalRecurrencesField
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Specifies the TotalRecurrences Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string TotalRecurrencesField {get; set;}
Delphi
public read-write property TotalRecurrencesField: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Binding")
System.ComponentModel.DescriptionAttribute("Specifies the TotalRecurrences Field.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set TotalRecurrencesField : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Specifies the TotalRecurrences Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_TotalRecurrencesField();
public: __property void set_TotalRecurrencesField(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Specifies the TotalRecurrences Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ TotalRecurrencesField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrencesBinding Class
WebSchedulerRecurrencesBinding Members


WeekDaysField Property

[image]
Intersoft WebScheduler Documentation
WeekDaysField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrencesBinding Class : WeekDaysField Property

Glossary Item Box

Specifies the WeekDays Field. Specifies the WeekDays field.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Binding")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the WeekDays Field.")>
Public Property WeekDaysField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrencesBinding
Dim value As System.String

instance.WeekDaysField = value

value = instance.WeekDaysField
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the WeekDays Field.")]
public System.string WeekDaysField {get; set;}
Delphi
public read-write property WeekDaysField: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Binding")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the WeekDays Field.")
public function get,set WeekDaysField : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the WeekDays Field.")]
public: __property System.string* get_WeekDaysField();
public: __property void set_WeekDaysField(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the WeekDays Field.")]
public:
property System.String^ WeekDaysField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrencesBinding Class
WebSchedulerRecurrencesBinding Members


WebSchedulerRecurrenceTextSettings Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurrenceTextSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerRecurrenceTextSettings Class

Glossary Item Box

A collection of tooltip text used for recurrence text settings.

Object Model

WebSchedulerRecurrenceTextSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerRecurrenceTextSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceTextSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerRecurrenceTextSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSchedulerRecurrenceTextSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerRecurrenceTextSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerRecurrenceTextSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerRecurrenceTextSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebScheduler.WebSchedulerRecurrenceTextSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceTextSettings Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerRecurrenceTextSettings Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurrenceTextSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerRecurrenceTextSettings Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerRecurrenceTextSettings.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerRecurrenceTextSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | DailyNDayToolTipText | Specifies DailyNDay tooltip text.
Public Property | DailyWeekDayToolTipText | Specifies WeekDay tooltip text.
Public Property | EndAfterNRecurrenceToolTipText | Specifies EndAfterRecurrence tooltip text.
Public Property | EndByDateToolTipText | Specifies EndByDate tooltip text.
Public Property | ExceptionToolTipText | Specifies Exception tooltip text.
Public Property | MonthlyToolTipText | Specifies Monthly tooltip text.
Public Property | WeeklyToolTipText | Specifies Weekly tooltip text.
Public Property | YearlyToolTipText | Specifies Yearly tooltip text.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerRecurrenceTextSettings Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerRecurrenceTextSettings Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurrenceTextSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceTextSettings Class : WebSchedulerRecurrenceTextSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerRecurrenceTextSettings()
C#
public WebSchedulerRecurrenceTextSettings()
Delphi
public WebSchedulerRecurrenceTextSettings();
JScript
public function WebSchedulerRecurrenceTextSettings();
Managed Extensions for C++
public: WebSchedulerRecurrenceTextSettings();
C++/CLI
public:
WebSchedulerRecurrenceTextSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceTextSettings Class
WebSchedulerRecurrenceTextSettings Members


WebSchedulerRecurrenceTextSettings Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurrenceTextSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerRecurrenceTextSettings Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerRecurrenceTextSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerRecurrenceTextSettings Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceTextSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceTextSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceTextSettings Class
WebSchedulerRecurrenceTextSettings Members


WebSchedulerRecurrenceTextSettings Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurrenceTextSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerRecurrenceTextSettings Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerRecurrenceTextSettings members.

Public Properties

 | Name | Description
Public Property | DailyNDayToolTipText | Specifies DailyNDay tooltip text.
Public Property | DailyWeekDayToolTipText | Specifies WeekDay tooltip text.
Public Property | EndAfterNRecurrenceToolTipText | Specifies EndAfterRecurrence tooltip text.
Public Property | EndByDateToolTipText | Specifies EndByDate tooltip text.
Public Property | ExceptionToolTipText | Specifies Exception tooltip text.
Public Property | MonthlyToolTipText | Specifies Monthly tooltip text.
Public Property | WeeklyToolTipText | Specifies Weekly tooltip text.
Public Property | YearlyToolTipText | Specifies Yearly tooltip text.
Top

See Also

Reference

WebSchedulerRecurrenceTextSettings Class
ISNet.WebUI.WebScheduler Namespace


DailyNDayToolTipText Property

[image]
Intersoft WebScheduler Documentation
DailyNDayToolTipText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceTextSettings Class : DailyNDayToolTipText Property

Glossary Item Box

Specifies DailyNDay tooltip text.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Recurrence Text Settings")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property DailyNDayToolTipText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceTextSettings
Dim value As System.String

instance.DailyNDayToolTipText = value

value = instance.DailyNDayToolTipText
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Recurrence Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string DailyNDayToolTipText {get; set;}
Delphi
public read-write property DailyNDayToolTipText: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Recurrence Text Settings")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set DailyNDayToolTipText : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Recurrence Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_DailyNDayToolTipText();
public: __property void set_DailyNDayToolTipText(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Recurrence Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ DailyNDayToolTipText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceTextSettings Class
WebSchedulerRecurrenceTextSettings Members


DailyWeekDayToolTipText Property

[image]
Intersoft WebScheduler Documentation
DailyWeekDayToolTipText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceTextSettings Class : DailyWeekDayToolTipText Property

Glossary Item Box

Specifies WeekDay tooltip text.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Recurrence Text Settings")>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property DailyWeekDayToolTipText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceTextSettings
Dim value As System.String

instance.DailyWeekDayToolTipText = value

value = instance.DailyWeekDayToolTipText
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Recurrence Text Settings")]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string DailyWeekDayToolTipText {get; set;}
Delphi
public read-write property DailyWeekDayToolTipText: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Recurrence Text Settings")
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set DailyWeekDayToolTipText : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Recurrence Text Settings")]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_DailyWeekDayToolTipText();
public: __property void set_DailyWeekDayToolTipText(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Recurrence Text Settings")]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ DailyWeekDayToolTipText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceTextSettings Class
WebSchedulerRecurrenceTextSettings Members


EndAfterNRecurrenceToolTipText Property

[image]
Intersoft WebScheduler Documentation
EndAfterNRecurrenceToolTipText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceTextSettings Class : EndAfterNRecurrenceToolTipText Property

Glossary Item Box

Specifies EndAfterRecurrence tooltip text.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Recurrence Text Settings")>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property EndAfterNRecurrenceToolTipText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceTextSettings
Dim value As System.String

instance.EndAfterNRecurrenceToolTipText = value

value = instance.EndAfterNRecurrenceToolTipText
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Recurrence Text Settings")]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string EndAfterNRecurrenceToolTipText {get; set;}
Delphi
public read-write property EndAfterNRecurrenceToolTipText: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Recurrence Text Settings")
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set EndAfterNRecurrenceToolTipText : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Recurrence Text Settings")]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_EndAfterNRecurrenceToolTipText();
public: __property void set_EndAfterNRecurrenceToolTipText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Recurrence Text Settings")]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ EndAfterNRecurrenceToolTipText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceTextSettings Class
WebSchedulerRecurrenceTextSettings Members


EndByDateToolTipText Property

[image]
Intersoft WebScheduler Documentation
EndByDateToolTipText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceTextSettings Class : EndByDateToolTipText Property

Glossary Item Box

Specifies EndByDate tooltip text.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Recurrence Text Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property EndByDateToolTipText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceTextSettings
Dim value As System.String

instance.EndByDateToolTipText = value

value = instance.EndByDateToolTipText
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Recurrence Text Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string EndByDateToolTipText {get; set;}
Delphi
public read-write property EndByDateToolTipText: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Recurrence Text Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set EndByDateToolTipText : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Recurrence Text Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_EndByDateToolTipText();
public: __property void set_EndByDateToolTipText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Recurrence Text Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ EndByDateToolTipText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceTextSettings Class
WebSchedulerRecurrenceTextSettings Members


ExceptionToolTipText Property

[image]
Intersoft WebScheduler Documentation
ExceptionToolTipText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceTextSettings Class : ExceptionToolTipText Property

Glossary Item Box

Specifies Exception tooltip text.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Recurrence Text Settings")>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ExceptionToolTipText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceTextSettings
Dim value As System.String

instance.ExceptionToolTipText = value

value = instance.ExceptionToolTipText
C#
[System.ComponentModel.CategoryAttribute("Recurrence Text Settings")]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string ExceptionToolTipText {get; set;}
Delphi
public read-write property ExceptionToolTipText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Recurrence Text Settings")
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ExceptionToolTipText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Recurrence Text Settings")]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_ExceptionToolTipText();
public: __property void set_ExceptionToolTipText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Recurrence Text Settings")]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ ExceptionToolTipText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceTextSettings Class
WebSchedulerRecurrenceTextSettings Members


MonthlyToolTipText Property

[image]
Intersoft WebScheduler Documentation
MonthlyToolTipText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceTextSettings Class : MonthlyToolTipText Property

Glossary Item Box

Specifies Monthly tooltip text.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Recurrence Text Settings")>
<System.ComponentModel.DescriptionAttribute()>
Public Property MonthlyToolTipText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceTextSettings
Dim value As System.String

instance.MonthlyToolTipText = value

value = instance.MonthlyToolTipText
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Recurrence Text Settings")]
[System.ComponentModel.DescriptionAttribute()]
public System.string MonthlyToolTipText {get; set;}
Delphi
public read-write property MonthlyToolTipText: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Recurrence Text Settings")
System.ComponentModel.DescriptionAttribute()
public function get,set MonthlyToolTipText : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Recurrence Text Settings")]
[System.ComponentModel.DescriptionAttribute()]
public: __property System.string* get_MonthlyToolTipText();
public: __property void set_MonthlyToolTipText(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Recurrence Text Settings")]
[System.ComponentModel.DescriptionAttribute()]
public:
property System.String^ MonthlyToolTipText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceTextSettings Class
WebSchedulerRecurrenceTextSettings Members


WeeklyToolTipText Property

[image]
Intersoft WebScheduler Documentation
WeeklyToolTipText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceTextSettings Class : WeeklyToolTipText Property

Glossary Item Box

Specifies Weekly tooltip text.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Recurrence Text Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute()>
Public Property WeeklyToolTipText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceTextSettings
Dim value As System.String

instance.WeeklyToolTipText = value

value = instance.WeeklyToolTipText
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Recurrence Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public System.string WeeklyToolTipText {get; set;}
Delphi
public read-write property WeeklyToolTipText: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Recurrence Text Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute()
public function get,set WeeklyToolTipText : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Recurrence Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public: __property System.string* get_WeeklyToolTipText();
public: __property void set_WeeklyToolTipText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Recurrence Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public:
property System.String^ WeeklyToolTipText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceTextSettings Class
WebSchedulerRecurrenceTextSettings Members


YearlyToolTipText Property

[image]
Intersoft WebScheduler Documentation
YearlyToolTipText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceTextSettings Class : YearlyToolTipText Property

Glossary Item Box

Specifies Yearly tooltip text.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Recurrence Text Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property YearlyToolTipText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceTextSettings
Dim value As System.String

instance.YearlyToolTipText = value

value = instance.YearlyToolTipText
C#
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Recurrence Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string YearlyToolTipText {get; set;}
Delphi
public read-write property YearlyToolTipText: System.String;
JScript
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Recurrence Text Settings")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set YearlyToolTipText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Recurrence Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_YearlyToolTipText();
public: __property void set_YearlyToolTipText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Recurrence Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ YearlyToolTipText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceTextSettings Class
WebSchedulerRecurrenceTextSettings Members


WebSchedulerRecurringEvent Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurringEvent Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerRecurringEvent Class

Glossary Item Box

A collection of recurring events used by WebScheduler.

Object Model

WebSchedulerRecurringEvent Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerRecurringEvent
   Inherits WebSchedulerEventBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurringEvent
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerRecurringEvent : WebSchedulerEventBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Delphi
public class WebSchedulerRecurringEvent = class(WebSchedulerEventBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerRecurringEvent extends WebSchedulerEventBase implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerRecurringEvent : public WebSchedulerEventBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerRecurringEvent : public WebSchedulerEventBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase2
ISNet.WebUI.WebScheduler.WebSchedulerEventBase
ISNet.WebUI.WebScheduler.WebSchedulerRecurringEvent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEvent Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerRecurringEvent Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurringEvent Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerRecurringEvent Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerRecurringEvent.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerRecurringEvent Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllDayEvent | Indicates whether the event is AllDayEvent. Specifies the EventBase's AllDayEvent. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | CategoryID | Gets or sets the CategoryID. Specifies the EventBase's CategoryID. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | Collection | (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | Description | Gets or sets the Description of the event. Specifies the EventBase's description. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | EndTime | Gets or sets the EndTime of the event. Specifies the EventBase's EndTime. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | EventID | Gets or sets the EventID. Specifies the EventBase's EventID. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | ExceptionDate | Specifies the ExceptionDate of the Recurrence. Specifies the ExceptionDate of recurring event.
Public Property | ExceptionInfo | Specifies the ExceptionInfo of the Recurrence. Specifies the ExceptionInfo of recurring event.
Public Property | Location | Gets or sets the Location of the event. Specifies the EventBase's location. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | Mode | Specifies the event's Mode. Specifies the EventBase's mode. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | Name | Overridden.
Public Property | ParentID | Specifies the ParentID of the Recurrence. Specifies the ParentID of recurring event.
Public Property | RecurrenceID | Specifies the RecurrenceID of the Recurrence. Specifies the RecurrenceID of recurring event.
Public Property | RecurrenceInfo | Specifies the RecurrenceInfo of the Recurrence. Specifies the RecurrenceInfo of recurring event.
Public Property | ReminderTimeSpan | Specifies the event's ReminderTimeSpan. Specifies the EventBase's ReminderTimeSpan. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | ResourceID | Gets or sets the ResourceID. Specifies the EventBase's ResourceID. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | StartTime | Gets or sets the StartTime of the event. Specifies the EventBase's StartTime. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | Subject | Gets or sets the Subject of the event. Specifies the EventBase's subject. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | Tooltip | Specifies the event's ToolTip. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerRecurringEvent Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerRecurringEvent Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurringEvent Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEvent Class : WebSchedulerRecurringEvent Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerRecurringEvent()
C#
public WebSchedulerRecurringEvent()
Delphi
public WebSchedulerRecurringEvent();
JScript
public function WebSchedulerRecurringEvent();
Managed Extensions for C++
public: WebSchedulerRecurringEvent();
C++/CLI
public:
WebSchedulerRecurringEvent();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEvent Class
WebSchedulerRecurringEvent Members


WebSchedulerRecurringEvent Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurringEvent Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerRecurringEvent Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerRecurringEvent members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerRecurringEvent Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEvent Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurringEvent
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEvent Class
WebSchedulerRecurringEvent Members


WebSchedulerRecurringEvent Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurringEvent Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerRecurringEvent Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerRecurringEvent members.

Public Properties

 | Name | Description
Public Property | AllDayEvent | Indicates whether the event is AllDayEvent. Specifies the EventBase's AllDayEvent. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | CategoryID | Gets or sets the CategoryID. Specifies the EventBase's CategoryID. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | Collection | (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | Description | Gets or sets the Description of the event. Specifies the EventBase's description. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | EndTime | Gets or sets the EndTime of the event. Specifies the EventBase's EndTime. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | EventID | Gets or sets the EventID. Specifies the EventBase's EventID. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | ExceptionDate | Specifies the ExceptionDate of the Recurrence. Specifies the ExceptionDate of recurring event.
Public Property | ExceptionInfo | Specifies the ExceptionInfo of the Recurrence. Specifies the ExceptionInfo of recurring event.
Public Property | Location | Gets or sets the Location of the event. Specifies the EventBase's location. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | Mode | Specifies the event's Mode. Specifies the EventBase's mode. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | Name | Overridden.
Public Property | ParentID | Specifies the ParentID of the Recurrence. Specifies the ParentID of recurring event.
Public Property | RecurrenceID | Specifies the RecurrenceID of the Recurrence. Specifies the RecurrenceID of recurring event.
Public Property | RecurrenceInfo | Specifies the RecurrenceInfo of the Recurrence. Specifies the RecurrenceInfo of recurring event.
Public Property | ReminderTimeSpan | Specifies the event's ReminderTimeSpan. Specifies the EventBase's ReminderTimeSpan. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | ResourceID | Gets or sets the ResourceID. Specifies the EventBase's ResourceID. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | StartTime | Gets or sets the StartTime of the event. Specifies the EventBase's StartTime. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | Subject | Gets or sets the Subject of the event. Specifies the EventBase's subject. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | Tooltip | Specifies the event's ToolTip. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Top

See Also

Reference

WebSchedulerRecurringEvent Class
ISNet.WebUI.WebScheduler Namespace


ExceptionDate Property

[image]
Intersoft WebScheduler Documentation
ExceptionDate Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEvent Class : ExceptionDate Property

Glossary Item Box

Specifies the ExceptionDate of the Recurrence. Specifies the ExceptionDate of recurring event.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
<System.ComponentModel.CategoryAttribute("Recurring Event Details")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ExceptionDate As System.Date
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurringEvent
Dim value As System.Date

instance.ExceptionDate = value

value = instance.ExceptionDate
C#
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.CategoryAttribute("Recurring Event Details")]
[System.ComponentModel.DefaultValueAttribute()]
public System.DateTime ExceptionDate {get; set;}
Delphi
public read-write property ExceptionDate: System.DateTime;
JScript
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
System.ComponentModel.CategoryAttribute("Recurring Event Details")
System.ComponentModel.DefaultValueAttribute()
public function get,set ExceptionDate : System.DateTime
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.CategoryAttribute("Recurring Event Details")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.DateTime get_ExceptionDate();
public: __property void set_ExceptionDate(
   System.DateTime value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.CategoryAttribute("Recurring Event Details")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.DateTime ExceptionDate {
   System.DateTime get();
   void set (    System.DateTime value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEvent Class
WebSchedulerRecurringEvent Members


ExceptionInfo Property

[image]
Intersoft WebScheduler Documentation
ExceptionInfo Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEvent Class : ExceptionInfo Property

Glossary Item Box

Specifies the ExceptionInfo of the Recurrence. Specifies the ExceptionInfo of recurring event.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Recurring Event Details")>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ExceptionInfo As WebSchedulerExceptionInfo
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurringEvent
Dim value As WebSchedulerExceptionInfo

instance.ExceptionInfo = value

value = instance.ExceptionInfo
C#
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Recurring Event Details")]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public WebSchedulerExceptionInfo ExceptionInfo {get; set;}
Delphi
public read-write property ExceptionInfo: WebSchedulerExceptionInfo;
JScript
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Recurring Event Details")
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set ExceptionInfo : WebSchedulerExceptionInfo
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Recurring Event Details")]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebSchedulerExceptionInfo get_ExceptionInfo();
public: __property void set_ExceptionInfo(
   WebSchedulerExceptionInfo value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Recurring Event Details")]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebSchedulerExceptionInfo ExceptionInfo {
   WebSchedulerExceptionInfo get();
   void set (    WebSchedulerExceptionInfo value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEvent Class
WebSchedulerRecurringEvent Members


Name Property

[image]
Intersoft WebScheduler Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEvent Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
Public Overrides Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurringEvent
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public override System.string Name {get; set;}
Delphi
public read-write property Name: System.String; override;
JScript
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
public override function get,set Name : System.String
Managed Extensions for C++
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public: __property System.string* get_Name() override;
public: __property void set_Name(
   System.string* value
) override;
C++/CLI
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public:
property System.String^ Name {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEvent Class
WebSchedulerRecurringEvent Members


ParentID Property

[image]
Intersoft WebScheduler Documentation
ParentID Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEvent Class : ParentID Property

Glossary Item Box

Specifies the ParentID of the Recurrence. Specifies the ParentID of recurring event.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the ParentID of the Recurrence.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Recurring Event Details")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ParentID As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurringEvent
Dim value As System.Integer

instance.ParentID = value

value = instance.ParentID
C#
[System.ComponentModel.DescriptionAttribute("Specifies the ParentID of the Recurrence.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Recurring Event Details")]
[System.ComponentModel.DefaultValueAttribute()]
public System.int ParentID {get; set;}
Delphi
public read-write property ParentID: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the ParentID of the Recurrence.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Recurring Event Details")
System.ComponentModel.DefaultValueAttribute()
public function get,set ParentID : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the ParentID of the Recurrence.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Recurring Event Details")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_ParentID();
public: __property void set_ParentID(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the ParentID of the Recurrence.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Recurring Event Details")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int ParentID {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEvent Class
WebSchedulerRecurringEvent Members


RecurrenceID Property

[image]
Intersoft WebScheduler Documentation
RecurrenceID Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEvent Class : RecurrenceID Property

Glossary Item Box

Specifies the RecurrenceID of the Recurrence. Specifies the RecurrenceID of recurring event.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the RecurrenceID of the Recurrence.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
<System.ComponentModel.CategoryAttribute("Recurring Event Details")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property RecurrenceID As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurringEvent
Dim value As System.Integer

instance.RecurrenceID = value

value = instance.RecurrenceID
C#
[System.ComponentModel.DescriptionAttribute("Specifies the RecurrenceID of the Recurrence.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.CategoryAttribute("Recurring Event Details")]
[System.ComponentModel.DefaultValueAttribute()]
public System.int RecurrenceID {get; set;}
Delphi
public read-write property RecurrenceID: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the RecurrenceID of the Recurrence.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
System.ComponentModel.CategoryAttribute("Recurring Event Details")
System.ComponentModel.DefaultValueAttribute()
public function get,set RecurrenceID : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the RecurrenceID of the Recurrence.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.CategoryAttribute("Recurring Event Details")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_RecurrenceID();
public: __property void set_RecurrenceID(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the RecurrenceID of the Recurrence.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.CategoryAttribute("Recurring Event Details")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int RecurrenceID {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEvent Class
WebSchedulerRecurringEvent Members


RecurrenceInfo Property

[image]
Intersoft WebScheduler Documentation
RecurrenceInfo Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEvent Class : RecurrenceInfo Property

Glossary Item Box

Specifies the RecurrenceInfo of the Recurrence. Specifies the RecurrenceInfo of recurring event.

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
<System.ComponentModel.CategoryAttribute("Recurring Event Details")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute()>
Public Property RecurrenceInfo As WebSchedulerRecurrence
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurringEvent
Dim value As WebSchedulerRecurrence

instance.RecurrenceInfo = value

value = instance.RecurrenceInfo
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.CategoryAttribute("Recurring Event Details")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public WebSchedulerRecurrence RecurrenceInfo {get; set;}
Delphi
public read-write property RecurrenceInfo: WebSchedulerRecurrence;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
System.ComponentModel.CategoryAttribute("Recurring Event Details")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute()
public function get,set RecurrenceInfo : WebSchedulerRecurrence
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.CategoryAttribute("Recurring Event Details")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public: __property WebSchedulerRecurrence* get_RecurrenceInfo();
public: __property void set_RecurrenceInfo(
   WebSchedulerRecurrence* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.CategoryAttribute("Recurring Event Details")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public:
property WebSchedulerRecurrence^ RecurrenceInfo {
   WebSchedulerRecurrence^ get();
   void set (    WebSchedulerRecurrence^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEvent Class
WebSchedulerRecurringEvent Members


WebSchedulerRecurringEventBinding Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurringEventBinding Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerRecurringEventBinding Class

Glossary Item Box

A collection of settings used for RecurringEvents binding.

Object Model

WebSchedulerRecurringEventBinding Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerRecurringEventBinding
   Inherits WebSchedulerEventsBindingBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurringEventBinding
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerRecurringEventBinding : WebSchedulerEventsBindingBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSchedulerRecurringEventBinding = class(WebSchedulerEventsBindingBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerRecurringEventBinding extends WebSchedulerEventsBindingBase implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerRecurringEventBinding : public WebSchedulerEventsBindingBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerRecurringEventBinding : public WebSchedulerEventsBindingBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase
ISNet.WebUI.WebScheduler.WebSchedulerRecurringEventBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEventBinding Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerRecurringEventBinding Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurringEventBinding Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerRecurringEventBinding Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerRecurringEventBinding.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerRecurringEventBinding Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllDayEventField | Specifies the AllDayEvent Field. Specifies the AllDayEvent field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | CategoryIDField | Specifies the CategoryID Field. Specifies the CategoryID field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | DescriptionField | Specifies the Description Field. Specifies the Description field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | EndTimeField | Specifies the EndTime Field. Specifies the EndTime field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | EventIDField | Specifies the EventID Field. Specifies the EventID field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | ExceptionDateField | Specifies the ExceptionDate Field. Specifies the ExceptionDate field.
Public Property | ExceptionInfoField | Specifies the ExceptionInfo Field. Specifies the ExceptionInfo field.
Public Property | LocationField | Specifies the Location Field. Specifies the Location field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | ModeField | Specifies the Mode Field. Specifies the Mode field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | ParentIDField | Specifies the ParentID Field. Specifies ParentID field.
Public Property | RecurrenceIDField | Specifies the RecurrenceID Field. Specifies RecurrenceID field.
Public Property | ReminderTimeSpanField | Specifies the ReminderTimeSpan Field. Specifies the ReminderTimeSpan field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | ResourceIDField | Specifies the ResourceID Field. Specifies the ResourceID field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | StartTimeField | Specifies the StartTime Field. Specifies the StartTime field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | SubjectField | Specifies the Subject Field. Specifies the Subject field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerRecurringEventBinding Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerRecurringEventBinding Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurringEventBinding Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEventBinding Class : WebSchedulerRecurringEventBinding Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerRecurringEventBinding()
C#
public WebSchedulerRecurringEventBinding()
Delphi
public WebSchedulerRecurringEventBinding();
JScript
public function WebSchedulerRecurringEventBinding();
Managed Extensions for C++
public: WebSchedulerRecurringEventBinding();
C++/CLI
public:
WebSchedulerRecurringEventBinding();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEventBinding Class
WebSchedulerRecurringEventBinding Members


WebSchedulerRecurringEventBinding Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurringEventBinding Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerRecurringEventBinding Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerRecurringEventBinding members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerRecurringEventBinding Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEventBinding Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurringEventBinding
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEventBinding Class
WebSchedulerRecurringEventBinding Members


WebSchedulerRecurringEventBinding Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurringEventBinding Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerRecurringEventBinding Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerRecurringEventBinding members.

Public Properties

 | Name | Description
Public Property | AllDayEventField | Specifies the AllDayEvent Field. Specifies the AllDayEvent field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | CategoryIDField | Specifies the CategoryID Field. Specifies the CategoryID field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | DescriptionField | Specifies the Description Field. Specifies the Description field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | EndTimeField | Specifies the EndTime Field. Specifies the EndTime field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | EventIDField | Specifies the EventID Field. Specifies the EventID field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | ExceptionDateField | Specifies the ExceptionDate Field. Specifies the ExceptionDate field.
Public Property | ExceptionInfoField | Specifies the ExceptionInfo Field. Specifies the ExceptionInfo field.
Public Property | LocationField | Specifies the Location Field. Specifies the Location field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | ModeField | Specifies the Mode Field. Specifies the Mode field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | ParentIDField | Specifies the ParentID Field. Specifies ParentID field.
Public Property | RecurrenceIDField | Specifies the RecurrenceID Field. Specifies RecurrenceID field.
Public Property | ReminderTimeSpanField | Specifies the ReminderTimeSpan Field. Specifies the ReminderTimeSpan field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | ResourceIDField | Specifies the ResourceID Field. Specifies the ResourceID field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | StartTimeField | Specifies the StartTime Field. Specifies the StartTime field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | SubjectField | Specifies the Subject Field. Specifies the Subject field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Top

See Also

Reference

WebSchedulerRecurringEventBinding Class
ISNet.WebUI.WebScheduler Namespace


ExceptionDateField Property

[image]
Intersoft WebScheduler Documentation
ExceptionDateField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEventBinding Class : ExceptionDateField Property

Glossary Item Box

Specifies the ExceptionDate Field. Specifies the ExceptionDate field.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the ExceptionDate Field.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Binding")>
Public Property ExceptionDateField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurringEventBinding
Dim value As System.String

instance.ExceptionDateField = value

value = instance.ExceptionDateField
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the ExceptionDate Field.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
public System.string ExceptionDateField {get; set;}
Delphi
public read-write property ExceptionDateField: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the ExceptionDate Field.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Binding")
public function get,set ExceptionDateField : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the ExceptionDate Field.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
public: __property System.string* get_ExceptionDateField();
public: __property void set_ExceptionDateField(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the ExceptionDate Field.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
public:
property System.String^ ExceptionDateField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEventBinding Class
WebSchedulerRecurringEventBinding Members


ExceptionInfoField Property

[image]
Intersoft WebScheduler Documentation
ExceptionInfoField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEventBinding Class : ExceptionInfoField Property

Glossary Item Box

Specifies the ExceptionInfo Field. Specifies the ExceptionInfo field.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the ExceptionInfo Field.")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.CategoryAttribute("Binding")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ExceptionInfoField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurringEventBinding
Dim value As System.String

instance.ExceptionInfoField = value

value = instance.ExceptionInfoField
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the ExceptionInfo Field.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string ExceptionInfoField {get; set;}
Delphi
public read-write property ExceptionInfoField: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the ExceptionInfo Field.")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.CategoryAttribute("Binding")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ExceptionInfoField : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the ExceptionInfo Field.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_ExceptionInfoField();
public: __property void set_ExceptionInfoField(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the ExceptionInfo Field.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ ExceptionInfoField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEventBinding Class
WebSchedulerRecurringEventBinding Members


ParentIDField Property

[image]
Intersoft WebScheduler Documentation
ParentIDField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEventBinding Class : ParentIDField Property

Glossary Item Box

Specifies the ParentID Field. Specifies ParentID field.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the ParentID Field.")>
<System.ComponentModel.CategoryAttribute("Binding")>
Public Property ParentIDField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurringEventBinding
Dim value As System.String

instance.ParentIDField = value

value = instance.ParentIDField
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the ParentID Field.")]
[System.ComponentModel.CategoryAttribute("Binding")]
public System.string ParentIDField {get; set;}
Delphi
public read-write property ParentIDField: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the ParentID Field.")
System.ComponentModel.CategoryAttribute("Binding")
public function get,set ParentIDField : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the ParentID Field.")]
[System.ComponentModel.CategoryAttribute("Binding")]
public: __property System.string* get_ParentIDField();
public: __property void set_ParentIDField(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the ParentID Field.")]
[System.ComponentModel.CategoryAttribute("Binding")]
public:
property System.String^ ParentIDField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEventBinding Class
WebSchedulerRecurringEventBinding Members


RecurrenceIDField Property

[image]
Intersoft WebScheduler Documentation
RecurrenceIDField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEventBinding Class : RecurrenceIDField Property

Glossary Item Box

Specifies the RecurrenceID Field. Specifies RecurrenceID field.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the RecurrenceID Field.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Binding")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property RecurrenceIDField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurringEventBinding
Dim value As System.String

instance.RecurrenceIDField = value

value = instance.RecurrenceIDField
C#
[System.ComponentModel.DescriptionAttribute("Specifies the RecurrenceID Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string RecurrenceIDField {get; set;}
Delphi
public read-write property RecurrenceIDField: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the RecurrenceID Field.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Binding")
System.ComponentModel.DefaultValueAttribute()
public function get,set RecurrenceIDField : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the RecurrenceID Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_RecurrenceIDField();
public: __property void set_RecurrenceIDField(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the RecurrenceID Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ RecurrenceIDField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEventBinding Class
WebSchedulerRecurringEventBinding Members


WebSchedulerResource Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerResource Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerResource Class

Glossary Item Box

A collection of members in WebScheduler's resource.

Object Model

WebSchedulerResource Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerResource
   Inherits ISNet.WebUI.NamedObjectBase2
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResource
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerResource : ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Delphi
public class WebSchedulerResource = class(ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerResource extends ISNet.WebUI.NamedObjectBase2 implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerResource : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerResource : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase2
ISNet.WebUI.WebScheduler.WebSchedulerResource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResource Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerResource Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerResource Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerResource Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerResource.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerResource Constructor |
Top

Public Properties

 | Name | Description
Public Property | Collection |
Public Property | Description | Specifies the Description of the Resource. Specifies the Description of the Resource.
Public Property | DisabledTime | The data collection used by WebScheduler as the disabled time for each resource.
Public Property | Events | The Events collection used by WebScheduler. The events collection used by WebScheduler.
Public Property | Location | Specifies the Location of the Resource. Specifies the Location of the Resource.
Public Property | Name | Overridden.
Public Property | RecurringEvents | The RecurringEvents collection used by WebScheduler. The RecurringEvents collection used by WebScheduler.
Public Property | ResourceColor | Specifies the Color of the Resource. Specifies the Color of the Resource.
Public Property | ResourceID | Specifies the ID of the Resource. Specifies the ID of the Resource.
Public Property | ResourceName | Specifies the Name of the Resource. Specifies the Name of the Resource.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | PopulateDisabledTime |
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerResource Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerResource Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerResource Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResource Class : WebSchedulerResource Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerResource()
C#
public WebSchedulerResource()
Delphi
public WebSchedulerResource();
JScript
public function WebSchedulerResource();
Managed Extensions for C++
public: WebSchedulerResource();
C++/CLI
public:
WebSchedulerResource();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResource Class
WebSchedulerResource Members


WebSchedulerResource Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerResource Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerResource Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerResource members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | PopulateDisabledTime |
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerResource Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResource Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResource
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResource Class
WebSchedulerResource Members


PopulateDisabledTime Method

[image]
Intersoft WebScheduler Documentation
PopulateDisabledTime Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResource Class : PopulateDisabledTime Method

DataObject
StartTimeField
EndTimeField

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub PopulateDisabledTime( _
   ByVal DataObject As System.Object, _
   ByVal StartTimeField As System.String, _
   ByVal EndTimeField As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResource
Dim DataObject As System.Object
Dim StartTimeField As System.String
Dim EndTimeField As System.String

instance.PopulateDisabledTime(DataObject, StartTimeField, EndTimeField)
C#
public void PopulateDisabledTime(
   System.object DataObject,
   System.string StartTimeField,
   System.string EndTimeField
)
Delphi
public procedure PopulateDisabledTime(
    DataObject: System.TObject;
    StartTimeField: System.String;
    EndTimeField: System.String
);
JScript
public function PopulateDisabledTime(
   DataObject : System.Object,
   StartTimeField : System.String,
   EndTimeField : System.String
);
Managed Extensions for C++
public: void PopulateDisabledTime(
   System.Object* DataObject,
   System.string* StartTimeField,
   System.string* EndTimeField
)
C++/CLI
public:
void PopulateDisabledTime(
   System.Object^ DataObject,
   System.String^ StartTimeField,
   System.String^ EndTimeField
)

Parameters

DataObject
StartTimeField
EndTimeField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResource Class
WebSchedulerResource Members


WebSchedulerResource Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerResource Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerResource Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerResource members.

Public Properties

 | Name | Description
Public Property | Collection |
Public Property | Description | Specifies the Description of the Resource. Specifies the Description of the Resource.
Public Property | DisabledTime | The data collection used by WebScheduler as the disabled time for each resource.
Public Property | Events | The Events collection used by WebScheduler. The events collection used by WebScheduler.
Public Property | Location | Specifies the Location of the Resource. Specifies the Location of the Resource.
Public Property | Name | Overridden.
Public Property | RecurringEvents | The RecurringEvents collection used by WebScheduler. The RecurringEvents collection used by WebScheduler.
Public Property | ResourceColor | Specifies the Color of the Resource. Specifies the Color of the Resource.
Public Property | ResourceID | Specifies the ID of the Resource. Specifies the ID of the Resource.
Public Property | ResourceName | Specifies the Name of the Resource. Specifies the Name of the Resource.
Top

See Also

Reference

WebSchedulerResource Class
ISNet.WebUI.WebScheduler Namespace


Collection Property

[image]
Intersoft WebScheduler Documentation
Collection Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResource Class : Collection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.JsonSerialization.ScriptIgnoreAttribute()>
Public Shadows Property Collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResource
Dim value As ISNet.WebUI.ISCollectionBase(Of INamedObject2)

instance.Collection = value

value = instance.Collection
C#
[ISNet.Serialization.JsonSerialization.ScriptIgnoreAttribute()]
public new ISNet.WebUI.ISCollectionBase<INamedObject2> Collection {get; set;}
Delphi
public read-write property Collection: ISNet.WebUI.ISCollectionBase;
JScript
ISNet.Serialization.JsonSerialization.ScriptIgnoreAttribute()
public hide function get,set Collection : ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[ISNet.Serialization.JsonSerialization.ScriptIgnoreAttribute()]
public: __property new ISNet.WebUI.ISCollectionBase<INamedObject2*>* get_Collection();
public: __property new void set_Collection(
   ISNet.WebUI.ISCollectionBase<INamedObject2*>* value
);
C++/CLI
[ISNet.Serialization.JsonSerialization.ScriptIgnoreAttribute()]
public:
new property ISNet.WebUI.ISCollectionBase<INamedObject2^>^ Collection {
   ISNet.WebUI.ISCollectionBase<INamedObject2^>^ get();
   void set (    ISNet.WebUI.ISCollectionBase<INamedObject2^>^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResource Class
WebSchedulerResource Members


Description Property

[image]
Intersoft WebScheduler Documentation
Description Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResource Class : Description Property

Glossary Item Box

Specifies the Description of the Resource. Specifies the Description of the Resource.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the Description of the Resource.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
<System.ComponentModel.CategoryAttribute("Resource")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Description As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResource
Dim value As System.String

instance.Description = value

value = instance.Description
C#
[System.ComponentModel.DescriptionAttribute("Specifies the Description of the Resource.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.CategoryAttribute("Resource")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Description {get; set;}
Delphi
public read-write property Description: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the Description of the Resource.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
System.ComponentModel.CategoryAttribute("Resource")
System.ComponentModel.DefaultValueAttribute()
public function get,set Description : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the Description of the Resource.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.CategoryAttribute("Resource")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Description();
public: __property void set_Description(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the Description of the Resource.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.CategoryAttribute("Resource")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Description {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResource Class
WebSchedulerResource Members


DisabledTime Property

[image]
Intersoft WebScheduler Documentation
DisabledTime Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResource Class : DisabledTime Property

Glossary Item Box

The data collection used by WebScheduler as the disabled time for each resource.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Resource")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.DescriptionAttribute("The data collection used by WebScheduler as the disabled time for each resource.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute("setDisabledTime")>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
Public ReadOnly Property DisabledTime As WebSchedulerDisabledTimeCollection
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResource
Dim value As WebSchedulerDisabledTimeCollection

value = instance.DisabledTime
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Resource")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DescriptionAttribute("The data collection used by WebScheduler as the disabled time for each resource.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setDisabledTime")]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public WebSchedulerDisabledTimeCollection DisabledTime {get;}
Delphi
public read-only property DisabledTime: WebSchedulerDisabledTimeCollection;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Resource")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.DescriptionAttribute("The data collection used by WebScheduler as the disabled time for each resource.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute("setDisabledTime")
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
public function get DisabledTime : WebSchedulerDisabledTimeCollection
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Resource")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DescriptionAttribute("The data collection used by WebScheduler as the disabled time for each resource.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setDisabledTime")]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public: __property WebSchedulerDisabledTimeCollection* get_DisabledTime();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Resource")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DescriptionAttribute("The data collection used by WebScheduler as the disabled time for each resource.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setDisabledTime")]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public:
property WebSchedulerDisabledTimeCollection^ DisabledTime {
   WebSchedulerDisabledTimeCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResource Class
WebSchedulerResource Members


Events Property

[image]
Intersoft WebScheduler Documentation
Events Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResource Class : Events Property

Glossary Item Box

The Events collection used by WebScheduler. The events collection used by WebScheduler.

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute("setEvents")>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.JsonSerialization.ScriptIgnoreAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The Events collection used by WebScheduler.")>
<System.ComponentModel.CategoryAttribute("Resource")>
Public ReadOnly Property Events As WebSchedulerEventCollection
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResource
Dim value As WebSchedulerEventCollection

value = instance.Events
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setEvents")]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.JsonSerialization.ScriptIgnoreAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The Events collection used by WebScheduler.")]
[System.ComponentModel.CategoryAttribute("Resource")]
public WebSchedulerEventCollection Events {get;}
Delphi
public read-only property Events: WebSchedulerEventCollection;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute("setEvents")
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.JsonSerialization.ScriptIgnoreAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The Events collection used by WebScheduler.")
System.ComponentModel.CategoryAttribute("Resource")
public function get Events : WebSchedulerEventCollection
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setEvents")]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.JsonSerialization.ScriptIgnoreAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The Events collection used by WebScheduler.")]
[System.ComponentModel.CategoryAttribute("Resource")]
public: __property WebSchedulerEventCollection* get_Events();
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setEvents")]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.JsonSerialization.ScriptIgnoreAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The Events collection used by WebScheduler.")]
[System.ComponentModel.CategoryAttribute("Resource")]
public:
property WebSchedulerEventCollection^ Events {
   WebSchedulerEventCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResource Class
WebSchedulerResource Members


Location Property

[image]
Intersoft WebScheduler Documentation
Location Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResource Class : Location Property

Glossary Item Box

Specifies the Location of the Resource. Specifies the Location of the Resource.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Resource")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the Location of the Resource.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Location As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResource
Dim value As System.String

instance.Location = value

value = instance.Location
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Resource")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the Location of the Resource.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string Location {get; set;}
Delphi
public read-write property Location: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Resource")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the Location of the Resource.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Location : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Resource")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the Location of the Resource.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_Location();
public: __property void set_Location(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Resource")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the Location of the Resource.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ Location {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResource Class
WebSchedulerResource Members


Name Property

[image]
Intersoft WebScheduler Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResource Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
Public Overrides Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResource
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public override System.string Name {get; set;}
Delphi
public read-write property Name: System.String; override;
JScript
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
public override function get,set Name : System.String
Managed Extensions for C++
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public: __property System.string* get_Name() override;
public: __property void set_Name(
   System.string* value
) override;
C++/CLI
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
public:
property System.String^ Name {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResource Class
WebSchedulerResource Members


RecurringEvents Property

[image]
Intersoft WebScheduler Documentation
RecurringEvents Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResource Class : RecurringEvents Property

Glossary Item Box

The RecurringEvents collection used by WebScheduler. The RecurringEvents collection used by WebScheduler.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.JsonSerialization.ScriptIgnoreAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setEvents")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The RecurringEvents collection used by WebScheduler.")>
<System.ComponentModel.CategoryAttribute("Resource")>
Public ReadOnly Property RecurringEvents As WebSchedulerEventCollection
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResource
Dim value As WebSchedulerEventCollection

value = instance.RecurringEvents
C#
[ISNet.Serialization.JsonSerialization.ScriptIgnoreAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setEvents")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The RecurringEvents collection used by WebScheduler.")]
[System.ComponentModel.CategoryAttribute("Resource")]
public WebSchedulerEventCollection RecurringEvents {get;}
Delphi
public read-only property RecurringEvents: WebSchedulerEventCollection;
JScript
ISNet.Serialization.JsonSerialization.ScriptIgnoreAttribute()
ISNet.Serialization.BinarySerializableAttribute("setEvents")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The RecurringEvents collection used by WebScheduler.")
System.ComponentModel.CategoryAttribute("Resource")
public function get RecurringEvents : WebSchedulerEventCollection
Managed Extensions for C++
[ISNet.Serialization.JsonSerialization.ScriptIgnoreAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setEvents")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The RecurringEvents collection used by WebScheduler.")]
[System.ComponentModel.CategoryAttribute("Resource")]
public: __property WebSchedulerEventCollection* get_RecurringEvents();
C++/CLI
[ISNet.Serialization.JsonSerialization.ScriptIgnoreAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setEvents")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The RecurringEvents collection used by WebScheduler.")]
[System.ComponentModel.CategoryAttribute("Resource")]
public:
property WebSchedulerEventCollection^ RecurringEvents {
   WebSchedulerEventCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResource Class
WebSchedulerResource Members


ResourceColor Property

[image]
Intersoft WebScheduler Documentation
ResourceColor Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResource Class : ResourceColor Property

Glossary Item Box

Specifies the Color of the Resource. Specifies the Color of the Resource.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the Color of the Resource.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("ISNet.WebUI.WebScheduler.ISColorConverter, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.CategoryAttribute("Resource")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ResourceColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResource
Dim value As System.Drawing.Color

instance.ResourceColor = value

value = instance.ResourceColor
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the Color of the Resource.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("ISNet.WebUI.WebScheduler.ISColorConverter, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.CategoryAttribute("Resource")]
[System.ComponentModel.DefaultValueAttribute()]
public System.Drawing.Color ResourceColor {get; set;}
Delphi
public read-write property ResourceColor: System.Drawing.Color;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the Color of the Resource.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("ISNet.WebUI.WebScheduler.ISColorConverter, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.CategoryAttribute("Resource")
System.ComponentModel.DefaultValueAttribute()
public function get,set ResourceColor : System.Drawing.Color
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the Color of the Resource.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("ISNet.WebUI.WebScheduler.ISColorConverter, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.CategoryAttribute("Resource")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Drawing.Color get_ResourceColor();
public: __property void set_ResourceColor(
   System.Drawing.Color value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the Color of the Resource.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("ISNet.WebUI.WebScheduler.ISColorConverter, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.CategoryAttribute("Resource")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Drawing.Color ResourceColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResource Class
WebSchedulerResource Members


ResourceID Property

[image]
Intersoft WebScheduler Documentation
ResourceID Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResource Class : ResourceID Property

Glossary Item Box

Specifies the ID of the Resource. Specifies the ID of the Resource.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the ID of the Resource.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
<System.ComponentModel.CategoryAttribute("Resource")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ResourceID As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResource
Dim value As System.Integer

instance.ResourceID = value

value = instance.ResourceID
C#
[System.ComponentModel.DescriptionAttribute("Specifies the ID of the Resource.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.CategoryAttribute("Resource")]
[System.ComponentModel.DefaultValueAttribute()]
public System.int ResourceID {get; set;}
Delphi
public read-write property ResourceID: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the ID of the Resource.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
System.ComponentModel.CategoryAttribute("Resource")
System.ComponentModel.DefaultValueAttribute()
public function get,set ResourceID : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the ID of the Resource.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.CategoryAttribute("Resource")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_ResourceID();
public: __property void set_ResourceID(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the ID of the Resource.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.CategoryAttribute("Resource")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int ResourceID {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResource Class
WebSchedulerResource Members


ResourceName Property

[image]
Intersoft WebScheduler Documentation
ResourceName Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResource Class : ResourceName Property

Glossary Item Box

Specifies the Name of the Resource. Specifies the Name of the Resource.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the Name of the Resource.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Resource")>
<ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ResourceName As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResource
Dim value As System.String

instance.ResourceName = value

value = instance.ResourceName
C#
[System.ComponentModel.DescriptionAttribute("Specifies the Name of the Resource.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Resource")]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string ResourceName {get; set;}
Delphi
public read-write property ResourceName: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the Name of the Resource.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Resource")
ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set ResourceName : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the Name of the Resource.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Resource")]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_ResourceName();
public: __property void set_ResourceName(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the Name of the Resource.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Resource")]
[ISNet.Serialization.JsonSerialization.IgnoreOnDefaultAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ ResourceName {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResource Class
WebSchedulerResource Members


WebSchedulerResourceCollection Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerResourceCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerResourceCollection Class

Glossary Item Box

The data collection used by WebScheduler to determine resources..

Object Model

WebSchedulerResourceCollection Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerResourceCollection
   Inherits ISNet.WebUI.ISGenericCollectionBase(Of WebSchedulerResource)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourceCollection
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerResourceCollection : ISNet.WebUI.ISGenericCollectionBase<WebSchedulerResource>
Delphi
public class WebSchedulerResourceCollection = class(ISNet.WebUI.ISGenericCollectionBase)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerResourceCollection extends ISNet.WebUI.ISGenericCollectionBase
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerResourceCollection : public ISNet.WebUI.ISGenericCollectionBase<WebSchedulerResource>
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerResourceCollection : public ISNet.WebUI.ISGenericCollectionBase<WebSchedulerResource>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
ISNet.WebUI.ISCollectionBase<T>
ISNet.WebUI.ISGenericCollectionBase<T>
ISNet.WebUI.WebScheduler.WebSchedulerResourceCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceCollection Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerResourceCollection Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerResourceCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerResourceCollection Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerResourceCollection.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerResourceCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
static (Shared in Visual Basic) | Compare |
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerResource>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerResource>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerResource>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebSchedulerResourceCollection Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerResourceCollection Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerResourceCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourceCollection Class : WebSchedulerResourceCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerResourceCollection()
C#
public WebSchedulerResourceCollection()
Delphi
public WebSchedulerResourceCollection();
JScript
public function WebSchedulerResourceCollection();
Managed Extensions for C++
public: WebSchedulerResourceCollection();
C++/CLI
public:
WebSchedulerResourceCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceCollection Class
WebSchedulerResourceCollection Members


WebSchedulerResourceCollection Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerResourceCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerResourceCollection Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerResourceCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
static (Shared in Visual Basic) | Compare |
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerResource>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerResource>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerResource>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebSchedulerResourceCollection Class
ISNet.WebUI.WebScheduler Namespace


Compare Method

[image]
Intersoft WebScheduler Documentation
Compare Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourceCollection Class : Compare Method

obj1
obj2

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function Compare( _
   ByVal obj1 As WebSchedulerEvent, _
   ByVal obj2 As WebSchedulerEvent _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim obj1 As WebSchedulerEvent
Dim obj2 As WebSchedulerEvent
Dim value As System.Integer

value = WebSchedulerResourceCollection.Compare(obj1, obj2)
C#
public static System.int Compare(
   WebSchedulerEvent obj1,
   WebSchedulerEvent obj2
)
Delphi
public function Compare(
    obj1: WebSchedulerEvent;
    obj2: WebSchedulerEvent
): System.Integer; static;
JScript
public static function Compare(
   obj1 : WebSchedulerEvent,
   obj2 : WebSchedulerEvent
) : System.int;
Managed Extensions for C++
public: static System.int Compare(
   WebSchedulerEvent* obj1,
   WebSchedulerEvent* obj2
)
C++/CLI
public:
static System.int Compare(
   WebSchedulerEvent^ obj1,
   WebSchedulerEvent^ obj2
)

Parameters

obj1
obj2

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceCollection Class
WebSchedulerResourceCollection Members


WebSchedulerResourceDataEditing Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerResourceDataEditing Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerResourceDataEditing Class

Glossary Item Box

A collection of settings used for resource's data editing.

Object Model

WebSchedulerResourceDataEditing Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerResourceDataEditing
   Inherits WebSchedulerDataEditing
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourceDataEditing
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerResourceDataEditing : WebSchedulerDataEditing, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSchedulerResourceDataEditing = class(WebSchedulerDataEditing, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerResourceDataEditing extends WebSchedulerDataEditing implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerResourceDataEditing : public WebSchedulerDataEditing, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerResourceDataEditing : public WebSchedulerDataEditing, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebScheduler.WebSchedulerDataEditing
ISNet.WebUI.WebScheduler.WebSchedulerResourceDataEditing

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceDataEditing Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerResourceDataEditing Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerResourceDataEditing Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerResourceDataEditing Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerResourceDataEditing.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerResourceDataEditing Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllowAdd | Indicates whether WebScheduler can add a new event. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerDataEditing)
Public Property | AllowDelete | Indicates whether WebScheduler can delete an event. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerDataEditing)
Public Property | AllowEdit | Indicates whether WebScheduler can edit an event. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerDataEditing)
Public Property | AllowMove | Indicates whether an event can be moved. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerDataEditing)
Public Property | AllowResize | Indicates whether an event can be resized. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerDataEditing)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerDataEditing)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerResourceDataEditing Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerResourceDataEditing Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerResourceDataEditing Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourceDataEditing Class : WebSchedulerResourceDataEditing Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerResourceDataEditing()
C#
public WebSchedulerResourceDataEditing()
Delphi
public WebSchedulerResourceDataEditing();
JScript
public function WebSchedulerResourceDataEditing();
Managed Extensions for C++
public: WebSchedulerResourceDataEditing();
C++/CLI
public:
WebSchedulerResourceDataEditing();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceDataEditing Class
WebSchedulerResourceDataEditing Members


WebSchedulerResourcesBinding Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerResourcesBinding Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerResourcesBinding Class

Glossary Item Box

A collection of settings used for resources binding.

Object Model

WebSchedulerResourcesBinding Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerResourcesBinding
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourcesBinding
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerResourcesBinding : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSchedulerResourcesBinding = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerResourcesBinding extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerResourcesBinding : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerResourcesBinding : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebScheduler.WebSchedulerResourcesBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourcesBinding Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerResourcesBinding Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerResourcesBinding Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerResourcesBinding Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerResourcesBinding.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerResourcesBinding Constructor |
Top

Public Properties

 | Name | Description
Public Property | DescriptionField | Specifies the ResourceName Field. Specifies the Description field.
Public Property | LocationField | Specifies the Location Field. Specifies the Location field.
Public Property | ResourceColorField | Specifies the ResourceColor Field. Specifies the ResourceColor field.
Public Property | ResourceIDField | Specifies the ResourceID Field. Specifies the ResourceID field.
Public Property | ResourceNameField | Specifies the ResourceName Field. Specifies the ResourceName field.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerResourcesBinding Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerResourcesBinding Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerResourcesBinding Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourcesBinding Class : WebSchedulerResourcesBinding Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerResourcesBinding()
C#
public WebSchedulerResourcesBinding()
Delphi
public WebSchedulerResourcesBinding();
JScript
public function WebSchedulerResourcesBinding();
Managed Extensions for C++
public: WebSchedulerResourcesBinding();
C++/CLI
public:
WebSchedulerResourcesBinding();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourcesBinding Class
WebSchedulerResourcesBinding Members


WebSchedulerResourcesBinding Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerResourcesBinding Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerResourcesBinding Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerResourcesBinding members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerResourcesBinding Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourcesBinding Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourcesBinding
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourcesBinding Class
WebSchedulerResourcesBinding Members


WebSchedulerResourcesBinding Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerResourcesBinding Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerResourcesBinding Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerResourcesBinding members.

Public Properties

 | Name | Description
Public Property | DescriptionField | Specifies the ResourceName Field. Specifies the Description field.
Public Property | LocationField | Specifies the Location Field. Specifies the Location field.
Public Property | ResourceColorField | Specifies the ResourceColor Field. Specifies the ResourceColor field.
Public Property | ResourceIDField | Specifies the ResourceID Field. Specifies the ResourceID field.
Public Property | ResourceNameField | Specifies the ResourceName Field. Specifies the ResourceName field.
Top

See Also

Reference

WebSchedulerResourcesBinding Class
ISNet.WebUI.WebScheduler Namespace


DescriptionField Property

[image]
Intersoft WebScheduler Documentation
DescriptionField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourcesBinding Class : DescriptionField Property

Glossary Item Box

Specifies the ResourceName Field. Specifies the Description field.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the ResourceName Field.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Binding")>
Public Property DescriptionField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourcesBinding
Dim value As System.String

instance.DescriptionField = value

value = instance.DescriptionField
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the ResourceName Field.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
public System.string DescriptionField {get; set;}
Delphi
public read-write property DescriptionField: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the ResourceName Field.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Binding")
public function get,set DescriptionField : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the ResourceName Field.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
public: __property System.string* get_DescriptionField();
public: __property void set_DescriptionField(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the ResourceName Field.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Binding")]
public:
property System.String^ DescriptionField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourcesBinding Class
WebSchedulerResourcesBinding Members


LocationField Property

[image]
Intersoft WebScheduler Documentation
LocationField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourcesBinding Class : LocationField Property

Glossary Item Box

Specifies the Location Field. Specifies the Location field.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.DescriptionAttribute("Specifies the Location Field.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("ResouBindingrce")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property LocationField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourcesBinding
Dim value As System.String

instance.LocationField = value

value = instance.LocationField
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DescriptionAttribute("Specifies the Location Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("ResouBindingrce")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string LocationField {get; set;}
Delphi
public read-write property LocationField: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.DescriptionAttribute("Specifies the Location Field.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("ResouBindingrce")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set LocationField : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DescriptionAttribute("Specifies the Location Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("ResouBindingrce")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_LocationField();
public: __property void set_LocationField(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DescriptionAttribute("Specifies the Location Field.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("ResouBindingrce")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ LocationField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourcesBinding Class
WebSchedulerResourcesBinding Members


ResourceColorField Property

[image]
Intersoft WebScheduler Documentation
ResourceColorField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourcesBinding Class : ResourceColorField Property

Glossary Item Box

Specifies the ResourceColor Field. Specifies the ResourceColor field.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the ResourceColor Field.")>
<System.ComponentModel.CategoryAttribute("Binding")>
Public Property ResourceColorField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourcesBinding
Dim value As System.String

instance.ResourceColorField = value

value = instance.ResourceColorField
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the ResourceColor Field.")]
[System.ComponentModel.CategoryAttribute("Binding")]
public System.string ResourceColorField {get; set;}
Delphi
public read-write property ResourceColorField: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the ResourceColor Field.")
System.ComponentModel.CategoryAttribute("Binding")
public function get,set ResourceColorField : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the ResourceColor Field.")]
[System.ComponentModel.CategoryAttribute("Binding")]
public: __property System.string* get_ResourceColorField();
public: __property void set_ResourceColorField(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the ResourceColor Field.")]
[System.ComponentModel.CategoryAttribute("Binding")]
public:
property System.String^ ResourceColorField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourcesBinding Class
WebSchedulerResourcesBinding Members


ResourceIDField Property

[image]
Intersoft WebScheduler Documentation
ResourceIDField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourcesBinding Class : ResourceIDField Property

Glossary Item Box

Specifies the ResourceID Field. Specifies the ResourceID field.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Binding")>
<System.ComponentModel.DescriptionAttribute("Specifies the ResourceID Field.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ResourceIDField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourcesBinding
Dim value As System.String

instance.ResourceIDField = value

value = instance.ResourceIDField
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Specifies the ResourceID Field.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string ResourceIDField {get; set;}
Delphi
public read-write property ResourceIDField: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Binding")
System.ComponentModel.DescriptionAttribute("Specifies the ResourceID Field.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ResourceIDField : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Specifies the ResourceID Field.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_ResourceIDField();
public: __property void set_ResourceIDField(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Specifies the ResourceID Field.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ ResourceIDField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourcesBinding Class
WebSchedulerResourcesBinding Members


ResourceNameField Property

[image]
Intersoft WebScheduler Documentation
ResourceNameField Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourcesBinding Class : ResourceNameField Property

Glossary Item Box

Specifies the ResourceName Field. Specifies the ResourceName field.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Binding")>
<System.ComponentModel.DescriptionAttribute("Specifies the ResourceName Field.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ResourceNameField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourcesBinding
Dim value As System.String

instance.ResourceNameField = value

value = instance.ResourceNameField
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Specifies the ResourceName Field.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string ResourceNameField {get; set;}
Delphi
public read-write property ResourceNameField: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Binding")
System.ComponentModel.DescriptionAttribute("Specifies the ResourceName Field.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ResourceNameField : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Specifies the ResourceName Field.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_ResourceNameField();
public: __property void set_ResourceNameField(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebScheduler.WebSchedulerDataFieldEditor, ISNet.WebUI.WebScheduler, Version=3.0.1000.5, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Binding")]
[System.ComponentModel.DescriptionAttribute("Specifies the ResourceName Field.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ ResourceNameField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourcesBinding Class
WebSchedulerResourcesBinding Members


WebSchedulerTextSettings Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerTextSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerTextSettings Class

Glossary Item Box

A collection of settings which controls the text shown in WebScheduler.

Object Model

WebSchedulerTextSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerTextSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerTextSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSchedulerTextSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerTextSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerTextSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerTextSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebScheduler.WebSchedulerTextSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerTextSettings Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerTextSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerTextSettings Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerTextSettings.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerTextSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | AddCategoryText | Specifies the text of Add Category title in callout. Determines the text of callout title in the related callout.
Public Property | AddEventText | Specifies the text of add event. This text settings will be implemented in CallOut's add event button and agenda add event. Specifies the text of add event. This text setting will be implemented in CallOut's add event button and agenda add event.
Public Property | AddResourceText | Specifies the text of Add Resource title in callout. Determines the text of callout title in the related callout.
Public Property | AgendaTabView | Specifies the tooltip text of agenda view's tab. Specifies the tooltip text of agenda view's tab.
Public Property | AgendaText | Specifies the text of Agenda's tab in WebScheduler header. Specifies the text of Agenda's tab in WebScheduler header.
Public Property | CalendarHeaderText | Specifies the tooltip text of calendar header. Specifies the tooltip text of calendar header.
Public Property | CalendarNextArrowText | Specifies the tooltip text of calendar's next arrow. Specifies the tooltip text of calendar's next arrow.
Public Property | CalendarPrevArrowText | Specifies the tooltip text of calendar's previous arrow. Specifies the tooltip text of calendar's previous arrow.
Public Property | CallOutResourceFieldText | Specifies the text of Resource field in callout. Determines the text of callout title in the related callout.
Public Property | CollapseAllText | Specifies the text of collapse icon in Agenda view. Specifies the text of collapse's icon in Agenda view.
Public Property | CollapseCalendarText | Specifies the text of collapse calendar icon tooltip in WebScheduler's header. Specifies the text of collapse calendar icon in WebScheduler's header.
Public Property | DayTabView | Specifies the tooltip text of day view's tab. Specifies the tooltip text of day view's tab.
Public Property | DayText | Specifies the text of Day's tab in WebScheduler header. Specifies the text of Day's tab in WebScheduler header
Public Property | DeleteEventText | Specifies the text of delete event. This text settings will be implemented in CallOut's delete event button and agenda edit event. Specifies the text of delete event.
Public Property | DescriptionText | Specifies the text of CallOut's description label. Specifies the text of CallOut's description label.
Public Property | DisabledTimeText | Specifies the tooltip text of Disabled time in Timeline view.
Public Property | EditDetailText | Specifies the text of edit detail link in the CallOut. Specifies the text of edit detail link in the CallOut.
Public Property | EditEventText | Specifies the text of edit event. This text settings will be implemented in CallOut's edit event button and agenda edit event. Specifies the text of edit event. This text setting will be implemented in CallOut's edit event button and agenda edit event.
Public Property | ExpandAllText | Specifies the text of expand icon in Agenda view. Specifies the text of expand's icon in Agenda view.
Public Property | ExpandCalendarText | Specifies the text of expand calendar icon tooltip in WebScheduler's header. Specifies the text of expand calendar icon in WebScheduler's header.
Public Property | HighImportanceText | Specifies the tooltip text of high importance image in event.
Public Property | LocationText | Specifies the text of CallOut's location label. Specifies the text of CallOut's location label.
Public Property | LowImportanceText | Specifies the tooltip text of low importance image in event.
Public Property | ManageResourcesText | Specifies the text of Resource's header. Specifies the text of Resource's header.
Public Property | MenuCategorizeText | Specifies the tooltip text of Categorize text in context menu.
Public Property | MenuDeleteEventText | Specifies the tooltip text of Delete Event text in context menu.
Public Property | MenuEditEventText | Specifies the tooltip text of Edit Event text in context menu.
Public Property | MenuGoToThisDayText | Specifies the tooltip text of Go To This Day text in context menu.
Public Property | MenuGoToToDayText | Specifies the tooltip text of Go To Today text in context menu.
Public Property | MenuNewAllDayEventText | Specifies the tooltip text of New All Day Event text in context menu.
Public Property | MenuNewEventText | Specifies the tooltip text of New Event text in context menu.
Public Property | MenuNewRecurringEventText | Specifies the tooltip text of New Recurring Event text in context menu.
Public Property | MenuSplitViewText | Specifies the tooltip text of Split View Mode text in context menu.
Public Property | MenuTabViewText | Specifies the text of menu icon tooltip in WebScheduler's header. Specifies the text of menu icon tooltip in WebScheduler's header.
Public Property | Minutes10Text | Specifies the text of 10 minutes option in context menu.
Public Property | Minutes15Text | Specifies the text of 15 minutes option in context menu.
Public Property | Minutes30Text | Specifies the text of 30 minutes option in context menu.
Public Property | Minutes60Text | Specifies the text of 60 minutes option in context menu.
Public Property | MonthDateHeaderText | Specifies the text of date header in Month's tooltip. Specifies the text of date header in Month's tooltip.
Public Property | MonthTabView | Specifies the tooltip text of month view's tab. Specifies the tooltip text of month view's tab.
Public Property | MonthText | Specifies the text of Month's tab in WebScheduler header. Specifies the text of Month's tab in WebScheduler header
Public Property | MoreText | Specifies the text of More elements in Month view.
Public Property | Quarter1Text | Specifies the text of first quarter header in Quarter view. Specifies the text of first quarter header in Quarter view.
Public Property | Quarter2Text | Specifies the text of second quarter header in Quarter view. Specifies the text of second quarter header in Quarter view.
Public Property | Quarter3Text | Specifies the text of third quarter header in Quarter view. Specifies the text of third quarter header in Quarter view.
Public Property | Quarter4Text | Specifies the text of fourth quarter header in Quarter view. Specifies the text of quarter quarter header in Quarter view.
Public Property | QuarterTabView | Specifies the tooltip text of quarter view's tab. Specifies the tooltip text of quarter view's tab.
Public Property | QuarterText | Specifies the text of Quarter's tab in WebScheduler header. Specifies the text of Quarter's tab in WebScheduler header.
Public Property | RecurrenceTextSettings | Provides the settings for RecurrenceText.
Public Property | ReminderToolTipText | Specifies the text of event reminder tooltip. Specifies the text of event reminder tooltip.
Public Property | ShowFullWeekText | Specifies the text settings for show full week option. Specifies the text settings for show full week option.
Public Property | ShowWorkWeekText | Specifies the text settings for show work week option. Specifies the text settings for show work week option.
Public Property | SubjectText | Specifies the text of CallOut's subject label. Specifies the text of CallOut's subject label.
Public Property | TimelineResourceHeaderText | Specifies the text of Timeline resource header text. Specifies the text of Timeline resource header text.
Public Property | TimelineTabView | Specifies the tooltip text of Timeline view's tab. Specifies the tooltip text of Timeline view's tab.
Public Property | TimelineText | Specifies the text of Timeline's tab in WebScheduler header. Specifies the text of Timeline's tab in WebScheduler header.
Public Property | TimelineWeekHeaderText | Specifies the tooltip text of Timeline Week view Header text.
Public Property | TimelineZoomIn | Specifies the tooltip text of Timeline ZoomIn icon (Timeline View).
Public Property | TimelineZoomOut | Specifies the tooltip text of Timeline ZoomOut icon (Timeline View).
Public Property | ValidateDisabledTimeText | Specifies the DisabledTime error alert.
Public Property | ViewOnMyCalendarText | Specifies the text of viewOnMyCalendarText in Agenda view. Specifies the text of viewOnMyCalendarText in Agenda view.
Public Property | WeekTabView | Specifies the tooltip text of week view's tab. Specifies the tooltip text of week view's tab.
Public Property | WeekText | Specifies the text of Week's tab in WebScheduler header. Specifies the text of Week's tab in WebScheduler header.
Public Property | WeekViewDateHeaderText | Specifies the text of date header in Week's tooltip. Specifies the text of date header of week view's tab.
Public Property | YearDayOfWeekText | Specifies the text of day header tooltip in Year and Quarter view. Specifies the text of day header tooltip in Year and Quarter view.
Public Property | YearMonthRowHeaderMonthViewText | Specifies the text of row header tooltip in Month view. Specifies the text of row header tooltip in Month view.
Public Property | YearMonthRowHeaderYearQuarterViewText | Specifies the text of row header tooltip in Year and Quarter view. Specifies the text of row header tooltip in Year and Quarter view.
Public Property | YearTabView | Specifies the tooltip text of year view's tab. Specifies the tooltip text of year view's tab.
Public Property | YearText | Specifies the text of Year's tab in WebScheduler header. Specifies the text of Year's tab in WebScheduler header.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerTextSettings Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerTextSettings Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerTextSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : WebSchedulerTextSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerTextSettings()
C#
public WebSchedulerTextSettings()
Delphi
public WebSchedulerTextSettings();
JScript
public function WebSchedulerTextSettings();
Managed Extensions for C++
public: WebSchedulerTextSettings();
C++/CLI
public:
WebSchedulerTextSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


WebSchedulerTextSettings Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerTextSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerTextSettings Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerTextSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerTextSettings Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


WebSchedulerTextSettings Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerTextSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerTextSettings Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerTextSettings members.

Public Properties

 | Name | Description
Public Property | AddCategoryText | Specifies the text of Add Category title in callout. Determines the text of callout title in the related callout.
Public Property | AddEventText | Specifies the text of add event. This text settings will be implemented in CallOut's add event button and agenda add event. Specifies the text of add event. This text setting will be implemented in CallOut's add event button and agenda add event.
Public Property | AddResourceText | Specifies the text of Add Resource title in callout. Determines the text of callout title in the related callout.
Public Property | AgendaTabView | Specifies the tooltip text of agenda view's tab. Specifies the tooltip text of agenda view's tab.
Public Property | AgendaText | Specifies the text of Agenda's tab in WebScheduler header. Specifies the text of Agenda's tab in WebScheduler header.
Public Property | CalendarHeaderText | Specifies the tooltip text of calendar header. Specifies the tooltip text of calendar header.
Public Property | CalendarNextArrowText | Specifies the tooltip text of calendar's next arrow. Specifies the tooltip text of calendar's next arrow.
Public Property | CalendarPrevArrowText | Specifies the tooltip text of calendar's previous arrow. Specifies the tooltip text of calendar's previous arrow.
Public Property | CallOutResourceFieldText | Specifies the text of Resource field in callout. Determines the text of callout title in the related callout.
Public Property | CollapseAllText | Specifies the text of collapse icon in Agenda view. Specifies the text of collapse's icon in Agenda view.
Public Property | CollapseCalendarText | Specifies the text of collapse calendar icon tooltip in WebScheduler's header. Specifies the text of collapse calendar icon in WebScheduler's header.
Public Property | DayTabView | Specifies the tooltip text of day view's tab. Specifies the tooltip text of day view's tab.
Public Property | DayText | Specifies the text of Day's tab in WebScheduler header. Specifies the text of Day's tab in WebScheduler header
Public Property | DeleteEventText | Specifies the text of delete event. This text settings will be implemented in CallOut's delete event button and agenda edit event. Specifies the text of delete event.
Public Property | DescriptionText | Specifies the text of CallOut's description label. Specifies the text of CallOut's description label.
Public Property | DisabledTimeText | Specifies the tooltip text of Disabled time in Timeline view.
Public Property | EditDetailText | Specifies the text of edit detail link in the CallOut. Specifies the text of edit detail link in the CallOut.
Public Property | EditEventText | Specifies the text of edit event. This text settings will be implemented in CallOut's edit event button and agenda edit event. Specifies the text of edit event. This text setting will be implemented in CallOut's edit event button and agenda edit event.
Public Property | ExpandAllText | Specifies the text of expand icon in Agenda view. Specifies the text of expand's icon in Agenda view.
Public Property | ExpandCalendarText | Specifies the text of expand calendar icon tooltip in WebScheduler's header. Specifies the text of expand calendar icon in WebScheduler's header.
Public Property | HighImportanceText | Specifies the tooltip text of high importance image in event.
Public Property | LocationText | Specifies the text of CallOut's location label. Specifies the text of CallOut's location label.
Public Property | LowImportanceText | Specifies the tooltip text of low importance image in event.
Public Property | ManageResourcesText | Specifies the text of Resource's header. Specifies the text of Resource's header.
Public Property | MenuCategorizeText | Specifies the tooltip text of Categorize text in context menu.
Public Property | MenuDeleteEventText | Specifies the tooltip text of Delete Event text in context menu.
Public Property | MenuEditEventText | Specifies the tooltip text of Edit Event text in context menu.
Public Property | MenuGoToThisDayText | Specifies the tooltip text of Go To This Day text in context menu.
Public Property | MenuGoToToDayText | Specifies the tooltip text of Go To Today text in context menu.
Public Property | MenuNewAllDayEventText | Specifies the tooltip text of New All Day Event text in context menu.
Public Property | MenuNewEventText | Specifies the tooltip text of New Event text in context menu.
Public Property | MenuNewRecurringEventText | Specifies the tooltip text of New Recurring Event text in context menu.
Public Property | MenuSplitViewText | Specifies the tooltip text of Split View Mode text in context menu.
Public Property | MenuTabViewText | Specifies the text of menu icon tooltip in WebScheduler's header. Specifies the text of menu icon tooltip in WebScheduler's header.
Public Property | Minutes10Text | Specifies the text of 10 minutes option in context menu.
Public Property | Minutes15Text | Specifies the text of 15 minutes option in context menu.
Public Property | Minutes30Text | Specifies the text of 30 minutes option in context menu.
Public Property | Minutes60Text | Specifies the text of 60 minutes option in context menu.
Public Property | MonthDateHeaderText | Specifies the text of date header in Month's tooltip. Specifies the text of date header in Month's tooltip.
Public Property | MonthTabView | Specifies the tooltip text of month view's tab. Specifies the tooltip text of month view's tab.
Public Property | MonthText | Specifies the text of Month's tab in WebScheduler header. Specifies the text of Month's tab in WebScheduler header
Public Property | MoreText | Specifies the text of More elements in Month view.
Public Property | Quarter1Text | Specifies the text of first quarter header in Quarter view. Specifies the text of first quarter header in Quarter view.
Public Property | Quarter2Text | Specifies the text of second quarter header in Quarter view. Specifies the text of second quarter header in Quarter view.
Public Property | Quarter3Text | Specifies the text of third quarter header in Quarter view. Specifies the text of third quarter header in Quarter view.
Public Property | Quarter4Text | Specifies the text of fourth quarter header in Quarter view. Specifies the text of quarter quarter header in Quarter view.
Public Property | QuarterTabView | Specifies the tooltip text of quarter view's tab. Specifies the tooltip text of quarter view's tab.
Public Property | QuarterText | Specifies the text of Quarter's tab in WebScheduler header. Specifies the text of Quarter's tab in WebScheduler header.
Public Property | RecurrenceTextSettings | Provides the settings for RecurrenceText.
Public Property | ReminderToolTipText | Specifies the text of event reminder tooltip. Specifies the text of event reminder tooltip.
Public Property | ShowFullWeekText | Specifies the text settings for show full week option. Specifies the text settings for show full week option.
Public Property | ShowWorkWeekText | Specifies the text settings for show work week option. Specifies the text settings for show work week option.
Public Property | SubjectText | Specifies the text of CallOut's subject label. Specifies the text of CallOut's subject label.
Public Property | TimelineResourceHeaderText | Specifies the text of Timeline resource header text. Specifies the text of Timeline resource header text.
Public Property | TimelineTabView | Specifies the tooltip text of Timeline view's tab. Specifies the tooltip text of Timeline view's tab.
Public Property | TimelineText | Specifies the text of Timeline's tab in WebScheduler header. Specifies the text of Timeline's tab in WebScheduler header.
Public Property | TimelineWeekHeaderText | Specifies the tooltip text of Timeline Week view Header text.
Public Property | TimelineZoomIn | Specifies the tooltip text of Timeline ZoomIn icon (Timeline View).
Public Property | TimelineZoomOut | Specifies the tooltip text of Timeline ZoomOut icon (Timeline View).
Public Property | ValidateDisabledTimeText | Specifies the DisabledTime error alert.
Public Property | ViewOnMyCalendarText | Specifies the text of viewOnMyCalendarText in Agenda view. Specifies the text of viewOnMyCalendarText in Agenda view.
Public Property | WeekTabView | Specifies the tooltip text of week view's tab. Specifies the tooltip text of week view's tab.
Public Property | WeekText | Specifies the text of Week's tab in WebScheduler header. Specifies the text of Week's tab in WebScheduler header.
Public Property | WeekViewDateHeaderText | Specifies the text of date header in Week's tooltip. Specifies the text of date header of week view's tab.
Public Property | YearDayOfWeekText | Specifies the text of day header tooltip in Year and Quarter view. Specifies the text of day header tooltip in Year and Quarter view.
Public Property | YearMonthRowHeaderMonthViewText | Specifies the text of row header tooltip in Month view. Specifies the text of row header tooltip in Month view.
Public Property | YearMonthRowHeaderYearQuarterViewText | Specifies the text of row header tooltip in Year and Quarter view. Specifies the text of row header tooltip in Year and Quarter view.
Public Property | YearTabView | Specifies the tooltip text of year view's tab. Specifies the tooltip text of year view's tab.
Public Property | YearText | Specifies the text of Year's tab in WebScheduler header. Specifies the text of Year's tab in WebScheduler header.
Top

See Also

Reference

WebSchedulerTextSettings Class
ISNet.WebUI.WebScheduler Namespace


AddCategoryText Property

[image]
Intersoft WebScheduler Documentation
AddCategoryText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : AddCategoryText Property

Glossary Item Box

Specifies the text of Add Category title in callout. Determines the text of callout title in the related callout.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Add Category title in callout.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property AddCategoryText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.AddCategoryText = value

value = instance.AddCategoryText
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Add Category title in callout.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string AddCategoryText {get; set;}
Delphi
public read-write property AddCategoryText: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.DescriptionAttribute("Specifies the text of Add Category title in callout.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set AddCategoryText : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Add Category title in callout.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_AddCategoryText();
public: __property void set_AddCategoryText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Add Category title in callout.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ AddCategoryText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Add Category.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


AddEventText Property

[image]
Intersoft WebScheduler Documentation
AddEventText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : AddEventText Property

Glossary Item Box

Specifies the text of add event. This text settings will be implemented in CallOut's add event button and agenda add event. Specifies the text of add event. This text setting will be implemented in CallOut's add event button and agenda add event.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the text of add event. This text settings will be implemented in CallOut's add event button and agenda add event.")>
Public Property AddEventText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.AddEventText = value

value = instance.AddEventText
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of add event. This text settings will be implemented in CallOut's add event button and agenda add event.")]
public System.string AddEventText {get; set;}
Delphi
public read-write property AddEventText: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.DescriptionAttribute("Specifies the text of add event. This text settings will be implemented in CallOut's add event button and agenda add event.")
public function get,set AddEventText : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of add event. This text settings will be implemented in CallOut's add event button and agenda add event.")]
public: __property System.string* get_AddEventText();
public: __property void set_AddEventText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of add event. This text settings will be implemented in CallOut's add event button and agenda add event.")]
public:
property System.String^ AddEventText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Add Event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


AddResourceText Property

[image]
Intersoft WebScheduler Documentation
AddResourceText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : AddResourceText Property

Glossary Item Box

Specifies the text of Add Resource title in callout. Determines the text of callout title in the related callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text Settings")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Add Resource title in callout.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property AddResourceText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.AddResourceText = value

value = instance.AddResourceText
C#
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Add Resource title in callout.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string AddResourceText {get; set;}
Delphi
public read-write property AddResourceText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text Settings")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Add Resource title in callout.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set AddResourceText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Add Resource title in callout.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_AddResourceText();
public: __property void set_AddResourceText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Add Resource title in callout.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ AddResourceText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Add Resource.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


AgendaTabView Property

[image]
Intersoft WebScheduler Documentation
AgendaTabView Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : AgendaTabView Property

Glossary Item Box

Specifies the tooltip text of agenda view's tab. Specifies the tooltip text of agenda view's tab.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of agenda view's tab.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AgendaTabView As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.AgendaTabView = value

value = instance.AgendaTabView
C#
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of agenda view's tab.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string AgendaTabView {get; set;}
Delphi
public read-write property AgendaTabView: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of agenda view's tab.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set AgendaTabView : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of agenda view's tab.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_AgendaTabView();
public: __property void set_AgendaTabView(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of agenda view's tab.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ AgendaTabView {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Agenda view.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


AgendaText Property

[image]
Intersoft WebScheduler Documentation
AgendaText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : AgendaText Property

Glossary Item Box

Specifies the text of Agenda's tab in WebScheduler header. Specifies the text of Agenda's tab in WebScheduler header.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Agenda's tab in WebScheduler header.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property AgendaText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.AgendaText = value

value = instance.AgendaText
C#
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Agenda's tab in WebScheduler header.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string AgendaText {get; set;}
Delphi
public read-write property AgendaText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.DescriptionAttribute("Specifies the text of Agenda's tab in WebScheduler header.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set AgendaText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Agenda's tab in WebScheduler header.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_AgendaText();
public: __property void set_AgendaText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Agenda's tab in WebScheduler header.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ AgendaText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Agenda.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


CalendarHeaderText Property

[image]
Intersoft WebScheduler Documentation
CalendarHeaderText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : CalendarHeaderText Property

Glossary Item Box

Specifies the tooltip text of calendar header. Specifies the tooltip text of calendar header.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of calendar header.")>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CalendarHeaderText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.CalendarHeaderText = value

value = instance.CalendarHeaderText
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of calendar header.")]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CalendarHeaderText {get; set;}
Delphi
public read-write property CalendarHeaderText: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of calendar header.")
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set CalendarHeaderText : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of calendar header.")]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CalendarHeaderText();
public: __property void set_CalendarHeaderText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of calendar header.")]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CalendarHeaderText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Change calendar view.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


CalendarNextArrowText Property

[image]
Intersoft WebScheduler Documentation
CalendarNextArrowText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : CalendarNextArrowText Property

Glossary Item Box

Specifies the tooltip text of calendar's next arrow. Specifies the tooltip text of calendar's next arrow.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of calendar's next arrow.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CalendarNextArrowText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.CalendarNextArrowText = value

value = instance.CalendarNextArrowText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of calendar's next arrow.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CalendarNextArrowText {get; set;}
Delphi
public read-write property CalendarNextArrowText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of calendar's next arrow.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set CalendarNextArrowText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of calendar's next arrow.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CalendarNextArrowText();
public: __property void set_CalendarNextArrowText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of calendar's next arrow.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CalendarNextArrowText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Forward.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


CalendarPrevArrowText Property

[image]
Intersoft WebScheduler Documentation
CalendarPrevArrowText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : CalendarPrevArrowText Property

Glossary Item Box

Specifies the tooltip text of calendar's previous arrow. Specifies the tooltip text of calendar's previous arrow.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of calendar's previous arrow.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CalendarPrevArrowText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.CalendarPrevArrowText = value

value = instance.CalendarPrevArrowText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of calendar's previous arrow.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CalendarPrevArrowText {get; set;}
Delphi
public read-write property CalendarPrevArrowText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of calendar's previous arrow.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set CalendarPrevArrowText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of calendar's previous arrow.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CalendarPrevArrowText();
public: __property void set_CalendarPrevArrowText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of calendar's previous arrow.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CalendarPrevArrowText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Back.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


CallOutResourceFieldText Property

[image]
Intersoft WebScheduler Documentation
CallOutResourceFieldText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : CallOutResourceFieldText Property

Glossary Item Box

Specifies the text of Resource field in callout. Determines the text of callout title in the related callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Resource field in callout.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property CallOutResourceFieldText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.CallOutResourceFieldText = value

value = instance.CallOutResourceFieldText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Resource field in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string CallOutResourceFieldText {get; set;}
Delphi
public read-write property CallOutResourceFieldText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Resource field in callout.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set CallOutResourceFieldText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Resource field in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_CallOutResourceFieldText();
public: __property void set_CallOutResourceFieldText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Resource field in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ CallOutResourceFieldText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Resource.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


CollapseAllText Property

[image]
Intersoft WebScheduler Documentation
CollapseAllText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : CollapseAllText Property

Glossary Item Box

Specifies the text of collapse icon in Agenda view. Specifies the text of collapse's icon in Agenda view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of collapse's icon in Agenda view.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CollapseAllText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.CollapseAllText = value

value = instance.CollapseAllText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of collapse's icon in Agenda view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CollapseAllText {get; set;}
Delphi
public read-write property CollapseAllText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of collapse's icon in Agenda view.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set CollapseAllText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of collapse's icon in Agenda view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CollapseAllText();
public: __property void set_CollapseAllText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of collapse's icon in Agenda view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CollapseAllText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Collapse all.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


CollapseCalendarText Property

[image]
Intersoft WebScheduler Documentation
CollapseCalendarText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : CollapseCalendarText Property

Glossary Item Box

Specifies the text of collapse calendar icon tooltip in WebScheduler's header. Specifies the text of collapse calendar icon in WebScheduler's header.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the text of collapse callendar icon in WebScheduler's header.")>
Public Property CollapseCalendarText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.CollapseCalendarText = value

value = instance.CollapseCalendarText
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of collapse callendar icon in WebScheduler's header.")]
public System.string CollapseCalendarText {get; set;}
Delphi
public read-write property CollapseCalendarText: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.DescriptionAttribute("Specifies the text of collapse callendar icon in WebScheduler's header.")
public function get,set CollapseCalendarText : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of collapse callendar icon in WebScheduler's header.")]
public: __property System.string* get_CollapseCalendarText();
public: __property void set_CollapseCalendarText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of collapse callendar icon in WebScheduler's header.")]
public:
property System.String^ CollapseCalendarText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Collapse calendar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


DayTabView Property

[image]
Intersoft WebScheduler Documentation
DayTabView Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : DayTabView Property

Glossary Item Box

Specifies the tooltip text of day view's tab. Specifies the tooltip text of day view's tab.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of day view's tab.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Text Settings")>
Public Property DayTabView As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.DayTabView = value

value = instance.DayTabView
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of day view's tab.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text Settings")]
public System.string DayTabView {get; set;}
Delphi
public read-write property DayTabView: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of day view's tab.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
public function get,set DayTabView : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of day view's tab.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text Settings")]
public: __property System.string* get_DayTabView();
public: __property void set_DayTabView(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of day view's tab.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text Settings")]
public:
property System.String^ DayTabView {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Day view.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


DayText Property

[image]
Intersoft WebScheduler Documentation
DayText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : DayText Property

Glossary Item Box

Specifies the text of Day's tab in WebScheduler header. Specifies the text of Day's tab in WebScheduler header

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Day's tab in WebScheduler header.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property DayText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.DayText = value

value = instance.DayText
C#
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Day's tab in WebScheduler header.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string DayText {get; set;}
Delphi
public read-write property DayText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.DescriptionAttribute("Specifies the text of Day's tab in WebScheduler header.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set DayText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Day's tab in WebScheduler header.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_DayText();
public: __property void set_DayText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Day's tab in WebScheduler header.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ DayText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Day.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


DeleteEventText Property

[image]
Intersoft WebScheduler Documentation
DeleteEventText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : DeleteEventText Property

Glossary Item Box

Specifies the text of delete event. This text settings will be implemented in CallOut's delete event button and agenda edit event. Specifies the text of delete event.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property DeleteEventText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.DeleteEventText = value

value = instance.DeleteEventText
C#
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string DeleteEventText {get; set;}
Delphi
public read-write property DeleteEventText: System.String;
JScript
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set DeleteEventText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_DeleteEventText();
public: __property void set_DeleteEventText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ DeleteEventText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Delete Event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


DescriptionText Property

[image]
Intersoft WebScheduler Documentation
DescriptionText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : DescriptionText Property

Glossary Item Box

Specifies the text of CallOut's description label. Specifies the text of CallOut's description label.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the text of CallOut's description label.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property DescriptionText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.DescriptionText = value

value = instance.DescriptionText
C#
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of CallOut's description label.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string DescriptionText {get; set;}
Delphi
public read-write property DescriptionText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of CallOut's description label.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set DescriptionText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of CallOut's description label.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_DescriptionText();
public: __property void set_DescriptionText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of CallOut's description label.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ DescriptionText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Description.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


DisabledTimeText Property

[image]
Intersoft WebScheduler Documentation
DisabledTimeText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : DisabledTimeText Property

Glossary Item Box

Specifies the tooltip text of Disabled time in Timeline view.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Disabled time in Timeline view.")>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property DisabledTimeText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.DisabledTimeText = value

value = instance.DisabledTimeText
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Disabled time in Timeline view.")]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string DisabledTimeText {get; set;}
Delphi
public read-write property DisabledTimeText: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Disabled time in Timeline view.")
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set DisabledTimeText : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Disabled time in Timeline view.")]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_DisabledTimeText();
public: __property void set_DisabledTimeText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Disabled time in Timeline view.")]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ DisabledTimeText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Disabled time.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


EditDetailText Property

[image]
Intersoft WebScheduler Documentation
EditDetailText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : EditDetailText Property

Glossary Item Box

Specifies the text of edit detail link in the CallOut. Specifies the text of edit detail link in the CallOut.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the text of edit detail link in the CallOut.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property EditDetailText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.EditDetailText = value

value = instance.EditDetailText
C#
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of edit detail link in the CallOut.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string EditDetailText {get; set;}
Delphi
public read-write property EditDetailText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.DescriptionAttribute("Specifies the text of edit detail link in the CallOut.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set EditDetailText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of edit detail link in the CallOut.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_EditDetailText();
public: __property void set_EditDetailText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of edit detail link in the CallOut.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ EditDetailText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Detail.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


EditEventText Property

[image]
Intersoft WebScheduler Documentation
EditEventText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : EditEventText Property

Glossary Item Box

Specifies the text of edit event. This text settings will be implemented in CallOut's edit event button and agenda edit event. Specifies the text of edit event. This text setting will be implemented in CallOut's edit event button and agenda edit event.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of edit event. This text settings will be implemented in CallOut's edit event button and agenda edit event.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property EditEventText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.EditEventText = value

value = instance.EditEventText
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of edit event. This text settings will be implemented in CallOut's edit event button and agenda edit event.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string EditEventText {get; set;}
Delphi
public read-write property EditEventText: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of edit event. This text settings will be implemented in CallOut's edit event button and agenda edit event.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set EditEventText : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of edit event. This text settings will be implemented in CallOut's edit event button and agenda edit event.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_EditEventText();
public: __property void set_EditEventText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of edit event. This text settings will be implemented in CallOut's edit event button and agenda edit event.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ EditEventText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Edit Event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


ExpandAllText Property

[image]
Intersoft WebScheduler Documentation
ExpandAllText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : ExpandAllText Property

Glossary Item Box

Specifies the text of expand icon in Agenda view. Specifies the text of expand's icon in Agenda view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of expand's icon in Agenda view.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ExpandAllText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.ExpandAllText = value

value = instance.ExpandAllText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of expand's icon in Agenda view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string ExpandAllText {get; set;}
Delphi
public read-write property ExpandAllText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of expand's icon in Agenda view.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set ExpandAllText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of expand's icon in Agenda view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_ExpandAllText();
public: __property void set_ExpandAllText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of expand's icon in Agenda view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ ExpandAllText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Expand all.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


ExpandCalendarText Property

[image]
Intersoft WebScheduler Documentation
ExpandCalendarText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : ExpandCalendarText Property

Glossary Item Box

Specifies the text of expand calendar icon tooltip in WebScheduler's header. Specifies the text of expand calendar icon in WebScheduler's header.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of expand calendar icon in WebScheduler's header.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ExpandCalendarText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.ExpandCalendarText = value

value = instance.ExpandCalendarText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of expand calendar icon in WebScheduler's header.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string ExpandCalendarText {get; set;}
Delphi
public read-write property ExpandCalendarText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of expand calendar icon in WebScheduler's header.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ExpandCalendarText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of expand calendar icon in WebScheduler's header.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_ExpandCalendarText();
public: __property void set_ExpandCalendarText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of expand calendar icon in WebScheduler's header.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ ExpandCalendarText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Expand calendar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


HighImportanceText Property

[image]
Intersoft WebScheduler Documentation
HighImportanceText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : HighImportanceText Property

Glossary Item Box

Specifies the tooltip text of high importance image in event.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of high importance image in event.")>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property HighImportanceText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.HighImportanceText = value

value = instance.HighImportanceText
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of high importance image in event.")]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string HighImportanceText {get; set;}
Delphi
public read-write property HighImportanceText: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of high importance image in event.")
System.ComponentModel.CategoryAttribute("Text Settings")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set HighImportanceText : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of high importance image in event.")]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_HighImportanceText();
public: __property void set_HighImportanceText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of high importance image in event.")]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ HighImportanceText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Today.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


LocationText Property

[image]
Intersoft WebScheduler Documentation
LocationText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : LocationText Property

Glossary Item Box

Specifies the text of CallOut's location label. Specifies the text of CallOut's location label.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the text of CallOut's location label.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property LocationText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.LocationText = value

value = instance.LocationText
C#
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of CallOut's location label.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string LocationText {get; set;}
Delphi
public read-write property LocationText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.DescriptionAttribute("Specifies the text of CallOut's location label.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set LocationText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of CallOut's location label.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_LocationText();
public: __property void set_LocationText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of CallOut's location label.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ LocationText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Location.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


LowImportanceText Property

[image]
Intersoft WebScheduler Documentation
LowImportanceText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : LowImportanceText Property

Glossary Item Box

Specifies the tooltip text of low importance image in event.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of low importance image in event.")>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property LowImportanceText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.LowImportanceText = value

value = instance.LowImportanceText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of low importance image in event.")]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string LowImportanceText {get; set;}
Delphi
public read-write property LowImportanceText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of low importance image in event.")
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set LowImportanceText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of low importance image in event.")]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_LowImportanceText();
public: __property void set_LowImportanceText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of low importance image in event.")]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ LowImportanceText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Today.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


ManageResourcesText Property

[image]
Intersoft WebScheduler Documentation
ManageResourcesText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : ManageResourcesText Property

Glossary Item Box

Specifies the text of Resource's header. Specifies the text of Resource's header.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Resource's header.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ManageResourcesText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.ManageResourcesText = value

value = instance.ManageResourcesText
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Resource's header.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string ManageResourcesText {get; set;}
Delphi
public read-write property ManageResourcesText: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.DescriptionAttribute("Specifies the text of Resource's header.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ManageResourcesText : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Resource's header.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_ManageResourcesText();
public: __property void set_ManageResourcesText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Resource's header.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ ManageResourcesText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Resources.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


MenuCategorizeText Property

[image]
Intersoft WebScheduler Documentation
MenuCategorizeText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : MenuCategorizeText Property

Glossary Item Box

Specifies the tooltip text of Categorize text in context menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Categorize text in context menu.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property MenuCategorizeText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.MenuCategorizeText = value

value = instance.MenuCategorizeText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Categorize text in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string MenuCategorizeText {get; set;}
Delphi
public read-write property MenuCategorizeText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Categorize text in context menu.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set MenuCategorizeText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Categorize text in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_MenuCategorizeText();
public: __property void set_MenuCategorizeText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Categorize text in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ MenuCategorizeText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Today.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


MenuDeleteEventText Property

[image]
Intersoft WebScheduler Documentation
MenuDeleteEventText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : MenuDeleteEventText Property

Glossary Item Box

Specifies the tooltip text of Delete Event text in context menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Delete Event text in context menu.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property MenuDeleteEventText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.MenuDeleteEventText = value

value = instance.MenuDeleteEventText
C#
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Delete Event text in context menu.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string MenuDeleteEventText {get; set;}
Delphi
public read-write property MenuDeleteEventText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Delete Event text in context menu.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set MenuDeleteEventText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Delete Event text in context menu.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_MenuDeleteEventText();
public: __property void set_MenuDeleteEventText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Delete Event text in context menu.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ MenuDeleteEventText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Delete.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


MenuEditEventText Property

[image]
Intersoft WebScheduler Documentation
MenuEditEventText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : MenuEditEventText Property

Glossary Item Box

Specifies the tooltip text of Edit Event text in context menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Edit Event text in context menu.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property MenuEditEventText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.MenuEditEventText = value

value = instance.MenuEditEventText
C#
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Edit Event text in context menu.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string MenuEditEventText {get; set;}
Delphi
public read-write property MenuEditEventText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Edit Event text in context menu.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set MenuEditEventText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Edit Event text in context menu.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_MenuEditEventText();
public: __property void set_MenuEditEventText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Edit Event text in context menu.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ MenuEditEventText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Edit.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


MenuGoToThisDayText Property

[image]
Intersoft WebScheduler Documentation
MenuGoToThisDayText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : MenuGoToThisDayText Property

Glossary Item Box

Specifies the tooltip text of Go To This Day text in context menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Go To This Day text in context menu.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property MenuGoToThisDayText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.MenuGoToThisDayText = value

value = instance.MenuGoToThisDayText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Go To This Day text in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string MenuGoToThisDayText {get; set;}
Delphi
public read-write property MenuGoToThisDayText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Go To This Day text in context menu.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set MenuGoToThisDayText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Go To This Day text in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_MenuGoToThisDayText();
public: __property void set_MenuGoToThisDayText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Go To This Day text in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ MenuGoToThisDayText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Go To This Day.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


MenuGoToToDayText Property

[image]
Intersoft WebScheduler Documentation
MenuGoToToDayText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : MenuGoToToDayText Property

Glossary Item Box

Specifies the tooltip text of Go To Today text in context menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Go To Today text in context menu.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property MenuGoToToDayText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.MenuGoToToDayText = value

value = instance.MenuGoToToDayText
C#
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Go To Today text in context menu.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string MenuGoToToDayText {get; set;}
Delphi
public read-write property MenuGoToToDayText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Go To Today text in context menu.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set MenuGoToToDayText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Go To Today text in context menu.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_MenuGoToToDayText();
public: __property void set_MenuGoToToDayText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Go To Today text in context menu.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ MenuGoToToDayText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Today.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


MenuNewAllDayEventText Property

[image]
Intersoft WebScheduler Documentation
MenuNewAllDayEventText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : MenuNewAllDayEventText Property

Glossary Item Box

Specifies the tooltip text of New All Day Event text in context menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of New All Day Event text in context menu.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property MenuNewAllDayEventText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.MenuNewAllDayEventText = value

value = instance.MenuNewAllDayEventText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of New All Day Event text in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string MenuNewAllDayEventText {get; set;}
Delphi
public read-write property MenuNewAllDayEventText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of New All Day Event text in context menu.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set MenuNewAllDayEventText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of New All Day Event text in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_MenuNewAllDayEventText();
public: __property void set_MenuNewAllDayEventText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of New All Day Event text in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ MenuNewAllDayEventText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is New All Day Event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


MenuNewEventText Property

[image]
Intersoft WebScheduler Documentation
MenuNewEventText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : MenuNewEventText Property

Glossary Item Box

Specifies the tooltip text of New Event text in context menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of New Event text in context menu.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property MenuNewEventText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.MenuNewEventText = value

value = instance.MenuNewEventText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of New Event text in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string MenuNewEventText {get; set;}
Delphi
public read-write property MenuNewEventText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of New Event text in context menu.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set MenuNewEventText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of New Event text in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_MenuNewEventText();
public: __property void set_MenuNewEventText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of New Event text in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ MenuNewEventText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is New Event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


MenuNewRecurringEventText Property

[image]
Intersoft WebScheduler Documentation
MenuNewRecurringEventText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : MenuNewRecurringEventText Property

Glossary Item Box

Specifies the tooltip text of New Recurring Event text in context menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of New Recurring Event text in context menu.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property MenuNewRecurringEventText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.MenuNewRecurringEventText = value

value = instance.MenuNewRecurringEventText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of New Recurring Event text in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string MenuNewRecurringEventText {get; set;}
Delphi
public read-write property MenuNewRecurringEventText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of New Recurring Event text in context menu.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set MenuNewRecurringEventText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of New Recurring Event text in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_MenuNewRecurringEventText();
public: __property void set_MenuNewRecurringEventText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of New Recurring Event text in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ MenuNewRecurringEventText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is New Recurring Event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


MenuSplitViewText Property

[image]
Intersoft WebScheduler Documentation
MenuSplitViewText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : MenuSplitViewText Property

Glossary Item Box

Specifies the tooltip text of Split View Mode text in context menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Split View Mode text in context menu.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property MenuSplitViewText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.MenuSplitViewText = value

value = instance.MenuSplitViewText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Split View Mode text in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string MenuSplitViewText {get; set;}
Delphi
public read-write property MenuSplitViewText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Split View Mode text in context menu.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set MenuSplitViewText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Split View Mode text in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_MenuSplitViewText();
public: __property void set_MenuSplitViewText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Split View Mode text in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ MenuSplitViewText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Split View Mode.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


MenuTabViewText Property

[image]
Intersoft WebScheduler Documentation
MenuTabViewText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : MenuTabViewText Property

Glossary Item Box

Specifies the text of menu icon tooltip in WebScheduler's header. Specifies the text of menu icon tooltip in WebScheduler's header.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of menu icon tooltip in WebScheduler's header.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property MenuTabViewText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.MenuTabViewText = value

value = instance.MenuTabViewText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of menu icon tooltip in WebScheduler's header.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string MenuTabViewText {get; set;}
Delphi
public read-write property MenuTabViewText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of menu icon tooltip in WebScheduler's header.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set MenuTabViewText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of menu icon tooltip in WebScheduler's header.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_MenuTabViewText();
public: __property void set_MenuTabViewText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of menu icon tooltip in WebScheduler's header.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ MenuTabViewText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Show menu.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


Minutes10Text Property

[image]
Intersoft WebScheduler Documentation
Minutes10Text Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : Minutes10Text Property

Glossary Item Box

Specifies the text of 10 minutes option in context menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of 10 minutes option in context menu.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Minutes10Text As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.Minutes10Text = value

value = instance.Minutes10Text
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of 10 minutes option in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Minutes10Text {get; set;}
Delphi
public read-write property Minutes10Text: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of 10 minutes option in context menu.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Minutes10Text : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of 10 minutes option in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Minutes10Text();
public: __property void set_Minutes10Text(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of 10 minutes option in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Minutes10Text {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is 10 Minutes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


Minutes15Text Property

[image]
Intersoft WebScheduler Documentation
Minutes15Text Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : Minutes15Text Property

Glossary Item Box

Specifies the text of 15 minutes option in context menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of 15 minutes option in context menu.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Minutes15Text As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.Minutes15Text = value

value = instance.Minutes15Text
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of 15 minutes option in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Minutes15Text {get; set;}
Delphi
public read-write property Minutes15Text: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of 15 minutes option in context menu.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Minutes15Text : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of 15 minutes option in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Minutes15Text();
public: __property void set_Minutes15Text(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of 15 minutes option in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Minutes15Text {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is 15 Minutes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


Minutes30Text Property

[image]
Intersoft WebScheduler Documentation
Minutes30Text Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : Minutes30Text Property

Glossary Item Box

Specifies the text of 30 minutes option in context menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of 30 minutes option in context menu.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Minutes30Text As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.Minutes30Text = value

value = instance.Minutes30Text
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of 30 minutes option in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Minutes30Text {get; set;}
Delphi
public read-write property Minutes30Text: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of 30 minutes option in context menu.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Minutes30Text : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of 30 minutes option in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Minutes30Text();
public: __property void set_Minutes30Text(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of 30 minutes option in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Minutes30Text {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is 30 Minutes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


Minutes60Text Property

[image]
Intersoft WebScheduler Documentation
Minutes60Text Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : Minutes60Text Property

Glossary Item Box

Specifies the text of 60 minutes option in context menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of 60 minutes option in context menu.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Minutes60Text As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.Minutes60Text = value

value = instance.Minutes60Text
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of 60 minutes option in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Minutes60Text {get; set;}
Delphi
public read-write property Minutes60Text: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of 60 minutes option in context menu.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Minutes60Text : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of 60 minutes option in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Minutes60Text();
public: __property void set_Minutes60Text(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of 60 minutes option in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Minutes60Text {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is 60 Minutes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


MonthDateHeaderText Property

[image]
Intersoft WebScheduler Documentation
MonthDateHeaderText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : MonthDateHeaderText Property

Glossary Item Box

Specifies the text of date header in Month's tooltip. Specifies the text of date header in Month's tooltip.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text Settings")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the text of date header in Month's tooltip.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property MonthDateHeaderText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.MonthDateHeaderText = value

value = instance.MonthDateHeaderText
C#
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of date header in Month's tooltip.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string MonthDateHeaderText {get; set;}
Delphi
public read-write property MonthDateHeaderText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text Settings")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of date header in Month's tooltip.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set MonthDateHeaderText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of date header in Month's tooltip.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_MonthDateHeaderText();
public: __property void set_MonthDateHeaderText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of date header in Month's tooltip.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ MonthDateHeaderText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Goto [day].

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


MonthTabView Property

[image]
Intersoft WebScheduler Documentation
MonthTabView Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : MonthTabView Property

Glossary Item Box

Specifies the tooltip text of month view's tab. Specifies the tooltip text of month view's tab.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of month view's tab.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
Public Property MonthTabView As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.MonthTabView = value

value = instance.MonthTabView
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of month view's tab.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
public System.string MonthTabView {get; set;}
Delphi
public read-write property MonthTabView: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of month view's tab.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
public function get,set MonthTabView : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of month view's tab.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
public: __property System.string* get_MonthTabView();
public: __property void set_MonthTabView(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of month view's tab.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
public:
property System.String^ MonthTabView {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Month view.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


MonthText Property

[image]
Intersoft WebScheduler Documentation
MonthText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : MonthText Property

Glossary Item Box

Specifies the text of Month's tab in WebScheduler header. Specifies the text of Month's tab in WebScheduler header

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text Settings")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Month's tab in WebScheduler header.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property MonthText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.MonthText = value

value = instance.MonthText
C#
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Month's tab in WebScheduler header.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string MonthText {get; set;}
Delphi
public read-write property MonthText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text Settings")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Month's tab in WebScheduler header.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set MonthText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Month's tab in WebScheduler header.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_MonthText();
public: __property void set_MonthText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Month's tab in WebScheduler header.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ MonthText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Month.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


MoreText Property

[image]
Intersoft WebScheduler Documentation
MoreText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : MoreText Property

Glossary Item Box

Specifies the text of More elements in Month view.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of More elements in Month view.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
Public Property MoreText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.MoreText = value

value = instance.MoreText
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of More elements in Month view.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
public System.string MoreText {get; set;}
Delphi
public read-write property MoreText: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of More elements in Month view.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
public function get,set MoreText : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of More elements in Month view.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
public: __property System.string* get_MoreText();
public: __property void set_MoreText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of More elements in Month view.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
public:
property System.String^ MoreText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is More.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


Quarter1Text Property

[image]
Intersoft WebScheduler Documentation
Quarter1Text Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : Quarter1Text Property

Glossary Item Box

Specifies the text of first quarter header in Quarter view. Specifies the text of first quarter header in Quarter view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of first quarter header in Quarter view.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Quarter1Text As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.Quarter1Text = value

value = instance.Quarter1Text
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of first quarter header in Quarter view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Quarter1Text {get; set;}
Delphi
public read-write property Quarter1Text: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of first quarter header in Quarter view.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Quarter1Text : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of first quarter header in Quarter view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Quarter1Text();
public: __property void set_Quarter1Text(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of first quarter header in Quarter view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Quarter1Text {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Quarter 1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


Quarter2Text Property

[image]
Intersoft WebScheduler Documentation
Quarter2Text Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : Quarter2Text Property

Glossary Item Box

Specifies the text of second quarter header in Quarter view. Specifies the text of second quarter header in Quarter view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of second quarter header in Quarter view.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Quarter2Text As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.Quarter2Text = value

value = instance.Quarter2Text
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of second quarter header in Quarter view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Quarter2Text {get; set;}
Delphi
public read-write property Quarter2Text: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of second quarter header in Quarter view.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Quarter2Text : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of second quarter header in Quarter view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Quarter2Text();
public: __property void set_Quarter2Text(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of second quarter header in Quarter view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Quarter2Text {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Quarter 2.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


Quarter3Text Property

[image]
Intersoft WebScheduler Documentation
Quarter3Text Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : Quarter3Text Property

Glossary Item Box

Specifies the text of third quarter header in Quarter view. Specifies the text of third quarter header in Quarter view.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of third quarter header in Quarter view.")>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Quarter3Text As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.Quarter3Text = value

value = instance.Quarter3Text
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of third quarter header in Quarter view.")]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Quarter3Text {get; set;}
Delphi
public read-write property Quarter3Text: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of third quarter header in Quarter view.")
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Quarter3Text : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of third quarter header in Quarter view.")]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Quarter3Text();
public: __property void set_Quarter3Text(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of third quarter header in Quarter view.")]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Quarter3Text {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Quarter 3.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


Quarter4Text Property

[image]
Intersoft WebScheduler Documentation
Quarter4Text Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : Quarter4Text Property

Glossary Item Box

Specifies the text of fourth quarter header in Quarter view. Specifies the text of quarter quarter header in Quarter view.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of fourth quarter header in Quarter view.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
Public Property Quarter4Text As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.Quarter4Text = value

value = instance.Quarter4Text
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of fourth quarter header in Quarter view.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
public System.string Quarter4Text {get; set;}
Delphi
public read-write property Quarter4Text: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of fourth quarter header in Quarter view.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
public function get,set Quarter4Text : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of fourth quarter header in Quarter view.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
public: __property System.string* get_Quarter4Text();
public: __property void set_Quarter4Text(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of fourth quarter header in Quarter view.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
public:
property System.String^ Quarter4Text {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Quarter 4.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


QuarterTabView Property

[image]
Intersoft WebScheduler Documentation
QuarterTabView Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : QuarterTabView Property

Glossary Item Box

Specifies the tooltip text of quarter view's tab. Specifies the tooltip text of quarter view's tab.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of quarter view's tab.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
Public Property QuarterTabView As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.QuarterTabView = value

value = instance.QuarterTabView
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of quarter view's tab.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
public System.string QuarterTabView {get; set;}
Delphi
public read-write property QuarterTabView: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of quarter view's tab.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
public function get,set QuarterTabView : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of quarter view's tab.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
public: __property System.string* get_QuarterTabView();
public: __property void set_QuarterTabView(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of quarter view's tab.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
public:
property System.String^ QuarterTabView {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Quarter view.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


QuarterText Property

[image]
Intersoft WebScheduler Documentation
QuarterText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : QuarterText Property

Glossary Item Box

Specifies the text of Quarter's tab in WebScheduler header. Specifies the text of Quarter's tab in WebScheduler header.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text Settings")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Quarter's tab in WebScheduler header.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property QuarterText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.QuarterText = value

value = instance.QuarterText
C#
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Quarter's tab in WebScheduler header.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string QuarterText {get; set;}
Delphi
public read-write property QuarterText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text Settings")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Quarter's tab in WebScheduler header.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set QuarterText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Quarter's tab in WebScheduler header.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_QuarterText();
public: __property void set_QuarterText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Quarter's tab in WebScheduler header.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ QuarterText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Quarter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


RecurrenceTextSettings Property

[image]
Intersoft WebScheduler Documentation
RecurrenceTextSettings Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : RecurrenceTextSettings Property

Glossary Item Box

Provides the settings for RecurrenceText.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public ReadOnly Property RecurrenceTextSettings As WebSchedulerRecurrenceTextSettings
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As WebSchedulerRecurrenceTextSettings

value = instance.RecurrenceTextSettings
C#
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebSchedulerRecurrenceTextSettings RecurrenceTextSettings {get;}
Delphi
public read-only property RecurrenceTextSettings: WebSchedulerRecurrenceTextSettings;
JScript
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get RecurrenceTextSettings : WebSchedulerRecurrenceTextSettings
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebSchedulerRecurrenceTextSettings* get_RecurrenceTextSettings();
C++/CLI
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebSchedulerRecurrenceTextSettings^ RecurrenceTextSettings {
   WebSchedulerRecurrenceTextSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


ReminderToolTipText Property

[image]
Intersoft WebScheduler Documentation
ReminderToolTipText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : ReminderToolTipText Property

Glossary Item Box

Specifies the text of event reminder tooltip. Specifies the text of event reminder tooltip.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of event reminder tooltip.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ReminderToolTipText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.ReminderToolTipText = value

value = instance.ReminderToolTipText
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of event reminder tooltip.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string ReminderToolTipText {get; set;}
Delphi
public read-write property ReminderToolTipText: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of event reminder tooltip.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set ReminderToolTipText : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of event reminder tooltip.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_ReminderToolTipText();
public: __property void set_ReminderToolTipText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of event reminder tooltip.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ ReminderToolTipText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Reminder: [n] minutes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


ShowFullWeekText Property

[image]
Intersoft WebScheduler Documentation
ShowFullWeekText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : ShowFullWeekText Property

Glossary Item Box

Specifies the text settings for show full week option. Specifies the text settings for show full week option.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the text settings for show full week option.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ShowFullWeekText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.ShowFullWeekText = value

value = instance.ShowFullWeekText
C#
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the text settings for show full week option.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string ShowFullWeekText {get; set;}
Delphi
public read-write property ShowFullWeekText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.DescriptionAttribute("Specifies the text settings for show full week option.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ShowFullWeekText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the text settings for show full week option.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_ShowFullWeekText();
public: __property void set_ShowFullWeekText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the text settings for show full week option.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ ShowFullWeekText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Show full week.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


ShowWorkWeekText Property

[image]
Intersoft WebScheduler Documentation
ShowWorkWeekText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : ShowWorkWeekText Property

Glossary Item Box

Specifies the text settings for show work week option. Specifies the text settings for show work week option.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text settings for show work week option.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ShowWorkWeekText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.ShowWorkWeekText = value

value = instance.ShowWorkWeekText
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text settings for show work week option.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string ShowWorkWeekText {get; set;}
Delphi
public read-write property ShowWorkWeekText: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text settings for show work week option.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ShowWorkWeekText : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text settings for show work week option.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_ShowWorkWeekText();
public: __property void set_ShowWorkWeekText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text settings for show work week option.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ ShowWorkWeekText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Show work week.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


SubjectText Property

[image]
Intersoft WebScheduler Documentation
SubjectText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : SubjectText Property

Glossary Item Box

Specifies the text of CallOut's subject label. Specifies the text of CallOut's subject label.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of CallOut's subject label.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property SubjectText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.SubjectText = value

value = instance.SubjectText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of CallOut's subject label.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string SubjectText {get; set;}
Delphi
public read-write property SubjectText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of CallOut's subject label.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set SubjectText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of CallOut's subject label.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_SubjectText();
public: __property void set_SubjectText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of CallOut's subject label.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ SubjectText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Subject.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


TimelineResourceHeaderText Property

[image]
Intersoft WebScheduler Documentation
TimelineResourceHeaderText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : TimelineResourceHeaderText Property

Glossary Item Box

Specifies the text of Timeline resource header text. Specifies the text of Timeline resource header text.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Timeline resource header text.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property TimelineResourceHeaderText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.TimelineResourceHeaderText = value

value = instance.TimelineResourceHeaderText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Timeline resource header text.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string TimelineResourceHeaderText {get; set;}
Delphi
public read-write property TimelineResourceHeaderText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Timeline resource header text.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set TimelineResourceHeaderText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Timeline resource header text.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_TimelineResourceHeaderText();
public: __property void set_TimelineResourceHeaderText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Timeline resource header text.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ TimelineResourceHeaderText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Resources.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


TimelineTabView Property

[image]
Intersoft WebScheduler Documentation
TimelineTabView Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : TimelineTabView Property

Glossary Item Box

Specifies the tooltip text of Timeline view's tab. Specifies the tooltip text of Timeline view's tab.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Timeline view's tab.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property TimelineTabView As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.TimelineTabView = value

value = instance.TimelineTabView
C#
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Timeline view's tab.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string TimelineTabView {get; set;}
Delphi
public read-write property TimelineTabView: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Timeline view's tab.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set TimelineTabView : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Timeline view's tab.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_TimelineTabView();
public: __property void set_TimelineTabView(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Timeline view's tab.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ TimelineTabView {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Timeline view.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


TimelineText Property

[image]
Intersoft WebScheduler Documentation
TimelineText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : TimelineText Property

Glossary Item Box

Specifies the text of Timeline's tab in WebScheduler header. Specifies the text of Timeline's tab in WebScheduler header.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Timeline's tab in WebScheduler header.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property TimelineText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.TimelineText = value

value = instance.TimelineText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Timeline's tab in WebScheduler header.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string TimelineText {get; set;}
Delphi
public read-write property TimelineText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Timeline's tab in WebScheduler header.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set TimelineText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Timeline's tab in WebScheduler header.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_TimelineText();
public: __property void set_TimelineText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Timeline's tab in WebScheduler header.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ TimelineText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Timeline.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


TimelineWeekHeaderText Property

[image]
Intersoft WebScheduler Documentation
TimelineWeekHeaderText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : TimelineWeekHeaderText Property

Glossary Item Box

Specifies the tooltip text of Timeline Week view Header text.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Timeline Week view Header text.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property TimelineWeekHeaderText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.TimelineWeekHeaderText = value

value = instance.TimelineWeekHeaderText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Timeline Week view Header text.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string TimelineWeekHeaderText {get; set;}
Delphi
public read-write property TimelineWeekHeaderText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Timeline Week view Header text.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set TimelineWeekHeaderText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Timeline Week view Header text.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_TimelineWeekHeaderText();
public: __property void set_TimelineWeekHeaderText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Timeline Week view Header text.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ TimelineWeekHeaderText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Week [n] ([MMM yyyy]).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


TimelineZoomIn Property

[image]
Intersoft WebScheduler Documentation
TimelineZoomIn Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : TimelineZoomIn Property

Glossary Item Box

Specifies the tooltip text of Timeline ZoomIn icon (Timeline View).

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Timeline ZoomIn icon (Timeline View).")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property TimelineZoomIn As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.TimelineZoomIn = value

value = instance.TimelineZoomIn
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Timeline ZoomIn icon (Timeline View).")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string TimelineZoomIn {get; set;}
Delphi
public read-write property TimelineZoomIn: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Timeline ZoomIn icon (Timeline View).")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set TimelineZoomIn : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Timeline ZoomIn icon (Timeline View).")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_TimelineZoomIn();
public: __property void set_TimelineZoomIn(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Timeline ZoomIn icon (Timeline View).")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ TimelineZoomIn {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is ZoomIn.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


TimelineZoomOut Property

[image]
Intersoft WebScheduler Documentation
TimelineZoomOut Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : TimelineZoomOut Property

Glossary Item Box

Specifies the tooltip text of Timeline ZoomOut icon (Timeline View).

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Timeline ZoomOut icon (Timeline View).")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Text Settings")>
Public Property TimelineZoomOut As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.TimelineZoomOut = value

value = instance.TimelineZoomOut
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Timeline ZoomOut icon (Timeline View).")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text Settings")]
public System.string TimelineZoomOut {get; set;}
Delphi
public read-write property TimelineZoomOut: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Timeline ZoomOut icon (Timeline View).")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
public function get,set TimelineZoomOut : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Timeline ZoomOut icon (Timeline View).")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text Settings")]
public: __property System.string* get_TimelineZoomOut();
public: __property void set_TimelineZoomOut(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of Timeline ZoomOut icon (Timeline View).")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text Settings")]
public:
property System.String^ TimelineZoomOut {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is ZoomOut.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


ValidateDisabledTimeText Property

[image]
Intersoft WebScheduler Documentation
ValidateDisabledTimeText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : ValidateDisabledTimeText Property

Glossary Item Box

Specifies the DisabledTime error alert.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the DisabledTime error alert.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
Public Property ValidateDisabledTimeText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.ValidateDisabledTimeText = value

value = instance.ValidateDisabledTimeText
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the DisabledTime error alert.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
public System.string ValidateDisabledTimeText {get; set;}
Delphi
public read-write property ValidateDisabledTimeText: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the DisabledTime error alert.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
public function get,set ValidateDisabledTimeText : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the DisabledTime error alert.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
public: __property System.string* get_ValidateDisabledTimeText();
public: __property void set_ValidateDisabledTimeText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the DisabledTime error alert.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
public:
property System.String^ ValidateDisabledTimeText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is The specified start and end time is within the range of disabled time. Please specify the correct start and end time..

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


ViewOnMyCalendarText Property

[image]
Intersoft WebScheduler Documentation
ViewOnMyCalendarText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : ViewOnMyCalendarText Property

Glossary Item Box

Specifies the text of viewOnMyCalendarText in Agenda view. Specifies the text of viewOnMyCalendarText in Agenda view.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of viewOnMyCalendarText in Agenda view.")>
Public Property ViewOnMyCalendarText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.ViewOnMyCalendarText = value

value = instance.ViewOnMyCalendarText
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of viewOnMyCalendarText in Agenda view.")]
public System.string ViewOnMyCalendarText {get; set;}
Delphi
public read-write property ViewOnMyCalendarText: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of viewOnMyCalendarText in Agenda view.")
public function get,set ViewOnMyCalendarText : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of viewOnMyCalendarText in Agenda view.")]
public: __property System.string* get_ViewOnMyCalendarText();
public: __property void set_ViewOnMyCalendarText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of viewOnMyCalendarText in Agenda view.")]
public:
property System.String^ ViewOnMyCalendarText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is View on my calendar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


WeekTabView Property

[image]
Intersoft WebScheduler Documentation
WeekTabView Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : WeekTabView Property

Glossary Item Box

Specifies the tooltip text of week view's tab. Specifies the tooltip text of week view's tab.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of week view's tab.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
Public Property WeekTabView As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.WeekTabView = value

value = instance.WeekTabView
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of week view's tab.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
public System.string WeekTabView {get; set;}
Delphi
public read-write property WeekTabView: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of week view's tab.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
public function get,set WeekTabView : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of week view's tab.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
public: __property System.string* get_WeekTabView();
public: __property void set_WeekTabView(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of week view's tab.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
public:
property System.String^ WeekTabView {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Week view.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


WeekText Property

[image]
Intersoft WebScheduler Documentation
WeekText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : WeekText Property

Glossary Item Box

Specifies the text of Week's tab in WebScheduler header. Specifies the text of Week's tab in WebScheduler header.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Week's tab in WebScheduler header.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property WeekText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.WeekText = value

value = instance.WeekText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Week's tab in WebScheduler header.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string WeekText {get; set;}
Delphi
public read-write property WeekText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Week's tab in WebScheduler header.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set WeekText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Week's tab in WebScheduler header.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_WeekText();
public: __property void set_WeekText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Week's tab in WebScheduler header.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ WeekText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Week.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


WeekViewDateHeaderText Property

[image]
Intersoft WebScheduler Documentation
WeekViewDateHeaderText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : WeekViewDateHeaderText Property

Glossary Item Box

Specifies the text of date header in Week's tooltip. Specifies the text of date header of week view's tab.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property WeekViewDateHeaderText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.WeekViewDateHeaderText = value

value = instance.WeekViewDateHeaderText
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string WeekViewDateHeaderText {get; set;}
Delphi
public read-write property WeekViewDateHeaderText: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set WeekViewDateHeaderText : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_WeekViewDateHeaderText();
public: __property void set_WeekViewDateHeaderText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ WeekViewDateHeaderText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Goto [day].

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


YearDayOfWeekText Property

[image]
Intersoft WebScheduler Documentation
YearDayOfWeekText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : YearDayOfWeekText Property

Glossary Item Box

Specifies the text of day header tooltip in Year and Quarter view. Specifies the text of day header tooltip in Year and Quarter view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of day header tooltip in Year and Quarter view.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property YearDayOfWeekText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.YearDayOfWeekText = value

value = instance.YearDayOfWeekText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of day header tooltip in Year and Quarter view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string YearDayOfWeekText {get; set;}
Delphi
public read-write property YearDayOfWeekText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of day header tooltip in Year and Quarter view.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set YearDayOfWeekText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of day header tooltip in Year and Quarter view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_YearDayOfWeekText();
public: __property void set_YearDayOfWeekText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of day header tooltip in Year and Quarter view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ YearDayOfWeekText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Goto [day].

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


YearMonthRowHeaderMonthViewText Property

[image]
Intersoft WebScheduler Documentation
YearMonthRowHeaderMonthViewText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : YearMonthRowHeaderMonthViewText Property

Glossary Item Box

Specifies the text of row header tooltip in Month view. Specifies the text of row header tooltip in Month view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text Settings")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of row header tooltip in Month view.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property YearMonthRowHeaderMonthViewText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.YearMonthRowHeaderMonthViewText = value

value = instance.YearMonthRowHeaderMonthViewText
C#
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of row header tooltip in Month view.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string YearMonthRowHeaderMonthViewText {get; set;}
Delphi
public read-write property YearMonthRowHeaderMonthViewText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text Settings")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of row header tooltip in Month view.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set YearMonthRowHeaderMonthViewText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of row header tooltip in Month view.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_YearMonthRowHeaderMonthViewText();
public: __property void set_YearMonthRowHeaderMonthViewText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of row header tooltip in Month view.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ YearMonthRowHeaderMonthViewText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Goto [month].

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


YearMonthRowHeaderYearQuarterViewText Property

[image]
Intersoft WebScheduler Documentation
YearMonthRowHeaderYearQuarterViewText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : YearMonthRowHeaderYearQuarterViewText Property

Glossary Item Box

Specifies the text of row header tooltip in Year and Quarter view. Specifies the text of row header tooltip in Year and Quarter view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text Settings")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of row header tooltip in Year and Quarter view.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property YearMonthRowHeaderYearQuarterViewText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.YearMonthRowHeaderYearQuarterViewText = value

value = instance.YearMonthRowHeaderYearQuarterViewText
C#
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of row header tooltip in Year and Quarter view.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string YearMonthRowHeaderYearQuarterViewText {get; set;}
Delphi
public read-write property YearMonthRowHeaderYearQuarterViewText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text Settings")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of row header tooltip in Year and Quarter view.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set YearMonthRowHeaderYearQuarterViewText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of row header tooltip in Year and Quarter view.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_YearMonthRowHeaderYearQuarterViewText();
public: __property void set_YearMonthRowHeaderYearQuarterViewText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of row header tooltip in Year and Quarter view.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ YearMonthRowHeaderYearQuarterViewText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Goto [month].

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


YearTabView Property

[image]
Intersoft WebScheduler Documentation
YearTabView Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : YearTabView Property

Glossary Item Box

Specifies the tooltip text of year view's tab. Specifies the tooltip text of year view's tab.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of year view's tab.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Text Settings")>
Public Property YearTabView As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.YearTabView = value

value = instance.YearTabView
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of year view's tab.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
public System.string YearTabView {get; set;}
Delphi
public read-write property YearTabView: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of year view's tab.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
public function get,set YearTabView : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of year view's tab.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
public: __property System.string* get_YearTabView();
public: __property void set_YearTabView(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of year view's tab.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text Settings")]
public:
property System.String^ YearTabView {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Year view.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


YearText Property

[image]
Intersoft WebScheduler Documentation
YearText Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : YearText Property

Glossary Item Box

Specifies the text of Year's tab in WebScheduler header. Specifies the text of Year's tab in WebScheduler header.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text Settings")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Year's tab in WebScheduler header.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property YearText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

instance.YearText = value

value = instance.YearText
C#
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Year's tab in WebScheduler header.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string YearText {get; set;}
Delphi
public read-write property YearText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text Settings")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Year's tab in WebScheduler header.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set YearText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Year's tab in WebScheduler header.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_YearText();
public: __property void set_YearText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Year's tab in WebScheduler header.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ YearText {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Year.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


WebSchedulerTimeBasedEventStyle Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerTimeBasedEventStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerTimeBasedEventStyle Class

Glossary Item Box

A collection of interactive styles used for TimeBasedEvent.

Object Model

WebSchedulerTimeBasedEventStyle Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerTimeBasedEventStyle
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimeBasedEventStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerTimeBasedEventStyle : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSchedulerTimeBasedEventStyle = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerTimeBasedEventStyle extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerTimeBasedEventStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerTimeBasedEventStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebScheduler.WebSchedulerTimeBasedEventStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimeBasedEventStyle Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerTimeBasedEventStyle Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerTimeBasedEventStyle Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerTimeBasedEventStyle Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerTimeBasedEventStyle.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerTimeBasedEventStyle Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | ContentStyle | Contains interactive style for TimeBasedEvent's Content. Contains interactive style for TimeBasedEvent's Content.
Public Property | HeaderStyle | Contains interactive style for TimeBasedEvent's Header. Contains interactive style for TimeBasedEvent's Header.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerTimeBasedEventStyle Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerTimeBasedEventStyle Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerTimeBasedEventStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimeBasedEventStyle Class : WebSchedulerTimeBasedEventStyle Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerTimeBasedEventStyle Constructor() |
WebSchedulerTimeBasedEventStyle Constructor(WebScheduler) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimeBasedEventStyle Class
WebSchedulerTimeBasedEventStyle Members


WebSchedulerTimeBasedEventStyle Constructor()

[image]
Intersoft WebScheduler Documentation
WebSchedulerTimeBasedEventStyle Constructor()
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimeBasedEventStyle Class > WebSchedulerTimeBasedEventStyle Constructor : WebSchedulerTimeBasedEventStyle Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerTimeBasedEventStyle()
C#
public WebSchedulerTimeBasedEventStyle()
Delphi
public WebSchedulerTimeBasedEventStyle();
JScript
public function WebSchedulerTimeBasedEventStyle();
Managed Extensions for C++
public: WebSchedulerTimeBasedEventStyle();
C++/CLI
public:
WebSchedulerTimeBasedEventStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimeBasedEventStyle Class
WebSchedulerTimeBasedEventStyle Members
Overload List


WebSchedulerTimeBasedEventStyle Constructor(WebScheduler)

[image]
Intersoft WebScheduler Documentation
WebSchedulerTimeBasedEventStyle Constructor(WebScheduler)
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimeBasedEventStyle Class > WebSchedulerTimeBasedEventStyle Constructor : WebSchedulerTimeBasedEventStyle Constructor(WebScheduler)

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal control As WebScheduler _
)
Visual Basic (Usage) Copy Code
Dim control As WebScheduler

Dim instance As New WebSchedulerTimeBasedEventStyle(control)
C#
public WebSchedulerTimeBasedEventStyle(
   WebScheduler control
)
Delphi
public WebSchedulerTimeBasedEventStyle(
    control: WebScheduler
);
JScript
public function WebSchedulerTimeBasedEventStyle(
   control : WebScheduler
);
Managed Extensions for C++
public: WebSchedulerTimeBasedEventStyle(
   WebScheduler* control
)
C++/CLI
public:
WebSchedulerTimeBasedEventStyle(
   WebScheduler^ control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimeBasedEventStyle Class
WebSchedulerTimeBasedEventStyle Members
Overload List


WebSchedulerTimeBasedEventStyle Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerTimeBasedEventStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerTimeBasedEventStyle Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerTimeBasedEventStyle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerTimeBasedEventStyle Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimeBasedEventStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimeBasedEventStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimeBasedEventStyle Class
WebSchedulerTimeBasedEventStyle Members


WebSchedulerTimeBasedEventStyle Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerTimeBasedEventStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerTimeBasedEventStyle Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerTimeBasedEventStyle members.

Public Properties

 | Name | Description
Public Property | ContentStyle | Contains interactive style for TimeBasedEvent's Content. Contains interactive style for TimeBasedEvent's Content.
Public Property | HeaderStyle | Contains interactive style for TimeBasedEvent's Header. Contains interactive style for TimeBasedEvent's Header.
Top

See Also

Reference

WebSchedulerTimeBasedEventStyle Class
ISNet.WebUI.WebScheduler Namespace


ContentStyle Property

[image]
Intersoft WebScheduler Documentation
ContentStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimeBasedEventStyle Class : ContentStyle Property

Glossary Item Box

Contains interactive style for TimeBasedEvent's Content. Contains interactive style for TimeBasedEvent's Content.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Time Based Event Style")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for TimeBasedEvent's Content.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
Public Property ContentStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimeBasedEventStyle
Dim value As ISNet.WebUI.WebStyle

instance.ContentStyle = value

value = instance.ContentStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Time Based Event Style")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for TimeBasedEvent's Content.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ISNet.WebUI.WebStyle ContentStyle {get; set;}
Delphi
public read-write property ContentStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Time Based Event Style")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for TimeBasedEvent's Content.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
public function get,set ContentStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Time Based Event Style")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for TimeBasedEvent's Content.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public: __property ISNet.WebUI.WebStyle* get_ContentStyle();
public: __property void set_ContentStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Time Based Event Style")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for TimeBasedEvent's Content.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public:
property ISNet.WebUI.WebStyle^ ContentStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimeBasedEventStyle Class
WebSchedulerTimeBasedEventStyle Members


HeaderStyle Property

[image]
Intersoft WebScheduler Documentation
HeaderStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimeBasedEventStyle Class : HeaderStyle Property

Glossary Item Box

Contains interactive style for TimeBasedEvent's Header. Contains interactive style for TimeBasedEvent's Header.

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for TimeBasedEvent's Header.")>
<System.ComponentModel.CategoryAttribute("Time Based Event Style")>
Public Property HeaderStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimeBasedEventStyle
Dim value As ISNet.WebUI.WebStyle

instance.HeaderStyle = value

value = instance.HeaderStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for TimeBasedEvent's Header.")]
[System.ComponentModel.CategoryAttribute("Time Based Event Style")]
public ISNet.WebUI.WebStyle HeaderStyle {get; set;}
Delphi
public read-write property HeaderStyle: ISNet.WebUI.WebStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for TimeBasedEvent's Header.")
System.ComponentModel.CategoryAttribute("Time Based Event Style")
public function get,set HeaderStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for TimeBasedEvent's Header.")]
[System.ComponentModel.CategoryAttribute("Time Based Event Style")]
public: __property ISNet.WebUI.WebStyle* get_HeaderStyle();
public: __property void set_HeaderStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for TimeBasedEvent's Header.")]
[System.ComponentModel.CategoryAttribute("Time Based Event Style")]
public:
property ISNet.WebUI.WebStyle^ HeaderStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimeBasedEventStyle Class
WebSchedulerTimeBasedEventStyle Members


WebSchedulerTimelineView Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerTimelineView Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerTimelineView Class

Glossary Item Box

A collection of settings used for Timeline in WebScheduler.

Object Model

WebSchedulerTimelineView Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerTimelineView
   Inherits WebSchedulerBaseView
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerTimelineView : WebSchedulerBaseView, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSchedulerTimelineView = class(WebSchedulerBaseView, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerTimelineView extends WebSchedulerBaseView implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerTimelineView : public WebSchedulerBaseView, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerTimelineView : public WebSchedulerBaseView, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebScheduler.WebSchedulerTimelineView

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerTimelineView Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerTimelineView Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerTimelineView Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerTimelineView.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerTimelineView Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | ClientPagingMode | Specifies Timeline client paging mode.
Public Property | ContentCellWidth | Specifies width of ContentCell (pixel). Specifies width of ContentCell (pixel).
Public Property | DateFormatString | Overridden. Specifies the DateFormatString of Timeline view. Specifies the DateFormatString of Timeline view.
Public Property | DateHeaderMode | Specifies Timeline DateHeader mode. (Applicable only for Quarter, Month and Week TimelineView). Specifies the mode used in date header.
Public Property | Day15MinutesExportColumnLength | Specifies Day15Minutes view export column length per row.
Public Property | DayHourlyExportColumnLength | Specifies DayHourly view export column length per row.
Public Property | DisplayDisabledTimeTooltip | ndicate whether DisabledTime's range of date time will be displayed when mouse over to the cell. Indicates whether DisabledTime's range of date time will be displayed when mouse over to the cell.
Public Property | EnableClientPaging | Indicate whether enable client paging is enabled in Timeline view.
Public Property | Enabled | Overridden. Indicate whether Timeline view should be enabled or not in WebScheduler. Indicates whether Timeline view should be enabled or not in WebScheduler.
Public Property | EnableServerPaging | Indicate whether enable server paging is enabled in Timeline view. To enable server side paging, client paging ViewPort or Both mode should be enabled.
Public Property | EndTime | Specifies start time of Timeline view. Specifies end time of Timeline view.
Public Property | EventPageSize | Specifies the event page size of client paging. Minimum value is 1.
Public Property | KeepHeaderVisible | Indicate whether timeline date header should be visible all the time in Timeline Quarter and Month view.
Public Property | MinimumEventHeight | Specifies minimum event height in Timeline view. Specifies minimum event height in Timeline view.
Public Property | MonthExportColumnLength | Specifies Month view export column length per row.
Public Property | NumberOfDays | Specifies the NumberOfDays of Timeline view. Specifies the NumberofDays of Timeline view.
Public Property | QuarterExportColumnLength | Specifies Quarter view export column length per row.
Public Property | ResourceCellWidth | Specifies width of ResourceCell (pixel). Specifies width of ResourceCell (pixel).
Public Property | ResourceRowHeight | Specifies height of Resource row in Timeline view. Specifies height of Resource row in Timeline view.
Public Property | ResourceRowString | Specifies the ResourceRowString of Timeline view.
Public Property | StartTime | Specifies start time of Timeline view. Specifies start time of Timeline view.
Public Property | TimelineWeekMode | Specifies TimelineWeekMode of Timeline view.
Public Property | TotalEventInCell | Specifies total event in a Timeline cell. Minimum value is 1. Specifies total event in a Timeline cell.
Public Property | WeekExportColumnLength | Specifies Week view export column length per row.
Public Property | ZoomInLevel | Specifies Timeline zoom in level.
Public Property | ZoomOutLevel | Specifies Timeline zoom out level.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerTimelineView Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerTimelineView Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerTimelineView Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : WebSchedulerTimelineView Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerTimelineView Constructor() |
WebSchedulerTimelineView Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


WebSchedulerTimelineView Constructor()

[image]
Intersoft WebScheduler Documentation
WebSchedulerTimelineView Constructor()
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class > WebSchedulerTimelineView Constructor : WebSchedulerTimelineView Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerTimelineView()
C#
public WebSchedulerTimelineView()
Delphi
public WebSchedulerTimelineView();
JScript
public function WebSchedulerTimelineView();
Managed Extensions for C++
public: WebSchedulerTimelineView();
C++/CLI
public:
WebSchedulerTimelineView();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members
Overload List


WebSchedulerTimelineView Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebScheduler Documentation
WebSchedulerTimelineView Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class > WebSchedulerTimelineView Constructor : WebSchedulerTimelineView Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebSchedulerTimelineView(info, context)
C#
public WebSchedulerTimelineView(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public WebSchedulerTimelineView(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function WebSchedulerTimelineView(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: WebSchedulerTimelineView(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
WebSchedulerTimelineView(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members
Overload List


WebSchedulerTimelineView Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerTimelineView Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerTimelineView Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerTimelineView members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerTimelineView Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


WebSchedulerTimelineView Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerTimelineView Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerTimelineView Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerTimelineView members.

Public Properties

 | Name | Description
Public Property | ClientPagingMode | Specifies Timeline client paging mode.
Public Property | ContentCellWidth | Specifies width of ContentCell (pixel). Specifies width of ContentCell (pixel).
Public Property | DateFormatString | Overridden. Specifies the DateFormatString of Timeline view. Specifies the DateFormatString of Timeline view.
Public Property | DateHeaderMode | Specifies Timeline DateHeader mode. (Applicable only for Quarter, Month and Week TimelineView). Specifies the mode used in date header.
Public Property | Day15MinutesExportColumnLength | Specifies Day15Minutes view export column length per row.
Public Property | DayHourlyExportColumnLength | Specifies DayHourly view export column length per row.
Public Property | DisplayDisabledTimeTooltip | ndicate whether DisabledTime's range of date time will be displayed when mouse over to the cell. Indicates whether DisabledTime's range of date time will be displayed when mouse over to the cell.
Public Property | EnableClientPaging | Indicate whether enable client paging is enabled in Timeline view.
Public Property | Enabled | Overridden. Indicate whether Timeline view should be enabled or not in WebScheduler. Indicates whether Timeline view should be enabled or not in WebScheduler.
Public Property | EnableServerPaging | Indicate whether enable server paging is enabled in Timeline view. To enable server side paging, client paging ViewPort or Both mode should be enabled.
Public Property | EndTime | Specifies start time of Timeline view. Specifies end time of Timeline view.
Public Property | EventPageSize | Specifies the event page size of client paging. Minimum value is 1.
Public Property | KeepHeaderVisible | Indicate whether timeline date header should be visible all the time in Timeline Quarter and Month view.
Public Property | MinimumEventHeight | Specifies minimum event height in Timeline view. Specifies minimum event height in Timeline view.
Public Property | MonthExportColumnLength | Specifies Month view export column length per row.
Public Property | NumberOfDays | Specifies the NumberOfDays of Timeline view. Specifies the NumberofDays of Timeline view.
Public Property | QuarterExportColumnLength | Specifies Quarter view export column length per row.
Public Property | ResourceCellWidth | Specifies width of ResourceCell (pixel). Specifies width of ResourceCell (pixel).
Public Property | ResourceRowHeight | Specifies height of Resource row in Timeline view. Specifies height of Resource row in Timeline view.
Public Property | ResourceRowString | Specifies the ResourceRowString of Timeline view.
Public Property | StartTime | Specifies start time of Timeline view. Specifies start time of Timeline view.
Public Property | TimelineWeekMode | Specifies TimelineWeekMode of Timeline view.
Public Property | TotalEventInCell | Specifies total event in a Timeline cell. Minimum value is 1. Specifies total event in a Timeline cell.
Public Property | WeekExportColumnLength | Specifies Week view export column length per row.
Public Property | ZoomInLevel | Specifies Timeline zoom in level.
Public Property | ZoomOutLevel | Specifies Timeline zoom out level.
Top

See Also

Reference

WebSchedulerTimelineView Class
ISNet.WebUI.WebScheduler Namespace


ClientPagingMode Property

[image]
Intersoft WebScheduler Documentation
ClientPagingMode Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : ClientPagingMode Property

Glossary Item Box

Specifies Timeline client paging mode.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies Timeline client paging mode.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Timeline View")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ClientPagingMode As WebSchedulerTimelineClientPagingMode
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim value As WebSchedulerTimelineClientPagingMode

instance.ClientPagingMode = value

value = instance.ClientPagingMode
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies Timeline client paging mode.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public WebSchedulerTimelineClientPagingMode ClientPagingMode {get; set;}
Delphi
public read-write property ClientPagingMode: WebSchedulerTimelineClientPagingMode;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies Timeline client paging mode.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Timeline View")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set ClientPagingMode : WebSchedulerTimelineClientPagingMode
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies Timeline client paging mode.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebSchedulerTimelineClientPagingMode get_ClientPagingMode();
public: __property void set_ClientPagingMode(
   WebSchedulerTimelineClientPagingMode value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies Timeline client paging mode.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebSchedulerTimelineClientPagingMode ClientPagingMode {
   WebSchedulerTimelineClientPagingMode get();
   void set (    WebSchedulerTimelineClientPagingMode value);
}

Property Value

The default value is Event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


ContentCellWidth Property

[image]
Intersoft WebScheduler Documentation
ContentCellWidth Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : ContentCellWidth Property

Glossary Item Box

Specifies width of ContentCell (pixel). Specifies width of ContentCell (pixel).

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Timeline View")>
<System.ComponentModel.DescriptionAttribute("Specifies width of ContentCell (pixel, minimum value is 12).")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ContentCellWidth As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim value As System.Integer

instance.ContentCellWidth = value

value = instance.ContentCellWidth
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.DescriptionAttribute("Specifies width of ContentCell (pixel, minimum value is 12).")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.int ContentCellWidth {get; set;}
Delphi
public read-write property ContentCellWidth: System.Integer;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Timeline View")
System.ComponentModel.DescriptionAttribute("Specifies width of ContentCell (pixel, minimum value is 12).")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ContentCellWidth : System.int
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.DescriptionAttribute("Specifies width of ContentCell (pixel, minimum value is 12).")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.int get_ContentCellWidth();
public: __property void set_ContentCellWidth(
   System.int value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.DescriptionAttribute("Specifies width of ContentCell (pixel, minimum value is 12).")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.int ContentCellWidth {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 100.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


DateFormatString Property

[image]
Intersoft WebScheduler Documentation
DateFormatString Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : DateFormatString Property

Glossary Item Box

Specifies the DateFormatString of Timeline view. Specifies the DateFormatString of Timeline view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the DateFormatString of Timeline view.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Timeline View")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Overrides Property DateFormatString As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim value As System.String

instance.DateFormatString = value

value = instance.DateFormatString
C#
[System.ComponentModel.DescriptionAttribute("Specifies the DateFormatString of Timeline view.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[ISNet.Serialization.XmlSerializableAttribute()]
public override System.string DateFormatString {get; set;}
Delphi
public read-write property DateFormatString: System.String; override;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the DateFormatString of Timeline view.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Timeline View")
ISNet.Serialization.XmlSerializableAttribute()
public override function get,set DateFormatString : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the DateFormatString of Timeline view.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_DateFormatString() override;
public: __property void set_DateFormatString(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the DateFormatString of Timeline view.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ DateFormatString {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Property Value

The default value is D.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


DateHeaderMode Property

[image]
Intersoft WebScheduler Documentation
DateHeaderMode Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : DateHeaderMode Property

Glossary Item Box

Specifies Timeline DateHeader mode. (Applicable only for Quarter, Month and Week TimelineView). Specifies the mode used in date header.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies Timeline DateHeader mode. (Applicable only for Quarter, Month and Week TimelineView).")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Timeline View")>
Public Property DateHeaderMode As WebSchedulerTimelineDateHeaderMode
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim value As WebSchedulerTimelineDateHeaderMode

instance.DateHeaderMode = value

value = instance.DateHeaderMode
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies Timeline DateHeader mode. (Applicable only for Quarter, Month and Week TimelineView).")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Timeline View")]
public WebSchedulerTimelineDateHeaderMode DateHeaderMode {get; set;}
Delphi
public read-write property DateHeaderMode: WebSchedulerTimelineDateHeaderMode;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies Timeline DateHeader mode. (Applicable only for Quarter, Month and Week TimelineView).")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Timeline View")
public function get,set DateHeaderMode : WebSchedulerTimelineDateHeaderMode
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies Timeline DateHeader mode. (Applicable only for Quarter, Month and Week TimelineView).")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Timeline View")]
public: __property WebSchedulerTimelineDateHeaderMode get_DateHeaderMode();
public: __property void set_DateHeaderMode(
   WebSchedulerTimelineDateHeaderMode value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies Timeline DateHeader mode. (Applicable only for Quarter, Month and Week TimelineView).")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Timeline View")]
public:
property WebSchedulerTimelineDateHeaderMode DateHeaderMode {
   WebSchedulerTimelineDateHeaderMode get();
   void set (    WebSchedulerTimelineDateHeaderMode value);
}

Property Value

The default value is DateNumber.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


Day15MinutesExportColumnLength Property

[image]
Intersoft WebScheduler Documentation
Day15MinutesExportColumnLength Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : Day15MinutesExportColumnLength Property

Glossary Item Box

Specifies Day15Minutes view export column length per row.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies Day15Minutes view export column length per row. The value should be in quadruple (4, 8, 16, 32, 40)")>
<System.ComponentModel.CategoryAttribute("Timeline View")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Day15MinutesExportColumnLength As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim value As System.Integer

instance.Day15MinutesExportColumnLength = value

value = instance.Day15MinutesExportColumnLength
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies Day15Minutes view export column length per row. The value should be in quadruple (4, 8, 16, 32, 40)")]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.int Day15MinutesExportColumnLength {get; set;}
Delphi
public read-write property Day15MinutesExportColumnLength: System.Integer;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies Day15Minutes view export column length per row. The value should be in quadruple (4, 8, 16, 32, 40)")
System.ComponentModel.CategoryAttribute("Timeline View")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Day15MinutesExportColumnLength : System.int
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies Day15Minutes view export column length per row. The value should be in quadruple (4, 8, 16, 32, 40)")]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_Day15MinutesExportColumnLength();
public: __property void set_Day15MinutesExportColumnLength(
   System.int value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies Day15Minutes view export column length per row. The value should be in quadruple (4, 8, 16, 32, 40)")]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int Day15MinutesExportColumnLength {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 4.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


DayHourlyExportColumnLength Property

[image]
Intersoft WebScheduler Documentation
DayHourlyExportColumnLength Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : DayHourlyExportColumnLength Property

Glossary Item Box

Specifies DayHourly view export column length per row.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies DayHourly view export column length per row.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Timeline View")>
Public Property DayHourlyExportColumnLength As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim value As System.Integer

instance.DayHourlyExportColumnLength = value

value = instance.DayHourlyExportColumnLength
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies DayHourly view export column length per row.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
public System.int DayHourlyExportColumnLength {get; set;}
Delphi
public read-write property DayHourlyExportColumnLength: System.Integer;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies DayHourly view export column length per row.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Timeline View")
public function get,set DayHourlyExportColumnLength : System.int
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies DayHourly view export column length per row.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
public: __property System.int get_DayHourlyExportColumnLength();
public: __property void set_DayHourlyExportColumnLength(
   System.int value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies DayHourly view export column length per row.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
public:
property System.int DayHourlyExportColumnLength {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 10.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


DisplayDisabledTimeTooltip Property

[image]
Intersoft WebScheduler Documentation
DisplayDisabledTimeTooltip Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : DisplayDisabledTimeTooltip Property

Glossary Item Box

ndicate whether DisabledTime's range of date time will be displayed when mouse over to the cell. Indicates whether DisabledTime's range of date time will be displayed when mouse over to the cell.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Indicate whether DisabledTime's range of date time will be displayed when mouse over to the cell.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Timeline View")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property DisplayDisabledTimeTooltip As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim value As System.Boolean

instance.DisplayDisabledTimeTooltip = value

value = instance.DisplayDisabledTimeTooltip
C#
[System.ComponentModel.DescriptionAttribute("Indicate whether DisabledTime's range of date time will be displayed when mouse over to the cell.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool DisplayDisabledTimeTooltip {get; set;}
Delphi
public read-write property DisplayDisabledTimeTooltip: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Indicate whether DisabledTime's range of date time will be displayed when mouse over to the cell.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Timeline View")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set DisplayDisabledTimeTooltip : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Indicate whether DisabledTime's range of date time will be displayed when mouse over to the cell.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_DisplayDisabledTimeTooltip();
public: __property void set_DisplayDisabledTimeTooltip(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Indicate whether DisabledTime's range of date time will be displayed when mouse over to the cell.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool DisplayDisabledTimeTooltip {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


EnableClientPaging Property

[image]
Intersoft WebScheduler Documentation
EnableClientPaging Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : EnableClientPaging Property

Glossary Item Box

Indicate whether enable client paging is enabled in Timeline view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Timeline View")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Indicate whether enable client paging is enabled in Timeline view.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property EnableClientPaging As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim value As System.Boolean

instance.EnableClientPaging = value

value = instance.EnableClientPaging
C#
[System.ComponentModel.CategoryAttribute("Timeline View")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Indicate whether enable client paging is enabled in Timeline view.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool EnableClientPaging {get; set;}
Delphi
public read-write property EnableClientPaging: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Timeline View")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Indicate whether enable client paging is enabled in Timeline view.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set EnableClientPaging : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Timeline View")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Indicate whether enable client paging is enabled in Timeline view.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_EnableClientPaging();
public: __property void set_EnableClientPaging(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Timeline View")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Indicate whether enable client paging is enabled in Timeline view.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool EnableClientPaging {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


Enabled Property

[image]
Intersoft WebScheduler Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : Enabled Property

Glossary Item Box

Indicate whether Timeline view should be enabled or not in WebScheduler. Indicates whether Timeline view should be enabled or not in WebScheduler.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Timeline View")>
<System.ComponentModel.DescriptionAttribute("Indicate whether Timeline view should be enabled or not in WebScheduler.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Overrides Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.DescriptionAttribute("Indicate whether Timeline view should be enabled or not in WebScheduler.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public override System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean; override;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Timeline View")
System.ComponentModel.DescriptionAttribute("Indicate whether Timeline view should be enabled or not in WebScheduler.")
ISNet.Serialization.XmlSerializableAttribute()
public override function get,set Enabled : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.DescriptionAttribute("Indicate whether Timeline view should be enabled or not in WebScheduler.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_Enabled() override;
public: __property void set_Enabled(
   System.bool value
) override;
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.DescriptionAttribute("Indicate whether Timeline view should be enabled or not in WebScheduler.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool Enabled {
   System.bool get() override;
   void set (    System.bool value) override;
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


EnableServerPaging Property

[image]
Intersoft WebScheduler Documentation
EnableServerPaging Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : EnableServerPaging Property

Glossary Item Box

Indicate whether enable server paging is enabled in Timeline view. To enable server side paging, client paging ViewPort or Both mode should be enabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Timeline View")>
<System.ComponentModel.DescriptionAttribute("Indicate whether enable server paging is enabled in Timeline view. To enable server side paging, client paging ViewPort or Both mode should be enabled.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property EnableServerPaging As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim value As System.Boolean

instance.EnableServerPaging = value

value = instance.EnableServerPaging
C#
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.DescriptionAttribute("Indicate whether enable server paging is enabled in Timeline view. To enable server side paging, client paging ViewPort or Both mode should be enabled.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool EnableServerPaging {get; set;}
Delphi
public read-write property EnableServerPaging: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Timeline View")
System.ComponentModel.DescriptionAttribute("Indicate whether enable server paging is enabled in Timeline view. To enable server side paging, client paging ViewPort or Both mode should be enabled.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set EnableServerPaging : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.DescriptionAttribute("Indicate whether enable server paging is enabled in Timeline view. To enable server side paging, client paging ViewPort or Both mode should be enabled.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_EnableServerPaging();
public: __property void set_EnableServerPaging(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.DescriptionAttribute("Indicate whether enable server paging is enabled in Timeline view. To enable server side paging, client paging ViewPort or Both mode should be enabled.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool EnableServerPaging {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


EndTime Property

[image]
Intersoft WebScheduler Documentation
EndTime Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : EndTime Property

Glossary Item Box

Specifies start time of Timeline view. Specifies end time of Timeline view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Timeline View")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies end time of Timeline view.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property EndTime As WebSchedulerTimeline
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim value As WebSchedulerTimeline

instance.EndTime = value

value = instance.EndTime
C#
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies end time of Timeline view.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public WebSchedulerTimeline EndTime {get; set;}
Delphi
public read-write property EndTime: WebSchedulerTimeline;
JScript
System.ComponentModel.CategoryAttribute("Timeline View")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies end time of Timeline view.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set EndTime : WebSchedulerTimeline
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies end time of Timeline view.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property WebSchedulerTimeline get_EndTime();
public: __property void set_EndTime(
   WebSchedulerTimeline value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies end time of Timeline view.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property WebSchedulerTimeline EndTime {
   WebSchedulerTimeline get();
   void set (    WebSchedulerTimeline value);
}

Property Value

The default value is t0800.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


EventPageSize Property

[image]
Intersoft WebScheduler Documentation
EventPageSize Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : EventPageSize Property

Glossary Item Box

Specifies the event page size of client paging. Minimum value is 1.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the event page size of client paging. Minimum value is 1.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Timeline View")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property EventPageSize As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim value As System.Integer

instance.EventPageSize = value

value = instance.EventPageSize
C#
[System.ComponentModel.DescriptionAttribute("Specifies the event page size of client paging. Minimum value is 1.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.int EventPageSize {get; set;}
Delphi
public read-write property EventPageSize: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the event page size of client paging. Minimum value is 1.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Timeline View")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set EventPageSize : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the event page size of client paging. Minimum value is 1.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_EventPageSize();
public: __property void set_EventPageSize(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the event page size of client paging. Minimum value is 1.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int EventPageSize {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 3.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


KeepHeaderVisible Property

[image]
Intersoft WebScheduler Documentation
KeepHeaderVisible Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : KeepHeaderVisible Property

Glossary Item Box

Indicate whether timeline date header should be visible all the time in Timeline Quarter and Month view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Timeline View")>
<System.ComponentModel.DescriptionAttribute("Indicate whether timeline date header should be visible all the time in Timeline Quarter and Month view.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property KeepHeaderVisible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim value As System.Boolean

instance.KeepHeaderVisible = value

value = instance.KeepHeaderVisible
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.DescriptionAttribute("Indicate whether timeline date header should be visible all the time in Timeline Quarter and Month view.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool KeepHeaderVisible {get; set;}
Delphi
public read-write property KeepHeaderVisible: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Timeline View")
System.ComponentModel.DescriptionAttribute("Indicate whether timeline date header should be visible all the time in Timeline Quarter and Month view.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set KeepHeaderVisible : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.DescriptionAttribute("Indicate whether timeline date header should be visible all the time in Timeline Quarter and Month view.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_KeepHeaderVisible();
public: __property void set_KeepHeaderVisible(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.DescriptionAttribute("Indicate whether timeline date header should be visible all the time in Timeline Quarter and Month view.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool KeepHeaderVisible {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


MinimumEventHeight Property

[image]
Intersoft WebScheduler Documentation
MinimumEventHeight Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : MinimumEventHeight Property

Glossary Item Box

Specifies minimum event height in Timeline view. Specifies minimum event height in Timeline view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies minimum event height in Timeline view.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Timeline View")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property MinimumEventHeight As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim value As System.Integer

instance.MinimumEventHeight = value

value = instance.MinimumEventHeight
C#
[System.ComponentModel.DescriptionAttribute("Specifies minimum event height in Timeline view.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.int MinimumEventHeight {get; set;}
Delphi
public read-write property MinimumEventHeight: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Specifies minimum event height in Timeline view.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Timeline View")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set MinimumEventHeight : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies minimum event height in Timeline view.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.int get_MinimumEventHeight();
public: __property void set_MinimumEventHeight(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies minimum event height in Timeline view.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.int MinimumEventHeight {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 24.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


MonthExportColumnLength Property

[image]
Intersoft WebScheduler Documentation
MonthExportColumnLength Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : MonthExportColumnLength Property

Glossary Item Box

Specifies Month view export column length per row.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies Month view export column length per row.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Timeline View")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property MonthExportColumnLength As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim value As System.Integer

instance.MonthExportColumnLength = value

value = instance.MonthExportColumnLength
C#
[System.ComponentModel.DescriptionAttribute("Specifies Month view export column length per row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.int MonthExportColumnLength {get; set;}
Delphi
public read-write property MonthExportColumnLength: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Specifies Month view export column length per row.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Timeline View")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set MonthExportColumnLength : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies Month view export column length per row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_MonthExportColumnLength();
public: __property void set_MonthExportColumnLength(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies Month view export column length per row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int MonthExportColumnLength {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 16.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


NumberOfDays Property

[image]
Intersoft WebScheduler Documentation
NumberOfDays Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : NumberOfDays Property

Glossary Item Box

Specifies the NumberOfDays of Timeline view. Specifies the NumberofDays of Timeline view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the NumberOfDays of Timeline view.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Timeline View")>
Public Property NumberOfDays As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim value As System.Integer

instance.NumberOfDays = value

value = instance.NumberOfDays
C#
[System.ComponentModel.DescriptionAttribute("Specifies the NumberOfDays of Timeline view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
public System.int NumberOfDays {get; set;}
Delphi
public read-write property NumberOfDays: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the NumberOfDays of Timeline view.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Timeline View")
public function get,set NumberOfDays : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the NumberOfDays of Timeline view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
public: __property System.int get_NumberOfDays();
public: __property void set_NumberOfDays(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the NumberOfDays of Timeline view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
public:
property System.int NumberOfDays {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


QuarterExportColumnLength Property

[image]
Intersoft WebScheduler Documentation
QuarterExportColumnLength Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : QuarterExportColumnLength Property

Glossary Item Box

Specifies Quarter view export column length per row.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies Quarter view export column length per row.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Timeline View")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property QuarterExportColumnLength As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim value As System.Integer

instance.QuarterExportColumnLength = value

value = instance.QuarterExportColumnLength
C#
[System.ComponentModel.DescriptionAttribute("Specifies Quarter view export column length per row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.int QuarterExportColumnLength {get; set;}
Delphi
public read-write property QuarterExportColumnLength: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Specifies Quarter view export column length per row.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Timeline View")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set QuarterExportColumnLength : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies Quarter view export column length per row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_QuarterExportColumnLength();
public: __property void set_QuarterExportColumnLength(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies Quarter view export column length per row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int QuarterExportColumnLength {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 16.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


ResourceCellWidth Property

[image]
Intersoft WebScheduler Documentation
ResourceCellWidth Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : ResourceCellWidth Property

Glossary Item Box

Specifies width of ResourceCell (pixel). Specifies width of ResourceCell (pixel).

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Timeline View")>
<System.ComponentModel.DescriptionAttribute("Specifies width of ResourceCell (pixel).")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ResourceCellWidth As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim value As System.Integer

instance.ResourceCellWidth = value

value = instance.ResourceCellWidth
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.DescriptionAttribute("Specifies width of ResourceCell (pixel).")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.int ResourceCellWidth {get; set;}
Delphi
public read-write property ResourceCellWidth: System.Integer;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Timeline View")
System.ComponentModel.DescriptionAttribute("Specifies width of ResourceCell (pixel).")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ResourceCellWidth : System.int
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.DescriptionAttribute("Specifies width of ResourceCell (pixel).")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.int get_ResourceCellWidth();
public: __property void set_ResourceCellWidth(
   System.int value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.DescriptionAttribute("Specifies width of ResourceCell (pixel).")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.int ResourceCellWidth {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 100.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


ResourceRowHeight Property

[image]
Intersoft WebScheduler Documentation
ResourceRowHeight Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : ResourceRowHeight Property

Glossary Item Box

Specifies height of Resource row in Timeline view. Specifies height of Resource row in Timeline view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Timeline View")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies height of Resource row in Timeline view.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ResourceRowHeight As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim value As System.Integer

instance.ResourceRowHeight = value

value = instance.ResourceRowHeight
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies height of Resource row in Timeline view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.int ResourceRowHeight {get; set;}
Delphi
public read-write property ResourceRowHeight: System.Integer;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Timeline View")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies height of Resource row in Timeline view.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ResourceRowHeight : System.int
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies height of Resource row in Timeline view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.int get_ResourceRowHeight();
public: __property void set_ResourceRowHeight(
   System.int value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies height of Resource row in Timeline view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.int ResourceRowHeight {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 40.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


ResourceRowString Property

[image]
Intersoft WebScheduler Documentation
ResourceRowString Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : ResourceRowString Property

Glossary Item Box

Specifies the ResourceRowString of Timeline view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the ResourceRowString of Timeline view.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Timeline View")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ResourceRowString As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim value As System.String

instance.ResourceRowString = value

value = instance.ResourceRowString
C#
[System.ComponentModel.DescriptionAttribute("Specifies the ResourceRowString of Timeline view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string ResourceRowString {get; set;}
Delphi
public read-write property ResourceRowString: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the ResourceRowString of Timeline view.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Timeline View")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set ResourceRowString : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the ResourceRowString of Timeline view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_ResourceRowString();
public: __property void set_ResourceRowString(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the ResourceRowString of Timeline view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ ResourceRowString {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is "".

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


StartTime Property

[image]
Intersoft WebScheduler Documentation
StartTime Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : StartTime Property

Glossary Item Box

Specifies start time of Timeline view. Specifies start time of Timeline view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Timeline View")>
<System.ComponentModel.DescriptionAttribute("Specifies start time of Timeline view.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property StartTime As WebSchedulerTimeline
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim value As WebSchedulerTimeline

instance.StartTime = value

value = instance.StartTime
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.DescriptionAttribute("Specifies start time of Timeline view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public WebSchedulerTimeline StartTime {get; set;}
Delphi
public read-write property StartTime: WebSchedulerTimeline;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Timeline View")
System.ComponentModel.DescriptionAttribute("Specifies start time of Timeline view.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set StartTime : WebSchedulerTimeline
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.DescriptionAttribute("Specifies start time of Timeline view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property WebSchedulerTimeline get_StartTime();
public: __property void set_StartTime(
   WebSchedulerTimeline value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.DescriptionAttribute("Specifies start time of Timeline view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property WebSchedulerTimeline StartTime {
   WebSchedulerTimeline get();
   void set (    WebSchedulerTimeline value);
}

Property Value

The default value is t0800.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


TimelineWeekMode Property

[image]
Intersoft WebScheduler Documentation
TimelineWeekMode Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : TimelineWeekMode Property

Glossary Item Box

Specifies TimelineWeekMode of Timeline view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Timeline View")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies TimelineWeekMode of Timeline view.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property TimelineWeekMode As WebSchedulerTimelineWeekMode
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim value As WebSchedulerTimelineWeekMode

instance.TimelineWeekMode = value

value = instance.TimelineWeekMode
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies TimelineWeekMode of Timeline view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public WebSchedulerTimelineWeekMode TimelineWeekMode {get; set;}
Delphi
public read-write property TimelineWeekMode: WebSchedulerTimelineWeekMode;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Timeline View")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies TimelineWeekMode of Timeline view.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set TimelineWeekMode : WebSchedulerTimelineWeekMode
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies TimelineWeekMode of Timeline view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property WebSchedulerTimelineWeekMode get_TimelineWeekMode();
public: __property void set_TimelineWeekMode(
   WebSchedulerTimelineWeekMode value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies TimelineWeekMode of Timeline view.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property WebSchedulerTimelineWeekMode TimelineWeekMode {
   WebSchedulerTimelineWeekMode get();
   void set (    WebSchedulerTimelineWeekMode value);
}

Property Value

The default value is FirstDay.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


TotalEventInCell Property

[image]
Intersoft WebScheduler Documentation
TotalEventInCell Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : TotalEventInCell Property

Glossary Item Box

Specifies total event in a Timeline cell. Minimum value is 1. Specifies total event in a Timeline cell.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies total event in a Timeline cell. Minimum value is 1.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Timeline View")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property TotalEventInCell As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim value As System.Integer

instance.TotalEventInCell = value

value = instance.TotalEventInCell
C#
[System.ComponentModel.DescriptionAttribute("Specifies total event in a Timeline cell. Minimum value is 1.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.int TotalEventInCell {get; set;}
Delphi
public read-write property TotalEventInCell: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Specifies total event in a Timeline cell. Minimum value is 1.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Timeline View")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set TotalEventInCell : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies total event in a Timeline cell. Minimum value is 1.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.int get_TotalEventInCell();
public: __property void set_TotalEventInCell(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies total event in a Timeline cell. Minimum value is 1.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.int TotalEventInCell {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 5.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


WeekExportColumnLength Property

[image]
Intersoft WebScheduler Documentation
WeekExportColumnLength Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : WeekExportColumnLength Property

Glossary Item Box

Specifies Week view export column length per row.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies Week view export column length per row.")>
<System.ComponentModel.CategoryAttribute("Timeline View")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property WeekExportColumnLength As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim value As System.Integer

instance.WeekExportColumnLength = value

value = instance.WeekExportColumnLength
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies Week view export column length per row.")]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.int WeekExportColumnLength {get; set;}
Delphi
public read-write property WeekExportColumnLength: System.Integer;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies Week view export column length per row.")
System.ComponentModel.CategoryAttribute("Timeline View")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set WeekExportColumnLength : System.int
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies Week view export column length per row.")]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_WeekExportColumnLength();
public: __property void set_WeekExportColumnLength(
   System.int value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies Week view export column length per row.")]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int WeekExportColumnLength {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 7.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


ZoomInLevel Property

[image]
Intersoft WebScheduler Documentation
ZoomInLevel Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : ZoomInLevel Property

Glossary Item Box

Specifies Timeline zoom in level.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Timeline View")>
<System.ComponentModel.DescriptionAttribute("Specifies Timeline zoom in level.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ZoomInLevel As WebSchedulerTimelineViewMode
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim value As WebSchedulerTimelineViewMode

instance.ZoomInLevel = value

value = instance.ZoomInLevel
C#
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.DescriptionAttribute("Specifies Timeline zoom in level.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebSchedulerTimelineViewMode ZoomInLevel {get; set;}
Delphi
public read-write property ZoomInLevel: WebSchedulerTimelineViewMode;
JScript
System.ComponentModel.CategoryAttribute("Timeline View")
System.ComponentModel.DescriptionAttribute("Specifies Timeline zoom in level.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ZoomInLevel : WebSchedulerTimelineViewMode
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.DescriptionAttribute("Specifies Timeline zoom in level.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebSchedulerTimelineViewMode get_ZoomInLevel();
public: __property void set_ZoomInLevel(
   WebSchedulerTimelineViewMode value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Timeline View")]
[System.ComponentModel.DescriptionAttribute("Specifies Timeline zoom in level.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebSchedulerTimelineViewMode ZoomInLevel {
   WebSchedulerTimelineViewMode get();
   void set (    WebSchedulerTimelineViewMode value);
}

Property Value

The default value is Day15Minutes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


ZoomOutLevel Property

[image]
Intersoft WebScheduler Documentation
ZoomOutLevel Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : ZoomOutLevel Property

Glossary Item Box

Specifies Timeline zoom out level.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies Timeline zoom out level.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Timeline View")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ZoomOutLevel As WebSchedulerTimelineViewMode
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim value As WebSchedulerTimelineViewMode

instance.ZoomOutLevel = value

value = instance.ZoomOutLevel
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies Timeline zoom out level.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebSchedulerTimelineViewMode ZoomOutLevel {get; set;}
Delphi
public read-write property ZoomOutLevel: WebSchedulerTimelineViewMode;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies Timeline zoom out level.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Timeline View")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ZoomOutLevel : WebSchedulerTimelineViewMode
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies Timeline zoom out level.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebSchedulerTimelineViewMode get_ZoomOutLevel();
public: __property void set_ZoomOutLevel(
   WebSchedulerTimelineViewMode value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies Timeline zoom out level.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Timeline View")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebSchedulerTimelineViewMode ZoomOutLevel {
   WebSchedulerTimelineViewMode get();
   void set (    WebSchedulerTimelineViewMode value);
}

Property Value

The default value is Month.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


WebSchedulerViewSettings Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerViewSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerViewSettings Class

Glossary Item Box

A collection of settings used for view in WebScheduler.

Object Model

WebSchedulerViewSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerViewSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerViewSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerViewSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSchedulerViewSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerViewSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerViewSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerViewSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebScheduler.WebSchedulerViewSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerViewSettings Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerViewSettings Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerViewSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerViewSettings Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerViewSettings.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerViewSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | AgendaView | Configures the settings used by agenda view. Configures the settings used by agenda view.
Public Property | DayView | Configures the settings used by day view. Configures the settings used by day view.
Public Property | EnableNavigateToOtherView | Indicates whether clicking on cell's header or row's header will navigate to other view or not. Indicates whether clicking on cell's header or row's header will navigate to other view or not.
Public Property | HighlightTodayDate | Indicates whether WebScheduler should highlight today date. Indicates whether WebScheduler should highlight today's date.
Public Property | MonthView | Configures the settings used by month view. Configures the settings used by month view.
Public Property | QuarterView | Configures the settings used by month view. Configures the settings used by quarter view.
Public Property | SelectedDate | Specifies the initial WebScheduler's Date and Time. Specifies the initial WebScheduler's Date and Time.
Public Property | SelectedTimelineViewMode | Specifies Timeline view mode. Specifies Timeline view mode.
Public Property | SelectedViewMode | Specifies the initial WebScheduler's view mode. Specifies the initial WebScheduler's view mode.
Public Property | SelectedWeekViewMode | Specifies the initial WebScheduler week view mode. Specifies the initial WebScheduler's week view mode.
Public Property | SynchronizeTimeInterval | Indicates whether time interval modification applied in one view should be synchronized to all views.
Public Property | TimelineView | Configures the settings used by Timeline view. Configures the settings used by Timeline view.
Public Property | WeekView | Configures the settings used by week view. Configures the settings used by week view.
Public Property | YearView | Configures the settings used by year view. Configures the settings used by year view.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerViewSettings Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerViewSettings Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerViewSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerViewSettings Class : WebSchedulerViewSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerViewSettings()
C#
public WebSchedulerViewSettings()
Delphi
public WebSchedulerViewSettings();
JScript
public function WebSchedulerViewSettings();
Managed Extensions for C++
public: WebSchedulerViewSettings();
C++/CLI
public:
WebSchedulerViewSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerViewSettings Class
WebSchedulerViewSettings Members


WebSchedulerViewSettings Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerViewSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerViewSettings Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerViewSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerViewSettings Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerViewSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerViewSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerViewSettings Class
WebSchedulerViewSettings Members


WebSchedulerViewSettings Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerViewSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerViewSettings Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerViewSettings members.

Public Properties

 | Name | Description
Public Property | AgendaView | Configures the settings used by agenda view. Configures the settings used by agenda view.
Public Property | DayView | Configures the settings used by day view. Configures the settings used by day view.
Public Property | EnableNavigateToOtherView | Indicates whether clicking on cell's header or row's header will navigate to other view or not. Indicates whether clicking on cell's header or row's header will navigate to other view or not.
Public Property | HighlightTodayDate | Indicates whether WebScheduler should highlight today date. Indicates whether WebScheduler should highlight today's date.
Public Property | MonthView | Configures the settings used by month view. Configures the settings used by month view.
Public Property | QuarterView | Configures the settings used by month view. Configures the settings used by quarter view.
Public Property | SelectedDate | Specifies the initial WebScheduler's Date and Time. Specifies the initial WebScheduler's Date and Time.
Public Property | SelectedTimelineViewMode | Specifies Timeline view mode. Specifies Timeline view mode.
Public Property | SelectedViewMode | Specifies the initial WebScheduler's view mode. Specifies the initial WebScheduler's view mode.
Public Property | SelectedWeekViewMode | Specifies the initial WebScheduler week view mode. Specifies the initial WebScheduler's week view mode.
Public Property | SynchronizeTimeInterval | Indicates whether time interval modification applied in one view should be synchronized to all views.
Public Property | TimelineView | Configures the settings used by Timeline view. Configures the settings used by Timeline view.
Public Property | WeekView | Configures the settings used by week view. Configures the settings used by week view.
Public Property | YearView | Configures the settings used by year view. Configures the settings used by year view.
Top

See Also

Reference

WebSchedulerViewSettings Class
ISNet.WebUI.WebScheduler Namespace


AgendaView Property

[image]
Intersoft WebScheduler Documentation
AgendaView Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerViewSettings Class : AgendaView Property

Glossary Item Box

Configures the settings used by agenda view. Configures the settings used by agenda view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("View")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Configures the settings used by agenda view.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute("setAgendaView")>
Public ReadOnly Property AgendaView As WebSchedulerAgendaView
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerViewSettings
Dim value As WebSchedulerAgendaView

value = instance.AgendaView
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by agenda view.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setAgendaView")]
public WebSchedulerAgendaView AgendaView {get;}
Delphi
public read-only property AgendaView: WebSchedulerAgendaView;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("View")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Configures the settings used by agenda view.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute("setAgendaView")
public function get AgendaView : WebSchedulerAgendaView
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by agenda view.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setAgendaView")]
public: __property WebSchedulerAgendaView* get_AgendaView();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by agenda view.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setAgendaView")]
public:
property WebSchedulerAgendaView^ AgendaView {
   WebSchedulerAgendaView^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerViewSettings Class
WebSchedulerViewSettings Members


DayView Property

[image]
Intersoft WebScheduler Documentation
DayView Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerViewSettings Class : DayView Property

Glossary Item Box

Configures the settings used by day view. Configures the settings used by day view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("View")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Configures the settings used by day view.")>
<ISNet.Serialization.BinarySerializableAttribute("setDayView")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
Public ReadOnly Property DayView As WebSchedulerDayView
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerViewSettings
Dim value As WebSchedulerDayView

value = instance.DayView
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("View")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by day view.")]
[ISNet.Serialization.BinarySerializableAttribute("setDayView")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public WebSchedulerDayView DayView {get;}
Delphi
public read-only property DayView: WebSchedulerDayView;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("View")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Configures the settings used by day view.")
ISNet.Serialization.BinarySerializableAttribute("setDayView")
ISNet.Serialization.XmlSerializableAttribute()
public function get DayView : WebSchedulerDayView
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("View")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by day view.")]
[ISNet.Serialization.BinarySerializableAttribute("setDayView")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public: __property WebSchedulerDayView* get_DayView();
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("View")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by day view.")]
[ISNet.Serialization.BinarySerializableAttribute("setDayView")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public:
property WebSchedulerDayView^ DayView {
   WebSchedulerDayView^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerViewSettings Class
WebSchedulerViewSettings Members


EnableNavigateToOtherView Property

[image]
Intersoft WebScheduler Documentation
EnableNavigateToOtherView Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerViewSettings Class : EnableNavigateToOtherView Property

Glossary Item Box

Indicates whether clicking on cell's header or row's header will navigate to other view or not. Indicates whether clicking on cell's header or row's header will navigate to other view or not.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Indicates whether clicking on cell's header or row's header will navigate to other view or not.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property EnableNavigateToOtherView As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerViewSettings
Dim value As System.Boolean

instance.EnableNavigateToOtherView = value

value = instance.EnableNavigateToOtherView
C#
[System.ComponentModel.DescriptionAttribute("Indicates whether clicking on cell's header or row's header will navigate to other view or not.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool EnableNavigateToOtherView {get; set;}
Delphi
public read-write property EnableNavigateToOtherView: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Indicates whether clicking on cell's header or row's header will navigate to other view or not.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set EnableNavigateToOtherView : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Indicates whether clicking on cell's header or row's header will navigate to other view or not.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_EnableNavigateToOtherView();
public: __property void set_EnableNavigateToOtherView(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Indicates whether clicking on cell's header or row's header will navigate to other view or not.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool EnableNavigateToOtherView {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerViewSettings Class
WebSchedulerViewSettings Members


HighlightTodayDate Property

[image]
Intersoft WebScheduler Documentation
HighlightTodayDate Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerViewSettings Class : HighlightTodayDate Property

Glossary Item Box

Indicates whether WebScheduler should highlight today date. Indicates whether WebScheduler should highlight today's date.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Indicates whether WebScheduler should highlight today date.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property HighlightTodayDate As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerViewSettings
Dim value As System.Boolean

instance.HighlightTodayDate = value

value = instance.HighlightTodayDate
C#
[System.ComponentModel.DescriptionAttribute("Indicates whether WebScheduler should highlight today date.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool HighlightTodayDate {get; set;}
Delphi
public read-write property HighlightTodayDate: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Indicates whether WebScheduler should highlight today date.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set HighlightTodayDate : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Indicates whether WebScheduler should highlight today date.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_HighlightTodayDate();
public: __property void set_HighlightTodayDate(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Indicates whether WebScheduler should highlight today date.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool HighlightTodayDate {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerViewSettings Class
WebSchedulerViewSettings Members


MonthView Property

[image]
Intersoft WebScheduler Documentation
MonthView Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerViewSettings Class : MonthView Property

Glossary Item Box

Configures the settings used by month view. Configures the settings used by month view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Configures the settings used by month view.")>
<System.ComponentModel.CategoryAttribute("View")>
<ISNet.Serialization.BinarySerializableAttribute("setMonthView")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
Public ReadOnly Property MonthView As WebSchedulerMonthView
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerViewSettings
Dim value As WebSchedulerMonthView

value = instance.MonthView
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by month view.")]
[System.ComponentModel.CategoryAttribute("View")]
[ISNet.Serialization.BinarySerializableAttribute("setMonthView")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public WebSchedulerMonthView MonthView {get;}
Delphi
public read-only property MonthView: WebSchedulerMonthView;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Configures the settings used by month view.")
System.ComponentModel.CategoryAttribute("View")
ISNet.Serialization.BinarySerializableAttribute("setMonthView")
ISNet.Serialization.XmlSerializableAttribute()
public function get MonthView : WebSchedulerMonthView
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by month view.")]
[System.ComponentModel.CategoryAttribute("View")]
[ISNet.Serialization.BinarySerializableAttribute("setMonthView")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public: __property WebSchedulerMonthView* get_MonthView();
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by month view.")]
[System.ComponentModel.CategoryAttribute("View")]
[ISNet.Serialization.BinarySerializableAttribute("setMonthView")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public:
property WebSchedulerMonthView^ MonthView {
   WebSchedulerMonthView^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerViewSettings Class
WebSchedulerViewSettings Members


QuarterView Property

[image]
Intersoft WebScheduler Documentation
QuarterView Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerViewSettings Class : QuarterView Property

Glossary Item Box

Configures the settings used by month view. Configures the settings used by quarter view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Configures the settings used by quarter view.")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("View")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute("setQuarterView")>
Public ReadOnly Property QuarterView As WebSchedulerQuarterView
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerViewSettings
Dim value As WebSchedulerQuarterView

value = instance.QuarterView
C#
[System.ComponentModel.DescriptionAttribute("Configures the settings used by quarter view.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("View")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setQuarterView")]
public WebSchedulerQuarterView QuarterView {get;}
Delphi
public read-only property QuarterView: WebSchedulerQuarterView;
JScript
System.ComponentModel.DescriptionAttribute("Configures the settings used by quarter view.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("View")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute("setQuarterView")
public function get QuarterView : WebSchedulerQuarterView
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Configures the settings used by quarter view.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("View")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setQuarterView")]
public: __property WebSchedulerQuarterView* get_QuarterView();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Configures the settings used by quarter view.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("View")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setQuarterView")]
public:
property WebSchedulerQuarterView^ QuarterView {
   WebSchedulerQuarterView^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerViewSettings Class
WebSchedulerViewSettings Members


SelectedDate Property

[image]
Intersoft WebScheduler Documentation
SelectedDate Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerViewSettings Class : SelectedDate Property

Glossary Item Box

Specifies the initial WebScheduler's Date and Time. Specifies the initial WebScheduler's Date and Time.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.TwoWay)>
<System.ComponentModel.DescriptionAttribute("Specifies the initial WebScheduler's Date and Time.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property SelectedDate As System.Date
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerViewSettings
Dim value As System.Date

instance.SelectedDate = value

value = instance.SelectedDate
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.TwoWay)]
[System.ComponentModel.DescriptionAttribute("Specifies the initial WebScheduler's Date and Time.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.DateTime SelectedDate {get; set;}
Delphi
public read-write property SelectedDate: System.DateTime;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.TwoWay)
System.ComponentModel.DescriptionAttribute("Specifies the initial WebScheduler's Date and Time.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set SelectedDate : System.DateTime
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.TwoWay)]
[System.ComponentModel.DescriptionAttribute("Specifies the initial WebScheduler's Date and Time.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.DateTime get_SelectedDate();
public: __property void set_SelectedDate(
   System.DateTime value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.TwoWay)]
[System.ComponentModel.DescriptionAttribute("Specifies the initial WebScheduler's Date and Time.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.DateTime SelectedDate {
   System.DateTime get();
   void set (    System.DateTime value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerViewSettings Class
WebSchedulerViewSettings Members


SelectedTimelineViewMode Property

[image]
Intersoft WebScheduler Documentation
SelectedTimelineViewMode Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerViewSettings Class : SelectedTimelineViewMode Property

Glossary Item Box

Specifies Timeline view mode. Specifies Timeline view mode.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("View")>
<System.ComponentModel.DescriptionAttribute("Specifies Timeline view mode.")>
Public Property SelectedTimelineViewMode As WebSchedulerTimelineViewMode
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerViewSettings
Dim value As WebSchedulerTimelineViewMode

instance.SelectedTimelineViewMode = value

value = instance.SelectedTimelineViewMode
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("View")]
[System.ComponentModel.DescriptionAttribute("Specifies Timeline view mode.")]
public WebSchedulerTimelineViewMode SelectedTimelineViewMode {get; set;}
Delphi
public read-write property SelectedTimelineViewMode: WebSchedulerTimelineViewMode;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("View")
System.ComponentModel.DescriptionAttribute("Specifies Timeline view mode.")
public function get,set SelectedTimelineViewMode : WebSchedulerTimelineViewMode
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("View")]
[System.ComponentModel.DescriptionAttribute("Specifies Timeline view mode.")]
public: __property WebSchedulerTimelineViewMode get_SelectedTimelineViewMode();
public: __property void set_SelectedTimelineViewMode(
   WebSchedulerTimelineViewMode value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("View")]
[System.ComponentModel.DescriptionAttribute("Specifies Timeline view mode.")]
public:
property WebSchedulerTimelineViewMode SelectedTimelineViewMode {
   WebSchedulerTimelineViewMode get();
   void set (    WebSchedulerTimelineViewMode value);
}

Property Value

The default value is Time.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerViewSettings Class
WebSchedulerViewSettings Members


SelectedViewMode Property

[image]
Intersoft WebScheduler Documentation
SelectedViewMode Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerViewSettings Class : SelectedViewMode Property

Glossary Item Box

Specifies the initial WebScheduler's view mode. Specifies the initial WebScheduler's view mode.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the initial WebScheduler's view mode.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property SelectedViewMode As WebSchedulerViewMode
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerViewSettings
Dim value As WebSchedulerViewMode

instance.SelectedViewMode = value

value = instance.SelectedViewMode
C#
[System.ComponentModel.DescriptionAttribute("Specifies the initial WebScheduler's view mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public WebSchedulerViewMode SelectedViewMode {get; set;}
Delphi
public read-write property SelectedViewMode: WebSchedulerViewMode;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the initial WebScheduler's view mode.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set SelectedViewMode : WebSchedulerViewMode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the initial WebScheduler's view mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebSchedulerViewMode get_SelectedViewMode();
public: __property void set_SelectedViewMode(
   WebSchedulerViewMode value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the initial WebScheduler's view mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebSchedulerViewMode SelectedViewMode {
   WebSchedulerViewMode get();
   void set (    WebSchedulerViewMode value);
}

Property Value

The default value is Day.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerViewSettings Class
WebSchedulerViewSettings Members


SelectedWeekViewMode Property

[image]
Intersoft WebScheduler Documentation
SelectedWeekViewMode Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerViewSettings Class : SelectedWeekViewMode Property

Glossary Item Box

Specifies the initial WebScheduler week view mode. Specifies the initial WebScheduler's week view mode.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the initial WebScheduler week view mode.")>
Public Property SelectedWeekViewMode As WebSchedulerWeekViewMode
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerViewSettings
Dim value As WebSchedulerWeekViewMode

instance.SelectedWeekViewMode = value

value = instance.SelectedWeekViewMode
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the initial WebScheduler week view mode.")]
public WebSchedulerWeekViewMode SelectedWeekViewMode {get; set;}
Delphi
public read-write property SelectedWeekViewMode: WebSchedulerWeekViewMode;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the initial WebScheduler week view mode.")
public function get,set SelectedWeekViewMode : WebSchedulerWeekViewMode
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the initial WebScheduler week view mode.")]
public: __property WebSchedulerWeekViewMode get_SelectedWeekViewMode();
public: __property void set_SelectedWeekViewMode(
   WebSchedulerWeekViewMode value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the initial WebScheduler week view mode.")]
public:
property WebSchedulerWeekViewMode SelectedWeekViewMode {
   WebSchedulerWeekViewMode get();
   void set (    WebSchedulerWeekViewMode value);
}

Property Value

The default value is FullWeek.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerViewSettings Class
WebSchedulerViewSettings Members


SynchronizeTimeInterval Property

[image]
Intersoft WebScheduler Documentation
SynchronizeTimeInterval Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerViewSettings Class : SynchronizeTimeInterval Property

Glossary Item Box

Indicates whether time interval modification applied in one view should be synchronized to all views.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Indicates whether time interval modification applied in one view should be synchronized to all views.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property SynchronizeTimeInterval As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerViewSettings
Dim value As System.Boolean

instance.SynchronizeTimeInterval = value

value = instance.SynchronizeTimeInterval
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether time interval modification applied in one view should be synchronized to all views.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool SynchronizeTimeInterval {get; set;}
Delphi
public read-write property SynchronizeTimeInterval: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Indicates whether time interval modification applied in one view should be synchronized to all views.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set SynchronizeTimeInterval : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether time interval modification applied in one view should be synchronized to all views.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_SynchronizeTimeInterval();
public: __property void set_SynchronizeTimeInterval(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether time interval modification applied in one view should be synchronized to all views.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool SynchronizeTimeInterval {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerViewSettings Class
WebSchedulerViewSettings Members


TimelineView Property

[image]
Intersoft WebScheduler Documentation
TimelineView Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerViewSettings Class : TimelineView Property

Glossary Item Box

Configures the settings used by Timeline view. Configures the settings used by Timeline view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("View")>
<System.ComponentModel.DescriptionAttribute("Configures the settings used by Timeline view.")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute("setTimelineView")>
Public ReadOnly Property TimelineView As WebSchedulerTimelineView
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerViewSettings
Dim value As WebSchedulerTimelineView

value = instance.TimelineView
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("View")]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by Timeline view.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setTimelineView")]
public WebSchedulerTimelineView TimelineView {get;}
Delphi
public read-only property TimelineView: WebSchedulerTimelineView;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("View")
System.ComponentModel.DescriptionAttribute("Configures the settings used by Timeline view.")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute("setTimelineView")
public function get TimelineView : WebSchedulerTimelineView
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("View")]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by Timeline view.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setTimelineView")]
public: __property WebSchedulerTimelineView* get_TimelineView();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("View")]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by Timeline view.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setTimelineView")]
public:
property WebSchedulerTimelineView^ TimelineView {
   WebSchedulerTimelineView^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerViewSettings Class
WebSchedulerViewSettings Members


WeekView Property

[image]
Intersoft WebScheduler Documentation
WeekView Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerViewSettings Class : WeekView Property

Glossary Item Box

Configures the settings used by week view. Configures the settings used by week view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("View")>
<System.ComponentModel.DescriptionAttribute("Configures the settings used by week view.")>
<ISNet.Serialization.BinarySerializableAttribute("setWeekView")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
Public ReadOnly Property WeekView As WebSchedulerWeekView
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerViewSettings
Dim value As WebSchedulerWeekView

value = instance.WeekView
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("View")]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by week view.")]
[ISNet.Serialization.BinarySerializableAttribute("setWeekView")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public WebSchedulerWeekView WeekView {get;}
Delphi
public read-only property WeekView: WebSchedulerWeekView;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("View")
System.ComponentModel.DescriptionAttribute("Configures the settings used by week view.")
ISNet.Serialization.BinarySerializableAttribute("setWeekView")
ISNet.Serialization.XmlSerializableAttribute()
public function get WeekView : WebSchedulerWeekView
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("View")]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by week view.")]
[ISNet.Serialization.BinarySerializableAttribute("setWeekView")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public: __property WebSchedulerWeekView* get_WeekView();
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("View")]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by week view.")]
[ISNet.Serialization.BinarySerializableAttribute("setWeekView")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public:
property WebSchedulerWeekView^ WeekView {
   WebSchedulerWeekView^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerViewSettings Class
WebSchedulerViewSettings Members


YearView Property

[image]
Intersoft WebScheduler Documentation
YearView Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerViewSettings Class : YearView Property

Glossary Item Box

Configures the settings used by year view. Configures the settings used by year view.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("View")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Configures the settings used by year view.")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute("setYearView")>
Public ReadOnly Property YearView As WebSchedulerYearView
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerViewSettings
Dim value As WebSchedulerYearView

value = instance.YearView
C#
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by year view.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setYearView")]
public WebSchedulerYearView YearView {get;}
Delphi
public read-only property YearView: WebSchedulerYearView;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("View")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Configures the settings used by year view.")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute("setYearView")
public function get YearView : WebSchedulerYearView
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by year view.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setYearView")]
public: __property WebSchedulerYearView* get_YearView();
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by year view.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setYearView")]
public:
property WebSchedulerYearView^ YearView {
   WebSchedulerYearView^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerViewSettings Class
WebSchedulerViewSettings Members


WebSchedulerWeekView Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerWeekView Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerWeekView Class

Glossary Item Box

A collection of settings used for week in WebScheduler.

Object Model

WebSchedulerWeekView Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerWeekView
   Inherits WebSchedulerBaseView
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWeekView
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerWeekView : WebSchedulerBaseView, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSchedulerWeekView = class(WebSchedulerBaseView, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerWeekView extends WebSchedulerBaseView implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerWeekView : public WebSchedulerBaseView, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerWeekView : public WebSchedulerBaseView, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebScheduler.WebSchedulerWeekView

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWeekView Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerWeekView Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerWeekView Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerWeekView Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerWeekView.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerWeekView Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllDayEventPageSize | Specifies the total number of all day events rendered when client paging is enabled.
Public Property | DateFormatString | Overridden. Specifies the DateFormatString of Week view. Specifies the DateFormatString of week view.
Public Property | EnableClientPaging | Specifies whether or not client paging is enabled.
Public Property | EventBlockSize | Specifies the total number of overlapped block allowed when client paging is enabled.
Public Property | ShowAllDayEventArea | Indicates whether AllDayEventArea should be visibled. Indicates whether AllDayEventsArea should be visible.
Public Property | TimeInterval | Specifies the time interval used when rendering the hour areas.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerWeekView Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerWeekView Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerWeekView Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWeekView Class : WebSchedulerWeekView Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerWeekView()
C#
public WebSchedulerWeekView()
Delphi
public WebSchedulerWeekView();
JScript
public function WebSchedulerWeekView();
Managed Extensions for C++
public: WebSchedulerWeekView();
C++/CLI
public:
WebSchedulerWeekView();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWeekView Class
WebSchedulerWeekView Members


WebSchedulerWeekView Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerWeekView Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerWeekView Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerWeekView members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerWeekView Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWeekView Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWeekView
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWeekView Class
WebSchedulerWeekView Members


WebSchedulerWeekView Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerWeekView Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerWeekView Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerWeekView members.

Public Properties

 | Name | Description
Public Property | AllDayEventPageSize | Specifies the total number of all day events rendered when client paging is enabled.
Public Property | DateFormatString | Overridden. Specifies the DateFormatString of Week view. Specifies the DateFormatString of week view.
Public Property | EnableClientPaging | Specifies whether or not client paging is enabled.
Public Property | EventBlockSize | Specifies the total number of overlapped block allowed when client paging is enabled.
Public Property | ShowAllDayEventArea | Indicates whether AllDayEventArea should be visibled. Indicates whether AllDayEventsArea should be visible.
Public Property | TimeInterval | Specifies the time interval used when rendering the hour areas.
Top

See Also

Reference

WebSchedulerWeekView Class
ISNet.WebUI.WebScheduler Namespace


AllDayEventPageSize Property

[image]
Intersoft WebScheduler Documentation
AllDayEventPageSize Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWeekView Class : AllDayEventPageSize Property

Glossary Item Box

Specifies the total number of all day events rendered when client paging is enabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the total number of all day events rendered when client paging is enabled.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Week View")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AllDayEventPageSize As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWeekView
Dim value As System.Integer

instance.AllDayEventPageSize = value

value = instance.AllDayEventPageSize
C#
[System.ComponentModel.DescriptionAttribute("Specifies the total number of all day events rendered when client paging is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Week View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.int AllDayEventPageSize {get; set;}
Delphi
public read-write property AllDayEventPageSize: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the total number of all day events rendered when client paging is enabled.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Week View")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set AllDayEventPageSize : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the total number of all day events rendered when client paging is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Week View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_AllDayEventPageSize();
public: __property void set_AllDayEventPageSize(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the total number of all day events rendered when client paging is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Week View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int AllDayEventPageSize {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 3.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWeekView Class
WebSchedulerWeekView Members


DateFormatString Property

[image]
Intersoft WebScheduler Documentation
DateFormatString Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWeekView Class : DateFormatString Property

Glossary Item Box

Specifies the DateFormatString of Week view. Specifies the DateFormatString of week view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Week View")>
<System.ComponentModel.DescriptionAttribute("Specifies the DateFormatString of Week view.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Overrides Property DateFormatString As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWeekView
Dim value As System.String

instance.DateFormatString = value

value = instance.DateFormatString
C#
[System.ComponentModel.CategoryAttribute("Week View")]
[System.ComponentModel.DescriptionAttribute("Specifies the DateFormatString of Week view.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public override System.string DateFormatString {get; set;}
Delphi
public read-write property DateFormatString: System.String; override;
JScript
System.ComponentModel.CategoryAttribute("Week View")
System.ComponentModel.DescriptionAttribute("Specifies the DateFormatString of Week view.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public override function get,set DateFormatString : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Week View")]
[System.ComponentModel.DescriptionAttribute("Specifies the DateFormatString of Week view.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_DateFormatString() override;
public: __property void set_DateFormatString(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.CategoryAttribute("Week View")]
[System.ComponentModel.DescriptionAttribute("Specifies the DateFormatString of Week view.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ DateFormatString {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Property Value

The default value is D.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWeekView Class
WebSchedulerWeekView Members


EnableClientPaging Property

[image]
Intersoft WebScheduler Documentation
EnableClientPaging Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWeekView Class : EnableClientPaging Property

Glossary Item Box

Specifies whether or not client paging is enabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether or not client paging is enabled.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Week View")>
Public Property EnableClientPaging As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWeekView
Dim value As System.Boolean

instance.EnableClientPaging = value

value = instance.EnableClientPaging
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether or not client paging is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Week View")]
public System.bool EnableClientPaging {get; set;}
Delphi
public read-write property EnableClientPaging: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether or not client paging is enabled.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Week View")
public function get,set EnableClientPaging : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether or not client paging is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Week View")]
public: __property System.bool get_EnableClientPaging();
public: __property void set_EnableClientPaging(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether or not client paging is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Week View")]
public:
property System.bool EnableClientPaging {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWeekView Class
WebSchedulerWeekView Members


EventBlockSize Property

[image]
Intersoft WebScheduler Documentation
EventBlockSize Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWeekView Class : EventBlockSize Property

Glossary Item Box

Specifies the total number of overlapped block allowed when client paging is enabled.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Week View")>
<System.ComponentModel.DescriptionAttribute("Specifies the total number of overlapped block allowed when client paging is enabled.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property EventBlockSize As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWeekView
Dim value As System.Integer

instance.EventBlockSize = value

value = instance.EventBlockSize
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Week View")]
[System.ComponentModel.DescriptionAttribute("Specifies the total number of overlapped block allowed when client paging is enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.int EventBlockSize {get; set;}
Delphi
public read-write property EventBlockSize: System.Integer;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Week View")
System.ComponentModel.DescriptionAttribute("Specifies the total number of overlapped block allowed when client paging is enabled.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set EventBlockSize : System.int
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Week View")]
[System.ComponentModel.DescriptionAttribute("Specifies the total number of overlapped block allowed when client paging is enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_EventBlockSize();
public: __property void set_EventBlockSize(
   System.int value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Week View")]
[System.ComponentModel.DescriptionAttribute("Specifies the total number of overlapped block allowed when client paging is enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int EventBlockSize {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 3.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWeekView Class
WebSchedulerWeekView Members


ShowAllDayEventArea Property

[image]
Intersoft WebScheduler Documentation
ShowAllDayEventArea Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWeekView Class : ShowAllDayEventArea Property

Glossary Item Box

Indicates whether AllDayEventArea should be visibled. Indicates whether AllDayEventsArea should be visible.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Week View")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Indicates whether AllDayEventArea should be visible.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ShowAllDayEventArea As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWeekView
Dim value As System.Boolean

instance.ShowAllDayEventArea = value

value = instance.ShowAllDayEventArea
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Week View")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether AllDayEventArea should be visible.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool ShowAllDayEventArea {get; set;}
Delphi
public read-write property ShowAllDayEventArea: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Week View")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Indicates whether AllDayEventArea should be visible.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ShowAllDayEventArea : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Week View")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether AllDayEventArea should be visible.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_ShowAllDayEventArea();
public: __property void set_ShowAllDayEventArea(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Week View")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether AllDayEventArea should be visible.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool ShowAllDayEventArea {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWeekView Class
WebSchedulerWeekView Members


TimeInterval Property

[image]
Intersoft WebScheduler Documentation
TimeInterval Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWeekView Class : TimeInterval Property

Glossary Item Box

Specifies the time interval used when rendering the hour areas.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the time interval used when rendering the hour areas.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Week View")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property TimeInterval As WebSchedulerTimeScale
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWeekView
Dim value As WebSchedulerTimeScale

instance.TimeInterval = value

value = instance.TimeInterval
C#
[System.ComponentModel.DescriptionAttribute("Specifies the time interval used when rendering the hour areas.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Week View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebSchedulerTimeScale TimeInterval {get; set;}
Delphi
public read-write property TimeInterval: WebSchedulerTimeScale;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the time interval used when rendering the hour areas.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Week View")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set TimeInterval : WebSchedulerTimeScale
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the time interval used when rendering the hour areas.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Week View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebSchedulerTimeScale get_TimeInterval();
public: __property void set_TimeInterval(
   WebSchedulerTimeScale value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the time interval used when rendering the hour areas.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Week View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebSchedulerTimeScale TimeInterval {
   WebSchedulerTimeScale get();
   void set (    WebSchedulerTimeScale value);
}

Property Value

The default value is Minutes30.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWeekView Class
WebSchedulerWeekView Members


WebSchedulerWorkWeekSettings Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerWorkWeekSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerWorkWeekSettings Class

Glossary Item Box

A collection of interactive styles used for work week in WebScheduler.

Object Model

WebSchedulerWorkWeekSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerWorkWeekSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWorkWeekSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerWorkWeekSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSchedulerWorkWeekSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerWorkWeekSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerWorkWeekSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerWorkWeekSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebScheduler.WebSchedulerWorkWeekSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWorkWeekSettings Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerWorkWeekSettings Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerWorkWeekSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerWorkWeekSettings Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerWorkWeekSettings.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerWorkWeekSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | EndTime | Specifies the end time of work week. Specifies the end time of work week.
Public Property | Friday | Indicates whether Friday is work week. Indicates whether Friday is work week.
Public Property | Monday | Indicates whether Monday is work week. Indicates whether Monday is work week.
Public Property | Saturday | Indicates whether Saturday is work week. Indicates whether Saturday is work week.
Public Property | StartTime | Specifies the start time of work week. Specifies the start time of work week.
Public Property | Sunday | Indicates whether Sunday is work week. Indicates whether Sunday is work week.
Public Property | Thursday | Indicates whether Thursday is work week. Indicates whether Thursday is work week.
Public Property | Tuesday | Indicates whether Tuesday is work week. Indicates whether Tuesday is work week.
Public Property | Wednesday | Indicates whether Wednesday is work week. Indicates whether Wednesday is work week.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerWorkWeekSettings Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerWorkWeekSettings Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerWorkWeekSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWorkWeekSettings Class : WebSchedulerWorkWeekSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerWorkWeekSettings()
C#
public WebSchedulerWorkWeekSettings()
Delphi
public WebSchedulerWorkWeekSettings();
JScript
public function WebSchedulerWorkWeekSettings();
Managed Extensions for C++
public: WebSchedulerWorkWeekSettings();
C++/CLI
public:
WebSchedulerWorkWeekSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWorkWeekSettings Class
WebSchedulerWorkWeekSettings Members


WebSchedulerWorkWeekSettings Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerWorkWeekSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerWorkWeekSettings Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerWorkWeekSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerWorkWeekSettings Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWorkWeekSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWorkWeekSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWorkWeekSettings Class
WebSchedulerWorkWeekSettings Members


WebSchedulerWorkWeekSettings Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerWorkWeekSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerWorkWeekSettings Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerWorkWeekSettings members.

Public Properties

 | Name | Description
Public Property | EndTime | Specifies the end time of work week. Specifies the end time of work week.
Public Property | Friday | Indicates whether Friday is work week. Indicates whether Friday is work week.
Public Property | Monday | Indicates whether Monday is work week. Indicates whether Monday is work week.
Public Property | Saturday | Indicates whether Saturday is work week. Indicates whether Saturday is work week.
Public Property | StartTime | Specifies the start time of work week. Specifies the start time of work week.
Public Property | Sunday | Indicates whether Sunday is work week. Indicates whether Sunday is work week.
Public Property | Thursday | Indicates whether Thursday is work week. Indicates whether Thursday is work week.
Public Property | Tuesday | Indicates whether Tuesday is work week. Indicates whether Tuesday is work week.
Public Property | Wednesday | Indicates whether Wednesday is work week. Indicates whether Wednesday is work week.
Top

See Also

Reference

WebSchedulerWorkWeekSettings Class
ISNet.WebUI.WebScheduler Namespace


EndTime Property

[image]
Intersoft WebScheduler Documentation
EndTime Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWorkWeekSettings Class : EndTime Property

Glossary Item Box

Specifies the end time of work week. Specifies the end time of work week.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Work Week")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the end time of work week.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property EndTime As WebSchedulerTime
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWorkWeekSettings
Dim value As WebSchedulerTime

instance.EndTime = value

value = instance.EndTime
C#
[System.ComponentModel.CategoryAttribute("Work Week")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the end time of work week.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebSchedulerTime EndTime {get; set;}
Delphi
public read-write property EndTime: WebSchedulerTime;
JScript
System.ComponentModel.CategoryAttribute("Work Week")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the end time of work week.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set EndTime : WebSchedulerTime
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Work Week")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the end time of work week.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebSchedulerTime get_EndTime();
public: __property void set_EndTime(
   WebSchedulerTime value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Work Week")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the end time of work week.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebSchedulerTime EndTime {
   WebSchedulerTime get();
   void set (    WebSchedulerTime value);
}

Property Value

The default value is t1700.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWorkWeekSettings Class
WebSchedulerWorkWeekSettings Members


Friday Property

[image]
Intersoft WebScheduler Documentation
Friday Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWorkWeekSettings Class : Friday Property

Glossary Item Box

Indicates whether Friday is work week. Indicates whether Friday is work week.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Work Week")>
<System.ComponentModel.DescriptionAttribute("Indicates whether Friday is work week.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Friday As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWorkWeekSettings
Dim value As System.Boolean

instance.Friday = value

value = instance.Friday
C#
[System.ComponentModel.CategoryAttribute("Work Week")]
[System.ComponentModel.DescriptionAttribute("Indicates whether Friday is work week.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool Friday {get; set;}
Delphi
public read-write property Friday: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Work Week")
System.ComponentModel.DescriptionAttribute("Indicates whether Friday is work week.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Friday : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Work Week")]
[System.ComponentModel.DescriptionAttribute("Indicates whether Friday is work week.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_Friday();
public: __property void set_Friday(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Work Week")]
[System.ComponentModel.DescriptionAttribute("Indicates whether Friday is work week.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool Friday {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWorkWeekSettings Class
WebSchedulerWorkWeekSettings Members


Monday Property

[image]
Intersoft WebScheduler Documentation
Monday Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWorkWeekSettings Class : Monday Property

Glossary Item Box

Indicates whether Monday is work week. Indicates whether Monday is work week.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Work Week")>
<System.ComponentModel.DescriptionAttribute("Indicates whether Monday is work week.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Monday As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWorkWeekSettings
Dim value As System.Boolean

instance.Monday = value

value = instance.Monday
C#
[System.ComponentModel.CategoryAttribute("Work Week")]
[System.ComponentModel.DescriptionAttribute("Indicates whether Monday is work week.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool Monday {get; set;}
Delphi
public read-write property Monday: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Work Week")
System.ComponentModel.DescriptionAttribute("Indicates whether Monday is work week.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Monday : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Work Week")]
[System.ComponentModel.DescriptionAttribute("Indicates whether Monday is work week.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_Monday();
public: __property void set_Monday(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Work Week")]
[System.ComponentModel.DescriptionAttribute("Indicates whether Monday is work week.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool Monday {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWorkWeekSettings Class
WebSchedulerWorkWeekSettings Members


Saturday Property

[image]
Intersoft WebScheduler Documentation
Saturday Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWorkWeekSettings Class : Saturday Property

Glossary Item Box

Indicates whether Saturday is work week. Indicates whether Saturday is work week.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Indicates whether Saturday is work week.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Work Week")>
Public Property Saturday As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWorkWeekSettings
Dim value As System.Boolean

instance.Saturday = value

value = instance.Saturday
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether Saturday is work week.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Work Week")]
public System.bool Saturday {get; set;}
Delphi
public read-write property Saturday: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Indicates whether Saturday is work week.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Work Week")
public function get,set Saturday : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether Saturday is work week.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Work Week")]
public: __property System.bool get_Saturday();
public: __property void set_Saturday(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether Saturday is work week.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Work Week")]
public:
property System.bool Saturday {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWorkWeekSettings Class
WebSchedulerWorkWeekSettings Members


StartTime Property

[image]
Intersoft WebScheduler Documentation
StartTime Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWorkWeekSettings Class : StartTime Property

Glossary Item Box

Specifies the start time of work week. Specifies the start time of work week.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Work Week")>
<System.ComponentModel.DescriptionAttribute("Specifies the start time of work week.")>
Public Property StartTime As WebSchedulerTime
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWorkWeekSettings
Dim value As WebSchedulerTime

instance.StartTime = value

value = instance.StartTime
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Work Week")]
[System.ComponentModel.DescriptionAttribute("Specifies the start time of work week.")]
public WebSchedulerTime StartTime {get; set;}
Delphi
public read-write property StartTime: WebSchedulerTime;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Work Week")
System.ComponentModel.DescriptionAttribute("Specifies the start time of work week.")
public function get,set StartTime : WebSchedulerTime
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Work Week")]
[System.ComponentModel.DescriptionAttribute("Specifies the start time of work week.")]
public: __property WebSchedulerTime get_StartTime();
public: __property void set_StartTime(
   WebSchedulerTime value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Work Week")]
[System.ComponentModel.DescriptionAttribute("Specifies the start time of work week.")]
public:
property WebSchedulerTime StartTime {
   WebSchedulerTime get();
   void set (    WebSchedulerTime value);
}

Property Value

The default value is t0800.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWorkWeekSettings Class
WebSchedulerWorkWeekSettings Members


Sunday Property

[image]
Intersoft WebScheduler Documentation
Sunday Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWorkWeekSettings Class : Sunday Property

Glossary Item Box

Indicates whether Sunday is work week. Indicates whether Sunday is work week.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Work Week")>
<System.ComponentModel.DescriptionAttribute("Indicates whether Sunday is work week.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Sunday As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWorkWeekSettings
Dim value As System.Boolean

instance.Sunday = value

value = instance.Sunday
C#
[System.ComponentModel.CategoryAttribute("Work Week")]
[System.ComponentModel.DescriptionAttribute("Indicates whether Sunday is work week.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool Sunday {get; set;}
Delphi
public read-write property Sunday: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Work Week")
System.ComponentModel.DescriptionAttribute("Indicates whether Sunday is work week.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Sunday : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Work Week")]
[System.ComponentModel.DescriptionAttribute("Indicates whether Sunday is work week.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_Sunday();
public: __property void set_Sunday(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Work Week")]
[System.ComponentModel.DescriptionAttribute("Indicates whether Sunday is work week.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool Sunday {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWorkWeekSettings Class
WebSchedulerWorkWeekSettings Members


Thursday Property

[image]
Intersoft WebScheduler Documentation
Thursday Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWorkWeekSettings Class : Thursday Property

Glossary Item Box

Indicates whether Thursday is work week. Indicates whether Thursday is work week.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Indicates whether Thursday is work week.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Work Week")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Thursday As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWorkWeekSettings
Dim value As System.Boolean

instance.Thursday = value

value = instance.Thursday
C#
[System.ComponentModel.DescriptionAttribute("Indicates whether Thursday is work week.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Work Week")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool Thursday {get; set;}
Delphi
public read-write property Thursday: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Indicates whether Thursday is work week.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Work Week")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Thursday : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Indicates whether Thursday is work week.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Work Week")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_Thursday();
public: __property void set_Thursday(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Indicates whether Thursday is work week.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Work Week")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool Thursday {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWorkWeekSettings Class
WebSchedulerWorkWeekSettings Members


Tuesday Property

[image]
Intersoft WebScheduler Documentation
Tuesday Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWorkWeekSettings Class : Tuesday Property

Glossary Item Box

Indicates whether Tuesday is work week. Indicates whether Tuesday is work week.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Work Week")>
<System.ComponentModel.DescriptionAttribute("Indicates whether Tuesday is work week.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Tuesday As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWorkWeekSettings
Dim value As System.Boolean

instance.Tuesday = value

value = instance.Tuesday
C#
[System.ComponentModel.CategoryAttribute("Work Week")]
[System.ComponentModel.DescriptionAttribute("Indicates whether Tuesday is work week.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool Tuesday {get; set;}
Delphi
public read-write property Tuesday: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Work Week")
System.ComponentModel.DescriptionAttribute("Indicates whether Tuesday is work week.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Tuesday : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Work Week")]
[System.ComponentModel.DescriptionAttribute("Indicates whether Tuesday is work week.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_Tuesday();
public: __property void set_Tuesday(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Work Week")]
[System.ComponentModel.DescriptionAttribute("Indicates whether Tuesday is work week.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool Tuesday {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWorkWeekSettings Class
WebSchedulerWorkWeekSettings Members


Wednesday Property

[image]
Intersoft WebScheduler Documentation
Wednesday Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWorkWeekSettings Class : Wednesday Property

Glossary Item Box

Indicates whether Wednesday is work week. Indicates whether Wednesday is work week.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Indicates whether Wednesday is work week.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Work Week")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Wednesday As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWorkWeekSettings
Dim value As System.Boolean

instance.Wednesday = value

value = instance.Wednesday
C#
[System.ComponentModel.DescriptionAttribute("Indicates whether Wednesday is work week.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Work Week")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool Wednesday {get; set;}
Delphi
public read-write property Wednesday: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Indicates whether Wednesday is work week.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Work Week")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Wednesday : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Indicates whether Wednesday is work week.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Work Week")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_Wednesday();
public: __property void set_Wednesday(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Indicates whether Wednesday is work week.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Work Week")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool Wednesday {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWorkWeekSettings Class
WebSchedulerWorkWeekSettings Members


WebSchedulerYearView Class

[image]
Intersoft WebScheduler Documentation
WebSchedulerYearView Class
Members See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerYearView Class

Glossary Item Box

A collection of interactive styles used for year view in WebScheduler.

Object Model

WebSchedulerYearView Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSchedulerYearView
   Inherits WebSchedulerBaseView
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerYearView
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSchedulerYearView : WebSchedulerBaseView, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSchedulerYearView = class(WebSchedulerBaseView, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSchedulerYearView extends WebSchedulerBaseView implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSchedulerYearView : public WebSchedulerBaseView, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSchedulerYearView : public WebSchedulerBaseView, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebScheduler.WebSchedulerYearView

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerYearView Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerYearView Class Members

[image]
Intersoft WebScheduler Documentation
WebSchedulerYearView Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerYearView Class

Glossary Item Box

The following tables list the members exposed by WebSchedulerYearView.

Public Constructors

 | Name | Description
Public Constructor | WebSchedulerYearView Constructor |
Top

Public Properties

 | Name | Description
Public Property | DateFormatString | Overridden. Specifies the DateFormatString of Year view. Specifies the DateFormatString of Year view.
Public Property | MinimumHeight | Specifies the minimum height of year and quarter view cell. Specifies the minimum height of year and quarter view cell.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerYearView Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerYearView Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerYearView Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerYearView Class : WebSchedulerYearView Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerYearView()
C#
public WebSchedulerYearView()
Delphi
public WebSchedulerYearView();
JScript
public function WebSchedulerYearView();
Managed Extensions for C++
public: WebSchedulerYearView();
C++/CLI
public:
WebSchedulerYearView();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerYearView Class
WebSchedulerYearView Members


WebSchedulerYearView Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerYearView Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerYearView Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerYearView members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerYearView Class
ISNet.WebUI.WebScheduler Namespace


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerYearView Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerYearView
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerYearView Class
WebSchedulerYearView Members


WebSchedulerYearView Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerYearView Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerYearView Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerYearView members.

Public Properties

 | Name | Description
Public Property | DateFormatString | Overridden. Specifies the DateFormatString of Year view. Specifies the DateFormatString of Year view.
Public Property | MinimumHeight | Specifies the minimum height of year and quarter view cell. Specifies the minimum height of year and quarter view cell.
Top

See Also

Reference

WebSchedulerYearView Class
ISNet.WebUI.WebScheduler Namespace


DateFormatString Property

[image]
Intersoft WebScheduler Documentation
DateFormatString Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerYearView Class : DateFormatString Property

Glossary Item Box

Specifies the DateFormatString of Year view. Specifies the DateFormatString of Year view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the DateFormatString of Year view.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Year View")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Overrides Property DateFormatString As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerYearView
Dim value As System.String

instance.DateFormatString = value

value = instance.DateFormatString
C#
[System.ComponentModel.DescriptionAttribute("Specifies the DateFormatString of Year view.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Year View")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public override System.string DateFormatString {get; set;}
Delphi
public read-write property DateFormatString: System.String; override;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the DateFormatString of Year view.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Year View")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public override function get,set DateFormatString : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the DateFormatString of Year view.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Year View")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_DateFormatString() override;
public: __property void set_DateFormatString(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the DateFormatString of Year view.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Year View")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ DateFormatString {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Property Value

The default value is yyyy.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerYearView Class
WebSchedulerYearView Members


MinimumHeight Property

[image]
Intersoft WebScheduler Documentation
MinimumHeight Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerYearView Class : MinimumHeight Property

Glossary Item Box

Specifies the minimum height of year and quarter view cell. Specifies the minimum height of year and quarter view cell.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Year View")>
<System.ComponentModel.DescriptionAttribute("Specifies the minimum height of year and quarter view cell.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property MinimumHeight As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerYearView
Dim value As System.Web.UI.WebControls.Unit

instance.MinimumHeight = value

value = instance.MinimumHeight
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Year View")]
[System.ComponentModel.DescriptionAttribute("Specifies the minimum height of year and quarter view cell.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.Web.UI.WebControls.Unit MinimumHeight {get; set;}
Delphi
public read-write property MinimumHeight: System.Web.UI.WebControls.Unit;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Year View")
System.ComponentModel.DescriptionAttribute("Specifies the minimum height of year and quarter view cell.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set MinimumHeight : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Year View")]
[System.ComponentModel.DescriptionAttribute("Specifies the minimum height of year and quarter view cell.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.Web.UI.WebControls.Unit get_MinimumHeight();
public: __property void set_MinimumHeight(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Year View")]
[System.ComponentModel.DescriptionAttribute("Specifies the minimum height of year and quarter view cell.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.Web.UI.WebControls.Unit MinimumHeight {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Property Value

The default value is 50px.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerYearView Class
WebSchedulerYearView Members


WebSchedulerAllowMode Enumeration

[image]
Intersoft WebScheduler Documentation
WebSchedulerAllowMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerAllowMode Enumeration

Glossary Item Box

Indicates whether allow mode is enabled or disabled.

Syntax

Visual Basic (Declaration)
Public Enum WebSchedulerAllowMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerAllowMode
C#
public enum WebSchedulerAllowMode : System.Enum
Delphi
public enum WebSchedulerAllowMode = class(System.Enum)
JScript
public enum WebSchedulerAllowMode extends System.Enum
Managed Extensions for C++
__value public enum WebSchedulerAllowMode : public System.Enum
C++/CLI
public enum class WebSchedulerAllowMode : public System.Enum

Members

Member | Description
Default |
No | Value which disables a property.
Yes | Value which enables a property.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebScheduler.WebSchedulerAllowMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebScheduler Namespace


WebSchedulerCustomViewMode Enumeration

[image]
Intersoft WebScheduler Documentation
WebSchedulerCustomViewMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerCustomViewMode Enumeration

Glossary Item Box

Specifies which custom view mode is used.

Syntax

Visual Basic (Declaration)
Public Enum WebSchedulerCustomViewMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCustomViewMode
C#
public enum WebSchedulerCustomViewMode : System.Enum
Delphi
public enum WebSchedulerCustomViewMode = class(System.Enum)
JScript
public enum WebSchedulerCustomViewMode extends System.Enum
Managed Extensions for C++
__value public enum WebSchedulerCustomViewMode : public System.Enum
C++/CLI
public enum class WebSchedulerCustomViewMode : public System.Enum

Members

Member | Description
IFrame |
Next2Days |
Next2Quarters |
Next2Weeks |
Next3Days |
Next3Weeks |
Next4Days |
Next4Weeks |
Next5Days |
Next6Days |
Next7Days |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebScheduler.WebSchedulerCustomViewMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebScheduler Namespace


WebSchedulerDailyRecurrenceMode Enumeration

[image]
Intersoft WebScheduler Documentation
WebSchedulerDailyRecurrenceMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDailyRecurrenceMode Enumeration

Glossary Item Box

Determines which recurrence mode is used.

Syntax

Visual Basic (Declaration)
Public Enum WebSchedulerDailyRecurrenceMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDailyRecurrenceMode
C#
public enum WebSchedulerDailyRecurrenceMode : System.Enum
Delphi
public enum WebSchedulerDailyRecurrenceMode = class(System.Enum)
JScript
public enum WebSchedulerDailyRecurrenceMode extends System.Enum
Managed Extensions for C++
__value public enum WebSchedulerDailyRecurrenceMode : public System.Enum
C++/CLI
public enum class WebSchedulerDailyRecurrenceMode : public System.Enum

Members

Member | Description
EveryNDay |
EveryWeekDay |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebScheduler.WebSchedulerDailyRecurrenceMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebScheduler Namespace


WebSchedulerDatePrefix Enumeration

[image]
Intersoft WebScheduler Documentation
WebSchedulerDatePrefix Enumeration
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDatePrefix Enumeration

Glossary Item Box

Determines which date prefix is used.

Syntax

Visual Basic (Declaration)
Public Enum WebSchedulerDatePrefix
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDatePrefix
C#
public enum WebSchedulerDatePrefix : System.Enum
Delphi
public enum WebSchedulerDatePrefix = class(System.Enum)
JScript
public enum WebSchedulerDatePrefix extends System.Enum
Managed Extensions for C++
__value public enum WebSchedulerDatePrefix : public System.Enum
C++/CLI
public enum class WebSchedulerDatePrefix : public System.Enum

Members

Member | Description
First |
Fourth |
Last |
Second |
Third |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebScheduler.WebSchedulerDatePrefix

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebScheduler Namespace


WebSchedulerDefaultStyleMode Enumeration

[image]
Intersoft WebScheduler Documentation
WebSchedulerDefaultStyleMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDefaultStyleMode Enumeration

Glossary Item Box

Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.

Syntax

Visual Basic (Declaration)
Public Enum WebSchedulerDefaultStyleMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDefaultStyleMode
C#
public enum WebSchedulerDefaultStyleMode : System.Enum
Delphi
public enum WebSchedulerDefaultStyleMode = class(System.Enum)
JScript
public enum WebSchedulerDefaultStyleMode extends System.Enum
Managed Extensions for C++
__value public enum WebSchedulerDefaultStyleMode : public System.Enum
C++/CLI
public enum class WebSchedulerDefaultStyleMode : public System.Enum

Members

Member | Description
OliveGreen |
Outlook2007Black | The mode will be set to Outlook 2007 black.
Outlook2007Blue | The mode will be set to Outlook 2007 blue.
Win7 |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebScheduler.WebSchedulerDefaultStyleMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebScheduler Namespace


WebSchedulerEditingFormStyle Enumeration

[image]
Intersoft WebScheduler Documentation
WebSchedulerEditingFormStyle Enumeration
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerEditingFormStyle Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum WebSchedulerEditingFormStyle
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingFormStyle
C#
public enum WebSchedulerEditingFormStyle : System.Enum
Delphi
public enum WebSchedulerEditingFormStyle = class(System.Enum)
JScript
public enum WebSchedulerEditingFormStyle extends System.Enum
Managed Extensions for C++
__value public enum WebSchedulerEditingFormStyle : public System.Enum
C++/CLI
public enum class WebSchedulerEditingFormStyle : public System.Enum

Members

Member | Description
Custom |
Minimalist |
Standard |
Win7 |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebScheduler.WebSchedulerEditingFormStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebScheduler Namespace


WebSchedulerEmptyCellClickAction Enumeration

[image]
Intersoft WebScheduler Documentation
WebSchedulerEmptyCellClickAction Enumeration
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerEmptyCellClickAction Enumeration

Glossary Item Box

Determines which empty cell click action is used.

Syntax

Visual Basic (Declaration)
Public Enum WebSchedulerEmptyCellClickAction
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEmptyCellClickAction
C#
public enum WebSchedulerEmptyCellClickAction : System.Enum
Delphi
public enum WebSchedulerEmptyCellClickAction = class(System.Enum)
JScript
public enum WebSchedulerEmptyCellClickAction extends System.Enum
Managed Extensions for C++
__value public enum WebSchedulerEmptyCellClickAction : public System.Enum
C++/CLI
public enum class WebSchedulerEmptyCellClickAction : public System.Enum

Members

Member | Description
ShowCallOut |
ShowEditingForm |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebScheduler.WebSchedulerEmptyCellClickAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebScheduler Namespace


WebSchedulerExceptionInfo Enumeration

[image]
Intersoft WebScheduler Documentation
WebSchedulerExceptionInfo Enumeration
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerExceptionInfo Enumeration

Glossary Item Box

Determines which exception info is used.

Syntax

Visual Basic (Declaration)
Public Enum WebSchedulerExceptionInfo
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerExceptionInfo
C#
public enum WebSchedulerExceptionInfo : System.Enum
Delphi
public enum WebSchedulerExceptionInfo = class(System.Enum)
JScript
public enum WebSchedulerExceptionInfo extends System.Enum
Managed Extensions for C++
__value public enum WebSchedulerExceptionInfo : public System.Enum
C++/CLI
public enum class WebSchedulerExceptionInfo : public System.Enum

Members

Member | Description
Altered |
Default |
Deleted |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebScheduler.WebSchedulerExceptionInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebScheduler Namespace


WebSchedulerFieldType Enumeration

[image]
Intersoft WebScheduler Documentation
WebSchedulerFieldType Enumeration
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerFieldType Enumeration

Glossary Item Box

Determines which field type is used.

Syntax

Visual Basic (Declaration)
Public Enum WebSchedulerFieldType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerFieldType
C#
public enum WebSchedulerFieldType : System.Enum
Delphi
public enum WebSchedulerFieldType = class(System.Enum)
JScript
public enum WebSchedulerFieldType extends System.Enum
Managed Extensions for C++
__value public enum WebSchedulerFieldType : public System.Enum
C++/CLI
public enum class WebSchedulerFieldType : public System.Enum

Members

Member | Description
Description |
Location |
Subject |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebScheduler.WebSchedulerFieldType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebScheduler Namespace


WebSchedulerFirstWeekOfYear Enumeration

[image]
Intersoft WebScheduler Documentation
WebSchedulerFirstWeekOfYear Enumeration
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerFirstWeekOfYear Enumeration

Glossary Item Box

Determines which first week of year is used.

Syntax

Visual Basic (Declaration)
Public Enum WebSchedulerFirstWeekOfYear
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerFirstWeekOfYear
C#
public enum WebSchedulerFirstWeekOfYear : System.Enum
Delphi
public enum WebSchedulerFirstWeekOfYear = class(System.Enum)
JScript
public enum WebSchedulerFirstWeekOfYear extends System.Enum
Managed Extensions for C++
__value public enum WebSchedulerFirstWeekOfYear : public System.Enum
C++/CLI
public enum class WebSchedulerFirstWeekOfYear : public System.Enum

Members

Member | Description
First4DayWeek |
FirstFullWeek |
StartsOnJanuary1 |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebScheduler.WebSchedulerFirstWeekOfYear

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebScheduler Namespace


WebSchedulerImportanceMode Enumeration

[image]
Intersoft WebScheduler Documentation
WebSchedulerImportanceMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerImportanceMode Enumeration

Glossary Item Box

Determines which importance mode is used.

Syntax

Visual Basic (Declaration)
Public Enum WebSchedulerImportanceMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImportanceMode
C#
public enum WebSchedulerImportanceMode : System.Enum
Delphi
public enum WebSchedulerImportanceMode = class(System.Enum)
JScript
public enum WebSchedulerImportanceMode extends System.Enum
Managed Extensions for C++
__value public enum WebSchedulerImportanceMode : public System.Enum
C++/CLI
public enum class WebSchedulerImportanceMode : public System.Enum

Members

Member | Description
HighImportance |
LowImportance |
Normal |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebScheduler.WebSchedulerImportanceMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebScheduler Namespace


WebSchedulerLoadOnDemandMode Enumeration

[image]
Intersoft WebScheduler Documentation
WebSchedulerLoadOnDemandMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerLoadOnDemandMode Enumeration

Glossary Item Box

Gets or sets a value that determines the mode of LoadOnDemand.

Syntax

Visual Basic (Declaration)
Public Enum WebSchedulerLoadOnDemandMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerLoadOnDemandMode
C#
public enum WebSchedulerLoadOnDemandMode : System.Enum
Delphi
public enum WebSchedulerLoadOnDemandMode = class(System.Enum)
JScript
public enum WebSchedulerLoadOnDemandMode extends System.Enum
Managed Extensions for C++
__value public enum WebSchedulerLoadOnDemandMode : public System.Enum
C++/CLI
public enum class WebSchedulerLoadOnDemandMode : public System.Enum

Members

Member | Description
SingleLoad |
TripleLoad |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebScheduler.WebSchedulerLoadOnDemandMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebScheduler Namespace


WebSchedulerObjectType Enumeration

[image]
Intersoft WebScheduler Documentation
WebSchedulerObjectType Enumeration
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerObjectType Enumeration

Glossary Item Box

Determines which object type is used.

Syntax

Visual Basic (Declaration)
Public Enum WebSchedulerObjectType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerObjectType
C#
public enum WebSchedulerObjectType : System.Enum
Delphi
public enum WebSchedulerObjectType = class(System.Enum)
JScript
public enum WebSchedulerObjectType extends System.Enum
Managed Extensions for C++
__value public enum WebSchedulerObjectType : public System.Enum
C++/CLI
public enum class WebSchedulerObjectType : public System.Enum

Members

Member | Description
Category |
Event |
RecurrenceInfo |
RecurringEvent |
Resource |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebScheduler.WebSchedulerObjectType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebScheduler Namespace


WebSchedulerRecurrenceMode Enumeration

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurrenceMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerRecurrenceMode Enumeration

Glossary Item Box

Determines which recurrence mode is used.

Syntax

Visual Basic (Declaration)
Public Enum WebSchedulerRecurrenceMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceMode
C#
public enum WebSchedulerRecurrenceMode : System.Enum
Delphi
public enum WebSchedulerRecurrenceMode = class(System.Enum)
JScript
public enum WebSchedulerRecurrenceMode extends System.Enum
Managed Extensions for C++
__value public enum WebSchedulerRecurrenceMode : public System.Enum
C++/CLI
public enum class WebSchedulerRecurrenceMode : public System.Enum

Members

Member | Description
Daily_EveryNDay |
Daily_EveryWeekDay |
Monthly |
Weekly |
Yearly |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebScheduler.WebSchedulerRecurrenceMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebScheduler Namespace


WebSchedulerRecurrenceRangeMode Enumeration

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurrenceRangeMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerRecurrenceRangeMode Enumeration

Glossary Item Box

Determines which recurrence range mode is used.

Syntax

Visual Basic (Declaration)
Public Enum WebSchedulerRecurrenceRangeMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceRangeMode
C#
public enum WebSchedulerRecurrenceRangeMode : System.Enum
Delphi
public enum WebSchedulerRecurrenceRangeMode = class(System.Enum)
JScript
public enum WebSchedulerRecurrenceRangeMode extends System.Enum
Managed Extensions for C++
__value public enum WebSchedulerRecurrenceRangeMode : public System.Enum
C++/CLI
public enum class WebSchedulerRecurrenceRangeMode : public System.Enum

Members

Member | Description
EndAfterNRecurrence |
EndByDate |
NoEndDate |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebScheduler.WebSchedulerRecurrenceRangeMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebScheduler Namespace


WebSchedulerReportOutputPathType Enumeration

[image]
Intersoft WebScheduler Documentation
WebSchedulerReportOutputPathType Enumeration
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerReportOutputPathType Enumeration

Glossary Item Box

Determines the output path for report type.

Syntax

Visual Basic (Declaration)
Public Enum WebSchedulerReportOutputPathType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerReportOutputPathType
C#
public enum WebSchedulerReportOutputPathType : System.Enum
Delphi
public enum WebSchedulerReportOutputPathType = class(System.Enum)
JScript
public enum WebSchedulerReportOutputPathType extends System.Enum
Managed Extensions for C++
__value public enum WebSchedulerReportOutputPathType : public System.Enum
C++/CLI
public enum class WebSchedulerReportOutputPathType : public System.Enum

Members

Member | Description
AbsolutePath |
RelativePath |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebScheduler.WebSchedulerReportOutputPathType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebScheduler Namespace


WebSchedulerTime Enumeration

[image]
Intersoft WebScheduler Documentation
WebSchedulerTime Enumeration
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerTime Enumeration

Glossary Item Box

Determines which time is used.

Syntax

Visual Basic (Declaration)
Public Enum WebSchedulerTime
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTime
C#
public enum WebSchedulerTime : System.Enum
Delphi
public enum WebSchedulerTime = class(System.Enum)
JScript
public enum WebSchedulerTime extends System.Enum
Managed Extensions for C++
__value public enum WebSchedulerTime : public System.Enum
C++/CLI
public enum class WebSchedulerTime : public System.Enum

Members

Member | Description
t0000 |
t0030 |
t0100 |
t0130 |
t0200 |
t0230 |
t0300 |
t0330 |
t0400 |
t0430 |
t0500 |
t0530 |
t0600 |
t0630 |
t0700 |
t0730 |
t0800 |
t0830 |
t0900 |
t0930 |
t1000 |
t1030 |
t1100 |
t1130 |
t1200 |
t1230 |
t1300 |
t1330 |
t1400 |
t1430 |
t1500 |
t1530 |
t1600 |
t1630 |
t1700 |
t1730 |
t1800 |
t1830 |
t1900 |
t1930 |
t2000 |
t2030 |
t2100 |
t2130 |
t2200 |
t2230 |
t2300 |
t2330 |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebScheduler.WebSchedulerTime

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebScheduler Namespace


WebSchedulerTimeBasedEventDisplay Enumeration

[image]
Intersoft WebScheduler Documentation
WebSchedulerTimeBasedEventDisplay Enumeration
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerTimeBasedEventDisplay Enumeration

Glossary Item Box

Determines which interactive style is used for TimeBasedEvent.

Syntax

Visual Basic (Declaration)
Public Enum WebSchedulerTimeBasedEventDisplay
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimeBasedEventDisplay
C#
public enum WebSchedulerTimeBasedEventDisplay : System.Enum
Delphi
public enum WebSchedulerTimeBasedEventDisplay = class(System.Enum)
JScript
public enum WebSchedulerTimeBasedEventDisplay extends System.Enum
Managed Extensions for C++
__value public enum WebSchedulerTimeBasedEventDisplay : public System.Enum
C++/CLI
public enum class WebSchedulerTimeBasedEventDisplay : public System.Enum

Members

Member | Description
ShowSubject |
ShowTimeAndSubject |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebScheduler.WebSchedulerTimeBasedEventDisplay

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebScheduler Namespace


WebSchedulerTimeFormat Enumeration

[image]
Intersoft WebScheduler Documentation
WebSchedulerTimeFormat Enumeration
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerTimeFormat Enumeration

Glossary Item Box

Determines the time format.

Syntax

Visual Basic (Declaration)
Public Enum WebSchedulerTimeFormat
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimeFormat
C#
public enum WebSchedulerTimeFormat : System.Enum
Delphi
public enum WebSchedulerTimeFormat = class(System.Enum)
JScript
public enum WebSchedulerTimeFormat extends System.Enum
Managed Extensions for C++
__value public enum WebSchedulerTimeFormat : public System.Enum
C++/CLI
public enum class WebSchedulerTimeFormat : public System.Enum

Members

Member | Description
Format12Hours |
Format24Hours |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebScheduler.WebSchedulerTimeFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebScheduler Namespace


WebSchedulerTimeline Enumeration

[image]
Intersoft WebScheduler Documentation
WebSchedulerTimeline Enumeration
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerTimeline Enumeration

Glossary Item Box

Determines the Timeline.

Syntax

Visual Basic (Declaration)
Public Enum WebSchedulerTimeline
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimeline
C#
public enum WebSchedulerTimeline : System.Enum
Delphi
public enum WebSchedulerTimeline = class(System.Enum)
JScript
public enum WebSchedulerTimeline extends System.Enum
Managed Extensions for C++
__value public enum WebSchedulerTimeline : public System.Enum
C++/CLI
public enum class WebSchedulerTimeline : public System.Enum

Members

Member | Description
t0000 |
t0100 |
t0200 |
t0300 |
t0400 |
t0500 |
t0600 |
t0700 |
t0800 |
t0900 |
t1000 |
t1100 |
t1200 |
t1300 |
t1400 |
t1500 |
t1600 |
t1700 |
t1800 |
t1900 |
t2000 |
t2100 |
t2200 |
t2300 |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebScheduler.WebSchedulerTimeline

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebScheduler Namespace


WebSchedulerTimelineClientPagingMode Enumeration

[image]
Intersoft WebScheduler Documentation
WebSchedulerTimelineClientPagingMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerTimelineClientPagingMode Enumeration

Glossary Item Box

Determines which client paging mode is used in Timeline view.

Syntax

Visual Basic (Declaration)
Public Enum WebSchedulerTimelineClientPagingMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineClientPagingMode
C#
public enum WebSchedulerTimelineClientPagingMode : System.Enum
Delphi
public enum WebSchedulerTimelineClientPagingMode = class(System.Enum)
JScript
public enum WebSchedulerTimelineClientPagingMode extends System.Enum
Managed Extensions for C++
__value public enum WebSchedulerTimelineClientPagingMode : public System.Enum
C++/CLI
public enum class WebSchedulerTimelineClientPagingMode : public System.Enum

Members

Member | Description
Both |
EventPageSize |
ViewPort |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebScheduler.WebSchedulerTimelineClientPagingMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebScheduler Namespace


WebSchedulerTimelineDateHeaderMode Enumeration

[image]
Intersoft WebScheduler Documentation
WebSchedulerTimelineDateHeaderMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerTimelineDateHeaderMode Enumeration

Glossary Item Box

Determines which date header mode is used in Timeline view.

Syntax

Visual Basic (Declaration)
Public Enum WebSchedulerTimelineDateHeaderMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineDateHeaderMode
C#
public enum WebSchedulerTimelineDateHeaderMode : System.Enum
Delphi
public enum WebSchedulerTimelineDateHeaderMode = class(System.Enum)
JScript
public enum WebSchedulerTimelineDateHeaderMode extends System.Enum
Managed Extensions for C++
__value public enum WebSchedulerTimelineDateHeaderMode : public System.Enum
C++/CLI
public enum class WebSchedulerTimelineDateHeaderMode : public System.Enum

Members

Member | Description
DateNumber |
DateNumberAndDayName |
DateNumberAndShortestDayName |
DayName |
DayNameAndDateNumber |
ShortestDayName |
ShortestDayNameAndDateNumber |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebScheduler.WebSchedulerTimelineDateHeaderMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebScheduler Namespace


WebSchedulerTimelineResourceContentMode Enumeration

[image]
Intersoft WebScheduler Documentation
WebSchedulerTimelineResourceContentMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerTimelineResourceContentMode Enumeration

Glossary Item Box

Determines which Timeline resource content mode is used.

Syntax

Visual Basic (Declaration)
Public Enum WebSchedulerTimelineResourceContentMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineResourceContentMode
C#
public enum WebSchedulerTimelineResourceContentMode : System.Enum
Delphi
public enum WebSchedulerTimelineResourceContentMode = class(System.Enum)
JScript
public enum WebSchedulerTimelineResourceContentMode extends System.Enum
Managed Extensions for C++
__value public enum WebSchedulerTimelineResourceContentMode : public System.Enum
C++/CLI
public enum class WebSchedulerTimelineResourceContentMode : public System.Enum

Members

Member | Description
Custom |
Default |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebScheduler.WebSchedulerTimelineResourceContentMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebScheduler Namespace


WebSchedulerTimelineViewMode Enumeration

[image]
Intersoft WebScheduler Documentation
WebSchedulerTimelineViewMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerTimelineViewMode Enumeration

Glossary Item Box

Determines which Timeline view mode is used.

Syntax

Visual Basic (Declaration)
Public Enum WebSchedulerTimelineViewMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineViewMode
C#
public enum WebSchedulerTimelineViewMode : System.Enum
Delphi
public enum WebSchedulerTimelineViewMode = class(System.Enum)
JScript
public enum WebSchedulerTimelineViewMode extends System.Enum
Managed Extensions for C++
__value public enum WebSchedulerTimelineViewMode : public System.Enum
C++/CLI
public enum class WebSchedulerTimelineViewMode : public System.Enum

Members

Member | Description
Day15Minutes |
DayHourly |
Month |
Quarter |
Week |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebScheduler.WebSchedulerTimelineViewMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebScheduler Namespace


WebSchedulerTimelineWeekMode Enumeration

[image]
Intersoft WebScheduler Documentation
WebSchedulerTimelineWeekMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerTimelineWeekMode Enumeration

Glossary Item Box

Determines which Timeline week mode is used.

Syntax

Visual Basic (Declaration)
Public Enum WebSchedulerTimelineWeekMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineWeekMode
C#
public enum WebSchedulerTimelineWeekMode : System.Enum
Delphi
public enum WebSchedulerTimelineWeekMode = class(System.Enum)
JScript
public enum WebSchedulerTimelineWeekMode extends System.Enum
Managed Extensions for C++
__value public enum WebSchedulerTimelineWeekMode : public System.Enum
C++/CLI
public enum class WebSchedulerTimelineWeekMode : public System.Enum

Members

Member | Description
FirstDay |
WeekNumber |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebScheduler.WebSchedulerTimelineWeekMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebScheduler Namespace


WebSchedulerTimeMode Enumeration

[image]
Intersoft WebScheduler Documentation
WebSchedulerTimeMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerTimeMode Enumeration

Glossary Item Box

Determines which time mode is used.

Syntax

Visual Basic (Declaration)
Public Enum WebSchedulerTimeMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimeMode
C#
public enum WebSchedulerTimeMode : System.Enum
Delphi
public enum WebSchedulerTimeMode = class(System.Enum)
JScript
public enum WebSchedulerTimeMode extends System.Enum
Managed Extensions for C++
__value public enum WebSchedulerTimeMode : public System.Enum
C++/CLI
public enum class WebSchedulerTimeMode : public System.Enum

Members

Member | Description
AllTime |
CustomTime |
WorkTime |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebScheduler.WebSchedulerTimeMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebScheduler Namespace


WebSchedulerTimeScale Enumeration

[image]
Intersoft WebScheduler Documentation
WebSchedulerTimeScale Enumeration
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerTimeScale Enumeration

Glossary Item Box

Determines the time scale.

Syntax

Visual Basic (Declaration)
Public Enum WebSchedulerTimeScale
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimeScale
C#
public enum WebSchedulerTimeScale : System.Enum
Delphi
public enum WebSchedulerTimeScale = class(System.Enum)
JScript
public enum WebSchedulerTimeScale extends System.Enum
Managed Extensions for C++
__value public enum WebSchedulerTimeScale : public System.Enum
C++/CLI
public enum class WebSchedulerTimeScale : public System.Enum

Members

Member | Description
Minutes10 |
Minutes15 |
Minutes30 |
Minutes60 |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebScheduler.WebSchedulerTimeScale

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebScheduler Namespace


WebSchedulerViewMode Enumeration

[image]
Intersoft WebScheduler Documentation
WebSchedulerViewMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerViewMode Enumeration

Glossary Item Box

Determines which view mode is used.

Syntax

Visual Basic (Declaration)
Public Enum WebSchedulerViewMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerViewMode
C#
public enum WebSchedulerViewMode : System.Enum
Delphi
public enum WebSchedulerViewMode = class(System.Enum)
JScript
public enum WebSchedulerViewMode extends System.Enum
Managed Extensions for C++
__value public enum WebSchedulerViewMode : public System.Enum
C++/CLI
public enum class WebSchedulerViewMode : public System.Enum

Members

Member | Description
Agenda |
Custom |
Day |
Month |
Quarter |
Timeline |
Week |
Year |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebScheduler.WebSchedulerViewMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebScheduler Namespace


WebSchedulerViewRecurrenceType Enumeration

[image]
Intersoft WebScheduler Documentation
WebSchedulerViewRecurrenceType Enumeration
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerViewRecurrenceType Enumeration

Glossary Item Box

Determines which view recurrence type is used.

Syntax

Visual Basic (Declaration)
Public Enum WebSchedulerViewRecurrenceType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerViewRecurrenceType
C#
public enum WebSchedulerViewRecurrenceType : System.Enum
Delphi
public enum WebSchedulerViewRecurrenceType = class(System.Enum)
JScript
public enum WebSchedulerViewRecurrenceType extends System.Enum
Managed Extensions for C++
__value public enum WebSchedulerViewRecurrenceType : public System.Enum
C++/CLI
public enum class WebSchedulerViewRecurrenceType : public System.Enum

Members

Member | Description
Default |
Exception |
None |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebScheduler.WebSchedulerViewRecurrenceType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebScheduler Namespace


WebSchedulerWeekDay Enumeration

[image]
Intersoft WebScheduler Documentation
WebSchedulerWeekDay Enumeration
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerWeekDay Enumeration

Glossary Item Box

Determines which week day is used.

Syntax

Visual Basic (Declaration)
<System.FlagsAttribute()>
Public Enum WebSchedulerWeekDay
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWeekDay
C#
[System.FlagsAttribute()]
public enum WebSchedulerWeekDay : System.Enum
Delphi
public enum WebSchedulerWeekDay = class(System.Enum)
JScript
System.FlagsAttribute()
public enum WebSchedulerWeekDay extends System.Enum
Managed Extensions for C++
[System.FlagsAttribute()]
__value public enum WebSchedulerWeekDay : public System.Enum
C++/CLI
[System.FlagsAttribute()]
public enum class WebSchedulerWeekDay : public System.Enum

Members

Member | Description
Friday |
Monday |
Saturday |
Sunday |
Thursday |
Tuesday |
Wednesday |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebScheduler.WebSchedulerWeekDay

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebScheduler Namespace


WebSchedulerWeekViewMode Enumeration

[image]
Intersoft WebScheduler Documentation
WebSchedulerWeekViewMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerWeekViewMode Enumeration

Glossary Item Box

Determines which week view mode is used.

Syntax

Visual Basic (Declaration)
Public Enum WebSchedulerWeekViewMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWeekViewMode
C#
public enum WebSchedulerWeekViewMode : System.Enum
Delphi
public enum WebSchedulerWeekViewMode = class(System.Enum)
JScript
public enum WebSchedulerWeekViewMode extends System.Enum
Managed Extensions for C++
__value public enum WebSchedulerWeekViewMode : public System.Enum
C++/CLI
public enum class WebSchedulerWeekViewMode : public System.Enum

Members

Member | Description
FullWeek |
WorkWeek |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebScheduler.WebSchedulerWeekViewMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebScheduler Namespace


WebSchedulerDataBoundEventHandler Delegate

[image]
Intersoft WebScheduler Documentation
WebSchedulerDataBoundEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDataBoundEventHandler Delegate

sender
e

Glossary Item Box

Delegates that handles the DataBound event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub WebSchedulerDataBoundEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebSchedulerDataBoundDataArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerDataBoundEventHandler(AddressOf HandlerMethod)
C#
public delegate void WebSchedulerDataBoundEventHandler(
   System.object sender,
   WebSchedulerDataBoundDataArgs e
)
Delphi
public delegate WebSchedulerDataBoundEventHandler(
    sender: System.TObject;
    e: WebSchedulerDataBoundDataArgs
);
JScript
public delegate WebSchedulerDataBoundEventHandler(
   sender : System.Object,
   e : WebSchedulerDataBoundDataArgs
)
Managed Extensions for C++
public: __gc __delegate void WebSchedulerDataBoundEventHandler(
   System.Object* sender,
   WebSchedulerDataBoundDataArgs* e
)
C++/CLI
public delegate void WebSchedulerDataBoundEventHandler(
   System.Object^ sender,
   WebSchedulerDataBoundDataArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDataBoundEventHandler Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerDataOperationEventHandler Delegate

[image]
Intersoft WebScheduler Documentation
WebSchedulerDataOperationEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDataOperationEventHandler Delegate

sender
e

Glossary Item Box

Delegates that handles the DataOperation event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub WebSchedulerDataOperationEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebSchedulerDataArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerDataOperationEventHandler(AddressOf HandlerMethod)
C#
public delegate void WebSchedulerDataOperationEventHandler(
   System.object sender,
   WebSchedulerDataArgs e
)
Delphi
public delegate WebSchedulerDataOperationEventHandler(
    sender: System.TObject;
    e: WebSchedulerDataArgs
);
JScript
public delegate WebSchedulerDataOperationEventHandler(
   sender : System.Object,
   e : WebSchedulerDataArgs
)
Managed Extensions for C++
public: __gc __delegate void WebSchedulerDataOperationEventHandler(
   System.Object* sender,
   WebSchedulerDataArgs* e
)
C++/CLI
public delegate void WebSchedulerDataOperationEventHandler(
   System.Object^ sender,
   WebSchedulerDataArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDataOperationEventHandler Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerExportEventHandler Delegate

[image]
Intersoft WebScheduler Documentation
WebSchedulerExportEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerExportEventHandler Delegate

sender
e

Glossary Item Box

Delegates that handles the export event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub WebSchedulerExportEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebSchedulerExportEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerExportEventHandler(AddressOf HandlerMethod)
C#
public delegate void WebSchedulerExportEventHandler(
   System.object sender,
   WebSchedulerExportEventArgs e
)
Delphi
public delegate WebSchedulerExportEventHandler(
    sender: System.TObject;
    e: WebSchedulerExportEventArgs
);
JScript
public delegate WebSchedulerExportEventHandler(
   sender : System.Object,
   e : WebSchedulerExportEventArgs
)
Managed Extensions for C++
public: __gc __delegate void WebSchedulerExportEventHandler(
   System.Object* sender,
   WebSchedulerExportEventArgs* e
)
C++/CLI
public delegate void WebSchedulerExportEventHandler(
   System.Object^ sender,
   WebSchedulerExportEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerExportEventHandler Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerJsonSerializationEventHandler Delegate

[image]
Intersoft WebScheduler Documentation
WebSchedulerJsonSerializationEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerJsonSerializationEventHandler Delegate

sender
e

Glossary Item Box

Delegates that handles Json serialization event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub WebSchedulerJsonSerializationEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebSchedulerJsonSerializationArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerJsonSerializationEventHandler(AddressOf HandlerMethod)
C#
public delegate void WebSchedulerJsonSerializationEventHandler(
   System.object sender,
   WebSchedulerJsonSerializationArgs e
)
Delphi
public delegate WebSchedulerJsonSerializationEventHandler(
    sender: System.TObject;
    e: WebSchedulerJsonSerializationArgs
);
JScript
public delegate WebSchedulerJsonSerializationEventHandler(
   sender : System.Object,
   e : WebSchedulerJsonSerializationArgs
)
Managed Extensions for C++
public: __gc __delegate void WebSchedulerJsonSerializationEventHandler(
   System.Object* sender,
   WebSchedulerJsonSerializationArgs* e
)
C++/CLI
public delegate void WebSchedulerJsonSerializationEventHandler(
   System.Object^ sender,
   WebSchedulerJsonSerializationArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerJsonSerializationEventHandler Members
ISNet.WebUI.WebScheduler Namespace


WebSchedulerPrepareExportExecuteEventHandler Delegate

[image]
Intersoft WebScheduler Documentation
WebSchedulerPrepareExportExecuteEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerPrepareExportExecuteEventHandler Delegate

sender
e

Glossary Item Box

Delegates that handles prepare export execute event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub WebSchedulerPrepareExportExecuteEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebSchedulerPrepareExportExecuteEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebSchedulerPrepareExportExecuteEventHandler(AddressOf HandlerMethod)
C#
public delegate void WebSchedulerPrepareExportExecuteEventHandler(
   System.object sender,
   WebSchedulerPrepareExportExecuteEventArgs e
)
Delphi
public delegate WebSchedulerPrepareExportExecuteEventHandler(
    sender: System.TObject;
    e: WebSchedulerPrepareExportExecuteEventArgs
);
JScript
public delegate WebSchedulerPrepareExportExecuteEventHandler(
   sender : System.Object,
   e : WebSchedulerPrepareExportExecuteEventArgs
)
Managed Extensions for C++
public: __gc __delegate void WebSchedulerPrepareExportExecuteEventHandler(
   System.Object* sender,
   WebSchedulerPrepareExportExecuteEventArgs* e
)
C++/CLI
public delegate void WebSchedulerPrepareExportExecuteEventHandler(
   System.Object^ sender,
   WebSchedulerPrepareExportExecuteEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerPrepareExportExecuteEventHandler Members
ISNet.WebUI.WebScheduler Namespace


Client-side References

Client-side References
Send Feedback
Intersoft WebScheduler > Client-side References

Glossary Item Box

This section is designated to help user working with client-side references in WebScheduler.NET.

In This Section

WebScheduler

WebSchedulerClientSideEvents

WebSchedulerCalendarSettings

WebSchedulerLayoutSettings

WebSchedulerTextSettings

WebSchedulerAgendaView

WebSchedulerDayView

WebSchedulerMonthView

WebSchedulerQuarterView

WebSchedulerWeekView

WebSchedulerYearView

WebSchedulerViewSettings

WebSchedulerWorkWeekSettings

WebSchedulerResource

WebSchedulerEventBase

WebScheduler Global Functions


WebScheduler

WebScheduler
Send Feedback
Intersoft WebScheduler > Client-side References > WebScheduler

Glossary Item Box

WebScheduler Properties

Enabled | Description Enables state of the control. ValueType Boolean Default Value True
TabIndex | Description The tab order of the control. ValueType Integer Default Value
ClientID | Description Gets the server control identifier generated by ASP.NET. ValueType The server control identifier generated by ASP.NET Default Value String
ID | Description Gets or sets the programmatic identifier assigned to the Button control. ValueType String Default Value The programmatic identifier assigned to the control
Width | Description Gets or sets the width of this WebScheduler instance. ValueType Integer Default Value
Height | Description Gets or sets the height of this WebScheduler instance. ValueType Integer Default Value
AllowCreateEventInHoliday | Description Indicates whether the event is allowed to be created when the day is holiday. ValueType Boolean Default Value True
Holidays | Description Gets the collection of Holidays. ValueType Default Value
MarkedDayWithEvents | Description Specifies whether Calendar's number of WebScheduler containing event should be marked with bold style. ValueType Boolean Default Value True
ShowWeekNumbers | Description Specifies whether WebScheduler should show week number. ValueType Boolean Default Value True
UseDefaultStyle | Description Specifies whether WebScheduler should apply embedded default style for its appearance. ValueType Boolean Default Value True
EnableAnimation | Description Specifies whether animation of WebScheduler's CallOut should be enabled or disabled. ValueType Boolean Default Value True
EnableContextMenu | Description Specifies whether ContextMenu should appear when right clicking on event. ValueType Boolean Default Value False
GridLineStyle | Description Gets the collection of grid line style. ValueType Default Value
TimeBasedEventStyle | Description Gets the collection of time based event style. ValueType Default Value
CalendarSettings | Description Gets the collection of calendar settings. ValueType Default Value
ImagesSettings | Description Gets the collection of images settings. ValueType Default Value
LayoutSettings | Description Gets the collection of layout settings. ValueType Default Value
TextSettings | Description Gets the collection of text settings. ValueType Default Value
ViewSettings | Description Gets the collection of view settings. ValueType Default Value
WorkWeekSettings | Description Gets the collection of work week settings. ValueType Default Value
ClientSideEvents | Description Contains client side events supported by WebScheduler. ValueType Default Value
DataEditing | Description Gets the collection of data editing. ValueType Default Value
Resources | Description Gets the collection of Resources. ValueType Default Value
Categories | Description Gets the collection of Categories. ValueType Default Value
EditingField | Description The data collection used by WebScheduler as the CallOut's EditingField. ValueType Default Value

WebScheduler Methods

GetElement Description
Gets any element by specifying valid values in the parameters.

Parameters

Remarks

Return Value

Samples

GetCellElement Description
Gets WebScheduler's cell element by specifying valid values in the parameters.

Parameters
date
The date of the cell to be retrieved.

resourceID
Specifies the resourceID of the cell to be retrieved.

getAllDayArea
Determines whether hour area or all-day area should be retrieved.

Remarks

Return Value

Samples

function GetCellElement()
{
    var scheduler = ISGetObject("WebScheduler1");
    var el = scheduler.GetCellElement(new Date(2009, 9, 1, 9, 10, 10), 1, true);

    if (el != null)
        el.style.backgroundColor = "red";
}
GetCellElements Description
Gets WebScheduler's multiple cell elements by specifying valid values in the parameters.

Parameters
StartTime
Specifies the start time of the date range.

EndTime
Specifies the end time of the date range.

ResouceID
Specifies the resource id of the cell to be retrieved.

DatePartType
Specifies which part of the date should be used to retrieve the cell elements.

Remarks

Return Value

Samples

function GetCellElementsByDate()

{
      var s = ISGetObject("WebScheduler1" );

      var arr = new ISArray();
      arr.Add(new WebSchedulerDateRange(new Date(2008, 2, 18, 6, 0, 0), new Date(2008, 2, 20, 7, 0, 0), 2, "Date"));

      var elements = s.GetCellElements(arr);

      SetBackgroundColor(elements);
}
GoToDate Description
Navigates to a specific date.

Parameters
Date
Specifies the date.

Remarks

Return Value

Samples

ScrollToViewByElement Description
Scrolls Timeline view horizontally and vertically to the specified element.

Parameters
element
Specifies the element.

Remarks

Return Value

Samples

HideResourcesFrame Description
Hides the resource table section below calendar section.

Parameters

Remarks

Return Value

Samples

ShowResourcesFrame Description
Shows the resource table section below calendar section.

Parameters

Remarks

Return Value

Samples

DoResize Description
Performs resize in WebScheduler.

Parameters

Remarks

Return Value

Samples

GoToToday Description
Navigates to today date.

Parameters

Remarks

Return Value

Samples

GetResourceById Description
Gets a specific resource object by its id.

Parameters
id
Specifies the resource's id.

Remarks

Return Value

Samples

ValidateDisabledTime Description
Checks whether defined StartDate and EndDate are validate disabled time.

Parameters
startDate
Specifies the start date.

endDate
Specifies the end date.

resourceID (optional)
specifies the resource id of the cell to be retrieved.

Remarks

Return Value

Samples

ShowAllEvents Description
Shows all events when client paging is enabled in Timeline view and client paging mode is set to EventPageSize.

Parameters

Remarks

Return Value

Samples

SetTimeInterval Description
Sets the time interval of the view.

Parameters
interval
Specifies the interval time.

Remarks

Return Value

Samples

GetSelectedEvent Description
Gets the event selected.

Parameters

Remarks

Return Value

Samples

GetSelectedDateArea Description
Gets the selected date area.

Parameters

Remarks

Return Value

Samples

GetDateTimeByCellElement Description
Gets the date time based on cell element specified.

Parameters
cellEl ( )
The cell element of WebScheduler's view.

flag ( )
A value that indicates the format of the time whether its Date only or a DateTime value

Remarks

Return Value

Samples

GetStartDateOfWeek Description
Gets the start date of week of a specific date.

Parameters
date (datetime )
The date specified by user.

Remarks

Return Value

Samples

GetEndDateOfWeek Description
Gets the end date of week of a specific date.

Parameters
date (datetime )
The date specified by user.

Remarks

Return Value

Samples

GetStartDateOfMonth Description
Gets the start date of month of a specific date.

Parameters
date (datetime )
The date specified by user.

Remarks

Return Value

Samples

GetEndDateOfMonth Description
Gets the end date of month of a specific date.

Parameters
date (datetime )
The date specified by user.

Remarks

Return Value

Samples

GetEditingFormWindow Description
Gets the editing form window of WebScheduler.

Parameters

Remarks

Return Value

Samples

GetCalendarSchedulerFrame Description
Gets the calendar scheduler's frame.

Parameters

Remarks

Return Value

Samples

GetCalendarResourcesFrame Description
Gets the calendar resources frame.

Parameters

Remarks

Return Value

Samples

GetSchedulerFrame Description
Gets the scheduler's frame.

Parameters

Remarks

Return Value

Samples

GetSchedulerTableFrame Description
Gets the scheduler's table frame.

Parameters

Remarks

Return Value

Samples

GetSchedulerHeader Description
Gets the scheduler's header.

Parameters

Remarks

Return Value

Samples

SetSchedulerHeaderText Description
Sets the scheduler's header text.

Parameters
text ( )
text value.

Remarks

Return Value

Samples

GetHeaderTextFrame Description
Gets the header's frame text.

Parameters

Remarks

Return Value

Samples

GetSchedulerMonthContent Description
Gets the content of scheduler's month.

Parameters

Remarks

Return Value

Samples

GetSchedulerYearQuarterContent Description
Gets the content of scheduler's year quarter.

Parameters

Remarks

Return Value

Samples

GetSchedulerAgendaContent Description
Gets the content of scheduler's agenda.

Parameters

Remarks

Return Value

Samples

GetViewHeaderFrame Description
Gets the view header's frame.

Parameters

Remarks

Return Value

Samples

GetViewHeaderDay Description
Gets the view header's day.

Parameters

Remarks

Return Value

Samples

GetViewHeaderWeek Description
Gets the view header's week.

Parameters

Remarks

Return Value

Samples

GetViewHeaderMonth Description
Gets the view header's month.

Parameters

Remarks

Return Value

Samples

GetViewHeaderQuarter Description
Gets the view header's quarter.

Parameters

Remarks

Return Value

Samples

GetViewHeaderYear Description
Gets the view header's year.

Parameters

Remarks

Return Value

Samples

GetViewHeaderAgenda Description
Gets the view header's agenda.

Parameters

Remarks

Return Value

Samples

GetViewHeaderWeekOptions Description
Gets the options view header's week.

Parameters

Remarks

Return Value

Samples

GetViewHeaderCollapse Description
Gets the view header's collapse.

Parameters

Remarks

Return Value

Samples

GetViewHeaderCollapseImage Description
Gets the collapse image of view header.

Parameters

Remarks

Return Value

Samples

GetViewHeaderMenu Description
Gets the view header's menu.

Parameters

Remarks

Return Value

Samples

GetViewHeaderMenuImage Description
Gets the image of view header's menu.

Parameters

Remarks

Return Value

Samples

GetWorkWeekRadio Description
Gets the work week radio.

Parameters

Remarks

Return Value

Samples

GetFullWeekRadio Description
Gets the full week radio.

Parameters

Remarks

Return Value

Samples

GetSchedulerAgendaAction Description
Gets the action of scheduler's agenda.

Parameters

Remarks

Return Value

Samples

GetDayDayHeader Description
Gets the day's day header.

Parameters

Remarks

Return Value

Samples

GetWeekDayHeader Description
Gets the week's day header.

Parameters

Remarks

Return Value

Samples

GetDayContent Description
Gets the day's content.

Parameters

Remarks

Return Value

Samples

GetWeekContent Description
Gets the week's content.

Parameters

Remarks

Return Value

Samples

GetResourcesFrame Description
Gets the resources frame.

Parameters

Remarks

Return Value

Samples

GetResourcesTable Description
Gets the resources table.

Parameters

Remarks

Return Value

Samples

GetResourceCheckBox Description
Gets the checkbox of resource.

Parameters
ResourceId ( )

Remarks

Return Value

Samples

ShowResources Description
Shows the resources.

Parameters
selectedResources ( )

Remarks

Return Value

Samples

HideResources Description
Hides the resources.

Parameters
selectedResources ( )

Remarks

Return Value

Samples

GetCallOutElement Description
Gets the element of callout.

Parameters

Remarks

Return Value

Samples

GetCallOutCloseIcon Description
Gets the close icon of callout.

Parameters

Remarks

Return Value

Samples

GetCallOutTopPointerElement Description
Gets the top pointer element of callout.

Parameters

Remarks

Return Value

Samples

GetCallOutBottomPointerElement Description
Gets the bottom pointer element of callout.

Parameters

Remarks

Return Value

Samples

GetCallOutContainerElement Description
Gets the container element of callout.

Parameters

Remarks

Return Value

Samples

GetCallOutDataElement Description
Gets the data element of callout.

Parameters

Remarks

Return Value

Samples

GetCallOutDateElement Description
Gets the date element of callout.

Parameters

Remarks

Return Value

Samples

GetCallOutAddButton Description
Gets the add button of callout.

Parameters

Remarks

Return Value

Samples

GetCallOutEditButton Description
Gets the edit button of callout.

Parameters

Remarks

Return Value

Samples

GetCallOutDeleteButton Description
Gets the delete button of callout.

Parameters

Remarks

Return Value

Samples

GetCallOutEditingField Description
Gets the editing field of callout.

Parameters
s ( WebScheduler object )
Gets the WebScheduler's object.

index ( Integer )
Gets the TD position of callout.

Remarks

Return Value

Samples

GetCallOutTDEditingField Description
Gets the TD elemet of callout's editing field.

Parameters
s ( WebScheduler object )
Gets the WebScheduler's object.

index ( Integer )
Gets the TD position of callout.

Remarks

Return Value

Samples

CallOutSetText Description
Sets the text of callout Date element's title.

Parameters
text ( string )
The text used for date element's title.

Remarks

Return Value

Samples

CallOutSetWidth Description
Sets the width of callout.

Parameters
width ( int )
The width of callout.

Remarks

Return Value

Samples

CallOutSetHeight Description
Sets the height of callout.

Parameters
height ( int )
The height of callout.

Remarks

Return Value

Samples

ShowCallOut Description
Shows the callout in x and y.

Parameters
x ( int )
The x position of callout.

y ( int )
The y position of callout.

Remarks

Return Value

Samples

HideCallOut Description
Hides the callout.

Parameters

Remarks

Return Value

Samples

RenderCallOut Description
Renders the callout.

Parameters

Remarks

Return Value

Samples

Refresh Description
Refresh the data in WebScheduler.

Parameters

Remarks

Return Value

Samples

RefreshAll Description
Invokes full refresh action to the WebScheduler. This method will refresh the whole WebScheduler, including its structure.

Parameters

Remarks

Return Value

Samples

RefreshView Description
Refresh the view in WebScheduler.

Parameters

Remarks

Return Value

Samples

InsertEvent Description
Inserts event to WebScheduler.

Parameters
item ( )
The event object that going to be inserted.

refresh ( )
A value indicating whether a full refresh is needed after the process.

Remarks

Return Value

Samples

InsertRecurringEvent Description
Inserts recurring event to WebScheduler.

Parameters
item ( )
The recurring event object that going to be inserted.

refresh ( )
A value indicating whether a full refresh is needed after the process.

Remarks

Return Value

Samples

SetSelectedViewMode Description
Sets the selected view mode.

Parameters
viewMode ( )
A value indicating the view mode of the WebScheduler ("Day, Week", "Month", "Year", "Quarter", "Agenda").

Remarks

Return Value

Samples

CreateNewEvent Description
Creates new event in WebScheduler.

Parameters

Remarks

Return Value

Samples

CreateNewRecurringEvent Description
Creates new recurring event in WebScheduler.

Parameters

Remarks

Return Value

Samples

InitializeEventView Description
Initializes the event view.

Parameters
eventView ( )
EventView of an event's object.

Remarks

Return Value

Samples

CreateNewEventView Description
Creates new event view in WebScheduler.

Parameters

Remarks

Return Value

Samples

CreateNewCategory Description
Creates new category in WebScheduler.

Parameters

Remarks

Return Value

Samples

CreateNewResource Description
Creates new resource in WebScheduler.

Parameters

Remarks

Return Value

Samples

EditEvent Description
The method is used to display the editing form.

Parameters
eventView ( )
EventView of an event's object.

eventType ( )
type of the Event ("Exception", "RecurringEvent").

Remarks

Return Value

Samples

ShowEditingForm Description
Shows the editing form in WebScheduler.

Parameters
action ( )
A value indicating the action will be perform in editing form ("New", "Edit").

mode ( )
A value indicating the type of event (only applicable for new action).

eventView ( )
EventView of an event's object.

eventType ( )
Type of the Event ("Exception", "RecurringEvent").

Remarks

Return Value

Samples

IsDesktopManagerExisted Description
Determines whether DesktopManager is existed.

Parameters

Remarks

Return Value

Samples

SetBusy Description
Sets busy mode.

Parameters

Remarks

Return Value

Samples

SetIdle Description
Sets idle mode.

Parameters

Remarks

Return Value

Samples

RefreshResources Description
Refresh all resources.

Parameters

Remarks

Return Value

Samples


WebSchedulerClientSideEvents

WebSchedulerClientSideEvents
Send Feedback
Intersoft WebScheduler > Client-side References > WebSchedulerClientSideEvents

Glossary Item Box

WebSchedulerClientSideEvents Properties

OnAfterAdd | Description Gets or sets the event handler when insert is completed. ValueType string Default Value -
OnAfterDelete | Description Gets or sets the event handler when delete is completed. ValueType string Default Value -
OnAfterEdit | Description Gets or sets the event handler when update is completed. ValueType string Default Value -
OnAfterRenderCalendar | Description Gets or sets the event handler after render calendar is completed. ValueType string Default Value -
OnAfterRenderView | Description Gets or sets the event handler after render view is completed. ValueType string Default Value -
OnAfterTimelineViewSwitch | Description Gets or sets the event handler after Timeline view switch is completed. ValueType string Default Value -
OnAfterViewSwitched | Description Gets or sets the event handler after scheduler view switch action. ValueType string Default Value -
OnBackNavigation | Description Gets or sets the event handler when back navigation action, in scheduler view and calendar, is about to be performed. ValueType string Default Value -
OnBeforeAdd | Description Gets or sets the event handler before update is executed. ValueType string Default Value -
OnBeforeDelete | Description Gets or sets the event handler when delete is executed. ValueType string Default Value -
OnBeforeEdit | Description Gets or sets the event handler when update is executed. ValueType string Default Value -
OnBeforeRequest | Description Gets or sets the event handler before request is posted. ValueType string Default Value -
OnBeforeTimelineViewSwitch | Description Gets or sets the event handler before Timeline view switch is completed. ValueType string Default Value -
OnBeforeViewSwitched | Description Gets or sets the event handler before scheduler view switch action. ValueType string Default Value -
OnCallOutClose | Description Gets or sets the event handler when WebScheduler callout is closed. ValueType string Default Value -
OnCallOutInitialize | Description Gets or sets the event handler when initialize WebScheduler callout. ValueType string Default Value -
OnCallOutShow | Description Gets or sets the event handler when WebScheduler callout is shown. ValueType string Default Value -
OnCellDoubleClicked | Description Gets or sets the event handler when a cell is being double clicked. ValueType string Default Value -
OnCellSelected | Description Gets or sets the event handler when a cell is selected. ValueType string Default Value -
OnContextMenu | Description Gets or sets the event handler when the context menu is being shown. ValueType string Default Value -
OnEditingFormCancel | Description Gets or sets the event handler when the cancel button in editing form is clicked. ValueType string Default Value -
OnEditingFormClose | Description Gets or sets the event handler when the editing form is being closed. ValueType string Default Value -
OnEditingFormInitialize | Description Gets or sets the event handler when the editing form is being initialized. ValueType string Default Value -
OnEditingFormSave | Description Gets or sets the event handler when the save button in editing form is clicked. ValueType string Default Value -
OnEditingFormShow | Description Gets or sets the event handler when the editing form is being shown. ValueType string Default Value -
OnEventBound | Description Gets or sets the event handler when Event is bound. ValueType string Default Value -
OnEventSelected | Description Gets or sets the event handler when an event is selected. ValueType string Default Value -
OnForwardNavigation | Description Gets or sets the event handler when forward navigation action, in scheduler view and calendar, is about to be performed. ValueType string Default Value -
OnMultipleCellSelected | Description Gets or sets the event handler when multiple dates are selected. ValueType string Default Value -
OnResponse | Description Gets or sets the event handler on response. ValueType string Default Value -
OnTimelineCustomResource | Description Gets or sets the event handler on Timeline's Custom Resource. ValueType string Default Value -
OnValidateDisabledTime | Description Determines the custom validation result. ValueType boolean Default Value -


WebSchedulerCalendarSettings

WebSchedulerCalendarSettings
Send Feedback
Intersoft WebScheduler > Client-side References > WebSchedulerCalendarSettings

Glossary Item Box

WebSchedulerCalendarSettings Properties

AllowCollapse | Description Determines a value whether AllowCollapse is applied. ValueType Default Value
HideCalendarInitially | Description Hides the calendar when the page loads initially. ValueType Default Value
NumberOfMonthDisplayed | Description Shows number of month in calendar. ValueType Default Value


WebSchedulerLayoutSettings

WebSchedulerLayoutSettings
Send Feedback
Intersoft WebScheduler > Client-side References > WebSchedulerLayoutSettings

Glossary Item Box

WebLayoutSettings Properties

RowHeight | Description Sets the row's height. ValueType Integer Default Value
AllDayEventHeight | Description Sets the all day event's height. ValueType Integer Default Value


WebSchedulerTextSettings

WebSchedulerTextSettings
Send Feedback
Intersoft WebScheduler > Client-side References > WebSchedulerTextSettings

Glossary Item Box

WebSchedulerTextSettings Properties

RecurrenceTextSettings Description
Sets the recurrence text in WebScheduler.

ValueType

Default Value


WebSchedulerAgendaView

WebSchedulerAgendaView
Send Feedback
Intersoft WebScheduler > Client-side References > WebSchedulerAgendaView

Glossary Item Box

WebSchedulerAgendaView Properties

Enabled | Description Enables the agenda view in WebScheduler. ValueType Default Value
ShowTotalEvents | Description Indicates whether TotalEvents should be shown. ValueType Default Value


WebSchedulerDayView

WebSchedulerDayView
Send Feedback
Intersoft WebScheduler > Client-side References > WebSchedulerDayView

Glossary Item Box

WebSchedulerDayView Properties

Enabled | Description Enables day view in WebScheduler. ValueType Default Value
EnableSplitView | Description Indicates whether split view is enabled. ValueType Default Value
ShowAllDayEventArea | Description Indicates whether AllDayEvent area should be shown. ValueType Default Value


WebSchedulerMonthView

WebSchedulerMonthView
Send Feedback
Intersoft WebScheduler > Client-side References > WebSchedulerMonthView

Glossary Item Box

WebSchedulerMonthView Properties

Enabled | Description Enables month view in WebScheduler. ValueType Default Value
EnableSplitView | Description Indicates whether split view is enabled. ValueType Default Value
ShowTotalEvents | Description Indicates whether TotalEvents should be shown. ValueType Default Value


WebSchedulerQuarterView

WebSchedulerQuarterView
Send Feedback
Intersoft WebScheduler > Client-side References > WebSchedulerQuarterView

Glossary Item Box

WebSchedulerQuarterView Properties

Enabled | Description Enables quarter view in WebScheduler. ValueType Default Value
ShowTotalEvents | Description Indicates whether TotalEvents should be shown. ValueType Default Value


WebSchedulerWeekView

WebSchedulerWeekView
Send Feedback
Intersoft WebScheduler > Client-side References > WebSchedulerWeekView

Glossary Item Box

WebSchedulerWeekView Properties

Enabled | Description Enables week view in WebScheduler. ValueType Default Value
EnableSplitView | Description Indicates whether split view is enabled. ValueType Default Value
ShowAllDayEventArea | Description Indicates whether AllDayEvent area should be shown. ValueType Default Value


WebSchedulerYearView

WebSchedulerYearView
Send Feedback
Intersoft WebScheduler > Client-side References > WebSchedulerYearView

Glossary Item Box

WebSchedulerYearView Properties

Enabled | Description Enables year view in WebScheduler. ValueType Default Value
MinimumHeight | Description Sets the minimum height in year view. ValueType Default Value
ShowTotalEvents | Description Indicates whether TotalEvents should be shown. ValueType Default Value


WebSchedulerViewSettings

WebSchedulerViewSettings
Send Feedback
Intersoft WebScheduler > Client-side References > WebSchedulerViewSettings

Glossary Item Box

WebSchedulerViewSettings Properties

AgendaView | Description Configures the settings used by agenda view. ValueType Default Value
CustomViews | Description Configures the custom settings used by view. ValueType Default Value
DayView | Description Configures the settings used by day view. ValueType Default Value
HighlightTodayDate | Description Indicates whether WebScheduler should highlight today date. ValueType Default Value
MonthView | Description Configures the settings used by month view. ValueType Default Value
QuarterView | Description Configures the settings used by quarter view. ValueType Default Value
WeekView | Description Configures the settings used by week view. ValueType Default Value
YearView | Description Configures the settings used by year view. ValueType Default Value


WebSchedulerWorkWeekSettings

WebSchedulerWorkWeekSettings
Send Feedback
Intersoft WebScheduler > Client-side References > WebSchedulerWorkWeekSettings

Glossary Item Box

WebSchedulerWorkWeekSettings Properties

Friday | Description Indicates whether Friday is work week. ValueType Default Value
Monday | Description Indicates whether Monday is work week. ValueType Default Value
Saturday | Description Indicates whether Saturday is work week. ValueType Default Value
Sunday | Description Indicates whether Sunday is work week. ValueType Default Value
Thursday | Description Indicates whether Thursday is work week. ValueType Default Value
Tuesday | Description Indicates whether Tuesday is work week. ValueType Default Value
Wednesday | Description Indicates whether Wednesday is work week. ValueType Default Value


WebSchedulerResource

WebSchedulerResource
Send Feedback
Intersoft WebScheduler > Client-side References > WebSchedulerResource

Glossary Item Box

WebSchedulerResource Properties

Events | Description The Events collection used by WebScheduler. ValueType Default Value
ResourceID | Description Specifies the ID of the Resource. ValueType Default Value
ResourceColor | Description Specifies the color of the Resource. ValueType Default Value
ResourceName | Description Specifies the name of the Resource. ValueType Default Value
Description | Description Specifies the description of the Resource. ValueType Default Value
Location | Description Specifies the location of the Resource. ValueType Default Value

WebSchedulerResource Methods

Insert Description
Inserts the WebScheduler's resource into existing collection.

Parameters
s ( scheduler object )

Remarks

Return Value

Samples

Update Description
Updates the WebScheduler's resource.

Parameters

Remarks

Return Value

Samples

Delete Description
Deletes the WebScheduler's resource from existing collection.

Parameters

Remarks

Return Value

Samples


WebSchedulerEventBase

WebSchedulerEventBase
Send Feedback
Intersoft WebScheduler > Client-side References > WebSchedulerEventBase

Glossary Item Box

WebSchedulerEventBase Properties

EventID | Description Specifies the ID of the event. ValueType Default Value
ResourceID | Description Specifies the ID of the resource. ValueType Default Value
AllDayEvent | Description Indicates whether AllDayEvent is enabled. ValueType Default Value
ReminderTimeSpan | Description Specifies the time used for reminder. ValueType Default Value
StartTime | Description Specifies the start time of the event. ValueType Default Value
EndTime | Description Specifies the end time of the event. ValueType Default Value

WebSchedulerEventBase Methods

IsAllDayEvent Description
Determines whether the event is an AllDay event or not.

Parameters

Remarks

Return Value

Samples

GetStartTime Description
Gets the start time of current event.

Parameters

Remarks

Return Value

Samples

GetEndTime Description
Gets the end time of current event.

Parameters

Remarks

Return Value

Samples

HasReminder Description
Determines whether the event has a reminder or not.

Parameters

Remarks

Return Value

Samples


WebScheduler Global Functions
Send Feedback
Intersoft WebScheduler > Client-side References > WebScheduler Global Functions

Glossary Item Box

WebScheduler Global Functions

WebSchedulerGridLineStyle Description
Provides interactive styles for Grid line.

Return Value

Samples

WebSchedulerTimeBasedEventStyle Description
Provides interactive styles for TimeBasedEvent.

Return Value

Samples

WebSchedulerImagesSettings Description
Provides the settings that control the images in WebScheduler.

Return Value

Samples

WebSchedulerRecurrenceTextSettings Description
Provides the setting that control the recurrence text in WebScheduler.

Return Value

Samples

WebSchedulerEditingField Description
Provides the settings to control the editing field in WebScheduler's callout.

Return Value

Samples

WebSchedulerDataEditing Description
Provides the settings that control the behaviors of the data editing in WebScheduler.

Return Value

Samples

WebSchedulerClientSideEvents Description
Provides client side events supported by WebScheduler.

Return Value

Samples


Product Support

Product Support
Send Feedback
Intersoft WebScheduler > Product Support

Glossary Item Box

This section contains product support in WebScheduler.NET.

In This Section

Bug Reports

Support Options


Bug Reports

Bug Reports
Send Feedback
Intersoft WebScheduler > Product Support > Bug Reports

Glossary Item Box

Please submit any bugs or product issues to technical@intersoftpt.com

When submitting the bug report, make sure you have following information to avoid multiple communication roundtrip:

  • Product Edition (if applicable)
  • Full Product Version. Eg: 1.0.1500
  • Browsers (with Full Version, including Service Packs or HotFixes if any)
  • Operating System (with Full Version, including Service Packs or HotFixes if any)
  • Development Environment Products
  • Development Environment Versions
  • Affected Machines: Development, Production Server or Both
  • Monitors: Single or Dual

You also might need to provide issue-specific information such as:

  • Current result/behavior
  • Expected result/behavior
  • Steps to reproduce
  • Working/Compilable Samples


Support Options

Support Options
Send Feedback
Intersoft WebScheduler > Product Support > Support Options

Glossary Item Box

WebScheduler.NET is developed and fully supported by Intersoft Solutions Corp. The company provides several methods for registered customers to obtain technical supports.

Online Support

All of WebScheduler.NET users have free access to our online support at www.intersoftpt.com which includes latest product updates, bug fixes, FAQ, hundreds of Knowledge Base Articles.

Standard Email Support

You can also send email to technical@intersoftpt.com for product troubleshooting or bugs. Please provides information on the product version, operating system name and version as well as your development environment and its version. Your email will be answered shortly by our technical support team.

The turnaround time for standard email support is 72 hours (at the latest).

Before sending out your email, we highly recommend you to initially search for the information on locally installed Reference and Online Support.

Developer Network Support

The company provides a rich web-based forums for registered customers to discuss about the product. You may find information and answer to your questions in the forums, or simply posting your message in the forums and our technical support team will answer it in short time.

To access the Developer Network, please go to Intersoft website and click on Developer Network.

Login details are required to access Developer Network. Please refer to your original order receipt sent from Intersoft Accounts. If you do not get the automated order receipt, please contact accounts@intersoftpt.com

Priority Support Options

The NEW Priority Support option allows registered customers to obtain technical support via direct e-mail or telephone support from our Senior Support Engineer.

This option is designated for advanced customers who require faster response time. The inquiries types are mostly intermediate to advanced involving application-specific scenarios, minor feature requests, quick patches and more.

For more information about the Priority Support pricing and online purchase, please visit Intersoft Solutions web site at http://www.intersoftpt.com

Phone Support

Phone Support is currently available only for registered customers who have purchased Priority Support. You can reach Technical Support through following numbers:

  • +62 21 25556680
  • +62 21 25556681
Please have your UserID ready when calling.

For pre-sales phone support, you may contact our Authorized Distributor at no cost.


Licensing

Licensing
Send Feedback
Intersoft WebScheduler > Licensing

Glossary Item Box

This section contains licensing in WebScheduler.NET.

In This Section

License Agreement

Copyright Information


License Agreement

License Agreement
Send Feedback
Intersoft WebScheduler > Licensing > License Agreement

Glossary Item Box

Software License Agreement for Intersoft Solutions Corp.

VERY IMPORTANT -- By installing the WebScheduler.NET Version 3.0 software (herein the 'SOFTWARE') developed by Intersoft Solutions Corp (hereinafter the 'VENDOR'), you are accepting the following License Agreement.

I. LICENSE AGREEMENT. This is a legal agreement between you (either an individual or a single entity) and VENDOR. By installing the SOFTWARE you are agreeing to be bound by the terms of this agreement. If you do not agree to the terms of this agreement, please kindly click the [CANCEL] icon to exit now. The installation process will be immediately terminated.

II. OWNERSHIP; GRANT OF LICENSE. This is a license agreement and NOT an agreement for sale. The VENDOR hereby grants to you, and you accept, a non-exclusive, non-transferable license to use, copy and modify the SOFTWARE only as authorized below.

III. PERMITTED USES. This LICENSE grants you the following rights:

A. The SOFTWARE is licensed per individual developer. You may make copies on more than one computer, as long as the use of the SOFTWARE is by the same developer. If you have purchased a "multi-pack" license, you may use a copy of the SOFTWARE identified in the multi-pack on the number of computers associated with the multi-pack (e.g. a five user multi-pack allows you to use the SOFTWARE on up to five computers concurrently or by five different developers, the ten user multi-pack on up to ten computers concurrently or by ten different developers). The SOFTWARE is in "use" on a computer when it is loaded into temporary memory (i.e. RAM) or installed into permanent memory (e.g. hard disk, CD-ROM, or other storage devise) of that computer. However, installation on a network server for the sole purpose of internal distribution to one or more other computer(s) shall not constitute "use" for which a separate license is required, provided you have a separate license for each computer to which the SOFTWARE is distributed.

B. Solely with respect to electronic documents included with the SOFTWARE, you may make a copy (either in hardcopy or electronic form) for each developer for which the Software has been licensed as described in Section III.A, above; provided, that such copies shall be used only by such developer for internal purposes and are not to be republished or distributed to any other third party.

C. Runtime and redistributable files. You may deploy your web applications using the SOFTWARE to any number of production server or clients with no additional charges. The SOFTWARE runtime files shouldn�??t be modified in any ways prior to deploying and all copyright notices should be retain.

IV. PROHIBITED USES. You may not, without the prior written permission of the VENDOR:

A. Disassemble, decompile or "unlock", decode or otherwise reverse translate or engineer, or attempt in any manner to reconstruct or discover any source code or underlying algorithms of SOFTWARE provided in object code form only.

B. Use, copy, modify, or merge copies of the SOFTWARE and any accompanying documents except as permitted in this LICENSE.

C. Transfer, rent, lease, or sublicense the SOFTWARE.

D. Separate the software programs comprising the SOFTWARE for use by more than one user at a time.

V. COPYRIGHT. All title and copyrights in and to the SOFTWARE (including but not limited to any images, photographs, animation, video, audio, music, text and "applets" incorporated into the SOFTWARE) and the accompanying printed materials are owned by the VENDOR or its suppliers. The SOFTWARE is protected by Indonesian copyright laws and international treaty provisions. All rights are reserved worldwide. You must treat the SOFTWARE like any other copyrighted material, except that you may, in addition to the copies permitted in this LICENSE, make one copy of the SOFTWARE solely for backup or archival purposes. No part of the accompanying printed materials may be reproduced, transmitted, transcribed, stored in any retrieval system, or translated into any language by any means without the express prior written permission of the VENDOR.

VI. TERMINATION

A. This LICENSE and your right to use the SOFTWARE will terminate immediately without notice from the VENDOR if you fail to comply with the terms and conditions of this LICENSE. Upon termination, you agree to destroy the SOFTWARE, including all accompanying documents and copies. This is in addition to and not in lieu of any criminal, civil or other remedies available to the VENDOR.

B. The VENDOR has the right to perform temporary or permanent TERMINATION to this LICENSE upon the detection of license violation described in Section III A. The SOFTWARE has implemented Installation Tracker which is used to increment the number of installations during the installation of SOFTWARE. Related to Section III A, the LICENSE will be temporarily or permanently terminated upon the detection of unauthorized transfer or distribution of the LICENSE to either private or public web site, or to ANY medium.

C. ANY VIOLATION TO THE COPYRIGHT, OR TO THIS LICENSE AGREEMENT, MAY RESULT IN SEVERE CIVIL AND CRIMINAL PENALTIES, AND WILL BE PROSECUTED TO THE MAXIMUM EXTENT POSSIBLE UNDER THE LAW.

VII. LIMITED WARRANTY.

A. The VENDOR warrants that the SOFTWARE will perform substantially in accordance with the accompanying printed materials or officially "online" documented materials for a period of thirty (30) days from the date of receipt. The VENDOR does not warranty that the SOFTWARE will be error-free.

B. Your exclusive remedy under the performance warranty set forth in Section X.A, shall be, at VENDOR's option, either (a) return of the purchase price paid, or (b) repair or replacement of the defective SOFTWARE. SOFTWARE purchased other than directly from the VENDOR shall be returned to the place it was purchased. This limited warranty is void if failure of the SOFTWARE has resulted from accident, abuse, or misapplication. Any replacement SOFTWARE will be warranted for the remainder of the original thirty (30) day period.


Copyright Information

Copyright Information
Send Feedback
Intersoft WebScheduler > Licensing > Copyright Information

Glossary Item Box

Information in this document, including URL and other Internet Web site references, is subject to change without notice. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Intersoft Solutions Corp.

Intersoft Solutions, Intersoft Solutions Logo, A Better Web Experience, WebUI.NET Framework, WebUI.NET Framework Logo, WebUI Studio.NET Family, WebCombo.NET, WebGrid.NET Enterprise, WebInput.NET, WebUIControls.NET, ISDataSource.NET, WebDesktop.NET, WebTreeView.NET , WebAqua.NET, WebScheduler.NET are either trademarks or registered trademarks of Intersoft Solutions Corporation.

Copyright © 2000-2007 Intersoft Solutions Corp. All rights reserved.

ActiveX, Internet Explorer, Microsoft, Visual Basic, Visual Basic .NET, Visual C# .NET, Visual C++ .NET, Visual Studio, Visual Studio .NET, Windows, Windows 95, Windows 98, Windows 2000, Windows Millennium Edition, Windows .NET server family, Windows NT, Windows XP and Windows Vista are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

The names of actual companies and products mentioned herein may be the trademarks or registered trademarks of their respective owners.


Configure SmartWebResources in a new web application

Configure SmartWebResources in a new web application
Send Feedback

Glossary Item Box

As the best practice in using Intersoft 2007's product lines, you are recommended to perform the following steps after you have created a new web application or migrated an existing web application.

  1. Right click on one of the Intersoft's control instance. For instance, WebGrid1.
  2. Click Register SmartWebResources™ command in the context menu.

  3. In short time after you clicked the command, you should receive a message prompt similar to the following:
    "SmartWebResources has been successfully configured for this web application."

If you are receiving an error message, it is likely that you have not installed the product properly. Please note that you can't enable this feature in older products (non 2007-platform products).

To learn more about SmartWebResources, please read Introducing SmartWebResources™.


Introducing SmartWebResources™

Introducing SmartWebResources™
Send Feedback

Glossary Item Box

ASP.NET 2.0 introduced Web Resources feature, which allows developers to embed the client resources into assemblies. They are fetched through the built-in WebResource.axd HTTP Handler that is specially designed for this purpose.

However, our SmartWebResources technology does not use the built-in ASP.NET 2.0�??s Web Resources due to several limitations and inflexibility and thus does not meet our requirements and does not suit into our products mechanism.

SmartWebResources�?� is designed to overcome the limitations of ASP.NET 2.0�??s Web Resources. Furthermore, it is developed with more advanced functionality and with better performance since it does not use Reflection.

SmartWebResources�?� takes advantage of custom HTTP Handler extensibility and tightly integrated into WebUI.NET Framework runtime to deliver high performance, secure and highly reusable components.


Assembly Overview

ISNet.WebUI.WebScheduler Assembly
See Also Send Feedback

Glossary Item Box

Namespaces

Namespace | Description
ISNet.WebUI.WebScheduler |


Getting Started - Intersoft WebScheduler Documentation

Getting Started
Send Feedback

Glossary Item Box


Introduction - Intersoft WebScheduler Documentation

Introduction
Send Feedback

Glossary Item Box


WebSchedulerActiveDayStyle Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerActiveDayStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerActiveDayStyle Class : WebSchedulerActiveDayStyle Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerActiveDayStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerActiveDayStyle Class
WebSchedulerActiveDayStyle Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerActiveDayStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerActiveDayStyle
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerActiveDayStyle Class
WebSchedulerActiveDayStyle Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerActiveDayStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerActiveDayStyle Class
WebSchedulerActiveDayStyle Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerActiveDayStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerActiveDayStyle
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerActiveDayStyle Class
WebSchedulerActiveDayStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerActiveDayStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerActiveDayStyle
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerActiveDayStyle Class
WebSchedulerActiveDayStyle Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerActiveDayStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerActiveDayStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerActiveDayStyle Class
WebSchedulerActiveDayStyle Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerActiveDayStyle Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerActiveDayStyle
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerActiveDayStyle Class
WebSchedulerActiveDayStyle Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerActiveDayStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerActiveDayStyle
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerActiveDayStyle Class
WebSchedulerActiveDayStyle Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerActiveDayStyle Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerActiveDayStyle

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerActiveDayStyle Class
WebSchedulerActiveDayStyle Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerActiveDayStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerActiveDayStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerActiveDayStyle Class
WebSchedulerActiveDayStyle Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerActiveDayStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerActiveDayStyle
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerActiveDayStyle Class
WebSchedulerActiveDayStyle Members


WebSchedulerAgendaView Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerAgendaView Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerAgendaView Class : WebSchedulerAgendaView Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerAgendaView Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerAgendaView Class
WebSchedulerAgendaView Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerAgendaView Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerAgendaView
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerAgendaView Class
WebSchedulerAgendaView Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerAgendaView Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerAgendaView Class
WebSchedulerAgendaView Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerAgendaView Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerAgendaView
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerAgendaView Class
WebSchedulerAgendaView Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerAgendaView Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerAgendaView
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerAgendaView Class
WebSchedulerAgendaView Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerAgendaView Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerAgendaView
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerAgendaView Class
WebSchedulerAgendaView Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerAgendaView Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerAgendaView
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerAgendaView Class
WebSchedulerAgendaView Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerAgendaView Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerAgendaView
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerAgendaView Class
WebSchedulerAgendaView Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerAgendaView Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerAgendaView

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerAgendaView Class
WebSchedulerAgendaView Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerAgendaView Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerAgendaView
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerAgendaView Class
WebSchedulerAgendaView Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerAgendaView Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerAgendaView
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerAgendaView Class
WebSchedulerAgendaView Members


WebSchedulerBinding Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerBinding Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerBinding Class : WebSchedulerBinding Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerBinding Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerBinding Class
WebSchedulerBinding Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerBinding Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerBinding
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerBinding Class
WebSchedulerBinding Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerBinding Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerBinding Class
WebSchedulerBinding Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerBinding Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerBinding
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerBinding Class
WebSchedulerBinding Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerBinding Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerBinding
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerBinding Class
WebSchedulerBinding Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerBinding Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerBinding
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerBinding Class
WebSchedulerBinding Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerBinding Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerBinding
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerBinding Class
WebSchedulerBinding Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerBinding Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerBinding
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerBinding Class
WebSchedulerBinding Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerBinding Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerBinding

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerBinding Class
WebSchedulerBinding Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerBinding Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerBinding
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerBinding Class
WebSchedulerBinding Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerBinding Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerBinding
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerBinding Class
WebSchedulerBinding Members


WebSchedulerCalendarSettings Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerCalendarSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCalendarSettings Class : WebSchedulerCalendarSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerCalendarSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCalendarSettings Class
WebSchedulerCalendarSettings Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCalendarSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCalendarSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCalendarSettings Class
WebSchedulerCalendarSettings Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCalendarSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCalendarSettings Class
WebSchedulerCalendarSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCalendarSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCalendarSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCalendarSettings Class
WebSchedulerCalendarSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCalendarSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCalendarSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCalendarSettings Class
WebSchedulerCalendarSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCalendarSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCalendarSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCalendarSettings Class
WebSchedulerCalendarSettings Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCalendarSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCalendarSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCalendarSettings Class
WebSchedulerCalendarSettings Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCalendarSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCalendarSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCalendarSettings Class
WebSchedulerCalendarSettings Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCalendarSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCalendarSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCalendarSettings Class
WebSchedulerCalendarSettings Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCalendarSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCalendarSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCalendarSettings Class
WebSchedulerCalendarSettings Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCalendarSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCalendarSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCalendarSettings Class
WebSchedulerCalendarSettings Members


WebSchedulerCategoriesBinding Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerCategoriesBinding Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoriesBinding Class : WebSchedulerCategoriesBinding Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerCategoriesBinding Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoriesBinding Class
WebSchedulerCategoriesBinding Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoriesBinding Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoriesBinding
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoriesBinding Class
WebSchedulerCategoriesBinding Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoriesBinding Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoriesBinding Class
WebSchedulerCategoriesBinding Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoriesBinding Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoriesBinding
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoriesBinding Class
WebSchedulerCategoriesBinding Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoriesBinding Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoriesBinding
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoriesBinding Class
WebSchedulerCategoriesBinding Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoriesBinding Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoriesBinding
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoriesBinding Class
WebSchedulerCategoriesBinding Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoriesBinding Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoriesBinding
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoriesBinding Class
WebSchedulerCategoriesBinding Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoriesBinding Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoriesBinding
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoriesBinding Class
WebSchedulerCategoriesBinding Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoriesBinding Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoriesBinding

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoriesBinding Class
WebSchedulerCategoriesBinding Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoriesBinding Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoriesBinding
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoriesBinding Class
WebSchedulerCategoriesBinding Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoriesBinding Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoriesBinding
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoriesBinding Class
WebSchedulerCategoriesBinding Members


WebSchedulerCategoryCollection Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerCategoryCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerCategoryCollection Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerCategoryCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerCategory>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerCategory>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerCategory>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebSchedulerCategoryCollection Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerCategoryCollection Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerCategoryCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerCategoryCollection Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerCategoryCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebSchedulerCategoryCollection Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerCategoryCollection Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerCategoryCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoryCollection Class : WebSchedulerCategoryCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerCategoryCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoryCollection Class
WebSchedulerCategoryCollection Members


Add Method

[image]
Intersoft WebScheduler Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoryCollection Class : Add Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Add( _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoryCollection
Dim item As ISNet.WebUI.INamedObject2

instance.Add(item)
C#
[__DynamicallyInvokableAttribute()]
public void Add(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Add(
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Add(
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Add(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Add(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoryCollection Class
WebSchedulerCategoryCollection Members


Clear Method

[image]
Intersoft WebScheduler Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoryCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoryCollection

instance.Clear()
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void Clear()
Delphi
public procedure Clear();
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function Clear();
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void Clear();
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoryCollection Class
WebSchedulerCategoryCollection Members


Contains Method

[image]
Intersoft WebScheduler Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoryCollection Class : Contains Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function Contains( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoryCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Contains(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.bool Contains(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Contains(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function Contains(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.bool Contains(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.bool Contains(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoryCollection Class
WebSchedulerCategoryCollection Members


CopyTo Method

[image]
Intersoft WebScheduler Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoryCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject2, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoryCollection
Dim array() As ISNet.WebUI.INamedObject2
Dim index As System.Integer

instance.CopyTo(array, index)
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void CopyTo(
   ISNet.WebUI.INamedObject2[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObject2array of;
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function CopyTo(
   array : ISNet.WebUI.INamedObject2[],
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void CopyTo(
   ISNet.WebUI.INamedObject2*[]* array,
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject2^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoryCollection Class
WebSchedulerCategoryCollection Members


Count Property

[image]
Intersoft WebScheduler Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoryCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoryCollection
Dim value As System.Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function get Count : System.int
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property System.int get_Count();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoryCollection Class
WebSchedulerCategoryCollection Members


CreateNewItem Method

[image]
Intersoft WebScheduler Documentation
CreateNewItem Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoryCollection Class : CreateNewItem Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateNewItem() As WebSchedulerCategory
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoryCollection
Dim value As WebSchedulerCategory

value = instance.CreateNewItem()
C#
public WebSchedulerCategory CreateNewItem()
Delphi
public function CreateNewItem(): WebSchedulerCategory;
JScript
public function CreateNewItem() : WebSchedulerCategory;
Managed Extensions for C++
public: WebSchedulerCategory* CreateNewItem();
C++/CLI
public:
WebSchedulerCategory^ CreateNewItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoryCollection Class
WebSchedulerCategoryCollection Members


GetEnumerator Method

[image]
Intersoft WebScheduler Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoryCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function GetEnumerator() As System.Collections.Generic.IEnumerator(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoryCollection
Dim value As System.Collections.Generic.IEnumerator(Of INamedObject2)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public System.Collections.Generic.IEnumerator<INamedObject2> GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.Generic.IEnumerator;
JScript
__DynamicallyInvokableAttribute()
public function GetEnumerator() : System.Collections.Generic.IEnumerator;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.Collections.Generic.IEnumerator<INamedObject2*>* GetEnumerator();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.Collections.Generic.IEnumerator<INamedObject2^>^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoryCollection Class
WebSchedulerCategoryCollection Members


GetNamedItem Method

[image]
Intersoft WebScheduler Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoryCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As WebSchedulerCategory
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoryCollection
Dim name As System.String
Dim value As WebSchedulerCategory

value = instance.GetNamedItem(name)
C#
public WebSchedulerCategory GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebSchedulerCategory;
JScript
public function GetNamedItem(
   name : System.String
) : WebSchedulerCategory;
Managed Extensions for C++
public: WebSchedulerCategory* GetNamedItem(
   System.string* name
)
C++/CLI
public:
WebSchedulerCategory^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoryCollection Class
WebSchedulerCategoryCollection Members


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoryCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoryCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoryCollection Class
WebSchedulerCategoryCollection Members


IndexOf Method

[image]
Intersoft WebScheduler Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoryCollection Class : IndexOf Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function IndexOf( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoryCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Integer

value = instance.IndexOf(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.int IndexOf(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function IndexOf(
    item: ISNet.WebUI.INamedObject2
): System.Integer;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function IndexOf(
   item : ISNet.WebUI.INamedObject2
) : System.int;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.int IndexOf(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoryCollection Class
WebSchedulerCategoryCollection Members


Insert Method

[image]
Intersoft WebScheduler Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoryCollection Class : Insert Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoryCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.Insert(index, item)
C#
[__DynamicallyInvokableAttribute()]
public void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Insert(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Insert(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoryCollection Class
WebSchedulerCategoryCollection Members


Item Property

[image]
Intersoft WebScheduler Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoryCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Default Property Item( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoryCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject2

instance.Item(index) = value

value = instance.Item(index)
C#
[__DynamicallyInvokableAttribute()]
public ISNet.WebUI.INamedObject2 this[
   System.int index
]; {get; set;}
Delphi
public  this: : ISNet.WebUI.INamedObject2;[
    index: System.Integer
]; read-write
JScript
__DynamicallyInvokableAttribute()
public  this[
   index : System.int
] get,set : ISNet.WebUI.INamedObject2
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property ISNet.WebUI.INamedObject2* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   ISNet.WebUI.INamedObject2* value
;
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property ISNet.WebUI.INamedObject2^ default [int] {
   ISNet.WebUI.INamedObject2^ get(System.int index);
   void set (System.int index, ISNet.WebUI.INamedObject2^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoryCollection Class
WebSchedulerCategoryCollection Members


Parent Property

[image]
Intersoft WebScheduler Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoryCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoryCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoryCollection Class
WebSchedulerCategoryCollection Members


Remove Method

[image]
Intersoft WebScheduler Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoryCollection Class : Remove Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function Remove( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoryCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Remove(item)
C#
[__DynamicallyInvokableAttribute()]
public System.bool Remove(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Remove(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
__DynamicallyInvokableAttribute()
public function Remove(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.bool Remove(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.bool Remove(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoryCollection Class
WebSchedulerCategoryCollection Members


RemoveAt Method

[image]
Intersoft WebScheduler Documentation
RemoveAt Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoryCollection Class : RemoveAt Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoryCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
[__DynamicallyInvokableAttribute()]
public void RemoveAt(
   System.int index
)
Delphi
public procedure RemoveAt(
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
public function RemoveAt(
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void RemoveAt(
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void RemoveAt(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoryCollection Class
WebSchedulerCategoryCollection Members


SerializerConstructor Method

[image]
Intersoft WebScheduler Documentation
SerializerConstructor Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoryCollection Class : SerializerConstructor Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializerConstructor( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoryCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializerConstructor(info, context)
C#
public void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializerConstructor(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializerConstructor(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoryCollection Class
WebSchedulerCategoryCollection Members


SetParent Method

[image]
Intersoft WebScheduler Documentation
SetParent Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategoryCollection Class : SetParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategoryCollection
Dim parent As System.Object

instance.SetParent(parent)
C#
public virtual void SetParent(
   System.object parent
)
Delphi
public procedure SetParent(
    parent: System.TObject
); virtual;
JScript
public function SetParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void SetParent(
   System.Object* parent
)
C++/CLI
public:
virtual void SetParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategoryCollection Class
WebSchedulerCategoryCollection Members


WebSchedulerCategory Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerCategory Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategory Class : WebSchedulerCategory Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerCategory Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategory Class
WebSchedulerCategory Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategory Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategory
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategory Class
WebSchedulerCategory Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategory Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategory Class
WebSchedulerCategory Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategory Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategory
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategory Class
WebSchedulerCategory Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategory Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategory
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategory Class
WebSchedulerCategory Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategory Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategory
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategory Class
WebSchedulerCategory Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategory Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategory
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategory Class
WebSchedulerCategory Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategory Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategory
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategory Class
WebSchedulerCategory Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategory Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategory

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategory Class
WebSchedulerCategory Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategory Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategory
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategory Class
WebSchedulerCategory Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerCategory Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerCategory
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerCategory Class
WebSchedulerCategory Members


WebSchedulerClientSideEvents Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerClientSideEvents Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : WebSchedulerClientSideEvents Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerClientSideEvents Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerClientSideEvents Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerClientSideEvents
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerClientSideEvents Class
WebSchedulerClientSideEvents Members


WebSchedulerDataEditing Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerDataEditing Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDataEditing Class : WebSchedulerDataEditing Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerDataEditing Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDataEditing Class
WebSchedulerDataEditing Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDataEditing Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDataEditing
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDataEditing Class
WebSchedulerDataEditing Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDataEditing Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDataEditing Class
WebSchedulerDataEditing Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDataEditing Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDataEditing
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDataEditing Class
WebSchedulerDataEditing Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDataEditing Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDataEditing
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDataEditing Class
WebSchedulerDataEditing Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDataEditing Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDataEditing
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDataEditing Class
WebSchedulerDataEditing Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDataEditing Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDataEditing
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDataEditing Class
WebSchedulerDataEditing Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDataEditing Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDataEditing
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDataEditing Class
WebSchedulerDataEditing Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDataEditing Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDataEditing

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDataEditing Class
WebSchedulerDataEditing Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDataEditing Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDataEditing
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDataEditing Class
WebSchedulerDataEditing Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDataEditing Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDataEditing
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDataEditing Class
WebSchedulerDataEditing Members


CanConvertFrom Method

[image]
Intersoft WebScheduler Documentation
CanConvertFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class : CanConvertFrom Method

Glossary Item Box

Overload List

Overload | Description
CanConvertFrom(Type) | (Inherited from System.ComponentModel.TypeConverter)
CanConvertFrom(ITypeDescriptorContext,Type) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members


CanConvertFrom(ITypeDescriptorContext,Type) Method

[image]
Intersoft WebScheduler Documentation
CanConvertFrom(ITypeDescriptorContext,Type) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > CanConvertFrom Method : CanConvertFrom(ITypeDescriptorContext,Type) Method

context
sourceType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function CanConvertFrom( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal sourceType As System.Type _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim sourceType As System.Type
Dim value As System.Boolean

value = instance.CanConvertFrom(context, sourceType)
C#
public virtual System.bool CanConvertFrom(
   System.ComponentModel.ITypeDescriptorContext context,
   System.Type sourceType
)
Delphi
public function CanConvertFrom(
    context: System.ComponentModel.ITypeDescriptorContext;
    sourceType: System.Type
): System.Boolean; virtual;
JScript
public function CanConvertFrom(
   context : System.ComponentModel.ITypeDescriptorContext,
   sourceType : System.Type
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool CanConvertFrom(
   System.ComponentModel.ITypeDescriptorContext* context,
   System.Type* sourceType
)
C++/CLI
public:
virtual System.bool CanConvertFrom(
   System.ComponentModel.ITypeDescriptorContext^ context,
   System.Type^ sourceType
)

Parameters

context
sourceType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


CanConvertFrom(Type) Method

[image]
Intersoft WebScheduler Documentation
CanConvertFrom(Type) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > CanConvertFrom Method : CanConvertFrom(Type) Method

sourceType

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function CanConvertFrom( _
   ByVal sourceType As System.Type _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim sourceType As System.Type
Dim value As System.Boolean

value = instance.CanConvertFrom(sourceType)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.bool CanConvertFrom(
   System.Type sourceType
)
Delphi
public function CanConvertFrom(
    sourceType: System.Type
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function CanConvertFrom(
   sourceType : System.Type
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.bool CanConvertFrom(
   System.Type* sourceType
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.bool CanConvertFrom(
   System.Type^ sourceType
)

Parameters

sourceType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


CanConvertTo(Type) Method

[image]
Intersoft WebScheduler Documentation
CanConvertTo(Type) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > CanConvertTo Method : CanConvertTo(Type) Method

destinationType

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function CanConvertTo( _
   ByVal destinationType As System.Type _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim destinationType As System.Type
Dim value As System.Boolean

value = instance.CanConvertTo(destinationType)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.bool CanConvertTo(
   System.Type destinationType
)
Delphi
public function CanConvertTo(
    destinationType: System.Type
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function CanConvertTo(
   destinationType : System.Type
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.bool CanConvertTo(
   System.Type* destinationType
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.bool CanConvertTo(
   System.Type^ destinationType
)

Parameters

destinationType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


ConvertFrom Method

[image]
Intersoft WebScheduler Documentation
ConvertFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class : ConvertFrom Method

Glossary Item Box

Overload List

Overload | Description
ConvertFrom(Object) | (Inherited from System.ComponentModel.TypeConverter)
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members


ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

[image]
Intersoft WebScheduler Documentation
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > ConvertFrom Method : ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

context
culture
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ConvertFrom( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal culture As System.Globalization.CultureInfo, _
   ByVal value As System.Object _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim culture As System.Globalization.CultureInfo
Dim value As System.Object
Dim value As System.Object

value = instance.ConvertFrom(context, culture, value)
C#
public virtual System.object ConvertFrom(
   System.ComponentModel.ITypeDescriptorContext context,
   System.Globalization.CultureInfo culture,
   System.object value
)
Delphi
public function ConvertFrom(
    context: System.ComponentModel.ITypeDescriptorContext;
    culture: System.Globalization.CultureInfo;
    value: System.TObject
): System.TObject; virtual;
JScript
public function ConvertFrom(
   context : System.ComponentModel.ITypeDescriptorContext,
   culture : System.Globalization.CultureInfo,
   value : System.Object
) : System.Object;
Managed Extensions for C++
public: virtual System.Object* ConvertFrom(
   System.ComponentModel.ITypeDescriptorContext* context,
   System.Globalization.CultureInfo* culture,
   System.Object* value
)
C++/CLI
public:
virtual System.Object^ ConvertFrom(
   System.ComponentModel.ITypeDescriptorContext^ context,
   System.Globalization.CultureInfo^ culture,
   System.Object^ value
)

Parameters

context
culture
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


ConvertFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
ConvertFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > ConvertFrom Method : ConvertFrom(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFrom( _
   ByVal value As System.Object _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim value As System.Object
Dim value As System.Object

value = instance.ConvertFrom(value)
C#
public System.object ConvertFrom(
   System.object value
)
Delphi
public function ConvertFrom(
    value: System.TObject
): System.TObject;
JScript
public function ConvertFrom(
   value : System.Object
) : System.Object;
Managed Extensions for C++
public: System.Object* ConvertFrom(
   System.Object* value
)
C++/CLI
public:
System.Object^ ConvertFrom(
   System.Object^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


ConvertFromInvariantString Method

[image]
Intersoft WebScheduler Documentation
ConvertFromInvariantString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class : ConvertFromInvariantString Method

Glossary Item Box

Overload List

Overload | Description
ConvertFromInvariantString(String) | (Inherited from System.ComponentModel.TypeConverter)
ConvertFromInvariantString(ITypeDescriptorContext,String) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members


ConvertFromInvariantString(ITypeDescriptorContext,String) Method

[image]
Intersoft WebScheduler Documentation
ConvertFromInvariantString(ITypeDescriptorContext,String) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > ConvertFromInvariantString Method : ConvertFromInvariantString(ITypeDescriptorContext,String) Method

context
text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromInvariantString( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal text As System.String _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim text As System.String
Dim value As System.Object

value = instance.ConvertFromInvariantString(context, text)
C#
public System.object ConvertFromInvariantString(
   System.ComponentModel.ITypeDescriptorContext context,
   System.string text
)
Delphi
public function ConvertFromInvariantString(
    context: System.ComponentModel.ITypeDescriptorContext;
    text: System.String
): System.TObject;
JScript
public function ConvertFromInvariantString(
   context : System.ComponentModel.ITypeDescriptorContext,
   text : System.String
) : System.Object;
Managed Extensions for C++
public: System.Object* ConvertFromInvariantString(
   System.ComponentModel.ITypeDescriptorContext* context,
   System.string* text
)
C++/CLI
public:
System.Object^ ConvertFromInvariantString(
   System.ComponentModel.ITypeDescriptorContext^ context,
   System.String^ text
)

Parameters

context
text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


ConvertFromInvariantString(String) Method

[image]
Intersoft WebScheduler Documentation
ConvertFromInvariantString(String) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > ConvertFromInvariantString Method : ConvertFromInvariantString(String) Method

text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromInvariantString( _
   ByVal text As System.String _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim text As System.String
Dim value As System.Object

value = instance.ConvertFromInvariantString(text)
C#
public System.object ConvertFromInvariantString(
   System.string text
)
Delphi
public function ConvertFromInvariantString(
    text: System.String
): System.TObject;
JScript
public function ConvertFromInvariantString(
   text : System.String
) : System.Object;
Managed Extensions for C++
public: System.Object* ConvertFromInvariantString(
   System.string* text
)
C++/CLI
public:
System.Object^ ConvertFromInvariantString(
   System.String^ text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


ConvertFromString Method

[image]
Intersoft WebScheduler Documentation
ConvertFromString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class : ConvertFromString Method

Glossary Item Box

Overload List

Overload | Description
ConvertFromString(String) | (Inherited from System.ComponentModel.TypeConverter)
ConvertFromString(ITypeDescriptorContext,String) | (Inherited from System.ComponentModel.TypeConverter)
ConvertFromString(ITypeDescriptorContext,CultureInfo,String) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members


ConvertFromString(ITypeDescriptorContext,CultureInfo,String) Method

[image]
Intersoft WebScheduler Documentation
ConvertFromString(ITypeDescriptorContext,CultureInfo,String) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > ConvertFromString Method : ConvertFromString(ITypeDescriptorContext,CultureInfo,String) Method

context
culture
text

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function ConvertFromString( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal culture As System.Globalization.CultureInfo, _
   ByVal text As System.String _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim culture As System.Globalization.CultureInfo
Dim text As System.String
Dim value As System.Object

value = instance.ConvertFromString(context, culture, text)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.object ConvertFromString(
   System.ComponentModel.ITypeDescriptorContext context,
   System.Globalization.CultureInfo culture,
   System.string text
)
Delphi
public function ConvertFromString(
    context: System.ComponentModel.ITypeDescriptorContext;
    culture: System.Globalization.CultureInfo;
    text: System.String
): System.TObject;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function ConvertFromString(
   context : System.ComponentModel.ITypeDescriptorContext,
   culture : System.Globalization.CultureInfo,
   text : System.String
) : System.Object;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Object* ConvertFromString(
   System.ComponentModel.ITypeDescriptorContext* context,
   System.Globalization.CultureInfo* culture,
   System.string* text
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Object^ ConvertFromString(
   System.ComponentModel.ITypeDescriptorContext^ context,
   System.Globalization.CultureInfo^ culture,
   System.String^ text
)

Parameters

context
culture
text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


ConvertFromString(ITypeDescriptorContext,String) Method

[image]
Intersoft WebScheduler Documentation
ConvertFromString(ITypeDescriptorContext,String) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > ConvertFromString Method : ConvertFromString(ITypeDescriptorContext,String) Method

context
text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromString( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal text As System.String _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim text As System.String
Dim value As System.Object

value = instance.ConvertFromString(context, text)
C#
public System.object ConvertFromString(
   System.ComponentModel.ITypeDescriptorContext context,
   System.string text
)
Delphi
public function ConvertFromString(
    context: System.ComponentModel.ITypeDescriptorContext;
    text: System.String
): System.TObject;
JScript
public function ConvertFromString(
   context : System.ComponentModel.ITypeDescriptorContext,
   text : System.String
) : System.Object;
Managed Extensions for C++
public: System.Object* ConvertFromString(
   System.ComponentModel.ITypeDescriptorContext* context,
   System.string* text
)
C++/CLI
public:
System.Object^ ConvertFromString(
   System.ComponentModel.ITypeDescriptorContext^ context,
   System.String^ text
)

Parameters

context
text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


ConvertFromString(String) Method

[image]
Intersoft WebScheduler Documentation
ConvertFromString(String) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > ConvertFromString Method : ConvertFromString(String) Method

text

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function ConvertFromString( _
   ByVal text As System.String _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim text As System.String
Dim value As System.Object

value = instance.ConvertFromString(text)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.object ConvertFromString(
   System.string text
)
Delphi
public function ConvertFromString(
    text: System.String
): System.TObject;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function ConvertFromString(
   text : System.String
) : System.Object;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Object* ConvertFromString(
   System.string* text
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Object^ ConvertFromString(
   System.String^ text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


ConvertTo(Object,Type) Method

[image]
Intersoft WebScheduler Documentation
ConvertTo(Object,Type) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > ConvertTo Method : ConvertTo(Object,Type) Method

value
destinationType

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function ConvertTo( _
   ByVal value As System.Object, _
   ByVal destinationType As System.Type _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim value As System.Object
Dim destinationType As System.Type
Dim value As System.Object

value = instance.ConvertTo(value, destinationType)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.object ConvertTo(
   System.object value,
   System.Type destinationType
)
Delphi
public function ConvertTo(
    value: System.TObject;
    destinationType: System.Type
): System.TObject;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function ConvertTo(
   value : System.Object,
   destinationType : System.Type
) : System.Object;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Object* ConvertTo(
   System.Object* value,
   System.Type* destinationType
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Object^ ConvertTo(
   System.Object^ value,
   System.Type^ destinationType
)

Parameters

value
destinationType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


ConvertToInvariantString Method

[image]
Intersoft WebScheduler Documentation
ConvertToInvariantString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class : ConvertToInvariantString Method

Glossary Item Box

Overload List

Overload | Description
ConvertToInvariantString(Object) | (Inherited from System.ComponentModel.TypeConverter)
ConvertToInvariantString(ITypeDescriptorContext,Object) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members


ConvertToInvariantString(ITypeDescriptorContext,Object) Method

[image]
Intersoft WebScheduler Documentation
ConvertToInvariantString(ITypeDescriptorContext,Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > ConvertToInvariantString Method : ConvertToInvariantString(ITypeDescriptorContext,Object) Method

context
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToInvariantString( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal value As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim value As System.Object
Dim value As System.String

value = instance.ConvertToInvariantString(context, value)
C#
public System.string ConvertToInvariantString(
   System.ComponentModel.ITypeDescriptorContext context,
   System.object value
)
Delphi
public function ConvertToInvariantString(
    context: System.ComponentModel.ITypeDescriptorContext;
    value: System.TObject
): System.String;
JScript
public function ConvertToInvariantString(
   context : System.ComponentModel.ITypeDescriptorContext,
   value : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* ConvertToInvariantString(
   System.ComponentModel.ITypeDescriptorContext* context,
   System.Object* value
)
C++/CLI
public:
System.String^ ConvertToInvariantString(
   System.ComponentModel.ITypeDescriptorContext^ context,
   System.Object^ value
)

Parameters

context
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


ConvertToInvariantString(Object) Method

[image]
Intersoft WebScheduler Documentation
ConvertToInvariantString(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > ConvertToInvariantString Method : ConvertToInvariantString(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToInvariantString( _
   ByVal value As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim value As System.Object
Dim value As System.String

value = instance.ConvertToInvariantString(value)
C#
public System.string ConvertToInvariantString(
   System.object value
)
Delphi
public function ConvertToInvariantString(
    value: System.TObject
): System.String;
JScript
public function ConvertToInvariantString(
   value : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* ConvertToInvariantString(
   System.Object* value
)
C++/CLI
public:
System.String^ ConvertToInvariantString(
   System.Object^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


ConvertToString Method

[image]
Intersoft WebScheduler Documentation
ConvertToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class : ConvertToString Method

Glossary Item Box

Overload List

Overload | Description
ConvertToString(Object) | (Inherited from System.ComponentModel.TypeConverter)
ConvertToString(ITypeDescriptorContext,Object) | (Inherited from System.ComponentModel.TypeConverter)
ConvertToString(ITypeDescriptorContext,CultureInfo,Object) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members


ConvertToString(ITypeDescriptorContext,CultureInfo,Object) Method

[image]
Intersoft WebScheduler Documentation
ConvertToString(ITypeDescriptorContext,CultureInfo,Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > ConvertToString Method : ConvertToString(ITypeDescriptorContext,CultureInfo,Object) Method

context
culture
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToString( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal culture As System.Globalization.CultureInfo, _
   ByVal value As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim culture As System.Globalization.CultureInfo
Dim value As System.Object
Dim value As System.String

value = instance.ConvertToString(context, culture, value)
C#
public System.string ConvertToString(
   System.ComponentModel.ITypeDescriptorContext context,
   System.Globalization.CultureInfo culture,
   System.object value
)
Delphi
public function ConvertToString(
    context: System.ComponentModel.ITypeDescriptorContext;
    culture: System.Globalization.CultureInfo;
    value: System.TObject
): System.String;
JScript
public function ConvertToString(
   context : System.ComponentModel.ITypeDescriptorContext,
   culture : System.Globalization.CultureInfo,
   value : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* ConvertToString(
   System.ComponentModel.ITypeDescriptorContext* context,
   System.Globalization.CultureInfo* culture,
   System.Object* value
)
C++/CLI
public:
System.String^ ConvertToString(
   System.ComponentModel.ITypeDescriptorContext^ context,
   System.Globalization.CultureInfo^ culture,
   System.Object^ value
)

Parameters

context
culture
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


ConvertToString(ITypeDescriptorContext,Object) Method

[image]
Intersoft WebScheduler Documentation
ConvertToString(ITypeDescriptorContext,Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > ConvertToString Method : ConvertToString(ITypeDescriptorContext,Object) Method

context
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToString( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal value As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim value As System.Object
Dim value As System.String

value = instance.ConvertToString(context, value)
C#
public System.string ConvertToString(
   System.ComponentModel.ITypeDescriptorContext context,
   System.object value
)
Delphi
public function ConvertToString(
    context: System.ComponentModel.ITypeDescriptorContext;
    value: System.TObject
): System.String;
JScript
public function ConvertToString(
   context : System.ComponentModel.ITypeDescriptorContext,
   value : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* ConvertToString(
   System.ComponentModel.ITypeDescriptorContext* context,
   System.Object* value
)
C++/CLI
public:
System.String^ ConvertToString(
   System.ComponentModel.ITypeDescriptorContext^ context,
   System.Object^ value
)

Parameters

context
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


ConvertToString(Object) Method

[image]
Intersoft WebScheduler Documentation
ConvertToString(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > ConvertToString Method : ConvertToString(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToString( _
   ByVal value As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim value As System.Object
Dim value As System.String

value = instance.ConvertToString(value)
C#
public System.string ConvertToString(
   System.object value
)
Delphi
public function ConvertToString(
    value: System.TObject
): System.String;
JScript
public function ConvertToString(
   value : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* ConvertToString(
   System.Object* value
)
C++/CLI
public:
System.String^ ConvertToString(
   System.Object^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


CreateInstance Method

[image]
Intersoft WebScheduler Documentation
CreateInstance Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class : CreateInstance Method

Glossary Item Box

Overload List

Overload | Description
CreateInstance(IDictionary) | (Inherited from System.ComponentModel.TypeConverter)
CreateInstance(ITypeDescriptorContext,IDictionary) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members


CreateInstance(IDictionary) Method

[image]
Intersoft WebScheduler Documentation
CreateInstance(IDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > CreateInstance Method : CreateInstance(IDictionary) Method

propertyValues

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function CreateInstance( _
   ByVal propertyValues As System.Collections.IDictionary _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim propertyValues As System.Collections.IDictionary
Dim value As System.Object

value = instance.CreateInstance(propertyValues)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.object CreateInstance(
   System.Collections.IDictionary propertyValues
)
Delphi
public function CreateInstance(
    propertyValues: System.Collections.IDictionary
): System.TObject;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function CreateInstance(
   propertyValues : System.Collections.IDictionary
) : System.Object;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Object* CreateInstance(
   System.Collections.IDictionary* propertyValues
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Object^ CreateInstance(
   System.Collections.IDictionary^ propertyValues
)

Parameters

propertyValues

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


CreateInstance(ITypeDescriptorContext,IDictionary) Method

[image]
Intersoft WebScheduler Documentation
CreateInstance(ITypeDescriptorContext,IDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > CreateInstance Method : CreateInstance(ITypeDescriptorContext,IDictionary) Method

context
propertyValues

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function CreateInstance( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal propertyValues As System.Collections.IDictionary _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim propertyValues As System.Collections.IDictionary
Dim value As System.Object

value = instance.CreateInstance(context, propertyValues)
C#
public virtual System.object CreateInstance(
   System.ComponentModel.ITypeDescriptorContext context,
   System.Collections.IDictionary propertyValues
)
Delphi
public function CreateInstance(
    context: System.ComponentModel.ITypeDescriptorContext;
    propertyValues: System.Collections.IDictionary
): System.TObject; virtual;
JScript
public function CreateInstance(
   context : System.ComponentModel.ITypeDescriptorContext,
   propertyValues : System.Collections.IDictionary
) : System.Object;
Managed Extensions for C++
public: virtual System.Object* CreateInstance(
   System.ComponentModel.ITypeDescriptorContext* context,
   System.Collections.IDictionary* propertyValues
)
C++/CLI
public:
virtual System.Object^ CreateInstance(
   System.ComponentModel.ITypeDescriptorContext^ context,
   System.Collections.IDictionary^ propertyValues
)

Parameters

context
propertyValues

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


GetCreateInstanceSupported Method

[image]
Intersoft WebScheduler Documentation
GetCreateInstanceSupported Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class : GetCreateInstanceSupported Method

Glossary Item Box

Overload List

Overload | Description
GetCreateInstanceSupported() | (Inherited from System.ComponentModel.TypeConverter)
GetCreateInstanceSupported(ITypeDescriptorContext) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members


GetCreateInstanceSupported() Method

[image]
Intersoft WebScheduler Documentation
GetCreateInstanceSupported() Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > GetCreateInstanceSupported Method : GetCreateInstanceSupported() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetCreateInstanceSupported() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim value As System.Boolean

value = instance.GetCreateInstanceSupported()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.bool GetCreateInstanceSupported()
Delphi
public function GetCreateInstanceSupported(): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetCreateInstanceSupported() : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.bool GetCreateInstanceSupported();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.bool GetCreateInstanceSupported();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


GetCreateInstanceSupported(ITypeDescriptorContext) Method

[image]
Intersoft WebScheduler Documentation
GetCreateInstanceSupported(ITypeDescriptorContext) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > GetCreateInstanceSupported Method : GetCreateInstanceSupported(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetCreateInstanceSupported( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim value As System.Boolean

value = instance.GetCreateInstanceSupported(context)
C#
public virtual System.bool GetCreateInstanceSupported(
   System.ComponentModel.ITypeDescriptorContext context
)
Delphi
public function GetCreateInstanceSupported(
    context: System.ComponentModel.ITypeDescriptorContext
): System.Boolean; virtual;
JScript
public function GetCreateInstanceSupported(
   context : System.ComponentModel.ITypeDescriptorContext
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool GetCreateInstanceSupported(
   System.ComponentModel.ITypeDescriptorContext* context
)
C++/CLI
public:
virtual System.bool GetCreateInstanceSupported(
   System.ComponentModel.ITypeDescriptorContext^ context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


GetProperties Method

[image]
Intersoft WebScheduler Documentation
GetProperties Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class : GetProperties Method

Glossary Item Box

Overload List

Overload | Description
GetProperties(Object) | (Inherited from System.ComponentModel.TypeConverter)
GetProperties(ITypeDescriptorContext,Object) | (Inherited from System.ComponentModel.TypeConverter)
GetProperties(ITypeDescriptorContext,Object,Attribute[]) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members


GetProperties(ITypeDescriptorContext,Object) Method

[image]
Intersoft WebScheduler Documentation
GetProperties(ITypeDescriptorContext,Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > GetProperties Method : GetProperties(ITypeDescriptorContext,Object) Method

context
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetProperties( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal value As System.Object _
) As System.ComponentModel.PropertyDescriptorCollection
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim value As System.Object
Dim value As System.ComponentModel.PropertyDescriptorCollection

value = instance.GetProperties(context, value)
C#
public System.ComponentModel.PropertyDescriptorCollection GetProperties(
   System.ComponentModel.ITypeDescriptorContext context,
   System.object value
)
Delphi
public function GetProperties(
    context: System.ComponentModel.ITypeDescriptorContext;
    value: System.TObject
): System.ComponentModel.PropertyDescriptorCollection;
JScript
public function GetProperties(
   context : System.ComponentModel.ITypeDescriptorContext,
   value : System.Object
) : System.ComponentModel.PropertyDescriptorCollection;
Managed Extensions for C++
public: System.ComponentModel.PropertyDescriptorCollection* GetProperties(
   System.ComponentModel.ITypeDescriptorContext* context,
   System.Object* value
)
C++/CLI
public:
System.ComponentModel.PropertyDescriptorCollection^ GetProperties(
   System.ComponentModel.ITypeDescriptorContext^ context,
   System.Object^ value
)

Parameters

context
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method

[image]
Intersoft WebScheduler Documentation
GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > GetProperties Method : GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method

context
value
attributes

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetProperties( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal value As System.Object, _
   ByVal attributes() As System.Attribute _
) As System.ComponentModel.PropertyDescriptorCollection
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim value As System.Object
Dim attributes() As System.Attribute
Dim value As System.ComponentModel.PropertyDescriptorCollection

value = instance.GetProperties(context, value, attributes)
C#
public virtual System.ComponentModel.PropertyDescriptorCollection GetProperties(
   System.ComponentModel.ITypeDescriptorContext context,
   System.object value,
   System.Attribute[] attributes
)
Delphi
public function GetProperties(
    context: System.ComponentModel.ITypeDescriptorContext;
    value: System.TObject;
    attributes: System.Attributearray of
): System.ComponentModel.PropertyDescriptorCollection; virtual;
JScript
public function GetProperties(
   context : System.ComponentModel.ITypeDescriptorContext,
   value : System.Object,
   attributes : System.Attribute[]
) : System.ComponentModel.PropertyDescriptorCollection;
Managed Extensions for C++
public: virtual System.ComponentModel.PropertyDescriptorCollection* GetProperties(
   System.ComponentModel.ITypeDescriptorContext* context,
   System.Object* value,
   System.Attribute*[]* attributes
)
C++/CLI
public:
virtual System.ComponentModel.PropertyDescriptorCollection^ GetProperties(
   System.ComponentModel.ITypeDescriptorContext^ context,
   System.Object^ value,
   System.array<Attribute^>^ attributes
)

Parameters

context
value
attributes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


GetProperties(Object) Method

[image]
Intersoft WebScheduler Documentation
GetProperties(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > GetProperties Method : GetProperties(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetProperties( _
   ByVal value As System.Object _
) As System.ComponentModel.PropertyDescriptorCollection
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim value As System.Object
Dim value As System.ComponentModel.PropertyDescriptorCollection

value = instance.GetProperties(value)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.ComponentModel.PropertyDescriptorCollection GetProperties(
   System.object value
)
Delphi
public function GetProperties(
    value: System.TObject
): System.ComponentModel.PropertyDescriptorCollection;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetProperties(
   value : System.Object
) : System.ComponentModel.PropertyDescriptorCollection;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.ComponentModel.PropertyDescriptorCollection* GetProperties(
   System.Object* value
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.ComponentModel.PropertyDescriptorCollection^ GetProperties(
   System.Object^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


GetPropertiesSupported Method

[image]
Intersoft WebScheduler Documentation
GetPropertiesSupported Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class : GetPropertiesSupported Method

Glossary Item Box

Overload List

Overload | Description
GetPropertiesSupported() | (Inherited from System.ComponentModel.TypeConverter)
GetPropertiesSupported(ITypeDescriptorContext) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members


GetPropertiesSupported() Method

[image]
Intersoft WebScheduler Documentation
GetPropertiesSupported() Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > GetPropertiesSupported Method : GetPropertiesSupported() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetPropertiesSupported() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim value As System.Boolean

value = instance.GetPropertiesSupported()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.bool GetPropertiesSupported()
Delphi
public function GetPropertiesSupported(): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetPropertiesSupported() : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.bool GetPropertiesSupported();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.bool GetPropertiesSupported();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


GetPropertiesSupported(ITypeDescriptorContext) Method

[image]
Intersoft WebScheduler Documentation
GetPropertiesSupported(ITypeDescriptorContext) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > GetPropertiesSupported Method : GetPropertiesSupported(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetPropertiesSupported( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim value As System.Boolean

value = instance.GetPropertiesSupported(context)
C#
public virtual System.bool GetPropertiesSupported(
   System.ComponentModel.ITypeDescriptorContext context
)
Delphi
public function GetPropertiesSupported(
    context: System.ComponentModel.ITypeDescriptorContext
): System.Boolean; virtual;
JScript
public function GetPropertiesSupported(
   context : System.ComponentModel.ITypeDescriptorContext
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool GetPropertiesSupported(
   System.ComponentModel.ITypeDescriptorContext* context
)
C++/CLI
public:
virtual System.bool GetPropertiesSupported(
   System.ComponentModel.ITypeDescriptorContext^ context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


GetStandardValues Method

[image]
Intersoft WebScheduler Documentation
GetStandardValues Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class : GetStandardValues Method

Glossary Item Box

Overload List

Overload | Description
GetStandardValues() | (Inherited from System.ComponentModel.TypeConverter)
GetStandardValues(ITypeDescriptorContext) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members


GetStandardValues() Method

[image]
Intersoft WebScheduler Documentation
GetStandardValues() Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > GetStandardValues Method : GetStandardValues() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetStandardValues() As System.Collections.ICollection
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim value As System.Collections.ICollection

value = instance.GetStandardValues()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.Collections.ICollection GetStandardValues()
Delphi
public function GetStandardValues(): System.Collections.ICollection;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetStandardValues() : System.Collections.ICollection;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Collections.ICollection* GetStandardValues();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Collections.ICollection^ GetStandardValues();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


GetStandardValues(ITypeDescriptorContext) Method

[image]
Intersoft WebScheduler Documentation
GetStandardValues(ITypeDescriptorContext) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > GetStandardValues Method : GetStandardValues(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetStandardValues( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext _
) As System.ComponentModel.TypeConverter.StandardValuesCollection
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim value As System.ComponentModel.TypeConverter.StandardValuesCollection

value = instance.GetStandardValues(context)
C#
public virtual System.ComponentModel.TypeConverter.StandardValuesCollection GetStandardValues(
   System.ComponentModel.ITypeDescriptorContext context
)
Delphi
public function GetStandardValues(
    context: System.ComponentModel.ITypeDescriptorContext
): System.ComponentModel.TypeConverter.StandardValuesCollection; virtual;
JScript
public function GetStandardValues(
   context : System.ComponentModel.ITypeDescriptorContext
) : System.ComponentModel.TypeConverter.StandardValuesCollection;
Managed Extensions for C++
public: virtual System.ComponentModel.TypeConverter.StandardValuesCollection* GetStandardValues(
   System.ComponentModel.ITypeDescriptorContext* context
)
C++/CLI
public:
virtual System.ComponentModel.TypeConverter.StandardValuesCollection^ GetStandardValues(
   System.ComponentModel.ITypeDescriptorContext^ context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


GetStandardValuesExclusive Method

[image]
Intersoft WebScheduler Documentation
GetStandardValuesExclusive Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class : GetStandardValuesExclusive Method

Glossary Item Box

Overload List

Overload | Description
GetStandardValuesExclusive() | (Inherited from System.ComponentModel.TypeConverter)
GetStandardValuesExclusive(ITypeDescriptorContext) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members


GetStandardValuesExclusive() Method

[image]
Intersoft WebScheduler Documentation
GetStandardValuesExclusive() Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > GetStandardValuesExclusive Method : GetStandardValuesExclusive() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetStandardValuesExclusive() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim value As System.Boolean

value = instance.GetStandardValuesExclusive()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.bool GetStandardValuesExclusive()
Delphi
public function GetStandardValuesExclusive(): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetStandardValuesExclusive() : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.bool GetStandardValuesExclusive();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.bool GetStandardValuesExclusive();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


GetStandardValuesExclusive(ITypeDescriptorContext) Method

[image]
Intersoft WebScheduler Documentation
GetStandardValuesExclusive(ITypeDescriptorContext) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > GetStandardValuesExclusive Method : GetStandardValuesExclusive(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetStandardValuesExclusive( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim value As System.Boolean

value = instance.GetStandardValuesExclusive(context)
C#
public virtual System.bool GetStandardValuesExclusive(
   System.ComponentModel.ITypeDescriptorContext context
)
Delphi
public function GetStandardValuesExclusive(
    context: System.ComponentModel.ITypeDescriptorContext
): System.Boolean; virtual;
JScript
public function GetStandardValuesExclusive(
   context : System.ComponentModel.ITypeDescriptorContext
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool GetStandardValuesExclusive(
   System.ComponentModel.ITypeDescriptorContext* context
)
C++/CLI
public:
virtual System.bool GetStandardValuesExclusive(
   System.ComponentModel.ITypeDescriptorContext^ context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


GetStandardValuesSupported Method

[image]
Intersoft WebScheduler Documentation
GetStandardValuesSupported Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class : GetStandardValuesSupported Method

Glossary Item Box

Overload List

Overload | Description
GetStandardValuesSupported() | (Inherited from System.ComponentModel.TypeConverter)
GetStandardValuesSupported(ITypeDescriptorContext) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members


GetStandardValuesSupported() Method

[image]
Intersoft WebScheduler Documentation
GetStandardValuesSupported() Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > GetStandardValuesSupported Method : GetStandardValuesSupported() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetStandardValuesSupported() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim value As System.Boolean

value = instance.GetStandardValuesSupported()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.bool GetStandardValuesSupported()
Delphi
public function GetStandardValuesSupported(): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetStandardValuesSupported() : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.bool GetStandardValuesSupported();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.bool GetStandardValuesSupported();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


GetStandardValuesSupported(ITypeDescriptorContext) Method

[image]
Intersoft WebScheduler Documentation
GetStandardValuesSupported(ITypeDescriptorContext) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > GetStandardValuesSupported Method : GetStandardValuesSupported(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetStandardValuesSupported( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim value As System.Boolean

value = instance.GetStandardValuesSupported(context)
C#
public virtual System.bool GetStandardValuesSupported(
   System.ComponentModel.ITypeDescriptorContext context
)
Delphi
public function GetStandardValuesSupported(
    context: System.ComponentModel.ITypeDescriptorContext
): System.Boolean; virtual;
JScript
public function GetStandardValuesSupported(
   context : System.ComponentModel.ITypeDescriptorContext
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool GetStandardValuesSupported(
   System.ComponentModel.ITypeDescriptorContext* context
)
C++/CLI
public:
virtual System.bool GetStandardValuesSupported(
   System.ComponentModel.ITypeDescriptorContext^ context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


IsValid Method

[image]
Intersoft WebScheduler Documentation
IsValid Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class : IsValid Method

Glossary Item Box

Overload List

Overload | Description
IsValid(Object) | (Inherited from System.ComponentModel.TypeConverter)
IsValid(ITypeDescriptorContext,Object) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members


IsValid(ITypeDescriptorContext,Object) Method

[image]
Intersoft WebScheduler Documentation
IsValid(ITypeDescriptorContext,Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > IsValid Method : IsValid(ITypeDescriptorContext,Object) Method

context
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IsValid( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal value As System.Object _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim value As System.Object
Dim value As System.Boolean

value = instance.IsValid(context, value)
C#
public virtual System.bool IsValid(
   System.ComponentModel.ITypeDescriptorContext context,
   System.object value
)
Delphi
public function IsValid(
    context: System.ComponentModel.ITypeDescriptorContext;
    value: System.TObject
): System.Boolean; virtual;
JScript
public function IsValid(
   context : System.ComponentModel.ITypeDescriptorContext,
   value : System.Object
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsValid(
   System.ComponentModel.ITypeDescriptorContext* context,
   System.Object* value
)
C++/CLI
public:
virtual System.bool IsValid(
   System.ComponentModel.ITypeDescriptorContext^ context,
   System.Object^ value
)

Parameters

context
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


IsValid(Object) Method

[image]
Intersoft WebScheduler Documentation
IsValid(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDateTimeConverter Class > IsValid Method : IsValid(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function IsValid( _
   ByVal value As System.Object _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDateTimeConverter
Dim value As System.Object
Dim value As System.Boolean

value = instance.IsValid(value)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.bool IsValid(
   System.object value
)
Delphi
public function IsValid(
    value: System.TObject
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function IsValid(
   value : System.Object
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.bool IsValid(
   System.Object* value
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.bool IsValid(
   System.Object^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDateTimeConverter Class
WebSchedulerDateTimeConverter Members
Overload List


WebSchedulerDayView Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerDayView Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDayView Class : WebSchedulerDayView Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerDayView Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDayView Class
WebSchedulerDayView Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDayView Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDayView
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDayView Class
WebSchedulerDayView Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDayView Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDayView Class
WebSchedulerDayView Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDayView Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDayView
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDayView Class
WebSchedulerDayView Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDayView Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDayView
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDayView Class
WebSchedulerDayView Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDayView Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDayView
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDayView Class
WebSchedulerDayView Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDayView Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDayView
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDayView Class
WebSchedulerDayView Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDayView Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDayView
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDayView Class
WebSchedulerDayView Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDayView Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDayView

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDayView Class
WebSchedulerDayView Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDayView Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDayView
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDayView Class
WebSchedulerDayView Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDayView Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDayView
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDayView Class
WebSchedulerDayView Members


WebSchedulerDetailInfoStyle Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerDetailInfoStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDetailInfoStyle Class : WebSchedulerDetailInfoStyle Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerDetailInfoStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDetailInfoStyle Class
WebSchedulerDetailInfoStyle Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDetailInfoStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDetailInfoStyle
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDetailInfoStyle Class
WebSchedulerDetailInfoStyle Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDetailInfoStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDetailInfoStyle Class
WebSchedulerDetailInfoStyle Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDetailInfoStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDetailInfoStyle
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDetailInfoStyle Class
WebSchedulerDetailInfoStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDetailInfoStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDetailInfoStyle
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDetailInfoStyle Class
WebSchedulerDetailInfoStyle Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDetailInfoStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDetailInfoStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDetailInfoStyle Class
WebSchedulerDetailInfoStyle Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDetailInfoStyle Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDetailInfoStyle
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDetailInfoStyle Class
WebSchedulerDetailInfoStyle Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDetailInfoStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDetailInfoStyle
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDetailInfoStyle Class
WebSchedulerDetailInfoStyle Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDetailInfoStyle Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDetailInfoStyle

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDetailInfoStyle Class
WebSchedulerDetailInfoStyle Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDetailInfoStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDetailInfoStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDetailInfoStyle Class
WebSchedulerDetailInfoStyle Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDetailInfoStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDetailInfoStyle
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDetailInfoStyle Class
WebSchedulerDetailInfoStyle Members


WebSchedulerDisabledTimeCollection Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerDisabledTimeCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDisabledTimeCollection Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerDisabledTimeCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerDisabledTime>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerDisabledTime>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerDisabledTime>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebSchedulerDisabledTimeCollection Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerDisabledTimeCollection Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerDisabledTimeCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerDisabledTimeCollection Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerDisabledTimeCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebSchedulerDisabledTimeCollection Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerDisabledTimeCollection Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerDisabledTimeCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTimeCollection Class : WebSchedulerDisabledTimeCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerDisabledTimeCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTimeCollection Class
WebSchedulerDisabledTimeCollection Members


Add Method

[image]
Intersoft WebScheduler Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTimeCollection Class : Add Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Add( _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDisabledTimeCollection
Dim item As ISNet.WebUI.INamedObject2

instance.Add(item)
C#
[__DynamicallyInvokableAttribute()]
public void Add(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Add(
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Add(
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Add(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Add(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTimeCollection Class
WebSchedulerDisabledTimeCollection Members


Clear Method

[image]
Intersoft WebScheduler Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTimeCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDisabledTimeCollection

instance.Clear()
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void Clear()
Delphi
public procedure Clear();
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function Clear();
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void Clear();
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTimeCollection Class
WebSchedulerDisabledTimeCollection Members


Contains Method

[image]
Intersoft WebScheduler Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTimeCollection Class : Contains Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function Contains( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDisabledTimeCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Contains(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.bool Contains(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Contains(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function Contains(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.bool Contains(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.bool Contains(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTimeCollection Class
WebSchedulerDisabledTimeCollection Members


CopyTo Method

[image]
Intersoft WebScheduler Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTimeCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject2, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDisabledTimeCollection
Dim array() As ISNet.WebUI.INamedObject2
Dim index As System.Integer

instance.CopyTo(array, index)
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void CopyTo(
   ISNet.WebUI.INamedObject2[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObject2array of;
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function CopyTo(
   array : ISNet.WebUI.INamedObject2[],
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void CopyTo(
   ISNet.WebUI.INamedObject2*[]* array,
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject2^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTimeCollection Class
WebSchedulerDisabledTimeCollection Members


Count Property

[image]
Intersoft WebScheduler Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTimeCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDisabledTimeCollection
Dim value As System.Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function get Count : System.int
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property System.int get_Count();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTimeCollection Class
WebSchedulerDisabledTimeCollection Members


CreateNewItem Method

[image]
Intersoft WebScheduler Documentation
CreateNewItem Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTimeCollection Class : CreateNewItem Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateNewItem() As WebSchedulerDisabledTime
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDisabledTimeCollection
Dim value As WebSchedulerDisabledTime

value = instance.CreateNewItem()
C#
public WebSchedulerDisabledTime CreateNewItem()
Delphi
public function CreateNewItem(): WebSchedulerDisabledTime;
JScript
public function CreateNewItem() : WebSchedulerDisabledTime;
Managed Extensions for C++
public: WebSchedulerDisabledTime* CreateNewItem();
C++/CLI
public:
WebSchedulerDisabledTime^ CreateNewItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTimeCollection Class
WebSchedulerDisabledTimeCollection Members


GetEnumerator Method

[image]
Intersoft WebScheduler Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTimeCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function GetEnumerator() As System.Collections.Generic.IEnumerator(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDisabledTimeCollection
Dim value As System.Collections.Generic.IEnumerator(Of INamedObject2)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public System.Collections.Generic.IEnumerator<INamedObject2> GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.Generic.IEnumerator;
JScript
__DynamicallyInvokableAttribute()
public function GetEnumerator() : System.Collections.Generic.IEnumerator;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.Collections.Generic.IEnumerator<INamedObject2*>* GetEnumerator();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.Collections.Generic.IEnumerator<INamedObject2^>^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTimeCollection Class
WebSchedulerDisabledTimeCollection Members


GetNamedItem Method

[image]
Intersoft WebScheduler Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTimeCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As WebSchedulerDisabledTime
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDisabledTimeCollection
Dim name As System.String
Dim value As WebSchedulerDisabledTime

value = instance.GetNamedItem(name)
C#
public WebSchedulerDisabledTime GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebSchedulerDisabledTime;
JScript
public function GetNamedItem(
   name : System.String
) : WebSchedulerDisabledTime;
Managed Extensions for C++
public: WebSchedulerDisabledTime* GetNamedItem(
   System.string* name
)
C++/CLI
public:
WebSchedulerDisabledTime^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTimeCollection Class
WebSchedulerDisabledTimeCollection Members


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTimeCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDisabledTimeCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTimeCollection Class
WebSchedulerDisabledTimeCollection Members


IndexOf Method

[image]
Intersoft WebScheduler Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTimeCollection Class : IndexOf Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function IndexOf( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDisabledTimeCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Integer

value = instance.IndexOf(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.int IndexOf(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function IndexOf(
    item: ISNet.WebUI.INamedObject2
): System.Integer;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function IndexOf(
   item : ISNet.WebUI.INamedObject2
) : System.int;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.int IndexOf(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTimeCollection Class
WebSchedulerDisabledTimeCollection Members


Insert Method

[image]
Intersoft WebScheduler Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTimeCollection Class : Insert Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDisabledTimeCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.Insert(index, item)
C#
[__DynamicallyInvokableAttribute()]
public void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Insert(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Insert(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTimeCollection Class
WebSchedulerDisabledTimeCollection Members


Item Property

[image]
Intersoft WebScheduler Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTimeCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Default Property Item( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDisabledTimeCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject2

instance.Item(index) = value

value = instance.Item(index)
C#
[__DynamicallyInvokableAttribute()]
public ISNet.WebUI.INamedObject2 this[
   System.int index
]; {get; set;}
Delphi
public  this: : ISNet.WebUI.INamedObject2;[
    index: System.Integer
]; read-write
JScript
__DynamicallyInvokableAttribute()
public  this[
   index : System.int
] get,set : ISNet.WebUI.INamedObject2
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property ISNet.WebUI.INamedObject2* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   ISNet.WebUI.INamedObject2* value
;
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property ISNet.WebUI.INamedObject2^ default [int] {
   ISNet.WebUI.INamedObject2^ get(System.int index);
   void set (System.int index, ISNet.WebUI.INamedObject2^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTimeCollection Class
WebSchedulerDisabledTimeCollection Members


Parent Property

[image]
Intersoft WebScheduler Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTimeCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDisabledTimeCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTimeCollection Class
WebSchedulerDisabledTimeCollection Members


Remove Method

[image]
Intersoft WebScheduler Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTimeCollection Class : Remove Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function Remove( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDisabledTimeCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Remove(item)
C#
[__DynamicallyInvokableAttribute()]
public System.bool Remove(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Remove(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
__DynamicallyInvokableAttribute()
public function Remove(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.bool Remove(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.bool Remove(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTimeCollection Class
WebSchedulerDisabledTimeCollection Members


RemoveAt Method

[image]
Intersoft WebScheduler Documentation
RemoveAt Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTimeCollection Class : RemoveAt Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDisabledTimeCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
[__DynamicallyInvokableAttribute()]
public void RemoveAt(
   System.int index
)
Delphi
public procedure RemoveAt(
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
public function RemoveAt(
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void RemoveAt(
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void RemoveAt(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTimeCollection Class
WebSchedulerDisabledTimeCollection Members


SerializerConstructor Method

[image]
Intersoft WebScheduler Documentation
SerializerConstructor Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTimeCollection Class : SerializerConstructor Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializerConstructor( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDisabledTimeCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializerConstructor(info, context)
C#
public void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializerConstructor(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializerConstructor(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTimeCollection Class
WebSchedulerDisabledTimeCollection Members


SetParent Method

[image]
Intersoft WebScheduler Documentation
SetParent Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTimeCollection Class : SetParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDisabledTimeCollection
Dim parent As System.Object

instance.SetParent(parent)
C#
public virtual void SetParent(
   System.object parent
)
Delphi
public procedure SetParent(
    parent: System.TObject
); virtual;
JScript
public function SetParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void SetParent(
   System.Object* parent
)
C++/CLI
public:
virtual void SetParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTimeCollection Class
WebSchedulerDisabledTimeCollection Members


WebSchedulerDisabledTime Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerDisabledTime Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTime Class : WebSchedulerDisabledTime Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerDisabledTime Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTime Class
WebSchedulerDisabledTime Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTime Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDisabledTime
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTime Class
WebSchedulerDisabledTime Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTime Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTime Class
WebSchedulerDisabledTime Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTime Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDisabledTime
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTime Class
WebSchedulerDisabledTime Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTime Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDisabledTime
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTime Class
WebSchedulerDisabledTime Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTime Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDisabledTime
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTime Class
WebSchedulerDisabledTime Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTime Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDisabledTime
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTime Class
WebSchedulerDisabledTime Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTime Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDisabledTime
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTime Class
WebSchedulerDisabledTime Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTime Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDisabledTime

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTime Class
WebSchedulerDisabledTime Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTime Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDisabledTime
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTime Class
WebSchedulerDisabledTime Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerDisabledTime Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerDisabledTime
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerDisabledTime Class
WebSchedulerDisabledTime Members


WebSchedulerEditingFieldCollection Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerEditingFieldCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerEditingFieldCollection Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerEditingFieldCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerEditingField>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerEditingField>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerEditingField>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebSchedulerEditingFieldCollection Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerEditingFieldCollection Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerEditingFieldCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerEditingFieldCollection Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerEditingFieldCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebSchedulerEditingFieldCollection Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerEditingFieldCollection Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerEditingFieldCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingFieldCollection Class : WebSchedulerEditingFieldCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerEditingFieldCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingFieldCollection Class
WebSchedulerEditingFieldCollection Members


Add Method

[image]
Intersoft WebScheduler Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingFieldCollection Class : Add Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Add( _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingFieldCollection
Dim item As ISNet.WebUI.INamedObject2

instance.Add(item)
C#
[__DynamicallyInvokableAttribute()]
public void Add(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Add(
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Add(
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Add(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Add(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingFieldCollection Class
WebSchedulerEditingFieldCollection Members


Clear Method

[image]
Intersoft WebScheduler Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingFieldCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingFieldCollection

instance.Clear()
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void Clear()
Delphi
public procedure Clear();
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function Clear();
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void Clear();
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingFieldCollection Class
WebSchedulerEditingFieldCollection Members


Contains Method

[image]
Intersoft WebScheduler Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingFieldCollection Class : Contains Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function Contains( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingFieldCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Contains(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.bool Contains(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Contains(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function Contains(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.bool Contains(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.bool Contains(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingFieldCollection Class
WebSchedulerEditingFieldCollection Members


CopyTo Method

[image]
Intersoft WebScheduler Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingFieldCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject2, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingFieldCollection
Dim array() As ISNet.WebUI.INamedObject2
Dim index As System.Integer

instance.CopyTo(array, index)
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void CopyTo(
   ISNet.WebUI.INamedObject2[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObject2array of;
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function CopyTo(
   array : ISNet.WebUI.INamedObject2[],
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void CopyTo(
   ISNet.WebUI.INamedObject2*[]* array,
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject2^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingFieldCollection Class
WebSchedulerEditingFieldCollection Members


Count Property

[image]
Intersoft WebScheduler Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingFieldCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingFieldCollection
Dim value As System.Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function get Count : System.int
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property System.int get_Count();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingFieldCollection Class
WebSchedulerEditingFieldCollection Members


CreateNewItem Method

[image]
Intersoft WebScheduler Documentation
CreateNewItem Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingFieldCollection Class : CreateNewItem Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateNewItem() As WebSchedulerEditingField
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingFieldCollection
Dim value As WebSchedulerEditingField

value = instance.CreateNewItem()
C#
public WebSchedulerEditingField CreateNewItem()
Delphi
public function CreateNewItem(): WebSchedulerEditingField;
JScript
public function CreateNewItem() : WebSchedulerEditingField;
Managed Extensions for C++
public: WebSchedulerEditingField* CreateNewItem();
C++/CLI
public:
WebSchedulerEditingField^ CreateNewItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingFieldCollection Class
WebSchedulerEditingFieldCollection Members


GetEnumerator Method

[image]
Intersoft WebScheduler Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingFieldCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function GetEnumerator() As System.Collections.Generic.IEnumerator(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingFieldCollection
Dim value As System.Collections.Generic.IEnumerator(Of INamedObject2)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public System.Collections.Generic.IEnumerator<INamedObject2> GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.Generic.IEnumerator;
JScript
__DynamicallyInvokableAttribute()
public function GetEnumerator() : System.Collections.Generic.IEnumerator;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.Collections.Generic.IEnumerator<INamedObject2*>* GetEnumerator();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.Collections.Generic.IEnumerator<INamedObject2^>^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingFieldCollection Class
WebSchedulerEditingFieldCollection Members


GetNamedItem Method

[image]
Intersoft WebScheduler Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingFieldCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As WebSchedulerEditingField
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingFieldCollection
Dim name As System.String
Dim value As WebSchedulerEditingField

value = instance.GetNamedItem(name)
C#
public WebSchedulerEditingField GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebSchedulerEditingField;
JScript
public function GetNamedItem(
   name : System.String
) : WebSchedulerEditingField;
Managed Extensions for C++
public: WebSchedulerEditingField* GetNamedItem(
   System.string* name
)
C++/CLI
public:
WebSchedulerEditingField^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingFieldCollection Class
WebSchedulerEditingFieldCollection Members


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingFieldCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingFieldCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingFieldCollection Class
WebSchedulerEditingFieldCollection Members


IndexOf Method

[image]
Intersoft WebScheduler Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingFieldCollection Class : IndexOf Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function IndexOf( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingFieldCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Integer

value = instance.IndexOf(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.int IndexOf(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function IndexOf(
    item: ISNet.WebUI.INamedObject2
): System.Integer;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function IndexOf(
   item : ISNet.WebUI.INamedObject2
) : System.int;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.int IndexOf(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingFieldCollection Class
WebSchedulerEditingFieldCollection Members


Insert Method

[image]
Intersoft WebScheduler Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingFieldCollection Class : Insert Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingFieldCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.Insert(index, item)
C#
[__DynamicallyInvokableAttribute()]
public void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Insert(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Insert(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingFieldCollection Class
WebSchedulerEditingFieldCollection Members


Item Property

[image]
Intersoft WebScheduler Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingFieldCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Default Property Item( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingFieldCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject2

instance.Item(index) = value

value = instance.Item(index)
C#
[__DynamicallyInvokableAttribute()]
public ISNet.WebUI.INamedObject2 this[
   System.int index
]; {get; set;}
Delphi
public  this: : ISNet.WebUI.INamedObject2;[
    index: System.Integer
]; read-write
JScript
__DynamicallyInvokableAttribute()
public  this[
   index : System.int
] get,set : ISNet.WebUI.INamedObject2
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property ISNet.WebUI.INamedObject2* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   ISNet.WebUI.INamedObject2* value
;
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property ISNet.WebUI.INamedObject2^ default [int] {
   ISNet.WebUI.INamedObject2^ get(System.int index);
   void set (System.int index, ISNet.WebUI.INamedObject2^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingFieldCollection Class
WebSchedulerEditingFieldCollection Members


Parent Property

[image]
Intersoft WebScheduler Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingFieldCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingFieldCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingFieldCollection Class
WebSchedulerEditingFieldCollection Members


Remove Method

[image]
Intersoft WebScheduler Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingFieldCollection Class : Remove Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function Remove( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingFieldCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Remove(item)
C#
[__DynamicallyInvokableAttribute()]
public System.bool Remove(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Remove(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
__DynamicallyInvokableAttribute()
public function Remove(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.bool Remove(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.bool Remove(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingFieldCollection Class
WebSchedulerEditingFieldCollection Members


RemoveAt Method

[image]
Intersoft WebScheduler Documentation
RemoveAt Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingFieldCollection Class : RemoveAt Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingFieldCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
[__DynamicallyInvokableAttribute()]
public void RemoveAt(
   System.int index
)
Delphi
public procedure RemoveAt(
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
public function RemoveAt(
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void RemoveAt(
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void RemoveAt(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingFieldCollection Class
WebSchedulerEditingFieldCollection Members


SerializerConstructor Method

[image]
Intersoft WebScheduler Documentation
SerializerConstructor Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingFieldCollection Class : SerializerConstructor Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializerConstructor( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingFieldCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializerConstructor(info, context)
C#
public void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializerConstructor(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializerConstructor(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingFieldCollection Class
WebSchedulerEditingFieldCollection Members


SetParent Method

[image]
Intersoft WebScheduler Documentation
SetParent Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingFieldCollection Class : SetParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingFieldCollection
Dim parent As System.Object

instance.SetParent(parent)
C#
public virtual void SetParent(
   System.object parent
)
Delphi
public procedure SetParent(
    parent: System.TObject
); virtual;
JScript
public function SetParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void SetParent(
   System.Object* parent
)
C++/CLI
public:
virtual void SetParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingFieldCollection Class
WebSchedulerEditingFieldCollection Members


WebSchedulerEditingField Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerEditingField Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingField Class : WebSchedulerEditingField Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerEditingField Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingField Class
WebSchedulerEditingField Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingField Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingField
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingField Class
WebSchedulerEditingField Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingField Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingField Class
WebSchedulerEditingField Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingField Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingField
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingField Class
WebSchedulerEditingField Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingField Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingField
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingField Class
WebSchedulerEditingField Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingField Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingField
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingField Class
WebSchedulerEditingField Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingField Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingField
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingField Class
WebSchedulerEditingField Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingField Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingField
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingField Class
WebSchedulerEditingField Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingField Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingField

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingField Class
WebSchedulerEditingField Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingField Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingField
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingField Class
WebSchedulerEditingField Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEditingField Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEditingField
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEditingField Class
WebSchedulerEditingField Members


WebSchedulerEvent Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerEvent Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerEvent Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerEvent members.

Public Properties

 | Name | Description
Public Property | AllDayEvent | Indicates whether the event is AllDayEvent. Specifies the EventBase's AllDayEvent. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | CategoryID | Gets or sets the CategoryID. Specifies the EventBase's CategoryID. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | Collection | (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | Description | Gets or sets the Description of the event. Specifies the EventBase's description. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | EndTime | Gets or sets the EndTime of the event. Specifies the EventBase's EndTime. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | EventID | Gets or sets the EventID. Specifies the EventBase's EventID. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | Location | Gets or sets the Location of the event. Specifies the EventBase's location. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | Mode | Specifies the event's Mode. Specifies the EventBase's mode. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | Name | (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | ReminderTimeSpan | Specifies the event's ReminderTimeSpan. Specifies the EventBase's ReminderTimeSpan. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | ResourceID | Gets or sets the ResourceID. Specifies the EventBase's ResourceID. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | StartTime | Gets or sets the StartTime of the event. Specifies the EventBase's StartTime. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | Subject | Gets or sets the Subject of the event. Specifies the EventBase's subject. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Public Property | Tooltip | Specifies the event's ToolTip. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventBase)
Top

See Also

Reference

WebSchedulerEvent Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerEventBase Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerEventBase Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventBase Class : WebSchedulerEventBase Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerEventBase Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventBase Class
WebSchedulerEventBase Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventBase Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventBase
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventBase Class
WebSchedulerEventBase Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventBase Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventBase Class
WebSchedulerEventBase Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventBase Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventBase
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventBase Class
WebSchedulerEventBase Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventBase Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventBase
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventBase Class
WebSchedulerEventBase Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventBase Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventBase
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventBase Class
WebSchedulerEventBase Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventBase Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventBase
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventBase Class
WebSchedulerEventBase Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventBase Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventBase
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventBase Class
WebSchedulerEventBase Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventBase Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventBase

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventBase Class
WebSchedulerEventBase Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventBase Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventBase
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventBase Class
WebSchedulerEventBase Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventBase Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventBase
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventBase Class
WebSchedulerEventBase Members


WebSchedulerEventCollection Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerEventCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerEventCollection Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerEventCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerEventBase>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerEventBase>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerEventBase>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebSchedulerEventCollection Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerEventCollection Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerEventCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerEventCollection Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerEventCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebSchedulerEventCollection Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerEventCollection Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerEventCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventCollection Class : WebSchedulerEventCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerEventCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventCollection Class
WebSchedulerEventCollection Members


Add Method

[image]
Intersoft WebScheduler Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventCollection Class : Add Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Add( _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventCollection
Dim item As ISNet.WebUI.INamedObject2

instance.Add(item)
C#
[__DynamicallyInvokableAttribute()]
public void Add(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Add(
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Add(
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Add(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Add(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventCollection Class
WebSchedulerEventCollection Members


Clear Method

[image]
Intersoft WebScheduler Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventCollection

instance.Clear()
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void Clear()
Delphi
public procedure Clear();
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function Clear();
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void Clear();
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventCollection Class
WebSchedulerEventCollection Members


Contains Method

[image]
Intersoft WebScheduler Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventCollection Class : Contains Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function Contains( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Contains(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.bool Contains(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Contains(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function Contains(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.bool Contains(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.bool Contains(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventCollection Class
WebSchedulerEventCollection Members


CopyTo Method

[image]
Intersoft WebScheduler Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject2, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventCollection
Dim array() As ISNet.WebUI.INamedObject2
Dim index As System.Integer

instance.CopyTo(array, index)
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void CopyTo(
   ISNet.WebUI.INamedObject2[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObject2array of;
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function CopyTo(
   array : ISNet.WebUI.INamedObject2[],
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void CopyTo(
   ISNet.WebUI.INamedObject2*[]* array,
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject2^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventCollection Class
WebSchedulerEventCollection Members


Count Property

[image]
Intersoft WebScheduler Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventCollection
Dim value As System.Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function get Count : System.int
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property System.int get_Count();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventCollection Class
WebSchedulerEventCollection Members


CreateNewItem Method

[image]
Intersoft WebScheduler Documentation
CreateNewItem Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventCollection Class : CreateNewItem Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateNewItem() As WebSchedulerEventBase
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventCollection
Dim value As WebSchedulerEventBase

value = instance.CreateNewItem()
C#
public WebSchedulerEventBase CreateNewItem()
Delphi
public function CreateNewItem(): WebSchedulerEventBase;
JScript
public function CreateNewItem() : WebSchedulerEventBase;
Managed Extensions for C++
public: WebSchedulerEventBase* CreateNewItem();
C++/CLI
public:
WebSchedulerEventBase^ CreateNewItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventCollection Class
WebSchedulerEventCollection Members


GetEnumerator Method

[image]
Intersoft WebScheduler Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function GetEnumerator() As System.Collections.Generic.IEnumerator(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventCollection
Dim value As System.Collections.Generic.IEnumerator(Of INamedObject2)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public System.Collections.Generic.IEnumerator<INamedObject2> GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.Generic.IEnumerator;
JScript
__DynamicallyInvokableAttribute()
public function GetEnumerator() : System.Collections.Generic.IEnumerator;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.Collections.Generic.IEnumerator<INamedObject2*>* GetEnumerator();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.Collections.Generic.IEnumerator<INamedObject2^>^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventCollection Class
WebSchedulerEventCollection Members


GetNamedItem Method

[image]
Intersoft WebScheduler Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As WebSchedulerEventBase
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventCollection
Dim name As System.String
Dim value As WebSchedulerEventBase

value = instance.GetNamedItem(name)
C#
public WebSchedulerEventBase GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebSchedulerEventBase;
JScript
public function GetNamedItem(
   name : System.String
) : WebSchedulerEventBase;
Managed Extensions for C++
public: WebSchedulerEventBase* GetNamedItem(
   System.string* name
)
C++/CLI
public:
WebSchedulerEventBase^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventCollection Class
WebSchedulerEventCollection Members


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventCollection Class
WebSchedulerEventCollection Members


IndexOf Method

[image]
Intersoft WebScheduler Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventCollection Class : IndexOf Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function IndexOf( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Integer

value = instance.IndexOf(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.int IndexOf(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function IndexOf(
    item: ISNet.WebUI.INamedObject2
): System.Integer;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function IndexOf(
   item : ISNet.WebUI.INamedObject2
) : System.int;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.int IndexOf(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventCollection Class
WebSchedulerEventCollection Members


Insert Method

[image]
Intersoft WebScheduler Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventCollection Class : Insert Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.Insert(index, item)
C#
[__DynamicallyInvokableAttribute()]
public void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Insert(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Insert(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventCollection Class
WebSchedulerEventCollection Members


Item Property

[image]
Intersoft WebScheduler Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Default Property Item( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject2

instance.Item(index) = value

value = instance.Item(index)
C#
[__DynamicallyInvokableAttribute()]
public ISNet.WebUI.INamedObject2 this[
   System.int index
]; {get; set;}
Delphi
public  this: : ISNet.WebUI.INamedObject2;[
    index: System.Integer
]; read-write
JScript
__DynamicallyInvokableAttribute()
public  this[
   index : System.int
] get,set : ISNet.WebUI.INamedObject2
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property ISNet.WebUI.INamedObject2* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   ISNet.WebUI.INamedObject2* value
;
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property ISNet.WebUI.INamedObject2^ default [int] {
   ISNet.WebUI.INamedObject2^ get(System.int index);
   void set (System.int index, ISNet.WebUI.INamedObject2^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventCollection Class
WebSchedulerEventCollection Members


Parent Property

[image]
Intersoft WebScheduler Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventCollection Class
WebSchedulerEventCollection Members


Remove Method

[image]
Intersoft WebScheduler Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventCollection Class : Remove Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function Remove( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Remove(item)
C#
[__DynamicallyInvokableAttribute()]
public System.bool Remove(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Remove(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
__DynamicallyInvokableAttribute()
public function Remove(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.bool Remove(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.bool Remove(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventCollection Class
WebSchedulerEventCollection Members


RemoveAt Method

[image]
Intersoft WebScheduler Documentation
RemoveAt Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventCollection Class : RemoveAt Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
[__DynamicallyInvokableAttribute()]
public void RemoveAt(
   System.int index
)
Delphi
public procedure RemoveAt(
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
public function RemoveAt(
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void RemoveAt(
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void RemoveAt(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventCollection Class
WebSchedulerEventCollection Members


SerializerConstructor Method

[image]
Intersoft WebScheduler Documentation
SerializerConstructor Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventCollection Class : SerializerConstructor Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializerConstructor( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializerConstructor(info, context)
C#
public void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializerConstructor(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializerConstructor(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventCollection Class
WebSchedulerEventCollection Members


SetParent Method

[image]
Intersoft WebScheduler Documentation
SetParent Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventCollection Class : SetParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventCollection
Dim parent As System.Object

instance.SetParent(parent)
C#
public virtual void SetParent(
   System.object parent
)
Delphi
public procedure SetParent(
    parent: System.TObject
); virtual;
JScript
public function SetParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void SetParent(
   System.Object* parent
)
C++/CLI
public:
virtual void SetParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventCollection Class
WebSchedulerEventCollection Members


WebSchedulerEventsBinding Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerEventsBinding Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerEventsBinding Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerEventsBinding members.

Public Properties

 | Name | Description
Public Property | AllDayEventField | Specifies the AllDayEvent Field. Specifies the AllDayEvent field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | CategoryIDField | Specifies the CategoryID Field. Specifies the CategoryID field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | DescriptionField | Specifies the Description Field. Specifies the Description field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | EndTimeField | Specifies the EndTime Field. Specifies the EndTime field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | EventIDField | Specifies the EventID Field. Specifies the EventID field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | LocationField | Specifies the Location Field. Specifies the Location field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | ModeField | Specifies the Mode Field. Specifies the Mode field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | ReminderTimeSpanField | Specifies the ReminderTimeSpan Field. Specifies the ReminderTimeSpan field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | ResourceIDField | Specifies the ResourceID Field. Specifies the ResourceID field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | StartTimeField | Specifies the StartTime Field. Specifies the StartTime field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Public Property | SubjectField | Specifies the Subject Field. Specifies the Subject field. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase)
Top

See Also

Reference

WebSchedulerEventsBinding Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerEventsBindingBase Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerEventsBindingBase Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBindingBase Class : WebSchedulerEventsBindingBase Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerEventsBindingBase Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBindingBase Class
WebSchedulerEventsBindingBase Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBindingBase Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBindingBase
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBindingBase Class
WebSchedulerEventsBindingBase Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBindingBase Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBindingBase Class
WebSchedulerEventsBindingBase Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBindingBase Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBindingBase
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBindingBase Class
WebSchedulerEventsBindingBase Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBindingBase Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBindingBase
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBindingBase Class
WebSchedulerEventsBindingBase Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBindingBase Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBindingBase
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBindingBase Class
WebSchedulerEventsBindingBase Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBindingBase Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBindingBase
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBindingBase Class
WebSchedulerEventsBindingBase Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBindingBase Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBindingBase
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBindingBase Class
WebSchedulerEventsBindingBase Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBindingBase Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBindingBase

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBindingBase Class
WebSchedulerEventsBindingBase Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBindingBase Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBindingBase
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBindingBase Class
WebSchedulerEventsBindingBase Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBindingBase Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBindingBase
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBindingBase Class
WebSchedulerEventsBindingBase Members


WebSchedulerEventsBinding Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerEventsBinding Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBinding Class : WebSchedulerEventsBinding Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerEventsBinding Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBinding Class
WebSchedulerEventsBinding Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBinding Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBinding
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBinding Class
WebSchedulerEventsBinding Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBinding Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBinding Class
WebSchedulerEventsBinding Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBinding Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBinding
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBinding Class
WebSchedulerEventsBinding Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBinding Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBinding
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBinding Class
WebSchedulerEventsBinding Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBinding Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBinding
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBinding Class
WebSchedulerEventsBinding Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBinding Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBinding
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBinding Class
WebSchedulerEventsBinding Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBinding Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBinding
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBinding Class
WebSchedulerEventsBinding Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBinding Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBinding

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBinding Class
WebSchedulerEventsBinding Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBinding Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBinding
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBinding Class
WebSchedulerEventsBinding Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEventsBinding Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEventsBinding
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEventsBinding Class
WebSchedulerEventsBinding Members


WebSchedulerEvent Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerEvent Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEvent Class : WebSchedulerEvent Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerEvent Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEvent Class
WebSchedulerEvent Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEvent Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEvent
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEvent Class
WebSchedulerEvent Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEvent Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEvent Class
WebSchedulerEvent Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEvent Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEvent
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEvent Class
WebSchedulerEvent Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEvent Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEvent
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEvent Class
WebSchedulerEvent Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEvent Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEvent
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEvent Class
WebSchedulerEvent Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEvent Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEvent
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEvent Class
WebSchedulerEvent Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEvent Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEvent
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEvent Class
WebSchedulerEvent Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEvent Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEvent

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEvent Class
WebSchedulerEvent Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEvent Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEvent
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEvent Class
WebSchedulerEvent Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerEvent Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerEvent
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerEvent Class
WebSchedulerEvent Members


WebSchedulerGridLineStyle Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerGridLineStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerGridLineStyle Class : WebSchedulerGridLineStyle Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerGridLineStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerGridLineStyle Class
WebSchedulerGridLineStyle Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerGridLineStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerGridLineStyle
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerGridLineStyle Class
WebSchedulerGridLineStyle Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerGridLineStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerGridLineStyle Class
WebSchedulerGridLineStyle Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerGridLineStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerGridLineStyle
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerGridLineStyle Class
WebSchedulerGridLineStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerGridLineStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerGridLineStyle
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerGridLineStyle Class
WebSchedulerGridLineStyle Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerGridLineStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerGridLineStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerGridLineStyle Class
WebSchedulerGridLineStyle Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerGridLineStyle Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerGridLineStyle
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerGridLineStyle Class
WebSchedulerGridLineStyle Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerGridLineStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerGridLineStyle
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerGridLineStyle Class
WebSchedulerGridLineStyle Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerGridLineStyle Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerGridLineStyle

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerGridLineStyle Class
WebSchedulerGridLineStyle Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerGridLineStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerGridLineStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerGridLineStyle Class
WebSchedulerGridLineStyle Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerGridLineStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerGridLineStyle
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerGridLineStyle Class
WebSchedulerGridLineStyle Members


WebSchedulerHolidayCollection Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerHolidayCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerHolidayCollection Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerHolidayCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerHoliday>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerHoliday>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerHoliday>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebSchedulerHolidayCollection Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerHolidayCollection Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerHolidayCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerHolidayCollection Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerHolidayCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebSchedulerHolidayCollection Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerHolidayCollection Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerHolidayCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHolidayCollection Class : WebSchedulerHolidayCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerHolidayCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHolidayCollection Class
WebSchedulerHolidayCollection Members


Add Method

[image]
Intersoft WebScheduler Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHolidayCollection Class : Add Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Add( _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHolidayCollection
Dim item As ISNet.WebUI.INamedObject2

instance.Add(item)
C#
[__DynamicallyInvokableAttribute()]
public void Add(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Add(
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Add(
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Add(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Add(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHolidayCollection Class
WebSchedulerHolidayCollection Members


Clear Method

[image]
Intersoft WebScheduler Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHolidayCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHolidayCollection

instance.Clear()
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void Clear()
Delphi
public procedure Clear();
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function Clear();
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void Clear();
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHolidayCollection Class
WebSchedulerHolidayCollection Members


Contains Method

[image]
Intersoft WebScheduler Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHolidayCollection Class : Contains Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function Contains( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHolidayCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Contains(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.bool Contains(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Contains(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function Contains(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.bool Contains(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.bool Contains(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHolidayCollection Class
WebSchedulerHolidayCollection Members


CopyTo Method

[image]
Intersoft WebScheduler Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHolidayCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject2, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHolidayCollection
Dim array() As ISNet.WebUI.INamedObject2
Dim index As System.Integer

instance.CopyTo(array, index)
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void CopyTo(
   ISNet.WebUI.INamedObject2[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObject2array of;
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function CopyTo(
   array : ISNet.WebUI.INamedObject2[],
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void CopyTo(
   ISNet.WebUI.INamedObject2*[]* array,
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject2^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHolidayCollection Class
WebSchedulerHolidayCollection Members


Count Property

[image]
Intersoft WebScheduler Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHolidayCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHolidayCollection
Dim value As System.Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function get Count : System.int
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property System.int get_Count();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHolidayCollection Class
WebSchedulerHolidayCollection Members


CreateNewItem Method

[image]
Intersoft WebScheduler Documentation
CreateNewItem Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHolidayCollection Class : CreateNewItem Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateNewItem() As WebSchedulerHoliday
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHolidayCollection
Dim value As WebSchedulerHoliday

value = instance.CreateNewItem()
C#
public WebSchedulerHoliday CreateNewItem()
Delphi
public function CreateNewItem(): WebSchedulerHoliday;
JScript
public function CreateNewItem() : WebSchedulerHoliday;
Managed Extensions for C++
public: WebSchedulerHoliday* CreateNewItem();
C++/CLI
public:
WebSchedulerHoliday^ CreateNewItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHolidayCollection Class
WebSchedulerHolidayCollection Members


GetEnumerator Method

[image]
Intersoft WebScheduler Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHolidayCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function GetEnumerator() As System.Collections.Generic.IEnumerator(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHolidayCollection
Dim value As System.Collections.Generic.IEnumerator(Of INamedObject2)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public System.Collections.Generic.IEnumerator<INamedObject2> GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.Generic.IEnumerator;
JScript
__DynamicallyInvokableAttribute()
public function GetEnumerator() : System.Collections.Generic.IEnumerator;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.Collections.Generic.IEnumerator<INamedObject2*>* GetEnumerator();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.Collections.Generic.IEnumerator<INamedObject2^>^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHolidayCollection Class
WebSchedulerHolidayCollection Members


GetNamedItem Method

[image]
Intersoft WebScheduler Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHolidayCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As WebSchedulerHoliday
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHolidayCollection
Dim name As System.String
Dim value As WebSchedulerHoliday

value = instance.GetNamedItem(name)
C#
public WebSchedulerHoliday GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebSchedulerHoliday;
JScript
public function GetNamedItem(
   name : System.String
) : WebSchedulerHoliday;
Managed Extensions for C++
public: WebSchedulerHoliday* GetNamedItem(
   System.string* name
)
C++/CLI
public:
WebSchedulerHoliday^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHolidayCollection Class
WebSchedulerHolidayCollection Members


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHolidayCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHolidayCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHolidayCollection Class
WebSchedulerHolidayCollection Members


IndexOf Method

[image]
Intersoft WebScheduler Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHolidayCollection Class : IndexOf Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function IndexOf( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHolidayCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Integer

value = instance.IndexOf(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.int IndexOf(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function IndexOf(
    item: ISNet.WebUI.INamedObject2
): System.Integer;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function IndexOf(
   item : ISNet.WebUI.INamedObject2
) : System.int;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.int IndexOf(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHolidayCollection Class
WebSchedulerHolidayCollection Members


Insert Method

[image]
Intersoft WebScheduler Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHolidayCollection Class : Insert Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHolidayCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.Insert(index, item)
C#
[__DynamicallyInvokableAttribute()]
public void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Insert(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Insert(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHolidayCollection Class
WebSchedulerHolidayCollection Members


Item Property

[image]
Intersoft WebScheduler Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHolidayCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Default Property Item( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHolidayCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject2

instance.Item(index) = value

value = instance.Item(index)
C#
[__DynamicallyInvokableAttribute()]
public ISNet.WebUI.INamedObject2 this[
   System.int index
]; {get; set;}
Delphi
public  this: : ISNet.WebUI.INamedObject2;[
    index: System.Integer
]; read-write
JScript
__DynamicallyInvokableAttribute()
public  this[
   index : System.int
] get,set : ISNet.WebUI.INamedObject2
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property ISNet.WebUI.INamedObject2* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   ISNet.WebUI.INamedObject2* value
;
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property ISNet.WebUI.INamedObject2^ default [int] {
   ISNet.WebUI.INamedObject2^ get(System.int index);
   void set (System.int index, ISNet.WebUI.INamedObject2^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHolidayCollection Class
WebSchedulerHolidayCollection Members


Parent Property

[image]
Intersoft WebScheduler Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHolidayCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHolidayCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHolidayCollection Class
WebSchedulerHolidayCollection Members


Remove Method

[image]
Intersoft WebScheduler Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHolidayCollection Class : Remove Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function Remove( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHolidayCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Remove(item)
C#
[__DynamicallyInvokableAttribute()]
public System.bool Remove(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Remove(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
__DynamicallyInvokableAttribute()
public function Remove(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.bool Remove(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.bool Remove(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHolidayCollection Class
WebSchedulerHolidayCollection Members


RemoveAt Method

[image]
Intersoft WebScheduler Documentation
RemoveAt Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHolidayCollection Class : RemoveAt Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHolidayCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
[__DynamicallyInvokableAttribute()]
public void RemoveAt(
   System.int index
)
Delphi
public procedure RemoveAt(
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
public function RemoveAt(
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void RemoveAt(
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void RemoveAt(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHolidayCollection Class
WebSchedulerHolidayCollection Members


SerializerConstructor Method

[image]
Intersoft WebScheduler Documentation
SerializerConstructor Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHolidayCollection Class : SerializerConstructor Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializerConstructor( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHolidayCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializerConstructor(info, context)
C#
public void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializerConstructor(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializerConstructor(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHolidayCollection Class
WebSchedulerHolidayCollection Members


SetParent Method

[image]
Intersoft WebScheduler Documentation
SetParent Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHolidayCollection Class : SetParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHolidayCollection
Dim parent As System.Object

instance.SetParent(parent)
C#
public virtual void SetParent(
   System.object parent
)
Delphi
public procedure SetParent(
    parent: System.TObject
); virtual;
JScript
public function SetParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void SetParent(
   System.Object* parent
)
C++/CLI
public:
virtual void SetParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHolidayCollection Class
WebSchedulerHolidayCollection Members


WebSchedulerHoliday Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerHoliday Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHoliday Class : WebSchedulerHoliday Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerHoliday Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHoliday Class
WebSchedulerHoliday Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHoliday Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHoliday
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHoliday Class
WebSchedulerHoliday Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHoliday Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHoliday Class
WebSchedulerHoliday Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHoliday Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHoliday
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHoliday Class
WebSchedulerHoliday Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHoliday Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHoliday
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHoliday Class
WebSchedulerHoliday Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHoliday Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHoliday
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHoliday Class
WebSchedulerHoliday Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHoliday Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHoliday
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHoliday Class
WebSchedulerHoliday Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHoliday Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHoliday
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHoliday Class
WebSchedulerHoliday Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHoliday Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHoliday

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHoliday Class
WebSchedulerHoliday Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHoliday Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHoliday
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHoliday Class
WebSchedulerHoliday Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerHoliday Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerHoliday
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerHoliday Class
WebSchedulerHoliday Members


WebSchedulerImagesSettings Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerImagesSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : WebSchedulerImagesSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerImagesSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerImagesSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerImagesSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerImagesSettings Class
WebSchedulerImagesSettings Members


WebSchedulerLayoutSettings Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerLayoutSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerLayoutSettings Class : WebSchedulerLayoutSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerLayoutSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerLayoutSettings Class
WebSchedulerLayoutSettings Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerLayoutSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerLayoutSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerLayoutSettings Class
WebSchedulerLayoutSettings Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerLayoutSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerLayoutSettings Class
WebSchedulerLayoutSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerLayoutSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerLayoutSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerLayoutSettings Class
WebSchedulerLayoutSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerLayoutSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerLayoutSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerLayoutSettings Class
WebSchedulerLayoutSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerLayoutSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerLayoutSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerLayoutSettings Class
WebSchedulerLayoutSettings Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerLayoutSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerLayoutSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerLayoutSettings Class
WebSchedulerLayoutSettings Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerLayoutSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerLayoutSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerLayoutSettings Class
WebSchedulerLayoutSettings Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerLayoutSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerLayoutSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerLayoutSettings Class
WebSchedulerLayoutSettings Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerLayoutSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerLayoutSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerLayoutSettings Class
WebSchedulerLayoutSettings Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerLayoutSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerLayoutSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerLayoutSettings Class
WebSchedulerLayoutSettings Members


WebSchedulerMonthView Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerMonthView Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerMonthView Class : WebSchedulerMonthView Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerMonthView Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerMonthView Class
WebSchedulerMonthView Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerMonthView Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerMonthView
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerMonthView Class
WebSchedulerMonthView Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerMonthView Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerMonthView Class
WebSchedulerMonthView Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerMonthView Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerMonthView
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerMonthView Class
WebSchedulerMonthView Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerMonthView Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerMonthView
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerMonthView Class
WebSchedulerMonthView Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerMonthView Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerMonthView
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerMonthView Class
WebSchedulerMonthView Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerMonthView Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerMonthView
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerMonthView Class
WebSchedulerMonthView Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerMonthView Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerMonthView
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerMonthView Class
WebSchedulerMonthView Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerMonthView Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerMonthView

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerMonthView Class
WebSchedulerMonthView Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerMonthView Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerMonthView
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerMonthView Class
WebSchedulerMonthView Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerMonthView Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerMonthView
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerMonthView Class
WebSchedulerMonthView Members


WebSchedulerQuarterView Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerQuarterView Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerQuarterView Class : WebSchedulerQuarterView Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerQuarterView Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerQuarterView Class
WebSchedulerQuarterView Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerQuarterView Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerQuarterView
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerQuarterView Class
WebSchedulerQuarterView Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerQuarterView Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerQuarterView Class
WebSchedulerQuarterView Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerQuarterView Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerQuarterView
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerQuarterView Class
WebSchedulerQuarterView Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerQuarterView Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerQuarterView
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerQuarterView Class
WebSchedulerQuarterView Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerQuarterView Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerQuarterView
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerQuarterView Class
WebSchedulerQuarterView Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerQuarterView Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerQuarterView
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerQuarterView Class
WebSchedulerQuarterView Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerQuarterView Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerQuarterView
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerQuarterView Class
WebSchedulerQuarterView Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerQuarterView Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerQuarterView

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerQuarterView Class
WebSchedulerQuarterView Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerQuarterView Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerQuarterView
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerQuarterView Class
WebSchedulerQuarterView Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerQuarterView Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerQuarterView
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerQuarterView Class
WebSchedulerQuarterView Members


WebSchedulerRecurrenceCollection Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurrenceCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerRecurrenceCollection Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerRecurrenceCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerRecurrence>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerRecurrence>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSchedulerRecurrence>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebSchedulerRecurrenceCollection Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerRecurrenceCollection Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurrenceCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerRecurrenceCollection Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerRecurrenceCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebSchedulerRecurrenceCollection Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerRecurrenceCollection Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurrenceCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceCollection Class : WebSchedulerRecurrenceCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerRecurrenceCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceCollection Class
WebSchedulerRecurrenceCollection Members


Add Method

[image]
Intersoft WebScheduler Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceCollection Class : Add Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Add( _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceCollection
Dim item As ISNet.WebUI.INamedObject2

instance.Add(item)
C#
[__DynamicallyInvokableAttribute()]
public void Add(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Add(
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Add(
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Add(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Add(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceCollection Class
WebSchedulerRecurrenceCollection Members


Clear Method

[image]
Intersoft WebScheduler Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceCollection

instance.Clear()
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void Clear()
Delphi
public procedure Clear();
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function Clear();
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void Clear();
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceCollection Class
WebSchedulerRecurrenceCollection Members


Contains Method

[image]
Intersoft WebScheduler Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceCollection Class : Contains Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function Contains( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Contains(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.bool Contains(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Contains(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function Contains(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.bool Contains(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.bool Contains(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceCollection Class
WebSchedulerRecurrenceCollection Members


CopyTo Method

[image]
Intersoft WebScheduler Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject2, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceCollection
Dim array() As ISNet.WebUI.INamedObject2
Dim index As System.Integer

instance.CopyTo(array, index)
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void CopyTo(
   ISNet.WebUI.INamedObject2[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObject2array of;
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function CopyTo(
   array : ISNet.WebUI.INamedObject2[],
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void CopyTo(
   ISNet.WebUI.INamedObject2*[]* array,
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject2^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceCollection Class
WebSchedulerRecurrenceCollection Members


Count Property

[image]
Intersoft WebScheduler Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceCollection
Dim value As System.Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function get Count : System.int
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property System.int get_Count();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceCollection Class
WebSchedulerRecurrenceCollection Members


CreateNewItem Method

[image]
Intersoft WebScheduler Documentation
CreateNewItem Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceCollection Class : CreateNewItem Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateNewItem() As WebSchedulerRecurrence
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceCollection
Dim value As WebSchedulerRecurrence

value = instance.CreateNewItem()
C#
public WebSchedulerRecurrence CreateNewItem()
Delphi
public function CreateNewItem(): WebSchedulerRecurrence;
JScript
public function CreateNewItem() : WebSchedulerRecurrence;
Managed Extensions for C++
public: WebSchedulerRecurrence* CreateNewItem();
C++/CLI
public:
WebSchedulerRecurrence^ CreateNewItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceCollection Class
WebSchedulerRecurrenceCollection Members


GetEnumerator Method

[image]
Intersoft WebScheduler Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function GetEnumerator() As System.Collections.Generic.IEnumerator(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceCollection
Dim value As System.Collections.Generic.IEnumerator(Of INamedObject2)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public System.Collections.Generic.IEnumerator<INamedObject2> GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.Generic.IEnumerator;
JScript
__DynamicallyInvokableAttribute()
public function GetEnumerator() : System.Collections.Generic.IEnumerator;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.Collections.Generic.IEnumerator<INamedObject2*>* GetEnumerator();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.Collections.Generic.IEnumerator<INamedObject2^>^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceCollection Class
WebSchedulerRecurrenceCollection Members


GetNamedItem Method

[image]
Intersoft WebScheduler Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As WebSchedulerRecurrence
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceCollection
Dim name As System.String
Dim value As WebSchedulerRecurrence

value = instance.GetNamedItem(name)
C#
public WebSchedulerRecurrence GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebSchedulerRecurrence;
JScript
public function GetNamedItem(
   name : System.String
) : WebSchedulerRecurrence;
Managed Extensions for C++
public: WebSchedulerRecurrence* GetNamedItem(
   System.string* name
)
C++/CLI
public:
WebSchedulerRecurrence^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceCollection Class
WebSchedulerRecurrenceCollection Members


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceCollection Class
WebSchedulerRecurrenceCollection Members


IndexOf Method

[image]
Intersoft WebScheduler Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceCollection Class : IndexOf Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function IndexOf( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Integer

value = instance.IndexOf(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.int IndexOf(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function IndexOf(
    item: ISNet.WebUI.INamedObject2
): System.Integer;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function IndexOf(
   item : ISNet.WebUI.INamedObject2
) : System.int;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.int IndexOf(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceCollection Class
WebSchedulerRecurrenceCollection Members


Insert Method

[image]
Intersoft WebScheduler Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceCollection Class : Insert Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.Insert(index, item)
C#
[__DynamicallyInvokableAttribute()]
public void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Insert(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Insert(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceCollection Class
WebSchedulerRecurrenceCollection Members


Item Property

[image]
Intersoft WebScheduler Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Default Property Item( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject2

instance.Item(index) = value

value = instance.Item(index)
C#
[__DynamicallyInvokableAttribute()]
public ISNet.WebUI.INamedObject2 this[
   System.int index
]; {get; set;}
Delphi
public  this: : ISNet.WebUI.INamedObject2;[
    index: System.Integer
]; read-write
JScript
__DynamicallyInvokableAttribute()
public  this[
   index : System.int
] get,set : ISNet.WebUI.INamedObject2
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property ISNet.WebUI.INamedObject2* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   ISNet.WebUI.INamedObject2* value
;
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property ISNet.WebUI.INamedObject2^ default [int] {
   ISNet.WebUI.INamedObject2^ get(System.int index);
   void set (System.int index, ISNet.WebUI.INamedObject2^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceCollection Class
WebSchedulerRecurrenceCollection Members


Parent Property

[image]
Intersoft WebScheduler Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceCollection Class
WebSchedulerRecurrenceCollection Members


Remove Method

[image]
Intersoft WebScheduler Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceCollection Class : Remove Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function Remove( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Remove(item)
C#
[__DynamicallyInvokableAttribute()]
public System.bool Remove(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Remove(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
__DynamicallyInvokableAttribute()
public function Remove(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.bool Remove(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.bool Remove(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceCollection Class
WebSchedulerRecurrenceCollection Members


RemoveAt Method

[image]
Intersoft WebScheduler Documentation
RemoveAt Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceCollection Class : RemoveAt Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
[__DynamicallyInvokableAttribute()]
public void RemoveAt(
   System.int index
)
Delphi
public procedure RemoveAt(
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
public function RemoveAt(
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void RemoveAt(
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void RemoveAt(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceCollection Class
WebSchedulerRecurrenceCollection Members


SerializerConstructor Method

[image]
Intersoft WebScheduler Documentation
SerializerConstructor Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceCollection Class : SerializerConstructor Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializerConstructor( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializerConstructor(info, context)
C#
public void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializerConstructor(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializerConstructor(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceCollection Class
WebSchedulerRecurrenceCollection Members


SetParent Method

[image]
Intersoft WebScheduler Documentation
SetParent Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceCollection Class : SetParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceCollection
Dim parent As System.Object

instance.SetParent(parent)
C#
public virtual void SetParent(
   System.object parent
)
Delphi
public procedure SetParent(
    parent: System.TObject
); virtual;
JScript
public function SetParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void SetParent(
   System.Object* parent
)
C++/CLI
public:
virtual void SetParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceCollection Class
WebSchedulerRecurrenceCollection Members


WebSchedulerRecurrencesBinding Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurrencesBinding Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrencesBinding Class : WebSchedulerRecurrencesBinding Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerRecurrencesBinding Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrencesBinding Class
WebSchedulerRecurrencesBinding Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrencesBinding Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrencesBinding
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrencesBinding Class
WebSchedulerRecurrencesBinding Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrencesBinding Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrencesBinding Class
WebSchedulerRecurrencesBinding Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrencesBinding Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrencesBinding
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrencesBinding Class
WebSchedulerRecurrencesBinding Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrencesBinding Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrencesBinding
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrencesBinding Class
WebSchedulerRecurrencesBinding Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrencesBinding Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrencesBinding
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrencesBinding Class
WebSchedulerRecurrencesBinding Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrencesBinding Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrencesBinding
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrencesBinding Class
WebSchedulerRecurrencesBinding Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrencesBinding Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrencesBinding
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrencesBinding Class
WebSchedulerRecurrencesBinding Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrencesBinding Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrencesBinding

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrencesBinding Class
WebSchedulerRecurrencesBinding Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrencesBinding Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrencesBinding
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrencesBinding Class
WebSchedulerRecurrencesBinding Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrencesBinding Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrencesBinding
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrencesBinding Class
WebSchedulerRecurrencesBinding Members


WebSchedulerRecurrenceTextSettings Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurrenceTextSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceTextSettings Class : WebSchedulerRecurrenceTextSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerRecurrenceTextSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceTextSettings Class
WebSchedulerRecurrenceTextSettings Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceTextSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceTextSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceTextSettings Class
WebSchedulerRecurrenceTextSettings Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceTextSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceTextSettings Class
WebSchedulerRecurrenceTextSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceTextSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceTextSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceTextSettings Class
WebSchedulerRecurrenceTextSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceTextSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceTextSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceTextSettings Class
WebSchedulerRecurrenceTextSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceTextSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceTextSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceTextSettings Class
WebSchedulerRecurrenceTextSettings Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceTextSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceTextSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceTextSettings Class
WebSchedulerRecurrenceTextSettings Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceTextSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceTextSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceTextSettings Class
WebSchedulerRecurrenceTextSettings Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceTextSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceTextSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceTextSettings Class
WebSchedulerRecurrenceTextSettings Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceTextSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceTextSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceTextSettings Class
WebSchedulerRecurrenceTextSettings Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrenceTextSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrenceTextSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrenceTextSettings Class
WebSchedulerRecurrenceTextSettings Members


WebSchedulerRecurrence Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurrence Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrence Class : WebSchedulerRecurrence Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerRecurrence Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrence Class
WebSchedulerRecurrence Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrence Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrence
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrence Class
WebSchedulerRecurrence Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrence Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrence Class
WebSchedulerRecurrence Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrence Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrence
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrence Class
WebSchedulerRecurrence Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrence Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrence
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrence Class
WebSchedulerRecurrence Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrence Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrence
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrence Class
WebSchedulerRecurrence Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrence Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrence
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrence Class
WebSchedulerRecurrence Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrence Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrence
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrence Class
WebSchedulerRecurrence Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrence Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrence

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrence Class
WebSchedulerRecurrence Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrence Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrence
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrence Class
WebSchedulerRecurrence Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurrence Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurrence
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurrence Class
WebSchedulerRecurrence Members


WebSchedulerRecurringEventBinding Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurringEventBinding Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEventBinding Class : WebSchedulerRecurringEventBinding Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerRecurringEventBinding Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEventBinding Class
WebSchedulerRecurringEventBinding Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEventBinding Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurringEventBinding
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEventBinding Class
WebSchedulerRecurringEventBinding Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEventBinding Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEventBinding Class
WebSchedulerRecurringEventBinding Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEventBinding Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurringEventBinding
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEventBinding Class
WebSchedulerRecurringEventBinding Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEventBinding Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurringEventBinding
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEventBinding Class
WebSchedulerRecurringEventBinding Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEventBinding Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurringEventBinding
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEventBinding Class
WebSchedulerRecurringEventBinding Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEventBinding Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurringEventBinding
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEventBinding Class
WebSchedulerRecurringEventBinding Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEventBinding Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurringEventBinding
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEventBinding Class
WebSchedulerRecurringEventBinding Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEventBinding Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurringEventBinding

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEventBinding Class
WebSchedulerRecurringEventBinding Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEventBinding Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurringEventBinding
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEventBinding Class
WebSchedulerRecurringEventBinding Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEventBinding Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurringEventBinding
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEventBinding Class
WebSchedulerRecurringEventBinding Members


WebSchedulerRecurringEvent Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerRecurringEvent Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEvent Class : WebSchedulerRecurringEvent Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerRecurringEvent Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEvent Class
WebSchedulerRecurringEvent Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEvent Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurringEvent
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEvent Class
WebSchedulerRecurringEvent Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEvent Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEvent Class
WebSchedulerRecurringEvent Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEvent Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurringEvent
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEvent Class
WebSchedulerRecurringEvent Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEvent Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurringEvent
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEvent Class
WebSchedulerRecurringEvent Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEvent Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurringEvent
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEvent Class
WebSchedulerRecurringEvent Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEvent Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurringEvent
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEvent Class
WebSchedulerRecurringEvent Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEvent Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurringEvent
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEvent Class
WebSchedulerRecurringEvent Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEvent Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurringEvent

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEvent Class
WebSchedulerRecurringEvent Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEvent Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurringEvent
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEvent Class
WebSchedulerRecurringEvent Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerRecurringEvent Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerRecurringEvent
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerRecurringEvent Class
WebSchedulerRecurringEvent Members


WebSchedulerResourceCollection Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerResourceCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerResourceCollection Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerResourceCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebSchedulerResourceCollection Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerResourceCollection Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerResourceCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourceCollection Class : WebSchedulerResourceCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerResourceCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceCollection Class
WebSchedulerResourceCollection Members


Add Method

[image]
Intersoft WebScheduler Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourceCollection Class : Add Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Add( _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourceCollection
Dim item As ISNet.WebUI.INamedObject2

instance.Add(item)
C#
[__DynamicallyInvokableAttribute()]
public void Add(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Add(
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Add(
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Add(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Add(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceCollection Class
WebSchedulerResourceCollection Members


Clear Method

[image]
Intersoft WebScheduler Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourceCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourceCollection

instance.Clear()
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void Clear()
Delphi
public procedure Clear();
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function Clear();
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void Clear();
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceCollection Class
WebSchedulerResourceCollection Members


Contains Method

[image]
Intersoft WebScheduler Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourceCollection Class : Contains Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function Contains( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourceCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Contains(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.bool Contains(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Contains(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function Contains(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.bool Contains(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.bool Contains(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceCollection Class
WebSchedulerResourceCollection Members


CopyTo Method

[image]
Intersoft WebScheduler Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourceCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject2, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourceCollection
Dim array() As ISNet.WebUI.INamedObject2
Dim index As System.Integer

instance.CopyTo(array, index)
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void CopyTo(
   ISNet.WebUI.INamedObject2[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObject2array of;
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function CopyTo(
   array : ISNet.WebUI.INamedObject2[],
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void CopyTo(
   ISNet.WebUI.INamedObject2*[]* array,
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject2^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceCollection Class
WebSchedulerResourceCollection Members


Count Property

[image]
Intersoft WebScheduler Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourceCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourceCollection
Dim value As System.Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function get Count : System.int
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property System.int get_Count();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceCollection Class
WebSchedulerResourceCollection Members


CreateNewItem Method

[image]
Intersoft WebScheduler Documentation
CreateNewItem Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourceCollection Class : CreateNewItem Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateNewItem() As WebSchedulerResource
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourceCollection
Dim value As WebSchedulerResource

value = instance.CreateNewItem()
C#
public WebSchedulerResource CreateNewItem()
Delphi
public function CreateNewItem(): WebSchedulerResource;
JScript
public function CreateNewItem() : WebSchedulerResource;
Managed Extensions for C++
public: WebSchedulerResource* CreateNewItem();
C++/CLI
public:
WebSchedulerResource^ CreateNewItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceCollection Class
WebSchedulerResourceCollection Members


GetEnumerator Method

[image]
Intersoft WebScheduler Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourceCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function GetEnumerator() As System.Collections.Generic.IEnumerator(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourceCollection
Dim value As System.Collections.Generic.IEnumerator(Of INamedObject2)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public System.Collections.Generic.IEnumerator<INamedObject2> GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.Generic.IEnumerator;
JScript
__DynamicallyInvokableAttribute()
public function GetEnumerator() : System.Collections.Generic.IEnumerator;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.Collections.Generic.IEnumerator<INamedObject2*>* GetEnumerator();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.Collections.Generic.IEnumerator<INamedObject2^>^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceCollection Class
WebSchedulerResourceCollection Members


GetNamedItem Method

[image]
Intersoft WebScheduler Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourceCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As WebSchedulerResource
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourceCollection
Dim name As System.String
Dim value As WebSchedulerResource

value = instance.GetNamedItem(name)
C#
public WebSchedulerResource GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebSchedulerResource;
JScript
public function GetNamedItem(
   name : System.String
) : WebSchedulerResource;
Managed Extensions for C++
public: WebSchedulerResource* GetNamedItem(
   System.string* name
)
C++/CLI
public:
WebSchedulerResource^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceCollection Class
WebSchedulerResourceCollection Members


GetObjectData Method

[image]
Intersoft WebScheduler Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourceCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourceCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceCollection Class
WebSchedulerResourceCollection Members


IndexOf Method

[image]
Intersoft WebScheduler Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourceCollection Class : IndexOf Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function IndexOf( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourceCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Integer

value = instance.IndexOf(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.int IndexOf(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function IndexOf(
    item: ISNet.WebUI.INamedObject2
): System.Integer;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function IndexOf(
   item : ISNet.WebUI.INamedObject2
) : System.int;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.int IndexOf(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceCollection Class
WebSchedulerResourceCollection Members


Insert Method

[image]
Intersoft WebScheduler Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourceCollection Class : Insert Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourceCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.Insert(index, item)
C#
[__DynamicallyInvokableAttribute()]
public void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Insert(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Insert(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceCollection Class
WebSchedulerResourceCollection Members


Item Property

[image]
Intersoft WebScheduler Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourceCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Default Property Item( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourceCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject2

instance.Item(index) = value

value = instance.Item(index)
C#
[__DynamicallyInvokableAttribute()]
public ISNet.WebUI.INamedObject2 this[
   System.int index
]; {get; set;}
Delphi
public  this: : ISNet.WebUI.INamedObject2;[
    index: System.Integer
]; read-write
JScript
__DynamicallyInvokableAttribute()
public  this[
   index : System.int
] get,set : ISNet.WebUI.INamedObject2
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property ISNet.WebUI.INamedObject2* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   ISNet.WebUI.INamedObject2* value
;
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property ISNet.WebUI.INamedObject2^ default [int] {
   ISNet.WebUI.INamedObject2^ get(System.int index);
   void set (System.int index, ISNet.WebUI.INamedObject2^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceCollection Class
WebSchedulerResourceCollection Members


Parent Property

[image]
Intersoft WebScheduler Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourceCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourceCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceCollection Class
WebSchedulerResourceCollection Members


Remove Method

[image]
Intersoft WebScheduler Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourceCollection Class : Remove Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function Remove( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourceCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Remove(item)
C#
[__DynamicallyInvokableAttribute()]
public System.bool Remove(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Remove(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
__DynamicallyInvokableAttribute()
public function Remove(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.bool Remove(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.bool Remove(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceCollection Class
WebSchedulerResourceCollection Members


RemoveAt Method

[image]
Intersoft WebScheduler Documentation
RemoveAt Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourceCollection Class : RemoveAt Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourceCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
[__DynamicallyInvokableAttribute()]
public void RemoveAt(
   System.int index
)
Delphi
public procedure RemoveAt(
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
public function RemoveAt(
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void RemoveAt(
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void RemoveAt(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceCollection Class
WebSchedulerResourceCollection Members


SerializerConstructor Method

[image]
Intersoft WebScheduler Documentation
SerializerConstructor Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourceCollection Class : SerializerConstructor Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializerConstructor( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourceCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializerConstructor(info, context)
C#
public void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializerConstructor(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializerConstructor(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceCollection Class
WebSchedulerResourceCollection Members


SetParent Method

[image]
Intersoft WebScheduler Documentation
SetParent Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourceCollection Class : SetParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourceCollection
Dim parent As System.Object

instance.SetParent(parent)
C#
public virtual void SetParent(
   System.object parent
)
Delphi
public procedure SetParent(
    parent: System.TObject
); virtual;
JScript
public function SetParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void SetParent(
   System.Object* parent
)
C++/CLI
public:
virtual void SetParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceCollection Class
WebSchedulerResourceCollection Members


WebSchedulerResourceDataEditing Class Methods

[image]
Intersoft WebScheduler Documentation
WebSchedulerResourceDataEditing Class Methods
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerResourceDataEditing Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerResourceDataEditing members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerDataEditing)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSchedulerResourceDataEditing Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerResourceDataEditing Class Properties

[image]
Intersoft WebScheduler Documentation
WebSchedulerResourceDataEditing Class Properties
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace : WebSchedulerResourceDataEditing Class

Glossary Item Box

For a list of all members of this type, see WebSchedulerResourceDataEditing members.

Public Properties

 | Name | Description
Public Property | AllowAdd | Indicates whether WebScheduler can add a new event. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerDataEditing)
Public Property | AllowDelete | Indicates whether WebScheduler can delete an event. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerDataEditing)
Public Property | AllowEdit | Indicates whether WebScheduler can edit an event. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerDataEditing)
Public Property | AllowMove | Indicates whether an event can be moved. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerDataEditing)
Public Property | AllowResize | Indicates whether an event can be resized. (Inherited from ISNet.WebUI.WebScheduler.WebSchedulerDataEditing)
Top

See Also

Reference

WebSchedulerResourceDataEditing Class
ISNet.WebUI.WebScheduler Namespace


WebSchedulerResourceDataEditing Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerResourceDataEditing Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourceDataEditing Class : WebSchedulerResourceDataEditing Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerResourceDataEditing Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceDataEditing Class
WebSchedulerResourceDataEditing Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourceDataEditing Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourceDataEditing
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceDataEditing Class
WebSchedulerResourceDataEditing Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourceDataEditing Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceDataEditing Class
WebSchedulerResourceDataEditing Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourceDataEditing Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourceDataEditing
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceDataEditing Class
WebSchedulerResourceDataEditing Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourceDataEditing Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourceDataEditing
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceDataEditing Class
WebSchedulerResourceDataEditing Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourceDataEditing Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourceDataEditing
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceDataEditing Class
WebSchedulerResourceDataEditing Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourceDataEditing Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourceDataEditing
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceDataEditing Class
WebSchedulerResourceDataEditing Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourceDataEditing Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourceDataEditing
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceDataEditing Class
WebSchedulerResourceDataEditing Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourceDataEditing Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourceDataEditing

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceDataEditing Class
WebSchedulerResourceDataEditing Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourceDataEditing Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourceDataEditing
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceDataEditing Class
WebSchedulerResourceDataEditing Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourceDataEditing Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourceDataEditing
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourceDataEditing Class
WebSchedulerResourceDataEditing Members


WebSchedulerResourcesBinding Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerResourcesBinding Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourcesBinding Class : WebSchedulerResourcesBinding Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerResourcesBinding Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourcesBinding Class
WebSchedulerResourcesBinding Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourcesBinding Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourcesBinding
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourcesBinding Class
WebSchedulerResourcesBinding Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourcesBinding Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourcesBinding Class
WebSchedulerResourcesBinding Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourcesBinding Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourcesBinding
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourcesBinding Class
WebSchedulerResourcesBinding Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourcesBinding Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourcesBinding
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourcesBinding Class
WebSchedulerResourcesBinding Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourcesBinding Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourcesBinding
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourcesBinding Class
WebSchedulerResourcesBinding Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourcesBinding Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourcesBinding
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourcesBinding Class
WebSchedulerResourcesBinding Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourcesBinding Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourcesBinding
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourcesBinding Class
WebSchedulerResourcesBinding Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourcesBinding Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourcesBinding

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourcesBinding Class
WebSchedulerResourcesBinding Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourcesBinding Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourcesBinding
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourcesBinding Class
WebSchedulerResourcesBinding Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResourcesBinding Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResourcesBinding
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResourcesBinding Class
WebSchedulerResourcesBinding Members


WebSchedulerResource Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerResource Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResource Class : WebSchedulerResource Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerResource Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResource Class
WebSchedulerResource Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResource Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResource
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResource Class
WebSchedulerResource Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResource Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResource Class
WebSchedulerResource Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResource Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResource
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResource Class
WebSchedulerResource Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResource Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResource
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResource Class
WebSchedulerResource Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResource Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResource
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResource Class
WebSchedulerResource Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResource Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResource
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResource Class
WebSchedulerResource Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResource Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResource
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResource Class
WebSchedulerResource Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResource Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResource

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResource Class
WebSchedulerResource Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResource Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResource
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResource Class
WebSchedulerResource Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerResource Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerResource
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerResource Class
WebSchedulerResource Members


WebSchedulerTextSettings Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerTextSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : WebSchedulerTextSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerTextSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTextSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTextSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTextSettings Class
WebSchedulerTextSettings Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimeBasedEventStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimeBasedEventStyle
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimeBasedEventStyle Class
WebSchedulerTimeBasedEventStyle Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimeBasedEventStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimeBasedEventStyle Class
WebSchedulerTimeBasedEventStyle Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimeBasedEventStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimeBasedEventStyle
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimeBasedEventStyle Class
WebSchedulerTimeBasedEventStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimeBasedEventStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimeBasedEventStyle
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimeBasedEventStyle Class
WebSchedulerTimeBasedEventStyle Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimeBasedEventStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimeBasedEventStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimeBasedEventStyle Class
WebSchedulerTimeBasedEventStyle Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimeBasedEventStyle Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimeBasedEventStyle
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimeBasedEventStyle Class
WebSchedulerTimeBasedEventStyle Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimeBasedEventStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimeBasedEventStyle
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimeBasedEventStyle Class
WebSchedulerTimeBasedEventStyle Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimeBasedEventStyle Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimeBasedEventStyle

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimeBasedEventStyle Class
WebSchedulerTimeBasedEventStyle Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimeBasedEventStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimeBasedEventStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimeBasedEventStyle Class
WebSchedulerTimeBasedEventStyle Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimeBasedEventStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimeBasedEventStyle
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimeBasedEventStyle Class
WebSchedulerTimeBasedEventStyle Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerTimelineView Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerTimelineView
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerTimelineView Class
WebSchedulerTimelineView Members


WebSchedulerViewSettings Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerViewSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerViewSettings Class : WebSchedulerViewSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerViewSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerViewSettings Class
WebSchedulerViewSettings Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerViewSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerViewSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerViewSettings Class
WebSchedulerViewSettings Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerViewSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerViewSettings Class
WebSchedulerViewSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerViewSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerViewSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerViewSettings Class
WebSchedulerViewSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerViewSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerViewSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerViewSettings Class
WebSchedulerViewSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerViewSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerViewSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerViewSettings Class
WebSchedulerViewSettings Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerViewSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerViewSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerViewSettings Class
WebSchedulerViewSettings Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerViewSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerViewSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerViewSettings Class
WebSchedulerViewSettings Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerViewSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerViewSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerViewSettings Class
WebSchedulerViewSettings Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerViewSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerViewSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerViewSettings Class
WebSchedulerViewSettings Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerViewSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerViewSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerViewSettings Class
WebSchedulerViewSettings Members


WebSchedulerWeekView Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerWeekView Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWeekView Class : WebSchedulerWeekView Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerWeekView Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWeekView Class
WebSchedulerWeekView Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWeekView Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWeekView
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWeekView Class
WebSchedulerWeekView Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWeekView Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWeekView Class
WebSchedulerWeekView Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWeekView Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWeekView
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWeekView Class
WebSchedulerWeekView Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWeekView Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWeekView
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWeekView Class
WebSchedulerWeekView Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWeekView Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWeekView
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWeekView Class
WebSchedulerWeekView Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWeekView Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWeekView
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWeekView Class
WebSchedulerWeekView Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWeekView Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWeekView
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWeekView Class
WebSchedulerWeekView Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWeekView Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWeekView

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWeekView Class
WebSchedulerWeekView Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWeekView Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWeekView
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWeekView Class
WebSchedulerWeekView Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWeekView Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWeekView
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWeekView Class
WebSchedulerWeekView Members


WebSchedulerWorkWeekSettings Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerWorkWeekSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWorkWeekSettings Class : WebSchedulerWorkWeekSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerWorkWeekSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWorkWeekSettings Class
WebSchedulerWorkWeekSettings Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWorkWeekSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWorkWeekSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWorkWeekSettings Class
WebSchedulerWorkWeekSettings Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWorkWeekSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWorkWeekSettings Class
WebSchedulerWorkWeekSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWorkWeekSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWorkWeekSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWorkWeekSettings Class
WebSchedulerWorkWeekSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWorkWeekSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWorkWeekSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWorkWeekSettings Class
WebSchedulerWorkWeekSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWorkWeekSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWorkWeekSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWorkWeekSettings Class
WebSchedulerWorkWeekSettings Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWorkWeekSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWorkWeekSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWorkWeekSettings Class
WebSchedulerWorkWeekSettings Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWorkWeekSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWorkWeekSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWorkWeekSettings Class
WebSchedulerWorkWeekSettings Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWorkWeekSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWorkWeekSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWorkWeekSettings Class
WebSchedulerWorkWeekSettings Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWorkWeekSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWorkWeekSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWorkWeekSettings Class
WebSchedulerWorkWeekSettings Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerWorkWeekSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerWorkWeekSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerWorkWeekSettings Class
WebSchedulerWorkWeekSettings Members


WebSchedulerYearView Constructor

[image]
Intersoft WebScheduler Documentation
WebSchedulerYearView Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerYearView Class : WebSchedulerYearView Constructor

Glossary Item Box

Overload List

Overload | Description
WebSchedulerYearView Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerYearView Class
WebSchedulerYearView Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerYearView Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerYearView
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerYearView Class
WebSchedulerYearView Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerYearView Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerYearView Class
WebSchedulerYearView Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerYearView Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerYearView
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerYearView Class
WebSchedulerYearView Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerYearView Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerYearView
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerYearView Class
WebSchedulerYearView Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerYearView Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerYearView
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerYearView Class
WebSchedulerYearView Members


GetHashCode Method

[image]
Intersoft WebScheduler Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerYearView Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerYearView
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerYearView Class
WebSchedulerYearView Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerYearView Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerYearView
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerYearView Class
WebSchedulerYearView Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerYearView Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerYearView

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerYearView Class
WebSchedulerYearView Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerYearView Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerYearView
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerYearView Class
WebSchedulerYearView Members


ToString Method

[image]
Intersoft WebScheduler Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebSchedulerYearView Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSchedulerYearView
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSchedulerYearView Class
WebSchedulerYearView Members


WebScheduler Constructor

[image]
Intersoft WebScheduler Documentation
WebScheduler Constructor
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : WebScheduler Constructor

Glossary Item Box

Overload List

Overload | Description
WebScheduler Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


AccessKey Property

[image]
Intersoft WebScheduler Documentation
AccessKey Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : AccessKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property AccessKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.String

instance.AccessKey = value

value = instance.AccessKey
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string AccessKey {get; set;}
Delphi
public read-write property AccessKey: System.String; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set AccessKey : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_AccessKey();
public: __property virtual void set_AccessKey(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ AccessKey {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ApplyStyle Method

[image]
Intersoft WebScheduler Documentation
ApplyStyle Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure ApplyStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function ApplyStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void ApplyStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void ApplyStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebScheduler Documentation
ApplyStyleSheetSkin Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)
Delphi
public procedure ApplyStyleSheetSkin(
    page: System.Web.UI.Page
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function ApplyStyleSheetSkin(
   page : System.Web.UI.Page
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page* page
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page^ page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


BackColor Property

[image]
Intersoft WebScheduler Documentation
BackColor Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : BackColor Property

Glossary Item Box

Background's color of the control.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Frame Appearance")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property BackColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual System.Drawing.Color BackColor {get; set;}
Delphi
public read-write property BackColor: System.Drawing.Color; virtual;
JScript
System.ComponentModel.CategoryAttribute("Frame Appearance")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
public function get,set BackColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual System.Drawing.Color get_BackColor();
public: __property virtual void set_BackColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property System.Drawing.Color BackColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


BorderColor Property

[image]
Intersoft WebScheduler Documentation
BorderColor Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : BorderColor Property

Glossary Item Box

Color of the border around the control.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Frame Appearance")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
Public Overridable Property BorderColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public virtual System.Drawing.Color BorderColor {get; set;}
Delphi
public read-write property BorderColor: System.Drawing.Color; virtual;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Frame Appearance")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
public function get,set BorderColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public: __property virtual System.Drawing.Color get_BorderColor();
public: __property virtual void set_BorderColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public:
virtual property System.Drawing.Color BorderColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


BorderStyle Property

[image]
Intersoft WebScheduler Documentation
BorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : BorderStyle Property

Glossary Item Box

Style of the border around the control.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Frame Appearance")>
Public Overridable Property BorderStyle As System.Web.UI.WebControls.BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Web.UI.WebControls.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
public virtual System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}
Delphi
public read-write property BorderStyle: System.Web.UI.WebControls.BorderStyle; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Frame Appearance")
public function get,set BorderStyle : System.Web.UI.WebControls.BorderStyle
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
public: __property virtual System.Web.UI.WebControls.BorderStyle get_BorderStyle();
public: __property virtual void set_BorderStyle(
   System.Web.UI.WebControls.BorderStyle value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
public:
virtual property System.Web.UI.WebControls.BorderStyle BorderStyle {
   System.Web.UI.WebControls.BorderStyle get();
   void set (    System.Web.UI.WebControls.BorderStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


BorderWidth Property

[image]
Intersoft WebScheduler Documentation
BorderWidth Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : BorderWidth Property

Glossary Item Box

Width of the border around the control.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Frame Appearance")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property BorderWidth As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Web.UI.WebControls.Unit

instance.BorderWidth = value

value = instance.BorderWidth
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual System.Web.UI.WebControls.Unit BorderWidth {get; set;}
Delphi
public read-write property BorderWidth: System.Web.UI.WebControls.Unit; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Frame Appearance")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set BorderWidth : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual System.Web.UI.WebControls.Unit get_BorderWidth();
public: __property virtual void set_BorderWidth(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property System.Web.UI.WebControls.Unit BorderWidth {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


CanUseWebResources Method

[image]
Intersoft WebScheduler Documentation
CanUseWebResources Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : CanUseWebResources Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CanUseWebResources() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

value = instance.CanUseWebResources()
C#
public System.bool CanUseWebResources()
Delphi
public function CanUseWebResources(): System.Boolean;
JScript
public function CanUseWebResources() : System.boolean;
Managed Extensions for C++
public: System.bool CanUseWebResources();
C++/CLI
public:
System.bool CanUseWebResources();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ClientIDMode Property

[image]
Intersoft WebScheduler Documentation
ClientIDMode Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")>
Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}
Delphi
public read-write property ClientIDMode: System.Web.UI.ClientIDMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")
public function get,set ClientIDMode : System.Web.UI.ClientIDMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public: __property virtual System.Web.UI.ClientIDMode get_ClientIDMode();
public: __property virtual void set_ClientIDMode(
   System.Web.UI.ClientIDMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public:
virtual property System.Web.UI.ClientIDMode ClientIDMode {
   System.Web.UI.ClientIDMode get();
   void set (    System.Web.UI.ClientIDMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


Clone Method

[image]
Intersoft WebScheduler Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ControlDataTransferFormat Property

[image]
Intersoft WebScheduler Documentation
ControlDataTransferFormat Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ControlDataTransferFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property ControlDataTransferFormat As ISNet.WebUI.DataTransferFormat
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.DataTransferFormat

instance.ControlDataTransferFormat = value

value = instance.ControlDataTransferFormat
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {get; set;}
Delphi
public read-write property ControlDataTransferFormat: ISNet.WebUI.DataTransferFormat; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set ControlDataTransferFormat : ISNet.WebUI.DataTransferFormat
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual ISNet.WebUI.DataTransferFormat get_ControlDataTransferFormat();
public: __property virtual void set_ControlDataTransferFormat(
   ISNet.WebUI.DataTransferFormat value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {
   ISNet.WebUI.DataTransferFormat get();
   void set (    ISNet.WebUI.DataTransferFormat value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


CopyBaseAttributes Method

[image]
Intersoft WebScheduler Documentation
CopyBaseAttributes Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)
Delphi
public procedure CopyBaseAttributes(
    controlSrc: System.Web.UI.WebControls.WebControl
);
JScript
public function CopyBaseAttributes(
   controlSrc : System.Web.UI.WebControls.WebControl
);
Managed Extensions for C++
public: void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl* controlSrc
)
C++/CLI
public:
void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl^ controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


CopyFrom Method

[image]
Intersoft WebScheduler Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.ISNetControl)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


CopyFrom(Object) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebScheduler Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members
Overload List


CssClass Property

[image]
Intersoft WebScheduler Documentation
CssClass Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : CssClass Property

Glossary Item Box

CSS Class name applied to the control.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Frame Appearance")>
Public Overridable Property CssClass As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.String

instance.CssClass = value

value = instance.CssClass
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
public virtual System.string CssClass {get; set;}
Delphi
public read-write property CssClass: System.String; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Frame Appearance")
public function get,set CssClass : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
public: __property virtual System.string* get_CssClass();
public: __property virtual void set_CssClass(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
public:
virtual property System.String^ CssClass {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


DataBind Method

[image]
Intersoft WebScheduler Documentation
DataBind Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : DataBind Method

Glossary Item Box

Overload List

Overload | Description
DataBind | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


DataBind() Method

[image]
Intersoft WebScheduler Documentation
DataBind() Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler

instance.DataBind()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public virtual void DataBind()
Delphi
public procedure DataBind(); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function DataBind();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual void DataBind();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual void DataBind();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


DataBinding Event

[image]
Intersoft WebScheduler Documentation
DataBinding Event
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")>
<WebCategoryAttribute("Data")>
Public Event DataBinding As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim handler As System.EventHandler

AddHandler instance.DataBinding, handler
C#
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public event System.EventHandler DataBinding
Delphi
public event DataBinding: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public: __event System.EventHandler* DataBinding
C++/CLI
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public:
event System.EventHandler^ DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


DeSerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


Dispose Method

[image]
Intersoft WebScheduler Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler

instance.Dispose()
C#
public virtual void Dispose()
Delphi
public procedure Dispose(); virtual;
JScript
public function Dispose();
Managed Extensions for C++
public: virtual void Dispose();
C++/CLI
public:
virtual void Dispose();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


Disposed Event

[image]
Intersoft WebScheduler Documentation
Disposed Event
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control has been disposed.")>
Public Event Disposed As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
C#
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public event System.EventHandler Disposed
Delphi
public event Disposed: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public: __event System.EventHandler* Disposed
C++/CLI
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public:
event System.EventHandler^ Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


Enabled Property

[image]
Intersoft WebScheduler Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : Enabled Property

Glossary Item Box

Enables state of the control.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set Enabled : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.bool get_Enabled();
public: __property virtual void set_Enabled(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


EnableManagedTheming Property

[image]
Intersoft WebScheduler Documentation
EnableManagedTheming Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : EnableManagedTheming Property

Glossary Item Box

Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Overridable Property EnableManagedTheming As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

instance.EnableManagedTheming = value

value = instance.EnableManagedTheming
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public virtual System.bool EnableManagedTheming {get; set;}
Delphi
public read-write property EnableManagedTheming: System.Boolean; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set EnableManagedTheming : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property virtual System.bool get_EnableManagedTheming();
public: __property virtual void set_EnableManagedTheming(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
virtual property System.bool EnableManagedTheming {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


EnableTheming Property

[image]
Intersoft WebScheduler Documentation
EnableTheming Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : EnableTheming Property

Glossary Item Box

Indicates whether the control can be themed.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property EnableTheming As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.bool EnableTheming {get; set;}
Delphi
public read-write property EnableTheming: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set EnableTheming : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.bool get_EnableTheming();
public: __property virtual void set_EnableTheming(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.bool EnableTheming {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


EnableViewState Property

[image]
Intersoft WebScheduler Documentation
EnableViewState Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : EnableViewState Property

Glossary Item Box

Indicates whether control automatically saves its state for use in round-trips.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property EnableViewState As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.bool EnableViewState {get; set;}
Delphi
public read-write property EnableViewState: System.Boolean; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set EnableViewState : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.bool get_EnableViewState();
public: __property virtual void set_EnableViewState(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.bool EnableViewState {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


EnableWebResources Property

[image]
Intersoft WebScheduler Documentation
EnableWebResources Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : EnableWebResources Property

Glossary Item Box

Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Web Resources")>
Public Property EnableWebResources As ISNet.WebUI.WebResourceType
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.WebResourceType

instance.EnableWebResources = value

value = instance.EnableWebResources
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public ISNet.WebUI.WebResourceType EnableWebResources {get; set;}
Delphi
public read-write property EnableWebResources: ISNet.WebUI.WebResourceType;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Web Resources")
public function get,set EnableWebResources : ISNet.WebUI.WebResourceType
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public: __property ISNet.WebUI.WebResourceType get_EnableWebResources();
public: __property void set_EnableWebResources(
   ISNet.WebUI.WebResourceType value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public:
property ISNet.WebUI.WebResourceType EnableWebResources {
   ISNet.WebUI.WebResourceType get();
   void set (    ISNet.WebUI.WebResourceType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


FindControl Method

[image]
Intersoft WebScheduler Documentation
FindControl Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


FindControl(String) Method

[image]
Intersoft WebScheduler Documentation
FindControl(String) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function FindControl( _
   ByVal id As System.String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim id As System.String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
public virtual System.Web.UI.Control FindControl(
   System.string id
)
Delphi
public function FindControl(
    id: System.String
): System.Web.UI.Control; virtual;
JScript
public function FindControl(
   id : System.String
) : System.Web.UI.Control;
Managed Extensions for C++
public: virtual System.Web.UI.Control* FindControl(
   System.string* id
)
C++/CLI
public:
virtual System.Web.UI.Control^ FindControl(
   System.String^ id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


Focus Method

[image]
Intersoft WebScheduler Documentation
Focus Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler

instance.Focus()
C#
public virtual void Focus()
Delphi
public procedure Focus(); virtual;
JScript
public function Focus();
Managed Extensions for C++
public: virtual void Focus();
C++/CLI
public:
virtual void Focus();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


Font Property

[image]
Intersoft WebScheduler Documentation
Font Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : Font Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Frame Appearance")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
Public Overridable ReadOnly Property Font As System.Web.UI.WebControls.FontInfo
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Web.UI.WebControls.FontInfo

value = instance.Font
C#
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public virtual System.Web.UI.WebControls.FontInfo Font {get;}
Delphi
public read-only property Font: System.Web.UI.WebControls.FontInfo; virtual;
JScript
System.ComponentModel.CategoryAttribute("Frame Appearance")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
public function get Font : System.Web.UI.WebControls.FontInfo
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public: __property virtual System.Web.UI.WebControls.FontInfo* get_Font();
C++/CLI
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public:
virtual property System.Web.UI.WebControls.FontInfo^ Font {
   System.Web.UI.WebControls.FontInfo^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ForceDisableXmlCompression Method

[image]
Intersoft WebScheduler Documentation
ForceDisableXmlCompression Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ForceDisableXmlCompression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ForceDisableXmlCompression()
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler

instance.ForceDisableXmlCompression()
C#
public void ForceDisableXmlCompression()
Delphi
public procedure ForceDisableXmlCompression();
JScript
public function ForceDisableXmlCompression();
Managed Extensions for C++
public: void ForceDisableXmlCompression();
C++/CLI
public:
void ForceDisableXmlCompression();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ForeColor Property

[image]
Intersoft WebScheduler Documentation
ForeColor Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ForeColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Frame Appearance")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property ForeColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual System.Drawing.Color ForeColor {get; set;}
Delphi
public read-write property ForeColor: System.Drawing.Color; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Frame Appearance")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ForeColor : System.Drawing.Color
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual System.Drawing.Color get_ForeColor();
public: __property virtual void set_ForeColor(
   System.Drawing.Color value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property System.Drawing.Color ForeColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


GetCurrentControlLifeCycle Method

[image]
Intersoft WebScheduler Documentation
GetCurrentControlLifeCycle Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : GetCurrentControlLifeCycle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentControlLifeCycle() As ISNet.WebUI.ControlLifeCycle
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.ControlLifeCycle

value = instance.GetCurrentControlLifeCycle()
C#
public ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle()
Delphi
public function GetCurrentControlLifeCycle(): ISNet.WebUI.ControlLifeCycle;
JScript
public function GetCurrentControlLifeCycle() : ISNet.WebUI.ControlLifeCycle;
Managed Extensions for C++
public: ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle();
C++/CLI
public:
ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


GetCurrentTheme Method

[image]
Intersoft WebScheduler Documentation
GetCurrentTheme Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : GetCurrentTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCurrentTheme()
C#
public ISNet.WebUI.ThemeInfo GetCurrentTheme()
Delphi
public function GetCurrentTheme(): ISNet.WebUI.ThemeInfo;
JScript
public function GetCurrentTheme() : ISNet.WebUI.ThemeInfo;
Managed Extensions for C++
public: ISNet.WebUI.ThemeInfo* GetCurrentTheme();
C++/CLI
public:
ISNet.WebUI.ThemeInfo^ GetCurrentTheme();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


GetFrameworkDataFolder Method

[image]
Intersoft WebScheduler Documentation
GetFrameworkDataFolder Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : GetFrameworkDataFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkDataFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.String

value = instance.GetFrameworkDataFolder()
C#
public System.string GetFrameworkDataFolder()
Delphi
public function GetFrameworkDataFolder(): System.String;
JScript
public function GetFrameworkDataFolder() : System.String;
Managed Extensions for C++
public: System.string* GetFrameworkDataFolder();
C++/CLI
public:
System.String^ GetFrameworkDataFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


GetFrameworkFolder Method

[image]
Intersoft WebScheduler Documentation
GetFrameworkFolder Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : GetFrameworkFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.String

value = instance.GetFrameworkFolder()
C#
public System.string GetFrameworkFolder()
Delphi
public function GetFrameworkFolder(): System.String;
JScript
public function GetFrameworkFolder() : System.String;
Managed Extensions for C++
public: System.string* GetFrameworkFolder();
C++/CLI
public:
System.String^ GetFrameworkFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


GetFrameworkVersion Method

[image]
Intersoft WebScheduler Documentation
GetFrameworkVersion Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : GetFrameworkVersion Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkVersion() As System.Version
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Version

value = instance.GetFrameworkVersion()
C#
public System.Version GetFrameworkVersion()
Delphi
public function GetFrameworkVersion(): System.Version;
JScript
public function GetFrameworkVersion() : System.Version;
Managed Extensions for C++
public: System.Version* GetFrameworkVersion();
C++/CLI
public:
System.Version^ GetFrameworkVersion();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


GetIntersoftFolder Method

[image]
Intersoft WebScheduler Documentation
GetIntersoftFolder Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : GetIntersoftFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetIntersoftFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.String

value = instance.GetIntersoftFolder()
C#
public System.string GetIntersoftFolder()
Delphi
public function GetIntersoftFolder(): System.String;
JScript
public function GetIntersoftFolder() : System.String;
Managed Extensions for C++
public: System.string* GetIntersoftFolder();
C++/CLI
public:
System.String^ GetIntersoftFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


GetLayoutFolder Method

[image]
Intersoft WebScheduler Documentation
GetLayoutFolder Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : GetLayoutFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLayoutFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.String

value = instance.GetLayoutFolder()
C#
public System.string GetLayoutFolder()
Delphi
public function GetLayoutFolder(): System.String;
JScript
public function GetLayoutFolder() : System.String;
Managed Extensions for C++
public: System.string* GetLayoutFolder();
C++/CLI
public:
System.String^ GetLayoutFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


GetPostedXMLData Method

[image]
Intersoft WebScheduler Documentation
GetPostedXMLData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : GetPostedXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPostedXMLData() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.String

value = instance.GetPostedXMLData()
C#
public System.string GetPostedXMLData()
Delphi
public function GetPostedXMLData(): System.String;
JScript
public function GetPostedXMLData() : System.String;
Managed Extensions for C++
public: System.string* GetPostedXMLData();
C++/CLI
public:
System.String^ GetPostedXMLData();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


GetProductInfoKey Method

[image]
Intersoft WebScheduler Documentation
GetProductInfoKey Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : GetProductInfoKey Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductInfoKey() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.String

value = instance.GetProductInfoKey()
C#
public System.string GetProductInfoKey()
Delphi
public function GetProductInfoKey(): System.String;
JScript
public function GetProductInfoKey() : System.String;
Managed Extensions for C++
public: System.string* GetProductInfoKey();
C++/CLI
public:
System.String^ GetProductInfoKey();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


GetProductSimpleName Method

[image]
Intersoft WebScheduler Documentation
GetProductSimpleName Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : GetProductSimpleName Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductSimpleName() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.String

value = instance.GetProductSimpleName()
C#
public System.string GetProductSimpleName()
Delphi
public function GetProductSimpleName(): System.String;
JScript
public function GetProductSimpleName() : System.String;
Managed Extensions for C++
public: System.string* GetProductSimpleName();
C++/CLI
public:
System.String^ GetProductSimpleName();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


GetPropertyValue Method

[image]
Intersoft WebScheduler Documentation
GetPropertyValue Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : GetPropertyValue Method

defValue
propValue
webConfigKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPropertyValue( _
   ByVal defValue As System.String, _
   ByVal propValue As System.String, _
   ByVal webConfigKey As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim defValue As System.String
Dim propValue As System.String
Dim webConfigKey As System.String
Dim value As System.String

value = instance.GetPropertyValue(defValue, propValue, webConfigKey)
C#
public System.string GetPropertyValue(
   System.string defValue,
   System.string propValue,
   System.string webConfigKey
)
Delphi
public function GetPropertyValue(
    defValue: System.String;
    propValue: System.String;
    webConfigKey: System.String
): System.String;
JScript
public function GetPropertyValue(
   defValue : System.String,
   propValue : System.String,
   webConfigKey : System.String
) : System.String;
Managed Extensions for C++
public: System.string* GetPropertyValue(
   System.string* defValue,
   System.string* propValue,
   System.string* webConfigKey
)
C++/CLI
public:
System.String^ GetPropertyValue(
   System.String^ defValue,
   System.String^ propValue,
   System.String^ webConfigKey
)

Parameters

defValue
propValue
webConfigKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


GetResourceStream Method

[image]
Intersoft WebScheduler Documentation
GetResourceStream Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : GetResourceStream Method

resourceUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetResourceStream( _
   ByVal resourceUrl As System.String _
) As System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim resourceUrl As System.String
Dim value As System.IO.Stream

value = instance.GetResourceStream(resourceUrl)
C#
public System.IO.Stream GetResourceStream(
   System.string resourceUrl
)
Delphi
public function GetResourceStream(
    resourceUrl: System.String
): System.IO.Stream;
JScript
public function GetResourceStream(
   resourceUrl : System.String
) : System.IO.Stream;
Managed Extensions for C++
public: System.IO.Stream* GetResourceStream(
   System.string* resourceUrl
)
C++/CLI
public:
System.IO.Stream^ GetResourceStream(
   System.String^ resourceUrl
)

Parameters

resourceUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


GetRouteUrl Method

[image]
Intersoft WebScheduler Documentation
GetRouteUrl Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


GetRouteUrl(Object) Method

[image]
Intersoft WebScheduler Documentation
GetRouteUrl(Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
public System.string GetRouteUrl(
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.Object^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebScheduler Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetRouteUrl(
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.string* GetRouteUrl(
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.String^ GetRouteUrl(
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebScheduler Documentation
GetRouteUrl(String,Object) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim routeName As System.String
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Object^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebScheduler Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim routeName As System.String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members
Overload List


GetStartDateOfWeek Method

[image]
Intersoft WebScheduler Documentation
GetStartDateOfWeek Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : GetStartDateOfWeek Method

Glossary Item Box

Overload List

Overload | Description
GetStartDateOfWeek |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


GetUniqueIDRelativeTo Method

[image]
Intersoft WebScheduler Documentation
GetUniqueIDRelativeTo Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim control As System.Web.UI.Control
Dim value As System.String

value = instance.GetUniqueIDRelativeTo(control)
C#
public System.string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)
Delphi
public function GetUniqueIDRelativeTo(
    control: System.Web.UI.Control
): System.String;
JScript
public function GetUniqueIDRelativeTo(
   control : System.Web.UI.Control
) : System.String;
Managed Extensions for C++
public: System.string* GetUniqueIDRelativeTo(
   System.Web.UI.Control* control
)
C++/CLI
public:
System.String^ GetUniqueIDRelativeTo(
   System.Web.UI.Control^ control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


HasControls Method

[image]
Intersoft WebScheduler Documentation
HasControls Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

value = instance.HasControls()
C#
public virtual System.bool HasControls()
Delphi
public function HasControls(): System.Boolean; virtual;
JScript
public function HasControls() : System.boolean;
Managed Extensions for C++
public: virtual System.bool HasControls();
C++/CLI
public:
virtual System.bool HasControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


Height Property

[image]
Intersoft WebScheduler Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : Height Property

Glossary Item Box

The height of the control.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Layout")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual System.Web.UI.WebControls.Unit Height {get; set;}
Delphi
public read-write property Height: System.Web.UI.WebControls.Unit; virtual;
JScript
System.ComponentModel.CategoryAttribute("Layout")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Height : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual System.Web.UI.WebControls.Unit get_Height();
public: __property virtual void set_Height(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property System.Web.UI.WebControls.Unit Height {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ID Property

[image]
Intersoft WebScheduler Documentation
ID Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ID Property

Glossary Item Box

Programmatic name of the control.

Syntax

Visual Basic (Declaration)
<System.Web.UI.FilterableAttribute(False)>
<System.Web.UI.ThemeableAttribute(False)>
<WebSysDescriptionAttribute("Programmatic name of the control.")>
<System.ComponentModel.ParenthesizePropertyNameAttribute(True)>
<System.ComponentModel.MergablePropertyAttribute(False)>
Public Overridable Property ID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.String

instance.ID = value

value = instance.ID
C#
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public virtual System.string ID {get; set;}
Delphi
public read-write property ID: System.String; virtual;
JScript
System.Web.UI.FilterableAttribute()
System.Web.UI.ThemeableAttribute()
WebSysDescriptionAttribute("Programmatic name of the control.")
System.ComponentModel.ParenthesizePropertyNameAttribute()
System.ComponentModel.MergablePropertyAttribute()
public function get,set ID : System.String
Managed Extensions for C++
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public: __property virtual System.string* get_ID();
public: __property virtual void set_ID(
   System.string* value
);
C++/CLI
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public:
virtual property System.String^ ID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


Init Event

[image]
Intersoft WebScheduler Documentation
Init Event
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been initialized.")>
Public Event Init As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim handler As System.EventHandler

AddHandler instance.Init, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public event System.EventHandler Init
Delphi
public event Init: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public: __event System.EventHandler* Init
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public:
event System.EventHandler^ Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


IsAtlasCallback Method

[image]
Intersoft WebScheduler Documentation
IsAtlasCallback Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : IsAtlasCallback Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsAtlasCallback() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

value = instance.IsAtlasCallback()
C#
public System.bool IsAtlasCallback()
Delphi
public function IsAtlasCallback(): System.Boolean;
JScript
public function IsAtlasCallback() : System.boolean;
Managed Extensions for C++
public: System.bool IsAtlasCallback();
C++/CLI
public:
System.bool IsAtlasCallback();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


IsBetaRelease Method

[image]
Intersoft WebScheduler Documentation
IsBetaRelease Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : IsBetaRelease Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsBetaRelease() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

value = instance.IsBetaRelease()
C#
public System.bool IsBetaRelease()
Delphi
public function IsBetaRelease(): System.Boolean;
JScript
public function IsBetaRelease() : System.boolean;
Managed Extensions for C++
public: System.bool IsBetaRelease();
C++/CLI
public:
System.bool IsBetaRelease();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


IsChromeBrowser Method

[image]
Intersoft WebScheduler Documentation
IsChromeBrowser Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : IsChromeBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsChromeBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

value = instance.IsChromeBrowser()
C#
public System.bool IsChromeBrowser()
Delphi
public function IsChromeBrowser(): System.Boolean;
JScript
public function IsChromeBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsChromeBrowser();
C++/CLI
public:
System.bool IsChromeBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


IsEmpty Method

[image]
Intersoft WebScheduler Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


IsFlyPostBackControl Method

[image]
Intersoft WebScheduler Documentation
IsFlyPostBackControl Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : IsFlyPostBackControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackControl() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

value = instance.IsFlyPostBackControl()
C#
public virtual System.bool IsFlyPostBackControl()
Delphi
public function IsFlyPostBackControl(): System.Boolean; virtual;
JScript
public function IsFlyPostBackControl() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsFlyPostBackControl();
C++/CLI
public:
virtual System.bool IsFlyPostBackControl();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


IsFlyPostBackRequest Method

[image]
Intersoft WebScheduler Documentation
IsFlyPostBackRequest Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : IsFlyPostBackRequest Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackRequest() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

value = instance.IsFlyPostBackRequest()
C#
public virtual System.bool IsFlyPostBackRequest()
Delphi
public function IsFlyPostBackRequest(): System.Boolean; virtual;
JScript
public function IsFlyPostBackRequest() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsFlyPostBackRequest();
C++/CLI
public:
virtual System.bool IsFlyPostBackRequest();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


IsGeckoBasedBrowser Method

[image]
Intersoft WebScheduler Documentation
IsGeckoBasedBrowser Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : IsGeckoBasedBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoBasedBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

value = instance.IsGeckoBasedBrowser()
C#
public System.bool IsGeckoBasedBrowser()
Delphi
public function IsGeckoBasedBrowser(): System.Boolean;
JScript
public function IsGeckoBasedBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsGeckoBasedBrowser();
C++/CLI
public:
System.bool IsGeckoBasedBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


IsGeckoVersion18 Method

[image]
Intersoft WebScheduler Documentation
IsGeckoVersion18 Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : IsGeckoVersion18 Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoVersion18() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

value = instance.IsGeckoVersion18()
C#
public System.bool IsGeckoVersion18()
Delphi
public function IsGeckoVersion18(): System.Boolean;
JScript
public function IsGeckoVersion18() : System.boolean;
Managed Extensions for C++
public: System.bool IsGeckoVersion18();
C++/CLI
public:
System.bool IsGeckoVersion18();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


IsInDesignMode Method

[image]
Intersoft WebScheduler Documentation
IsInDesignMode Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : IsInDesignMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInDesignMode() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

value = instance.IsInDesignMode()
C#
public System.bool IsInDesignMode()
Delphi
public function IsInDesignMode(): System.Boolean;
JScript
public function IsInDesignMode() : System.boolean;
Managed Extensions for C++
public: System.bool IsInDesignMode();
C++/CLI
public:
System.bool IsInDesignMode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


IsInternetExplorer8Browser Method

[image]
Intersoft WebScheduler Documentation
IsInternetExplorer8Browser Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : IsInternetExplorer8Browser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorer8Browser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

value = instance.IsInternetExplorer8Browser()
C#
public System.bool IsInternetExplorer8Browser()
Delphi
public function IsInternetExplorer8Browser(): System.Boolean;
JScript
public function IsInternetExplorer8Browser() : System.boolean;
Managed Extensions for C++
public: System.bool IsInternetExplorer8Browser();
C++/CLI
public:
System.bool IsInternetExplorer8Browser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


IsInternetExplorerBrowser Method

[image]
Intersoft WebScheduler Documentation
IsInternetExplorerBrowser Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : IsInternetExplorerBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorerBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

value = instance.IsInternetExplorerBrowser()
C#
public System.bool IsInternetExplorerBrowser()
Delphi
public function IsInternetExplorerBrowser(): System.Boolean;
JScript
public function IsInternetExplorerBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsInternetExplorerBrowser();
C++/CLI
public:
System.bool IsInternetExplorerBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


IsOperaBrowser Method

[image]
Intersoft WebScheduler Documentation
IsOperaBrowser Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : IsOperaBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsOperaBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

value = instance.IsOperaBrowser()
C#
public System.bool IsOperaBrowser()
Delphi
public function IsOperaBrowser(): System.Boolean;
JScript
public function IsOperaBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsOperaBrowser();
C++/CLI
public:
System.bool IsOperaBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


IsSafariBrowser Method

[image]
Intersoft WebScheduler Documentation
IsSafariBrowser Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : IsSafariBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsSafariBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

value = instance.IsSafariBrowser()
C#
public System.bool IsSafariBrowser()
Delphi
public function IsSafariBrowser(): System.Boolean;
JScript
public function IsSafariBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsSafariBrowser();
C++/CLI
public:
System.bool IsSafariBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


IsW3CStandardBrowser Method

[image]
Intersoft WebScheduler Documentation
IsW3CStandardBrowser Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : IsW3CStandardBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsW3CStandardBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

value = instance.IsW3CStandardBrowser()
C#
public System.bool IsW3CStandardBrowser()
Delphi
public function IsW3CStandardBrowser(): System.Boolean;
JScript
public function IsW3CStandardBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsW3CStandardBrowser();
C++/CLI
public:
System.bool IsW3CStandardBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


Load Event

[image]
Intersoft WebScheduler Documentation
Load Event
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been loaded.")>
Public Event Load As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim handler As System.EventHandler

AddHandler instance.Load, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public event System.EventHandler Load
Delphi
public event Load: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public: __event System.EventHandler* Load
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public:
event System.EventHandler^ Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


LoadLayout Method

[image]
Intersoft WebScheduler Documentation
LoadLayout Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : LoadLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim settings As ISNet.WebUI.LayoutInfo

instance.LoadLayout(settings)
C#
public virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo settings
)
Delphi
public procedure LoadLayout(
    settings: ISNet.WebUI.LayoutInfo
); virtual;
JScript
public function LoadLayout(
   settings : ISNet.WebUI.LayoutInfo
);
Managed Extensions for C++
public: virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo* settings
)
C++/CLI
public:
virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo^ settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


LoadLayoutFromFile Method

[image]
Intersoft WebScheduler Documentation
LoadLayoutFromFile Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : LoadLayoutFromFile Method

filePath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromFile( _
   ByVal filePath As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim filePath As System.String

instance.LoadLayoutFromFile(filePath)
C#
public virtual void LoadLayoutFromFile(
   System.string filePath
)
Delphi
public procedure LoadLayoutFromFile(
    filePath: System.String
); virtual;
JScript
public function LoadLayoutFromFile(
   filePath : System.String
);
Managed Extensions for C++
public: virtual void LoadLayoutFromFile(
   System.string* filePath
)
C++/CLI
public:
virtual void LoadLayoutFromFile(
   System.String^ filePath
)

Parameters

filePath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


LoadLayoutFromPredefinedName Method

[image]
Intersoft WebScheduler Documentation
LoadLayoutFromPredefinedName Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : LoadLayoutFromPredefinedName Method

predefinedName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromPredefinedName( _
   ByVal predefinedName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim predefinedName As System.String

instance.LoadLayoutFromPredefinedName(predefinedName)
C#
public virtual void LoadLayoutFromPredefinedName(
   System.string predefinedName
)
Delphi
public procedure LoadLayoutFromPredefinedName(
    predefinedName: System.String
); virtual;
JScript
public function LoadLayoutFromPredefinedName(
   predefinedName : System.String
);
Managed Extensions for C++
public: virtual void LoadLayoutFromPredefinedName(
   System.string* predefinedName
)
C++/CLI
public:
virtual void LoadLayoutFromPredefinedName(
   System.String^ predefinedName
)

Parameters

predefinedName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


LoadLayoutFromStream Method

[image]
Intersoft WebScheduler Documentation
LoadLayoutFromStream Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : LoadLayoutFromStream Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromStream( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim stream As System.IO.Stream

instance.LoadLayoutFromStream(stream)
C#
public virtual void LoadLayoutFromStream(
   System.IO.Stream stream
)
Delphi
public procedure LoadLayoutFromStream(
    stream: System.IO.Stream
); virtual;
JScript
public function LoadLayoutFromStream(
   stream : System.IO.Stream
);
Managed Extensions for C++
public: virtual void LoadLayoutFromStream(
   System.IO.Stream* stream
)
C++/CLI
public:
virtual void LoadLayoutFromStream(
   System.IO.Stream^ stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


LoadPostData Method

[image]
Intersoft WebScheduler Documentation
LoadPostData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : LoadPostData Method

postDataKey
postCollection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function LoadPostData( _
   ByVal postDataKey As System.String, _
   ByVal postCollection As System.Collections.Specialized.NameValueCollection _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim postDataKey As System.String
Dim postCollection As System.Collections.Specialized.NameValueCollection
Dim value As System.Boolean

value = instance.LoadPostData(postDataKey, postCollection)
C#
public virtual System.bool LoadPostData(
   System.string postDataKey,
   System.Collections.Specialized.NameValueCollection postCollection
)
Delphi
public function LoadPostData(
    postDataKey: System.String;
    postCollection: System.Collections.Specialized.NameValueCollection
): System.Boolean; virtual;
JScript
public function LoadPostData(
   postDataKey : System.String,
   postCollection : System.Collections.Specialized.NameValueCollection
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool LoadPostData(
   System.string* postDataKey,
   System.Collections.Specialized.NameValueCollection* postCollection
)
C++/CLI
public:
virtual System.bool LoadPostData(
   System.String^ postDataKey,
   System.Collections.Specialized.NameValueCollection^ postCollection
)

Parameters

postDataKey
postCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


MergeStyle Method

[image]
Intersoft WebScheduler Documentation
MergeStyle Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure MergeStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function MergeStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void MergeStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void MergeStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


OnInfoChanged Method

[image]
Intersoft WebScheduler Documentation
OnInfoChanged Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : OnInfoChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnInfoChanged( _
   ByVal e As ISNet.WebUI.SynchronizeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim e As ISNet.WebUI.SynchronizeEventArgs

instance.OnInfoChanged(e)
C#
public void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs e
)
Delphi
public procedure OnInfoChanged(
    e: ISNet.WebUI.SynchronizeEventArgs
);
JScript
public function OnInfoChanged(
   e : ISNet.WebUI.SynchronizeEventArgs
);
Managed Extensions for C++
public: void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs* e
)
C++/CLI
public:
void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


OnPreInitialize Method

[image]
Intersoft WebScheduler Documentation
OnPreInitialize Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : OnPreInitialize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnPreInitialize()
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler

instance.OnPreInitialize()
C#
public virtual void OnPreInitialize()
Delphi
public procedure OnPreInitialize(); virtual;
JScript
public function OnPreInitialize();
Managed Extensions for C++
public: virtual void OnPreInitialize();
C++/CLI
public:
virtual void OnPreInitialize();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


Page Property

[image]
Intersoft WebScheduler Documentation
Page Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : Page Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Page As System.Web.UI.Page
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
C#
public virtual System.Web.UI.Page Page {get; set;}
Delphi
public read-write property Page: System.Web.UI.Page; virtual;
JScript
public function get,set Page : System.Web.UI.Page
Managed Extensions for C++
public: __property virtual System.Web.UI.Page* get_Page();
public: __property virtual void set_Page(
   System.Web.UI.Page* value
);
C++/CLI
public:
virtual property System.Web.UI.Page^ Page {
   System.Web.UI.Page^ get();
   void set (    System.Web.UI.Page^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


PreInitialize Event

[image]
Intersoft WebScheduler Documentation
PreInitialize Event
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : PreInitialize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreInitialize As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim handler As System.EventHandler

AddHandler instance.PreInitialize, handler
C#
public event System.EventHandler PreInitialize
Delphi
public event PreInitialize: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event System.EventHandler* PreInitialize
C++/CLI
public:
event System.EventHandler^ PreInitialize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


PreRender Event

[image]
Intersoft WebScheduler Documentation
PreRender Event
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires before the page is rendered.")>
Public Event PreRender As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim handler As System.EventHandler

AddHandler instance.PreRender, handler
C#
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public event System.EventHandler PreRender
Delphi
public event PreRender: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public: __event System.EventHandler* PreRender
C++/CLI
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public:
event System.EventHandler^ PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


RaisePostDataChangedEvent Method

[image]
Intersoft WebScheduler Documentation
RaisePostDataChangedEvent Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : RaisePostDataChangedEvent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RaisePostDataChangedEvent()
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler

instance.RaisePostDataChangedEvent()
C#
public virtual void RaisePostDataChangedEvent()
Delphi
public procedure RaisePostDataChangedEvent(); virtual;
JScript
public function RaisePostDataChangedEvent();
Managed Extensions for C++
public: virtual void RaisePostDataChangedEvent();
C++/CLI
public:
virtual void RaisePostDataChangedEvent();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ReadWebConfigValue Method

[image]
Intersoft WebScheduler Documentation
ReadWebConfigValue Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ReadWebConfigValue Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadWebConfigValue( _
   ByVal key As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim key As System.String
Dim value As System.String

value = instance.ReadWebConfigValue(key)
C#
public System.string ReadWebConfigValue(
   System.string key
)
Delphi
public function ReadWebConfigValue(
    key: System.String
): System.String;
JScript
public function ReadWebConfigValue(
   key : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ReadWebConfigValue(
   System.string* key
)
C++/CLI
public:
System.String^ ReadWebConfigValue(
   System.String^ key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


RegisterBoxSizing Method

[image]
Intersoft WebScheduler Documentation
RegisterBoxSizing Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : RegisterBoxSizing Method

Glossary Item Box

Overload List

Overload | Description
RegisterBoxSizing() | (Inherited from ISNet.WebUI.ISNetControl)
RegisterBoxSizing(Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


RegisterBoxSizing() Method

[image]
Intersoft WebScheduler Documentation
RegisterBoxSizing() Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class > RegisterBoxSizing Method : RegisterBoxSizing() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing()
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler

instance.RegisterBoxSizing()
C#
public void RegisterBoxSizing()
Delphi
public procedure RegisterBoxSizing();
JScript
public function RegisterBoxSizing();
Managed Extensions for C++
public: void RegisterBoxSizing();
C++/CLI
public:
void RegisterBoxSizing();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members
Overload List


RegisterBoxSizing(Boolean) Method

[image]
Intersoft WebScheduler Documentation
RegisterBoxSizing(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class > RegisterBoxSizing Method : RegisterBoxSizing(Boolean) Method

forceAll

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing( _
   ByVal forceAll As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim forceAll As System.Boolean

instance.RegisterBoxSizing(forceAll)
C#
public void RegisterBoxSizing(
   System.bool forceAll
)
Delphi
public procedure RegisterBoxSizing(
    forceAll: System.Boolean
);
JScript
public function RegisterBoxSizing(
   forceAll : System.boolean
);
Managed Extensions for C++
public: void RegisterBoxSizing(
   System.bool forceAll
)
C++/CLI
public:
void RegisterBoxSizing(
   System.bool forceAll
)

Parameters

forceAll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members
Overload List


RegisterGlobalStyle Method

[image]
Intersoft WebScheduler Documentation
RegisterGlobalStyle Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : RegisterGlobalStyle Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterGlobalStyle( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim style As ISNet.WebUI.WebStyle

instance.RegisterGlobalStyle(style)
C#
public void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle style
)
Delphi
public procedure RegisterGlobalStyle(
    style: ISNet.WebUI.WebStyle
);
JScript
public function RegisterGlobalStyle(
   style : ISNet.WebUI.WebStyle
);
Managed Extensions for C++
public: void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle* style
)
C++/CLI
public:
void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle^ style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


RegisterLink Method

[image]
Intersoft WebScheduler Documentation
RegisterLink Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : RegisterLink Method

name
url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterLink( _
   ByVal name As System.String, _
   ByVal url As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim name As System.String
Dim url As System.String

instance.RegisterLink(name, url)
C#
public void RegisterLink(
   System.string name,
   System.string url
)
Delphi
public procedure RegisterLink(
    name: System.String;
    url: System.String
);
JScript
public function RegisterLink(
   name : System.String,
   url : System.String
);
Managed Extensions for C++
public: void RegisterLink(
   System.string* name,
   System.string* url
)
C++/CLI
public:
void RegisterLink(
   System.String^ name,
   System.String^ url
)

Parameters

name
url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


RegisterOptimizedCssClasses Method

[image]
Intersoft WebScheduler Documentation
RegisterOptimizedCssClasses Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : RegisterOptimizedCssClasses Method

runtimeStyleOnly

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterOptimizedCssClasses( _
   ByVal runtimeStyleOnly As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim runtimeStyleOnly As System.Boolean

instance.RegisterOptimizedCssClasses(runtimeStyleOnly)
C#
public void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)
Delphi
public procedure RegisterOptimizedCssClasses(
    runtimeStyleOnly: System.Boolean
);
JScript
public function RegisterOptimizedCssClasses(
   runtimeStyleOnly : System.boolean
);
Managed Extensions for C++
public: void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)
C++/CLI
public:
void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)

Parameters

runtimeStyleOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


RegisterPreloadImage Method

[image]
Intersoft WebScheduler Documentation
RegisterPreloadImage Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : RegisterPreloadImage Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterPreloadImage( _
   ByVal image As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim image As System.String

instance.RegisterPreloadImage(image)
C#
public void RegisterPreloadImage(
   System.string image
)
Delphi
public procedure RegisterPreloadImage(
    image: System.String
);
JScript
public function RegisterPreloadImage(
   image : System.String
);
Managed Extensions for C++
public: void RegisterPreloadImage(
   System.string* image
)
C++/CLI
public:
void RegisterPreloadImage(
   System.String^ image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


RegisterSharePointHandler Method

[image]
Intersoft WebScheduler Documentation
RegisterSharePointHandler Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : RegisterSharePointHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RegisterSharePointHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler

instance.RegisterSharePointHandler()
C#
public virtual void RegisterSharePointHandler()
Delphi
public procedure RegisterSharePointHandler(); virtual;
JScript
public function RegisterSharePointHandler();
Managed Extensions for C++
public: virtual void RegisterSharePointHandler();
C++/CLI
public:
virtual void RegisterSharePointHandler();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


RenderBeginTag Method

[image]
Intersoft WebScheduler Documentation
RenderBeginTag Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderBeginTag(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
public function RenderBeginTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
public:
virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


RenderControl Method

[image]
Intersoft WebScheduler Documentation
RenderControl Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebScheduler Documentation
RenderControl(HtmlTextWriter) Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderControl(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function RenderControl(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual void RenderControl(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual void RenderControl(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


RenderingMode Property

[image]
Intersoft WebScheduler Documentation
RenderingMode Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : RenderingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property RenderingMode As ISNet.WebUI.RenderMode
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.RenderMode

instance.RenderingMode = value

value = instance.RenderingMode
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual ISNet.WebUI.RenderMode RenderingMode {get; set;}
Delphi
public read-write property RenderingMode: ISNet.WebUI.RenderMode; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set RenderingMode : ISNet.WebUI.RenderMode
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual ISNet.WebUI.RenderMode get_RenderingMode();
public: __property virtual void set_RenderingMode(
   ISNet.WebUI.RenderMode value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property ISNet.WebUI.RenderMode RenderingMode {
   ISNet.WebUI.RenderMode get();
   void set (    ISNet.WebUI.RenderMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


Reset Method

[image]
Intersoft WebScheduler Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ResolveClientUrl Method

[image]
Intersoft WebScheduler Documentation
ResolveClientUrl Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveClientUrl(relativeUrl)
C#
public System.string ResolveClientUrl(
   System.string relativeUrl
)
Delphi
public function ResolveClientUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveClientUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveClientUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveClientUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ResolveImagePath Method

[image]
Intersoft WebScheduler Documentation
ResolveImagePath Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ResolveImagePath Method

folder
image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveImagePath( _
   ByVal folder As System.String, _
   ByVal image As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim folder As System.String
Dim image As System.String
Dim value As System.String

value = instance.ResolveImagePath(folder, image)
C#
public System.string ResolveImagePath(
   System.string folder,
   System.string image
)
Delphi
public function ResolveImagePath(
    folder: System.String;
    image: System.String
): System.String;
JScript
public function ResolveImagePath(
   folder : System.String,
   image : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveImagePath(
   System.string* folder,
   System.string* image
)
C++/CLI
public:
System.String^ ResolveImagePath(
   System.String^ folder,
   System.String^ image
)

Parameters

folder
image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ResolveRelativeURL Method

[image]
Intersoft WebScheduler Documentation
ResolveRelativeURL Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ResolveRelativeURL Method

url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveRelativeURL( _
   ByVal url As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim url As System.String
Dim value As System.String

value = instance.ResolveRelativeURL(url)
C#
public virtual System.string ResolveRelativeURL(
   System.string url
)
Delphi
public function ResolveRelativeURL(
    url: System.String
): System.String; virtual;
JScript
public function ResolveRelativeURL(
   url : System.String
) : System.String;
Managed Extensions for C++
public: virtual System.string* ResolveRelativeURL(
   System.string* url
)
C++/CLI
public:
virtual System.String^ ResolveRelativeURL(
   System.String^ url
)

Parameters

url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ResolveResourceUrl Method

[image]
Intersoft WebScheduler Documentation
ResolveResourceUrl Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ResolveResourceUrl Method

kind
defaultFolder
currentFolder
resourceName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveResourceUrl( _
   ByVal kind As ISNet.WebUI.ResourceKind, _
   ByVal defaultFolder As System.String, _
   ByVal currentFolder As System.String, _
   ByVal resourceName As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim kind As ISNet.WebUI.ResourceKind
Dim defaultFolder As System.String
Dim currentFolder As System.String
Dim resourceName As System.String
Dim value As System.String

value = instance.ResolveResourceUrl(kind, defaultFolder, currentFolder, resourceName)
C#
public System.string ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.string defaultFolder,
   System.string currentFolder,
   System.string resourceName
)
Delphi
public function ResolveResourceUrl(
    kind: ISNet.WebUI.ResourceKind;
    defaultFolder: System.String;
    currentFolder: System.String;
    resourceName: System.String
): System.String;
JScript
public function ResolveResourceUrl(
   kind : ISNet.WebUI.ResourceKind,
   defaultFolder : System.String,
   currentFolder : System.String,
   resourceName : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.string* defaultFolder,
   System.string* currentFolder,
   System.string* resourceName
)
C++/CLI
public:
System.String^ ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.String^ defaultFolder,
   System.String^ currentFolder,
   System.String^ resourceName
)

Parameters

kind
defaultFolder
currentFolder
resourceName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ResolveUrl Method

[image]
Intersoft WebScheduler Documentation
ResolveUrl Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveUrl(relativeUrl)
C#
public System.string ResolveUrl(
   System.string relativeUrl
)
Delphi
public function ResolveUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


RuntimeLicenseKey Property

[image]
Intersoft WebScheduler Documentation
RuntimeLicenseKey Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : RuntimeLicenseKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.PersistLayoutAttribute(False)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")>
Public Overridable Property RuntimeLicenseKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.String

instance.RuntimeLicenseKey = value

value = instance.RuntimeLicenseKey
C#
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public virtual System.string RuntimeLicenseKey {get; set;}
Delphi
public read-write property RuntimeLicenseKey: System.String; virtual;
JScript
ISNet.PersistLayoutAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")
public function get,set RuntimeLicenseKey : System.String
Managed Extensions for C++
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public: __property virtual System.string* get_RuntimeLicenseKey();
public: __property virtual void set_RuntimeLicenseKey(
   System.string* value
);
C++/CLI
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public:
virtual property System.String^ RuntimeLicenseKey {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


SaveLayout Method

[image]
Intersoft WebScheduler Documentation
SaveLayout Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : SaveLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim settings As ISNet.WebUI.LayoutInfo

instance.SaveLayout(settings)
C#
public virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo settings
)
Delphi
public procedure SaveLayout(
    settings: ISNet.WebUI.LayoutInfo
); virtual;
JScript
public function SaveLayout(
   settings : ISNet.WebUI.LayoutInfo
);
Managed Extensions for C++
public: virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo* settings
)
C++/CLI
public:
virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo^ settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


SaveLayoutToFile Method

[image]
Intersoft WebScheduler Documentation
SaveLayoutToFile Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : SaveLayoutToFile Method

filePath
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToFile( _
   ByVal filePath As System.String, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim filePath As System.String
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToFile(filePath, saveOptions)
C#
public virtual void SaveLayoutToFile(
   System.string filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
Delphi
public procedure SaveLayoutToFile(
    filePath: System.String;
    saveOptions: ISNet.WebUI.SaveLayoutOptions
); virtual;
JScript
public function SaveLayoutToFile(
   filePath : System.String,
   saveOptions : ISNet.WebUI.SaveLayoutOptions
);
Managed Extensions for C++
public: virtual void SaveLayoutToFile(
   System.string* filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
C++/CLI
public:
virtual void SaveLayoutToFile(
   System.String^ filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

filePath
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


SaveLayoutToStream Method

[image]
Intersoft WebScheduler Documentation
SaveLayoutToStream Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : SaveLayoutToStream Method

stream
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToStream( _
   ByVal stream As System.IO.Stream, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim stream As System.IO.Stream
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToStream(stream, saveOptions)
C#
public virtual void SaveLayoutToStream(
   System.IO.Stream stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
Delphi
public procedure SaveLayoutToStream(
    stream: System.IO.Stream;
    saveOptions: ISNet.WebUI.SaveLayoutOptions
); virtual;
JScript
public function SaveLayoutToStream(
   stream : System.IO.Stream,
   saveOptions : ISNet.WebUI.SaveLayoutOptions
);
Managed Extensions for C++
public: virtual void SaveLayoutToStream(
   System.IO.Stream* stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
C++/CLI
public:
virtual void SaveLayoutToStream(
   System.IO.Stream^ stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

stream
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


SerializeObjectData Method

[image]
Intersoft WebScheduler Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


SetRenderMethodDelegate Method

[image]
Intersoft WebScheduler Documentation
SetRenderMethodDelegate Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)
Delphi
public procedure SetRenderMethodDelegate(
    renderMethod: System.Web.UI.RenderMethod
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function SetRenderMethodDelegate(
   renderMethod : System.Web.UI.RenderMethod
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod* renderMethod
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod^ renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


SetSessionTheme Method

[image]
Intersoft WebScheduler Documentation
SetSessionTheme Method
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : SetSessionTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetSessionTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetSessionTheme(themeInfo)
C#
public void SetSessionTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)
Delphi
public procedure SetSessionTheme(
    themeInfo: ISNet.WebUI.ThemeInfo
);
JScript
public function SetSessionTheme(
   themeInfo : ISNet.WebUI.ThemeInfo
);
Managed Extensions for C++
public: void SetSessionTheme(
   ISNet.WebUI.ThemeInfo* themeInfo
)
C++/CLI
public:
void SetSessionTheme(
   ISNet.WebUI.ThemeInfo^ themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


SkinID Property

[image]
Intersoft WebScheduler Documentation
SkinID Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : SkinID Property

Glossary Item Box

The id of the control skin.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property SkinID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.String

instance.SkinID = value

value = instance.SkinID
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.string SkinID {get; set;}
Delphi
public read-write property SkinID: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set SkinID : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.string* get_SkinID();
public: __property virtual void set_SkinID(
   System.string* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.String^ SkinID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


TabIndex Property

[image]
Intersoft WebScheduler Documentation
TabIndex Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : TabIndex Property

Glossary Item Box

The tab order of the control.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property TabIndex As System.Short
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Short

instance.TabIndex = value

value = instance.TabIndex
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.short TabIndex {get; set;}
Delphi
public read-write property TabIndex: System.Int16; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set TabIndex : System.short
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.short get_TabIndex();
public: __property virtual void set_TabIndex(
   System.short value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.short TabIndex {
   System.short get();
   void set (    System.short value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ToolTip Property

[image]
Intersoft WebScheduler Documentation
ToolTip Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ToolTip Property

Glossary Item Box

The tooltip displayed when the mouse is over the control.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property ToolTip As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.String

instance.ToolTip = value

value = instance.ToolTip
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string ToolTip {get; set;}
Delphi
public read-write property ToolTip: System.String; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set ToolTip : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_ToolTip();
public: __property virtual void set_ToolTip(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ ToolTip {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


Unload Event

[image]
Intersoft WebScheduler Documentation
Unload Event
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page is unloaded.")>
Public Event Unload As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim handler As System.EventHandler

AddHandler instance.Unload, handler
C#
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public event System.EventHandler Unload
Delphi
public event Unload: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public: __event System.EventHandler* Unload
C++/CLI
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public:
event System.EventHandler^ Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ValidateRequestMode Property

[image]
Intersoft WebScheduler Documentation
ValidateRequestMode Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")>
Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}
Delphi
public read-write property ValidateRequestMode: System.Web.UI.ValidateRequestMode; virtual;
JScript
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")
public function get,set ValidateRequestMode : System.Web.UI.ValidateRequestMode
Managed Extensions for C++
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public: __property virtual System.Web.UI.ValidateRequestMode get_ValidateRequestMode();
public: __property virtual void set_ValidateRequestMode(
   System.Web.UI.ValidateRequestMode value
);
C++/CLI
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public:
virtual property System.Web.UI.ValidateRequestMode ValidateRequestMode {
   System.Web.UI.ValidateRequestMode get();
   void set (    System.Web.UI.ValidateRequestMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ViewStateItems Property

[image]
Intersoft WebScheduler Documentation
ViewStateItems Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ViewStateItems Property

Glossary Item Box

Gets or sets the items to be stored in view state storage.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("View State Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")>
Public Overridable Property ViewStateItems As ISNet.WebUI.ViewStateItem
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.ViewStateItem

instance.ViewStateItems = value

value = instance.ViewStateItems
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public virtual ISNet.WebUI.ViewStateItem ViewStateItems {get; set;}
Delphi
public read-write property ViewStateItems: ISNet.WebUI.ViewStateItem; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("View State Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")
public function get,set ViewStateItems : ISNet.WebUI.ViewStateItem
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public: __property virtual ISNet.WebUI.ViewStateItem get_ViewStateItems();
public: __property virtual void set_ViewStateItems(
   ISNet.WebUI.ViewStateItem value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public:
virtual property ISNet.WebUI.ViewStateItem ViewStateItems {
   ISNet.WebUI.ViewStateItem get();
   void set (    ISNet.WebUI.ViewStateItem value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ViewStateMode Property

[image]
Intersoft WebScheduler Documentation
ViewStateMode Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
<WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}
Delphi
public read-write property ViewStateMode: System.Web.UI.ViewStateMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")
System.ComponentModel.DefaultValueAttribute()
public function get,set ViewStateMode : System.Web.UI.ViewStateMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Web.UI.ViewStateMode get_ViewStateMode();
public: __property virtual void set_ViewStateMode(
   System.Web.UI.ViewStateMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Web.UI.ViewStateMode ViewStateMode {
   System.Web.UI.ViewStateMode get();
   void set (    System.Web.UI.ViewStateMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ViewStateServerConnection Property

[image]
Intersoft WebScheduler Documentation
ViewStateServerConnection Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ViewStateServerConnection Property

Glossary Item Box

Gets or sets the server connection string for file server-based viewstate storage.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")>
<System.ComponentModel.CategoryAttribute("View State Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property ViewStateServerConnection As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.String

instance.ViewStateServerConnection = value

value = instance.ViewStateServerConnection
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string ViewStateServerConnection {get; set;}
Delphi
public read-write property ViewStateServerConnection: System.String; virtual;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")
System.ComponentModel.CategoryAttribute("View State Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set ViewStateServerConnection : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_ViewStateServerConnection();
public: __property virtual void set_ViewStateServerConnection(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ ViewStateServerConnection {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ViewStateStorage Property

[image]
Intersoft WebScheduler Documentation
ViewStateStorage Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : ViewStateStorage Property

Glossary Item Box

Gets or sets the location to store the viewstate of this control.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")>
<System.ComponentModel.CategoryAttribute("View State Settings")>
Public Overridable Property ViewStateStorage As ISNet.WebUI.StateCacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As ISNet.WebUI.StateCacheStorage

instance.ViewStateStorage = value

value = instance.ViewStateStorage
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public virtual ISNet.WebUI.StateCacheStorage ViewStateStorage {get; set;}
Delphi
public read-write property ViewStateStorage: ISNet.WebUI.StateCacheStorage; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")
System.ComponentModel.CategoryAttribute("View State Settings")
public function get,set ViewStateStorage : ISNet.WebUI.StateCacheStorage
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public: __property virtual ISNet.WebUI.StateCacheStorage get_ViewStateStorage();
public: __property virtual void set_ViewStateStorage(
   ISNet.WebUI.StateCacheStorage value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public:
virtual property ISNet.WebUI.StateCacheStorage ViewStateStorage {
   ISNet.WebUI.StateCacheStorage get();
   void set (    ISNet.WebUI.StateCacheStorage value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


Visible Property

[image]
Intersoft WebScheduler Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : Visible Property

Glossary Item Box

Indicates whether the control is visible and rendered.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean; virtual;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set Visible : System.boolean
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.bool get_Visible();
public: __property virtual void set_Visible(
   System.bool value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


Width Property

[image]
Intersoft WebScheduler Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : Width Property

Glossary Item Box

The width of the control.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Layout")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
[System.ComponentModel.CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.Web.UI.WebControls.Unit Width {get; set;}
Delphi
public read-write property Width: System.Web.UI.WebControls.Unit; virtual;
JScript
System.ComponentModel.CategoryAttribute("Layout")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set Width : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.Web.UI.WebControls.Unit get_Width();
public: __property virtual void set_Width(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.Web.UI.WebControls.Unit Width {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


XmlCompressionEnabled Property

[image]
Intersoft WebScheduler Documentation
XmlCompressionEnabled Property
See Also Send Feedback
ISNet.WebUI.WebScheduler Namespace > WebScheduler Class : XmlCompressionEnabled Property

Glossary Item Box

Specifies whether the Xml used for client side state storage should be compressed.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property XmlCompressionEnabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebScheduler
Dim value As System.Boolean

instance.XmlCompressionEnabled = value

value = instance.XmlCompressionEnabled
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.bool XmlCompressionEnabled {get; set;}
Delphi
public read-write property XmlCompressionEnabled: System.Boolean; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set XmlCompressionEnabled : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.bool get_XmlCompressionEnabled();
public: __property virtual void set_XmlCompressionEnabled(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.bool XmlCompressionEnabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebScheduler Class
WebScheduler Members


ISNet.WebUI.WebScheduler Namespace Inheritance Hierarchy

ISNet.WebUI.WebScheduler Namespace Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase2
ISNet.WebUI.WebScheduler.WebSchedulerCategory
ISNet.WebUI.WebScheduler.WebSchedulerDisabledTime
ISNet.WebUI.WebScheduler.WebSchedulerEditingField
ISNet.WebUI.WebScheduler.WebSchedulerEventBase
ISNet.WebUI.WebScheduler.WebSchedulerEvent
ISNet.WebUI.WebScheduler.WebSchedulerRecurringEvent
ISNet.WebUI.WebScheduler.WebSchedulerHoliday
ISNet.WebUI.WebScheduler.WebSchedulerResource
ISNet.WebUI.WebScheduler.WebSchedulerActiveDayStyle
ISNet.WebUI.WebScheduler.WebSchedulerBaseView
ISNet.WebUI.WebScheduler.WebSchedulerAgendaView
ISNet.WebUI.WebScheduler.WebSchedulerDayView
ISNet.WebUI.WebScheduler.WebSchedulerMonthView
ISNet.WebUI.WebScheduler.WebSchedulerQuarterView
ISNet.WebUI.WebScheduler.WebSchedulerTimelineView
ISNet.WebUI.WebScheduler.WebSchedulerWeekView
ISNet.WebUI.WebScheduler.WebSchedulerYearView
ISNet.WebUI.WebScheduler.WebSchedulerBinding
ISNet.WebUI.WebScheduler.WebSchedulerCalendarSettings
ISNet.WebUI.WebScheduler.WebSchedulerCategoriesBinding
ISNet.WebUI.WebScheduler.WebSchedulerClientSideEvents
ISNet.WebUI.WebScheduler.WebSchedulerDataEditing
ISNet.WebUI.WebScheduler.WebSchedulerResourceDataEditing
ISNet.WebUI.WebScheduler.WebSchedulerDetailInfoStyle
ISNet.WebUI.WebScheduler.WebSchedulerEventsBindingBase
ISNet.WebUI.WebScheduler.WebSchedulerEventsBinding
ISNet.WebUI.WebScheduler.WebSchedulerRecurringEventBinding
ISNet.WebUI.WebScheduler.WebSchedulerGridLineStyle
ISNet.WebUI.WebScheduler.WebSchedulerImagesSettings
ISNet.WebUI.WebScheduler.WebSchedulerLayoutSettings
ISNet.WebUI.WebScheduler.WebSchedulerRecurrence
ISNet.WebUI.WebScheduler.WebSchedulerRecurrencesBinding
ISNet.WebUI.WebScheduler.WebSchedulerRecurrenceTextSettings
ISNet.WebUI.WebScheduler.WebSchedulerResourcesBinding
ISNet.WebUI.WebScheduler.WebSchedulerTextSettings
ISNet.WebUI.WebScheduler.WebSchedulerTimeBasedEventStyle
ISNet.WebUI.WebScheduler.WebSchedulerViewSettings
ISNet.WebUI.WebScheduler.WebSchedulerWorkWeekSettings
System.Collections.ObjectModel.Collection<T>
ISNet.WebUI.ISCollectionBase<T>
ISNet.WebUI.ISGenericCollectionBase<T>
ISNet.WebUI.WebScheduler.WebSchedulerCategoryCollection
ISNet.WebUI.WebScheduler.WebSchedulerDisabledTimeCollection
ISNet.WebUI.WebScheduler.WebSchedulerEditingFieldCollection
ISNet.WebUI.WebScheduler.WebSchedulerEventCollection
ISNet.WebUI.WebScheduler.WebSchedulerHolidayCollection
ISNet.WebUI.WebScheduler.WebSchedulerRecurrenceCollection
ISNet.WebUI.WebScheduler.WebSchedulerResourceCollection
System.ComponentModel.TypeConverter
ISNet.WebUI.WebScheduler.WebSchedulerDateTimeConverter
System.EventArgs
ISNet.WebUI.WebScheduler.WebSchedulerDataArgs
ISNet.WebUI.WebScheduler.WebSchedulerDataBoundDataArgs
ISNet.WebUI.WebScheduler.WebSchedulerExportEventArgs
ISNet.WebUI.WebScheduler.WebSchedulerJsonSerializationArgs
ISNet.WebUI.WebScheduler.WebSchedulerPrepareExportExecuteEventArgs
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebScheduler.WebScheduler

See Also

Reference

ISNet.WebUI.WebScheduler Assembly


a
about
after
against
all
along
also
although
am
among
an
and
are
as
at
be
became
because
been
being
between
but
by
can
caution
come
could
details
did
do
does
doing
done
during
each
early
far
finally
for
found
from
had
has
have
he
her
here
his
how
however
I
if
in
include
including
information
into
is
it
its
late
later
made
many
may
me
med
might
more
most
near
no
non
none
nor
not
note
of
off
on
only
or
other
over
saw
see
seen
several
she
since
so
some
such
than
that
the
their
them
then
there
these
they
this
those
through
tip
to
too
under
until
up
us
use
very
warning
was
we
were
when
where
which
while
who
with
you


WebSchedulerViewCacheCollection Properties

WebSchedulerViewCacheCollection Properties
Send Feedback

Glossary Item Box


WebSchedulerWorkWeekSettings

WebSchedulerWorkWeekSettings
Send Feedback

Glossary Item Box

WebSchedulerWorkWeekSettings Properties

Friday | Description Indicates whether Friday is work week. ValueType Default Value
Monday | Description Indicates whether Monday is work week. ValueType Default Value
Saturday | Description Indicates whether Saturday is work week. ValueType Default Value
Sunday | Description Indicates whether Sunday is work week. ValueType Default Value
Thursday | Description Indicates whether Thursday is work week. ValueType Default Value
Tuesday | Description Indicates whether Tuesday is work week. ValueType Default Value
Wednesday | Description Indicates whether Wednesday is work week. ValueType Default Value