Intersoft WebCombo

Intersoft WebCombo Documentation
Intersoft WebCombo
Send Feedback

Glossary Item Box

WebCombo gives your users the most powerful, flexible combo box available in the industry and delivers instant data retrieval with LINQ-to-SQL technology, fetching millions of rows in just a few seconds. With features such as type-ahead searching, auto completion mode, multiple columns, multiple selections and more, performing data entry is easier and more accurate than ever before.

Supporting dozens of data source controls, WebCombo's codeless databinding lets you seamlessly bind it to even the largest and most complex data sets in just a few clicks. Designed to be highly scalable, WebCombo employs a sophisticated flexible caching mechanism to achieve superior performance levels.

With its all new crystal-clear rounded corners, WebCombo is quite simply the sexiest dropdown box in the industry. A rich set of predefined styles and visual effects make it easy to create an attractive, consistent visual theme to your application.

In This Section

Getting Started

Provides information and resources intended for developers that are new to WebCombo, which includes topics that discuss about development prerequisites, installation, and basic walkthroughs to use WebCombo in your ASP.NET projects.

What's New In WebCombo 6

Provides information and links to the new features and enhancements available in WebCombo 6.

Walkthrough Topics

Contains links to the walkthroughs topics that provide step-by-step guidance on using WebCombo controls to achieve various scenarios and business challenges.

FAQ and How-to Topics

Contains links to the frequently asked questions and how-to topics that provide quick guidance on using WebCombo controls to achieve particular development challenges.

Features and Concepts

Describes the architecture, concepts and key features that are fundamental to build high-performance applications using WebCombo.

Learning More

Learn more about WebCombo features and its rich designer capabilities. Getting familiar with SmartTag Designer, and learn how to bind data using Datasource control, as well as customizing the control with Component Designer.

Advanced How-to Topics

Contains links to the advanced how-to topics that provide quick guidance on using WebCombo controls to achieve advanced development scenarios.

Server-side References

Provides links to the samples codes and documentation of assemblies, namespaces and types available in WebCombo.

Client-side References

Provides links to the samples codes and documentation of Javascript objects, properties and methods available in WebCombo.

Product Support

Provides resources and links to get product support, report issues, submit feedback, and access to community sites such as developer network, forum and blog.

Licensing

Describes the methods to license WebCombo for the development and deployment, as well as provides information about software license agreement for end users.

© 2012 Intersoft Solutions Corp. All Rights Reserved.


Getting Started

Getting Started
See Also Send Feedback
Intersoft WebCombo > Getting Started

Glossary Item Box

This topic provides links designated to help you quickly getting started with Intersoft WebCombo. Please refer to the Walkthroughs section below for step-by-step instructions to start using WebCombo in your ASP.NET projects.

Installation

The following topics guide you how to install WebCombo and describe the system requirements to start using WebCombo in your development computer.

  • Installation Guide
  • Manually installing WebCombo to Visual Studio 2005 ToolBox
  • Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox
  • System Requirements

Deployment

The following topics guide you to configure and prepare your applications for deployment to the server. It also provides information on using Deployment Manager which contains important instructions that you need to apply before proceeding to the deployment.

  • Deployment Guide
  • Application Wide Configurations

Upgrading

This following topics gives you the information about the breaking changes in the latest version of WebCombo, and information to upgrade the assembly references from the previous version of WebCombo.

  • Breaking Changes in WebCombo
  • Upgrading From the Previous Version

Walkthroughs

The following walkthroughs guide you through the completion of basic tasks using WebCombo. Use walkthroughs to learn WebCombo and know how to implement basic data binding in your ASP.NET application.

Term | Definition
Walkthrough: Binding WebCombo to AccessDataSource control | Describes the processes of binding a WebCombo to an AccessDataSource control.
Walkthrough: Binding WebCombo to ObjectDataSource control | Describes the processes of binding a WebCombo to an ObjectDataSource control.
Walkthrough: Binding WebCombo to ISDataSource control | Describes the processes of binding a WebCombo to an ISDataSource control.

For a list of complete walkthroughs, see WebCombo Walkthroughs.

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

Concepts
Features and Concepts
Learning More
Advanced How-to Topics

Other Resources
Features Added In WebCombo 5


Installation

Installation
See Also Send Feedback
Intersoft WebCombo > Getting Started > Installation

Glossary Item Box

This section contains information on installing WebCombo and specifying the system requirements needed by the component.

In This Section

Installation Guide
Information about installing WebCombo on your PC.

Manually installing WebCombo to Visual Studio 2005 ToolBox
Information about installing WebCombo control to Visual Studio 2005 ToolBox manually.

Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox
Information about installing WebCombo control to Visual Studio ToolBox using Toolbox Utiliy tool.

System Requirements
Read about the Windows version, Visual Studio application, WebUI Framework and other software requirements for installing WebCombo.

See Also

Other Resources
Deployment
Upgrading
Samples and Walkthroughs


Installation Guide

Installation Guide
See Also Send Feedback
Intersoft WebCombo > Getting Started > Installation > Installation Guide

Glossary Item Box

Installation Requirement

For system requirement, please see the System Requirements section.

Installing WebCombo 6

Intersoft has released the new setup installer which includes WebUI Framework 3, WebGrid 8, WebCombo 6, WebInput 4, WebDesktop 3, WebTreeView, ISDataSource, WebScheduler 3, WebAqua 2, WebTextEditor, WebEssentials and clientUI components.

Here are the step-by-step instructions to install WebCombo 6:

  1. Double click on the "Intersoft WebUI Studio 2012 R1.exe" icon to start the installation process. Read the instructions, and click next.

  2. Please read the license agreement. You must accept the terms in the license agreement in order to install WebCombo 6.

  3. Fill in your details such as User Name and Organization. Click Next to proceed.

  4. You can select the product edition and setup type that you would like to install and perform.

    The product contains three editions such as WebUI Studio for ASP.NET, WebUI Studio for Silverlight and WebUI Studio for WPF.

  5. Click Next to proceed with the installation process.

  6. The wizard is installing WebUI Studio 2012 R1.

  7. A window showing the installation progress appears. It will list the status of components that are being installed.

  8. After the installation process has been finished, you will see a confirmation window. Click Finish to close the window. At this rate, you have successfully installed the Intersoft WebUI Studio 2012 R1.

  9. To install the full version of WebCombo 6, proceed by using License Manager that can be triggered from Start menu >> All Programs >> Intersoft WebUI Studio 2012 R1 >> License Manager.

  10. Intersoft License Manager window will appear. Click "Add License" to proceed to the next step.

  11. Now, Select a product from the combo box. In this case, select WebCombo.NET Version 6.0.7200 and enter the license according to the component.

  12. Click Add and it will automatically check the license with the server through internet connection. If it is correct, then you have successfully installed the full version of WebCombo 6.

See Also

Other Resources
Manually installing WebCombo to Visual Studio 2005 ToolBox
Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox
System Requirements


Manually installing WebCombo to Visual Studio 2005 ToolBox

Manually installing WebCombo to Visual Studio 2005 ToolBox
See Also Send Feedback
Intersoft WebCombo > Getting Started > Installation > Manually installing WebCombo to Visual Studio 2005 ToolBox

Glossary Item Box

This document provides a step-by-step guidance on how to manually install WebCombo to Visual Studio 2005 ToolBox.

Step-By Step Instructions

To manually install WebCombo to Visual Studio 2005 ToolBox

  1. Open Visual Studio 2005 application.
  2. Create a new WebSite application.
  3. In the Designer view, refer to the ToolBox on the left side.
  4. Right-click on the ToolBox and choose Add Tab.
  5. Named the Tab as "WebUI Studio".
  6. Right-click on the created Tab and select Choose Items.
  7. Browse and Add ISNet.WebUI.WebCombo.dll from C:\[Installation Folder]\Intersoft Solutions\WebUI Studio for ASP.NET\WebCombo.NET 4.0.
  8. Finally, your ToolBox will look like the following.

    ToolBox

See Also

Other Resources
Installation Guide
System Requirements
Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox


Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox

Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox
See Also Send Feedback
Intersoft WebCombo > Getting Started > Installation > Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox

Glossary Item Box

This topic provides a step-by-step instruction on how to manually add Intersoft products to Visual Studio Toolbox using Toolbox Utility tool.

To add Intersoft products to Visual Studio Toolbox

  1. Run Intersoft ToolBox Utility for Visual Studio from Start Menu >> All Programs >> Intersoft WebUI Studio 2010 R1 >> Intersoft ToolBox Utility for Visual Studio or you can access ToolBoxUtility.exe from [Installation Folder]\Intersoft Solutions\Intersoft WebUI Studio 2010 R1\ToolBoxUtility.
  2. Select on the Visual Studio platform you want Intersoft products to be installed. By default, it will automatically select all Visual Studio versions installed on your PC.

  3. Click Register to run the tool and wait until the process is finished.

  4. Finally, open your project and you will notice that Intersoft products has been installed successfully into Visual Studio Toolbox.

See Also

Other Resources
Installation Guide
System Requirements


System Requirements

System Requirements
See Also Send Feedback
Intersoft WebCombo > Getting Started > Installation > System Requirements

Glossary Item Box

Development Machine Requirements

    • Microsoft Windows Vista
    • Microsoft Windows 2000/2003/2008 Server family
    • Microsoft Windows XP Professional or Home Edition
    • Microsoft .NET Framework v2.0 or higher
    • Microsoft Visual Studio 2005 Professional/Team Studio/Express Edition
    • Microsoft Visual Studio 2008
    • Intersoft WebUI.NET Framework v3.0 or higher

Server Machine Requirements

    • Windows Server 2003 Enterprise
    • Windows Server 2003 Web Edition
    • Windows Server 2008
    • Internet Information Services 6.0 or later
    • Microsoft .NET Framework Version 2.0 or later
    • Intersoft WebUI.NET Framework v3.0 or higher

Client Machine Requirements

    • Microsoft Internet Explorer 5.5 or higher
    • Mozilla V1.7 +for Windows/Mac/Linux/Solaris
    • Firefox V1.0+ for Windows/Mac/Linux/Solaris
    • Netscape V7.0+ for Windows/Mac/Linux/Solaris
    • Opera 9.5+ for Windows/Mac/Linux/Solaris/FreeBSD/BeOS/QNX
    • Apple Safari 3+ for Windows/Mac

See Also

Other Resources
Installation Guide
Manually installing WebCombo to Visual Studio 2005 ToolBox
Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox


Deployment

Deployment
See Also Send Feedback
Intersoft WebCombo > Getting Started > Deployment

Glossary Item Box

This section contains information on configuring the application and guiding user with a step-by-step checklist instructions for deployment purposes.

In This Section

Deployment Guide
Information about Deployment Checklist that will list all the important tasks you need to do before deploying the project.

Application Wide Configurations
Read about the WebCombo's ability to configure deployment-related properties via web.config, such as ScriptDirectory and many others.

See Also

Other Resources
Installation
Upgrading
Samples and Walkthroughs
Hassle-free deployment through SmartWebResources™ technology


Deployment Guide

Deployment Guide
Send Feedback
Intersoft WebCombo > Getting Started > Deployment > Deployment Guide

Glossary Item Box

This section continues to guide you on how to deploy the project by using Deployment Manager and SmartWebResources™.

In This Section

Using Deployment Manager
Learn how to use deployment manager to set the web.config.

Deploying project that uses SmartWebResources™
Information about deploying project using SmartWebResources™.

Deploying project that does not use SmartWebResources™
Information about deploying project without using SmartWebResources™. In other words, you need to copy CommonLibrary, project's directory and assemblies.


Using Deployment Manager
See Also Send Feedback
Intersoft WebCombo > Getting Started > Deployment > Deployment Guide > Using Deployment Manager

Glossary Item Box

Intersoft comes up with a new hassle-free Deployment Manager that is designated to help developers to easily manage configurations during deployment phase.

Now, you can quickly configure the common settings required in deployment such as entering runtime license keys, view state configurations and others through user-friendly Windows GUI application.

Using Deployment Manager

Here are the step-by-step instructions to use Deployment Manager:

  1. Open Deployment Manager from Start menu >> All Programs >> Intersoft WebUI Studio 2010 R1 >> WebUI Studio for ASP.NET >> Deployment Manager.
  2. Click Browse and select the project's directory of your web application to be configured. Click Next afterwards.

  3. Tick WebCombo.NET 4.0.7200 and put the Runtime License key according to the component. Click Next to proceed to the next step.

  4. In this step, there are many settings you can configure such as View State Storage, Optimization, Client Resources and Advanced sections.

    View State Storage Section

    View State Storage section lets you configure how ViewState is stored, specify how ViewState items are going to be saved in ViewState and determine the priority and duration of items stored in Cache object.

    Optimization Section

    Optimization section lets you choose whether to enable CSS Optimization and XML compression.

    Client Resources Section

    This section contains information on how to enable WebResources and set its mode.

    If you have applied SmartWebResources™ in your project, then this option will be automatically selected with its default mode set to Auto.

    Advanced Section

    Advances section allows you to add necessary keys such as SharedScriptDirectory, ImagesDirectory or custom keys.

    In this section, you will learn how to assign the keys and values needed when you deploy the project.
    - In Advances section, click the ">" sign to move the available keys to the applied keys.
    - In Applied Keys table, Set the values like following:

    Key | Value
    ScriptDirectory | ~/CommonLibrary/WebCombo/V4_0_7200/
    SharedScriptDirectory | ~/CommonLibrary/Shared/
    ImagesDirectory | ~/CommonLibrary/Images/

    This section is very critical to be applied when you copy the CommonLibrary folder to the project's directory in development machine. However, if you have enabled SmartWebResources™, you no longer need to configure the directory settings.

  5. Click Next or Apply to save the configuration. Finally, the web.config has been updated successfully. Click Close to apply the settings.

See Also

Other Resources
Deploying project that uses SmartWebResources™
Deploying project that does not use SmartWebResources™
Application Wide Configurations

References
ImagesDirectory Property
ScriptDirectory Property
SharedScriptDirectory Property


Deploying project that uses SmartWebResources™
See Also Send Feedback
Intersoft WebCombo > Getting Started > Deployment > Deployment Guide > Deploying project that uses SmartWebResources™

Glossary Item Box

Intersoft Solutions constantly conduct extensive research and development to deliver new innovations that help developers become more productive by reducing the efforts and overwhelming complexity in both development and deployment stage.

SmartWebResources™ Framework is one of the great technology offered by Intersoft, which is used to eliminate the external physical resources such as scripts, images, etc.

WebCombo Deployment Checklist

  1. RuntimeLicenseKey
    This is a key required in order to license the components for deployment purpose in production environment.

    Runtime license key is different with design-time license key that you get during purchase. Please obtain each licensed component's RuntimeLicenseKey from Intersoft Developer Network under My Component section. You only need to obtain once and reuse it in multiple projects. The login detail is provided in your purchase receipt. If you purchased from our resellers, it may take 24-48 hours for the verification and account creation process.

  2. Resources Assembly
    Ensure that you have copied the resources assemblies to your project's bin folder. The resources assembly can be found in [Installation Folder]\Intersoft Solutions\WebUI Studio for ASP.NET\WebCombo.NET 4.0\Bin. The resources assembly is:
    * ISNet.WebUI.WebCombo.Resources.dll
  3. Framework Assemblies
    You are required to copy framework assemblies to your project's bin folder. The framework assemblies can be found in [Installation Folder\Intersoft Solutions\WebUI Studio for ASP.NET\WebUI.NET Framework 3.0\Bin (Default installation directory). The framework assemblies are:
    * ISNet.dll
    * ISNet.WebUI.dll
  4. Component Assembly
    Component assembly is required to be copied to your project's bin folder. The component assembly can be found in [Installation Folder]\Intersoft Solutions\WebUI Studio for ASP.NET\WebCombo.NET 4.0\Bin. The component assembly is:
    * ISNet.WebUI.WebCombo.dll

Deploying project that uses SmartWebResources™

Here are step-by-step instructions to deploy the project using SmartWebResources™:

  1. Before deploying the project, you have to configure SmartWebResources after you created a new web application. Click here for guidance.
  2. Next, you need to use Deployment Manager in order to set the Web.config of your web application, such as defining Runtime License key. Please read Using Deployment Manager for more information.
  3. Finally, you simply need to XCopy all required web application files along with the bin folder (i.e. your project's directory) to a destination folder in your web server.

See Also

Other Resources
Using Deployment Manager
Deploying project that does not use SmartWebResources™
Application Wide Configurations

References
RuntimeLicenseKey Property


Deploying project that does not use SmartWebResources™

Deploying project that does not use SmartWebResources™
See Also Send Feedback
Intersoft WebCombo > Getting Started > Deployment > Deployment Guide > Deploying project that does not use SmartWebResources™

Glossary Item Box

General

WebCombo is built on the top of WebUI.NET Framework. It includes the common concept, functionalities and features implemented in the framework level.

WebCombo Deployment Checklist

  1. RuntimeLicenseKey
    This is a key required in order to license the components for deployment purpose in production environment.

    Runtime license key is different with design-time license key that you get during purchase.

    Use Deployment Manager to set the project's Web.config. There are 2 important things you need to notice:

    - If you set CommonLibrary folder as IIS Virtual Directory in development machine, you may refer to Using Deployment Manager topic for guidance.

    - If you copy the CommonLibrary folder to the project's directory in development machine, you may refer to Using Deployment Manager topic under Advanced section for guidance.

    Please obtain each licensed component's RuntimeLicenseKey from Intersoft Developer Network under My Component section. You only need to obtain once and reuse it in multiple projects. The login detail is provided in your purchase receipt. If you purchased from our resellers, it may take 24-48 hours for the verification and account creation process.
  2. CommonLibrary
    All subfolders and files inside CommonLibrary folder is required.
  3. Framework Assemblies
    You are required to copy framework assemblies to your project's bin folder. The framework assemblies can be found in [Installation Folder]\Intersoft Solutions\WebUI Studio for ASP.NET\WebUI.NET Framework 3.0\Bin (Default installation directory). The framework assemblies are as following:
    * ISNet.dll
    * ISNet.WebUI.dll
  4. Component Assembly
    Component assembly is required to be copied to your project's bin folder. The component assembly can be found in [Installation Folder]\Intersoft Solutions\WebUI Studio for ASP.NET\WebCombo.NET 4.0\Bin. The component assembly is as following:
    * ISNet.WebUI.WebCombo.dll

WebCombo Deployment Guide

  1. If you set CommonLibrary folder as IIS Virtual Directory in development machine
    - XCopy all your required web application files along with the bin folder (i.e. your project's directory) to a destination folder in your web server.
    - XCopy the CommonLibrary folder to your web server. It is recommended to place it under wwwroot folder (usually c:\inetpub\wwwroot). You need to map the destination folder to IIS Virtual Directory with name "CommonLibrary".
  2. If you copy the CommonLibrary folder to the project's directory in development machine
    - XCopy all your required web application files along with the bin and CommonLibrary folders (i.e. your project's directory) to a destination folder in your web server.

    Creating CommonLibrary as IIS Virtual Directory is not required in this case.

See Also

Other Resources
{Using Deployment Manager}
{Deploying project that uses SmartWebResources™}
{Application Wide Configurations}

References
RuntimeLicenseKey Property


Application Wide Configurations

Application Wide Configurations
See Also Send Feedback
Intersoft WebCombo > Getting Started > Deployment > Application Wide Configurations

Glossary Item Box

One of the unique features introduced since the initial WebCombo release is the ability to configure specific deployment-related properties via web.config. WebUI Framework further enhanced this capability by adding more properties which are configurable through web.config. Now, it also supports relative application path by using ~ character. The application-wide configurations feature allows centralized configuration for common deployment properties such as ScriptDirectory etc, which dramatically increase effectiveness and efficiency particularly for maintenance purpose.

Following is the list of properties that are configurable through web.config:

  • SharedScriptDirectory
  • ScriptDirectory
  • ImagesDirectory
  • ViewStateStorage
  • RuntimeLicenseKey
  • PageCachePriority
  • PageCacheDuration
  • RenderingMode
The settings specified in web.config will only be applied to instances' properties that have Default value (unchanged).

The format of the key used for the configuration is AssemblyFullName.vProductVersion.Properties.

Examples:

The sample configuration in web.config below will change the property value of ScriptDirectory, ImagesDirectory and SharedScriptDirectory to all WebCombo V4.0.7200 instances in the application.

<configuration>
   <appSettings>
      <add key="ISNet.WebUI.WebCombo.v4_0_7200.ScriptDirectory" value="~/CommonLibrary/WebCombo/V4_0_7200/" />
      <add key="ISNet.WebUI.WebCombo.v4_0_7200.ImagesDirectory" value="~/CommonLibrary/Images/" />
      <add key="ISNet.WebUI.WebCombo.v4_0_7200.SharedScriptDirectory" value="/CommonLibrary/Shared/" />
   </appSettings>
   ... other settings
</configuration>
Additional application-wide configurations may be available specifically per product. Please refer to the Application-wide Configurations topic in the product's help file.

See Also

Other Resources
Deployment Guide

References
SharedScriptDirectory Property
ScriptDirectory Property
ViewStateStorage Property
RuntimeLicenseKey Property
ImagesDirectory Property


Upgrading

Upgrading
See Also Send Feedback
Intersoft WebCombo > Getting Started > Upgrading

Glossary Item Box

This section contains information on the breaking changes in WebCombo and upgrading assembly reference from its previous version.

In This Section

Breaking Changes in WebCombo
Information about breaking changes in WebCombo 4.0 such as object model, user interface and others.

Upgrading from previous version
Read about the latest upgrade in WebCombo 4.0.

See Also

Other Resources
Samples and Walkthroughs


Breaking Changes in WebCombo

Breaking Changes in WebCombo
Send Feedback
Intersoft WebCombo > Getting Started > Upgrading > Breaking Changes in WebCombo

Glossary Item Box

This section contains information on the breaking changes in WebCombo 4.0, such as User Interface and others.

In This Section

User Interface
Read about the improvement user interface elements in WebCombo 4.0.

Default Value
Read about the changes on several properties for better user interface.

Styles
Learn how to use predefined styles in WebCombo 4.0.


Object Model

Object Model
See Also Send Feedback
Intersoft WebCombo > Getting Started > Upgrading > Breaking Changes in WebCombo > Object Model

Glossary Item Box

There are no breaking changes related to object model in WebCombo.NET 4.0. Your existing web application should be able to be run properly after migration to version 4.0.

See Also

Related Sections
User Interface
Default Values
Styles


User Interface

User Interface
See Also Send Feedback
Intersoft WebCombo > Getting Started > Upgrading > Breaking Changes in WebCombo > User Interface

Glossary Item Box

The user interface elements have been significantly improved in WebCombo.NET 4.0. In previous version, WebCombo control can be positioned inline with other text elements. That is possible because the previous version of WebCombo used inline SPAN element as the frame container. However, this introduced limitation to web standard support.

In version 4.0, WebCombo.NET has been revamped to use block element such as DIV for the frame container element. Other elements may have also been changed to block element. This breaking changes is made for better web standard support such as XHTML 1.1. Therefore in version 4.0, WebCombo.NET now fully supports XHTML 1.1 Transitional DOCTYPE.

In This Section

Layout comparison between previous version and version 4.0

How-to: Enable text floating to the right side of the WebCombo.NET control

How-to: Simulate inline text floating behavior as in previous version

FAQ: Recommended Layout Scenario

See Also

Other Resources
User Interface Elements
Default Values
Styles


Layout comparison between previous version and version 4.0

Layout comparison between previous version and version 4.0
See Also Send Feedback
Intersoft WebCombo > Getting Started > Upgrading > Breaking Changes in WebCombo > User Interface > Layout comparison between previous version and version 4.0

Glossary Item Box

The following illustration describes the layout changes and compare the result between previous version and version 4.0.

Layout model in WebCombo.NET 3.0:

Layout model in WebCombo.NET 3.0

Layout model in WebCombo.NET 4.0:
Layout model in WebCombo.NET 4.0

You can notice that the inline text in the left and right side of WebCombo in version 4 is pushed to either top or bottom of the WebCombo element. By default, inline text can no longer be at the same row with WebCombo due to this changes. However, there are ways to put text on the left and the right side of WebCombo to simulate the previous version's behavior. To learn more, please read How-to: Enable text floating to the right side of the WebCombo.NET control.

See Also

Other Resources
User Interface


How-to: Enable text floating to the right side of the WebCombo.NET control

How-to: Enable text floating to the right side of the WebCombo.NET control
See Also Send Feedback
Intersoft WebCombo > Getting Started > Upgrading > Breaking Changes in WebCombo > User Interface > How-to: Enable text floating to the right side of the WebCombo.NET control

Glossary Item Box

Due to the user interface changes in version 4.0, WebCombo introduces a new property that you can easily set to allow some text to float in the right side of the WebCombo control.

Enable text floating

For compatibility purpose, this property called AllowTextFloating is set to True by default. With this property set to True, the layout will look like the following:

Notice that the text now appears properly to the right side of WebCombo.

See Also

Tasks
How-to: Simulate inline text floating behavior as in previous version
FAQ: Recommended Layout Scenario
Walkthrough Topics
FAQ and How-to Topics

Concepts
User Interface

References
AllowFloatingText Property


How-to: Simulate inline text floating behavior as in previous version

How-to: Simulate inline text floating behavior as in previous version
See Also Send Feedback
Intersoft WebCombo > Getting Started > Upgrading > Breaking Changes in WebCombo > User Interface > How-to: Simulate inline text floating behavior as in previous version

Glossary Item Box

In the previous section, you have learned how to enable text floating on the right side of WebCombo.

In this section, we will discuss how to enable the text floating on the left side as well to simulate the behavior of WebCombo.NET 3.x.

Simulate inline text floating behavior

  1. Wrap the inline text that appears on the left of WebCombo inside a DIV container.
  2. Set the DIV's style to "float: left"
  3. The result should look like the following:

    The layout in WebCombo.NET 4.0 that simulates previous version's behavior.
  4. The modified HTML should look like the following:

    The modified HTML to simulate left text floating.

See Also

Tasks
How-to: Enable text floating to the right side of the WebCombo.NET control
FAQ: Recommended Layout Scenario
Walkthrough Topics
FAQ and How-to Topics

Concepts
{User Interface}

References
AllowFloatingText Property


FAQ: Recommended Layout Scenario

FAQ: Recommended Layout Scenario
See Also Send Feedback
Intersoft WebCombo > Getting Started > Upgrading > Breaking Changes in WebCombo > User Interface > FAQ: Recommended Layout Scenario

Glossary Item Box

Although the techniques in How-to: Simulate inline text floating behavior as in previous version work properly in common scenarios, it is not the recommended way to create a pixel-perfect layout. The recommended way to create side-by-side elements in a single row is by using TABLE layout.

TABLE layout enables you to create layout that will look and behave consistently in either old or modern browsers. If your web page has been using TABLE layout since previous version of WebCombo, you do not need to perform any extra efforts to adapt to the changes in User Interface. As an example, all of our samples provided in the previous version of WebCombo were using TABLE layout. When they are migrated to version 4.0, they can be displayed properly without changes.
The following illustration shows the design using TABLE layout. Notice that text and WebCombo are contained in separate cells.

See Also

Tasks
How-to: Enable text floating to the right side of the WebCombo control
How-to: Simulate inline text floating behavior as in previous version
Walkthrough Topics
FAQ and How-to Topics

Concepts
User Interface


FAQ: What does Default Style look like?

FAQ: What does Default Style look like?
See Also Send Feedback

Glossary Item Box

Please refer to New User Interface topic to see the look and feel of the Default Style.

See Also

Tasks
{How-to: Enable Default Style for existing instance of WebCombo}
FAQ: How can I continue to use 'classic WebCombo style' for new instances of WebCombo controls?
{FAQ: Can I still apply other predefined style in WebCombo.NET 4.0?}
{FAQ: What is the difference between Default Style and Predefined Style?}

Concepts
{Cleaner and reduced page output through built-in Default Style}


FAQ: How can I continue to use 'classic WebCombo style' for new instances of WebCombo controls?

FAQ: How can I continue to use 'classic WebCombo style' for new instances of WebCombo controls?
See Also Send Feedback

Glossary Item Box

You can continue to use classic style of WebCombo by applying the classic style from predefined style. When you do so, the Default Style feature will be automatically turned off. The styles definition will be embedded back to the control since WebCombo treats any predefined styles as custom style.

To apply classic style, please follow the steps below:

  1. Open the SmartTag Designer Panel.
  2. Click on Apply Predefined Style's dropdown under Styles category.

  3. Choose "Default Classic".

See Also

Tasks
How-to: Enable Default Style for existing instance of WebCombo
{FAQ: What does Default Style look like?}
{FAQ: Can I still apply other predefined style in WebCombo.NET 4.0?}
{FAQ: What is the difference between Default Style and Predefined Style?}

Concepts
Optimized Page Output


FAQ: Can I still apply other predefined style in WebCombo.NET 4.0?

FAQ: Can I still apply other predefined style in WebCombo.NET 4.0?
See Also Send Feedback

Glossary Item Box

In case that the Default Style does not look suitable to your web application, you can always choose to apply one of the predefined styles that come with WebCombo.NET.

To apply a predefined style, please follow the steps below:

  1. Open the SmartTag Designer Panel.
  2. Click on the Apply Predefined Style's dropdown under Styles category.

  3. Choose the desired predefined style to be applied.

See Also

Tasks
{How-to: Enable Default Style for existing instance of WebCombo}
{FAQ: What does Default Style look like?}
{FAQ: How can I continue to use "classic WebCombo style" for new instances of WebCombo controls?}
{FAQ: What is the difference between Default Style and Predefined Style?}

Concepts
Optimized Page Output


FAQ: What is the difference between Default Style and Predefined Style?

FAQ: What is the difference between Default Style and Predefined Style?
See Also Send Feedback

Glossary Item Box

Default Style is a new feature in WebCombo.NET version 4.0. It is different with Predefined Style.

Default Style feature marks the instance to use the default style that comes with WebCombo.NET 4.0. You are not recommended to customize any of the styles when using Default Style feature.

Predefined Styles is a list of styles that included in WebCombo.NET designated to help developer to easily achieve stylish look and feel. Predefined style is a physical file with ISL extension, and applied from Layout Manager. You can also apply predefined style from API at runtime.

See Also

Tasks
How-to: Enable Default Style for existing instance of WebCombo
{FAQ: What does Default Style look like?}
{FAQ: How can I continue to use "classic WebCombo style" for new instances of WebCombo controls?}
{FAQ: Can I still apply other predefined style in WebCombo.NET 4.0?}

Concepts
{Cleaner and reduced page output through built-in Default Style}


FAQ: Does SmartWebResources feature automatically enabled in WebCombo.NET 4.0?

FAQ: Does SmartWebResources feature automatically enabled in WebCombo.NET 4.0?
See Also Send Feedback

Glossary Item Box

By default, Intersoft 2007 product platform has the SmartWebResources set to Automatic mode. This automatic mode ensures compatibility with existing web application when developers migrated to 2007 platform, while at the same time attempting to utilize SmartWebResources in new web application whenever possible.

When you created a new web application and started to use WebCombo.NET version 4.0, the SmartWebResources is not configured initially. With the automatic mode as default behavior, WebCombo.NET will use physical resources since the SmartWebResources has not been configured.

See Also

Tasks
How-to: Configure SmartWebResources in a new web application

Concepts
Hassle-free deployment through SmartWebResources™ technology


FAQ: I am not familiar with DataSource control concept and I have been pretty much familiar with DataSource object binding that you introduced in pre-2007 products. Why do you introduce this new data binding concept?

FAQ: I am not familiar with DataSource control concept and I have been pretty much familiar with DataSource object binding that you introduced in pre-2007 products. Why do you introduce this new data binding concept?
See Also Send Feedback

Glossary Item Box

We did not introduce this new DataSource control binding concept. This new concept was introduced by Microsoft in ASP.NET 2.0. With this new data binding mechanism in ASP.NET 2.0, Microsoft encouraged developers to use DataSource control to take advantage of new features and productivity gains.

As leading third party component provider, we are committed to deliver latest products that integrate and work best with latest Microsoft's technologies. The DataSource control supported in Intersoft 2007 product lines enables professional developers to leverage the benefits of new data access features and functions available in ASP.NET 2.0 and Visual Studio 2005.

Recognizing many benefits that DataSource control offered, we highly recommend developers to use this new data binding mechanism.

See Also

Tasks
Walkthrough: Binding WebCombo to AccessDataSource control
Walkthrough: Binding WebCombo to ObjectDataSource control
FAQ: How can I learn more and where can I get more resources related to DataSource control?
FAQ: Does WebCombo.NET version 4.0 still support older data binding mechanism (i.e. through InitializeDataSource)?

Concepts
No-codes data binding through DataSourceControl support


FAQ: How can I learn more and where can I get more resources related to DataSource control?

FAQ: How can I learn more and where can I get more resources related to DataSource control?
See Also Send Feedback

Glossary Item Box

There are a lot of resources that explain how to use DataSource control. Please refer to the following sections.

  • To learn more about DataSource concept in general, read ASP.NET Data Access Overview.
  • To learn more about ObjectDataSource control, read ObjectDataSource Overview.
  • To learn how to display data using ObjectDataSource control in 3-tier application, visit http://www.asp.net/data-access/tutorials/displaying-data-with-the-objectdatasource-cs

See Also

Tasks
Walkthrough: Binding WebCombo to AccessDataSource control
Walkthrough: Binding WebCombo to ObjectDataSource control
FAQ: I am not familiar with DataSource control concept and I have been pretty much familiar with DataSource object binding that you introduced in pre-2007 products. Why do you introduce this new data binding concept?
FAQ: Does WebCombo.NET version 4.0 still support older data binding mechanism (i.e. through InitializeDataSource)?

Concepts
No-codes data binding through DataSourceControl support


FAQ: Does WebCombo.NET version 4.0 still support older data binding mechanism (i.e. through InitializeDataSource)?

FAQ: Does WebCombo.NET version 4.0 still support older data binding mechanism (i.e. through InitializeDataSource)?
See Also Send Feedback

Glossary Item Box

Older data binding mechanism through InitializeDataSource or DataSource property set in code behind is still supported. Existing web application that is still using older data binding mechanism will work flawlessly once migrated to Intersoft 2007 platform.

See Also

Tasks
Walkthrough: Binding WebCombo to AccessDataSource control
Walkthrough: Binding WebCombo to ObjectDataSource control
FAQ: I am not familiar with DataSource control concept and I have been pretty much familiar with DataSource object binding that you introduced in pre-2007 products. Why do you introduce this new data binding concept?
FAQ: How can I learn more and where can I get more resources related to DataSource control?

Concepts
No-codes data binding through DataSourceControl support


FAQ: How to use WebCombo in dual monitor?

FAQ: How to use WebCombo in dual monitor?
See Also Send Feedback

Glossary Item Box

As described in Real Dropdownlist Window topic, WebCombo's result box can be "float" outside its main window. Unfortunately, this feature caused issue in dual monitor, i.e. The result box is not displayed in the secondary monitor. To solve this issue, you need to set ResultBoxWindowType property to Normal.

This issue only occurs in IE.

See Also

Tasks
How-to: Set result box window type

References
ResultBoxWindowType Property


FAQ: How to implement adding item in WebCombo when we set AllowAutoPostBack and AllowAddItem to true?

FAQ: How to implement adding item in WebCombo when we set AllowAutoPostBack and AllowAddItem to true?
See Also Send Feedback

Glossary Item Box

Sometimes when you enable AllowAddItem and AllowAutoPostBack, you missed to create WebCombo_AddItem server side event. In this case, an error will occur because AddItem event is called but there is no event to handle this task. In this situation, you should create WebCombo_AddItem server side event.

For example:

C# Copy Image Copy Code
protected void WebCombo1_AddItem(object sender, ISNet.WebUI.WebCombo.RowEventArgs e
{
   // get cached data from data source control
   DataView view = this.EmployeeDataSource.Select(DataSourceSelectArguments.Empty) as DataView;

  // update the cached data
  DataTable table = view.Table;
  DataRow newRow = table.NewRow();
  newRow["FirstName"] = e.Row.Value;
  table.Rows.Add(newRow);
}

See Also

Tasks
How-to: AlowAddItem in WebCombo
How-to: Add item in bound WebCombo
How-to: Add item in unbound WebCombo from server side
How-to: Add item in unbound WebCombo from client side
How-to: Use OnAddItem client side event to validate input

Concepts
Dynamically Add Item


Default Values

Default Values
See Also Send Feedback
Intersoft WebCombo > Getting Started > Upgrading > Breaking Changes in WebCombo > Default Values

Glossary Item Box

In version 4.0, there are several properties which default value have been changed for better user interface that adapt to most common scenarios. Most of these changes are based on customer's feedbacks.
Property Name | Old Default Value | New Default Value
StatusBoxPosition | Top | Bottom

The changes in default values do not affect the functionality of WebCombo controls.

See Also

Other Resources
User Interface
Styles

References
StatusBoxPosition Property


Styles

Styles
See Also Send Feedback
Intersoft WebCombo > Getting Started > Upgrading > Breaking Changes in WebCombo > Styles

Glossary Item Box

Related to the User Interface changes as described in above topic, the styles of the WebCombo require significant updates as well. If you planned to upgrade your existing web application to use WebCombo.NET 4.0, you should carefully review the breaking changes in the styles aspect as described in the following:

  • Affected predefined styles
  • The impact level of this breaking changes

In This Section

How-to: Re-apply the styles to use updated predefined style in designer

How-to: Update the style definition when applying the style programmatically at runtime

How-to: Update the style definition when the WebCombo control is themed at application-wide level (themed using WebStyleManager)

See Also

Other Resources
User Interface
Default Values


Affected predefined styles

Affected predefined styles
See Also Send Feedback
Intersoft WebCombo > Getting Started > Upgrading > Breaking Changes in WebCombo > Styles > Affected predefined styles

Glossary Item Box

If you are using one of the predefined style in the following list, you will need to re-apply and update them in order to appear properly in version 4.0.

  • WinXP Blue
  • WinXP Silver
  • Mac OS X Tiger
  • Minimalist

See Also

Related Sections
The impact level of this breaking changes

Other Resources
Styles


The impact level of this breaking changes

The impact level of this breaking changes
See Also Send Feedback
Intersoft WebCombo > Getting Started > Upgrading > Breaking Changes in WebCombo > Styles > The impact level of this breaking changes

Glossary Item Box

The breaking changes in styles has crucial impact level to the appearance of WebCombo, while it may not affect the functionality. Several display issues may happen at runtime if your existing web application was using one of the styles listed above, such as:

  • The image of the dropdown button does not display in proper position.
  • The dropdown button size may exceed the height of the control so it gives impression of being truncated.
  • The textbox element and dropdown element may be separated (not inline).
If you are experiencing one of the condition mentioned above, please update the styles with the new ones that come with WebCombo.NET 4.0. To learn more about how to update the styles, please read the topics under In This Section below.

In This Section

How-to: Re-apply the styles to use updated predefined style in designer

How-to: Update the style definition when applying the style programmatically at runtime

How-to: Update the style definition when the WebCombo control is themed at application-wide level (themed using WebStyleManager)

See Also

Related Sections
Affected predefined styles

Other Resources
Styles


How-to: Re-apply the styles to use updated predefined style in designer

How-to: Re-apply the styles to use updated predefined style in designer
See Also Send Feedback
Intersoft WebCombo > Getting Started > Upgrading > Breaking Changes in WebCombo > Styles > How-to: Re-apply the styles to use updated predefined style in designer

Glossary Item Box

In this section, you will be guided to re-apply the styles to use updated predefined style using the new WebCombo designer.

For example, if you were previously using Mac OS Tiger style then you would need to re-apply the style due to the breaking changes.

Re-apply styles using designer

  1. Open the SmartTag Panel, click on WebCombo Designer command.
  2. Click on Layout Manager link in the left navigation.
  3. Expand Predefined Style, choose Mac OS X Tiger then click apply.

See Also

Tasks
How-to: Update the style definition when applying the style programmatically at runtime
How-to: Update the style definition when the WebCombo control is themed at application-wide level (themed using WebStyleManager)
Walkthrough Topics
FAQ and How-to Topics

Concepts
Styles

References
LayoutSet Class


How-to: Update the style definition when applying the style programmatically at runtime

How-to: Update the style definition when applying the style programmatically at runtime
See Also Send Feedback
Intersoft WebCombo > Getting Started > Upgrading > Breaking Changes in WebCombo > Styles > How-to: Update the style definition when applying the style programmatically at runtime

Glossary Item Box

If you are applying style using programmatic technique, that is by loading the layout at runtime (calling LoadLayout function), then all you need to do is simply copying the new styles definition to the folder where the existing styles reside. The next time you deploy your application, the WebCombo should automatically load from the new styles.

The new predefined styles can be found at [Program Files]\Intersoft Solution\WebCombo.NET 4.0\Layout

See Also

Tasks
How-to: Re-apply the styles to use updated predefined style in designer
How-to: Update the style definition when the WebCombo control is themed at application-wide level (themed using WebStyleManager)
Walkthrough Topics
FAQ and How-to Topics

Concepts
{Styles}

References
LoadLayout Method


How-to: Update the style definition when the WebCombo control is themed at application-wide level (themed using WebStyleManager)

How-to: Update the style definition when the WebCombo control is themed at application-wide level (themed using WebStyleManager)
See Also Send Feedback
Intersoft WebCombo > Getting Started > Upgrading > Breaking Changes in WebCombo > Styles > How-to: Update the style definition when the WebCombo control is themed at application-wide level (themed using WebStyleManager)

Glossary Item Box

If you are using WebStyleManager to theme the WebCombo appearance globally in your web application, please do the following to apply the new styles:

  1. Determine the theme's path used in your web application. In most common scenarios, themes are stored in private path of web application. E.g. ~/Themes.
  2. Open Windows Explorer and go to the folder containing the theme's definition.
  3. Copy the designated style definition (e.g. Mac.isl) from WebCombo Installation Folder to the theme's folder. Note that this process will replace/overwrite the old WebCombo style definition with the new one.
  4. Delete the auto-generated external stylesheet (css) manually.
  5. Restart your web application. The easiest way to do this is by killing aspnet_wp process.
  6. Run your web application.
The first request to your web application will automatically regenerate the external stylesheet which is used by the entire pages that apply this theme. You should see the proper appearance and display of the WebCombo after performing the styles upgrade.

Please note that you only need to do these instructions if you were using one of the predefined styles that listed in Affected Predefine Styles section.

See Also

Tasks
How-to: Re-apply the styles to use updated predefined style in designer
How-to: Update the style definition when applying the style programmatically at runtime
Walkthrough Topics
FAQ and How-to Topics

Concepts
Styles


Upgrading from previous version

Upgrading from previous version
Send Feedback
Intersoft WebCombo > Getting Started > Upgrading > Upgrading from previous version

Glossary Item Box

This section contains information on the upgrading areas from WebCombo's previous version.

In This Section

Overview
Read about the most significant major upgrade in WebCombo.

Assembly Reference
Learn how to migrate your existing web application to WebCombo .

Checking Layout after Upgrading
Learn how to deal with strange layout in WebCombo after upgrading.

Checking Styles after Upgrading
Learn how to deal with inappropriate display of WebCombo's appearance.


Overview

Overview
See Also Send Feedback
Intersoft WebCombo > Getting Started > Upgrading > Upgrading from previous version > Overview

Glossary Item Box

WebCombo 4.0 is the most significant major upgrade since initial version of WebCombo containing key enhancements in user interface, entry behaviors and full declarative data binding support.

If you are planning to upgrade your existing web application to use WebCombo.NET 4.0, please take the following points into consideration:

  • WebCombo 4.0 is especially designed for ASP.NET 2.0 in order to fully support native databinding features and new design-time features to improve developer's productivity.
    If your existing web application is still running on ASP.NET 1.x (developed using Visual Studio 2003), you cannot upgrade to version 4.0. We strongly encourage developers to start migrating to Visual Studio 2005 to obtain many benefits and features introduced in .NET 2.0.
If you are a new web developer and would like to develop ASP.NET 2.0 web application using WebCombo 4.0, you may want to check out Microsoft's Visual Web Developer Express. Visual Web Developer Express is a lightweight version of Visual Studio 2005, and is provided for free by Microsoft. Since that WebCombo 4.0 is built on the top of Visual Studio 2005 architecture, Visual Web Developer Express is fully supported as well. To download Visual Web Developer Express, visit http://msdn.microsoft.com/vstudio/express/vwd/download/
  • If you are planning to upgrade existing web application to use WebCombo 4.0, please ensure you have carefully read, reviewed and understood the changes introduced in version 4.0. All breaking changes are listed in Breaking Changes section.

See Also

Other Resources
Assembly Reference
Checking Layout after Upgradin
Checking Styles after Upgrading


Assembly Reference

Assembly Reference
See Also Send Feedback
Intersoft WebCombo > Getting Started > Upgrading > Upgrading from previous version > Assembly Reference

Glossary Item Box

Our development team is working hard to ensure that you can upgrade your web application as smooth as possible in less efforts. You can easily migrate your existing web application to use version 4.0 by simply changing the assembly references to 4.0 assemblies.

This is possible because there is no breaking changes in this object model since version 3.0. and thus there is no need to upgrade the existing application using external upgrade tool. However, if you are upgrading from WebCombo 1.x or 2.x, you will need to run Upgrade Tool before migrating to version 4.0.

To upgrade an existing ASP.NET 2.0 web application to use WebCombo 4.0, please do the following:

  • Open an existing web application in Visual Studio 2005/Express
  • Expand Bin folder
  • Remove ISNet.dll, ISNet.WebUI.dll and ISNet.WebUI.WebCombo.dll
  • Right click on the Project node then click Add Reference
  • Add ISNet.dll, ISNet.WebUI.dll from [Installation Folder]\Intersoft Solutions\WebUI Studio for ASP.NET\WebUI.NET Framework 3.0\Bin
    [Note that the file version should be 3.0.5000.400+]
  • Add ISNet.WebUI.WebCombo.dll from [Installation Folder]\Intersoft Solutions\WebUI Studio for ASP.NET\WebCombo.NET 4.0\Bin
  • Rebuild your web application and run in browser.
If you are planning to use new SmartWebResouces™ feature available in WebCombo 4.0 for simpler deployment, please refer to Easy SmartWebResources Deployment.

See Also

Other Resources
Upgrading Overview
Checking Layout after Upgrading
Checking Styles after Upgrading


Checking Layout after Upgrading

Checking Layout after Upgrading
See Also Send Feedback
Intersoft WebCombo > Getting Started > Upgrading > Upgrading from previous version > Checking Layout after Upgrading

Glossary Item Box

If you are experiencing strange layout or display in the WebCombo control after upgrading to version 4.0, please read breaking changes in User Interface area. The resolutions to the problem are also discussed in the sub topic.

See Also

Other Resources
Upgrading Overview
Assembly Reference
Checking Styles after Upgrading


Checking Styles after Upgrading

Checking Styles after Upgrading
See Also Send Feedback
Intersoft WebCombo > Getting Started > Upgrading > Upgrading from previous version > Checking Styles after Upgrading

Glossary Item Box

Once you have successfully upgrade to version 4.0 by referencing to new assemblies, you may want to check the WebCombo's appearance in your existing web pages. If you are experiencing inappropriate display of the WebCombo's appearance, most chance you were using one of the styles listed in Styles breaking changes. Please read the Breaking Changes topic to learn what have been changed since previous version. The resolution to the styles problem are also discussed in the sub topic.

See Also

Other Resources
Upgrading Overview
Assembly Reference
Checking Layout after Upgrading


Samples and Walkthroughs

Samples and Walkthroughs
See Also Send Feedback
Intersoft WebCombo > Getting Started > Samples and Walkthroughs

Glossary Item Box

This section contains information about location of sample and tutorial files, example codes and how to use WebCombo in Visual Studio 2005.

In This Section

Locating Sample Files
Discover the locations where sample files are stored on your computer or the installation source.

WebCombo Walkthroughs
Learn how to create basic applications in WebCombo with these step-by-step guides.

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

Other Resources
What's new in 4.0
Features and Concepts
Advanced


Locating Sample Files

Locating Sample Files
See Also Send Feedback
Intersoft WebCombo > Getting Started > Samples and Walkthroughs > Locating Sample Files

Glossary Item Box

The default locations for Sample files in this release are listed below. %% represents the location where Intersoft's components are installed, such as \Program Files\Intersoft Solutions\.

Product | Sample Location
C# Samples (Visual Studio 2010 Solution) | [Installation Folder]\Intersoft WebUI Studio 2010 R1\Samples\For ASP.NET\ISNet.WebUI.Samples\cs
VB Samples (Visual Studio 2010 Solution) | [Installation Folder]\Intersoft WebUI Studio 2010 R1\Samples\For ASP.NET\ISNet.WebUI.Samples\vb

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

Other Resources
WebCombo Walkthroughs


WebCombo Walkthroughs

WebCombo Walkthroughs
See Also Send Feedback
Intersoft WebCombo > Getting Started > Samples and Walkthroughs > WebCombo Walkthroughs

Glossary Item Box

These walkthroughs introduce the important basic area of WebCombo component. Each walkthrough discusses the development of binding WebCombo for the first time, how to set up the DataSource and apply WebCombo basic features such as refresh bind WebCombo to AccessDataSource control and refresh combo using a series of step-by-step instructions.

In This Section

Walkthrough: Binding WebCombo to AccessDataSource control
Demonstrates how to bind WebCombo with AccessDataSource control such as Access DataBase created by Microsoft Office.

Walkthrough: Binding WebCombo to ObjectDataSource control
Demonstrates how to bind WebCombo with ObjectDataSource such as DataSet in the Bin or App_code directory.

Walkthrough: Binding WebCombo to ISDataSource control
Demonstrates how to bind WebCombo with the new Intersoft's technology, ISDataSource control.

Walkthrough: Binding WebCombo to SqlDataSource control
Demonstrates how to bind WebCombo with SqlDataSource control.

How-to: Set initial value from server side in WebCombo
Demonstrates how to set initial value from code behind.

How-to: Refresh WebCombo
Demonstrates how to refresh WebCombo from both server side and client side.

More Walkthrough Topics
Lists complete walkthrough topics available in WebCombo.

See Also

Tasks
Walkthrough Topics
{FAQ and How-to Topics}


Walkthrough: Binding WebCombo to AccessDataSource control

Walkthrough: Binding WebCombo to AccessDataSource control
See Also Send Feedback
Intersoft WebCombo > Getting Started > Samples and Walkthroughs > WebCombo Walkthroughs > Walkthrough: Binding WebCombo to AccessDataSource control

Glossary Item Box

This walkthrough shows you how to create and bind WebCombo to AccessDataSource control.

During this walkthrough, you will learn how to do the following:

  • Use AccessDataSource.
  • Use SmartTag to set DataSource.
  • Use Data Source Configuration Wizard to set the Database and table.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and bind WebCombo to AccessDataSource

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. In the Solution Explorer, right-click on App_Data and select Add Existing Item.
  8. Browse and add NorthWind.mdb in C:\Program Files\Intersoft Solutions\Data (Default installation folder).
  9. Drag WebCombo instance from ToolBar to WebForm.
  10. Click the SmartTag on the upper right of the WebCombo.
  11. Set the DataTextField and DataValueField for WebCombo.
  12. In Choose Data Source field, choose <New data source...>

  13. In Data Source Configuration Wizard, choose AccessDatabase and click OK.

  14. Select the connection string in App_Data and click OK.

  15. Select the table that you want to use, click Next and Finish afterwards.

  16. Run the project and the combo will look like following.

See Also

Tasks
Walkthrough: Binding WebCombo to ObjectDataSource control
Walkthrough: Binding WebCombo to ISDataSource control
Walkthrough: Binding WebCombo to SqlDataSource control
How-to: Refresh WebCombo
FAQ: I am not familiar with DataSource control concept and I have been pretty much familiar with DataSource object binding that you introduced in pre-2007 products. Why do you introduce this new data binding concept?
FAQ: How can I learn more and where can I get more resources related to DataSource control?
FAQ: Does WebCombo.NET version 4.0 still support older data binding mechanism (i.e. through InitializeDataSource)?

Concepts
Data Binding Wakthroughs

References
DataSource Property
WebCombo Class
DataSourceID Property
DataTextField Property
DataValueField Property


Walkthrough: Binding WebCombo to ObjectDataSource control

Walkthrough: Binding WebCombo to ObjectDataSource control
See Also Send Feedback
Intersoft WebCombo > Getting Started > Samples and Walkthroughs > WebCombo Walkthroughs > Walkthrough: Binding WebCombo to ObjectDataSource control

Glossary Item Box

This walkthrough shows you how to create and bind WebCombo to ObjectDataSource control.

During this walkthrough, you will learn how to do the following:

  • Use ObjectDataSource.
  • Use SmartTag to set DataSource.
  • Use Data Source Configuration Wizard to set the Database and table.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and bind WebCombo to ObjectDataSource

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. In the Solution Explorer, right-click on App_Data and select Add Existing Item.
  8. Browse and add NorthWind.mdb in C:\Program Files\Intersoft Solutions\Data (Default installation folder).
  9. Drag WebCombo instance from ToolBar to WebForm.
  10. Click the SmartTag on the upper right of the WebCombo.
  11. Set the DataTextField and DataValueField for WebCombo.
  12. In Choose Data Source field, choose <New data source...>.

  13. In Data Source Configuration Wizard, choose Object and click OK.

  14. Select your Business Object and click Next.

  15. Click Finish and run the project.

  16. The combo will look like following.

See Also

Tasks
Walkthrough: Binding WebCombo to AccessDataSource control
Walkthrough: Binding WebCombo to ISDataSource control
Walkthrough: Binding WebCombo to SqlDataSource control
How-to: Refresh WebCombo
FAQ: I am not familiar with DataSource control concept and I have been pretty much familiar with DataSource object binding that you introduced in pre-2007 products. Why do you introduce this new data binding concept?
FAQ: How can I learn more and where can I get more resources related to DataSource control?
FAQ: Does WebCombo.NET version 4.0 still support older data binding mechanism (i.e. through InitializeDataSource)?

Concepts
No-codes data binding through DataSourceControl support

References
DataSource Property
WebCombo Class
DataTextField Property
DataValueField Property


Walkthrough: Binding WebCombo to ISDataSource control

Walkthrough: Binding WebCombo to ISDataSource control
See Also Send Feedback
Intersoft WebCombo > Getting Started > Samples and Walkthroughs > WebCombo Walkthroughs > Walkthrough: Binding WebCombo to ISDataSource control

Glossary Item Box

This walkthrough shows you how to create and bind WebCombo to ISDataSource control.

During this walkthrough, you will learn how to do the following:

  • Use ISDataSource.
  • Use SmartTag to set DataSource.
  • Use Data Source Configuration Wizard to set the Database and table.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and bind WebCombo to ISDataSource

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. In the Solution Explorer, right-click on App_Data and select Add Existing Item.
  8. Browse and add NorthWind.mdb in C:\Program Files\Intersoft Solutions\Data (Default installation folder).
  9. Drag WebCombo instance from ToolBar to WebForm.
  10. Click the SmartTag on the upper right of the WebCombo.
  11. Set the DataTextField and DataValueField for WebCombo.
  12. In Choose Data Source field, choose <New data source...>.

  13. In Data Source Configuration Wizard, choose ISDataSource and click OK.

  14. Select the Schema Type that you want to use and click Next.

  15. Add the table required and click Finish.

  16. Run the project and the combo will look like following.

See Also

Tasks
Walkthrough: Binding WebCombo to AccessDataSource control
Walkthrough: Binding WebCombo to ObjectDataSource control
Walkthrough: Binding WebCombo to SqlDataSource control
Walkthrough: Binding multiple WebCombo instances to ISDataSource control
Walkthrough: Using load-on-demand data retrieval with ISDataSource control in WebCombo
How-to: Refresh WebCombo

Concepts
No-codes data binding through DataSourceControl support
Advanced Load-on-Demand data retrieval through ISDataSourceControl support

References
DataSource Property
WebCombo Class
DataTextField Property
DataValueField Property


Walkthrough: Binding WebCombo to SqlDataSource control

Walkthrough: Binding WebCombo to SqlDataSource control
See Also Send Feedback
Intersoft WebCombo > Getting Started > Samples and Walkthroughs > WebCombo Walkthroughs > Walkthrough: Binding WebCombo to SqlDataSource control

Glossary Item Box

This walkthrough shows you how to create and bind WebCombo to SQLDataSource control.

During this walkthrough, you will learn how to do the following:

  • Use SQLDataSource.
  • Use SmartTag to set DataSource.
  • Use Data Source Configuration Wizard to set the Database and table.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft SQL Northwind database.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and bind WebCombo to SQLDataSource

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. In the Solution Explorer, right-click on App_Data and select Add Existing Item.
  8. Browse and add NorthWind.mdb in C:\Program Files\Intersoft Solutions\Data (Default installation folder).
  9. Drag WebCombo instance from ToolBar to WebForm.
  10. Click the SmartTag on the upper right of the WebCombo.
  11. Set the DataTextField and DataValueField for WebCombo.
  12. In Choose Data Source field, choose <New data source...>.

  13. In Data Source Configuration Wizard, choose Database and click OK.

  14. Select the ConnectionString and click Next.

  15. Select the table that you want to use and click Next.

  16. Click Finish and run the project.

  17. The combo will look like following.

See Also

Tasks
Walkthrough: Binding WebCombo to AccessDataSource control
Walkthrough: Binding WebCombo to ObjectDataSource control
Walkthrough: Binding WebCombo to ISDataSource control
How-to: Refresh WebCombo

Concepts
No-codes data binding through DataSourceControl support

References
DataSource Property
DataSourceID Property
DataTextField Property
DataValueField Property


How-to: Set initial value from server side in WebCombo

How-to: Set initial value from server side in WebCombo
See Also Send Feedback
Intersoft WebCombo > Getting Started > Samples and Walkthroughs > WebCombo Walkthroughs > How-to: Set initial value from server side in WebCombo

Glossary Item Box

In WebCombo, you can set initial WebCombo value from Server-side.

This topic will show you how to set initial value from Server-side in WebCombo.

To Set initial value from Server-side in WebCombo

  1. Bind WebCombo to AccessDataSource.
  2. Initiate WebCombo's Value in Page_Load server side event using WebCombo's Value property.

    C# Copy Image Copy Code
    WebCombo1.Value = "ANTON";

  3. Here is the result.

WebCombo.Value should be supplied with WebCombo DataValueField not DataTextField

See Also

Tasks
Walkthrough: Binding WebCombo to AccessDataSource control
Walkthrough: Binding WebCombo to ObjectDataSource control
Walkthrough: Binding WebCombo to ISDataSource control
Walkthrough: Binding WebCombo to SqlDataSource control
How-to: Set initial value from server side in WebCombo


How-to: Refresh WebCombo

How-to: Refresh WebCombo
See Also Send Feedback
Intersoft WebCombo > Getting Started > Samples and Walkthroughs > WebCombo Walkthroughs > How-to: Refresh WebCombo

Glossary Item Box

In WebCombo, you can refresh the combo from either Client or Server-side.

This topic will show you how to refresh WebCombo on both sides.

To Refresh WebCombo on Server-side

  1. Drag ASP.NET Button to the page.
  2. Double click the ASP.NET button. Then, add the following code in Button1_Click event handler:

    C# Copy Image Copy Code
    WebCombo1.ClearCachedDataSource();

  3. Run the project.

To Refresh WebCombo on Client-side

  1. Go to HTML View and write <input id="Button2" type="button" value="Refresh" onclick="refresh()" />.
  2. Create function refresh() in HTML and add the following code:

    JavaScript Copy Code
    var combo = ISGetObject("WebCombo1");
combo.NeedClearList = true;

  3. Run the project.

See Also

Tasks
Walkthrough: Binding WebCombo to AccessDataSource control
Walkthrough: Binding WebCombo to ObjectDataSource control
Walkthrough: Binding WebCombo to ISDataSource control
Walkthrough: Binding WebCombo to SqlDataSource control
How-to: Set initial value from server side in WebCombo


More Walkthrough Topics

More Walkthrough Topics
See Also Send Feedback
Intersoft WebCombo > Getting Started > Samples and Walkthroughs > WebCombo Walkthroughs > More Walkthrough Topics

Glossary Item Box

For a list of complete walkthrough topics, please see Complete Walkthrough Topics.

See Also

Tasks
FAQ and How-to Topics


What's New In WebCombo 6

What's New In WebCombo 6
See Also Send Feedback
Intersoft WebCombo > What's New In WebCombo 6

Glossary Item Box

WebCombo provides you with the most powerful, flexible combo box available in the industry which delivers instant data retrieval with LINQ-to-SQL technology and the capability to fetch millions of rows in just a few seconds. With innovative features such as type-ahead searching, auto completion mode, multiple columns, multiple selections and more, performing data entry with WebCombo is easier and more reliable than ever before.

In version 6, WebCombo has been redesigned to fully support the latest web standards. This allows you to use the powerful WebCombo's features in your next-generation web applications that leverages the cutting-edge technologies such as HTML5.

The following list details the enhancements and new features introduced in WebCombo 6.

  • Full compliance with HTML5 doc type.

    HTML5 doc type enables consistent results and pixel-perfect rendering across all modern browsers that support HTML5.

    The following features have been enhanced to support HTML5 doc type:
      • Multiple Columns
      • Multiple Selection
      • SearchBox Position
      • Dynamic Add Items
      • Integration with Context Menu
      • ResultBoxWindowType will default to Normal when using HTML5 mode

To learn how to enable HTML5 rendering mode in WebCombo, see How-to: Enable HTML5 Rendering Mode.

  • CSS3 support.

    When the WebCombo control is hosted in pages that use HTML5 doc type, it will automatically enable CSS3 to deliver better visual effects and consistent results across all modern browsers. The CSS3 adoption also increases performance in overall due to the reduced HTML output. This is possible because certain markups are no longer required in the rendering which makes the WebCombo output even more compact.

    The following features have been enhanced to use CSS3:
      • Round Corner Edges
      • ResultBox Drop Shadow
      • ResultBox Rendering
WebCombo 6 continues to support backward compatibility with HTML4 and XHTML doc type. This means that you can upgrade your existing projects to WebCombo 6 without any additional efforts.

See Also

Getting Started
Getting Started

Features and Concepts
WebCombo Features Overview
WebCombo Advanced Features

Learning More
Learning More


How-to: Enable HTML5 Rendering Mode

How-to: Enable HTML5 Rendering Mode
See Also Send Feedback
Intersoft WebCombo > What's New In WebCombo 6 > How-to: Enable HTML5 Rendering Mode

Glossary Item Box

This topic explains how to configure WebCombo to emit HTML5 compliance output.

Configure Doc Type

Each doctype declaration in HTML specification produces different results and behaviors, mostly in the layout and rendering aspects. WebCombo supports most commonly used doctype and automatically adjust the behaviors and rendering results by detecting the doctype declaration of the HTML page.

In version 6, WebCombo has been significantly enhanced to deliver consistent behaviors and layout in HTML5 pages. All features should work exactly as in other doctype.

To enable HTML5 support in WebCombo, make sure you have configured the HTML pages to use the proper doctype. The standard doctype for HTML5 is <!DOCTYPE html>.

The following code example shows how to use WebCombo in a simple WebForm using HTML5 doctype.

ASPX Copy Code
<%@ Page Language="C#" AutoEventWireup="true" CodeFile="Default.aspx.cs" Inherits="cs_WebCombo_Default" %>
<%@ Register Assembly="ISNet.WebUI.WebCombo" Namespace="ISNet.WebUI.WebCombo" TagPrefix="ISWebCombo" %>

<!DOCTYPE html>
<html>
<head runat="server">
    <title></title>
</head>
<body>
    <form id="form1" runat="server">
    <div>
        <ISWebCombo:WebCombo ID="WebCombo1" runat="server" DataSourceID="AccessDataSource1"
            DataTextField="ContactName" DataValueField="CustomerID" UseDefaultStyle="True"
            Width="200px">
        </ISWebCombo:WebCombo>
        <asp:AccessDataSource ID="AccessDataSource1" runat="server" DataFile="~/App_Data/Northwind.mdb"
            SelectCommand="SELECT * FROM [Customers]"></asp:AccessDataSource>
    </div>
    </form>
</body>
</html>

Note that the xmlns attribute is no longer necessary to be defined in the <html> tag. If you upgraded your existing pages, make sure the xmlns attribute is removed from the <html> tag.

Configure Rendering Mode

To provide the best HTML5 support, WebCombo needs to adjust several features that are commonly processed in the server-side such as markup rendering and AJAX callback response. Unfortunately, the HTML5 doctype cannot be automatically detected by the server-side browser capability. As such, WebCombo introduces a new property called RenderingMode which you must set explicitly in order to activate HTML5 compliance output.

You can set the rendering mode in a WebCombo instance individually by setting the RenderingMode property to HTML5 value, such as shown in the example below.

ASPX Copy Code
<ISWebCombo:WebCombo ID="WebCombo1" runat="server" RenderingMode="HTML5">
</ISWebCombo:WebCombo>

Alternatively, you can also apply the rendering mode globally through the application-wide configuration, see the following example.

Web.config Copy Code
<add key="ISNet.WebUI.WebCombo.v6_0_7200.RenderingMode" value="HTML5"/>
If your project is exclusively targeting HTML5, it's recommended to use application-wide configuration to apply the rendering mode to all WebCombo instances in the project.

For more information about application-wide settings in WebCombo, see Application Wide Configurations.

See Also

What's New
What's New In WebCombo 6


Walkthrough Topics

Walkthrough Topics
See Also Send Feedback
Intersoft WebCombo > Walkthrough Topics

Glossary Item Box

This topic provides the links to walkthroughs that demonstrate how to use the features implemented in WebCombo, and how to customize the behaviors through the means of programmatic APIs and events.

Common Tasks

The topics in this category list all the general and common WebCombo tasks such as data binding.

  • Walkthrough: Binding WebCombo to AccessDataSource control
  • Walkthrough: Binding WebCombo to SqlDataSource control
  • Walkthrough: Binding WebCombo to ObjectDataSource control
  • Walkthrough: Binding WebCombo to ISDataSource control
  • Walkthrough: Binding WebCombo to XMLDataSource control
  • Walkthrough: Binding WebCombo to a DataSet
  • Walkthrough: Getting started with WebCombo.NET version 4.0 using SmartTag Designer
  • Walkthrough: Binding multiple WebCombo instances to ISDataSource control
  • Walkthrough: Using load-on-demand data retrieval with ISDataSource control in WebCombo

Client Data Services

The topics in this category provide information about configuring WebCombo with Client Data Services

  • Walkthrough: Configure WebCombo To Retrieve Data From Web Service
  • Walkthrough: Configure WebCombo To Retrieve Data From WCF Service
  • Walkthrough: Configure WebCombo To Retrieve Data From ADO Data Service

WebCombo and LINQ to SQL

The topics in this category provide information about configuring WebCombo to use LinqDataSource.

  • Walkthrough: Binding WebCombo to LinqDataSource
  • Walkthrough: Enabling AllowWildcardSearch
  • Walkthrough: Configuring Linked WebCombo

No-code data binding through DataSourceControl support

The topics in this category provide information about binding WebCombo to AccessDataSource, ObjectDataSource and other data source controls.

  • Walkthrough: Binding WebCombo to AccessDataSource control
  • Walkthrough: Binding WebCombo to SqlDataSource control
  • Walkthrough: Binding WebCombo to ObjectDataSource control
  • Walkthrough: Binding WebCombo to ISDataSource control
  • Walkthrough: Binding WebCombo to XMLDataSource control
  • Walkthrough: Binding WebCombo to XML-based DataSource
  • Walkthrough: Binding WebCombo to IList DataSource control
  • Walkthrough: Binding WebCombo to a DataSet
  • Walkthrough: Binding WebCombo to custom object
  • Walkthrough: Implementing requery method using traditional DataSource
  • Walkthrough: Implementing requery method using ISDataSource

Advanced Load-on-Demand data retrieval through ISDataSourceControl support

The topics in this category provide information about binding WebCombo to ISDataSource control.

  • Walkthrough: Binding WebCombo to ISDataSource control
  • Walkthrough: Binding multiple WebCombo instances to ISDataSource control
  • Walkthrough: Using load-on-demand data retrieval with ISDataSource control in WebCombo

Learning More

The topic in this category provides information about using SmartTag Designer together with WebCombo.

  • Walkthrough: Getting started with WebCombo.NET version 4.0 using SmartTag Designer

Data Binding Techniques using Data Source Object

The topics in this category show how to bind WebCombo to data source objects.

  • Walkthrough: Binding WebCombo to a DataSet
  • Walkthrough: Binding WebCombo to XML-based DataSource
  • Walkthrough: Binding WebCombo to IList DataSource control
  • Walkthrough: Binding WebCombo to custom object

Data Binding Techniques using Data Source Control

The topics in this category shows how to bind WebCombo to data source controls.

  • Walkthrough: Binding WebCombo to AccessDataSource control
  • Walkthrough: Binding WebCombo to SqlDataSource control
  • Walkthrough: Binding WebCombo to ObjectDataSource control
  • Walkthrough: Binding WebCombo to XMLDataSource control
  • Walkthrough: Binding WebCombo to DataSet using ISDataSource control

See Also

Tasks
FAQ and How-to Topics

Other Resources
Features and Concepts
Advanced


FAQ and How-to Topics

FAQ and How-to Topics
See Also Send Feedback
Intersoft WebCombo > FAQ and How-to Topics

Glossary Item Box

This topic lists the how-to and FAQ topics of WebCombo and describes how to implement the wide range of WebCombo features in your ASP.NET projects.

Common Tasks

The topics in this category list all the common and general WebCombo tasks such as data binding and styles customization.

  • How-to: Enable HTML5 Rendering Mode
  • How-to: Set initial value from server side in WebCombo
  • How-to: Refresh WebCombo
  • How-to: Enable text floating to the right side of the WebCombo.NET control
  • How-to: Enable Round Corner in WebCombo.NET 4.0
  • How-to: Enable animation
  • How-to: Enable Default Style for existing instance of WebCombo
  • How-to: Configure SmartWebResources in a new web application
  • How-to: Set selected row in unbound WebCombo
  • How-to: Create unbound WebCombo using PopulateUnboundData method
  • How-to: Allow auto PostBack
  • How-to: Always show all rows on dropdown combo
  • How-to: Define the search image
  • How-to: Set the TextBox mode in WebCombo
  • How-to: Get the hidden cell's value of the selected row
  • How-to: Set combo's alignment to be right displayed
  • How-to: Allow AddItem in WebCombo
  • How-to: Add item in bound WebCombo
  • How-to: Add item in unbound WebCombo from server side
  • How-to: Enable wildcard search
  • How-to: Use WebCombo without search button
  • How-to: Utilize ImageAndText ColumnType
  • How-to: Get the value of the selected row in WebCombo
  • How-to: Set selected row in bound WebCombo
  • How-to: Show/Hide WebCombo
  • How-to: Set focus on WebCombo
  • How-to: Get the text and value of multiple selection WebCombo
  • How-to: Get WebCombo instance
  • How-to: Trigger OnTheFlyPost from client side
  • How-to: Set result box window type
  • How-to: Use multiple columns mode
  • How-to: Use single dependency linked WebCombo
  • How-to: Use bound multiple selection WebCombo
  • How-to: Use unbound multiple selection WebCombo
  • How-to: Set initial value of multiple selection WebCombo from server side
  • How-to: Apply load on demand in WebCombo
  • How-to: Add columns to WebCombo
  • How-to: Add rows to WebCombo
  • How-to: Enable XML compression
  • FAQ: Recommended Layout Scenario
  • FAQ: What is the difference between Default Style and Predefined Style?
  • FAQ: I am not familiar with DataSource control concept and I have been pretty much familiar with DataSource object binding that you introduced in pre-2007 products. Why do you introduce this new data binding concept?
  • FAQ: How to use WebCombo in dual monitor?

Client Data Binding

The topic in this category provides direct instruction on how to configure Client Binding.

  • How-to: Configure Client Binding Mode using Server Data Source

Client Data Services

The topics in this category provide direct instructions on how to configure Client Data Services.

  • How-to: Add New Item to Web Service
  • How-to: Handle Data Service Events

Client Binding API

The topic in this category provides direct instruction on how to configure Client Binding API.

  • How-to: Bind WebCombo to Client-side Data Source

User Interface Customization

The topics in this category provide direct instructions on how to enable text floating in WebCombo.

  • How-to: Enable Round Corner in WebCombo.NET 4.0
  • How-to: Enable animation
  • How-to: Enable Sliding Animation in WebCombo
  • How-to: Enable text floating to the right side of the WebCombo.NET control
  • How-to: Simulate inline text floating behavior as in previous version
  • How-to: Set combo's alignment to be right displayed
  • How-to: Position search box on the left
  • How-to: Use WebCombo without search button
  • FAQ: Recommended Layout Scenario

Styles Customization

The topics in this category provide direct instructions on how to use predefined style.

  • How-to: Re-apply the styles to use updated predefined style in designer
  • How-to: Update the style definition when applying the style programmatically at runtime
  • How-to: Update the style definition when the WebCombo control is themed at application-wide level (themed using WebStyleManager)

Using Default Style

The topics in this category provide direct instructions on how to enable Default Style.

  • How-to: Enable Default Style for existing instance of WebCombo
  • FAQ: What does Default Style look like?
  • FAQ: How can I continue to use 'classic WebCombo style' for new instances of WebCombo controls?
  • FAQ: Can I still apply other predefined style in WebCombo.NET 4.0?
  • FAQ: What is the difference between Default Style and Predefined Style?

Configuring SmartWebResources Deployment

The topics in this category provide a direct instruction on how to configure SmartWebResources.

  • How-to: Configure SmartWebResources in a new web application
  • FAQ: Does SmartWebResources feature automatically enabled in WebCombo.NET 4.0?

Using Data Source Control

The topics in this category provide the frequently asked questions about data source control.

  • FAQ: I am not familiar with DataSource control concept and I have been pretty much familiar with DataSource object binding that you introduced in pre-2007 products. Why do you introduce this new data binding concept?
  • FAQ: How can I learn more and where can I get more resources related to DataSource control?
  • FAQ: Does WebCombo version 4.0 still support older data binding mechanism (i.e. through InitiliazeDataSource)?

Integration with WebTreeView

The topic in this category provide information on how to integrate WebTreeView control to WebCombo.

  • How-to: Integrate a WebTreeView control to WebCombo

Integration with WebContextMenu

The topic in this category provide information on how to integrate WebContextMenu control to WebCombo.

  • How-to: Integrate a WebContextMenu control to WebCombo

Unbound Mode

The topics in this category provide direct instructions on how to perform various scenarios in unbound WebCombo.

  • How-to: Add Item in unbound WebCombo from server side
  • How-to: Add item in unbound WebCombo from client side
  • How-to: Set selected row in unbound WebCombo
  • How-to: Modify the first cell of the first row in unbound WebCombo
  • How-to: Delete a row in unbound WebCombo
  • How-to: Perform batch update in unbound WebCombo
  • How-to: Create unbound WebCombo using PopulateUnboundData method
  • How-to: Create multiple columns unbound WebCombo using PopulateUnboundData method

Behaviors Customization

The topics in this category provide direct instructions on how to configure WebCombo's behaviors and features in details.

  • How-to: Define access key
  • How-to: Display tooltip in WebCombo
  • How-to: Determine the number of rows first requested by WebCombo
  • How-to: Set the latency
  • How-to: Allow auto PostBack
  • How-to: Disable auto query handler
  • How-to: Enable/Disable WebCombo
  • How-to: Show/Hide WebCombo
  • How-to: Disable ViewState in WebCombo
  • How-to: Show error message when there is missing specification
  • How-to: Define tab index
  • How-to: Disable auto data caching
  • How-to: Use cached data on first load
  • How-to: Disable WebResources
  • How-to: Adjust result box position
  • How-to: Allow text to float on the right side of WebCombo
  • How-to: Allow navigation on mouse wheel
  • How-to: Always show all rows on dropdown combo
  • How-to: Always show column headers
  • How-to: Always show help button
  • How-to: Always show result box
  • How-to: Always show search button
  • How-to: Set default column width
  • How-to: Enable/Disable animation
  • How-to: Define the help image
  • How-to: Define help URL
  • How-to: Define the row's height
  • How-to: Define the action when no results is found in WebCombo
  • How-to: Define the result box's height and width
  • How-to: Show the result box's shadow
  • How-to: Position search box on the left
  • How-to: Use round corner in WebCombo
  • How-to: Define the search image
  • How-to: Define the position of status bar
  • How-to: Hide/Show the status box
  • How-to: Define XHTML search image
  • How-to: Get the hidden cell's value of the selected row
  • How-to: Set result box window type

Dynamically Add Item

The topics in this category provide direct instructions on how to add item in WebCombo.

  • How-to: Allow AddItem in WebCombo
  • How-to: Add item in bound WebCombo
  • How-to: Add item in unbound WebCombo from server side
  • How-to: Add item in unbound WebCombo from client side
  • How-to: Use OnAddItem client side event to validate input
  • FAQ: How to implement adding item in WebCombo when we set AllowAutoPostBack and AllowAddItem to true?

Additional Search Field

The topic in this category provides a direct instruction on how to use AdditionalSearchField for searching text.

  • How-to: Use AdditionalSearchField to search a query text on other column besides DataTextField column

Minimum Character Request

The topic in this category provides a direct instruction on how to configure minimum character typed.

  • How-to: Set minimum character typed to request the data

Allow WildCard Search

The topic in this category provides a direct instruction on how to activate wildcard search.

  • How-to: Enable wildcard search

TextBox Mode

The topic in this category provides a direct instruction on how to set TextBox mode.

  • How-to: Set the TextBox mode in WebCombo

Validation

The topics in this category provide direct instructions on how to apply validation such as RequiredFieldValidator in WebCombo.

  • How-to: Use RequiredFieldValidator to ensure the WebCombo cannot be empty
  • How-to: Implement WebCombo and RequiedFieldValidator in Web User Control

Column Types

The topics in this category provide direct instructions on how to utilize various column types in WebCombo.

  • How-to: Utilize text ColumnType
  • How-to: Utilize image ColumnType
  • How-to: Utilize ImageAndText ColumnType
  • How-to: Utilize custom ColumnType

Extensible Client-side Programming

The topics in this category provide direct instructions on how to perform various scenarios using client side programming.

  • How-to: Filter the data in WebCombo using SetAdditionalFilter method
  • How-to: Clear the AdditionalFilter applied to WebCombo
  • How-to: Get the text of the selected row in WebCombo
  • How-to: Get the value of the selected row in WebCombo
  • How-to: Set selected row in bound WebCombo
  • How-to: Set selected row in unbound WebCombo
  • How-to: Get total retrieved rows in WebCombo
  • How-to: Get total rows in WebCombo
  • How-to: Hide and show dropdown combo
  • How-to: Modify the first cell of the first row in unbound WebCombo
  • How-to: Delete a row in unbound WebCombo
  • How-to: Perform batch update in unbound WebCombo
  • How-to: Get the selected row
  • How-to: Use OnAddItem client side event to validate input
  • How-to: Refresh WebCombo
  • How-to: Get/Set the TextBox value
  • How-to: Get the number of rows in WebCombo
  • How-to: Get specific row by its index
  • How-to: Enable/Disable WebCombo
  • How-to: Show/Hide WebCombo
  • How-to: Set focus on WebCombo
  • How-to: Get the text and value of multiple selection WebCombo
  • How-to: Get WebCombo instance
  • How-to: Display the result box to the right side of WebCombo
  • How-to: Trigger OnTheFlyPost from client side
  • How-to: Set the value of another controls in OnAfterItemSelected client side events
  • How-to: Validate string only input in OnKeyDown client side events

Automatic Data Caching Handler

The topic in this category provides a direct instruction on how to turn off auto data caching.

  • How-to: Disable auto data caching

ClientAction Engine

The topics in this category provide direct instructions on how to ClientAction function in server side.

  • How-to: Display message box if unable to add a row
  • How-to: Navigate to specific page after adding a row
  • How-to: Refresh other control during row addition

Real Dropdownlist Window

The topics in this category provide direct instructions on how to set result box type and use combo in dual monitor.

  • How-to: Set result box window type
  • FAQ: How to use WebCombo in dual monitor?

Multiple Columns

The topic in this category provides a direct instruction on how to apply multiple columns mode in WebCombo.

  • How-to: Use multiple columns mode

Entry Mode

The topics in this category provide direct instructions on how to configure various entry mode in WebCombo.

  • How-to: Use default entry mode
  • How-to: Use AutoComplete entry mode
  • How-to: Use InstantLookUp entry mode

Linked WebCombo

The topics in this category provide direct instructions on how to get familiar with linked WebCombo.

  • How-to: Use combined dependencies linked WebCombo
  • How-to: Use multiple dependencies linked WebCombo
  • How-to: Use single dependency linked WebCombo
  • How-to: Use unbound linked WebCombo

Multiple Selection

The topics in this category provide direct instructions on how to use multiple selection in WebCombo.

  • How-to: Use bound multiple selection WebCombo
  • How-to: Use unbound multiple selection WebCombo
  • How-to: Set initial value of multiple selection WebCombo from server side
  • How-to: Set initial value of multiple selection WebCombo from client side

Load On Demand

The topic in this category provides a direct instruction on how to apply load on demand.

  • How-to: Apply load on demand in WebCombo

OnTheFly PostBack

The topic in this category provides a direct instruction on how to apply SetAdditionalFilter from server side.

  • How-to: Use SetAdditionalFilter to filter data from server side

Working with Designer

The topics in this category provide direct instructions on how to add columns and rows using WebCombo Designer.

  • How-to: Add columns to WebCombo
  • How-to: Add rows to WebCombo

Layout Manager

The topics in this category provide direct instructions on how to apply and preview the layout available in WebCombo.

  • How-to: Apply Predefined Layout
  • How-to: Save Current Layout
  • How-to: Apply Saved Layout
  • How-to: Preview Layout

Miscellaneous WebCombo Settings

The topics in this category provide direct instructions on how to perform other settings in WebCombo.

  • How-to: Integrate to FormView
  • How-to: Integrate to GridView
  • How-to: Integrate to WebGrid
  • How-to: Set FlyPostBackSettings
  • How-to: Enable XML compression
  • How-to: Set ScriptDirectory and SharedScriptDirectory
  • How-to: Set images directory
  • How-to: Implement linked WebCombo functionality using column that is not DataTextField or DataValueField as the FilterDataMember
  • How-to: Improve FlyPostBack performance

See Also

Tasks
Walkthrough Topics

Other Resources
Features and Concepts
Advanced

References
AllowAddItem Property
OnAddItem Property


WebCombo Features Overview

WebCombo Features Overview
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview

Glossary Item Box

This topic summarizes the key features available in the latest version of WebCombo. It provides information about the basic features of WebCombo such as query mode, multiple columns, editing validation and rich UI customizations. You will also learn how to use WebCombo such as using the control in data bound mode, customizing the search fields and items adding, allowing wild card search, and more.

This topic discusses the WebCombo features in depth, which contains the following topics.

  • Data Binding
  • Unbound Mode
  • User Interface Elements
  • Improved Layout
  • Dynamically Add Item
  • Additional Search Field
  • Minimum Character Request
  • Allow WildCard Search
  • TextBox Mode
  • Validation
  • WebCombo Look and Feel
  • Column Types
  • Extensible Client-side API
  • Text Settings

Data Binding

One of the most significant productivity gain that you can experience after migrating to the latest version of WebCombo version 4 is the new, codeless data binding development experience.

Codeless data binding means that you can configure the data source, its connection and related property without writing code. This means that means you can configure the datasource through a simple drag-drop and a few mouse clicks.

You can declaratively create a WebCombo instance and bind it to a table in your SQL database in two simple statements such as illustrated in the following example:

ASPX Copy Code
<ISWebCombo:WebCombo ID="WebCombo1" runat="server"
            UseDefaultStyle="True" Width="200px" Height="20px"
            DataSourceID="SqlDataSource1" DataTextField="ActivityName
            DataValueField="ActivitiesId">
</ISWebCombo:WebCombo>
ASPX Copy Code
<asp:SqlDataSource ID="SqlDataSource1" runat="server"
                   ConnectionString="<$ ConnectionStrings:DbConnectionString >"
                   SelectCommand="SELECT * FROM [Activities]">

As you can see in the above examples, the WebCombo1 is bound to a DataSource control through DataSourceID property. The WebCombo connects to the specified DataSource control and display data from the DataSource available in SqlDataSource1.

With this new data binding concept, building a data bound web application is very fairly easy and straightforward. Also notice that there is no code required in the page's code behind. In the previous version, you will need to configure the InitializeDataSource event and write code in the event which pass the DataSource to the e.DataSource property. While this technique is no longer required in WebCombo version 4.0, it is still supported for backward compatibility.

The benefits of the new DataSource control binding support:

  • Improved developer's productivity via codeless, simple and hassle-free data binding.
  • Cleaner separation between User Interface and Data Access/Business Layer codes.
    All data layer codes and logics are now handled at DataSource control level instead of component level. That means UI component such as WebCombo is now purely serving as data selector and combo box function, and no longer handling DataSource.
  • Better architecture.
    For more than decades, developer was struggling to find the best pattern in developing data bound application. DataSource control binding concept is one of the most appealing and acceptable mechanism recognizing its cleaner separation between user interface and data access layer.
  • Highly reusable.
    DataSource control offers better reusability since it has rock solid architecture. For instance, developer can write business layer codes in application level which is used throughout the application and use ObjectDataSource to connect to the business layer function.
  • Extensible.
    DataSource controls such as ObjectDataSource and ISDataSource (Intersoft's proprietary multi-views DataSource control) have the ability to connect to custom business layer codes. You can also connect the controls to DataSet and TableAdapter that are generated using Visual Designer in Visual Studio 2005, as well as connect it to extended function that you write in an extended class through new "partial class" mechanism.

Several important notes that developer should aware with the new DataSource control concept:

  • InitializeDataSource event is no longer fired when the WebCombo is bound to DataSourceID. This event will still be fired normally when the DataSourceID property is empty (old data binding mode).
  • You cannot bind to DataSource control and DataSource object at the same time. For instance, if you set DataSourceID to SqlDataSource1 and at the same time set WebCombo1.DataSource = dsNorthWind.Customers in the code, these will throw an invalid operation exception.
  • Flat-view DataSource controls that come with ASP.NET 2.0 are all supported. This includes SqlDataSource, AccessDataSource and ObjectDataSource.
  • All internal operations and existing functions in WebCombo are still working properly with the new DataSource control binding. This ensures full compatibility in behaviors and functions with the previous versions.
  • Data caching.
    In pre-2007 platform, Intersoft's data bound control such as WebCombo and WebGrid Enterprise employ built-in automatic data caching mechanism. In 2007 product lines, the built-in data caching is no longer functioning when the control is bound to DataSource control. To configure caching, please refer to the capability of the DataSource control that you used to bind to the control. For instance, if you bind a WebCombo control to SqlDataSource, then you can enable the caching by setting EnableCaching of the SqlDataSource control to True.

To learn more about data binding, see Data Binding Wakthroughs.

FAQ

FAQ: I am not familiar with DataSource control concept and I have been pretty much familiar with DataSource object binding that you introduced in pre-2007 products. Why do you introduce this new data binding concept?

We did not introduce this new DataSource control binding concept. This new concept was introduced by Microsoft in ASP.NET 2.0. With this new data binding mechanism in ASP.NET 2.0, Microsoft encouraged developers to use DataSource control to take advantage of new features and productivity gains.

As leading third party component provider, we are committed to deliver latest products that integrate and work best with latest Microsoft's technologies. The DataSource control supported in Intersoft 2007 product lines enables professional developers to leverage the benefits of new data access features and functions available in ASP.NET 2.0 and Visual Studio 2005.

Recognizing many benefits that DataSource control offered, we highly recommend developers to use this new data binding mechanism.

FAQ: How can I learn more and where can I get more resources related to DataSource control?

There are a lot of resources that explain how to use DataSource control. Please refer to the following sections.

  • To learn more about DataSource concept in general, read ASP.NET Data Access Overview.
  • To learn more about ObjectDataSource control, read ObjectDataSource Overview.
  • To learn how to display data using ObjectDataSource control in 3-tier application, visit http://www.asp.net/data-access/tutorials/displaying-data-with-the-objectdatasource-cs

FAQ: Does WebCombo version 4.0 still support older data binding mechanism (i.e. through InitiliazeDataSource)?

Older data binding mechanism through InitializeDataSource or DataSource property set in code behind is still supported. Existing web application that is still using older data binding mechanism will work flawlessly once migrated to Intersoft 2007 platform.

Unbound Mode

WebCombo has the ability to implement the control in true Unbound mode by using improved server-side object models. Unbound mode is a feature where the data is not bound to database even though the data could be taken from database. Developers can easily add multiple columns and row items in a single interface WebCombo Designer(Centralized). The columns and rows can also be added dynamically at runtime. It is also applicable to the Microsoft ASP.NET Server component guideline including standard ViewState implementation.

Here is the snapshot to create unbound mode in WebCombo Designer:

To learn more about unbound mode, see Unbound Mode How-to Topics.

User Interface Elements

WebCombo is designed to deliver the most sophisticated and rich user interface. The UI elements of WebCombo include:
  • DropDown arrow [Refer to screenshot A]
    An arrow that is used to open the result box of WebCombo.
  • Round corner edges [Refer to screenshot A]
    One of the most significant user interface improvements in version 4 is its ability to render round corner around the edges. The round corner rendering is fluid and flexible, means that it can be drawn properly regardless of the size.
  • Column name [Refer to screenshot B]
    Shows the name for each column in result box.
  • WebCombo's TextBox [Refer to screenshot C]
    You could enter text that you want to search in the WebCombo. The result box will show the filtered text based on the inputted text in the combo's TextBox.
  • ResultBox [Refer to screenshot D]
    It shows you the filtered data based on the inputed text in WebCombo's TextBox.
  • Status [Refer to screenshot E]
    A panel that is used to display the loaded data and the number of the total rows.
  • Load more data arrow [Refer to screenshot F] [Refer to screenshot F]
    This arrow is used to get more data loaded.
  • ScrollBar [Refer to screenshot G]
    You can use the scrollbar to navigate data inside WebCombo.
  • Help icon [Refer to screenshot H]
    When you click the help icon, there will be a pop-up window that shows you the combo's help guidance.

To learn more, please see User Interface Customization How-to Topics.

Improved Layout

WebCombo adds numerous appearance-related properties to improve the look and appearance of the WebCombo layout such as:

  • Ability to truncate overflow text as ellipsis and display the complete text in a ToolTip.

  • Configures the default ListBox's width and height.
  • Supports percentage width.
  • Improves automated ListBox positioning when used in complex container.
  • Save and apply layout setting at runtime.
  • Set WebCombo's alignment to be right displayed.
  • And much more.

To learn more about combo's alignment, see How-to: Set combo's alignment to be right displayed.

Dynamically Add Item

One of the unique features available in WebCombo is the ability to add a new record at run time without requiring full page postback. When you set the AllowAddItem property of the WebCombo to true, you will be able to add items which are not existed in the data source.

Now, the row addition to WebCombo can be done through client-side. You can use the object-oriented JavaScript function which has been provided by the WebCombo API specifically to add new rows to the WebCombo. The best thing about this feature is that the new object will be available directly in the client-side which replicates the server object model. This makes client-side development as comfortable as in the server.

The following illustration shows the snapshots the feature:

  1. Initial data population

  2. Search for specific record

  3. Searched text is added

  4. Final data

As you can see from the snapshots above, the data insertion is fairly simple and straightforward. When you search for an item which is not existed in the list, the particlar item can be added instantly to the collection by simply pressing the "Enter" key. The result is shown in the third snapshot above.

FAQ

FAQ: How to implement adding item in WebCombo when we set AllowAutoPostBack and AllowAddItem to true?

Sometimes when you enable AllowAddItem and AllowAutoPostBack, you missed to create WebCombo_AddItem server side event. In this case, an error will occur because AddItem event is called but there is no event to handle this task. In this situation, you should handle the WebCombo_AddItem server side event.

For example:

C# Copy Image Copy Code
protected void WebCombo1_AddItem(object sender, ISNet.WebUI.WebCombo.RowEventArgs e
{
   // get cached data from data source control
   DataView view = this.EmployeeDataSource.Select(DataSourceSelectArguments.Empty) as DataView;

  // update the cached data
  DataTable table = view.Table;
  DataRow newRow = table.NewRow();
  newRow["FirstName"] = e.Row.Value;
  table.Rows.Add(newRow);
}

Additional Search Field

WebCombo allows multiple field to be searched against DataSource instead of just the specified DataTextField. The DataTextField remains to be the primary search field followed by comma separated list of string specified in the AdditionalSearchField property. This feature is extremely useful in a situation where you want to search the information in multiple columns.

The following image illustrates the AdditionalSearchField feature.

In the screenshot above, AdditionalSearchField is set to ContactName and City columns. When user types "ber" in the combo's box, it will search any data that contains "ber" characters in the defined columns, such as Bernardo Batista (ContactName), Berlin (City) and etc.

To learn more, see How-to: Use AdditionalSearchField to search a query text on other column besides DataTextField column.

Minimum Character Request

Another time-saving features available in WebCombo is the ability to define the minimum character before the control queries the data to the server. First, it checks for the input length that users type into the WebCombo, then compare against the length specified in the MinCharsToRequest property. With this feature, data retrieval will be performed only if it satisfies the value assigned to MinCharsToRequest property. This feature is specifically useful to narrow down relatively large result sets by limiting the data requests based on the number of typed characters.

Below is the snapshot of the feature:

Normal behavior

Behavior with MinCharsToRequest property set to 2

To learn more, see How-to: Set minimum character typed to request the data.

Allow Wildcard Search

By default, WebCombo will search the datasource based on the starting character of the user's input. For example, if user inputs an "a" character in the text box, WebCombo will search all data that begins with the "a" character.

Allow Wildcard Search is a feature that allows wildcard/fuzzy logic searching. For example, if user inputs "rio" in the search field, WebCombo will search all data that contains the word "rio".

To learn more, see How-to: Enable wildcard search.

TextBox Mode

TextBoxMode has two enumeration: Editable and ReadOnly.

When the TextBoxMode is set to Editable, WebCombo will use the default searching behavior. Users can filter the datasource by typing a keyword into the text box. When set to ReadOnly, WebCombo will behave like a standard ASP.NET Dropdown List. Users can select an item from the list, but filtering functionality is disabled.

To learn more, see How-to: Set the TextBox mode in WebCombo.

Validation

WebCombo supports .NET's control validation, which means that it is compatible with all Validators control such as RequiredFieldValidator. You can easily create a validation simply by dropping a validator control from toolbox into your web form and set its ControlToValidate property to the WebCombo object you want to validate.

The results look like the following illustration.

To learn more, see Validation How-to Topics.

Column Types

WebCombo provides predefined column type such as Image, ImageAndText and so on, which are most commonly used. For greater level of customization, the content of the WebCombo's column can also be customized to display rich HTML-based content by setting the ColumnType property to Custom and write the custom content code in InitializeRow Server-side event.

Below is the screenshot of ImageAndText Column Type:

To learn more about Column Types, see Column Type How-to Topics.

Extensible Client-side Programming

WebCombo provides a set of comprehensive client side API to let developers extending the WebCombo to achieve more advanced business scenarios. You can access WebCombo's properties and methods using the similar server-side syntax.

The following example shows how to get the selected row in WebCombo in the client-side.

JavaScript Copy Image Copy Code
function SetText()
{
   var WebCombo1 = ISGetObject("WebCombo1");
   WebCombo1.SetText("Maria Anders");
   WebCombo1.LoadValue();
}

To learn more, please see Extensible Client-side Programming How-to Topics.

Text Settings

You can easily customize the textual settings of the WebCombo control through the WebCombo Designer. Under the Advanced Settings node, expands LayoutSettings and Text Settings node, you will find the textual-related properties as you can see in the following illustration. You can modify each property in the designer by simply modified the predefined text settings.

textSetting

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

Other Resources
Features Added In WebCombo 5
Learning More
Advanced


Features Added In WebCombo 5

Features Added In WebCombo 5
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added In WebCombo 5

Glossary Item Box

WebCombo 5 is strongly focused on enterprise web development which has evolved to adopt the latest web technologies such as cloud computing, software-as-a-service (SaaS) and other Web 2.0 related technologies. WebCombo 5 features an advanced client-side data binding architecture which allows you to easily bind a WebCombo to service-based data source such as Web Service, WCF (Windows Communication Foundation) Service, and the ADO Data Service. In addition, WebCombo also enables a number of advanced client-side scenarios such as binding to a JSON data source which is retrieved from a RESTful web service.

This topic provides the information and links to the new features and enhancements in WebCombo 5.

In This Section

Client Data Binding

Provides a comprehensive overview of the client-side data binding architecture spanning from the concepts, benefits, to the supported features and samples.

Client Data Services

Discusses the concepts of client data services, the type of service it supports, and provides information on the best practices and key scenarios to develop service-based applications using WebCombo.

Client Binding API

Describes the new public methods and events which are available when client binding mode is enabled, and the data source type is set to either client services or client data source.

Default Style Merging

Contains information about the new option in WebCombo to merge user-defined styles with the default style.

See Also

Getting Started
Getting Started
WebCombo Walkthroughs

How-to
FAQ and How-to Topics


Client Data Binding

Client Data Binding
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added In WebCombo 5 > Client Data Binding

Glossary Item Box

WebCombo 5 is strongly focused on enterprise web development which has evolved to adopt the latest web technologies such as cloud computing, software-as-a-service (SaaS) and other Web 2.0 related technologies. Featuring a powerful client binding architecture, WebCombo 5 is the most revolutionary release yet which has been significantly revamped to meet the high performance standards demanded by today’s web applications. This topic discusses the new client-side data binding feature in WebCombo, describes its new technologies and benefits, and explains how it resolves performance bottleneck without trading-off the essential features.

This topic contains the following sections:

  • Introduction to the Client Data Binding
  • The Benefits of Client Data Binding
  • Performance Benchmark and Comparison
  • Supported Features
  • The Differences with Server Data Binding
  • How Client Data Binding Works
  • Rich Client Data Operation

Introduction to the Client Data Binding

Client-side binding is a mechanism that processes data operation and perform data binding entirely in the client-side. Data binding consists of a series of data processing operation that takes a raw-form of data and shapes it into a logical object, which is then rendered into user interface. Client-side binding simply means that data binding should be performed in the client-side (also known as browser), rather than in the server-side (ASP.NET).

All previous versions of WebCombo and most of the ASP.NET server-side controls perform data binding in the server-side. Server-side binding normally sent HTML markup as the final output, which is directly recognized by browsers with very minimum overhead in the client side. In certain scenarios such as in data listing that consist of many rows and cells, the HTML markup result could become huge and takes longer time to transfer from the server to client. Consequently, it could bring potential performance problems that impact user experiences in overall.

Unlike server-side binding, the client-side binding often returns raw data which has significantly smaller size compared to the HTML markup. WebCombo 5 incorporates JSON (Javascript Object Notation) as its data exchange format for all data operation in WebCombo.

The following diagram illustrates the new WebCombo’s architecture and client binding life cycle.

As seen in the above illustration, WebCombo is built on the top of solid client binding architecture which processes data operation entirely in the client-side – from the data dispatching, data filtering, binding to rendering.

The Benefits of Client Data Binding

At the heart of the WebCombo's client binding architecture is VirtualRendering, a state-of-the-art client rendering framework that enables WebCombo to render data rows efficiently, while at the same time delivering identical user interface as in server-side rendering. This rendering technology is one of the key components in Intersoft’s client binding architecture that transform logical data object into user interface elements.

The uniqueness of Intersoft’s rendering technology lies in its ability to perform rendering with very minimum overhead. This is made possible with sophisticated state management that automatically synchronizes its current state as user interacts with the WebCombo control in the runtime.

Client-side binding provides comprehensive solution for developers to accomplish many advanced scenarios and tasks which were previously difficult or not possible to be achieved. The following list explains several key benefits of client-side binding:

  • Data footprint reduction by over 90%. When operating in client binding mode, WebCombo returns raw data in JSON format which is significantly smaller compared to HTML markup. In many scenarios, WebCombo has been proven to reduce data footprint consistently by over 90%. For more information, please refer to Performance Benchmark and Comparison in the section below.
  • Superior performance and increased response time. With re-engineered architecture to support client binding extensively, WebCombo yields better performance and increased response time as it skips several default behaviors, data processing and rendering that used to be produced from server side.
  • More responsive and intuitive user experiences. The nature of client-side binding – which exchange data in its raw format, enables WebCombo to receive data faster from the server. Consequently, end users will get more responsive user experience even in relatively slower network connection.
  • Connect to external site or service-based datasource (“Cloud” support). With solid client binding implementation, developers can bind WebCombo to data source from an external location such as Web service, Windows Communication Foundation (WCF) service, or ADO Data Service.
  • Future proof – supporting more service-oriented development methodology. Intersoft’s approach to client-side binding is an agnostic implementation that completely independence from the server-side object model. This enables WebCombo to perform data binding based on any raw forms of data in JSON format. The JSON data can be produced by a server hosted by ASP.NET, PHP, or other platforms. Based on the understanding of Intersoft’s client binding implementation, it also enables developers to achieve completely unbound scenarios as well as future development methodologies such as ASP.NET MVC and Windows Azure.

Performance Benchmark and Comparison

The following charts illustrate the performance comparison between server-side and client-side binding in several aspects, such as data footprint and network connection type. This section also shows the comparison between different modes of client-side binding.

Data footprint size comparison on AJAX operation based on various Grid configurations

Response time comparison on AJAX operation

*) Performance benchmark is tested on Intel® Core™ 2 Duo 2.4Ghz processor with 2 GB memory.
**) Tested samples are using the combination of Northwind’s Customers and Orders data table.

Supported Features

WebCombo 5 features unique client binding architecture that addresses performance bottleneck as well as introduces numerous benefits, without trading-off essential Grid features. Intersoft’s ClientBinding is designed to work in concert with key and fundamental features already implemented in WebCombo.

The following features have been tested and enhanced to fully support the client binding operation mode:

  • Core features such as querying and paging (load more operation).
  • Multiple Columns
  • Wildcard Searching
  • Multiple Selection
  • Linked WebCombo
  • Add Item
  • Data Format String
  • Entry Mode
  • All layout settings such as round corner and default style

The Differences with Server Data Binding

This section provides information on how client-side binding differs to server-side binding in terms of data processing and event life cycle. The details will also help you in upgrading existing implementation that used server-side binding into client-side binding properly.

Server-side binding processes data binding, initialization and rendering in the following way:

Client-side binding includes a special ServerDataSource mode to enable you to quickly leverage existing server-side infrastructure while taking advantage of many benefits introduced by client binding. This means that you can still connect WebCombo to a server-side data source – such as SqlDataSource, ObjectDataSource, LinqDataSource – or data source object assigned in InitializeDataSource event; while performing data binding operation in the client side.

Client-side binding using ServerDataSource mode processes data binding, initialization and rendering in the following way:

As you can see in the illustrated diagram above, client-side binding mode stripped several processes from the data binding, initialization and rendering process in server-side.

The key points of the differences can be summarized in the following:

  • Physical data connection such as retrieving data from data source control and prepare data binding event will still be invoked in client binding mode. The life cycle is consistent in both first page load and FlyPostBack actions, and works in the same way as in server-side binding mode.
  • Client binding shapes the raw data into semi-processed data, such as including important data such as value list translation, sorted rows, and more. It doesn’t perform grouping operation.
  • WebCombo intelligently repackages the data into rowset required only by the current view – taking account paging, filtering and other aspects.
  • WebCombo sent the repackaged data in JSON format – reducing over 90 percent of data footprint.
  • Since the actual rendering does no longer occurring in the server side, the initialize events – such as InitializeColumn, InitializeRow and InitializeCell – are no longer raised.
  • As the data binding is performed in the client side, WebCombo provides new client side events for data post-processing requirements. As such, if you have existing codes that perform initialization in one of the above mentioned events, the codes will no longer work. You’ll need to migrate the codes to the appropriate client-side events.

    For example, consider the following C# codes to handle post-processing in InitializeRow server-side event:
    C# Copy Code
        protected void wcReportsTo_InitializeRow(object sender, ISNet.WebUI.WebCombo.RowEventArgs e)
    {
        e.Row.Cells[0].Image = "images/" + e.Row.Cells[0].Text + ".jpg";
        e.Row.Cells[0].CustomObjectAttributes = " width='48' height='48'";
    }

Since the InitializeRow event is no longer raised in client binding mode, the above code will not be executed. To achieve the same post-processing in client binding mode, handle the OnInitializeRow client-side event. Thanks to Intersoft’s framework that provides identical server-side object model in the client-side, you can easily convert the C# code to Javascript such as shown in the following:

Javascript Copy Code
   function wcReportsTo_InitializeRow(id, row)
   {
        row.Cells[0].Image = "images/" + row.Cells[0].Text + ".jpg";
        row.Cells[0].CustomObjectAttributes = " width='48' height='48'";
   }

How Client Data Binding Works

WebCombo relies heavily on a solid client data framework in order to perform client binding efficiently, and to support the existing features in various configurations and scenarios. At the heart of the client data binding is the Client Data Object Framework.

Intersoft’s Client Data Object Framework can be illustrated as a lightweight, mini version of Microsoft’s ADO.NET Framework. Client Data Object Framework will be further abbreviated as CDOF in this topic. CDOF includes client-side implementation of DataSet, DataTable and DataView – which acts as the backbone of all client-side data operations in WebCombo. The ISDataSet and ISDataTable represent the main data object which is then used by WebCombo for further processing such as data shaping, formatting, paging and more.

The following illustration describes the overall client binding processing in WebCombo.

As shown in above illustration, WebCombo doesn’t process the data shaping by its own – it relies on the CDOF to obtain finalized data shape, which is then processed further by the VirtualRendering. This unique architecture enables clean separation between data abstraction layer and rendering layer – making it easy to be consumed by WebCombo and other WebUI Studio® controls that requires client binding implementation in the future.

In addition to the overall binding process as shown above, it’s also important to understand the new process model and events life cycle in WebCombo. The following information explains the client binding process life cycle in details:

Rich Client Data Operation

In addition to providing a solid client binding platform, Client Data Object Framework™ (CDOF) also enables many client-side data processing which were previously difficult or not possible to achieve.

The following lists the key features of client-side data processing.

Client-side Data Formatting

One of the most powerful features in CDOF is its comprehensive data formatting function. It supports composite data formatting such as string, date time and number formatting. It also takes account Culture information. You can think it as a client-side implementation of .NET Data Formatting Library.

Client-side Sorting

CDOF implements high-performance client-side sorting that is capable to sort multiple columns in a fraction of seconds.

The client sorting also supports different sorting direction on each column. For instances, sort on Country descending, while ContactTitle ascending. The client sorting is implemented at data access level instead of UI level – enables developers to have greater control over data shaping process. The sorting feature is implemented at ISDataView class.

Client-side Filtering

CDOF features comprehensive filtering support enabling developers to easily perform row filtering at data object level. The client-side filtering implements syntax that is fully compatible with server-side ADO.NET Framework’s filter expression – making it easy for .NET developers to consume client-side filtering features.

The client-side filtering supports the following standard operators:

  • Equals to (=)
  • Not equals to (<>)
  • Greater than or equals to (>=)
  • Greater than (>)
  • Less than or equals to (<=)
  • Less than (<)

It also supports more advanced operators such as:

  • Like
  • Contains
  • Nested Conditioning Group

The following samples show various filter expression supported in CDOF.

Filter Examples Copy Code
Basic string-type filter expression:
[ContactTitle] = ‘Owner’ and [Country] = ‘USA’

Filter expression on various types with group:
(([ContactTitle] = ‘Owner’ or [ContactTitle] like ‘sales’) and ([OrderDate] > #1/1/2008# and [OrderDate] < #1/1/2009#))

Number filter expression:
[OrderAmount] > 123.45 and [OrderAmount] < 456.78

Filtering out null or empty data:
[Region] <> null and [Region] <> ‘’

Client-side Paging

Since that CDOF implements data shaping processing entirely in client side, it enables paging to be performed in client-side as well. Client-side paging is easy to be implemented at control/UI level, as long as the final data shape is available in the client-side. WebCombo automatically performs client-side paging when the client-side data source has more data than specified in the DropDownRows property.

See Also

What's New
Features Added In WebCombo 5
Client Data Services

Walkthrough
Walkthrough Topics

How-to
FAQ and How-to Topics


How-to: Configure Client Binding Mode using Server Data Source

How-to: Configure Client Binding Mode using Server Data Source
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added In WebCombo 5 > Client Data Binding > How-to: Configure Client Binding Mode using Server Data Source

Glossary Item Box

WebCombo introduces the new client-side data binding along with its new technologies and benefits, and explains how it resolves performance bottleneck without trading-off the essential features.

This topic shows how to configure Client-binding mode using Server Data Source.

To configure Client Binding Mode using Server Data Source

  1. Select an instance of WebCombo in designer surface.
  2. Press F4 to bring up the Property Window.
  3. Set BindingOperationMode to ClientBinding.

See Also

Concepts
Client Data Binding


Client Data Services

Client Data Services
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added In WebCombo 5 > Client Data Services

Glossary Item Box

This topic discusses the concepts of client data service, the type of service it supports, and provides information on the best practices and key scenarios to develop service-based applications using WebCombo.

This topic contains the following sections:

  • Understanding Server-side Data Source
  • Understanding Services Data Source
  • Understanding Client-side Data Source
  • Best Practices and Key Scenarios

Understanding Server-side Data Source

This data source type enables you to continue using server-side data source in WebCombo. Supported server-side data source are:

  • Datasource controls, such as AccessDataSource, LinqDataSource, ObjectDataSource, etc.
  • Datasource object, which is assigned in InitializeDataSource event (also known as Traditional Binding).

This data source type is designed to help you leverage and reuse existing infrastructure which has used server-side data source, while at the same time enables you to take advantage of many client binding benefits such as improved performance and reduced data footprint.

To learn the difference between server-side binding mode and client-side binding mode with server-side datasource type, please see The Differences with Server-side Binding.

Server-side data source type is the quickest and easiest way to take advantage of client-side binding. You don’t need to create web service or data service as WebGrid seamlessly connects to server-side data source for data retrieval, which is then repackaged into lightweight format for further processing in the client-side.

Understanding Services Data Source

This section describes the service type supported in WebCombo, and explains the techniques to work with the data services using the provided LINQ data provider. The service events is also discussed in this section.

Service Types

Web Service

WebService data source type enables you to connect WebCombo to a web service in elegant fashion, which is done through properties configuration without requiring you to write Javascript code. To connect WebCombo to a web service, simply specify the service address in the provided ServiceUrl property and the web method used to retrieve data in the SelectMethod property.

WebService will automatically activate full client-side operation mode when your data service returns all data. It also supports paged data retrieval for optimized performance. By default, WebCombo is operating in paged data mode when using services data source.

WebService fully supports data transaction operations such as insert, update, and delete. It also supports more advanced operation such as batch update.

The following example shows the WebCombo markup declaration that uses WebService service type.

Copy Code
<ISWebCombo:WebCombo ID="wcCountry" runat="server" UseDefaultStyle="True" Width="150px"
    Height="20px" DataTextField="CountryName" DataValueField="Country_Id"
    BindingOperationMode="ClientBinding">
    <LayoutSettings EntryMode="AutoComplete"/>
    <ClientBindingSettings DataSourceType="WebService" ServiceUrl="WebCombo_WebService.asmx">
        <ServiceMethods SelectMethod="GetCountries" />
    </ClientBindingSettings>
</ISWebCombo:WebCombo>
Your web service should have the capability to return output in JSON format since client binding accepts data only in JSON format. If you are developing the web service in ASP.NET 3.5, this indicates that your web services have supported JSON response format.

Windows Communication Foundation (WCF) Service

WcfService data source type enables you to connect a WebCombo to a Windows Communication Foundation service in an elegant fashion, which is done through properties configuration without requiring you to write Javascript code.

To connect WebCombo to a WCF service, simply specify the service address in the provided ServiceUrl property and the web method used to retrieve data in the SelectMethod property.

Copy Code
<ISWebCombo:WebCombo ID="wcCountry" runat="server" UseDefaultStyle="True" Width="150px"
    Height="20px" DataTextField="CountryName" DataValueField="Country_Id"
    BindingOperationMode="ClientBinding">
    <LayoutSettings EntryMode="AutoComplete"/>
    <ClientBindingSettings DataSourceType="WcfService" ServiceUrl="WebCombo_WcfService.svc">
        <ServiceMethods SelectMethod="GetCountries" />
    </ClientBindingSettings>
</ISWebCombo:WebCombo>
Your WCF service should have the capability to return output in JSON format since client binding accepts data only in JSON format. If you are developing the WCF services in ASP.NET 3.5, this indicates that your WCF services have supported JSON response format.

ADO Data Service

ADO Data Service is Microsoft’s latest data service technology introduced in .NET Framework 3.5 SP1. It enables data to be consumed programmatically through standard Web protocols such as REST, XML, SOAP and JSON. To learn more about ADO Data Service, please visit ADO.NET Data Service Home.

Intersoft’s ClientBinding is the industry's first client-side framework that implements full support for this latest technology. To connect a WebCombo to a ADO.NET data service, all you need to do is specifying the service address in the provided ServiceUrl property.

ADO Data Service enables programmatic data access over the Web with very minimal effort, which includes support for sorting, filtering and paging. It also includes native support for data transactions such as insert, update, delete, as well as more advanced operation such as batch update.

ClientBinding fully takes advantage of ADO Data Service's capabilities and implement direct interface to access its functionality. As the results, you are not required to specify any of the service methods.

The following example shows a simple declarative markup to enable all data operations.

ASPX Copy Code
<ISWebCombo:WebCombo ID="wcProducts" runat="server" UseDefaultStyle="True" Width="150px"
    Height="20px" DataTextField="ProductName" DataValueField="ProductID"
    DataMember="Products" BindingOperationMode="ClientBinding">

    <ClientBindingSettings DataSourceType="AdoDataService" ServiceUrl="NorthwindDataService.svc" />

</ISWebCombo:WebCombo>

Service Handlers

In server-side binding mode, WebCombo handles the search query automatically based on the provided data source. This means that developers simply need to pass the data source and WebCombo will process all the data operations such as data lookup, filtering and adding. It is also possible to customize the data operations by using load-on-demand technique.

In contrast, the client-side binding mode would require you to handle the data retrieval process in the service handler and return the required data shape to be passed to the WebCombo. This process is by design because WebCombo is no longer processing data operations in the server-side.

For the best performance, it is recommended that the paging is processed in the data service during data retrieval. The following section explains about the possible techniques to achieve such implementation.

Using LINQ to Query Data

Intersoft’s ClientBinding™ introduces an elegant solution that enables you to easily retrieve paged data in your data service. ClientBinding encapsulates essential select arguments into an object called DataSourceSelectArguments. This object is always passed to the parameter of your Select method, enabling you to easily perform data selection based on the given information.

When a data operation, such as sorting and filtering, is required; WebCombo will send a request to the specified data service by including the complete request data in the selectArguments parameter. You are responsible to handle the sorting, filtering and paging based on the select arguments. In addition, WebCombo will also send a SelectCount request when it needs to invalidate the paging status.

DataSourceSelectArguments class contains the following properties:

  • FilterExpression. The string of filter expression based on ADO.NET syntax.
  • SortExpression. The string of sort expression based on ADO.NETsyntax.
  • MaximumRows. The number of maximum rows to be retrieved.
  • OperationType. The type of the operation for this request.
  • StartRowIndex. The start index of the row to be retrieved.
  • ViewName. The view name or table name to be selected.
  • RetrieveTotalCount. Specifies whether the results should include total count of the query.
  • Tag. Custom information passed from client-side.

Additionally, a GetLinqFilterExpression method is provided to convert ADO.NET filter expression into LINQ-compatible filter expression. This method is specifically useful for data services that use LINQ to retrieve data.

The DataSourceSelectArguments for the WCF Service counterpart is also provided, named WcfDataSourceSelectArguments. The WcfDataSourceSelectArguments is implemented in ISNet.Data.Linq assembly.

The Select method of your Web services should return a QueryResult object, which contains the following properties:

  • Results. The returned data source in IEnumerable type.
  • Tag. Custom information to pass to the client-side.
  • TotalRowCount. The total row count of the query.

The following C# sample shows how to handle data retrieval using LINQ in a Web service.

C# Copy Code
    [WebMethod]
    public QueryResult GetCustomers(DataSourceSelectArguments selectArguments)
    {
        QueryResult result = new QueryResult();
        NorthwindDataContext context = new NorthwindDataContext();
        context.DeferredLoadingEnabled = false;

        var pagedData = context.Customers.AsQueryable();

        // handle filtering
        if (!string.IsNullOrEmpty(selectArguments.FilterExpression))
            pagedData =
                pagedData.Where(selectArguments.GetLinqFilterExpression());

         // handle total count
        if (selectArguments.RetrieveTotalCount)
            result.TotalRowCount = pagedData.Count();

        if (selectArguments.OperationType == SelectOperation.SelectData)
        {
            if (selectArguments.StartRowIndex > -1)
                pagedData = pagedData.Skip(selectArguments.StartRowIndex);

            if (selectArguments.StartRowIndex == -1)
                selectArguments.StartRowIndex = 0;

            pagedData = pagedData.Take(selectArguments.MaximumRows - selectArguments.StartRowIndex);
            result.Results = dataSource.ToList();
        }

        return result;
    }

Using WebCombo LINQ Data Provider

In the above section, you have learned how to retrieve data using LINQ by manually parsing the provided select arguments. WebCombo 5 also includes WebComboDataProvider, a new LINQ data provider to help simplifying and automating the data retrieval process. You can use WebComboDataProvider in both Web and WCF services.

By using the generic WebComboDataProvider class, you can easily perform data retrieval in just a few line of code. The WebComboDataProvider automatically handle the data retrieval, filtering, total count, paging, and other operations that maybe supported in the select arguments.

The WebComboDataProvider is implemented in the ISNet.Data.Linq assembly which can be found in the WebUI Framework installation folder.

The following C# sample shows how to handle data retrieval using WebCombo LINQ data provider in a Web service.

C# Copy Code
    [WebMethod]
    public QueryResult GetSuppliers(DataSourceSelectArguments selectArguments)
    {
        NorthwindDataContext context = new NorthwindDataContext();
        context.DeferredLoadingEnabled = false;
        context.ObjectTrackingEnabled = false;

        WebComboDataProvider<Supplier> query = new WebComboDataProvider(context.Suppliers);
        return query.Select(selectArguments);
    }

The following C# sample shows how to handle data retrieval using WebCombo LINQ data provider in a WCF service.

C# Copy Code
    [OperationContract]
    [ServiceKnownType(typeof(List<Supplier>))]
    public QueryResult GetSuppliers(WcfDataSourceSelectArguments selectArguments)
    {
        NorthwindDataContext context = new NorthwindDataContext();
        context.DeferredLoadingEnabled = false;
        context.ObjectTrackingEnabled = false;

        WebComboDataProvider<Supplier> query = new WebComboDataProvider<Supplier>(context.Suppliers);
        return query.Select(selectArguments);
    }
The OperationContract and ServiceKnownType attributes are mandatory in the methods that return the QueryResult object.

Service Events

All data operations in the data service are powered with a solid, provider-based architecture that is highly extensible.

Client data services that supported by WebCombo such as WebService, WcfService and AstoriaDataSource are derived from the same data provider base. As the results, these data services share the same process life cycle, events and behaviors.

Client data services support the following events:

  • Selecting. Invoked when the data provider is about to perform data selection.
  • Selected. Invoked after the data provider has successfully selecting data.
  • Updating. Invoked when the data provider is about to perform data update.
  • Updated. Invoked after the data provider has successfully updating data.
  • Inserting. Invoked when the data provider is about to perform data insert.
  • Inserted. Invoked after the data provider has successfully inserting data.
  • Deleting. Invoked when the data provider is about to perform data delete.
  • Deleted. Invoked after the data provider has successfully deleting data.
  • BatchUpdating. Invoked when the data provider is about to perform batch update
  • BatchUpdated. Invoked after the data provider has successfully perform batch update.

Each operation includes pre and post events for more extensive customization. The pre events such as Selecting can be cancelled with a return false statement.

These service events are available in ServiceEvents object which is located in the ClientBindingSettings property of WebCombo.

Understanding Client-side Data Source

Client data source type allows you to assign a completely custom data source in the client-side. When this type is used, WebCombo will not request data source from services.

This type is specifically useful when you need to retrieve datasource from external sites or data services that are not supported in Intersoft’s ClientBinding. For examples, consider a scenario where you want to fetch data from an external site manually in the client-side, then pass the results to the WebCombo.

Pure client-side binding takes as little as three lines of code, such as shown in the following:

Javascript Copy Code
   combo.SetDataSource(dataSource);
   combo.DataBind();
   combo.Render();

WebCombo accepts ISDataSet, ISDataTable or any array-based collection as data source. For more information about client binding API, please see Client Binding API.

Best Practices and Key Scenarios

This section discusses the consideration for using client binding mode in your applications, as well as provides information about the best practices for a number of common scenarios.

Although client binding offers numerous benefits, it doesn’t always fit all scenarios. If your application is running locally in corporate network or on fast broadband network, and that your application doesn’t require a service-based data source, you may consider to stay with server binding mode.

Likewise, if your end users run on thin-client with slightly limited resources, or slower terminal – client binding might not be suitable as client binding performs all operations – such as populating data, formatting, sorting, filtering, grouping, paging and more – entirely in the client side.

Client binding is generally ideal with paged data loading mode, which balances the workload between server and client side.

The following sections describe the best practices for a number of key scenarios.

Best practice #1 – Using ServerDataSource with Paging Enabled

If you are already using WebCombo control in your applications (which means server binding is used by default), you may consider using ServerDataSource mode to reuse your existing server assets and infrastructure while migrating to the client binding mode.

ServerDataSource is the mode that requires the most minimal changes to your existing code. If you don’t have post-binding processing in your code (such as in InitializeRow or InitializeCell event), the migration to client binding is nearly seamless without any significant changes.

In this case, you simply need to set DataSourceType of the ClientBindingSettings to ServerDataSource. Run your page to ensure everything is working properly.

Best practice #2 – Using WebService with Paging Enabled

If you are considering developing application that retrieves data from a data service, you can consider using WebService or WcfService depending on your server infrastructure.

To anticipate the growth of the data size returned by your data service, you can prepare your data service to return paged data instead of all data. This ensures your application to extend and scale up properly in the future.

Best practice #3 – Using AdoDataService

If you are considering to develop data service platform that is accessible over the Web from various clients such as Silverlight, WPF or Web application – you may consider developing with ADO data service.

See Also

What's New
Features Added In WebCombo 5
Client Data Binding
Client Binding API

Walkthrough
Walkthrough Topics


Walkthrough: Configure WebCombo To Retrieve Data From Web Service

Walkthrough: Configure WebCombo To Retrieve Data From Web Service
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added In WebCombo 5 > Client Data Services > Walkthrough: Configure WebCombo To Retrieve Data From Web Service

Glossary Item Box

This walkthrough shows you how to configure client binding using WebService mode in WebCombo.

During this walkthrough, you will learn how to do the following:

  • Create WebService
  • Bind WebService into WebCombo

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Northwind.mdf.
  • Visual Studio 2008/2010 Application.

Step-By-Step Instructions

To configure client binding using WebService mode

  1. Launch Visual Studio.NET 2010.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box.
  4. Named the Web Site and click OK.
  5. In the Solution Explorer, right-click on App_Data and select Add Existing Item.
  6. Browse and add NorthWind.mdf in C:\Program Files\Intersoft Solutions\Data (Default installation folder).
  7. Add new page in App_Code and select Linq to Sql classes template. Named it Northwind.dbml.

  8. Drag Table Customer in Northwind.mdf from Server Explorer.

  9. Right-click on Project's name and select Add New Item.
  10. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  11. Create WebService.asmx in the same level with your aspx name.

  12. Go to App_Code and add method GetCustomers in WebService.cs.

    C# Copy Code
    using ISNet.ClientServices;
using ISNet.Data.Linq;

[System.Web.Script.Services.ScriptService]
public class WebService : System.Web.Services.WebService
{
   [WebMethod]
   public QueryResult GetCustomers(DataSourceSelectArguments selectArguments)
   {
      NorthwindDataContext context = new NorthwindDataContext();
      context.DeferredLoadingEnabled = false;
      context.ObjectTrackingEnabled = false;

      WebComboDataProvider<Customer> query =
         new WebComboDataProvider<Customer>(context.Customers);
      return query.Select(selectArguments);
   }
}

  13. Drag WebCombo instance from Toolbox to WebForm.
  14. Set the properties based on the table and code below.

    Property | Value
    BindingOperationMode | ClientBinding
    DataSourceType | WebService
    ServiceUrl | WebService.asmx (or any .asmx file created by user)
    SelectMethod | GetCustomers

    HTML Copy Code
    <ISWebCombo:WebCombo ID="wcSupplier" runat="server" Width="150px"
   DataTextField="ContactName" DataValueField="CustomerID" Height="20px"
   UseDefaultStyle="True" BindingOperationMode="ClientBinding">
   <ClientBindingSettings DataSourceType="WebService" ServiceUrl="WebService.asmx">
      <ServiceMethods SelectMethod="GetCustomers" />
   </ClientBindingSettings>
</ISWebCombo:WebCombo>

  15. Save all the pages. Browse WebService.asmx to ensure that the service works then run Walkthrough.aspx.

See Also

Tasks
Walkthrough: Configure WebCombo To Retrieve Data From WCF Service
Walkthrough: Configure WebCombo To Retrieve Data From ADO Data Service
How-to: Add New Item to Web Service
How-to: Handle Data Service Events

Concepts
Client Data Services


Walkthrough: Configure WebCombo To Retrieve Data From WCF Service

Walkthrough: Configure WebCombo To Retrieve Data From WCF Service
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added In WebCombo 5 > Client Data Services > Walkthrough: Configure WebCombo To Retrieve Data From WCF Service

Glossary Item Box

This walkthrough shows you how to configure Client binding using WcfService mode in WebCombo.

During this walkthrough, you will learn how to do the following:

  • Create WcfService
  • Bind WcfService into WebCombo

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Northwind.mdf.
  • Visual Studio 2008/2010 Application.

Step-By-Step Instructions

To configure client binding using WebService mode

  1. Launch Visual Studio.NET 2010.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box.
  4. Named the Web Site and click OK.
  5. In the Solution Explorer, right-click on App_Data and select Add Existing Item.
  6. Browse and add NorthWind.mdf in C:\Program Files\Intersoft Solutions\Data (Default installation folder).
  7. Add new page in App_Code and select Linq to Sql classes template. Named it Northwind.dbml.

  8. Drag Table Customer in Northwind.mdf from Server Explorer.

  9. Right-click on Project's name and select Add New Item.
  10. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  11. Create WcfService.svc in the same level with your aspx name.

  12. Go to App_Code and add method GetCustomers in WcfService.cs.

    C# Copy Code
    using System.Web.Services;
using ISNet.ClientServices;
using ISNet.Data.Linq;
using System.ServiceModel;
using System.ServiceModel.Activation;
using ISNet.Data;

[ServiceContract()]
public class WcfService
{
   [OperationContract]
   [ServiceKnownType(typeof(List))]
   public QueryResult GetCustomers(WcfDataSourceSelectArguments selectArguments)
   {
      NorthwindDataContext context = new NorthwindDataContext();
      context.DeferredLoadingEnabled = false;
      context.ObjectTrackingEnabled = false;

      WebComboDataProvider<Customer> query =
         new WebComboDataProvider<Customer>(context.Customers);
      return query.Select(selectArguments);
   }
}

  13. Drag WebCombo instance from Toolbox to WebForm.
  14. Set the properties based on the table and code below.

    Property | Value
    BindingOperationMode | ClientBinding
    DataSourceType | WcfService
    ServiceUrl | WcfService.asmx (or any .asmx file created by user)
    SelectMethod | GetCustomers

    HTML Copy Code
    <ISWebCombo:WebCombo ID="wcSupplier" runat="server" Width="150px"
   DataTextField="ContactName" DataValueField="CustomerID" Height="20px"
   UseDefaultStyle="True" BindingOperationMode="ClientBinding">
   <ClientBindingSettings DataSourceType="WcfService" ServiceUrl="WcfService.svc">
      <ServiceMethods SelectMethod="GetCustomers" />
   </ClientBindingSettings>
</ISWebCombo:WebCombo>

  15. Add the following code to web.config.

    web.config Copy Code
    <system.serviceModel>
    <behaviors>
      <endpointBehaviors>
        <behavior name="WcfServiceAspNetAjaxBehavior">
          <enableWebScript />
        </behavior>
      </endpointBehaviors>
    </behaviors>
    <!--
        Note: The following config can be enabled when the service is running in the context of the ASP.NET HTTP application pipeline.
        <serviceHostingEnvironment aspNetCompatibilityEnabled="true" multipleSiteBindingsEnabled="true" />
    -->
    <services>
      <service name="WcfService">
        <endpoint address="" behaviorConfiguration="WcfServiceAspNetAjaxBehavior"
         binding="webHttpBinding" contract="WcfService"/>
      </service>
    </services>
</system.serviceModel>

  16. Save all the pages. Browse WebService.asmx to ensure that the service works then run Walkthrough.aspx.

See Also

Tasks
Walkthrough: Configure WebCombo To Retrieve Data From Web Service
Walkthrough: Configure WebCombo To Retrieve Data From ADO Data Service
How-to: Add New Item to Web Service
How-to: Handle Data Service Events

Concepts
Client Data Services


Walkthrough: Configure WebCombo To Retrieve Data From ADO Data Service

Walkthrough: Configure WebCombo To Retrieve Data From ADO Data Service
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added In WebCombo 5 > Client Data Services > Walkthrough: Configure WebCombo To Retrieve Data From ADO Data Service

Glossary Item Box

This walkthrough shows you how to WebCombo to client-binding using AdoDataService mode.

During this walkthrough, you will learn how to do the following:

  • Create and use AdoDataService mode.
  • Configure WebCombo to client-binding using AdoDataService mode

Prerequisites

In order to complete this walkthrough, you will need the following:

  • ADO.NET Entity Data Model.
  • Visual Studio 2008/2010 Application.

Step-By-Step Instructions

To configure client binding using WebService mode

  1. Launch Visual Studio.NET 2010.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box.
  4. Named the Web Site and click OK.
  5. In the Solution Explorer, right-click on App_Data and select Add Existing Item.
  6. Browse and add NorthWind.mdf in C:\Program Files\Intersoft Solutions\Data (Default installation folder).
  7. In the Solution Explorer, right-click on App_Code and select Add New Item.
  8. Create a new ADO.NET Entity Data Model and named it NorthwindDataModel.edmx. Pick generate the model from database, choose Northwind.mdf as the data source and named the entity as NorthwindEntities.

  9. On the next screen, choose Customers to include in your database model. Click Finish.
  10. In the Solution Explorer, right-click on the WebProject and select Add New Item.
  11. Create a new WCF Data Service and named it NorthwindDataService.svc.
  12. Modify the NorthwindDataService.svc.cs to accept Customers and have full access.

    C# Copy Code
    using System;
using System.Data.Services;
using System.Collections.Generic;
using System.Linq;
using System.ServiceModel.Web;
using NorthwindDataModel;

[System.ServiceModel.ServiceBehavior(IncludeExceptionDetailInFaults = true)]
public class NorthwindDataService : DataService<NorthwindEntities>
{
   // This method is called only once to initialize service-wide policies.
   public static void InitializeService(IDataServiceConfiguration config)
   {
      // TODO: set rules to indicate which entity sets and service
      // operations are visible, updatable, etc.
      // Examples:

      config.SetEntitySetAccessRule("*", EntitySetRights.All);
      config.SetServiceOperationAccessRule("*", ServiceOperationRights.All);
      config.UseVerboseErrors = true;
   }
}

  13. In the Solution Explorer, right-click on the project and select Add New Item.
  14. Select Web Form in the Templates box and named it as Walkthrough.aspx.
  15. Drag WebCombo instance from Toolbox to WebForm.
  16. Set the properties based on the table and code below.

    Property | Value
    BindingOperationMode | ClientBinding
    DataSourceType | AdoDataService
    ServiceUrl | NorthwindDataService.svc

    HTML Copy Code
    <ISWebCombo:WebCombo ID="wcCustomers" runat="server" Height="20px" UseDefaultStyle="True"
   Width="150px" ViewStateStorage="None" DataTextField="ContactName"
   DataValueField="CustomerID" DataMember="Customers"
   BindingOperationMode="ClientBinding">
      <FlyPostBackSettings PostHiddenFields="true" PostInputControls="true" />
      <ClientBindingSettings DataSourceType="AdoDataService"
         ServiceUrl="NorthwindDataService.svc" />
</ISWebCombo:WebCombo>

  17. Run the project and the WebCombo should look like following.

See Also

Tasks
Walkthrough: Configure WebCombo To Retrieve Data From Web Service
Walkthrough: Configure WebCombo To Retrieve Data From WCF Service
How-to: Add New Item to Web Service
How-to: Handle Data Service Events

Concepts
Client Data Services


How-to: Add New Item to Web Service

How-to: Add New Item to Web Service
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added In WebCombo 5 > Client Data Services > How-to: Add New Item to Web Service

Glossary Item Box

WebService data source type enables you to connect WebCombo to a Web Service in elegant fashion, which is done through properties configuration without requiring you to write Javascript code.

This topic shows how to add new item to Web Service.

To add new item to WebService

  1. Right-click on WebCombo control and select Properties.
  2. Expand LayoutSettings and set AllowAddItem to True.
  3. Create WebService.asmx in the same level with your aspx name.
  4. Go to App_Code and add method GetEmployees and InsertEmployee in WebService.cs.

    C# Copy Code
    [System.Web.Script.Services.ScriptService]
[WebMethod]
public QueryResult GetEmployees(DataSourceSelectArguments selectArguments)
{
   NorthwindDataContext context = new NorthwindDataContext();
   context.DeferredLoadingEnabled = false;
   context.ObjectTrackingEnabled = false;

   WebComboDataProvider<Employee> query = new WebComboDataProvider<Employee>(context.Employees);
   return query.Select(selectArguments);
}

[WebMethod]public TransactionResult InsertEmployee(Employee newObject)
{
   NorthwindDataContext context = new NorthwindDataContext();
   WebComboDataProvider<Employee> query = new WebComboDataProvider<Employee>(context.Employees);
   TransactionResult result = new TransactionResult();

   // only add new item when the submitted firstname has not existed in our database
   if (context.Employees.Where(e => e.FirstName == newObject.FirstName).Count() == 0)
   {
      result = query.Insert(newObject);
      result.NewID = newObject.EmployeeID;      result.AffectedResults = 1;   }

      return result;
}

  5. Set the properties based on the table and code below.

    Property | Value
    BindingOperationMode | ClientBinding
    DataSourceType | WebService
    ServiceUrl | WebCombo_WebService.asmx (or any .asmx created by user)
    ItemTypeName | Employee
    SelectMethod | GetEmployees
    InsertMethod | InsertEmployee

    HTML Copy Code
    <ISWebCombo:WebCombo ID="WebCombo1" runat="server" DataTextField="FirstName" DataValueField="EmployeeID"
   Height="20px" UseDefaultStyle="True" Width="200px" BindingOperationMode="ClientBinding">
   <LayoutSettings AllowAddItem="True">
   </LayoutSettings>
   <ClientBindingSettings DataSourceType="WebService" ServiceUrl="WebCombo_WebService.asmx" ItemTypeName="Employee">
      <ServiceMethods SelectMethod="GetEmployees" InsertMethod="InsertEmployee" />
   </ClientBindingSettings>
</ISWebCombo:WebCombo>

  6. Run the project.

See Also

Tasks
How-to: Handle Data Service Events
Walkthrough: Configure WebCombo To Retrieve Data From Web Service
Walkthrough: Configure WebCombo To Retrieve Data From WCF Service
Walkthrough: Configure WebCombo To Retrieve Data From ADO Data Service

Concepts
Client Data Services


How-to: Handle Data Service Events

How-to: Handle Data Service Events
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added In WebCombo 5 > Client Data Services > How-to: Handle Data Service Events

Glossary Item Box

WebCombo's client binding technology provides not only advanced features and engaging UX, but also well-designed architecture to enable greater control over data service processing.

Client data services support the following events:

  • Selecting. Invoked when the data provider is about to perform data selection.
  • Selected. Invoked after the data provider has successfully selecting data.
  • Updating. Invoked when the data provider is about to perform data update.
  • Updated. Invoked after the data provider has successfully updating data.
  • Inserting. Invoked when the data provider is about to perform data insert.
  • Inserted. Invoked after the data provider has successfully inserting data.
  • Deleting. Invoked when the data provider is about to perform data delete.
  • Deleted. Invoked after the data provider has successfully deleting data.
  • BatchUpdating. Invoked when the data provider is about to perform batch update
  • BatchUpdated. Invoked after the data provider has successfully perform batch update.

This topic shows how to handle Data Service Events.

To handle Data Service Events

  1. Create a Javascript function in the client-side to be used in ServiceEvents.

    Javascript Copy Code
    var logCount = 0;

function LogEvent(text)
{
    var dvLog = document.getElementById("dvLog");

    dvLog.innerHTML += "" + text + "";
    dvLog.scrollTop = dvLog.scrollHeight;

    logCount++;
}

function Service_Selecting(control, selectArguments)
{
    LogEvent("Selecting data. Operation Type: " + selectArguments.OperationType + ", FilterExpression=" + selectArguments.FilterExpression +
                ", SortExpression=" + selectArguments.SortExpression);
}

function Service_Selected(control, result)
{
    var resultText = "";

    if (typeof (result) == "number")
        resultText = "Total record count = " + result;
    else
        resultText = result.Results.length + " records retrieved";

    LogEvent("Data selected - " + resultText);
}

    Service_Selecting function is used in Selecting event, whereas Service_Selected is used in Selected event.
  2. In ClientBindingSettings property, there are several events provided in Service Events. The following code is used to apply the Selecting and Selected events along with the function created before.

    Property | Value
    BindingOperationMode | ClientBinding
    DataSourceType | WebService
    ServiceUrl | WebCombo_WebService.asmx (or any .asmx file created by user)
    Selecting | Service_Selecting
    Selected | Service_Selected

    HTML Copy Code
    <ISWebCombo:WebCombo ID="WebCombo1" runat="server" DataTextField="ContactName" DataValueField="CustomerID"
   Height="20px" UseDefaultStyle="True" Width="200px" BindingOperationMode="ClientBinding">
   <ClientBindingSettings DataSourceType="WebService" ServiceUrl="WebCombo_WebService.asmx">
      <ServiceMethods SelectMethod="GetCustomers" />
      <ServiceEvents Selecting="Service_Selecting" Selected="Service_Selected" />
   </ClientBindingSettings>
</ISWebCombo:WebCombo>

See Also

Tasks
Walkthrough: Configure WebCombo To Retrieve Data From Web Service
Walkthrough: Configure WebCombo To Retrieve Data From WCF Service
Walkthrough: Configure WebCombo To Retrieve Data From ADO Data Service
How-to: Add New Item to Web Service

Concepts
Client Data Services


Client Binding API

Client Binding API
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added In WebCombo 5 > Client Binding API

Glossary Item Box

The client binding architecture implemented in WebCombo is consisted of a set of comprehensive new classes, methods and interfaces to enable programmatic consumption in the most elegant fashion. The user interface functions and high-level encapsulation of the binding process actually called the same underlying APIs.

This topic explains the new public methods and events which are available when client binding mode is enabled, and the data source type is set to either client services or client data source.

New Methods

Several methods have been added to the WebCombo class as extensions to provide programmatic client binding functionality. These methods will only be available when client binding feature is enabled.

New Methods | Parameters | Description
SetDataSource | dataSource, tableName | Assigns a new client-side datasource to WebCombo.
GetConvertedDataSource | - | Gets the datasource that has been converted to CDOF-compatible object.
DataBind | - | Instructs WebCombo to perform data binding based on assigned datasource.
LoadData | - | Instructs WebCombo to perform initial data loading.
Render | - | Perform rendering based on bound data.
RebindData | dataSource, skipDataDispatch | Rebind WebCombo with a new datasource.
DispatchDataTable | - | Gets the CDOF data table object.
GetView | - | Gets the CDOF data view object.
GetFilterExpression | - | Gets the filter expression required to construct the view for this table.
WebComboRow.CopyTo | targetObject, isModifiedOnly, followTargetStructure | Copies the WebComboRow properties and data to the destination object.

New Events

The following table describes the new client side events related to client binding feature.

Event Name | Parameters | Description
OnInitializeRow | controlId, row | Fired when a row is initialized.
OnInitializeCell | controlId, cell | Fired when a cell is initialized.
OnDataSourceChanged | controlId | Fired when data source has been changed.
OnDataBound | controlId | Fired when data binding process is completed.
OnPreRender | controlId | Fired before WebGrid enters rendering phase.
OnPostRender | controlId | Fired after rendering operation is completed.

See Also

What's New
Features Added In WebCombo 5
Client Data Binding
Client Data Services


How-to: Bind WebCombo to Client-side Data Source

How-to: Bind WebCombo to Client-side Data Source
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added In WebCombo 5 > Client Binding API > How-to: Bind WebCombo to Client-side Data Source

Glossary Item Box

In addition to built-in client services, you can also programmatically create your own datasource entirely in the client-side, then bind it to the WebCombo via client API. This mode is called ClientDataSource.

This topic shows how to bind WebCombo to client-side Data Source.

To bind WebCombo to Client-side Data Source

  1. Right-click on WebCombo control and select Properties.
  2. Expand ClientBindingSettings and set DataSourceType property to ClientDataSource.
  3. Create a function called CreateData(). In the function, there are several things that need to be configured.
  4. First of all, create a DataTable using the following code:

    Javascript Copy Code
    var combo = ISGetObject("wcClient");
var dataTable = new ISDataTable();
var idColumn = new ISDataColumn(dataTable);
var textColumn = new ISDataColumn(dataTable);
var checkColumn = new ISDataColumn(dataTable);
var descColumn = new ISDataColumn(dataTable);
  5. Then, set up the data columns like following:

    Javascript Copy Code
    /* setup data columns */
DataTable.Name = dataTable.TableName = "Root";
idColumn.Name = idColumn.ColumnName = "ID";
textColumn.Name = textColumn.ColumnName = "Text";
checkColumn.Name = checkColumn.ColumnName = "Bool";
descColumn.Name = descColumn.ColumnName = "Desc";
  6. Next, add the created columns to the data table:

    Javascript Copy Code
    /* add columns to data table */
dataTable.Columns.Add(idColumn);
dataTable.Columns.Add(textColumn);
dataTable.Columns.Add(checkColumn);
dataTable.Columns.Add(descColumn);
  7. The columns has been set. Now, add rows to the data table like following:

    Javascript Copy Code
    /* add rows to data table */
for (var i = 0; i < 100; i++)
{
  var dataRow = dataTable.NewRow();
  dataRow.Cells.GetNamedItem("ID").Value = i;
  dataRow.Cells.GetNamedItem("Text").Value = "Item " + i;
  dataRow.Cells.GetNamedItem("Bool").Value = (i % 3 != 0);
  DataRow.Cells.GetNamedItem("Desc").Value = "Description " + i;

  dataTable.Rows.Add(dataRow);
}
  8. Everything has been configured. Finally, bind the data table to WebCombo.

    Javascript Copy Code
    /* bind the data table to WebCombo */
combo.SetDataSource(dataTable);
combo.DataBind();
combo.Render();
combo.ShowDropDown();

event.cancelBubble = true;
event.returnValue = false;
  9. The CreateData() function has been completed. You can invoke this function using any control, such as using HTML Input Button's OnClick event.

    Javascript Copy Code
    function CreateData()
{
   var combo = ISGetObject("wcClient");
   var dataTable = new ISDataTable();
   var idColumn = new ISDataColumn(dataTable);
   var textColumn = new ISDataColumn(dataTable);
   var checkColumn = new ISDataColumn(dataTable);
   var descColumn = new ISDataColumn(dataTable);

   /* setup data columns */
   DataTable.Name = dataTable.TableName = "Root";
   idColumn.Name = idColumn.ColumnName = "ID";
   textColumn.Name = textColumn.ColumnName = "Text";
   checkColumn.Name = checkColumn.ColumnName = "Bool";
   descColumn.Name = descColumn.ColumnName = "Desc";

   /* add columns to data table */
   dataTable.Columns.Add(idColumn);
   dataTable.Columns.Add(textColumn);
   dataTable.Columns.Add(checkColumn);
   dataTable.Columns.Add(descColumn);

   /* add rows to data table */
   for (var i = 0; i < 100; i++)
   {
      var dataRow = dataTable.NewRow();
      dataRow.Cells.GetNamedItem("ID").Value = i;
      dataRow.Cells.GetNamedItem("Text").Value = "Item " + i;
      dataRow.Cells.GetNamedItem("Bool").Value = (i % 3 != 0);
      DataRow.Cells.GetNamedItem("Desc").Value = "Description " + i;

      dataTable.Rows.Add(dataRow);
   }

   /* bind the data table to WebCombo */
    combo.SetDataSource(dataTable);
    combo.DataBind();
    combo.Render();
    combo.ShowDropDown();

    event.cancelBubble = true;
    event.returnValue = false;
}

See Also

Concepts
Client Binding API


Default Style Merging

Default Style Merging
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added In WebCombo 5 > Default Style Merging

Glossary Item Box

WebCombo 5 introduces default style merging, a new feature that automatically merges your customized styles with default style.

Default style, a feature introduced in the previous version was designed to let you easily change WebCombo’s theme in a single property set. However, you can no longer customize WebCombo styles when you activate this feature without additional workarounds. Default style merging is designed to address this limitation, makes it easy for you to customize WebCombo styles while preserving the original default styles.

To enable the default style merging feature, simply set the AllowDefaultStyleMerging property to true. This new property can be found in the LayoutSettings object.

For example, the following illustration shows a WebCombo with default style enabled.

Consider that you would like to customize the selected row's font color, you would have to declare the following style definition in the LayoutSettings such as shown below.

ASPX Copy Code
<ISWebCombo:WebCombo runat="server" UseDefaultStyle="True" Width="150px" Height="20px">
     <LayoutSettings AllowDefaultStyleMerging="true" ResultBoxWindowType="Normal">
         <SelectedRowStyle ForeColor="DarkRed" />
     </LayoutSettings>
</ISWebCombo:WebCombo>

The following illustrations compare the two results.

Without Default Style Merging

Notice that the selected row’s default style is lost after you defined a custom selected row style.

With Default Style Merging

Notice that the selected row’s default style is perfectly merged with your custom selected style.

See Also

What's New
Features Added In WebCombo 5

Walkthrough
Walkthrough Topics

How-to
FAQ and How-to Topics


Features Added in WebCombo 4

Features Added in WebCombo 4
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added in WebCombo 4

Glossary Item Box

Intersoft WebCombo is a high-performance combo box component with industry's best features for ASP.NET web development. Top features include cutting-edge LINQ-to-SQL databinding support, intuitive wizard designer,multiple instances linking, type-ahead completion, advanced load-on demand, innovative Outlook-style multiple selection and much more.

This topic provides information and links to the features added in the WebCombo version 4.

In This Section

New User Interface Features

Provides information about new user interface with latest Windows look and feel. It also improves its ability to render round corner in the edges.

XHTML 1.1 Transitional Support

Describes XHTML 1.1 Transitional supported by WebCombo. All user interface features and data functions are also supported and fully tested.

Easy SmartWebResources Deployment

Contains information about SmartWebResources which simplify the deployment process. No more copying javascript, component images and runtime files. You can simply copy the assemblies to the bin folder.

Data Binding Wakthroughs

Provides information about the new and codeless data binding experience, which means that you are no longer required to write any code to configure data source, connection and related properties.

Advanced Load-on-Demand Data Retrieval using ISDataSourceControl

Contains information about ISDataSource control which is Intersoft's flagship DataSource control. Learn how advanced load-on-demand data retrieval can be applied to WebCombo using the ISDataSource control.

Quick Configuration using SmartTag Designer

Introduces SmartTag Designer that extends Visual Studio's designer architecture, which is useful to help users in getting started of WebCombo instance.

Guided Design-time Data Source Configuration

Describes the new component designer that used Vista-style window controls. This designer is used to help developer understanding and applying most features available in WebCombo.

Improved Data Caching

Provides information about data caching feature to avoid memory leak and store the cache to physical disk.

Support for Latest Opera and Safari Browsers

Describes the support for latest Opera and Safari browsers in WebCombo.

Integration with WebTreeView

Provides integration with WebTreeView.

Integration with WebContextMenu

Provides integration with WebContextMenu.

See Also

Other Resources
Features and Concepts
Learning More


New User Interface Features

New User Interface Features
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added in WebCombo 4 > New User Interface Features

Glossary Item Box

This topic discusses the new user interface features added in version 4 such as listed below:

  • New Default Styles
  • Fluid Round Corner
  • Animated Background Image
  • Enhanced User Interactions
  • Stunning Sliding Animation

New Default Styles

WebCombo now comes with an improved user interface that sports neutral colors with minimalist look and feel. The fresh look and feel was modeled after the new Windows operating system. As the results, WebCombo control now provides more familiar and consistent user interface throughout your web applications.

The following shows the WebCombo's look and feel in different state.

WebCombo in normal state:

WebCombo in hover state:

WebCombo in active state:

Single column WebCombo, with status bar in the bottom by default:

WebCombo with multiple columns:

In version 4, the column header now has flat separator with soft blue gradient background. This look and feel is the default style in WebCombo version 4. WebCombo is also using "Segoe UI" as the standard font in all UI elements. As a clear type font, it ensures better readability and smooth display.

By default, WebCombo will use Tahoma font when "Segoe UI" cannot be found in user's computer.

Fluid Round Corner

One of the most significant user interface improvements in version 4 is the ability to render round corner around the edges of the control. The round corner rendering is fluid and flexible, which means that it can be drawn properly regardless of the user specified size.

The round corner rendering in WebCombo adopts Intersoft's proprietary TrueShape rendering framework which is widely used in WebDesktop components.

The round corner interface enables you to display smooth and stylish user interface in your web application as well as delivering unique user experience. The round corner interface is also adopted widely in the upcoming Windows Vista operating system and its desktop application. Therefore, with the round corner support in WebCombo, it ensure latest user interface design that definitely pleasing to your end users.

The following illustration shows various round corner user interface which works properly in a number of combinations.

Round corner rendering using default style:

Round corner with combination of background image during hover state:

Round corner interface with dropdown in the left side:

Round corner interface with borderless frame:

Round corner interface without dropdown:

For more information, see How-to: Enable Round Corner in WebCombo.NET 4.0.

Animated Background Image

WebCombo supports background image animation to help you replicate rich UI controls similar to Windows UI controls. In this version, the background image animation is supported in dropdown element only.

However, note that the image animation requires certain design in order to create smooth effect. Not all designs will look good when the animation is enabled. For instance, the default style that comes in version 4.0 is specially designed to display smoothly while animation is enabled.

When a new instance of WebCombo is created in designer (design time), the EnableAnimation property is enabled by default. However, to preserve compatibility with existing applications, this new feature will not be automatically enabled in the existing instances of WebCombo.

For more information, see How-to: Enable animation.

Enhanced User Interactions

In addition to new user interface and new productivity features introduced in version 4.0, this new version also improves in the user interaction area. The user interaction includes the main behavior of the WebCombo control, such as how it handles focus and lost focus, the typing and asynchronous loading experience, the dropdown button click behaviors when single clicked and double clicked and many more.

The improvement in user interaction ensures your end users to have best experience while interacting with the WebCombo control as main input and data selection control.

Stunning Sliding Animation

One of the Intersoft's key goals in the latest release is to deliver smooth and animation feature in its WebUI Studio lineups. You can now quickly add quadratic sliding animation to WebCombo control with a property set. When the feature is applied, the sliding animation will apply when you clicked on the dropdown arrow. The animation will be also applied every time the dropdown content is displayed, such as when you type into the textbox.

To learn more about sliding animation, see How-to: Enable Sliding Animation in WebCombo.

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

References
EnableAnimation Property


How-to: Enable Round Corner in WebCombo.NET 4.0

How-to: Enable Round Corner in WebCombo.NET 4.0
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added in WebCombo 4 > New User Interface Features > How-to: Enable Round Corner in WebCombo.NET 4.0

Glossary Item Box

By default, WebCombo does not enable round corner in its initial state. To enable round corner in WebCombo, please follow the instructions below:

  1. Select an instance of WebCombo in designer surface.
  2. Press F4 to bring up the Property Window.
  3. Expand LayoutSettings.
  4. Set RoundCorner to True.

See Also

Tasks
How-to: Enable animation

References
RoundCorner Property


How-to: Enable animation

How-to: Enable animation
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added in WebCombo 4 > New User Interface Features > How-to: Enable animation

Glossary Item Box

To enable dropdown background animation in WebCombo:

  1. Select an instance of WebCombo in the designer surface
  2. Press F4 to bring up the Property Window.
  3. Expand LayoutSettings.
  4. Set EnableAnimation to True.

See Also

Tasks
How-to: Enable Round Corner in WebCombo.NET 4.0

References
EnableAnimation Property


Optimized Page Output

Optimized Page Output
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added in WebCombo 4 > Optimized Page Output

Glossary Item Box

WebCombo introduces a default style concept to deliver optimal performance right out-of-the-box.

The default style feature offers the following benefits:

  • Clean control definition during development. This significantly improves loading time in the Visual Studio 2005 designer because unnecessary style objects do not need to be created.

    For instance, WebCombo version 4.0 only requires the following simple tag.
    <ISWebCombo:WebCombo ID="WebCombo1" runat="server" UseDefaultStyle="true">
    </ISWebCombo:WebCombo>

    In previous version, WebCombo will automatically generate a lot of codes containing the styles definition in order for the WebCombo to render properly.
  • Best performance in server throughput. If your end users are satisfied with the default style of WebCombo version 4.0, we highly recommend you to use the default style whenever possible. By enabling default style, the server side processing is significantly reduced because there is no need to serializing styles, validating and parsing the styles and finally generate the styles into css-based classes in the page output.
  • Reduced page output size up to 70 percent. Based on a research, more than 60 percent of web developers do not modify the styles of Intersoft's control in their web application.

    In the previous version of WebCombo, all styles are automatically generated to the page output regardless of whether the style is the one that comes with the control or custom style that is applied by the developer. Consider that you have 10 instances of WebCombo that use default style, the control will generate each style of each instance to the page output. This is normal behavior in the previous version since there is no mechanism that tell the controls whether the defined style is a default or a custom style.
    In version 4, with the Default Style feature, WebCombo control no longer produces page-level styles for instances that enable Default Style. This mechanism enables page output reduction up to 70 percent, since styles are no longer produced regardless of the number of instances in a page.

    The following illustration compares the page output between WebCombo 4.0 and its predecessors.
    WebCombo 1.x - 3.x WebCombo 4.0

    <style>
    .WebCombo1-Row { ... }
    .WebCombo1-Header { ... }
    .WebCombo1-Frame { ... }
    ...
    .WebCombo10-Row { ... }
    .WebCombo10-Header { ... }
    .WebCombo10-Frame { .... }
    </style>

    Total bytes occupied
    only for style: ± 20KB

            <style>
    /* empty */
    </style>

    <link rel="stylesheet"
    href="/WC4Test/WebResource.axd?d=x
    &t=632936740395297500"
    type="text/css" />

    Total bytes occupied for style: 0 KB

    External style sheet size
    for default style: 2KB (reusable and
    cacheable for other pages)

    Several important things to note around Default Style feature:
  • When Default Style is enabled, WebCombo will include a link to external stylesheet that contains reusable style definition used by the Default Style. This external resource is fetched by using standard WebResource feature, and is automatically handled by WebCombo. There is no efforts required by developers.
  • When Default Style is enabled, all styles definition in the control instance should be removed. You cannot have styles definition and using default style at the same time.
  • Default Style feature is enabled by default for new instance of WebCombo 4.0. Existing instances of WebCombo (i.e. after migrated from previous version) will continue to use their existing styles definition.

To learn more about Default style, see How-to: Enable Default Style for existing instance of WebCombo.

FAQ

FAQ: What does Default Style look like?

Please refer to New User Interface topic to see the look and feel of the Default Style.

FAQ: How can I continue to use "classic WebCombo style" for new instances of WebCombo controls?

You can continue to use classic style of WebCombo by applying the classic style from predefined style. When you do so, the Default Style feature will be automatically turned off. The styles definition will be embedded back to the control since WebCombo treats any predefined styles as custom style.

To apply classic style, please follow the steps below:

  1. Open the SmartTag Designer Panel.
  2. Click on Apply Predefined Style's dropdown under Styles category.

  3. Choose "Default Classic".

FAQ: Can I still apply other predefined style in WebCombo.NET 4.0?

In case that the Default Style does not look suitable to your web application, you can always choose to apply one of the predefined styles that come with WebCombo.NET.

To apply a predefined style, please follow the steps below:

  1. Open the SmartTag Designer Panel.
  2. Click on the Apply Predefined Style's dropdown under Styles category.

  3. Choose the desired predefined style to be applied.

FAQ: What is the difference between Default Style and Predefined Style?

Default Style is a new feature in WebCombo.NET version 4.0. It is different with Predefined Style.

Default Style feature marks the instance to use the default style that comes with WebCombo.NET 4.0. You are not recommended to customize any of the styles when using Default Style feature.

Predefined Styles is a list of styles that included in WebCombo.NET designated to help developer to easily achieve stylish look and feel. Predefined style is a physical file with ISL extension, and applied from Layout Manager. You can also apply predefined style from API at runtime.

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

References
UseDefaultStyle Property


How-to: Enable Default Style for existing instance of WebCombo

How-to: Enable Default Style for existing instance of WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added in WebCombo 4 > Optimized Page Output > How-to: Enable Default Style for existing instance of WebCombo

Glossary Item Box

You can enable default style in one of the three way described in the following:

  1. SmartTag Designer
    The easiest way to enable Default Style for an existing instance of WebCombo is through SmartTag Designer. SmartTag Designer is a new feature in WebCombo version 4.0.

    To enable default style from SmartTag Designer:
    • Select an instance of WebCombo
    • If the SmartTag Designer Panel does not appear, please click the [image] symbol that appears to the right top relatively to the WebCombo.
    • With the SmartTag Designer Panel shown, click on the "Reset to Default Style" link under Styles category.

    Using SmartTag Designer is the recommended way to enable Default Style feature. The Reset to Default Style command will automatically clean up all styles tag in the control definition.
  2. Property Set
    You can also manually enable the Default Style feature by setting the UseDefaultStyle property to True in the Visual Studio's property window.

    However note that this manual approach does not automatically clean up existing style definition.
  3. WebCombo Component Designer
    Component Designer is a new feature in WebCombo version 4.0. To learn more about WebCombo Component Designer, go to Guided Design-time Data Source Configuration.

    To enable Default Style in Component Designer:
      • Launch Component Designer.
      • Click on the "Styles" link in the left navigation.
      • Check the "Use WebCombo 4.0 Default Style" checkbox.

      • Click OK.

See Also

Tasks
FAQ: What does Default Style look like?
FAQ: How can I continue to use "classic WebCombo style" for new instances of WebCombo controls?
FAQ: Can I still apply other predefined style in WebCombo 4.0?
FAQ: What is the difference between Default Style and Predefined Style?

Concepts
Cleaner and reduced page output through built-in Default Style

References
UseDefaultStyle Property


XHTML 1.1 Transitional Support

XHTML 1.1 Transitional Support
Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added in WebCombo 4 > XHTML 1.1 Transitional Support

Glossary Item Box

WebCombo now fully supports XHTML 1.1 Transitional. This is made possible with the revamped core rendering and UI design. To learn more about breaking changes due to the XHTML 1.1 support, read Breaking Changes in User Interface.

Along with XHTML 1.1 compliant output and Transitional support, all user interface features and data functions are supported and have been fully tested.

To use WebCombo in XHTML 1.1 Transitional web page, please ensure that the DOCTYPE and the namespace have been registered properly. See the following code example.

<!DOCTYPE html PUBLIC "-/W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/xhtml">

</html>

The XHTML 1.1 Transitional support allows developers to use WebCombo in their web applications that target W3C standards compliance.


Easy SmartWebResources Deployment

Easy SmartWebResources Deployment
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added in WebCombo 4 > Easy SmartWebResources Deployment

Glossary Item Box

Often times, developers found it too complicated to deploy their web applications that used third party components. There are too much things to prepare to deploy the applications successfully. For instances, the Javascript files, images and other runtime client files need to be copied to proper folders in order for the components to run properly.

One of the goals in the latest Intersoft's product lineups is to simplify the deployment process of Intersoft's ASP.NET controls. Our approach is by providing a new infrastructure that handles the storage and retrieval system of these client resources, thus the physical files can be completely eliminated. This new infrastructure is called SmartWebResources™.

WebCombo version 4.0 fully supports SmartWebResources infrastructure. This enables WebCombo to function right out-of-the-box after a simple XCOPY deployment.

Both developers and site administrators can now deploy Intersoft's components by simply copying the assemblies in the Bin folder of the project to the web server - without requiring to copy the Javascript files, component-specific images and other runtime files.

To learn how to configure SmartWebResources, see How-to: Configure SmartWebResources in a new web application.

New SmartWebResources™ Framework

At Intersoft Solutions, we constantly conduct extensive research and development to deliver new innovations that help developers become more productive by reducing the efforts and complexity in both development and deployment stage.

The brand-new SmartWebResources™ Framework is one of the powerful technology available in the latest WebUI Framework. The key objective of SmartWebResources™ is to eliminate external physical resources such as scripts, images, and so forth - which are required by the web components to function properly.

Common Problems in Traditional Web Components

Most web components require client resources such as scripts, images, style sheets and other client files to enable some advanced and powerful features. Normally these client resources are delivered through physical client files. In ASP.NET, these files may be located in aspnet_client folder or other common folder which needs to be mapped properly into an IIS virtual path in order to function properly.

There are several issues with this traditional approach which causing inefficiency, such as:

  • Special IIS virtual directory is required to store the client resources. In several web hosting that does not support manual virtual directory setup, this can be a significant deployment problem.
  • Special attention and more efforts are required during deployment.
  • Versioning problems. This could cause overwhelming complexity while maintaining the versions of the client resources for specific components.
  • Complexity in maintaining control-specific's resources folder. For instance, some scripts are located in folder X, images in folder Y, and other scripts in folder Z.

The Solution: SmartWebResources

The solution to the several issues mentioned above can be achieved by eliminating the requirements to use physical client resources. Thanks to the new SmartWebResources™ Framework, the physical client resources can be completely eliminated.

The client resources are still required in our web components. It is just they are now stored in "virtual location" which does not require the awareness of developers. They are fetched and delivered to client (browsers) in a new, different way.

How Does SmartWebResources Work

Each product has their own resources such as scripts and images. For instance, previously these resources are stored in /CommonLibrary/Shared for core framework resources. WebGrid's resources are stored in /CommonLibrary/WebGrid/v4_0_6200.

With SmartWebResources, they are now embedded into .NET assembly. Unlike ASP.NET's built-in Web Resources which embeds client resources in main assembly, SmartWebResources stores each product's client resources in separate assembly. This enables flexible update (maintenance) to the client resources without has to rebuild the main server-side assembly.
SmartWebResources implements each product's client resources as separate resources assembly. Each product that supports SmartWebResources technology will have a companion resources assembly. The resources assembly commonly has this format: [ProductAssemblyFullName].Resources.dll.
For instance, the assembly hierarchy for WebCombo looks like the following illustration:

The SmartWebResources works by intercepting the HTTP requests through a custom HTTP handler which is extended in the Framework runtime. The SmartWebResources will then dispatch the requests and automatically determines the correct resources assembly, then finally fetching the resource from the assembly and deliver it to the client.
The way it works can be seen in the following illustration:

With SmartWebResources enabled, you no longer need to aware what you should do to configure the client scripts virtual directory, or where to locate/store it. You simply ensure that the resources assemblies are in the Bin folder of your application. For more information, read How-to: Configure SmartWebResources in a new web application.

Features And Benefits

The following list describes the features and benefits of SmartWebResources deployment architecture.

  • Better throughput: IIS6 Kernel-level Caching.
  • More secure: Does not use query string.
  • Faster performance: Does not use Reflection. The SmartWebResources does not use WebResourceAttribute mechanism, thus avoids the needs to use Reflection.
  • Smaller output: Simpler path formatting and does not use long-encrypted string. For instance, the built-in ASP.NET 2.0's Web Resource commonly produced a web resource Url such as /WebResource.axd?d=X3DBWN0WSNooBvJskjFXaHbLs_89EdATLyWdaCXXWBuO_EqnAFr_Di1ag4ubAsDdMu4h_k0tff_bX4YhT_csWQ2&t=632939437740000000. In SmartWebResources, the output Url format is as simple as /ISRes.axd?C/WebCombo.js/4072001.
  • Hassle-free Deployment: No more external client resources are required during deployment. Only one assembly is required to be copied into your app's bin folder.
  • Reduced Complexity: SmartWebResources includes automatic web resources configuration. When in auto mode, the client resources will be retrieved from Web Resources assembly whenever possible. Otherwise, it will automatically fallback the retrieval from traditional external resources which stored in IIS virtual directory (also known as CommonLibrary)
  • Easy to Configure: Easily configure the settings from application level. You can also customize the settings for individual control's instances for more precise control.
  • Flexibility: You can easily switch between SmartWebResources or external resources mode through EnableWebResources setting.
  • Seamless integration with VS 2005: The handlers and resources configuration can seamlessly added to your web application configuration.
  • FileSystem Project Support: For better design-time experience in FileSystem web project, the image resources are now properly displayed in the Visual Studio 2005 designer. Thanks to SmartWebResources Framework that provides automatic Url conversion mechanism in design-time.

FAQ

FAQ: Does SmartWebResources feature automatically enabled in WebCombo 4.0?

By default, Intersoft 2007 product lineups have the SmartWebResources set to Automatic mode. This automatic mode ensures compatibility with existing web application when developers migrated to 2007 platform, while at the same time attempting to utilize SmartWebResources in new web application whenever possible.

When you created a new web application and started to use WebCombo version 4.0, the SmartWebResources is not configured initially. With the automatic mode as default behavior, WebCombo will use physical resources since the SmartWebResources has not been configured.

See Also

Other Resources
Deployment Guide

What's New
Features Added in WebCombo 4


How-to: Configure SmartWebResources in a new web application

How-to: Configure SmartWebResources in a new web application
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added in WebCombo 4 > Easy SmartWebResources Deployment > How-to: Configure SmartWebResources in a new web application

Glossary Item Box

As the best practice in using Intersoft 2007's product lines, you are recommended to perform the following steps after you have created a new web application or migrated an existing web application.

  1. Right click on one of the Intersoft's control instance. For instance, WebCombo1.
  2. Click Register SmartWebResources™ command in the context menu.

  3. In short time after you clicked the command, you should receive a message prompt similar to the following:
    "SmartWebResources has been successfully configured for this web application."

If you are receiving an error message, it is likely that you have not installed the product properly. Please note that you can't enable this feature in older products (non 2007-platform products).

To learn more about SmartWebResources, please read Introducing SmartWebResources™.

See Also

Tasks
FAQ: Does SmartWebResources feature automatically enabled in WebCombo.NET 4.0?

Concepts
Hassle-free deployment through SmartWebResources™ technology

References
ScriptDirectory Property
WebCombo Class


Advanced Load-on-Demand Data Retrieval using ISDataSourceControl

Advanced Load-on-Demand Data Retrieval using ISDataSourceControl
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added in WebCombo 4 > Advanced Load-on-Demand Data Retrieval using ISDataSourceControl

Glossary Item Box

ISDataSource control is Intersoft's flagship data source control that extends ObjectDataSource functionality with hierarchical business object binding and automatic load on demand integration.

ISDataSource control includes many powerful features that you cannot find in standard DataSource controls that come with ASP.NET 2.0. These powerful features include advanced caching mechanism, cache to disk option, conflict detection, connect to dataset, and much more.

To learn more about the features and benefits of ISDataSource control, please refer to ISDataSource documentation.

In the previous versions of WebCombo, data retrieval is handled at component level. The load-on-demand mechanism is also handled at the component level, for instances, at the WebCombo level. This is required because both user interface and data handling contain mixed implementation.

With the new DataSource control support in version 4, WebCombo can now connect to ISDataSource control as well since ISDataSource implements the DataSource control standards and interfaces.

The load-on-demand data retrieval in WebCombo version 4 can also be used when bound to a DataSource control. However, the currently supported DataSource control for this operation is lilmited to ISDataSource control only at the time being.

Required Method Signature for Load-on-demand

When bound to a ISDataSource control and the AllowAutoQueryHandler property of WebCombo is set to false, the WebCombo will connect to a special method available in the specified Select method property of ISDataSource control.

For instances, if the Select method property is set to GetData, you are required to create a new method with the name GetData containing 3 parameters. You will also need to create one get count method that contains one parameter. The detailed signature is as following:

public DataTable GetData(int maximumRows, int startRowIndex, string queryText)

public int SelectCount(string queryText)

The supplied methods allow the DataSource control to reuse them in other pages, thus providing higher level of reusability. This concept also enables other user interface components to interact with DataSource in consistent fashion through the DataSource control.

To learn more about how to use load-on-demand feature using ISDataSourceControl, please see Walkthrough: Using load-on-demand data retrieval with ISDataSource control in WebCombo.

To learn more about binding WebCombo to ISDataSource, see Walkthrough: Binding WebCombo to ISDataSource control.

To learn more about binding multiple WebCombo instances to ISDataSource control, see Walkthrough: Binding multiple WebCombo instances to ISDataSource control.

To learn more about Load-on-demand data retrieval with ISDataSource, see Walkthrough: Using load-on-demand data retrieval with ISDataSource control in WebCombo.

See Also

Tasks
Retrieving data using Load-on-Demand feature in ISDataSource control
Walkthrough Topics
FAQ and How-to Topics

References
DataSource Property
AllowAutoQueryHandler Property


Walkthrough: Binding multiple WebCombo instances to ISDataSource control

Walkthrough: Binding multiple WebCombo instances to ISDataSource control
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added in WebCombo 4 > Advanced Load-on-Demand Data Retrieval using ISDataSourceControl > Walkthrough: Binding multiple WebCombo instances to ISDataSource control

Glossary Item Box

This walkthrough shows you how to create and bind multiple WebCombo to ISDataSource control.

During this walkthrough, you will learn how to do the following:

  • Use ISDataSource.
  • Use Multiple WebCombo with a same ISDataSource
  • Use SmartTag to set DataSource.
  • Use Data Source Configuration Wizard to set the Database and table.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

To create new web application and bind WebCombo to ISDataSource

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag three WebCombo instances from ToolBar to WebForm.
  8. Drag an ISDataSource control from ToolBar to WebForm.
  9. Click the SmartTag on the upper right of the ISDataSource and choose Configure Data Source.

  10. Select the Schema Type that you want to use and click Next.

  11. Add the table required and click Finish.

  12. Click the SmartTag on the upper right of the WebCombo.
  13. In the SmartTag of each WebCombo, set Choose Data Source field to ISDataSource1.
  14. Set the DataTextField and DataValueField for every WebCombo in the Page as well.
  15. Run the project.

See Also

Tasks
Walkthrough: Binding WebCombo to ISDataSource control
Walkthrough: Using load-on-demand data retrieval with ISDataSource control in WebCombo

Concepts
Advanced Load-on-Demand data retrieval through ISDataSourceControl support

References
DataSource Property
DataTextField Property
DataValueField Property


Walkthrough: Using load-on-demand data retrieval with ISDataSource control in WebCombo

Walkthrough: Using load-on-demand data retrieval with ISDataSource control in WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added in WebCombo 4 > Advanced Load-on-Demand Data Retrieval using ISDataSourceControl > Walkthrough: Using load-on-demand data retrieval with ISDataSource control in WebCombo

Glossary Item Box

This walkthrough shows you how to use load-on-demand data retrieval with ISDataSource control.

During this walkthrough, you will learn how to do the following:

  • Use ISDataSource.
  • Use SmartTag to set DataSource.
  • Use DataSourceConfigurationWizard to set the Database and table.
  • Set load-on-demand data retrieval.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

To create new web application, bind WebCombo to ISDataSource and set load on demand

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebCombo instance from ToolBar to WebForm.
  8. Click the SmartTag on the upper right of the WebCombo.
  9. In Choose Data Source field, choose <New data source...>.

  10. In Data Source Configuration Wizard, choose ISDataSource and click OK.

  11. Select the Schema Type that you want to use and click Next.

  12. Add the table required and click Finish.

  13. Click the WebCombo instance and press F4.
  14. Set the AllowAutoQueryHandler to False.
  15. Then, right-click ISDataSource instance and choose ISDataSource Designer.
  16. Set SelectMethod to GetData.
  17. Set TypeName to dsNorthwind_ReadOnlyTableAdapters.CustomersTableAdapter.
  18. Set EnablePaging to Yes.
  19. Set the SelectCountMethod to SelectCount.
  20. Set the MaximumRowsParameterName to maximumRows.
  21. Set StartRowIndexParameterName to startRowIndex.
  22. Run the project and the combo will look like following.

See Also

Tasks
Walkthrough: Binding WebCombo to ISDataSource control
Walkthrough: Binding multiple WebCombo instances to ISDataSource control

Concepts
Advanced Load-on-Demand data retrieval through ISDataSourceControl support

References
AllowAutoQueryHandler Property
DataSource Property


Quick Configuration using SmartTag Designer

Quick Configuration using SmartTag Designer
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added in WebCombo 4 > Quick Configuration using SmartTag Designer

Glossary Item Box

WebCombo provides SmartTag Designer that extends Visual Studio's designer architecture. The SmartTag Designer is useful to help developers easily getting started with the new WebCombo control.

The SmartTag Designer consists of 4 main groups as shown in the following:

  1. Data Source group
    With DataSource control support in version 4, WebCombo also integrates the DataSource control support in design-time. This enables developer to easily connect to DataSource control inside the design-time environment without has to switch to HTML view.

    The Data Source designer in SmartTag Panel allows you to bind the WebCombo to a DataSource in very minimal efforts and without any coding. To learn how to getting started with WebCombo in version 4.0, read Walkthrough: Getting started with WebCombo version 4.0 using SmartTag Designer.
  2. Styles group
    This group contains quick access to the predefined styles available in the WebCombo. When a new instance of WebCombo is created in designer surface, it will automatically use Default Style.

    With "Apply Predefined Style" feature, you can now easily apply a predefined style by clicking on the dropdown and choose a predefined style to apply. This time-saving feature avoids unnecessary designer dialogbox and complicated steps.
  3. Behaviors group
    This group contains quick access to most common used features such as allow auto postback, textbox mode and so on. This allows you to configure the new WebCombo instance in a snap, without even has to bring up Property Window.
  4. Commands group
    Although the SmartTag Designer provides a quick way for you to getting started, it is designed only for most common scenarios.

    If you wanted to configure more advanced settings or enable advanced features, it is recommended for you to use the all-new WebCombo Designer. The Designer has been improved to have more intuitive and user-friendly interface enabling you to quickly discover and understand the advanced features.

    To launch WebCombo Designer, click on the WebCombo Designer command. To learn more about WebCombo Designer, read Guided design-time configuration.

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics


Guided Design-time Data Source Configuration

Guided Design-time Data Source Configuration
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added in WebCombo 4 > Guided Design-time Data Source Configuration

Glossary Item Box

One of the most significant productivity features in the latest version of WebCombo is the component designer. Together with the rest of WebUI Studio lineups, the ASP.NET controls now come with an intuitive and user-friendly designer.

The new Component Designer sports a new look and feel, and new designer concept that enables developers to quickly discover and leverage most of the features available in WebCombo.

The new Component Designer for WebCombo provides three major groups: Quick Start, Advanced Settings and Layout Manager. See the following image:

The new designer concept employs guided configuration experience in assisted mode. For instance, most property elements now have Tooltip that describes the function. The features of the component are also converted to use question-based model and included more verbose text.

In overall, this new concept of designer is designated to reduce the learning curve needed to getting started with WebCombo. This also improves developer's productivity by avoiding the needs to open documentation in order to just configure a simple scenario.

The classic designer that shows all properties in a property grid is still supported in this new designer. In version 4, the property grid is now contained in Advanced Settings area. If you are advanced users and preferred to browse all properties, you can always click Advanced Settings link in the left navigation. The following illustration shows the advanced settings interface.

You can also configure more advanced configurations related to Cache and Performance Tuning. The new designer makes it easy for both new and advanced developers to configure most aspects and features in WebCombo control.

The Layout Manager is also revamped to use the streamlined and intuitive user interface. The user interface is also simplified and reorganized to bring convenience while using the Layout Manager, as well as avoiding confusion in the style concept introduced in previous version of Layout Manager. See the following image for Layout Manager.

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics


Improved Data Caching

Improved Data Caching
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added in WebCombo 4 > Improved Data Caching

Glossary Item Box

The data caching feature in WebCombo version 4 has been significantly improved to avoid memory leaks and lower usage of allocated resources particularly when the DataCacheStorage is set to PageCache (default).

Note that the built-in data caching is disabled by default when the WebCombo is bound to DataSource control. The data caching is provided for the usage when the WebCombo is bound to DataSource object (i.e. through InitializeDataSource event). When bound to DataSource control, the data caching is handled at DataSource control level (through EnableCaching property) and thus no longer need to be handled by WebCombo.

Another new feature related to the built-in data caching is the ability to store data cache to physical disk. WebCombo now exposed a new option in the DataCacheStorage called FileServer. When you choose this option, the data cache will be stored to the path defined in the CacheServerConnection property. This new option provides better scalability and reliability to your web application since the data caches are no longer stored in the ASP.NET's worker process or Session.

See Also

References
DataCacheStorage Property
CacheServerConnection Property


Support for Latest Opera and Safari Browsers

Support for Latest Opera and Safari Browsers
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added in WebCombo 4 > Support for Latest Opera and Safari Browsers

Glossary Item Box

WebCombo now offers excellent support for Opera 9.5 and Safari 3.0 browsers. The rich and advanced functions such as Outlook-style multiple selection, AJAX auto-complete, multiple columns, Vista-style image animation, fluid round corner are working flawlessly in these browsers.

The following screenshot demonstrates the WebCombo in Opera 9.5 browser.

The following screenshot demonstrates the WebCombo in Safari for Windows.

See Also

Other Resources
Integration with WebTreeView
Integration with WebContextMenu


Integration with WebTreeView

Integration with WebTreeView
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added in WebCombo 4 > Integration with WebTreeView

Glossary Item Box

The tight integration between both Intersoft's flagship products (WebCombo and WebTreeView) means that you can now offer richer and more intuitive way for your end users to select an input from hierarchical/grouped data.

The following illustration shows the WebTreeView control used as the dropdown container in a WebCombo instance.

When using this new integration feature, the default WebCombo's input and dropdown behaviors are no longer used. Instead, WebCombo will delegate the behaviors to the client APIs which contain specific implementations of the required plug-in behaviors.

When WebTreeView is integrated into WebCombo, the WebTreeView will be automatically shown when the WebCombo's dropdown button is clicked. When a selection is made in the WebTreeView instance, the text will be sent back to the WebCombo text box. This feature enables out-of-the-box integration between Intersoft's controls which significantly reduces development time and efforts.

To learn more about integrating WebTreeView to WebCombo, see How-to: Integrate a WebTreeView control to WebCombo.

See Also

Tasks
How-to: Integrate a WebTreeView control to WebCombo

Other Resources
Support for Opera 9.5 and Safari 3.0 browsers
Integration with WebContextMenu


How-to: Integrate a WebTreeView control to WebCombo

How-to: Integrate a WebTreeView control to WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added in WebCombo 4 > Integration with WebTreeView > How-to: Integrate a WebTreeView control to WebCombo

Glossary Item Box

WebCombo introduces its new ability to be integrated with WebTreeView control. With this feature, you can provide richer and more intuitive way for your end users to input from hierarchical/grouped data.

This topic shows how to integrate WebTreeView to WebCombo.

To integrate WebTreeView with WebCombo

  1. Right click on WebCombo control and choose Properties.
  2. Expand IntegrationSettings.
  3. Set ControlId to WebTreeView control, such as WebTreeView1.
  4. Then, set ControlType to WebTreeView and Enabled to True.
  5. Note that you need to add style="display: none;" in WebTreeView's tag.
    For example:

    <iswebtreeview:webtreeview id="WebTreeView1" style="display: none;" runat="server">
    </iswebtreeview:webtreeview>

See Also

Concepts
{Integration with WebTreeView}


Integration with WebContextMenu

Integration with WebContextMenu
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added in WebCombo 4 > Integration with WebContextMenu

Glossary Item Box

Tight integration with WebContextMenu enables you to easily input a data by selecting from a hierarchical Menu User Interface. For instances, instead of showing a long list of hundreds items during product entry, you can show a short list of logically-grouped items displayed in a Menu interface. The result is better data entry experience, allowing end users to perform entry tasks in more intuitive and productive way.

The following illustration shows a WebContextMenu control used as the dropdown container in a WebCombo instance.

When WebContextMenu is integrated into WebCombo, the WebContextMenu will be automatically shown when the WebCombo's dropdown button is clicked. When a selection is made in the WebContextMenu instance, the text will be sent back to the WebCombo text box. This feature enables out-of-the-box integration between Intersoft's controls which significantly reduces development time and efforts.

An interesting ability in this WebContextMenu integration is the support for editable WebCombo. When you typed into the textbox, WebCombo will attempt to find the matching menu item and loop into the sub menu hierarchically. The first match menu item will then be displayed and focused. When a valid menu item is highlighted, you can simply press Tab to select the item and WebCombo will automatically set the Text and Value. When the typed text is invalid, WebCombo will remove the Text and Value as well - all done without additional code.

To learn more about integrating a WebContextMenu to WebCombo, see How-to: Integrate a WebContextMenu control to WebCombo.

See Also

Tasks
How-to: Integrate a WebContextMenu control to WebCombo

Other Resources
Support for Opera 9.5 and Safari 3.0 browsers
Integration with WebTreeView


How-to: Integrate a WebContextMenu control to WebCombo

How-to: Integrate a WebContextMenu control to WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added in WebCombo 4 > Integration with WebContextMenu > How-to: Integrate a WebContextMenu control to WebCombo

Glossary Item Box

WebCombo introduces its new ability to be integrated with WebContextMenu control. With this feature, you can provide a better data entry result that allows end users to perform entry tasks in more productive way.

This topics shows how to integrate WebContextMenu to WebCombo.

To integrate WebContextMenu with WebCombo

  1. Right click on WebCombo control and choose Properties.
  2. Expand IntegrationSettings.
  3. Set ControlId to WebContextMenu control, such as WebContextMenu1.
  4. Then, set ControlType to WebContextMenu and Enabled to True.

See Also

Concepts
Integration with WebContextMenu


How-to: Enable Sliding Animation in WebCombo

How-to: Enable Sliding Animation in WebCombo
Send Feedback

Glossary Item Box

WebCombo adds a new quadratic sliding animation that will be played when you click on the dropdown arrow or even when you type in the textbox.

This topic shows how to configure sliding animation from WebCombo's Properties.

To enable sliding animation

  1. Right click on WebCombo control and choose Properties.
  2. Expand LayoutSettings.
  3. Set ResultBoxWindowType to Normal and EnableSlidingAnimation to True.


LINQ to SQL Support

LINQ to SQL Support
Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added in WebCombo 4 > LINQ to SQL Support

Glossary Item Box

WebCombo has been improved to support 'LINQ to SQL' technology as well. WebCombo can connect to either LinqDataSource or ISLinqDataSource. When bound to LinqDataSource, WebCombo will perform the query and paging on the database server through LINQ to SQL, while at the same time consistently supporting the essential WebCombo features such as AllowWildcardSearch, AdditionalSearchFields and Linked WebCombo. Together with the state-of-the-art AJAX architecture, this improvement enables WebCombo to retrieve data from million records table in a fraction of seconds, which ultimately translates to an improved user experience.

Before LINQ to SQL, WebCombo already provides advanced mechanism to allow users to perform query at database layer. However, the previous technique will require tremendous amount of code. Now, thanks to LINQ to SQL technology, WebCombo can perform value lookup and text searching automatically, without requiring extensive coding. This translates to big time-saving in both development and production.

It is highly recommended to use LinqDataSource when you bind a fairly large datasource to the WebCombo. With LinqDataSource, WebCombo can perform search query and return it to client in less than a second.

The following sections describe how to prepare the project to start using LINQ-to-SQL.

Preparing the project

Before we can use LINQ to SQL, we need to configure the LINQ to SQL classes. To get started, let's create a new Web application project (or a new Website), and add Northwind.mdf to your App_Data folder.

Next, add LINQ to SQL Classes and name it Northwind.dbml such as shown below.

Finally, open Server Explorer, then drag the desired SQL tables into the designer surface of the newly created Northwind.dbml such as shown below:

Save the Northwind.dbml file.

To learn more about binding WebCombo to LinqDataSource, see Walkthrough: Binding WebCombo to LinqDataSource.

To learn more about AllowWildcardSearch, see Walkthrough: Enabling AllowWildcardSearch.

To learn more about linked WebCombo, see Walkthrough: Configuring Linked WebCombo.


Walkthrough: Binding WebCombo to LinqDataSource

Walkthrough: Binding WebCombo to LinqDataSource
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added in WebCombo 4 > LINQ to SQL Support > Walkthrough: Binding WebCombo to LinqDataSource

Glossary Item Box

This walkthrough will guide you to bind the WebCombo control to ISLinqDataSource.

During this walkthrough, you will learn how to do the following:

  • Configure the LINQ to SQL classes.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2008/2010 Application.
  • Microsoft.NET Framework 3.5.

Step-By-Step Instructions

To create new web application and bind WebCombo to ISLinqDataSource

  1. Open Visual Studio toolbox. Drag WebCombo to your WebForm's designer surface.
  2. Drag LinqDataSource to the designer surface.
  3. Click Configure Datasource from the LinqDataSource smart tag.
  4. The LinqDataSource Wizard is pretty simple and straightforward. On the first screen, it should already select NorthwindDataContext by default, so simply click Next.
  5. On the second screen, since we want to select all customer properties, we don't need to configure anything else, simply click Finish. See below.

  6. Select WebCombo instance and open its smart tag. Choose LinqDataSource1 as the DataSourceID, set DataTextField to ContactName, and DataValueField to CustomerID. You can click on the dropdown to pick a field from the list. See below.

  7. You're all set. Save your WebForm, and run in browser.
  8. Try to type something into the textbox to search, or click on the dropdown arrow. The result should be similar to the following image.

    With LINQ to SQL (through LinqDataSource), WebCombo executes the query and returns it to the client in a fraction of second - no matter how large the datasource is.

See Also

Tasks
Walkthrough: Enabling AllowWildcardSearch
Walkthrough: Configuring Linked WebCombo


Walkthrough: Enabling AllowWildcardSearch

Walkthrough: Enabling AllowWildcardSearch
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added in WebCombo 4 > LINQ to SQL Support > Walkthrough: Enabling AllowWildcardSearch

Glossary Item Box

This walkthrough will guide you to enable AllowWildcardSearch feature in WebCombo.

During this walkthrough, you will learn how to do the following:

  • Configure the LINQ to SQL classes.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2008/2010 Application.
  • Microsoft.NET Framework 3.5.

Step-By-Step Instructions

To create new web application and enable AllowWildcardSearch feature

  1. Continuing Walkthrough: Binding WebCombo to LinqDataSource, select WebCombo instance and open its smart tag designer.
  2. Simply check the Allow Wildcard Search checkbox.
  3. Save your WebForm and run the page to browser.

See Also

Tasks
Walkthrough: Binding WebCombo to LinqDataSource
Walkthrough: Configuring Linked WebCombo


Walkthrough: Configuring Linked WebCombo

Walkthrough: Configuring Linked WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Features Added in WebCombo 4 > LINQ to SQL Support > Walkthrough: Configuring Linked WebCombo

Glossary Item Box

This walkthrough will guide you to link two WebCombo instances.

During this walkthrough, you will learn how to do the following:

  • Configure the LINQ to SQL classes.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2008/2010 Application.
  • Microsoft.NET Framework 3.5.

Step-By-Step Instructions

To create new web application and apply linked WebCombo feature

  1. Create a new WebForm page to your Website project.
  2. Add two instances of WebCombo to the page.
  3. Add two instances of LinqDataSource to the page.
  4. Bind the first LinqDataSource to Customers table, and the second one to Orders table. Place the WebCombo in a table such as shown below.

  5. Select the first WebCombo, set its DataSourceID to LinqDataSource1, DataTextField to ContactName and DataValueField to CustomerID.
  6. Select the second WebCombo, set its DataSourceID to LinqDataSource2, DataTextField and DataValueField to OrderID.
  7. Configure LinkSettings for Orders WebCombo by launching WebCombo Designer. Follow the configuration as shown in the following.

  8. Save the page, and run it to browser.
  9. Your browser should look like the following screenshot.

    Try to interact with the WebCombo, such as selecting a customer. Next, when you open the Orders' WebCombo dropdown, you will see the order list of the selected customers.

    New enhancement: When bound to LinqDataSource, WebCombo can now perform wildcard search on non-string type. For instance as in above sample, the OrderID is of integer type. If you typed in "10" then it will show the records starting with "10". This feature is not possible before LinqDataSource, as non-string type can't be queried using like or contains predicate in ADO.NET objects.

See Also

Tasks
{Walkthrough: Binding WebCombo to LinqDataSource}
{Walkthrough: Enabling AllowWildcardSearch}


Data Binding Wakthroughs

Data Binding Wakthroughs
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Data Binding Wakthroughs

Glossary Item Box

This topic provides links to the step-by-step walkthroughs to achieve common data binding tasks using WebCombo.

In This Section

Walkthrough: Binding WebCombo to AccessDataSource control

Walkthrough: Binding WebCombo to ObjectDataSource control

Walkthrough: Binding WebCombo to ISDataSource control

Walkthrough: Binding WebCombo to SqlDataSource control

Walkthrough: Binding WebCombo to XMLDataSource control

Walkthrough: Binding WebCombo to IList DataSource control

Walkthrough: Binding WebCombo to a DataSet

Walkthrough: Binding WebCombo to custom object

Walkthrough: Implementing requery method using traditional DataSource

Walkthrough: Implementing requery method using ISDataSource

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

References
DataSource Property
DataSourceID Property
UseDefaultStyle Property
DataTextField Property
DataValueField Property
InitializeDataSource Event


Walkthrough: Binding WebCombo to XMLDataSource control

Walkthrough: Binding WebCombo to XMLDataSource control
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Data Binding Wakthroughs > Walkthrough: Binding WebCombo to XMLDataSource control

Glossary Item Box

This walkthrough shows you how to create and bind WebCombo to XMLDataSource control.

During this walkthrough, you will learn how to do the following:

  • Use XMLDataSource.
  • Use SmartTag to set DataSource.
  • Use DataSourceConfigurationWizard to set the Database and table.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the XML database.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and bind WebCombo to XMLDataSource

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebCombo instance from ToolBar to WebForm.
  8. Click the SmartTag on the upper right of the WebCombo.
  9. Set the DataTextField and DataValueField for WebCombo.
  10. In Choose Data Source field, choose <New data source...>

  11. In Data Source Configuration Wizard, choose XML File and click OK.

  12. Set the Data file and XPath expression.

  13. Click OK and run the project. The combo will look like following.

See Also

Tasks
Walkthrough: Binding WebCombo to AccessDataSource control
Walkthrough: Binding WebCombo to ObjectDataSource control
Walkthrough: Binding WebCombo to ISDataSource control
Walkthrough: Binding WebCombo to SqlDataSource control
Walkthrough: Binding WebCombo to IList DataSource control

Concepts
No-codes data binding through DataSourceControl support

References
DataSource Property
DataTextField Property
DataValueField Property


Walkthrough: Binding WebCombo to XML-based DataSource

Walkthrough: Binding WebCombo to XML-based DataSource
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Data Binding Wakthroughs > Walkthrough: Binding WebCombo to XML-based DataSource

Glossary Item Box

This walkthrough shows you how to create and bind WebCombo to XML-based DataSource.

During this walkthrough, you will learn how to do the following:

  • Use XML-based DataSource.
  • Use InitializeDataSource events to set the DataSource.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the XML database.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and bind WebCombo to XML-based DataSource

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebCombo instance from ToolBar to WebForm.
  8. Double click the WebCombo instance and put the following code in WebCombo1_InitializeDataSource event :

    C# Copy Code
    protected void WebCombo1_InitializeDataSource(object sender, DataSourceEventArgs e)
{
   XmlDataDocument xDoc = new XmlDataDocument();
   xDoc.DataSet.ReadXmlSchema(Server.MapPath("CustomerOrders.xml"));
   xDoc.Load(Server.MapPath("CustomerOrders.xml"));

   e.DataSource = xDoc.DataSet;
   WebCombo1.DataTextField = "CustomerID";
   WebCombo1.DataValueField = "CustomerID";
}

  9. Run the project and the combo will look like following.

See Also

Tasks
Walkthrough: Binding WebCombo to AccessDataSource control
Walkthrough: Binding WebCombo to ObjectDataSource control
Walkthrough: Binding WebCombo to ISDataSource control

References
DataSource Property
DataTextField Property
DataValueField Property
InitializeDataSource Event
OnInitializeDataSource Method


Walkthrough: Binding WebCombo to IList DataSource control

Walkthrough: Binding WebCombo to IList DataSource control
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Data Binding Wakthroughs > Walkthrough: Binding WebCombo to IList DataSource control

Glossary Item Box

This walkthrough shows you how to create and bind WebCombo to IList DataSource.

During this walkthrough, you will learn how to do the following:

  • Use IList DataSource.
  • Use Page_Load events to set the DataSource.
  • Create Class for the dataset.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and bind WebCombo to IList DataSource

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebCombo instance from ToolBar to WebForm.
  8. Create a class for the database in code behind:

    C# Copy Code
    public class Invoices
{
    private int mInvoiceId;
    private string mInvoiceNo;
    private DateTime mInvoiceDate;
    private string mCustomerName;
    private int mQty;
    private double mUnitPrice;
    private double mTotal;

    public Invoices(int InvoiceId, string InvoiceNo, DateTime InvoiceDate, string CustomerName, int Qty, double UnitPrice, double Total)
    {
        this.mInvoiceId = InvoiceId;
        this.mInvoiceNo = InvoiceNo;
        this.mInvoiceDate = InvoiceDate;
        this.mCustomerName = CustomerName;
        this.mQty = Qty;
        this.mUnitPrice = UnitPrice;
        this.mTotal = Total;
    }

    public int InvoiceId
    {
        get { return this.mInvoiceId; }
    }

    public string InvoiceNo
    {
        get { return this.mInvoiceNo; }
    }

    public DateTime InvoiceDate
    {
        get { return this.mInvoiceDate; }
    }

    public string CustomerName
    {
        get { return this.mCustomerName; }
    }

    public int Qty
    {
        get { return this.mQty; }
    }

    public double UnitPrice
    {
        get { return this.mUnitPrice; }
    }

    public double Total
    {
        get { return this.mTotal; }
    }
}

  9. On the Page_Load event handler, write the following code:

    C# Copy Code
    protected void Page_Load(object sender, EventArgs e)
{
   body.Style.Add("overflow", "hidden");
   ArrayList aList = new ArrayList();

   aList.Add(new Invoices(1, "INV-001", DateTime.Parse("2/1/2003"), "John Smith", 5, 750, 750 * 5));
   aList.Add(new Invoices(2, "INV-002", DateTime.Parse("2/2/2003"), "Steven Buchanan", 10, 450.7, 4507));
   aList.Add(new Invoices(3, "INV-003", DateTime.Parse("2/10/2003"), "Alexander King", 25, 700, 25 * 700));
   aList.Add(new Invoices(3, "INV-003", DateTime.Parse("2/10/2003"), "Alexander King", 25, 700, 25 * 700));

   WebCombo1.DataSource = aList;

   WebCombo1.DataTextField = "CustomerName";
   WebCombo1.DataValueField = "InvoiceId";
}

  10. Run the project and the combo will look like following.

See Also

Tasks
Walkthrough: Binding WebCombo to AccessDataSource control
Walkthrough: Binding WebCombo to ObjectDataSource control
Walkthrough: Binding WebCombo to ISDataSource control
Walkthrough: Binding WebCombo to SqlDataSource control
Walkthrough: Binding WebCombo to XMLDataSource control

Concepts
No-codes data binding through DataSourceControl support

References
DataSource Property
DataTextField Property
DataValueField Property


Walkthrough: Binding WebCombo to a DataSet

Walkthrough: Binding WebCombo to a DataSet
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Data Binding Wakthroughs > Walkthrough: Binding WebCombo to a DataSet

Glossary Item Box

This walkthrough shows you how to create and bind WebCombo to a DataSet.

During this walkthrough, you will learn how to do the following:

  • Connect to a Microsoft Access database using Microsoft Jet 4.0 OLE DB Provider.
  • Use OleDbDataAdapter to configure SQL Query and generate DataSet.
  • Set Web Application's environment and the DataSource.
  • Use WebCombo's InitializeDataSource event to bind the DataSet.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and bind WebCombo with DataSource

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebCombo instance from ToolBar to WebForm.
  8. Double click on WebCombo instance and write this code:

    C# Copy Code
    protected void WebCombo1_InitializeDataSource(object sender, ISNet.WebUI.WebCombo.DataSourceEventArgs e)
{
   DataSet1TableAdapters.ProductsTableAdapter da = new DataSet1TableAdapters.ProductsTableAdapter();
   e.DataSource = da.GetData();
   WebCombo1.DataTextField = "ProductName";
   WebCombo1.DataValueField = "ProductID";
}

  9. Run the project and the combo will look like following.

See Also

Tasks
Walkthrough: Binding WebCombo to AccessDataSource control
Walkthrough: Binding WebCombo to ObjectDataSource control
Walkthrough: Binding WebCombo to ISDataSource control
Walkthrough: Binding WebCombo to SqlDataSource control
Walkthrough: Binding WebCombo to XMLDataSource control
Walkthrough: Binding WebCombo to IList DataSource control
Walkthrough: Binding WebCombo to custom object

Concepts
No-codes data binding through DataSourceControl support

References
DataSource Property
DataTextField Property
DataValueField Property
InitializeDataSource Event
OnInitializeDataSource Method


Walkthrough: Binding WebCombo to custom object

Walkthrough: Binding WebCombo to custom object
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Data Binding Wakthroughs > Walkthrough: Binding WebCombo to custom object

Glossary Item Box

This walkthrough shows you how to create and bind WebCombo to custom object.

During this walkthrough, you will learn how to do the following:

  • Use ISDataSource.
  • Use Custom Object.
  • Use SmartTag to set DataSource.
  • Use Data Source Configuration Wizard to set the Database and table.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and bind WebCombo to CustomObject

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. In the Solution Explorer, right-click on App_Data and select Add Existing Item.
  8. Browse and add NorthWind.mdb in C:\Program Files\Intersoft Solutions\Data (Default installation folder).
  9. Right click on App_Code folder, choose New Folder and name the new folder DataObject.
  10. After that right click on the DataObject folder and choose Add New Item.
  11. Then set C# class and named it as MyData.cs and MyDataAccess.cs respectively.
  12. In MyData.cs, add the following code:

    C# Copy Code
    namespace DataObject
{
    public class MyData
    {
        private int shipperID;
        private string companyName;
        private string phone;

        public int ShipperID
        {
            get { return this.shipperID; }
            set { this.shipperID = value; }
        }

        public string CompanyName
        {
            get { return this.companyName; }
            set { this.companyName = value; }
        }

        public string Phone
        {
            get { return this.phone; }
            set { this.phone = value; }
        }
    }
}

  13. In MyDataAccess.cs, add the following code:

    C# Copy Code
    namespace DataObject
{
    [System.ComponentModel.DataObject]
    public class MyDataAccess
    {

        private dsNorthwind_OverwriteChangesTableAdapters.ShippersTableAdapter shipperDA = new dsNorthwind_OverwriteChangesTableAdapters.ShippersTableAdapter();

        public MyDataAccess()
        {

        }

        [System.ComponentModel.DataObjectMethodAttribute(System.ComponentModel.DataObjectMethodType.Select, true)]
        public dsNorthwind_OverwriteChanges.ShippersDataTable GetData()
        {
            return shipperDA.GetData();
        }

        [System.ComponentModel.DataObjectMethodAttribute(System.ComponentModel.DataObjectMethodType.Insert, true)]
        public int Insert(MyData data)
        {
            return shipperDA.Insert(data.CompanyName, data.Phone);
        }

        [System.ComponentModel.DataObjectMethodAttribute(System.ComponentModel.DataObjectMethodType.Update, true)]
        public int Update(MyData data)
        {
            return shipperDA.Update(data.CompanyName, data.Phone, data.ShipperID);
        }

        [System.ComponentModel.DataObjectMethodAttribute(System.ComponentModel.DataObjectMethodType.Delete, true)]
        public int Delete(MyData data)
        {
            return shipperDA.Delete(data.ShipperID);
        }
    }
}

  14. Drag WebCombo instance from ToolBar to WebForm.
  15. Click the SmartTag on the upper right of the WebCombo.
  16. Set the DataTextField and DataValueField for WebCombo.
  17. In Choose Data Source field, choose <New data source...>.

  18. In Data Source Configuration Wizard, choose ISDataSource and click OK.

  19. Set the Schema Type to CustomObject and click Next.

  20. Add new table and choose a business object like the following screenshot. Click Finish afterwards.

  21. Run the project and the combo will look like the following.

See Also

Tasks
Walkthrough: Binding WebCombo to AccessDataSource control
Walkthrough: Binding WebCombo to ObjectDataSource control
Walkthrough: Binding WebCombo to ISDataSource control
Walkthrough: Binding WebCombo to SqlDataSource control
Walkthrough: Binding WebCombo to XMLDataSource control
Walkthrough: Binding WebCombo to a DataSet

Concepts
No-codes data binding through DataSourceControl support

References
DataSource Property
DataTextField Property
DataValueField Property


Walkthrough: Implementing requery method using traditional DataSource

Walkthrough: Implementing requery method using traditional DataSource
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Data Binding Wakthroughs > Walkthrough: Implementing requery method using traditional DataSource

Glossary Item Box

This walkthrough shows you how to implement requery method using traditional DataSource.

During this walkthrough, you will learn how to do the following:

  • Connect to a Microsoft Access database using Microsoft Jet 4.0 OLE DB Provider.
  • Use WebCombo's InitializeDataSource event to bind the DataSet.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005/208/2010 Application.

Step-By-Step Instructions

To create new web application and bind WebCombo with DataSource

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebCombo instance from ToolBar to WebForm.
  8. Double click on WebCombo instance and write the following code:

    C# Copy Code
    protected void WebCombo1_InitializeDataSource(object sender, ISNet.WebUI.WebCombo.DataSourceEventArgs e)
{
    OleDbConnection conn = new OleDbConnection(@"Provider=Microsoft.Jet.OLEDB.4.0;Data Source=|DataDirectory|\NorthWind.mdb");
    OleDbDataAdapter da = new OleDbDataAdapter();
    DataSet ds = new DataSet();
    string queryText = "";

    da.SelectCommand = new OleDbCommand();
    da.SelectCommand.Connection = conn;

    if (!e.IsFlyDataRequest)
    {
       if (WebCombo1.Value != "" && WebCombo1.Value != null)
       {
         da.SelectCommand.CommandText = "Select * From Customers Where " + WebCombo1.DataValueField + " = '" + WebCombo1.Value + "'";
         da.Fill(ds);
         e.DataSource = ds;
       }
     }
     else
     {
       int TopRows = e.StartRow + e.RowCount;
       queryText = WebCombo1.DataTextField + " Like '" + e.QueryText + "%'";

       da.SelectCommand.CommandText = "Select TOP " + TopRows + " * From Customers Where " + queryText;

       da.Fill(ds, e.StartRow, e.RowCount, "Table1");

       if (ds.Tables[0].Rows.Count < 3)
       {
          queryText += " Or " + WebCombo1.DataTextField + " Like '" + e.QueryText.Substring(0, 1) + "%'";
          da.SelectCommand.Commandtext = "Select TOP " + TopRows + " * From Customers Where " + queryText;

          ds.Tables[0].Rows.Clear();
          da.Fill(ds, e.StartRow, e.RowCount, "Table1");
        }
        e.DataSource = ds;

        WebCombo1.SkipRowParsing = true;

        conn.Open();
        OleDbCommand cmd = new OleDbCommand();
        cmd.Commandtext = "Select Count(CustomerID) From Customers Where " + queryText;
        cmd.Connection = conn;

        WebCombo1.TotalDataSourcerows = int.Parse(cmd.ExecuteScalar().ToString());
      }
}

  9. On Page_Load event handler, put the following code:

    C# Copy Code
    WebCombo1.AllowAutoQueryHandler = false;
WebCombo1.DataTextField = "ContactName";
WebCombo1.DataValueField = "CustomerID";

  10. Run the project and the combo will look like following.

See Also

Tasks
Walkthrough: Implementing requery method using ISDataSource

Concepts
No-codes data binding through DataSourceControl support


Walkthrough: Implementing requery method using ISDataSource

Walkthrough: Implementing requery method using ISDataSource
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Data Binding Wakthroughs > Walkthrough: Implementing requery method using ISDataSource

Glossary Item Box

This walkthrough shows you how to implement requery method using ISDataSource.

During this walkthrough, you will learn how to do the following:

  • Connect to a Microsoft Access database using Microsoft Jet 4.0 OLE DB Provider.
  • Use WebCombo's InitializeDataSource event to bind the DataSet.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and implementing requery method using ISDataSource

  1. Drag two WebCombo instances from ToolBar to WebForm.
  2. Create a new DataSet and name it dsRequery.
  3. Drag Products and Categories table into the DataSet.
  4. Right click on the product table and choose Add Query.
  5. In TableAdapter Query Configuration Wizard, specify a SQL Select Statement "SELECT ProductID, ProductName, SupplierID, CategoryID, QuantityPerUnit, UnitPrice, UnitsInStock, UnitsOnOrder, ReorderLevel, Discontinued
    FROM Products
    WHERE (CategoryID = ?)"
  6. Click the SmartTag on the upper right of the WebCombo.
  7. Set the DataTextField and DataValueField for WebCombo.
  8. In Choose Data Source field, choose <New data source...>.
  9. In Data Source Configuration Wizard, choose AccessDatabase and click next.
  10. Select the connection string in App_Data and click next.
  11. Select the table that you want to use, click next and finish afterwards.
  12. Run the project the combo will look like following.

See Also

Tasks
Walkthrough: Binding WebCombo to ISDataSource control
Walkthrough: Implementing requery method using traditional DataSource

Concepts
No-codes data binding through DataSourceControl support


Unbound Mode How-to Topics

Unbound Mode How-to Topics
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Unbound Mode How-to Topics

Glossary Item Box

The topics in this section describe how to achieve common unbound tasks.

In This Section

How-to: Add item in unbound WebCombo from Server-side

How-to: Add item in unbound WebCombo from Client-side

How-to: Set selected row in unbound WebCombo

How-to: Modify the first cell of the first row in unbound WebCombo

How-to: Delete a row in unbound WebCombo

How-to: Perform batch update in unbound WebCombo

How-to: Create unbound WebCombo using PopulateUnboundData method

How-to: Create multiple columns unbound WebCombo using PopulateUnboundData method

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics


How-to: Add item in unbound WebCombo from server side

How-to: Add item in unbound WebCombo from server side
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Unbound Mode How-to Topics > How-to: Add item in unbound WebCombo from server side

Glossary Item Box

In WebCombo, you can add item from Server-side.

This topic will show you how to add item to WebCombo on Server-side.

To add item to unbound WebCombo from Server-side

  1. Drag ASP.NET Button to the page.
  2. Double click the ASP.NET button. Then, add the following code in Button1_Click event handler:

    C# Copy Image Copy Code
    WebComboRow row = new WebComboRow();
row.Cells.Add(new WebComboCell());
row.Cells[0].Text = "New Item";

WebCombo1.Rows.Add(row);

  3. Run the project.

See Also

Tasks
How-to: Add item in unbound WebCombo from client side
How-to: Set selected row in unbound WebCombo
How-to: Delete a row in unbound WebCombo
How-to: Create unbound WebCombo using PopupateUnboundData method

Concepts
Unbound Mode

References
WebComboRow Class
Cells Property


How-to: Add item in unbound WebCombo from client side

How-to: Add item in unbound WebCombo from client side
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Unbound Mode How-to Topics > How-to: Add item in unbound WebCombo from client side

Glossary Item Box

In WebCombo, you can add item from Client-side.

This topic will show you how to add item to unbound WebCombo on Client-side.

To add item in unbound WebCombo from Client-side

  1. Drag HTML Button to the page.
  2. Add the following function in client side:

    JavaScript Copy Image Copy Code
    function addItem()
{
   var wc4 = ISGetObject("WebCombo1");
   var rows = wc4.GetRows(); // get the WebCombo4's rows for addition
   var newRow = wc4.NewRow("NEWCUST2"); // instantiate new row with NEWCUST as the KeyValue, containing cells with empty value
   var cells = newRow.GetCells(); // get the cells of the new row for value assignment

   // addition
   cells.GetNamedItem("ContactName").Text = "New Customer2"; // write codes in the same way as in server-side object model, with similar object hierarchy.
   cells.GetNamedItem("Address").Text = "New Address2"; // assign value to Address Cell
   cells.GetNamedItem("CustomerID").Text = "NEWCUST2";
   rows.Add(newRow); //add the newRow to the rows collection

   // modification
   cells = rows[1].GetCells();
   cells[0].Text = "Changed Text"; // modify the text
   rows[1].SetChanged();

   // update all changes now
   wc4.UpdateUI();
}

  3. Next, add onclick ="addItem()" on the HTML Button's tag like following:

    <input id="Button1" type="button" value="Test" onclick="addItem()" />

  4. Run the project.

See Also

Tasks
How-to: Add item in unbound WebCombo from server side
How-to: Set selected row in unbound WebCombo
How-to: Delete a row in unbound WebCombo
How-to: Create unbound WebCombo using PopupateUnboundData method

Concepts
Unbound Mode


How-to: Set selected row in unbound WebCombo

How-to: Set selected row in unbound WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Unbound Mode How-to Topics > How-to: Set selected row in unbound WebCombo

Glossary Item Box

In WebCombo, you can set selected row in Unbound WebCombo from Client-side.

This topic will show you how to set selected value from WebCombo on Client-side

To set selected value in WebCombo from Client-Side

  1. Go to HTML View and put the following code:

    <input id="Button1" type="button" value="SetValue" onclick="SetValue()" />

  2. Create function SetValue() in client side and add one of the these codes based on your need:

    JavaScript Copy Image Copy Code
    function SetValue()
{
   // To Set selected Value Directly
   var combo = ISGetObject("WebCombo1");
   combo.SetText("Brian");
   alert("Text set to Brian");
}

    JavaScript Copy Image Copy Code
    function SetValue()
{
   // To Set selected Value by Index
   var combo = ISGetObject("WebCombo1");
   combo.SetSelectedIndex(2);
   alert("Set value by index 2");
}

    JavaScript Copy Image Copy Code
    function SetValue()
{
   // To Set selected Value by KeyValue
   var combo = ISGetObject("WebCombo1");
   combo.SetSelectedRowByValue("Andrew");
   alert("Set value by KeyValue Andrew");
}

    JavaScript Copy Image Copy Code
    function SetValue()
{
   // To Set selected Value by RowObject
   var combo = ISGetObject("WebCombo1");
   var rows = combo.GetRows();
   var row = rows[1];
   row.Select();
   alert("Set value by calling Select() method of a WebComboRow object");
}

  3. Run the project.

See Also

Tasks
How-to: Modify the first cell of the first row in unbound WebCombo
How-to: Delete a row in unbound WebCombo
How-to: Add item in unbound WebCombo from client side
How-to: Perform batch update in unbound WebCombo
How-to: Create unbound WebCombo using PopupateUnboundData method

Concepts
Unbound Mode


How-to: Modify the first cell of the first row in unbound WebCombo

How-to: Modify the first cell of the first row in unbound WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Unbound Mode How-to Topics > How-to: Modify the first cell of the first row in unbound WebCombo

Glossary Item Box

In WebCombo, you can modify the first cell of the first row in Unbound WebCombo.

This topic will show you how to perform the modification via Client-side.

To modify the first cell of the first row in WebCombo from Client-Side

  1. Go to HTML View and put the following code:

    <input id="Button1" type="button" value="SetColour" onclick="SetColor()" />

  2. Create function SetColor() in client side and add one of these codes based on your need:

    JavaScript Copy Image Copy Code
    function SetColor()
{
   var combo = ISGetObject("WebCombo1");
   var row0 = combo.GetRow(0);

   if (row0 != null)
   {
        var cell0 = row0.GetCell(0);
        var cellElement = cell0.GetElement();

        if (cellElement)
        {
                cellElement.style.color = "red";
                alert("HTML Element of WebCombo1's Row 0, Cell 0 found. The fore color has been changed to Red.");
                combo.SetFocus();
                combo.ShowDropDown();
        }
   }
}

  3. Run the project.

See Also

Tasks
How-to: Set selected row in unbound WebCombo
How-to: Delete a row in unbound WebCombo
How-to: Perform batch update in unbound WebCombo
How-to: Create unbound WebCombo using PopupateUnboundData method

Concepts
Unbound Mode How-to Topics


How-to: Delete a row in unbound WebCombo

How-to: Delete a row in unbound WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Unbound Mode How-to Topics > How-to: Delete a row in unbound WebCombo

Glossary Item Box

WebCombo provides a method to delete a row in unbound mode.

In this topic, you will learn how to implement the delete method.

To delete a row in unbound WebCombo

  1. Go to HTML view and add the following code:

    JavaScript Copy Image Copy Code
    function DeleteRow()
{
   var WebCombo1 = ISGetObject("WebCombo1");
   var rows = WebCombo1.GetRows();
   rows.Remove(rows[0], true); //remove row 0 from Rows collection, 2nd parameter must always be set to true
   WebCombo1.UpdateUI();
   alert("Row 0 removed!");
}

  2. Invoke DeleteRow() function by adding the following code:

    <input id="Button1" type="button" value="Delete Row" onclick="DeleteRow()" />

See Also

Tasks
How-to: Add item in unbound WebCombo from client side
How-to: Set selected row in unbound WebCombo
How-to: Modify the first cell of the first row in unbound WebCombo
How-to: Create unbound WebCombo using PopupateUnboundData method
How-to: Create multiple columns unbound WebCombo using PopulateUnboundData method

Concepts
Unbound Mode


How-to: Perform batch update in unbound WebCombo

How-to: Perform batch update in unbound WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Unbound Mode How-to Topics > How-to: Perform batch update in unbound WebCombo

Glossary Item Box

WebCombo V4.0 gives you the ability to perform batch update in unbound mode.

In this topic, you will learn how to implement the batch update.

To perform batch update in unbound WebCombo

  1. Set WebCombo to unbound mode.
  2. Go to HTML view and add the following code:

    JavaScript Copy Image Copy Code
    function BatchUpdate()
{
   var WebCombo1 = ISGetObject("WebCombo1");
   var firstRow= WebCombo1.GetRows()[0]; // get the WebCombo1's rows
   var firstCell = firstRow.GetCells()[0];
   firstCell.Text = "Changed Text"; // modify the text
   firstRow.SetChanged();
   WebCombo1.UpdateUI();
   alert("Batch Update done!");
}

  3. Invoke BatchUpdate() function by adding the following code:

    <input id="Button1" type="button" value="Update" onclick="BatchUpdate()" />

See Also

Tasks
How-to: Delete a row in unbound WebCombo
How-to: Create unbound WebCombo using PopupateUnboundData method
How-to: Create multiple columns unbound WebCombo using PopulateUnboundData method
How-to: Modify the first cell of the first row in unbound WebCombo
How-to: Add item in unbound WebCombo from client side

Concepts
Unbound Mode


How-to: Create unbound WebCombo using PopupateUnboundData method

How-to: Create unbound WebCombo using PopupateUnboundData method
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Unbound Mode How-to Topics > How-to: Create unbound WebCombo using PopupateUnboundData method

Glossary Item Box

In WebCombo, you can create unbound WebCombo using PopulateUnboundData method.

This topic will show you how to use PopulateUnboundData method.

To create unbound WebCombo using PopulateUnboundData method

  1. Drag WebCombo instance from ToolBox to WebForm.
  2. In Page_Load event handler, add the following code :

    C# Copy Image Copy Code
    WebCombo1.DataMember = "Customers";
WebCombo1.DataTextField = "ContactName";
WebCombo1.DataValueField = "CustomerID";

WebCombo1.LayoutSettings.StatusBoxVisible = false;

WebCombo1.Columns.Add("ContactName");
WebCombo1.Columns.Add("CustomerID");

dsNorthwind.CustomersDataTable dt = new dsNorthwind.CustomersDataTable();
dsNorthwindTableAdapters.CustomersTableAdapter da = new dsNorthwindTableAdapters.CustomersTableAdapter();
da.Fill(dt);
WebCombo1.PopulateUnboundData(dt, false);

  3. Run the project.

See Also

Tasks
How-to: Create multiple columns unbound WebCombo using PopulateUnboundData method
How-to: Perform batch update in unbound WebCombo
How-to: Delete a row in unbound WebCombo
How-to: Modify the first cell of the first row in unbound WebCombo
How-to: Set selected row in unbound WebCombo
How-to: Add item in unbound WebCombo from client side

Concepts
{Unbound Mode}

References
PopulateUnboundData Method


How-to: Create multiple columns unbound WebCombo using PopulateUnboundData method

How-to: Create multiple columns unbound WebCombo using PopulateUnboundData method
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Unbound Mode How-to Topics > How-to: Create multiple columns unbound WebCombo using PopulateUnboundData method

Glossary Item Box

Another ability offered by WebCombo is that you can create multiple columns unbound combo using PopulateUnboundData method.

This topic will show you how to perform the above scenario.

To create multiple column's unbound WebCombo using PopulateUnboundData method

  1. Drag WebCombo instance from ToolBox to WebForm.
  2. In Page_Load event handler, add the following code:

    C# Copy Image Copy Code
    WebCombo1.DataMember = "Customers";
WebCombo1.DataTextField = "ContactName";
WebCombo1.DataValueField = "CustomerID";

WebCombo1.LayoutSettings.ComboMode = Mode.MultipleColumns;
WebCombo1.LayoutSettings.StatusBoxVisible = false;

WebCombo1.Columns.Add("ContactName");
WebCombo1.Columns.Add("Address");
WebCombo1.Columns.Add("CustomerID");

dsNorthwind.CustomersDataTable dt = new dsNorthwind.CustomersDataTable();
dsNorthwindTableAdapters.CustomersTableAdapter da = new dsNorthwindTableAdapters.CustomersTableAdapter();
da.Fill(dt);
WebCombo1.PopulateUnboundData(dt, false);

  3. Run the project.

See Also

Tasks
How-to: Create unbound WebCombo using PopupateUnboundData method
How-to: Perform batch update in unbound WebCombo
How-to: Delete a row in unbound WebCombo
How-to: Modify the first cell of the first row in unbound WebCombo
How-to: Set selected row in unbound WebCombo
How-to: Add item in unbound WebCombo from client side

Concepts
Unbound Mode

References
PopulateUnboundData Method


User Interface Customization How-to Topics

User Interface Customization How-to Topics
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics

Glossary Item Box

The topics in this section describe how to achieve common user interface customization tasks.

In This Section

How-to: Define access key

How-to: Display tooltip in WebCombo

How-to: Determine the number of rows first requested by WebCombo

How-to: Set the latency

How-to: Allow auto PostBack

How-to: Disable auto query handler

How-to: Enable/Disable WebCombo

How-to: Show/Hide WebCombo

How-to: Disable ViewState in WebCombo

How-to: Show error message when there is missing specification

How-to: Define tab index

How-to: Define TextBox length

How-to: Disable auto data caching

How-to: Use cached data on first load

How-to: Disable WebResources

How-to: Adjust result box position

How-to: Allow text to float on the right side of WebCombo

How-to: Allow navigation on mouse wheel

How-to: Allow text wrapping to the next line

How-to: Always show all rows on dropdown combo

How-to: Always show column headers

How-to: Always show help button

How-to: Always show result box

How-to: Always show search button

How-to: Set default column width

How-to: Enable/Disable animation

How-to: Define the help image

How-to: Define help URL

How-to: Define the row's height

How-to: Define the action when no results is found in WebCombo

How-to: Define the result box's height and width

How-to: Show the result box's shadow

How-to: Position search box on the left

How-to: Use round corner in WebCombo

How-to: Define the search image

How-to: Define the position of status bar

How-to: Hide/Show the status box

How-to: Define XHTML search image

How-to: Get the hidden cell's value of the selected row

How-to: Set result box window type

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

References
DropDownStyle Property
RoundCorner Property
ResultBoxStyle Property
TextBoxMode Property
ColumnStyle Property
AlwaysShowHelpButton Property


How-to: Define access key

How-to: Define access key
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Define access key

Glossary Item Box

Like .NET standard control, you can also define access key in WebCombo.

In this topic, you will learn how to define access key "p" as WebCombo's access key.

To define access key

  1. Open WebCombo Designer - Advanced Settings.
  2. Set AccessKey to "p".
  3. In order to set focus to WebCombo, you can press "Alt + p".

See Also

Tasks
Walkthrough Topics
How-to: Display tooltip in WebCombo
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
AccessKey Property


How-to: Display tooltip in WebCombo

How-to: Display tooltip in WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Display tooltip in WebCombo

Glossary Item Box

Like .NET standard control, you also could display tooltip in WebCombo.

In this topic, you will learn how to display "Please fill Employee's Date Of Birth" as tooltip in WebCombo.

To display tooltip in WebCombo

  1. Open WebCombo Designer - Advanced Settings.
  2. Set ToolTip to "Please fill Employee's Date Of Birth".

See Also

Tasks
How-to: Define access key
How-to: Determine the number of rows first requested by WebCombo
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
TooltipText Property


How-to: Determine the number of rows first requested by WebCombo

How-to: Determine the number of rows first requested by WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Determine the number of rows first requested by WebCombo

Glossary Item Box

By default, the number of rows first requested by WebCombo is 15. However, you can set this number.

In this topic, you will learn how to set the number of rows from designer.

To determine the number of rows first requested by WebCombo

  1. Open WebCombo Designer - Advanced Settings.
  2. Set DropDownRows to 10.

See Also

Tasks
How-to: Define access key
How-to: Display tooltip in WebCombo
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
DropDownRows Property


How-to: Set the latency

How-to: Set the latency
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Set the latency

Glossary Item Box

By default, WebCombo latency is set to 500. However, you can also set this latency to match your scenario.

In this topic, you will learn how to set the latency from designer.

To set the latency

  1. Open WebCombo Designer - Advanced Settings.
  2. Set Latency to "200".

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
Latency Property


How-to: Allow auto PostBack

How-to: Allow auto PostBack
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Allow auto PostBack

Glossary Item Box

By default, allow auto postback is set to false. However, you can enable this property from designer.

In this topic, you will learn how to allow auto postback.

To allow auto postback

  1. Open WebCombo Designer - Advanced Settings.
  2. Set AllowAutoPostBack to True.

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
AllowAutoPostback Property


How-to: Disable auto query handler

How-to: Disable auto query handler
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Disable auto query handler

Glossary Item Box

By default, auto query handler is set to true. However, you can disable this property from designer.

In this topic, you will learn how to disable auto query handler.

To disable auto query handler

  1. Open WebCombo Designer - Advanced Settings.
  2. Set AllowAutoQueryHandler to False.

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
AllowAutoQueryHandler Property


How-to: Enable/Disable WebCombo

How-to: Enable/Disable WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Enable/Disable WebCombo

Glossary Item Box

You can enable/disable WebCombo in two ways, which are using property and Client-side API.

In this topic, you will learn how to enable/disable WebCombo using both ways.

To enable/disable WebCombo using property

  1. Open WebCombo Designer - Advanced Settings.
  2. Set Enabled to False in order to disable WebCombo.
  3. Set Enabled to True in order to enable WebCombo.

To enable/disable WebCombo using Client-side API

  1. Use the following code to disable combo:

    JavaScript Copy Image Copy Code
    //Disable WebCombo
var combo = ISGetObject("WebCombo1");
combo.Disable();

  2. Use the following code to enable combo:

    JavaScript Copy Image Copy Code
    //Enable WebCombo
var combo = ISGetObject("WebCombo1");
combo.Enable();

See Also

Tasks
How-to: Show/Hide WebCombo
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements


How-to: Show/Hide WebCombo

How-to: Show/Hide WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Show/Hide WebCombo

Glossary Item Box

You could show/hide WebCombo in two ways, which are using property and Client-side API.

In this topic, you will learn how to show/hide WebCombo using both ways.

To show/hide WebCombo using property

  1. Open WebCombo Designer - Advanced Settings.
  2. Set Visible to False in order to hide WebCombo.
  3. Set Visible to True in order to show WebCombo.

To show/hide WebCombo using Client-side API

  1. Use the following code to hide combo:

    JavaScript Copy Image Copy Code
    //Hide WebCombo
var combo = ISGetObject("WebCombo1");
combo.Hide();

  2. Use the following code to show combo:

    JavaScript Copy Image Copy Code
    //Show WebCombo
var combo = ISGetObject("WebCombo1");
combo.Show();

See Also

Tasks
How-to: Enable/Disable WebCombo
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
Visible Property


How-to: Disable ViewState in WebCombo

How-to: Disable ViewState in WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Disable ViewState in WebCombo

Glossary Item Box

By default, ViewState is set to enable. However, you can disable this ViewState property.

In this topic, you will learn how to disable this property using designer.

To Disable ViewState in WebCombo

  1. Open WebCombo.NET Designer - Advanced Settings.
  2. Set EnableViewState to False.

See Also

Tasks
How-to: Disable auto query handler
Walkthrough Topics
FAQ and How-to Topics

Concepts
New User Interface Features
User Interface Elements


How-to: Show error message when there is missing specification

How-to: Show error message when there is missing specification
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Show error message when there is missing specification

Glossary Item Box

By default, show error message is set to enable. However, you are also able to disable this error message.

In this topic, you will learn how to disable this property using designer.

To Disable show error message when there is missing specification

  1. Open WebCombo Designer - Advanced Settings.
  2. Set ShowErrorMessages to False.

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
ShowErrorMessages Property


How-to: Define tab index

How-to: Define tab index
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Define tab index

Glossary Item Box

If you have a lot of WebCombo controls in your page, you can define their tab index.

In this topic, you will learn how to set tab index from designer.

To Define tab index

  1. Open WebCombo Designer - Advanced Settings.
  2. Set TabIndex to 2.

See Also

Tasks
How-to: Define TextBox length
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
TabIndex Property


How-to: Define TextBox length

How-to: Define TextBox length
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Define TextBox length

Glossary Item Box

You can define TextBox length in WebCombo, so that user is not allowed to type more than the defined length.

In this topic, you will learn how to set TextBox length from designer.

To Define TextBox length

  1. Open WebCombo Designer - Advanced Settings.
  2. Set TextBoxLength to 10.

See Also

Tasks
How-to: Define access key
How-to: Define tab index
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
TextBoxLength Property


How-to: Disable auto data caching

How-to: Disable auto data caching
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Disable auto data caching

Glossary Item Box

By default, auto data caching is set to true. However, you can disable this property from designer.

In this topic, you will learn how to disable auto data caching.

To Show/Hide WebCombo using property

  1. Open WebCombo Designer - Advanced Settings.
  2. Set AllowAutoDataCaching to False.

See Also

Tasks
How-to: Disable auto query handler
How-to: Disable ViewState in WebCombo
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
AllowAutoDataCaching Property
DataCacheStorage Property


How-to: Use cached data on first load

How-to: Use cached data on first load
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Use cached data on first load

Glossary Item Box

By default, WebCombo will disable use cached data on first load. However, you can enable this feature from designer.

In this topic, you will learn how to enable use cached data on first load.

To use cached data on first load

  1. Open WebCombo Designer - Advanced Settings.
  2. Set UseCachedDataOnFirstLoad to True.

See Also

Tasks
How-to: Disable auto data caching
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
UseCachedDataOnFirstLoad Property


How-to: Disable WebResources

How-to: Disable WebResources
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Disable WebResources

Glossary Item Box

By default, WebResources is set to "auto" in WebCombo. However, you can disable this property from designer.

In this topic, you will learn how to disable WebResources.

To disable WebResources

  1. Open WebCombo Designer - Advanced Settings.
  2. Set EnableWebResources to Never.

See Also

Tasks
How-to: Disable auto query handler
How-to: Disable ViewState in WebCombo
How-to: Disable auto data caching
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
EnableWebResources Property


How-to: Adjust result box position

How-to: Adjust result box position
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Adjust result box position

Glossary Item Box

Sometimes you would like the result box's position to show in a different place. In order to do this, you need to adjust/set the result box position.

In this topic, you will learn how to adjust result box position from designer.

To adjust result box position

  1. Open WebCombo Designer - Advanced Settings - LayoutSettings.
  2. Set AdjustResultBoxLeft to 50.
  3. Set AdjustResultBoxTop to 0.

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
AdjustResultBoxLeft Property
AdjustResultBoxTop Property


How-to: Allow text to float on the right side of WebCombo

How-to: Allow text to float on the right side of WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Allow text to float on the right side of WebCombo

Glossary Item Box

Sometimes you would like to put text on the right side of WebCombo. By default, this feature is set to enable. However, you can disable this feature from designer.

In this topic, you will learn how to disable allow text to float on the right side of WebCombo.

To disable allow text to float on the right side of WebCombo

  1. Open WebComboDesigner - Advanced Settings - LayoutSettings.
  2. Set AllowFloatingText to False.

See Also

Tasks
How-to: Allow auto PostBack
How-to: Allow navigation on mouse wheel
How-to: Allow text wrapping to the next line
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
AllowFloatingText Property


How-to: Allow navigation on mouse wheel

How-to: Allow navigation on mouse wheel
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Allow navigation on mouse wheel

Glossary Item Box

By default, allow navigation on mouse wheel is set to true. However, you can disable this feature from designer.

In this topic, you will learn how to disable navigation on mouse wheel.

To disable allow navigation on mouse wheel

  1. Open WebCombo Designer - Advanced Settings - LayoutSettings.
  2. Set AllowNavigationOnMouseWheel to False.

See Also

Tasks
How-to: Adjust result box position
How-to: Allow text to float on the right side of WebCombo
How-to: Allow text wrapping to the next line
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
AllowNavigationOnMouseWheel Property


How-to: Allow text wrapping to the next line

How-to: Allow text wrapping to the next line
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Allow text wrapping to the next line

Glossary Item Box

Sometimes you would like to wrap WebCombo's text. By default, this feature is set to disable.

In this topic, you will learn how to allow text wrapping to the next line.

To Allow text wrapping to the next line

  1. Open WebCombo Designer - Advanced Settings - LayoutSettings.
  2. Set AllowTextWrapping to True.

See Also

Tasks
How-to: Allow text to float on the right side of WebCombo
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
AllowTextWrapping Property


How-to: Always show all rows on dropdown combo

How-to: Always show all rows on dropdown combo
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Always show all rows on dropdown combo

Glossary Item Box

By default, WebCombo will show only one value after you input a text such as Maria. However, you can show all rows on dropdown using designer.

In this topic, you will learn how to allow text wrapping to the next line.

To always show all rows on dropdown combo

  1. Open WebCombo Designer - Advanced Settings - LayoutSettings.
  2. Set AlwaysShowAllRowsOnDropdown to True.

See Also

Tasks
How-to: Always show column headers
How-to: Always show help button
How-to: Always show result box
How-to: Always show search button

Concepts
All-new, sleeker User Interface
User Interface Elements

References
AlwaysShowAllRowsOnDropdown Property


How-to: Always show column headers

How-to: Always show column headers
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Always show column headers

Glossary Item Box

By default, AlwaysShowColumnHeaders property is set to true. However, you can enable or disable this property from designer.

In this topic, you will learn how to show or hide the column headers.

To always show/hide column headers

  1. Open WebCombo Designer - Advanced Settings - LayoutSettings.
  2. Set AlwaysShowColumnHeaders to True in order to show column headers.
  3. Set AlwaysShowColumnHeaders to False in order to hide column headers.

See Also

Tasks
How-to: Always show all rows on dropdown combo
How-to: Always show help button
How-to: Always show result box
How-to: Always show search button
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
AlwaysShowColumnHeaders Property


How-to: Always show help button

How-to: Always show help button
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Always show help button

Glossary Item Box

By default, AlwaysShowHelpButton property is set to true. However, you can enable or disable this property using designer.

In this topic, you will learn how to show or hide the help button.

To always show/hide help button

  1. Open WebCombo Designer - Advanced Settings - LayoutSettings.
  2. Set AlwaysShowHelpButton to True in order to show the help button.
  3. Set AlwaysShowHelpButton to False in order to hide the help button.

See Also

Tasks
How-to: Always show all rows on dropdown combo
How-to: Always show column headers
How-to: Always show result box
How-to: Always show search button
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
AlwaysShowHelpButton Property


How-to: Always show result box

How-to: Always show result box
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Always show result box

Glossary Item Box

By default, AlwaysShowResultBox property is set to false. However, you can enable or disable this property from designer.

In this topic, you will learn how to show or hide the result box.

To always show/hide result box

  1. Open WebCombo Designer - Advanced Settings - LayoutSettings.
  2. Set AlwaysShowResultBox to True in order to show result box.
  3. Set AlwaysShowResultBox to False in order to hide result box.

See Also

Tasks
How-to: Always show all rows on dropdown combo
How-to: Always show column headers
How-to: Always show help button
How-to: Always show search button
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
AlwaysShowResultBox Property


How-to: Always show search button

How-to: Always show search button
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Always show search button

Glossary Item Box

By default, AlwaysShowSearchButton property is set to true. However, you can enable or disable this property from designer.

In this topic, you will learn how to show or hide the search button.

To always show/hide search button

  1. Open WebCombo Designer - Advanced Settings - LayoutSettings.
  2. Set AlwaysShowSearchButton to True in order to show search button.
  3. Set AlwaysShowSearchButton to False in order to hide search button.

See Also

Tasks
How-to: Always show all rows on dropdown combo
How-to: Always show column headers
How-to: Always show help button
How-to: Always show result box
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
AlwaysShowSearchButton Property


How-to: Set default column width

How-to: Set default column width
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Set default column width

Glossary Item Box

By default, the column's width of each combo is 100px. However, you can set this property from designer.

In this topic, you will learn how to set the default combo's width.

To set default column width

  1. Open WebCombo Designer - Advanced Settings - LayoutSettings.
  2. Set ColumnWidthDefault to 150px.

See Also

Tasks
How-to: Set combo's alignment to be right displayed
Walkthrough Topics
FAQ and How-to Topics}

Concepts
All-new, sleeker User Interface
User Interface Elements

References
ColumnWidthDefault Property


How-to: Enable/Disable animation

How-to: Enable/Disable animation
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Enable/Disable animation

Glossary Item Box

By default, EnableAnimation property is set to false. However, you can enable this property from designer.

In this topic, you will learn how to enable/disable animation.

To enable/disable animation

  1. Open WebCombo Designer - Advanced Settings - LayoutSettings.
  2. Set EnableAnimation to True in order to enable animation.
  3. Set EnableAnimation to False in order to disable animation.

See Also

Tasks
How-to: Enable Round Corner in WebCombo.NET 4.0
How-to: Enable Default Style for existing instance of WebCombo
How-to: Enable/Disable WebCombo
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
EnableAnimation Property


How-to: Define the help image

How-to: Define the help image
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Define the help image

Glossary Item Box

By default, HelpImage property is pointed to wc4_help.gif. However, you can change this property's value from designer.

In this topic, you will learn how to change the help image.

To define help image

  1. Open WebCombo Designer - Advanced Settings - LayoutSettings.
  2. Set HelpImage to other image file.

See Also

Tasks
How-to: Define help URL
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
HelpImage Property


How-to: Define help URL

How-to: Define help URL
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Define help URL

Glossary Item Box

By default, HelpURL is set to blank/empty. You can set this property to define the help URL from designer.

In this topic, you will learn how to define the help URL.

To define the help URL

  1. Open WebCombo Designer - Advanced Settings - LayoutSettings.
  2. Set HelpURL property to a URL path.

See Also

Tasks
How-to: Define the help image
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
HelpURL Property


How-to: Define the row's height

How-to: Define the row's height
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Define the row's height

Glossary Item Box

By default, the row's height is set to 20px. You can set this property to another value from designer.

In this topic, you will learn how to set the row's height.

To define the row's height

  1. Open WebCombo Designer - Advanced Settings - LayoutSettings.
  2. Set ItemHeight property to 25px.

See Also

Tasks
How-to: Define the result box's height and width
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
ItemHeight Property


How-to: Define the action when no result is found in WebCombo

How-to: Define the action when no result is found in WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Define the action when no result is found in WebCombo

Glossary Item Box

By default, NoResultFoundAction property is set to RevertCollection. You can set this property to another value from designer.

In this topic, you will learn how to define action when no result is found.

To define the action when no result is found

  1. Open WebCombo Designer - Advanced Settings - LayoutSettings.
  2. Set NoResultFoundAction property to FocusAndShowResultBox.

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
NoResultFoundAction Property


How-to: Define the result box's height and width

How-to: Define the result box's height and width
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Define the result box's height and width

Glossary Item Box

By default, ResultBoxHeight and ResultBoxWidth properties are set to 200 and 0 respectively. You can set these properties to other values from designer.

In this topic, you will learn how to define the result box's height and width.

To define the result box's height and width

  1. Open WebCombo Designer - Advanced Settings - LayoutSettings.
  2. Set ResultBoxHeight property to 250.
  3. Set ResultBoxWidth property to 100.

See Also

Tasks
How-to: Define TextBox length
How-to: Define the row's height
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
ResultBoxHeight Property
ResultBoxWidth Property


How-to: Show the result box's shadow

How-to: Show the result box's shadow
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Show the result box's shadow

Glossary Item Box

By default, the result box's shadow is set to true. You can set this property to another value from designer.

In this topic, you will learn how to hide the result box's shadow.

To show/hide the result box's shadow

  1. Open WebCombo Designer - Advanced Settings - LayoutSettings.
  2. Set ResultBoxShadow property to False in order to hide result box's shadow.
  3. Set ResultBoxShadow property to True in order to show result box's shadow.

See Also

Tasks
How-to: Show/Hide WebCombo
How-to: Show error message when there is missing specification
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
ResultBoxWindowType Property


How-to: Position search box on the left

How-to: Position search box on the left
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Position search box on the left

Glossary Item Box

By default, the search button's position is set to right. You can set this property to another value from designer.

In this topic, you will learn how to define the position of search button.

To position search box on the left

  1. Right click on the WebCombo instance and select WebCombo Designer.
  2. Select Advanced Settings - LayoutSettings.
  3. Set SearchButtonPosition to Left.
  4. Run the project.

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
SearchButtonPosition Property


How-to: Use round corner in WebCombo

How-to: Use round corner in WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Use round corner in WebCombo

Glossary Item Box

WebCombo provides you the ability to use round corner.

This topic will show you how to use round corner in WebCombo.

To use round corner in WebCombo

  1. Right click on the WebCombo instance and select WebCombo Designer.
  2. Set RoundCorner to True in Advanced Settings - LayoutSettings.
  3. Run the project.

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
RoundCorner Property


How-to: Define the search image

How-to: Define the search image
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Define the search image

Glossary Item Box

By default, search icon mode is set to text. However, you can set this property to image from designer.

In this topic, you will learn how to set the search icon to graphic.

To how to set the search icon to graphic

  1. Open WebCombo Designer - Advanced Settings - LayoutSettings.
  2. Set SearchIconMode property to Graphic.
  3. Set SearchImage property to an image file name.

See Also

Tasks
How-to: Define the help image
How-to: Define the position of status bar
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
SearchImage Property
SearchIconMode Property


How-to: Define the position of status bar

How-to: Define the position of status bar
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Define the position of status bar

Glossary Item Box

In WebCombo, you can change the search box to the left side.

This topic will show you how to Set SearchButtonPosition to Left from designer.

To use search box on the left

  1. Right click on the WebCombo instance and select WebCombo Designer.
  2. Set SearchButtonPosition to Left in Advanced Settings - LayoutSettings.
  3. Run the project.

See Also

Tasks
How-to: Position search box on the left
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
SearchButtonPosition Property


How-to: Hide/Show the status box

How-to: Hide/Show the status box
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Hide/Show the status box

Glossary Item Box

By default, the status box's visibility is set to true. You can set this property to false from designer.

In this topic, you will learn how to define the status box's visibility.

To hide/show the status box

  1. Open WebCombo Designer - Advanced Settings - LayoutSettings.
  2. Set StatusBoxVisibility property to False in order to hide status box.
  3. Set StatusBoxVisibility property to True in order to show status box.

See Also

Tasks
How-to: Hide and show dropdown combo
How-to: Show/Hide WebCombo
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
StatusBoxVisible Property


How-to: Set the TextBox mode in WebCombo

How-to: Set the TextBox mode in WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Set the TextBox mode in WebCombo

Glossary Item Box

In WebCombo, you can set the TextBox mode to Editable or ReadOnly.

This topic will show you how to set TextBox mode using designer.

To set the TextBox mode in WebCombo

  1. Right click on the WebCombo instance and select WebCombo Designer.
  2. Set TextBoxMode to ReadOnly in Advanced Settings - LayoutSettings.
  3. Click OK to apply the changes.

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
TextBoxMode Property


How-to: Define XHTML search image

How-to: Define XHTML search image
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Define XHTML search image

Glossary Item Box

By default, the XHTML search image is set to arrow_black.gif. However, you can set this property's value to other image file.

In this topic, you will learn how to set the XHTML search image using designer.

To define XHTML search image

  1. Open WebCombo Designer - Advanced Settings - LayoutSettings.
  2. Set XHTMLSearchImage property to other image file.

See Also

Tasks
How-to: Define the help image
How-to: Define the search image
How-to: Define help URL
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
XhtmlSearchImage Property


How-to: Get the hidden cell's value of the selected row

How-to: Get the hidden cell's value of the selected row
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Get the hidden cell's value of the selected row

Glossary Item Box

By default, RenderOnHidden property is set to false. However, you can set this property to true to render the column on hidden.

In this topic, you will learn how to set the RenderOnHidden property using designer.

To get the render on hidden property on WebCombo

  1. Open WebCombo Designer - Columns and Rows.
  2. Set RenderOnHidden property to True from appropriate column.

See Also

Tasks
How-to: Get the text of the selected row in WebCombo
How-to: Get the value of the selected row in WebCombo
How-to: Get the selected row
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
User Interface Elements

References
RenderOnHidden Property


How-to: Set combo's alignment to be right displayed

How-to: Set combo's alignment to be right displayed
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Set combo's alignment to be right displayed

Glossary Item Box

In WebCombo, you can set the combo's alignment to be right displayed.

This topic will show you how to display combo to the right side of the page.

To set combo's alignment to be right displayed

  1. Right click on the WebCombo instance and select WebCombo Designer.
  2. On the Advanced Settings >> LayoutSettings >> TextBoxStyle >> Active >> HorizontalAlign to Right.
  3. On the Advanced Settings >> LayoutSettings >> TextBoxStyle >> Normal >> HorizontalAlign to Right.
  4. On the Advanced Settings >> LayoutSettings >> TextBoxStyle >> Over >> HorizontalAlign to Right.
  5. On the Advanced Settings >> LayoutSettings >> ResultBoxStyle >>HorizontalAlign to Right
  6. Run the project.

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

References
TextBoxMode Property
TextBoxStyle Property


How-to: Use AdditionalSearchField to search a query text on other column besides DataTextField column

How-to: Use AdditionalSearchField to search a query text on other column besides DataTextField column
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Use AdditionalSearchField to search a query text on other column besides DataTextField column

Glossary Item Box

When you want to search for word that is not existed in DataTextField column, you can set AdditionalSearchField to specific columns. Therefore, the combo will search for the word in those columns.

This topic will show you how to use AdditionalSearchField from designer.

To set AdditionalSearchField

  1. Right click on the WebCombo instance and select WebCombo Designer.
  2. Set AdditionalSearchField to ContactName, City, Country in Advanced Settings.
  3. You can also set AdditionalSearchField from server-side like following:

    C# Copy Image Copy Code
    protected void WebCombo1_InitializeLayout(object sender, ISNet.WebUI.WebCombo.LayoutEventArgs e)
{
   e.Layout.ComboMode = Mode.MultipleColumns;
   WebCombo1.AdditionalSearchFields = "ContactName, City, Country";
}

  4. Run the project.

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

References
AdditionalSearchFields Property


How-to: Set minimum character typed to request the data

How-to: Set minimum character typed to request the data
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Set minimum character typed to request the data

Glossary Item Box

To narrow-down large-results DataSource, WebCombo offers a feature called MinCharsToRequest.

This topic will show you how to set MinCharsToRequest property from designer.

To set minimum character typed to request

  1. Right click on the WebCombo instance and select WebCombo Designer.
  2. Set MinCharsToRequest to 3 in Advanced Settings.
  3. Run the project.

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

References
MinCharsToRequest Property


How-to: Enable wildcard search

How-to: Enable wildcard search
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > User Interface Customization How-to Topics > How-to: Enable wildcard search

Glossary Item Box

Wildcard search is a feature that allows wildcard/fuzzy logic searching.

This topic will show you how to enable wildcard search from designer.

To enable wildcard search

  1. Right click on the WebCombo instance and select WebCombo Designer.
  2. Set AllowWildCardSearch to True in Advanced Settings.
  3. Run the project.

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

References
AllowWildCardSearch Property


Dynamically Add Item How-to Topics

Dynamically Add Item How-to Topics
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Dynamically Add Item How-to Topics

Glossary Item Box

The topics in this section describe how to achieve common add item tasks.

In This Section

How-to: Allow AddItem in WebCombo

How-to: Add item in bound WebCombo

How-to: Add item in unbound WebCombo from server side

How-to: Add item in unbound WebCombo from client side

How-to: Use OnAddItem client side event to validate input

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

References
AllowAddItem Property


How-to: AlowAddItem in WebCombo

How-to: AlowAddItem in WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Dynamically Add Item How-to Topics > How-to: AlowAddItem in WebCombo

Glossary Item Box

In WebCombo, you are able to add new item in WebCombo.

This topic will show you how to set AllowAddItem using designer.

To set AllowAddItem in WebCombo

  1. Drag WebCombo instance to the page.
  2. Right click on the WebCombo instance and select WebCombo Designer.
  3. Set AllowAddItem to True in Advanced Settings - Layoutsettings.
  4. Run the project.

    See Also

    Tasks
    How-to: Add item in bound WebCombo
    How-to: Add item in unbound WebCombo from server side
    How-to: Add item in unbound WebCombo from client side
    How-to: Use OnAddItem client side event to validate input
    FAQ: How to implement adding item in WebCombo when we set AllowAutoPostBack and AllowAddItem to true

    Concepts
    Dynamically Add Item

    References
    AllowAddItem Property


How-to: Add item in bound WebCombo

How-to: Add item in bound WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Dynamically Add Item How-to Topics > How-to: Add item in bound WebCombo

Glossary Item Box

In WebCombo, you are able to add new item in WebCombo.

This topic will show you how to Add Item in bound WebCombo.

To add Item in bound WebCombo

  1. Set AllowAddItem in WebCombo.
  2. Drag AccessDataSource control to the page.
  3. Click the AccessDataSource instance and press F4.
  4. Set EnableCaching to True from the properties box.
  5. On the WebCombo's AddItem event handler, put the following code :

    C# Copy Image Copy Code
    protected void WebCombo1_AddItem(object sender, ISNet.WebUI.WebCombo.RowEventArgs e)
{
   // get cached data from data source control
   DataView view = this.EmployeeDataSource.Select(DataSourceSelectArguments.Empty) as DataView;

   // update the cached data
   DataTable table = view.Table;
   DataRow newRow = table.NewRow();
   newRow["FirstName"] = e.Row.Value;
   table.Rows.Add(newRow);
}

  6. Run the project.

    See Also

    Tasks
    How-to: Add item in unbound WebCombo from server side
    How-to: Add item in unbound WebCombo from client side
    How-to: Use OnAddItem client side event to validate input
    FAQ: How to implement adding item in WebCombo when we set AllowAutoPostBack and AllowAddItem to true?

    Concepts
    Dynamically Add Item

    References
    AddItem Event


How-to: Use OnAddItem client side event to validate input

How-to: Use OnAddItem client side event to validate input
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Dynamically Add Item How-to Topics > How-to: Use OnAddItem client side event to validate input

Glossary Item Box

In WebCombo, you can use OnAddItem Client-side event to validate input.

This topic will show you how to use OnAddItem client side event.

To validate input using OnAddItem Client-side event

  1. Right click the WebCombo instance and choose WebCombo.NET Designer.
  2. Set OnAddItem to "DoAdd" in Advanced Settings - LayoutSettings - ClientSideEvents.
  3. In HTML view, put the following function:

    JavaScript Copy Image Copy Code
    function DoAdd(controlId)
{
    var combo = ISGetObject(controlId);
    if(combo.TextObj.value == "Brad")
    {
       return True;
    }
    else
    {
       return false;
    }
}

  4. Run the project.

See Also

Tasks
How-to: AlowAddItem in WebCombo
How-to: Add item in bound WebCombo
How-to: Add item in unbound WebCombo from server side
How-to: Add item in unbound WebCombo from client side
FAQ: How to implement adding item in WebCombo when we set AllowAutoPostBack and AllowAddItem to true?

Concepts
Dynamically Add Item

References
ClientEvents Class
OnAddItem Property


Validation How-to Topics

Validation How-to Topics
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Validation How-to Topics

Glossary Item Box

WebCombo supports .NET's control validation, means that it is compatible with all Validators control such as RequiredFieldValidator. You can easily create a validation simply by dropping a validator control from toolbox into your webform and set its ControlToValidate property to the WebCombo object you want to validate.

In This Section

How-to: Use RequiredFieldValidator to ensure the WebCombo cannot be empty

How-to: Implement WebCombo and RequiedFieldValidator in Web User Control

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics


Styles How-to Topics

Styles How-to Topics
Send Feedback

Glossary Item Box

The topics in this section describe how to achieve common styles tasks.

In This Section

How-to: Position search box on the left

How-to: Use round corner in WebCombo

How-to: Use WebCombo without search button


How-to: Use RequiredFieldValidator to ensure the WebCombo cannot be empty

How-to: Use RequiredFieldValidator to ensure the WebCombo cannot be empty
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Validation How-to Topics > How-to: Use RequiredFieldValidator to ensure the WebCombo cannot be empty

Glossary Item Box

In WebCombo, you can Use RequiredFieldValidator to ensure the webcombo cannot be empty.

This topic will show you how toUse RequiredFieldValidator to ensure the webcombo cannot be empty.

To use RequiredFieldValidator to ensure WebCombo cannot be empty

  1. Drag RequiredFieldValidator control to the page.
  2. Click the RequiredFieldValidator instance and press F4.
  3. Set ControlToValidate to WebCombo1.
  4. Set ErrorMessage to Please select an item.
  5. Run the project.

See Also

Tasks
How-to: Implement WebCombo and RequiredFieldValidator in Web User Control
Walkthrough Topics
FAQ and How-to Topics

Concepts
Validation


How-to: Implement WebCombo and RequiredFieldValidator in Web User Control

How-to: Implement WebCombo and RequiredFieldValidator in Web User Control
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Validation How-to Topics > How-to: Implement WebCombo and RequiredFieldValidator in Web User Control

Glossary Item Box

In WebCombo, you can implement WebCombo and Required Validator in Web User Control.

This topic will show you how to perform the scenario above.

To implement WebCombo and Required Validator in Web User Control

  1. Create a new Web User Control and leave the name as it is.
  2. Drag WebCombo control from the toolbox to the web user control.
  3. Fill the WebCombo with unbound data.
  4. Drag a RequiredFieldValidator control from the toolbox to the right side of the WebCombo's instance.
  5. Set its ControlToValidate to WebCombo1.
  6. Create a new WebForm and named it as WebUserControlHost.aspx.
  7. Drag the WebUserControl1.ascx from the Solution Explorer to the WebForm page.
  8. Run the project.

See Also

Tasks
How-to: Use RequiredFieldValidator to ensure the WebCombo cannot be empty
Walkthrough Topics
FAQ and How-to Topics

Concepts
Validation


Column Types How-to Topics

Column Types How-to Topics
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Column Types How-to Topics

Glossary Item Box

The topics in this section describe how to achieve common Column Types tasks.

In This Section

How-to: Utilize text ColumnType

How-to: Utilize image ColumnType

How-to: Utilize ImageAndText ColumnType

How-to: Utilize custom ColumnType

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

References
ColumnType Property
InitializeRow Event


How-to: Customize Column Types

How-to: Customize Column Types
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Column Types How-to Topics > How-to: Customize Column Types

Glossary Item Box

In WebCombo, you can set the ColumnType to many types.

This topic will show you how to customize several ColumnTypes.

To customize ColumnType to text

  1. Right click on the WebCombo instance and select WebCombo Designer.
  2. Choose QuickStart - Column and Rows and select one of the column.
  3. Set ColumnType to Text.
  4. Run the project.

To utilize ColumnType to image

  1. Right click on the WebCombo instance and select WebCombo Designer.
  2. Choose QuickStart - Column and Rows and select one of the column.
  3. Set ColumnType to Image.
  4. In WebCombo's InitializeRow events, put the following code:

    C# Copy Image Copy Code
    private void WebCombo1_InitializeRow(object sender, ISNet.WebUI.WebCombo.RowEventArgs e)
{
 e.Row.Cells.GetNamedItem("Column1").Image = "Images/" + e.Row.Cells.GetNamedItem("FirstName").Text + ".jpg";
 e.Row.Cells.GetNamedItem("Column1").CustomObjectAttributes = "height=20px width=10px";
}

  5. Run the project.

To utilize ColumnType to ImageAndText

  1. Right click on the WebCombo instance and select WebCombo Designer.
  2. Choose QuickStart - Column and Rows and select one of the column.
  3. Set ColumnType to ImageAndText.
  4. Set CellImage to any image file. For example: "Images/customer.gif".
  5. Run the project.

To utilize ColumnType to Custom

  1. Right click on the WebCombo instance and select WebCombo Designer.
  2. On the QuickStart - Column and Rows and select one of the column.
  3. Set ColumnType to Custom.
  4. Run the project.

See Also

Tasks
How-to: Utilize text ColumnType
How-to: Utilize image ColumnType
How-to: Utilize ImageAndText ColumnType

Concepts
Column Types How-to Topics


How-to: Utilize text ColumnType

How-to: Utilize text ColumnType
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Column Types How-to Topics > How-to: Utilize text ColumnType

Glossary Item Box

In WebCombo, you can set the ColumnType to many types.

This topic will show you how to utilize ColumnType to text.

To utilize ColumnType to text

  1. Right click on the WebCombo instance and select WebCombo Designer.
  2. Choose QuickStart - Column and Rows and select one of the column.
  3. Set ColumnType to Text.
  4. Run the project.

See Also

Tasks
How-to: Utilize image ColumnType
How-to: Utilize ImageAndText ColumnType
How-to: Utilize custom ColumnType

Concepts
Column Types

References
ColumnType Property


How-to: Utilize image ColumnType

How-to: Utilize image ColumnType
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Column Types How-to Topics > How-to: Utilize image ColumnType

Glossary Item Box

In WebCombo, you can set the ColumnType to many types.

This topic will show you how to utilize ColumnType to image.

To utilize ColumnType to image

  1. Right click on the WebCombo instance and select WebCombo Designer.
  2. Choose QuickStart - Column and Rows and select one of the column.
  3. Set ColumnType to Image.
  4. In WebCombo's InitializeRow events, put the following code:

    C# Copy Image Copy Code
    private void WebCombo1_InitializeRow(object sender, ISNet.WebUI.WebCombo.RowEventArgs e)
{
 e.Row.Cells.GetNamedItem("Column1").Image = "Images/" + e.Row.Cells.GetNamedItem("FirstName").Text + ".jpg";
 e.Row.Cells.GetNamedItem("Column1").CustomObjectAttributes = "height=20px width=10px";
}

  5. Run the project.

See Also

Tasks
How-to: Utilize text ColumnType
How-to: Utilize ImageAndText ColumnType
How-to: Utilize custom ColumnType

Concepts
Column Types

References
InitializeRow Event
ColumnType Property


How-to: Utilize ImageAndText ColumnType

How-to: Utilize ImageAndText ColumnType
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Column Types How-to Topics > How-to: Utilize ImageAndText ColumnType

Glossary Item Box

In WebCombo, you can set the ColumnType to many types.

This topic will show you how to utilize ColumnType to ImageAndText.

To utilize ColumnType to ImageAndText

  1. Right click on the WebCombo instance and select WebCombo Designer.
  2. Choose QuickStart - Column and Rows and select one of the column.
  3. Set ColumnType to ImageAndText.
  4. Set CellImage to any image file. For example: "Images/customer.gif".
  5. Run the project.

See Also

Tasks
How-to: Utilize text ColumnType
How-to: Utilize image ColumnType
How-to: Utilize custom ColumnType

Concepts
Column Types


How-to: Utilize custom ColumnType

How-to: Utilize custom ColumnType
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Column Types How-to Topics > How-to: Utilize custom ColumnType

Glossary Item Box

In WebCombo, you can set the ColumnType to many types.

This topic will show you how to utilize ColumnType to Custom.

To utilize ColumnType to Custom

  1. Right click on the WebCombo instance and select WebCombo Designer.
  2. On the QuickStart - Column and Rows and select one of the column.
  3. Set ColumnType to Custom.
  4. Run the project.

See Also

Tasks
How-to: Utilize text ColumnType
How-to: Utilize image ColumnType
How-to: Utilize ImageAndText ColumnType

Concepts
Column Types

References
ColumnType Property


Client-side Programming How-to Topics

Client-side Programming How-to Topics
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Client-side Programming How-to Topics

Glossary Item Box

The topics in this section describe how to achieve common client-side programming tasks.

In This Section

How-to: Filter the data in WebCombo using SetAdditionalFilter method

How-to: Clear the AdditionalFilter applied to WebCombo

How-to: Get the text of the selected row in WebCombo

How-to: Get the value of the selected row in WebCombo

How-to: Set selected row in bound WebCombo

How-to: Set selected row in unbound WebCombo

How-to: Get total retrieved rows in WebCombo

How-to: Get total rows in WebCombo

How-to: Hide and show dropdown combo

How-to: Modify the first cell of the first row in unbound WebCombo

How-to: Delete a row in unbound WebCombo

How-to: Perform batch update in unbound WebCombo

How-to: Get the selected row

How-to: Use OnAddItem client side event to validate input

How-to: Refresh WebCombo

How-to: Get/Set the TextBox value

How-to: Get the number of rows in WebCombo

How-to: Get specific row by its index

How-to: Enable/Disable WebCombo

How-to: Show/Hide WebCombo

How-to: Set focus on WebCombo

How-to: Get the text and value of multiple selection WebCombo

How-to: Get WebCombo instance

How-to: Display the result box to the right side of WebCombo

How-to: Trigger OnTheFlyPost from client side

How-to: Set the value of another controls in OnAfterItemSelected client side events

How-to: Validate string only input in OnKeyDown client side events

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics


How-to: Manipulate data in rows and cells

How-to: Manipulate data in rows and cells
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Client-side Programming How-to Topics > How-to: Manipulate data in rows and cells

Glossary Item Box

In WebCombo, you can manipulate data such as adding, deleting and updating from client-side.

This topic will show you how to add item, delete row and perform batch update in unbound WebCombo.

To add item in unbound WebCombo from client side

  1. Drag HTML Button to the page.
  2. Add the following function in client side:

    JavaScript Copy Image Copy Code
    function AddItem()
{
   var wc4 = ISGetObject("WebCombo1");
   var rows = wc4.GetRows(); // get the WebCombo4's rows for addition
   var newRow = wc4.NewRow("NEWCUST2"); // instantiate new row with NEWCUST as the KeyValue, containing cells with empty value
   var cells = newRow.GetCells(); // get the cells of the new row for value assignment

   // addition
   cells.GetNamedItem("ContactName").Text = "New Customer2"; // write codes in the same way as in server-side object model, with similar object hierarchy.
   cells.GetNamedItem("Address").Text = "New Address2"; // assign value to Address Cell
   cells.GetNamedItem("CustomerID").Text = "NEWCUST2";
   rows.Add(newRow); //add the newRow to the rows collection

   // modification
   cells = rows[1].GetCells();
   cells[0].Text = "Changed Text"; // modify the text
   rows[1].SetChanged();

   // update all changes now
   wc4.UpdateUI();
}

  3. Next, add onclick ="test()" on the HTML Button's tag like following:

    <input id="Button1" type="button" value="Test" onclick="test()" />

  4. Run the project.

To delete a row in unbound WebCombo

  1. Go to HTML view and add the following code:

    JavaScript Copy Image Copy Code
    function DeleteRow()
{
   var WebCombo1 = ISGetObject("WebCombo1");
   var rows = WebCombo1.GetRows();
   rows.Remove(rows[0], true); //remove row 0 from Rows collection, 2nd parameter must always be set to true
   WebCombo1.UpdateUI();
   alert("Row 0 removed!");
}

  2. Invoke DeleteRow() function by adding the following code:

    <input id="Button1" type="button" value="Delete Row" onclick="DeleteRow()" />

To perform batch update in unbound WebCombo

  1. Set WebCombo to unbound mode.
  2. Go to HTML view and add the following code:

    JavaScript Copy Image Copy Code
    function BatchUpdate()
{
   var WebCombo1 = ISGetObject("WebCombo1");
   var firstRow= WebCombo1.GetRows()[0]; // get the WebCombo1's rows
   var firstCell = firstRow.GetCells()[0];
   firstCell.Text = "Changed Text"; // modify the text
   firstRow.SetChanged();
   WebCombo1.UpdateUI();
   alert("Batch Update done!");
}

  3. Invoke BatchUpdate() function by adding the following code:

    <input id="Button1" type="button" value="Update" onclick="BatchUpdate()" />

See Also

Tasks
How-to: Filter the data in WebCombo using SetAdditionalFilter method
How-to: Clear the AdditionalFilter applied to WebCombo

Concepts
Client-side Programming How-to Topics


How-to: Filter the data in WebCombo using SetAdditionalFilter method

How-to: Filter the data in WebCombo using SetAdditionalFilter method
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Client-side Programming How-to Topics > How-to: Filter the data in WebCombo using SetAdditionalFilter method

Glossary Item Box

WebCombo provides a client side method to filter the data in Client-side event.

In this topic, you will learn how to use SetAdditionalFilter method.

To filter the data in WebCombo using SetAdditionalFilter method

  1. Bind WebCombo to AccessDataSource.
  2. Drag a HTML button and leave the Id as it is, which is Button1.
  3. Double click the HTML button and add the following code in the defined client side event handler:

    JavaScript Copy Image Copy Code
    function Button1_onclick()
{
   var WebCombo1 = ISGetObject("WebCombo1");
   var customer = "ANTON";
   WebCombo1.SetAdditionalFilters("[CustomerID] = '" + customer + "'");
}

  4. Run the project.

See Also

Tasks
How-to: Clear the AdditionalFilter applied to WebCombo
Walkthrough Topics
FAQ and How-to Topics

Concepts
Extensible Client side Programming


How-to: Clear the AdditionalFilter applied to WebCombo

How-to: Clear the AdditionalFilter applied to WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Client-side Programming How-to Topics > How-to: Clear the AdditionalFilter applied to WebCombo

Glossary Item Box

WebCombo provides a client side method to clear AdditionalFilter in Client-side event.

In this topic, you will learn how to clear the AdditionalFilter.

To clear the AdditionalFilter applied to WebCombo

  1. Drag a HTML button and leave the Id as it is, which is Button1.
  2. Double click the HTML button and add the following code in the defined Client-side event handler:

    JavaScript Copy Image Copy Code
    function Button1_onclick()
{
   var WebCombo1 = ISGetObject("WebCombo1");
   WebCombo1.ClearAdditionalFilters();
}

  3. Run the project.

See Also

Tasks
How-to: Filter the data in WebCombo using SetAdditionalFilter method
Walkthrough Topics
FAQ and How-to Topics

Concepts
Extensible Client side Programming


How-to: Get the text of the selected row in WebCombo

How-to: Get the text of the selected row in WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Client-side Programming How-to Topics > How-to: Get the text of the selected row in WebCombo

Glossary Item Box

WebCombo provides a client side method to get the text from the selected row.

In this topic, you will learn how to use GetTextBoxValue method.

To get the text of the selected row in WebCombo

  1. Drag a HTML button and leave the Id as it is, which is Button1.
  2. Double click the HTML button and add the following code in the defined client side event handler:

    JavaScript Copy Image Copy Code
    function Button1_onclick()
{
   var WebCombo1 = ISGetObject("WebCombo1");
   var result = WebCombo1.GetTextBoxValue();
   alert(result);
}

  3. Run the project.

See Also

Tasks
How-to: Get the value of the selected row in WebCombo
Walkthrough Topics
FAQ and How-to Topics

Concepts
Extensible Client side Programming


How-to: Get the value of the selected row in WebCombo

How-to: Get the value of the selected row in WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Client-side Programming How-to Topics > How-to: Get the value of the selected row in WebCombo

Glossary Item Box

WebCombo provides a client side method to get the value from the selected row.

In this topic, you will learn how to use Value method.

To get the value of the selected row in WebCombo

  1. Drag a HTML button and leave the Id as it is, which is Button1.
  2. Double click the HTML button and add the following code in the defined Client-side event handler:

    JavaScript Copy Image Copy Code
    function Button1_onclick()
{
   var WebCombo1 = ISGetObject("WebCombo1");
   var result = WebCombo1.Value
   alert(result);
}

  3. Run the project.

See Also

Tasks
How-to: Get the text of the selected row in WebCombo
Walkthrough Topics
FAQ and How-to Topics

Concepts
Extensible Client side Programming


How-to: Set selected row in bound WebCombo

How-to: Set selected row in bound WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Client-side Programming How-to Topics > How-to: Set selected row in bound WebCombo

Glossary Item Box

WebCombo provides a Client-side method to set selected row in bound WebCombo.

In this topic, you will learn how to use SetText and LoadValue methods.

To set selected row in bound WebCombo

  1. Drag a HTML button and leave the Id as it is, which is Button1.
  2. Double click the HTML button and add the following code in the defined Client-side event handler:

    JavaScript Copy Image Copy Code
    function Button1_onclick()
{
   var WebCombo1 = ISGetObject("WebCombo1");
   WebCombo1.SetText("Maria Anders");
   WebCombo1.LoadValue();
}

  3. Run the project.

See Also

Tasks
How-to: Set selected row in unbound WebCombo
Walkthrough Topics
FAQ and How-to Topics

Concepts
Extensible Client side Programming


How-to: Get total retrieved rows in WebCombo

How-to: Get total retrieved rows in WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Client-side Programming How-to Topics > How-to: Get total retrieved rows in WebCombo

Glossary Item Box

In WebCombo, you can get the total retrieved rows.

In this topic, you will learn how to use TotalRetrievedRows method.

To get total retrieved rows in WebCombo

  1. Drag a HTML button and leave the Id as it is, which is Button1.
  2. Double click the HTML button and add the following code in the defined client side event handler:

    JavaScript Copy Image Copy Code
    function Button1_onclick()
{
   var WebCombo1 = ISGetObject("WebCombo1");
   var result = WebCombo1.TotalRetrievedRows;
   alert(result);
}

  3. Run the project.

See Also

Tasks
How-to: Get total rows in WebCombo
Walkthrough Topics
FAQ and How-to Topics

Concepts
Extensible Client side Programming


How-to: Get total rows in WebCombo

How-to: Get total rows in WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Client-side Programming How-to Topics > How-to: Get total rows in WebCombo

Glossary Item Box

WebCombo provides a method in client side to get the total rows.

In this topic, you will learn how to use TotalRows method.

To get total rows in WebCombo

  1. Drag a HTML button and leave the Id as it is, which is Button1.
  2. Double click the HTML button and add the following code in the defined Client-side event handler:

    JavaScript CopyHover Image Copy Code
    function Button1_onclick()
{
   var WebCombo1 = ISGetObject("WebCombo1");
   var result = WebCombo1.TotalRows;
   alert(result)
}

  3. Run the project.

See Also

Tasks
How-to: Get total retrieved rows in WebCombo
Walkthrough Topics
FAQ and How-to Topics

Concepts
Extensible Client side Programming


How-to: Hide and show dropdown combo

How-to: Hide and show dropdown combo
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Client-side Programming How-to Topics > How-to: Hide and show dropdown combo

Glossary Item Box

WebCombo provide a method in client side to hide and show dropdown combo.

In this topic, you will learn how to hide and show dropdown

To show dropdown combo

  1. Drag a HTML button and leave the Id as it is, which is Button1.
  2. Double click the HTML button and add the following code in the defined client side event handler:

    JavaScript Copy Image Copy Code
    function Button1_onclick()
{
   var WebCombo1 = ISGetObject("WebCombo1");
   WebCombo1.SetFocus();
   WebCombo1.ShowDropDown();
}

  3. Run the project.

To hide dropdown combo

  1. Drag a HTML button and leave the Id as it is, which is Button1.
  2. Double click the HTML button and add the following code in the defined client side event handler:

    JavaScript Copy Image Copy Code
    function HideDropDown()
{
   var WebCombo1 = ISGetObject("WebCombo1");
   WebCombo1.SetFocus();
   WebCombo1.HideDropDown();
}

  3. Run the project.

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

Concepts
{Extensible Client side Programming}


How-to: Get the selected row

How-to: Get the selected row
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Client-side Programming How-to Topics > How-to: Get the selected row

Glossary Item Box

WebCombo provides a method to get the selected row's object in combo.

In this topic, you will learn how to use GetSelectedRow and rowIndex methods.

To perform batch update in unbound WebCombo

  1. Drag a HTML button and leave the Id as it is, which is Button1.
  2. Double click the HTML button and add the following code in the defined Client-side event handler:

    JavaScript Copy Image Copy Code
    function Button1_onclick()
{
   var WebCombo1 = ISGetObject("WebCombo1");
   var rowObj = WebCombo1.GetSelectedRow();
   var rowIndex = rowObj.rowIndex;
   alert("Row Index : " + rowIndex);
}

  3. Run the project.

See Also

Tasks
How-to: Get the text of the selected row in WebCombo
{How-to: Get the value of the selected row in WebCombo}
{How-to: Get total retrieved rows in WebCombo}
{How-to: Get total rows in WebCombo}

Concepts
{Extensible Client side Programming}


How-to: Set initial value of multiple selection WebCombo from client side

How-to: Set initial value of multiple selection WebCombo from client side
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Client-side Programming How-to Topics > How-to: Set initial value of multiple selection WebCombo from client side

Glossary Item Box

In multiple selection mode, you can set initial value from client side.

In this topic, you will learn how to use SetMultipleValues method.

To set initial value of multiple selection WebCombo from Client-side

  1. Drag a HTML button and leave the Id as it is, which is Button1.
  2. Double click the HTML button and add the following code in the defined client side event handler:

    JavaScript Copy Image Copy Code
    function Button1_onclick()
{
   var WebCombo1 = ISGetObject("WebCombo1");
   WebCombo1.SetMultipleValues("Maria Anders", "ALFKI");
   WebCombo1.RefreshTextByValueItems();
}

  3. Run the project.

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

Concepts
Extensible Client side Programming


How-to: Clear selected row

How-to: Clear selected row
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Client-side Programming How-to Topics > How-to: Clear selected row

Glossary Item Box

WebCombo provides a method to clear the selected row.

In this topic, you will learn how to use ClearSelection method.

To clear selected row

  1. Drag a HTML button and leave the Id as it is, which is Button1.
  2. Double click the HTML button and add the following code in the defined client side event handler:

    JavaScript Copy Image Copy Code
    function Button1_onclick()
{
   var WebCombo1 = ISGetObject("WebCombo1");
   WebCombo1.ClearSelection();
}

  3. Run the project.

See Also

Tasks
{How-to: Get the selected row}
{How-to: Set selected row in bound WebCombo}
{How-to: Get the text of the selected row in WebCombo}
How-to: Get the value of the selected row in WebCombo

Concepts
{Extensible Client side Programming}


How-to: Get/Set the TextBox value

How-to: Get/Set the TextBox value
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Client-side Programming How-to Topics > How-to: Get/Set the TextBox value

Glossary Item Box

You can get/set TextBox value on WebCombo via client side. The value inside the TextBox portion is NOT the WebCombo's Text (DataTextField).

In this topic, you will learn how to use GetTextBoxValue and SetTextBoxValue methods.

To get/set the TextBox on WebCombo

  1. Drag a WebCombo instance into the WebForm.
  2. Drag a HTML button and leave the Id as it is, which is Button1.
  3. To get TextBox value of combo, double click the HTML button and add the following code in the defined client side event handler:

    JavaScript Copy Image Copy Code
    function Button1_onclick()
{
   // Obtain WebCombo object
   var combo = ISGetObject("WebCombo1");

   // Obtains the value inside the TextBox
   // portion of the WebCombo
   combo.GetTextBoxValue();
   return true;
}

  4. To set TextBox value of combo, double click the HTML button and add the following code in the defined client side event handler:

    JavaScript Copy Image Copy Code
    function Button1_onclick()
{
   // Obtain WebCombo object
   var combo = ISGetObject("WebCombo1");

   // Sets the value inside the TextBox
   // portion of the WebCombo
   combo.SetTextBoxValue("Please select the CustomerID");
   return true;
}

  5. Run the project.

See Also

Tasks
{How-to: Get the text and value of multiple selection WebCombo}
{Walkthrough Topics}
{FAQ and How-to Topics}

Concepts
{Extensible Client side Programming}


How-to: Get the number of rows in WebCombo

How-to: Get the number of rows in WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Client-side Programming How-to Topics > How-to: Get the number of rows in WebCombo

Glossary Item Box

In WebCombo.NET V4.0, you can get number of loaded rows in combo via client side.

In this topic, you will learn how to use GetRowsCount method.

To get the number of rows in WebCombo

  1. Drag a WebCombo instance into the WebForm.
  2. Drag a HTML button and leave the Id as it is, which is Button1.
  3. Double click the HTML button and add the following code in the defined client side event handler:
  4. JavaScript Copy Image Copy Code
    function Button_onclick()
{
   // Obtain WebCombo object
   var combo = ISGetObject("WebCombo1");

   // Show the number of loaded rows
   alert(combo.GetRowsCount());
   return true;
}

  5. Run the project.

See Also

Tasks
{How-to: Get total rows in WebCombo}
{Walkthrough Topics}
{FAQ and How-to Topics}

Concepts
{Extensible Client side Programming}


How-to: Get specific row by its index

How-to: Get specific row by its index
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Client-side Programming How-to Topics > How-to: Get specific row by its index

Glossary Item Box

In WebCombo.NET V4.0, you can get specific row in combo via client side.

In this topic, you will learn how to use GetRow method.

To get specific row by its index in WebCombo

  1. Drag a WebCombo instance into the WebForm.
  2. Drag a HTML button and leave the Id as it is, which is Button1.
  3. Double click the HTML button and add the following code in the defined client side event handler:

  4. JavaScript Copy Image Copy Code
    function Button1_onclick()
{
   // Obtain WebCombo object
   var combo = ISGetObject("WebCombo1");
   var row0 = combo.GetRow(0);
}

  5. Run the project.

See Also

Tasks
Walkthrough Topics
{FAQ and How-to Topics}

Concepts
{Extensible Client side Programming}


How-to: Set focus on WebCombo

How-to: Set focus on WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Client-side Programming How-to Topics > How-to: Set focus on WebCombo

Glossary Item Box

You can set focus on WebCombo via client side using SetFocus method.

In this topic, you will learn how to implement the method.

To set focus on WebCombo using client side API

  1. Drag a WebCombo instance into the WebForm.
  2. Drag a HTML button and leave the Id as it is, which is Button1.
  3. Double click the HTML button and add the following code in the defined client side event handler:

    JavaScript Copy Image Copy Code
    function CustomFunction()
{
   var combo = ISGetObject("WebCombo1");
   combo.SetFocus();
}

  4. Run the project.

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

Concepts
Client-side Programming How-to Topics


How-to: Get the text and value of multiple selection WebCombo

How-to: Get the text and value of multiple selection WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Client-side Programming How-to Topics > How-to: Get the text and value of multiple selection WebCombo

Glossary Item Box

You can get the text and value of multiple selection WebCombo using GetMultipleValuesText and GetMultipleValuesValue methods.

In this topic, you will learn how to implement those methods.

To get the text and value of multiple selection using client side API

  1. Drag a WebCombo instance into the WebForm.
  2. Drag a HTML button and leave the Id as it is, which is Button1.
  3. To get the text of multiple selection combo, double click the HTML button and add the following code in the defined client side event handler:

    JavaScript Copy Image Copy Code
    function Button1_onclick()
{
   var combo = ISGetObject("WebCombo1");
   alert(combo.GetMultipleValuesText());
   return true;
}

  4. To get the value of multiple selection combo, double click the HTML button and add the following code in the defined client side event handler:

    JavaScript Copy Image Copy Code
    function Button1_onclick()
{
   var combo = ISGetObject("WebCombo1");
   alert(combo.GetMultipleValuesValue());
   return true;
}

  5. Run the project.

See Also

Tasks
How-to: Get the text of the selected row in WebCombo
How-to: Get the value of the selected row in WebCombo
How-to: Set initial value of multiple selection WebCombo from client side

Concepts
Extensible Client side Programming


How-to: Get WebCombo instance

How-to: Get WebCombo instance
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Client-side Programming How-to Topics > How-to: Get WebCombo instance

Glossary Item Box

You can get WebCombo instance via client side using ISGetObject method.

In this topic, you will learn how to implement the method.

To get WebCombo instance using client side API

  1. Drag a WebCombo instance into the WebForm.
  2. Drag a HTML button and leave the Id as it is, which is Button1.
  3. Double click the HTML button and add the following code in the defined client side event handler:

    JavaScript Copy Image Copy Code
    function doClick()
{
   var combo = ISGetObject("WebCombo1");
   alert(combo.Text);
}

  4. Run the project.

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

Concepts
Extensible Client side Programming


How-to: Display the result box to the right side of WebCombo

How-to: Display the result box to the right side of WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Client-side Programming How-to Topics > How-to: Display the result box to the right side of WebCombo

Glossary Item Box

You could set result box to the right side of WebCombo.

In this topic, you will learn how to display the result box to the right side.

To display result box to the right side of WebCombo

  1. Drag a WebCombo instance into the WebForm.
  2. Add the following function in client side:

    JavaScript Copy Image Copy Code
    function WebCombo1_OnShowDropDown(controlId, left, top, width, height)
    {
        var wc1 = ISGetObject("WebCombo1");
        var wcheight = wc1.LayoutSettings.ItemHeight;

        wc1.ResultBox.show(left+wc1.FrameObj.offsetWidth,top-wcheight,width,height);

        return false;
    }

  3. Invoke WebCombo1_OnShowDropDown() function in OnShowDropDown client side events of WebCombo.
  4. Run the project.

See Also

Tasks
How-to: Display tooltip in WebCombo
How-to: Show the result box's shadow
How-to: Set result box window type

Concepts
Extensible Client side Programming

References
ClientEvents Class
OnShowDropDown Property


How-to: Trigger OnTheFlyPostBack from client side

How-to: Trigger OnTheFlyPostBack from client side
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Client-side Programming How-to Topics > How-to: Trigger OnTheFlyPostBack from client side

Glossary Item Box

You can trigger OnTheFlyPostBack from client side using SendCustomRequest method.

In this topic, you will learn how to implement the method.

To trigger OnTheFlyPostback

  1. Drag a WebCombo instance into the WebForm.
  2. Drag a HTML button and leave the Id as it is, which is Button1.
  3. Double click the HTML button and add the following code in the defined client side event handler:

    JavaScript Copy Image Copy Code
    function Button1_onclick()
{
   var combo = ISGetObject("WebCombo1");
   combo.SendCustomRequest();
   return true;
}

  4. Run the project.

When you click the HTML button, InitializePostBack server side event of WebCombo will be invoked.

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

Concepts
Extensible Client side Programming


How-to: Set the value of another controls in OnAfterItemSelected client side events

How-to: Set the value of another controls in OnAfterItemSelected client side events
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Client-side Programming How-to Topics > How-to: Set the value of another controls in OnAfterItemSelected client side events

Glossary Item Box

You can set value of another controls using OnAfterItemSelected client side event.

In this topic, you will learn how to implement the method.

To set value to another control in OnAfterItemSelected event

  1. Drag a WebCombo instance into the WebForm.
  2. Add the following function in client side:

    JavaScript Copy Image Copy Code
    function WebCombo1_OnAfterItemSelected(controlId)
{
        var comboFirstName = ISGetObject("WebCombo1");
        var grid = ISGetObject("WebGrid1");
        var row = grid.GetSelectedObject().GetRowObject();
        if(comboFirstName.Text == "Andrew" || comboFirstName.Text == "Michael")
        {
                var cells = row.GetCells();
                var cellCity = cells.GetNamedItem("City");
                cellCity.SetText("Redmond");
                cellCity.SetValue("Redmond");
        }
        return true;
}

  3. Invoke WebCombo1_OnAfterItemSelected() function in OnAfterItemSelected client side event of WebCombo.
  4. Run the project.

See Also

Tasks
How-to: Set initial value of multiple selection WebCombo from client side
Walkthrough Topics
FAQ and How-to Topics

Concepts
Extensible Client side Programming

References
ClientEvents Class
OnAfterItemSelected Property


How-to: Validate string only input in OnKeyDown client side events

How-to: Validate string only input in OnKeyDown client side events
See Also Send Feedback
Intersoft WebCombo > WebCombo Features Overview > Client-side Programming How-to Topics > How-to: Validate string only input in OnKeyDown client side events

Glossary Item Box

In order to validate string only input, you can use OnKeyDown Client-side event in WebCombo.

In this topic, you will learn how to implement the method.

To validate string only input Client-side event

  1. Drag a WebCombo instance into the WebForm.
  2. Add the following code in client side:

    JavaScript Copy Image Copy Code
    function WebCombo1_OnKeyDown()
{
    var n ="";
    var e = window.event;

    if (48<=e.keyCode && e.keyCode<=57)
            n = e.keyCode - 48;
    else
            if (96<=e.keyCode && e.keyCode<=105)
                    n = e.keyCode - 96;
            else
                    if (e.keyCode==110 || e.keyCode==190)
                            n = ".";
    if (n != "")
       return false;
    else
       return true;
}

  3. Invoke WebCombo1_OnKeyDown() function in OnKeyDown client side event of WebCombo.
  4. Run the project.

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

Concepts
Extensible Client side Programming

References
ClientEvents Class
OnKeyDown Property


WebCombo Styles Overview

WebCombo Styles Overview
See Also Send Feedback
Intersoft WebCombo > WebCombo Styles Overview

Glossary Item Box

WebCombo provides comprehensive look & feel customization settings which allows you to customize most of the UI elements in the WebCombo control. You can change the styles directly by using either the provided style properties or control the WebCombo's appearance globally by specifying the CSS class name.

The rich WebStyle and DynamicStyle object in WebCombo which inherited from WebUI Framework enables non-technical designers or developers to easily customize the appearance of the WebCombo by changing the Style's properties visually, without has to delve into technical CSS syntax or HTML knowledge.

Here are the list of styles available in WebCombo:

  • ColumnStyle
    This style is applied to WebCombo's Column.

  • DrowDownStyle
    This style is applied to WebCombo's DropDown Arrow.

  • FrameStyle
    This style is applied to WebCombo's Frame.

  • HeaderStyle
    This style is applied to WebCombo's Columns Header.

  • MoreButtonStyle
    This style is applied to WebCombo's MoreButton Link.

  • ResultBoxStyle
    This style is applied to WebCombo's ResultBox (Only Box that contains data).
  • ResultFrameStyle
    This style is applied to WebCombo's ResultFrame (the outer ResultBox).

  • RowStyle
    This style is applied to WebCombo's Row.

  • SelectedRowStyle
    This style is applied to WebCombo's Selected Row.

  • StatusBoxStyle
    This style is applied to WebCombo's StatusBox.

  • TextBoxStyle
    This style is applied to WebCombo's TextBox.

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

References
ColumnStyle Property
DropDownStyle Property
FrameStyle Property
HeaderStyle Property
MoreButtonStyle Property
ResultFrameStyle Property
ResultBoxStyle Property
RowStyle Property
SelectedRowStyle Property
StatusBoxStyle Property
TextBoxStyle Property


How-to: Use WebCombo without search button

How-to: Use WebCombo without search button
See Also Send Feedback
Intersoft WebCombo > WebCombo Styles Overview > How-to: Use WebCombo without search button

Glossary Item Box

In WebCombo, you can hide the search button.

This topic will show you how to use WebCombo without search button.

To use WebCombo without search button

  1. Right click on the WebCombo instance and select WebCombo Designer.
  2. Set AlwaysShowSearchButton to False in the Advanced Settings - LayoutSettings.
  3. Run the project.

See Also

Tasks
How-to: Position search box on the left
How-to: Use round corner in WebCombo

Concepts
New User Interface Features
WebCombo Look and Feel

References
AlwaysShowSearchButton Property


WebCombo Advanced Features

WebCombo Advanced Features
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features

Glossary Item Box

WebCombo is an advanced combo box component for ASP.NET web development. To learn the basics and key features of WebCombo, see WebCombo Features Overview.

This topic discusses WebCombo's advanced features in depth, which contains the following topics.

    • Automatic Data Caching Handler
    • ClientAction Engine
    • Popup Dropdown List
    • Multiple Columns
    • Entry Mode
    • Linked WebCombo
    • Multiple Selection
    • Load-On-Demand
    • OnTheFly PostBack

Automatic Data Caching Handler

AllowAutoDataCaching feature is enabled by default. WebCombo implements its own unique data caching mechanism based on the built in ASP.NET caching feature.

The advantage of using WebCombo's data caching mechanism is a more powerful and effective data caching compared to the traditional ASP.NET caching. Consequently, it will significantly reduce server's workloads and dramatically improve server's response time.

The scope of the WebCombo's cache is session. WebCombo will track each session's cache and automatically remove the DataSource object from cache when the time is expired and it is no longer accessed. If the DataSource object is a dynamic object which means that the object is frequently modified, consider to set the AllowAutoDataCaching property to False. However, in most cases, leave this property to True for better performance.

In order to make use of this feature effectively, call the IsDataCached method to check whether the data source is already cached prior to assigning a new data source.

In some scenarios, a different data source can be assigned directly from code by simply assigning the DataSource property to a new data source. In this case, the old cache will be automatically removed and the new instance of cache will be created.

To learn more, see How-to: Disable auto data caching.

ClientAction Engine

ClientAction is a great improvement to the OnTheFly™ Postback architecture. This object is attached per WebCombo instance and designed to bridge the gaps between the client and server. It enables predefined client actions to be executed directly from the server during OnTheFly Postback (a.k.a. AJAX callback). As the results, it eliminates the needs to write client-side code.

This time-saving feature also allows you to invoke your own client-side function directly from the server code. There are two ways to invoke the predefined client actions. The first is through a static method call, which means that it does not require a WebCombo's instance. For examples, Alert, NavigateTo and so on.

The framework's built-in ClientAction engine enables developers to easily call client-side action or code in the server-side. For examples, GetClientAction().Alert("msg") or GetClientAction().NavigateTo("page2.aspx") can be called directly in the server-side code during page callback.

Scenario 1 - Display message box to user

C# Copy Image Copy Code
protected void WebCombo1_InitializePostBack(object sender, ISNet.WebUI.WebCombo.PostbackEventArgs e)
{
   // Display alert to user
   WebCombo1.GetClientAction().Alert("You can't update this row!");
}

Scenario 2 - Refreshing another WebCombo instance

C# Copy Image Copy Code
protected void WebCombo1_InitializePostBack(object sender, ISNet.WebUI.WebCombo.PostbackEventArgs e)
{
   // Refresh another WebCombo
   WebCombo2.GetClientAction().Refresh();
}

Scenario 3 - Navigate to specific page after record addition

C# Copy Image Copy Code
protected void WebCombo1_InitializePostBack(object sender, ISNet.WebUI.WebCombo.PostbackEventArgs e)
{
   // Called directly in server side codes within OTFPB context.
   WebCombo1.GetClientAction().NavigateTo("StatusForm.aspx?UserId=" +
   e.Row.Cells.GetNamedItem("UserId").Value.ToString());
}

To learn more, see ClientAction Engine How-to topics.

Popup Dropdown List

Since the first version, "floating" result window was one of WebCombo's most powerful features. The result box is using popup window type by default, which can be customized through the ResultBoxWindowType property.

To see the popup window type in action, open a WebCombo sample in the browser and resize your browser's window. Notice that the WebCombo's result box will be displayed on the top of the browser window which is not limited to the browser's size.

Compare the results with the traditional ASP.NET DropDownList control such as shown in the following.

Traditional ASP.NET DropDownList Result Box Window

Notice that the result box of the standard ASP.NET DropDownList is always limited to the size of the browser window. This feature greatly enhances user experiences as the end users can always see the whole data regardless of the browser's size.

Note that this feature is only available in Internet Explorer browsers. Non IE browsers will gracefully fall back to Normal window type.

To learn more, see How-to: Set result box window type.

FAQ

FAQ: How to use WebCombo in dual monitor?

As described in the above topic, WebCombo's result box can be "floating" outside the browser's window. Unfortunately, this feature caused an issue when used in a dual monitor environment, i.e., the result box is not displayed in the secondary monitor. To solve this issue, please set the ResultBoxWindowType property to Normal.

Note that this issue applies only to Internet Explorer browser. The dual monitor issue has been clarified to be a limitation in the Internet Explorer browser.

The following illustration shows how to customize the ResultBoxWindowType property using the WebCombo Designer.

Multiple Columns

You can easily configure WebCombo to display multiple column result window. First, open the WebCombo Designer by right clicking on the WebCombo instance, then choose the WebCombo Designer such as shown in the following illustration.

Look for the ComboMode property in the LayoutSettings section and make sure that its value is set to MultipleColumn.

Now, users can see the results list in the multiple columns mode instead of the single column display in classic ASP.NET DropDown List control.

To learn more about multiple columns, see How-to: Use multiple columns mode.

Entry Mode

WebCombo provides 3 types of entry mode such as explained in the following.

  • Default Entry mode

  • The default entry mode is the original WebCombo entry mode.

  • Default Entry Mode

  • Instant Lookup

  • The "InstantLookup" entry mode allows quick data input which is validated by WebCombo only in certain conditions such as when "Enter" key is pressed or when the control lost its focus . In case that the input data has perfect match in the database, no result box will be shown. This enables the data entry operation to be done with less keystrokes.

    When the users type in OrderID such as "10248" or "10561" then press Tab key, or try to enter other value such as "1056" then press Tab key, the WebCombo will automatically instant lookup as you can see in the screenshot below.

  • AutoComplete Entry mode

    The second new entry mode is "AutoComplete" which has similar behaviors as in the "Default" entry mode. The difference is that the AutoComplete mode performs auto text completion to the first matched item in the results. The AutoComplete mode behaves much like in the traditional desktop applications which is still preferred by many end users today.

To learn more about entry mode, see Entry Mode How-to Topics.

Linked WebCombo

Linking two or more WebCombo is one of the most requested features. While it is feasible to be done in the previous version, it requires extensive code in the client-side. The complexity grows when you need to link a few WebCombo instances together.

Now linking two or more WebCombo is easier than ever. You no longer have to deal with great amount of code, you can simply select the link settings through the server-side properties. The designer enables you to easily select which WebCombo you desire to link.

The Linked WebCombo feature supports the following scenarios:

  • Single dependency mode

    This is the most common scenario in web application where one WebCombo should depend on the value of another WebCombo. It involves only one-to-one relation between one WebCombo and another. The most common scenario is such as the relations between Division, Manager and Staff. Users will initially select the Division record, then a list of managers will appear based on selected Division. It will then follow by list of staff who reported to the selected Manager. In this scenario, Division has one-to-one relation with Manager, and Manager has one-to-one relation with Staff. This is known as Single Dependency Scenario.

  • Multiple dependency mode

    This mode allows you to configure a WebCombo to be dependent to more than one WebCombo. The users are then required to fill the specified Parent WebCombo(s) first prior to be able to select a value in the linked combo. For example, Supplier list is based on ProductCategory and City. Both ProductCategory and City are independent and not linked. However, the Supplier list requires both ProductCategory and City to be filled prior to be able to select a Supplier. This situation is named Multiple Dependencies Scenario which demonstrated in below sample. The sample also demonstrates the use of Unbound mode for ProductCategory and City, while the Supplier instance is configured to use Bound mode in order to utilize LinkSettings feature.

  • Combined dependency mode

    WebCombo also supports more advanced scenarios, where an array of WebCombo instances can be linked in several ways, some of them could be linked using Single dependency mode, and others can be linked using Multiple dependency. Combined scenario is the combination of single and multiple dependencies scenario in order to create an array of linked WebCombo instances, where one WebCombo is dependent to another WebCombo and another WebCombo is dependent to one or more than one other instances. One common scenario for the combined mode is similar to following, where Vehicle input requires VehicleType to be filled first, next the available dealer is dependent to VehicleType and Dealer input. These links between single and multiple dependencies create an array of linked WebCombo named Combined Dependencies. Dealer and Models are configured in Bound mode, and others in Unbound mode to demonstrate more advanced scenario.

  • Unbound mode

    The LinkedWebCombo feature supports Unbound mode specifically. You can define LinkSettings in the similar way as in Bound mode, and have the linked WebCombo filtered in the client side automatically.

To learn more, see Linked WebCombo How-to Topics.

Multiple Selection

One of the most powerful features in WebCombo is the Multiple Selection feature. Using the same data binding concept and WebCombo solid architecture, you can easily enable your end users to select multiple items from a list.

WebCombo is designed to support broad and advanced business application scenarios such as Bound mode, Unbound Mode, Unbound ReadOnly mode, AllowBrowseAll mode and many more. The combination of the OnTheFly-PostBack™ and IEMozBridge™ architecture together with the Multiple Selection feature makes data entry and presentation easier and more efficient than ever before. The feature runs consistently in all popular browsers such as Internet Explorer, Firefox, Safari, and Opera.

The Multiple Selection feature includes behaviors such as explained in the following:

  1. Data Input

    There are several input modes to accept an item:

    • Using Keyboard

The valid built-in keystrokes are Tab, Enter and the character specified in SeparatorChar property. These keys can be used to accept a selected item only when the ResultBox is shown. This will result in better consistency as a user can hit the Tab key again to move to the next field after the input is done.

    • Using Mouse

When the ResultBox is open, you can select the item by clicking on it, WebCombo will then insert the item and automatically position the cursor ready for next item input.

  1. Navigation

    You can use the left and right arrow keys to navigate from previous item to the next item, or vice versa. WebCombo will automatically determine the entered valid items and set the cursor position accordingly.

  2. Highlight

    You can easily select an item among multiple values by clicking the region of a valid item. When the clicked item is valid (that is, it has a Value), the item will be highlighted similar to the Microsoft Outlook® 2003 TextBox feature. You can delete the selected item by pressing the Delete or Backspace key.

  3. Item Deletion

    Item deletion can be done using the Delete or Backspace key. WebCombo is capable of identifying tokens in the cursor position and delete the previous item when the Backspace key is pressed, it can also delete the next item if the Delete key is pressed. WebCombo can automatically determine the current context when pressing these keys, e.g. whether the user is in editing mode or selection mode. Editing mode is when the ResultBox is shown and the item is not yet valid.

  4. Item Insertion

    WebCombo features an extensive keyboard handling mechanism capable of parsing the tokens intelligently. The MultipleSelection feature can even allow a user to insert an item. This can be done by placing the cursor in the position where you want to insert. Then, start typing and press Tab to select an item, and the new item will be properly inserted among other values.

  5. Advanced features

    WebCombo includes numerous advanced settings related to the MultipleSelection feature. These settings can be found in MultipleSelectionSettings object that contains all information about the MultipleSelection feature. The advanced features are:

    • AllowBrowseAll

    When this property is set to True, you can list all items by pressing Ctrl+Space. Note that when the MultipleSelection property is Enabled and the TextBoxMode property is Editable, the DropDownButton will be disabled and invisible.

    • AllowNotInListText

    This setting allows the user to input text which is not listed in the ResultBox. You should handle the OnValueItemNotInList client-side event to determine how the item should be treated.

    • AutoPositionResultBox

    When this property is set to True, the ResultBox location will be automatically positioned beneath the cursor position.

    • AutoSelectFirstMatch

    When set to True, the first row will always be highlighted. This allows a user to quickly select an item by pressing the Tab key without first having to press the Down arrow key to select.

    Multiple Selections using advanced features

  6. Complete Client-side and Server-side Object Models

    Along with the MultipleSelection feature, numerous client-side methods and properties have been added to both the server-side and client-side objects. Developers are allowed to obtain multiple values on client-side, programmatically add, change or delete any ValueItem, and more.

To learn more about multiple selection, see Multiple Selection How-to Topics.

Load-on-Demand

The load-on-demand feature has been around since early WebCombo version and it was made available to meet the growing complexity of business requirements. One of the requirements is, for instance, controlling data retrieval from a large data source precisely based on the user interaction.

This feature allows developers to write their own code to control the data rows that need to be retrieved from the physical data source through the provided event arguments. This provides an ideal solution for data selection in applications with relatively large data source.

To enable the load-on-demand data retrieval feature, you set the AllowAutoQueryHandler property to False. Consequently, WebCombo will not perform the automatic (default behavior) query handling. You will need to write your own code for your specific data-retrieval scenario in the InitializeDataSource server-side event.

To learn more about Load-on-demand, see How-to: Apply load on demand in WebCombo.

What is OnTheFly-PostBack™

If you are a web developer, you should already be familiar with server postback mechanism where the entire page is submitted back to server for processing and then returned the complete output back to client side. In ASP.NET, a server control requires postback to server in order to process the information and events passed from the client. While ASP.NET has greatly improved the architecture of server-based processing such as server controls and control events, it is still unable to deliver the web experiences expected by both developers and end users since it had to perform standard page postback mechanism which is undoubtedly cause inconvenience and produce slow response between user interactions.

OnTheFly postback is a patented technology by Intersoft Corp eliminating the need to perform full page postback in order to communicate with server resources. This technology is built on the top of ASP.NET® and latest web technology, therefore allowing our commercial server components to better run on .NET-enabled server and to take advantage of the technology in order to produce a better web experience - as stated in Intersoft's vision.

Benefits

There are many benefits when data can be requested and delivered by clients without losing the state of the client. The most significant benefits is improved overall performance and minimized server's workload.

Normally, a standard server control will need to do postback to server in order to interact with server's resources such as retrieving data or do server-specific tasks. Since that the web applications is stateless, there is a need to save latest client state for the whole page when posting back to server. This is done by the VIEWSTATE implementation in Microsoft ASP.NET. There is nothing wrong with the ViewState implementation and in fact it does very well. However, a major performance issue will appear when there are a lot of complex controls in a page, which is caused by large saved view state and the need to send back the whole page's output.

The OnTheFly postback feature allows the implemented controls to interact with server and send back only necessary UI elements, without the need to send the whole page's elements. This dramatically saves the server's resources, time and bandwidth needed to perform server interaction.

The summary of the benefits are:

Rich and smoother user interactions.
Improved performance up to 50%.
Minimized server workload.
Increased end users productivity.
True server-events processing.
Faster rendering and realtime response.

About Callbacks

Callbacks is the generic term used by other vendors to identify the postback through XMLHTTP channel over traditional postback. Many developers have asked the difference about the callback with Intersoft's proprietary OnTheFly-Postback™ architecture. So, are there any difference? The answer is yes.

Although more vendors will claim that their products support callbacks, still many of them failed in state persistence as well as tons of issues related to ASP.NET performance and page life cycle. Intersoft's OnTheFly-Postback™ is not a few lines of javascript codes sending request to server through XmlHttp (as of Callbacks), it is a truly integrated client-server architecture with comprehensive server component interfaces for cross-products consistency and reliability resulting in smooth UI interactions.

Following is the details that make Intersoft's OnTheFly-Postback unique and strongly stand out of the crowd:

Conformance to Microsoft .NET's Page framework

There are certainly a few issues that appear with the introduced onthefly-postback feature, such as the state of IsPostBack, the viewstate restoration and so on. Intersoft recognizes that without the compatibility of .NET's page framework, it is unlikely that the architecture will become a solid, mature, and enterprise-ready architecture. Therefore, the architecture has been designed with full support and conformance to the .NET's standard page framework.
The implemented supports are:

  • IsPostBack state. When controls that implement the architecture initiates a data request or server's interaction, the Page.IsPostBack of the requested page will be set to True. By comfort to this standard, all existing codes that implemented in !IsPostBack condition will run properly without additional codes changing.
  • ViewState restoration. It is important that when initiates onthefly data request or server's interaction in Page's code-behind, the last viewstate of other controls contained in the Page is restored. This is done transparently in WebCommonControl, while many other vendor's controls that offer similar function failed to comfort to the framework's standard.
    Multiple instances. The architecture fully supports multiple instances of the control that implement it. That means server page's framework will be able to distinguish which controls that initiate the server request, and continues to process attached server event handler of the control.
  • Common data binding. The architecture allows you to bind data the same way you bind data to any common controls. This is a totally unique and advanced feature recognizing that the controls are in fact working in onthefly postback which doesn't require the page to be refreshed. You can assign the DataSource of the control by specifying it in Page_Load or provided events based on the controls, and call DataBind().
  • IntersoftControl's postback state. It is a special class that contains the Postback state of the architecture. Keep in mind that the onthefly postback sets the Page.IsPostBack to True as well. It is very important that developers can determine whether the initated postback is a normal postback made by other controls or a postback initiated by Intersoft's controls. With the provided class, developers have the ability to fully customize, extend and develop high performance and productive web applications.
    Server events. The architecture will invoke server events just like in traditional postbacks. Page's lifecycle events will fire as usual followed with control-specific events that implement the architecture.
  • Intrinsic controls value. The architecture allows developers to decide whether other intrinsic controls' value to be passed back during OnTheFly postbacks. When the controls' value is submitted, developer can easily obtain the value in server side. For example, TextBox1.Text or Checkbox1.Checked.
  • ClientAction engine. The framework built-in ClientAction engine enables developers to easily call client-side action or codes in server side. For example, ClientAction.Alert("msg") or ClientAction.NavigateTo("page2.aspx") can be called directly in server side codes within OTFPB context.
  • Inline script tag supports. By default other callbacks will fail when inline script tag is used in the aspx page. For example, <%= DoSomeFunc() %> will cause issue during page response. Intersoft's OnTheFly-Postback has been designed to support inline script tag supports as well as inline databinding, inline templates and more. Over dozens of advanced scenarios, integration within other framework, SSL context, as well as in load-balanced enterprise environment has been fully tested and verified to work flawlessly.

About ASP.NET V2.0 Support

At the time of this writing, Microsoft has planned to support what they called "out-of-band callbacks" directly into the ASP.NET V2.0 architecture.

Intersoft's OnTheFly postback architecture has been redesigned and further optimized when built into the WebUI.NET Framework. The architecture has been made "plugable" and thus it could be easily integrated into ASP.NET V2.0's interface once it is available.

However, Intersoft might not be utilizing ASP.NET 2.0's built-in callbacks support due to many of limitation in the .NET Framework itself.

About Mozilla support

Internet Explorer® users have been enjoying the benefits of this architecture since its initial release. Intersoft is proud to announce that the architecture has been redesigned to support Mozilla-based browsers as well. That means, Intersoft has now opened the chance for other platforms such as Macintosh, Linux or Solaris to enjoy the rich features of Intersoft's products, delivering wealth user experience and greater productivity to both developer and end users.

The Mozilla and other Gecko-engine based browsers support is implemented in WebUI.NET Framework V3.0.

See Also

Other Resources
Features Added In WebCombo 5
Learning More
Advanced

Tasks
Walkthrough Topics
FAQ and How-to Topics


ClientAction Engine How-to Topics

ClientAction Engine How-to Topics
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > ClientAction Engine How-to Topics

Glossary Item Box

The topics in this section describe how to achieve common ClientAction tasks.

In This Section

How-to: Display message box if unable to add a row

How-to: Navigate to specific page after adding a row

How-to: Refresh other control during row addition

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

References
GetClientAction Method


How-to: Display message box if unable to add a row

How-to: Display message box if unable to add a row
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > ClientAction Engine How-to Topics > How-to: Display message box if unable to add a row

Glossary Item Box

You can display a message box during AddItem event.

In this topic, you will learn how to display message box if unable to add a row.

To display message box if unable to add a row

  1. Add the following code in WebCombo's AddItem server side event:

    C# Copy Image Copy Code
    protected void WebCombo1_AddItem(object sender, ISNet.WebUI.WebCombo.RowEventArgs e)
{
   if (e.Row.Value == "ABC" || e.Row.Value == "abc")
   {
      WebCombo1.GetClientAction().Alert("Unable to add " + e.Row.Value);
   }
}

  2. Run the project.

See Also

Tasks
How-to: Navigate to specific page after adding a row
How-to: Refresh other control during row addition

Concepts
ClientAction Engine

References
GetClientAction Method
AddItem Event


How-to: Navigate to specific page after adding a row

How-to: Navigate to specific page after adding a row
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > ClientAction Engine How-to Topics > How-to: Navigate to specific page after adding a row

Glossary Item Box

WebCombo provides a method to navigate to specific page after adding a row.

In this topic, you will learn how to use NavigateTo method.

To navigate to specific page after adding a row

  1. Create WebCombo's AddItem server side event.
  2. Put the following code in AddItem server side event after adding a row:
    C# Copy Image Copy Code
    WebCombo1.GetClientAction().NavigateTo("Default.aspx");

  3. Run the project.

See Also

Tasks
How-to: Display message box if unable to add a row
How-to: Refresh other control during row addition

Concepts
ClientAction Engine

References
GetClientAction Method
AddItem Event


How-to: Refresh other control during row addition

How-to: Refresh other control during row addition
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > ClientAction Engine How-to Topics > How-to: Refresh other control during row addition

Glossary Item Box

WebCombo provides a method to refresh other controls using RefreshModifiedControls method.

In this topic, you will learn how to implement the method.

To refresh other control during row addition

  1. Create WebCombo's AddItem server side event.
  2. Add the following code in AddItem server side event after adding a row:
    C# Copy Image Copy Code
    WebCombo1.GetClientAction().RefreshModifiedControls();

  3. Run the project.

See Also

Tasks
How-to: Display message box if unable to add a row
How-to: Navigate to specific page after adding a row

Concepts
ClientAction Engine

References
GetClientAction Method
AddItem Event


Entry Mode How-to Topics

Entry Mode How-to Topics
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > Entry Mode How-to Topics

Glossary Item Box

The topics in this section describe how to achieve common entry mode tasks.

In This Section

How-to: Use default entry mode

How-to: Use AutoComplete entry mode

How-to: Use InstantLookUp entry mode

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

References
EntryMode Property


How-to: Use default entry mode

How-to: Use default entry mode
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > Entry Mode How-to Topics > How-to: Use default entry mode

Glossary Item Box

The default entry mode is an original WebCombo.NET entry mode.

In this topic, you will learn how to set default entry mode from designer.

To use default entry mode.

  1. Open WebCombo.NET Designer - Advanced Settings - LayoutSettings.
  2. Set EntryMode to Default.

See Also

Tasks
How-to: Use AutoComplete entry mode
How-to: Use InstantLookUp entry mode

Concepts
Entry Mode

References
EntryMode Property


How-to: Use AutoComplete entry mode

How-to: Use AutoComplete entry mode
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > Entry Mode How-to Topics > How-to: Use AutoComplete entry mode

Glossary Item Box

AutoComplete entry mode has same behavior as Default entry mode, but with text auto completion to first-matched item of the results.

In this topic, you will learn how to set AutoComplete entry mode from designer.

To use AutoComplete entry mode.

  1. Open WebCombo.NET Designer - Advanced Settings - LayoutSettings.
  2. Set EntryMode to AutoComplete.

See Also

Tasks
How-to: Use default entry mode
How-to: Use InstantLookUp entry mode

Concepts
Entry Mode

References
EntryMode Property


How-to: Use InstantLookUp entry mode

How-to: Use InstantLookUp entry mode
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > Entry Mode How-to Topics > How-to: Use InstantLookUp entry mode

Glossary Item Box

The "InstantLookup" entry mode allows quick data input.

In this topic, you will learn how to set InstantLookUp entry mode from designer.

To use InstantLookUp entry mode.

  1. Open WebCombo.NET Designer - Advanced Settings - LayoutSettings.
  2. Set EntryMode to InstantLookUp.

See Also

Tasks
How-to: Use default entry mode
How-to: Use AutoComplete entry mode

Concepts
Entry Mode

References
EntryMode Property


Linked WebCombo How-to Topics

Linked WebCombo How-to Topics
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > Linked WebCombo How-to Topics

Glossary Item Box

The topics in this section describe how to achieve common linked WebCombo tasks.

In This Section

How-to: Use combined dependencies linked WebCombo

How-to: Use multiple dependencies linked WebCombo

How-to: Use single dependency linked WebCombo

How-to: Use unbound linked WebCombo

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

References
LinkSettings Class


How-to: Use combined dependencies linked WebCombo

How-to: Use combined dependencies linked WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > Linked WebCombo How-to Topics > How-to: Use combined dependencies linked WebCombo

Glossary Item Box

Combined scenario is the combination of single and multiple dependencies scenario in order to create an array of linked WebCombo instances, where one WebCombo is dependent to another WebCombo and another WebCombo is dependent to one or more than one other instances.

In this topic, you will learn how to use combined dependencies linked WebCombo.

To use combined dependencies linked WebCombo.

  1. Bind Country field to WebCombo1 using AccessdataSource (Customers table from NorthWind), checked "Return only unique rows" check box
  2. Bind WebCombo2 to AccessDataSource (using Table Suppliers from database NorthWind).
  3. Bind WebCombo3 to AccessDataSource (using Table Categories from database NorthWind).
  4. Bind WebCombo4 to AccessDataSource (using Table Products from database NorthWind).
  5. Open WebCombo2's designer - Advanced Settings - LinkSettings.
  6. Set Enabled to True, Set the ParentWebComboID to "WebCombo1".

  7. Open WebCombo4's designer - Advanced Settings - LinkSettings.
  8. Set Enabled to True, Set FilteredDataMember to "SupplierID, CategoryID"
  9. Set the ParentWebComboID to "WebCombo2, WebCombo3".

  10. The result should look like following.

See Also

Tasks
How-to: Use multiple dependencies linked WebCombo
How-to: Use single dependencies linked WebCombo
How-to: Use unbound linked WebCombo

Concepts
Linked WebCombo

References
LinkSettings Class
FilterDataMember Property
ParentWebComboID Property
Enabled Property


How-to: Use multiple dependencies linked WebCombo

How-to: Use multiple dependencies linked WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > Linked WebCombo How-to Topics > How-to: Use multiple dependencies linked WebCombo

Glossary Item Box

This mode allows you to configure a WebCombo to be dependent to more than one WebCombo.

In this topic, you will learn how to use multiple dependencies linked WebCombo.

To use multiple dependencies linked WebCombo.

  1. Bind WebCombo1 to AccessDataSource (using Table Suppliers from database NorthWind).
  2. Bind WebCombo2 to AccessDataSource (using Table Categories from database NorthWind).
  3. Bind WebCombo3 to AccessDataSource (using Table Products from database NorthWind).
  4. Open WebCombo3's designer - Advanced Settings - LinkSettings.
  5. Set Enabled to True.
  6. Set FilteredDataMember to "SupplierID, CategoryID"
  7. Set the ParentWebComboID to "WebCombo1, WebCombo2".

  8. The result should look like following.

See Also

Tasks
How-to: Use combined dependencies linked WebCombo
How-to: Use single dependencies linked WebCombo
How-to: Use unbound linked WebCombo

Concepts
Linked WebCombo

References
LinkSettings Class
FilterDataMember Property
ParentWebComboID Property
Enabled Property


How-to: Use single dependency linked WebCombo

How-to: Use single dependency linked WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > Linked WebCombo How-to Topics > How-to: Use single dependency linked WebCombo

Glossary Item Box

ncesThis is the most common scenario in web application, where one WebCombo should depend on the value of another WebCombo.

In this topic, you will learn how to use single dependencies linked WebCombo.

To use single dependencies linked WebCombo.

  1. Bind WebCombo1 to AccessDataSource (using Table Categories from database NorthWind).
  2. Bind WebCombo2 to AccessDataSource (using Table Products from database NorthWind).
  3. Open WebCombo2's designer - Advanced Features - Checked the Enable Linked WebCombo.
  4. Select the parent WebCombo's ID to WebCombo1.

  5. The result should look like following.

See Also

Tasks
How-to: Use combined dependencies linked WebCombo
How-to: Use multiple dependencies linked WebCombo
How-to: Use unbound linked WebCombo

Concepts
Linked WebCombo

References
LinkSettings Class
Enabled Property
ParentWebComboID Property


How-to: Use unbound linked WebCombo

How-to: Use unbound linked WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > Linked WebCombo How-to Topics > How-to: Use unbound linked WebCombo

Glossary Item Box

In WebCombo V4.0, you are able to use linked combo in unbound mode.

In this topic, you will learn how to implement the scenario above.

To use unbound linked WebCombo.

  1. Drag and drop two WebCombo instances and named them as WebCombo1 and WebCombo2 respectively.
  2. Right click on WebCombo1 to open WebCombo.NET Designer - Columns and Rows.
  3. Add a new Column and named it Country.
  4. Click on the Rows and add "USA", "England" and "Japan".

  5. Right click on WebCombo2 to open WebCombo.NET Designer - Columns and Rows.
  6. Add two new Column and named them as City and Country respectively.
  7. Set City's BaseFileName to "City" and Country's BaseFileName to "Country".
  8. Set Country's Hidden and RenderOnHidden to True.

  9. Click on the Rows to add some rows to WebCombo2's columns.

  10. Open WebCombo2's properties and find the LinkSettings.
    Property | Value
    Enabled | True
    FilterDataMember | Country
    ParentWebComboID | WebCombo1

  11. The result should look like following.

See Also

Tasks
How-to: Use combined dependencies linked WebCombo
How-to: Use multiple dependencies linked WebCombo
How-to: Use single dependencies linked WebCombo

Concepts
Linked WebCombo

References
LinkSettings Class
BoundMode Property
FilterDataMember Property
ParentWebComboID Property
Hidden Property
Enabled Property
RenderOnHidden Property


Multiple Selection How-to Topics

Multiple Selection How-to Topics
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > Multiple Selection How-to Topics

Glossary Item Box

The topics in this section describe how to achieve common multiple selection tasks.

In This Section

How-to: Use bound multiple selection WebCombo

How-to: Use unbound multiple selection WebCombo

How-to: Set initial value of multiple selection WebCombo from server side

How-to: Set initial value of multiple selection WebCombo from client side

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

References
MultipleSelectionSettings Property


How-to: Use bound multiple selection WebCombo

How-to: Use bound multiple selection WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > Multiple Selection How-to Topics > How-to: Use bound multiple selection WebCombo

Glossary Item Box

WebCombo has a feature called Multiple Selection which can be used in bound mode using AccessDataSource control.

In this topic, you will learn how to set selection WebCombo in bound mode.

To use WebCombo's multiple selection bound mode

  1. Bind WebCombo to AccessDataSource.
  2. Open WebCombo.NET Designer. Select Advanced Settings and expand MultipleSelectionSettings.
  3. Set Enabled property to True.

See Also

Concepts
Multiple Selection

Tasks
How-to: Use unbound multiple selection WebCombo
How-to: Set initial value of multiple selection WebCombo from server side
How-to: Set initial value of multiple selection WebCombo from client side

References
BoundMode Property
MultipleSelectionSettings Class


How-to: Use unbound multiple selection WebCombo

How-to: Use unbound multiple selection WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > Multiple Selection How-to Topics > How-to: Use unbound multiple selection WebCombo

Glossary Item Box

WebCombo has a feature called Multiple Selection which is can be used in Unbound mode using AccessDataSource control.

In this topic, you will learn how to set multiple selection in Unbound mode.

To use WebCombo's multiple selection Unbound mode

  1. Create WebCombo's columns in WebCombo.NET Designer - Columns and Rows.
  2. Go to WebCombo.NET Designer - Advance Settings - MultipleSelectionSettings.
  3. Set Enabled property to True.
  4. In LayoutSettings, set TextBoxMode property to ReadOnly.

See Also

Tasks
How-to: Use bound multiple selection WebCombo
How-to: Set initial value of multiple selection WebCombo from server side
How-to: Set initial value of multiple selection WebCombo from client side

Concepts
Multiple Selection

References
WebComboColumn Class
BoundMode Property
MultipleSelectionSettings Class


How-to: Set initial value of multiple selection WebCombo from server side

How-to: Set initial value of multiple selection WebCombo from server side
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > Multiple Selection How-to Topics > How-to: Set initial value of multiple selection WebCombo from server side

Glossary Item Box

In multiple selection mode, you can set initial value from server side. The initial value can be set both in WebCombo unbound or bound mode.

In this topic, you will learn how to use

To set initial value of multiple selection WebCombo from Server-side

  1. Bind WebCombo to AccessDataSource.
  2. Go to WebCombo.NET Designer - Advance Settings - MultipleSelectionSettings.
  3. Set Enabled property to True.
  4. Use following code to set multiple values:

    C# Copy Image Copy Code
    protected void Page_Load(object sender, EventArgs e)
{
   WebCombo1.SetMultipleValues("Anna Trujillo", "ANATR");
}

See Also

Tasks
How-to: Use bound multiple selection WebCombo
How-to: Use unbound multiple selection WebCombo
How-to: Set initial value of multiple selection WebCombo from client side

Concepts
Multiple Selection

References
MultipleSelectionSettings Class
SetMultipleValues Method


Advanced How-to Topics

Advanced How-to Topics
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > Advanced How-to Topics

Glossary Item Box

This topic provides the links to all topics that are categorized as advanced topics.

In This Section

How-to: Integrate to FormView
Learn how to integrate WebCombo with Microsoft's FormView's EditTemplate.

How-to: Integrate to GridView
Learn how to integrate WebCombo with Microsoft's GridView.

How-to: Integrate to WebGrid
Learn how to integrate WebCombo with WebGrid.NET.

How-to: Set FlyPostBackSettings
Learn how to set FlyPostBackSettings in WebCombo.NET Designer.

How-to: Enable XML compression
Learn how to enable XML compression using WebCombo.NET Designer.

How-to: Set ScriptDirectory and SharedScriptDirectory
Learn how to set ScriptDirectory and SharedSriptDirectory in WebCombo.NET Designer.

How-to: Set images directory
Learn how to set ImagesDirectory in WebCombo.NET Designer.

How-to: Implement linked WebCombo functionality using column that is not DataTextField or DataValueField as the FilterDataMember
Learn how to deal with linked WebCombo in advanced scenario.

How-to: Improve FlyPostBack performance
Learn how to set FlyPostBackSettings to improve its performance.

See Also

Other Resources
Features and Concepts
Learning More

Tasks
Walkthrough Topics
FAQ and How-to Topics


How-to: Create WebCombo at runtime

How-to: Create WebCombo at runtime
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > Advanced How-to Topics > How-to: Create WebCombo at runtime

Glossary Item Box

You can create WebCombo programmatically from server-side.

In this topic, you will learn how to create WebCombo at runtime.

To create WebCombo at runtime

  1. Create a DIV container like following.

    <div runat="server" id="DivContainer">

  2. Switch to View Code. At first, you need to add the following namespace.

    using ISNet.WebUI.WebCombo;

  3. Put the following code in Page_Load.
    C# Copy Image Copy Code
    protected void Page_Load(object sender, EventArgs e)
{
   AccessDataSource access;
   access = new AccessDataSource(Server.MapPath("./App_Data/Northwind.mdb"), "Select * from Customers");
   access.ID = "AccessDataSource1";

   WebCombo combo = new WebCombo("WebCombo1");
   combo.Width = Unit.Pixel(200);
   combo.Height = Unit.Pixel(20);
   combo.UseDefaultStyle = true;

   // Setup Events
   combo.InitializeDataSource += new DataSourceEventHandler(combo_InitializeDataSource);
   combo.InitializeLayout += new LayoutEventHandler(combo_InitializeLayout);

   //this.Controls.Add(combo);
   this.DivContainer.Controls.Add(access);
   this.DivContainer.Controls.Add(combo);
}

  4. Put the following code in InitializeDataSource server-side event to setup the DataSource.
    C# Copy Image Copy Code
    protected void combo_InitializeDataSource(object sender, DataSourceEventArgs e)
{
   // Setup DataSource
   WebCombo combo = (WebCombo)sender;
   combo.DataSourceID = "AccessDataSource1";
}

  5. Finally, put the following code in InitializeLayout server-side event to setup WebCombo's behavior.
    C# Copy Image Copy Code
    protected void combo_InitializeLayout(object sender, LayoutEventArgs e)
{
   // Setup Behavior
   WebCombo combo = (WebCombo)sender;
   combo.DataTextField = "ContactName";
   combo.DataValueField = "CustomerID";
}

  6. Run the project.

See Also

Tasks
How-to: Set value at runtime
How-to: Integrate to FormView
How-to: Integrate to GridView


How-to: Set value at runtime

How-to: Set value at runtime
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > Advanced How-to Topics > How-to: Set value at runtime

Glossary Item Box

In many case, we usually want to set a default text in the first or initial load of WebCombo based on its DataValueField.

In this topic, you will learn how to set WebCombo's value at runtime.

To set value at runtime

  1. Bind WebCombo to AccessDataSource control. (Use Customers table)
  2. To set the Webcombo value control you need to define Value property on Page_Load event.
    C# Copy Image Copy Code
    protected void Page_Load(object sender, EventArgs e)
{
   WebCombo1.Value = "ANATR";
}

  3. In this case, the combo text is based on one of the value ANATR, which is Ana Trujillo.
  4. Run the project.

See Also

Tasks
How-to: Create WebCombo at runtime
How-to: Integrate to FormView
How-to: Integrate to GridView


How-to: Integrate to FormView

How-to: Integrate to FormView
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > Advanced How-to Topics > How-to: Integrate to FormView

Glossary Item Box

WebCombo.NET V4.0 is already compatible with the standard infrastructure Microsoft's FormView EditTemplate.

In this topic, you will learn how to integrate WebCombo to FormView.

To integrate WebCombo to FormView

  1. Drag and drop FormView control to the WebForm.
  2. Bind it to Customers table.
  3. Right click on FormView and choose EditTemplate, EditItemTemplate.
  4. Drag and drop a WebCombo control to ContactName cell in FormView EditTemplate.
  5. Bind WebCombo to AccessDataSource with DisplayMember and ValueMember to ContactName.
  6. Add an event to FormView control called FormView1_ItemCreated and put the following code:

    C# Copy Image Copy Code
    protected void FormView1_ItemCreated(object sender, EventArgs e)
{
   if (FormView1.Row.RowState == DataControlRowState.Edit)
   {
      DataRowView rowView = FormView1.DataItem as DataRowView;
      if (rowView != null)
      {
         string contactName = rowView.Row.ItemArray[2] as string;
         WebCombo combo = FormView1.FindControl("WebCombo1") as WebCombo;
         combo.Value = contactName;
      }
   }
}

  7. Add an event to FormView control called FormView1_ItemUpdating and put the following code:

    C# Copy Code
    protected void FormView1_ItemUpdating(object sender, FormViewUpdateEventArgs e)
{
   WebCombo combo = FormView1.FindControl("WebCombo1") as WebCombo;
   e.NewValues.Add("ContactName", combo.Text);
   ClientScript.RegisterClientScriptBlock(
        typeof(Page), "result",
        "<script language='JScript'>alert('Your selection is: " + combo.Text + "');</script>");
}

See Also

Tasks
How-to: Integrate to GridView
How-to: Integrate to WebGrid


How-to: Integrate to GridView

How-to: Integrate to GridView
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > Advanced How-to Topics > How-to: Integrate to GridView

Glossary Item Box

WebCombo.NET V4.0 is already compatible with the standard infrastructure Microsoft's GridView.

In this topic, you will learn how to integrate WebCombo to GridView.

To integrate WebCombo to GridView

  1. Drag and drop GridView control to the WebForm.
  2. Bind it to Customers table.
  3. Go to properties and choose a ContactName column from Columns collection.
  4. Click Convert this field into a TemplateField.
  5. Right click on GridView and choose EditTemplate, ContactName.
  6. Drag and drop a WebCombo control to ContactName cell in GridView EditTemplate.
  7. Bind WebCombo to AccessDataSource with DisplayMember and ValueMember to ContactName.
  8. Add an event to GridView control called GridView1_RowCreated and put the following code:

    C# Copy Code
    protected void GridView1_RowCreated(object sender, GridViewRowEventArgs e)
{
   if (e.Row.RowState == DataControlRowState.Edit)
   {
      DataRowView drv = e.Row.DataItem as DataRowView;
      if (drv != null)
      {
         TableCell contactNameCell = e.Row.Cells[3];
         WebCombo combo = contactNameCell.FindControl("WebCombo1") as WebCombo;
         combo.Value = drv["ContactName"] as string;
      }
   }
}

  9. Add an event to FormView control called GridView1_RowUpdating and put the following code:

    C# Copy Code
    protected void GridView1_RowUpdating(object sender, GridViewUpdateEventArgs e)
{
   System.Web.UI.WebControls.GridView grid = sender as System.Web.UI.WebControls.GridView;
   WebCombo combo = grid.Rows[e.RowIndex].Cells[3].FindControl("WebCombo1") as WebCombo;
   e.NewValues.Add("ContactName", combo.Text);
   ClientScript.RegisterClientScriptBlock(
       typeof(Page),"result",
       "<script language='JScript'>alert('Your selection is: " + combo.Text + "');</script>");
}

See Also

Tasks
How-to: Integrate to FormView
How-to: Integrate to WebGrid


How-to: Integrate to WebGrid

How-to: Integrate to WebGrid
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > Advanced How-to Topics > How-to: Integrate to WebGrid

Glossary Item Box

WebCombo.NET can be integrated with WebGrid.NET as an EditType. This integration can be specified using WebGrid.NET Designer or programmatically in runtime.

In this topic, you will learn how to integrate WebCombo to WebGrid.

To integrate WebCombo to WebGrid

  1. Drag and drop WebGrid control to the WebForm.
  2. Set AllowEdit property to true in WebGrid.NET Designer.
  3. Drag and drop WebCombo control to the WebForm.
  4. Bind the grid to Products table.
  5. Bind the combo using ISNetDataSource control to Suppliers table.
  6. Go to grid's properties and choose a SupplierID column from Columns collection.
  7. Set its EditType property to WebComboNET.
  8. Go to grid's SupplierID properties - ValueList then set the following properties:

    Property | Value
    DataMember | Suppliers
    DataSource | ISDataSource1
    DataTextField | CompanyName
    DataValueField | SupplierID

  9. Set the WebComboID to wcCategories.
  10. Run the project.

See Also

Tasks
How-to: Integrate to FormView
How-to: Integrate to GridView


How-to: Set FlyPostBackSettings

How-to: Set FlyPostBackSettings
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > Advanced How-to Topics > How-to: Set FlyPostBackSettings

Glossary Item Box

FlyPostBackSettings can be set directly per WebCombo instance by specifying the properties in WebCombo.NET designer.

In this topic, you will learn how to set FlyPostBackSettings using designer.

To set FlyPostBackSettings in WebCombo

  1. Bind WebCombo to AccessDataSource.
  2. Open WebCombo.NET Designer - Advanced Settings - FlyPostBackSettings.
  3. You will find 4 properties to be set:
    • PostControlState
    • PostHiddenFields
    • PostInputControls
    • PostViewState

See Also

Tasks
How-to: Enable XML compression
How-to: Set ScriptDirectory and SharedScriptDirectory
How-to: Set images directory

References
FlyPostBackSettings Property


How-to: Enable XML compression

How-to: Enable XML compression
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > Advanced How-to Topics > How-to: Enable XML compression

Glossary Item Box

Intersoft developed its own compression and decompression algorithm in order to compress the XML storage into 40-60% smaller size. This significantly improves the performance of page load in narrow bandwidth.

In this topic, you will learn how to enable XML compression on WebCombo.

To enable XML compression on WebCombo

  1. Bind WebCombo to AccessDataSource
  2. Open WebCombo.NET Designer - Advanced Settings.
  3. Set XMLCompressionEnabled property to True.

See Also

Tasks
How-to: Set FlyPostBackSettings
How-to: Set ScriptDirectory and SharedScriptDirectory
How-to: Set images directory

References
XmlCompressionEnabled Property


How-to: Set ScriptDirectory and SharedScriptDirectory

How-to: Set ScriptDirectory and SharedScriptDirectory
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > Advanced How-to Topics > How-to: Set ScriptDirectory and SharedScriptDirectory

Glossary Item Box

ScriptDirectory and SharedScriptDirectory can be set directly per WebCombo instance by specifying the properties in WebCombo.NET designer.

In this topic, you will learn how to set these properties from designer.

To set ScriptDirectory and SharedScriptDirectory

  1. Open WebCombo.NET Designer - Advanced Settings.
  2. In Client Script Directory section you will find two properties which are ScriptDirectory and SharedScriptDirectory.
  3. Set ScriptDirectory to /CommonLibrary/WebCombo/V4_0_7200/.
  4. Set SharedScriptDirectory to /CommonLibrary/Shared/.
  5. Click OK to apply the changes.

See Also

Tasks
How-to: Set images directory

Other Resources
Application Wide Configurations

References
ScriptDirectory Property


How-to: Set images directory

How-to: Set images directory
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > Advanced How-to Topics > How-to: Set images directory

Glossary Item Box

ImagesDirectory can be set directly per WebCombo instance by specifying the property in WebCombo.NET designer.

In this topic, you will learn how to set the property from designer.

To set ImagesDirectory on WebCombo

  1. Open WebCombo.NET Designer - Advanced Settings - LayoutSettings.
  2. Set ImagesDirectory to /CommonLibrary/Images/.
  3. Click OK to apply the changes.

See Also

Tasks
How-to: Set ScriptDirectory and SharedScriptDirectory

Other Resources
Application Wide Configurations

References
ImagesDirectory Property


How-to: Implement linked WebCombo functionality using column that is not DataTextField or DataValueField as the FilterDataMember

How-to: Implement linked WebCombo functionality using column that is not DataTextField or DataValueField as the FilterDataMember
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > Advanced How-to Topics > How-to: Implement linked WebCombo functionality using column that is not DataTextField or DataValueField as the FilterDataMember

Glossary Item Box

Using built-in LinkedWebCombo feature, the WebCombo should be populated with the data during initialization.

In this topic, you will learn how to implement linked WebCombo functionality using column that is not DataTextField or DataValueField as the FilterDataMember.

To implement linked WebCombo functionality

  1. Add two instances of WebCombo to the WebForm. Specify the Name as WebCombo1 and WebCombo2 respectively.
  2. Bind WebCombo1 to AccessDataSource. In this sample, you will use Suppliers and Products tables in NorthWind database.
  3. Set AllowAutoQueryHandler property of WebCombo2 to False. AllowAutoDataCaching property will automatically set to False. By setting AllowAutoQueryHandler property to false, you do not need to use the built in query function and thus, developing our own Requery method.

    WebCombo2_InitializeDataSource event will be triggered in every request.
  4. In WebCombo2's InitializeDataSource event, add the following code:

    C# Copy Image Copy Code
    string queryText = "";
DataTable dt = new DataTable("Products");

if(WebCombo1.Value != "" && WebCombo1.Value != null)
{
   queryText = "SupplierID = " + WebCombo1.Value;
   OleDbDataAdapter da = new OleDbDataAdapter("Select * From Products
        Where " + queryText,oleDbConnection1);
   da.FillSchema(dt,SchemaType.Mapped);
   da.Fill(dt);
   e.DataSource = dt;
}

WebCombo2.DataMember = "Products";
WebCombo2.DataTextField = "ProductName";
WebCombo2.DataValueField = "ProductID";

  5. A request is already made when you select a value from WebCombo1. Therefore, you need to define some codes to force a request when you want to load data in WebCombo2. You can put the following code in WebCombo1's OnAfterItemSelected client side events:

    Javascript Copy Code
    function WebCombo1_OnAfterItemSelected(controlId)
{
   var WebCombo2 = ISGetObject("WebCombo2");

   //clears the data list in WebCombo2
   WebCombo2.NeedClearList = true;
   WebCombo2.IsDirty = true;

   return true;
}

  6. User cannot select a value in WebCombo2 before a value is selected in WebCombo1. Hence, you need to define a validation function. Specify a function for WebCombo2's OnBeforeRequest client side events, and add the following code:

    JavaScript Copy Image Copy Code
    function WebCombo2_OnBeforeRequest(controlId, action)
{
   var WebCombo1 = ISGetObject("WebCombo1");
   if(action == "LoadData")
   {
      if(WebCombo1.Value == "" || WebCombo1.Value == null)
      {
         alert("Please select a value for the following webcombo
         input : " + WebCombo1.Name);
         return false;
      }
   }
      return true;
}

  7. Run the project.

See Also

Tasks
How-to: Use combined dependencies linked WebCombo
How-to: Use multiple dependencies linked WebCombo
How-to: Use single dependencies linked WebCombo
How-to: Use unbound linked WebCombo

Concepts
{Linked WebCombo}

References
FilterDataMember Property
AllowAutoQueryHandler Property
DataTextField Property
DataValueField Property
OnAfterItemSelected Property
OnBeforeRequest Property
InitializeDataSource Event


How-to: Use SetAdditionalFilter to filter data from server side

How-to: Use SetAdditionalFilter to filter data from server side
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > Advanced How-to Topics > How-to: Use SetAdditionalFilter to filter data from server side

Glossary Item Box

Sets the additional filter constraints in order to filter the contents of the WebCombo.

In this topic, you will learn how to use AdditionalFilters method.

To use SetAdditionalFilter to filter data from server side

  1. Bind WebCombo to AccessDataSource.
  2. Use the following code to filter text:

    C# Copy Code
    protected void Page_Load(object sender, EventArgs e)
    {
        WebCombo1.AdditionalFiltersText = "City = 'London'";
    }

  3. Run the project.

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics


How-to: Improve FlyPostBack performance

How-to: Improve FlyPostBack performance
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > Advanced How-to Topics > How-to: Improve FlyPostBack performance

Glossary Item Box

This topic will discuss the concept of FlyPostback architecture and how to improve its performance in Internet-zone web applications.

OnTheFly-Postback Introduction

Since introduced in WebCombo.NET V1.0 back in 2002, the FlyPostBack architecture developed by Intersoft Solutions have been significantly enhanced from time to time, until the release of WebUI.NET Framework 2.0.

Today we have seen the trend of AJAX or callback in ASP.NET 2.0, component vendors are now focusing to provide similar functionality to their products. Many of our customers have asked whether AJAX is something similar to our OnTheFly-Postback architecture, or is it something new. In this article, I'll try to explore some comparison of concepts and functionalities between our architecture and the others.

FlyPostback concepts and features

As you may have already know, AJAX is not a technology, it is an approach. It basically means that the approach used Asynchronous Javascript and XML to perform communications between client and server by using XmlHttp request which is supported by most modern browsers. So the whole idea is XmlHttp request. However, XmlHttp is not a new thing, it has been existed since 2001 when Microsoft introduced Internet Explorer 5.0. The point is, it is just getting attention and becomes popular recently as Gecko and Opera started to support it.

FlyPostback architecture is not just about using XmlHttp request to perform out-of-band callbacks to server and then obtain the response from server. FlyPostback is kind of framework or engine which built on the top of XmlHttp plus our own features implementation to bring a new standards for our ASP.NET components product line.

To clearly understand the concept of FlyPostback architecture, I've listed some of the unique features below which can't be accomplished by other similar XmlHttp-based approach:

  • Full ASP.NET Framework and Page support

    It means that FlyPostback supports any kind of ASP.NET Framework scenarios and page life cycle. For example, you can use inline <% %> server side codes in the aspx and the FlyPostback can still perform perfectly. The FlyPostback can work seamlessly and do not require you to configure HttpModule or any changes in your web configuration file.

  • ViewState restoration.

    Unlike other XmlHttp approach, FlyPostback automatically restores the viewstate of all server controls available in the Page. This enables developers to be able to obtain other controls' value while in the FlyPostback context.

  • Controls state and input parameters

    All products that built on the top of FlyPostback architecture such as WebGrid.NET Enterprise and WebCombo.NET will have its state automatically maintained by the FlyPostback architecture. This is very crucial and important for developers in order to extend the products functionalities to fit their custom logics. For example, I can get the selected object of WebGrid1 instance while the current context of FlyPostback is initiated by WebGrid2. I will then be able to populate data based on the selection made in WebGrid1. Remember that we're on FlyPostback context, not a full page postback.

    I can also add custom parameters and send it along with the FlyPostback request, for example, adding additional data or flag during updating row. It can be easily done by using AddInput() method which is applicable to all products that supported FlyPostback.

Improving FlyPostback performance

Now, the interesting part of this article is how we can improve the performance of FlyPostback. By understanding the concepts and features above, we clearly understand that FlyPostback architecture posted quite a lot of data during the request. There is no significant performance issues when the application is running in intranet or extranet zone, however when utilized in public website -- and especially when end users used narrow-bandwith, it is noticable that the FlyPostback request is a bit slow in the response.

In WebUI.NET Framework 2.0, we have developed a few properties which developers can configure in order to turn off specific features of FlyPostback in case they did not utilize it in their applications. Many of our customers still have not aware of these capabilities and hopefully with this article, they would be able to set best configuration to use for their applications.

Following are the list of features which may be turned off to improve the response time of FlyPostback request. These settings can be found in FlyPostbackSettings object in control's instance:

  • PostViewState.

    The value is True by default. When set to true, FlyPostback will automatically restores the viewstate of all server controls available in the page. So, if you do not access other controls' properties in FlyPostback context, you can safely set this property to False. This will give significant improvement especially when the viewstate of the Page is large.

  • PostHiddenFields.

    The default value is True. If you do not access hidden fields on page load or in FlyPostback requests, you can safely turn off this feature by setting it to False.

  • PostInputControls.

    The default value is False. This feature enables you to get the latest value for the html input fields in the FlyPostback context. If you do not need to access other controls' value (such as TextBox's value), then you should have this property's value remain False.

  • PostControlState.

    This is a new property added in WebUI.NET Framework Build 12. The default value is True. In previous build, you have to turn on PostHiddenFields in order for the FlyPostback's control to maintain its state properly during request. However, since PostHiddenFields also send out other controls' hidden fields, it becomes ineffective and causing slower response time due to larger post data. Now, you can safely turn off PostHiddenFields and leaving this property value to True.

    The control state is the most interesting point in the features above since it needs to be configured properly, otherwise client interactions will react improperly. The best value for this configuration is based on the nature of product and which features are enabled. For example, in WebCombo, you may turn off this feature since WebCombo did not have as much client interaction as in WebGrid. As for WebGrid, this feature is recommended to be turned on (by default). There are however, certain scenarios where you can safely turn off this feature in WebGrid. For instance, if your Grid instance does not require clientside user interactions features such as column moving, resizing, sorting, filtering or others, then you can safely turn off this feature. These scenarios are suitable for application which require only hierarchical load on demand Grid mode or self hierarchical load on demand feature.

By summary, if you do not access other controls' value or properties, here's the most recommended FlyPostBackSettings:

For WebCombo.NET 3.0:

  • PostViewState = False
  • PostHiddenFields = False
  • PostInputControls = False
  • PostControlState = False

For WebGrid.NET Enterprise 4.0:

  • PostViewState=False
  • PostHiddenFields=False
  • PostInputControls=False
  • PostControlState=True

With above configurations, you'll get a significant response time improvement of every FlyPostback requests by at least 60%. Thus, if previously it needs 3 seconds to load WebCombo during dropdown, you'll now get the results in 1 or 1.5 seconds. Again, note that the context of this article is using narrow-bandwith protocols such as dialup

Conclusion

As a proof of concept, we have also modified our live samples to use minimal features since they are not utilized in common basic scenarios. For WebCombo, please take a look and play with the "Basic" sample. For WebGrid, play with the "Hierarchical" sample. Then, compare with other samples. You'll be able to see significant response time improvement in both samples mentioned above.

As a final note, you would need to update to latest build for the framework and all products in order to take advantage of some of the new functionalities.

The Future

Our current FlyPostback architecture enables the options to provide richer functionalities, or to tradeoff between speed and functionalities. In the future, we would provide a new breakthrough in the server communication architecture, enabling both rich functionalities and speed to work in harmony.

See Also

Other Resources
{Improved Data Caching}

References
FlyPostBackSettings Property


How-to: Set result box window type

How-to: Set result box window type
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > Advanced How-to Topics > How-to: Set result box window type

Glossary Item Box

By default, result box window type is set to Popup. However, you can change this property to normal type.

In this topic, you will learn how to set result box window type from designer.

To set result box window type

  1. Open WebCombo.NET Designer - Advanced Settings - LayoutSettings.
  2. Set ResultBoxWindowType to Normal.
  3. Click OK to apply the changes.

See Also

Tasks
FAQ: How to use WebCombo in dual monitor?

References
ResultBoxWindowType Property


How-to: Use multiple columns mode

How-to: Use multiple columns mode
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > Advanced How-to Topics > How-to: Use multiple columns mode

Glossary Item Box

Instead of singe column, you can use multiple columns in WebCombo.

In this topic, you will learn how to set multiple columns from designer.

To use multiple columns mode

  1. Bind WebCombo to AccessDataSource.
  2. Open WebCombo.NET Designer - Advanced Settings - LayoutSettings.
  3. Set ComboMode to MultipleColumns.
  4. Go to Column and Rows and select Displays multiple columns in the result box of this control instance.
  5. Add the columns that you want to display.
  6. Click OK to apply the changes and run the project.

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

References
WebComboColumn Class
ComboMode Property


How-to: Apply load on demand in WebCombo

How-to: Apply load on demand in WebCombo
See Also Send Feedback
Intersoft WebCombo > WebCombo Advanced Features > Advanced How-to Topics > How-to: Apply load on demand in WebCombo

Glossary Item Box

Retrieves data rows manually from DataSource based on user's queryText, startRow, rowCount and other properties that are available to the context. This feature allows faster and more effective partial data rows retrieval against a very large DataSource.

In this topic, you will learn how to apply load on demand in WebCombo.

To apply load on demand in WebCombo

  1. Drag and drop WebCombo instance to the form.
  2. Bind WebCombo to ISDataSource control.
  3. In ISDataSource control, set the following properties:

    Property | Value
    EnablePaging | True
    SelectCountMethod | SelectCount
    MaximumRowsParameterName | maximumRows
    StartRowIndexParameterName | startRowIndex
    SelectMethod | GetData
    TableName | Customers

  4. Open WebCombo.NET Designer - Advanced Settings.
  5. Set AllowAutoQueryHandler to False.
  6. Click OK to apply the changes.

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

References
AllowAutoQueryHandler Property
DataSource Property


Learning More

Learning More
See Also Send Feedback
Intersoft WebCombo > Learning More

Glossary Item Box

The topics in this section provide essential information on getting familiar with SmartTag Designer, learning how to do data binding using Data Source object and control and working with Designer.

In This Section

Walkthrough: Getting Started with WebCombo.NET version 4.0 using SmartTag Designer
Learn how to get familiar with data binding in WebCombo using DataSource object and control.

Data Binding Techniques using Data Source Object
Learn how to bind WebCombo with various DataSource object such as DataSet and others.

Data Binding Techniques using Data Source Control
Learn how to bind WebCombo with various DataSource control such as AccessDataSource and others.

Retrieving data using Load-on-Demand feature in ISDataSource control
Learn how to retrieve data using load on demand with ISDataSource.

Working with Designer
Learn how to use and customize properties in WebCombo.NET Designer.

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

Other Resources
Advanced
Features and Concepts


Walkthrough: Getting started with WebCombo.NET version 4.0 using SmartTag Designer

Walkthrough: Getting started with WebCombo.NET version 4.0 using SmartTag Designer
See Also Send Feedback
Intersoft WebCombo > Learning More > Walkthrough: Getting started with WebCombo.NET version 4.0 using SmartTag Designer

Glossary Item Box

This walkthrough shows you how to getting started using SmartTag designer.

During this walkthrough, you will learn how to do the following:

  • Use SmartTagDesigner.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005 Application.

Step-By-Step Instructions

To use SmartTagDesigner in WebCombo.NET Version 4.0

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebCombo instance from ToolBar to WebForm.
  8. Click the SmartTag on the upper right of the WebCombo.

  9. In ChooseDataSource field you can choose DataSource that you want to use.
  10. In Display Member field you can set the DataTextField.
  11. In Value Member field you can set DataValueField.
  12. Run the project.

See Also

Other Resources
Data Binding Techniques using Data Source Object
Data Binding Techniques using Data Source Control
Retrieving data using Load-on-Demand feature in ISDataSource control
Working with Designer

References
DataSource Property
DataTextField Property
DataValueField Property


Data Binding Techniques using Data Source Object

Data Binding Techniques using Data Source Object
Send Feedback
Intersoft WebCombo > Learning More > Walkthrough: Getting started with WebCombo.NET version 4.0 using SmartTag Designer > Data Binding Techniques using Data Source Object

Glossary Item Box

WebCombo 4.0 introduces data binding techniques using DataSource object such as DataSet, DataTable and others.

In This Section

Walkthrough: Binding WebCombo to a DataSet

Walkthrough: Binding WebCombo to XML-based DataSource

Walkthrough: Binding WebCombo to IList DataSource control

Walkthrough: Binding WebCombo to custom object


Data Binding Techniques using Data Source Control

Data Binding Techniques using Data Source Control
Send Feedback
Intersoft WebCombo > Learning More > Walkthrough: Getting started with WebCombo.NET version 4.0 using SmartTag Designer > Data Binding Techniques using Data Source Control

Glossary Item Box

WebCombo 4.0 introduces data binding techniques using DataSource controls such as AccessDataSource, SqlDataSource and others.

In This Section

Walkthrough: Binding WebCombo to AccessDataSource control

Walkthrough: Binding WebCombo to ObjectDataSource control

Walkthrough: Binding WebCombo to ISDataSource control

Walkthrough: Binding WebCombo to SqlDataSource control

Walkthrough: Binding WebCombo to XMLDataSource control

Walkthrough: Binding WebCombo to DataSet using ISDataSource control

Wakthrough: Binding WebCombo to custom object using ISDataSource control


Walkthrough: Binding WebCombo to DataSet using ISDataSource control

Walkthrough: Binding WebCombo to DataSet using ISDataSource control
See Also Send Feedback
Intersoft WebCombo > Learning More > Walkthrough: Getting started with WebCombo.NET version 4.0 using SmartTag Designer > Data Binding Techniques using Data Source Control > Walkthrough: Binding WebCombo to DataSet using ISDataSource control

Glossary Item Box

This walkthrough shows you how to create and bind WebCombo to a DataSet using ISDataSource control.

During this walkthrough, you will learn how to do the following:

  • Use ISDataSource.
  • Use SmartTag to set DataSource.
  • Use Data Source Configuration Wizard to set the Database and table.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

To create new web application and bind WebCombo to ISDataSource

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebCombo instance from ToolBar to WebForm.
  8. Click the SmartTag on the upper right of the WebCombo.
  9. Set the DataTextField and DataValueField for WebCombo.
  10. In Choose Data Source field, choose <New data source...>.

  11. In Data Source Configuration Wizard, choose ISDataSource and click OK.

  12. Select the dataset that you want to use and click Next.

  13. Add the table required and click Finish.

  14. Run the project.

See Also

Tasks
Walkthrough: Binding WebCombo to AccessDataSource control
Walkthrough: Binding WebCombo to ObjectDataSource control
Walkthrough: Binding WebCombo to SqlDataSource control
Walkthrough: Binding WebCombo to XMLDataSource control
Walkthrough: Getting started with WebCombo.NET version 4.0 using SmartTag Designer


Retrieving data using Load-on-Demand feature in ISDataSource control

Retrieving data using Load-on-Demand feature in ISDataSource control
See Also Send Feedback
Intersoft WebCombo > Learning More > Walkthrough: Getting started with WebCombo.NET version 4.0 using SmartTag Designer > Retrieving data using Load-on-Demand feature in ISDataSource control

Glossary Item Box

This walkthrough shows you how to retrieving data using Load-on-Demand feature in ISDataSourcecontrol.

During this walkthrough, you will learn how to do the following:

  • Use ISDataSource.
  • Use SmartTag to set DataSource.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

To create new web application and bind WebCombo to CustomObject

  1. Create DataSet named NorthWind.
  2. Create partial class CustomersTableAdapter.
    C# Copy Image Copy Code
    using System;
using System.Data;
using System.Configuration;
using System.Web;
using System.Web.Security;
using System.Web.UI;
using System.Web.UI.WebControls;
using System.Web.UI.WebControls.WebParts;using System.Web.UI.HtmlControls;using System.Data.OleDb;

namespace NorthWindTableAdapters
{
   public partial class CustomersTableAdapter
   {
      public DataTable GetData(int maximumRows, int startRowIndex)
      {
         int topRows = startRowIndex + maximumRows;
         OleDbDataAdapter adapter = new OleDbDataAdapter("SELECT TOP " + topRows + " * FROM Customers", this.Connection);
         NorthWind.CustomersDataTable baseData = new NorthWind.CustomersDataTable();
         adapter.Fill(startRowIndex, maximumRows, new DataTable[] { baseData });
         return baseData;
      }

      public DataTable GetData(int maximumRows, int startRowIndex, string queryText)
      {
         NorthWind.CustomersDataTable baseData = new NorthWind.CustomersDataTable();

         if (string.IsNullOrEmpty(queryText))
            queryText = string.Empty;

         // do not need to populate data in first load or standard postback, without value (queryText is empty)
         if (maximumRows == 0 && startRowIndex == 0 && string.IsNullOrEmpty(queryText))
            return baseData;

         if (maximumRows > 0)
         {
             // retrieves a list of data based on given startRow and maxRow
             int topRows = startRowIndex + maximumRows;
             OleDbDataAdapter adapter = new OleDbDataAdapter("Select TOP " + topRows + " * FROM Customers WHERE ContactName LIKE '" + queryText + "%'", this.Connection);
             adapter.Fill(startRowIndex, maximumRows, new DataTable[] { baseData });
         }
         else
         {
            // bind to single value, this will be called during first load or postback, and value is filled.
           // note that the query is made against value field.
           if(!string.IsNullOrEmpty(queryText))
           {
              OleDbDataAdapter adapter = new OleDbDataAdapter("Select * from Customers Where CustomerID =  '" + queryText + "'", this.Connection);
              adapter.Fill(baseData);
           }
        }
        return baseData;
   }

   public int SelectCount(string queryText)
   {
         OleDbDataAdapter myDa = new OleDbDataAdapter();

         string selectCommand = "Select Count(*) From customers Where contactName like '" + queryText + "%'";
         myDa.SelectCommand = new OleDbCommand(selectCommand, this.Connection);

         this.Connection.Open();
         int result = (int)myDa.SelectCommand.ExecuteScalar();
         this.Connection.Close();
         return result;
      }
   }
}
  3. Drag ISDataSource instance from ToolBar to WebForm.
  4. Bind the DataSet to ISDataSource.
  5. Open ISDataSource.NET Designer.
  6. Set EnablePaging = Yes
    SelectCountMethod = "SelectCount"
    MaxiumRowsParameterName ="maximumRows"
    StartRowIndexParameterName     ="startRowIndex"
  7. Drag WebCombo instance from ToolBar to WebForm.
  8. Click the SmartTag on the upper right of the WebCombo.
  9. Set DataSource to ISDataSource
  10. Set the DataTextField and DataValueField for WebCombo.

For more information, please refer to WebCombo.NET V4.0 Sample - LoadOnDemand.aspx

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics


Working with Designer

Working with Designer
See Also Send Feedback
Intersoft WebCombo > Learning More > Working with Designer

Glossary Item Box

This topic guides you to get familiar with Intersoft's rich WebCombo Component Designer.

In This Section

How-to: Add Columns to WebCombo
Learn how to add columns using WebCombo Designer.

How-to: Add Rows to WebCombo
Learn how to add rows using WebCombo Designer.

Define the styles
Read about customizing styles in WebCombo Designer.

Cache
Read about automatic data caching handled by WebCombo.

Performance Tuning
Learn how to customize performance tuning in WebCombo Designer.

Layout Manager
Read about applying updated predefined styles using WebCombo Designer.

Client side Event Designer
Learn how to attach a client-side event handler to the event using the Client-side Event Editor.

See Also

Other Resources
Styles


How-to: Add columns to WebCombo

How-to: Add columns to WebCombo
See Also Send Feedback
Intersoft WebCombo > Learning More > Working with Designer > How-to: Add columns to WebCombo

Glossary Item Box

WebCombo.NET V4.0 has the ability to implement the control by using improved server-side object models. You can easily add multiple columns and row items in a single interface WebCombo.NET Designer(Centralized). The columns and rows can also be added dynamically at runtime.

This topic will show you how to add columns to WebCombo using WebCombo designer.

To add columns to the WebCombo

  1. Right click on the WebCombo instance and select WebCombo.NET Designer.
  2. Go to Columns and Rows then press the green "+" button to add new column (you can add more than one column).
  3. Set the Bound property to True if you want the column type in Bound mode, and False if you want to set it to unbound mode.
  4. Check the Displays multiple columns in the result box of this control instance if you want to set the combo's resultbox in multiple columns.
  5. Run the project.

Here is the snapshot to create columns in WebCombo.NET Designer:

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
Cleaner and reduced page output through built-in Default Style

References
WebComboColumn Class
WebComboRow Class
BoundMode Property


How-to: Add rows to WebCombo

How-to: Add rows to WebCombo
See Also Send Feedback
Intersoft WebCombo > Learning More > Working with Designer > How-to: Add rows to WebCombo

Glossary Item Box

WebCombo.NET 4.0 allows you to add rows easily by using the WebCombo.NET designer.

This topic will show you how to add rows to combo.

To add rows to the WebCombo

Here is the snapshot to create Unbound mode in WebCombo.NET Designer:

Rows

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

Concepts
All-new, sleeker User Interface
Cleaner and reduced page output through built-in Default Style

References
WebComboColumn Class
WebComboRow Class
BoundMode Property


Define the styles

Define the styles
See Also Send Feedback
Intersoft WebCombo > Learning More > Working with Designer > Define the styles

Glossary Item Box

When default style is enabled, the overall of page performance is significantly increased because individual style per control are not required. WebCombo.NET V4.0 automatically includes single external stylesheet for the default style in outpage page which can take advantage of cache and browser compression.

When the default style is enabled, there is no need to specify the individual styles in the control.

See Also

Concepts
New User Interface Features
Cleaner and reduced page output through built-in Default Style

Related Sections
Cache
Performance Tuning
Layout Manager
Client side Event Designer

References
UseDefaultStyle Property


Cache

Cache
See Also Send Feedback
Intersoft WebCombo > Learning More > Working with Designer > Cache

Glossary Item Box

WebCombo.NET control includes automatic data caching feature to help reducing database workload. When enabled, a copy of datasource per user session will be stored in cache. As long as the cache is still valid and active, WebCombo will use the cached data for all data-aware functions, including during AJAX callback and full page postback.

See Also

Concepts
All-new, sleeker User Interface
Cleaner and reduced page output through built-in Default Style

Related Sections
Define the styles
Performance Tuning
Layout Manager
Client side Event Designer

References
DataCacheStorage Property
AllowAutoDataCaching Property


Performance Tuning

Performance Tuning
See Also Send Feedback
Intersoft WebCombo > Learning More > Working with Designer > Performance Tuning

Glossary Item Box

WebCombo.NET V4.0 designer also provides you with Performance Tuning ability that will help to improve the performance for WebCombo.

Performance Tuning in WebCombo.NET Version 4.0 can be grouped into 3 categories :

  1. Client performance -> The tuning significantly reduces page output size which results in faster page response.
  2. Server Performance -> You can gain better page throughput and performance by using appropriate Cache configuration and ViewState setting.
  3. AJAX performance(Advanced) -> By properly configuring the following settings, you can significantly improve AJAX's callback performance. These settings are applicable only in DataBound mode.

See Also

Concepts
All-new, sleeker User Interface
Cleaner and reduced page output through built-in Default Style

Related Sections
Define the styles
Cache
Layout Manager
Client side Event Designer


Layout Manager

Layout Manager
See Also Send Feedback
Intersoft WebCombo > Learning More > Working with Designer > Layout Manager

Glossary Item Box

WebCombo.NET V4.0 comes with much improved Layout Manager functionality to provide robust and rock-solid layout persistence mechanism. One of the most significant improvement in the new Layout Manager is its consistent and fast performance to persist into XML-based format. It can also load the XML Layout file in either Designer or programmatically. Previously, the Layout Manager produces Binary format which invokes some issues in compatibility between builds and major versions.

The other significant innovation in the new Layout Manager is the time-saving "OnTheFly Preview" feature. You no longer need to perform "Set-Save-Build" operations in order to see the reflected result, you can now simply click a button to see the real preview of a predefined or custom style using the current configured behaviors in the Preview Pane window.

The new Layout Manager which now inherited from the WebUI.NET Framework exposes a function to persist Style-Only or StyleWithBehavior mode. The persistence architecture intelligently applies the defined styles and attributes existed in the Layout file while leaving other non-style-related properties as it is. The end goal for the feature is to be able to consistently and reliably persist and load layout flawlessly during both Design and Runtime. The Theme Architecture introduced by the Framework is using the same persistence architecture as well.

In This Section

How-to: Apply Predefined Layout

How-to: Save Current Layout

How-to: Apply Saved Layout

How-to: Preview Layout

See Also

Concepts
New User Interface Features
Cleaner and reduced page output through built-in Default Style

Related Sections
Define the styles
Cache
Performance Tuning
Client side Event Designer


How-to: Apply Predefined Layout

How-to: Apply Predefined Layout
See Also Send Feedback
Intersoft WebCombo > Learning More > Working with Designer > Layout Manager > How-to: Apply Predefined Layout

Glossary Item Box

By default, WebCombo.NET is equipped with 15 predefined layouts, such as 'Default', 'Default 3D', 'Default 2005' etc.

Here are step-by-step procedures :

  1. In the Visual Studio .NET IDE, right-click an instance of WebCombo and choose WebCombo.NET Designer. Click on the Layout Manager. When Layout Manager section is clicked, developers will be presented with below snapshot:

  2. When developers want to apply a predefined layout such as Mac OS X Tiger, simply double-click that entry. The below snapshot shows the result:

  3. Remember to click the Apply button in order to apply the new predefined layout. When it is finished, the combo will show the following snapshot :

  4. Click OK button to apply the changes. In the Visual Studio.NET IDE, the combo layout will be changed into the new layout.

See Also

Tasks
How-to: Save Current Layout
How-to: Apply Saved Layout
How-to: Preview Layout

Concepts
Layout Manager

References
UseDefaultStyle Property


How-to: Save Current Layout

How-to: Save Current Layout
See Also Send Feedback
Intersoft WebCombo > Learning More > Working with Designer > Layout Manager > How-to: Save Current Layout

Glossary Item Box

Developers can save the current layout of WebCombo into *.isl file. Therefore, it could be retrieved easily in the future.

Here are step by step procedures :

  1. Try to modify the RowStyle BackColor into LightCoral using WebCombo.NET Designer - AdvanceSettings. This style will be saved into an *.isl file.

  2. Click on the Layout Manager, developers will be presented with below snapshot:

  3. Click the Save button in order to save the combo's current layout into a file.

  4. Try to open the saved *.isl file using a Text Editor. Notice that the modified RowStyle is saved into the file.

See Also

Tasks
How-to: Apply Predefined Layout
How-to: Apply Saved Layout
How-to: Preview Layout

Concepts
Layout Manager


How-to: Apply Saved Layout

How-to: Apply Saved Layout
See Also Send Feedback
Intersoft WebCombo > Learning More > Working with Designer > Layout Manager > How-to: Apply Saved Layout

Glossary Item Box

Developers can easily apply their past saved layout which is retrieved from the *.isl file.

Here are step by step procedures:

  1. We are trying to apply our custom layout into the combo.

  2. In the Visual Studio.NET IDE, right-click an instance of WebCombo and choose WebCombo.NET Designer. Click on Layout Manager. When Layout Manager section is clicked, developers will be presented with below snapshot:

  3. Click the Add Layout button in order to add developers'custom layout into the Layout Manager. In this sample, we are retrieving layout1.isl into the Layout Manager. When it is succeed, the 'layout1.isl' should be listed in the Custom Layout part in the left pane.

  4. Click the Apply button to apply the current layout.

See Also

Tasks
How-to: Apply Predefined Layout
How-to: Save Current Layout
How-to: Preview Layout

Concepts
Layout Manager


How-to: Preview Layout

How-to: Preview Layout
See Also Send Feedback
Intersoft WebCombo > Learning More > Working with Designer > Layout Manager > How-to: Preview Layout

Glossary Item Box

By default, WebCombo.NET is equipped with 15 predefined layouts, such as 'Default', 'Default 3D', 'Default 2005' etc.

Here are step-by-step procedures :

  1. In the Visual Studio .NET IDE, right-click an instance of WebCombo and choose WebCombo.NET Designer. Click on the Layout Manager. When Layout Manager section is clicked, developers will be presented with below snapshot:

  2. When developers want to apply a predefined layout such as Mac OS X Tiger, simply double-click that entry. The below snapshot shows the result :

  3. Remember to click the Apply button in order to apply the new predefined layout. When it is finished, the combo will show the following snapshot :

  4. Click the Preview button in order to see the preview of the current layout.

  5. Click the OK button to apply the changes. In the Visual Studio .NET IDE, the combo layout will be changed into the new layout.

See Also

Tasks
How-to: Apply Predefined Layout
How-to: Save Current Layout
How-to: Apply Saved Layout

Concepts
Layout Manager


Client side Event Designer

Client side Event Designer
See Also Send Feedback
Intersoft WebCombo > Learning More > Working with Designer > Client side Event Designer

Glossary Item Box

One of WebCombo's most powerful features is the ability to accommodate a broad range of scenarios through its extendable capability using client-side events. In this section, we will see how we can attach a client-side event handler to the event using the Client-side Event Editor.

Assuming that you already have the combo bound to a data source and there is data to be displayed, the steps needed are as following:

  1. Switch to design view of the page and right-click on the combo, then select Properties.
  2. In the Properties tab, expand LayoutSettings - ClientSideEvents nodes.

  3. Find the OnAfterItemSelected event and click the drop down arrow. In the drop down list you will see an item Add New Handler - WebCombo1_OnAfterItemSelected_1(controlId) and/or other event handler names if the page has already contained other client-side event handlers.
  4. Click on the Add New Handler... item. The page will then automatically switch to HTML view and the event handler will be automatically added.

See Also

Related Sections
Define the styles
Cache
Performance Tuning
Layout Manager

References
ClientEvents Class


Server-side References

Server-side References
Send Feedback
Intersoft WebCombo > Server-side References

Glossary Item Box

This section is designated to help user working with server-side references in WebCombo.


ISNet.WebUI.WebCombo Namespace

ISNet.WebUI.WebCombo Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | BaseEventArgs | The base class for all event arguments classes. The ReturnValue allows events to be cancelled to skip default event behavior. The base class for all event arguments classes. The ReturnValue allows events to be cancelled to skip default event behavior.
Class | Cells | Represents an individual data item when ComboMode is set to MultipleColumns. Class Cells
Class | ClientEvents | Provides a centralized class for client side events. Provides a centralized class for client side events.
Class | Columns | Columns object provides a collection for the columns contained in WebGrid control. Columns object provides a collection for the columns contained in WebGrid control.
Class | DataSourceEventArgs | Provides data for datasource related event. Provides data for datasource related event.
Class | FieldTypeEditor | Summary description for FieldTypeEditor. Summary description for FieldTypeEditor.
Class | LayoutEventArgs | Provides data for layout related event. Provides data for layout related event.
Class | LayoutSet | LayoutSet in WebCombo.NET 4.0 provides a centralized access to control the behavior and styles of the whole WebCombo object. This class allows users to manage the behavior and styles for almost the whole control's part. LayoutSet provides a centralized access to configure the behaviors and styles of the WebCombo control.
Class | LinkSettings | LinkSettings class provides information about WebCombo links configurations. LinkSettings class provides information about WebCombo links configurations.
Class | MultipleSelectionSettings | Provides advanced settings related to the MultipleSelection feature.
Class | PostBackAction | Class that contains string constants for OnTheFly post back actions. Class that contains string constants for OnTheFly post back actions.
Class | PostbackEventArgs | Provides data for OnTheFly postback event. Provides data for OnTheFly postback event.
Class | Presets | Presets class contains static methods that are used to initialize default styles and provides centralized access for other predefined styles. Presets class contains static methods that are used to initialize default styles and provides centralized access for other predefined styles.
Class | RowEventArgs | Provides data for row related event. Provides data for row related event.
Class | Rows | A collection of Rows objects that represent the rows of the WebCombo control. A collection of Rows objects that represent the rows of the WebCombo control.
Class | TextSet | Provides a centralized access for customizing texts which used in WebCombo control. Provides a centralized access for customizing texts which used in WebCombo control.
Class | ValueChangedEventArgs | Events class contains all event argument definitions that are used in WebCombo control. Events class contains all event argument definitions that are used in WebCombo control.
Class | WebCombo | WebCombo is the main control object. WebCombo provides advanced data-bound functionality without additional server pages or components. The LayoutSettings property contains many of the appearance and layout settings for WebCombo. WebCombo is the main control object. The LayoutSettings property contains many of the appearance and layout settings for WebCombo. WebCombo provides advanced data-bound functionality without additional server pages or components.
Class | WebComboCell | Represents an individual data item when ComboMode is set to MultipleColumns. Represents an individual data item when ComboMode is set to MultipleColumns.
Class | WebComboColumn | The Column object contains properties to customize basic column information such as ColumnType, HeaderText and Width. This class should be used only when ComboMode is set to MultipleColumns. The Column object contains properties to customize basic column information such as HeaderText and Width. This class should be used only when LayoutSet.ComboMode is set to MultipleColumns
Class | WebComboIntegrationSettings | Provides settings for integrating other server side controls as the WebCombo's ResultBox.
Class | WebComboRow | Represents the data row that belongs to WebCombo object. Represents the data row that belongs to WebCombo object.
Class | WebComboValueItem | Items contained in WebCombo multiple selection.

Delegates

 | Delegate | Description
Delegate | DataSourceEventHandler | Delegate that handles the InitializeDataSource event.Delegate that handles the WebCombo.InitializeDataSource event.
Delegate | LayoutEventHandler | Delegate that handles the InitializeLayout event.Delegate that handles the WebCombo.InitializeLayout event.
Delegate | PostBackEventHandler | Delegate that handles the InitializePostBack event.Delegate that handles the WebCombo.InitializePostBack event.
Delegate | RowEventHandler | Delegate that handles the InitializeRow event.Delegate that handles the WebCombo.InitializeRow event.
Delegate | ValueChangedEventHandler | The delegate that handles the ValueChanged event, which is invoked when the value of WebCombo control is changed.The delegate that handles the WebCombo.ValueChanged event, which is invoked when the value of WebCombo control is changed.

Enumerations

 | Enumeration | Description
Enumeration | BoundMode | Value representing the bound mode of WebCombo.
Enumeration | BoxPosition | Value indicating where the status box is located. Enumerations for status of WebCombo control.
Enumeration | ButtonPosition | Value indicating the search button position on WebCombo.NET
Enumeration | ColLayout | Value indicating the column layout style of WebCombo. Enumerations for column layout.
Enumeration | ColumnType | Value representing the column type of WebCombo ColumnType Enumeration.
Enumeration | EmptyAction | Value indicating the action to be performed when this WebCombo is selected while the specified ParentWebCombo has no value.
Enumeration | EntryMode | Value representing the entry behavior of WebCombo.NET
Enumeration | IntegrationControlType |
Enumeration | LoadMoreKeyGesture |
Enumeration | Mode | Value representing the Combo mode of WebCombo.NET Enumerations for WebCombo's mode.
Enumeration | NoResultFoundAction | Value indicating the action if the user has typed in a value and switched to another input, but no results found for the typed value.
Enumeration | ParentFilterMode | Value indicating which key field of the parent WebCombo that should be used for filtering this WebCombo data.
Enumeration | SearchMode | Value indicating the search icon mode of WebCombo.NET Enumerations for SearchIcon's mode.
Enumeration | TextboxMode | Value indicating the text box mode on WebCombo.NET TextboxMode Enumeration.

See Also

Reference

ISNet.WebUI.WebCombo Assembly


ISNet.WebUI.WebCombo Namespace Inheritance Hierarchy

ISNet.WebUI.WebCombo Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
ISNet.WebUI.ISCollectionBase
System.Collections.CollectionBase
ISNet.WebUI.WebCombo.Cells
ISNet.WebUI.WebCombo.Columns
ISNet.WebUI.WebCombo.Rows
ISNet.WebUI.ISNetControl
System.Web.UI.WebControls.WebControl
System.Web.UI.Control
ISNet.WebUI.WebCombo.WebCombo
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebCombo.WebComboCell
ISNet.WebUI.WebCombo.WebComboColumn
ISNet.WebUI.WebCombo.WebComboRow
ISNet.WebUI.WebCombo.PostBackAction
ISNet.WebUI.WebCombo.Presets
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebCombo.ClientEvents
ISNet.WebUI.WebCombo.LayoutSet
ISNet.WebUI.WebCombo.LinkSettings
ISNet.WebUI.WebCombo.MultipleSelectionSettings
ISNet.WebUI.WebCombo.TextSet
ISNet.WebUI.WebCombo.WebComboIntegrationSettings
ISNet.WebUI.WebCombo.WebComboValueItem
System.Drawing.Design.UITypeEditor
ISNet.WebUI.WebCombo.FieldTypeEditor
System.EventArgs
ISNet.WebUI.WebCombo.BaseEventArgs
ISNet.WebUI.WebCombo.DataSourceEventArgs
ISNet.WebUI.WebCombo.LayoutEventArgs
ISNet.WebUI.WebCombo.PostbackEventArgs
ISNet.WebUI.WebCombo.RowEventArgs
ISNet.WebUI.WebCombo.ValueChangedEventArgs

See Also

Reference

ISNet.WebUI.WebCombo Assembly


BaseEventArgs Class

[image]
Intersoft WebCombo Documentation
BaseEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : BaseEventArgs Class

The base class for all event arguments classes. The ReturnValue allows events to be cancelled to skip default event behavior. The base class for all event arguments classes. The ReturnValue allows events to be cancelled to skip default event behavior.

Object Model

BaseEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class BaseEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As BaseEventArgs
C#
public class BaseEventArgs : System.EventArgs
Delphi
public class BaseEventArgs = class(System.EventArgs)
JScript
public class BaseEventArgs extends System.EventArgs
Managed Extensions for C++
public __gc class BaseEventArgs : public System.EventArgs
C++/CLI
public ref class BaseEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebCombo.BaseEventArgs
ISNet.WebUI.WebCombo.DataSourceEventArgs
ISNet.WebUI.WebCombo.LayoutEventArgs
ISNet.WebUI.WebCombo.PostbackEventArgs
ISNet.WebUI.WebCombo.RowEventArgs
ISNet.WebUI.WebCombo.ValueChangedEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BaseEventArgs Members
ISNet.WebUI.WebCombo Namespace


BaseEventArgs Class Members

[image]
Intersoft WebCombo Documentation
BaseEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebCombo Namespace : BaseEventArgs Class

The following tables list the members exposed by BaseEventArgs.

Public Constructors

 | Name | Description
public Constructor | BaseEventArgs Constructor | Initializes a new instance of the BaseEventArgs class.
Top

Public Properties

 | Name | Description
public Property | ReturnValue |
Top

See Also

Reference

BaseEventArgs Class
ISNet.WebUI.WebCombo Namespace


BaseEventArgs Constructor

[image]
Intersoft WebCombo Documentation
BaseEventArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > BaseEventArgs Class : BaseEventArgs Constructor

Initializes a new instance of the BaseEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New BaseEventArgs()
C#
public BaseEventArgs()
Delphi
public BaseEventArgs();
JScript
public function BaseEventArgs();
Managed Extensions for C++
public: BaseEventArgs();
C++/CLI
public:
BaseEventArgs();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BaseEventArgs Class
BaseEventArgs Members


BaseEventArgs Class Properties

[image]
Intersoft WebCombo Documentation
BaseEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : BaseEventArgs Class

For a list of all members of this type, see BaseEventArgs members.

Public Properties

 | Name | Description
public Property | ReturnValue |
Top

See Also

Reference

BaseEventArgs Class
ISNet.WebUI.WebCombo Namespace


ReturnValue Property

[image]
Intersoft WebCombo Documentation
ReturnValue Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > BaseEventArgs Class : ReturnValue Property

Syntax

Visual Basic (Declaration)
Public Property ReturnValue As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BaseEventArgs
Dim value As Boolean

instance.ReturnValue = value

value = instance.ReturnValue
C#
public bool ReturnValue {get; set;}
Delphi
public read-write property ReturnValue: Boolean;
JScript
public function get,set ReturnValue : boolean
Managed Extensions for C++
public: __property bool get_ReturnValue();
public: __property void set_ReturnValue(
   bool value
);
C++/CLI
public:
property bool ReturnValue {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BaseEventArgs Class
BaseEventArgs Members


Cells Class

[image]
Intersoft WebCombo Documentation
Cells Class
Members See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : Cells Class

Represents an individual data item when ComboMode is set to MultipleColumns. Class Cells

Object Model

Cells Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
<SerializableAttribute()>
Public Class Cells
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As Cells
C#
[DefaultMemberAttribute("Item")]
[SerializableAttribute()]
public class Cells : ISNet.WebUI.ISCollectionBase
Delphi
public class Cells = class(ISNet.WebUI.ISCollectionBase)
JScript
DefaultMemberAttribute("Item")
SerializableAttribute()
public class Cells extends ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
[SerializableAttribute()]
public __gc class Cells : public ISNet.WebUI.ISCollectionBase
C++/CLI
[DefaultMemberAttribute("Item")]
[SerializableAttribute()]
public ref class Cells : public ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebCombo.Cells

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cells Members
ISNet.WebUI.WebCombo Namespace


Cells Class Members

[image]
Intersoft WebCombo Documentation
Cells Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebCombo Namespace : Cells Class

The following tables list the members exposed by Cells.

Public Constructors

 | Name | Description
public Constructor | Cells Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | Capacity | (Inherited from System.Collections.CollectionBase)
public Property | Count | (Inherited from System.Collections.CollectionBase)
public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only. Returns a Boolean value indicating whether the collection is read-only.
public Property | Item | Property indexer for the collection. Property indexer for the collection.
public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
public Method | Add | Overloaded. Add an WebComboCell object into the WebComboCell collection. Add an WebComboCell object into the WebComboCell collection.
public Method | AddRange |
public Method | Clear | Removes all WebComboCell objects from the collection. Removes all WebComboCell objects from the collection.
public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | CopyFrom |
public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | GetEnumerator | Returns an enumerator object for the collection. Returns an enumerator object for the collection.
public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | GetNamedItem | Property indexer for the collection. Uses the Name string to return an WebComboCell object. Property indexer for the collection. Uses the Name string to return an WebComboCell object.
public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | Insert | Inserts an WebComboCell object into the WebComboCell collection at a specified index. Inserts an WebComboCell object into the WebComboCell collection at a specified index.
public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | Remove | Removes the specified WebComboCell object from the collection. Removes the specified WebComboCell object from the collection.
public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

Cells Class
ISNet.WebUI.WebCombo Namespace


Cells Constructor

[image]
Intersoft WebCombo Documentation
Cells Constructor
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Cells Class : Cells Constructor

Initializes a new instance of the Cells class.

Overload List

Overload | Description
Cells Constructor() | Initializes a new instance of the Cells class with no argument. Public constructor for the Cells Collection.
Cells Constructor(WebComboCell[]) | Initializes a new instance of the Cells class with cells parameter. Public constructor for the Cells Collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cells Class
Cells Members


Cells Constructor()

[image]
Intersoft WebCombo Documentation
Cells Constructor()
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Cells Class > Cells Constructor : Cells Constructor()

Initializes a new instance of the Cells class with no argument. Public constructor for the Cells Collection.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Cells()
C#
public Cells()
Delphi
public Cells();
JScript
public function Cells();
Managed Extensions for C++
public: Cells();
C++/CLI
public:
Cells();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cells Class
Cells Members
Overload List


Cells Constructor(WebComboCell[])

[image]
Intersoft WebCombo Documentation
Cells Constructor(WebComboCell[])
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Cells Class > Cells Constructor : Cells Constructor(WebComboCell[])

cells
Initializes a new instance of the Cells class with cells parameter. Public constructor for the Cells Collection.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal cells() As WebComboCell _
)
Visual Basic (Usage) Copy Code
Dim cells() As WebComboCell

Dim instance As New Cells(cells)
C#
public Cells(
   WebComboCell[] cells
)
Delphi
public Cells(
    cells: WebComboCellarray of
);
JScript
public function Cells(
   cells : WebComboCell[]
);
Managed Extensions for C++
public: Cells(
   WebComboCell*[]* cells
)
C++/CLI
public:
Cells(
   array<WebComboCell^>^ cells
)

Parameters

cells

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cells Class
Cells Members
Overload List


Cells Class Methods

[image]
Intersoft WebCombo Documentation
Cells Class Methods
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : Cells Class

For a list of all members of this type, see Cells members.

Public Methods

 | Name | Description
public Method | Add | Overloaded. Add an WebComboCell object into the WebComboCell collection. Add an WebComboCell object into the WebComboCell collection.
public Method | AddRange |
public Method | Clear | Removes all WebComboCell objects from the collection. Removes all WebComboCell objects from the collection.
public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | CopyFrom |
public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | GetEnumerator | Returns an enumerator object for the collection. Returns an enumerator object for the collection.
public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | GetNamedItem | Property indexer for the collection. Uses the Name string to return an WebComboCell object. Property indexer for the collection. Uses the Name string to return an WebComboCell object.
public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | Insert | Inserts an WebComboCell object into the WebComboCell collection at a specified index. Inserts an WebComboCell object into the WebComboCell collection at a specified index.
public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | Remove | Removes the specified WebComboCell object from the collection. Removes the specified WebComboCell object from the collection.
public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

Cells Class
ISNet.WebUI.WebCombo Namespace


Add Method

[image]
Intersoft WebCombo Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Cells Class : Add Method

Add an WebComboCell object into the WebComboCell collection.

Add an WebComboCell object into the WebComboCell collection.

Overload List

Overload | Description
Add(WebComboCell) | Add an WebComboCell object into the WebComboCell collection. Add an WebComboCell object into the WebComboCell collection.
Add(String) | Creates a new WebComboCell object in the collection and initializes its Name value. Creates a new WebComboCell object in the collection and initializes its Name value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cells Class
Cells Members


Add(WebComboCell) Method

[image]
Intersoft WebCombo Documentation
Add(WebComboCell) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Cells Class > Add Method : Add(WebComboCell) Method

cell
The WebComboCell object to be added.The WebComboCell object to be added.

Add an WebComboCell object into the WebComboCell collection.

Add an WebComboCell object into the WebComboCell collection.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal cell As WebComboCell _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Cells
Dim cell As WebComboCell
Dim value As Integer

value = instance.Add(cell)
C#
public virtual int Add(
   WebComboCell cell
)
Delphi
public function Add(
    cell: WebComboCell
): Integer; virtual;
JScript
public function Add(
   cell : WebComboCell
) : int;
Managed Extensions for C++
public: virtual int Add(
   WebComboCell* cell
)
C++/CLI
public:
virtual int Add(
   WebComboCell^ cell
)

Parameters

cell
The WebComboCell object to be added.The WebComboCell object to be added.

Return Value

The index of the newly added WebComboCell.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cells Class
Cells Members
Overload List


Add(String) Method

[image]
Intersoft WebCombo Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Cells Class > Add Method : Add(String) Method

name
The unique Name value.The unique Name value.

Creates a new WebComboCell object in the collection and initializes its Name value.

Creates a new WebComboCell object in the collection and initializes its Name value.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Cells
Dim name As String
Dim value As Integer

value = instance.Add(name)
C#
public int Add(
   string name
)
Delphi
public function Add(
    name: String
): Integer;
JScript
public function Add(
   name : String
) : int;
Managed Extensions for C++
public: int Add(
   string* name
)
C++/CLI
public:
int Add(
   String^ name
)

Parameters

name
The unique Name value.The unique Name value.

Return Value

The index of the newly-added WebComboCell object within the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cells Class
Cells Members
Overload List


AddRange Method

[image]
Intersoft WebCombo Documentation
AddRange Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Cells Class : AddRange Method

cells

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal cells() As WebComboCell _
)
Visual Basic (Usage) Copy Code
Dim instance As Cells
Dim cells() As WebComboCell

instance.AddRange(cells)
C#
public void AddRange(
   WebComboCell[] cells
)
Delphi
public procedure AddRange(
    cells: WebComboCellarray of
);
JScript
public function AddRange(
   cells : WebComboCell[]
);
Managed Extensions for C++
public: void AddRange(
   WebComboCell*[]* cells
)
C++/CLI
public:
void AddRange(
   array<WebComboCell^>^ cells
)

Parameters

cells

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cells Class
Cells Members


Clear Method

[image]
Intersoft WebCombo Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Cells Class : Clear Method

Removes all WebComboCell objects from the collection.

Removes all WebComboCell objects from the collection.

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As Cells

instance.Clear()
C#
public new void Clear()
Delphi
public procedure Clear();
JScript
public hide function Clear();
Managed Extensions for C++
public: new void Clear();
C++/CLI
public:
new void Clear();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cells Class
Cells Members


Contains Method

[image]
Intersoft WebCombo Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Cells Class : Contains Method

value

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Cells
Dim value As ISNet.WebUI.INamedObject
Dim value As Boolean

value = instance.Contains(value)
C#
public bool Contains(
   ISNet.WebUI.INamedObject value
)
Delphi
public function Contains(
    value: ISNet.WebUI.INamedObject
): Boolean;
JScript
public function Contains(
   value : ISNet.WebUI.INamedObject
) : boolean;
Managed Extensions for C++
public: bool Contains(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
bool Contains(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cells Class
Cells Members


CopyFrom Method

[image]
Intersoft WebCombo Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Cells Class : CopyFrom Method

passIn

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As Cells _
) As Cells
Visual Basic (Usage) Copy Code
Dim instance As Cells
Dim passIn As Cells
Dim value As Cells

value = instance.CopyFrom(passIn)
C#
public Cells CopyFrom(
   Cells passIn
)
Delphi
public function CopyFrom(
    passIn: Cells
): Cells;
JScript
public function CopyFrom(
   passIn : Cells
) : Cells;
Managed Extensions for C++
public: Cells* CopyFrom(
   Cells* passIn
)
C++/CLI
public:
Cells^ CopyFrom(
   Cells^ passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cells Class
Cells Members


CopyTo Method

[image]
Intersoft WebCombo Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Cells Class : CopyTo Method

array
index

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As Cells
Dim array() As ISNet.WebUI.INamedObject
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObjectarray of;
    index: Integer
);
JScript
public function CopyTo(
   array : ISNet.WebUI.INamedObject[],
   index : int
);
Managed Extensions for C++
public: void CopyTo(
   ISNet.WebUI.INamedObject*[]* array,
   int index
)
C++/CLI
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject^>^ array,
   int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cells Class
Cells Members


Exists Method

[image]
Intersoft WebCombo Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Cells Class : Exists Method

name

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Cells
Dim name As String
Dim value As Boolean

value = instance.Exists(name)
C#
public bool Exists(
   string name
)
Delphi
public function Exists(
    name: String
): Boolean;
JScript
public function Exists(
   name : String
) : boolean;
Managed Extensions for C++
public: bool Exists(
   string* name
)
C++/CLI
public:
bool Exists(
   String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cells Class
Cells Members


GetEnumerator Method

[image]
Intersoft WebCombo Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Cells Class : GetEnumerator Method

Returns an enumerator object for the collection. Returns an enumerator object for the collection.

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As Cells
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public new IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
JScript
public hide function GetEnumerator() : IEnumerator;
Managed Extensions for C++
public: new IEnumerator* GetEnumerator();
C++/CLI
public:
new IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cells Class
Cells Members


GetItem Method

[image]
Intersoft WebCombo Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Cells Class : GetItem Method

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cells Class
Cells Members


GetItem(Int32) Method

[image]
Intersoft WebCombo Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Cells Class : GetItem(Int32) Method

index

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As Cells
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   int index
)
Delphi
public function GetItem(
    index: Integer
): ISNet.WebUI.INamedObject; virtual;
JScript
public function GetItem(
   index : int
) : ISNet.WebUI.INamedObject;
Managed Extensions for C++
public: virtual ISNet.WebUI.INamedObject* GetItem(
   int index
)
C++/CLI
public:
virtual ISNet.WebUI.INamedObject^ GetItem(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cells Class
Cells Members


GetNamedItem Method

[image]
Intersoft WebCombo Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Cells Class : GetNamedItem Method

name

Property indexer for the collection. Uses the Name string to return an WebComboCell object.

Property indexer for the collection. Uses the Name string to return an WebComboCell object.

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As String _
) As WebComboCell
Visual Basic (Usage) Copy Code
Dim instance As Cells
Dim name As String
Dim value As WebComboCell

value = instance.GetNamedItem(name)
C#
public WebComboCell GetNamedItem(
   string name
)
Delphi
public function GetNamedItem(
    name: String
): WebComboCell;
JScript
public function GetNamedItem(
   name : String
) : WebComboCell;
Managed Extensions for C++
public: WebComboCell* GetNamedItem(
   string* name
)
C++/CLI
public:
WebComboCell^ GetNamedItem(
   String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cells Class
Cells Members


IndexOf Method

[image]
Intersoft WebCombo Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Cells Class : IndexOf Method

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cells Class
Cells Members


IndexOf(String) Method

[image]
Intersoft WebCombo Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Cells Class > IndexOf Method : IndexOf(String) Method

name

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Cells
Dim name As String
Dim value As Integer

value = instance.IndexOf(name)
C#
public virtual int IndexOf(
   string name
)
Delphi
public function IndexOf(
    name: String
): Integer; virtual;
JScript
public function IndexOf(
   name : String
) : int;
Managed Extensions for C++
public: virtual int IndexOf(
   string* name
)
C++/CLI
public:
virtual int IndexOf(
   String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cells Class
Cells Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebCombo Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Cells Class > IndexOf Method : IndexOf(INamedObject) Method

value

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Cells
Dim value As ISNet.WebUI.INamedObject
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   ISNet.WebUI.INamedObject value
)
Delphi
public function IndexOf(
    value: ISNet.WebUI.INamedObject
): Integer;
JScript
public function IndexOf(
   value : ISNet.WebUI.INamedObject
) : int;
Managed Extensions for C++
public: int IndexOf(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
int IndexOf(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cells Class
Cells Members
Overload List


Insert Method

[image]
Intersoft WebCombo Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Cells Class : Insert Method

index
The position in the collection for the new WebComboCell.The position in the collection for the new WebComboCell.
cell
The WebComboCell object to be inserted into the collection. The WebComboCell object to be inserted into the collection.

Inserts an WebComboCell object into the WebComboCell collection at a specified index.

Inserts an WebComboCell object into the WebComboCell collection at a specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal cell As WebComboCell _
)
Visual Basic (Usage) Copy Code
Dim instance As Cells
Dim index As Integer
Dim cell As WebComboCell

instance.Insert(index, cell)
C#
public void Insert(
   int index,
   WebComboCell cell
)
Delphi
public procedure Insert(
    index: Integer;
    cell: WebComboCell
);
JScript
public function Insert(
   index : int,
   cell : WebComboCell
);
Managed Extensions for C++
public: void Insert(
   int index,
   WebComboCell* cell
)
C++/CLI
public:
void Insert(
   int index,
   WebComboCell^ cell
)

Parameters

index
The position in the collection for the new WebComboCell.The position in the collection for the new WebComboCell.
cell
The WebComboCell object to be inserted into the collection. The WebComboCell object to be inserted into the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cells Class
Cells Members


IntInsert Method

[image]
Intersoft WebCombo Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Cells Class : IntInsert Method

index
value

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As Cells
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   int index,
   ISNet.WebUI.INamedObject value
)
Delphi
public procedure IntInsert(
    index: Integer;
    value: ISNet.WebUI.INamedObject
);
JScript
public function IntInsert(
   index : int,
   value : ISNet.WebUI.INamedObject
);
Managed Extensions for C++
public: void IntInsert(
   int index,
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
void IntInsert(
   int index,
   ISNet.WebUI.INamedObject^ value
)

Parameters

index
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cells Class
Cells Members


Remove Method

[image]
Intersoft WebCombo Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Cells Class : Remove Method

cell
The WebComboCell object to be removed from the collection. The WebComboCell object to be removed from the collection.
Removes the specified WebComboCell object from the collection. Removes the specified WebComboCell object from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal cell As WebComboCell _
)
Visual Basic (Usage) Copy Code
Dim instance As Cells
Dim cell As WebComboCell

instance.Remove(cell)
C#
public void Remove(
   WebComboCell cell
)
Delphi
public procedure Remove(
    cell: WebComboCell
);
JScript
public function Remove(
   cell : WebComboCell
);
Managed Extensions for C++
public: void Remove(
   WebComboCell* cell
)
C++/CLI
public:
void Remove(
   WebComboCell^ cell
)

Parameters

cell
The WebComboCell object to be removed from the collection. The WebComboCell object to be removed from the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cells Class
Cells Members


setParent Method

[image]
Intersoft WebCombo Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Cells Class : setParent Method

parent

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As Cells
Dim parent As Object

instance.setParent(parent)
C#
public virtual void setParent(
   object parent
)
Delphi
public procedure setParent(
    parent: TObject
); virtual;
JScript
public function setParent(
   parent : Object
);
Managed Extensions for C++
public: virtual void setParent(
   Object* parent
)
C++/CLI
public:
virtual void setParent(
   Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cells Class
Cells Members


Capacity Property

[image]
Intersoft WebCombo Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Cells Class : Capacity Property

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)>
Public Property Capacity As Integer
Visual Basic (Usage) Copy Code
Dim instance As Cells
Dim value As Integer

instance.Capacity = value

value = instance.Capacity
C#
[ComVisibleAttribute(false)]
public int Capacity {get; set;}
Delphi
public read-write property Capacity: Integer;
JScript
ComVisibleAttribute()
public function get,set Capacity : int
Managed Extensions for C++
[ComVisibleAttribute(false)]
public: __property int get_Capacity();
public: __property void set_Capacity(
   int value
);
C++/CLI
[ComVisibleAttribute(false)]
public:
property int Capacity {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cells Class
Cells Members


Count Property

[image]
Intersoft WebCombo Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Cells Class : Count Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As Cells
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Delphi
public read-only property Count: Integer;
JScript
public function get Count : int
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cells Class
Cells Members


Cells Class Properties

[image]
Intersoft WebCombo Documentation
Cells Class Properties
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : Cells Class

For a list of all members of this type, see Cells members.

Public Properties

 | Name | Description
public Property | Capacity | (Inherited from System.Collections.CollectionBase)
public Property | Count | (Inherited from System.Collections.CollectionBase)
public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only. Returns a Boolean value indicating whether the collection is read-only.
public Property | Item | Property indexer for the collection. Property indexer for the collection.
public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

Cells Class
ISNet.WebUI.WebCombo Namespace


IsReadOnly Property

[image]
Intersoft WebCombo Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Cells Class : IsReadOnly Property

Returns a Boolean value indicating whether the collection is read-only. Returns a Boolean value indicating whether the collection is read-only.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Cells
Dim value As Boolean

value = instance.IsReadOnly
C#
public override bool IsReadOnly {get;}
Delphi
public read-only property IsReadOnly: Boolean; override;
JScript
public override function get IsReadOnly : boolean
Managed Extensions for C++
public: __property bool get_IsReadOnly() override;
C++/CLI
public:
property bool IsReadOnly {
   bool get() override;
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cells Class
Cells Members


Item Property

[image]
Intersoft WebCombo Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Cells Class : Item Property

index
Property indexer for the collection. Property indexer for the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As WebComboCell
Visual Basic (Usage) Copy Code
Dim instance As Cells
Dim index As Integer
Dim value As WebComboCell

value = instance.Item(index)
C#
public WebComboCell this(
   int index
) {get;}
Delphi
public  this: : WebComboCell;(
    index: Integer
); read-only
JScript
public  this(
   index : int
) get : WebComboCell
Managed Extensions for C++
public: __property WebComboCell* get_Item(
   int index
);
C++/CLI
public:
property WebComboCell^ default [int] {
   WebComboCell^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cells Class
Cells Members


Parent Property

[image]
Intersoft WebCombo Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Cells Class : Parent Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As Object
Visual Basic (Usage) Copy Code
Dim instance As Cells
Dim value As Object

value = instance.Parent
C#
public object Parent {get;}
Delphi
public read-only property Parent: TObject;
JScript
public function get Parent : Object
Managed Extensions for C++
public: __property Object* get_Parent();
C++/CLI
public:
property Object^ Parent {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cells Class
Cells Members


ClientEvents Class

[image]
Intersoft WebCombo Documentation
ClientEvents Class
Members See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : ClientEvents Class

Provides a centralized class for client side events.

Provides a centralized class for client side events.

Object Model

ClientEvents Class

Syntax

Visual Basic (Declaration)
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<DescriptionAttribute()>
<SerializableAttribute()>
Public Class ClientEvents
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
C#
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DescriptionAttribute()]
[SerializableAttribute()]
public class ClientEvents : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ClientEvents = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
PersistenceModeAttribute(PersistenceMode.InnerProperty)
DescriptionAttribute()
SerializableAttribute()
public class ClientEvents extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DescriptionAttribute()]
[SerializableAttribute()]
public __gc class ClientEvents : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DescriptionAttribute()]
[SerializableAttribute()]
public ref class ClientEvents : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Remarks

WebCombo provides a powerful feature to accommodate a broad range of scenarios through its extendable capability using client-side events. You can attach a client-side event handler to the event using the Client-side Event Editor.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebCombo.ClientEvents

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Members
ISNet.WebUI.WebCombo Namespace

Concepts

Client side Event Designer


ClientEvents Class Members

[image]
Intersoft WebCombo Documentation
ClientEvents Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebCombo Namespace : ClientEvents Class

The following tables list the members exposed by ClientEvents.

Public Constructors

 | Name | Description
public Constructor | ClientEvents Constructor |
Top

Public Properties

 | Name | Description
public Property | OnActionDispatched | Specifies the client side (JavaScript) function that will be invoked after an FlyPostBack action is dispatched during response. Specifies the client side (JavaScript) function that will be invoked after an FlyPostBack action is dispacthed during response.
public Property | OnAddItem | This event is fired when an item is about to be added. This event fired when an item is about to be added.
public Property | OnAfterItemSelected | This event is fired after an item is selected. This event fired after an item is selected.
public Property | OnAfterResponseProcess | Specifies the client side (JavaScript) function that will be invoked after the response action of a request has been performed. Specifies the client side (JavaScript) function that will be invoked after the response action of a request has been performed.
public Property | OnBeforeItemSelected | This event is fired when an item is about to be selected. This event fired when an item is about to be selected.
public Property | OnBeforeRequest | This event is fired when the request is about to be made. This event fired when the request is about to be made.
public Property | OnDataBound |
public Property | OnDataSourceChanged |
public Property | OnError | This event is fired when error response from server is detected. This event fired when error response from server is detected.
public Property | OnHideDropDown |
public Property | OnInitialize | This event is fired when WebCombo is being initialized. This event fired when WebCombo is being initialized.
public Property | OnInitializeCell |
public Property | OnInitializeRow |
public Property | OnKeyDown | Specifies the client side (JavaScript) function that will be invoked when user is typing in the WebCombo textbox. Specifies the client side (JavaScript) function that will be invoked when user is typing in the WebCombo textbox.
public Property | OnLostFocus | This event is fired when the control's focus is lost. This event fired when the control's focus is lost.
public Property | OnMatchInstantLookup | This event is fired when perfect match is found when using InstantLookup EntryMode. This event fired when perfect match is found when using InstantLookup EntryMode.
public Property | OnPostRender |
public Property | OnPreRender |
public Property | OnResponse | This event is fired when response is returned from server. This event fired when response is returned from server.
public Property | OnShowDropDown | Specifies the client side (JavaScript) function that will be invoked when the ResultBox is about to show. Specifies the client side (JavaScript) function that will be invoked when the ResultBox is about to show.
public Property | OnUnhandledError | This event is fired when there is unhandled error. This event fired when there is unhandled error.
public Property | OnValueItemContextMenu | Specifies the JavaScript function to be invoked when mouse's right button is clicked on a valid ValueItem. This event is only applicable when MultipleSelectionSettings is enabled. Specifies the JavaScript function to be invoked when mouse's right button is clicked on a valid ValueItem. This event is only applicable when MultipleSelectionSettings is enabled.
public Property | OnValueItemNotInList | Specifies the JavaScript function that will be invoked when the typed text can not be found in the List. This event is only applicable when MultipleSelectionSettings is enabled and AllowNotInListText is set to True. Specifies the JavaScript function that will be invoked when the typed text can't be found in the List. This event is only applicable when MultipleSelectionSettings is enabled and AllowNotInListText is set to True.
Top

Public Methods

 | Name | Description
public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | GetObjectData | Overridden.
public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | ToString | Override of ToString() method.
Top

See Also

Reference

ClientEvents Class
ISNet.WebUI.WebCombo Namespace


ClientEvents Constructor

[image]
Intersoft WebCombo Documentation
ClientEvents Constructor
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : ClientEvents Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ClientEvents()
C#
public ClientEvents()
Delphi
public ClientEvents();
JScript
public function ClientEvents();
Managed Extensions for C++
public: ClientEvents();
C++/CLI
public:
ClientEvents();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members


Clone Method

[image]
Intersoft WebCombo Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : Clone Method

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()
Delphi
public function Clone(): TObject; virtual;
JScript
public function Clone() : Object;
Managed Extensions for C++
public: virtual Object* Clone();
C++/CLI
public:
virtual Object^ Clone();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members


CopyFrom Method

[image]
Intersoft WebCombo Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : CopyFrom Method

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members


CopyFrom(Object) Method

[image]
Intersoft WebCombo Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)
Delphi
public procedure CopyFrom(
    objSource: TObject
); virtual;
JScript
public function CopyFrom(
   objSource : Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebCombo Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: TObject;
    cloneSourceValue: Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : Object,
   cloneSourceValue : boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   Object* objSource,
   bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   Object^ objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebCombo Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : DeSerializeObjectData Method

type
info
context

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim type As Type
Dim info As SerializationInfo
Dim context As StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: Type;
    info: SerializationInfo;
    context: StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : Type,
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   Type* type,
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   Type^ type,
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members


ClientEvents Class Methods

[image]
Intersoft WebCombo Documentation
ClientEvents Class Methods
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : ClientEvents Class

For a list of all members of this type, see ClientEvents members.

Public Methods

 | Name | Description
public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | GetObjectData | Overridden.
public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | ToString | Override of ToString() method.
Top

See Also

Reference

ClientEvents Class
ISNet.WebUI.WebCombo Namespace


GetObjectData Method

[image]
Intersoft WebCombo Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : GetObjectData Method

info
context

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: SerializationInfo;
    context: StreamingContext
); override;
JScript
public override function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members


IsEmpty Method

[image]
Intersoft WebCombo Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : IsEmpty Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()
Delphi
public function IsEmpty(): Boolean; virtual;
JScript
public function IsEmpty() : boolean;
Managed Extensions for C++
public: virtual bool IsEmpty();
C++/CLI
public:
virtual bool IsEmpty();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members


Reset Method

[image]
Intersoft WebCombo Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : Reset Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members


SerializeObjectData Method

[image]
Intersoft WebCombo Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : SerializeObjectData Method

type
info
context

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim type As Type
Dim info As SerializationInfo
Dim context As StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: Type;
    info: SerializationInfo;
    context: StreamingContext
);
JScript
public function SerializeObjectData(
   type : Type,
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   Type* type,
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   Type^ type,
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members


ToString Method

[image]
Intersoft WebCombo Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : ToString Method

Override of ToString() method.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Delphi
public function ToString(): String; override;
JScript
public override function ToString() : String;
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members


ClientEvents Class Properties

[image]
Intersoft WebCombo Documentation
ClientEvents Class Properties
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : ClientEvents Class

For a list of all members of this type, see ClientEvents members.

Public Properties

 | Name | Description
public Property | OnActionDispatched | Specifies the client side (JavaScript) function that will be invoked after an FlyPostBack action is dispatched during response. Specifies the client side (JavaScript) function that will be invoked after an FlyPostBack action is dispacthed during response.
public Property | OnAddItem | This event is fired when an item is about to be added. This event fired when an item is about to be added.
public Property | OnAfterItemSelected | This event is fired after an item is selected. This event fired after an item is selected.
public Property | OnAfterResponseProcess | Specifies the client side (JavaScript) function that will be invoked after the response action of a request has been performed. Specifies the client side (JavaScript) function that will be invoked after the response action of a request has been performed.
public Property | OnBeforeItemSelected | This event is fired when an item is about to be selected. This event fired when an item is about to be selected.
public Property | OnBeforeRequest | This event is fired when the request is about to be made. This event fired when the request is about to be made.
public Property | OnDataBound |
public Property | OnDataSourceChanged |
public Property | OnError | This event is fired when error response from server is detected. This event fired when error response from server is detected.
public Property | OnHideDropDown |
public Property | OnInitialize | This event is fired when WebCombo is being initialized. This event fired when WebCombo is being initialized.
public Property | OnInitializeCell |
public Property | OnInitializeRow |
public Property | OnKeyDown | Specifies the client side (JavaScript) function that will be invoked when user is typing in the WebCombo textbox. Specifies the client side (JavaScript) function that will be invoked when user is typing in the WebCombo textbox.
public Property | OnLostFocus | This event is fired when the control's focus is lost. This event fired when the control's focus is lost.
public Property | OnMatchInstantLookup | This event is fired when perfect match is found when using InstantLookup EntryMode. This event fired when perfect match is found when using InstantLookup EntryMode.
public Property | OnPostRender |
public Property | OnPreRender |
public Property | OnResponse | This event is fired when response is returned from server. This event fired when response is returned from server.
public Property | OnShowDropDown | Specifies the client side (JavaScript) function that will be invoked when the ResultBox is about to show. Specifies the client side (JavaScript) function that will be invoked when the ResultBox is about to show.
public Property | OnUnhandledError | This event is fired when there is unhandled error. This event fired when there is unhandled error.
public Property | OnValueItemContextMenu | Specifies the JavaScript function to be invoked when mouse's right button is clicked on a valid ValueItem. This event is only applicable when MultipleSelectionSettings is enabled. Specifies the JavaScript function to be invoked when mouse's right button is clicked on a valid ValueItem. This event is only applicable when MultipleSelectionSettings is enabled.
public Property | OnValueItemNotInList | Specifies the JavaScript function that will be invoked when the typed text can not be found in the List. This event is only applicable when MultipleSelectionSettings is enabled and AllowNotInListText is set to True. Specifies the JavaScript function that will be invoked when the typed text can't be found in the List. This event is only applicable when MultipleSelectionSettings is enabled and AllowNotInListText is set to True.
Top

See Also

Reference

ClientEvents Class
ISNet.WebUI.WebCombo Namespace


ClientEvents Constructor

[image]
Intersoft WebCombo Documentation
ClientEvents Constructor
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : ClientEvents Constructor

Initializes a new instance of the ClientEvents class.

Overload List

Overload | Description
ClientEvents Constructor |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members


OnActionDispatched Property

[image]
Intersoft WebCombo Documentation
OnActionDispatched Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : OnActionDispatched Property

Specifies the client side (JavaScript) function that will be invoked after an FlyPostBack action is dispatched during response. Specifies the client side (JavaScript) function that will be invoked after an FlyPostBack action is dispacthed during response.

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after an FlyPostBack action is dispacthed during response.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, action")>
Public Property OnActionDispatched As String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As String

instance.OnActionDispatched = value

value = instance.OnActionDispatched
C#
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after an FlyPostBack action is dispacthed during response.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, action")]
public string OnActionDispatched {get; set;}
Delphi
public read-write property OnActionDispatched: String;
JScript
NotifyParentPropertyAttribute()
DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after an FlyPostBack action is dispacthed during response.")
ISNet.Serialization.XmlSerializableAttribute()
EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId, action")
public function get,set OnActionDispatched : String
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after an FlyPostBack action is dispacthed during response.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, action")]
public: __property string* get_OnActionDispatched();
public: __property void set_OnActionDispatched(
   string* value
);
C++/CLI
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after an FlyPostBack action is dispacthed during response.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, action")]
public:
property String^ OnActionDispatched {
   String^ get();
   void set (    String^ value);
}

Remarks

As part of IFlyPostBack interface members, this event will be invoked when response is returned from server and the action name related to the response has been dispatched. You can handle this event for additional codes or behavior that need to be invoked only in success response condition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members

Concepts

Client side Event Designer


OnAddItem Property

[image]
Intersoft WebCombo Documentation
OnAddItem Property
See Also Example Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : OnAddItem Property

This event is fired when an item is about to be added. This event fired when an item is about to be added.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId")>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("This event fired when an item is about to be added.")>
<DefaultValueAttribute()>
Public Property OnAddItem As String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As String

instance.OnAddItem = value

value = instance.OnAddItem
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("This event fired when an item is about to be added.")]
[DefaultValueAttribute()]
public string OnAddItem {get; set;}
Delphi
public read-write property OnAddItem: String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId")
NotifyParentPropertyAttribute()
DescriptionAttribute("This event fired when an item is about to be added.")
DefaultValueAttribute()
public function get,set OnAddItem : String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("This event fired when an item is about to be added.")]
[DefaultValueAttribute()]
public: __property string* get_OnAddItem();
public: __property void set_OnAddItem(
   string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("This event fired when an item is about to be added.")]
[DefaultValueAttribute()]
public:
property String^ OnAddItem {
   String^ get();
   void set (    String^ value);
}

Example

The folowing example shows you how to display confirmation box after user has added a value on a WebCombo.
C# Copy Code
WebCombo1.LayoutSettings.ClientSideEvents.OnAfterAdd = "DoAddItem";
The following is the example of the javascript function that is assigned in above event.
JScript Copy Code
function DoAddItem()
   {
      var combo = ISGetObject(controlId);
      if (confirm("The customer '" + combo.TextObj.value + "' is not exist. Do you want to add it?"))
      return true;
   }

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members

Tasks

How-to: Use OnAddItem client side event to validate input

Concepts

Dynamically Add Item

concepts

Client side Event Designer


OnAfterItemSelected Property

[image]
Intersoft WebCombo Documentation
OnAfterItemSelected Property
See Also Example Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : OnAfterItemSelected Property

This event is fired after an item is selected. This event fired after an item is selected.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.BinarySerializableAttribute()>
<DescriptionAttribute("This event fired after an item is selected.")>
<DefaultValueAttribute()>
<ISNet.EventParameterAttribute("controlId")>
Public Property OnAfterItemSelected As String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As String

instance.OnAfterItemSelected = value

value = instance.OnAfterItemSelected
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("This event fired after an item is selected.")]
[DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId")]
public string OnAfterItemSelected {get; set;}
Delphi
public read-write property OnAfterItemSelected: String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
NotifyParentPropertyAttribute()
EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.BinarySerializableAttribute()
DescriptionAttribute("This event fired after an item is selected.")
DefaultValueAttribute()
ISNet.EventParameterAttribute("controlId")
public function get,set OnAfterItemSelected : String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("This event fired after an item is selected.")]
[DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId")]
public: __property string* get_OnAfterItemSelected();
public: __property void set_OnAfterItemSelected(
   string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("This event fired after an item is selected.")]
[DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId")]
public:
property String^ OnAfterItemSelected {
   String^ get();
   void set (    String^ value);
}

Example

The following is the example on how to assign a javascript function to the client side event after an item has been selected. In this scenario, you need to set the DataValueField is CustomerID and the DataTextField is CompanyName. The message box will display the customer Id after you have selected an item.
C# Copy Code
WebCombo1.LayoutSettings.ClientSideEvents.OnAfterItemsSelected = "WebCombo1_OnAfterItemSelected";
The following is the example of the javascript function that is assigned in above event.
JScript Copy Code
function WebCombo1_OnAfterItemSelected(controlId)
{
    var combo = ISGetObject(controlId);

    alert("Selected value is "+combo.Value);

    return true;
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members

Concepts

Client side Event Designer

Tasks

How-to: Set the value of another controls in OnAfterItemSelected client side events


OnAfterResponseProcess Property

[image]
Intersoft WebCombo Documentation
OnAfterResponseProcess Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : OnAfterResponseProcess Property

Specifies the client side (JavaScript) function that will be invoked after the response action of a request has been performed. Specifies the client side (JavaScript) function that will be invoked after the response action of a request has been performed.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId, action, xmlResponse")>
<DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after the response action of a request has been performed.")>
<DefaultValueAttribute()>
Public Property OnAfterResponseProcess As String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As String

instance.OnAfterResponseProcess = value

value = instance.OnAfterResponseProcess
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, action, xmlResponse")]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after the response action of a request has been performed.")]
[DefaultValueAttribute()]
public string OnAfterResponseProcess {get; set;}
Delphi
public read-write property OnAfterResponseProcess: String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId, action, xmlResponse")
DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after the response action of a request has been performed.")
DefaultValueAttribute()
public function get,set OnAfterResponseProcess : String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, action, xmlResponse")]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after the response action of a request has been performed.")]
[DefaultValueAttribute()]
public: __property string* get_OnAfterResponseProcess();
public: __property void set_OnAfterResponseProcess(
   string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, action, xmlResponse")]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after the response action of a request has been performed.")]
[DefaultValueAttribute()]
public:
property String^ OnAfterResponseProcess {
   String^ get();
   void set (    String^ value);
}

Remarks

As part of IFlyPostBack interface members, this event will be invoked once the default response process has been executed for the related action. This event is suitable for codes that need to be invoked after the default behaviors and processes have been executed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members

Concepts

Client side Event Designer


OnBeforeItemSelected Property

[image]
Intersoft WebCombo Documentation
OnBeforeItemSelected Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : OnBeforeItemSelected Property

This event is fired when an item is about to be selected. This event fired when an item is about to be selected.

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<DefaultValueAttribute()>
<DescriptionAttribute("This event fired when an item is about to be selected.")>
<ISNet.EventParameterAttribute("controlId, action")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property OnBeforeItemSelected As String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As String

instance.OnBeforeItemSelected = value

value = instance.OnBeforeItemSelected
C#
[NotifyParentPropertyAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[DefaultValueAttribute()]
[DescriptionAttribute("This event fired when an item is about to be selected.")]
[ISNet.EventParameterAttribute("controlId, action")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public string OnBeforeItemSelected {get; set;}
Delphi
public read-write property OnBeforeItemSelected: String;
JScript
NotifyParentPropertyAttribute()
EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
DefaultValueAttribute()
DescriptionAttribute("This event fired when an item is about to be selected.")
ISNet.EventParameterAttribute("controlId, action")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set OnBeforeItemSelected : String
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[DefaultValueAttribute()]
[DescriptionAttribute("This event fired when an item is about to be selected.")]
[ISNet.EventParameterAttribute("controlId, action")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property string* get_OnBeforeItemSelected();
public: __property void set_OnBeforeItemSelected(
   string* value
);
C++/CLI
[NotifyParentPropertyAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[DefaultValueAttribute()]
[DescriptionAttribute("This event fired when an item is about to be selected.")]
[ISNet.EventParameterAttribute("controlId, action")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property String^ OnBeforeItemSelected {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members

Concepts

Client side Event Designer


OnBeforeRequest Property

[image]
Intersoft WebCombo Documentation
OnBeforeRequest Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : OnBeforeRequest Property

This event is fired when the request is about to be made. This event fired when the request is about to be made.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<DescriptionAttribute("This event fired when the request is about to be made.")>
<DefaultValueAttribute()>
<ISNet.EventParameterAttribute("controlId, action")>
Public Property OnBeforeRequest As String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As String

instance.OnBeforeRequest = value

value = instance.OnBeforeRequest
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[DescriptionAttribute("This event fired when the request is about to be made.")]
[DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, action")]
public string OnBeforeRequest {get; set;}
Delphi
public read-write property OnBeforeRequest: String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
DescriptionAttribute("This event fired when the request is about to be made.")
DefaultValueAttribute()
ISNet.EventParameterAttribute("controlId, action")
public function get,set OnBeforeRequest : String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[DescriptionAttribute("This event fired when the request is about to be made.")]
[DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, action")]
public: __property string* get_OnBeforeRequest();
public: __property void set_OnBeforeRequest(
   string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[DescriptionAttribute("This event fired when the request is about to be made.")]
[DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, action")]
public:
property String^ OnBeforeRequest {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members

Concepts

Client side Event Designer


OnDataBound Property

[image]
Intersoft WebCombo Documentation
OnDataBound Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : OnDataBound Property

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when WebCombo has completed the data binding process in client binding mode.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId")>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property OnDataBound As String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As String

instance.OnDataBound = value

value = instance.OnDataBound
C#
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when WebCombo has completed the data binding process in client binding mode.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
public string OnDataBound {get; set;}
Delphi
public read-write property OnDataBound: String;
JScript
NotifyParentPropertyAttribute()
DefaultValueAttribute()
DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when WebCombo has completed the data binding process in client binding mode.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId")
EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set OnDataBound : String
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when WebCombo has completed the data binding process in client binding mode.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property string* get_OnDataBound();
public: __property void set_OnDataBound(
   string* value
);
C++/CLI
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when WebCombo has completed the data binding process in client binding mode.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property String^ OnDataBound {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members


OnDataSourceChanged Property

[image]
Intersoft WebCombo Documentation
OnDataSourceChanged Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : OnDataSourceChanged Property

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId")>
<NotifyParentPropertyAttribute(True)>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a new datasource is assigned to WebCombo in client binding mode.")>
<DefaultValueAttribute()>
Public Property OnDataSourceChanged As String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As String

instance.OnDataSourceChanged = value

value = instance.OnDataSourceChanged
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[NotifyParentPropertyAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a new datasource is assigned to WebCombo in client binding mode.")]
[DefaultValueAttribute()]
public string OnDataSourceChanged {get; set;}
Delphi
public read-write property OnDataSourceChanged: String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId")
NotifyParentPropertyAttribute()
EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a new datasource is assigned to WebCombo in client binding mode.")
DefaultValueAttribute()
public function get,set OnDataSourceChanged : String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[NotifyParentPropertyAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a new datasource is assigned to WebCombo in client binding mode.")]
[DefaultValueAttribute()]
public: __property string* get_OnDataSourceChanged();
public: __property void set_OnDataSourceChanged(
   string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[NotifyParentPropertyAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a new datasource is assigned to WebCombo in client binding mode.")]
[DefaultValueAttribute()]
public:
property String^ OnDataSourceChanged {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members


OnError Property

[image]
Intersoft WebCombo Documentation
OnError Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : OnError Property

This event is fired when error response from server is detected.

This event fired when error response from server is detected.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<DescriptionAttribute("This event fired when error response from server is detected.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId")>
Public Property OnError As String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As String

instance.OnError = value

value = instance.OnError
C#
[DefaultValueAttribute()]
[DescriptionAttribute("This event fired when error response from server is detected.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
public string OnError {get; set;}
Delphi
public read-write property OnError: String;
JScript
DefaultValueAttribute()
DescriptionAttribute("This event fired when error response from server is detected.")
ISNet.Serialization.XmlSerializableAttribute()
EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId")
public function get,set OnError : String
Managed Extensions for C++
[DefaultValueAttribute()]
[DescriptionAttribute("This event fired when error response from server is detected.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
public: __property string* get_OnError();
public: __property void set_OnError(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[DescriptionAttribute("This event fired when error response from server is detected.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
public:
property String^ OnError {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members


OnHideDropDown Property

[image]
Intersoft WebCombo Documentation
OnHideDropDown Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : OnHideDropDown Property

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId")>
<DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the ResultBox is about to close.")>
<DefaultValueAttribute()>
Public Property OnHideDropDown As String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As String

instance.OnHideDropDown = value

value = instance.OnHideDropDown
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the ResultBox is about to close.")]
[DefaultValueAttribute()]
public string OnHideDropDown {get; set;}
Delphi
public read-write property OnHideDropDown: String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId")
DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the ResultBox is about to close.")
DefaultValueAttribute()
public function get,set OnHideDropDown : String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the ResultBox is about to close.")]
[DefaultValueAttribute()]
public: __property string* get_OnHideDropDown();
public: __property void set_OnHideDropDown(
   string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the ResultBox is about to close.")]
[DefaultValueAttribute()]
public:
property String^ OnHideDropDown {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members


OnInitialize Property

[image]
Intersoft WebCombo Documentation
OnInitialize Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : OnInitialize Property

This event is fired when WebCombo is being initialized. This event fired when WebCombo is being initialized.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("This event fired when WebCombo is being initialized.")>
<ISNet.EventParameterAttribute("controlId")>
<DefaultValueAttribute()>
Public Property OnInitialize As String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As String

instance.OnInitialize = value

value = instance.OnInitialize
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("This event fired when WebCombo is being initialized.")]
[ISNet.EventParameterAttribute("controlId")]
[DefaultValueAttribute()]
public string OnInitialize {get; set;}
Delphi
public read-write property OnInitialize: String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
NotifyParentPropertyAttribute()
DescriptionAttribute("This event fired when WebCombo is being initialized.")
ISNet.EventParameterAttribute("controlId")
DefaultValueAttribute()
public function get,set OnInitialize : String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("This event fired when WebCombo is being initialized.")]
[ISNet.EventParameterAttribute("controlId")]
[DefaultValueAttribute()]
public: __property string* get_OnInitialize();
public: __property void set_OnInitialize(
   string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("This event fired when WebCombo is being initialized.")]
[ISNet.EventParameterAttribute("controlId")]
[DefaultValueAttribute()]
public:
property String^ OnInitialize {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members


OnInitializeCell Property

[image]
Intersoft WebCombo Documentation
OnInitializeCell Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : OnInitializeCell Property

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, cell")>
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a WebComboCell is initialized in client binding mode.")>
<NotifyParentPropertyAttribute(True)>
Public Property OnInitializeCell As String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As String

instance.OnInitializeCell = value

value = instance.OnInitializeCell
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, cell")]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a WebComboCell is initialized in client binding mode.")]
[NotifyParentPropertyAttribute(true)]
public string OnInitializeCell {get; set;}
Delphi
public read-write property OnInitializeCell: String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, cell")
DefaultValueAttribute()
DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a WebComboCell is initialized in client binding mode.")
NotifyParentPropertyAttribute()
public function get,set OnInitializeCell : String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, cell")]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a WebComboCell is initialized in client binding mode.")]
[NotifyParentPropertyAttribute(true)]
public: __property string* get_OnInitializeCell();
public: __property void set_OnInitializeCell(
   string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, cell")]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a WebComboCell is initialized in client binding mode.")]
[NotifyParentPropertyAttribute(true)]
public:
property String^ OnInitializeCell {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members


OnInitializeRow Property

[image]
Intersoft WebCombo Documentation
OnInitializeRow Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : OnInitializeRow Property

Syntax

Visual Basic (Declaration)
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, row")>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a WebComboRow is initialized in client binding mode.")>
Public Property OnInitializeRow As String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As String

instance.OnInitializeRow = value

value = instance.OnInitializeRow
C#
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, row")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a WebComboRow is initialized in client binding mode.")]
public string OnInitializeRow {get; set;}
Delphi
public read-write property OnInitializeRow: String;
JScript
EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, row")
NotifyParentPropertyAttribute()
DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a WebComboRow is initialized in client binding mode.")
public function get,set OnInitializeRow : String
Managed Extensions for C++
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, row")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a WebComboRow is initialized in client binding mode.")]
public: __property string* get_OnInitializeRow();
public: __property void set_OnInitializeRow(
   string* value
);
C++/CLI
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, row")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a WebComboRow is initialized in client binding mode.")]
public:
property String^ OnInitializeRow {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members


OnKeyDown Property

[image]
Intersoft WebCombo Documentation
OnKeyDown Property
See Also Example Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : OnKeyDown Property

Specifies the client side (JavaScript) function that will be invoked when user is typing in the WebCombo textbox. Specifies the client side (JavaScript) function that will be invoked when user is typing in the WebCombo textbox.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, keyValue")>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when user is typing in the WebCombo textbox.")>
<DefaultValueAttribute()>
Public Property OnKeyDown As String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As String

instance.OnKeyDown = value

value = instance.OnKeyDown
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, keyValue")]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when user is typing in the WebCombo textbox.")]
[DefaultValueAttribute()]
public string OnKeyDown {get; set;}
Delphi
public read-write property OnKeyDown: String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, keyValue")
NotifyParentPropertyAttribute()
DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when user is typing in the WebCombo textbox.")
DefaultValueAttribute()
public function get,set OnKeyDown : String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, keyValue")]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when user is typing in the WebCombo textbox.")]
[DefaultValueAttribute()]
public: __property string* get_OnKeyDown();
public: __property void set_OnKeyDown(
   string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, keyValue")]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when user is typing in the WebCombo textbox.")]
[DefaultValueAttribute()]
public:
property String^ OnKeyDown {
   String^ get();
   void set (    String^ value);
}

Example

The following example shows you how to display a message showing a value that has been entered by user.
C# Copy Code
WebCombo1.LayoutSettings.ClientSideEvents.OnKeyDown = "WebCombo1_OnkeyDown";
The following is the example of the javascript function that is assigned in above event:
JScript Copy Code
function WebCombo1_OnKeyDown(controlId, keyValue)
{
   var combo = ISGetObject("WebCombo1");
   alert("The value that you entered is " + combo.TextObj.value);

   return true;
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members

Concepts

Client side Event Designer

Tasks

How-to: Validate string only input in OnKeyDown client side events


OnLostFocus Property

[image]
Intersoft WebCombo Documentation
OnLostFocus Property
See Also Example Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : OnLostFocus Property

This event is fired when the control's focus is lost. This event fired when the control's focus is lost.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("This event fired when the control's focus is lost.")>
<ISNet.EventParameterAttribute("controlId")>
Public Property OnLostFocus As String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As String

instance.OnLostFocus = value

value = instance.OnLostFocus
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("This event fired when the control's focus is lost.")]
[ISNet.EventParameterAttribute("controlId")]
public string OnLostFocus {get; set;}
Delphi
public read-write property OnLostFocus: String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
DefaultValueAttribute()
NotifyParentPropertyAttribute()
DescriptionAttribute("This event fired when the control's focus is lost.")
ISNet.EventParameterAttribute("controlId")
public function get,set OnLostFocus : String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("This event fired when the control's focus is lost.")]
[ISNet.EventParameterAttribute("controlId")]
public: __property string* get_OnLostFocus();
public: __property void set_OnLostFocus(
   string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("This event fired when the control's focus is lost.")]
[ISNet.EventParameterAttribute("controlId")]
public:
property String^ OnLostFocus {
   String^ get();
   void set (    String^ value);
}

Example

The following example shows you how to display a message box when the combo is lost focus.
C# Copy Code
WebCombo1.LayoutSettings.ClientSideEvents.OnLostFocus = "WebCombo1_OnLostFocus";
The following is the example of the javascript function that is assigned in above event.
JScript Copy Code
function WebCombo1_OnLostFocus(controlId)
{
    var WebCombo1 = ISGetObject(controlId);
    alert("WebCombo is lost focus!");
    return true;
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members

Concepts

Client side Event Designer


OnMatchInstantLookup Property

[image]
Intersoft WebCombo Documentation
OnMatchInstantLookup Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : OnMatchInstantLookup Property

This event is fired when perfect match is found when using InstantLookup EntryMode. This event fired when perfect match is found when using InstantLookup EntryMode.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId")>
<DescriptionAttribute("This event fired when perfect match is found when using InstantLookup EntryMode.")>
<DefaultValueAttribute()>
Public Property OnMatchInstantLookup As String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As String

instance.OnMatchInstantLookup = value

value = instance.OnMatchInstantLookup
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
[DescriptionAttribute("This event fired when perfect match is found when using InstantLookup EntryMode.")]
[DefaultValueAttribute()]
public string OnMatchInstantLookup {get; set;}
Delphi
public read-write property OnMatchInstantLookup: String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId")
DescriptionAttribute("This event fired when perfect match is found when using InstantLookup EntryMode.")
DefaultValueAttribute()
public function get,set OnMatchInstantLookup : String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
[DescriptionAttribute("This event fired when perfect match is found when using InstantLookup EntryMode.")]
[DefaultValueAttribute()]
public: __property string* get_OnMatchInstantLookup();
public: __property void set_OnMatchInstantLookup(
   string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
[DescriptionAttribute("This event fired when perfect match is found when using InstantLookup EntryMode.")]
[DefaultValueAttribute()]
public:
property String^ OnMatchInstantLookup {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members


OnPostRender Property

[image]
Intersoft WebCombo Documentation
OnPostRender Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : OnPostRender Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after data rendering has been completed in client binding mode.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.XmlSerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId")>
Public Property OnPostRender As String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As String

instance.OnPostRender = value

value = instance.OnPostRender
C#
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after data rendering has been completed in client binding mode.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
public string OnPostRender {get; set;}
Delphi
public read-write property OnPostRender: String;
JScript
DefaultValueAttribute()
DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after data rendering has been completed in client binding mode.")
ISNet.Serialization.BinarySerializableAttribute()
EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.XmlSerializableAttribute()
NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId")
public function get,set OnPostRender : String
Managed Extensions for C++
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after data rendering has been completed in client binding mode.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
public: __property string* get_OnPostRender();
public: __property void set_OnPostRender(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after data rendering has been completed in client binding mode.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
public:
property String^ OnPostRender {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members


OnPreRender Property

[image]
Intersoft WebCombo Documentation
OnPreRender Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : OnPreRender Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before data rendering phase in client binding mode.")>
<ISNet.EventParameterAttribute("controlId")>
<ISNet.Serialization.XmlSerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property OnPreRender As String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As String

instance.OnPreRender = value

value = instance.OnPreRender
C#
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before data rendering phase in client binding mode.")]
[ISNet.EventParameterAttribute("controlId")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
public string OnPreRender {get; set;}
Delphi
public read-write property OnPreRender: String;
JScript
DefaultValueAttribute()
DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before data rendering phase in client binding mode.")
ISNet.EventParameterAttribute("controlId")
ISNet.Serialization.XmlSerializableAttribute()
NotifyParentPropertyAttribute()
EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set OnPreRender : String
Managed Extensions for C++
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before data rendering phase in client binding mode.")]
[ISNet.EventParameterAttribute("controlId")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property string* get_OnPreRender();
public: __property void set_OnPreRender(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before data rendering phase in client binding mode.")]
[ISNet.EventParameterAttribute("controlId")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property String^ OnPreRender {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members


OnResponse Property

[image]
Intersoft WebCombo Documentation
OnResponse Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : OnResponse Property

This event is fired when response is returned from server. This event fired when response is returned from server.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("This event fired when response is returned from server.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId")>
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
Public Property OnResponse As String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As String

instance.OnResponse = value

value = instance.OnResponse
C#
[DescriptionAttribute("This event fired when response is returned from server.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
public string OnResponse {get; set;}
Delphi
public read-write property OnResponse: String;
JScript
DescriptionAttribute("This event fired when response is returned from server.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId")
DefaultValueAttribute()
NotifyParentPropertyAttribute()
public function get,set OnResponse : String
Managed Extensions for C++
[DescriptionAttribute("This event fired when response is returned from server.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
public: __property string* get_OnResponse();
public: __property void set_OnResponse(
   string* value
);
C++/CLI
[DescriptionAttribute("This event fired when response is returned from server.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
public:
property String^ OnResponse {
   String^ get();
   void set (    String^ value);
}

Remarks

Server response is xml format.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members


OnShowDropDown Property

[image]
Intersoft WebCombo Documentation
OnShowDropDown Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : OnShowDropDown Property

Specifies the client side (JavaScript) function that will be invoked when the ResultBox is about to show. Specifies the client side (JavaScript) function that will be invoked when the ResultBox is about to show.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId, left, top, width, height")>
<DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the ResultBox is about to show.")>
<DefaultValueAttribute()>
Public Property OnShowDropDown As String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As String

instance.OnShowDropDown = value

value = instance.OnShowDropDown
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, left, top, width, height")]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the ResultBox is about to show.")]
[DefaultValueAttribute()]
public string OnShowDropDown {get; set;}
Delphi
public read-write property OnShowDropDown: String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId, left, top, width, height")
DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the ResultBox is about to show.")
DefaultValueAttribute()
public function get,set OnShowDropDown : String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, left, top, width, height")]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the ResultBox is about to show.")]
[DefaultValueAttribute()]
public: __property string* get_OnShowDropDown();
public: __property void set_OnShowDropDown(
   string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, left, top, width, height")]
[DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the ResultBox is about to show.")]
[DefaultValueAttribute()]
public:
property String^ OnShowDropDown {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members

Concepts

Client side Event Designer

Tasks

How-to: Display the result box to the right side of WebCombo


OnUnhandledError Property

[image]
Intersoft WebCombo Documentation
OnUnhandledError Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : OnUnhandledError Property

This event is fired when there is unhandled error. This event fired when there is unhandled error.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, lastAction, lastError")>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<DescriptionAttribute("This event fired when there is unhandled error.")>
<DefaultValueAttribute()>
Public Property OnUnhandledError As String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As String

instance.OnUnhandledError = value

value = instance.OnUnhandledError
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, lastAction, lastError")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("This event fired when there is unhandled error.")]
[DefaultValueAttribute()]
public string OnUnhandledError {get; set;}
Delphi
public read-write property OnUnhandledError: String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, lastAction, lastError")
NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
DescriptionAttribute("This event fired when there is unhandled error.")
DefaultValueAttribute()
public function get,set OnUnhandledError : String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, lastAction, lastError")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("This event fired when there is unhandled error.")]
[DefaultValueAttribute()]
public: __property string* get_OnUnhandledError();
public: __property void set_OnUnhandledError(
   string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, lastAction, lastError")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("This event fired when there is unhandled error.")]
[DefaultValueAttribute()]
public:
property String^ OnUnhandledError {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members


OnValueItemContextMenu Property

[image]
Intersoft WebCombo Documentation
OnValueItemContextMenu Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : OnValueItemContextMenu Property

Specifies the JavaScript function to be invoked when mouse's right button is clicked on a valid ValueItem. This event is only applicable when MultipleSelectionSettings is enabled. Specifies the JavaScript function to be invoked when mouse's right button is clicked on a valid ValueItem. This event is only applicable when MultipleSelectionSettings is enabled.

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, valueItem")>
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies the JavaScript function to be invoked when mouse's right button is clicked on a valid ValueItem. This event is only applicable when MultipleSelectionSettings is enabled.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnValueItemContextMenu As String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As String

instance.OnValueItemContextMenu = value

value = instance.OnValueItemContextMenu
C#
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, valueItem")]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the JavaScript function to be invoked when mouse's right button is clicked on a valid ValueItem. This event is only applicable when MultipleSelectionSettings is enabled.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public string OnValueItemContextMenu {get; set;}
Delphi
public read-write property OnValueItemContextMenu: String;
JScript
NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.EventParameterAttribute("controlId, valueItem")
DefaultValueAttribute()
DescriptionAttribute("Specifies the JavaScript function to be invoked when mouse's right button is clicked on a valid ValueItem. This event is only applicable when MultipleSelectionSettings is enabled.")
ISNet.Serialization.BinarySerializableAttribute()
EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnValueItemContextMenu : String
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, valueItem")]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the JavaScript function to be invoked when mouse's right button is clicked on a valid ValueItem. This event is only applicable when MultipleSelectionSettings is enabled.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property string* get_OnValueItemContextMenu();
public: __property void set_OnValueItemContextMenu(
   string* value
);
C++/CLI
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, valueItem")]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the JavaScript function to be invoked when mouse's right button is clicked on a valid ValueItem. This event is only applicable when MultipleSelectionSettings is enabled.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property String^ OnValueItemContextMenu {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members

Concepts

Client side Event Designer


OnValueItemNotInList Property

[image]
Intersoft WebCombo Documentation
OnValueItemNotInList Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ClientEvents Class : OnValueItemNotInList Property

Specifies the JavaScript function that will be invoked when the typed text can not be found in the List. This event is only applicable when MultipleSelectionSettings is enabled and AllowNotInListText is set to True. Specifies the JavaScript function that will be invoked when the typed text can't be found in the List. This event is only applicable when MultipleSelectionSettings is enabled and AllowNotInListText is set to True.

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies the JavaScript function that will be invoked when the typed text can't be found in the List. This event is only applicable when MultipleSelectionSettings is enabled.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, valueItems")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property OnValueItemNotInList As String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As String

instance.OnValueItemNotInList = value

value = instance.OnValueItemNotInList
C#
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the JavaScript function that will be invoked when the typed text can't be found in the List. This event is only applicable when MultipleSelectionSettings is enabled.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, valueItems")]
[ISNet.Serialization.XmlSerializableAttribute()]
public string OnValueItemNotInList {get; set;}
Delphi
public read-write property OnValueItemNotInList: String;
JScript
NotifyParentPropertyAttribute()
DefaultValueAttribute()
DescriptionAttribute("Specifies the JavaScript function that will be invoked when the typed text can't be found in the List. This event is only applicable when MultipleSelectionSettings is enabled.")
ISNet.Serialization.BinarySerializableAttribute()
EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, valueItems")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set OnValueItemNotInList : String
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the JavaScript function that will be invoked when the typed text can't be found in the List. This event is only applicable when MultipleSelectionSettings is enabled.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, valueItems")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property string* get_OnValueItemNotInList();
public: __property void set_OnValueItemNotInList(
   string* value
);
C++/CLI
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the JavaScript function that will be invoked when the typed text can't be found in the List. This event is only applicable when MultipleSelectionSettings is enabled.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, valueItems")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property String^ OnValueItemNotInList {
   String^ get();
   void set (    String^ value);
}

Remarks

You can handle this event to determine how items that are not in list should be treated. You can either alert the user that the specified value is not currently available and provide a form for them to input it. You can also instruct WebCombo to cancel the addition of unknown items by specifying return false at the end of function.

You can handle this event to determine how items that are not in list should be treated. You can either alert the user that the specified value is not currently available and provide a form for them to input it. You can also instruct WebCombo to cancel the addition of unknown items by specifying return false at the end of function.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientEvents Class
ClientEvents Members

Concepts

Client side Event Designer


Columns Class

[image]
Intersoft WebCombo Documentation
Columns Class
Members See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : Columns Class

Columns object provides a collection for the columns contained in WebGrid control. Columns object provides a collection for the columns contained in WebGrid control.

Object Model

Columns Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<SerializableAttribute()>
Public Class Columns
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As Columns
C#
[DefaultMemberAttribute("Item")]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[SerializableAttribute()]
public class Columns : ISNet.WebUI.ISCollectionBase
Delphi
public class Columns = class(ISNet.WebUI.ISCollectionBase)
JScript
DefaultMemberAttribute("Item")
PersistenceModeAttribute(PersistenceMode.InnerProperty)
SerializableAttribute()
public class Columns extends ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[SerializableAttribute()]
public __gc class Columns : public ISNet.WebUI.ISCollectionBase
C++/CLI
[DefaultMemberAttribute("Item")]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[SerializableAttribute()]
public ref class Columns : public ISNet.WebUI.ISCollectionBase

Remarks

You should never create this class manually as it is automatically populated on DataBind process.You should never create this class manually as it is automatically populated on DataBind process.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebCombo.Columns

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Columns Members
ISNet.WebUI.WebCombo Namespace


Columns Class Members

[image]
Intersoft WebCombo Documentation
Columns Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebCombo Namespace : Columns Class

The following tables list the members exposed by Columns.

Public Constructors

 | Name | Description
public Constructor | Columns Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | Capacity | (Inherited from System.Collections.CollectionBase)
public Property | Count | (Inherited from System.Collections.CollectionBase)
public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only. Returns a Boolean value indicating whether the collection is read-only.
public Property | Item | Property indexer for the collection. Property indexer for the collection.
public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
public Method | Add | Overloaded. Add Column object to Columns collection. Add Column object to Columns collection.
public Method | Clear | Removes all Column objects from the collection. Removes all Column objects from the collection.
public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | CopyFrom |
public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | GetByFieldName |
public Method | GetEnumerator | Returns an enumerator object for the collection. Returns an enumerator object for the collection.
public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | GetNamedItem | Property indexer for the collection. Uses the Name string to return an WebGridColumn object. Property indexer for the collection. Uses the Name string to return an WebGridColumn object.
public Method | GetVisibleColumnsCount |
public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | ShowOnlyColumns |
Top

See Also

Reference

Columns Class
ISNet.WebUI.WebCombo Namespace


Columns Constructor

[image]
Intersoft WebCombo Documentation
Columns Constructor
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Columns Class : Columns Constructor

Initializes a new instance of the Columns class.

Overload List

Overload | Description
Columns Constructor() | Initializes a new instance of the Columns class with no argument.
Columns Constructor(WebCombo) | Default constructor for Columns.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Columns Class
Columns Members


Columns Constructor()

[image]
Intersoft WebCombo Documentation
Columns Constructor()
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Columns Class > Columns Constructor : Columns Constructor()

Initializes a new instance of the Columns class with no argument.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Columns()
C#
public Columns()
Delphi
public Columns();
JScript
public function Columns();
Managed Extensions for C++
public: Columns();
C++/CLI
public:
Columns();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Columns Class
Columns Members
Overload List


Columns Constructor(WebCombo)

[image]
Intersoft WebCombo Documentation
Columns Constructor(WebCombo)
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Columns Class > Columns Constructor : Columns Constructor(WebCombo)

o
Default constructor for Columns.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal o As WebCombo _
)
Visual Basic (Usage) Copy Code
Dim o As WebCombo

Dim instance As New Columns(o)
C#
public Columns(
   WebCombo o
)
Delphi
public Columns(
    o: WebCombo
);
JScript
public function Columns(
   o : WebCombo
);
Managed Extensions for C++
public: Columns(
   WebCombo* o
)
C++/CLI
public:
Columns(
   WebCombo^ o
)

Parameters

o

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Columns Class
Columns Members
Overload List


Columns Class Methods

[image]
Intersoft WebCombo Documentation
Columns Class Methods
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : Columns Class

For a list of all members of this type, see Columns members.

Public Methods

 | Name | Description
public Method | Add | Overloaded. Add Column object to Columns collection. Add Column object to Columns collection.
public Method | Clear | Removes all Column objects from the collection. Removes all Column objects from the collection.
public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | CopyFrom |
public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | GetByFieldName |
public Method | GetEnumerator | Returns an enumerator object for the collection. Returns an enumerator object for the collection.
public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | GetNamedItem | Property indexer for the collection. Uses the Name string to return an WebGridColumn object. Property indexer for the collection. Uses the Name string to return an WebGridColumn object.
public Method | GetVisibleColumnsCount |
public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | ShowOnlyColumns |
Top

See Also

Reference

Columns Class
ISNet.WebUI.WebCombo Namespace


Add Method

[image]
Intersoft WebCombo Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Columns Class : Add Method

Add Column object to Columns collection.

Add Column object to Columns collection.

Overload List

Overload | Description
Add(String) | Add Column object to Columns collection. Add Column object to Columns collection.
Add(WebComboColumn) | Add an Column object into the Columns collection. Add an Column object into the Columns collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Columns Class
Columns Members


Add(String) Method

[image]
Intersoft WebCombo Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Columns Class > Add Method : Add(String) Method

FieldName
The data column field to add. The data column field to add.

Add Column object to Columns collection.

Add Column object to Columns collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal FieldName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Columns
Dim FieldName As String

instance.Add(FieldName)
C#
public void Add(
   string FieldName
)
Delphi
public procedure Add(
    FieldName: String
);
JScript
public function Add(
   FieldName : String
);
Managed Extensions for C++
public: void Add(
   string* FieldName
)
C++/CLI
public:
void Add(
   String^ FieldName
)

Parameters

FieldName
The data column field to add. The data column field to add.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Columns Class
Columns Members
Overload List


Add(WebComboColumn) Method

[image]
Intersoft WebCombo Documentation
Add(WebComboColumn) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Columns Class > Add Method : Add(WebComboColumn) Method

column
The Column object to be added.The Column object to be added.
Add an Column object into the Columns collection. Add an Column object into the Columns collection.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal column As WebComboColumn _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Columns
Dim column As WebComboColumn
Dim value As Integer

value = instance.Add(column)
C#
public virtual int Add(
   WebComboColumn column
)
Delphi
public function Add(
    column: WebComboColumn
): Integer; virtual;
JScript
public function Add(
   column : WebComboColumn
) : int;
Managed Extensions for C++
public: virtual int Add(
   WebComboColumn* column
)
C++/CLI
public:
virtual int Add(
   WebComboColumn^ column
)

Parameters

column
The Column object to be added.The Column object to be added.

Return Value

The index of the newly added Column.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Columns Class
Columns Members
Overload List


Clear Method

[image]
Intersoft WebCombo Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Columns Class : Clear Method

Removes all Column objects from the collection. Removes all Column objects from the collection.

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As Columns

instance.Clear()
C#
public new void Clear()
Delphi
public procedure Clear();
JScript
public hide function Clear();
Managed Extensions for C++
public: new void Clear();
C++/CLI
public:
new void Clear();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Columns Class
Columns Members


Contains Method

[image]
Intersoft WebCombo Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Columns Class : Contains Method

value

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Columns
Dim value As ISNet.WebUI.INamedObject
Dim value As Boolean

value = instance.Contains(value)
C#
public bool Contains(
   ISNet.WebUI.INamedObject value
)
Delphi
public function Contains(
    value: ISNet.WebUI.INamedObject
): Boolean;
JScript
public function Contains(
   value : ISNet.WebUI.INamedObject
) : boolean;
Managed Extensions for C++
public: bool Contains(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
bool Contains(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Columns Class
Columns Members


CopyFrom Method

[image]
Intersoft WebCombo Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Columns Class : CopyFrom Method

passIn

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As Columns _
) As Columns
Visual Basic (Usage) Copy Code
Dim instance As Columns
Dim passIn As Columns
Dim value As Columns

value = instance.CopyFrom(passIn)
C#
public Columns CopyFrom(
   Columns passIn
)
Delphi
public function CopyFrom(
    passIn: Columns
): Columns;
JScript
public function CopyFrom(
   passIn : Columns
) : Columns;
Managed Extensions for C++
public: Columns* CopyFrom(
   Columns* passIn
)
C++/CLI
public:
Columns^ CopyFrom(
   Columns^ passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Columns Class
Columns Members


CopyTo Method

[image]
Intersoft WebCombo Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Columns Class : CopyTo Method

array
index

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As Columns
Dim array() As ISNet.WebUI.INamedObject
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObjectarray of;
    index: Integer
);
JScript
public function CopyTo(
   array : ISNet.WebUI.INamedObject[],
   index : int
);
Managed Extensions for C++
public: void CopyTo(
   ISNet.WebUI.INamedObject*[]* array,
   int index
)
C++/CLI
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject^>^ array,
   int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Columns Class
Columns Members


Exists Method

[image]
Intersoft WebCombo Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Columns Class : Exists Method

name

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Columns
Dim name As String
Dim value As Boolean

value = instance.Exists(name)
C#
public bool Exists(
   string name
)
Delphi
public function Exists(
    name: String
): Boolean;
JScript
public function Exists(
   name : String
) : boolean;
Managed Extensions for C++
public: bool Exists(
   string* name
)
C++/CLI
public:
bool Exists(
   String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Columns Class
Columns Members


GetByFieldName Method

[image]
Intersoft WebCombo Documentation
GetByFieldName Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Columns Class : GetByFieldName Method

fieldName

Syntax

Visual Basic (Declaration)
Public Function GetByFieldName( _
   ByVal fieldName As String _
) As WebComboColumn
Visual Basic (Usage) Copy Code
Dim instance As Columns
Dim fieldName As String
Dim value As WebComboColumn

value = instance.GetByFieldName(fieldName)
C#
public WebComboColumn GetByFieldName(
   string fieldName
)
Delphi
public function GetByFieldName(
    fieldName: String
): WebComboColumn;
JScript
public function GetByFieldName(
   fieldName : String
) : WebComboColumn;
Managed Extensions for C++
public: WebComboColumn* GetByFieldName(
   string* fieldName
)
C++/CLI
public:
WebComboColumn^ GetByFieldName(
   String^ fieldName
)

Parameters

fieldName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Columns Class
Columns Members


GetEnumerator Method

[image]
Intersoft WebCombo Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Columns Class : GetEnumerator Method

Returns an enumerator object for the collection. Returns an enumerator object for the collection.

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As Columns
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public new IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
JScript
public hide function GetEnumerator() : IEnumerator;
Managed Extensions for C++
public: new IEnumerator* GetEnumerator();
C++/CLI
public:
new IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Columns Class
Columns Members


GetItem Method

[image]
Intersoft WebCombo Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Columns Class : GetItem Method

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Columns Class
Columns Members


GetItem(Int32) Method

[image]
Intersoft WebCombo Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Columns Class : GetItem(Int32) Method

index

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As Columns
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   int index
)
Delphi
public function GetItem(
    index: Integer
): ISNet.WebUI.INamedObject; virtual;
JScript
public function GetItem(
   index : int
) : ISNet.WebUI.INamedObject;
Managed Extensions for C++
public: virtual ISNet.WebUI.INamedObject* GetItem(
   int index
)
C++/CLI
public:
virtual ISNet.WebUI.INamedObject^ GetItem(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Columns Class
Columns Members


GetNamedItem Method

[image]
Intersoft WebCombo Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Columns Class : GetNamedItem Method

name
Property indexer for the collection. Uses the Name string to return an WebGridColumn object. Property indexer for the collection. Uses the Name string to return an WebGridColumn object.

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As String _
) As WebComboColumn
Visual Basic (Usage) Copy Code
Dim instance As Columns
Dim name As String
Dim value As WebComboColumn

value = instance.GetNamedItem(name)
C#
public WebComboColumn GetNamedItem(
   string name
)
Delphi
public function GetNamedItem(
    name: String
): WebComboColumn;
JScript
public function GetNamedItem(
   name : String
) : WebComboColumn;
Managed Extensions for C++
public: WebComboColumn* GetNamedItem(
   string* name
)
C++/CLI
public:
WebComboColumn^ GetNamedItem(
   String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Columns Class
Columns Members


GetVisibleColumnsCount Method

[image]
Intersoft WebCombo Documentation
GetVisibleColumnsCount Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Columns Class : GetVisibleColumnsCount Method

Syntax

Visual Basic (Declaration)
Public Function GetVisibleColumnsCount() As Integer
Visual Basic (Usage) Copy Code
Dim instance As Columns
Dim value As Integer

value = instance.GetVisibleColumnsCount()
C#
public int GetVisibleColumnsCount()
Delphi
public function GetVisibleColumnsCount(): Integer;
JScript
public function GetVisibleColumnsCount() : int;
Managed Extensions for C++
public: int GetVisibleColumnsCount();
C++/CLI
public:
int GetVisibleColumnsCount();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Columns Class
Columns Members


IndexOf Method

[image]
Intersoft WebCombo Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Columns Class : IndexOf Method

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Columns Class
Columns Members


IndexOf(String) Method

[image]
Intersoft WebCombo Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Columns Class > IndexOf Method : IndexOf(String) Method

name

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Columns
Dim name As String
Dim value As Integer

value = instance.IndexOf(name)
C#
public virtual int IndexOf(
   string name
)
Delphi
public function IndexOf(
    name: String
): Integer; virtual;
JScript
public function IndexOf(
   name : String
) : int;
Managed Extensions for C++
public: virtual int IndexOf(
   string* name
)
C++/CLI
public:
virtual int IndexOf(
   String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Columns Class
Columns Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebCombo Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Columns Class > IndexOf Method : IndexOf(INamedObject) Method

value

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Columns
Dim value As ISNet.WebUI.INamedObject
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   ISNet.WebUI.INamedObject value
)
Delphi
public function IndexOf(
    value: ISNet.WebUI.INamedObject
): Integer;
JScript
public function IndexOf(
   value : ISNet.WebUI.INamedObject
) : int;
Managed Extensions for C++
public: int IndexOf(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
int IndexOf(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Columns Class
Columns Members
Overload List


IntInsert Method

[image]
Intersoft WebCombo Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Columns Class : IntInsert Method

index
value

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As Columns
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   int index,
   ISNet.WebUI.INamedObject value
)
Delphi
public procedure IntInsert(
    index: Integer;
    value: ISNet.WebUI.INamedObject
);
JScript
public function IntInsert(
   index : int,
   value : ISNet.WebUI.INamedObject
);
Managed Extensions for C++
public: void IntInsert(
   int index,
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
void IntInsert(
   int index,
   ISNet.WebUI.INamedObject^ value
)

Parameters

index
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Columns Class
Columns Members


RemoveAt Method

[image]
Intersoft WebCombo Documentation
RemoveAt Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Columns Class : RemoveAt Method

index

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As Columns
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)
Delphi
public procedure RemoveAt(
    index: Integer
);
JScript
public function RemoveAt(
   index : int
);
Managed Extensions for C++
public: void RemoveAt(
   int index
)
C++/CLI
public:
void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Columns Class
Columns Members


setParent Method

[image]
Intersoft WebCombo Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Columns Class : setParent Method

parent

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As Columns
Dim parent As Object

instance.setParent(parent)
C#
public virtual void setParent(
   object parent
)
Delphi
public procedure setParent(
    parent: TObject
); virtual;
JScript
public function setParent(
   parent : Object
);
Managed Extensions for C++
public: virtual void setParent(
   Object* parent
)
C++/CLI
public:
virtual void setParent(
   Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Columns Class
Columns Members


ShowOnlyColumns Method

[image]
Intersoft WebCombo Documentation
ShowOnlyColumns Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Columns Class : ShowOnlyColumns Method

fieldName

Syntax

Visual Basic (Declaration)
Public Sub ShowOnlyColumns( _
   ByVal fieldName() As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Columns
Dim fieldName() As String

instance.ShowOnlyColumns(fieldName)
C#
public void ShowOnlyColumns(
   string[] fieldName
)
Delphi
public procedure ShowOnlyColumns(
    fieldName: Stringarray of
);
JScript
public function ShowOnlyColumns(
   fieldName : String[]
);
Managed Extensions for C++
public: void ShowOnlyColumns(
   string*[]* fieldName
)
C++/CLI
public:
void ShowOnlyColumns(
   array<String^>^ fieldName
)

Parameters

fieldName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Columns Class
Columns Members


Capacity Property

[image]
Intersoft WebCombo Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Columns Class : Capacity Property

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)>
Public Property Capacity As Integer
Visual Basic (Usage) Copy Code
Dim instance As Columns
Dim value As Integer

instance.Capacity = value

value = instance.Capacity
C#
[ComVisibleAttribute(false)]
public int Capacity {get; set;}
Delphi
public read-write property Capacity: Integer;
JScript
ComVisibleAttribute()
public function get,set Capacity : int
Managed Extensions for C++
[ComVisibleAttribute(false)]
public: __property int get_Capacity();
public: __property void set_Capacity(
   int value
);
C++/CLI
[ComVisibleAttribute(false)]
public:
property int Capacity {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Columns Class
Columns Members


Count Property

[image]
Intersoft WebCombo Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Columns Class : Count Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As Columns
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Delphi
public read-only property Count: Integer;
JScript
public function get Count : int
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Columns Class
Columns Members


Columns Class Properties

[image]
Intersoft WebCombo Documentation
Columns Class Properties
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : Columns Class

For a list of all members of this type, see Columns members.

Public Properties

 | Name | Description
public Property | Capacity | (Inherited from System.Collections.CollectionBase)
public Property | Count | (Inherited from System.Collections.CollectionBase)
public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only. Returns a Boolean value indicating whether the collection is read-only.
public Property | Item | Property indexer for the collection. Property indexer for the collection.
public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

Columns Class
ISNet.WebUI.WebCombo Namespace


IsReadOnly Property

[image]
Intersoft WebCombo Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Columns Class : IsReadOnly Property

Returns a Boolean value indicating whether the collection is read-only.

Returns a Boolean value indicating whether the collection is read-only.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Columns
Dim value As Boolean

value = instance.IsReadOnly
C#
public override bool IsReadOnly {get;}
Delphi
public read-only property IsReadOnly: Boolean; override;
JScript
public override function get IsReadOnly : boolean
Managed Extensions for C++
public: __property bool get_IsReadOnly() override;
C++/CLI
public:
property bool IsReadOnly {
   bool get() override;
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Columns Class
Columns Members


Item Property

[image]
Intersoft WebCombo Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Columns Class : Item Property

index
Property indexer for the collection. Property indexer for the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As WebComboColumn
Visual Basic (Usage) Copy Code
Dim instance As Columns
Dim index As Integer
Dim value As WebComboColumn

value = instance.Item(index)
C#
public WebComboColumn this(
   int index
) {get;}
Delphi
public  this: : WebComboColumn;(
    index: Integer
); read-only
JScript
public  this(
   index : int
) get : WebComboColumn
Managed Extensions for C++
public: __property WebComboColumn* get_Item(
   int index
);
C++/CLI
public:
property WebComboColumn^ default [int] {
   WebComboColumn^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Columns Class
Columns Members


Parent Property

[image]
Intersoft WebCombo Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Columns Class : Parent Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As Object
Visual Basic (Usage) Copy Code
Dim instance As Columns
Dim value As Object

value = instance.Parent
C#
public object Parent {get;}
Delphi
public read-only property Parent: TObject;
JScript
public function get Parent : Object
Managed Extensions for C++
public: __property Object* get_Parent();
C++/CLI
public:
property Object^ Parent {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Columns Class
Columns Members


DataSourceEventArgs Class

[image]
Intersoft WebCombo Documentation
DataSourceEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : DataSourceEventArgs Class

Provides data for datasource related event. Provides data for datasource related event.

Object Model

DataSourceEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class DataSourceEventArgs
   Inherits BaseEventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataSourceEventArgs
C#
public class DataSourceEventArgs : BaseEventArgs
Delphi
public class DataSourceEventArgs = class(BaseEventArgs)
JScript
public class DataSourceEventArgs extends BaseEventArgs
Managed Extensions for C++
public __gc class DataSourceEventArgs : public BaseEventArgs
C++/CLI
public ref class DataSourceEventArgs : public BaseEventArgs

Remarks

DataSourceEventArgs mostly used in load on demand scenario, in which users can retrieve data rows manually from DataSource based on user's QueryText, StartRow, RowCount and other properties that are available to the context.

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebCombo.BaseEventArgs
ISNet.WebUI.WebCombo.DataSourceEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataSourceEventArgs Members
ISNet.WebUI.WebCombo Namespace

Concepts

Retrieving data using Load-on-Demand feature in ISDataSource control


DataSourceEventArgs Class Members

[image]
Intersoft WebCombo Documentation
DataSourceEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebCombo Namespace : DataSourceEventArgs Class

The following tables list the members exposed by DataSourceEventArgs.

Public Properties

 | Name | Description
public Property | AdditionalFilters |
public Property | DataSource | Gets or sets the DataSource for the control. Gets or sets the DataSource for the control.
public Property | EndRow |
public Property | IsDropDownClicked | Specifies whether the dropdown is clicked.
public Property | IsFlyDataRequest | Specifies whether the WebCombo's data request invoke a Postback.
public Property | QueryText |
public Property | ReturnValue | (Inherited from ISNet.WebUI.WebCombo.BaseEventArgs)
public Property | RowCount | Gets row count that will be retrieved from DataSource.
public Property | StartRow | Gets start rows that will be retrieved from DataSource
Top

See Also

Reference

DataSourceEventArgs Class
ISNet.WebUI.WebCombo Namespace


DataSourceEventArgs Class Properties

[image]
Intersoft WebCombo Documentation
DataSourceEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : DataSourceEventArgs Class

For a list of all members of this type, see DataSourceEventArgs members.

Public Properties

 | Name | Description
public Property | AdditionalFilters |
public Property | DataSource | Gets or sets the DataSource for the control. Gets or sets the DataSource for the control.
public Property | EndRow |
public Property | IsDropDownClicked | Specifies whether the dropdown is clicked.
public Property | IsFlyDataRequest | Specifies whether the WebCombo's data request invoke a Postback.
public Property | QueryText |
public Property | ReturnValue | (Inherited from ISNet.WebUI.WebCombo.BaseEventArgs)
public Property | RowCount | Gets row count that will be retrieved from DataSource.
public Property | StartRow | Gets start rows that will be retrieved from DataSource
Top

See Also

Reference

DataSourceEventArgs Class
ISNet.WebUI.WebCombo Namespace


AdditionalFilters Property

[image]
Intersoft WebCombo Documentation
AdditionalFilters Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > DataSourceEventArgs Class : AdditionalFilters Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AdditionalFilters As String
Visual Basic (Usage) Copy Code
Dim instance As DataSourceEventArgs
Dim value As String

value = instance.AdditionalFilters
C#
public string AdditionalFilters {get;}
Delphi
public read-only property AdditionalFilters: String;
JScript
public function get AdditionalFilters : String
Managed Extensions for C++
public: __property string* get_AdditionalFilters();
C++/CLI
public:
property String^ AdditionalFilters {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataSourceEventArgs Class
DataSourceEventArgs Members


DataSource Property

[image]
Intersoft WebCombo Documentation
DataSource Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > DataSourceEventArgs Class : DataSource Property

Gets or sets the DataSource for the control. Gets or sets the DataSource for the control.

Syntax

Visual Basic (Declaration)
Public Property DataSource As Object
Visual Basic (Usage) Copy Code
Dim instance As DataSourceEventArgs
Dim value As Object

instance.DataSource = value

value = instance.DataSource
C#
public object DataSource {get; set;}
Delphi
public read-write property DataSource: TObject;
JScript
public function get,set DataSource : Object
Managed Extensions for C++
public: __property Object* get_DataSource();
public: __property void set_DataSource(
   Object* value
);
C++/CLI
public:
property Object^ DataSource {
   Object^ get();
   void set (    Object^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataSourceEventArgs Class
DataSourceEventArgs Members


EndRow Property

[image]
Intersoft WebCombo Documentation
EndRow Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > DataSourceEventArgs Class : EndRow Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EndRow As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataSourceEventArgs
Dim value As Integer

value = instance.EndRow
C#
public int EndRow {get;}
Delphi
public read-only property EndRow: Integer;
JScript
public function get EndRow : int
Managed Extensions for C++
public: __property int get_EndRow();
C++/CLI
public:
property int EndRow {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataSourceEventArgs Class
DataSourceEventArgs Members


IsDropDownClicked Property

[image]
Intersoft WebCombo Documentation
IsDropDownClicked Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > DataSourceEventArgs Class : IsDropDownClicked Property

Specifies whether the dropdown is clicked.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsDropDownClicked As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataSourceEventArgs
Dim value As Boolean

value = instance.IsDropDownClicked
C#
public bool IsDropDownClicked {get;}
Delphi
public read-only property IsDropDownClicked: Boolean;
JScript
public function get IsDropDownClicked : boolean
Managed Extensions for C++
public: __property bool get_IsDropDownClicked();
C++/CLI
public:
property bool IsDropDownClicked {
   bool get();
}

Remarks

If you want to use this property, you need to set the AllowAutoDataCaching and AllowAutoQueryHandler to False.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataSourceEventArgs Class
DataSourceEventArgs Members


IsFlyDataRequest Property

[image]
Intersoft WebCombo Documentation
IsFlyDataRequest Property
See Also Example Send Feedback
ISNet.WebUI.WebCombo Namespace > DataSourceEventArgs Class : IsFlyDataRequest Property

Specifies whether the WebCombo's data request invoke a Postback.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFlyDataRequest As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataSourceEventArgs
Dim value As Boolean

value = instance.IsFlyDataRequest
C#
public bool IsFlyDataRequest {get;}
Delphi
public read-only property IsFlyDataRequest: Boolean;
JScript
public function get IsFlyDataRequest : boolean
Managed Extensions for C++
public: __property bool get_IsFlyDataRequest();
C++/CLI
public:
property bool IsFlyDataRequest {
   bool get();
}

Example

The following example shows you to retrieve data manually from DataSource (Load on Demand) based on user's queryText, startRow, rowCount and other properties that are available to the context. Insert the codes below in InitializeDataSource event.
C# Copy Code
if (!e.IsFlyDataRequest)
{
        // the codes below is used to retrieve WebCombo's text value on data binding when page is first load.
        if (WebCombo1.Value != "" && WebCombo1.Value != null)
        {
                oleDbSelectCommand1.CommandText = "Select * From Customers Where " + WebCombo1.DataValueField + " = '" + WebCombo1.Value + "'";
                oleDbDataAdapter1.Fill(dsNorthWind1);
                e.DataSource = dsNorthWind1;
        }
}
else
{
        // use following codes to retrieve data when data request is invoked from client.
        int TopRows = e.StartRow + e.RowCount;
        oleDbSelectCommand1.CommandText = "Select TOP " + TopRows + " * From Customers Where " + WebCombo1.DataTextField + " Like '" + e.QueryText + "%'";

        // fill data source with a start row and maximum rows, pass it to e.DataSource.
        oleDbDataAdapter1.Fill(dsNorthWind1, e.StartRow, e.RowCount, "Customers");
        e.DataSource = dsNorthWind1;
        // tell WebCombo to skip automatic row parsing because we already implement our own top rows implementation.
        WebCombo1.SkipRowParsing = true;
        // now we need to retrieve original total records of the query in order for WebCombo to show correct total rows.
        // notice that we used fast and lightweight data reader to get the total rows count.
        oleDbConnection1.Open();
        oleDbSelectCommand1.CommandText = "Select Count(CustomerID) From Customers Where " + WebCombo1.DataTextField + " Like '" + e.QueryText + "%'";

        OleDbDataReader dr = oleDbSelectCommand1.ExecuteReader(CommandBehavior.CloseConnection);
        dr.Read();
        WebCombo1.TotalDataSourceRows = int.Parse(dr[0].ToString());
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataSourceEventArgs Class
DataSourceEventArgs Members

Concepts

Retrieving data using Load-on-Demand feature in ISDataSource control


QueryText Property

[image]
Intersoft WebCombo Documentation
QueryText Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > DataSourceEventArgs Class : QueryText Property

Syntax

Visual Basic (Declaration)
Public Property QueryText As String
Visual Basic (Usage) Copy Code
Dim instance As DataSourceEventArgs
Dim value As String

instance.QueryText = value

value = instance.QueryText
C#
public string QueryText {get; set;}
Delphi
public read-write property QueryText: String;
JScript
public function get,set QueryText : String
Managed Extensions for C++
public: __property string* get_QueryText();
public: __property void set_QueryText(
   string* value
);
C++/CLI
public:
property String^ QueryText {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataSourceEventArgs Class
DataSourceEventArgs Members


RowCount Property

[image]
Intersoft WebCombo Documentation
RowCount Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > DataSourceEventArgs Class : RowCount Property

Gets row count that will be retrieved from DataSource.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RowCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataSourceEventArgs
Dim value As Integer

value = instance.RowCount
C#
public int RowCount {get;}
Delphi
public read-only property RowCount: Integer;
JScript
public function get RowCount : int
Managed Extensions for C++
public: __property int get_RowCount();
C++/CLI
public:
property int RowCount {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataSourceEventArgs Class
DataSourceEventArgs Members


StartRow Property

[image]
Intersoft WebCombo Documentation
StartRow Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > DataSourceEventArgs Class : StartRow Property

Gets start rows that will be retrieved from DataSource

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StartRow As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataSourceEventArgs
Dim value As Integer

value = instance.StartRow
C#
public int StartRow {get;}
Delphi
public read-only property StartRow: Integer;
JScript
public function get StartRow : int
Managed Extensions for C++
public: __property int get_StartRow();
C++/CLI
public:
property int StartRow {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataSourceEventArgs Class
DataSourceEventArgs Members


FieldTypeEditor Class

[image]
Intersoft WebCombo Documentation
FieldTypeEditor Class
Members See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : FieldTypeEditor Class

Summary description for FieldTypeEditor. Summary description for FieldTypeEditor.

Object Model

FieldTypeEditor Class

Syntax

Visual Basic (Declaration)
Public Class FieldTypeEditor
   Inherits System.Drawing.Design.UITypeEditor
Visual Basic (Usage) Copy Code
Dim instance As FieldTypeEditor
C#
public class FieldTypeEditor : System.Drawing.Design.UITypeEditor
Delphi
public class FieldTypeEditor = class(System.Drawing.Design.UITypeEditor)
JScript
public class FieldTypeEditor extends System.Drawing.Design.UITypeEditor
Managed Extensions for C++
public __gc class FieldTypeEditor : public System.Drawing.Design.UITypeEditor
C++/CLI
public ref class FieldTypeEditor : public System.Drawing.Design.UITypeEditor

Inheritance Hierarchy

System.Object
System.Drawing.Design.UITypeEditor
ISNet.WebUI.WebCombo.FieldTypeEditor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FieldTypeEditor Members
ISNet.WebUI.WebCombo Namespace


FieldTypeEditor Class Members

[image]
Intersoft WebCombo Documentation
FieldTypeEditor Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebCombo Namespace : FieldTypeEditor Class

The following tables list the members exposed by FieldTypeEditor.

Public Constructors

 | Name | Description
public Constructor | FieldTypeEditor Constructor | Initializes a new instance of the DataSourceEventArgs class.
Top

Public Properties

 | Name | Description
public Property | IsDropDownResizable | (Inherited from System.Drawing.Design.UITypeEditor)
Top

Public Methods

Name | Description
public Method EditValue Overloaded. Overridden.

This is an override from UITypeEditor. The property grid will call this when it wants to display the editor for the given value.

This is an override from UITypeEditor. The property grid will call this when it wants to display the editor for the given value.

public Method GetEditStyle Overloaded. Overridden.

This is an override from UITypeEditor. The editor style indicates what type of editor we are providing: we can either display a dialog or a drop-down box. Our editor always shows a drop-down box.

This is an override from UITypeEditor. The editor style indicates what type of editor we are providing: we can either display a dialog or a drop-down box. Our editor always shows a drop-down box.

public Method GetPaintValueSupported Overloaded. Overridden.

This is an override from UITypeEditor and indicates if we support painting a small representation of our value in the property grid.

This is an override from UITypeEditor and indicates if we support painting a small representation of our value in the property grid.

public Method | PaintValue | Overloaded. (Inherited from System.Drawing.Design.UITypeEditor)
Top

See Also

Reference

FieldTypeEditor Class
ISNet.WebUI.WebCombo Namespace


FieldTypeEditor Constructor

[image]
Intersoft WebCombo Documentation
FieldTypeEditor Constructor
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > FieldTypeEditor Class : FieldTypeEditor Constructor

Initializes a new instance of the DataSourceEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New FieldTypeEditor()
C#
public FieldTypeEditor()
Delphi
public FieldTypeEditor();
JScript
public function FieldTypeEditor();
Managed Extensions for C++
public: FieldTypeEditor();
C++/CLI
public:
FieldTypeEditor();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FieldTypeEditor Class
FieldTypeEditor Members


FieldTypeEditor Class Methods

[image]
Intersoft WebCombo Documentation
FieldTypeEditor Class Methods
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : FieldTypeEditor Class

For a list of all members of this type, see FieldTypeEditor members.

Public Methods

Name | Description
public Method EditValue Overloaded. Overridden.

This is an override from UITypeEditor. The property grid will call this when it wants to display the editor for the given value.

This is an override from UITypeEditor. The property grid will call this when it wants to display the editor for the given value.

public Method GetEditStyle Overloaded. Overridden.

This is an override from UITypeEditor. The editor style indicates what type of editor we are providing: we can either display a dialog or a drop-down box. Our editor always shows a drop-down box.

This is an override from UITypeEditor. The editor style indicates what type of editor we are providing: we can either display a dialog or a drop-down box. Our editor always shows a drop-down box.

public Method GetPaintValueSupported Overloaded. Overridden.

This is an override from UITypeEditor and indicates if we support painting a small representation of our value in the property grid.

This is an override from UITypeEditor and indicates if we support painting a small representation of our value in the property grid.

public Method | PaintValue | Overloaded. (Inherited from System.Drawing.Design.UITypeEditor)
Top

See Also

Reference

FieldTypeEditor Class
ISNet.WebUI.WebCombo Namespace


FieldTypeEditor Class Properties

[image]
Intersoft WebCombo Documentation
FieldTypeEditor Class Properties
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : FieldTypeEditor Class

For a list of all members of this type, see FieldTypeEditor members.

Public Properties

 | Name | Description
public Property | IsDropDownResizable | (Inherited from System.Drawing.Design.UITypeEditor)
Top

See Also

Reference

FieldTypeEditor Class
ISNet.WebUI.WebCombo Namespace


EditValue Method

[image]
Intersoft WebCombo Documentation
EditValue Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > FieldTypeEditor Class : EditValue Method

This is an override from UITypeEditor. The property grid will call this when it wants to display the editor for the given value.

This is an override from UITypeEditor. The property grid will call this when it wants to display the editor for the given value.

Overload List

Overload | Description
EditValue(ITypeDescriptorContext,IServiceProvider,Object)

This is an override from UITypeEditor. The property grid will call this when it wants to display the editor for the given value.

This is an override from UITypeEditor. The property grid will call this when it wants to display the editor for the given value.

EditValue(IServiceProvider,Object) | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FieldTypeEditor Class
FieldTypeEditor Members


EditValue(ITypeDescriptorContext,IServiceProvider,Object) Method

[image]
Intersoft WebCombo Documentation
EditValue(ITypeDescriptorContext,IServiceProvider,Object) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > FieldTypeEditor Class > EditValue Method : EditValue(ITypeDescriptorContext,IServiceProvider,Object) Method

context
provider
value

This is an override from UITypeEditor. The property grid will call this when it wants to display the editor for the given value.

This is an override from UITypeEditor. The property grid will call this when it wants to display the editor for the given value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function EditValue( _
   ByVal context As ITypeDescriptorContext, _
   ByVal provider As IServiceProvider, _
   ByVal value As Object _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As FieldTypeEditor
Dim context As ITypeDescriptorContext
Dim provider As IServiceProvider
Dim value As Object
Dim value As Object

value = instance.EditValue(context, provider, value)
C#
public override object EditValue(
   ITypeDescriptorContext context,
   IServiceProvider provider,
   object value
)
Delphi
public function EditValue(
    context: ITypeDescriptorContext;
    provider: IServiceProvider;
    value: TObject
): TObject; override;
JScript
public override function EditValue(
   context : ITypeDescriptorContext,
   provider : IServiceProvider,
   value : Object
) : Object;
Managed Extensions for C++
public: Object* EditValue(
   ITypeDescriptorContext* context,
   IServiceProvider* provider,
   Object* value
) override
C++/CLI
public:
Object^ EditValue(
   ITypeDescriptorContext^ context,
   IServiceProvider^ provider,
   Object^ value
) override

Parameters

context
provider
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FieldTypeEditor Class
FieldTypeEditor Members
Overload List


EditValue(IServiceProvider,Object) Method

[image]
Intersoft WebCombo Documentation
EditValue(IServiceProvider,Object) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > FieldTypeEditor Class > EditValue Method : EditValue(IServiceProvider,Object) Method

provider
value

Syntax

Visual Basic (Declaration)
Public Overloads Function EditValue( _
   ByVal provider As IServiceProvider, _
   ByVal value As Object _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As FieldTypeEditor
Dim provider As IServiceProvider
Dim value As Object
Dim value As Object

value = instance.EditValue(provider, value)
C#
public object EditValue(
   IServiceProvider provider,
   object value
)
Delphi
public function EditValue(
    provider: IServiceProvider;
    value: TObject
): TObject;
JScript
public function EditValue(
   provider : IServiceProvider,
   value : Object
) : Object;
Managed Extensions for C++
public: Object* EditValue(
   IServiceProvider* provider,
   Object* value
)
C++/CLI
public:
Object^ EditValue(
   IServiceProvider^ provider,
   Object^ value
)

Parameters

provider
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FieldTypeEditor Class
FieldTypeEditor Members
Overload List


GetEditStyle Method

[image]
Intersoft WebCombo Documentation
GetEditStyle Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > FieldTypeEditor Class : GetEditStyle Method

This is an override from UITypeEditor. The editor style indicates what type of editor we are providing: we can either display a dialog or a drop-down box. Our editor always shows a drop-down box.

This is an override from UITypeEditor. The editor style indicates what type of editor we are providing: we can either display a dialog or a drop-down box. Our editor always shows a drop-down box.

Overload List

Overload | Description
GetEditStyle(ITypeDescriptorContext)

This is an override from UITypeEditor. The editor style indicates what type of editor we are providing: we can either display a dialog or a drop-down box. Our editor always shows a drop-down box.

This is an override from UITypeEditor. The editor style indicates what type of editor we are providing: we can either display a dialog or a drop-down box. Our editor always shows a drop-down box.

GetEditStyle() | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FieldTypeEditor Class
FieldTypeEditor Members


GetEditStyle(ITypeDescriptorContext) Method

[image]
Intersoft WebCombo Documentation
GetEditStyle(ITypeDescriptorContext) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > FieldTypeEditor Class > GetEditStyle Method : GetEditStyle(ITypeDescriptorContext) Method

context

This is an override from UITypeEditor. The editor style indicates what type of editor we are providing: we can either display a dialog or a drop-down box. Our editor always shows a drop-down box.

This is an override from UITypeEditor. The editor style indicates what type of editor we are providing: we can either display a dialog or a drop-down box. Our editor always shows a drop-down box.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetEditStyle( _
   ByVal context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
Visual Basic (Usage) Copy Code
Dim instance As FieldTypeEditor
Dim context As ITypeDescriptorContext
Dim value As UITypeEditorEditStyle

value = instance.GetEditStyle(context)
C#
public override UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext context
)
Delphi
public function GetEditStyle(
    context: ITypeDescriptorContext
): UITypeEditorEditStyle; override;
JScript
public override function GetEditStyle(
   context : ITypeDescriptorContext
) : UITypeEditorEditStyle;
Managed Extensions for C++
public: UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext* context
) override
C++/CLI
public:
UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext^ context
) override

Parameters

context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FieldTypeEditor Class
FieldTypeEditor Members
Overload List


GetEditStyle() Method

[image]
Intersoft WebCombo Documentation
GetEditStyle() Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > FieldTypeEditor Class > GetEditStyle Method : GetEditStyle() Method

Syntax

Visual Basic (Declaration)
Public Overloads Function GetEditStyle() As UITypeEditorEditStyle
Visual Basic (Usage) Copy Code
Dim instance As FieldTypeEditor
Dim value As UITypeEditorEditStyle

value = instance.GetEditStyle()
C#
public UITypeEditorEditStyle GetEditStyle()
Delphi
public function GetEditStyle(): UITypeEditorEditStyle;
JScript
public function GetEditStyle() : UITypeEditorEditStyle;
Managed Extensions for C++
public: UITypeEditorEditStyle GetEditStyle();
C++/CLI
public:
UITypeEditorEditStyle GetEditStyle();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FieldTypeEditor Class
FieldTypeEditor Members
Overload List


GetPaintValueSupported Method

[image]
Intersoft WebCombo Documentation
GetPaintValueSupported Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > FieldTypeEditor Class : GetPaintValueSupported Method

This is an override from UITypeEditor and indicates if we support painting a small representation of our value in the property grid.

This is an override from UITypeEditor and indicates if we support painting a small representation of our value in the property grid.

Overload List

Overload | Description
GetPaintValueSupported(ITypeDescriptorContext)

This is an override from UITypeEditor and indicates if we support painting a small representation of our value in the property grid.

This is an override from UITypeEditor and indicates if we support painting a small representation of our value in the property grid.

GetPaintValueSupported() | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FieldTypeEditor Class
FieldTypeEditor Members


GetPaintValueSupported(ITypeDescriptorContext) Method

[image]
Intersoft WebCombo Documentation
GetPaintValueSupported(ITypeDescriptorContext) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > FieldTypeEditor Class > GetPaintValueSupported Method : GetPaintValueSupported(ITypeDescriptorContext) Method

context

This is an override from UITypeEditor and indicates if we support painting a small representation of our value in the property grid.

This is an override from UITypeEditor and indicates if we support painting a small representation of our value in the property grid.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetPaintValueSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FieldTypeEditor
Dim context As ITypeDescriptorContext
Dim value As Boolean

value = instance.GetPaintValueSupported(context)
C#
public override bool GetPaintValueSupported(
   ITypeDescriptorContext context
)
Delphi
public function GetPaintValueSupported(
    context: ITypeDescriptorContext
): Boolean; override;
JScript
public override function GetPaintValueSupported(
   context : ITypeDescriptorContext
) : boolean;
Managed Extensions for C++
public: bool GetPaintValueSupported(
   ITypeDescriptorContext* context
) override
C++/CLI
public:
bool GetPaintValueSupported(
   ITypeDescriptorContext^ context
) override

Parameters

context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FieldTypeEditor Class
FieldTypeEditor Members
Overload List


GetPaintValueSupported() Method

[image]
Intersoft WebCombo Documentation
GetPaintValueSupported() Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > FieldTypeEditor Class > GetPaintValueSupported Method : GetPaintValueSupported() Method

Syntax

Visual Basic (Declaration)
Public Overloads Function GetPaintValueSupported() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FieldTypeEditor
Dim value As Boolean

value = instance.GetPaintValueSupported()
C#
public bool GetPaintValueSupported()
Delphi
public function GetPaintValueSupported(): Boolean;
JScript
public function GetPaintValueSupported() : boolean;
Managed Extensions for C++
public: bool GetPaintValueSupported();
C++/CLI
public:
bool GetPaintValueSupported();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FieldTypeEditor Class
FieldTypeEditor Members
Overload List


PaintValue Method

[image]
Intersoft WebCombo Documentation
PaintValue Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > FieldTypeEditor Class : PaintValue Method

Overload List

Overload | Description
PaintValue(Object,Graphics,Rectangle) | (Inherited from System.Drawing.Design.UITypeEditor)
PaintValue(PaintValueEventArgs) | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FieldTypeEditor Class
FieldTypeEditor Members


PaintValue(Object,Graphics,Rectangle) Method

[image]
Intersoft WebCombo Documentation
PaintValue(Object,Graphics,Rectangle) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > FieldTypeEditor Class > PaintValue Method : PaintValue(Object,Graphics,Rectangle) Method

value
canvas
rectangle

Syntax

Visual Basic (Declaration)
Public Overloads Sub PaintValue( _
   ByVal value As Object, _
   ByVal canvas As Graphics, _
   ByVal rectangle As Rectangle _
)
Visual Basic (Usage) Copy Code
Dim instance As FieldTypeEditor
Dim value As Object
Dim canvas As Graphics
Dim rectangle As Rectangle

instance.PaintValue(value, canvas, rectangle)
C#
public void PaintValue(
   object value,
   Graphics canvas,
   Rectangle rectangle
)
Delphi
public procedure PaintValue(
    value: TObject;
    canvas: Graphics;
    rectangle: Rectangle
);
JScript
public function PaintValue(
   value : Object,
   canvas : Graphics,
   rectangle : Rectangle
);
Managed Extensions for C++
public: void PaintValue(
   Object* value,
   Graphics* canvas,
   Rectangle rectangle
)
C++/CLI
public:
void PaintValue(
   Object^ value,
   Graphics^ canvas,
   Rectangle rectangle
)

Parameters

value
canvas
rectangle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FieldTypeEditor Class
FieldTypeEditor Members
Overload List


PaintValue(PaintValueEventArgs) Method

[image]
Intersoft WebCombo Documentation
PaintValue(PaintValueEventArgs) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > FieldTypeEditor Class > PaintValue Method : PaintValue(PaintValueEventArgs) Method

e

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub PaintValue( _
   ByVal e As PaintValueEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As FieldTypeEditor
Dim e As PaintValueEventArgs

instance.PaintValue(e)
C#
public virtual void PaintValue(
   PaintValueEventArgs e
)
Delphi
public procedure PaintValue(
    e: PaintValueEventArgs
); virtual;
JScript
public function PaintValue(
   e : PaintValueEventArgs
);
Managed Extensions for C++
public: virtual void PaintValue(
   PaintValueEventArgs* e
)
C++/CLI
public:
virtual void PaintValue(
   PaintValueEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FieldTypeEditor Class
FieldTypeEditor Members
Overload List


IsDropDownResizable Property

[image]
Intersoft WebCombo Documentation
IsDropDownResizable Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > FieldTypeEditor Class : IsDropDownResizable Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsDropDownResizable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FieldTypeEditor
Dim value As Boolean

value = instance.IsDropDownResizable
C#
public virtual bool IsDropDownResizable {get;}
Delphi
public read-only property IsDropDownResizable: Boolean; virtual;
JScript
public function get IsDropDownResizable : boolean
Managed Extensions for C++
public: __property virtual bool get_IsDropDownResizable();
C++/CLI
public:
virtual property bool IsDropDownResizable {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FieldTypeEditor Class
FieldTypeEditor Members


LayoutEventArgs Class

[image]
Intersoft WebCombo Documentation
LayoutEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : LayoutEventArgs Class

Provides data for layout related event. Provides data for layout related event.

Object Model

LayoutEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class LayoutEventArgs
   Inherits BaseEventArgs
Visual Basic (Usage) Copy Code
Dim instance As LayoutEventArgs
C#
public class LayoutEventArgs : BaseEventArgs
Delphi
public class LayoutEventArgs = class(BaseEventArgs)
JScript
public class LayoutEventArgs extends BaseEventArgs
Managed Extensions for C++
public __gc class LayoutEventArgs : public BaseEventArgs
C++/CLI
public ref class LayoutEventArgs : public BaseEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebCombo.BaseEventArgs
ISNet.WebUI.WebCombo.LayoutEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutEventArgs Members
ISNet.WebUI.WebCombo Namespace


LayoutEventArgs Class Members

[image]
Intersoft WebCombo Documentation
LayoutEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebCombo Namespace : LayoutEventArgs Class

The following tables list the members exposed by LayoutEventArgs.

Public Properties

 | Name | Description
public Property | Layout | Gets the LayoutSet object used by the event. Gets the LayoutSet object used by the event.
public Property | ReturnValue | (Inherited from ISNet.WebUI.WebCombo.BaseEventArgs)
Top

See Also

Reference

LayoutEventArgs Class
ISNet.WebUI.WebCombo Namespace


LayoutEventArgs Class Properties

[image]
Intersoft WebCombo Documentation
LayoutEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : LayoutEventArgs Class

For a list of all members of this type, see LayoutEventArgs members.

Public Properties

 | Name | Description
public Property | Layout | Gets the LayoutSet object used by the event. Gets the LayoutSet object used by the event.
public Property | ReturnValue | (Inherited from ISNet.WebUI.WebCombo.BaseEventArgs)
Top

See Also

Reference

LayoutEventArgs Class
ISNet.WebUI.WebCombo Namespace


Layout Property

[image]
Intersoft WebCombo Documentation
Layout Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutEventArgs Class : Layout Property

Gets the LayoutSet object used by the event. Gets the LayoutSet object used by the event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Layout As LayoutSet
Visual Basic (Usage) Copy Code
Dim instance As LayoutEventArgs
Dim value As LayoutSet

value = instance.Layout
C#
public LayoutSet Layout {get;}
Delphi
public read-only property Layout: LayoutSet;
JScript
public function get Layout : LayoutSet
Managed Extensions for C++
public: __property LayoutSet* get_Layout();
C++/CLI
public:
property LayoutSet^ Layout {
   LayoutSet^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutEventArgs Class
LayoutEventArgs Members


LayoutSet Class

[image]
Intersoft WebCombo Documentation
LayoutSet Class
Members See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : LayoutSet Class

LayoutSet in WebCombo.NET 4.0 provides a centralized access to control the behavior and styles of the whole WebCombo object. This class allows users to manage the behavior and styles for almost the whole control's part.

LayoutSet provides a centralized access to configure the behaviors and styles of the WebCombo control.

Object Model

LayoutSet Class

Syntax

Visual Basic (Declaration)
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<SerializableAttribute()>
Public NotInheritable Class LayoutSet
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
C#
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[SerializableAttribute()]
public sealed class LayoutSet : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class LayoutSet = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)sealed;
JScript
PersistenceModeAttribute(PersistenceMode.InnerProperty)
SerializableAttribute()
public sealed class LayoutSet extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[SerializableAttribute()]
public __gc __sealed class LayoutSet : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[SerializableAttribute()]
public ref class LayoutSet sealed : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Remarks

WebCombo.NET 4.0 comes with new looks and smoother user interface. The LayoutSet offers new looks that are adjusted with the upcoming Windows Vista operating system. This ensures WebCombo.NET controls to have familiar and consistent user interface throughout your application.

You can customize the styles for almost the whole control's part. For greater web experiences, LayoutSet even provides onmouseover styles for main part of control. You can easily set the styles in design-time without any knowledge needed in DHTML, Scripts or CSS syntax.

In WebCombo.NET 4.0, the user interface elements have been significantly improved. The new property in LayoutSet include RoundCorner, EnableAnimation and AllowFloatingText. RoundCorner shape rendering is one of the most enhancement of user interface in WebCombo.NET v4.0. It allows you to set round corner around the edges of WebCombo. The round corner interface is adopted widely in the Windows Vista operating system and its desktop application. Therefore with round corner support in WebCombo.NET 4.0, the end users will get the latest user interface design. To give you better illustration on round corner interface, you can read Fluid round corner through TrueShape™.

WebCombo.NET 4.0 supports background image animation to help you replicate rich UI controls in Windows Vista. In this version, the background image animation is supported in dropdown element only.
Please note that the image animation requires certain design in order to create smooth effect. Not all design will look good when the animation is enabled. For example, the default style in version 4.0 is specially designed to display smoothly while animation is enabled. To enable dropdown background animation on WebCombo, you only need to set EnableAnimation to True.

Unlike in the previous version, the inline text in the left and right side of WebCombo.NET v4.0 is pushed to either top or bottom of the WebCombo element. By default, inline text can no longer be at the same row with WebCombo due to this changes. Therefore, if you want to put text on the left and right side of WebCombo you need to set True on the AllowFloatingText property.

Related to the User Interface changes, the styles of the WebCombo require significant updates as well. If you planned to upgrade your existing web application to use WebCombo.NET 4.0, you should carefully review the breaking changes in the styles aspect. You will need to reapply and update the predefined styles in order to appear properly in version 4.0 if you are using WinXP Blue, WinXP Silver, Mac OS X Tiger, or Minimalist.

For more information, you can read How-to: Reapply the styles to use updated predefined style in designer.

You can customize the styles for almost the whole control's user interface elements. For greater web experiences, this class provides many interactive styles for most elements of the control. With strongly-typed WebStyle object, you can easily configure the styles in design-time without expertise in DHTML, client scripting or CSS.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebCombo.LayoutSet

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Members
ISNet.WebUI.WebCombo Namespace

Tasks

How-to: Apply Predefined Layout
How-to: Save Current Layout
How-to: Apply Saved Layout
How-to: Preview Layout
How-to: Reapply the styles to use updated predefined style in designer
How-to: Set combo's alignment to be right displayed
How-to: Show/Hide WebCombo
How-to: Enable/Disable WebCombo
How-to: Determine the number of rows first requested by WebCombo
How-to: Display tooltip in WebCombo

Concepts

Improved Layout
Layout Manager
User Interface Elements
Fluid round corner through TrueShape™
New User Interface
Vista-style image animation
WebCombo Look and Feel
Layout comparison between previous version and version 4.0

Other Resources

Cleaner and reduced page output through built-in Default Style


LayoutSet Class Members

[image]
Intersoft WebCombo Documentation
LayoutSet Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebCombo Namespace : LayoutSet Class

The following tables list the members exposed by LayoutSet.

Public Constructors

 | Name | Description
public Constructor | LayoutSet Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | AdjustResultBoxLeft | Specifies the left position adjustment for ResultBox object. Specifies the left position adjustment for ResultBox object.
public Property | AdjustResultBoxTop | Specifies the top position adjustment for ResultBox object. Specifies the top position adjustment for ResultBox object.
public Property | AllowAddItem | Specifies whether item addition is allowed when input text doesn't match any list items. Specifies whether item addition is allowed when input text doesn't match any list items.
public Property | AllowDefaultStyleMerging |
public Property | AllowFloatingText | Specifies whether users can set some text to float in the right side of WebCombo control.Gets or sets a value whether text is allowed to float in the right side of WebCombo.
public Property | AllowNavigationOnMouseWheel | Specifies whether navigation of records is allowed when moving the mouse wheel. Specifies whether navigation of records is allowed when moving the mouse wheel.
public Property | AllowTextWrapping | Returns or sets whether overflow text will be wrapped to next line. If set to false, the overflow text will be truncated with ellipsis. Returns or sets whether overflow text will be wrapped to next line. If set to false, the overflow text will be truncated with ellipsis.
public Property | AlwaysShowAllRowsOnDropdown | Determines whether or not to display all rows when dropdown arrow is clicked. Determines whether or not to display all rows when dropdown arrow is clicked.
public Property | AlwaysShowColumnHeaders | Specifies whether the column headers are displayed when ComboMode is set to MultipleColumns. Specifies whether the column headers is displayed when LayoutSet.ComboMode is set to MultipleColumns.
public Property | AlwaysShowHelpButton | Specifies whether the help button is displayed. Specifies whether the help button is displayed.
public Property | AlwaysShowResultBox | Specifies whether result box is still displayed after item selection made by mouse click. Specifies whether result box is still displayed after item selection made by mouse click.
public Property | AlwaysShowSearchButton | Specifies whether the dropdown arrow button is displayed. Specifies whether the dropdown arrow button is displayed.
public Property | AutoColumnOrdering |
public Property | BoundMode | Gets or sets the bound mode of WebCombo. Gets or sets the bound mode of WebCombo.
public Property | ClientSideEvents | Represents ClientEvents object that hold list of client eventsReturns ClientEvents object.
public Property | ColumnSeparatorColor | Gets or sets the separator color between columns Gets or sets the separator color between columns.
public Property | ColumnStyle | The styles applied to column. The styles applied to column.
public Property | ColumnWidthDefault | Specifies the column width default. Only affected to MultipleColumns mode. Specifies the column width default. Only affected to MultipleColumns mode.
public Property | ComboMode | Specifies the mode of the WebCombo control. Specifies the mode of the WebCombo control.
public Property | DropDownStyle | The interactive style applied to WebCombo's DropDown. The interactive style applied to WebCombo's DropDown.
public Property | EnableAnimation | Enable background image animation in dropdown element. Gets or sets a value indicating whether background animation is enabled when mouse is over the dropdown button.
public Property | EnableSlidingAnimation | Specifies whether the ResultBox should be animated when user clicked on the drop down element of the WebCombo.
public Property | EntryMode | Gets or sets the entry behavior of WebCombo. Gets or sets the entry behavior of WebCombo.
public Property | FrameStyle | The interactive styles of the WebCombo's Frame. The interactive styles of the WebCombo's Frame.
public Property | HeaderStyle | The styles applied to columns header. The styles applied to columns header.
public Property | HelpImage | Specifies the image for Help. Specifies the image for Help.
public Property | HelpURL | Specifies the client's help URL when user click on the Help icon. The default is Intersoft's own help page URL. This property is application-wide configurable. Specifies the client's help URL when user clicked on the Help icon. This property is application-wide configurable.
public Property | ImagesDirectory | Specifies the directory used to store WebCombo images files. Specifies the directory used to store WebCombo images files.
public Property | ItemHeight | Specifies the default item row height. Specifies the default item row height.
public Property | LoadMoreKeyGesture |
public Property | MoreButtonStyle | The interactive style applied to WebCombo's more button. The interactive style applied to WebCombo's more button.
public Property | NoResultFoundAction | Gets or sets the action which WebCombo should perform when there are no results found and the WebCombo has lost its focus. Gets or sets the action which WebCombo should perform when there are no results found and the WebCombo has lost its focus.
public Property | ResultBoxHeight | Returns or sets the height of the result box. Returns or sets the height of the result box.
public Property | ResultBoxShadow | Specifies whether shadow should be applied to resultbox. This property is only applicable to IE browser and ResultBoxWindowType should be set to Normal. Specifies whether shadow should be applied to resultbox. This property is only applicable to IE browser and ResultBoxWindowType should be set to Normal.
public Property | ResultBoxStyle | The sytle applied to result box (only the box that contain data) The sytle applied to result box (only the box that contain data)
public Property | ResultBoxWidth | Returns or sets the width of the result box. Set this property to 0 for automatic width calculation. Returns or sets the width of the result box. Set this property to 0 for automatic width calculation.
public Property | ResultBoxWindowType | Specifies the resultbox's window type. This property is only applicable to IE browser. Specifies the resultbox's window type. This property is only applicable to IE browser.
public Property | ResultFrameStyle | The styles applied to result frame (the outer result box). The styles applied to result frame (the outer result box).
public Property | RoundCorner | Specifies whether the combo render the control's user interface in round corner effect. Whether to render the control's user interface in round corner effect.
public Property | RowStyle | The interactive style applied to row. The interactive style applied to row.
public Property | ScriptDirectory | This property is available for backward compabitility with V2.x only. This property is linked to WebCombo.ScriptDirectory directly. This property is available for backward compabitility with V2.x only. This property is linked to WebCombo.ScriptDirectory directly.
public Property | SearchButtonPosition | Gets or sets the search button (dropdown button) position of the WebCombo. Gets or sets the search button (dropdown button) position of the WebCombo.
public Property | SearchIconMode | Specifies the mode of search icon. Specifies the mode of search icon.
public Property | SearchImage | Specifies the image for search icon. Specifies the image for search icon.
public Property | SelectedRowStyle | The styles applied to selected row. The styles applied to selected row.
public Property | StatusBoxPosition | Specifies the status box position. Specifies the status box position.
public Property | StatusBoxStyle | The style applied to the status box. The styles applied to status box.
public Property | StatusBoxVisible | Specifies whether the status box is visible or not. Specifies whether the status box is visible.
public Property | TextBoxMode | Returns or sets the textbox mode of the control. Returns or sets the textbox mode of the control.
public Property | TextBoxStyle | The interactive style applied to WebCombo's TextBox. The interactive style applied to WebCombo's TextBox.
public Property | TextSettings | Represents a TextSet object which contains text used in WebCombo control. Represents a TextSet object which contains text used in WebCombo control.
public Property | XhtmlSearchImage | Specifies the image file name used to render the search button's arrow. This property is designed to be used in XHTML document and applies to Mozilla browsers. Specifies the image file name used to render the search button's arrow. This property is designed to be used in XHTML document and applies to Mozilla browsers.
Top

Public Methods

 | Name | Description
public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | GetObjectData | Overridden.
public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | ToString |
Top

See Also

Reference

LayoutSet Class
ISNet.WebUI.WebCombo Namespace


LayoutSet Constructor

[image]
Intersoft WebCombo Documentation
LayoutSet Constructor
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : LayoutSet Constructor

Initializes a new instance of the LayoutSet class.

Overload List

Overload | Description
LayoutSet Constructor(SerializationInfo,StreamingContext) | Initializes a new instance of the LayoutSet class with SeriliazationInfo and StreamingContext.
LayoutSet Constructor() | Initializes a new instance of the LayoutSet class with no argument.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members


LayoutSet Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebCombo Documentation
LayoutSet Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class > LayoutSet Constructor : LayoutSet Constructor(SerializationInfo,StreamingContext)

info
context
Initializes a new instance of the LayoutSet class with SeriliazationInfo and StreamingContext.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As New LayoutSet(info, context)
C#
public LayoutSet(
   SerializationInfo info,
   StreamingContext context
)
Delphi
public LayoutSet(
    info: SerializationInfo;
    context: StreamingContext
);
JScript
public function LayoutSet(
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: LayoutSet(
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
public:
LayoutSet(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members
Overload List


LayoutSet Constructor()

[image]
Intersoft WebCombo Documentation
LayoutSet Constructor()
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class > LayoutSet Constructor : LayoutSet Constructor()

Initializes a new instance of the LayoutSet class with no argument.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New LayoutSet()
C#
public LayoutSet()
Delphi
public LayoutSet();
JScript
public function LayoutSet();
Managed Extensions for C++
public: LayoutSet();
C++/CLI
public:
LayoutSet();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members
Overload List


Clone Method

[image]
Intersoft WebCombo Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : Clone Method

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Object

value = instance.Clone()
C#
public object Clone()
Delphi
public function Clone(): TObject;
JScript
public function Clone() : Object;
Managed Extensions for C++
public: Object* Clone();
C++/CLI
public:
Object^ Clone();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members


CopyFrom Method

[image]
Intersoft WebCombo Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : CopyFrom Method

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members


CopyFrom(Object) Method

[image]
Intersoft WebCombo Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public void CopyFrom(
   object objSource
)
Delphi
public procedure CopyFrom(
    objSource: TObject
);
JScript
public function CopyFrom(
   objSource : Object
);
Managed Extensions for C++
public: void CopyFrom(
   Object* objSource
)
C++/CLI
public:
void CopyFrom(
   Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebCombo Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public void CopyFrom(
   object objSource,
   bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: TObject;
    cloneSourceValue: Boolean
);
JScript
public function CopyFrom(
   objSource : Object,
   cloneSourceValue : boolean
);
Managed Extensions for C++
public: void CopyFrom(
   Object* objSource,
   bool cloneSourceValue
)
C++/CLI
public:
void CopyFrom(
   Object^ objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebCombo Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : DeSerializeObjectData Method

type
info
context

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim type As Type
Dim info As SerializationInfo
Dim context As StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: Type;
    info: SerializationInfo;
    context: StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : Type,
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   Type* type,
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   Type^ type,
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members


LayoutSet Class Methods

[image]
Intersoft WebCombo Documentation
LayoutSet Class Methods
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : LayoutSet Class

For a list of all members of this type, see LayoutSet members.

Public Methods

 | Name | Description
public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | GetObjectData | Overridden.
public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | ToString |
Top

See Also

Reference

LayoutSet Class
ISNet.WebUI.WebCombo Namespace


GetObjectData Method

[image]
Intersoft WebCombo Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : GetObjectData Method

info
context

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: SerializationInfo;
    context: StreamingContext
); override;
JScript
public override function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members


IsEmpty Method

[image]
Intersoft WebCombo Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : IsEmpty Method

Syntax

Visual Basic (Declaration)
Public Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Boolean

value = instance.IsEmpty()
C#
public bool IsEmpty()
Delphi
public function IsEmpty(): Boolean;
JScript
public function IsEmpty() : boolean;
Managed Extensions for C++
public: bool IsEmpty();
C++/CLI
public:
bool IsEmpty();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members


Reset Method

[image]
Intersoft WebCombo Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : Reset Method

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet

instance.Reset()
C#
public void Reset()
Delphi
public procedure Reset();
JScript
public function Reset();
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members


SerializeObjectData Method

[image]
Intersoft WebCombo Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : SerializeObjectData Method

type
info
context

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim type As Type
Dim info As SerializationInfo
Dim context As StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: Type;
    info: SerializationInfo;
    context: StreamingContext
);
JScript
public function SerializeObjectData(
   type : Type,
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   Type* type,
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   Type^ type,
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members


ToString Method

[image]
Intersoft WebCombo Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : ToString Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Delphi
public function ToString(): String; override;
JScript
public override function ToString() : String;
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members


LayoutSet Class Properties

[image]
Intersoft WebCombo Documentation
LayoutSet Class Properties
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : LayoutSet Class

For a list of all members of this type, see LayoutSet members.

Public Properties

 | Name | Description
public Property | AdjustResultBoxLeft | Specifies the left position adjustment for ResultBox object. Specifies the left position adjustment for ResultBox object.
public Property | AdjustResultBoxTop | Specifies the top position adjustment for ResultBox object. Specifies the top position adjustment for ResultBox object.
public Property | AllowAddItem | Specifies whether item addition is allowed when input text doesn't match any list items. Specifies whether item addition is allowed when input text doesn't match any list items.
public Property | AllowDefaultStyleMerging |
public Property | AllowFloatingText | Specifies whether users can set some text to float in the right side of WebCombo control.Gets or sets a value whether text is allowed to float in the right side of WebCombo.
public Property | AllowNavigationOnMouseWheel | Specifies whether navigation of records is allowed when moving the mouse wheel. Specifies whether navigation of records is allowed when moving the mouse wheel.
public Property | AllowTextWrapping | Returns or sets whether overflow text will be wrapped to next line. If set to false, the overflow text will be truncated with ellipsis. Returns or sets whether overflow text will be wrapped to next line. If set to false, the overflow text will be truncated with ellipsis.
public Property | AlwaysShowAllRowsOnDropdown | Determines whether or not to display all rows when dropdown arrow is clicked. Determines whether or not to display all rows when dropdown arrow is clicked.
public Property | AlwaysShowColumnHeaders | Specifies whether the column headers are displayed when ComboMode is set to MultipleColumns. Specifies whether the column headers is displayed when LayoutSet.ComboMode is set to MultipleColumns.
public Property | AlwaysShowHelpButton | Specifies whether the help button is displayed. Specifies whether the help button is displayed.
public Property | AlwaysShowResultBox | Specifies whether result box is still displayed after item selection made by mouse click. Specifies whether result box is still displayed after item selection made by mouse click.
public Property | AlwaysShowSearchButton | Specifies whether the dropdown arrow button is displayed. Specifies whether the dropdown arrow button is displayed.
public Property | AutoColumnOrdering |
public Property | BoundMode | Gets or sets the bound mode of WebCombo. Gets or sets the bound mode of WebCombo.
public Property | ClientSideEvents | Represents ClientEvents object that hold list of client eventsReturns ClientEvents object.
public Property | ColumnSeparatorColor | Gets or sets the separator color between columns Gets or sets the separator color between columns.
public Property | ColumnStyle | The styles applied to column. The styles applied to column.
public Property | ColumnWidthDefault | Specifies the column width default. Only affected to MultipleColumns mode. Specifies the column width default. Only affected to MultipleColumns mode.
public Property | ComboMode | Specifies the mode of the WebCombo control. Specifies the mode of the WebCombo control.
public Property | DropDownStyle | The interactive style applied to WebCombo's DropDown. The interactive style applied to WebCombo's DropDown.
public Property | EnableAnimation | Enable background image animation in dropdown element. Gets or sets a value indicating whether background animation is enabled when mouse is over the dropdown button.
public Property | EnableSlidingAnimation | Specifies whether the ResultBox should be animated when user clicked on the drop down element of the WebCombo.
public Property | EntryMode | Gets or sets the entry behavior of WebCombo. Gets or sets the entry behavior of WebCombo.
public Property | FrameStyle | The interactive styles of the WebCombo's Frame. The interactive styles of the WebCombo's Frame.
public Property | HeaderStyle | The styles applied to columns header. The styles applied to columns header.
public Property | HelpImage | Specifies the image for Help. Specifies the image for Help.
public Property | HelpURL | Specifies the client's help URL when user click on the Help icon. The default is Intersoft's own help page URL. This property is application-wide configurable. Specifies the client's help URL when user clicked on the Help icon. This property is application-wide configurable.
public Property | ImagesDirectory | Specifies the directory used to store WebCombo images files. Specifies the directory used to store WebCombo images files.
public Property | ItemHeight | Specifies the default item row height. Specifies the default item row height.
public Property | LoadMoreKeyGesture |
public Property | MoreButtonStyle | The interactive style applied to WebCombo's more button. The interactive style applied to WebCombo's more button.
public Property | NoResultFoundAction | Gets or sets the action which WebCombo should perform when there are no results found and the WebCombo has lost its focus. Gets or sets the action which WebCombo should perform when there are no results found and the WebCombo has lost its focus.
public Property | ResultBoxHeight | Returns or sets the height of the result box. Returns or sets the height of the result box.
public Property | ResultBoxShadow | Specifies whether shadow should be applied to resultbox. This property is only applicable to IE browser and ResultBoxWindowType should be set to Normal. Specifies whether shadow should be applied to resultbox. This property is only applicable to IE browser and ResultBoxWindowType should be set to Normal.
public Property | ResultBoxStyle | The sytle applied to result box (only the box that contain data) The sytle applied to result box (only the box that contain data)
public Property | ResultBoxWidth | Returns or sets the width of the result box. Set this property to 0 for automatic width calculation. Returns or sets the width of the result box. Set this property to 0 for automatic width calculation.
public Property | ResultBoxWindowType | Specifies the resultbox's window type. This property is only applicable to IE browser. Specifies the resultbox's window type. This property is only applicable to IE browser.
public Property | ResultFrameStyle | The styles applied to result frame (the outer result box). The styles applied to result frame (the outer result box).
public Property | RoundCorner | Specifies whether the combo render the control's user interface in round corner effect. Whether to render the control's user interface in round corner effect.
public Property | RowStyle | The interactive style applied to row. The interactive style applied to row.
public Property | ScriptDirectory | This property is available for backward compabitility with V2.x only. This property is linked to WebCombo.ScriptDirectory directly. This property is available for backward compabitility with V2.x only. This property is linked to WebCombo.ScriptDirectory directly.
public Property | SearchButtonPosition | Gets or sets the search button (dropdown button) position of the WebCombo. Gets or sets the search button (dropdown button) position of the WebCombo.
public Property | SearchIconMode | Specifies the mode of search icon. Specifies the mode of search icon.
public Property | SearchImage | Specifies the image for search icon. Specifies the image for search icon.
public Property | SelectedRowStyle | The styles applied to selected row. The styles applied to selected row.
public Property | StatusBoxPosition | Specifies the status box position. Specifies the status box position.
public Property | StatusBoxStyle | The style applied to the status box. The styles applied to status box.
public Property | StatusBoxVisible | Specifies whether the status box is visible or not. Specifies whether the status box is visible.
public Property | TextBoxMode | Returns or sets the textbox mode of the control. Returns or sets the textbox mode of the control.
public Property | TextBoxStyle | The interactive style applied to WebCombo's TextBox. The interactive style applied to WebCombo's TextBox.
public Property | TextSettings | Represents a TextSet object which contains text used in WebCombo control. Represents a TextSet object which contains text used in WebCombo control.
public Property | XhtmlSearchImage | Specifies the image file name used to render the search button's arrow. This property is designed to be used in XHTML document and applies to Mozilla browsers. Specifies the image file name used to render the search button's arrow. This property is designed to be used in XHTML document and applies to Mozilla browsers.
Top

See Also

Reference

LayoutSet Class
ISNet.WebUI.WebCombo Namespace


AdjustResultBoxLeft Property

[image]
Intersoft WebCombo Documentation
AdjustResultBoxLeft Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : AdjustResultBoxLeft Property

Specifies the left position adjustment for ResultBox object. Specifies the left position adjustment for ResultBox object.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Specifies the left position adjustment for ResultBox object.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
Public Property AdjustResultBoxLeft As Integer
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Integer

instance.AdjustResultBoxLeft = value

value = instance.AdjustResultBoxLeft
C#
[DescriptionAttribute("Specifies the left position adjustment for ResultBox object.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public int AdjustResultBoxLeft {get; set;}
Delphi
public read-write property AdjustResultBoxLeft: Integer;
JScript
DescriptionAttribute("Specifies the left position adjustment for ResultBox object.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
NotifyParentPropertyAttribute()
DefaultValueAttribute()
public function get,set AdjustResultBoxLeft : int
Managed Extensions for C++
[DescriptionAttribute("Specifies the left position adjustment for ResultBox object.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public: __property int get_AdjustResultBoxLeft();
public: __property void set_AdjustResultBoxLeft(
   int value
);
C++/CLI
[DescriptionAttribute("Specifies the left position adjustment for ResultBox object.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public:
property int AdjustResultBoxLeft {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Adjust result box position

Concepts

All-new, sleeker User Interface
User Interface Elements


AdjustResultBoxTop Property

[image]
Intersoft WebCombo Documentation
AdjustResultBoxTop Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : AdjustResultBoxTop Property

Specifies the top position adjustment for ResultBox object. Specifies the top position adjustment for ResultBox object.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Specifies the top position adjustment for ResultBox object.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
Public Property AdjustResultBoxTop As Integer
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Integer

instance.AdjustResultBoxTop = value

value = instance.AdjustResultBoxTop
C#
[DescriptionAttribute("Specifies the top position adjustment for ResultBox object.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public int AdjustResultBoxTop {get; set;}
Delphi
public read-write property AdjustResultBoxTop: Integer;
JScript
DescriptionAttribute("Specifies the top position adjustment for ResultBox object.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
DefaultValueAttribute()
public function get,set AdjustResultBoxTop : int
Managed Extensions for C++
[DescriptionAttribute("Specifies the top position adjustment for ResultBox object.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public: __property int get_AdjustResultBoxTop();
public: __property void set_AdjustResultBoxTop(
   int value
);
C++/CLI
[DescriptionAttribute("Specifies the top position adjustment for ResultBox object.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public:
property int AdjustResultBoxTop {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Adjust result box position

Concepts

All-new, sleeker User Interface
User Interface Elements


AllowAddItem Property

[image]
Intersoft WebCombo Documentation
AllowAddItem Property
See Also Example Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : AllowAddItem Property

Specifies whether item addition is allowed when input text doesn't match any list items.

Specifies whether item addition is allowed when input text doesn't match any list items.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Specifies whether item addition is allowed when input text doesn't match any list items.")>
Public Property AllowAddItem As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Boolean

instance.AllowAddItem = value

value = instance.AllowAddItem
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies whether item addition is allowed when input text doesn't match any list items.")]
public bool AllowAddItem {get; set;}
Delphi
public read-write property AllowAddItem: Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
NotifyParentPropertyAttribute()
DescriptionAttribute("Specifies whether item addition is allowed when input text doesn't match any list items.")
public function get,set AllowAddItem : boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies whether item addition is allowed when input text doesn't match any list items.")]
public: __property bool get_AllowAddItem();
public: __property void set_AllowAddItem(
   bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies whether item addition is allowed when input text doesn't match any list items.")]
public:
property bool AllowAddItem {
   bool get();
   void set (    bool value);
}

Example

The following example shows you how to use AllowAddItem feature using code- behind.
C# Copy Code
private void WebCombo1_InitializeLayout(object sender, ISNet.WebUI.WebCombo.LayoutEventArgs e)
{
   e.Layout.AllowAddItem = true;
}

Remarks

When set to True, input text that doesn't match the text in the list will automatically be added in the list.

You can write client scripts to validate and response this event by assigning your function name in OnAddItem. To cancel the default item addition process, return the function's value as false (return false).

In DataBound mode, the AddItem server side event will be invoked after the clientside OnAddItem's event is evaluated and the return value is true. The server side AddItem event provides a way for developer to handle and process the added item to the DataSource.

When set to True, input text that doesn't match the text in the list will automatically be added in the list.

You can write client scripts to validate and response this event by assigning your function name in ClientSideEvents.OnAddItem. To cancel the default item addition process, return the function's value as false (return false).

In DataBound mode, the AddItem server side event will be invoked after the clientside OnAddItem's event is evaluated and the return value is true. The server side AddItem event provides a way for developer to handle and process the added item to the DataSource.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members
How-to: Add item in unbound WebCombo from server side
How-to: AlowAddItem in WebCombo
How-to: Add item in bound WebCombo

Concepts

Dynamically Add Item


AllowDefaultStyleMerging Property

[image]
Intersoft WebCombo Documentation
AllowDefaultStyleMerging Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : AllowDefaultStyleMerging Property

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<DescriptionAttribute("Specifies whether the default styles should be merged with user defined styles.")>
<NotifyParentPropertyAttribute(True)>
Public Property AllowDefaultStyleMerging As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Boolean

instance.AllowDefaultStyleMerging = value

value = instance.AllowDefaultStyleMerging
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Specifies whether the default styles should be merged with user defined styles.")]
[NotifyParentPropertyAttribute(true)]
public bool AllowDefaultStyleMerging {get; set;}
Delphi
public read-write property AllowDefaultStyleMerging: Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
DescriptionAttribute("Specifies whether the default styles should be merged with user defined styles.")
NotifyParentPropertyAttribute()
public function get,set AllowDefaultStyleMerging : boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Specifies whether the default styles should be merged with user defined styles.")]
[NotifyParentPropertyAttribute(true)]
public: __property bool get_AllowDefaultStyleMerging();
public: __property void set_AllowDefaultStyleMerging(
   bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Specifies whether the default styles should be merged with user defined styles.")]
[NotifyParentPropertyAttribute(true)]
public:
property bool AllowDefaultStyleMerging {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members


AllowFloatingText Property

[image]
Intersoft WebCombo Documentation
AllowFloatingText Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : AllowFloatingText Property

Specifies whether users can set some text to float in the right side of WebCombo control.Gets or sets a value whether text is allowed to float in the right side of WebCombo.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Gets or sets a value whether text is allowed to float in the right side of WebCombo.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
Public Property AllowFloatingText As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Boolean

instance.AllowFloatingText = value

value = instance.AllowFloatingText
C#
[DescriptionAttribute("Gets or sets a value whether text is allowed to float in the right side of WebCombo.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public bool AllowFloatingText {get; set;}
Delphi
public read-write property AllowFloatingText: Boolean;
JScript
DescriptionAttribute("Gets or sets a value whether text is allowed to float in the right side of WebCombo.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
DefaultValueAttribute()
public function get,set AllowFloatingText : boolean
Managed Extensions for C++
[DescriptionAttribute("Gets or sets a value whether text is allowed to float in the right side of WebCombo.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public: __property bool get_AllowFloatingText();
public: __property void set_AllowFloatingText(
   bool value
);
C++/CLI
[DescriptionAttribute("Gets or sets a value whether text is allowed to float in the right side of WebCombo.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public:
property bool AllowFloatingText {
   bool get();
   void set (    bool value);
}

Remarks

Unlike in WebCombo.NET v3.0, the inline text in the left and right side of WebCombo.NET v4.0 is pushed to either top or bottom of the WebCombo element. By default, inline text can no longer be at the same row with WebCombo due to this changes. To give you better illustration on how to set the text on the right side of WebCombo, you can read How-to: Enable text floating to the right side of the WebCombo.NET control.

To enable text floating on the left side of WebCombo (the behavior of WebCombo.NET 3.0), you can follow the steps in How-to: Simulate inline text floating behavior as in previous version.

Although the above techniques works properly in common scenarios, it is not the recommended way to create pixel-perfect layout. We recommend you to create side-by-side elements in a single row is by using TABLE layout.

TABLE layout enables you to create layout that will look and behave consistently in either old or modern browsers. If your web page has been using TABLE layout since previous version of WebCombo.NET, you don’t need to perform any extra efforts to adapt to the changes in User Interface. As an example, all of our samples provided in the previous version of WebCombo were using TABLE layout. When they are migrated to version 4.0, they can be displayed properly without changes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Allow text to float on the right side of WebCombo
How-to: Enable text floating to the right side of the WebCombo.NET control
How-to: Simulate inline text floating behavior as in previous version

Concepts

All-new, sleeker User Interface
User Interface Elements

Other Resources

Layout comparison between previous version and version 4.0


AllowNavigationOnMouseWheel Property

[image]
Intersoft WebCombo Documentation
AllowNavigationOnMouseWheel Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : AllowNavigationOnMouseWheel Property

Specifies whether navigation of records is allowed when moving the mouse wheel. Specifies whether navigation of records is allowed when moving the mouse wheel.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<DescriptionAttribute("Specifies whether navigation of records is allowed when moving the mouse wheel.")>
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property AllowNavigationOnMouseWheel As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Boolean

instance.AllowNavigationOnMouseWheel = value

value = instance.AllowNavigationOnMouseWheel
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Specifies whether navigation of records is allowed when moving the mouse wheel.")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public bool AllowNavigationOnMouseWheel {get; set;}
Delphi
public read-write property AllowNavigationOnMouseWheel: Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
DescriptionAttribute("Specifies whether navigation of records is allowed when moving the mouse wheel.")
DefaultValueAttribute()
NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set AllowNavigationOnMouseWheel : boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Specifies whether navigation of records is allowed when moving the mouse wheel.")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property bool get_AllowNavigationOnMouseWheel();
public: __property void set_AllowNavigationOnMouseWheel(
   bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Specifies whether navigation of records is allowed when moving the mouse wheel.")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property bool AllowNavigationOnMouseWheel {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Allow navigation on mouse wheel

Concepts

All-new, sleeker User Interface
User Interface Elements


AllowTextWrapping Property

[image]
Intersoft WebCombo Documentation
AllowTextWrapping Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : AllowTextWrapping Property

Returns or sets whether overflow text will be wrapped to next line. If set to false, the overflow text will be truncated with ellipsis.

Returns or sets whether overflow text will be wrapped to next line. If set to false, the overflow text will be truncated with ellipsis.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
<DescriptionAttribute("Returns or sets whether overflow text will be wrapped to next line. If set to false, the overflow text will be truncated with ellipsis.")>
Public Property AllowTextWrapping As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Boolean

instance.AllowTextWrapping = value

value = instance.AllowTextWrapping
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Returns or sets whether overflow text will be wrapped to next line. If set to false, the overflow text will be truncated with ellipsis.")]
public bool AllowTextWrapping {get; set;}
Delphi
public read-write property AllowTextWrapping: Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
DefaultValueAttribute()
DescriptionAttribute("Returns or sets whether overflow text will be wrapped to next line. If set to false, the overflow text will be truncated with ellipsis.")
public function get,set AllowTextWrapping : boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Returns or sets whether overflow text will be wrapped to next line. If set to false, the overflow text will be truncated with ellipsis.")]
public: __property bool get_AllowTextWrapping();
public: __property void set_AllowTextWrapping(
   bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Returns or sets whether overflow text will be wrapped to next line. If set to false, the overflow text will be truncated with ellipsis.")]
public:
property bool AllowTextWrapping {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Allow text wrapping to the next line

Concepts

All-new, sleeker User Interface
User Interface Elements


AlwaysShowAllRowsOnDropdown Property

[image]
Intersoft WebCombo Documentation
AlwaysShowAllRowsOnDropdown Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : AlwaysShowAllRowsOnDropdown Property

Determines whether or not to display all rows when dropdown arrow is clicked. Determines whether or not to display all rows when dropdown arrow is clicked.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
<DescriptionAttribute("Determines whether or not to display all rows when dropdown arrow is clicked.")>
Public Property AlwaysShowAllRowsOnDropdown As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Boolean

instance.AlwaysShowAllRowsOnDropdown = value

value = instance.AlwaysShowAllRowsOnDropdown
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Determines whether or not to display all rows when dropdown arrow is clicked.")]
public bool AlwaysShowAllRowsOnDropdown {get; set;}
Delphi
public read-write property AlwaysShowAllRowsOnDropdown: Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
DefaultValueAttribute()
DescriptionAttribute("Determines whether or not to display all rows when dropdown arrow is clicked.")
public function get,set AlwaysShowAllRowsOnDropdown : boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Determines whether or not to display all rows when dropdown arrow is clicked.")]
public: __property bool get_AlwaysShowAllRowsOnDropdown();
public: __property void set_AlwaysShowAllRowsOnDropdown(
   bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Determines whether or not to display all rows when dropdown arrow is clicked.")]
public:
property bool AlwaysShowAllRowsOnDropdown {
   bool get();
   void set (    bool value);
}

Remarks

This behavior allows filtering to be turned off easily when there is selected value and dropdown arrow is clicked. Note that AdditionalFilter will still take affect and DropDownRows property will be accounted.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Always show all rows on dropdown combo

Concepts

All-new, sleeker User Interface
User Interface Elements


AlwaysShowColumnHeaders Property

[image]
Intersoft WebCombo Documentation
AlwaysShowColumnHeaders Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : AlwaysShowColumnHeaders Property

Specifies whether the column headers are displayed when ComboMode is set to MultipleColumns.

Specifies whether the column headers is displayed when LayoutSet.ComboMode is set to MultipleColumns.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Specifies whether the column headers is displayed when ComboMode is set to MultipleColumns.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
Public Property AlwaysShowColumnHeaders As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Boolean

instance.AlwaysShowColumnHeaders = value

value = instance.AlwaysShowColumnHeaders
C#
[DescriptionAttribute("Specifies whether the column headers is displayed when ComboMode is set to MultipleColumns.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public bool AlwaysShowColumnHeaders {get; set;}
Delphi
public read-write property AlwaysShowColumnHeaders: Boolean;
JScript
DescriptionAttribute("Specifies whether the column headers is displayed when ComboMode is set to MultipleColumns.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
DefaultValueAttribute()
public function get,set AlwaysShowColumnHeaders : boolean
Managed Extensions for C++
[DescriptionAttribute("Specifies whether the column headers is displayed when ComboMode is set to MultipleColumns.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public: __property bool get_AlwaysShowColumnHeaders();
public: __property void set_AlwaysShowColumnHeaders(
   bool value
);
C++/CLI
[DescriptionAttribute("Specifies whether the column headers is displayed when ComboMode is set to MultipleColumns.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public:
property bool AlwaysShowColumnHeaders {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Always show column headers

Concepts

All-new, sleeker User Interface
User Interface Elements


AlwaysShowHelpButton Property

[image]
Intersoft WebCombo Documentation
AlwaysShowHelpButton Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : AlwaysShowHelpButton Property

Specifies whether the help button is displayed. Specifies whether the help button is displayed.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies whether the help button is displayed.")>
Public Property AlwaysShowHelpButton As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Boolean

instance.AlwaysShowHelpButton = value

value = instance.AlwaysShowHelpButton
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies whether the help button is displayed.")]
public bool AlwaysShowHelpButton {get; set;}
Delphi
public read-write property AlwaysShowHelpButton: Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
DescriptionAttribute("Specifies whether the help button is displayed.")
public function get,set AlwaysShowHelpButton : boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies whether the help button is displayed.")]
public: __property bool get_AlwaysShowHelpButton();
public: __property void set_AlwaysShowHelpButton(
   bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies whether the help button is displayed.")]
public:
property bool AlwaysShowHelpButton {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Always show help button

Concepts

All-new, sleeker User Interface
User Interface Elements


AlwaysShowResultBox Property

[image]
Intersoft WebCombo Documentation
AlwaysShowResultBox Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : AlwaysShowResultBox Property

Specifies whether result box is still displayed after item selection made by mouse click.

Specifies whether result box is still displayed after item selection made by mouse click.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute(" Specifies whether result box is still displayed after item selection made by mouse click.")>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
Public Property AlwaysShowResultBox As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Boolean

instance.AlwaysShowResultBox = value

value = instance.AlwaysShowResultBox
C#
[DescriptionAttribute(" Specifies whether result box is still displayed after item selection made by mouse click.")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
public bool AlwaysShowResultBox {get; set;}
Delphi
public read-write property AlwaysShowResultBox: Boolean;
JScript
DescriptionAttribute(" Specifies whether result box is still displayed after item selection made by mouse click.")
NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
public function get,set AlwaysShowResultBox : boolean
Managed Extensions for C++
[DescriptionAttribute(" Specifies whether result box is still displayed after item selection made by mouse click.")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
public: __property bool get_AlwaysShowResultBox();
public: __property void set_AlwaysShowResultBox(
   bool value
);
C++/CLI
[DescriptionAttribute(" Specifies whether result box is still displayed after item selection made by mouse click.")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
public:
property bool AlwaysShowResultBox {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Always show result box

Concepts

All-new, sleeker User Interface
User Interface Elements


AlwaysShowSearchButton Property

[image]
Intersoft WebCombo Documentation
AlwaysShowSearchButton Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : AlwaysShowSearchButton Property

Specifies whether the dropdown arrow button is displayed. Specifies whether the dropdown arrow button is displayed.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Specifies whether the dropdown arrow button is displayed.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
Public Property AlwaysShowSearchButton As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Boolean

instance.AlwaysShowSearchButton = value

value = instance.AlwaysShowSearchButton
C#
[DescriptionAttribute("Specifies whether the dropdown arrow button is displayed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public bool AlwaysShowSearchButton {get; set;}
Delphi
public read-write property AlwaysShowSearchButton: Boolean;
JScript
DescriptionAttribute("Specifies whether the dropdown arrow button is displayed.")
ISNet.Serialization.XmlSerializableAttribute()
DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
public function get,set AlwaysShowSearchButton : boolean
Managed Extensions for C++
[DescriptionAttribute("Specifies whether the dropdown arrow button is displayed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public: __property bool get_AlwaysShowSearchButton();
public: __property void set_AlwaysShowSearchButton(
   bool value
);
C++/CLI
[DescriptionAttribute("Specifies whether the dropdown arrow button is displayed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public:
property bool AlwaysShowSearchButton {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Use WebCombo without search button
How-to: Always show search button

Concepts

All-new, sleeker User Interface
User Interface Elements


AutoColumnOrdering Property

[image]
Intersoft WebCombo Documentation
AutoColumnOrdering Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : AutoColumnOrdering Property

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Specifies whether WebCombo should perform automatic column ordering checking.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
Public Property AutoColumnOrdering As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Boolean

instance.AutoColumnOrdering = value

value = instance.AutoColumnOrdering
C#
[DescriptionAttribute("Specifies whether WebCombo should perform automatic column ordering checking.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
public bool AutoColumnOrdering {get; set;}
Delphi
public read-write property AutoColumnOrdering: Boolean;
JScript
DescriptionAttribute("Specifies whether WebCombo should perform automatic column ordering checking.")
ISNet.Serialization.XmlSerializableAttribute()
NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
public function get,set AutoColumnOrdering : boolean
Managed Extensions for C++
[DescriptionAttribute("Specifies whether WebCombo should perform automatic column ordering checking.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
public: __property bool get_AutoColumnOrdering();
public: __property void set_AutoColumnOrdering(
   bool value
);
C++/CLI
[DescriptionAttribute("Specifies whether WebCombo should perform automatic column ordering checking.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
public:
property bool AutoColumnOrdering {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members


BoundMode Property

[image]
Intersoft WebCombo Documentation
BoundMode Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : BoundMode Property

Gets or sets the bound mode of WebCombo. Gets or sets the bound mode of WebCombo.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets the bound mode of WebCombo.")>
Public Property BoundMode As BoundMode
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As BoundMode

instance.BoundMode = value

value = instance.BoundMode
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the bound mode of WebCombo.")]
public BoundMode BoundMode {get; set;}
Delphi
public read-write property BoundMode: BoundMode;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
DefaultValueAttribute()
DescriptionAttribute("Gets or sets the bound mode of WebCombo.")
public function get,set BoundMode : BoundMode
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the bound mode of WebCombo.")]
public: __property BoundMode get_BoundMode();
public: __property void set_BoundMode(
   BoundMode value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the bound mode of WebCombo.")]
public:
property BoundMode BoundMode {
   BoundMode get();
   void set (    BoundMode value);
}

Remarks

By default, the bound mode of WebCombo is set to AutoDetect, that means it will automatically determine whether the WebCombo is working in DataBound or Unbound mode. The detection is basically based on the DataSource property of the WebCombo. If the DataSource is filled then WebCombo will work in DataBound mode, it will query the InitializeDataSource event. Generally, it is best to leave this setting to the default but in some complex scenarios where DataBound mode can't be determined automatically such as in Requery implementation, you can force the WebCombo to work in DataBound mode by setting the value of this property to ForceBound. By default, the bound mode of WebCombo is set to AutoDetect, which it will automatically determine whether the WebCombo is working in DataBound or Unbound mode. The detection is basically based on the DataSource property of the WebCombo, so if the DataSource is filled then WebCombo will work in DataBound mode, which it will query the InitializeDataSource event. Generally, it is best to leave this setting to the default but in some complex scenarios where DataBound mode can't be determined automatically such as in Requery implementation, you can force the WebCombo to work in DataBound mode by setting the value of this property to ForceBound.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Use bound multiple selection WebCombo
How-to: Use unbound multiple selection WebCombo

Other Resources

Unbound Mode


ClientSideEvents Property

[image]
Intersoft WebCombo Documentation
ClientSideEvents Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : ClientSideEvents Property

Represents ClientEvents object that hold list of client eventsReturns ClientEvents object.

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute()>
<DescriptionAttribute("Represents ClientEvents object that hold list of client events.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ClientSideEvents As ClientEvents
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As ClientEvents

instance.ClientSideEvents = value

value = instance.ClientSideEvents
C#
[NotifyParentPropertyAttribute(true)]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Represents ClientEvents object that hold list of client events.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public ClientEvents ClientSideEvents {get; set;}
Delphi
public read-write property ClientSideEvents: ClientEvents;
JScript
NotifyParentPropertyAttribute()
PersistenceModeAttribute(PersistenceMode.InnerProperty)
TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute()
DescriptionAttribute("Represents ClientEvents object that hold list of client events.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ClientSideEvents : ClientEvents
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Represents ClientEvents object that hold list of client events.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property ClientEvents* get_ClientSideEvents();
public: __property void set_ClientSideEvents(
   ClientEvents* value
);
C++/CLI
[NotifyParentPropertyAttribute(true)]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Represents ClientEvents object that hold list of client events.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property ClientEvents^ ClientSideEvents {
   ClientEvents^ get();
   void set (    ClientEvents^ value);
}

Remarks

Client-Side event editor is used to attach a client-side event handler to the event. This will enable WebCombo to accommodate a broad range of scenarios through its extendable capability using client-side events. Some of the ClientEvents property that often used are OnAddItem and OnAfterItemSelected.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Concepts

Client side Event Designer


ColumnSeparatorColor Property

[image]
Intersoft WebCombo Documentation
ColumnSeparatorColor Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : ColumnSeparatorColor Property

Gets or sets the separator color between columns Gets or sets the separator color between columns.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<DescriptionAttribute("Gets or sets the separator color between columns.")>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
Public Property ColumnSeparatorColor As Color
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Color

instance.ColumnSeparatorColor = value

value = instance.ColumnSeparatorColor
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Gets or sets the separator color between columns.")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public Color ColumnSeparatorColor {get; set;}
Delphi
public read-write property ColumnSeparatorColor: Color;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
DescriptionAttribute("Gets or sets the separator color between columns.")
NotifyParentPropertyAttribute()
DefaultValueAttribute()
public function get,set ColumnSeparatorColor : Color
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Gets or sets the separator color between columns.")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public: __property Color get_ColumnSeparatorColor();
public: __property void set_ColumnSeparatorColor(
   Color value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Gets or sets the separator color between columns.")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public:
property Color ColumnSeparatorColor {
   Color get();
   void set (    Color value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Concepts

User Interface Elements
All-new, sleeker User Interface


ColumnStyle Property

[image]
Intersoft WebCombo Documentation
ColumnStyle Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : ColumnStyle Property

The styles applied to column. The styles applied to column.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<DescriptionAttribute("The styles applied to column.")>
Public Property ColumnStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As ISNet.WebUI.WebStyle

instance.ColumnStyle = value

value = instance.ColumnStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[DescriptionAttribute("The styles applied to column.")]
public ISNet.WebUI.WebStyle ColumnStyle {get; set;}
Delphi
public read-write property ColumnStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
PersistenceModeAttribute(PersistenceMode.InnerProperty)
TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
DescriptionAttribute("The styles applied to column.")
public function get,set ColumnStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[DescriptionAttribute("The styles applied to column.")]
public: __property ISNet.WebUI.WebStyle* get_ColumnStyle();
public: __property void set_ColumnStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[DescriptionAttribute("The styles applied to column.")]
public:
property ISNet.WebUI.WebStyle^ ColumnStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Remarks

You can customize the WebCombo's column table using this property, such as changing the back color, border color, font, and so on.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Concepts

All-new, sleeker User Interface
User Interface Elements


ColumnWidthDefault Property

[image]
Intersoft WebCombo Documentation
ColumnWidthDefault Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : ColumnWidthDefault Property

Specifies the column width default. Only affected to MultipleColumns mode. Specifies the column width default. Only affected to MultipleColumns mode.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Specifies the column width default.")>
<DefaultValueAttribute()>
Public Property ColumnWidthDefault As Unit
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Unit

instance.ColumnWidthDefault = value

value = instance.ColumnWidthDefault
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies the column width default.")]
[DefaultValueAttribute()]
public Unit ColumnWidthDefault {get; set;}
Delphi
public read-write property ColumnWidthDefault: Unit;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
DescriptionAttribute("Specifies the column width default.")
DefaultValueAttribute()
public function get,set ColumnWidthDefault : Unit
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies the column width default.")]
[DefaultValueAttribute()]
public: __property Unit get_ColumnWidthDefault();
public: __property void set_ColumnWidthDefault(
   Unit value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies the column width default.")]
[DefaultValueAttribute()]
public:
property Unit ColumnWidthDefault {
   Unit get();
   void set (    Unit value);
}

Remarks

The default value of this property is 100px.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Set default column width

Concepts

All-new, sleeker User Interface
User Interface Elements


ComboMode Property

[image]
Intersoft WebCombo Documentation
ComboMode Property
See Also Example Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : ComboMode Property

Specifies the mode of the WebCombo control.

Specifies the mode of the WebCombo control.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies the mode of the WebCombo control.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
Public Property ComboMode As Mode
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Mode

instance.ComboMode = value

value = instance.ComboMode
C#
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the mode of the WebCombo control.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public Mode ComboMode {get; set;}
Delphi
public read-write property ComboMode: Mode;
JScript
DefaultValueAttribute()
DescriptionAttribute("Specifies the mode of the WebCombo control.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
public function get,set ComboMode : Mode
Managed Extensions for C++
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the mode of the WebCombo control.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public: __property Mode get_ComboMode();
public: __property void set_ComboMode(
   Mode value
);
C++/CLI
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the mode of the WebCombo control.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public:
property Mode ComboMode {
   Mode get();
   void set (    Mode value);
}

Example

The following example shows you how to bind a WebCombo and configure the ComboMode to MultipleColumns programmatically.
C# Copy Code
private void WebCombo1_InitializeDataSource(object sender, ISNet.WebUI.WebCombo.DataSourceEventArgs e)
{
    DataSet ds = new DataSet();
    oleDbDataAdapter1.Fill(ds,"Customers");
    e.DataSource =  ds;
    WebCombo2.DataTextField = "ContactName";
    WebCombo2.DataValueField = "CustomerID";
}

private void WebCombo1_InitializeLayout(object sender, ISNet.WebUI.WebCombo.LayoutEventArgs e)
{
    e.Layout.ComboMode = Mode.MultipleColumns;
}

Remarks

The control will work as a normal dropdownlist control when it is set to SingleColumn (Default). In this mode, DataTextField and DataValueField will be used to display data. Other columns in DataSource are ignored.

On the other hand, the control will show all columns by default when it is set to MultipleColumns. DataTextField field will always at the first position and its width is set to the width of control by default.

For greater level of customization, WebCombo provides Column object which contains basic column properties such as HeaderText or Width. You can access the Column object after DataBind is called.

When set to SingleColumn (Default), the control will work as a normal dropdownlist control. In this mode, DataTextField and DataValueField will be used to display data. Other columns in DataSource are ignored.

When set to MultipleColumns, the control will show all columns by default. DataTextField field will always at the first position and its width is set to the width of control by default.

For greater level of customization, WebCombo provides Column object which contains basic column properties such as HeaderText or Width. You can access the Column object after WebCombo.DataBind is called.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Concepts

Multiple Columns

Tasks

How-to: Use multiple columns mode


DropDownStyle Property

[image]
Intersoft WebCombo Documentation
DropDownStyle Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : DropDownStyle Property

The interactive style applied to WebCombo's DropDown. The interactive style applied to WebCombo's DropDown.

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<DescriptionAttribute("The interactive style applied to WebCombo's drop down element.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<CategoryAttribute("Appearance")>
<DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property DropDownStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As ISNet.WebUI.DynamicStyle

instance.DropDownStyle = value

value = instance.DropDownStyle
C#
[NotifyParentPropertyAttribute(true)]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DescriptionAttribute("The interactive style applied to WebCombo's drop down element.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[CategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public ISNet.WebUI.DynamicStyle DropDownStyle {get; set;}
Delphi
public read-write property DropDownStyle: ISNet.WebUI.DynamicStyle;
JScript
NotifyParentPropertyAttribute()
PersistenceModeAttribute(PersistenceMode.InnerProperty)
DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
DescriptionAttribute("The interactive style applied to WebCombo's drop down element.")
ISNet.Serialization.XmlSerializableAttribute()
CategoryAttribute("Appearance")
DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set DropDownStyle : ISNet.WebUI.DynamicStyle
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DescriptionAttribute("The interactive style applied to WebCombo's drop down element.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[CategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property ISNet.WebUI.DynamicStyle* get_DropDownStyle();
public: __property void set_DropDownStyle(
   ISNet.WebUI.DynamicStyle* value
);
C++/CLI
[NotifyParentPropertyAttribute(true)]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DescriptionAttribute("The interactive style applied to WebCombo's drop down element.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[CategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property ISNet.WebUI.DynamicStyle^ DropDownStyle {
   ISNet.WebUI.DynamicStyle^ get();
   void set (    ISNet.WebUI.DynamicStyle^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Concepts

Real Dropdownlist Window

Tasks

How-to: Set result box window type


EnableAnimation Property

[image]
Intersoft WebCombo Documentation
EnableAnimation Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : EnableAnimation Property

Enable background image animation in dropdown element. Gets or sets a value indicating whether background animation is enabled when mouse is over the dropdown button.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Gets or sets a value indicating whether background animation is enabled when mouse is over the dropdown button.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property EnableAnimation As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Boolean

instance.EnableAnimation = value

value = instance.EnableAnimation
C#
[DescriptionAttribute("Gets or sets a value indicating whether background animation is enabled when mouse is over the dropdown button.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public bool EnableAnimation {get; set;}
Delphi
public read-write property EnableAnimation: Boolean;
JScript
DescriptionAttribute("Gets or sets a value indicating whether background animation is enabled when mouse is over the dropdown button.")
ISNet.Serialization.XmlSerializableAttribute()
DefaultValueAttribute()
NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set EnableAnimation : boolean
Managed Extensions for C++
[DescriptionAttribute("Gets or sets a value indicating whether background animation is enabled when mouse is over the dropdown button.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property bool get_EnableAnimation();
public: __property void set_EnableAnimation(
   bool value
);
C++/CLI
[DescriptionAttribute("Gets or sets a value indicating whether background animation is enabled when mouse is over the dropdown button.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property bool EnableAnimation {
   bool get();
   void set (    bool value);
}

Remarks

WebCombo.NET 4.0 supports background image animation to help you replicate rich UI controls in Windows Vista®. In this version, the background image animation is supported in dropdown element only.

However, note that the image animation requires certain design in order to create smooth effect. Not all design will look good when the animation is enabled. For instance, the default style that comes in version 4.0 is specially designed to display smoothly while animation is enabled.

When a new instance of WebCombo is created in designer (design time), EnableAnimation is enabled by default. However, to preserve compatibility with existing application, this new feature will not be enabled for existing instances of WebCombo.

To enable dropdown background animation on WebCombo, you can read How-To: Enable animation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-To: Enable animation

Concepts

Vista-style image animation


EnableSlidingAnimation Property

[image]
Intersoft WebCombo Documentation
EnableSlidingAnimation Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : EnableSlidingAnimation Property

Specifies whether the ResultBox should be animated when user clicked on the drop down element of the WebCombo.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Specifies whether the ResultBox should be animated when user clicked on the drop down element of the WebCombo.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property EnableSlidingAnimation As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Boolean

instance.EnableSlidingAnimation = value

value = instance.EnableSlidingAnimation
C#
[DescriptionAttribute("Specifies whether the ResultBox should be animated when user clicked on the drop down element of the WebCombo.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public bool EnableSlidingAnimation {get; set;}
Delphi
public read-write property EnableSlidingAnimation: Boolean;
JScript
DescriptionAttribute("Specifies whether the ResultBox should be animated when user clicked on the drop down element of the WebCombo.")
ISNet.Serialization.XmlSerializableAttribute()
DefaultValueAttribute()
NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set EnableSlidingAnimation : boolean
Managed Extensions for C++
[DescriptionAttribute("Specifies whether the ResultBox should be animated when user clicked on the drop down element of the WebCombo.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property bool get_EnableSlidingAnimation();
public: __property void set_EnableSlidingAnimation(
   bool value
);
C++/CLI
[DescriptionAttribute("Specifies whether the ResultBox should be animated when user clicked on the drop down element of the WebCombo.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property bool EnableSlidingAnimation {
   bool get();
   void set (    bool value);
}

Remarks

One of the Intersoft’s focuses in the 2008 release is core animation feature. In this new release, you can add stunning quadratic sliding animation to WebCombo control. When this feature is applied, the sliding animation will be played when you clicked on the dropdown arrow. The animation will also be played every time the dropdown content needs to be displayed – such as when you type into the textbox.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Enable Sliding Animation in WebCombo


EntryMode Property

[image]
Intersoft WebCombo Documentation
EntryMode Property
See Also Example Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : EntryMode Property

Gets or sets the entry behavior of WebCombo. Gets or sets the entry behavior of WebCombo.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Gets or sets the entry behavior of WebCombo.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
Public Property EntryMode As EntryMode
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As EntryMode

instance.EntryMode = value

value = instance.EntryMode
C#
[DescriptionAttribute("Gets or sets the entry behavior of WebCombo.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public EntryMode EntryMode {get; set;}
Delphi
public read-write property EntryMode: EntryMode;
JScript
DescriptionAttribute("Gets or sets the entry behavior of WebCombo.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
NotifyParentPropertyAttribute()
DefaultValueAttribute()
public function get,set EntryMode : EntryMode
Managed Extensions for C++
[DescriptionAttribute("Gets or sets the entry behavior of WebCombo.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public: __property EntryMode get_EntryMode();
public: __property void set_EntryMode(
   EntryMode value
);
C++/CLI
[DescriptionAttribute("Gets or sets the entry behavior of WebCombo.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public:
property EntryMode EntryMode {
   EntryMode get();
   void set (    EntryMode value);
}

Example

The following sample code shows you how to configure the EntryMode to InstantLookUp programmatically.
C# Copy Code
WebCombo1.LayoutSettings.EntryMode = EntryMode.InstantLookup;

Remarks

WebCombo.NET now includes 2 new entry behaviors for Bound mode instead of existing entry mode which called Default. The InstantLookup entry mode designated for scenarios which input data is mostly available and exact such as "OrderID". This mode is also designed for end-users who requires fast data entry and only wanted to see the resultbox when exact match is not found.

Scenario example for InstantLookup mode:

Let's say user wants to search OrderID "299980"

  1. "299980" is typed in the WebCombo's textbox (any combination of one or more characters). WebCombo will not perform any search at this step.
  2. Pressing Enter or Tab key fires "InitializeDataSource" event.
  3. WebCombo.NET searches the text in database and upon a perfect match "ValueChanged" event is fired when AllowAutoPostBack is set to True - no resultbox is shown. When AllowAutoPostBack is set to False (default), the WebCombo will simply set the text as selected and assign the corresponding value automatically from search result.
  4. In case there is no perfect match (result is 0 or more than 1 or when input text is not equal to result's text), the resultbox window will be shown (as in Default mode).

Note that when AllowAutoPostback is not used when using this mode, you should make sure that all controls that cause postback should check the state of the WebCombo before the postback occurs. This is important because the WebCombo will perform searching silently in this mode. For example, you typed "299980" then you click on a button, upon the focus changes from WebCombo to Button, WebCombo will try to check whether specified input has perfect match in the database. If yes then the value will be assigned to the WebCombo and mark it as selected. Looking at the mechanism above, clicking on a button that cause postback after typing the value in WebCombo will cause the WebCombo's value to Empty. This condition happened because WebCombo's asynchronous searching hasn't return any result yet when the postback occured.

Although the above scenario might be rare to happen, it is a good idea to avoid any further issues. You can easily handle the form's onsubmit event and perform a simple check such as:

if (webCombo.IsInProgress) {
alert("wcOrderID's searching is in progress...");
return false;
}

Alternatively, if the WebCombo is a required field, you can put a .NET required validator to check the WebCombo's value. In this case, when you changed focus from WebCombo to button, the page will not postback because there is no selected value yet in WebCombo.

The AutoComplete entry mode allow "traditional" text auto-completion such as in IE 4.x days. The entry mode has exact behavior as in Default mode, except it will autocomplete the text with first matched result.

To learn more and give you more illustration please read Entry Mode.

Starting from SP2 (Build 20), WebCombo.NET includes 2 new entry behaviors for Bound mode instead of existing entry mode which called Default. The InstantLookup entry mode designated for scenarios which input data is mostly available and exact such as "OrderID". This mode is also designed for end-users who requires fast data entry and only wanted to see the resultbox when exact match is not found.

Scenario example for InstantLookup mode:

Let's say user wants to search OrderID "299980"

  1. "299980" is typed in the WebCombo's textbox (any combination of one or more characters). WebCombo will not perform any search at this step.
  2. Pressing Enter or Tab key fires "InitializeDataSource" event.
  3. WebCombo.NET searches the text in database and upon a perfect match "ValueChanged" event is fired when AllowAutoPostBack is set to True - no resultbox is shown. When AllowAutoPostBack is set to False (default), the WebCombo will simply set the text as selected and assign the corresponding value automatically from search result.
  4. In case there is no perfect match (result is 0 or more than 1 or when input text is not equal to result's text), the resultbox window will be shown (as in Default mode).

Notes that when AllowAutoPostback is not used when using this mode, you should make sure that all controls that cause postback should check the state of the WebCombo before the postback occurs. This is important because the WebCombo will perform searching silently in this mode. For example, you typed "299980" then you click on a button, upon the focus changes from WebCombo to Button, WebCombo will try to check whether specified input has perfect match in the database. If yes then the value will be assigned to the WebCombo and mark it as selected. Looking at the mechanism above, clicking on a button that cause postback after typing the value in WebCombo will cause the WebCombo's value to Empty. This condition happened because WebCombo's asynchronous searching hasn't return any result yet when the postback occured.

Although the above scenario might be rare to happen, it is a good idea to avoid any further issues. You can easily handle the form's onsubmit event and perform a simple check such as:

            if (webCombo.IsInProgress) {
                alert("wcOrderID's searching is in progress...");
                return false;
            }

Alternatively, if the WebCombo is a required field, you can put a .NET required validator to check the WebCombo's value. In this case, when you changed focus from WebCombo to button, the page will not postback because there is no selected value yet in WebCombo.

The AutoComplete entry mode allow "traditional" text auto-completion such as in IE 4.x days. The entry mode has exact behavior as in Default mode, except it will autocomplete the text with first matched result.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Use default entry mode
How-to: Use AutoComplete entry mode
How-to: Use InstantLookUp entry mode

Concepts

Entry Mode


FrameStyle Property

[image]
Intersoft WebCombo Documentation
FrameStyle Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : FrameStyle Property

The interactive styles of the WebCombo's Frame. The interactive styles of the WebCombo's Frame.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<DefaultValueAttribute()>
<CategoryAttribute("Appearance")>
<DescriptionAttribute("The interactive styles of the WebCombo's Frame.")>
Public Property FrameStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As ISNet.WebUI.DynamicStyle

instance.FrameStyle = value

value = instance.FrameStyle
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
[DescriptionAttribute("The interactive styles of the WebCombo's Frame.")]
public ISNet.WebUI.DynamicStyle FrameStyle {get; set;}
Delphi
public read-write property FrameStyle: ISNet.WebUI.DynamicStyle;
JScript
ISNet.Serialization.XmlSerializableAttribute()
TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
PersistenceModeAttribute(PersistenceMode.InnerProperty)
DefaultValueAttribute()
CategoryAttribute("Appearance")
DescriptionAttribute("The interactive styles of the WebCombo's Frame.")
public function get,set FrameStyle : ISNet.WebUI.DynamicStyle
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
[DescriptionAttribute("The interactive styles of the WebCombo's Frame.")]
public: __property ISNet.WebUI.DynamicStyle* get_FrameStyle();
public: __property void set_FrameStyle(
   ISNet.WebUI.DynamicStyle* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
[DescriptionAttribute("The interactive styles of the WebCombo's Frame.")]
public:
property ISNet.WebUI.DynamicStyle^ FrameStyle {
   ISNet.WebUI.DynamicStyle^ get();
   void set (    ISNet.WebUI.DynamicStyle^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Concepts

User Interface Elements
All-new, sleeker User Interface


HeaderStyle Property

[image]
Intersoft WebCombo Documentation
HeaderStyle Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : HeaderStyle Property

The styles applied to columns header. The styles applied to columns header.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<DescriptionAttribute("The styles applied to columns header.")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Property HeaderStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As ISNet.WebUI.WebStyle

instance.HeaderStyle = value

value = instance.HeaderStyle
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[DescriptionAttribute("The styles applied to columns header.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ISNet.WebUI.WebStyle HeaderStyle {get; set;}
Delphi
public read-write property HeaderStyle: ISNet.WebUI.WebStyle;
JScript
DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
DescriptionAttribute("The styles applied to columns header.")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get,set HeaderStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[DescriptionAttribute("The styles applied to columns header.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ISNet.WebUI.WebStyle* get_HeaderStyle();
public: __property void set_HeaderStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[DescriptionAttribute("The styles applied to columns header.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ISNet.WebUI.WebStyle^ HeaderStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Concepts

User Interface Elements
All-new, sleeker User Interface


HelpImage Property

[image]
Intersoft WebCombo Documentation
HelpImage Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : HelpImage Property

Specifies the image for Help. Specifies the image for Help.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies the image for Help.")>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property HelpImage As String
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As String

instance.HelpImage = value

value = instance.HelpImage
C#
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the image for Help.")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public string HelpImage {get; set;}
Delphi
public read-write property HelpImage: String;
JScript
DefaultValueAttribute()
DescriptionAttribute("Specifies the image for Help.")
NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set HelpImage : String
Managed Extensions for C++
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the image for Help.")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property string* get_HelpImage();
public: __property void set_HelpImage(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the image for Help.")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property String^ HelpImage {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Define the help image

Concepts

All-new, sleeker User Interface
User Interface Elements


HelpURL Property

[image]
Intersoft WebCombo Documentation
HelpURL Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : HelpURL Property

Specifies the client's help URL when user click on the Help icon. The default is Intersoft's own help page URL. This property is application-wide configurable. Specifies the client's help URL when user clicked on the Help icon. This property is application-wide configurable.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Specifies the client's help URL when user clicked on the Help icon. The default is Intersoft's own help page URL. This property is application-wide configurable.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property HelpURL As String
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As String

instance.HelpURL = value

value = instance.HelpURL
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies the client's help URL when user clicked on the Help icon. The default is Intersoft's own help page URL. This property is application-wide configurable.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public string HelpURL {get; set;}
Delphi
public read-write property HelpURL: String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
NotifyParentPropertyAttribute()
DescriptionAttribute("Specifies the client's help URL when user clicked on the Help icon. The default is Intersoft's own help page URL. This property is application-wide configurable.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set HelpURL : String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies the client's help URL when user clicked on the Help icon. The default is Intersoft's own help page URL. This property is application-wide configurable.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property string* get_HelpURL();
public: __property void set_HelpURL(
   string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies the client's help URL when user clicked on the Help icon. The default is Intersoft's own help page URL. This property is application-wide configurable.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property String^ HelpURL {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Define help URL

Concepts

All-new, sleeker User Interface
User Interface Elements


ImagesDirectory Property

[image]
Intersoft WebCombo Documentation
ImagesDirectory Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : ImagesDirectory Property

Specifies the directory used to store WebCombo images files. Specifies the directory used to store WebCombo images files.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<DescriptionAttribute("Specifies the WebCombo image files directory.")>
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
<ISNet.PersistLayoutAttribute(False)>
Public Property ImagesDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As String

instance.ImagesDirectory = value

value = instance.ImagesDirectory
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Specifies the WebCombo image files directory.")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.PersistLayoutAttribute(false)]
public string ImagesDirectory {get; set;}
Delphi
public read-write property ImagesDirectory: String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
DescriptionAttribute("Specifies the WebCombo image files directory.")
DefaultValueAttribute()
NotifyParentPropertyAttribute()
ISNet.PersistLayoutAttribute()
public function get,set ImagesDirectory : String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Specifies the WebCombo image files directory.")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.PersistLayoutAttribute(false)]
public: __property string* get_ImagesDirectory();
public: __property void set_ImagesDirectory(
   string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Specifies the WebCombo image files directory.")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.PersistLayoutAttribute(false)]
public:
property String^ ImagesDirectory {
   String^ get();
   void set (    String^ value);
}

Remarks

Same thing like ScriptDirectory, In WebCombo.NET V5.0 the required images for the control at runtime are bundled in single assembly of WebGrid's SmartWebResources.

When the SmartWebResources Framework is configured to "Auto" mode and the ImagesDirectory has been changed (not default value), the SmartWebResources will not attempt to enable itself when it detects customized ImagesDirectory (same behavior with the behavior of ScriptDirectory). This ensures that your existing web application runs perfectly after you migrate to the new framework.

If ImagesDirectory is customized, but ScriptDirectory is using default value (not customized), the SmartWebResources will fallback to ScriptOnly mode. That means, the scripts will be handled by SmartWebResources. For more information, please read the SmartWebResources™ modes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Set images directory
How-to: Configure SmartWebResources in a new web application
How-to: Disable WebResources
FAQ: Does SmartWebResources feature automatically enabled in WebCombo.NET 4.0?

Concepts

Hassle-free deployment through SmartWebResources™ technology


ItemHeight Property

[image]
Intersoft WebCombo Documentation
ItemHeight Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : ItemHeight Property

Specifies the default item row height. Specifies the default item row height.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Specifies the default item row height.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ItemHeight As Unit
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Unit

instance.ItemHeight = value

value = instance.ItemHeight
C#
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies the default item row height.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public Unit ItemHeight {get; set;}
Delphi
public read-write property ItemHeight: Unit;
JScript
DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
NotifyParentPropertyAttribute()
DescriptionAttribute("Specifies the default item row height.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ItemHeight : Unit
Managed Extensions for C++
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies the default item row height.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property Unit get_ItemHeight();
public: __property void set_ItemHeight(
   Unit value
);
C++/CLI
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies the default item row height.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property Unit ItemHeight {
   Unit get();
   void set (    Unit value);
}

Remarks

The default value is 20px.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Define the row's height

Concepts

All-new, sleeker User Interface
User Interface Elements


LoadMoreKeyGesture Property

[image]
Intersoft WebCombo Documentation
LoadMoreKeyGesture Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : LoadMoreKeyGesture Property

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<CategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Gets or sets a value that determines the key gesture used to load more data when the ResultBox is shown.")>
Public Property LoadMoreKeyGesture As LoadMoreKeyGesture
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As LoadMoreKeyGesture

instance.LoadMoreKeyGesture = value

value = instance.LoadMoreKeyGesture
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Gets or sets a value that determines the key gesture used to load more data when the ResultBox is shown.")]
public LoadMoreKeyGesture LoadMoreKeyGesture {get; set;}
Delphi
public read-write property LoadMoreKeyGesture: LoadMoreKeyGesture;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
CategoryAttribute("Behavior")
DefaultValueAttribute()
NotifyParentPropertyAttribute()
DescriptionAttribute("Gets or sets a value that determines the key gesture used to load more data when the ResultBox is shown.")
public function get,set LoadMoreKeyGesture : LoadMoreKeyGesture
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Gets or sets a value that determines the key gesture used to load more data when the ResultBox is shown.")]
public: __property LoadMoreKeyGesture get_LoadMoreKeyGesture();
public: __property void set_LoadMoreKeyGesture(
   LoadMoreKeyGesture value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Gets or sets a value that determines the key gesture used to load more data when the ResultBox is shown.")]
public:
property LoadMoreKeyGesture LoadMoreKeyGesture {
   LoadMoreKeyGesture get();
   void set (    LoadMoreKeyGesture value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members


MoreButtonStyle Property

[image]
Intersoft WebCombo Documentation
MoreButtonStyle Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : MoreButtonStyle Property

The interactive style applied to WebCombo's more button.

The interactive style applied to WebCombo's more button.

Syntax

Visual Basic (Declaration)
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<DescriptionAttribute("The interactive style applied to WebCombo's more button.")>
<TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<CategoryAttribute("Appearance")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property MoreButtonStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As ISNet.WebUI.DynamicStyle

instance.MoreButtonStyle = value

value = instance.MoreButtonStyle
C#
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DescriptionAttribute("The interactive style applied to WebCombo's more button.")]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[CategoryAttribute("Appearance")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public ISNet.WebUI.DynamicStyle MoreButtonStyle {get; set;}
Delphi
public read-write property MoreButtonStyle: ISNet.WebUI.DynamicStyle;
JScript
PersistenceModeAttribute(PersistenceMode.InnerProperty)
DescriptionAttribute("The interactive style applied to WebCombo's more button.")
TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
CategoryAttribute("Appearance")
DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set MoreButtonStyle : ISNet.WebUI.DynamicStyle
Managed Extensions for C++
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DescriptionAttribute("The interactive style applied to WebCombo's more button.")]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[CategoryAttribute("Appearance")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property ISNet.WebUI.DynamicStyle* get_MoreButtonStyle();
public: __property void set_MoreButtonStyle(
   ISNet.WebUI.DynamicStyle* value
);
C++/CLI
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DescriptionAttribute("The interactive style applied to WebCombo's more button.")]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[CategoryAttribute("Appearance")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property ISNet.WebUI.DynamicStyle^ MoreButtonStyle {
   ISNet.WebUI.DynamicStyle^ get();
   void set (    ISNet.WebUI.DynamicStyle^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Concepts

All-new, sleeker User Interface

Tasks

User Interface Elements


NoResultFoundAction Property

[image]
Intersoft WebCombo Documentation
NoResultFoundAction Property
See Also Example Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : NoResultFoundAction Property

Gets or sets the action which WebCombo should perform when there are no results found and the WebCombo has lost its focus.

Gets or sets the action which WebCombo should perform when there are no results found and the WebCombo has lost its focus.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<DescriptionAttribute("Gets or sets the action which WebCombo should perform when there are no results found and the WebCombo has lost its focus.")>
<NotifyParentPropertyAttribute(True)>
<CategoryAttribute("Behavior")>
Public Property NoResultFoundAction As NoResultFoundAction
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As NoResultFoundAction

instance.NoResultFoundAction = value

value = instance.NoResultFoundAction
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Gets or sets the action which WebCombo should perform when there are no results found and the WebCombo has lost its focus.")]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Behavior")]
public NoResultFoundAction NoResultFoundAction {get; set;}
Delphi
public read-write property NoResultFoundAction: NoResultFoundAction;
JScript
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
DescriptionAttribute("Gets or sets the action which WebCombo should perform when there are no results found and the WebCombo has lost its focus.")
NotifyParentPropertyAttribute()
CategoryAttribute("Behavior")
public function get,set NoResultFoundAction : NoResultFoundAction
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Gets or sets the action which WebCombo should perform when there are no results found and the WebCombo has lost its focus.")]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Behavior")]
public: __property NoResultFoundAction get_NoResultFoundAction();
public: __property void set_NoResultFoundAction(
   NoResultFoundAction value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Gets or sets the action which WebCombo should perform when there are no results found and the WebCombo has lost its focus.")]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Behavior")]
public:
property NoResultFoundAction NoResultFoundAction {
   NoResultFoundAction get();
   void set (    NoResultFoundAction value);
}

Example

The following sample code shows you how to configure the NoResultFundAction to RevertSelection programmatically.
C# Copy Code
WebCombo1.LayoutSettings.NoResultFoundAction =  NoResultFoundAction.RevertSelection;

Remarks

This property only applicable in following conditions:

  • WebCombo is configured to use Bound mode.
  • WebCombo is not using AllowAddItem feature.

WebCombo.NET v4.0 improves the natural behavior of end users while entering data. WebCombo.NET introduced Latency property which determines the number of milliseconds to wait before requesting the data to server. Everything is good except for fast-typing end users as the users typed the data quicker than the Latency period, and press Tab key to go to the next field.
In previous versions, the scenario above would fail as the typed data will be reverted back (or empty if previously has no selection). It would also sometimes display the resultbox in incorrect position and causing some interruption since the WebCombo expect the user to wait for the response and select an input before entering next field. In v4.0, this scenario has been completely taken care. WebCombo will do the following:

  • Silently select the result if the result row is only 1, and that row has the same text as input text. No display or focus interruption occurred.
  • If the returned rows are more than one or empty, WebCombo will get the NoResultFoundAction property and perform the action according to value of this property.

If this property is set to RevertSelection, then WebCombo will revert back the previously selected value when the returned rows are more than one or empty. Otherwise, WebCombo will take the focus back to the related WebCombo instance and display the ResultBox thus the end users know that their entry is incorrect.

This property only applicable when WebCombo is in following conditions: - WebCombo is configured to use Bound mode. - WebCombo is not using AllowAddItem feature.

WebCombo.NET V3 improves the natural behavior of end users while entrying data. WebCombo.NET introduced Latency property which determines the number of milliseconds to wait before requesting the data to server. Everything is good except for fast-typing end users as the users typed the data quicker than the Latency period, and press Tab key to go to the next field.

In previous versions, the scenario above would fail as the typed data will be reverted back (or empty if previously has no selection). It would also sometimes redisplay the resultbox in incorrect position and causing some interruption since the WebCombo expects the user to wait for the response and then select an input before entering next field. In V3, this scenario has been completely taken care. WebCombo will do following: - Silently select the result if the result row is only 1, and that row has the same text as input text. No display or focus interuption occured. - If the returned rows are more than one or empty, WebCombo will get the NoResultFoundAction property and perform the action according to value of this property.

If this property is set to RevertSelection, then WebCombo will revert back the previously selected value when the returned rows are more than one or empty. Otherwise, WebCombo will take the focus back to the related WebCombo instance and display the ResultBox so the end users know that his/her entry is incorrect.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Define the action when no result is found in WebCombo

Concepts

All-new, sleeker User Interface
User Interface Elements


ResultBoxHeight Property

[image]
Intersoft WebCombo Documentation
ResultBoxHeight Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : ResultBoxHeight Property

Returns or sets the height of the result box.

Returns or sets the height of the result box.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Returns or sets the height of the result box.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ResultBoxHeight As Integer
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Integer

instance.ResultBoxHeight = value

value = instance.ResultBoxHeight
C#
[DescriptionAttribute("Returns or sets the height of the result box.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public int ResultBoxHeight {get; set;}
Delphi
public read-write property ResultBoxHeight: Integer;
JScript
DescriptionAttribute("Returns or sets the height of the result box.")
ISNet.Serialization.XmlSerializableAttribute()
DefaultValueAttribute()
NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ResultBoxHeight : int
Managed Extensions for C++
[DescriptionAttribute("Returns or sets the height of the result box.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property int get_ResultBoxHeight();
public: __property void set_ResultBoxHeight(
   int value
);
C++/CLI
[DescriptionAttribute("Returns or sets the height of the result box.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property int ResultBoxHeight {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Define the result box's height and width

Concepts

All-new, sleeker User Interface
User Interface Elements


ResultBoxShadow Property

[image]
Intersoft WebCombo Documentation
ResultBoxShadow Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : ResultBoxShadow Property

Specifies whether shadow should be applied to resultbox. This property is only applicable to IE browser and ResultBoxWindowType should be set to Normal. Specifies whether shadow should be applied to resultbox. This property is only applicable to IE browser and ResultBoxWindowType should be set to Normal.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<DescriptionAttribute("Specifies whether shadow should be applied to resultbox. This property is only applicable to IE browser and ResultBoxWindowType should be set to Normal.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
<CategoryAttribute("Behavior")>
Public Property ResultBoxShadow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Boolean

instance.ResultBoxShadow = value

value = instance.ResultBoxShadow
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Specifies whether shadow should be applied to resultbox. This property is only applicable to IE browser and ResultBoxWindowType should be set to Normal.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
public bool ResultBoxShadow {get; set;}
Delphi
public read-write property ResultBoxShadow: Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
DescriptionAttribute("Specifies whether shadow should be applied to resultbox. This property is only applicable to IE browser and ResultBoxWindowType should be set to Normal.")
ISNet.Serialization.XmlSerializableAttribute()
NotifyParentPropertyAttribute()
DefaultValueAttribute()
CategoryAttribute("Behavior")
public function get,set ResultBoxShadow : boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Specifies whether shadow should be applied to resultbox. This property is only applicable to IE browser and ResultBoxWindowType should be set to Normal.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
public: __property bool get_ResultBoxShadow();
public: __property void set_ResultBoxShadow(
   bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Specifies whether shadow should be applied to resultbox. This property is only applicable to IE browser and ResultBoxWindowType should be set to Normal.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
public:
property bool ResultBoxShadow {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Show the result box's shadow

Concepts

All-new, sleeker User Interface
User Interface Elements


ResultBoxStyle Property

[image]
Intersoft WebCombo Documentation
ResultBoxStyle Property
See Also Example Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : ResultBoxStyle Property

The sytle applied to result box (only the box that contain data) The sytle applied to result box (only the box that contain data)

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<DescriptionAttribute("The sytle applied to result box (only the box that contain data)")>
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
Public Property ResultBoxStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As ISNet.WebUI.WebStyle

instance.ResultBoxStyle = value

value = instance.ResultBoxStyle
C#
[NotifyParentPropertyAttribute(true)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[DescriptionAttribute("The sytle applied to result box (only the box that contain data)")]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public ISNet.WebUI.WebStyle ResultBoxStyle {get; set;}
Delphi
public read-write property ResultBoxStyle: ISNet.WebUI.WebStyle;
JScript
NotifyParentPropertyAttribute()
TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
DescriptionAttribute("The sytle applied to result box (only the box that contain data)")
PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
public function get,set ResultBoxStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[DescriptionAttribute("The sytle applied to result box (only the box that contain data)")]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public: __property ISNet.WebUI.WebStyle* get_ResultBoxStyle();
public: __property void set_ResultBoxStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[NotifyParentPropertyAttribute(true)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[DescriptionAttribute("The sytle applied to result box (only the box that contain data)")]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public:
property ISNet.WebUI.WebStyle^ ResultBoxStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Example

The following sample code shows you how to configure the ResultBoxStyle, in which BackColor = Red.
C# Copy Code
WebCombo1.LayoutSettings.ResultBoxStyle.BackColor = Color.Red;

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Concepts

All-new, sleeker User Interface
User Interface Elements


ResultBoxWidth Property

[image]
Intersoft WebCombo Documentation
ResultBoxWidth Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : ResultBoxWidth Property

Returns or sets the width of the result box. Set this property to 0 for automatic width calculation.

Returns or sets the width of the result box. Set this property to 0 for automatic width calculation.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Returns or sets the width of the result box. Set this property to 0 for automatic width calculation.")>
Public Property ResultBoxWidth As Integer
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Integer

instance.ResultBoxWidth = value

value = instance.ResultBoxWidth
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Returns or sets the width of the result box. Set this property to 0 for automatic width calculation.")]
public int ResultBoxWidth {get; set;}
Delphi
public read-write property ResultBoxWidth: Integer;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
NotifyParentPropertyAttribute()
DescriptionAttribute("Returns or sets the width of the result box. Set this property to 0 for automatic width calculation.")
public function get,set ResultBoxWidth : int
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Returns or sets the width of the result box. Set this property to 0 for automatic width calculation.")]
public: __property int get_ResultBoxWidth();
public: __property void set_ResultBoxWidth(
   int value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Returns or sets the width of the result box. Set this property to 0 for automatic width calculation.")]
public:
property int ResultBoxWidth {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Define the result box's height and width

Concepts

All-new, sleeker User Interface
User Interface Elements


ResultBoxWindowType Property

[image]
Intersoft WebCombo Documentation
ResultBoxWindowType Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : ResultBoxWindowType Property

Specifies the resultbox's window type. This property is only applicable to IE browser. Specifies the resultbox's window type. This property is only applicable to IE browser.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies the resultbox's window type. This property is only applicable to IE browser.")>
<CategoryAttribute("Behavior")>
Public Property ResultBoxWindowType As ISNet.WebUI.DisplayType
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As ISNet.WebUI.DisplayType

instance.ResultBoxWindowType = value

value = instance.ResultBoxWindowType
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the resultbox's window type. This property is only applicable to IE browser.")]
[CategoryAttribute("Behavior")]
public ISNet.WebUI.DisplayType ResultBoxWindowType {get; set;}
Delphi
public read-write property ResultBoxWindowType: ISNet.WebUI.DisplayType;
JScript
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
DefaultValueAttribute()
DescriptionAttribute("Specifies the resultbox's window type. This property is only applicable to IE browser.")
CategoryAttribute("Behavior")
public function get,set ResultBoxWindowType : ISNet.WebUI.DisplayType
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the resultbox's window type. This property is only applicable to IE browser.")]
[CategoryAttribute("Behavior")]
public: __property ISNet.WebUI.DisplayType get_ResultBoxWindowType();
public: __property void set_ResultBoxWindowType(
   ISNet.WebUI.DisplayType value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the resultbox's window type. This property is only applicable to IE browser.")]
[CategoryAttribute("Behavior")]
public:
property ISNet.WebUI.DisplayType ResultBoxWindowType {
   ISNet.WebUI.DisplayType get();
   void set (    ISNet.WebUI.DisplayType value);
}

Remarks

Since the first beginning version, “floating” result window has always been one of WebCombo’s key advantage. Users can always see the whole data regardless of the size of the browser, because the result box window is always “floating”. To give you better illustration please read Real Dropdownlist Window.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Set result box window type

Concepts

Real Dropdownlist Window


ResultFrameStyle Property

[image]
Intersoft WebCombo Documentation
ResultFrameStyle Property
See Also Example Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : ResultFrameStyle Property

The styles applied to result frame (the outer result box). The styles applied to result frame (the outer result box).

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The styles applied to result frame (the outer result box).")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<ISNet.Serialization.BinarySerializableAttribute()>
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<NotifyParentPropertyAttribute(True)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property ResultFrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As ISNet.WebUI.WebStyle

instance.ResultFrameStyle = value

value = instance.ResultFrameStyle
C#
[DescriptionAttribute("The styles applied to result frame (the outer result box).")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[NotifyParentPropertyAttribute(true)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ISNet.WebUI.WebStyle ResultFrameStyle {get; set;}
Delphi
public read-write property ResultFrameStyle: ISNet.WebUI.WebStyle;
JScript
DescriptionAttribute("The styles applied to result frame (the outer result box).")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
ISNet.Serialization.BinarySerializableAttribute()
PersistenceModeAttribute(PersistenceMode.InnerProperty)
NotifyParentPropertyAttribute()
DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set ResultFrameStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[DescriptionAttribute("The styles applied to result frame (the outer result box).")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[NotifyParentPropertyAttribute(true)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ISNet.WebUI.WebStyle* get_ResultFrameStyle();
public: __property void set_ResultFrameStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[DescriptionAttribute("The styles applied to result frame (the outer result box).")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[NotifyParentPropertyAttribute(true)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ISNet.WebUI.WebStyle^ ResultFrameStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Example

The following sample code shows you how to configure the ResultFrameStyle, in which BorderColor = RossyBrown.
C# Copy Code
WebCombo1.LayoutSettings.ResultFrameStyle.BorderColor = Color.RossyBrown;

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Concepts

All-new, sleeker User Interface
User Interface Elements


RoundCorner Property

[image]
Intersoft WebCombo Documentation
RoundCorner Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : RoundCorner Property

Specifies whether the combo render the control's user interface in round corner effect. Whether to render the control's user interface in round corner effect.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<DescriptionAttribute("Whether to render the control's user interface in round corner effect.")>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
Public Property RoundCorner As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Boolean

instance.RoundCorner = value

value = instance.RoundCorner
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Whether to render the control's user interface in round corner effect.")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public bool RoundCorner {get; set;}
Delphi
public read-write property RoundCorner: Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
DescriptionAttribute("Whether to render the control's user interface in round corner effect.")
NotifyParentPropertyAttribute()
DefaultValueAttribute()
public function get,set RoundCorner : boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Whether to render the control's user interface in round corner effect.")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public: __property bool get_RoundCorner();
public: __property void set_RoundCorner(
   bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Whether to render the control's user interface in round corner effect.")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public:
property bool RoundCorner {
   bool get();
   void set (    bool value);
}

Remarks

RoundCorner shape rendering is one of the most enhancement of user interface in WebCombo.NET v4.0. The round corner is fluid and flexible, means that it can be drawn properly regardless of the size.

The round corner rendering in WebCombo.NET 4.0 adopts Intersoft’s proprietary TrueShape™ rendering framework which is widely used in WebDesktop.NET components. The round corner interface enables you to display smooth and stylish user interface in your web application as well as delivering unique user experience. To enable round corner in WebCombo, simply set the RoundCorner in LayoutSettings to True from the WebCombo Designer. To give you better illustration you can read Fluid round corner through TrueShape™.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Use round corner in WebCombo

Concepts

Fluid round corner through TrueShape™
All-new, sleeker User Interface
User Interface Elements


RowStyle Property

[image]
Intersoft WebCombo Documentation
RowStyle Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : RowStyle Property

The interactive style applied to row. The interactive style applied to row.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<DescriptionAttribute("The styles applied to row.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
Public Property RowStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As ISNet.WebUI.DynamicStyle

instance.RowStyle = value

value = instance.RowStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[DescriptionAttribute("The styles applied to row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public ISNet.WebUI.DynamicStyle RowStyle {get; set;}
Delphi
public read-write property RowStyle: ISNet.WebUI.DynamicStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
PersistenceModeAttribute(PersistenceMode.InnerProperty)
TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
DescriptionAttribute("The styles applied to row.")
ISNet.Serialization.XmlSerializableAttribute()
NotifyParentPropertyAttribute()
public function get,set RowStyle : ISNet.WebUI.DynamicStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[DescriptionAttribute("The styles applied to row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public: __property ISNet.WebUI.DynamicStyle* get_RowStyle();
public: __property void set_RowStyle(
   ISNet.WebUI.DynamicStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[DescriptionAttribute("The styles applied to row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public:
property ISNet.WebUI.DynamicStyle^ RowStyle {
   ISNet.WebUI.DynamicStyle^ get();
   void set (    ISNet.WebUI.DynamicStyle^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Concepts

User Interface Elements
All-new, sleeker User Interface


ScriptDirectory Property

[image]
Intersoft WebCombo Documentation
ScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : ScriptDirectory Property

This property is available for backward compabitility with V2.x only. This property is linked to WebCombo.ScriptDirectory directly.

This property is available for backward compabitility with V2.x only. This property is linked to WebCombo.ScriptDirectory directly.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<DescriptionAttribute("This property is available for backward compabitility with V2.x only. This property is linked to WebCombo.ScriptDirectory directly.")>
<DefaultValueAttribute()>
<ISNet.PersistLayoutAttribute(False)>
<NotifyParentPropertyAttribute(True)>
Public Property ScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As String

instance.ScriptDirectory = value

value = instance.ScriptDirectory
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("This property is available for backward compabitility with V2.x only. This property is linked to WebCombo.ScriptDirectory directly.")]
[DefaultValueAttribute()]
[ISNet.PersistLayoutAttribute(false)]
[NotifyParentPropertyAttribute(true)]
public string ScriptDirectory {get; set;}
Delphi
public read-write property ScriptDirectory: String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
DescriptionAttribute("This property is available for backward compabitility with V2.x only. This property is linked to WebCombo.ScriptDirectory directly.")
DefaultValueAttribute()
ISNet.PersistLayoutAttribute()
NotifyParentPropertyAttribute()
public function get,set ScriptDirectory : String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("This property is available for backward compabitility with V2.x only. This property is linked to WebCombo.ScriptDirectory directly.")]
[DefaultValueAttribute()]
[ISNet.PersistLayoutAttribute(false)]
[NotifyParentPropertyAttribute(true)]
public: __property string* get_ScriptDirectory();
public: __property void set_ScriptDirectory(
   string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("This property is available for backward compabitility with V2.x only. This property is linked to WebCombo.ScriptDirectory directly.")]
[DefaultValueAttribute()]
[ISNet.PersistLayoutAttribute(false)]
[NotifyParentPropertyAttribute(true)]
public:
property String^ ScriptDirectory {
   String^ get();
   void set (    String^ value);
}

Remarks

In previous versions, resources of product such as scripts are stored in ScriptDirectory. For example, WebCombo's resources are stored in /CommonLibrary/WebCombo/V4_0_7200.

Since WebCombo.NET v5.0 uses a new SmartWebResources Framework, the resources in script directory are now embedded into .NET assembly. Unlike ASP.NET’s built-in Web Resources which embeds client resources in main assembly, SmartWebResources stores each product’s client resources in separate assembly. This enables flexible update (maintenance) to the client resources without has to rebuild the main server-side assembly.

With SmartWebResources enabled, you no longer need to aware what you should do to configure the client scripts virtual directory, or where to locate/store it. You simply ensure that the resources assemblies are in the Bin folder of your application. For more information, you can read How-to: Configure SmartWebResources in a web application.

The "Auto" mode of SmartWebResources will attempt to use SmartWebResources whenever possible. When it detects invalid configuration or usage of product that does not support SmartWebResources, it will automatically fallback to traditional physical client resources approach. For instance, if ScriptDirectory or SharedScriptDirectory has been changed (not default), SmartWebResources detects whether an existing web application was configured to use specific script directory other than the default (for best compatibility). Let's say if the ScriptDirectory is set to “~/SomeOtherFolders” in the control tag or in web.config, then SmartWebResources will not attempt to enable itself.

If ScriptDirectory is customized, but ImagesDirectory is using default value (not customized), the SmartWebResources will fallback to ResourceOnly mode. That means, images and other client resources will still be handled by SmartWebResources. For more information, please read the SmartWebResources™ modes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Set ScriptDirectory and SharedScriptDirectory
How-to: Configure SmartWebResources in a web application
How-to: Disable WebResources
How-to: Set images directory
FAQ: Does SmartWebResources feature automatically enabled in WebCombo.NET 4.0?

Concepts

Hassle-free deployment through SmartWebResources™ technology

Other Resources

SmartWebResources™ modes
Assembly Reference


SearchButtonPosition Property

[image]
Intersoft WebCombo Documentation
SearchButtonPosition Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : SearchButtonPosition Property

Gets or sets the search button (dropdown button) position of the WebCombo. Gets or sets the search button (dropdown button) position of the WebCombo.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets the search button (dropdown button) position of the WebCombo.")>
Public Property SearchButtonPosition As ButtonPosition
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As ButtonPosition

instance.SearchButtonPosition = value

value = instance.SearchButtonPosition
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the search button (dropdown button) position of the WebCombo.")]
public ButtonPosition SearchButtonPosition {get; set;}
Delphi
public read-write property SearchButtonPosition: ButtonPosition;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
DefaultValueAttribute()
DescriptionAttribute("Gets or sets the search button (dropdown button) position of the WebCombo.")
public function get,set SearchButtonPosition : ButtonPosition
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the search button (dropdown button) position of the WebCombo.")]
public: __property ButtonPosition get_SearchButtonPosition();
public: __property void set_SearchButtonPosition(
   ButtonPosition value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the search button (dropdown button) position of the WebCombo.")]
public:
property ButtonPosition SearchButtonPosition {
   ButtonPosition get();
   void set (    ButtonPosition value);
}

Remarks

You can determine whether the search button is positioned on the right or left of WebCombo.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Position search box on the left

Concepts

All-new, sleeker User Interface
User Interface Elements


SearchIconMode Property

[image]
Intersoft WebCombo Documentation
SearchIconMode Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : SearchIconMode Property

Specifies the mode of search icon. Specifies the mode of search icon.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies the mode of search icon.")>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.MarkAsStyleAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property SearchIconMode As SearchMode
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As SearchMode

instance.SearchIconMode = value

value = instance.SearchIconMode
C#
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the mode of search icon.")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public SearchMode SearchIconMode {get; set;}
Delphi
public read-write property SearchIconMode: SearchMode;
JScript
DefaultValueAttribute()
DescriptionAttribute("Specifies the mode of search icon.")
NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.MarkAsStyleAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set SearchIconMode : SearchMode
Managed Extensions for C++
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the mode of search icon.")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property SearchMode get_SearchIconMode();
public: __property void set_SearchIconMode(
   SearchMode value
);
C++/CLI
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the mode of search icon.")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property SearchMode SearchIconMode {
   SearchMode get();
   void set (    SearchMode value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Define the search image

Concepts

All-new, sleeker User Interface
User Interface Elements


SearchImage Property

[image]
Intersoft WebCombo Documentation
SearchImage Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : SearchImage Property

Specifies the image for search icon. Specifies the image for search icon.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<DescriptionAttribute("Specifies the image for search icon.")>
<ISNet.MarkAsStyleAttribute(True)>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
Public Property SearchImage As String
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As String

instance.SearchImage = value

value = instance.SearchImage
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Specifies the image for search icon.")]
[ISNet.MarkAsStyleAttribute(true)]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public string SearchImage {get; set;}
Delphi
public read-write property SearchImage: String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
DescriptionAttribute("Specifies the image for search icon.")
ISNet.MarkAsStyleAttribute()
NotifyParentPropertyAttribute()
DefaultValueAttribute()
public function get,set SearchImage : String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Specifies the image for search icon.")]
[ISNet.MarkAsStyleAttribute(true)]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public: __property string* get_SearchImage();
public: __property void set_SearchImage(
   string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Specifies the image for search icon.")]
[ISNet.MarkAsStyleAttribute(true)]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public:
property String^ SearchImage {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Define the search image

Concepts

All-new, sleeker User Interface
User Interface Elements


SelectedRowStyle Property

[image]
Intersoft WebCombo Documentation
SelectedRowStyle Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : SelectedRowStyle Property

The styles applied to selected row. The styles applied to selected row.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<DescriptionAttribute("The styles applied to selected row.")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<NotifyParentPropertyAttribute(True)>
Public Property SelectedRowStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As ISNet.WebUI.WebStyle

instance.SelectedRowStyle = value

value = instance.SelectedRowStyle
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[DescriptionAttribute("The styles applied to selected row.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[NotifyParentPropertyAttribute(true)]
public ISNet.WebUI.WebStyle SelectedRowStyle {get; set;}
Delphi
public read-write property SelectedRowStyle: ISNet.WebUI.WebStyle;
JScript
DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
DescriptionAttribute("The styles applied to selected row.")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
PersistenceModeAttribute(PersistenceMode.InnerProperty)
NotifyParentPropertyAttribute()
public function get,set SelectedRowStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[DescriptionAttribute("The styles applied to selected row.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[NotifyParentPropertyAttribute(true)]
public: __property ISNet.WebUI.WebStyle* get_SelectedRowStyle();
public: __property void set_SelectedRowStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[DescriptionAttribute("The styles applied to selected row.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[NotifyParentPropertyAttribute(true)]
public:
property ISNet.WebUI.WebStyle^ SelectedRowStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Concepts

User Interface Elements
All-new, sleeker User Interface


StatusBoxPosition Property

[image]
Intersoft WebCombo Documentation
StatusBoxPosition Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : StatusBoxPosition Property

Specifies the status box position. Specifies the status box position.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Specifies the status box position.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property StatusBoxPosition As BoxPosition
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As BoxPosition

instance.StatusBoxPosition = value

value = instance.StatusBoxPosition
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies the status box position.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public BoxPosition StatusBoxPosition {get; set;}
Delphi
public read-write property StatusBoxPosition: BoxPosition;
JScript
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
NotifyParentPropertyAttribute()
DescriptionAttribute("Specifies the status box position.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set StatusBoxPosition : BoxPosition
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies the status box position.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property BoxPosition get_StatusBoxPosition();
public: __property void set_StatusBoxPosition(
   BoxPosition value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies the status box position.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property BoxPosition StatusBoxPosition {
   BoxPosition get();
   void set (    BoxPosition value);
}

Remarks

In WebCombo.NET v4.0, there are several properties which default value have been changed for better user interface that adapt to most common scenarios. Unlike in the previous version (which the default value is Top), the default value of this property in version 4.0 has been changed to Bottom. The changes in default values do not affect the functionality of WebCombo controls.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Hide/Show the status box

Other Resources

User Interface Elements

Concepts

Default Values


StatusBoxStyle Property

[image]
Intersoft WebCombo Documentation
StatusBoxStyle Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : StatusBoxStyle Property

The style applied to the status box. The styles applied to status box.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<DescriptionAttribute("The styles applied to status box.")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<ISNet.Serialization.BinarySerializableAttribute()>
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<NotifyParentPropertyAttribute(True)>
Public Property StatusBoxStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As ISNet.WebUI.WebStyle

instance.StatusBoxStyle = value

value = instance.StatusBoxStyle
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[DescriptionAttribute("The styles applied to status box.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[NotifyParentPropertyAttribute(true)]
public ISNet.WebUI.WebStyle StatusBoxStyle {get; set;}
Delphi
public read-write property StatusBoxStyle: ISNet.WebUI.WebStyle;
JScript
DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
DescriptionAttribute("The styles applied to status box.")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
ISNet.Serialization.BinarySerializableAttribute()
PersistenceModeAttribute(PersistenceMode.InnerProperty)
TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
NotifyParentPropertyAttribute()
public function get,set StatusBoxStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[DescriptionAttribute("The styles applied to status box.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[NotifyParentPropertyAttribute(true)]
public: __property ISNet.WebUI.WebStyle* get_StatusBoxStyle();
public: __property void set_StatusBoxStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[DescriptionAttribute("The styles applied to status box.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[NotifyParentPropertyAttribute(true)]
public:
property ISNet.WebUI.WebStyle^ StatusBoxStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Concepts

User Interface Elements
All-new, sleeker User Interface


StatusBoxVisible Property

[image]
Intersoft WebCombo Documentation
StatusBoxVisible Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : StatusBoxVisible Property

Specifies whether the status box is visible or not. Specifies whether the status box is visible.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Specifies whether the status box is visible.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
Public Property StatusBoxVisible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Boolean

instance.StatusBoxVisible = value

value = instance.StatusBoxVisible
C#
[DescriptionAttribute("Specifies whether the status box is visible.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
public bool StatusBoxVisible {get; set;}
Delphi
public read-write property StatusBoxVisible: Boolean;
JScript
DescriptionAttribute("Specifies whether the status box is visible.")
ISNet.Serialization.XmlSerializableAttribute()
NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
public function get,set StatusBoxVisible : boolean
Managed Extensions for C++
[DescriptionAttribute("Specifies whether the status box is visible.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
public: __property bool get_StatusBoxVisible();
public: __property void set_StatusBoxVisible(
   bool value
);
C++/CLI
[DescriptionAttribute("Specifies whether the status box is visible.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
public:
property bool StatusBoxVisible {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Hide/Show the status box

Concepts

All-new, sleeker User Interface
User Interface Elements


TextBoxMode Property

[image]
Intersoft WebCombo Documentation
TextBoxMode Property
See Also Example Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : TextBoxMode Property

Returns or sets the textbox mode of the control. Returns or sets the textbox mode of the control.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
<DescriptionAttribute("Returns or sets the textbox mode of the control.")>
Public Property TextBoxMode As TextboxMode
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As TextboxMode

instance.TextBoxMode = value

value = instance.TextBoxMode
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Returns or sets the textbox mode of the control.")]
public TextboxMode TextBoxMode {get; set;}
Delphi
public read-write property TextBoxMode: TextboxMode;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
DefaultValueAttribute()
DescriptionAttribute("Returns or sets the textbox mode of the control.")
public function get,set TextBoxMode : TextboxMode
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Returns or sets the textbox mode of the control.")]
public: __property TextboxMode get_TextBoxMode();
public: __property void set_TextBoxMode(
   TextboxMode value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Returns or sets the textbox mode of the control.")]
public:
property TextboxMode TextBoxMode {
   TextboxMode get();
   void set (    TextboxMode value);
}

Example

The following example shows you how to configure the TextBoxMode to ReadOnly programmatically
C# Copy Code
WebCombo1.LayoutSettings.TextBoxMode = TextboxMode.ReadOnly;

Remarks

The default value in this property is Editable - it means user can type or add a value on the combo. However users can set this property to ReadOnly, in which the combo is not editable.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Set the TextBox mode in WebCombo

Concepts

All-new, sleeker User Interface
User Interface Elements
TextBox Mode


TextBoxStyle Property

[image]
Intersoft WebCombo Documentation
TextBoxStyle Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : TextBoxStyle Property

The interactive style applied to WebCombo's TextBox.

The interactive style applied to WebCombo's TextBox.

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<CategoryAttribute("Appearance")>
<ISNet.Serialization.BinarySerializableAttribute()>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<DescriptionAttribute("The interactive style applied to WebCombo's TextBox.")>
Public Property TextBoxStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As ISNet.WebUI.DynamicStyle

instance.TextBoxStyle = value

value = instance.TextBoxStyle
C#
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DescriptionAttribute("The interactive style applied to WebCombo's TextBox.")]
public ISNet.WebUI.DynamicStyle TextBoxStyle {get; set;}
Delphi
public read-write property TextBoxStyle: ISNet.WebUI.DynamicStyle;
JScript
TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
CategoryAttribute("Appearance")
ISNet.Serialization.BinarySerializableAttribute()
DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute()
NotifyParentPropertyAttribute()
DefaultValueAttribute()
PersistenceModeAttribute(PersistenceMode.InnerProperty)
DescriptionAttribute("The interactive style applied to WebCombo's TextBox.")
public function get,set TextBoxStyle : ISNet.WebUI.DynamicStyle
Managed Extensions for C++
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DescriptionAttribute("The interactive style applied to WebCombo's TextBox.")]
public: __property ISNet.WebUI.DynamicStyle* get_TextBoxStyle();
public: __property void set_TextBoxStyle(
   ISNet.WebUI.DynamicStyle* value
);
C++/CLI
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DescriptionAttribute("The interactive style applied to WebCombo's TextBox.")]
public:
property ISNet.WebUI.DynamicStyle^ TextBoxStyle {
   ISNet.WebUI.DynamicStyle^ get();
   void set (    ISNet.WebUI.DynamicStyle^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Set combo's alignment to be right displayed

Concepts

Improved Layout


TextSettings Property

[image]
Intersoft WebCombo Documentation
TextSettings Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : TextSettings Property

Represents a TextSet object which contains text used in WebCombo control.

Represents a TextSet object which contains text used in WebCombo control.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Represents a TextSet object")>
<ISNet.Serialization.XmlSerializableAttribute()>
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property TextSettings As TextSet
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As TextSet

instance.TextSettings = value

value = instance.TextSettings
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Represents a TextSet object")]
[ISNet.Serialization.XmlSerializableAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public TextSet TextSettings {get; set;}
Delphi
public read-write property TextSettings: TextSet;
JScript
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
DescriptionAttribute("Represents a TextSet object")
ISNet.Serialization.XmlSerializableAttribute()
PersistenceModeAttribute(PersistenceMode.InnerProperty)
DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set TextSettings : TextSet
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Represents a TextSet object")]
[ISNet.Serialization.XmlSerializableAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property TextSet* get_TextSettings();
public: __property void set_TextSettings(
   TextSet* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Represents a TextSet object")]
[ISNet.Serialization.XmlSerializableAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property TextSet^ TextSettings {
   TextSet^ get();
   void set (    TextSet^ value);
}

Remarks

Using this property you can modify the default text settings. The combo-level TextSettings customization is the lowest level which will override the definition in default xml language file as well as custom defined language file. This provides flexibility to developers who wanted to customize specific TextItem that applicable to a combo instance only. Note that all properties in TextSettings should be removed in order for the new combo to work properly.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Concepts

All-new, sleeker User Interface
Text Settings


XhtmlSearchImage Property

[image]
Intersoft WebCombo Documentation
XhtmlSearchImage Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LayoutSet Class : XhtmlSearchImage Property

Specifies the image file name used to render the search button's arrow. This property is designed to be used in XHTML document and applies to Mozilla browsers. Specifies the image file name used to render the search button's arrow. This property is designed to be used in XHTML document and applies to Mozilla browsers.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Specifies the image file name used to render the search button's arrow. This property is designed to be used in XHTML document and applies to Mozilla browsers.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
Public Property XhtmlSearchImage As String
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As String

instance.XhtmlSearchImage = value

value = instance.XhtmlSearchImage
C#
[DescriptionAttribute("Specifies the image file name used to render the search button's arrow. This property is designed to be used in XHTML document and applies to Mozilla browsers.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public string XhtmlSearchImage {get; set;}
Delphi
public read-write property XhtmlSearchImage: String;
JScript
DescriptionAttribute("Specifies the image file name used to render the search button's arrow. This property is designed to be used in XHTML document and applies to Mozilla browsers.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
DefaultValueAttribute()
public function get,set XhtmlSearchImage : String
Managed Extensions for C++
[DescriptionAttribute("Specifies the image file name used to render the search button's arrow. This property is designed to be used in XHTML document and applies to Mozilla browsers.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public: __property string* get_XhtmlSearchImage();
public: __property void set_XhtmlSearchImage(
   string* value
);
C++/CLI
[DescriptionAttribute("Specifies the image file name used to render the search button's arrow. This property is designed to be used in XHTML document and applies to Mozilla browsers.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public:
property String^ XhtmlSearchImage {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSet Class
LayoutSet Members

Tasks

How-to: Define XHTML search image

Concepts

All-new, sleeker User Interface
User Interface Elements


LinkSettings Class

[image]
Intersoft WebCombo Documentation
LinkSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : LinkSettings Class

LinkSettings class provides information about WebCombo links configurations. LinkSettings class provides information about WebCombo links configurations.

Object Model

LinkSettings Class

Syntax

Visual Basic (Declaration)
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<SerializableAttribute()>
Public NotInheritable Class LinkSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As LinkSettings
C#
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[SerializableAttribute()]
public sealed class LinkSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class LinkSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)sealed;
JScript
PersistenceModeAttribute(PersistenceMode.InnerProperty)
SerializableAttribute()
public sealed class LinkSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[SerializableAttribute()]
public __gc __sealed class LinkSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[SerializableAttribute()]
public ref class LinkSettings sealed : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Remarks

LinkSettings allow users to configure one WebCombo to be dependent on another WebCombo without writing any line of codes. The WebCombo instances which have LinkSettings Enabled should be set in Bound mode, as its datasource will be automatically filtered based on the value entered in specified ParentWebComboID. This feature supports most scenarios from basic single dependency scenario to combined dependencies scenario. Developers can also write their custom codes in order to use their own filtering algorithm for advanced LoadOnDemand scenario

The Linked WebCombo feature supports following scenarios:

  1. Single dependency mode. This is the most common scenario in web application, where one WebCombo should depend on the value of another WebCombo. It involves only one-to-one relation between one WebCombo and another. The most common scenario is such as the relations between Division, Manager and Staff.
  2. Multiple dependency mode. This mode allows you to configure a WebCombo to be dependent to more than one WebCombo. The users are then required to fill the specified Parent WebCombo(s) first prior to be able to select a value in the linked combo. For example, Supplier list that based on ProductCategory and City. Both ProductCategory and City are independent and not linked. However, the Supplier list requires both ProductCategory and City to be filled prior to be able to select a Supplier.
  3. Combined dependency mode. In this advanced scenarios, an array of WebCombo instances can be linked in several ways, some of them could be linked using Single dependency mode, and others can be linked using Multiple dependency. Combined scenario is the combination of single and multiple dependencies scenario in order to create an array of linked WebCombo instances, where one WebCombo is dependent to another WebCombo and another WebCombo is dependent to one or more than one other instances. One common scenario for the combined mode is similar to following, where Vehicle input requires VehicleType to be filled first, next the available dealers is dependent to VehicleType and Dealer input. These links between single and multiple dependencies creates an array of linked WebCombo named Combined Dependencies. Dealer and Models are configured in Bound mode, and others in Unbound mode to demonstrate more advanced scenario.
  4. Unbound mode. The LinkedWebCombo feature supports Unbound mode specifically. You can define LinkSettings in the similar way as in Bound mode, and have the linked WebCombo filtered in the client side automatically.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebCombo.LinkSettings

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkSettings Members
ISNet.WebUI.WebCombo Namespace

Tasks

How-to: Use combined dependencies linked WebCombo
How-to: Use multiple dependencies linked WebCombo
How-to: Use single dependencies linked WebCombo
How-to: Use unbound linked WebCombo

Concepts

Linked WebCombo

Other Resources

Unbound Mode


LinkSettings Class Members

[image]
Intersoft WebCombo Documentation
LinkSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebCombo Namespace : LinkSettings Class

The following tables list the members exposed by LinkSettings.

Public Constructors

 | Name | Description
public Constructor | LinkSettings Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | Enabled | Gets or sets whether the link feature should be enabled for this WebCombo instance. Gets or sets whether the link feature should be enabled for this WebCombo instance.
public Property | FilterDataMember | Gets or sets the data member within the DataSource which should be used for filtering during automatic lookup. Gets or sets the data member within the DataSource which should be used for filtering during automatic lookup.
public Property | FilterMemberDataType |
public Property | ParentEmptyAction | Gets or sets the action to be performed when the user requests data for this WebCombo instance, but the specified ParentWebCombo(s) are still empty (no value selected). Gets or sets the action to be performed when the user requests data for this WebCombo instance, but the specified ParentWebCombo(s) are still empty (no value selected).
public Property | ParentFilterMode | Gets or sets which key field of the parent WebCombo that should be used for filtering this WebCombo data. Gets or sets which key field of the parent WebCombo that should be used for filtering this WebCombo data.
public Property | ParentWebComboID | Gets or sets the parent WebCombo's ID which this instance should be linked to. Gets or sets the parent WebCombo's ID which this instance should be linked to.
public Property | SkipQueryTextField | Gets or sets a value indicating whether WebCombo should query the text based on the DataTextField. Gets or sets a value indicating whether WebCombo should query the text based on the DataTextField.
Top

Public Methods

 | Name | Description
public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | GetObjectData | Overridden.
public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

LinkSettings Class
ISNet.WebUI.WebCombo Namespace


LinkSettings Constructor

[image]
Intersoft WebCombo Documentation
LinkSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LinkSettings Class : LinkSettings Constructor

Initializes a new instance of the LinkSettings class.

Overload List

Overload | Description
LinkSettings Constructor() | Initializes a new instance of the LinkSettings class with no argument.
LinkSettings Constructor(SerializationInfo,StreamingContext) | Initializes a new instance of the LinkSettings class with SerializationInfo and StreamingContext.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkSettings Class
LinkSettings Members


LinkSettings Constructor()

[image]
Intersoft WebCombo Documentation
LinkSettings Constructor()
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LinkSettings Class > LinkSettings Constructor : LinkSettings Constructor()

Initializes a new instance of the LinkSettings class with no argument.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New LinkSettings()
C#
public LinkSettings()
Delphi
public LinkSettings();
JScript
public function LinkSettings();
Managed Extensions for C++
public: LinkSettings();
C++/CLI
public:
LinkSettings();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkSettings Class
LinkSettings Members
Overload List


LinkSettings Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebCombo Documentation
LinkSettings Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LinkSettings Class > LinkSettings Constructor : LinkSettings Constructor(SerializationInfo,StreamingContext)

info
context
Initializes a new instance of the LinkSettings class with SerializationInfo and StreamingContext.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As New LinkSettings(info, context)
C#
public LinkSettings(
   SerializationInfo info,
   StreamingContext context
)
Delphi
public LinkSettings(
    info: SerializationInfo;
    context: StreamingContext
);
JScript
public function LinkSettings(
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: LinkSettings(
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
public:
LinkSettings(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkSettings Class
LinkSettings Members
Overload List


Clone Method

[image]
Intersoft WebCombo Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LinkSettings Class : Clone Method

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As LinkSettings
Dim value As Object

value = instance.Clone()
C#
public object Clone()
Delphi
public function Clone(): TObject;
JScript
public function Clone() : Object;
Managed Extensions for C++
public: Object* Clone();
C++/CLI
public:
Object^ Clone();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkSettings Class
LinkSettings Members


CopyFrom Method

[image]
Intersoft WebCombo Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LinkSettings Class : CopyFrom Method

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkSettings Class
LinkSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebCombo Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LinkSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As LinkSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public void CopyFrom(
   object objSource
)
Delphi
public procedure CopyFrom(
    objSource: TObject
);
JScript
public function CopyFrom(
   objSource : Object
);
Managed Extensions for C++
public: void CopyFrom(
   Object* objSource
)
C++/CLI
public:
void CopyFrom(
   Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkSettings Class
LinkSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebCombo Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LinkSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As LinkSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public void CopyFrom(
   object objSource,
   bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: TObject;
    cloneSourceValue: Boolean
);
JScript
public function CopyFrom(
   objSource : Object,
   cloneSourceValue : boolean
);
Managed Extensions for C++
public: void CopyFrom(
   Object* objSource,
   bool cloneSourceValue
)
C++/CLI
public:
void CopyFrom(
   Object^ objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkSettings Class
LinkSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebCombo Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LinkSettings Class : DeSerializeObjectData Method

type
info
context

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As LinkSettings
Dim type As Type
Dim info As SerializationInfo
Dim context As StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: Type;
    info: SerializationInfo;
    context: StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : Type,
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   Type* type,
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   Type^ type,
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkSettings Class
LinkSettings Members


LinkSettings Class Methods

[image]
Intersoft WebCombo Documentation
LinkSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : LinkSettings Class

For a list of all members of this type, see LinkSettings members.

Public Methods

 | Name | Description
public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | GetObjectData | Overridden.
public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

LinkSettings Class
ISNet.WebUI.WebCombo Namespace


GetObjectData Method

[image]
Intersoft WebCombo Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LinkSettings Class : GetObjectData Method

info
context

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As LinkSettings
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: SerializationInfo;
    context: StreamingContext
); override;
JScript
public override function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkSettings Class
LinkSettings Members


IsEmpty Method

[image]
Intersoft WebCombo Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LinkSettings Class : IsEmpty Method

Syntax

Visual Basic (Declaration)
Public Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LinkSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public bool IsEmpty()
Delphi
public function IsEmpty(): Boolean;
JScript
public function IsEmpty() : boolean;
Managed Extensions for C++
public: bool IsEmpty();
C++/CLI
public:
bool IsEmpty();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkSettings Class
LinkSettings Members


Reset Method

[image]
Intersoft WebCombo Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LinkSettings Class : Reset Method

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As LinkSettings

instance.Reset()
C#
public void Reset()
Delphi
public procedure Reset();
JScript
public function Reset();
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkSettings Class
LinkSettings Members


SerializeObjectData Method

[image]
Intersoft WebCombo Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LinkSettings Class : SerializeObjectData Method

type
info
context

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As LinkSettings
Dim type As Type
Dim info As SerializationInfo
Dim context As StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: Type;
    info: SerializationInfo;
    context: StreamingContext
);
JScript
public function SerializeObjectData(
   type : Type,
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   Type* type,
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   Type^ type,
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkSettings Class
LinkSettings Members


LinkSettings Class Properties

[image]
Intersoft WebCombo Documentation
LinkSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : LinkSettings Class

For a list of all members of this type, see LinkSettings members.

Public Properties

 | Name | Description
public Property | Enabled | Gets or sets whether the link feature should be enabled for this WebCombo instance. Gets or sets whether the link feature should be enabled for this WebCombo instance.
public Property | FilterDataMember | Gets or sets the data member within the DataSource which should be used for filtering during automatic lookup. Gets or sets the data member within the DataSource which should be used for filtering during automatic lookup.
public Property | FilterMemberDataType |
public Property | ParentEmptyAction | Gets or sets the action to be performed when the user requests data for this WebCombo instance, but the specified ParentWebCombo(s) are still empty (no value selected). Gets or sets the action to be performed when the user requests data for this WebCombo instance, but the specified ParentWebCombo(s) are still empty (no value selected).
public Property | ParentFilterMode | Gets or sets which key field of the parent WebCombo that should be used for filtering this WebCombo data. Gets or sets which key field of the parent WebCombo that should be used for filtering this WebCombo data.
public Property | ParentWebComboID | Gets or sets the parent WebCombo's ID which this instance should be linked to. Gets or sets the parent WebCombo's ID which this instance should be linked to.
public Property | SkipQueryTextField | Gets or sets a value indicating whether WebCombo should query the text based on the DataTextField. Gets or sets a value indicating whether WebCombo should query the text based on the DataTextField.
Top

See Also

Reference

LinkSettings Class
ISNet.WebUI.WebCombo Namespace


Enabled Property

[image]
Intersoft WebCombo Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LinkSettings Class : Enabled Property

Gets or sets whether the link feature should be enabled for this WebCombo instance. Gets or sets whether the link feature should be enabled for this WebCombo instance.

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Gets or sets whether the link feature should be enabled for this WebCombo instance.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LinkSettings
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Gets or sets whether the link feature should be enabled for this WebCombo instance.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public bool Enabled {get; set;}
Delphi
public read-write property Enabled: Boolean;
JScript
NotifyParentPropertyAttribute()
DescriptionAttribute("Gets or sets whether the link feature should be enabled for this WebCombo instance.")
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Enabled : boolean
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Gets or sets whether the link feature should be enabled for this WebCombo instance.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property bool get_Enabled();
public: __property void set_Enabled(
   bool value
);
C++/CLI
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Gets or sets whether the link feature should be enabled for this WebCombo instance.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property bool Enabled {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkSettings Class
LinkSettings Members
How-to: Use single dependencies linked WebCombo

Concepts

Linked WebCombo


FilterDataMember Property

[image]
Intersoft WebCombo Documentation
FilterDataMember Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LinkSettings Class : FilterDataMember Property

Gets or sets the data member within the DataSource which should be used for filtering during automatic lookup. Gets or sets the data member within the DataSource which should be used for filtering during automatic lookup.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Gets or sets the data member within the DataSource which should be used for filtering during automatic lookup.")>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebCombo.FieldTypeEditor, ISNet.WebUI.WebCombo, Version=5.0.7200.1, Culture=neutral, PublicKeyToken=c4184ef0d326354b")>
<DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
Public Property FilterDataMember As String
Visual Basic (Usage) Copy Code
Dim instance As LinkSettings
Dim value As String

instance.FilterDataMember = value

value = instance.FilterDataMember
C#
[DescriptionAttribute("Gets or sets the data member within the DataSource which should be used for filtering during automatic lookup.")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebCombo.FieldTypeEditor, ISNet.WebUI.WebCombo, Version=5.0.7200.1, Culture=neutral, PublicKeyToken=c4184ef0d326354b")]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public string FilterDataMember {get; set;}
Delphi
public read-write property FilterDataMember: String;
JScript
DescriptionAttribute("Gets or sets the data member within the DataSource which should be used for filtering during automatic lookup.")
EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebCombo.FieldTypeEditor, ISNet.WebUI.WebCombo, Version=5.0.7200.1, Culture=neutral, PublicKeyToken=c4184ef0d326354b")
DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
public function get,set FilterDataMember : String
Managed Extensions for C++
[DescriptionAttribute("Gets or sets the data member within the DataSource which should be used for filtering during automatic lookup.")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebCombo.FieldTypeEditor, ISNet.WebUI.WebCombo, Version=5.0.7200.1, Culture=neutral, PublicKeyToken=c4184ef0d326354b")]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public: __property string* get_FilterDataMember();
public: __property void set_FilterDataMember(
   string* value
);
C++/CLI
[DescriptionAttribute("Gets or sets the data member within the DataSource which should be used for filtering during automatic lookup.")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebCombo.FieldTypeEditor, ISNet.WebUI.WebCombo, Version=5.0.7200.1, Culture=neutral, PublicKeyToken=c4184ef0d326354b")]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public:
property String^ FilterDataMember {
   String^ get();
   void set (    String^ value);
}

Remarks

You may leave this property blank to use the same field specified in parent's WebCombo value or text field. If you need to link to multiple parent WebCombo, you can leave this property blank or specify multiple filter members separated by comma, in the appropriate order of ParentWebComboID property.

You may leave this property blank to use the same field specified in parent's WebCombo value or text field. If you need to link to multiple parent WebCombo, you can leave this property blank or specify multiple filter members separated by comma, in the appropriate order of ParentWebComboID property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkSettings Class
LinkSettings Members

Tasks

How-to: Implement linked WebCombo functionality using column that is not DataTextField or DataValueField as the FilterDataMember
How-to: Use multiple dependencies linked WebCombo
How-to: Use unbound linked WebCombo
How-to: Use combined dependencies linked WebCombo

Concepts

Linked WebCombo


FilterMemberDataType Property

[image]
Intersoft WebCombo Documentation
FilterMemberDataType Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LinkSettings Class : FilterMemberDataType Property

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Gets or sets the data type of the specified filter data member. This property is required when the BindingOperation is set to Client.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
Public Property FilterMemberDataType As String
Visual Basic (Usage) Copy Code
Dim instance As LinkSettings
Dim value As String

instance.FilterMemberDataType = value

value = instance.FilterMemberDataType
C#
[DescriptionAttribute("Gets or sets the data type of the specified filter data member. This property is required when the BindingOperation is set to Client.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
public string FilterMemberDataType {get; set;}
Delphi
public read-write property FilterMemberDataType: String;
JScript
DescriptionAttribute("Gets or sets the data type of the specified filter data member. This property is required when the BindingOperation is set to Client.")
ISNet.Serialization.XmlSerializableAttribute()
NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
public function get,set FilterMemberDataType : String
Managed Extensions for C++
[DescriptionAttribute("Gets or sets the data type of the specified filter data member. This property is required when the BindingOperation is set to Client.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
public: __property string* get_FilterMemberDataType();
public: __property void set_FilterMemberDataType(
   string* value
);
C++/CLI
[DescriptionAttribute("Gets or sets the data type of the specified filter data member. This property is required when the BindingOperation is set to Client.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
public:
property String^ FilterMemberDataType {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkSettings Class
LinkSettings Members


ParentEmptyAction Property

[image]
Intersoft WebCombo Documentation
ParentEmptyAction Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LinkSettings Class : ParentEmptyAction Property

Gets or sets the action to be performed when the user requests data for this WebCombo instance, but the specified ParentWebCombo(s) are still empty (no value selected). Gets or sets the action to be performed when the user requests data for this WebCombo instance, but the specified ParentWebCombo(s) are still empty (no value selected).

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Gets or sets the action to be performed when the user requests data for this WebCombo instance, but the specified ParentWebCombo(s) are still empty (no value selected).")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
Public Property ParentEmptyAction As EmptyAction
Visual Basic (Usage) Copy Code
Dim instance As LinkSettings
Dim value As EmptyAction

instance.ParentEmptyAction = value

value = instance.ParentEmptyAction
C#
[DescriptionAttribute("Gets or sets the action to be performed when the user requests data for this WebCombo instance, but the specified ParentWebCombo(s) are still empty (no value selected).")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public EmptyAction ParentEmptyAction {get; set;}
Delphi
public read-write property ParentEmptyAction: EmptyAction;
JScript
DescriptionAttribute("Gets or sets the action to be performed when the user requests data for this WebCombo instance, but the specified ParentWebCombo(s) are still empty (no value selected).")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
DefaultValueAttribute()
public function get,set ParentEmptyAction : EmptyAction
Managed Extensions for C++
[DescriptionAttribute("Gets or sets the action to be performed when the user requests data for this WebCombo instance, but the specified ParentWebCombo(s) are still empty (no value selected).")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public: __property EmptyAction get_ParentEmptyAction();
public: __property void set_ParentEmptyAction(
   EmptyAction value
);
C++/CLI
[DescriptionAttribute("Gets or sets the action to be performed when the user requests data for this WebCombo instance, but the specified ParentWebCombo(s) are still empty (no value selected).")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public:
property EmptyAction ParentEmptyAction {
   EmptyAction get();
   void set (    EmptyAction value);
}

Remarks

By default, the value of this property is PromptMessage where the combo will prompt a message if the ParentWebCombo contains no value. If you set this property to ShowEmptyResult, the combo will show empty result when the ParentWebCombo contains no value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkSettings Class
LinkSettings Members

Concepts

Linked WebCombo


ParentFilterMode Property

[image]
Intersoft WebCombo Documentation
ParentFilterMode Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LinkSettings Class : ParentFilterMode Property

Gets or sets which key field of the parent WebCombo that should be used for filtering this WebCombo data. Gets or sets which key field of the parent WebCombo that should be used for filtering this WebCombo data.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Gets or sets which key field of the parent WebCombo that should be used for filtering this WebCombo data.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
Public Property ParentFilterMode As ParentFilterMode
Visual Basic (Usage) Copy Code
Dim instance As LinkSettings
Dim value As ParentFilterMode

instance.ParentFilterMode = value

value = instance.ParentFilterMode
C#
[DescriptionAttribute("Gets or sets which key field of the parent WebCombo that should be used for filtering this WebCombo data.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
public ParentFilterMode ParentFilterMode {get; set;}
Delphi
public read-write property ParentFilterMode: ParentFilterMode;
JScript
DescriptionAttribute("Gets or sets which key field of the parent WebCombo that should be used for filtering this WebCombo data.")
ISNet.Serialization.XmlSerializableAttribute()
NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
public function get,set ParentFilterMode : ParentFilterMode
Managed Extensions for C++
[DescriptionAttribute("Gets or sets which key field of the parent WebCombo that should be used for filtering this WebCombo data.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
public: __property ParentFilterMode get_ParentFilterMode();
public: __property void set_ParentFilterMode(
   ParentFilterMode value
);
C++/CLI
[DescriptionAttribute("Gets or sets which key field of the parent WebCombo that should be used for filtering this WebCombo data.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
public:
property ParentFilterMode ParentFilterMode {
   ParentFilterMode get();
   void set (    ParentFilterMode value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkSettings Class
LinkSettings Members

Concepts

Linked WebCombo


ParentWebComboID Property

[image]
Intersoft WebCombo Documentation
ParentWebComboID Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LinkSettings Class : ParentWebComboID Property

Gets or sets the parent WebCombo's ID which this instance should be linked to. Gets or sets the parent WebCombo's ID which this instance should be linked to.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets the parent WebCombo's ID which this instance should be linked to.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ParentWebComboID As String
Visual Basic (Usage) Copy Code
Dim instance As LinkSettings
Dim value As String

instance.ParentWebComboID = value

value = instance.ParentWebComboID
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the parent WebCombo's ID which this instance should be linked to.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public string ParentWebComboID {get; set;}
Delphi
public read-write property ParentWebComboID: String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
DefaultValueAttribute()
DescriptionAttribute("Gets or sets the parent WebCombo's ID which this instance should be linked to.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ParentWebComboID : String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the parent WebCombo's ID which this instance should be linked to.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property string* get_ParentWebComboID();
public: __property void set_ParentWebComboID(
   string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the parent WebCombo's ID which this instance should be linked to.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property String^ ParentWebComboID {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkSettings Class
LinkSettings Members

Concepts

Linked WebCombo

Tasks

How-to: Use combined dependencies linked WebCombo
How-to: Use multiple dependencies linked WebCombo


SkipQueryTextField Property

[image]
Intersoft WebCombo Documentation
SkipQueryTextField Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > LinkSettings Class : SkipQueryTextField Property

Gets or sets a value indicating whether WebCombo should query the text based on the DataTextField. Gets or sets a value indicating whether WebCombo should query the text based on the DataTextField.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<DescriptionAttribute("Gets or sets a value indicating whether WebCombo should query the text based on the DataTextField. ")>
Public Property SkipQueryTextField As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LinkSettings
Dim value As Boolean

instance.SkipQueryTextField = value

value = instance.SkipQueryTextField
C#
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether WebCombo should query the text based on the DataTextField. ")]
public bool SkipQueryTextField {get; set;}
Delphi
public read-write property SkipQueryTextField: Boolean;
JScript
DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
DescriptionAttribute("Gets or sets a value indicating whether WebCombo should query the text based on the DataTextField. ")
public function get,set SkipQueryTextField : boolean
Managed Extensions for C++
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether WebCombo should query the text based on the DataTextField. ")]
public: __property bool get_SkipQueryTextField();
public: __property void set_SkipQueryTextField(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Gets or sets a value indicating whether WebCombo should query the text based on the DataTextField. ")]
public:
property bool SkipQueryTextField {
   bool get();
   void set (    bool value);
}

Remarks

You can set this property to True when you don't want the WebCombo to be filtered by the entered text. This is especially useful when the DataTextField is not a String type, where WebCombo can't effectively perform automatic lookup. In this scenario, oftenly the WebCombo is ReadOnly (not Editable) and user simply pick a selection from the ResultBox. You can set this property to True when you don't want the WebCombo to be filtered by the entered text. This is especially useful when the DataTextField is not a String type, where WebCombo can't effectively perform automatic lookup. In this scenario, oftenly the WebCombo is ReadOnly (not Editable) and user simply pick a selection from the ResultBox.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkSettings Class
LinkSettings Members

Concepts

Linked WebCombo


MultipleSelectionSettings Class

[image]
Intersoft WebCombo Documentation
MultipleSelectionSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : MultipleSelectionSettings Class

Provides advanced settings related to the MultipleSelection feature.

Object Model

MultipleSelectionSettings Class

Syntax

Visual Basic (Declaration)
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<DescriptionAttribute("Provides settings for multiple selections.")>
<SerializableAttribute()>
Public Class MultipleSelectionSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As MultipleSelectionSettings
C#
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DescriptionAttribute("Provides settings for multiple selections.")]
[SerializableAttribute()]
public class MultipleSelectionSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class MultipleSelectionSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
PersistenceModeAttribute(PersistenceMode.InnerProperty)
DescriptionAttribute("Provides settings for multiple selections.")
SerializableAttribute()
public class MultipleSelectionSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DescriptionAttribute("Provides settings for multiple selections.")]
[SerializableAttribute()]
public __gc class MultipleSelectionSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DescriptionAttribute("Provides settings for multiple selections.")]
[SerializableAttribute()]
public ref class MultipleSelectionSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Remarks

WebCombo.NET includes numerous advanced settings related to the MultipleSelection feature. These settings can be found in MultipleSelectionSettings object that contains all information about the MultipleSelection feature.

WebCombo.NET's MultipleSelection feature is designed to be very easy-to-use for end users while entering multiple values. Beside the advanced features in MultipleSelectionSettings, the feature includes numerous behaviors as you can explore as in following:

1. Data Input. There are several methods to accept an item, such as:
Using Keyboard. Valid built-in keystrokes are Tab, Enter and the character specified in SeparatorChar property. The above keys will be used to accept the selected item only when the ResultBox is shown. This will result in better consistency so that when the users have finished the input, they can hit Tab again to go to next field.
Using Mouse. When the resultbox is in open state, you can select the item by clicking your left mouse's button. WebCombo.NET will automatically position the cursor for next item input.

2. Navigation. WebCombo.NET allows you to easily navigate between items. You can use keyboard left and right arrow keys to navigate to previous and next items. WebCombo.NET will automatically determine entered valid items and set the cursor position accordingly.

3. Highlight. WebCombo.NET enables end-users to easily select an item among multiple values by clicking the region of valid item. When the clicked item is valid (it has Value content), the item will be highlighted similarly as in Outlook® 2003 textbox feature.

4. Item Deletion. To delete items, you can use keyboard DELETE and BACKSPACE key. WebCombo.NET will intelligently detects every tokens in the cursor position and delete the previous item when BACKSPACE is pressed. It will delete next item when DELETE key is pressed. WebCombo.NET will also automatically determine the current context when pressing these keys, e.g. whether the user is in editing mode or in selection mode. Editing mode is indicated when ResultBox is shown and the item is not valid yet.

5. Item Insertion. The MultipleSelection feature even allow users to insert an item. This can be easily done by placing the cursor in the position you want to insert, then start typing and press Tab to select an item. The new item will then be inserted properly among other values.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebCombo.MultipleSelectionSettings

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MultipleSelectionSettings Members
ISNet.WebUI.WebCombo Namespace

Concepts

Multiple Selection

Tasks

How-to: Use bound multiple selection WebCombo
How-to: Use unbound multiple selection WebCombo
How-to: Set initial value of multiple selection WebCombo from server side


MultipleSelectionSettings Class Members

[image]
Intersoft WebCombo Documentation
MultipleSelectionSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebCombo Namespace : MultipleSelectionSettings Class

The following tables list the members exposed by MultipleSelectionSettings.

Public Constructors

 | Name | Description
public Constructor | MultipleSelectionSettings Constructor |
Top

Public Properties

 | Name | Description
public Property | AllowBrowseAll | Gets or sets whether WebCombo should allow the user to browse all list by pressing Ctrl Space key. Gets or sets whether WebCombo should allow the user to browse all list by pressing Ctrl Space key.
public Property | AllowNotInListText | Gets or sets whether WebCombo should accept text which is not appear in the list. Gets or sets whether WebCombo should accept text which is not appear in the list.
public Property | AutoPositionResultBox | Gets or sets whether the ResultBox position should be automatically positioned beneath the cursor position. Gets or sets whether the ResultBox position should be automatically positioned beneath the cursor position.
public Property | AutoSelectFirstMatch | Gets or sets whether WebCombo should automatically select first row of matched items against input Text. Gets or sets whether WebCombo should automatically select first row of matched items against input Text.
public Property | Enabled | Gets or sets whether multiple selections feature should be enabled. Gets or sets whether multiple selections feature should be enabled.
public Property | HideResultBoxOnEmptyResult |
public Property | ItemContextMenu | Gets or sets the Intersoft WebContextMenu object to be displayed when right clicking an item. Gets or sets the Intersoft WebContextMenu object to be displayed when right clicking an item.
public Property | SeparatorChar | Gets or sets the separator character used to separate multiple values in the textbox. Gets or sets the separator character used to separate multiple values in the textbox.
Top

Public Methods

 | Name | Description
public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | GetObjectData | Overridden.
public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

MultipleSelectionSettings Class
ISNet.WebUI.WebCombo Namespace


MultipleSelectionSettings Constructor

[image]
Intersoft WebCombo Documentation
MultipleSelectionSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > MultipleSelectionSettings Class : MultipleSelectionSettings Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New MultipleSelectionSettings()
C#
public MultipleSelectionSettings()
Delphi
public MultipleSelectionSettings();
JScript
public function MultipleSelectionSettings();
Managed Extensions for C++
public: MultipleSelectionSettings();
C++/CLI
public:
MultipleSelectionSettings();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MultipleSelectionSettings Class
MultipleSelectionSettings Members


Clone Method

[image]
Intersoft WebCombo Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > MultipleSelectionSettings Class : Clone Method

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As MultipleSelectionSettings
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()
Delphi
public function Clone(): TObject; virtual;
JScript
public function Clone() : Object;
Managed Extensions for C++
public: virtual Object* Clone();
C++/CLI
public:
virtual Object^ Clone();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MultipleSelectionSettings Class
MultipleSelectionSettings Members


CopyFrom Method

[image]
Intersoft WebCombo Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > MultipleSelectionSettings Class : CopyFrom Method

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MultipleSelectionSettings Class
MultipleSelectionSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebCombo Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > MultipleSelectionSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As MultipleSelectionSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)
Delphi
public procedure CopyFrom(
    objSource: TObject
); virtual;
JScript
public function CopyFrom(
   objSource : Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MultipleSelectionSettings Class
MultipleSelectionSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebCombo Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > MultipleSelectionSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As MultipleSelectionSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: TObject;
    cloneSourceValue: Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : Object,
   cloneSourceValue : boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   Object* objSource,
   bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   Object^ objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MultipleSelectionSettings Class
MultipleSelectionSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebCombo Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > MultipleSelectionSettings Class : DeSerializeObjectData Method

type
info
context

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As MultipleSelectionSettings
Dim type As Type
Dim info As SerializationInfo
Dim context As StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: Type;
    info: SerializationInfo;
    context: StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : Type,
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   Type* type,
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   Type^ type,
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MultipleSelectionSettings Class
MultipleSelectionSettings Members


MultipleSelectionSettings Class Methods

[image]
Intersoft WebCombo Documentation
MultipleSelectionSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : MultipleSelectionSettings Class

For a list of all members of this type, see MultipleSelectionSettings members.

Public Methods

 | Name | Description
public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | GetObjectData | Overridden.
public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

MultipleSelectionSettings Class
ISNet.WebUI.WebCombo Namespace


GetObjectData Method

[image]
Intersoft WebCombo Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > MultipleSelectionSettings Class : GetObjectData Method

info
context

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As MultipleSelectionSettings
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: SerializationInfo;
    context: StreamingContext
); override;
JScript
public override function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MultipleSelectionSettings Class
MultipleSelectionSettings Members


IsEmpty Method

[image]
Intersoft WebCombo Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > MultipleSelectionSettings Class : IsEmpty Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MultipleSelectionSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()
Delphi
public function IsEmpty(): Boolean; virtual;
JScript
public function IsEmpty() : boolean;
Managed Extensions for C++
public: virtual bool IsEmpty();
C++/CLI
public:
virtual bool IsEmpty();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MultipleSelectionSettings Class
MultipleSelectionSettings Members


Reset Method

[image]
Intersoft WebCombo Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > MultipleSelectionSettings Class : Reset Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As MultipleSelectionSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MultipleSelectionSettings Class
MultipleSelectionSettings Members


SerializeObjectData Method

[image]
Intersoft WebCombo Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > MultipleSelectionSettings Class : SerializeObjectData Method

type
info
context

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As MultipleSelectionSettings
Dim type As Type
Dim info As SerializationInfo
Dim context As StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: Type;
    info: SerializationInfo;
    context: StreamingContext
);
JScript
public function SerializeObjectData(
   type : Type,
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   Type* type,
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   Type^ type,
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MultipleSelectionSettings Class
MultipleSelectionSettings Members


MultipleSelectionSettings Class Properties

[image]
Intersoft WebCombo Documentation
MultipleSelectionSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : MultipleSelectionSettings Class

For a list of all members of this type, see MultipleSelectionSettings members.

Public Properties

 | Name | Description
public Property | AllowBrowseAll | Gets or sets whether WebCombo should allow the user to browse all list by pressing Ctrl Space key. Gets or sets whether WebCombo should allow the user to browse all list by pressing Ctrl Space key.
public Property | AllowNotInListText | Gets or sets whether WebCombo should accept text which is not appear in the list. Gets or sets whether WebCombo should accept text which is not appear in the list.
public Property | AutoPositionResultBox | Gets or sets whether the ResultBox position should be automatically positioned beneath the cursor position. Gets or sets whether the ResultBox position should be automatically positioned beneath the cursor position.
public Property | AutoSelectFirstMatch | Gets or sets whether WebCombo should automatically select first row of matched items against input Text. Gets or sets whether WebCombo should automatically select first row of matched items against input Text.
public Property | Enabled | Gets or sets whether multiple selections feature should be enabled. Gets or sets whether multiple selections feature should be enabled.
public Property | HideResultBoxOnEmptyResult |
public Property | ItemContextMenu | Gets or sets the Intersoft WebContextMenu object to be displayed when right clicking an item. Gets or sets the Intersoft WebContextMenu object to be displayed when right clicking an item.
public Property | SeparatorChar | Gets or sets the separator character used to separate multiple values in the textbox. Gets or sets the separator character used to separate multiple values in the textbox.
Top

See Also

Reference

MultipleSelectionSettings Class
ISNet.WebUI.WebCombo Namespace


MultipleSelectionSettings Constructor

[image]
Intersoft WebCombo Documentation
MultipleSelectionSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > MultipleSelectionSettings Class : MultipleSelectionSettings Constructor

Initializes a new instance of the MultipleSelectionSettings class.

Overload List

Overload | Description
MultipleSelectionSettings Constructor |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MultipleSelectionSettings Class
MultipleSelectionSettings Members


AllowBrowseAll Property

[image]
Intersoft WebCombo Documentation
AllowBrowseAll Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > MultipleSelectionSettings Class : AllowBrowseAll Property

Gets or sets whether WebCombo should allow the user to browse all list by pressing Ctrl Space key. Gets or sets whether WebCombo should allow the user to browse all list by pressing Ctrl Space key.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Gets or sets whether WebCombo should allow the user to browse all list by pressing Ctrl Space key.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
Public Property AllowBrowseAll As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MultipleSelectionSettings
Dim value As Boolean

instance.AllowBrowseAll = value

value = instance.AllowBrowseAll
C#
[DescriptionAttribute("Gets or sets whether WebCombo should allow the user to browse all list by pressing Ctrl Space key.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public bool AllowBrowseAll {get; set;}
Delphi
public read-write property AllowBrowseAll: Boolean;
JScript
DescriptionAttribute("Gets or sets whether WebCombo should allow the user to browse all list by pressing Ctrl Space key.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
DefaultValueAttribute()
public function get,set AllowBrowseAll : boolean
Managed Extensions for C++
[DescriptionAttribute("Gets or sets whether WebCombo should allow the user to browse all list by pressing Ctrl Space key.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public: __property bool get_AllowBrowseAll();
public: __property void set_AllowBrowseAll(
   bool value
);
C++/CLI
[DescriptionAttribute("Gets or sets whether WebCombo should allow the user to browse all list by pressing Ctrl Space key.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public:
property bool AllowBrowseAll {
   bool get();
   void set (    bool value);
}

Remarks

When this property is set to True, you can list all items by pressing Ctrl+Space. Note that when the MultipleSelection property is Enabled and the TextBoxMode property is Editable, the DropDownButton will be disabled and invisible.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MultipleSelectionSettings Class
MultipleSelectionSettings Members


AllowNotInListText Property

[image]
Intersoft WebCombo Documentation
AllowNotInListText Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > MultipleSelectionSettings Class : AllowNotInListText Property

Gets or sets whether WebCombo should accept text which is not appear in the list. Gets or sets whether WebCombo should accept text which is not appear in the list.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets whether WebCombo should accept text which is not appear in the list.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property AllowNotInListText As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MultipleSelectionSettings
Dim value As Boolean

instance.AllowNotInListText = value

value = instance.AllowNotInListText
C#
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets whether WebCombo should accept text which is not appear in the list.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public bool AllowNotInListText {get; set;}
Delphi
public read-write property AllowNotInListText: Boolean;
JScript
DefaultValueAttribute()
DescriptionAttribute("Gets or sets whether WebCombo should accept text which is not appear in the list.")
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set AllowNotInListText : boolean
Managed Extensions for C++
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets whether WebCombo should accept text which is not appear in the list.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property bool get_AllowNotInListText();
public: __property void set_AllowNotInListText(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets whether WebCombo should accept text which is not appear in the list.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property bool AllowNotInListText {
   bool get();
   void set (    bool value);
}

Remarks

This setting allows the user to input text which is not listed in the ResultBox. You should handle the OnValueItemNotInList client-side event to determine how the item should be treated.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MultipleSelectionSettings Class
MultipleSelectionSettings Members


AutoPositionResultBox Property

[image]
Intersoft WebCombo Documentation
AutoPositionResultBox Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > MultipleSelectionSettings Class : AutoPositionResultBox Property

Gets or sets whether the ResultBox position should be automatically positioned beneath the cursor position.

Gets or sets whether the ResultBox position should be automatically positioned beneath the cursor position.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets whether the ResultBox position should be automatically positioned beneath the cursor position.")>
Public Property AutoPositionResultBox As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MultipleSelectionSettings
Dim value As Boolean

instance.AutoPositionResultBox = value

value = instance.AutoPositionResultBox
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets whether the ResultBox position should be automatically positioned beneath the cursor position.")]
public bool AutoPositionResultBox {get; set;}
Delphi
public read-write property AutoPositionResultBox: Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
DescriptionAttribute("Gets or sets whether the ResultBox position should be automatically positioned beneath the cursor position.")
public function get,set AutoPositionResultBox : boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets whether the ResultBox position should be automatically positioned beneath the cursor position.")]
public: __property bool get_AutoPositionResultBox();
public: __property void set_AutoPositionResultBox(
   bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets whether the ResultBox position should be automatically positioned beneath the cursor position.")]
public:
property bool AutoPositionResultBox {
   bool get();
   void set (    bool value);
}

Remarks

When this property is set to True, the ResultBox location will be automatically positioned beneath the cursor position.

This property is only applicable for Editable mode, that is TextBoxMode is set to Editable.

This property is only applicable for Editable mode, that is TextBoxMode is set to Editable.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MultipleSelectionSettings Class
MultipleSelectionSettings Members


AutoSelectFirstMatch Property

[image]
Intersoft WebCombo Documentation
AutoSelectFirstMatch Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > MultipleSelectionSettings Class : AutoSelectFirstMatch Property

Gets or sets whether WebCombo should automatically select first row of matched items against input Text.

Gets or sets whether WebCombo should automatically select first row of matched items against input Text.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Gets or sets whether WebCombo should automatically select first row of matched items against input Text.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AutoSelectFirstMatch As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MultipleSelectionSettings
Dim value As Boolean

instance.AutoSelectFirstMatch = value

value = instance.AutoSelectFirstMatch
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Gets or sets whether WebCombo should automatically select first row of matched items against input Text.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public bool AutoSelectFirstMatch {get; set;}
Delphi
public read-write property AutoSelectFirstMatch: Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
DefaultValueAttribute()
NotifyParentPropertyAttribute()
DescriptionAttribute("Gets or sets whether WebCombo should automatically select first row of matched items against input Text.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AutoSelectFirstMatch : boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Gets or sets whether WebCombo should automatically select first row of matched items against input Text.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property bool get_AutoSelectFirstMatch();
public: __property void set_AutoSelectFirstMatch(
   bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Gets or sets whether WebCombo should automatically select first row of matched items against input Text.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property bool AutoSelectFirstMatch {
   bool get();
   void set (    bool value);
}

Remarks

When this property is set to True, the first row will always be highlighted. This allows a user to quickly select an item by pressing the Tab key without first having to press the Down arrow key to select.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MultipleSelectionSettings Class
MultipleSelectionSettings Members


Enabled Property

[image]
Intersoft WebCombo Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > MultipleSelectionSettings Class : Enabled Property

Gets or sets whether multiple selections feature should be enabled. Gets or sets whether multiple selections feature should be enabled.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Gets or sets whether multiple selections feature should be enabled.")>
Public Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MultipleSelectionSettings
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Gets or sets whether multiple selections feature should be enabled.")]
public bool Enabled {get; set;}
Delphi
public read-write property Enabled: Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
NotifyParentPropertyAttribute()
DescriptionAttribute("Gets or sets whether multiple selections feature should be enabled.")
public function get,set Enabled : boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Gets or sets whether multiple selections feature should be enabled.")]
public: __property bool get_Enabled();
public: __property void set_Enabled(
   bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Gets or sets whether multiple selections feature should be enabled.")]
public:
property bool Enabled {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MultipleSelectionSettings Class
MultipleSelectionSettings Members


HideResultBoxOnEmptyResult Property

[image]
Intersoft WebCombo Documentation
HideResultBoxOnEmptyResult Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > MultipleSelectionSettings Class : HideResultBoxOnEmptyResult Property

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Specifies whether result box should be hidden when search result is empty")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
Public Property HideResultBoxOnEmptyResult As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MultipleSelectionSettings
Dim value As Boolean

instance.HideResultBoxOnEmptyResult = value

value = instance.HideResultBoxOnEmptyResult
C#
[DescriptionAttribute("Specifies whether result box should be hidden when search result is empty")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public bool HideResultBoxOnEmptyResult {get; set;}
Delphi
public read-write property HideResultBoxOnEmptyResult: Boolean;
JScript
DescriptionAttribute("Specifies whether result box should be hidden when search result is empty")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
NotifyParentPropertyAttribute()
DefaultValueAttribute()
public function get,set HideResultBoxOnEmptyResult : boolean
Managed Extensions for C++
[DescriptionAttribute("Specifies whether result box should be hidden when search result is empty")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public: __property bool get_HideResultBoxOnEmptyResult();
public: __property void set_HideResultBoxOnEmptyResult(
   bool value
);
C++/CLI
[DescriptionAttribute("Specifies whether result box should be hidden when search result is empty")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public:
property bool HideResultBoxOnEmptyResult {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MultipleSelectionSettings Class
MultipleSelectionSettings Members


ItemContextMenu Property

[image]
Intersoft WebCombo Documentation
ItemContextMenu Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > MultipleSelectionSettings Class : ItemContextMenu Property

Gets or sets the Intersoft WebContextMenu object to be displayed when right clicking an item. Gets or sets the Intersoft WebContextMenu object to be displayed when right clicking an item.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets the Intersoft WebContextMenu object to be displayed when right clicking an item.")>
Public Property ItemContextMenu As Object
Visual Basic (Usage) Copy Code
Dim instance As MultipleSelectionSettings
Dim value As Object

instance.ItemContextMenu = value

value = instance.ItemContextMenu
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the Intersoft WebContextMenu object to be displayed when right clicking an item.")]
public object ItemContextMenu {get; set;}
Delphi
public read-write property ItemContextMenu: TObject;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
DefaultValueAttribute()
DescriptionAttribute("Gets or sets the Intersoft WebContextMenu object to be displayed when right clicking an item.")
public function get,set ItemContextMenu : Object
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the Intersoft WebContextMenu object to be displayed when right clicking an item.")]
public: __property Object* get_ItemContextMenu();
public: __property void set_ItemContextMenu(
   Object* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the Intersoft WebContextMenu object to be displayed when right clicking an item.")]
public:
property Object^ ItemContextMenu {
   Object^ get();
   void set (    Object^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MultipleSelectionSettings Class
MultipleSelectionSettings Members


SeparatorChar Property

[image]
Intersoft WebCombo Documentation
SeparatorChar Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > MultipleSelectionSettings Class : SeparatorChar Property

Gets or sets the separator character used to separate multiple values in the textbox. Gets or sets the separator character used to separate multiple values in the textbox.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Gets or sets the separator character used to separate multiple values in the textbox.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
Public Property SeparatorChar As String
Visual Basic (Usage) Copy Code
Dim instance As MultipleSelectionSettings
Dim value As String

instance.SeparatorChar = value

value = instance.SeparatorChar
C#
[DescriptionAttribute("Gets or sets the separator character used to separate multiple values in the textbox.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public string SeparatorChar {get; set;}
Delphi
public read-write property SeparatorChar: String;
JScript
DescriptionAttribute("Gets or sets the separator character used to separate multiple values in the textbox.")
ISNet.Serialization.XmlSerializableAttribute()
DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
public function get,set SeparatorChar : String
Managed Extensions for C++
[DescriptionAttribute("Gets or sets the separator character used to separate multiple values in the textbox.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public: __property string* get_SeparatorChar();
public: __property void set_SeparatorChar(
   string* value
);
C++/CLI
[DescriptionAttribute("Gets or sets the separator character used to separate multiple values in the textbox.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public:
property String^ SeparatorChar {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MultipleSelectionSettings Class
MultipleSelectionSettings Members


PostBackAction Class

[image]
Intersoft WebCombo Documentation
PostBackAction Class
Members See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : PostBackAction Class

Class that contains string constants for OnTheFly post back actions.

Class that contains string constants for OnTheFly post back actions.

Object Model

PostBackAction Class

Syntax

Visual Basic (Declaration)
Public Class PostBackAction
Visual Basic (Usage) Copy Code
Dim instance As PostBackAction
C#
public class PostBackAction
Delphi
public class PostBackAction
JScript
public class PostBackAction
Managed Extensions for C++
public __gc class PostBackAction
C++/CLI
public ref class PostBackAction

Remarks

The OnTheFly postback feature allows the implemented controls to interact with server and sends back only necessary UI elements, without the need to send the whole page's elements. This will save lot of the server's resources, time and bandwidth needed to perform server interaction.

The benefits of the feature are:

1. Rich and smoother user interactions.

2. Improved performance up to 50%

3. Minimized server workload.

4. Increased end users productivity.

5. True server-events processing.

6. Faster rendering and realtime response.

For more information you read OnTheFly PostBack.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebCombo.PostBackAction

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PostBackAction Members
ISNet.WebUI.WebCombo Namespace

Concepts

OnTheFly PostBack


PostBackAction Class Members

[image]
Intersoft WebCombo Documentation
PostBackAction Class Members
See Also Fields Send Feedback
ISNet.WebUI.WebCombo Namespace : PostBackAction Class

The following tables list the members exposed by PostBackAction.

Public Constructors

 | Name | Description
public Constructor | PostBackAction Constructor | Initializes a new instance of the PostBackAction class.
Top

Public Fields

 | Name | Description
public Field | AddItem |
public Field | Custom |
public Field | LoadData |
public Field | Refresh |
Top

See Also

Reference

PostBackAction Class
ISNet.WebUI.WebCombo Namespace


PostBackAction Constructor

[image]
Intersoft WebCombo Documentation
PostBackAction Constructor
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > PostBackAction Class : PostBackAction Constructor

Initializes a new instance of the PostBackAction class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New PostBackAction()
C#
public PostBackAction()
Delphi
public PostBackAction();
JScript
public function PostBackAction();
Managed Extensions for C++
public: PostBackAction();
C++/CLI
public:
PostBackAction();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PostBackAction Class
PostBackAction Members


PostBackAction Class Fields

[image]
Intersoft WebCombo Documentation
PostBackAction Class Fields
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : PostBackAction Class

For a list of all members of this type, see PostBackAction members.

Public Fields

 | Name | Description
public Field | AddItem |
public Field | Custom |
public Field | LoadData |
public Field | Refresh |
Top

See Also

Reference

PostBackAction Class
ISNet.WebUI.WebCombo Namespace


AddItem Field

[image]
Intersoft WebCombo Documentation
AddItem Field
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > PostBackAction Class : AddItem Field

Syntax

Visual Basic (Declaration)
Public Const AddItem As String
Visual Basic (Usage) Copy Code
Dim value As String

value = PostBackAction.AddItem
C#
public const string AddItem
Delphi
public field AddItem: String; Const
JScript
public constvar AddItem : String;
Managed Extensions for C++
public: const string* AddItem
C++/CLI
public:
const String^ AddItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PostBackAction Class
PostBackAction Members


Custom Field

[image]
Intersoft WebCombo Documentation
Custom Field
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > PostBackAction Class : Custom Field

Syntax

Visual Basic (Declaration)
Public Const Custom As String
Visual Basic (Usage) Copy Code
Dim value As String

value = PostBackAction.Custom
C#
public const string Custom
Delphi
public field Custom: String; Const
JScript
public constvar Custom : String;
Managed Extensions for C++
public: const string* Custom
C++/CLI
public:
const String^ Custom

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PostBackAction Class
PostBackAction Members


LoadData Field

[image]
Intersoft WebCombo Documentation
LoadData Field
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > PostBackAction Class : LoadData Field

Syntax

Visual Basic (Declaration)
Public Const LoadData As String
Visual Basic (Usage) Copy Code
Dim value As String

value = PostBackAction.LoadData
C#
public const string LoadData
Delphi
public field LoadData: String; Const
JScript
public constvar LoadData : String;
Managed Extensions for C++
public: const string* LoadData
C++/CLI
public:
const String^ LoadData

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PostBackAction Class
PostBackAction Members


Refresh Field

[image]
Intersoft WebCombo Documentation
Refresh Field
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > PostBackAction Class : Refresh Field

Syntax

Visual Basic (Declaration)
Public Const Refresh As String
Visual Basic (Usage) Copy Code
Dim value As String

value = PostBackAction.Refresh
C#
public const string Refresh
Delphi
public field Refresh: String; Const
JScript
public constvar Refresh : String;
Managed Extensions for C++
public: const string* Refresh
C++/CLI
public:
const String^ Refresh

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PostBackAction Class
PostBackAction Members


PostbackEventArgs Class

[image]
Intersoft WebCombo Documentation
PostbackEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : PostbackEventArgs Class

Provides data for OnTheFly postback event.

Provides data for OnTheFly postback event.

Object Model

PostbackEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class PostbackEventArgs
   Inherits BaseEventArgs
Visual Basic (Usage) Copy Code
Dim instance As PostbackEventArgs
C#
public class PostbackEventArgs : BaseEventArgs
Delphi
public class PostbackEventArgs = class(BaseEventArgs)
JScript
public class PostbackEventArgs extends BaseEventArgs
Managed Extensions for C++
public __gc class PostbackEventArgs : public BaseEventArgs
C++/CLI
public ref class PostbackEventArgs : public BaseEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebCombo.BaseEventArgs
ISNet.WebUI.WebCombo.PostbackEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PostbackEventArgs Members
ISNet.WebUI.WebCombo Namespace


PostbackEventArgs Class Members

[image]
Intersoft WebCombo Documentation
PostbackEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebCombo Namespace : PostbackEventArgs Class

The following tables list the members exposed by PostbackEventArgs.

Public Properties

 | Name | Description
public Property | Action | Gets the action name (PostBackAction) for the requests that initiate the event.Gets the action name (PostBackAction) for the requests that initiate the event.
public Property | Combo | Gets the WebGrid object used by the event. Gets the WebGrid object used by the event.
public Property | CustomActionData | Gets or sets custom action data for requests that initiated by custom request function. Gets or sets custom action data for requests that initiated by custom request function.
public Property | DataSource | Gets the assigned WebGrid's DataSource. Gets the assigned WebGrid's DataSource.
public Property | ReturnValue | (Inherited from ISNet.WebUI.WebCombo.BaseEventArgs)
public Property | XmlRequest | Gets the request in XmlDocument type that contains requests information by clients. Gets the request in XmlDocument type that contains requests information by clients.
Top

See Also

Reference

PostbackEventArgs Class
ISNet.WebUI.WebCombo Namespace


PostbackEventArgs Class Properties

[image]
Intersoft WebCombo Documentation
PostbackEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : PostbackEventArgs Class

For a list of all members of this type, see PostbackEventArgs members.

Public Properties

 | Name | Description
public Property | Action | Gets the action name (PostBackAction) for the requests that initiate the event.Gets the action name (PostBackAction) for the requests that initiate the event.
public Property | Combo | Gets the WebGrid object used by the event. Gets the WebGrid object used by the event.
public Property | CustomActionData | Gets or sets custom action data for requests that initiated by custom request function. Gets or sets custom action data for requests that initiated by custom request function.
public Property | DataSource | Gets the assigned WebGrid's DataSource. Gets the assigned WebGrid's DataSource.
public Property | ReturnValue | (Inherited from ISNet.WebUI.WebCombo.BaseEventArgs)
public Property | XmlRequest | Gets the request in XmlDocument type that contains requests information by clients. Gets the request in XmlDocument type that contains requests information by clients.
Top

See Also

Reference

PostbackEventArgs Class
ISNet.WebUI.WebCombo Namespace


Action Property

[image]
Intersoft WebCombo Documentation
Action Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > PostbackEventArgs Class : Action Property

Gets the action name (PostBackAction) for the requests that initiate the event.Gets the action name (PostBackAction) for the requests that initiate the event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Action As String
Visual Basic (Usage) Copy Code
Dim instance As PostbackEventArgs
Dim value As String

value = instance.Action
C#
public string Action {get;}
Delphi
public read-only property Action: String;
JScript
public function get Action : String
Managed Extensions for C++
public: __property string* get_Action();
C++/CLI
public:
property String^ Action {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PostbackEventArgs Class
PostbackEventArgs Members


Combo Property

[image]
Intersoft WebCombo Documentation
Combo Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > PostbackEventArgs Class : Combo Property

Gets the WebGrid object used by the event. Gets the WebGrid object used by the event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Combo As WebCombo
Visual Basic (Usage) Copy Code
Dim instance As PostbackEventArgs
Dim value As WebCombo

value = instance.Combo
C#
public WebCombo Combo {get;}
Delphi
public read-only property Combo: WebCombo;
JScript
public function get Combo : WebCombo
Managed Extensions for C++
public: __property WebCombo* get_Combo();
C++/CLI
public:
property WebCombo^ Combo {
   WebCombo^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PostbackEventArgs Class
PostbackEventArgs Members


CustomActionData Property

[image]
Intersoft WebCombo Documentation
CustomActionData Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > PostbackEventArgs Class : CustomActionData Property

Gets or sets custom action data for requests that initiated by custom request function. Gets or sets custom action data for requests that initiated by custom request function.

Syntax

Visual Basic (Declaration)
Public Property CustomActionData As String
Visual Basic (Usage) Copy Code
Dim instance As PostbackEventArgs
Dim value As String

instance.CustomActionData = value

value = instance.CustomActionData
C#
public string CustomActionData {get; set;}
Delphi
public read-write property CustomActionData: String;
JScript
public function get,set CustomActionData : String
Managed Extensions for C++
public: __property string* get_CustomActionData();
public: __property void set_CustomActionData(
   string* value
);
C++/CLI
public:
property String^ CustomActionData {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PostbackEventArgs Class
PostbackEventArgs Members


DataSource Property

[image]
Intersoft WebCombo Documentation
DataSource Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > PostbackEventArgs Class : DataSource Property

Gets the assigned WebGrid's DataSource. Gets the assigned WebGrid's DataSource.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataSource As Object
Visual Basic (Usage) Copy Code
Dim instance As PostbackEventArgs
Dim value As Object

value = instance.DataSource
C#
public object DataSource {get;}
Delphi
public read-only property DataSource: TObject;
JScript
public function get DataSource : Object
Managed Extensions for C++
public: __property Object* get_DataSource();
C++/CLI
public:
property Object^ DataSource {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PostbackEventArgs Class
PostbackEventArgs Members


XmlRequest Property

[image]
Intersoft WebCombo Documentation
XmlRequest Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > PostbackEventArgs Class : XmlRequest Property

Gets the request in XmlDocument type that contains requests information by clients. Gets the request in XmlDocument type that contains requests information by clients.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property XmlRequest As XmlDocument
Visual Basic (Usage) Copy Code
Dim instance As PostbackEventArgs
Dim value As XmlDocument

value = instance.XmlRequest
C#
public XmlDocument XmlRequest {get;}
Delphi
public read-only property XmlRequest: XmlDocument;
JScript
public function get XmlRequest : XmlDocument
Managed Extensions for C++
public: __property XmlDocument* get_XmlRequest();
C++/CLI
public:
property XmlDocument^ XmlRequest {
   XmlDocument^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PostbackEventArgs Class
PostbackEventArgs Members


Presets Class

[image]
Intersoft WebCombo Documentation
Presets Class
Members See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : Presets Class

Presets class contains static methods that are used to initialize default styles and provides centralized access for other predefined styles.

Presets class contains static methods that are used to initialize default styles and provides centralized access for other predefined styles.

Object Model

Presets Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Presets
Visual Basic (Usage) Copy Code
Dim instance As Presets
C#
public sealed class Presets
Delphi
public class Presets sealed;
JScript
public sealed class Presets
Managed Extensions for C++
public __gc __sealed class Presets
C++/CLI
public ref class Presets sealed

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebCombo.Presets

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Presets Members
ISNet.WebUI.WebCombo Namespace


Presets Class Members

[image]
Intersoft WebCombo Documentation
Presets Class Members
See Also Methods Send Feedback
ISNet.WebUI.WebCombo Namespace : Presets Class

The following tables list the members exposed by Presets.

Public Constructors

 | Name | Description
public Constructor | Presets Constructor | Initializes a new instance of the Presets class.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ApplyDefaultMulticolumnsStyle | Apply default multicolumn style to the WebCombo control. Apply default multicolumn style to the WebCombo control.
static (Shared in Visual Basic) | ApplyDefaultPreset | Apply default style to the WebCombo control. Apply default style to the WebCombo control.
Top

See Also

Reference

Presets Class
ISNet.WebUI.WebCombo Namespace


Presets Constructor

[image]
Intersoft WebCombo Documentation
Presets Constructor
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Presets Class : Presets Constructor

Initializes a new instance of the Presets class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Presets()
C#
public Presets()
Delphi
public Presets();
JScript
public function Presets();
Managed Extensions for C++
public: Presets();
C++/CLI
public:
Presets();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Presets Class
Presets Members


Presets Class Methods

[image]
Intersoft WebCombo Documentation
Presets Class Methods
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : Presets Class

For a list of all members of this type, see Presets members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ApplyDefaultMulticolumnsStyle | Apply default multicolumn style to the WebCombo control. Apply default multicolumn style to the WebCombo control.
static (Shared in Visual Basic) | ApplyDefaultPreset | Apply default style to the WebCombo control. Apply default style to the WebCombo control.
Top

See Also

Reference

Presets Class
ISNet.WebUI.WebCombo Namespace


ApplyDefaultMulticolumnsStyle Method

[image]
Intersoft WebCombo Documentation
ApplyDefaultMulticolumnsStyle Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Presets Class : ApplyDefaultMulticolumnsStyle Method

ls
Apply default multicolumn style to the WebCombo control. Apply default multicolumn style to the WebCombo control.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("This method has been deprecated and replaced with UseDefaultStyle feature.")>
Public Shared Sub ApplyDefaultMulticolumnsStyle( _
   ByVal ls As LayoutSet _
)
Visual Basic (Usage) Copy Code
Dim ls As LayoutSet

Presets.ApplyDefaultMulticolumnsStyle(ls)
C#
[ObsoleteAttribute("This method has been deprecated and replaced with UseDefaultStyle feature.")]
public static void ApplyDefaultMulticolumnsStyle(
   LayoutSet ls
)
Delphi
public procedure ApplyDefaultMulticolumnsStyle(
    ls: LayoutSet
); static;
JScript
ObsoleteAttribute("This method has been deprecated and replaced with UseDefaultStyle feature.")
public static function ApplyDefaultMulticolumnsStyle(
   ls : LayoutSet
);
Managed Extensions for C++
[ObsoleteAttribute("This method has been deprecated and replaced with UseDefaultStyle feature.")]
public: static void ApplyDefaultMulticolumnsStyle(
   LayoutSet* ls
)
C++/CLI
[ObsoleteAttribute("This method has been deprecated and replaced with UseDefaultStyle feature.")]
public:
static void ApplyDefaultMulticolumnsStyle(
   LayoutSet^ ls
)

Parameters

ls

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Presets Class
Presets Members


ApplyDefaultPreset Method

[image]
Intersoft WebCombo Documentation
ApplyDefaultPreset Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Presets Class : ApplyDefaultPreset Method

o
The Webcombo object to apply.
Apply default style to the WebCombo control. Apply default style to the WebCombo control.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("This method has been deprecated and replaced with UseDefaultStyle feature.")>
Public Shared Sub ApplyDefaultPreset( _
   ByVal o As WebCombo _
)
Visual Basic (Usage) Copy Code
Dim o As WebCombo

Presets.ApplyDefaultPreset(o)
C#
[ObsoleteAttribute("This method has been deprecated and replaced with UseDefaultStyle feature.")]
public static void ApplyDefaultPreset(
   WebCombo o
)
Delphi
public procedure ApplyDefaultPreset(
    o: WebCombo
); static;
JScript
ObsoleteAttribute("This method has been deprecated and replaced with UseDefaultStyle feature.")
public static function ApplyDefaultPreset(
   o : WebCombo
);
Managed Extensions for C++
[ObsoleteAttribute("This method has been deprecated and replaced with UseDefaultStyle feature.")]
public: static void ApplyDefaultPreset(
   WebCombo* o
)
C++/CLI
[ObsoleteAttribute("This method has been deprecated and replaced with UseDefaultStyle feature.")]
public:
static void ApplyDefaultPreset(
   WebCombo^ o
)

Parameters

o
The Webcombo object to apply.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Presets Class
Presets Members


RowEventArgs Class

[image]
Intersoft WebCombo Documentation
RowEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : RowEventArgs Class

Provides data for row related event. Provides data for row related event.

Object Model

RowEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class RowEventArgs
   Inherits BaseEventArgs
Visual Basic (Usage) Copy Code
Dim instance As RowEventArgs
C#
public class RowEventArgs : BaseEventArgs
Delphi
public class RowEventArgs = class(BaseEventArgs)
JScript
public class RowEventArgs extends BaseEventArgs
Managed Extensions for C++
public __gc class RowEventArgs : public BaseEventArgs
C++/CLI
public ref class RowEventArgs : public BaseEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebCombo.BaseEventArgs
ISNet.WebUI.WebCombo.RowEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RowEventArgs Members
ISNet.WebUI.WebCombo Namespace


RowEventArgs Class Members

[image]
Intersoft WebCombo Documentation
RowEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebCombo Namespace : RowEventArgs Class

The following tables list the members exposed by RowEventArgs.

Public Properties

 | Name | Description
public Property | ReturnValue | (Inherited from ISNet.WebUI.WebCombo.BaseEventArgs)
public Property | Row | Gets the WebGridRow object used by the event. Gets the WebGridRow object used by the event.
Top

See Also

Reference

RowEventArgs Class
ISNet.WebUI.WebCombo Namespace


RowEventArgs Class Properties

[image]
Intersoft WebCombo Documentation
RowEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : RowEventArgs Class

For a list of all members of this type, see RowEventArgs members.

Public Properties

 | Name | Description
public Property | ReturnValue | (Inherited from ISNet.WebUI.WebCombo.BaseEventArgs)
public Property | Row | Gets the WebGridRow object used by the event. Gets the WebGridRow object used by the event.
Top

See Also

Reference

RowEventArgs Class
ISNet.WebUI.WebCombo Namespace


Row Property

[image]
Intersoft WebCombo Documentation
Row Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > RowEventArgs Class : Row Property

Gets the WebGridRow object used by the event. Gets the WebGridRow object used by the event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Row As WebComboRow
Visual Basic (Usage) Copy Code
Dim instance As RowEventArgs
Dim value As WebComboRow

value = instance.Row
C#
public WebComboRow Row {get;}
Delphi
public read-only property Row: WebComboRow;
JScript
public function get Row : WebComboRow
Managed Extensions for C++
public: __property WebComboRow* get_Row();
C++/CLI
public:
property WebComboRow^ Row {
   WebComboRow^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RowEventArgs Class
RowEventArgs Members


Rows Class

[image]
Intersoft WebCombo Documentation
Rows Class
Members See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : Rows Class

A collection of Rows objects that represent the rows of the WebCombo control. A collection of Rows objects that represent the rows of the WebCombo control.

Object Model

Rows Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
<SerializableAttribute()>
Public Class Rows
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As Rows
C#
[DefaultMemberAttribute("Item")]
[SerializableAttribute()]
public class Rows : ISNet.WebUI.ISCollectionBase
Delphi
public class Rows = class(ISNet.WebUI.ISCollectionBase)
JScript
DefaultMemberAttribute("Item")
SerializableAttribute()
public class Rows extends ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
[SerializableAttribute()]
public __gc class Rows : public ISNet.WebUI.ISCollectionBase
C++/CLI
[DefaultMemberAttribute("Item")]
[SerializableAttribute()]
public ref class Rows : public ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebCombo.Rows

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Rows Members
ISNet.WebUI.WebCombo Namespace


Rows Class Members

[image]
Intersoft WebCombo Documentation
Rows Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebCombo Namespace : Rows Class

The following tables list the members exposed by Rows.

Public Constructors

 | Name | Description
public Constructor | Rows Constructor | Public constructor for the Rows Collection.
Top

Public Properties

 | Name | Description
public Property | Capacity | (Inherited from System.Collections.CollectionBase)
public Property | Combo | Gets the WebCombo object that owns the row.
public Property | Count | (Inherited from System.Collections.CollectionBase)
public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only. Returns a Boolean value indicating whether the collection is read-only.
public Property | Item | Property indexer for the collection. Property indexer for the collection.
public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
public Method | Add | Overloaded. Add an WebComboRow object into the WebComboRow collection. Add an WebComboRow object into the WebComboRow collection.
public Method | AddRange | Removes all WebComboRow objects from the collection.
public Method | Clear | Removes all WebComboRow objects from the collection. Removes all WebComboRow objects from the collection.
public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | CopyFrom |
public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | FindRowByText | Find specified text in DataTextField and return the WebComboRow object that match. Find specified text in DataTextField and return the WebComboRow object that match.
public Method | FindRowByValue | Find specified text in DataValueField and return the WebComboRow object that match. Find specified text in DataValueField and return the WebComboRow object that match.
public Method | GetEnumerator | Returns an enumerator object for the collection. Returns an enumerator object for the collection.
public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | GetNamedItem | Property indexer for the collection. Uses the Name string to return an WebComboRow object. Property indexer for the collection. Uses the Name string to return an WebComboRow object.
public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | Insert | Inserts an WebComboRow object into the WebComboRow collection at a specified index. Inserts an WebComboRow object into the WebComboRow collection at a specified index.
public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | Remove | Removes the specified WebComboRow object from the collection. Removes the specified WebComboRow object from the collection.
public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

Rows Class
ISNet.WebUI.WebCombo Namespace


Rows Constructor

[image]
Intersoft WebCombo Documentation
Rows Constructor
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Rows Class : Rows Constructor

Public constructor for the Rows Collection.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Rows()
C#
public Rows()
Delphi
public Rows();
JScript
public function Rows();
Managed Extensions for C++
public: Rows();
C++/CLI
public:
Rows();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Rows Class
Rows Members


Rows Class Methods

[image]
Intersoft WebCombo Documentation
Rows Class Methods
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : Rows Class

For a list of all members of this type, see Rows members.

Public Methods

 | Name | Description
public Method | Add | Overloaded. Add an WebComboRow object into the WebComboRow collection. Add an WebComboRow object into the WebComboRow collection.
public Method | AddRange | Removes all WebComboRow objects from the collection.
public Method | Clear | Removes all WebComboRow objects from the collection. Removes all WebComboRow objects from the collection.
public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | CopyFrom |
public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | FindRowByText | Find specified text in DataTextField and return the WebComboRow object that match. Find specified text in DataTextField and return the WebComboRow object that match.
public Method | FindRowByValue | Find specified text in DataValueField and return the WebComboRow object that match. Find specified text in DataValueField and return the WebComboRow object that match.
public Method | GetEnumerator | Returns an enumerator object for the collection. Returns an enumerator object for the collection.
public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | GetNamedItem | Property indexer for the collection. Uses the Name string to return an WebComboRow object. Property indexer for the collection. Uses the Name string to return an WebComboRow object.
public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | Insert | Inserts an WebComboRow object into the WebComboRow collection at a specified index. Inserts an WebComboRow object into the WebComboRow collection at a specified index.
public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | Remove | Removes the specified WebComboRow object from the collection. Removes the specified WebComboRow object from the collection.
public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

Rows Class
ISNet.WebUI.WebCombo Namespace


Add Method

[image]
Intersoft WebCombo Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Rows Class : Add Method

Add an WebComboRow object into the WebComboRow collection. Add an WebComboRow object into the WebComboRow collection.

Overload List

Overload | Description
Add(WebComboRow) | Add an WebComboRow object into the WebComboRow collection. Add an WebComboRow object into the WebComboRow collection.
Add(String) | Creates a new WebComboRow object in the collection and initializes its Name value. Creates a new WebComboRow object in the collection and initializes its Name value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Rows Class
Rows Members


Add(WebComboRow) Method

[image]
Intersoft WebCombo Documentation
Add(WebComboRow) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Rows Class > Add Method : Add(WebComboRow) Method

row
The WebComboRow object to be added.
Add an WebComboRow object into the WebComboRow collection. Add an WebComboRow object into the WebComboRow collection.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal row As WebComboRow _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Rows
Dim row As WebComboRow
Dim value As Integer

value = instance.Add(row)
C#
public virtual int Add(
   WebComboRow row
)
Delphi
public function Add(
    row: WebComboRow
): Integer; virtual;
JScript
public function Add(
   row : WebComboRow
) : int;
Managed Extensions for C++
public: virtual int Add(
   WebComboRow* row
)
C++/CLI
public:
virtual int Add(
   WebComboRow^ row
)

Parameters

row
The WebComboRow object to be added.

Return Value

The index of the newly added WebComboRow.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Rows Class
Rows Members
Overload List


Add(String) Method

[image]
Intersoft WebCombo Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Rows Class > Add Method : Add(String) Method

name
The unique Name value.
Creates a new WebComboRow object in the collection and initializes its Name value. Creates a new WebComboRow object in the collection and initializes its Name value.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Rows
Dim name As String
Dim value As Integer

value = instance.Add(name)
C#
public int Add(
   string name
)
Delphi
public function Add(
    name: String
): Integer;
JScript
public function Add(
   name : String
) : int;
Managed Extensions for C++
public: int Add(
   string* name
)
C++/CLI
public:
int Add(
   String^ name
)

Parameters

name
The unique Name value.

Return Value

The index of the newly-added WebComboRow object within the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Rows Class
Rows Members
Overload List


AddRange Method

[image]
Intersoft WebCombo Documentation
AddRange Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Rows Class : AddRange Method

rows
Removes all WebComboRow objects from the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal rows() As WebComboRow _
)
Visual Basic (Usage) Copy Code
Dim instance As Rows
Dim rows() As WebComboRow

instance.AddRange(rows)
C#
public void AddRange(
   WebComboRow[] rows
)
Delphi
public procedure AddRange(
    rows: WebComboRowarray of
);
JScript
public function AddRange(
   rows : WebComboRow[]
);
Managed Extensions for C++
public: void AddRange(
   WebComboRow*[]* rows
)
C++/CLI
public:
void AddRange(
   array<WebComboRow^>^ rows
)

Parameters

rows

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Rows Class
Rows Members


Clear Method

[image]
Intersoft WebCombo Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Rows Class : Clear Method

Removes all WebComboRow objects from the collection.

Removes all WebComboRow objects from the collection.

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As Rows

instance.Clear()
C#
public new void Clear()
Delphi
public procedure Clear();
JScript
public hide function Clear();
Managed Extensions for C++
public: new void Clear();
C++/CLI
public:
new void Clear();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Rows Class
Rows Members


Contains Method

[image]
Intersoft WebCombo Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Rows Class : Contains Method

value

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Rows
Dim value As ISNet.WebUI.INamedObject
Dim value As Boolean

value = instance.Contains(value)
C#
public bool Contains(
   ISNet.WebUI.INamedObject value
)
Delphi
public function Contains(
    value: ISNet.WebUI.INamedObject
): Boolean;
JScript
public function Contains(
   value : ISNet.WebUI.INamedObject
) : boolean;
Managed Extensions for C++
public: bool Contains(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
bool Contains(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Rows Class
Rows Members


CopyFrom Method

[image]
Intersoft WebCombo Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Rows Class : CopyFrom Method

passIn

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As Rows _
) As Rows
Visual Basic (Usage) Copy Code
Dim instance As Rows
Dim passIn As Rows
Dim value As Rows

value = instance.CopyFrom(passIn)
C#
public Rows CopyFrom(
   Rows passIn
)
Delphi
public function CopyFrom(
    passIn: Rows
): Rows;
JScript
public function CopyFrom(
   passIn : Rows
) : Rows;
Managed Extensions for C++
public: Rows* CopyFrom(
   Rows* passIn
)
C++/CLI
public:
Rows^ CopyFrom(
   Rows^ passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Rows Class
Rows Members


CopyTo Method

[image]
Intersoft WebCombo Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Rows Class : CopyTo Method

array
index

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As Rows
Dim array() As ISNet.WebUI.INamedObject
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObjectarray of;
    index: Integer
);
JScript
public function CopyTo(
   array : ISNet.WebUI.INamedObject[],
   index : int
);
Managed Extensions for C++
public: void CopyTo(
   ISNet.WebUI.INamedObject*[]* array,
   int index
)
C++/CLI
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject^>^ array,
   int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Rows Class
Rows Members


Exists Method

[image]
Intersoft WebCombo Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Rows Class : Exists Method

name

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Rows
Dim name As String
Dim value As Boolean

value = instance.Exists(name)
C#
public bool Exists(
   string name
)
Delphi
public function Exists(
    name: String
): Boolean;
JScript
public function Exists(
   name : String
) : boolean;
Managed Extensions for C++
public: bool Exists(
   string* name
)
C++/CLI
public:
bool Exists(
   String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Rows Class
Rows Members


FindRowByText Method

[image]
Intersoft WebCombo Documentation
FindRowByText Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Rows Class : FindRowByText Method

text
The text to find.The text to find.
Find specified text in DataTextField and return the WebComboRow object that match. Find specified text in DataTextField and return the WebComboRow object that match.

Syntax

Visual Basic (Declaration)
Public Function FindRowByText( _
   ByVal text As String _
) As WebComboRow
Visual Basic (Usage) Copy Code
Dim instance As Rows
Dim text As String
Dim value As WebComboRow

value = instance.FindRowByText(text)
C#
public WebComboRow FindRowByText(
   string text
)
Delphi
public function FindRowByText(
    text: String
): WebComboRow;
JScript
public function FindRowByText(
   text : String
) : WebComboRow;
Managed Extensions for C++
public: WebComboRow* FindRowByText(
   string* text
)
C++/CLI
public:
WebComboRow^ FindRowByText(
   String^ text
)

Parameters

text
The text to find.The text to find.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Rows Class
Rows Members


FindRowByValue Method

[image]
Intersoft WebCombo Documentation
FindRowByValue Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Rows Class : FindRowByValue Method

_value
The text to find.
Find specified text in DataValueField and return the WebComboRow object that match. Find specified text in DataValueField and return the WebComboRow object that match.

Syntax

Visual Basic (Declaration)
Public Function FindRowByValue( _
   ByVal _value As String _
) As WebComboRow
Visual Basic (Usage) Copy Code
Dim instance As Rows
Dim _value As String
Dim value As WebComboRow

value = instance.FindRowByValue(_value)
C#
public WebComboRow FindRowByValue(
   string _value
)
Delphi
public function FindRowByValue(
    _value: String
): WebComboRow;
JScript
public function FindRowByValue(
   _value : String
) : WebComboRow;
Managed Extensions for C++
public: WebComboRow* FindRowByValue(
   string* _value
)
C++/CLI
public:
WebComboRow^ FindRowByValue(
   String^ _value
)

Parameters

_value
The text to find.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Rows Class
Rows Members


GetEnumerator Method

[image]
Intersoft WebCombo Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Rows Class : GetEnumerator Method

Returns an enumerator object for the collection. Returns an enumerator object for the collection.

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As Rows
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public new IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
JScript
public hide function GetEnumerator() : IEnumerator;
Managed Extensions for C++
public: new IEnumerator* GetEnumerator();
C++/CLI
public:
new IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Rows Class
Rows Members


GetItem Method

[image]
Intersoft WebCombo Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Rows Class : GetItem Method

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Rows Class
Rows Members


GetItem(Int32) Method

[image]
Intersoft WebCombo Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Rows Class : GetItem(Int32) Method

index

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As Rows
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   int index
)
Delphi
public function GetItem(
    index: Integer
): ISNet.WebUI.INamedObject; virtual;
JScript
public function GetItem(
   index : int
) : ISNet.WebUI.INamedObject;
Managed Extensions for C++
public: virtual ISNet.WebUI.INamedObject* GetItem(
   int index
)
C++/CLI
public:
virtual ISNet.WebUI.INamedObject^ GetItem(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Rows Class
Rows Members


GetNamedItem Method

[image]
Intersoft WebCombo Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Rows Class : GetNamedItem Method

name
Property indexer for the collection. Uses the Name string to return an WebComboRow object. Property indexer for the collection. Uses the Name string to return an WebComboRow object.

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As String _
) As WebComboRow
Visual Basic (Usage) Copy Code
Dim instance As Rows
Dim name As String
Dim value As WebComboRow

value = instance.GetNamedItem(name)
C#
public WebComboRow GetNamedItem(
   string name
)
Delphi
public function GetNamedItem(
    name: String
): WebComboRow;
JScript
public function GetNamedItem(
   name : String
) : WebComboRow;
Managed Extensions for C++
public: WebComboRow* GetNamedItem(
   string* name
)
C++/CLI
public:
WebComboRow^ GetNamedItem(
   String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Rows Class
Rows Members


IndexOf Method

[image]
Intersoft WebCombo Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Rows Class : IndexOf Method

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Rows Class
Rows Members


IndexOf(String) Method

[image]
Intersoft WebCombo Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Rows Class > IndexOf Method : IndexOf(String) Method

name

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Rows
Dim name As String
Dim value As Integer

value = instance.IndexOf(name)
C#
public virtual int IndexOf(
   string name
)
Delphi
public function IndexOf(
    name: String
): Integer; virtual;
JScript
public function IndexOf(
   name : String
) : int;
Managed Extensions for C++
public: virtual int IndexOf(
   string* name
)
C++/CLI
public:
virtual int IndexOf(
   String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Rows Class
Rows Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebCombo Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Rows Class > IndexOf Method : IndexOf(INamedObject) Method

value

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Rows
Dim value As ISNet.WebUI.INamedObject
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   ISNet.WebUI.INamedObject value
)
Delphi
public function IndexOf(
    value: ISNet.WebUI.INamedObject
): Integer;
JScript
public function IndexOf(
   value : ISNet.WebUI.INamedObject
) : int;
Managed Extensions for C++
public: int IndexOf(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
int IndexOf(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Rows Class
Rows Members
Overload List


Insert Method

[image]
Intersoft WebCombo Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Rows Class : Insert Method

index
The position in the collection for the new WebComboRow.The position in the collection for the new WebComboRow.
row
The WebComboRow object to be inserted into the collection.The WebComboRow object to be inserted into the collection.
Inserts an WebComboRow object into the WebComboRow collection at a specified index. Inserts an WebComboRow object into the WebComboRow collection at a specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal row As WebComboRow _
)
Visual Basic (Usage) Copy Code
Dim instance As Rows
Dim index As Integer
Dim row As WebComboRow

instance.Insert(index, row)
C#
public void Insert(
   int index,
   WebComboRow row
)
Delphi
public procedure Insert(
    index: Integer;
    row: WebComboRow
);
JScript
public function Insert(
   index : int,
   row : WebComboRow
);
Managed Extensions for C++
public: void Insert(
   int index,
   WebComboRow* row
)
C++/CLI
public:
void Insert(
   int index,
   WebComboRow^ row
)

Parameters

index
The position in the collection for the new WebComboRow.The position in the collection for the new WebComboRow.
row
The WebComboRow object to be inserted into the collection.The WebComboRow object to be inserted into the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Rows Class
Rows Members


IntInsert Method

[image]
Intersoft WebCombo Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Rows Class : IntInsert Method

index
value

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As Rows
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   int index,
   ISNet.WebUI.INamedObject value
)
Delphi
public procedure IntInsert(
    index: Integer;
    value: ISNet.WebUI.INamedObject
);
JScript
public function IntInsert(
   index : int,
   value : ISNet.WebUI.INamedObject
);
Managed Extensions for C++
public: void IntInsert(
   int index,
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
void IntInsert(
   int index,
   ISNet.WebUI.INamedObject^ value
)

Parameters

index
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Rows Class
Rows Members


Remove Method

[image]
Intersoft WebCombo Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Rows Class : Remove Method

row
The WebComboRow object to be removed from the collection.The WebComboRow object to be removed from the collection.
Removes the specified WebComboRow object from the collection. Removes the specified WebComboRow object from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal row As WebComboRow _
)
Visual Basic (Usage) Copy Code
Dim instance As Rows
Dim row As WebComboRow

instance.Remove(row)
C#
public void Remove(
   WebComboRow row
)
Delphi
public procedure Remove(
    row: WebComboRow
);
JScript
public function Remove(
   row : WebComboRow
);
Managed Extensions for C++
public: void Remove(
   WebComboRow* row
)
C++/CLI
public:
void Remove(
   WebComboRow^ row
)

Parameters

row
The WebComboRow object to be removed from the collection.The WebComboRow object to be removed from the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Rows Class
Rows Members


setParent Method

[image]
Intersoft WebCombo Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Rows Class : setParent Method

parent

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As Rows
Dim parent As Object

instance.setParent(parent)
C#
public virtual void setParent(
   object parent
)
Delphi
public procedure setParent(
    parent: TObject
); virtual;
JScript
public function setParent(
   parent : Object
);
Managed Extensions for C++
public: virtual void setParent(
   Object* parent
)
C++/CLI
public:
virtual void setParent(
   Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Rows Class
Rows Members


Capacity Property

[image]
Intersoft WebCombo Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Rows Class : Capacity Property

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)>
Public Property Capacity As Integer
Visual Basic (Usage) Copy Code
Dim instance As Rows
Dim value As Integer

instance.Capacity = value

value = instance.Capacity
C#
[ComVisibleAttribute(false)]
public int Capacity {get; set;}
Delphi
public read-write property Capacity: Integer;
JScript
ComVisibleAttribute()
public function get,set Capacity : int
Managed Extensions for C++
[ComVisibleAttribute(false)]
public: __property int get_Capacity();
public: __property void set_Capacity(
   int value
);
C++/CLI
[ComVisibleAttribute(false)]
public:
property int Capacity {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Rows Class
Rows Members


Rows Class Properties

[image]
Intersoft WebCombo Documentation
Rows Class Properties
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : Rows Class

For a list of all members of this type, see Rows members.

Public Properties

 | Name | Description
public Property | Capacity | (Inherited from System.Collections.CollectionBase)
public Property | Combo | Gets the WebCombo object that owns the row.
public Property | Count | (Inherited from System.Collections.CollectionBase)
public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only. Returns a Boolean value indicating whether the collection is read-only.
public Property | Item | Property indexer for the collection. Property indexer for the collection.
public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

Rows Class
ISNet.WebUI.WebCombo Namespace


Rows Constructor

[image]
Intersoft WebCombo Documentation
Rows Constructor
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Rows Class : Rows Constructor

Initializes a new instance of the Rows class.

Overload List

Overload | Description
Rows Constructor | Public constructor for the Rows Collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Rows Class
Rows Members


Combo Property

[image]
Intersoft WebCombo Documentation
Combo Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Rows Class : Combo Property

Gets the WebCombo object that owns the row.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Combo As WebCombo
Visual Basic (Usage) Copy Code
Dim instance As Rows
Dim value As WebCombo

value = instance.Combo
C#
public WebCombo Combo {get;}
Delphi
public read-only property Combo: WebCombo;
JScript
public function get Combo : WebCombo
Managed Extensions for C++
public: __property WebCombo* get_Combo();
C++/CLI
public:
property WebCombo^ Combo {
   WebCombo^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Rows Class
Rows Members


Count Property

[image]
Intersoft WebCombo Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Rows Class : Count Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As Rows
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Delphi
public read-only property Count: Integer;
JScript
public function get Count : int
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Rows Class
Rows Members


IsReadOnly Property

[image]
Intersoft WebCombo Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Rows Class : IsReadOnly Property

Returns a Boolean value indicating whether the collection is read-only.

Returns a Boolean value indicating whether the collection is read-only.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Rows
Dim value As Boolean

value = instance.IsReadOnly
C#
public override bool IsReadOnly {get;}
Delphi
public read-only property IsReadOnly: Boolean; override;
JScript
public override function get IsReadOnly : boolean
Managed Extensions for C++
public: __property bool get_IsReadOnly() override;
C++/CLI
public:
property bool IsReadOnly {
   bool get() override;
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Rows Class
Rows Members


Item Property

[image]
Intersoft WebCombo Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Rows Class : Item Property

index

Property indexer for the collection.

Property indexer for the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As WebComboRow
Visual Basic (Usage) Copy Code
Dim instance As Rows
Dim index As Integer
Dim value As WebComboRow

value = instance.Item(index)
C#
public WebComboRow this(
   int index
) {get;}
Delphi
public  this: : WebComboRow;(
    index: Integer
); read-only
JScript
public  this(
   index : int
) get : WebComboRow
Managed Extensions for C++
public: __property WebComboRow* get_Item(
   int index
);
C++/CLI
public:
property WebComboRow^ default [int] {
   WebComboRow^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Rows Class
Rows Members


Parent Property

[image]
Intersoft WebCombo Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > Rows Class : Parent Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As Object
Visual Basic (Usage) Copy Code
Dim instance As Rows
Dim value As Object

value = instance.Parent
C#
public object Parent {get;}
Delphi
public read-only property Parent: TObject;
JScript
public function get Parent : Object
Managed Extensions for C++
public: __property Object* get_Parent();
C++/CLI
public:
property Object^ Parent {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Rows Class
Rows Members


TextSet Class

[image]
Intersoft WebCombo Documentation
TextSet Class
Members See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : TextSet Class

Provides a centralized access for customizing texts which used in WebCombo control. Provides a centralized access for customizing texts which used in WebCombo control.

Object Model

TextSet Class

Syntax

Visual Basic (Declaration)
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<SerializableAttribute()>
Public Class TextSet
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As TextSet
C#
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[SerializableAttribute()]
public class TextSet : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class TextSet = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
PersistenceModeAttribute(PersistenceMode.InnerProperty)
SerializableAttribute()
public class TextSet extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[SerializableAttribute()]
public __gc class TextSet : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[SerializableAttribute()]
public ref class TextSet : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Remarks

In WebCombo.NET v4.0, TextSettings can be customized in WebCombo.NET Designer under Advanced Settings - LayoutSettings - Text Settings node. You can customize each property in TextSettings, such as the LoadingText, NoResultsText, SearchText, etc. by simply edit the default text settings defined.

The combo-level TextSettings customization is the lowest level which will override the definition in default xml language file as well as custom defined language file. This provides flexibility to developers who wanted to customize specific TextItem that applicable to a combo instance only. Note that all properties in TextSettings should be removed in order for the new combo to work properly.

You can customize almost all text that is used in WebCombo control, such as the Loading text, Search text, etc.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebCombo.TextSet

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextSet Members
ISNet.WebUI.WebCombo Namespace

Concepts

Text Settings


TextSet Class Members

[image]
Intersoft WebCombo Documentation
TextSet Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebCombo Namespace : TextSet Class

The following tables list the members exposed by TextSet.

Public Constructors

 | Name | Description
public Constructor | TextSet Constructor |
Top

Public Properties

 | Name | Description
public Property | HelpTitleText | Specifies the text that will appear when mouse is over the Help button. Specifies the text that will appear when mouse is over the Help button.
public Property | LoadingText | Specifies the loading text. Specifies the loading text.
public Property | MoreTitleText | Specifies the text that will appear when mouse is over the More button. Specifies the text that will appear when mouse is over the More button.
public Property | NoResultsText | Specifies the no result text. Specifies the no results text.
public Property | ParentEmptyPromptText | Specifies the text used for the prompt when ParentEmptyAction is set to PromptMessage. Specifies the text used for the prompt when ParentEmptyAction is set to PromptMessage.
public Property | RetrievedTextFormat | Specifies the retrieved text format. Specifies the retrieved text format.
public Property | SearchText | Specifies the search text. Specifies the search text.
public Property | UnhandledErrorText | Specifies the text that will appear in the error box when an unhandled exception occurred. Specifies the text that will appear in the error box when an unhandled exception occurred.
Top

Public Methods

 | Name | Description
public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | GetObjectData | Overridden.
public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | ToString |
Top

See Also

Reference

TextSet Class
ISNet.WebUI.WebCombo Namespace


TextSet Constructor

[image]
Intersoft WebCombo Documentation
TextSet Constructor
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > TextSet Class : TextSet Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New TextSet()
C#
public TextSet()
Delphi
public TextSet();
JScript
public function TextSet();
Managed Extensions for C++
public: TextSet();
C++/CLI
public:
TextSet();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextSet Class
TextSet Members


Clone Method

[image]
Intersoft WebCombo Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > TextSet Class : Clone Method

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As TextSet
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()
Delphi
public function Clone(): TObject; virtual;
JScript
public function Clone() : Object;
Managed Extensions for C++
public: virtual Object* Clone();
C++/CLI
public:
virtual Object^ Clone();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextSet Class
TextSet Members


CopyFrom Method

[image]
Intersoft WebCombo Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > TextSet Class : CopyFrom Method

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextSet Class
TextSet Members


CopyFrom(Object) Method

[image]
Intersoft WebCombo Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > TextSet Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As TextSet
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)
Delphi
public procedure CopyFrom(
    objSource: TObject
); virtual;
JScript
public function CopyFrom(
   objSource : Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextSet Class
TextSet Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebCombo Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > TextSet Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As TextSet
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: TObject;
    cloneSourceValue: Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : Object,
   cloneSourceValue : boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   Object* objSource,
   bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   Object^ objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextSet Class
TextSet Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebCombo Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > TextSet Class : DeSerializeObjectData Method

type
info
context

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As TextSet
Dim type As Type
Dim info As SerializationInfo
Dim context As StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: Type;
    info: SerializationInfo;
    context: StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : Type,
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   Type* type,
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   Type^ type,
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextSet Class
TextSet Members


TextSet Class Methods

[image]
Intersoft WebCombo Documentation
TextSet Class Methods
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : TextSet Class

For a list of all members of this type, see TextSet members.

Public Methods

 | Name | Description
public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | GetObjectData | Overridden.
public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | ToString |
Top

See Also

Reference

TextSet Class
ISNet.WebUI.WebCombo Namespace


GetObjectData Method

[image]
Intersoft WebCombo Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > TextSet Class : GetObjectData Method

info
context

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As TextSet
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: SerializationInfo;
    context: StreamingContext
); override;
JScript
public override function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextSet Class
TextSet Members


IsEmpty Method

[image]
Intersoft WebCombo Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > TextSet Class : IsEmpty Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TextSet
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()
Delphi
public function IsEmpty(): Boolean; virtual;
JScript
public function IsEmpty() : boolean;
Managed Extensions for C++
public: virtual bool IsEmpty();
C++/CLI
public:
virtual bool IsEmpty();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextSet Class
TextSet Members


Reset Method

[image]
Intersoft WebCombo Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > TextSet Class : Reset Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As TextSet

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextSet Class
TextSet Members


SerializeObjectData Method

[image]
Intersoft WebCombo Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > TextSet Class : SerializeObjectData Method

type
info
context

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As TextSet
Dim type As Type
Dim info As SerializationInfo
Dim context As StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: Type;
    info: SerializationInfo;
    context: StreamingContext
);
JScript
public function SerializeObjectData(
   type : Type,
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   Type* type,
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   Type^ type,
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextSet Class
TextSet Members


ToString Method

[image]
Intersoft WebCombo Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > TextSet Class : ToString Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As TextSet
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Delphi
public function ToString(): String; override;
JScript
public override function ToString() : String;
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextSet Class
TextSet Members


TextSet Class Properties

[image]
Intersoft WebCombo Documentation
TextSet Class Properties
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : TextSet Class

For a list of all members of this type, see TextSet members.

Public Properties

 | Name | Description
public Property | HelpTitleText | Specifies the text that will appear when mouse is over the Help button. Specifies the text that will appear when mouse is over the Help button.
public Property | LoadingText | Specifies the loading text. Specifies the loading text.
public Property | MoreTitleText | Specifies the text that will appear when mouse is over the More button. Specifies the text that will appear when mouse is over the More button.
public Property | NoResultsText | Specifies the no result text. Specifies the no results text.
public Property | ParentEmptyPromptText | Specifies the text used for the prompt when ParentEmptyAction is set to PromptMessage. Specifies the text used for the prompt when ParentEmptyAction is set to PromptMessage.
public Property | RetrievedTextFormat | Specifies the retrieved text format. Specifies the retrieved text format.
public Property | SearchText | Specifies the search text. Specifies the search text.
public Property | UnhandledErrorText | Specifies the text that will appear in the error box when an unhandled exception occurred. Specifies the text that will appear in the error box when an unhandled exception occurred.
Top

See Also

Reference

TextSet Class
ISNet.WebUI.WebCombo Namespace


TextSet Constructor

[image]
Intersoft WebCombo Documentation
TextSet Constructor
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > TextSet Class : TextSet Constructor

Initializes a new instance of the TextSet class.

Overload List

Overload | Description
TextSet Constructor |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextSet Class
TextSet Members


HelpTitleText Property

[image]
Intersoft WebCombo Documentation
HelpTitleText Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > TextSet Class : HelpTitleText Property

Specifies the text that will appear when mouse is over the Help button. Specifies the text that will appear when mouse is over the Help button.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies the text that will appear when mouse is over the Help button.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
Public Property HelpTitleText As String
Visual Basic (Usage) Copy Code
Dim instance As TextSet
Dim value As String

instance.HelpTitleText = value

value = instance.HelpTitleText
C#
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the text that will appear when mouse is over the Help button.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public string HelpTitleText {get; set;}
Delphi
public read-write property HelpTitleText: String;
JScript
DefaultValueAttribute()
DescriptionAttribute("Specifies the text that will appear when mouse is over the Help button.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
public function get,set HelpTitleText : String
Managed Extensions for C++
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the text that will appear when mouse is over the Help button.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public: __property string* get_HelpTitleText();
public: __property void set_HelpTitleText(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the text that will appear when mouse is over the Help button.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public:
property String^ HelpTitleText {
   String^ get();
   void set (    String^ value);
}

Remarks

The default value of this property is "Help".

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextSet Class
TextSet Members

Concepts

Text Settings


LoadingText Property

[image]
Intersoft WebCombo Documentation
LoadingText Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > TextSet Class : LoadingText Property

Specifies the loading text. Specifies the loading text.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Specifies the loading text.")>
Public Property LoadingText As String
Visual Basic (Usage) Copy Code
Dim instance As TextSet
Dim value As String

instance.LoadingText = value

value = instance.LoadingText
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies the loading text.")]
public string LoadingText {get; set;}
Delphi
public read-write property LoadingText: String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
DescriptionAttribute("Specifies the loading text.")
public function get,set LoadingText : String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies the loading text.")]
public: __property string* get_LoadingText();
public: __property void set_LoadingText(
   string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies the loading text.")]
public:
property String^ LoadingText {
   String^ get();
   void set (    String^ value);
}

Remarks

The default value of this property is "Loading..."

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextSet Class
TextSet Members


MoreTitleText Property

[image]
Intersoft WebCombo Documentation
MoreTitleText Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > TextSet Class : MoreTitleText Property

Specifies the text that will appear when mouse is over the More button. Specifies the text that will appear when mouse is over the More button.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies the text that will appear when mouse is over the More button.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
Public Property MoreTitleText As String
Visual Basic (Usage) Copy Code
Dim instance As TextSet
Dim value As String

instance.MoreTitleText = value

value = instance.MoreTitleText
C#
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the text that will appear when mouse is over the More button.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public string MoreTitleText {get; set;}
Delphi
public read-write property MoreTitleText: String;
JScript
DefaultValueAttribute()
DescriptionAttribute("Specifies the text that will appear when mouse is over the More button.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
public function get,set MoreTitleText : String
Managed Extensions for C++
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the text that will appear when mouse is over the More button.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public: __property string* get_MoreTitleText();
public: __property void set_MoreTitleText(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the text that will appear when mouse is over the More button.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public:
property String^ MoreTitleText {
   String^ get();
   void set (    String^ value);
}

Remarks

The default value of this property is "More Records".

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextSet Class
TextSet Members


NoResultsText Property

[image]
Intersoft WebCombo Documentation
NoResultsText Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > TextSet Class : NoResultsText Property

Specifies the no result text. Specifies the no results text.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Specifies the no results text.")>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property NoResultsText As String
Visual Basic (Usage) Copy Code
Dim instance As TextSet
Dim value As String

instance.NoResultsText = value

value = instance.NoResultsText
C#
[DescriptionAttribute("Specifies the no results text.")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public string NoResultsText {get; set;}
Delphi
public read-write property NoResultsText: String;
JScript
DescriptionAttribute("Specifies the no results text.")
NotifyParentPropertyAttribute()
DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set NoResultsText : String
Managed Extensions for C++
[DescriptionAttribute("Specifies the no results text.")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property string* get_NoResultsText();
public: __property void set_NoResultsText(
   string* value
);
C++/CLI
[DescriptionAttribute("Specifies the no results text.")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property String^ NoResultsText {
   String^ get();
   void set (    String^ value);
}

Remarks

The default value of this property is "No results found".

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextSet Class
TextSet Members


ParentEmptyPromptText Property

[image]
Intersoft WebCombo Documentation
ParentEmptyPromptText Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > TextSet Class : ParentEmptyPromptText Property

Specifies the text used for the prompt when ParentEmptyAction is set to PromptMessage. Specifies the text used for the prompt when ParentEmptyAction is set to PromptMessage.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies the text used for the prompt when ParentEmptyAction is set to PromptMessage.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
Public Property ParentEmptyPromptText As String
Visual Basic (Usage) Copy Code
Dim instance As TextSet
Dim value As String

instance.ParentEmptyPromptText = value

value = instance.ParentEmptyPromptText
C#
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the text used for the prompt when ParentEmptyAction is set to PromptMessage.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public string ParentEmptyPromptText {get; set;}
Delphi
public read-write property ParentEmptyPromptText: String;
JScript
DefaultValueAttribute()
DescriptionAttribute("Specifies the text used for the prompt when ParentEmptyAction is set to PromptMessage.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
public function get,set ParentEmptyPromptText : String
Managed Extensions for C++
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the text used for the prompt when ParentEmptyAction is set to PromptMessage.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public: __property string* get_ParentEmptyPromptText();
public: __property void set_ParentEmptyPromptText(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the text used for the prompt when ParentEmptyAction is set to PromptMessage.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public:
property String^ ParentEmptyPromptText {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextSet Class
TextSet Members


RetrievedTextFormat Property

[image]
Intersoft WebCombo Documentation
RetrievedTextFormat Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > TextSet Class : RetrievedTextFormat Property

Specifies the retrieved text format. Specifies the retrieved text format.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Specifies the retrieved text format.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
Public Property RetrievedTextFormat As String
Visual Basic (Usage) Copy Code
Dim instance As TextSet
Dim value As String

instance.RetrievedTextFormat = value

value = instance.RetrievedTextFormat
C#
[DescriptionAttribute("Specifies the retrieved text format.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
public string RetrievedTextFormat {get; set;}
Delphi
public read-write property RetrievedTextFormat: String;
JScript
DescriptionAttribute("Specifies the retrieved text format.")
ISNet.Serialization.XmlSerializableAttribute()
NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
public function get,set RetrievedTextFormat : String
Managed Extensions for C++
[DescriptionAttribute("Specifies the retrieved text format.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
public: __property string* get_RetrievedTextFormat();
public: __property void set_RetrievedTextFormat(
   string* value
);
C++/CLI
[DescriptionAttribute("Specifies the retrieved text format.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
public:
property String^ RetrievedTextFormat {
   String^ get();
   void set (    String^ value);
}

Remarks

With this property, you can change the way retrieved text is formatted.

{retrieved} is the total rows retrieved in WebCombo control.

{totalrows} is the total rows of the DataSource object.

With this property, you can change the way retrieved text is formatted.

{retrieved} is the total rows retrieved in WebCombo control.

{totalrows} is the total rows of the WebCombo.DataSource object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextSet Class
TextSet Members


SearchText Property

[image]
Intersoft WebCombo Documentation
SearchText Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > TextSet Class : SearchText Property

Specifies the search text. Specifies the search text.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Specifies the search text.")>
<DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property SearchText As String
Visual Basic (Usage) Copy Code
Dim instance As TextSet
Dim value As String

instance.SearchText = value

value = instance.SearchText
C#
[DescriptionAttribute("Specifies the search text.")]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public string SearchText {get; set;}
Delphi
public read-write property SearchText: String;
JScript
DescriptionAttribute("Specifies the search text.")
DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set SearchText : String
Managed Extensions for C++
[DescriptionAttribute("Specifies the search text.")]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property string* get_SearchText();
public: __property void set_SearchText(
   string* value
);
C++/CLI
[DescriptionAttribute("Specifies the search text.")]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property String^ SearchText {
   String^ get();
   void set (    String^ value);
}

Remarks

The default value of this property is "Search for".

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextSet Class
TextSet Members


UnhandledErrorText Property

[image]
Intersoft WebCombo Documentation
UnhandledErrorText Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > TextSet Class : UnhandledErrorText Property

Specifies the text that will appear in the error box when an unhandled exception occurred. Specifies the text that will appear in the error box when an unhandled exception occurred.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies the text that will appear in the error box when an unhandled exception occurred.")>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property UnhandledErrorText As String
Visual Basic (Usage) Copy Code
Dim instance As TextSet
Dim value As String

instance.UnhandledErrorText = value

value = instance.UnhandledErrorText
C#
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the text that will appear in the error box when an unhandled exception occurred.")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public string UnhandledErrorText {get; set;}
Delphi
public read-write property UnhandledErrorText: String;
JScript
DefaultValueAttribute()
DescriptionAttribute("Specifies the text that will appear in the error box when an unhandled exception occurred.")
NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set UnhandledErrorText : String
Managed Extensions for C++
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the text that will appear in the error box when an unhandled exception occurred.")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property string* get_UnhandledErrorText();
public: __property void set_UnhandledErrorText(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the text that will appear in the error box when an unhandled exception occurred.")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property String^ UnhandledErrorText {
   String^ get();
   void set (    String^ value);
}

Remarks

The default value of this property is "Unhandled exception occurred. See following for details."

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextSet Class
TextSet Members


ValueChangedEventArgs Class

[image]
Intersoft WebCombo Documentation
ValueChangedEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : ValueChangedEventArgs Class

Events class contains all event argument definitions that are used in WebCombo control.

Events class contains all event argument definitions that are used in WebCombo control.

Object Model

ValueChangedEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class ValueChangedEventArgs
   Inherits BaseEventArgs
Visual Basic (Usage) Copy Code
Dim instance As ValueChangedEventArgs
C#
public class ValueChangedEventArgs : BaseEventArgs
Delphi
public class ValueChangedEventArgs = class(BaseEventArgs)
JScript
public class ValueChangedEventArgs extends BaseEventArgs
Managed Extensions for C++
public __gc class ValueChangedEventArgs : public BaseEventArgs
C++/CLI
public ref class ValueChangedEventArgs : public BaseEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebCombo.BaseEventArgs
ISNet.WebUI.WebCombo.ValueChangedEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ValueChangedEventArgs Members
ISNet.WebUI.WebCombo Namespace


ValueChangedEventArgs Class Members

[image]
Intersoft WebCombo Documentation
ValueChangedEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebCombo Namespace : ValueChangedEventArgs Class

The following tables list the members exposed by ValueChangedEventArgs.

Public Properties

 | Name | Description
public Property | ReturnValue | (Inherited from ISNet.WebUI.WebCombo.BaseEventArgs)
public Property | Text |
public Property | Value |
Top

See Also

Reference

ValueChangedEventArgs Class
ISNet.WebUI.WebCombo Namespace


ValueChangedEventArgs Class Properties

[image]
Intersoft WebCombo Documentation
ValueChangedEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : ValueChangedEventArgs Class

For a list of all members of this type, see ValueChangedEventArgs members.

Public Properties

 | Name | Description
public Property | ReturnValue | (Inherited from ISNet.WebUI.WebCombo.BaseEventArgs)
public Property | Text |
public Property | Value |
Top

See Also

Reference

ValueChangedEventArgs Class
ISNet.WebUI.WebCombo Namespace


Text Property

[image]
Intersoft WebCombo Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ValueChangedEventArgs Class : Text Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As ValueChangedEventArgs
Dim value As String

value = instance.Text
C#
public string Text {get;}
Delphi
public read-only property Text: String;
JScript
public function get Text : String
Managed Extensions for C++
public: __property string* get_Text();
C++/CLI
public:
property String^ Text {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ValueChangedEventArgs Class
ValueChangedEventArgs Members


Value Property

[image]
Intersoft WebCombo Documentation
Value Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > ValueChangedEventArgs Class : Value Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As String
Visual Basic (Usage) Copy Code
Dim instance As ValueChangedEventArgs
Dim value As String

value = instance.Value
C#
public string Value {get;}
Delphi
public read-only property Value: String;
JScript
public function get Value : String
Managed Extensions for C++
public: __property string* get_Value();
C++/CLI
public:
property String^ Value {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ValueChangedEventArgs Class
ValueChangedEventArgs Members


WebCombo Class

[image]
Intersoft WebCombo Documentation
WebCombo Class
Members Example See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : WebCombo Class

WebCombo is the main control object. WebCombo provides advanced data-bound functionality without additional server pages or components. The LayoutSettings property contains many of the appearance and layout settings for WebCombo.

WebCombo is the main control object. The LayoutSettings property contains many of the appearance and layout settings for WebCombo. WebCombo provides advanced data-bound functionality without additional server pages or components.

Object Model

WebCombo Class

Syntax

Visual Basic (Declaration)
<ValidationPropertyAttribute("Value")>
<DescriptionAttribute("Displays combo box or dropdown list control in web page for data entry purpose with advanced input functionality.")>
<ISNet.Serialization.XmlSerializableAttribute("WebCombo.js;Shared\ISCore_UI.js")>
<DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebCombo.WebComboDesigner, ISNet.WebUI.WebCombo, Version=5.0.7200.1, Culture=neutral, PublicKeyToken=c4184ef0d326354b")>
<DefaultEventAttribute("InitializeDataSource")>
<ToolboxDataAttribute("<{0}:WebCombo runat="server" UseDefaultStyle="true"></{0}:WebCombo>")>
<DefaultPropertyAttribute("LayoutSettings")>
<SerializableAttribute()>
<AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
<AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Public Class WebCombo
   Inherits ISNet.WebUI.ISNetControl
   Implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IAutoDataCache, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IClientBinding, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ISDataSource
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
C#
[ValidationPropertyAttribute("Value")]
[DescriptionAttribute("Displays combo box or dropdown list control in web page for data entry purpose with advanced input functionality.")]
[ISNet.Serialization.XmlSerializableAttribute("WebCombo.js;Shared\ISCore_UI.js")]
[DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebCombo.WebComboDesigner, ISNet.WebUI.WebCombo, Version=5.0.7200.1, Culture=neutral, PublicKeyToken=c4184ef0d326354b")]
[DefaultEventAttribute("InitializeDataSource")]
[ToolboxDataAttribute("<{0}:WebCombo runat="server" UseDefaultStyle="true"></{0}:WebCombo>")]
[DefaultPropertyAttribute("LayoutSettings")]
[SerializableAttribute()]
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public class WebCombo : ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IAutoDataCache, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IClientBinding, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ISDataSource
Delphi
public class WebCombo = class(ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IAutoDataCache, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IClientBinding, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ISDataSource)
JScript
ValidationPropertyAttribute("Value")
DescriptionAttribute("Displays combo box or dropdown list control in web page for data entry purpose with advanced input functionality.")
ISNet.Serialization.XmlSerializableAttribute("WebCombo.js;Shared\ISCore_UI.js")
DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebCombo.WebComboDesigner, ISNet.WebUI.WebCombo, Version=5.0.7200.1, Culture=neutral, PublicKeyToken=c4184ef0d326354b")
DefaultEventAttribute("InitializeDataSource")
ToolboxDataAttribute("<{0}:WebCombo runat="server" UseDefaultStyle="true"></{0}:WebCombo>")
DefaultPropertyAttribute("LayoutSettings")
SerializableAttribute()
AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
public class WebCombo extends ISNet.WebUI.ISNetControl implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IAutoDataCache, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IClientBinding, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ISDataSource
Managed Extensions for C++
[ValidationPropertyAttribute("Value")]
[DescriptionAttribute("Displays combo box or dropdown list control in web page for data entry purpose with advanced input functionality.")]
[ISNet.Serialization.XmlSerializableAttribute("WebCombo.js;Shared\ISCore_UI.js")]
[DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebCombo.WebComboDesigner, ISNet.WebUI.WebCombo, Version=5.0.7200.1, Culture=neutral, PublicKeyToken=c4184ef0d326354b")]
[DefaultEventAttribute("InitializeDataSource")]
[ToolboxDataAttribute("<{0}:WebCombo runat="server" UseDefaultStyle="true"></{0}:WebCombo>")]
[DefaultPropertyAttribute("LayoutSettings")]
[SerializableAttribute()]
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public __gc class WebCombo : public ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IAutoDataCache, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IClientBinding, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ISDataSource
C++/CLI
[ValidationPropertyAttribute("Value")]
[DescriptionAttribute("Displays combo box or dropdown list control in web page for data entry purpose with advanced input functionality.")]
[ISNet.Serialization.XmlSerializableAttribute("WebCombo.js;Shared\ISCore_UI.js")]
[DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebCombo.WebComboDesigner, ISNet.WebUI.WebCombo, Version=5.0.7200.1, Culture=neutral, PublicKeyToken=c4184ef0d326354b")]
[DefaultEventAttribute("InitializeDataSource")]
[ToolboxDataAttribute("<{0}:WebCombo runat="server" UseDefaultStyle="true"></{0}:WebCombo>")]
[DefaultPropertyAttribute("LayoutSettings")]
[SerializableAttribute()]
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public ref class WebCombo : public ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IAutoDataCache, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IClientBinding, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ISDataSource

Example

The following example shows you how to create a WebCombo programmatically.
C# Copy Code
private void Page_Load(object sender, System.EventArgs e)
{
    WebCombo wc = new WebCombo();
    wc.ID = "WebCombo1";
    wc.InitializeDataSource +=     new DataSourceEventHandler(wc_InitializeDataSource);
    wc.InitializeLayout +=    new LayoutEventHandler(wc_InitializeLayout);
    HtmlForm frm = (HtmlForm) Page.FindControl("Form1");
    frm.Controls.Add(wc);
}

private void wc_InitializeDataSource(object sender, ISNet.WebUI.WebCombo.DataSourceEventArgs e)
{
    DataSet ds = new DataSet();
    OleDbDataAdapter da = new OleDbDataAdapter(
       "SELECT * FROM [Customers]", oleDbConnection1);
    da.Fill(ds, "Customers");
    e.DataSource = ds;
    WebCombo wc = (WebCombo)sender;
    wc.DataMember = "Customers";
    wc.DataTextField = "ContactName";
    wc.DataValueField = "CustomerID";
}

private void wc_InitializeLayout(object sender, ISNet.WebUI.WebCombo.LayoutEventArgs e)
{
    e.Layout.ComboMode = Mode.MultipleColumns;
    WebComboColumn colContactName = new WebComboColumn("ContactName");
    WebComboColumn colContactTitle = new WebComboColumn("ContactTitle");
    WebCombo wc = (WebCombo) sender;  wc.Columns.Add(colContactName);
    wc.Columns.Add(colContactTitle);
}

Remarks

The latest version of WebCombo.NET 4.0 is the successor of the previous version of WebCombo.NET which offer significant improvements and numerous new features. It focus on productivity features design specifically for Visual Studio 2005 development environment, such as ObjectDataSource data binding support and SmartTag Designer.

WebCombo.NET 4.0 is designed to deliver cleaner and lighter output for faster page rendering. This latest version is able to render work properly in XHTML 1.1 Transitional Doc Type.

WebCombo.NET 4.0 uses Vista style for its background animation support that allow users to deliver greater data input experience to your web application. As a result, the user interface of WebCombo.NET 4.0 is sleeker and smother than ever before.

The latest version of WebCombo.NET solves several problems and limitations that existed in the previous version such as the capability to input free text value and integration with WebMenu or other containers as the dropdown. These new features, along with some others make WebCombo.NET 4.0 the most powerful ComboBox component.

WebCombo.NET 4.0 will introduce a new framework (WebUI.NET Framework 2007 R1). There are some new changes in WebUI.NET Framework 2007 R1 that can improve the performance on your web application. Those new features are:

  1. ViewStateStorage. We have improved the ViewStateStorage feature using new OptimizedState architecture that based on "Delta changes." The default value for this feature is now set to Client instead of PageCache. The reasons we decided to use Client as the default value are to reduce the viewstate size of a control and to confirm standard mechanism as in standard.NET controls. In previous version of framework, there are three kind of storage for saving ViewState (PageCache, Session and Client). In 2007 R1, ViewStateStorage includes new option to save the state to physical disk. The option called FileServer enables the view state to be saved to a physical disk in the local computer or a shared drive in network. The FileServer cache option solved many barriers around view state topic. With FileServer, you no longer have to worry about memory leaks or limited server resources. Some of benefits using FileServer cache are:
    • Highly scalable. You can choose a network drive to store the caches which enable multiple web servers to access the state.
    • Decent performance. With more than dozen of high performance hard drives, you can choose a near-memory speed with high random access and sequential read write hard drive to store the caches.
    • Easily extensible. Unlike memory (RAM), you can easily extend hard drives with larger one when it becomes insufficient.
  2. ViewStateItems. This new feature works in conjunction with ViewStateStorage. ViewStateItems allow advanced developers to set what type of items that should be saved in ViewState. The default value ViewStateItems is Behavior.

For more information on new features in WebUI.NET Framework 2007 R1, please read the WebUI.NET Framework 2007 R1 documentation.

New SmartWebResources™ Framework

Our new products, including WebCombo.NET v4.0, use new framework. The brand-new SmartWebResources Framework is one of the exciting technology that we had to offer in 2007 R1 platform. The key objective of SmartWebResources™ is to eliminate the external physical resources – such as scripts, images, etc – which required by web components to function properly.

SmartWebResources™ takes advantage of custom HTTP Handler extensibility and tightly integrated into WebUI.NET Framework runtime to deliver high performance, secure and highly reusable components.

Some of the features and benefits introduced by SmartWebResources™ :

  • Better throughput: IIS6 Kernel-level Caching
  • More secure: Does not use query string
  • Faster performance: Does not use Reflection. The SmartWebResources does not use WebResourceAttribute mechanism, so avoiding the needs to use Reflection.
  • Smaller output: Simpler path formatting and does not use long-encrypted string.
  • Hassle-free Deployment: No more external client resources are required during deployment. Only one assembly is required to be copied into your app's bin folder.
  • Reduced Complexity: SmartWebResources includes automatic web resources configuration. When in auto mode, the client resources will be retrieved from Web Resources assembly whenever possible. Otherwise, it will automatically fallback the retrieval from traditional external resources which stored in IIS virtual directory (also known as CommonLibrary).
  • Easy to Configure: Easily configure the settings from application level. You can also customize the settings for individual control's instances for more precise control.
  • Flexibility: You can easily switch between SmartWebResources or external resources mode through EnableWebResources setting.
  • Seamless integration with VS 2005: The handlers and resources configuration can seamlessly added to your web application configuration.

To learn more on SmartWebResources™ and how it works, please read SmartWebResources Documentation and How-to: Configure SmartWebResources™ in a web application.

Codeless DataBinding

WebCombo.NET version 4.0 also introduce you to a new codeless data binding experience. It will be one of the most important productivity gains that you can experience. Codeless databinding means that you can configure the datasource, its connection and its related property without writing codes. You can do everything by simply using drag, drop and click.

Declaratively, you can create a WebCombo instance and bind it to a table in your Sql database in two simple statements as in the following:

<ISWebCombo:WebCombo ID="WebCombo1" runat="server"
UseDefaultStyle="True" Width="200px" Height="20px"
DataSourceID="SqlDataSource1" DataTextField="ActivityName"
DataValueField="ActivitiesId">
</ISWebCombo:WebCombo>

<asp:SqlDataSource ID="SqlDataSource1" runat="server"
ConnectionString="<%$ ConnectionStrings:DbConnectionString %>"
SelectCommand="SELECT * FROM [Activities]">
</asp:SqlDataSource>

As you can see with the above statements, the WebCombo1 is bound to a datasource control through DataSourceID property. The WebCombo connects to the specified datasource control and display data from the datasource available in SqlDataSource1.

To learn more about how to bind WebCombo to AccessDataSourceControl, please read Walkthrough: Binding WebCombo to AccessDataSource control .

To learn more about how to bind WebCombo to ObjectDataSourceControl, please read Walkthrough: Binding WebCombo to ObjectDataSource control .

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebCombo.WebCombo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Members
ISNet.WebUI.WebCombo Namespace

Tasks

Walkthrough: Binding WebCombo to XMLDataSource control
Walkthrough: Binding WebCombo to SqlDataSource control
Walkthrough: Binding WebCombo to ISDataSource control
Walkthrough: Binding WebCombo to IList DataSource control
Walkthrough: Binding WebCombo to custom object
Walkthrough: Binding WebCombo to a DataSet
Walkthrough: Binding WebCombo to XML-based DataSource
Walkthrough: Binding multiple WebCombo instances to ISDataSource control
Walkthrough: Binding WebCombo to AccessDataSource control
Walkthrough: Binding WebCombo to ObjectDataSource control
How-to: Disable WebResources
How-to: Refresh WebCombo
How-to: Apply load on demand in WebCombo

Concepts

No-codes data binding through DataSourceControl support
Data Binding


WebCombo Class Members

[image]
Intersoft WebCombo Documentation
WebCombo Class Members
See Also Fields Properties Methods Events Send Feedback
ISNet.WebUI.WebCombo Namespace : WebCombo Class

The following tables list the members exposed by WebCombo.

Public Constructors

 | Name | Description
public Constructor | WebCombo Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | SkipRowParsing |
public Field | TotalDataSourceRows |
Top

Public Properties

 | Name | Description
public Property | AccessKey | Keyboard shortcut used by the control. (Inherited from System.Web.UI.WebControls.WebControl)
public Property | AdditionalSearchFields | Returns or sets the additional data field used to match rows against user's input. Returns or sets the additional data field used to match rows against user's input.
public Property | AllowAutoDataCaching | Specifies whether data caching is automatically handled by the control. Specifies whether data caching is automatically handled by the control.
public Property | AllowAutoPostback | Specifies whether postback will be automatically invoked when selected index is changed. Specifies whether postback will be automatically invoked when selected index is changed.
public Property | AllowAutoQueryHandler | Specifies whether or not to allow WebCombo to automatically handle query request. Specifies whether or not to allow WebCombo to automatically handle query request.
public Property | AllowWildCardSearch | Specifies whether or not to allow wild card searching / fuzzy logic searching. Specifies whether or not to allow wild card searching / fuzzy logic searching.
public Property | BackColor | Overridden. Returns or sets the background color of the control. Returns or sets the background color of the control.
public Property | BindingOperationMode |
public Property | BorderColor | Overridden. Returns or sets the border color of the control. Returns or sets the border color of the control.
public Property | BorderStyle | Overridden. Returns or sets the border style of the control. returns or sets the border style of the control.
public Property | BorderWidth | Overridden. Returns or sets the border width of the control. Returns or sets the border width of the control.
public Property | CacheServerConnection | Specifies the file server connection string to store data cache. Specifies the file server connection string to store data cache.
public Property | ClientBindingSettings |
public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
public Property | DataCacheStorage | Specifies where to store the data cache. Specifies where to store the data cache.
public Property | DataMember | Specifies the data member in multimember data source to bind to the WebCombo control. Specifies the data member in multimember data source to bind to the WebCombo control.
public Property | DataSource | Specifies the datasource object which the control bind to. Specifies the datasource object which the control bind to.
public Property | DataSourceID | Gets or sets the ID of the control from which the WebCombo control retrieves its list of data items.Gets or sets the ID of the control from which the WebCombo control retrieves its list of data items.
public Property | DataTextField | Returns or sets the data field used to display the text in WebCombo control. Returns or sets the data field used to display the text in WebCombo control.
public Property | DataValueField | Returns or sets the field used as the value in WebCombo control. Returns or sets the field used as the value in WebCombo control.
public Property | DropDownRows | Specifies the number of initial records retrieved by the WebCombo control. Specifies the number of initial records retrieved by the WebCombo control.
public Property | Enabled | Gets or sets the enabled state of the control. (Inherited from System.Web.UI.WebControls.WebControl)
public Property | EnableManagedTheming | Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture. (Inherited from ISNet.WebUI.ISNetControl)
public Property | EnableTheming | (Inherited from System.Web.UI.Control)
public Property | EnableViewState | Gets or sets whether the control automatically saves its state for use in round-trip. (Inherited from System.Web.UI.Control)
public Property | EnableWebResources | Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). (Inherited from ISNet.WebUI.ISNetControl)
public Property | FlyPostBackSettings | Configures the settings used by the control when performing OnTheFly postback. Configures the settings used by the control when performing OnTheFly postback.
public Property | Font | Overridden. Returns or sets the font used in the control. Returns or sets the font used in the control.
public Property | ForeColor | Overridden. Returns or sets a Color object that specifies the foreground color of the control.Returns or sets a Color object that specifies the foreground color of the control.
public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
public Property | ID | (Inherited from System.Web.UI.Control)
public Property | IntegrationSettings | Provides settings for integrating other server side controls as the WebCombo's ResultBox.
public Property | Latency | Specifies the wait time after last keypress in milliseconds before the control make data request. Specifies the wait time after last keypress in milliseconds before the control make data request.
public Property | LayoutSettings | The central object that contain all the behaviors and styles for the whole WebCombo control. LayoutSettings is the central object that contain all the behaviors and styles for the whole WebCombo control.
public Property | LinkSettings | Provides settings for linking to another WebCombo. Provides settings for linking to another WebCombo.
public Property | MinCharsToRequest | Returns or sets the minimum length of input character for requesting data retrieval. Returns or sets the minimum length of input character for requesting data retrieval.
public Property | MultipleSelectionSettings | Provides settings for multiple selections feature. Provides settings for multiple selections feature.
public Property | Page | (Inherited from System.Web.UI.Control)
public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
public Property | RuntimeLicenseKey | The runtime license key for xcopy deployment. Registered customers please obtain through Intersoft Developer Network. (Inherited from ISNet.WebUI.ISNetControl)
public Property | ScriptDirectory | Overridden. Overriden.
public Property | SerializeTagToClient |
public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all shared scripts for Intersoft controls are stored.
public Property | ShowErrorMessages | Specifies whether to display error messages when DataSources, DataTextField or DataValueField is not specified.Specifies whether error messages always be shown when no datasource, datatextfield or datavaluefield is specified.
public Property | SkinID | (Inherited from System.Web.UI.Control)
public Property | TabIndex | The tab order of the control. (Inherited from System.Web.UI.WebControls.WebControl)
public Property | TextBoxLength | Specifies the size of the textbox control. Specifies the size of the textbox control.
public Property | ToolTip | The tooltip displayed when the mouse is over the control. (Inherited from System.Web.UI.WebControls.WebControl)
public Property | UseCachedDataOnFirstLoad | Specifies whether the cached data source will always be used on first page load. Specifies whether the cached data source will always be used on first page load.
public Property | UseDefaultStyle | Indicates whether this control should use default WebCombo.NET 4.0 styles and appearance settings. Indicates whether this control should use default WebCombo.NET 4.0 styles and appearance settings. See Help for more information.
public Property | Value | Returns or sets the value for WebCombo control. Returns or sets the value for WebCombo control.
public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
public Property | Visible | Gets or sets a value indicating whether the control is rendered as UI on the page. (Inherited from System.Web.UI.Control)
public Property | Width | Overridden. Overriden. Returns or sets the width of the control. Returns or sets the width of the control.
public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Methods

 | Name | Description
public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
public Method | CheckConstrains | Overridden.
public Method | ClearCachedDataSource | Clears the cached data source. Clears the cached data source.
public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
public Method | DataBind | Overridden. Starts databinding process for the WebCombo control.
public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
public Method | Dispose | (Inherited from System.Web.UI.Control)
public Method | FindControl | (Inherited from System.Web.UI.Control)
public Method | Focus | Overridden.
public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
public Method | GetCachedDataSource | Gets the currently cached data source of the specified control. Get the currently cached data source of the specified control.
public Method | GetClientAction | Gets the client action engine that designed to bridge the gaps between client and server.
public Method | GetColumn | Returns Column object which provide access to basic column properties. You should only use this method when ComboMode is set to MultipleColumns. Returns Column object which provide access to basic column properties. You should only use this method when ComboMode is set to MultipleColumns.
public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
public Method | GetIntersoftFolder | Gets the folder path of Intersoft Solutions. (Inherited from ISNet.WebUI.ISNetControl)
public Method | GetLayoutFolder | Gets the folder path of the layout files of WebCombo. (Inherited from ISNet.WebUI.ISNetControl)
public Method | GetMultipleValues | Gets the multiple values collection in ArrayList object. Gets the multiple values collection in ArrayList object.
public Method | GetMultipleValuesText | Gets the string representation of multiple values' Text. Each values will be separated by the character specified in SeparatorChar property, followed by a space. Gets the string representation of multiple values' Text. Each values will be separated by the character specified in SeparatorChar property, followed by a space.
public Method | GetMultipleValuesValue | Gets the string representation of multiple values' Value. Each values will be separated by the character specified in SeparatorChar property, followed by a space. Gets the string representation of multiple values' Value. Each values will be separated by the character specified in SeparatorChar property, followed by a space.
public Method | GetObjectData | Overridden.
public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
public Method | GetValueByText | Returns a value by specified text from datasource. Returns a value by specified text from datasource.
public Method | HasControls | (Inherited from System.Web.UI.Control)
public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
public Method | IsDataCached | Returns whether the Datasource is already cached. Returns whether the Datasource is already cached.
public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
public Method | IsFlyPostBackControl | Determines whether this instance of WebGrid is the one which invoking FlyPostBack request. (Inherited from ISNet.WebUI.ISNetControl)
public Method | IsFlyPostBackRequest | Determines whether the current postback is a FlyPostBack (AJAX) request. (Inherited from ISNet.WebUI.ISNetControl)
public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
public Method | LoadLayout | Overloaded. Developers can save commonly used Layout and apply it to WebCombo at runtime. This also enables developers to create highly customizable look and feel web applications by saving a few layout themes and let users choose their preferences at runtime.
public Method | LoadLayoutFromFile | Overridden. Restore WebCombo's layout settings and visual styles by loading it from a file.
public Method | LoadLayoutFromPredefinedName | Restore WebCombo's layout settings and visual styles by loading it from predefined name. (Inherited from ISNet.WebUI.ISNetControl)
public Method | LoadLayoutFromStream | Restore WebCombo's layout settings and visual styles by loading it from memory stream. (Inherited from ISNet.WebUI.ISNetControl)
public Method | LoadPostData | Overridden.
public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
public Method | OnAddItem | Invoked when an item is about to be added.
public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
public Method | OnInitializeDataSource | Invoked when data source need to be initialized. It is highly recommended that you use this event to initialize your databinding code for more centralized and easy to maintain codes. Invoked when data source need to be initialized. It is highly recommended that you use this event to initialize your databinding code for more centralized and easy to maintain codes.
public Method | OnInitializeJsonRow |
public Method | OnInitializeLayout | Invoked when the WebCombo's layout needs to be initialized during data binding. You can write the codes to set WebCombo's appearance-related settings in this event. Invoked when the WebCombo's layout needs to be initialized during data binding. You can write the codes to set WebCombo's appearance-related settings in this event.
public Method | OnInitializePostBack | Invoked when the WebCombo is performing OnTheFly postback. You can handle this event to perform additional functions or create your own custom actions. Invoked when the WebCombo is performing OnTheFly postback. You can handle this event to perform additional functions or create your own custom actions.
public Method | OnInitializeRow | Invoked when a WebComboRow is being initialized for rendering. Invoked when a WebComboRow is being initialized for rendering.
public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
public Method | OnPrepareDataBinding | Invoked when data source ready to be binded.
public Method | OnValueChanged | Invoked when the value is changed. Invoked when the value is changed.
public Method | PopulateUnboundData | Overloaded. Populate the appropriate texts of the specified multiple values into a collection of WebComboValueItem objects. Called by the framework to save round-trip data from the WebCombo into the html ViewState variable.
public Method | PopulateValueItems | Populate the appropriate texts of the specified multiple values into a collection of WebComboValueItem objects. Populate the appropriate texts of the specified multiple values into a collection of WebComboValueItem objects.
public Method | RaisePostBackEvent | Called by the framework and raises post back event.
public Method | RaisePostDataChangedEvent | Overridden.
public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
public Method | RegisterScript | Overridden.
public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
public Method | ReInitialize | Forces WebCombo to be initialized. This method is useful when retrieving WebCombo object from persistence storage.
public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
public Method | RenderControl | (Inherited from System.Web.UI.Control)
public Method | RenderEndTag | Overridden.
public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
public Method | ResetStyleToDefault | Clear any styles associated with this control and set the control to use default WebCombo.NET style.
public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
public Method | SaveLayout | Overloaded. Saves LayoutSet properties to a file.Saves LayoutSet properties to a file.
public Method | SaveLayoutToFile | Saves WebCombo's layout settings properties to a file. (Inherited from ISNet.WebUI.ISNetControl)
public Method | SaveLayoutToStream | Saves WebCombo's layout settings properties to a memory stream. (Inherited from ISNet.WebUI.ISNetControl)
public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
public Method | SetCacheControl | Overrides the default data cache configuration. Overrides the default data cache configuration.
public Method | SetMultipleValues | Overloaded. Sets multiple values into the WebCombo. Sets multiple values into the WebCombo.
public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
public Method | ShowOnlyColumns | Show only the columns specified in fieldNames. You should only use this method when ComboMode is set to MultipleColumns. Show only the columns specified in fieldNames. You should only use this method when LayoutSet.ComboMode is set to MultipleColumns.
Top

Public Events

 | Name | Description
public Event | AddItem | Occurs when adding an item is performed.Manages delegates of the type ISNet.WebUI.WebGrid.RowEventHandler.
public Event | DataBinding | (Inherited from System.Web.UI.Control)
public Event | Disposed | (Inherited from System.Web.UI.Control)
public Event | Init | (Inherited from System.Web.UI.Control)
public Event | InitializeDataSource | Occurs when a datasource needs to be initialized during data binding.Manages delegates of the type DataSourceEventHandler.
public Event | InitializeJsonRow |
public Event | InitializeLayout | Occurs when the grid's layout needs to be initialized during data binding.Manages delegates of the type LayoutEventHandler.
public Event | InitializePostBack | Occurs when when OnTheFlyPostBack action needs to be initialized. Manages delegates of the type ISNet.WebUI.WebGrid.PostBackEventHandler.
public Event | InitializeRow | Occurs when a row is being initialized and about to be rendered.Manages delegates of the type ISNet.WebUI.WebGrid.RowEventHandler.
public Event | Load | (Inherited from System.Web.UI.Control)
public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
public Event | PrepareDataBinding | Occurs when any data-related functionality is performed before the combo renders data.Manages delegates of the type DataSourceEventHandler.
public Event | PreRender | (Inherited from System.Web.UI.Control)
public Event | Unload | (Inherited from System.Web.UI.Control)
public Event | ValueChanged | Occurs when the value is changed.Manages delegates of type ValueChangedEventHandler
Top

See Also

Reference

WebCombo Class
ISNet.WebUI.WebCombo Namespace


WebCombo Constructor

[image]
Intersoft WebCombo Documentation
WebCombo Constructor
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : WebCombo Constructor

Initializes a new instance of the WebCombo class.

Overload List

Overload | Description
WebCombo Constructor() | Initializes a new instance of the WebCombo class with no argument. The default constructor for WebCombo. This constructor should not be called directly from code. To create WebCombo control from code, use WebCombo(id) instead.
WebCombo Constructor(String) | Initializes a new instance of the WebCombo class with Id parameter. Special constructor used to create WebCombo dynamically in code.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


WebCombo Constructor()

[image]
Intersoft WebCombo Documentation
WebCombo Constructor()
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class > WebCombo Constructor : WebCombo Constructor()

Initializes a new instance of the WebCombo class with no argument. The default constructor for WebCombo. This constructor should not be called directly from code. To create WebCombo control from code, use WebCombo(id) instead.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebCombo()
C#
public WebCombo()
Delphi
public WebCombo();
JScript
public function WebCombo();
Managed Extensions for C++
public: WebCombo();
C++/CLI
public:
WebCombo();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members
Overload List


WebCombo Constructor(String)

[image]
Intersoft WebCombo Documentation
WebCombo Constructor(String)
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class > WebCombo Constructor : WebCombo Constructor(String)

id
Initializes a new instance of the WebCombo class with Id parameter. Special constructor used to create WebCombo dynamically in code.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal id As String _
)
Visual Basic (Usage) Copy Code
Dim id As String

Dim instance As New WebCombo(id)
C#
public WebCombo(
   string id
)
Delphi
public WebCombo(
    id: String
);
JScript
public function WebCombo(
   id : String
);
Managed Extensions for C++
public: WebCombo(
   string* id
)
C++/CLI
public:
WebCombo(
   String^ id
)

Parameters

id

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members
Overload List


ApplyStyle Method

[image]
Intersoft WebCombo Documentation
ApplyStyle Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : ApplyStyle Method

s

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim s As Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   Style s
)
Delphi
public procedure ApplyStyle(
    s: Style
);
JScript
public function ApplyStyle(
   s : Style
);
Managed Extensions for C++
public: void ApplyStyle(
   Style* s
)
C++/CLI
public:
void ApplyStyle(
   Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebCombo Documentation
ApplyStyleSheetSkin Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : ApplyStyleSheetSkin Method

page

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim page As Page

instance.ApplyStyleSheetSkin(page)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual void ApplyStyleSheetSkin(
   Page page
)
Delphi
public procedure ApplyStyleSheetSkin(
    page: Page
); virtual;
JScript
EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function ApplyStyleSheetSkin(
   page : Page
);
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: virtual void ApplyStyleSheetSkin(
   Page* page
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual void ApplyStyleSheetSkin(
   Page^ page
)

Parameters

page

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


CanUseWebResources Method

[image]
Intersoft WebCombo Documentation
CanUseWebResources Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : CanUseWebResources Method

Syntax

Visual Basic (Declaration)
Public Function CanUseWebResources() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

value = instance.CanUseWebResources()
C#
public bool CanUseWebResources()
Delphi
public function CanUseWebResources(): Boolean;
JScript
public function CanUseWebResources() : boolean;
Managed Extensions for C++
public: bool CanUseWebResources();
C++/CLI
public:
bool CanUseWebResources();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


WebCombo Class Methods

[image]
Intersoft WebCombo Documentation
WebCombo Class Methods
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : WebCombo Class

For a list of all members of this type, see WebCombo members.

Public Methods

 | Name | Description
public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
public Method | CheckConstrains | Overridden.
public Method | ClearCachedDataSource | Clears the cached data source. Clears the cached data source.
public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
public Method | DataBind | Overridden. Starts databinding process for the WebCombo control.
public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
public Method | Dispose | (Inherited from System.Web.UI.Control)
public Method | FindControl | (Inherited from System.Web.UI.Control)
public Method | Focus | Overridden.
public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
public Method | GetCachedDataSource | Gets the currently cached data source of the specified control. Get the currently cached data source of the specified control.
public Method | GetClientAction | Gets the client action engine that designed to bridge the gaps between client and server.
public Method | GetColumn | Returns Column object which provide access to basic column properties. You should only use this method when ComboMode is set to MultipleColumns. Returns Column object which provide access to basic column properties. You should only use this method when ComboMode is set to MultipleColumns.
public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
public Method | GetIntersoftFolder | Gets the folder path of Intersoft Solutions. (Inherited from ISNet.WebUI.ISNetControl)
public Method | GetLayoutFolder | Gets the folder path of the layout files of WebCombo. (Inherited from ISNet.WebUI.ISNetControl)
public Method | GetMultipleValues | Gets the multiple values collection in ArrayList object. Gets the multiple values collection in ArrayList object.
public Method | GetMultipleValuesText | Gets the string representation of multiple values' Text. Each values will be separated by the character specified in SeparatorChar property, followed by a space. Gets the string representation of multiple values' Text. Each values will be separated by the character specified in SeparatorChar property, followed by a space.
public Method | GetMultipleValuesValue | Gets the string representation of multiple values' Value. Each values will be separated by the character specified in SeparatorChar property, followed by a space. Gets the string representation of multiple values' Value. Each values will be separated by the character specified in SeparatorChar property, followed by a space.
public Method | GetObjectData | Overridden.
public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
public Method | GetValueByText | Returns a value by specified text from datasource. Returns a value by specified text from datasource.
public Method | HasControls | (Inherited from System.Web.UI.Control)
public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
public Method | IsDataCached | Returns whether the Datasource is already cached. Returns whether the Datasource is already cached.
public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
public Method | IsFlyPostBackControl | Determines whether this instance of WebGrid is the one which invoking FlyPostBack request. (Inherited from ISNet.WebUI.ISNetControl)
public Method | IsFlyPostBackRequest | Determines whether the current postback is a FlyPostBack (AJAX) request. (Inherited from ISNet.WebUI.ISNetControl)
public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
public Method | LoadLayout | Overloaded. Developers can save commonly used Layout and apply it to WebCombo at runtime. This also enables developers to create highly customizable look and feel web applications by saving a few layout themes and let users choose their preferences at runtime.
public Method | LoadLayoutFromFile | Overridden. Restore WebCombo's layout settings and visual styles by loading it from a file.
public Method | LoadLayoutFromPredefinedName | Restore WebCombo's layout settings and visual styles by loading it from predefined name. (Inherited from ISNet.WebUI.ISNetControl)
public Method | LoadLayoutFromStream | Restore WebCombo's layout settings and visual styles by loading it from memory stream. (Inherited from ISNet.WebUI.ISNetControl)
public Method | LoadPostData | Overridden.
public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
public Method | OnAddItem | Invoked when an item is about to be added.
public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
public Method | OnInitializeDataSource | Invoked when data source need to be initialized. It is highly recommended that you use this event to initialize your databinding code for more centralized and easy to maintain codes. Invoked when data source need to be initialized. It is highly recommended that you use this event to initialize your databinding code for more centralized and easy to maintain codes.
public Method | OnInitializeJsonRow |
public Method | OnInitializeLayout | Invoked when the WebCombo's layout needs to be initialized during data binding. You can write the codes to set WebCombo's appearance-related settings in this event. Invoked when the WebCombo's layout needs to be initialized during data binding. You can write the codes to set WebCombo's appearance-related settings in this event.
public Method | OnInitializePostBack | Invoked when the WebCombo is performing OnTheFly postback. You can handle this event to perform additional functions or create your own custom actions. Invoked when the WebCombo is performing OnTheFly postback. You can handle this event to perform additional functions or create your own custom actions.
public Method | OnInitializeRow | Invoked when a WebComboRow is being initialized for rendering. Invoked when a WebComboRow is being initialized for rendering.
public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
public Method | OnPrepareDataBinding | Invoked when data source ready to be binded.
public Method | OnValueChanged | Invoked when the value is changed. Invoked when the value is changed.
public Method | PopulateUnboundData | Overloaded. Populate the appropriate texts of the specified multiple values into a collection of WebComboValueItem objects. Called by the framework to save round-trip data from the WebCombo into the html ViewState variable.
public Method | PopulateValueItems | Populate the appropriate texts of the specified multiple values into a collection of WebComboValueItem objects. Populate the appropriate texts of the specified multiple values into a collection of WebComboValueItem objects.
public Method | RaisePostBackEvent | Called by the framework and raises post back event.
public Method | RaisePostDataChangedEvent | Overridden.
public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
public Method | RegisterScript | Overridden.
public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
public Method | ReInitialize | Forces WebCombo to be initialized. This method is useful when retrieving WebCombo object from persistence storage.
public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
public Method | RenderControl | (Inherited from System.Web.UI.Control)
public Method | RenderEndTag | Overridden.
public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
public Method | ResetStyleToDefault | Clear any styles associated with this control and set the control to use default WebCombo.NET style.
public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
public Method | SaveLayout | Overloaded. Saves LayoutSet properties to a file.Saves LayoutSet properties to a file.
public Method | SaveLayoutToFile | Saves WebCombo's layout settings properties to a file. (Inherited from ISNet.WebUI.ISNetControl)
public Method | SaveLayoutToStream | Saves WebCombo's layout settings properties to a memory stream. (Inherited from ISNet.WebUI.ISNetControl)
public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
public Method | SetCacheControl | Overrides the default data cache configuration. Overrides the default data cache configuration.
public Method | SetMultipleValues | Overloaded. Sets multiple values into the WebCombo. Sets multiple values into the WebCombo.
public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
public Method | ShowOnlyColumns | Show only the columns specified in fieldNames. You should only use this method when ComboMode is set to MultipleColumns. Show only the columns specified in fieldNames. You should only use this method when LayoutSet.ComboMode is set to MultipleColumns.
Top

See Also

Reference

WebCombo Class
ISNet.WebUI.WebCombo Namespace


CheckConstrains Method

[image]
Intersoft WebCombo Documentation
CheckConstrains Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : CheckConstrains Method

Syntax

Visual Basic (Declaration)
Public Overrides Sub CheckConstrains()
Visual Basic (Usage) Copy Code
Dim instance As WebCombo

instance.CheckConstrains()
C#
public override void CheckConstrains()
Delphi
public procedure CheckConstrains(); override;
JScript
public override function CheckConstrains();
Managed Extensions for C++
public: void CheckConstrains(); override
C++/CLI
public:
void CheckConstrains(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


ClearCachedDataSource Method

[image]
Intersoft WebCombo Documentation
ClearCachedDataSource Method
See Also Example Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : ClearCachedDataSource Method

Clears the cached data source.

Clears the cached data source.

Syntax

Visual Basic (Declaration)
Public Sub ClearCachedDataSource()
Visual Basic (Usage) Copy Code
Dim instance As WebCombo

instance.ClearCachedDataSource()
C#
public void ClearCachedDataSource()
Delphi
public procedure ClearCachedDataSource();
JScript
public function ClearCachedDataSource();
Managed Extensions for C++
public: void ClearCachedDataSource();
C++/CLI
public:
void ClearCachedDataSource();

Example

You can add the following code in Button1_Click event handler in order to refresh WebCombo from server side.
C# Copy Code
WebCombo1.ClearCachedDataSource();

Remarks

ClearCachedDataSource method can be used to refresh WebCombo on server side. To learn more regarding this issue please read How-to: Refresh WebCombo.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

How-to: Refresh WebCombo


Clone Method

[image]
Intersoft WebCombo Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : Clone Method

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()
Delphi
public function Clone(): TObject; virtual;
JScript
public function Clone() : Object;
Managed Extensions for C++
public: virtual Object* Clone();
C++/CLI
public:
virtual Object^ Clone();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


CopyBaseAttributes Method

[image]
Intersoft WebCombo Documentation
CopyBaseAttributes Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : CopyBaseAttributes Method

controlSrc

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim controlSrc As WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   WebControl controlSrc
)
Delphi
public procedure CopyBaseAttributes(
    controlSrc: WebControl
);
JScript
public function CopyBaseAttributes(
   controlSrc : WebControl
);
Managed Extensions for C++
public: void CopyBaseAttributes(
   WebControl* controlSrc
)
C++/CLI
public:
void CopyBaseAttributes(
   WebControl^ controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


CopyFrom Method

[image]
Intersoft WebCombo Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : CopyFrom Method

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.ISNetControl)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


CopyFrom(Object) Method

[image]
Intersoft WebCombo Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)
Delphi
public procedure CopyFrom(
    objSource: TObject
); virtual;
JScript
public function CopyFrom(
   objSource : Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebCombo Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: TObject;
    cloneSourceValue: Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : Object,
   cloneSourceValue : boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   Object* objSource,
   bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   Object^ objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members
Overload List


DataBind Method

[image]
Intersoft WebCombo Documentation
DataBind Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : DataBind Method

Starts databinding process for the WebCombo control.

Overload List

Overload | Description
DataBind | Starts databinding process for the WebCombo control.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


DataBind() Method

[image]
Intersoft WebCombo Documentation
DataBind() Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : DataBind() Method

Starts databinding process for the WebCombo control.

Syntax

Visual Basic (Declaration)
Public Overrides Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebCombo

instance.DataBind()
C#
public override void DataBind()
Delphi
public procedure DataBind(); override;
JScript
public override function DataBind();
Managed Extensions for C++
public: void DataBind(); override
C++/CLI
public:
void DataBind(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


DeSerializeObjectData Method

[image]
Intersoft WebCombo Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : DeSerializeObjectData Method

type
info
context

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim type As Type
Dim info As SerializationInfo
Dim context As StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: Type;
    info: SerializationInfo;
    context: StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : Type,
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   Type* type,
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   Type^ type,
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


Dispose Method

[image]
Intersoft WebCombo Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : Dispose Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebCombo

instance.Dispose()
C#
public virtual void Dispose()
Delphi
public procedure Dispose(); virtual;
JScript
public function Dispose();
Managed Extensions for C++
public: virtual void Dispose();
C++/CLI
public:
virtual void Dispose();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


FindControl Method

[image]
Intersoft WebCombo Documentation
FindControl Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : FindControl Method

Overload List

Overload | Description
FindControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


FindControl(String) Method

[image]
Intersoft WebCombo Documentation
FindControl(String) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : FindControl(String) Method

id

Syntax

Visual Basic (Declaration)
Public Overridable Function FindControl( _
   ByVal id As String _
) As Control
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim id As String
Dim value As Control

value = instance.FindControl(id)
C#
public virtual Control FindControl(
   string id
)
Delphi
public function FindControl(
    id: String
): Control; virtual;
JScript
public function FindControl(
   id : String
) : Control;
Managed Extensions for C++
public: virtual Control* FindControl(
   string* id
)
C++/CLI
public:
virtual Control^ FindControl(
   String^ id
)

Parameters

id

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


Focus Method

[image]
Intersoft WebCombo Documentation
Focus Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : Focus Method

Syntax

Visual Basic (Declaration)
Public Overrides Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebCombo

instance.Focus()
C#
public override void Focus()
Delphi
public procedure Focus(); override;
JScript
public override function Focus();
Managed Extensions for C++
public: void Focus(); override
C++/CLI
public:
void Focus(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


ForceDisableXmlCompression Method

[image]
Intersoft WebCombo Documentation
ForceDisableXmlCompression Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : ForceDisableXmlCompression Method

Syntax

Visual Basic (Declaration)
Public Sub ForceDisableXmlCompression()
Visual Basic (Usage) Copy Code
Dim instance As WebCombo

instance.ForceDisableXmlCompression()
C#
public void ForceDisableXmlCompression()
Delphi
public procedure ForceDisableXmlCompression();
JScript
public function ForceDisableXmlCompression();
Managed Extensions for C++
public: void ForceDisableXmlCompression();
C++/CLI
public:
void ForceDisableXmlCompression();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


GetCachedDataSource Method

[image]
Intersoft WebCombo Documentation
GetCachedDataSource Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : GetCachedDataSource Method

Gets the currently cached data source of the specified control. Get the currently cached data source of the specified control.

Syntax

Visual Basic (Declaration)
Public Function GetCachedDataSource() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Object

value = instance.GetCachedDataSource()
C#
public object GetCachedDataSource()
Delphi
public function GetCachedDataSource(): TObject;
JScript
public function GetCachedDataSource() : Object;
Managed Extensions for C++
public: Object* GetCachedDataSource();
C++/CLI
public:
Object^ GetCachedDataSource();

Return Value

Cached data source object if any, otherwise returns null.

Cached data source object if any, otherwise returns null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


GetClientAction Method

[image]
Intersoft WebCombo Documentation
GetClientAction Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : GetClientAction Method

Gets the client action engine that designed to bridge the gaps between client and server.

Syntax

Visual Basic (Declaration)
Public Function GetClientAction() As ISNet.WebUI.BaseClientSideAction
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As ISNet.WebUI.BaseClientSideAction

value = instance.GetClientAction()
C#
public ISNet.WebUI.BaseClientSideAction GetClientAction()
Delphi
public function GetClientAction(): ISNet.WebUI.BaseClientSideAction;
JScript
public function GetClientAction() : ISNet.WebUI.BaseClientSideAction;
Managed Extensions for C++
public: ISNet.WebUI.BaseClientSideAction* GetClientAction();
C++/CLI
public:
ISNet.WebUI.BaseClientSideAction^ GetClientAction();

Remarks

This object is attached per combo instance and designed to bridge the gaps between client and server. It enables predefined client actions to be executed directly from server code during OnTheFly Postback. Therefore, avoiding writing unnecessary client-side codes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

How-to: Navigate to specific page after adding a row
How-to: Refresh other control during row addition
How-to: Display message box if unable to add a row

Concepts

ClientAction Engine


GetColumn Method

[image]
Intersoft WebCombo Documentation
GetColumn Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : GetColumn Method

fieldName
The data field name.The data field name.

Returns Column object which provide access to basic column properties. You should only use this method when ComboMode is set to MultipleColumns.

Returns Column object which provide access to basic column properties. You should only use this method when ComboMode is set to MultipleColumns.

Syntax

Visual Basic (Declaration)
Public Function GetColumn( _
   ByVal fieldName As String _
) As WebComboColumn
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim fieldName As String
Dim value As WebComboColumn

value = instance.GetColumn(fieldName)
C#
public WebComboColumn GetColumn(
   string fieldName
)
Delphi
public function GetColumn(
    fieldName: String
): WebComboColumn;
JScript
public function GetColumn(
   fieldName : String
) : WebComboColumn;
Managed Extensions for C++
public: WebComboColumn* GetColumn(
   string* fieldName
)
C++/CLI
public:
WebComboColumn^ GetColumn(
   String^ fieldName
)

Parameters

fieldName
The data field name.The data field name.

Return Value

Returns Column object

Returns Column object

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


GetCurrentControlLifeCycle Method

[image]
Intersoft WebCombo Documentation
GetCurrentControlLifeCycle Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : GetCurrentControlLifeCycle Method

Syntax

Visual Basic (Declaration)
Public Function GetCurrentControlLifeCycle() As ISNet.WebUI.ControlLifeCycle
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As ISNet.WebUI.ControlLifeCycle

value = instance.GetCurrentControlLifeCycle()
C#
public ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle()
Delphi
public function GetCurrentControlLifeCycle(): ISNet.WebUI.ControlLifeCycle;
JScript
public function GetCurrentControlLifeCycle() : ISNet.WebUI.ControlLifeCycle;
Managed Extensions for C++
public: ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle();
C++/CLI
public:
ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


GetCurrentTheme Method

[image]
Intersoft WebCombo Documentation
GetCurrentTheme Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : GetCurrentTheme Method

Syntax

Visual Basic (Declaration)
Public Function GetCurrentTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCurrentTheme()
C#
public ISNet.WebUI.ThemeInfo GetCurrentTheme()
Delphi
public function GetCurrentTheme(): ISNet.WebUI.ThemeInfo;
JScript
public function GetCurrentTheme() : ISNet.WebUI.ThemeInfo;
Managed Extensions for C++
public: ISNet.WebUI.ThemeInfo* GetCurrentTheme();
C++/CLI
public:
ISNet.WebUI.ThemeInfo^ GetCurrentTheme();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


GetFrameworkDataFolder Method

[image]
Intersoft WebCombo Documentation
GetFrameworkDataFolder Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : GetFrameworkDataFolder Method

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkDataFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As String

value = instance.GetFrameworkDataFolder()
C#
public string GetFrameworkDataFolder()
Delphi
public function GetFrameworkDataFolder(): String;
JScript
public function GetFrameworkDataFolder() : String;
Managed Extensions for C++
public: string* GetFrameworkDataFolder();
C++/CLI
public:
String^ GetFrameworkDataFolder();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


GetFrameworkFolder Method

[image]
Intersoft WebCombo Documentation
GetFrameworkFolder Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : GetFrameworkFolder Method

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As String

value = instance.GetFrameworkFolder()
C#
public string GetFrameworkFolder()
Delphi
public function GetFrameworkFolder(): String;
JScript
public function GetFrameworkFolder() : String;
Managed Extensions for C++
public: string* GetFrameworkFolder();
C++/CLI
public:
String^ GetFrameworkFolder();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


GetFrameworkVersion Method

[image]
Intersoft WebCombo Documentation
GetFrameworkVersion Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : GetFrameworkVersion Method

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkVersion() As Version
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Version

value = instance.GetFrameworkVersion()
C#
public Version GetFrameworkVersion()
Delphi
public function GetFrameworkVersion(): Version;
JScript
public function GetFrameworkVersion() : Version;
Managed Extensions for C++
public: Version* GetFrameworkVersion();
C++/CLI
public:
Version^ GetFrameworkVersion();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


GetIntersoftFolder Method

[image]
Intersoft WebCombo Documentation
GetIntersoftFolder Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : GetIntersoftFolder Method

Gets the folder path of Intersoft Solutions.

Syntax

Visual Basic (Declaration)
Public Function GetIntersoftFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As String

value = instance.GetIntersoftFolder()
C#
public string GetIntersoftFolder()
Delphi
public function GetIntersoftFolder(): String;
JScript
public function GetIntersoftFolder() : String;
Managed Extensions for C++
public: string* GetIntersoftFolder();
C++/CLI
public:
String^ GetIntersoftFolder();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


GetLayoutFolder Method

[image]
Intersoft WebCombo Documentation
GetLayoutFolder Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : GetLayoutFolder Method

Gets the folder path of the layout files of WebCombo.

Syntax

Visual Basic (Declaration)
Public Function GetLayoutFolder() As String
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As String

value = instance.GetLayoutFolder()
C#
public string GetLayoutFolder()
Delphi
public function GetLayoutFolder(): String;
JScript
public function GetLayoutFolder() : String;
Managed Extensions for C++
public: string* GetLayoutFolder();
C++/CLI
public:
String^ GetLayoutFolder();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


GetMultipleValues Method

[image]
Intersoft WebCombo Documentation
GetMultipleValues Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : GetMultipleValues Method

Gets the multiple values collection in ArrayList object.

Gets the multiple values collection in ArrayList object.

Syntax

Visual Basic (Declaration)
Public Function GetMultipleValues() As IEnumerable
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As IEnumerable

value = instance.GetMultipleValues()
C#
public IEnumerable GetMultipleValues()
Delphi
public function GetMultipleValues(): IEnumerable;
JScript
public function GetMultipleValues() : IEnumerable;
Managed Extensions for C++
public: IEnumerable* GetMultipleValues();
C++/CLI
public:
IEnumerable^ GetMultipleValues();

Return Value

ArrayList object containing collection of WebComboValueItem objects which represents the multiple values entried by users.

Remarks

ArrayList object containing collection of WebComboValueItem objects which represents the multiple values entried by users.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


GetMultipleValuesText Method

[image]
Intersoft WebCombo Documentation
GetMultipleValuesText Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : GetMultipleValuesText Method

Gets the string representation of multiple values' Text. Each values will be separated by the character specified in SeparatorChar property, followed by a space. Gets the string representation of multiple values' Text. Each values will be separated by the character specified in SeparatorChar property, followed by a space.

Syntax

Visual Basic (Declaration)
Public Function GetMultipleValuesText() As String
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As String

value = instance.GetMultipleValuesText()
C#
public string GetMultipleValuesText()
Delphi
public function GetMultipleValuesText(): String;
JScript
public function GetMultipleValuesText() : String;
Managed Extensions for C++
public: string* GetMultipleValuesText();
C++/CLI
public:
String^ GetMultipleValuesText();

Return Value

stringstring.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


GetMultipleValuesValue Method

[image]
Intersoft WebCombo Documentation
GetMultipleValuesValue Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : GetMultipleValuesValue Method

Gets the string representation of multiple values' Value. Each values will be separated by the character specified in SeparatorChar property, followed by a space. Gets the string representation of multiple values' Value. Each values will be separated by the character specified in SeparatorChar property, followed by a space.

Syntax

Visual Basic (Declaration)
Public Function GetMultipleValuesValue() As String
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As String

value = instance.GetMultipleValuesValue()
C#
public string GetMultipleValuesValue()
Delphi
public function GetMultipleValuesValue(): String;
JScript
public function GetMultipleValuesValue() : String;
Managed Extensions for C++
public: string* GetMultipleValuesValue();
C++/CLI
public:
String^ GetMultipleValuesValue();

Return Value

string.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


GetObjectData Method

[image]
Intersoft WebCombo Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : GetObjectData Method

info
context

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: SerializationInfo;
    context: StreamingContext
); override;
JScript
public override function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


GetPostedXMLData Method

[image]
Intersoft WebCombo Documentation
GetPostedXMLData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : GetPostedXMLData Method

Syntax

Visual Basic (Declaration)
Public Function GetPostedXMLData() As String
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As String

value = instance.GetPostedXMLData()
C#
public string GetPostedXMLData()
Delphi
public function GetPostedXMLData(): String;
JScript
public function GetPostedXMLData() : String;
Managed Extensions for C++
public: string* GetPostedXMLData();
C++/CLI
public:
String^ GetPostedXMLData();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


GetProductSimpleName Method

[image]
Intersoft WebCombo Documentation
GetProductSimpleName Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : GetProductSimpleName Method

Syntax

Visual Basic (Declaration)
Public Function GetProductSimpleName() As String
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As String

value = instance.GetProductSimpleName()
C#
public string GetProductSimpleName()
Delphi
public function GetProductSimpleName(): String;
JScript
public function GetProductSimpleName() : String;
Managed Extensions for C++
public: string* GetProductSimpleName();
C++/CLI
public:
String^ GetProductSimpleName();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


GetPropertyValue Method

[image]
Intersoft WebCombo Documentation
GetPropertyValue Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : GetPropertyValue Method

defValue
propValue
webConfigKey

Syntax

Visual Basic (Declaration)
Public Function GetPropertyValue( _
   ByVal defValue As String, _
   ByVal propValue As String, _
   ByVal webConfigKey As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim defValue As String
Dim propValue As String
Dim webConfigKey As String
Dim value As String

value = instance.GetPropertyValue(defValue, propValue, webConfigKey)
C#
public string GetPropertyValue(
   string defValue,
   string propValue,
   string webConfigKey
)
Delphi
public function GetPropertyValue(
    defValue: String;
    propValue: String;
    webConfigKey: String
): String;
JScript
public function GetPropertyValue(
   defValue : String,
   propValue : String,
   webConfigKey : String
) : String;
Managed Extensions for C++
public: string* GetPropertyValue(
   string* defValue,
   string* propValue,
   string* webConfigKey
)
C++/CLI
public:
String^ GetPropertyValue(
   String^ defValue,
   String^ propValue,
   String^ webConfigKey
)

Parameters

defValue
propValue
webConfigKey

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


GetResourceStream Method

[image]
Intersoft WebCombo Documentation
GetResourceStream Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : GetResourceStream Method

resourceUrl

Syntax

Visual Basic (Declaration)
Public Function GetResourceStream( _
   ByVal resourceUrl As String _
) As Stream
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim resourceUrl As String
Dim value As Stream

value = instance.GetResourceStream(resourceUrl)
C#
public Stream GetResourceStream(
   string resourceUrl
)
Delphi
public function GetResourceStream(
    resourceUrl: String
): Stream;
JScript
public function GetResourceStream(
   resourceUrl : String
) : Stream;
Managed Extensions for C++
public: Stream* GetResourceStream(
   string* resourceUrl
)
C++/CLI
public:
Stream^ GetResourceStream(
   String^ resourceUrl
)

Parameters

resourceUrl

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


GetValueByText Method

[image]
Intersoft WebCombo Documentation
GetValueByText Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : GetValueByText Method

text
The text to searchThe text to search

Returns a value by specified text from datasource.

Returns a value by specified text from datasource.

Syntax

Visual Basic (Declaration)
Public Function GetValueByText( _
   ByVal text As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim text As String
Dim value As Object

value = instance.GetValueByText(text)
C#
public object GetValueByText(
   string text
)
Delphi
public function GetValueByText(
    text: String
): TObject;
JScript
public function GetValueByText(
   text : String
) : Object;
Managed Extensions for C++
public: Object* GetValueByText(
   string* text
)
C++/CLI
public:
Object^ GetValueByText(
   String^ text
)

Parameters

text
The text to searchThe text to search

Return Value

ObjectObject.

Remarks

Use this method to return the corresponding value by a search text based on DataValueField and DataTextField in DataSource.

Use this method to return the corresponding value by a search text based on DataValueField and DataTextField in DataSource.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


HasControls Method

[image]
Intersoft WebCombo Documentation
HasControls Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : HasControls Method

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

value = instance.HasControls()
C#
public virtual bool HasControls()
Delphi
public function HasControls(): Boolean; virtual;
JScript
public function HasControls() : boolean;
Managed Extensions for C++
public: virtual bool HasControls();
C++/CLI
public:
virtual bool HasControls();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


IsAtlasCallback Method

[image]
Intersoft WebCombo Documentation
IsAtlasCallback Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : IsAtlasCallback Method

Syntax

Visual Basic (Declaration)
Public Function IsAtlasCallback() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

value = instance.IsAtlasCallback()
C#
public bool IsAtlasCallback()
Delphi
public function IsAtlasCallback(): Boolean;
JScript
public function IsAtlasCallback() : boolean;
Managed Extensions for C++
public: bool IsAtlasCallback();
C++/CLI
public:
bool IsAtlasCallback();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


IsBetaRelease Method

[image]
Intersoft WebCombo Documentation
IsBetaRelease Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : IsBetaRelease Method

Syntax

Visual Basic (Declaration)
Public Function IsBetaRelease() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

value = instance.IsBetaRelease()
C#
public bool IsBetaRelease()
Delphi
public function IsBetaRelease(): Boolean;
JScript
public function IsBetaRelease() : boolean;
Managed Extensions for C++
public: bool IsBetaRelease();
C++/CLI
public:
bool IsBetaRelease();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


IsChromeBrowser Method

[image]
Intersoft WebCombo Documentation
IsChromeBrowser Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : IsChromeBrowser Method

Syntax

Visual Basic (Declaration)
Public Function IsChromeBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

value = instance.IsChromeBrowser()
C#
public bool IsChromeBrowser()
Delphi
public function IsChromeBrowser(): Boolean;
JScript
public function IsChromeBrowser() : boolean;
Managed Extensions for C++
public: bool IsChromeBrowser();
C++/CLI
public:
bool IsChromeBrowser();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


IsDataCached Method

[image]
Intersoft WebCombo Documentation
IsDataCached Method
See Also Example Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : IsDataCached Method

Returns whether the Datasource is already cached.

Returns whether the Datasource is already cached.

Syntax

Visual Basic (Declaration)
Public Function IsDataCached() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

value = instance.IsDataCached()
C#
public bool IsDataCached()
Delphi
public function IsDataCached(): Boolean;
JScript
public function IsDataCached() : boolean;
Managed Extensions for C++
public: bool IsDataCached();
C++/CLI
public:
bool IsDataCached();

Return Value

Returns true if DataSource is already cached

Example

With automatic datacaching feature on, the codes in your webform code behind should looks like the example below.
C# Copy Code
private void Page_Load(object sender, System.EventArgs e)
{
    if (!WebCombo1.IsDataCached())
    {
       WebCombo1.DataSource = LookupClass.GetProducts();
       WebCombo1.DataBind();
    }
}
C# Copy Code
private void Page_Load(object sender, System.EventArgs e)
{
    if (!WebCombo1.IsDataCached())
    {
        WebCombo1.DataSource = LookupClass.GetProducts();
        WebCombo1.DataBind();
    }

Remarks

This method is required to take advantage of built-in datacaching mechanism implemented in WebCombo control. With automatic datacaching feature on, the codes in your webform code behind should looks like the example below.

This method is required to take advantage of built-in datacaching mechanism implemented in WebCombo control. With automatic datacaching feature on, the codes in your webform code behind should looks like the example below.
            private void Page_Load(object sender, System.EventArgs e)
            {
                if (!WebCombo1.IsDataCached())
                {
                    WebCombo1.DataSource = LookupClass.GetProducts();
                    WebCombo1.DataBind();
                }
///

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


IsEmpty Method

[image]
Intersoft WebCombo Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : IsEmpty Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()
Delphi
public function IsEmpty(): Boolean; virtual;
JScript
public function IsEmpty() : boolean;
Managed Extensions for C++
public: virtual bool IsEmpty();
C++/CLI
public:
virtual bool IsEmpty();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


IsFlyPostBackControl Method

[image]
Intersoft WebCombo Documentation
IsFlyPostBackControl Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : IsFlyPostBackControl Method

Determines whether this instance of WebGrid is the one which invoking FlyPostBack request.

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackControl() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

value = instance.IsFlyPostBackControl()
C#
public virtual bool IsFlyPostBackControl()
Delphi
public function IsFlyPostBackControl(): Boolean; virtual;
JScript
public function IsFlyPostBackControl() : boolean;
Managed Extensions for C++
public: virtual bool IsFlyPostBackControl();
C++/CLI
public:
virtual bool IsFlyPostBackControl();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


IsFlyPostBackRequest Method

[image]
Intersoft WebCombo Documentation
IsFlyPostBackRequest Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : IsFlyPostBackRequest Method

Determines whether the current postback is a FlyPostBack (AJAX) request.

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackRequest() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

value = instance.IsFlyPostBackRequest()
C#
public virtual bool IsFlyPostBackRequest()
Delphi
public function IsFlyPostBackRequest(): Boolean; virtual;
JScript
public function IsFlyPostBackRequest() : boolean;
Managed Extensions for C++
public: virtual bool IsFlyPostBackRequest();
C++/CLI
public:
virtual bool IsFlyPostBackRequest();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


IsGeckoBasedBrowser Method

[image]
Intersoft WebCombo Documentation
IsGeckoBasedBrowser Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : IsGeckoBasedBrowser Method

Syntax

Visual Basic (Declaration)
Public Function IsGeckoBasedBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

value = instance.IsGeckoBasedBrowser()
C#
public bool IsGeckoBasedBrowser()
Delphi
public function IsGeckoBasedBrowser(): Boolean;
JScript
public function IsGeckoBasedBrowser() : boolean;
Managed Extensions for C++
public: bool IsGeckoBasedBrowser();
C++/CLI
public:
bool IsGeckoBasedBrowser();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


IsGeckoVersion18 Method

[image]
Intersoft WebCombo Documentation
IsGeckoVersion18 Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : IsGeckoVersion18 Method

Syntax

Visual Basic (Declaration)
Public Function IsGeckoVersion18() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

value = instance.IsGeckoVersion18()
C#
public bool IsGeckoVersion18()
Delphi
public function IsGeckoVersion18(): Boolean;
JScript
public function IsGeckoVersion18() : boolean;
Managed Extensions for C++
public: bool IsGeckoVersion18();
C++/CLI
public:
bool IsGeckoVersion18();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


IsInDesignMode Method

[image]
Intersoft WebCombo Documentation
IsInDesignMode Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : IsInDesignMode Method

Syntax

Visual Basic (Declaration)
Public Function IsInDesignMode() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

value = instance.IsInDesignMode()
C#
public bool IsInDesignMode()
Delphi
public function IsInDesignMode(): Boolean;
JScript
public function IsInDesignMode() : boolean;
Managed Extensions for C++
public: bool IsInDesignMode();
C++/CLI
public:
bool IsInDesignMode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


IsInternetExplorer8Browser Method

[image]
Intersoft WebCombo Documentation
IsInternetExplorer8Browser Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : IsInternetExplorer8Browser Method

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorer8Browser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

value = instance.IsInternetExplorer8Browser()
C#
public bool IsInternetExplorer8Browser()
Delphi
public function IsInternetExplorer8Browser(): Boolean;
JScript
public function IsInternetExplorer8Browser() : boolean;
Managed Extensions for C++
public: bool IsInternetExplorer8Browser();
C++/CLI
public:
bool IsInternetExplorer8Browser();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


IsInternetExplorerBrowser Method

[image]
Intersoft WebCombo Documentation
IsInternetExplorerBrowser Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : IsInternetExplorerBrowser Method

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorerBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

value = instance.IsInternetExplorerBrowser()
C#
public bool IsInternetExplorerBrowser()
Delphi
public function IsInternetExplorerBrowser(): Boolean;
JScript
public function IsInternetExplorerBrowser() : boolean;
Managed Extensions for C++
public: bool IsInternetExplorerBrowser();
C++/CLI
public:
bool IsInternetExplorerBrowser();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


IsOperaBrowser Method

[image]
Intersoft WebCombo Documentation
IsOperaBrowser Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : IsOperaBrowser Method

Syntax

Visual Basic (Declaration)
Public Function IsOperaBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

value = instance.IsOperaBrowser()
C#
public bool IsOperaBrowser()
Delphi
public function IsOperaBrowser(): Boolean;
JScript
public function IsOperaBrowser() : boolean;
Managed Extensions for C++
public: bool IsOperaBrowser();
C++/CLI
public:
bool IsOperaBrowser();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


IsSafariBrowser Method

[image]
Intersoft WebCombo Documentation
IsSafariBrowser Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : IsSafariBrowser Method

Syntax

Visual Basic (Declaration)
Public Function IsSafariBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

value = instance.IsSafariBrowser()
C#
public bool IsSafariBrowser()
Delphi
public function IsSafariBrowser(): Boolean;
JScript
public function IsSafariBrowser() : boolean;
Managed Extensions for C++
public: bool IsSafariBrowser();
C++/CLI
public:
bool IsSafariBrowser();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


IsW3CStandardBrowser Method

[image]
Intersoft WebCombo Documentation
IsW3CStandardBrowser Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : IsW3CStandardBrowser Method

Syntax

Visual Basic (Declaration)
Public Function IsW3CStandardBrowser() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

value = instance.IsW3CStandardBrowser()
C#
public bool IsW3CStandardBrowser()
Delphi
public function IsW3CStandardBrowser(): Boolean;
JScript
public function IsW3CStandardBrowser() : boolean;
Managed Extensions for C++
public: bool IsW3CStandardBrowser();
C++/CLI
public:
bool IsW3CStandardBrowser();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


LoadLayout Method

[image]
Intersoft WebCombo Documentation
LoadLayout Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : LoadLayout Method

Developers can save commonly used Layout and apply it to WebCombo at runtime. This also enables developers to create highly customizable look and feel web applications by saving a few layout themes and let users choose their preferences at runtime.

Invoked when you are applying style using programmatic technique, which is loading the layout during runtime.

Overload List

Overload | Description
LoadLayout(String) | Developers can save commonly used Layout and apply it to WebCombo at runtime. This also enables developers to create highly customizable look and feel web applications by saving a few layout themes and let users choose their preferences at runtime.
LoadLayout(LayoutInfo) | Load layout configuration from LayoutInfo object. Load layout configuration from LayoutInfo object.

Remarks

If you use WebCombo.NET v4.0, and you use one of the predefined style in the following list, you will need to reapply and update them in order to appear properly in version 4.0.

  • WinXP Blue
  • WinXP Silver
  • Mac OS X Tiger
  • Minimalist

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

How-to: Apply Predefined Layout
How-to: Re-apply the styles to use updated predefined style in designer
How-to: Update the style definition when applying the style programmatically at runtime

Concepts

Layout Manager
Affected predefined styles


LoadLayout(String) Method

[image]
Intersoft WebCombo Documentation
LoadLayout(String) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class > LoadLayout Method : LoadLayout(String) Method

fileName

Developers can save commonly used Layout and apply it to WebCombo at runtime. This also enables developers to create highly customizable look and feel web applications by saving a few layout themes and let users choose their preferences at runtime.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Use LoadLayoutFromFile(string) method for loading layout from XML-based file.")>
Public Overloads Sub LoadLayout( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim fileName As String

instance.LoadLayout(fileName)
C#
[ObsoleteAttribute("Use LoadLayoutFromFile(string) method for loading layout from XML-based file.")]
public void LoadLayout(
   string fileName
)
Delphi
public procedure LoadLayout(
    fileName: String
);
JScript
ObsoleteAttribute("Use LoadLayoutFromFile(string) method for loading layout from XML-based file.")
public function LoadLayout(
   fileName : String
);
Managed Extensions for C++
[ObsoleteAttribute("Use LoadLayoutFromFile(string) method for loading layout from XML-based file.")]
public: void LoadLayout(
   string* fileName
)
C++/CLI
[ObsoleteAttribute("Use LoadLayoutFromFile(string) method for loading layout from XML-based file.")]
public:
void LoadLayout(
   String^ fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members
Overload List


LoadLayout(LayoutInfo) Method

[image]
Intersoft WebCombo Documentation
LoadLayout(LayoutInfo) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class > LoadLayout Method : LoadLayout(LayoutInfo) Method

settings
A LayoutInfo object representing the layout configuration.
Load layout configuration from LayoutInfo object. Load layout configuration from LayoutInfo object.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub LoadLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim settings As ISNet.WebUI.LayoutInfo

instance.LoadLayout(settings)
C#
public override void LoadLayout(
   ISNet.WebUI.LayoutInfo settings
)
Delphi
public procedure LoadLayout(
    settings: ISNet.WebUI.LayoutInfo
); override;
JScript
public override function LoadLayout(
   settings : ISNet.WebUI.LayoutInfo
);
Managed Extensions for C++
public: void LoadLayout(
   ISNet.WebUI.LayoutInfo* settings
) override
C++/CLI
public:
void LoadLayout(
   ISNet.WebUI.LayoutInfo^ settings
) override

Parameters

settings
A LayoutInfo object representing the layout configuration.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members
Overload List


LoadLayoutFromFile Method

[image]
Intersoft WebCombo Documentation
LoadLayoutFromFile Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : LoadLayoutFromFile Method

filePath
Restore WebCombo's layout settings and visual styles by loading it from a file.

Syntax

Visual Basic (Declaration)
Public Overrides Sub LoadLayoutFromFile( _
   ByVal filePath As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim filePath As String

instance.LoadLayoutFromFile(filePath)
C#
public override void LoadLayoutFromFile(
   string filePath
)
Delphi
public procedure LoadLayoutFromFile(
    filePath: String
); override;
JScript
public override function LoadLayoutFromFile(
   filePath : String
);
Managed Extensions for C++
public: void LoadLayoutFromFile(
   string* filePath
) override
C++/CLI
public:
void LoadLayoutFromFile(
   String^ filePath
) override

Parameters

filePath

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


LoadLayoutFromPredefinedName Method

[image]
Intersoft WebCombo Documentation
LoadLayoutFromPredefinedName Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : LoadLayoutFromPredefinedName Method

predefinedName
Restore WebCombo's layout settings and visual styles by loading it from predefined name.

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromPredefinedName( _
   ByVal predefinedName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim predefinedName As String

instance.LoadLayoutFromPredefinedName(predefinedName)
C#
public virtual void LoadLayoutFromPredefinedName(
   string predefinedName
)
Delphi
public procedure LoadLayoutFromPredefinedName(
    predefinedName: String
); virtual;
JScript
public function LoadLayoutFromPredefinedName(
   predefinedName : String
);
Managed Extensions for C++
public: virtual void LoadLayoutFromPredefinedName(
   string* predefinedName
)
C++/CLI
public:
virtual void LoadLayoutFromPredefinedName(
   String^ predefinedName
)

Parameters

predefinedName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


LoadLayoutFromStream Method

[image]
Intersoft WebCombo Documentation
LoadLayoutFromStream Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : LoadLayoutFromStream Method

stream
Restore WebCombo's layout settings and visual styles by loading it from memory stream.

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromStream( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim stream As Stream

instance.LoadLayoutFromStream(stream)
C#
public virtual void LoadLayoutFromStream(
   Stream stream
)
Delphi
public procedure LoadLayoutFromStream(
    stream: Stream
); virtual;
JScript
public function LoadLayoutFromStream(
   stream : Stream
);
Managed Extensions for C++
public: virtual void LoadLayoutFromStream(
   Stream* stream
)
C++/CLI
public:
virtual void LoadLayoutFromStream(
   Stream^ stream
)

Parameters

stream

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


LoadPostData Method

[image]
Intersoft WebCombo Documentation
LoadPostData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : LoadPostData Method

postDataKey
values

Syntax

Visual Basic (Declaration)
Public Overrides Function LoadPostData( _
   ByVal postDataKey As String, _
   ByVal values As NameValueCollection _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim postDataKey As String
Dim values As NameValueCollection
Dim value As Boolean

value = instance.LoadPostData(postDataKey, values)
C#
public override bool LoadPostData(
   string postDataKey,
   NameValueCollection values
)
Delphi
public function LoadPostData(
    postDataKey: String;
    values: NameValueCollection
): Boolean; override;
JScript
public override function LoadPostData(
   postDataKey : String,
   values : NameValueCollection
) : boolean;
Managed Extensions for C++
public: bool LoadPostData(
   string* postDataKey,
   NameValueCollection* values
) override
C++/CLI
public:
bool LoadPostData(
   String^ postDataKey,
   NameValueCollection^ values
) override

Parameters

postDataKey
values

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


MergeStyle Method

[image]
Intersoft WebCombo Documentation
MergeStyle Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : MergeStyle Method

s

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim s As Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   Style s
)
Delphi
public procedure MergeStyle(
    s: Style
);
JScript
public function MergeStyle(
   s : Style
);
Managed Extensions for C++
public: void MergeStyle(
   Style* s
)
C++/CLI
public:
void MergeStyle(
   Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


OnAddItem Method

[image]
Intersoft WebCombo Documentation
OnAddItem Method
See Also Example Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : OnAddItem Method

row
Invoked when an item is about to be added.

Syntax

Visual Basic (Declaration)
Public Overridable Function OnAddItem( _
   ByVal row As WebComboRow _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim row As WebComboRow
Dim value As Boolean

value = instance.OnAddItem(row)
C#
public virtual bool OnAddItem(
   WebComboRow row
)
Delphi
public function OnAddItem(
    row: WebComboRow
): Boolean; virtual;
JScript
public function OnAddItem(
   row : WebComboRow
) : boolean;
Managed Extensions for C++
public: virtual bool OnAddItem(
   WebComboRow* row
)
C++/CLI
public:
virtual bool OnAddItem(
   WebComboRow^ row
)

Parameters

row

Example

The following example shows you how to create a WebCombo that you can add items to it.
C# Copy Code
private void WebCombo1_InitializeDataSource(object sender, ISNet.WebUI.WebCombo.DataSourceEventArgs e)
{
    oleDbDataAdapter1.Fill( dsNorthWind1 );
    e.DataSource = dsNorthWind1;
}

protected void OnAddItem(object sender, RowEventArgs e)
{

    //retrieves the DataSet from internal cache then add new row to it.

    DataSet ds = (DataSet)WebCombo1.GetCachedDataSource();

    DataRow row = ds.Tables[0].NewRow();
    row["CustomerID"] = e.Row.Value;
    row["ContactName"] = e.Row.Value;

    ds.Tables[0].Rows.Add(row);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


OnInfoChanged Method

[image]
Intersoft WebCombo Documentation
OnInfoChanged Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : OnInfoChanged Method

e

Syntax

Visual Basic (Declaration)
Public Sub OnInfoChanged( _
   ByVal e As ISNet.WebUI.SynchronizeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim e As ISNet.WebUI.SynchronizeEventArgs

instance.OnInfoChanged(e)
C#
public void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs e
)
Delphi
public procedure OnInfoChanged(
    e: ISNet.WebUI.SynchronizeEventArgs
);
JScript
public function OnInfoChanged(
   e : ISNet.WebUI.SynchronizeEventArgs
);
Managed Extensions for C++
public: void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs* e
)
C++/CLI
public:
void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


OnInitializeDataSource Method

[image]
Intersoft WebCombo Documentation
OnInitializeDataSource Method
See Also Example Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : OnInitializeDataSource Method

dataSource
A reference to the dataSource object.
isFlyRequest
queryText
startRow
endRow
rowCount
additionalFilters
isDDClicked

Invoked when data source need to be initialized. It is highly recommended that you use this event to initialize your databinding code for more centralized and easy to maintain codes.

Invoked when data source need to be initialized. It is highly recommended that you use this event to initialize your databinding code for more centralized and easy to maintain codes.

Syntax

Visual Basic (Declaration)
Public Overridable Function OnInitializeDataSource( _
   ByVal dataSource As Object, _
   ByVal isFlyRequest As Boolean, _
   ByVal queryText As String, _
   ByVal startRow As Integer, _
   ByVal endRow As Integer, _
   ByVal rowCount As Integer, _
   ByVal additionalFilters As String, _
   ByVal isDDClicked As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim dataSource As Object
Dim isFlyRequest As Boolean
Dim queryText As String
Dim startRow As Integer
Dim endRow As Integer
Dim rowCount As Integer
Dim additionalFilters As String
Dim isDDClicked As Boolean
Dim value As Boolean

value = instance.OnInitializeDataSource(dataSource, isFlyRequest, queryText, startRow, endRow, rowCount, additionalFilters, isDDClicked)
C#
public virtual bool OnInitializeDataSource(
   object dataSource,
   bool isFlyRequest,
   string queryText,
   int startRow,
   int endRow,
   int rowCount,
   string additionalFilters,
   bool isDDClicked
)
Delphi
public function OnInitializeDataSource(
    dataSource: TObject;
    isFlyRequest: Boolean;
    queryText: String;
    startRow: Integer;
    endRow: Integer;
    rowCount: Integer;
    additionalFilters: String;
    isDDClicked: Boolean
): Boolean; virtual;
JScript
public function OnInitializeDataSource(
   dataSource : Object,
   isFlyRequest : boolean,
   queryText : String,
   startRow : int,
   endRow : int,
   rowCount : int,
   additionalFilters : String,
   isDDClicked : boolean
) : boolean;
Managed Extensions for C++
public: virtual bool OnInitializeDataSource(
   Object* dataSource,
   bool isFlyRequest,
   string* queryText,
   int startRow,
   int endRow,
   int rowCount,
   string* additionalFilters,
   bool isDDClicked
)
C++/CLI
public:
virtual bool OnInitializeDataSource(
   Object^ dataSource,
   bool isFlyRequest,
   String^ queryText,
   int startRow,
   int endRow,
   int rowCount,
   String^ additionalFilters,
   bool isDDClicked
)

Parameters

dataSource
A reference to the dataSource object.
isFlyRequest
queryText
startRow
endRow
rowCount
additionalFilters
isDDClicked

Return Value

Returns ReturnValue. Event will be cancelled when ReturnValue is False.

Example

C# Example:
C# Copy Code
protected void WebCombo1_InitializeDataSource(object sender, DataSourceEventArgs e)
{
    // the codes will only be executed on first page load, when refresh function invoked
    // from client, or when the cache is expired/cleared.

    sqlDataAdapter1.Fill(dataSet11.Customers);
    e.DataSource = dataSet11;
}
C# Copy Code
protected void WebCombo1_InitData(object sender, DataSourceEventArgs e)
{
    // the codes will only be executed on first page load, when refresh function invoked
    // from client, or when the cache is expired/cleared.

    sqlDataAdapter1.Fill(dataSet11.Customers);
    e.DataSource = dataSet11;
}

Remarks

Instead of writing your databinding code in Page_Load event, it is more effective to use InitializeDataSource event as a central place for the WebCombo's databinding code. By using this event, you are automatically taking advantage of the WebCombo's automatic data caching feature.

Note that you don't need to use IsDataCached anymore to query the DataCache status since that the control will automatically check it and only call this event when it needs DataSource. You also don't need to put it under !IsPostBack or other conditions because the event is only fired on first page load, on refresh, or when the cache has been cleared/expired. Additionally, the databinding code has been very simplified so that you don't have to call DataBind after you assign the DataSource as needed by other controls normally.

WebCombo.NET 4.0 introduces you to a new code-less data binding. With this new databinding concept, programming databind web application is very easy, simple and straightforward. There are no codes that required in the page’s code behind. Unlike in the previous version, you do not need to write codes inside InitializeDataSource event which pass the datasource to e.DataSource.

Instead of writing your databinding code in Page_Load event, it is more effective to use InitializeDataSource event as a central place for the WebCombo's databinding code. By using this event, you are automatically taking advantage of the WebCombo's automatic data caching feature.

Note that you don't need to use IsDataCached anymore to query the DataCache status since that the control will automatically check it and only call this event when it needs DataSource. You also don't need to put it under !IsPostBack or other conditions because the event is only fired on first page load, on refresh, or when the cache has been cleared/expired. Additionally, the databinding code has been very simplified so that you don't have to call WebCombo.DataBind after you assign the DataSource as needed by other controls normally.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

Walkthrough: Binding WebCombo to a DataSet
Walkthrough: Binding WebCombo to XML-based DataSource

Concepts

No-codes data binding through DataSourceControl support


OnInitializeJsonRow Method

[image]
Intersoft WebCombo Documentation
OnInitializeJsonRow Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : OnInitializeJsonRow Method

row

Syntax

Visual Basic (Declaration)
Public Overridable Function OnInitializeJsonRow( _
   ByVal row As WebComboRow _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim row As WebComboRow
Dim value As Boolean

value = instance.OnInitializeJsonRow(row)
C#
public virtual bool OnInitializeJsonRow(
   WebComboRow row
)
Delphi
public function OnInitializeJsonRow(
    row: WebComboRow
): Boolean; virtual;
JScript
public function OnInitializeJsonRow(
   row : WebComboRow
) : boolean;
Managed Extensions for C++
public: virtual bool OnInitializeJsonRow(
   WebComboRow* row
)
C++/CLI
public:
virtual bool OnInitializeJsonRow(
   WebComboRow^ row
)

Parameters

row

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


OnInitializeLayout Method

[image]
Intersoft WebCombo Documentation
OnInitializeLayout Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : OnInitializeLayout Method

layout
A reference to the LayoutSet object.A reference to the LayoutSet object.

Invoked when the WebCombo's layout needs to be initialized during data binding. You can write the codes to set WebCombo's appearance-related settings in this event.

Invoked when the WebCombo's layout needs to be initialized during data binding. You can write the codes to set WebCombo's appearance-related settings in this event.

Syntax

Visual Basic (Declaration)
Public Overridable Function OnInitializeLayout( _
   ByVal layout As LayoutSet _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim layout As LayoutSet
Dim value As Boolean

value = instance.OnInitializeLayout(layout)
C#
public virtual bool OnInitializeLayout(
   LayoutSet layout
)
Delphi
public function OnInitializeLayout(
    layout: LayoutSet
): Boolean; virtual;
JScript
public function OnInitializeLayout(
   layout : LayoutSet
) : boolean;
Managed Extensions for C++
public: virtual bool OnInitializeLayout(
   LayoutSet* layout
)
C++/CLI
public:
virtual bool OnInitializeLayout(
   LayoutSet^ layout
)

Parameters

layout
A reference to the LayoutSet object.A reference to the LayoutSet object.

Return Value

Returns ReturnValue. Event will be cancelled when ReturnValue is False.

Returns ReturnValue. Event will be cancelled when ReturnValue is False.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


OnInitializePostBack Method

[image]
Intersoft WebCombo Documentation
OnInitializePostBack Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : OnInitializePostBack Method

combo
The reference to the WebCombo object.The reference to the WebCombo object.
dataSource
The datasourceThe datasource.
request
The request context in XmlDocument type.The request context in XmlDocument type.
action
The action name of the current request. The action name of the current request.
Invoked when the WebCombo is performing OnTheFly postback. You can handle this event to perform additional functions or create your own custom actions. Invoked when the WebCombo is performing OnTheFly postback. You can handle this event to perform additional functions or create your own custom actions.

Syntax

Visual Basic (Declaration)
Public Overridable Function OnInitializePostBack( _
   ByVal combo As WebCombo, _
   ByVal dataSource As Object, _
   ByVal request As XmlDocument, _
   ByVal action As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim combo As WebCombo
Dim dataSource As Object
Dim request As XmlDocument
Dim action As String
Dim value As Boolean

value = instance.OnInitializePostBack(combo, dataSource, request, action)
C#
public virtual bool OnInitializePostBack(
   WebCombo combo,
   object dataSource,
   XmlDocument request,
   string action
)
Delphi
public function OnInitializePostBack(
    combo: WebCombo;
    dataSource: TObject;
    request: XmlDocument;
    action: String
): Boolean; virtual;
JScript
public function OnInitializePostBack(
   combo : WebCombo,
   dataSource : Object,
   request : XmlDocument,
   action : String
) : boolean;
Managed Extensions for C++
public: virtual bool OnInitializePostBack(
   WebCombo* combo,
   Object* dataSource,
   XmlDocument* request,
   string* action
)
C++/CLI
public:
virtual bool OnInitializePostBack(
   WebCombo^ combo,
   Object^ dataSource,
   XmlDocument^ request,
   String^ action
)

Parameters

combo
The reference to the WebCombo object.The reference to the WebCombo object.
dataSource
The datasourceThe datasource.
request
The request context in XmlDocument type.The request context in XmlDocument type.
action
The action name of the current request. The action name of the current request.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


OnInitializeRow Method

[image]
Intersoft WebCombo Documentation
OnInitializeRow Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : OnInitializeRow Method

row
The row which is being initialized. The row which is being initialized.

Invoked when a WebComboRow is being initialized for rendering.

Invoked when a WebComboRow is being initialized for rendering.

Syntax

Visual Basic (Declaration)
Public Overridable Function OnInitializeRow( _
   ByVal row As WebComboRow _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim row As WebComboRow
Dim value As Boolean

value = instance.OnInitializeRow(row)
C#
public virtual bool OnInitializeRow(
   WebComboRow row
)
Delphi
public function OnInitializeRow(
    row: WebComboRow
): Boolean; virtual;
JScript
public function OnInitializeRow(
   row : WebComboRow
) : boolean;
Managed Extensions for C++
public: virtual bool OnInitializeRow(
   WebComboRow* row
)
C++/CLI
public:
virtual bool OnInitializeRow(
   WebComboRow^ row
)

Parameters

row
The row which is being initialized. The row which is being initialized.

Return Value

Returns ReturnValue.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


OnPreInitialize Method

[image]
Intersoft WebCombo Documentation
OnPreInitialize Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : OnPreInitialize Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnPreInitialize()
Visual Basic (Usage) Copy Code
Dim instance As WebCombo

instance.OnPreInitialize()
C#
public virtual void OnPreInitialize()
Delphi
public procedure OnPreInitialize(); virtual;
JScript
public function OnPreInitialize();
Managed Extensions for C++
public: virtual void OnPreInitialize();
C++/CLI
public:
virtual void OnPreInitialize();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


OnPrepareDataBinding Method

[image]
Intersoft WebCombo Documentation
OnPrepareDataBinding Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : OnPrepareDataBinding Method

dataSource
isFlyRequest
queryText
startRow
endRow
rowCount
additionalFilters
isDDClicked
Invoked when data source ready to be binded.

Syntax

Visual Basic (Declaration)
Public Overridable Function OnPrepareDataBinding( _
   ByVal dataSource As Object, _
   ByVal isFlyRequest As Boolean, _
   ByVal queryText As String, _
   ByVal startRow As Integer, _
   ByVal endRow As Integer, _
   ByVal rowCount As Integer, _
   ByVal additionalFilters As String, _
   ByVal isDDClicked As Boolean _
) As DataSourceEventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim dataSource As Object
Dim isFlyRequest As Boolean
Dim queryText As String
Dim startRow As Integer
Dim endRow As Integer
Dim rowCount As Integer
Dim additionalFilters As String
Dim isDDClicked As Boolean
Dim value As DataSourceEventArgs

value = instance.OnPrepareDataBinding(dataSource, isFlyRequest, queryText, startRow, endRow, rowCount, additionalFilters, isDDClicked)
C#
public virtual DataSourceEventArgs OnPrepareDataBinding(
   object dataSource,
   bool isFlyRequest,
   string queryText,
   int startRow,
   int endRow,
   int rowCount,
   string additionalFilters,
   bool isDDClicked
)
Delphi
public function OnPrepareDataBinding(
    dataSource: TObject;
    isFlyRequest: Boolean;
    queryText: String;
    startRow: Integer;
    endRow: Integer;
    rowCount: Integer;
    additionalFilters: String;
    isDDClicked: Boolean
): DataSourceEventArgs; virtual;
JScript
public function OnPrepareDataBinding(
   dataSource : Object,
   isFlyRequest : boolean,
   queryText : String,
   startRow : int,
   endRow : int,
   rowCount : int,
   additionalFilters : String,
   isDDClicked : boolean
) : DataSourceEventArgs;
Managed Extensions for C++
public: virtual DataSourceEventArgs* OnPrepareDataBinding(
   Object* dataSource,
   bool isFlyRequest,
   string* queryText,
   int startRow,
   int endRow,
   int rowCount,
   string* additionalFilters,
   bool isDDClicked
)
C++/CLI
public:
virtual DataSourceEventArgs^ OnPrepareDataBinding(
   Object^ dataSource,
   bool isFlyRequest,
   String^ queryText,
   int startRow,
   int endRow,
   int rowCount,
   String^ additionalFilters,
   bool isDDClicked
)

Parameters

dataSource
isFlyRequest
queryText
startRow
endRow
rowCount
additionalFilters
isDDClicked

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


OnValueChanged Method

[image]
Intersoft WebCombo Documentation
OnValueChanged Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : OnValueChanged Method

Text
Returns the new datatext from changed value.
Value
Returns the new value.
Invoked when the value is changed. Invoked when the value is changed.

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnValueChanged( _
   ByVal Text As String, _
   ByVal Value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim Text As String
Dim Value As String

instance.OnValueChanged(Text, Value)
C#
public virtual void OnValueChanged(
   string Text,
   string Value
)
Delphi
public procedure OnValueChanged(
    Text: String;
    Value: String
); virtual;
JScript
public function OnValueChanged(
   Text : String,
   Value : String
);
Managed Extensions for C++
public: virtual void OnValueChanged(
   string* Text,
   string* Value
)
C++/CLI
public:
virtual void OnValueChanged(
   String^ Text,
   String^ Value
)

Parameters

Text
Returns the new datatext from changed value.
Value
Returns the new value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


PopulateUnboundData Method

[image]
Intersoft WebCombo Documentation
PopulateUnboundData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : PopulateUnboundData Method

Populate the appropriate texts of the specified multiple values into a collection of WebComboValueItem objects.

Called by the framework to save round-trip data from the WebCombo into the html ViewState variable. Called by the framework to save round-trip data from the WebCombo into the html ViewState variable.

Overload List

Overload | Description
PopulateUnboundData(DataSet,String,Boolean) | Populate the appropriate texts of the specified multiple values into a collection of WebComboValueItem objects. Called by the framework to save round-trip data from the WebCombo into the html ViewState variable.
PopulateUnboundData(DataTable,Boolean) |
PopulateUnboundData(DataView,Boolean) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

How-to: Create unbound WebCombo using PopupateUnboundData method
How-to: Create multiple columns unbound WebCombo using PopulateUnboundData method

Concepts

Unbound Mode


PopulateUnboundData(DataSet,String,Boolean) Method

[image]
Intersoft WebCombo Documentation
PopulateUnboundData(DataSet,String,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class > PopulateUnboundData Method : PopulateUnboundData(DataSet,String,Boolean) Method

ds
dataMember
isAutoCreateColumn

Populate the appropriate texts of the specified multiple values into a collection of WebComboValueItem objects.

Called by the framework to save round-trip data from the WebCombo into the html ViewState variable.

Syntax

Visual Basic (Declaration)
Public Overloads Sub PopulateUnboundData( _
   ByVal ds As DataSet, _
   ByVal dataMember As String, _
   ByVal isAutoCreateColumn As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim ds As DataSet
Dim dataMember As String
Dim isAutoCreateColumn As Boolean

instance.PopulateUnboundData(ds, dataMember, isAutoCreateColumn)
C#
public void PopulateUnboundData(
   DataSet ds,
   string dataMember,
   bool isAutoCreateColumn
)
Delphi
public procedure PopulateUnboundData(
    ds: DataSet;
    dataMember: String;
    isAutoCreateColumn: Boolean
);
JScript
public function PopulateUnboundData(
   ds : DataSet,
   dataMember : String,
   isAutoCreateColumn : boolean
);
Managed Extensions for C++
public: void PopulateUnboundData(
   DataSet* ds,
   string* dataMember,
   bool isAutoCreateColumn
)
C++/CLI
public:
void PopulateUnboundData(
   DataSet^ ds,
   String^ dataMember,
   bool isAutoCreateColumn
)

Parameters

ds
dataMember
isAutoCreateColumn

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members
Overload List


PopulateUnboundData(DataTable,Boolean) Method

[image]
Intersoft WebCombo Documentation
PopulateUnboundData(DataTable,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class > PopulateUnboundData Method : PopulateUnboundData(DataTable,Boolean) Method

dt
isAutoCreateColumn

Syntax

Visual Basic (Declaration)
Public Overloads Sub PopulateUnboundData( _
   ByVal dt As DataTable, _
   ByVal isAutoCreateColumn As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim dt As DataTable
Dim isAutoCreateColumn As Boolean

instance.PopulateUnboundData(dt, isAutoCreateColumn)
C#
public void PopulateUnboundData(
   DataTable dt,
   bool isAutoCreateColumn
)
Delphi
public procedure PopulateUnboundData(
    dt: DataTable;
    isAutoCreateColumn: Boolean
);
JScript
public function PopulateUnboundData(
   dt : DataTable,
   isAutoCreateColumn : boolean
);
Managed Extensions for C++
public: void PopulateUnboundData(
   DataTable* dt,
   bool isAutoCreateColumn
)
C++/CLI
public:
void PopulateUnboundData(
   DataTable^ dt,
   bool isAutoCreateColumn
)

Parameters

dt
isAutoCreateColumn

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members
Overload List


PopulateUnboundData(DataView,Boolean) Method

[image]
Intersoft WebCombo Documentation
PopulateUnboundData(DataView,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class > PopulateUnboundData Method : PopulateUnboundData(DataView,Boolean) Method

dv
isAutoCreateColumn

Syntax

Visual Basic (Declaration)
Public Overloads Sub PopulateUnboundData( _
   ByVal dv As DataView, _
   ByVal isAutoCreateColumn As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim dv As DataView
Dim isAutoCreateColumn As Boolean

instance.PopulateUnboundData(dv, isAutoCreateColumn)
C#
public void PopulateUnboundData(
   DataView dv,
   bool isAutoCreateColumn
)
Delphi
public procedure PopulateUnboundData(
    dv: DataView;
    isAutoCreateColumn: Boolean
);
JScript
public function PopulateUnboundData(
   dv : DataView,
   isAutoCreateColumn : boolean
);
Managed Extensions for C++
public: void PopulateUnboundData(
   DataView* dv,
   bool isAutoCreateColumn
)
C++/CLI
public:
void PopulateUnboundData(
   DataView^ dv,
   bool isAutoCreateColumn
)

Parameters

dv
isAutoCreateColumn

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members
Overload List


PopulateValueItems Method

[image]
Intersoft WebCombo Documentation
PopulateValueItems Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : PopulateValueItems Method

values
Multiple values separated by the character specified in SeparatorChar property.Multiple values separated by the character specified in SeparatorChar property.
Populate the appropriate texts of the specified multiple values into a collection of WebComboValueItem objects. Populate the appropriate texts of the specified multiple values into a collection of WebComboValueItem objects.

Syntax

Visual Basic (Declaration)
Public Function PopulateValueItems( _
   ByVal values As String _
) As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim values As String
Dim value As ArrayList

value = instance.PopulateValueItems(values)
C#
public ArrayList PopulateValueItems(
   string values
)
Delphi
public function PopulateValueItems(
    values: String
): ArrayList;
JScript
public function PopulateValueItems(
   values : String
) : ArrayList;
Managed Extensions for C++
public: ArrayList* PopulateValueItems(
   string* values
)
C++/CLI
public:
ArrayList^ PopulateValueItems(
   String^ values
)

Parameters

values
Multiple values separated by the character specified in SeparatorChar property.Multiple values separated by the character specified in SeparatorChar property.

Return Value

ArrayList.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


RaisePostBackEvent Method

[image]
Intersoft WebCombo Documentation
RaisePostBackEvent Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : RaisePostBackEvent Method

eventArgument
Called by the framework and raises post back event.

Syntax

Visual Basic (Declaration)
Public Sub RaisePostBackEvent( _
   ByVal eventArgument As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim eventArgument As String

instance.RaisePostBackEvent(eventArgument)
C#
public void RaisePostBackEvent(
   string eventArgument
)
Delphi
public procedure RaisePostBackEvent(
    eventArgument: String
);
JScript
public function RaisePostBackEvent(
   eventArgument : String
);
Managed Extensions for C++
public: void RaisePostBackEvent(
   string* eventArgument
)
C++/CLI
public:
void RaisePostBackEvent(
   String^ eventArgument
)

Parameters

eventArgument

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


RaisePostDataChangedEvent Method

[image]
Intersoft WebCombo Documentation
RaisePostDataChangedEvent Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : RaisePostDataChangedEvent Method

Syntax

Visual Basic (Declaration)
Public Overrides Sub RaisePostDataChangedEvent()
Visual Basic (Usage) Copy Code
Dim instance As WebCombo

instance.RaisePostDataChangedEvent()
C#
public override void RaisePostDataChangedEvent()
Delphi
public procedure RaisePostDataChangedEvent(); override;
JScript
public override function RaisePostDataChangedEvent();
Managed Extensions for C++
public: void RaisePostDataChangedEvent(); override
C++/CLI
public:
void RaisePostDataChangedEvent(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


ReadWebConfigValue Method

[image]
Intersoft WebCombo Documentation
ReadWebConfigValue Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : ReadWebConfigValue Method

key

Syntax

Visual Basic (Declaration)
Public Function ReadWebConfigValue( _
   ByVal key As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim key As String
Dim value As String

value = instance.ReadWebConfigValue(key)
C#
public string ReadWebConfigValue(
   string key
)
Delphi
public function ReadWebConfigValue(
    key: String
): String;
JScript
public function ReadWebConfigValue(
   key : String
) : String;
Managed Extensions for C++
public: string* ReadWebConfigValue(
   string* key
)
C++/CLI
public:
String^ ReadWebConfigValue(
   String^ key
)

Parameters

key

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


RegisterBoxSizing Method

[image]
Intersoft WebCombo Documentation
RegisterBoxSizing Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : RegisterBoxSizing Method

Overload List

Overload | Description
RegisterBoxSizing() | (Inherited from ISNet.WebUI.ISNetControl)
RegisterBoxSizing(Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


RegisterBoxSizing() Method

[image]
Intersoft WebCombo Documentation
RegisterBoxSizing() Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class > RegisterBoxSizing Method : RegisterBoxSizing() Method

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing()
Visual Basic (Usage) Copy Code
Dim instance As WebCombo

instance.RegisterBoxSizing()
C#
public void RegisterBoxSizing()
Delphi
public procedure RegisterBoxSizing();
JScript
public function RegisterBoxSizing();
Managed Extensions for C++
public: void RegisterBoxSizing();
C++/CLI
public:
void RegisterBoxSizing();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members
Overload List


RegisterBoxSizing(Boolean) Method

[image]
Intersoft WebCombo Documentation
RegisterBoxSizing(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class > RegisterBoxSizing Method : RegisterBoxSizing(Boolean) Method

forceAll

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing( _
   ByVal forceAll As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim forceAll As Boolean

instance.RegisterBoxSizing(forceAll)
C#
public void RegisterBoxSizing(
   bool forceAll
)
Delphi
public procedure RegisterBoxSizing(
    forceAll: Boolean
);
JScript
public function RegisterBoxSizing(
   forceAll : boolean
);
Managed Extensions for C++
public: void RegisterBoxSizing(
   bool forceAll
)
C++/CLI
public:
void RegisterBoxSizing(
   bool forceAll
)

Parameters

forceAll

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members
Overload List


RegisterGlobalStyle Method

[image]
Intersoft WebCombo Documentation
RegisterGlobalStyle Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : RegisterGlobalStyle Method

style

Syntax

Visual Basic (Declaration)
Public Sub RegisterGlobalStyle( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim style As ISNet.WebUI.WebStyle

instance.RegisterGlobalStyle(style)
C#
public void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle style
)
Delphi
public procedure RegisterGlobalStyle(
    style: ISNet.WebUI.WebStyle
);
JScript
public function RegisterGlobalStyle(
   style : ISNet.WebUI.WebStyle
);
Managed Extensions for C++
public: void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle* style
)
C++/CLI
public:
void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle^ style
)

Parameters

style

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


RegisterLink Method

[image]
Intersoft WebCombo Documentation
RegisterLink Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : RegisterLink Method

name
url

Syntax

Visual Basic (Declaration)
Public Sub RegisterLink( _
   ByVal name As String, _
   ByVal url As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim name As String
Dim url As String

instance.RegisterLink(name, url)
C#
public void RegisterLink(
   string name,
   string url
)
Delphi
public procedure RegisterLink(
    name: String;
    url: String
);
JScript
public function RegisterLink(
   name : String,
   url : String
);
Managed Extensions for C++
public: void RegisterLink(
   string* name,
   string* url
)
C++/CLI
public:
void RegisterLink(
   String^ name,
   String^ url
)

Parameters

name
url

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


RegisterOptimizedCssClasses Method

[image]
Intersoft WebCombo Documentation
RegisterOptimizedCssClasses Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : RegisterOptimizedCssClasses Method

runtimeStyleOnly

Syntax

Visual Basic (Declaration)
Public Sub RegisterOptimizedCssClasses( _
   ByVal runtimeStyleOnly As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim runtimeStyleOnly As Boolean

instance.RegisterOptimizedCssClasses(runtimeStyleOnly)
C#
public void RegisterOptimizedCssClasses(
   bool runtimeStyleOnly
)
Delphi
public procedure RegisterOptimizedCssClasses(
    runtimeStyleOnly: Boolean
);
JScript
public function RegisterOptimizedCssClasses(
   runtimeStyleOnly : boolean
);
Managed Extensions for C++
public: void RegisterOptimizedCssClasses(
   bool runtimeStyleOnly
)
C++/CLI
public:
void RegisterOptimizedCssClasses(
   bool runtimeStyleOnly
)

Parameters

runtimeStyleOnly

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


RegisterPreloadImage Method

[image]
Intersoft WebCombo Documentation
RegisterPreloadImage Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : RegisterPreloadImage Method

image

Syntax

Visual Basic (Declaration)
Public Sub RegisterPreloadImage( _
   ByVal image As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim image As String

instance.RegisterPreloadImage(image)
C#
public void RegisterPreloadImage(
   string image
)
Delphi
public procedure RegisterPreloadImage(
    image: String
);
JScript
public function RegisterPreloadImage(
   image : String
);
Managed Extensions for C++
public: void RegisterPreloadImage(
   string* image
)
C++/CLI
public:
void RegisterPreloadImage(
   String^ image
)

Parameters

image

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


RegisterScript Method

[image]
Intersoft WebCombo Documentation
RegisterScript Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : RegisterScript Method

Syntax

Visual Basic (Declaration)
Public Overrides Sub RegisterScript()
Visual Basic (Usage) Copy Code
Dim instance As WebCombo

instance.RegisterScript()
C#
public override void RegisterScript()
Delphi
public procedure RegisterScript(); override;
JScript
public override function RegisterScript();
Managed Extensions for C++
public: void RegisterScript(); override
C++/CLI
public:
void RegisterScript(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


RegisterSharePointHandler Method

[image]
Intersoft WebCombo Documentation
RegisterSharePointHandler Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : RegisterSharePointHandler Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub RegisterSharePointHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebCombo

instance.RegisterSharePointHandler()
C#
public virtual void RegisterSharePointHandler()
Delphi
public procedure RegisterSharePointHandler(); virtual;
JScript
public function RegisterSharePointHandler();
Managed Extensions for C++
public: virtual void RegisterSharePointHandler();
C++/CLI
public:
virtual void RegisterSharePointHandler();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


ReInitialize Method

[image]
Intersoft WebCombo Documentation
ReInitialize Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : ReInitialize Method

Forces WebCombo to be initialized. This method is useful when retrieving WebCombo object from persistence storage.

Syntax

Visual Basic (Declaration)
Public Sub ReInitialize()
Visual Basic (Usage) Copy Code
Dim instance As WebCombo

instance.ReInitialize()
C#
public void ReInitialize()
Delphi
public procedure ReInitialize();
JScript
public function ReInitialize();
Managed Extensions for C++
public: void ReInitialize();
C++/CLI
public:
void ReInitialize();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


RenderBeginTag Method

[image]
Intersoft WebCombo Documentation
RenderBeginTag Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : RenderBeginTag Method

writer

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderBeginTag( _
   ByVal writer As HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim writer As HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public virtual void RenderBeginTag(
   HtmlTextWriter writer
)
Delphi
public procedure RenderBeginTag(
    writer: HtmlTextWriter
); virtual;
JScript
public function RenderBeginTag(
   writer : HtmlTextWriter
);
Managed Extensions for C++
public: virtual void RenderBeginTag(
   HtmlTextWriter* writer
)
C++/CLI
public:
virtual void RenderBeginTag(
   HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


RenderControl Method

[image]
Intersoft WebCombo Documentation
RenderControl Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : RenderControl Method

Overload List

Overload | Description
RenderControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebCombo Documentation
RenderControl(HtmlTextWriter) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : RenderControl(HtmlTextWriter) Method

writer

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderControl( _
   ByVal writer As HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim writer As HtmlTextWriter

instance.RenderControl(writer)
C#
public virtual void RenderControl(
   HtmlTextWriter writer
)
Delphi
public procedure RenderControl(
    writer: HtmlTextWriter
); virtual;
JScript
public function RenderControl(
   writer : HtmlTextWriter
);
Managed Extensions for C++
public: virtual void RenderControl(
   HtmlTextWriter* writer
)
C++/CLI
public:
virtual void RenderControl(
   HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


RenderEndTag Method

[image]
Intersoft WebCombo Documentation
RenderEndTag Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : RenderEndTag Method

writer

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderEndTag( _
   ByVal writer As HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim writer As HtmlTextWriter

instance.RenderEndTag(writer)
C#
public override void RenderEndTag(
   HtmlTextWriter writer
)
Delphi
public procedure RenderEndTag(
    writer: HtmlTextWriter
); override;
JScript
public override function RenderEndTag(
   writer : HtmlTextWriter
);
Managed Extensions for C++
public: void RenderEndTag(
   HtmlTextWriter* writer
) override
C++/CLI
public:
void RenderEndTag(
   HtmlTextWriter^ writer
) override

Parameters

writer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


Reset Method

[image]
Intersoft WebCombo Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : Reset Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebCombo

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


ResetStyleToDefault Method

[image]
Intersoft WebCombo Documentation
ResetStyleToDefault Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : ResetStyleToDefault Method

Clear any styles associated with this control and set the control to use default WebCombo.NET style.

Syntax

Visual Basic (Declaration)
Public Sub ResetStyleToDefault()
Visual Basic (Usage) Copy Code
Dim instance As WebCombo

instance.ResetStyleToDefault()
C#
public void ResetStyleToDefault()
Delphi
public procedure ResetStyleToDefault();
JScript
public function ResetStyleToDefault();
Managed Extensions for C++
public: void ResetStyleToDefault();
C++/CLI
public:
void ResetStyleToDefault();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


ResolveClientUrl Method

[image]
Intersoft WebCombo Documentation
ResolveClientUrl Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : ResolveClientUrl Method

relativeUrl

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim relativeUrl As String
Dim value As String

value = instance.ResolveClientUrl(relativeUrl)
C#
public string ResolveClientUrl(
   string relativeUrl
)
Delphi
public function ResolveClientUrl(
    relativeUrl: String
): String;
JScript
public function ResolveClientUrl(
   relativeUrl : String
) : String;
Managed Extensions for C++
public: string* ResolveClientUrl(
   string* relativeUrl
)
C++/CLI
public:
String^ ResolveClientUrl(
   String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


ResolveImagePath Method

[image]
Intersoft WebCombo Documentation
ResolveImagePath Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : ResolveImagePath Method

folder
image

Syntax

Visual Basic (Declaration)
Public Function ResolveImagePath( _
   ByVal folder As String, _
   ByVal image As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim folder As String
Dim image As String
Dim value As String

value = instance.ResolveImagePath(folder, image)
C#
public string ResolveImagePath(
   string folder,
   string image
)
Delphi
public function ResolveImagePath(
    folder: String;
    image: String
): String;
JScript
public function ResolveImagePath(
   folder : String,
   image : String
) : String;
Managed Extensions for C++
public: string* ResolveImagePath(
   string* folder,
   string* image
)
C++/CLI
public:
String^ ResolveImagePath(
   String^ folder,
   String^ image
)

Parameters

folder
image

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


ResolveRelativeURL Method

[image]
Intersoft WebCombo Documentation
ResolveRelativeURL Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : ResolveRelativeURL Method

url

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveRelativeURL( _
   ByVal url As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim url As String
Dim value As String

value = instance.ResolveRelativeURL(url)
C#
public virtual string ResolveRelativeURL(
   string url
)
Delphi
public function ResolveRelativeURL(
    url: String
): String; virtual;
JScript
public function ResolveRelativeURL(
   url : String
) : String;
Managed Extensions for C++
public: virtual string* ResolveRelativeURL(
   string* url
)
C++/CLI
public:
virtual String^ ResolveRelativeURL(
   String^ url
)

Parameters

url

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


ResolveResourceUrl Method

[image]
Intersoft WebCombo Documentation
ResolveResourceUrl Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : ResolveResourceUrl Method

kind
defaultFolder
currentFolder
resourceName

Syntax

Visual Basic (Declaration)
Public Function ResolveResourceUrl( _
   ByVal kind As ISNet.WebUI.ResourceKind, _
   ByVal defaultFolder As String, _
   ByVal currentFolder As String, _
   ByVal resourceName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim kind As ISNet.WebUI.ResourceKind
Dim defaultFolder As String
Dim currentFolder As String
Dim resourceName As String
Dim value As String

value = instance.ResolveResourceUrl(kind, defaultFolder, currentFolder, resourceName)
C#
public string ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   string defaultFolder,
   string currentFolder,
   string resourceName
)
Delphi
public function ResolveResourceUrl(
    kind: ISNet.WebUI.ResourceKind;
    defaultFolder: String;
    currentFolder: String;
    resourceName: String
): String;
JScript
public function ResolveResourceUrl(
   kind : ISNet.WebUI.ResourceKind,
   defaultFolder : String,
   currentFolder : String,
   resourceName : String
) : String;
Managed Extensions for C++
public: string* ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   string* defaultFolder,
   string* currentFolder,
   string* resourceName
)
C++/CLI
public:
String^ ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   String^ defaultFolder,
   String^ currentFolder,
   String^ resourceName
)

Parameters

kind
defaultFolder
currentFolder
resourceName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


ResolveUrl Method

[image]
Intersoft WebCombo Documentation
ResolveUrl Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : ResolveUrl Method

relativeUrl

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim relativeUrl As String
Dim value As String

value = instance.ResolveUrl(relativeUrl)
C#
public string ResolveUrl(
   string relativeUrl
)
Delphi
public function ResolveUrl(
    relativeUrl: String
): String;
JScript
public function ResolveUrl(
   relativeUrl : String
) : String;
Managed Extensions for C++
public: string* ResolveUrl(
   string* relativeUrl
)
C++/CLI
public:
String^ ResolveUrl(
   String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


SaveLayout Method

[image]
Intersoft WebCombo Documentation
SaveLayout Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : SaveLayout Method

Saves LayoutSet properties to a file.Saves LayoutSet properties to a file. Save WebCombo's layout settings to a layout file

Overload List

Overload | Description
SaveLayout(String) | Saves LayoutSet properties to a file.Saves LayoutSet properties to a file.
SaveLayout(Stream) | Saves LayoutSet properties to Stream.Saves LayoutSet properties to Stream.
SaveLayout(LayoutInfo) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members
How-to: Save Current Layout


SaveLayout(String) Method

[image]
Intersoft WebCombo Documentation
SaveLayout(String) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class > SaveLayout Method : SaveLayout(String) Method

fileName
The layout filename.The layout filename.
Saves LayoutSet properties to a file.Saves LayoutSet properties to a file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveLayout( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim fileName As String

instance.SaveLayout(fileName)
C#
public void SaveLayout(
   string fileName
)
Delphi
public procedure SaveLayout(
    fileName: String
);
JScript
public function SaveLayout(
   fileName : String
);
Managed Extensions for C++
public: void SaveLayout(
   string* fileName
)
C++/CLI
public:
void SaveLayout(
   String^ fileName
)

Parameters

fileName
The layout filename.The layout filename.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members
Overload List


SaveLayout(Stream) Method

[image]
Intersoft WebCombo Documentation
SaveLayout(Stream) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class > SaveLayout Method : SaveLayout(Stream) Method

stream
Saves LayoutSet properties to Stream.Saves LayoutSet properties to Stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveLayout( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim stream As Stream

instance.SaveLayout(stream)
C#
public void SaveLayout(
   Stream stream
)
Delphi
public procedure SaveLayout(
    stream: Stream
);
JScript
public function SaveLayout(
   stream : Stream
);
Managed Extensions for C++
public: void SaveLayout(
   Stream* stream
)
C++/CLI
public:
void SaveLayout(
   Stream^ stream
)

Parameters

stream

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members
Overload List


SaveLayout(LayoutInfo) Method

[image]
Intersoft WebCombo Documentation
SaveLayout(LayoutInfo) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class > SaveLayout Method : SaveLayout(LayoutInfo) Method

settings

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub SaveLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim settings As ISNet.WebUI.LayoutInfo

instance.SaveLayout(settings)
C#
public virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo settings
)
Delphi
public procedure SaveLayout(
    settings: ISNet.WebUI.LayoutInfo
); virtual;
JScript
public function SaveLayout(
   settings : ISNet.WebUI.LayoutInfo
);
Managed Extensions for C++
public: virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo* settings
)
C++/CLI
public:
virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo^ settings
)

Parameters

settings

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members
Overload List


SaveLayoutToFile Method

[image]
Intersoft WebCombo Documentation
SaveLayoutToFile Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : SaveLayoutToFile Method

filePath
saveOptions
Saves WebCombo's layout settings properties to a file.

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToFile( _
   ByVal filePath As String, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim filePath As String
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToFile(filePath, saveOptions)
C#
public virtual void SaveLayoutToFile(
   string filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
Delphi
public procedure SaveLayoutToFile(
    filePath: String;
    saveOptions: ISNet.WebUI.SaveLayoutOptions
); virtual;
JScript
public function SaveLayoutToFile(
   filePath : String,
   saveOptions : ISNet.WebUI.SaveLayoutOptions
);
Managed Extensions for C++
public: virtual void SaveLayoutToFile(
   string* filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
C++/CLI
public:
virtual void SaveLayoutToFile(
   String^ filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

filePath
saveOptions

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


SaveLayoutToStream Method

[image]
Intersoft WebCombo Documentation
SaveLayoutToStream Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : SaveLayoutToStream Method

stream
saveOptions
Saves WebCombo's layout settings properties to a memory stream.

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToStream( _
   ByVal stream As Stream, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim stream As Stream
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToStream(stream, saveOptions)
C#
public virtual void SaveLayoutToStream(
   Stream stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
Delphi
public procedure SaveLayoutToStream(
    stream: Stream;
    saveOptions: ISNet.WebUI.SaveLayoutOptions
); virtual;
JScript
public function SaveLayoutToStream(
   stream : Stream,
   saveOptions : ISNet.WebUI.SaveLayoutOptions
);
Managed Extensions for C++
public: virtual void SaveLayoutToStream(
   Stream* stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
C++/CLI
public:
virtual void SaveLayoutToStream(
   Stream^ stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

stream
saveOptions

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


SerializeObjectData Method

[image]
Intersoft WebCombo Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : SerializeObjectData Method

type
info
context

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim type As Type
Dim info As SerializationInfo
Dim context As StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: Type;
    info: SerializationInfo;
    context: StreamingContext
);
JScript
public function SerializeObjectData(
   type : Type,
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   Type* type,
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   Type^ type,
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


SetCacheControl Method

[image]
Intersoft WebCombo Documentation
SetCacheControl Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : SetCacheControl Method

duration
The duration of the cache.
priority
Overrides the default data cache configuration. Overrides the default data cache configuration.

Syntax

Visual Basic (Declaration)
Public Sub SetCacheControl( _
   ByVal duration As TimeSpan, _
   ByVal priority As CacheItemPriority _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim duration As TimeSpan
Dim priority As CacheItemPriority

instance.SetCacheControl(duration, priority)
C#
public void SetCacheControl(
   TimeSpan duration,
   CacheItemPriority priority
)
Delphi
public procedure SetCacheControl(
    duration: TimeSpan;
    priority: CacheItemPriority
);
JScript
public function SetCacheControl(
   duration : TimeSpan,
   priority : CacheItemPriority
);
Managed Extensions for C++
public: void SetCacheControl(
   TimeSpan duration,
   CacheItemPriority priority
)
C++/CLI
public:
void SetCacheControl(
   TimeSpan duration,
   CacheItemPriority priority
)

Parameters

duration
The duration of the cache.
priority

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


SetMultipleValues Method

[image]
Intersoft WebCombo Documentation
SetMultipleValues Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : SetMultipleValues Method

Sets multiple values into the WebCombo.

Sets multiple values into the WebCombo.

Overload List

Overload | Description
SetMultipleValues(String,String) | Sets multiple values into the WebCombo. Sets multiple values into the WebCombo.
SetMultipleValues(ArrayList) | Sets multiple values into the WebCombo. Sets multiple values into the WebCombo.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

How-to: Set initial value of multiple selection WebCombo from server side

Concepts

Multiple Selection


SetMultipleValues(String,String) Method

[image]
Intersoft WebCombo Documentation
SetMultipleValues(String,String) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class > SetMultipleValues Method : SetMultipleValues(String,String) Method

text
string contains multiple value's text separated by the character specified in SeparatorChar propertystring contains multiple value's text separated by the character specified in SeparatorChar property
values
string contains multiple value's value separated by the character specified in SeparatorChar property string contains multiple value's value separated by the character specified in SeparatorChar property

Sets multiple values into the WebCombo.

Sets multiple values into the WebCombo.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetMultipleValues( _
   ByVal text As String, _
   ByVal values As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim text As String
Dim values As String

instance.SetMultipleValues(text, values)
C#
public void SetMultipleValues(
   string text,
   string values
)
Delphi
public procedure SetMultipleValues(
    text: String;
    values: String
);
JScript
public function SetMultipleValues(
   text : String,
   values : String
);
Managed Extensions for C++
public: void SetMultipleValues(
   string* text,
   string* values
)
C++/CLI
public:
void SetMultipleValues(
   String^ text,
   String^ values
)

Parameters

text
string contains multiple value's text separated by the character specified in SeparatorChar propertystring contains multiple value's text separated by the character specified in SeparatorChar property
values
string contains multiple value's value separated by the character specified in SeparatorChar property string contains multiple value's value separated by the character specified in SeparatorChar property

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members
Overload List


SetMultipleValues(ArrayList) Method

[image]
Intersoft WebCombo Documentation
SetMultipleValues(ArrayList) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class > SetMultipleValues Method : SetMultipleValues(ArrayList) Method

valueItems
ArrayList object contains a collection of WebComboValueItem objects.ArrayList object contains a collection of WebComboValueItem objects.

Sets multiple values into the WebCombo.

Sets multiple values into the WebCombo.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetMultipleValues( _
   ByVal valueItems As ArrayList _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim valueItems As ArrayList

instance.SetMultipleValues(valueItems)
C#
public void SetMultipleValues(
   ArrayList valueItems
)
Delphi
public procedure SetMultipleValues(
    valueItems: ArrayList
);
JScript
public function SetMultipleValues(
   valueItems : ArrayList
);
Managed Extensions for C++
public: void SetMultipleValues(
   ArrayList* valueItems
)
C++/CLI
public:
void SetMultipleValues(
   ArrayList^ valueItems
)

Parameters

valueItems
ArrayList object contains a collection of WebComboValueItem objects.ArrayList object contains a collection of WebComboValueItem objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members
Overload List


SetRenderMethodDelegate Method

[image]
Intersoft WebCombo Documentation
SetRenderMethodDelegate Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : SetRenderMethodDelegate Method

renderMethod

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim renderMethod As RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void SetRenderMethodDelegate(
   RenderMethod renderMethod
)
Delphi
public procedure SetRenderMethodDelegate(
    renderMethod: RenderMethod
);
JScript
EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function SetRenderMethodDelegate(
   renderMethod : RenderMethod
);
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void SetRenderMethodDelegate(
   RenderMethod* renderMethod
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void SetRenderMethodDelegate(
   RenderMethod^ renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


SetSessionTheme Method

[image]
Intersoft WebCombo Documentation
SetSessionTheme Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : SetSessionTheme Method

themeInfo

Syntax

Visual Basic (Declaration)
Public Sub SetSessionTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetSessionTheme(themeInfo)
C#
public void SetSessionTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)
Delphi
public procedure SetSessionTheme(
    themeInfo: ISNet.WebUI.ThemeInfo
);
JScript
public function SetSessionTheme(
   themeInfo : ISNet.WebUI.ThemeInfo
);
Managed Extensions for C++
public: void SetSessionTheme(
   ISNet.WebUI.ThemeInfo* themeInfo
)
C++/CLI
public:
void SetSessionTheme(
   ISNet.WebUI.ThemeInfo^ themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


ShouldReturnJson Method

[image]
Intersoft WebCombo Documentation
ShouldReturnJson Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : ShouldReturnJson Method

Syntax

Visual Basic (Declaration)
Public Overridable Function ShouldReturnJson() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

value = instance.ShouldReturnJson()
C#
public virtual bool ShouldReturnJson()
Delphi
public function ShouldReturnJson(): Boolean; virtual;
JScript
public function ShouldReturnJson() : boolean;
Managed Extensions for C++
public: virtual bool ShouldReturnJson();
C++/CLI
public:
virtual bool ShouldReturnJson();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


ShowOnlyColumns Method

[image]
Intersoft WebCombo Documentation
ShowOnlyColumns Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : ShowOnlyColumns Method

fieldNames
An array of string representing the field name you want it to be shown. An array of string representing the field name you want it to be shown.

Show only the columns specified in fieldNames. You should only use this method when ComboMode is set to MultipleColumns.

Show only the columns specified in fieldNames. You should only use this method when LayoutSet.ComboMode is set to MultipleColumns.

Syntax

Visual Basic (Declaration)
Public Sub ShowOnlyColumns( _
   ByVal fieldNames() As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim fieldNames() As String

instance.ShowOnlyColumns(fieldNames)
C#
public void ShowOnlyColumns(
   string[] fieldNames
)
Delphi
public procedure ShowOnlyColumns(
    fieldNames: Stringarray of
);
JScript
public function ShowOnlyColumns(
   fieldNames : String[]
);
Managed Extensions for C++
public: void ShowOnlyColumns(
   string*[]* fieldNames
)
C++/CLI
public:
void ShowOnlyColumns(
   array<String^>^ fieldNames
)

Parameters

fieldNames
An array of string representing the field name you want it to be shown. An array of string representing the field name you want it to be shown.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


AccessKey Property

[image]
Intersoft WebCombo Documentation
AccessKey Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : AccessKey Property

Keyboard shortcut used by the control.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<CategoryAttribute("Behavior")>
Public Overridable Property AccessKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As String

instance.AccessKey = value

value = instance.AccessKey
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[CategoryAttribute("Behavior")]
public virtual string AccessKey {get; set;}
Delphi
public read-write property AccessKey: String; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
CategoryAttribute("Behavior")
public function get,set AccessKey : String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[CategoryAttribute("Behavior")]
public: __property virtual string* get_AccessKey();
public: __property virtual void set_AccessKey(
   string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[CategoryAttribute("Behavior")]
public:
virtual property String^ AccessKey {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

How-to: Define access key

Concepts

All-new, sleeker User Interface
User Interface Elements


WebCombo Class Properties

[image]
Intersoft WebCombo Documentation
WebCombo Class Properties
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : WebCombo Class

For a list of all members of this type, see WebCombo members.

Public Properties

 | Name | Description
public Property | AccessKey | Keyboard shortcut used by the control. (Inherited from System.Web.UI.WebControls.WebControl)
public Property | AdditionalSearchFields | Returns or sets the additional data field used to match rows against user's input. Returns or sets the additional data field used to match rows against user's input.
public Property | AllowAutoDataCaching | Specifies whether data caching is automatically handled by the control. Specifies whether data caching is automatically handled by the control.
public Property | AllowAutoPostback | Specifies whether postback will be automatically invoked when selected index is changed. Specifies whether postback will be automatically invoked when selected index is changed.
public Property | AllowAutoQueryHandler | Specifies whether or not to allow WebCombo to automatically handle query request. Specifies whether or not to allow WebCombo to automatically handle query request.
public Property | AllowWildCardSearch | Specifies whether or not to allow wild card searching / fuzzy logic searching. Specifies whether or not to allow wild card searching / fuzzy logic searching.
public Property | BackColor | Overridden. Returns or sets the background color of the control. Returns or sets the background color of the control.
public Property | BindingOperationMode |
public Property | BorderColor | Overridden. Returns or sets the border color of the control. Returns or sets the border color of the control.
public Property | BorderStyle | Overridden. Returns or sets the border style of the control. returns or sets the border style of the control.
public Property | BorderWidth | Overridden. Returns or sets the border width of the control. Returns or sets the border width of the control.
public Property | CacheServerConnection | Specifies the file server connection string to store data cache. Specifies the file server connection string to store data cache.
public Property | ClientBindingSettings |
public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
public Property | DataCacheStorage | Specifies where to store the data cache. Specifies where to store the data cache.
public Property | DataMember | Specifies the data member in multimember data source to bind to the WebCombo control. Specifies the data member in multimember data source to bind to the WebCombo control.
public Property | DataSource | Specifies the datasource object which the control bind to. Specifies the datasource object which the control bind to.
public Property | DataSourceID | Gets or sets the ID of the control from which the WebCombo control retrieves its list of data items.Gets or sets the ID of the control from which the WebCombo control retrieves its list of data items.
public Property | DataTextField | Returns or sets the data field used to display the text in WebCombo control. Returns or sets the data field used to display the text in WebCombo control.
public Property | DataValueField | Returns or sets the field used as the value in WebCombo control. Returns or sets the field used as the value in WebCombo control.
public Property | DropDownRows | Specifies the number of initial records retrieved by the WebCombo control. Specifies the number of initial records retrieved by the WebCombo control.
public Property | Enabled | Gets or sets the enabled state of the control. (Inherited from System.Web.UI.WebControls.WebControl)
public Property | EnableManagedTheming | Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture. (Inherited from ISNet.WebUI.ISNetControl)
public Property | EnableTheming | (Inherited from System.Web.UI.Control)
public Property | EnableViewState | Gets or sets whether the control automatically saves its state for use in round-trip. (Inherited from System.Web.UI.Control)
public Property | EnableWebResources | Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). (Inherited from ISNet.WebUI.ISNetControl)
public Property | FlyPostBackSettings | Configures the settings used by the control when performing OnTheFly postback. Configures the settings used by the control when performing OnTheFly postback.
public Property | Font | Overridden. Returns or sets the font used in the control. Returns or sets the font used in the control.
public Property | ForeColor | Overridden. Returns or sets a Color object that specifies the foreground color of the control.Returns or sets a Color object that specifies the foreground color of the control.
public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
public Property | ID | (Inherited from System.Web.UI.Control)
public Property | IntegrationSettings | Provides settings for integrating other server side controls as the WebCombo's ResultBox.
public Property | Latency | Specifies the wait time after last keypress in milliseconds before the control make data request. Specifies the wait time after last keypress in milliseconds before the control make data request.
public Property | LayoutSettings | The central object that contain all the behaviors and styles for the whole WebCombo control. LayoutSettings is the central object that contain all the behaviors and styles for the whole WebCombo control.
public Property | LinkSettings | Provides settings for linking to another WebCombo. Provides settings for linking to another WebCombo.
public Property | MinCharsToRequest | Returns or sets the minimum length of input character for requesting data retrieval. Returns or sets the minimum length of input character for requesting data retrieval.
public Property | MultipleSelectionSettings | Provides settings for multiple selections feature. Provides settings for multiple selections feature.
public Property | Page | (Inherited from System.Web.UI.Control)
public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
public Property | RuntimeLicenseKey | The runtime license key for xcopy deployment. Registered customers please obtain through Intersoft Developer Network. (Inherited from ISNet.WebUI.ISNetControl)
public Property | ScriptDirectory | Overridden. Overriden.
public Property | SerializeTagToClient |
public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all shared scripts for Intersoft controls are stored.
public Property | ShowErrorMessages | Specifies whether to display error messages when DataSources, DataTextField or DataValueField is not specified.Specifies whether error messages always be shown when no datasource, datatextfield or datavaluefield is specified.
public Property | SkinID | (Inherited from System.Web.UI.Control)
public Property | TabIndex | The tab order of the control. (Inherited from System.Web.UI.WebControls.WebControl)
public Property | TextBoxLength | Specifies the size of the textbox control. Specifies the size of the textbox control.
public Property | ToolTip | The tooltip displayed when the mouse is over the control. (Inherited from System.Web.UI.WebControls.WebControl)
public Property | UseCachedDataOnFirstLoad | Specifies whether the cached data source will always be used on first page load. Specifies whether the cached data source will always be used on first page load.
public Property | UseDefaultStyle | Indicates whether this control should use default WebCombo.NET 4.0 styles and appearance settings. Indicates whether this control should use default WebCombo.NET 4.0 styles and appearance settings. See Help for more information.
public Property | Value | Returns or sets the value for WebCombo control. Returns or sets the value for WebCombo control.
public Property | ViewStateItems | Gets or sets the items to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
public Property | Visible | Gets or sets a value indicating whether the control is rendered as UI on the page. (Inherited from System.Web.UI.Control)
public Property | Width | Overridden. Overriden. Returns or sets the width of the control. Returns or sets the width of the control.
public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebCombo Class
ISNet.WebUI.WebCombo Namespace


AdditionalSearchFields Property

[image]
Intersoft WebCombo Documentation
AdditionalSearchFields Property
See Also Example Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : AdditionalSearchFields Property

Returns or sets the additional data field used to match rows against user's input. Returns or sets the additional data field used to match rows against user's input.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Returns or sets the additional data fields used to match rows against user's input.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<CategoryAttribute("Data")>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
Public Property AdditionalSearchFields As String
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As String

instance.AdditionalSearchFields = value

value = instance.AdditionalSearchFields
C#
[DescriptionAttribute("Returns or sets the additional data fields used to match rows against user's input.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[CategoryAttribute("Data")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
public string AdditionalSearchFields {get; set;}
Delphi
public read-write property AdditionalSearchFields: String;
JScript
DescriptionAttribute("Returns or sets the additional data fields used to match rows against user's input.")
ISNet.Serialization.XmlSerializableAttribute()
CategoryAttribute("Data")
NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
public function get,set AdditionalSearchFields : String
Managed Extensions for C++
[DescriptionAttribute("Returns or sets the additional data fields used to match rows against user's input.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[CategoryAttribute("Data")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
public: __property string* get_AdditionalSearchFields();
public: __property void set_AdditionalSearchFields(
   string* value
);
C++/CLI
[DescriptionAttribute("Returns or sets the additional data fields used to match rows against user's input.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[CategoryAttribute("Data")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
public:
property String^ AdditionalSearchFields {
   String^ get();
   void set (    String^ value);
}

Example

The following example shows you how to bind data source to a WebCombo using e.DataSource (old databinding mode) and use the AdditionalSearchFields programmatically in InitializeLayout event. Note that the name of the columns which will be inserted into the AdditionalSearchFields property should be separated by comma.
C# Copy Code
private void WebCombo1_InitializeDataSource(object sender, ISNet.WebUI.WebCombo.DataSourceEventArgs e)
{
    DataSet ds = new DataSet();
    oleDbDataAdapter1.Fill(ds,"Customers");
    e.DataSource =  ds;
    WebCombo1.DataTextField = "ContactName";
    WebCombo1.DataValueField = "CustomerID";
}

private void WebCombo1_InitializeLayout(object sender, ISNet.WebUI.WebCombo.LayoutEventArgs e)
{
    e.Layout.ComboMode = Mode.MultipleColumns;
    WebCombo1.AdditionalSearchFields = "ContactName, City, Country";
}

Remarks

You can set multiple data fields by using comma as separator. For example, OfficePhone, HomePhone

This property provides a convenient way for developers when the application require more than one data field to be searched instead of the specified DataTextField.

When you set a value to this property and AllowAutoQueryHandler is set to True, WebCombo will automatically search the user's input initially by DataTextField then followed by comma separated data fields assigned in this property. This feature is normally used in conjunction with MultipleColumns combo mode which allow users to see matched information in columns based on their input.

Note that this property will only be used to search against user's input, the displayed selected text will still be using the value specified in DataTextField. To learn more on this feature please read Additional Search Field.

You can set multiple data fields by using comma as separator. For example, OfficePhone, HomePhone

This property provides a convenient way for developers when the application require more than one data field to be searched instead of the specified DataTextField.

When you set a value to this property and AllowAutoQueryHandler is set to True, WebCombo will automatically search the user's input initially by DataTextField then followed by comma separated data fields assigned in this property. This feature is normally used in conjuction with MultipleColumns combomode which allow users to see matched information in columns based on their input.

Note that this property will only be used to search against user's input, the displayed selected text will still be using the value specified in DataTextField.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

How-to: Use AdditionalSearchField to search a query text on other column besides DataTextField column

Concepts

Additional Search Field


AllowAutoDataCaching Property

[image]
Intersoft WebCombo Documentation
AllowAutoDataCaching Property
See Also Example Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : AllowAutoDataCaching Property

Specifies whether data caching is automatically handled by the control. Specifies whether data caching is automatically handled by the control.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Data")>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies whether data caching is automatically handled by the control.")>
Public Property AllowAutoDataCaching As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

instance.AllowAutoDataCaching = value

value = instance.AllowAutoDataCaching
C#
[CategoryAttribute("Data")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies whether data caching is automatically handled by the control.")]
public bool AllowAutoDataCaching {get; set;}
Delphi
public read-write property AllowAutoDataCaching: Boolean;
JScript
CategoryAttribute("Data")
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
DescriptionAttribute("Specifies whether data caching is automatically handled by the control.")
public function get,set AllowAutoDataCaching : boolean
Managed Extensions for C++
[CategoryAttribute("Data")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies whether data caching is automatically handled by the control.")]
public: __property bool get_AllowAutoDataCaching();
public: __property void set_AllowAutoDataCaching(
   bool value
);
C++/CLI
[CategoryAttribute("Data")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies whether data caching is automatically handled by the control.")]
public:
property bool AllowAutoDataCaching {
   bool get();
   void set (    bool value);
}

Example

You should use IsDataCached method before assign a DataSource to take advantage the built-in WebCombo datacaching mechanishm.
You should use IsDataCached method before assign a DataSource to take advantage the built-in WebCombo datacaching mechanism.
C# Copy Code
private void Page_Load(object sender, System.EventArgs e)
{
    if (!WebCombo1.IsDataCached())
    {
        WebCombo1.DataSource = LookupClass.GetProducts();
        WebCombo1.DataBind();
    }
}
C# Copy Code
private void Page_Load(object sender, System.EventArgs e)
{
    if (!WebCombo1.IsDataCached())
    {
        WebCombo1.DataSource = LookupClass.GetProducts();
        WebCombo1.DataBind();
    }

Remarks

This property enables the automatic caching of assigned DataSource object. The default value is True which is a powerful and effective approach to reduce server's workload and dramatically increase server response time.

By utilizing the power of .NET caching feature, WebCombo.NET implements advanced datacaching mechanism to reduce server workloads. The scope of the cache is session. This enables a greater and more flexible control to the WebCombo object. The WebCombo control keeps track of each session's cache and will automatically remove the DataSource object from cache when it's no longer accessed.

If the DataSource object is a dynamic object -- means that it is changed or added in less than 5 minutes -- you may consider to set this property to False.

In order to take advantage of this property, you should always use IsDataCached to check whether the DataSource has already been cached before you assign a DataSource. See the example for details.

In some scenarios, you can assign a different DataSource directly from code with just assigning the DataSource property to new datasource. In this case, old cache will be automatically removed and new instance of cache will be created.

This property enables the automatic caching of assigned DataSource object. Always leave this property to True as it's a powerful and effective approach to reduce server's workload and dramatically increase server response time.

By utilizing the power of .NET caching feature, WebCombo.NET implements advanced datacaching mechanism to reduce server workloads. The scope of the cache is session. This enables a greater and more flexible control to the WebCombo object. The WebCombo control keeps track of each session's cache and will automatically remove the DataSource object from cache when it's no longer accessed.

If the DataSource object is a dynamic object -- means that it always been changed or added in less than 5 mins -- you may consider to set this property to False.

In order to take advantage of this property, you should always use IsDataCached to check whether the DataSource already been cached before you assign a DataSource. See the examples for details.

In some scenarios, you can assign a different DataSource directly from code with just assigning the DataSource property to new datasource. In this case, old cache will be automatically removed and new instance of cache will be created.

Default value is True.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

How-to: Disable auto data caching

Concepts

User Interface Elements
Automatic Data Caching Handler
All-new, sleeker User Interface


AllowAutoPostback Property

[image]
Intersoft WebCombo Documentation
AllowAutoPostback Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : AllowAutoPostback Property

Specifies whether postback will be automatically invoked when selected index is changed. Specifies whether postback will be automatically invoked when selected index is changed.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<CategoryAttribute("Behavior")>
<DescriptionAttribute("Specifies whether postback will be automatically invoked when selected index is changed.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<DefaultValueAttribute()>
Public Property AllowAutoPostback As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

instance.AllowAutoPostback = value

value = instance.AllowAutoPostback
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Specifies whether postback will be automatically invoked when selected index is changed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
public bool AllowAutoPostback {get; set;}
Delphi
public read-write property AllowAutoPostback: Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
CategoryAttribute("Behavior")
DescriptionAttribute("Specifies whether postback will be automatically invoked when selected index is changed.")
ISNet.Serialization.XmlSerializableAttribute()
DefaultValueAttribute()
public function get,set AllowAutoPostback : boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Specifies whether postback will be automatically invoked when selected index is changed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
public: __property bool get_AllowAutoPostback();
public: __property void set_AllowAutoPostback(
   bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Specifies whether postback will be automatically invoked when selected index is changed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
public:
property bool AllowAutoPostback {
   bool get();
   void set (    bool value);
}

Remarks

When this property is set to True, the browser will automatically invoke postback when selected index is changed.

Default value is False.

When set to true, the browser will automatically invoke postback when selected index is changed.

Default value is False.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

How-to: Allow auto PostBack

Concepts

All-new, sleeker User Interface
User Interface Elements


AllowAutoQueryHandler Property

[image]
Intersoft WebCombo Documentation
AllowAutoQueryHandler Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : AllowAutoQueryHandler Property

Specifies whether or not to allow WebCombo to automatically handle query request. Specifies whether or not to allow WebCombo to automatically handle query request.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Specifies whether or not to allow WebCombo to automatically handle query request.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<CategoryAttribute("Behavior")>
Public Property AllowAutoQueryHandler As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

instance.AllowAutoQueryHandler = value

value = instance.AllowAutoQueryHandler
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies whether or not to allow WebCombo to automatically handle query request.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
public bool AllowAutoQueryHandler {get; set;}
Delphi
public read-write property AllowAutoQueryHandler: Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
NotifyParentPropertyAttribute()
DescriptionAttribute("Specifies whether or not to allow WebCombo to automatically handle query request.")
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
CategoryAttribute("Behavior")
public function get,set AllowAutoQueryHandler : boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies whether or not to allow WebCombo to automatically handle query request.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
public: __property bool get_AllowAutoQueryHandler();
public: __property void set_AllowAutoQueryHandler(
   bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies whether or not to allow WebCombo to automatically handle query request.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
public:
property bool AllowAutoQueryHandler {
   bool get();
   void set (    bool value);
}

Remarks

The default value of this property is True, which the WebCombo will perform automatic query handling.

You need to set this property to False if you want to enable LoadOnDemand data retrieval mechanism. With this property set to False, the WebCombo will not perform the automatic (default behavior) query handling. In previous versions, you need to write your own code for your specific data-retrieval scenario in InitializeDataSource event. Data retrieval is handled at component level. The load-on-demand mechanism is also handled at component level, for instance, at WebCombo level. This is required because both user interface and data handling are mixed.

The load-on-demand data retrieval in WebCombo.NET version 4.0 can be used when bound to datasource control. However, the currently supported datasource control for this operation is ISDataSource control only.

When bound to ISDataSource and AllowAutoQueryHandler of WebCombo is set to False, the WebCombo will connect to special method available in the specified Select method property of ISDataSource control. For instance, if the Select method property is set to GetData, then you required to create one method with name GetData with 3 parameters, and one get count method with 1 parameter. The detailed signature is as following:

public DataTable GetData(int maximumRows, int startRowIndex, string queryText)
public int SelectCount(string queryText)

The supplied methods allow the datasource control to reuse it in other pages, and thus providing higher level of usability. This concept also enables user interface components to interact with datasource in consistent fashion through datasource control.

To learn more about how to use load-on-demand feature using ISDataSourceControl, please read Walkthrough: Using load-on-demand data retrieval with ISDataSource control in WebCombo .

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

Walkthrough: Using load-on-demand data retrieval with ISDataSource control in WebCombo
How-to: Apply load on demand in WebCombo
How-to: Disable auto query handler

Concepts

Load On Demand
All-new, sleeker User Interface
User Interface Elements


AllowWildCardSearch Property

[image]
Intersoft WebCombo Documentation
AllowWildCardSearch Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : AllowWildCardSearch Property

Specifies whether or not to allow wild card searching / fuzzy logic searching. Specifies whether or not to allow wild card searching / fuzzy logic searching.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Specifies whether or not to allow wild card searching / fuzzy logic searching.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<CategoryAttribute("Behavior")>
Public Property AllowWildCardSearch As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

instance.AllowWildCardSearch = value

value = instance.AllowWildCardSearch
C#
[DescriptionAttribute("Specifies whether or not to allow wild card searching / fuzzy logic searching.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Behavior")]
public bool AllowWildCardSearch {get; set;}
Delphi
public read-write property AllowWildCardSearch: Boolean;
JScript
DescriptionAttribute("Specifies whether or not to allow wild card searching / fuzzy logic searching.")
ISNet.Serialization.XmlSerializableAttribute()
DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
CategoryAttribute("Behavior")
public function get,set AllowWildCardSearch : boolean
Managed Extensions for C++
[DescriptionAttribute("Specifies whether or not to allow wild card searching / fuzzy logic searching.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Behavior")]
public: __property bool get_AllowWildCardSearch();
public: __property void set_AllowWildCardSearch(
   bool value
);
C++/CLI
[DescriptionAttribute("Specifies whether or not to allow wild card searching / fuzzy logic searching.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Behavior")]
public:
property bool AllowWildCardSearch {
   bool get();
   void set (    bool value);
}

Remarks

By setting this property to True, users will be able to perform fuzzy logic searching without has to add * in the front of input text.

By default, this feature will allow WebCombo to search its data list from the first character based on the user's input. For example : if user inputs "a" in the search field, WebCombo will search for data that begins with the character "a". For more information, please read Allow Wildcard Search.

By setting this property to True, users will be able to perform fuzzy logic searching without has to add * in the front of input text.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

How-to: Enable wildcard search

Concepts

Allow Wildcard Search


BackColor Property

[image]
Intersoft WebCombo Documentation
BackColor Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : BackColor Property

Returns or sets the background color of the control. Returns or sets the background color of the control.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<CategoryAttribute("Appearance")>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Color of the background of the control.")>
Public Overrides Property BackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Color

instance.BackColor = value

value = instance.BackColor
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[CategoryAttribute("Appearance")]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Color of the background of the control.")]
public override Color BackColor {get; set;}
Delphi
public read-write property BackColor: Color; override;
JScript
DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
PersistenceModeAttribute(PersistenceMode.InnerProperty)
CategoryAttribute("Appearance")
NotifyParentPropertyAttribute()
DescriptionAttribute("Color of the background of the control.")
public override function get,set BackColor : Color
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[CategoryAttribute("Appearance")]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Color of the background of the control.")]
public: __property Color get_BackColor() override;
public: __property void set_BackColor(
   Color value
) override;
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[CategoryAttribute("Appearance")]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Color of the background of the control.")]
public:
property Color BackColor {
   Color get() override;
   void set (    Color value) override;
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


BindingOperationMode Property

[image]
Intersoft WebCombo Documentation
BindingOperationMode Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : BindingOperationMode Property

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Gets or sets the control operation mode for data binding.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<CategoryAttribute("Data")>
<DefaultValueAttribute()>
Public Property BindingOperationMode As ISNet.WebUI.BindingMode
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As ISNet.WebUI.BindingMode

instance.BindingOperationMode = value

value = instance.BindingOperationMode
C#
[DescriptionAttribute("Gets or sets the control operation mode for data binding.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Data")]
[DefaultValueAttribute()]
public ISNet.WebUI.BindingMode BindingOperationMode {get; set;}
Delphi
public read-write property BindingOperationMode: ISNet.WebUI.BindingMode;
JScript
DescriptionAttribute("Gets or sets the control operation mode for data binding.")
ISNet.Serialization.XmlSerializableAttribute()
NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
CategoryAttribute("Data")
DefaultValueAttribute()
public function get,set BindingOperationMode : ISNet.WebUI.BindingMode
Managed Extensions for C++
[DescriptionAttribute("Gets or sets the control operation mode for data binding.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Data")]
[DefaultValueAttribute()]
public: __property ISNet.WebUI.BindingMode get_BindingOperationMode();
public: __property void set_BindingOperationMode(
   ISNet.WebUI.BindingMode value
);
C++/CLI
[DescriptionAttribute("Gets or sets the control operation mode for data binding.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Data")]
[DefaultValueAttribute()]
public:
property ISNet.WebUI.BindingMode BindingOperationMode {
   ISNet.WebUI.BindingMode get();
   void set (    ISNet.WebUI.BindingMode value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


BorderColor Property

[image]
Intersoft WebCombo Documentation
BorderColor Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : BorderColor Property

Returns or sets the border color of the control. Returns or sets the border color of the control.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Color of the border of the control.")>
<CategoryAttribute("Appearance")>
Public Overrides Property BorderColor As Color
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Color

instance.BorderColor = value

value = instance.BorderColor
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Color of the border of the control.")]
[CategoryAttribute("Appearance")]
public override Color BorderColor {get; set;}
Delphi
public read-write property BorderColor: Color; override;
JScript
DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
NotifyParentPropertyAttribute()
DescriptionAttribute("Color of the border of the control.")
CategoryAttribute("Appearance")
public override function get,set BorderColor : Color
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Color of the border of the control.")]
[CategoryAttribute("Appearance")]
public: __property Color get_BorderColor() override;
public: __property void set_BorderColor(
   Color value
) override;
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Color of the border of the control.")]
[CategoryAttribute("Appearance")]
public:
property Color BorderColor {
   Color get() override;
   void set (    Color value) override;
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


BorderStyle Property

[image]
Intersoft WebCombo Documentation
BorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : BorderStyle Property

Returns or sets the border style of the control. returns or sets the border style of the control.

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<CategoryAttribute("Appearance")>
<DescriptionAttribute("Style of the border of the control.")>
Public Overrides Property BorderStyle As BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
[NotifyParentPropertyAttribute(true)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[CategoryAttribute("Appearance")]
[DescriptionAttribute("Style of the border of the control.")]
public override BorderStyle BorderStyle {get; set;}
Delphi
public read-write property BorderStyle: BorderStyle; override;
JScript
NotifyParentPropertyAttribute()
DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
CategoryAttribute("Appearance")
DescriptionAttribute("Style of the border of the control.")
public override function get,set BorderStyle : BorderStyle
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[CategoryAttribute("Appearance")]
[DescriptionAttribute("Style of the border of the control.")]
public: __property BorderStyle get_BorderStyle() override;
public: __property void set_BorderStyle(
   BorderStyle value
) override;
C++/CLI
[NotifyParentPropertyAttribute(true)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[CategoryAttribute("Appearance")]
[DescriptionAttribute("Style of the border of the control.")]
public:
property BorderStyle BorderStyle {
   BorderStyle get() override;
   void set (    BorderStyle value) override;
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


BorderWidth Property

[image]
Intersoft WebCombo Documentation
BorderWidth Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : BorderWidth Property

Returns or sets the border width of the control. Returns or sets the border width of the control.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<CategoryAttribute("Appearance")>
<DescriptionAttribute("Width of the border.")>
<NotifyParentPropertyAttribute(True)>
Public Overrides Property BorderWidth As Unit
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Unit

instance.BorderWidth = value

value = instance.BorderWidth
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[CategoryAttribute("Appearance")]
[DescriptionAttribute("Width of the border.")]
[NotifyParentPropertyAttribute(true)]
public override Unit BorderWidth {get; set;}
Delphi
public read-write property BorderWidth: Unit; override;
JScript
DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
CategoryAttribute("Appearance")
DescriptionAttribute("Width of the border.")
NotifyParentPropertyAttribute()
public override function get,set BorderWidth : Unit
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[CategoryAttribute("Appearance")]
[DescriptionAttribute("Width of the border.")]
[NotifyParentPropertyAttribute(true)]
public: __property Unit get_BorderWidth() override;
public: __property void set_BorderWidth(
   Unit value
) override;
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[CategoryAttribute("Appearance")]
[DescriptionAttribute("Width of the border.")]
[NotifyParentPropertyAttribute(true)]
public:
property Unit BorderWidth {
   Unit get() override;
   void set (    Unit value) override;
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


CacheServerConnection Property

[image]
Intersoft WebCombo Documentation
CacheServerConnection Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : CacheServerConnection Property

Specifies the file server connection string to store data cache. Specifies the file server connection string to store data cache.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies the file server connection string to store data cache.")>
<CategoryAttribute("Data")>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property CacheServerConnection As String
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As String

instance.CacheServerConnection = value

value = instance.CacheServerConnection
C#
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the file server connection string to store data cache.")]
[CategoryAttribute("Data")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public string CacheServerConnection {get; set;}
Delphi
public read-write property CacheServerConnection: String;
JScript
DefaultValueAttribute()
DescriptionAttribute("Specifies the file server connection string to store data cache.")
CategoryAttribute("Data")
NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set CacheServerConnection : String
Managed Extensions for C++
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the file server connection string to store data cache.")]
[CategoryAttribute("Data")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property string* get_CacheServerConnection();
public: __property void set_CacheServerConnection(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the file server connection string to store data cache.")]
[CategoryAttribute("Data")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property String^ CacheServerConnection {
   String^ get();
   void set (    String^ value);
}

Remarks

WebCombo.NET v4.0 allows you to store data cache to a physical disc in the local computer or a shared drive in network. If you choose "FileServer" on DataCacheStorage, the data cache will be stored to the path defined in CacheServerConnection property. This new option allows better scalability and reliability to your web application, as the data caches are no longer stored in ASP.NET's worker process or Session.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Concepts

Improved Data Caching


ClientBindingSettings Property

[image]
Intersoft WebCombo Documentation
ClientBindingSettings Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : ClientBindingSettings Property

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<CategoryAttribute("Data")>
<ISNet.Serialization.XmlSerializableAttribute(Type=XmlSerializationType.ClientAndLayout, DiscardEmptyObject=True)>
<ISNet.Serialization.BinarySerializableAttribute("setClientBindingSettings")>
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<DescriptionAttribute("Provides settings for client data binding.")>
Public ReadOnly Property ClientBindingSettings As ISNet.WebUI.ClientBindingSettings
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As ISNet.WebUI.ClientBindingSettings

value = instance.ClientBindingSettings
C#
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[CategoryAttribute("Data")]
[ISNet.Serialization.XmlSerializableAttribute(Type=XmlSerializationType.ClientAndLayout, DiscardEmptyObject=true)]
[ISNet.Serialization.BinarySerializableAttribute("setClientBindingSettings")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DescriptionAttribute("Provides settings for client data binding.")]
public ISNet.WebUI.ClientBindingSettings ClientBindingSettings {get;}
Delphi
public read-only property ClientBindingSettings: ISNet.WebUI.ClientBindingSettings;
JScript
TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
CategoryAttribute("Data")
ISNet.Serialization.XmlSerializableAttribute(Type=XmlSerializationType.ClientAndLayout, DiscardEmptyObject=)
ISNet.Serialization.BinarySerializableAttribute("setClientBindingSettings")
DefaultValueAttribute()
NotifyParentPropertyAttribute()
PersistenceModeAttribute(PersistenceMode.InnerProperty)
DescriptionAttribute("Provides settings for client data binding.")
public function get ClientBindingSettings : ISNet.WebUI.ClientBindingSettings
Managed Extensions for C++
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[CategoryAttribute("Data")]
[ISNet.Serialization.XmlSerializableAttribute(Type=XmlSerializationType.ClientAndLayout, DiscardEmptyObject=true)]
[ISNet.Serialization.BinarySerializableAttribute("setClientBindingSettings")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DescriptionAttribute("Provides settings for client data binding.")]
public: __property ISNet.WebUI.ClientBindingSettings* get_ClientBindingSettings();
C++/CLI
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[CategoryAttribute("Data")]
[ISNet.Serialization.XmlSerializableAttribute(Type=XmlSerializationType.ClientAndLayout, DiscardEmptyObject=true)]
[ISNet.Serialization.BinarySerializableAttribute("setClientBindingSettings")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DescriptionAttribute("Provides settings for client data binding.")]
public:
property ISNet.WebUI.ClientBindingSettings^ ClientBindingSettings {
   ISNet.WebUI.ClientBindingSettings^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


ControlDataTransferFormat Property

[image]
Intersoft WebCombo Documentation
ControlDataTransferFormat Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : ControlDataTransferFormat Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Overridable Property ControlDataTransferFormat As ISNet.WebUI.DataTransferFormat
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As ISNet.WebUI.DataTransferFormat

instance.ControlDataTransferFormat = value

value = instance.ControlDataTransferFormat
C#
[CategoryAttribute("Behavior")]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public virtual ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {get; set;}
Delphi
public read-write property ControlDataTransferFormat: ISNet.WebUI.DataTransferFormat; virtual;
JScript
CategoryAttribute("Behavior")
NotifyParentPropertyAttribute()
DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ControlDataTransferFormat : ISNet.WebUI.DataTransferFormat
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property virtual ISNet.WebUI.DataTransferFormat get_ControlDataTransferFormat();
public: __property virtual void set_ControlDataTransferFormat(
   ISNet.WebUI.DataTransferFormat value
);
C++/CLI
[CategoryAttribute("Behavior")]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
virtual property ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {
   ISNet.WebUI.DataTransferFormat get();
   void set (    ISNet.WebUI.DataTransferFormat value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


DataCacheStorage Property

[image]
Intersoft WebCombo Documentation
DataCacheStorage Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : DataCacheStorage Property

Specifies where to store the data cache. Specifies where to store the data cache.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<CategoryAttribute("Data")>
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies where to store the data cache.")>
Public Property DataCacheStorage As ISNet.WebUI.CacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As ISNet.WebUI.CacheStorage

instance.DataCacheStorage = value

value = instance.DataCacheStorage
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Data")]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies where to store the data cache.")]
public ISNet.WebUI.CacheStorage DataCacheStorage {get; set;}
Delphi
public read-write property DataCacheStorage: ISNet.WebUI.CacheStorage;
JScript
ISNet.Serialization.BinarySerializableAttribute()
CategoryAttribute("Data")
DefaultValueAttribute()
DescriptionAttribute("Specifies where to store the data cache.")
public function get,set DataCacheStorage : ISNet.WebUI.CacheStorage
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Data")]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies where to store the data cache.")]
public: __property ISNet.WebUI.CacheStorage get_DataCacheStorage();
public: __property void set_DataCacheStorage(
   ISNet.WebUI.CacheStorage value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Data")]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies where to store the data cache.")]
public:
property ISNet.WebUI.CacheStorage DataCacheStorage {
   ISNet.WebUI.CacheStorage get();
   void set (    ISNet.WebUI.CacheStorage value);
}

Remarks

In previous version of WebCombo.NET, there were only 2 option on where to store datacache. They are PageCache and Session.

The data caching feature in version 4.0 has been significantly improved to avoid memory leaks and lower usage of allocated resources when DataCacheStorage is set to PageCache.

WebCombo.NET v4.0 allows you to store data cache to a physical disc in the local computer or a shared drive in network. If you choose "FileServer" on DataCacheStorage, the data cache will be stored to the path defined in CacheServerConnection property. This new option allows better scalability and reliability to your web application, as the data caches are no longer stored in ASP.NET's worker process or Session.

Some of benefits using FileServer cache are:

  • Highly scalable. You can choose a network drive to store the caches which enable multiple web servers to access the state.
  • Decent performance. With more than dozen of high performance hard drives, you can choose a near-memory speed with high random access and sequential read write hard drive to store the caches.
  • Easily extensible. Unlike memory (RAM), you can easily extend hard drives with larger one when it becomes insufficient.

Features of FileServer:

  • Automatic cleaning. When the cache for the viewstate has expired, the caches will be automatically deleted.
  • Easily configurable for application-wide through web.config.
  • Allow customizations on cache policy and expiration duration.
The default value is PageCache. The PageCache data storage implementation is the one implemented in previous version of WebCombo component. This property is only taken affect when AllowAutoDataCaching property is set to True (by default).

The new Session data storage mode enables better datasource persistent mechanism when information is more scoped per user's session. With this mode, datasource's cache will be valid as long as the session hasn't expired.

The default PageCache storage mode is sufficient and effective for most development scenarios. Following describes the behavior of both modes:

PageCache

  • Stored in ASP.NET's built-in Cache object.
  • Expiring in a time period, default is 15 minutes.
  • Use SetCacheControl() method to control cache's time and priority.
  • Requires implementation of InitializeDataSource event to taken affect effectively.
  • Best used for scenarios when all level of data can be retrieved once together.

Session

  • Stored in Session object.
  • Expiring when session is timed out or Session.Abandon() method is called. To longer the cache time, simply increase the Session's timeout value.
  • Doesn't require implementation of InitializeDataSource event. Work perfectly with common databinding method using DataBind() in Page_Load event. However, databinding implementation using InitializeDataSource event is more recommended for centralized and standarization in control's binding mechanism.
  • Best used for scenarios when data is scoped based per user/session and when on demand data retrieval implementation is required for WebCombo.
  • Better performance, the control will only hit the database for first page load and use the cached data for entire session - unlike PageCache which will need to renew the data in a time period.
  • Better scalability, you can implement SqlServer mode for storing the Session's data for larger applications that work in WebFarm or clustering.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Concepts

Automatic Data Caching Handler
Improved Data Caching
Cache

Tasks

How-to: Disable auto data caching

Other Resources

Improved Data Caching


DataMember Property

[image]
Intersoft WebCombo Documentation
DataMember Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : DataMember Property

Specifies the data member in multimember data source to bind to the WebCombo control. Specifies the data member in multimember data source to bind to the WebCombo control.

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Windows.Forms.Design.DataMemberListEditor, System.Windows.Forms.Design.DLL")>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies the data member in multimember data source to bind to the WebCombo control.")>
<CategoryAttribute("Data")>
Public Property DataMember As String
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As String

instance.DataMember = value

value = instance.DataMember
C#
[NotifyParentPropertyAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Windows.Forms.Design.DataMemberListEditor, System.Windows.Forms.Design.DLL")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the data member in multimember data source to bind to the WebCombo control.")]
[CategoryAttribute("Data")]
public string DataMember {get; set;}
Delphi
public read-write property DataMember: String;
JScript
NotifyParentPropertyAttribute()
EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Windows.Forms.Design.DataMemberListEditor, System.Windows.Forms.Design.DLL")
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
DescriptionAttribute("Specifies the data member in multimember data source to bind to the WebCombo control.")
CategoryAttribute("Data")
public function get,set DataMember : String
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Windows.Forms.Design.DataMemberListEditor, System.Windows.Forms.Design.DLL")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the data member in multimember data source to bind to the WebCombo control.")]
[CategoryAttribute("Data")]
public: __property string* get_DataMember();
public: __property void set_DataMember(
   string* value
);
C++/CLI
[NotifyParentPropertyAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Windows.Forms.Design.DataMemberListEditor, System.Windows.Forms.Design.DLL")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the data member in multimember data source to bind to the WebCombo control.")]
[CategoryAttribute("Data")]
public:
property String^ DataMember {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


DataSource Property

[image]
Intersoft WebCombo Documentation
DataSource Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : DataSource Property

Specifies the datasource object which the control bind to. Specifies the datasource object which the control bind to.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
<CategoryAttribute("Data")>
<DescriptionAttribute("Specifies the datasource object which the control bind to.")>
<BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property DataSource As Object
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Object

instance.DataSource = value

value = instance.DataSource
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
[CategoryAttribute("Data")]
[DescriptionAttribute("Specifies the datasource object which the control bind to.")]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual object DataSource {get; set;}
Delphi
public read-write property DataSource: TObject; virtual;
JScript
DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
DefaultValueAttribute()
CategoryAttribute("Data")
DescriptionAttribute("Specifies the datasource object which the control bind to.")
BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set DataSource : Object
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
[CategoryAttribute("Data")]
[DescriptionAttribute("Specifies the datasource object which the control bind to.")]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual Object* get_DataSource();
public: __property virtual void set_DataSource(
   Object* value
);
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
[CategoryAttribute("Data")]
[DescriptionAttribute("Specifies the datasource object which the control bind to.")]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property Object^ DataSource {
   Object^ get();
   void set (    Object^ value);
}

Remarks

One of WebCombo.NET key features is its ability to use the common DataSource and DataBind method for data binding purpose.

WebCombo.NET has been specially designed to bring a new web experience when selecting from a large dropdown rows and also meet the .NET infrastructure requirement needed by developers.

DataSource property can be assigned from anywhere in the code. It supports all ADO.Net objects, means that you have all the flexibility to use custom classes that returns a DataSet object, stored procedures, Oracle source and so on.

By assigning a DataSource, you are all set and the WebCombo control is ready to use. WebCombo control is built with automatic query handler. That means you do not have to create another stored procedure to match with the control's infrastructure. Instead, WebCombo's automatic query handler will do all required lookups and filtering process.

WebCombo.NET v3.0 supports even more data source types including SqlDataReader, OleDbDataReader, Xml data source and any objects that implement IEnumerable such as Collections or ArrayList. The feature works perfectly in conjunction with AutoQueryHandler, this allow developers to use non-DataSet objects as datasource while having query automatically handled by WebCombo.

WebCombo.NET v4.0 allows you to perform codeless data binding through DataSourceControl support. You can configure the datasource, its connection and its related property without writing codes.
Declaratively, you can create a WebCombo instance and bind it to a table in your Sql database in two simple statements as in the following:

<ISWebCombo:WebCombo ID="WebCombo1" runat="server"
UseDefaultStyle="True" Width="200px" Height="20px"
DataSourceID="SqlDataSource1" DataTextField="ActivityName"
DataValueField="ActivitiesId">
</ISWebCombo:WebCombo>

<asp:SqlDataSource ID="SqlDataSource1" runat="server"
ConnectionString="<%$ ConnectionStrings:DbConnectionString %>"
SelectCommand="SELECT * FROM [Activities]">
</asp:SqlDataSource>

From the statements above we can see the WebCombo1 is bound to a datasource control through DataSourceID property. The WebCombo connects to the specified datasource control and display data from the datasource available in SqlDataSource1.

WebCombo.NET v4.0 still support older databinding mechanism through InitializeDataSource or DataSource property set in code behind.

The benefits of the new datasource control binding support:

  • Improved developers' productivity through codeless, simple and hassle-free databinding.
  • Cleaner separation between User Interface and Data Access/Business Layer codes. All data layer codes and logics are now handled at datasource control level instead of component level. That means UI component such as WebCombo is now purely serving as data selector and combobox function, and no longer handling datasource.
  • Better architecture. For more than decades, developers have struggled to find the best pattern in developing databound application. Datasource control binding concept is one of the most appealing and acceptable mechanism recognizing its cleaner separation between user interface and data access layer.
  • Highly reusable. Datasource control offers better reusability since it has rock solid architecture. For instance, developer can write business layer codes in application level which is used throughout the application and use ObjectDataSource to connect to the business layer function.
  • Extensible. Datasource control such as ObjectDataSource and ISDataSource (Intersoft’s proprietary multi-views datasource control) has ability to connect to custom business layer codes. You can also connect the controls to DataSet and TableAdapter that generated using Visual Designer in Visual Studio 2005, as well as connect it to extended function that you write in an extended class through new “partial class” mechanism.

Some important things that developers need to pay attention regarding the new datasource control concept:

  • InitializeDataSource event is no longer fired when the WebCombo is bound to DataSourceID. This event will still be fired normally when the DataSourceID property is empty (old databinding mode).
  • You can not bind to datasource control and datasource object at the same time. For instance, if you set DataSourceID to SqlDataSource1 and at the same time set WebCombo1.DataSource = dsNorthWind.Customers in the code, this will throw an invalid operation exception.
  • Flat-view datasource controls that come with ASP.NET 2.0 are all supported. This includes SqlDataSource, AccessDataSource and ObjectDataSource.
  • All internal operations and existing functions in WebCombo.NET are still working properly with the new datasource control binding. This ensures full compatibility in behaviors and functions with the previous versions.
  • Data caching. In pre-2007 platform, Intersoft’s databound control such as WebCombo.NET and WebGrid.NET Enterprise employs built-in automatic data caching mechanism. In 2007 product lines, the built-in data caching is no longer functioning when the control is bound to datasource control. If you want to configure caching, please refer to the capability of the datasource control that you used to bound to the control. For instance, if you bind a WebCombo control to SqlDataSource, then you can enable the caching by setting EnableCaching of the SqlDataSource control to True.

To learn more about how to bind WebCombo to AccessDataSourceControl and ObjectDataSourceControl, please read Walkthrough: Binding WebCombo to AccessDataSource control and Walkthrough: Binding WebCombo to ObjectDataSource control .

Advanced Load-on-Demand data retrieval through ISDataSourceControl support

ISDataSource control is Intersoft's proprietary data source control that extends ObjectDataSource functionalities with hierarchical business object binding and automatic load on demand integration.

In previous versions of WebCombo.NET, data retrieval is handled at component level. The load-on-demand mechanism is also handled at component level, for instance, at WebCombo level. This is required because both user interface and data handling are mixed. With the new datasource control support in version 4.0, WebCombo can connect to ISDataSource control as well since ISDataSource implements the datasource control standards and interfaces.

The load-on-demand data retrieval in WebCombo.NET version 4.0 can be used when bound to datasource control. However, the currently supported datasource control for this operation is ISDataSource control only.

When bound to ISDataSource and AllowAutoQueryHandler of WebCombo is set to False, the WebCombo will connect to special method available in the specified Select method property of ISDataSource control. For instance, if the Select method property is set to GetData, then you required to create one method with name GetData with 3 parameters, and one get count method with 1 parameter. The detailed signature is as following:

public DataTable GetData(int maximumRows, int startRowIndex, string queryText) public int SelectCount(string queryText)

The supplied methods allow the datasource control to reuse it in other pages, and thus providing higher level of usability. This concept also enables user interface components to interact with datasource in consistent fashion through datasource control.

To learn more about how to use load-on-demand feature using ISDataSourceControl, please read Walkthrough: Using load-on-demand data retrieval with ISDataSource control in WebCombo .

Walkthrough: Binding WebCombo to ISDataSource control.

Walkthrough: Binding multiple WebCombo instances to ISDataSource control.

One of WebCombo.NET key features is its ability to use the common DataSource and WebCombo.DataBind method for data binding purpose.

WebCombo.NET has been specially designed to bring a new web experience when selecting from a large dropdown rows and also meet the .NET infrastructure requirement needed by developers.

DataSource property can be assigned from anywhere in the code. It supports all ADO.Net objects, means that you have all the flexibility to use custom classes that returns a DataSet object, stored procedures, Oracle source and so on.

By assigning a DataSource, you are all set and the WebCombo control is ready to use. WebCombo control is built with automatic query handler. That means you don't have to create another stored procedure to match with the control's infrastructure. Instead, WebCombo's automatic query handler will do all required lookups and filtering process.

This version of WebCombo supports even more data source types including SqlDataReader, OleDbDataReader, Xml data source and any objects that implement IEnumerable such as Collections or ArrayList. The feature works perfectly in conjuction with AutoQueryHandler, this allow developers to use non-DataSet objects as datasource while having query automatically handled by WebCombo.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

Walkthrough: Binding WebCombo to SqlDataSource control
Walkthrough: Binding WebCombo to XMLDataSource control
Walkthrough: Binding WebCombo to IList DataSource control
Walkthrough: Binding WebCombo to AccessDataSource control
Walkthrough: Binding WebCombo to ObjectDataSource control
Walkthrough: Using load-on-demand data retrieval with ISDataSource control in WebCombo
Walkthrough: Binding WebCombo to ISDataSource control
Walkthrough: Binding multiple WebCombo instances to ISDataSource control
How-to: Apply load on demand in WebCombo

Concepts

No-codes data binding through DataSourceControl support


DataSourceID Property

[image]
Intersoft WebCombo Documentation
DataSourceID Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : DataSourceID Property

Gets or sets the ID of the control from which the WebCombo control retrieves its list of data items.Gets or sets the ID of the control from which the WebCombo control retrieves its list of data items.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
<CategoryAttribute("Data")>
<IDReferencePropertyAttribute(System.Web.UI.DataSourceControl)>
<DescriptionAttribute("Gets or sets the ID of the control from which the WebCombo control retrieves its list of data items.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property DataSourceID As String
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As String

instance.DataSourceID = value

value = instance.DataSourceID
C#
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Data")]
[IDReferencePropertyAttribute(System.Web.UI.DataSourceControl)]
[DescriptionAttribute("Gets or sets the ID of the control from which the WebCombo control retrieves its list of data items.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public string DataSourceID {get; set;}
Delphi
public read-write property DataSourceID: String;
JScript
DefaultValueAttribute()
NotifyParentPropertyAttribute()
CategoryAttribute("Data")
IDReferencePropertyAttribute(System.Web.UI.DataSourceControl)
DescriptionAttribute("Gets or sets the ID of the control from which the WebCombo control retrieves its list of data items.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set DataSourceID : String
Managed Extensions for C++
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Data")]
[IDReferencePropertyAttribute(System.Web.UI.DataSourceControl)]
[DescriptionAttribute("Gets or sets the ID of the control from which the WebCombo control retrieves its list of data items.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property string* get_DataSourceID();
public: __property void set_DataSourceID(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Data")]
[IDReferencePropertyAttribute(System.Web.UI.DataSourceControl)]
[DescriptionAttribute("Gets or sets the ID of the control from which the WebCombo control retrieves its list of data items.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property String^ DataSourceID {
   String^ get();
   void set (    String^ value);
}

Example

Remarks

WebCombo.NET 4.0 allows you to perform codeless databinding which you can configure the datasource, its connection and its related property without writing codes. The WebCombo will bound to a datasource control through DataSourceID property. The WebCombo connects to the specified datasource control and display data from the datasource available in SqlDataSource (Please look at the statement below).

<ISWebCombo:WebCombo ID="WebCombo1" runat="server"
UseDefaultStyle="True" Width="200px" Height="20px"
DataSourceID="SqlDataSource1" DataTextField="ActivityName"
DataValueField="ActivitiesId">
</ISWebCombo:WebCombo>

<asp:SqlDataSource ID="SqlDataSource1" runat="server"
ConnectionString="<%$ ConnectionStrings:DbConnectionString %>"
SelectCommand="SELECT * FROM [Activities]">
</asp:SqlDataSource>

Unlike in the previous versions, InitializeDataSource event is no longer fired when the WebCombo is bound to DataSourceID. This event will still be fired normally when the DataSourceID property is empty (old databinding mode).

To learn more about how to bind WebCombo to AccessDataSourceControl, please read Walkthrough: Binding WebCombo to AccessDataSource control.

WebCombo.NET v4.0 still support older databinding mechanism through InitializeDataSource or DataSource property set in code behind.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

Walkthrough: Binding WebCombo to AccessDataSource control

Concepts

No-codes data binding through DataSourceControl support


DataTextField Property

[image]
Intersoft WebCombo Documentation
DataTextField Property
See Also Example Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : DataTextField Property

Returns or sets the data field used to display the text in WebCombo control. Returns or sets the data field used to display the text in WebCombo control.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Data")>
<DescriptionAttribute("Returns or sets the data field used to display the text in WebCombo control.")>
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property DataTextField As String
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As String

instance.DataTextField = value

value = instance.DataTextField
C#
[CategoryAttribute("Data")]
[DescriptionAttribute("Returns or sets the data field used to display the text in WebCombo control.")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public string DataTextField {get; set;}
Delphi
public read-write property DataTextField: String;
JScript
CategoryAttribute("Data")
DescriptionAttribute("Returns or sets the data field used to display the text in WebCombo control.")
DefaultValueAttribute()
NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set DataTextField : String
Managed Extensions for C++
[CategoryAttribute("Data")]
[DescriptionAttribute("Returns or sets the data field used to display the text in WebCombo control.")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property string* get_DataTextField();
public: __property void set_DataTextField(
   string* value
);
C++/CLI
[CategoryAttribute("Data")]
[DescriptionAttribute("Returns or sets the data field used to display the text in WebCombo control.")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property String^ DataTextField {
   String^ get();
   void set (    String^ value);
}

Example

The following example shows you how to bind data source to a WebCombo (using old databinding mode) and configure the DataTextField programmatically.
C# Copy Code
private void WebCombo1_InitializeDataSource(object sender, ISNet.WebUI.WebCombo.DataSourceEventArgs e)
{
    DataSet ds = new DataSet();
    oleDbDataAdapter1.Fill(ds,"Customers");
    e.DataSource =  ds;
    WebCombo1.DataTextField = "ContactName";
    WebCombo1.DataValueField = "CustomerID";
}

Remarks

DataTextField is a required property in WebCombo control. The control will use the field specified in this property to display the text in WebCombo.

DataTextField can be configured in WebCombo Designer. Alternatively, you can configure it programmatically under InitializeDataSource or InitializeLayout (please look at example above).

DataTextField is a required property in WebCombo control. The control will use the field specified in this property to display the text in WebCombo.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

Walkthrough: Binding WebCombo to AccessDataSource control
Walkthrough: Binding WebCombo to ObjectDataSource control
Walkthrough: Binding WebCombo to ISDataSource control
Walkthrough: Binding WebCombo to SqlDataSource control
Walkthrough: Binding WebCombo to XMLDataSource control
How-to: Implement linked WebCombo functionality using column that is not DataTextField or DataValueField as the FilterDataMember

Concepts

No-codes data binding through DataSourceControl support


DataValueField Property

[image]
Intersoft WebCombo Documentation
DataValueField Property
See Also Example Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : DataValueField Property

Returns or sets the field used as the value in WebCombo control. Returns or sets the field used as the value in WebCombo control.

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Returns or sets the field used as the value in WebCombo control.")>
<DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<CategoryAttribute("Data")>
Public Property DataValueField As String
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As String

instance.DataValueField = value

value = instance.DataValueField
C#
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Returns or sets the field used as the value in WebCombo control.")]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[CategoryAttribute("Data")]
public string DataValueField {get; set;}
Delphi
public read-write property DataValueField: String;
JScript
NotifyParentPropertyAttribute()
DescriptionAttribute("Returns or sets the field used as the value in WebCombo control.")
DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
CategoryAttribute("Data")
public function get,set DataValueField : String
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Returns or sets the field used as the value in WebCombo control.")]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[CategoryAttribute("Data")]
public: __property string* get_DataValueField();
public: __property void set_DataValueField(
   string* value
);
C++/CLI
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Returns or sets the field used as the value in WebCombo control.")]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[CategoryAttribute("Data")]
public:
property String^ DataValueField {
   String^ get();
   void set (    String^ value);
}

Example

The following example shows you to bind data source to a WebCombo (using old databinding mode) and configure the DataValueField programmatically.
C# Copy Code
private void WebCombo1_InitializeDataSource(object sender, ISNet.WebUI.WebCombo.DataSourceEventArgs e)
{
    DataSet ds = new DataSet();
    oleDbDataAdapter1.Fill(ds,"Employees");
    e.DataSource =  ds;
    WebCombo1.DataTextField = "LastName";
    WebCombo1.DataValueField = "EmployeeID";
}

Remarks

DataValueField is a required property in WebCombo control. The control will use the field specified in this property as the value in WebCombo.

DataValueField can be configured in WebCombo Designer. Alternatively, you can configure it programmatically under InitializeDataSource or InitializeLayout (please look at example above).

DataValueField is a required property in WebCombo control. The control will use the field specified in this property as the value in WebCombo.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

Walkthrough: Binding WebCombo to AccessDataSource control
Walkthrough: Binding WebCombo to ObjectDataSource control
Walkthrough: Binding WebCombo to ISDataSource control
Walkthrough: Binding WebCombo to SqlDataSource control
Walkthrough: Binding WebCombo to XMLDataSource control
How-to: Implement linked WebCombo functionality using column that is not DataTextField or DataValueField as the FilterDataMember

Concepts

No-codes data binding through DataSourceControl support


DropDownRows Property

[image]
Intersoft WebCombo Documentation
DropDownRows Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : DropDownRows Property

Specifies the number of initial records retrieved by the WebCombo control. Specifies the number of initial records retrieved by the WebCombo control.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies the number of initial records retrieved by the WebCombo control.")>
<CategoryAttribute("Behavior")>
<NotifyParentPropertyAttribute(True)>
Public Property DropDownRows As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Integer

instance.DropDownRows = value

value = instance.DropDownRows
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the number of initial records retrieved by the WebCombo control.")]
[CategoryAttribute("Behavior")]
[NotifyParentPropertyAttribute(true)]
public int DropDownRows {get; set;}
Delphi
public read-write property DropDownRows: Integer;
JScript
DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
DescriptionAttribute("Specifies the number of initial records retrieved by the WebCombo control.")
CategoryAttribute("Behavior")
NotifyParentPropertyAttribute()
public function get,set DropDownRows : int
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the number of initial records retrieved by the WebCombo control.")]
[CategoryAttribute("Behavior")]
[NotifyParentPropertyAttribute(true)]
public: __property int get_DropDownRows();
public: __property void set_DropDownRows(
   int value
);
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the number of initial records retrieved by the WebCombo control.")]
[CategoryAttribute("Behavior")]
[NotifyParentPropertyAttribute(true)]
public:
property int DropDownRows {
   int get();
   void set (    int value);
}

Remarks

This property is used to determine the number of retrieved records when requested by WebCombo control for the first time. The second and further request made by WebCombo is the double of this property. You may specify a larger number for this property if you run the control in Intranet or large bandwidth. The default value is 15.

This property is used to determine the number of retrieved records when firstly requested by WebCombo control. The second and further request made by WebCombo is the double of this property. You may specify a larger number for this property if you run the control in Intranet or large bandwidth. The default value is 15.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

How-to: Determine the number of rows first requested by WebCombo

Concepts

All-new, sleeker User Interface
User Interface Elements


Enabled Property

[image]
Intersoft WebCombo Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : Enabled Property

Gets or sets the enabled state of the control.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<CategoryAttribute("Behavior")>
Public Overridable Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[CategoryAttribute("Behavior")]
public virtual bool Enabled {get; set;}
Delphi
public read-write property Enabled: Boolean; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
CategoryAttribute("Behavior")
public function get,set Enabled : boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[CategoryAttribute("Behavior")]
public: __property virtual bool get_Enabled();
public: __property virtual void set_Enabled(
   bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[CategoryAttribute("Behavior")]
public:
virtual property bool Enabled {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


EnableManagedTheming Property

[image]
Intersoft WebCombo Documentation
EnableManagedTheming Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : EnableManagedTheming Property

Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
<CategoryAttribute("Behavior")>
Public Overridable Property EnableManagedTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

instance.EnableManagedTheming = value

value = instance.EnableManagedTheming
C#
[DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
public virtual bool EnableManagedTheming {get; set;}
Delphi
public read-write property EnableManagedTheming: Boolean; virtual;
JScript
DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
DefaultValueAttribute()
CategoryAttribute("Behavior")
public function get,set EnableManagedTheming : boolean
Managed Extensions for C++
[DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
public: __property virtual bool get_EnableManagedTheming();
public: __property virtual void set_EnableManagedTheming(
   bool value
);
C++/CLI
[DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
public:
virtual property bool EnableManagedTheming {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


EnableTheming Property

[image]
Intersoft WebCombo Documentation
EnableTheming Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : EnableTheming Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
Public Overridable Property EnableTheming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
[BrowsableAttribute(true)]
public virtual bool EnableTheming {get; set;}
Delphi
public read-write property EnableTheming: Boolean; virtual;
JScript
BrowsableAttribute()
public function get,set EnableTheming : boolean
Managed Extensions for C++
[BrowsableAttribute(true)]
public: __property virtual bool get_EnableTheming();
public: __property virtual void set_EnableTheming(
   bool value
);
C++/CLI
[BrowsableAttribute(true)]
public:
virtual property bool EnableTheming {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


EnableViewState Property

[image]
Intersoft WebCombo Documentation
EnableViewState Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : EnableViewState Property

Gets or sets whether the control automatically saves its state for use in round-trip.

Syntax

Visual Basic (Declaration)
<BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property EnableViewState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual bool EnableViewState {get; set;}
Delphi
public read-write property EnableViewState: Boolean; virtual;
JScript
BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set EnableViewState : boolean
Managed Extensions for C++
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual bool get_EnableViewState();
public: __property virtual void set_EnableViewState(
   bool value
);
C++/CLI
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property bool EnableViewState {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

How-to: Disable ViewState in WebCombo

Concepts

All-new, sleeker User Interface
User Interface Elements


EnableWebResources Property

[image]
Intersoft WebCombo Documentation
EnableWebResources Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : EnableWebResources Property

Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory).

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")>
<CategoryAttribute("Web Resources")>
Public Property EnableWebResources As ISNet.WebUI.WebResourceType
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As ISNet.WebUI.WebResourceType

instance.EnableWebResources = value

value = instance.EnableWebResources
C#
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[CategoryAttribute("Web Resources")]
public ISNet.WebUI.WebResourceType EnableWebResources {get; set;}
Delphi
public read-write property EnableWebResources: ISNet.WebUI.WebResourceType;
JScript
NotifyParentPropertyAttribute()
DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")
CategoryAttribute("Web Resources")
public function get,set EnableWebResources : ISNet.WebUI.WebResourceType
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[CategoryAttribute("Web Resources")]
public: __property ISNet.WebUI.WebResourceType get_EnableWebResources();
public: __property void set_EnableWebResources(
   ISNet.WebUI.WebResourceType value
);
C++/CLI
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[CategoryAttribute("Web Resources")]
public:
property ISNet.WebUI.WebResourceType EnableWebResources {
   ISNet.WebUI.WebResourceType get();
   void set (    ISNet.WebUI.WebResourceType value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

How-to: Disable WebResources

Concepts

All-new, sleeker User Interface
User Interface Elements


FlyPostBackSettings Property

[image]
Intersoft WebCombo Documentation
FlyPostBackSettings Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : FlyPostBackSettings Property

Configures the settings used by the control when performing OnTheFly postback. Configures the settings used by the control when performing OnTheFly postback.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<DefaultValueAttribute()>
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<CategoryAttribute("Behavior")>
Public ReadOnly Property FlyPostBackSettings As ISNet.WebUI.FlyPostBackSettings
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As ISNet.WebUI.FlyPostBackSettings

value = instance.FlyPostBackSettings
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DefaultValueAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[CategoryAttribute("Behavior")]
public ISNet.WebUI.FlyPostBackSettings FlyPostBackSettings {get;}
Delphi
public read-only property FlyPostBackSettings: ISNet.WebUI.FlyPostBackSettings;
JScript
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
DefaultValueAttribute()
PersistenceModeAttribute(PersistenceMode.InnerProperty)
DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
CategoryAttribute("Behavior")
public function get FlyPostBackSettings : ISNet.WebUI.FlyPostBackSettings
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DefaultValueAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[CategoryAttribute("Behavior")]
public: __property ISNet.WebUI.FlyPostBackSettings* get_FlyPostBackSettings();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DefaultValueAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[CategoryAttribute("Behavior")]
public:
property ISNet.WebUI.FlyPostBackSettings^ FlyPostBackSettings {
   ISNet.WebUI.FlyPostBackSettings^ get();
}

Remarks

The FlyPostBackSettings below can be configured in design time through IDE or programmatically. These are the properties in FlyPostBackSettings:

  • PostControlState: Gets or sets a value indicating whether this control's state should be posted during OnTheFly postback. Default value is True.
  • PostHiddenFields: Gets or sets whether INPUT hidden fields should be posted to server. Default value is True.
  • PostInputControls: Gets or sets whether input-related controls such as INPUT, SELECT or TEXTAREA should be posted to server. Default value is False.
  • PostViewState: Gets or sets whether VIEWSTATE should be posted to server. Default value is True.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Concepts

OnTheFly PostBack

Tasks

How-to: Set FlyPostBackSettings
How-to: Improve FlyPostBack performance


Font Property

[image]
Intersoft WebCombo Documentation
Font Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : Font Property

Returns or sets the font used in the control. Returns or sets the font used in the control.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Appearance")>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Font used in the control.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overrides ReadOnly Property Font As FontInfo
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As FontInfo

value = instance.Font
C#
[CategoryAttribute("Appearance")]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Font used in the control.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public override FontInfo Font {get;}
Delphi
public read-only property Font: FontInfo; override;
JScript
CategoryAttribute("Appearance")
NotifyParentPropertyAttribute()
DescriptionAttribute("Font used in the control.")
DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public override function get Font : FontInfo
Managed Extensions for C++
[CategoryAttribute("Appearance")]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Font used in the control.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property FontInfo* get_Font() override;
C++/CLI
[CategoryAttribute("Appearance")]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Font used in the control.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property FontInfo^ Font {
   FontInfo^ get() override;
}

Remarks

WebCombo.NET 4.0 uses "Segoe UI" as the standard font in all UI elements. As clear type font, it ensures better readability and smooth display. By default, WebCombo.NET 4.0 will use Tahoma font when “Segoe UI” can’t be found in user’s computer.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Concepts

New User Interface

Other Resources

Vista-style image animation
Fluid round corner through TrueShape™


ForeColor Property

[image]
Intersoft WebCombo Documentation
ForeColor Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : ForeColor Property

Returns or sets a Color object that specifies the foreground color of the control.Returns or sets a Color object that specifies the foreground color of the control.

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<CategoryAttribute("Appearance")>
<DescriptionAttribute("Forecolor of the control.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overrides Property ForeColor As Color
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Color

instance.ForeColor = value

value = instance.ForeColor
C#
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Appearance")]
[DescriptionAttribute("Forecolor of the control.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public override Color ForeColor {get; set;}
Delphi
public read-write property ForeColor: Color; override;
JScript
NotifyParentPropertyAttribute()
CategoryAttribute("Appearance")
DescriptionAttribute("Forecolor of the control.")
DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public override function get,set ForeColor : Color
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Appearance")]
[DescriptionAttribute("Forecolor of the control.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property Color get_ForeColor() override;
public: __property void set_ForeColor(
   Color value
) override;
C++/CLI
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Appearance")]
[DescriptionAttribute("Forecolor of the control.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property Color ForeColor {
   Color get() override;
   void set (    Color value) override;
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


Height Property

[image]
Intersoft WebCombo Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : Height Property

Syntax

Visual Basic (Declaration)
<BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<CategoryAttribute("Layout")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property Height As Unit
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Unit

instance.Height = value

value = instance.Height
C#
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual Unit Height {get; set;}
Delphi
public read-write property Height: Unit; virtual;
JScript
BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
CategoryAttribute("Layout")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Height : Unit
Managed Extensions for C++
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual Unit get_Height();
public: __property virtual void set_Height(
   Unit value
);
C++/CLI
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property Unit Height {
   Unit get();
   void set (    Unit value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


ID Property

[image]
Intersoft WebCombo Documentation
ID Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : ID Property

Syntax

Visual Basic (Declaration)
<MergablePropertyAttribute(False)>
<ParenthesizePropertyNameAttribute(True)>
<FilterableAttribute(False)>
<ThemeableAttribute(False)>
<WebSysDescriptionAttribute("Programmatic name of the control.")>
Public Overridable Property ID As String
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As String

instance.ID = value

value = instance.ID
C#
[MergablePropertyAttribute(false)]
[ParenthesizePropertyNameAttribute(true)]
[FilterableAttribute(false)]
[ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
public virtual string ID {get; set;}
Delphi
public read-write property ID: String; virtual;
JScript
MergablePropertyAttribute()
ParenthesizePropertyNameAttribute()
FilterableAttribute()
ThemeableAttribute()
WebSysDescriptionAttribute("Programmatic name of the control.")
public function get,set ID : String
Managed Extensions for C++
[MergablePropertyAttribute(false)]
[ParenthesizePropertyNameAttribute(true)]
[FilterableAttribute(false)]
[ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
public: __property virtual string* get_ID();
public: __property virtual void set_ID(
   string* value
);
C++/CLI
[MergablePropertyAttribute(false)]
[ParenthesizePropertyNameAttribute(true)]
[FilterableAttribute(false)]
[ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
public:
virtual property String^ ID {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


IntegrationSettings Property

[image]
Intersoft WebCombo Documentation
IntegrationSettings Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : IntegrationSettings Property

Provides settings for integrating other server side controls as the WebCombo's ResultBox.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<CategoryAttribute("Behavior")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<DescriptionAttribute("Provides settings for integrating other server side controls as the WebCombo's ResultBox.")>
Public Property IntegrationSettings As WebComboIntegrationSettings
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As WebComboIntegrationSettings

instance.IntegrationSettings = value

value = instance.IntegrationSettings
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[CategoryAttribute("Behavior")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DescriptionAttribute("Provides settings for integrating other server side controls as the WebCombo's ResultBox.")]
public WebComboIntegrationSettings IntegrationSettings {get; set;}
Delphi
public read-write property IntegrationSettings: WebComboIntegrationSettings;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
DefaultValueAttribute()
NotifyParentPropertyAttribute()
PersistenceModeAttribute(PersistenceMode.InnerProperty)
CategoryAttribute("Behavior")
DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
DescriptionAttribute("Provides settings for integrating other server side controls as the WebCombo's ResultBox.")
public function get,set IntegrationSettings : WebComboIntegrationSettings
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[CategoryAttribute("Behavior")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DescriptionAttribute("Provides settings for integrating other server side controls as the WebCombo's ResultBox.")]
public: __property WebComboIntegrationSettings* get_IntegrationSettings();
public: __property void set_IntegrationSettings(
   WebComboIntegrationSettings* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[CategoryAttribute("Behavior")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DescriptionAttribute("Provides settings for integrating other server side controls as the WebCombo's ResultBox.")]
public:
property WebComboIntegrationSettings^ IntegrationSettings {
   WebComboIntegrationSettings^ get();
   void set (    WebComboIntegrationSettings^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


Latency Property

[image]
Intersoft WebCombo Documentation
Latency Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : Latency Property

Specifies the wait time after last keypress in milliseconds before the control make data request. Specifies the wait time after last keypress in milliseconds before the control make data request.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Specifies the wait time after last keypress in milliseconds before the control make data request.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<CategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
Public Property Latency As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Integer

instance.Latency = value

value = instance.Latency
C#
[DescriptionAttribute("Specifies the wait time after last keypress in milliseconds before the control make data request.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
public int Latency {get; set;}
Delphi
public read-write property Latency: Integer;
JScript
DescriptionAttribute("Specifies the wait time after last keypress in milliseconds before the control make data request.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
CategoryAttribute("Behavior")
DefaultValueAttribute()
NotifyParentPropertyAttribute()
public function get,set Latency : int
Managed Extensions for C++
[DescriptionAttribute("Specifies the wait time after last keypress in milliseconds before the control make data request.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
public: __property int get_Latency();
public: __property void set_Latency(
   int value
);
C++/CLI
[DescriptionAttribute("Specifies the wait time after last keypress in milliseconds before the control make data request.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
public:
property int Latency {
   int get();
   void set (    int value);
}

Remarks

Setting this property to a lower number produces a faster response based on entered query. You should carefully consider the value for this property as it will affect on server's performance and workloads. You may consider a lower number if you're using the control in Intranet or when server workload is minimal. Default value is 500. For more information, you can read How-to: Set the latency.

Setting this property to a lower number results a faster response based on entered query. You should carefully consider the value for this property as it will affect on server's performance and workloads. You may consider a lower number if you're using the control in Intranet or when server workload is minimal. Default value is 500.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

How-to: Set the latency

Concepts

All-new, sleeker User Interface
User Interface Elements


LayoutSettings Property

[image]
Intersoft WebCombo Documentation
LayoutSettings Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : LayoutSettings Property

The central object that contain all the behaviors and styles for the whole WebCombo control. LayoutSettings is the central object that contain all the behaviors and styles for the whole WebCombo control.

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<NotifyParentPropertyAttribute(True)>
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<DescriptionAttribute("LayoutSettings is the central object that contain all the behaviors and styles for the whole WebCombo control.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property LayoutSettings As LayoutSet
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As LayoutSet

instance.LayoutSettings = value

value = instance.LayoutSettings
C#
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[NotifyParentPropertyAttribute(true)]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DescriptionAttribute("LayoutSettings is the central object that contain all the behaviors and styles for the whole WebCombo control.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public LayoutSet LayoutSettings {get; set;}
Delphi
public read-write property LayoutSettings: LayoutSet;
JScript
TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
NotifyParentPropertyAttribute()
PersistenceModeAttribute(PersistenceMode.InnerProperty)
DescriptionAttribute("LayoutSettings is the central object that contain all the behaviors and styles for the whole WebCombo control.")
DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set LayoutSettings : LayoutSet
Managed Extensions for C++
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[NotifyParentPropertyAttribute(true)]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DescriptionAttribute("LayoutSettings is the central object that contain all the behaviors and styles for the whole WebCombo control.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property LayoutSet* get_LayoutSettings();
public: __property void set_LayoutSettings(
   LayoutSet* value
);
C++/CLI
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[NotifyParentPropertyAttribute(true)]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DescriptionAttribute("LayoutSettings is the central object that contain all the behaviors and styles for the whole WebCombo control.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property LayoutSet^ LayoutSettings {
   LayoutSet^ get();
   void set (    LayoutSet^ value);
}

Remarks

All Intersoft's component provides a common, centralized object called LayoutSettings. It contains many features that allow you to fully customize each part of the control's look and feel directly at design-time, such as AllowAddItem, AllowTextWrapping, AlwaysShowColumnHeaders, and so on.

WebCombo.NET 4.0 offers some new features in LayoutSettings. They are RoundCorner, EnableAnimation and AllowFloatingText. The new features on WebCombo.NET v4.0 result in new and sleeker user interface. For more information and illustration on user interface, you can read New and Sleeker User Interface.

All Intersoft's component provides a common, centralized object called LayoutSettings. It contains many features that allow you to fully customize each part of the control's look and feel directly at design-time.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Concepts

New and Sleeker User Interface
Layout comparison between previous version and version 4.0


LinkSettings Property

[image]
Intersoft WebCombo Documentation
LinkSettings Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : LinkSettings Property

Provides settings for linking to another WebCombo. Provides settings for linking to another WebCombo.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<DescriptionAttribute("Provides settings for linking to another WebCombo.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<CategoryAttribute("Behavior")>
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<NotifyParentPropertyAttribute(True)>
Public ReadOnly Property LinkSettings As LinkSettings
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As LinkSettings

value = instance.LinkSettings
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[DescriptionAttribute("Provides settings for linking to another WebCombo.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[CategoryAttribute("Behavior")]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[NotifyParentPropertyAttribute(true)]
public LinkSettings LinkSettings {get;}
Delphi
public read-only property LinkSettings: LinkSettings;
JScript
DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
DescriptionAttribute("Provides settings for linking to another WebCombo.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
CategoryAttribute("Behavior")
PersistenceModeAttribute(PersistenceMode.InnerProperty)
NotifyParentPropertyAttribute()
public function get LinkSettings : LinkSettings
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[DescriptionAttribute("Provides settings for linking to another WebCombo.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[CategoryAttribute("Behavior")]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[NotifyParentPropertyAttribute(true)]
public: __property LinkSettings* get_LinkSettings();
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[DescriptionAttribute("Provides settings for linking to another WebCombo.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[CategoryAttribute("Behavior")]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[NotifyParentPropertyAttribute(true)]
public:
property LinkSettings^ LinkSettings {
   LinkSettings^ get();
}

Remarks

There are six properties in LinkSettings:

  • Enabled: This property is used to set whether the link feature should be enabled for this WebCombo instance.
  • FilterDataMember: This property is used to set the data member within the DataSource that should be used for filtering during automatic lookup.
  • ParentEmptyAction: This property is used to set the action to be performed when the user requests data for this WebCombo instance, but the specified ParentWebCombo(s) are still empty (no value selected).
  • ParentFilterMode: This property is used to set which key field of the parent WebCombo that should be used for filtering this WebCombo data.
  • ParentWebComboID: This property is used to set the parent WebCombo's ID which this instance should be linked to.
  • SkipQueryTextField: This property is used to set a value indicating whether WebCombo should query the text based on the DataTextField.

You can link two WebCombo simply by configuring the LinkSettings. The Linked WebCombo feature supports following scenarios: Single dependency mode, Multiple dependency mode, Combined dependency mode, and Unbound mode. For more information you can read Linked WebCombo.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

How-to: Use single dependencies linked WebCombo
How-to: Use multiple dependencies linked WebCombo
How-to: Use combined dependencies linked WebCombo
How-to: Use unbound linked WebCombo

Concepts

Linked WebCombo


MinCharsToRequest Property

[image]
Intersoft WebCombo Documentation
MinCharsToRequest Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : MinCharsToRequest Property

Returns or sets the minimum length of input character for requesting data retrieval. Returns or sets the minimum length of input character for requesting data retrieval.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Returns or sets the minimum length of input character for requesting data retrieval.")>
<CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
Public Property MinCharsToRequest As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Integer

instance.MinCharsToRequest = value

value = instance.MinCharsToRequest
C#
[DescriptionAttribute("Returns or sets the minimum length of input character for requesting data retrieval.")]
[CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
public int MinCharsToRequest {get; set;}
Delphi
public read-write property MinCharsToRequest: Integer;
JScript
DescriptionAttribute("Returns or sets the minimum length of input character for requesting data retrieval.")
CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
DefaultValueAttribute()
NotifyParentPropertyAttribute()
public function get,set MinCharsToRequest : int
Managed Extensions for C++
[DescriptionAttribute("Returns or sets the minimum length of input character for requesting data retrieval.")]
[CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
public: __property int get_MinCharsToRequest();
public: __property void set_MinCharsToRequest(
   int value
);
C++/CLI
[DescriptionAttribute("Returns or sets the minimum length of input character for requesting data retrieval.")]
[CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
public:
property int MinCharsToRequest {
   int get();
   void set (    int value);
}

Remarks

Use this property when data retrieval is only need to be performed with a minimal length assigned in this property.

For example, setting this property to 5 will tell WebCombo to retrieve data only when user typing in at least 5 character. Otherwise, WebCombo will not display the drop down list automatically. When the drop down arrow is clicked, it will display the drop down list but with no data retrieving. In this context, the status of the WebCombo will remain "Ready".

Use this property when data retrieval is only need to be performed with a minimal length assigned in this property.

For example, setting this property to 5 will tell WebCombo to retrieve data only when user typing in at least 5 characters. Otherwise, WebCombo will not display the drop down list automatically. When the drop down arrow is clicked, it will display the drop down list but with no data retrieving. In this context, the status of the WebCombo will remain "Ready".

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

How-to: Set minimum character typed to request the data

Concepts

Minimum Character Request


MultipleSelectionSettings Property

[image]
Intersoft WebCombo Documentation
MultipleSelectionSettings Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : MultipleSelectionSettings Property

Provides settings for multiple selections feature. Provides settings for multiple selections feature.

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<NotifyParentPropertyAttribute(True)>
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute()>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute()>
<CategoryAttribute("Behavior")>
<DescriptionAttribute("Provides settings for multiple selections feature.")>
Public ReadOnly Property MultipleSelectionSettings As MultipleSelectionSettings
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As MultipleSelectionSettings

value = instance.MultipleSelectionSettings
C#
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[NotifyParentPropertyAttribute(true)]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Provides settings for multiple selections feature.")]
public MultipleSelectionSettings MultipleSelectionSettings {get;}
Delphi
public read-only property MultipleSelectionSettings: MultipleSelectionSettings;
JScript
TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
NotifyParentPropertyAttribute()
PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute()
DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute()
CategoryAttribute("Behavior")
DescriptionAttribute("Provides settings for multiple selections feature.")
public function get MultipleSelectionSettings : MultipleSelectionSettings
Managed Extensions for C++
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[NotifyParentPropertyAttribute(true)]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Provides settings for multiple selections feature.")]
public: __property MultipleSelectionSettings* get_MultipleSelectionSettings();
C++/CLI
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[NotifyParentPropertyAttribute(true)]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Provides settings for multiple selections feature.")]
public:
property MultipleSelectionSettings^ MultipleSelectionSettings {
   MultipleSelectionSettings^ get();
}

Remarks

There are six important properties in MultipleSelectionSettings:

  • AllowBrowseAll
    If you set the value of AllowBrowseAll property of WebCombo to True, users can list all available items inside the WebCombo result box by using 'Ctrl+Space' keystroke combination.
  • AutoSelectFirstMatch
    The first row will be highlighted when AutoSelectFirstMatch property is set to True. WebCombo users can quickly select an item by pressing 'Tab' key, without using 'Down' key first to select an item.
  • Enabled
    This property is used to set whether multiple selections feature should be enabled. When MultipleSelection is Enabled and TextBoxMode is Editable, the DropDownButton will be disabled and is not visible.
  • AutoPositionResultBox If the AutoPositionResultBox is set to True, the ResultBox location will be automatically placed right under the cursor position depending on the value of the AutoPositionResultBox property.
  • AllowNotInListText
    This property is used to set whether WebCombo should accept text which is not appear in the list.
  • SeparatorChar
    This property is used to set the separator character used to separate multiple values in the textbox.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Concepts

Multiple Selection

Tasks

How-to: Use bound multiple selection WebCombo
How-to: Use unbound multiple selection WebCombo
How-to: Set initial value of multiple selection WebCombo from server side

Other Resources

Unbound Mode


Page Property

[image]
Intersoft WebCombo Documentation
Page Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : Page Property

Syntax

Visual Basic (Declaration)
Public Overridable Property Page As Page
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Page

instance.Page = value

value = instance.Page
C#
public virtual Page Page {get; set;}
Delphi
public read-write property Page: Page; virtual;
JScript
public function get,set Page : Page
Managed Extensions for C++
public: __property virtual Page* get_Page();
public: __property virtual void set_Page(
   Page* value
);
C++/CLI
public:
virtual property Page^ Page {
   Page^ get();
   void set (    Page^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


RenderingMode Property

[image]
Intersoft WebCombo Documentation
RenderingMode Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : RenderingMode Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")>
<NotifyParentPropertyAttribute(True)>
Public Overridable Property RenderingMode As ISNet.WebUI.RenderMode
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As ISNet.WebUI.RenderMode

instance.RenderingMode = value

value = instance.RenderingMode
C#
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[NotifyParentPropertyAttribute(true)]
public virtual ISNet.WebUI.RenderMode RenderingMode {get; set;}
Delphi
public read-write property RenderingMode: ISNet.WebUI.RenderMode; virtual;
JScript
DefaultValueAttribute()
CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")
NotifyParentPropertyAttribute()
public function get,set RenderingMode : ISNet.WebUI.RenderMode
Managed Extensions for C++
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[NotifyParentPropertyAttribute(true)]
public: __property virtual ISNet.WebUI.RenderMode get_RenderingMode();
public: __property virtual void set_RenderingMode(
   ISNet.WebUI.RenderMode value
);
C++/CLI
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[NotifyParentPropertyAttribute(true)]
public:
virtual property ISNet.WebUI.RenderMode RenderingMode {
   ISNet.WebUI.RenderMode get();
   void set (    ISNet.WebUI.RenderMode value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


RuntimeLicenseKey Property

[image]
Intersoft WebCombo Documentation
RuntimeLicenseKey Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : RuntimeLicenseKey Property

The runtime license key for xcopy deployment. Registered customers please obtain through Intersoft Developer Network.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")>
<ISNet.PersistLayoutAttribute(False)>
Public Overridable Property RuntimeLicenseKey As String
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As String

instance.RuntimeLicenseKey = value

value = instance.RuntimeLicenseKey
C#
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
[ISNet.PersistLayoutAttribute(false)]
public virtual string RuntimeLicenseKey {get; set;}
Delphi
public read-write property RuntimeLicenseKey: String; virtual;
JScript
DefaultValueAttribute()
NotifyParentPropertyAttribute()
DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")
ISNet.PersistLayoutAttribute()
public function get,set RuntimeLicenseKey : String
Managed Extensions for C++
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
[ISNet.PersistLayoutAttribute(false)]
public: __property virtual string* get_RuntimeLicenseKey();
public: __property virtual void set_RuntimeLicenseKey(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
[ISNet.PersistLayoutAttribute(false)]
public:
virtual property String^ RuntimeLicenseKey {
   String^ get();
   void set (    String^ value);
}

Remarks

RuntimeLicenseKey is required in order to license the components so it works properly in production environment. When the runtime key is used in production environment, the component cannot be used in design time for further development purpose.

Runtime license key is different with design-time license key that you get during purchase.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


ScriptDirectory Property

[image]
Intersoft WebCombo Documentation
ScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : ScriptDirectory Property

Overriden.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Client Script Directory")>
<BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<DefaultValueAttribute()>
Public Overrides Property ScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As String

instance.ScriptDirectory = value

value = instance.ScriptDirectory
C#
[CategoryAttribute("Client Script Directory")]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[DefaultValueAttribute()]
public override string ScriptDirectory {get; set;}
Delphi
public read-write property ScriptDirectory: String; override;
JScript
CategoryAttribute("Client Script Directory")
BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
DefaultValueAttribute()
public override function get,set ScriptDirectory : String
Managed Extensions for C++
[CategoryAttribute("Client Script Directory")]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[DefaultValueAttribute()]
public: __property string* get_ScriptDirectory() override;
public: __property void set_ScriptDirectory(
   string* value
) override;
C++/CLI
[CategoryAttribute("Client Script Directory")]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[DefaultValueAttribute()]
public:
property String^ ScriptDirectory {
   String^ get() override;
   void set (    String^ value) override;
}

Remarks

In previous versions, resources of product such as scripts are stored in ScriptDirectory. For example, WebCombo's resources are stored in /CommonLibrary/WebCombo/V4_0_7200.

Since WebCombo.NET v4.0 uses a new SmartWebResources Framework, the resources in script directory are now embedded into .NET assembly. Unlike ASP.NET’s built-in Web Resources which embeds client resources in main assembly, SmartWebResources stores each product’s client resources in separate assembly. This enables flexible update (maintenance) to the client resources without has to rebuild the main server-side assembly.

With SmartWebResources enabled, you no longer need to aware what you should do to configure the client scripts virtual directory, or where to locate/store it. You simply ensure that the resources assemblies are in the Bin folder of your application. For more information, read How-to: Configure SmartWebResources in a web application.

The "Auto" mode of SmartWebResources will attempt to use SmartWebResources whenever possible. When it detects invalid configuration or usage of product that does not support SmartWebResources, it will automatically fallback to traditional physical client resources approach. For instance, if ScriptDirectory or SharedScriptDirectory has been changed (not default), SmartWebResources detects whether an existing web application was configured to use specific script directory other than the default (for best compatibility).

If ScriptDirectory is customized, but ImagesDirectory is using default value (not customized), the SmartWebResources will fallback to ResourceOnly mode. That means, images and other client resources will still be handled by SmartWebResources. For more information, you can read the SmartWebResources™ modes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

How-to: Set ScriptDirectory and SharedScriptDirectory
How-to: Configure SmartWebResources in a web application
How-to: Set images directory
How-to: Disable WebResources
FAQ: Does SmartWebResources feature automatically enabled in WebCombo.NET 4.0?

Concepts

Hassle-free deployment through SmartWebResources™ technology

Other Resources

SmartWebResources™ modes
Assembly Reference


SerializeTagToClient Property

[image]
Intersoft WebCombo Documentation
SerializeTagToClient Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : SerializeTagToClient Property

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<CategoryAttribute("Data")>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Specifies whether the row's tag should be serialized to client side, when client binding is enabled.")>
Public Property SerializeTagToClient As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

instance.SerializeTagToClient = value

value = instance.SerializeTagToClient
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Data")]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies whether the row's tag should be serialized to client side, when client binding is enabled.")]
public bool SerializeTagToClient {get; set;}
Delphi
public read-write property SerializeTagToClient: Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
CategoryAttribute("Data")
NotifyParentPropertyAttribute()
DescriptionAttribute("Specifies whether the row's tag should be serialized to client side, when client binding is enabled.")
public function get,set SerializeTagToClient : boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Data")]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies whether the row's tag should be serialized to client side, when client binding is enabled.")]
public: __property bool get_SerializeTagToClient();
public: __property void set_SerializeTagToClient(
   bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Data")]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies whether the row's tag should be serialized to client side, when client binding is enabled.")]
public:
property bool SerializeTagToClient {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


SharedScriptDirectory Property

[image]
Intersoft WebCombo Documentation
SharedScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : SharedScriptDirectory Property

Gets or sets the directory where all shared scripts for Intersoft controls are stored.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<CategoryAttribute("Client Script Directory")>
<DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")>
<BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overrides Property SharedScriptDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As String

instance.SharedScriptDirectory = value

value = instance.SharedScriptDirectory
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[CategoryAttribute("Client Script Directory")]
[DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public override string SharedScriptDirectory {get; set;}
Delphi
public read-write property SharedScriptDirectory: String; override;
JScript
ISNet.Serialization.XmlSerializableAttribute()
CategoryAttribute("Client Script Directory")
DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")
BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public override function get,set SharedScriptDirectory : String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[CategoryAttribute("Client Script Directory")]
[DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property string* get_SharedScriptDirectory() override;
public: __property void set_SharedScriptDirectory(
   string* value
) override;
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[CategoryAttribute("Client Script Directory")]
[DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property String^ SharedScriptDirectory {
   String^ get() override;
   void set (    String^ value) override;
}

Remarks

Since WebCombo.NET v4.0 uses a new SmartWebResources Framework, the resources in script directory and shared scrip directory are now embedded into .NET assembly. Unlike ASP.NET’s built-in Web Resources which embeds client resources in main assembly, SmartWebResources stores each product’s client resources in separate assembly. This enables flexible update (maintenance) to the client resources without has to rebuild the main server-side assembly.

With SmartWebResources enabled, you no longer need to aware what you should do to configure the client scripts virtual directory, or where to locate/store it. You simply ensure that the resources assemblies are in the Bin folder of your application. For more information, read How-to: Configure SmartWebResources in a web application.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

How-to: Set ScriptDirectory and SharedScriptDirectory
How-to: Configure SmartWebResources in a new web application
How-to: Disable WebResources
FAQ: Does SmartWebResources feature automatically enabled in WebCombo.NET 4.0?

Concepts

Hassle-free deployment through SmartWebResources™ technology


ShowErrorMessages Property

[image]
Intersoft WebCombo Documentation
ShowErrorMessages Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : ShowErrorMessages Property

Specifies whether to display error messages when DataSources, DataTextField or DataValueField is not specified.Specifies whether error messages always be shown when no datasource, datatextfield or datavaluefield is specified.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<DescriptionAttribute("Specifies whether error messages always be shown when no datasource, datatextfield or datavaluefield is specified.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
Public Property ShowErrorMessages As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

instance.ShowErrorMessages = value

value = instance.ShowErrorMessages
C#
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Specifies whether error messages always be shown when no datasource, datatextfield or datavaluefield is specified.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public bool ShowErrorMessages {get; set;}
Delphi
public read-write property ShowErrorMessages: Boolean;
JScript
CategoryAttribute("Behavior")
DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
DescriptionAttribute("Specifies whether error messages always be shown when no datasource, datatextfield or datavaluefield is specified.")
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
public function get,set ShowErrorMessages : boolean
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Specifies whether error messages always be shown when no datasource, datatextfield or datavaluefield is specified.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public: __property bool get_ShowErrorMessages();
public: __property void set_ShowErrorMessages(
   bool value
);
C++/CLI
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Specifies whether error messages always be shown when no datasource, datatextfield or datavaluefield is specified.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public:
property bool ShowErrorMessages {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

How-to: Show error message when there is missing specification

Concepts

All-new, sleeker User Interface
User Interface Elements


SkinID Property

[image]
Intersoft WebCombo Documentation
SkinID Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : SkinID Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
Public Overridable Property SkinID As String
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As String

instance.SkinID = value

value = instance.SkinID
C#
[BrowsableAttribute(true)]
public virtual string SkinID {get; set;}
Delphi
public read-write property SkinID: String; virtual;
JScript
BrowsableAttribute()
public function get,set SkinID : String
Managed Extensions for C++
[BrowsableAttribute(true)]
public: __property virtual string* get_SkinID();
public: __property virtual void set_SkinID(
   string* value
);
C++/CLI
[BrowsableAttribute(true)]
public:
virtual property String^ SkinID {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


TabIndex Property

[image]
Intersoft WebCombo Documentation
TabIndex Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : TabIndex Property

The tab order of the control.

Syntax

Visual Basic (Declaration)
<BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<CategoryAttribute("Behavior")>
Public Overridable Property TabIndex As Short
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Short

instance.TabIndex = value

value = instance.TabIndex
C#
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Behavior")]
public virtual short TabIndex {get; set;}
Delphi
public read-write property TabIndex: ShortInt; virtual;
JScript
BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
CategoryAttribute("Behavior")
public function get,set TabIndex : short
Managed Extensions for C++
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Behavior")]
public: __property virtual short get_TabIndex();
public: __property virtual void set_TabIndex(
   short value
);
C++/CLI
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Behavior")]
public:
virtual property short TabIndex {
   short get();
   void set (    short value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

How-to: Define tab index

Concepts

All-new, sleeker User Interface
User Interface Elements


TextBoxLength Property

[image]
Intersoft WebCombo Documentation
TextBoxLength Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : TextBoxLength Property

Specifies the size of the textbox control. Specifies the size of the textbox control.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<CategoryAttribute("Behavior")>
<DescriptionAttribute("Specifies the size of the textbox control.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
Public Property TextBoxLength As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Integer

instance.TextBoxLength = value

value = instance.TextBoxLength
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Specifies the size of the textbox control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
public int TextBoxLength {get; set;}
Delphi
public read-write property TextBoxLength: Integer;
JScript
ISNet.Serialization.XmlSerializableAttribute()
CategoryAttribute("Behavior")
DescriptionAttribute("Specifies the size of the textbox control.")
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
NotifyParentPropertyAttribute()
public function get,set TextBoxLength : int
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Specifies the size of the textbox control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
public: __property int get_TextBoxLength();
public: __property void set_TextBoxLength(
   int value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Specifies the size of the textbox control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
public:
property int TextBoxLength {
   int get();
   void set (    int value);
}

Remarks

Use this property to limit the size of allowed input in WebCombo control. Default value is 0 (unlimited). Use this property to limit the size of allowed input in WebCombo control. Default is 0 (unlimited).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

How-to: Define TextBox length

Concepts

All-new, sleeker User Interface
User Interface Elements


ToolTip Property

[image]
Intersoft WebCombo Documentation
ToolTip Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : ToolTip Property

The tooltip displayed when the mouse is over the control.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<CategoryAttribute("Behavior")>
Public Overridable Property ToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As String

instance.ToolTip = value

value = instance.ToolTip
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[CategoryAttribute("Behavior")]
public virtual string ToolTip {get; set;}
Delphi
public read-write property ToolTip: String; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
CategoryAttribute("Behavior")
public function get,set ToolTip : String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[CategoryAttribute("Behavior")]
public: __property virtual string* get_ToolTip();
public: __property virtual void set_ToolTip(
   string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[CategoryAttribute("Behavior")]
public:
virtual property String^ ToolTip {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


UseCachedDataOnFirstLoad Property

[image]
Intersoft WebCombo Documentation
UseCachedDataOnFirstLoad Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : UseCachedDataOnFirstLoad Property

Specifies whether the cached data source will always be used on first page load. Specifies whether the cached data source will always be used on first page load.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<CategoryAttribute("Data")>
<DescriptionAttribute("Specifies whether the cached data source will always be used on first page load.")>
Public Property UseCachedDataOnFirstLoad As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

instance.UseCachedDataOnFirstLoad = value

value = instance.UseCachedDataOnFirstLoad
C#
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Data")]
[DescriptionAttribute("Specifies whether the cached data source will always be used on first page load.")]
public bool UseCachedDataOnFirstLoad {get; set;}
Delphi
public read-write property UseCachedDataOnFirstLoad: Boolean;
JScript
DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
CategoryAttribute("Data")
DescriptionAttribute("Specifies whether the cached data source will always be used on first page load.")
public function get,set UseCachedDataOnFirstLoad : boolean
Managed Extensions for C++
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Data")]
[DescriptionAttribute("Specifies whether the cached data source will always be used on first page load.")]
public: __property bool get_UseCachedDataOnFirstLoad();
public: __property void set_UseCachedDataOnFirstLoad(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Data")]
[DescriptionAttribute("Specifies whether the cached data source will always be used on first page load.")]
public:
property bool UseCachedDataOnFirstLoad {
   bool get();
   void set (    bool value);
}

Remarks

The default value of this property is False, which means WebGrid disable the use cached data on first load. When set to True, InitializeDataSource event will not be fired even on first page load if the DataSource is still in cache. Set this property to True will improve the performance significantly and is highly recommended for page that display static/unconditional data, such as all customers data. For page that displays grid data based on a condition or criteria, it is best to set this property to False.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

How-to: Use cached data on first load

Concepts

All-new, sleeker User Interface
User Interface Elements


UseDefaultStyle Property

[image]
Intersoft WebCombo Documentation
UseDefaultStyle Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : UseDefaultStyle Property

Indicates whether this control should use default WebCombo.NET 4.0 styles and appearance settings. Indicates whether this control should use default WebCombo.NET 4.0 styles and appearance settings. See Help for more information.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Indicates whether this control should use default WebCombo styles and appearance settings. See Help for more information.")>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
<CategoryAttribute("Appearance")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property UseDefaultStyle As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

instance.UseDefaultStyle = value

value = instance.UseDefaultStyle
C#
[DescriptionAttribute("Indicates whether this control should use default WebCombo styles and appearance settings. See Help for more information.")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public bool UseDefaultStyle {get; set;}
Delphi
public read-write property UseDefaultStyle: Boolean;
JScript
DescriptionAttribute("Indicates whether this control should use default WebCombo styles and appearance settings. See Help for more information.")
NotifyParentPropertyAttribute()
DefaultValueAttribute()
CategoryAttribute("Appearance")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set UseDefaultStyle : boolean
Managed Extensions for C++
[DescriptionAttribute("Indicates whether this control should use default WebCombo styles and appearance settings. See Help for more information.")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property bool get_UseDefaultStyle();
public: __property void set_UseDefaultStyle(
   bool value
);
C++/CLI
[DescriptionAttribute("Indicates whether this control should use default WebCombo styles and appearance settings. See Help for more information.")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property bool UseDefaultStyle {
   bool get();
   void set (    bool value);
}

Remarks

We recommend you to enable the default style feature since it offers the following benefits:

  • Clean control definition during development. This significantly improves loading time in the VS 2005 designer because unnecessary style objects do not need to be created. For instance, WebCombo.NET version 4.0 only requires the following simple tag.
    <ISWebCombo:WebCombo ID="WebCombo1" runat="server" UseDefaultStyle="true"> </ISWebCombo:WebCombo>
  • Best performance in server throughput. Using default style will significantly reduce server side processing because there is no need for serializing styles, validating and parsing the styles and finally generate the styles into css-based classes in the page output.
  • Reduced page output size up to 70 percent. Based on a research, more than 60 percent of web developers do not modify the styles of Intersoft’s controls in their web application.

In previous version of WebCombo, all styles are automatically generated to the page output, regardless whether the style is the one that come with the control or custom style that applied by the developer. For example, if you have 10 instances of WebCombo that use default style, the control will generate each style of each instance to the page output. This is normal behavior in previous version since there is no mechanism that tell the control whether the defined style is a default style or custom style.

In version 4.0, with the Default Style feature, WebCombo control no longer produces page-level styles for instances that enable Default Style. This mechanism enables page output reduction up to 70 percent, since styles are no longer produced regardless of the number of instances in a page.

Several important things to note around Default Style feature:

  • When Default Style is enabled, WebCombo will include a link to external stylesheet that contains reusable style definition used by the Default Style. This external resource is fetched by using standard WebResource feature, and is automatically handled by WebCombo. There is no efforts required by developers.
  • When Default Style is enabled, all styles definition in the control instance should be removed. You can’t have styles definition and using default style at the same time.
  • Default Style feature is enabled by default for new instance of WebCombo.NET 4.0. Exisiting instances of WebCombo (i.e., after migrated from previous version) will continue to use their existing styles definition.

There are three ways to enable DefaultStyle of WebCombo:

1. SmartTag Designer.
2. Property Set.
3. WebCombo Component Designer.

For more information, you can read How-to: Enable Default Style for existing instance of WebCombo.

Default Style is a new feature in WebCombo.NET version 4.0. It is different with Predefined Style. Default Style feature marks the instance to use the default style that come with WebCombo.NET 4.0. You are not recommended to customize any of the styles when using Default Style feature. Predefined Styles is a list of styles that included in WebCombo.NET designated to help developer to easily achieve stylish look and feel. Predefined style is a physical file with ISL extension, and applied from Layout Manager. You can also apply predefined style from API at runtime.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

How-to: Enable Default Style for existing instance of WebCombo
FAQ: What does Default Style look like?
FAQ: How can I continue to use "classic WebCombo style" for new instances of WebCombo controls?
FAQ: Can I still apply other predefined style in WebCombo.NET 4.0?
FAQ: What is the difference between Default Style and Predefined Style?

Concepts

Cleaner and reduced page output through built-in Default Style
Define the styles
Quick configuration by using SmartTag Designer
Layout comparison between previous version and version 4.0

Other Resources

Guided design-time data source configuration
Affected predefined styles
Layout Manager


Value Property

[image]
Intersoft WebCombo Documentation
Value Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : Value Property

Returns or sets the value for WebCombo control. Returns or sets the value for WebCombo control.

Syntax

Visual Basic (Declaration)
<XmlTextAttribute(System.String)>
<ISNet.Serialization.XmlSerializableAttribute()>
<BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<DescriptionAttribute("Returns or sets the value for WebCombo control.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
Public Property Value As String
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As String

instance.Value = value

value = instance.Value
C#
[XmlTextAttribute(System.String)]
[ISNet.Serialization.XmlSerializableAttribute()]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[DescriptionAttribute("Returns or sets the value for WebCombo control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
public string Value {get; set;}
Delphi
public read-write property Value: String;
JScript
XmlTextAttribute(System.String)
ISNet.Serialization.XmlSerializableAttribute()
BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
DescriptionAttribute("Returns or sets the value for WebCombo control.")
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
public function get,set Value : String
Managed Extensions for C++
[XmlTextAttribute(System.String)]
[ISNet.Serialization.XmlSerializableAttribute()]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[DescriptionAttribute("Returns or sets the value for WebCombo control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
public: __property string* get_Value();
public: __property void set_Value(
   string* value
);
C++/CLI
[XmlTextAttribute(System.String)]
[ISNet.Serialization.XmlSerializableAttribute()]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[DescriptionAttribute("Returns or sets the value for WebCombo control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
public:
property String^ Value {
   String^ get();
   void set (    String^ value);
}

Remarks

You can set the Value property in code at runtime to set initial value for the WebCombo control. This property is also available at design time.

Value property has behaviors as below:

  • On databinding process, it will automatically check the existence of Value property in the DataSource. If the specified Value is found, the Text property will be automatically populated based on DataTextField property. Otherwise, the Value and Text will be set to empty.
  • The value property will also be automatically populated on every postback based on last active selection. You may also programmatically set a different value on postback event.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


ViewStateItems Property

[image]
Intersoft WebCombo Documentation
ViewStateItems Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : ViewStateItems Property

Gets or sets the items to be stored in view state storage.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets the items to be stored in view state storage.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<CategoryAttribute("View State Settings")>
<NotifyParentPropertyAttribute(True)>
<BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property ViewStateItems As ISNet.WebUI.ViewStateItem
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As ISNet.WebUI.ViewStateItem

instance.ViewStateItems = value

value = instance.ViewStateItems
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[CategoryAttribute("View State Settings")]
[NotifyParentPropertyAttribute(true)]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual ISNet.WebUI.ViewStateItem ViewStateItems {get; set;}
Delphi
public read-write property ViewStateItems: ISNet.WebUI.ViewStateItem; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
DescriptionAttribute("Gets or sets the items to be stored in view state storage.")
ISNet.Serialization.XmlSerializableAttribute()
CategoryAttribute("View State Settings")
NotifyParentPropertyAttribute()
BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set ViewStateItems : ISNet.WebUI.ViewStateItem
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[CategoryAttribute("View State Settings")]
[NotifyParentPropertyAttribute(true)]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual ISNet.WebUI.ViewStateItem get_ViewStateItems();
public: __property virtual void set_ViewStateItems(
   ISNet.WebUI.ViewStateItem value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[CategoryAttribute("View State Settings")]
[NotifyParentPropertyAttribute(true)]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property ISNet.WebUI.ViewStateItem ViewStateItems {
   ISNet.WebUI.ViewStateItem get();
   void set (    ISNet.WebUI.ViewStateItem value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Concepts

Selective ViewState saving with the new ViewStateItems feature


ViewStateServerConnection Property

[image]
Intersoft WebCombo Documentation
ViewStateServerConnection Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : ViewStateServerConnection Property

Gets or sets the server connection string for file server-based viewstate storage.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("View State Settings")>
<BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")>
Public Overridable Property ViewStateServerConnection As String
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As String

instance.ViewStateServerConnection = value

value = instance.ViewStateServerConnection
C#
[CategoryAttribute("View State Settings")]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
public virtual string ViewStateServerConnection {get; set;}
Delphi
public read-write property ViewStateServerConnection: String; virtual;
JScript
CategoryAttribute("View State Settings")
BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
NotifyParentPropertyAttribute()
DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")
public function get,set ViewStateServerConnection : String
Managed Extensions for C++
[CategoryAttribute("View State Settings")]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
public: __property virtual string* get_ViewStateServerConnection();
public: __property virtual void set_ViewStateServerConnection(
   string* value
);
C++/CLI
[CategoryAttribute("View State Settings")]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
public:
virtual property String^ ViewStateServerConnection {
   String^ get();
   void set (    String^ value);
}

Remarks

The following lists the parameters that can be used in ViewStateServerConnection:

  • path. Specify the path of the file server storage.
  • expireduration. Specify the time in minutes how long should a cache stay in the storage.
  • expirationpolicy. Specify the expiration policy of the cache. The valid values are Sliding, Absolute.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

How-to: Use file server for an instance of control
How-to: Configure file server to use shared network drive

Concepts

Enhanced ViewStateStorage™ with the new optimized architecture


ViewStateStorage Property

[image]
Intersoft WebCombo Documentation
ViewStateStorage Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : ViewStateStorage Property

Gets or sets the location to store the viewstate of this control.

Syntax

Visual Basic (Declaration)
<BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<CategoryAttribute("View State Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")>
Public Overridable Property ViewStateStorage As ISNet.WebUI.StateCacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As ISNet.WebUI.StateCacheStorage

instance.ViewStateStorage = value

value = instance.ViewStateStorage
C#
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
public virtual ISNet.WebUI.StateCacheStorage ViewStateStorage {get; set;}
Delphi
public read-write property ViewStateStorage: ISNet.WebUI.StateCacheStorage; virtual;
JScript
BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
NotifyParentPropertyAttribute()
CategoryAttribute("View State Settings")
ISNet.Serialization.BinarySerializableAttribute()
DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")
public function get,set ViewStateStorage : ISNet.WebUI.StateCacheStorage
Managed Extensions for C++
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
public: __property virtual ISNet.WebUI.StateCacheStorage get_ViewStateStorage();
public: __property virtual void set_ViewStateStorage(
   ISNet.WebUI.StateCacheStorage value
);
C++/CLI
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
public:
virtual property ISNet.WebUI.StateCacheStorage ViewStateStorage {
   ISNet.WebUI.StateCacheStorage get();
   void set (    ISNet.WebUI.StateCacheStorage value);
}

Remarks

In WebCombo.NET v4.0 the default value for ViewStateStorage is now set to Client instead of PageCache. The reasons we decided to use Client as the default value are to reduce the viewstate size of a control and to confirm standard mechanism as in standard.NET controls. ViewStateStorage now includes new option to save the state to physical disk. The option called FileServer enables the view state to be saved to a physical disk in the local computer or a shared drive in network. The FileServer cache option solved many barriers around view state topic. With FileServer, you no longer have to worry about memory leaks or limited server resources. Some of benefits using FileServer cache are:
  • Highly scalable. You can choose a network drive to store the caches which enable multiple web servers to access the state.
  • Decent performance. With more than dozen of high performance hard drives, you can choose a near-memory speed with high random access and sequential read write hard drive to store the caches.
  • Easily extensible. Unlike memory (RAM), you can easily extend hard drives with larger one when it becomes insufficient.

Features of FileServer:

  • Automatic cleaning. When the cache for the viewstate has expired, the caches will be automatically deleted.
  • Easily configurable for application-wide through web.config.
  • Allow customizations on cache policy and expiration duration.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

How-to: Use file server for an instance of control
How-to: Configure file server to use shared network drive

Concepts

Enhanced ViewStateStorage™ with the new optimized architecture


Visible Property

[image]
Intersoft WebCombo Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : Visible Property

Gets or sets a value indicating whether the control is rendered as UI on the page.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
[CategoryAttribute("Behavior")]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual bool Visible {get; set;}
Delphi
public read-write property Visible: Boolean; virtual;
JScript
CategoryAttribute("Behavior")
BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set Visible : boolean
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual bool get_Visible();
public: __property virtual void set_Visible(
   bool value
);
C++/CLI
[CategoryAttribute("Behavior")]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property bool Visible {
   bool get();
   void set (    bool value);
}

Remarks

Using this property you can determine to show or hide a WebCombo. If you set the value to False, the combo will be hidden. On the other hand, if you set the value to True the combo will be shown.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

How-to: Show/Hide WebCombo


Width Property

[image]
Intersoft WebCombo Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : Width Property

Overriden. Returns or sets the width of the control. Returns or sets the width of the control.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Width of the control.")>
<NotifyParentPropertyAttribute(True)>
<CategoryAttribute("Layout")>
<ISNet.PersistLayoutAttribute(False)>
Public Overrides Property Width As Unit
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Unit

instance.Width = value

value = instance.Width
C#
[DescriptionAttribute("Width of the control.")]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Layout")]
[ISNet.PersistLayoutAttribute(false)]
public override Unit Width {get; set;}
Delphi
public read-write property Width: Unit; override;
JScript
DescriptionAttribute("Width of the control.")
NotifyParentPropertyAttribute()
CategoryAttribute("Layout")
ISNet.PersistLayoutAttribute()
public override function get,set Width : Unit
Managed Extensions for C++
[DescriptionAttribute("Width of the control.")]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Layout")]
[ISNet.PersistLayoutAttribute(false)]
public: __property Unit get_Width() override;
public: __property void set_Width(
   Unit value
) override;
C++/CLI
[DescriptionAttribute("Width of the control.")]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Layout")]
[ISNet.PersistLayoutAttribute(false)]
public:
property Unit Width {
   Unit get() override;
   void set (    Unit value) override;
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


XmlCompressionEnabled Property

[image]
Intersoft WebCombo Documentation
XmlCompressionEnabled Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : XmlCompressionEnabled Property

Specifies whether the Xml used for clientside state storage should be compressed.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")>
Public Overridable Property XmlCompressionEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

instance.XmlCompressionEnabled = value

value = instance.XmlCompressionEnabled
C#
[CategoryAttribute("Behavior")]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
public virtual bool XmlCompressionEnabled {get; set;}
Delphi
public read-write property XmlCompressionEnabled: Boolean; virtual;
JScript
CategoryAttribute("Behavior")
BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")
public function get,set XmlCompressionEnabled : boolean
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
public: __property virtual bool get_XmlCompressionEnabled();
public: __property virtual void set_XmlCompressionEnabled(
   bool value
);
C++/CLI
[CategoryAttribute("Behavior")]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
public:
virtual property bool XmlCompressionEnabled {
   bool get();
   void set (    bool value);
}

Remarks

Intersoft developed its own compression and decompression algorithm in order to compress the XML storage into 40-60% smaller size. This significantly improves the performance of page load in narrow bandwidth.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

How-to: Enable XML compression


WebCombo Class Fields

[image]
Intersoft WebCombo Documentation
WebCombo Class Fields
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : WebCombo Class

For a list of all members of this type, see WebCombo members.

Public Fields

 | Name | Description
public Field | SkipRowParsing |
public Field | TotalDataSourceRows |
Top

See Also

Reference

WebCombo Class
ISNet.WebUI.WebCombo Namespace


SkipRowParsing Field

[image]
Intersoft WebCombo Documentation
SkipRowParsing Field
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : SkipRowParsing Field

Syntax

Visual Basic (Declaration)
Public SkipRowParsing As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Boolean

value = instance.SkipRowParsing

instance.SkipRowParsing = value
C#
public bool SkipRowParsing
Delphi
public field SkipRowParsing: Boolean;
JScript
public var SkipRowParsing : boolean;
Managed Extensions for C++
public: bool SkipRowParsing
C++/CLI
public:
bool SkipRowParsing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


TotalDataSourceRows Field

[image]
Intersoft WebCombo Documentation
TotalDataSourceRows Field
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : TotalDataSourceRows Field

Syntax

Visual Basic (Declaration)
Public TotalDataSourceRows As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim value As Integer

value = instance.TotalDataSourceRows

instance.TotalDataSourceRows = value
C#
public int TotalDataSourceRows
Delphi
public field TotalDataSourceRows: Integer;
JScript
public var TotalDataSourceRows : int;
Managed Extensions for C++
public: int TotalDataSourceRows
C++/CLI
public:
int TotalDataSourceRows

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


WebCombo Class Events

[image]
Intersoft WebCombo Documentation
WebCombo Class Events
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : WebCombo Class

For a list of all members of this type, see WebCombo members.

Public Events

 | Name | Description
public Event | AddItem | Occurs when adding an item is performed.Manages delegates of the type ISNet.WebUI.WebGrid.RowEventHandler.
public Event | DataBinding | (Inherited from System.Web.UI.Control)
public Event | Disposed | (Inherited from System.Web.UI.Control)
public Event | Init | (Inherited from System.Web.UI.Control)
public Event | InitializeDataSource | Occurs when a datasource needs to be initialized during data binding.Manages delegates of the type DataSourceEventHandler.
public Event | InitializeJsonRow |
public Event | InitializeLayout | Occurs when the grid's layout needs to be initialized during data binding.Manages delegates of the type LayoutEventHandler.
public Event | InitializePostBack | Occurs when when OnTheFlyPostBack action needs to be initialized. Manages delegates of the type ISNet.WebUI.WebGrid.PostBackEventHandler.
public Event | InitializeRow | Occurs when a row is being initialized and about to be rendered.Manages delegates of the type ISNet.WebUI.WebGrid.RowEventHandler.
public Event | Load | (Inherited from System.Web.UI.Control)
public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
public Event | PrepareDataBinding | Occurs when any data-related functionality is performed before the combo renders data.Manages delegates of the type DataSourceEventHandler.
public Event | PreRender | (Inherited from System.Web.UI.Control)
public Event | Unload | (Inherited from System.Web.UI.Control)
public Event | ValueChanged | Occurs when the value is changed.Manages delegates of type ValueChangedEventHandler
Top

See Also

Reference

WebCombo Class
ISNet.WebUI.WebCombo Namespace


AddItem Event

[image]
Intersoft WebCombo Documentation
AddItem Event
See Also Example Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : AddItem Event

Occurs when adding an item is performed.Manages delegates of the type ISNet.WebUI.WebGrid.RowEventHandler.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute()>
<CategoryAttribute("Behavior")>
Public Event AddItem As RowEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim handler As RowEventHandler

AddHandler instance.AddItem, handler
C#
[DescriptionAttribute()]
[CategoryAttribute("Behavior")]
public event RowEventHandler AddItem
Delphi
public event AddItem: RowEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[DescriptionAttribute()]
[CategoryAttribute("Behavior")]
public: __event RowEventHandler* AddItem
C++/CLI
[DescriptionAttribute()]
[CategoryAttribute("Behavior")]
public:
event RowEventHandler^ AddItem

Event Data

The event handler receives an argument of type RowEventArgs containing data related to this event. The following RowEventArgs properties provide information specific to this event.

Property | Description
ReturnValue (Inherited from ISNet.WebUI.WebCombo.BaseEventArgs) |
Row | Gets the WebGridRow object used by the event. Gets the WebGridRow object used by the event.

Example

The following example shows you how to bind WebCombo to a Data Set and allow users to add item.
C# Copy Code
private void WebCombo1_InitializeDataSource(object sender, ISNet.WebUI.WebCombo.DataSourceEventArgs e)
{
    oleDbDataAdapter1.Fill( dsNorthWind1 );
    e.DataSource = dsNorthWind1;
}

protected void OnAddItem(object sender, RowEventArgs e)
{
    DataSet ds = (DataSet)WebCombo1.GetCachedDataSource();

    DataRow row = ds.Tables[0].NewRow();
    row["CustomerID"] = e.Row.Value;
    row["ContactName"] = e.Row.Value;

    ds.Tables[0].Rows.Add(row);

    // performs update to physical datasource.
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

How-to: Add item in bound WebCombo
How-to: Navigate to specific page after adding a row
How-to: Refresh other control during row addition
How-to: Display message box if unable to add a row

Concepts

Dynamically Add Item


DataBinding Event

[image]
Intersoft WebCombo Documentation
DataBinding Event
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : DataBinding Event

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")>
<WebCategoryAttribute("Data")>
Public Event DataBinding As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim handler As EventHandler

AddHandler instance.DataBinding, handler
C#
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public event EventHandler DataBinding
Delphi
public event DataBinding: EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public: __event EventHandler* DataBinding
C++/CLI
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public:
event EventHandler^ DataBinding

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


Disposed Event

[image]
Intersoft WebCombo Documentation
Disposed Event
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : Disposed Event

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control has been disposed.")>
Public Event Disposed As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim handler As EventHandler

AddHandler instance.Disposed, handler
C#
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public event EventHandler Disposed
Delphi
public event Disposed: EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public: __event EventHandler* Disposed
C++/CLI
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public:
event EventHandler^ Disposed

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


Init Event

[image]
Intersoft WebCombo Documentation
Init Event
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : Init Event

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been initialized.")>
Public Event Init As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim handler As EventHandler

AddHandler instance.Init, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public event EventHandler Init
Delphi
public event Init: EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public: __event EventHandler* Init
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public:
event EventHandler^ Init

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


InitializeDataSource Event

[image]
Intersoft WebCombo Documentation
InitializeDataSource Event
See Also Example Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : InitializeDataSource Event

Occurs when a datasource needs to be initialized during data binding.Manages delegates of the type DataSourceEventHandler.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<DescriptionAttribute()>
Public Event InitializeDataSource As DataSourceEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim handler As DataSourceEventHandler

AddHandler instance.InitializeDataSource, handler
C#
[CategoryAttribute("Behavior")]
[DescriptionAttribute()]
public event DataSourceEventHandler InitializeDataSource
Delphi
public event InitializeDataSource: DataSourceEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[DescriptionAttribute()]
public: __event DataSourceEventHandler* InitializeDataSource
C++/CLI
[CategoryAttribute("Behavior")]
[DescriptionAttribute()]
public:
event DataSourceEventHandler^ InitializeDataSource

Event Data

The event handler receives an argument of type DataSourceEventArgs containing data related to this event. The following DataSourceEventArgs properties provide information specific to this event.

Property | Description
AdditionalFilters |
DataSource | Gets or sets the DataSource for the control. Gets or sets the DataSource for the control.
EndRow |
IsDropDownClicked | Specifies whether the dropdown is clicked.
IsFlyDataRequest | Specifies whether the WebCombo's data request invoke a Postback.
QueryText |
ReturnValue (Inherited from ISNet.WebUI.WebCombo.BaseEventArgs) |
RowCount | Gets row count that will be retrieved from DataSource.
StartRow | Gets start rows that will be retrieved from DataSource

Example

The following example show you how to create and bind WebCombo programmatically using InitializeDataSource event (old databinding mode in WebCombo.NET 3.0)
C# Copy Code
private void wc_InitializeDataSource(object sender, ISNet.WebUI.WebCombo.DataSourceEventArgs e)
{
    DataSet ds = new DataSet();
    OleDbDataAdapter1.Fill(ds, "Customers");
    e.DataSource = ds;
    WebCombo1.DataTextField = "ContactName";
    WebCombo1.DataValueField = "CustomerID";
}

Remarks

In WebCombo.NET 3.0, using InitializeDataSource event users can make the data source bounded using e.DataSource (old databinding mode). You can also configure DataTextField and DataValueField properties of the WebCombo programmatically at this event.

WebCombo.NET 4.0 introduces you to a new code-less data binding. Binding is supported through DataSource support. With this new datasource control concept, InitializeDataSource event is no longer fired when the WebCombo is bound to DataSourceID. This event will still be fired normally when the DataSourceID property is empty (old databinding mode). Programming databind web application is very easy, simple and straightforward. There are no codes that required in the page’s code behind if you use datasource control. To give you better understanding on code-less data binding, you can read: Walkthrough: Binding WebCombo to AccessDataSource control, Walkthrough: Binding WebCombo to ObjectDataSource control, and Walkthrough: Binding WebCombo to ISDataSource control.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members

Tasks

Walkthrough: Binding WebCombo to a DataSet
Walkthrough: Binding WebCombo to XML-based DataSource
Walkthrough: Binding WebCombo to AccessDataSource control
Walkthrough: Binding WebCombo to ObjectDataSource control
Walkthrough: Binding WebCombo to ISDataSource control

Concepts

No-codes data binding through DataSourceControl support


InitializeJsonRow Event

[image]
Intersoft WebCombo Documentation
InitializeJsonRow Event
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : InitializeJsonRow Event

Syntax

Visual Basic (Declaration)
<DescriptionAttribute()>
<CategoryAttribute("Behavior")>
Public Event InitializeJsonRow As RowEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim handler As RowEventHandler

AddHandler instance.InitializeJsonRow, handler
C#
[DescriptionAttribute()]
[CategoryAttribute("Behavior")]
public event RowEventHandler InitializeJsonRow
Delphi
public event InitializeJsonRow: RowEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[DescriptionAttribute()]
[CategoryAttribute("Behavior")]
public: __event RowEventHandler* InitializeJsonRow
C++/CLI
[DescriptionAttribute()]
[CategoryAttribute("Behavior")]
public:
event RowEventHandler^ InitializeJsonRow

Event Data

The event handler receives an argument of type RowEventArgs containing data related to this event. The following RowEventArgs properties provide information specific to this event.

Property | Description
ReturnValue (Inherited from ISNet.WebUI.WebCombo.BaseEventArgs) |
Row | Gets the WebGridRow object used by the event. Gets the WebGridRow object used by the event.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


InitializeLayout Event

[image]
Intersoft WebCombo Documentation
InitializeLayout Event
See Also Example Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : InitializeLayout Event

Occurs when the grid's layout needs to be initialized during data binding.Manages delegates of the type LayoutEventHandler.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<DescriptionAttribute()>
Public Event InitializeLayout As LayoutEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim handler As LayoutEventHandler

AddHandler instance.InitializeLayout, handler
C#
[CategoryAttribute("Behavior")]
[DescriptionAttribute()]
public event LayoutEventHandler InitializeLayout
Delphi
public event InitializeLayout: LayoutEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[DescriptionAttribute()]
public: __event LayoutEventHandler* InitializeLayout
C++/CLI
[CategoryAttribute("Behavior")]
[DescriptionAttribute()]
public:
event LayoutEventHandler^ InitializeLayout

Event Data

The event handler receives an argument of type LayoutEventArgs containing data related to this event. The following LayoutEventArgs properties provide information specific to this event.

Property | Description
Layout | Gets the LayoutSet object used by the event. Gets the LayoutSet object used by the event.
ReturnValue (Inherited from ISNet.WebUI.WebCombo.BaseEventArgs) |

Example

The following example shows you how to bind WebCombo using old databinding mode and set the layout and styles, such as the MultipleColumns, BorderColor and BackColor using InitializeLayout event.
C# Copy Code
private void WebCombo1_InitializeDataSource(object sender, ISNet.WebUI.WebCombo.DataSourceEventArgs e)
{
    oleDbDataAdapter1.Fill(dataSet11.Customers);
    e.DataSource = dataSet11;
}

private void WebCombo1_InitializeLayout(object sender, ISNet.WebUI.WebCombo.LayoutEventArgs e)
{
    e.Layout.ComboMode = Mode.MultipleColumns;
    WebCombo1.AdditionalSearchFields = "ContactName, City, Country";
    e.Layout.Combo.BorderColor = System.Drawing.Color.Red;
    e.Layout.Combo.BackColor = System.Drawing.Color.Gray;
}

Remarks

In this event you can configure the styles and layout of a WebCombo programmatically. Developers also can configure the ComboMode property as well as the AdditionalSearchFields property. Note that the name of the columns which will be inserted into the AdditionalSearchFields property should be separated by comma (see the sample code above).
You can also configure DataTextField and DataValueField programmatically in InitializeLayout event instead of InitializeDataSource event.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


InitializePostBack Event

[image]
Intersoft WebCombo Documentation
InitializePostBack Event
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : InitializePostBack Event

Occurs when when OnTheFlyPostBack action needs to be initialized. Manages delegates of the type ISNet.WebUI.WebGrid.PostBackEventHandler.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute()>
<CategoryAttribute("Behavior")>
Public Event InitializePostBack As PostBackEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim handler As PostBackEventHandler

AddHandler instance.InitializePostBack, handler
C#
[DescriptionAttribute()]
[CategoryAttribute("Behavior")]
public event PostBackEventHandler InitializePostBack
Delphi
public event InitializePostBack: PostBackEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[DescriptionAttribute()]
[CategoryAttribute("Behavior")]
public: __event PostBackEventHandler* InitializePostBack
C++/CLI
[DescriptionAttribute()]
[CategoryAttribute("Behavior")]
public:
event PostBackEventHandler^ InitializePostBack

Event Data

The event handler receives an argument of type PostbackEventArgs containing data related to this event. The following PostbackEventArgs properties provide information specific to this event.

Property | Description
Action | Gets the action name (PostBackAction) for the requests that initiate the event.Gets the action name (PostBackAction) for the requests that initiate the event.
Combo | Gets the WebGrid object used by the event. Gets the WebGrid object used by the event.
CustomActionData | Gets or sets custom action data for requests that initiated by custom request function. Gets or sets custom action data for requests that initiated by custom request function.
DataSource | Gets the assigned WebGrid's DataSource. Gets the assigned WebGrid's DataSource.
ReturnValue (Inherited from ISNet.WebUI.WebCombo.BaseEventArgs) |
XmlRequest | Gets the request in XmlDocument type that contains requests information by clients. Gets the request in XmlDocument type that contains requests information by clients.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


InitializeRow Event

[image]
Intersoft WebCombo Documentation
InitializeRow Event
See Also Example Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : InitializeRow Event

Occurs when a row is being initialized and about to be rendered.Manages delegates of the type ISNet.WebUI.WebGrid.RowEventHandler.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute()>
<CategoryAttribute("Behavior")>
Public Event InitializeRow As RowEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim handler As RowEventHandler

AddHandler instance.InitializeRow, handler
C#
[DescriptionAttribute()]
[CategoryAttribute("Behavior")]
public event RowEventHandler InitializeRow
Delphi
public event InitializeRow: RowEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[DescriptionAttribute()]
[CategoryAttribute("Behavior")]
public: __event RowEventHandler* InitializeRow
C++/CLI
[DescriptionAttribute()]
[CategoryAttribute("Behavior")]
public:
event RowEventHandler^ InitializeRow

Event Data

The event handler receives an argument of type RowEventArgs containing data related to this event. The following RowEventArgs properties provide information specific to this event.

Property | Description
ReturnValue (Inherited from ISNet.WebUI.WebCombo.BaseEventArgs) |
Row | Gets the WebGridRow object used by the event. Gets the WebGridRow object used by the event.

Example

The following example shows you how to bind WebCombo using old databinding mode and modify the styles and contents of cell before it is rendered. In this example we modify the text color of Owner in ContactTitle cell to red color.
C# Copy Code
private void WebCombo1_InitializeDataSource(object sender, ISNet.WebUI.WebCombo.DataSourceEventArgs e)
{
    oleDbDataAdapter1.Fill(dataSet11.Customers);
    e.DataSource = dataSet11;
}

protected void WebCombo1_InitializeRow(object sender, ISNet.WebUI.WebCombo.RowEventArgs e)
{
     WebComboCell contactTitle = e.Row.Cells.GetNamedItem("ContactTitle");

     if (contactTitle.Text == "Owner")
     contactTitle.Style.ForeColor = Color.Red;
}

Remarks

The InitializeRow event allow you to modify the cell's content and styles before it goes to rendering. This is especially useful to write Custom Column, validate a specific condition and add rich HTML-based contents.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


Load Event

[image]
Intersoft WebCombo Documentation
Load Event
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : Load Event

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been loaded.")>
Public Event Load As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim handler As EventHandler

AddHandler instance.Load, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public event EventHandler Load
Delphi
public event Load: EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public: __event EventHandler* Load
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public:
event EventHandler^ Load

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


PreInitialize Event

[image]
Intersoft WebCombo Documentation
PreInitialize Event
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : PreInitialize Event

Syntax

Visual Basic (Declaration)
Public Event PreInitialize As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim handler As EventHandler

AddHandler instance.PreInitialize, handler
C#
public event EventHandler PreInitialize
Delphi
public event PreInitialize: EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event EventHandler* PreInitialize
C++/CLI
public:
event EventHandler^ PreInitialize

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


PrepareDataBinding Event

[image]
Intersoft WebCombo Documentation
PrepareDataBinding Event
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : PrepareDataBinding Event

Occurs when any data-related functionality is performed before the combo renders data.Manages delegates of the type DataSourceEventHandler.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute()>
<CategoryAttribute("Behavior")>
Public Event PrepareDataBinding As DataSourceEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim handler As DataSourceEventHandler

AddHandler instance.PrepareDataBinding, handler
C#
[DescriptionAttribute()]
[CategoryAttribute("Behavior")]
public event DataSourceEventHandler PrepareDataBinding
Delphi
public event PrepareDataBinding: DataSourceEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[DescriptionAttribute()]
[CategoryAttribute("Behavior")]
public: __event DataSourceEventHandler* PrepareDataBinding
C++/CLI
[DescriptionAttribute()]
[CategoryAttribute("Behavior")]
public:
event DataSourceEventHandler^ PrepareDataBinding

Event Data

The event handler receives an argument of type DataSourceEventArgs containing data related to this event. The following DataSourceEventArgs properties provide information specific to this event.

Property | Description
AdditionalFilters |
DataSource | Gets or sets the DataSource for the control. Gets or sets the DataSource for the control.
EndRow |
IsDropDownClicked | Specifies whether the dropdown is clicked.
IsFlyDataRequest | Specifies whether the WebCombo's data request invoke a Postback.
QueryText |
ReturnValue (Inherited from ISNet.WebUI.WebCombo.BaseEventArgs) |
RowCount | Gets row count that will be retrieved from DataSource.
StartRow | Gets start rows that will be retrieved from DataSource

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


PreRender Event

[image]
Intersoft WebCombo Documentation
PreRender Event
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : PreRender Event

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires before the page is rendered.")>
Public Event PreRender As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim handler As EventHandler

AddHandler instance.PreRender, handler
C#
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public event EventHandler PreRender
Delphi
public event PreRender: EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public: __event EventHandler* PreRender
C++/CLI
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public:
event EventHandler^ PreRender

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


Unload Event

[image]
Intersoft WebCombo Documentation
Unload Event
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : Unload Event

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page is unloaded.")>
Public Event Unload As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim handler As EventHandler

AddHandler instance.Unload, handler
C#
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public event EventHandler Unload
Delphi
public event Unload: EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public: __event EventHandler* Unload
C++/CLI
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public:
event EventHandler^ Unload

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


ValueChanged Event

[image]
Intersoft WebCombo Documentation
ValueChanged Event
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebCombo Class : ValueChanged Event

Occurs when the value is changed.Manages delegates of type ValueChangedEventHandler

Syntax

Visual Basic (Declaration)
Public Event ValueChanged As ValueChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebCombo
Dim handler As ValueChangedEventHandler

AddHandler instance.ValueChanged, handler
C#
public event ValueChangedEventHandler ValueChanged
Delphi
public event ValueChanged: ValueChangedEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event ValueChangedEventHandler* ValueChanged
C++/CLI
public:
event ValueChangedEventHandler^ ValueChanged

Event Data

The event handler receives an argument of type ValueChangedEventArgs containing data related to this event. The following ValueChangedEventArgs properties provide information specific to this event.

Property | Description
ReturnValue (Inherited from ISNet.WebUI.WebCombo.BaseEventArgs) |
Text |
Value |

Remarks

This event is called by OnValueChanged method.Fires when the value is changed. Called by OnValueChanged

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCombo Class
WebCombo Members


WebComboCell Class

[image]
Intersoft WebCombo Documentation
WebComboCell Class
Members Example See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : WebComboCell Class

Represents an individual data item when ComboMode is set to MultipleColumns.

Represents an individual data item when ComboMode is set to MultipleColumns.

Object Model

WebComboCell Class

Syntax

Visual Basic (Declaration)
<DescriptionAttribute()>
<SerializableAttribute()>
Public Class WebComboCell
   Inherits ISNet.WebUI.NamedObjectBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebComboCell
C#
[DescriptionAttribute()]
[SerializableAttribute()]
public class WebComboCell : ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Delphi
public class WebComboCell = class(ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject)
JScript
DescriptionAttribute()
SerializableAttribute()
public class WebComboCell extends ISNet.WebUI.NamedObjectBase implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Managed Extensions for C++
[DescriptionAttribute()]
[SerializableAttribute()]
public __gc class WebComboCell : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
C++/CLI
[DescriptionAttribute()]
[SerializableAttribute()]
public ref class WebComboCell : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Example

The following example shows you how to bind a WebCombo to DataSet and change the color of text Madrid and Spain to red.
C# Copy Code
private void WebCombo1_InitializeDataSource(object sender, ISNet.WebUI.WebCombo.DataSourceEventArgs e)
{
    oleDbDataAdapter1.Fill(dataSet11.Customers);
    e.DataSource = dataSet11;
}

private void WebCombo1_InitializeRow(object sender, ISNet.WebUI.WebCombo.RowEventArgs e)
{
    WebComboCell city = e.Row.Cells.GetNamedItem("City");
    WebComboCell country = e.Row.Cells.GetNamedItem("Country");

    if (city.Text == "Madrid")
      city.Style.ForeColor = Color.Red;
    if (country.Text == "Spain")
      country.Style.ForeColor = Color.Red;
}

Remarks

WebComboCell allows you to obtain text and value of a cell in WebCombo when you set your combo to MultipleColumns. In addition, you can customize the appearance and behavior of each cell by configuring its properties programmatically.

The Text property is used to specify the text displayed on WebComboCell while the Value property can be used to get the value of a cell. Moreover, you can use the Style property to apply your preferred style, such as determining the color, font, backcolor, and so on. Another important property is CustomObjectAttributes which you can assign custom attributes that you want to render along with the object's tag.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebCombo.WebComboCell

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboCell Members
ISNet.WebUI.WebCombo Namespace


WebComboCell Class Members

[image]
Intersoft WebCombo Documentation
WebComboCell Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebCombo Namespace : WebComboCell Class

The following tables list the members exposed by WebComboCell.

Public Constructors

 | Name | Description
public Constructor | WebComboCell Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | Image | Gets or sets the image filename that will be used to display image of an Image or ImageAndText Column. Gets or sets the image filename that will be used to display image of an Image or ImageAndText Column.
public Property | Style | Gets or sets the style applied to the cell object. Gets or sets the style applied to the cell object.
public Property | Tag | Gets or sets custom data for the cell object. Gets or sets custom data for the cell object.
public Property | Text | Gets or sets the text that will be displayed in cell. Gets or sets the text that will be displayed in cell.
public Property | TooltipText | Gets or sets the tooltip text of cell object. Gets or sets the tooltip text of cell object.
public Property | Value | Gets or sets the cell's value. Gets or sets the cell's value.
Top

Public Methods

 | Name | Description
public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | GetObjectData | Overridden.
public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | SetColumn | This function is intended for internal use only.
public Method | ToString |
Top

See Also

Reference

WebComboCell Class
ISNet.WebUI.WebCombo Namespace


WebComboCell Constructor

[image]
Intersoft WebCombo Documentation
WebComboCell Constructor
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboCell Class : WebComboCell Constructor

Initializes a new instance of the WebComboCell class.

Overload List

Overload | Description
WebComboCell Constructor() | Initializes a new instance of the WebComboCell class with no argument. The default constructor for the WebComboCell object.
WebComboCell Constructor(String,Object) | Initializes a new instance of the WebComboCell class with Text and Value. The default constructor for the WebComboCell object.
WebComboCell Constructor(String) | Initializes a new instance of the WebComboCell class with Text. The default constructor for the WebComboCell object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboCell Class
WebComboCell Members


WebComboCell Constructor()

[image]
Intersoft WebCombo Documentation
WebComboCell Constructor()
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboCell Class > WebComboCell Constructor : WebComboCell Constructor()

Initializes a new instance of the WebComboCell class with no argument. The default constructor for the WebComboCell object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebComboCell()
C#
public WebComboCell()
Delphi
public WebComboCell();
JScript
public function WebComboCell();
Managed Extensions for C++
public: WebComboCell();
C++/CLI
public:
WebComboCell();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboCell Class
WebComboCell Members
Overload List


WebComboCell Constructor(String,Object)

[image]
Intersoft WebCombo Documentation
WebComboCell Constructor(String,Object)
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboCell Class > WebComboCell Constructor : WebComboCell Constructor(String,Object)

Text
Value
Initializes a new instance of the WebComboCell class with Text and Value. The default constructor for the WebComboCell object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal Text As String, _
   ByVal Value As Object _
)
Visual Basic (Usage) Copy Code
Dim Text As String
Dim Value As Object

Dim instance As New WebComboCell(Text, Value)
C#
public WebComboCell(
   string Text,
   object Value
)
Delphi
public WebComboCell(
    Text: String;
    Value: TObject
);
JScript
public function WebComboCell(
   Text : String,
   Value : Object
);
Managed Extensions for C++
public: WebComboCell(
   string* Text,
   Object* Value
)
C++/CLI
public:
WebComboCell(
   String^ Text,
   Object^ Value
)

Parameters

Text
Value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboCell Class
WebComboCell Members
Overload List


WebComboCell Constructor(String)

[image]
Intersoft WebCombo Documentation
WebComboCell Constructor(String)
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboCell Class > WebComboCell Constructor : WebComboCell Constructor(String)

Text
Initializes a new instance of the WebComboCell class with Text. The default constructor for the WebComboCell object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal Text As String _
)
Visual Basic (Usage) Copy Code
Dim Text As String

Dim instance As New WebComboCell(Text)
C#
public WebComboCell(
   string Text
)
Delphi
public WebComboCell(
    Text: String
);
JScript
public function WebComboCell(
   Text : String
);
Managed Extensions for C++
public: WebComboCell(
   string* Text
)
C++/CLI
public:
WebComboCell(
   String^ Text
)

Parameters

Text

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboCell Class
WebComboCell Members
Overload List


Clone Method

[image]
Intersoft WebCombo Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboCell Class : Clone Method

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebComboCell
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()
Delphi
public function Clone(): TObject; virtual;
JScript
public function Clone() : Object;
Managed Extensions for C++
public: virtual Object* Clone();
C++/CLI
public:
virtual Object^ Clone();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboCell Class
WebComboCell Members


CopyFrom Method

[image]
Intersoft WebCombo Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboCell Class : CopyFrom Method

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboCell Class
WebComboCell Members


CopyFrom(Object) Method

[image]
Intersoft WebCombo Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboCell Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebComboCell
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)
Delphi
public procedure CopyFrom(
    objSource: TObject
); virtual;
JScript
public function CopyFrom(
   objSource : Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboCell Class
WebComboCell Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebCombo Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboCell Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebComboCell
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: TObject;
    cloneSourceValue: Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : Object,
   cloneSourceValue : boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   Object* objSource,
   bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   Object^ objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboCell Class
WebComboCell Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebCombo Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboCell Class : DeSerializeObjectData Method

type
info
context

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebComboCell
Dim type As Type
Dim info As SerializationInfo
Dim context As StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: Type;
    info: SerializationInfo;
    context: StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : Type,
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   Type* type,
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   Type^ type,
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboCell Class
WebComboCell Members


WebComboCell Class Methods

[image]
Intersoft WebCombo Documentation
WebComboCell Class Methods
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : WebComboCell Class

For a list of all members of this type, see WebComboCell members.

Public Methods

 | Name | Description
public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | GetObjectData | Overridden.
public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | SetColumn | This function is intended for internal use only.
public Method | ToString |
Top

See Also

Reference

WebComboCell Class
ISNet.WebUI.WebCombo Namespace


GetObjectData Method

[image]
Intersoft WebCombo Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboCell Class : GetObjectData Method

info
context

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebComboCell
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: SerializationInfo;
    context: StreamingContext
); override;
JScript
public override function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboCell Class
WebComboCell Members


IsEmpty Method

[image]
Intersoft WebCombo Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboCell Class : IsEmpty Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebComboCell
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()
Delphi
public function IsEmpty(): Boolean; virtual;
JScript
public function IsEmpty() : boolean;
Managed Extensions for C++
public: virtual bool IsEmpty();
C++/CLI
public:
virtual bool IsEmpty();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboCell Class
WebComboCell Members


Reset Method

[image]
Intersoft WebCombo Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboCell Class : Reset Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebComboCell

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboCell Class
WebComboCell Members


SerializeObjectData Method

[image]
Intersoft WebCombo Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboCell Class : SerializeObjectData Method

type
info
context

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebComboCell
Dim type As Type
Dim info As SerializationInfo
Dim context As StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: Type;
    info: SerializationInfo;
    context: StreamingContext
);
JScript
public function SerializeObjectData(
   type : Type,
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   Type* type,
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   Type^ type,
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboCell Class
WebComboCell Members


SetColumn Method

[image]
Intersoft WebCombo Documentation
SetColumn Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboCell Class : SetColumn Method

column
This function is intended for internal use only.

Syntax

Visual Basic (Declaration)
Public Sub SetColumn( _
   ByVal column As WebComboColumn _
)
Visual Basic (Usage) Copy Code
Dim instance As WebComboCell
Dim column As WebComboColumn

instance.SetColumn(column)
C#
public void SetColumn(
   WebComboColumn column
)
Delphi
public procedure SetColumn(
    column: WebComboColumn
);
JScript
public function SetColumn(
   column : WebComboColumn
);
Managed Extensions for C++
public: void SetColumn(
   WebComboColumn* column
)
C++/CLI
public:
void SetColumn(
   WebComboColumn^ column
)

Parameters

column

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboCell Class
WebComboCell Members


ToString Method

[image]
Intersoft WebCombo Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboCell Class : ToString Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebComboCell
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Delphi
public function ToString(): String; override;
JScript
public override function ToString() : String;
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboCell Class
WebComboCell Members


WebComboCell Class Properties

[image]
Intersoft WebCombo Documentation
WebComboCell Class Properties
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : WebComboCell Class

For a list of all members of this type, see WebComboCell members.

Public Properties

 | Name | Description
public Property | Image | Gets or sets the image filename that will be used to display image of an Image or ImageAndText Column. Gets or sets the image filename that will be used to display image of an Image or ImageAndText Column.
public Property | Style | Gets or sets the style applied to the cell object. Gets or sets the style applied to the cell object.
public Property | Tag | Gets or sets custom data for the cell object. Gets or sets custom data for the cell object.
public Property | Text | Gets or sets the text that will be displayed in cell. Gets or sets the text that will be displayed in cell.
public Property | TooltipText | Gets or sets the tooltip text of cell object. Gets or sets the tooltip text of cell object.
public Property | Value | Gets or sets the cell's value. Gets or sets the cell's value.
Top

See Also

Reference

WebComboCell Class
ISNet.WebUI.WebCombo Namespace


Image Property

[image]
Intersoft WebCombo Documentation
Image Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboCell Class : Image Property

Gets or sets the image filename that will be used to display image of an Image or ImageAndText Column.

Gets or sets the image filename that will be used to display image of an Image or ImageAndText Column.

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets the image filename that will be used to display image of an Image or ImageAndText Column.")>
Public Property Image As String
Visual Basic (Usage) Copy Code
Dim instance As WebComboCell
Dim value As String

instance.Image = value

value = instance.Image
C#
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the image filename that will be used to display image of an Image or ImageAndText Column.")]
public string Image {get; set;}
Delphi
public read-write property Image: String;
JScript
NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
DescriptionAttribute("Gets or sets the image filename that will be used to display image of an Image or ImageAndText Column.")
public function get,set Image : String
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the image filename that will be used to display image of an Image or ImageAndText Column.")]
public: __property string* get_Image();
public: __property void set_Image(
   string* value
);
C++/CLI
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the image filename that will be used to display image of an Image or ImageAndText Column.")]
public:
property String^ Image {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboCell Class
WebComboCell Members


Style Property

[image]
Intersoft WebCombo Documentation
Style Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboCell Class : Style Property

Gets or sets the style applied to the cell object. Gets or sets the style applied to the cell object.

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Gets or sets the style applied to the cell object.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<DefaultValueAttribute()>
Public Property Style As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebComboCell
Dim value As ISNet.WebUI.WebStyle

instance.Style = value

value = instance.Style
C#
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Gets or sets the style applied to the cell object.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DefaultValueAttribute()]
public ISNet.WebUI.WebStyle Style {get; set;}
Delphi
public read-write property Style: ISNet.WebUI.WebStyle;
JScript
TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
NotifyParentPropertyAttribute()
DescriptionAttribute("Gets or sets the style applied to the cell object.")
ISNet.Serialization.BinarySerializableAttribute()
PersistenceModeAttribute(PersistenceMode.InnerProperty)
DefaultValueAttribute()
public function get,set Style : ISNet.WebUI.WebStyle
Managed Extensions for C++
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Gets or sets the style applied to the cell object.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DefaultValueAttribute()]
public: __property ISNet.WebUI.WebStyle* get_Style();
public: __property void set_Style(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Gets or sets the style applied to the cell object.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[DefaultValueAttribute()]
public:
property ISNet.WebUI.WebStyle^ Style {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboCell Class
WebComboCell Members


Tag Property

[image]
Intersoft WebCombo Documentation
Tag Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboCell Class : Tag Property

Gets or sets custom data for the cell object. Gets or sets custom data for the cell object.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets custom data for the cell object.")>
Public Property Tag As String
Visual Basic (Usage) Copy Code
Dim instance As WebComboCell
Dim value As String

instance.Tag = value

value = instance.Tag
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets custom data for the cell object.")]
public string Tag {get; set;}
Delphi
public read-write property Tag: String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
DefaultValueAttribute()
DescriptionAttribute("Gets or sets custom data for the cell object.")
public function get,set Tag : String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets custom data for the cell object.")]
public: __property string* get_Tag();
public: __property void set_Tag(
   string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets custom data for the cell object.")]
public:
property String^ Tag {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboCell Class
WebComboCell Members


Text Property

[image]
Intersoft WebCombo Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboCell Class : Text Property

Gets or sets the text that will be displayed in cell. Gets or sets the text that will be displayed in cell.

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets the text that will be displayed in cell.")>
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As WebComboCell
Dim value As String

instance.Text = value

value = instance.Text
C#
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the text that will be displayed in cell.")]
public string Text {get; set;}
Delphi
public read-write property Text: String;
JScript
NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
DescriptionAttribute("Gets or sets the text that will be displayed in cell.")
public function get,set Text : String
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the text that will be displayed in cell.")]
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
C++/CLI
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the text that will be displayed in cell.")]
public:
property String^ Text {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboCell Class
WebComboCell Members


TooltipText Property

[image]
Intersoft WebCombo Documentation
TooltipText Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboCell Class : TooltipText Property

Gets or sets the tooltip text of cell object. Gets or sets the tooltip text of cell object.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Gets or sets the tooltip text of cell object.")>
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property TooltipText As String
Visual Basic (Usage) Copy Code
Dim instance As WebComboCell
Dim value As String

instance.TooltipText = value

value = instance.TooltipText
C#
[DescriptionAttribute("Gets or sets the tooltip text of cell object.")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public string TooltipText {get; set;}
Delphi
public read-write property TooltipText: String;
JScript
DescriptionAttribute("Gets or sets the tooltip text of cell object.")
DefaultValueAttribute()
NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set TooltipText : String
Managed Extensions for C++
[DescriptionAttribute("Gets or sets the tooltip text of cell object.")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property string* get_TooltipText();
public: __property void set_TooltipText(
   string* value
);
C++/CLI
[DescriptionAttribute("Gets or sets the tooltip text of cell object.")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property String^ TooltipText {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboCell Class
WebComboCell Members
All-new, sleeker User Interface

Tasks

How-to: Display tooltip in WebCombo

Concepts

User Interface Elements
Improved Layout


Value Property

[image]
Intersoft WebCombo Documentation
Value Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboCell Class : Value Property

Gets or sets the cell's value. Gets or sets the cell's value.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Gets or sets the cell's value.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
Public Property Value As Object
Visual Basic (Usage) Copy Code
Dim instance As WebComboCell
Dim value As Object

instance.Value = value

value = instance.Value
C#
[DescriptionAttribute("Gets or sets the cell's value.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
public object Value {get; set;}
Delphi
public read-write property Value: TObject;
JScript
DescriptionAttribute("Gets or sets the cell's value.")
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
NotifyParentPropertyAttribute()
public function get,set Value : Object
Managed Extensions for C++
[DescriptionAttribute("Gets or sets the cell's value.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
public: __property Object* get_Value();
public: __property void set_Value(
   Object* value
);
C++/CLI
[DescriptionAttribute("Gets or sets the cell's value.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
public:
property Object^ Value {
   Object^ get();
   void set (    Object^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboCell Class
WebComboCell Members


WebComboColumn Class

[image]
Intersoft WebCombo Documentation
WebComboColumn Class
Members Example See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : WebComboColumn Class

The Column object contains properties to customize basic column information such as ColumnType, HeaderText and Width. This class should be used only when ComboMode is set to MultipleColumns.

The Column object contains properties to customize basic column information such as HeaderText and Width. This class should be used only when LayoutSet.ComboMode is set to MultipleColumns

Object Model

WebComboColumn Class

Syntax

Visual Basic (Declaration)
<DescriptionAttribute()>
<SerializableAttribute()>
Public Class WebComboColumn
   Inherits ISNet.WebUI.NamedObjectBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebComboColumn
C#
[DescriptionAttribute()]
[SerializableAttribute()]
public class WebComboColumn : ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Delphi
public class WebComboColumn = class(ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject)
JScript
DescriptionAttribute()
SerializableAttribute()
public class WebComboColumn extends ISNet.WebUI.NamedObjectBase implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Managed Extensions for C++
[DescriptionAttribute()]
[SerializableAttribute()]
public __gc class WebComboColumn : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
C++/CLI
[DescriptionAttribute()]
[SerializableAttribute()]
public ref class WebComboColumn : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Example

The following example shows you on how to bind WebCombo and create WebComboColumn (ContactName and City) programmatically.
C# Copy Code
private void WebCombo2_InitializeDataSource(object sender, ISNet.WebUI.WebCombo.DataSourceEventArgs e)
{
    DataSet ds = new DataSet();
    oleDbDataAdapter1.Fill(ds,"Customers");
    e.DataSource =  ds;
    WebCombo2.DataTextField = "ContactName";
    WebCombo2.DataValueField = "CustomerID";
}

private void WebCombo2_InitializeLayout(object sender, ISNet.WebUI.WebCombo.LayoutEventArgs e)
{
    e.Layout.ComboMode = Mode.MultipleColumns;
    WebComboColumn a = new WebComboColumn("ContactName");
    WebComboColumn b = new WebComboColumn("City");
    WebCombo wc = (WebCombo) sender;
    wc.Columns.Add(a);
    wc.Columns.Add(b);
}

Remarks

WebComboColumn provides powerful and easy-to-use control to display multiple column. Using WebCombo.NET Designer, user can determine the column structure and the column sequence that will be displayed, choose what type of column, determine the header text and the width of column, and so on. As always, you can also configure the WebComboColumn programmatically.

Creating WebComboColumn using Designer is quick and easy. After you have binded a WebCombo to a data source, open the WebCombo.NET Designer, then choose Column in the left-pane tree view. Click Add button to add a new column in WebCombo. In BaseFieldName property, choose the column name that you want to display. You can repeat this step to add more columns. For instance, if you use "Customer" Table, you can add CompanyName, ContactName, and City column.

The column's sequence can be arranged by using the Move Down and Move Up button. For example, column ContactName is previously in the second sequence. Click Move Up button and the ContactName will be displayed in the first sequence. You can also determine the style of WebComboColumn by configuring the ColumnType, HeaderText, and Width.

You can also create the WebComboColumn programmatically, like shown in the example above.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebCombo.WebComboColumn

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboColumn Members
ISNet.WebUI.WebCombo Namespace

Tasks

How-to: Use multiple columns mode
How-to: Use bound multiple selection WebCombo
How-to: Use unbound multiple selection WebCombo
How-to: Add columns to WebCombo

Concepts

Multiple Columns
Multiple Selection

Other Resources

Column Types


WebComboColumn Class Members

[image]
Intersoft WebCombo Documentation
WebComboColumn Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebCombo Namespace : WebComboColumn Class

The following tables list the members exposed by WebComboColumn.

Public Constructors

 | Name | Description
public Constructor | WebComboColumn Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | BaseFieldName | Returns or sets the base field name of the column. You should never set this property manually as it's populated automatically on DataBind Returns or sets the base field name of the column. You should never set this property manually as it's populated automatically on WebCombo.DataBind
public Property | Bound | Specifies whether the column is bound to the DataColumn of DataSource. Specifies whether the column is bound to the DataColumn of DataSource.
public Property | CellImage | Gets or sets the image filename that will be displayed in cells that belong to this column. Gets or sets the image filename that will be displayed in cells that belong to this column.
public Property | ColumnType | Gets or sets the type of the column that control how the column content will be rendered. Gets or sets the type of the column that control how the column content will be rendered.
public Property | DataFormatString | Gets or sets the string format to use when rendering values. Gets or sets the string format to use when rendering values.
public Property | DataType | Gets or sets the data type of the column. Gets or sets the data type of the column.
public Property | HeaderText | Returns or sets the header text for the column. Returns or sets the header text for the column.
public Property | Hidden | Specifies whether the column should be displayed or hidden. Specifies whether the column should be displayed or hidden.
public Property | Name | Overridden.
public Property | RenderOnHidden | Gets or sets a value indicating whether WebCombo should render this Column and its cell to client (in invisible display) when its Hidden property is set to True. Gets or sets a value indicating whether WebCombo should render this Column and its cell to client (in invisible display) when its Hidden property is set to True.
public Property | Width | Specifies the width of column Specifies the width of the column.
Top

Public Methods

 | Name | Description
public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | GetObjectData | Overridden.
public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebComboColumn Class
ISNet.WebUI.WebCombo Namespace


WebComboColumn Constructor

[image]
Intersoft WebCombo Documentation
WebComboColumn Constructor
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboColumn Class : WebComboColumn Constructor

Initializes a new instance of the WebComboColumn.

Overload List

Overload | Description
WebComboColumn Constructor() | Initializes a new instance of the WebComboColumn class with no argument.
WebComboColumn Constructor(String) | Initializes a new instance of the WebComboColumn class with FieldName. Creates column object with BaseFieldName.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboColumn Class
WebComboColumn Members


WebComboColumn Constructor()

[image]
Intersoft WebCombo Documentation
WebComboColumn Constructor()
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboColumn Class > WebComboColumn Constructor : WebComboColumn Constructor()

Initializes a new instance of the WebComboColumn class with no argument.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebComboColumn()
C#
public WebComboColumn()
Delphi
public WebComboColumn();
JScript
public function WebComboColumn();
Managed Extensions for C++
public: WebComboColumn();
C++/CLI
public:
WebComboColumn();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboColumn Class
WebComboColumn Members
Overload List


WebComboColumn Constructor(String)

[image]
Intersoft WebCombo Documentation
WebComboColumn Constructor(String)
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboColumn Class > WebComboColumn Constructor : WebComboColumn Constructor(String)

FieldName
Initializes a new instance of the WebComboColumn class with FieldName. Creates column object with BaseFieldName.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal FieldName As String _
)
Visual Basic (Usage) Copy Code
Dim FieldName As String

Dim instance As New WebComboColumn(FieldName)
C#
public WebComboColumn(
   string FieldName
)
Delphi
public WebComboColumn(
    FieldName: String
);
JScript
public function WebComboColumn(
   FieldName : String
);
Managed Extensions for C++
public: WebComboColumn(
   string* FieldName
)
C++/CLI
public:
WebComboColumn(
   String^ FieldName
)

Parameters

FieldName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboColumn Class
WebComboColumn Members
Overload List


Clone Method

[image]
Intersoft WebCombo Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboColumn Class : Clone Method

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebComboColumn
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()
Delphi
public function Clone(): TObject; virtual;
JScript
public function Clone() : Object;
Managed Extensions for C++
public: virtual Object* Clone();
C++/CLI
public:
virtual Object^ Clone();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboColumn Class
WebComboColumn Members


CopyFrom Method

[image]
Intersoft WebCombo Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboColumn Class : CopyFrom Method

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboColumn Class
WebComboColumn Members


CopyFrom(Object) Method

[image]
Intersoft WebCombo Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboColumn Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebComboColumn
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)
Delphi
public procedure CopyFrom(
    objSource: TObject
); virtual;
JScript
public function CopyFrom(
   objSource : Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboColumn Class
WebComboColumn Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebCombo Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboColumn Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebComboColumn
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: TObject;
    cloneSourceValue: Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : Object,
   cloneSourceValue : boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   Object* objSource,
   bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   Object^ objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboColumn Class
WebComboColumn Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebCombo Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboColumn Class : DeSerializeObjectData Method

type
info
context

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebComboColumn
Dim type As Type
Dim info As SerializationInfo
Dim context As StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: Type;
    info: SerializationInfo;
    context: StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : Type,
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   Type* type,
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   Type^ type,
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboColumn Class
WebComboColumn Members


WebComboColumn Class Methods

[image]
Intersoft WebCombo Documentation
WebComboColumn Class Methods
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : WebComboColumn Class

For a list of all members of this type, see WebComboColumn members.

Public Methods

 | Name | Description
public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | GetObjectData | Overridden.
public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebComboColumn Class
ISNet.WebUI.WebCombo Namespace


GetObjectData Method

[image]
Intersoft WebCombo Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboColumn Class : GetObjectData Method

info
context

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebComboColumn
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: SerializationInfo;
    context: StreamingContext
); override;
JScript
public override function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboColumn Class
WebComboColumn Members


IsEmpty Method

[image]
Intersoft WebCombo Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboColumn Class : IsEmpty Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebComboColumn
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()
Delphi
public function IsEmpty(): Boolean; virtual;
JScript
public function IsEmpty() : boolean;
Managed Extensions for C++
public: virtual bool IsEmpty();
C++/CLI
public:
virtual bool IsEmpty();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboColumn Class
WebComboColumn Members


Reset Method

[image]
Intersoft WebCombo Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboColumn Class : Reset Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebComboColumn

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboColumn Class
WebComboColumn Members


SerializeObjectData Method

[image]
Intersoft WebCombo Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboColumn Class : SerializeObjectData Method

type
info
context

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebComboColumn
Dim type As Type
Dim info As SerializationInfo
Dim context As StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: Type;
    info: SerializationInfo;
    context: StreamingContext
);
JScript
public function SerializeObjectData(
   type : Type,
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   Type* type,
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   Type^ type,
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboColumn Class
WebComboColumn Members


WebComboColumn Class Properties

[image]
Intersoft WebCombo Documentation
WebComboColumn Class Properties
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : WebComboColumn Class

For a list of all members of this type, see WebComboColumn members.

Public Properties

 | Name | Description
public Property | BaseFieldName | Returns or sets the base field name of the column. You should never set this property manually as it's populated automatically on DataBind Returns or sets the base field name of the column. You should never set this property manually as it's populated automatically on WebCombo.DataBind
public Property | Bound | Specifies whether the column is bound to the DataColumn of DataSource. Specifies whether the column is bound to the DataColumn of DataSource.
public Property | CellImage | Gets or sets the image filename that will be displayed in cells that belong to this column. Gets or sets the image filename that will be displayed in cells that belong to this column.
public Property | ColumnType | Gets or sets the type of the column that control how the column content will be rendered. Gets or sets the type of the column that control how the column content will be rendered.
public Property | DataFormatString | Gets or sets the string format to use when rendering values. Gets or sets the string format to use when rendering values.
public Property | DataType | Gets or sets the data type of the column. Gets or sets the data type of the column.
public Property | HeaderText | Returns or sets the header text for the column. Returns or sets the header text for the column.
public Property | Hidden | Specifies whether the column should be displayed or hidden. Specifies whether the column should be displayed or hidden.
public Property | Name | Overridden.
public Property | RenderOnHidden | Gets or sets a value indicating whether WebCombo should render this Column and its cell to client (in invisible display) when its Hidden property is set to True. Gets or sets a value indicating whether WebCombo should render this Column and its cell to client (in invisible display) when its Hidden property is set to True.
public Property | Width | Specifies the width of column Specifies the width of the column.
Top

See Also

Reference

WebComboColumn Class
ISNet.WebUI.WebCombo Namespace


BaseFieldName Property

[image]
Intersoft WebCombo Documentation
BaseFieldName Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboColumn Class : BaseFieldName Property

Returns or sets the base field name of the column. You should never set this property manually as it's populated automatically on DataBind

Returns or sets the base field name of the column. You should never set this property manually as it's populated automatically on WebCombo.DataBind

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Returns or sets the base field name of the column.")>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebCombo.FieldTypeEditor, ISNet.WebUI.WebCombo, Version=5.0.7200.1, Culture=neutral, PublicKeyToken=c4184ef0d326354b")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
Public Property BaseFieldName As String
Visual Basic (Usage) Copy Code
Dim instance As WebComboColumn
Dim value As String

instance.BaseFieldName = value

value = instance.BaseFieldName
C#
[DescriptionAttribute("Returns or sets the base field name of the column.")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebCombo.FieldTypeEditor, ISNet.WebUI.WebCombo, Version=5.0.7200.1, Culture=neutral, PublicKeyToken=c4184ef0d326354b")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public string BaseFieldName {get; set;}
Delphi
public read-write property BaseFieldName: String;
JScript
DescriptionAttribute("Returns or sets the base field name of the column.")
EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebCombo.FieldTypeEditor, ISNet.WebUI.WebCombo, Version=5.0.7200.1, Culture=neutral, PublicKeyToken=c4184ef0d326354b")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
DefaultValueAttribute()
public function get,set BaseFieldName : String
Managed Extensions for C++
[DescriptionAttribute("Returns or sets the base field name of the column.")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebCombo.FieldTypeEditor, ISNet.WebUI.WebCombo, Version=5.0.7200.1, Culture=neutral, PublicKeyToken=c4184ef0d326354b")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public: __property string* get_BaseFieldName();
public: __property void set_BaseFieldName(
   string* value
);
C++/CLI
[DescriptionAttribute("Returns or sets the base field name of the column.")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebCombo.FieldTypeEditor, ISNet.WebUI.WebCombo, Version=5.0.7200.1, Culture=neutral, PublicKeyToken=c4184ef0d326354b")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public:
property String^ BaseFieldName {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboColumn Class
WebComboColumn Members


Bound Property

[image]
Intersoft WebCombo Documentation
Bound Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboColumn Class : Bound Property

Specifies whether the column is bound to the DataColumn of DataSource.

Specifies whether the column is bound to the DataColumn of DataSource.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<DescriptionAttribute("Specifies whether the column is bound to the DataColumn of DataSource.")>
<DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
Public Property Bound As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebComboColumn
Dim value As Boolean

instance.Bound = value

value = instance.Bound
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Specifies whether the column is bound to the DataColumn of DataSource.")]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public bool Bound {get; set;}
Delphi
public read-write property Bound: Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
DescriptionAttribute("Specifies whether the column is bound to the DataColumn of DataSource.")
DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
NotifyParentPropertyAttribute()
public function get,set Bound : boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Specifies whether the column is bound to the DataColumn of DataSource.")]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public: __property bool get_Bound();
public: __property void set_Bound(
   bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Specifies whether the column is bound to the DataColumn of DataSource.")]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public:
property bool Bound {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboColumn Class
WebComboColumn Members


CellImage Property

[image]
Intersoft WebCombo Documentation
CellImage Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboColumn Class : CellImage Property

Gets or sets the image filename that will be displayed in cells that belong to this column.

Gets or sets the image filename that will be displayed in cells that belong to this column.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Gets or sets the image filename that will be displayed in cells that belong to this column.")>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property CellImage As String
Visual Basic (Usage) Copy Code
Dim instance As WebComboColumn
Dim value As String

instance.CellImage = value

value = instance.CellImage
C#
[DescriptionAttribute("Gets or sets the image filename that will be displayed in cells that belong to this column.")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public string CellImage {get; set;}
Delphi
public read-write property CellImage: String;
JScript
DescriptionAttribute("Gets or sets the image filename that will be displayed in cells that belong to this column.")
NotifyParentPropertyAttribute()
DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set CellImage : String
Managed Extensions for C++
[DescriptionAttribute("Gets or sets the image filename that will be displayed in cells that belong to this column.")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property string* get_CellImage();
public: __property void set_CellImage(
   string* value
);
C++/CLI
[DescriptionAttribute("Gets or sets the image filename that will be displayed in cells that belong to this column.")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property String^ CellImage {
   String^ get();
   void set (    String^ value);
}

Remarks

This property will only take affect on column which ColumnType is Image or ImageAndTextThis property will only take affect on column which ColumnType is ColumnType.Image or ColumnType.ImageAndText

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboColumn Class
WebComboColumn Members


ColumnType Property

[image]
Intersoft WebCombo Documentation
ColumnType Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboColumn Class : ColumnType Property

Gets or sets the type of the column that control how the column content will be rendered.

Gets or sets the type of the column that control how the column content will be rendered.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<DescriptionAttribute("Gets or sets the type of the column.")>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ColumnType As ColumnType
Visual Basic (Usage) Copy Code
Dim instance As WebComboColumn
Dim value As ColumnType

instance.ColumnType = value

value = instance.ColumnType
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Gets or sets the type of the column.")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public ColumnType ColumnType {get; set;}
Delphi
public read-write property ColumnType: ColumnType;
JScript
ISNet.Serialization.BinarySerializableAttribute()
DescriptionAttribute("Gets or sets the type of the column.")
NotifyParentPropertyAttribute()
DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ColumnType : ColumnType
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Gets or sets the type of the column.")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property ColumnType get_ColumnType();
public: __property void set_ColumnType(
   ColumnType value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Gets or sets the type of the column.")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property ColumnType ColumnType {
   ColumnType get();
   void set (    ColumnType value);
}

Remarks

WebCombo provides predefined column type such as Text, Image, ImageAndText and Custom, which are most commonly used. For greater level of customization, WebCombo's Column contents can also be customized to display rich HTML-based contents by setting its ColumnType to Custom and write the custom content codes in InitializeRow event.

WebCombo provides predefined column type such as Image, ImageAndText and so on, which are most commonly used. For greater level of customization, WebCombo's Column contents can also be customized to display rich HTML-based contents by setting its ColumnType to ColumnType.Custom and write the custom content codes in InitializeRow event.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboColumn Class
WebComboColumn Members

Tasks

How-to: Utilize text ColumnType
How-to: Utilize image ColumnType
How-to: Utilize ImageAndText ColumnType
How-to: Utilize custom ColumnType

Concepts

Column Types


DataFormatString Property

[image]
Intersoft WebCombo Documentation
DataFormatString Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboColumn Class : DataFormatString Property

Gets or sets the string format to use when rendering values. Gets or sets the string format to use when rendering values.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets the format to use when rendering values.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
Public Property DataFormatString As String
Visual Basic (Usage) Copy Code
Dim instance As WebComboColumn
Dim value As String

instance.DataFormatString = value

value = instance.DataFormatString
C#
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the format to use when rendering values.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public string DataFormatString {get; set;}
Delphi
public read-write property DataFormatString: String;
JScript
DefaultValueAttribute()
DescriptionAttribute("Gets or sets the format to use when rendering values.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
NotifyParentPropertyAttribute()
public function get,set DataFormatString : String
Managed Extensions for C++
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the format to use when rendering values.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public: __property string* get_DataFormatString();
public: __property void set_DataFormatString(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the format to use when rendering values.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public:
property String^ DataFormatString {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboColumn Class
WebComboColumn Members


DataType Property

[image]
Intersoft WebCombo Documentation
DataType Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboColumn Class : DataType Property

Gets or sets the data type of the column. Gets or sets the data type of the column.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets the data type of the column.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
Public Property DataType As String
Visual Basic (Usage) Copy Code
Dim instance As WebComboColumn
Dim value As String

instance.DataType = value

value = instance.DataType
C#
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the data type of the column.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public string DataType {get; set;}
Delphi
public read-write property DataType: String;
JScript
DefaultValueAttribute()
DescriptionAttribute("Gets or sets the data type of the column.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
NotifyParentPropertyAttribute()
public function get,set DataType : String
Managed Extensions for C++
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the data type of the column.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public: __property string* get_DataType();
public: __property void set_DataType(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the data type of the column.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public:
property String^ DataType {
   String^ get();
   void set (    String^ value);
}

Remarks

By default, WebCombo will automatically determines the data type of columns which is bound to DataSource and previous settings of DataType specified in design time is overriden. By default, WebCombo will automatically determines the data type of columns which is bound to DataSource and previous settings of DataType specified in design time is overriden.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboColumn Class
WebComboColumn Members


HeaderText Property

[image]
Intersoft WebCombo Documentation
HeaderText Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboColumn Class : HeaderText Property

Returns or sets the header text for the column. Returns or sets the header text for the column.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
Public Property HeaderText As String
Visual Basic (Usage) Copy Code
Dim instance As WebComboColumn
Dim value As String

instance.HeaderText = value

value = instance.HeaderText
C#
[DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public string HeaderText {get; set;}
Delphi
public read-write property HeaderText: String;
JScript
DescriptionAttribute()
ISNet.Serialization.XmlSerializableAttribute()
DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
public function get,set HeaderText : String
Managed Extensions for C++
[DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public: __property string* get_HeaderText();
public: __property void set_HeaderText(
   string* value
);
C++/CLI
[DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public:
property String^ HeaderText {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboColumn Class
WebComboColumn Members


Hidden Property

[image]
Intersoft WebCombo Documentation
Hidden Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboColumn Class : Hidden Property

Specifies whether the column should be displayed or hidden. Specifies whether the column should be displayed or hidden.

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<DescriptionAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Hidden As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebComboColumn
Dim value As Boolean

instance.Hidden = value

value = instance.Hidden
C#
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public bool Hidden {get; set;}
Delphi
public read-write property Hidden: Boolean;
JScript
NotifyParentPropertyAttribute()
DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
DescriptionAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Hidden : boolean
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property bool get_Hidden();
public: __property void set_Hidden(
   bool value
);
C++/CLI
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property bool Hidden {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboColumn Class
WebComboColumn Members


Name Property

[image]
Intersoft WebCombo Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboColumn Class : Name Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overrides Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As WebComboColumn
Dim value As String

instance.Name = value

value = instance.Name
C#
[BrowsableAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[ISNet.Serialization.BinarySerializableAttribute()]
public override string Name {get; set;}
Delphi
public read-write property Name: String; override;
JScript
BrowsableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
ISNet.Serialization.BinarySerializableAttribute()
public override function get,set Name : String
Managed Extensions for C++
[BrowsableAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property string* get_Name() override;
public: __property void set_Name(
   string* value
) override;
C++/CLI
[BrowsableAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property String^ Name {
   String^ get() override;
   void set (    String^ value) override;
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboColumn Class
WebComboColumn Members


RenderOnHidden Property

[image]
Intersoft WebCombo Documentation
RenderOnHidden Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboColumn Class : RenderOnHidden Property

Gets or sets a value indicating whether WebCombo should render this Column and its cell to client (in invisible display) when its Hidden property is set to True.

Gets or sets a value indicating whether WebCombo should render this Column and its cell to client (in invisible display) when its Hidden property is set to True.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Gets or sets a value indicating whether WebCombo should render this Column and its cell to client (in invisible display) when its Hidden property is set to True.")>
<DefaultValueAttribute()>
Public Property RenderOnHidden As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebComboColumn
Dim value As Boolean

instance.RenderOnHidden = value

value = instance.RenderOnHidden
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Gets or sets a value indicating whether WebCombo should render this Column and its cell to client (in invisible display) when its Hidden property is set to True.")]
[DefaultValueAttribute()]
public bool RenderOnHidden {get; set;}
Delphi
public read-write property RenderOnHidden: Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
NotifyParentPropertyAttribute()
DescriptionAttribute("Gets or sets a value indicating whether WebCombo should render this Column and its cell to client (in invisible display) when its Hidden property is set to True.")
DefaultValueAttribute()
public function get,set RenderOnHidden : boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Gets or sets a value indicating whether WebCombo should render this Column and its cell to client (in invisible display) when its Hidden property is set to True.")]
[DefaultValueAttribute()]
public: __property bool get_RenderOnHidden();
public: __property void set_RenderOnHidden(
   bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Gets or sets a value indicating whether WebCombo should render this Column and its cell to client (in invisible display) when its Hidden property is set to True.")]
[DefaultValueAttribute()]
public:
property bool RenderOnHidden {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboColumn Class
WebComboColumn Members
How-to: Get the hidden cell's value of the selected row


Width Property

[image]
Intersoft WebCombo Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboColumn Class : Width Property

Specifies the width of column Specifies the width of the column.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<DescriptionAttribute("Specifies the width of the column.")>
<DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
Public Property Width As Unit
Visual Basic (Usage) Copy Code
Dim instance As WebComboColumn
Dim value As Unit

instance.Width = value

value = instance.Width
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Specifies the width of the column.")]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public Unit Width {get; set;}
Delphi
public read-write property Width: Unit;
JScript
ISNet.Serialization.BinarySerializableAttribute()
DescriptionAttribute("Specifies the width of the column.")
DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
NotifyParentPropertyAttribute()
public function get,set Width : Unit
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Specifies the width of the column.")]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public: __property Unit get_Width();
public: __property void set_Width(
   Unit value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Specifies the width of the column.")]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public:
property Unit Width {
   Unit get();
   void set (    Unit value);
}

Remarks

The value of this property Empty by default. WebCombo control will use ColumnWidthDefault property as the default column width for the second and the rest columns.

When working in MultipleColumns mode, WebCombo always set the 1st column's width to width of the WebCombo control. This is based on the standard behavior of Windows GUI.

You may manually assign column's width from anywhere in the code.

This property is leave to Empty by default. WebCombo control will use ColumnWidthDefault property as the default column width for the 2nd and the rest columns.

When working in MultipleColumns mode, WebCombo always set the 1st column's width to width of the WebCombo control. This is based on the standard behavior of Windows GUI.

You may manually assign column's width from anywhere in the code.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboColumn Class
WebComboColumn Members


WebComboIntegrationSettings Class

[image]
Intersoft WebCombo Documentation
WebComboIntegrationSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : WebComboIntegrationSettings Class

Provides settings for integrating other server side controls as the WebCombo's ResultBox.

Object Model

WebComboIntegrationSettings Class

Syntax

Visual Basic (Declaration)
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<SerializableAttribute()>
Public NotInheritable Class WebComboIntegrationSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebComboIntegrationSettings
C#
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[SerializableAttribute()]
public sealed class WebComboIntegrationSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebComboIntegrationSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)sealed;
JScript
PersistenceModeAttribute(PersistenceMode.InnerProperty)
SerializableAttribute()
public sealed class WebComboIntegrationSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[SerializableAttribute()]
public __gc __sealed class WebComboIntegrationSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[SerializableAttribute()]
public ref class WebComboIntegrationSettings sealed : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebCombo.WebComboIntegrationSettings

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboIntegrationSettings Members
ISNet.WebUI.WebCombo Namespace

Concepts

Integration with WebTreeView
Integration with WebContextMenu

Tasks

How-to: Integrate a WebTreeView control to WebCombo
How-to: Integrate a WebContextMenu control to WebCombo


WebComboIntegrationSettings Class Members

[image]
Intersoft WebCombo Documentation
WebComboIntegrationSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebCombo Namespace : WebComboIntegrationSettings Class

The following tables list the members exposed by WebComboIntegrationSettings.

Public Constructors

 | Name | Description
public Constructor | WebComboIntegrationSettings Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | ControlId | Specifies the target server control ID to be integrated according to the specified control type.
public Property | ControlType | Specifies the built-in control type to be integrated in the WebCombo's ResultBox.
public Property | Enabled | Specifies whether WebCombo should integrate the specified control as its ResultBox.
Top

Public Methods

 | Name | Description
public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | GetObjectData | Overridden.
public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebComboIntegrationSettings Class
ISNet.WebUI.WebCombo Namespace


WebComboIntegrationSettings Constructor

[image]
Intersoft WebCombo Documentation
WebComboIntegrationSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboIntegrationSettings Class : WebComboIntegrationSettings Constructor

Overload List

Overload | Description
WebComboIntegrationSettings Constructor() |
WebComboIntegrationSettings Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboIntegrationSettings Class
WebComboIntegrationSettings Members


WebComboIntegrationSettings Constructor()

[image]
Intersoft WebCombo Documentation
WebComboIntegrationSettings Constructor()
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboIntegrationSettings Class > WebComboIntegrationSettings Constructor : WebComboIntegrationSettings Constructor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebComboIntegrationSettings()
C#
public WebComboIntegrationSettings()
Delphi
public WebComboIntegrationSettings();
JScript
public function WebComboIntegrationSettings();
Managed Extensions for C++
public: WebComboIntegrationSettings();
C++/CLI
public:
WebComboIntegrationSettings();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboIntegrationSettings Class
WebComboIntegrationSettings Members
Overload List


WebComboIntegrationSettings Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebCombo Documentation
WebComboIntegrationSettings Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboIntegrationSettings Class > WebComboIntegrationSettings Constructor : WebComboIntegrationSettings Constructor(SerializationInfo,StreamingContext)

info
context

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As New WebComboIntegrationSettings(info, context)
C#
public WebComboIntegrationSettings(
   SerializationInfo info,
   StreamingContext context
)
Delphi
public WebComboIntegrationSettings(
    info: SerializationInfo;
    context: StreamingContext
);
JScript
public function WebComboIntegrationSettings(
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: WebComboIntegrationSettings(
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
public:
WebComboIntegrationSettings(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboIntegrationSettings Class
WebComboIntegrationSettings Members
Overload List


Clone Method

[image]
Intersoft WebCombo Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboIntegrationSettings Class : Clone Method

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebComboIntegrationSettings
Dim value As Object

value = instance.Clone()
C#
public object Clone()
Delphi
public function Clone(): TObject;
JScript
public function Clone() : Object;
Managed Extensions for C++
public: Object* Clone();
C++/CLI
public:
Object^ Clone();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboIntegrationSettings Class
WebComboIntegrationSettings Members


CopyFrom Method

[image]
Intersoft WebCombo Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboIntegrationSettings Class : CopyFrom Method

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboIntegrationSettings Class
WebComboIntegrationSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebCombo Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboIntegrationSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebComboIntegrationSettings
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public void CopyFrom(
   object objSource
)
Delphi
public procedure CopyFrom(
    objSource: TObject
);
JScript
public function CopyFrom(
   objSource : Object
);
Managed Extensions for C++
public: void CopyFrom(
   Object* objSource
)
C++/CLI
public:
void CopyFrom(
   Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboIntegrationSettings Class
WebComboIntegrationSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebCombo Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboIntegrationSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebComboIntegrationSettings
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public void CopyFrom(
   object objSource,
   bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: TObject;
    cloneSourceValue: Boolean
);
JScript
public function CopyFrom(
   objSource : Object,
   cloneSourceValue : boolean
);
Managed Extensions for C++
public: void CopyFrom(
   Object* objSource,
   bool cloneSourceValue
)
C++/CLI
public:
void CopyFrom(
   Object^ objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboIntegrationSettings Class
WebComboIntegrationSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebCombo Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboIntegrationSettings Class : DeSerializeObjectData Method

type
info
context

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebComboIntegrationSettings
Dim type As Type
Dim info As SerializationInfo
Dim context As StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: Type;
    info: SerializationInfo;
    context: StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : Type,
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   Type* type,
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   Type^ type,
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboIntegrationSettings Class
WebComboIntegrationSettings Members


WebComboIntegrationSettings Class Methods

[image]
Intersoft WebCombo Documentation
WebComboIntegrationSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : WebComboIntegrationSettings Class

For a list of all members of this type, see WebComboIntegrationSettings members.

Public Methods

 | Name | Description
public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | GetObjectData | Overridden.
public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebComboIntegrationSettings Class
ISNet.WebUI.WebCombo Namespace


GetObjectData Method

[image]
Intersoft WebCombo Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboIntegrationSettings Class : GetObjectData Method

info
context

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebComboIntegrationSettings
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: SerializationInfo;
    context: StreamingContext
); override;
JScript
public override function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboIntegrationSettings Class
WebComboIntegrationSettings Members


IsEmpty Method

[image]
Intersoft WebCombo Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboIntegrationSettings Class : IsEmpty Method

Syntax

Visual Basic (Declaration)
Public Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebComboIntegrationSettings
Dim value As Boolean

value = instance.IsEmpty()
C#
public bool IsEmpty()
Delphi
public function IsEmpty(): Boolean;
JScript
public function IsEmpty() : boolean;
Managed Extensions for C++
public: bool IsEmpty();
C++/CLI
public:
bool IsEmpty();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboIntegrationSettings Class
WebComboIntegrationSettings Members


Reset Method

[image]
Intersoft WebCombo Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboIntegrationSettings Class : Reset Method

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebComboIntegrationSettings

instance.Reset()
C#
public void Reset()
Delphi
public procedure Reset();
JScript
public function Reset();
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboIntegrationSettings Class
WebComboIntegrationSettings Members


SerializeObjectData Method

[image]
Intersoft WebCombo Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboIntegrationSettings Class : SerializeObjectData Method

type
info
context

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebComboIntegrationSettings
Dim type As Type
Dim info As SerializationInfo
Dim context As StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: Type;
    info: SerializationInfo;
    context: StreamingContext
);
JScript
public function SerializeObjectData(
   type : Type,
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   Type* type,
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   Type^ type,
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboIntegrationSettings Class
WebComboIntegrationSettings Members


WebComboIntegrationSettings Class Properties

[image]
Intersoft WebCombo Documentation
WebComboIntegrationSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : WebComboIntegrationSettings Class

For a list of all members of this type, see WebComboIntegrationSettings members.

Public Properties

 | Name | Description
public Property | ControlId | Specifies the target server control ID to be integrated according to the specified control type.
public Property | ControlType | Specifies the built-in control type to be integrated in the WebCombo's ResultBox.
public Property | Enabled | Specifies whether WebCombo should integrate the specified control as its ResultBox.
Top

See Also

Reference

WebComboIntegrationSettings Class
ISNet.WebUI.WebCombo Namespace


ControlId Property

[image]
Intersoft WebCombo Documentation
ControlId Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboIntegrationSettings Class : ControlId Property

Specifies the target server control ID to be integrated according to the specified control type.

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies the target server control ID to be integrated according to the specified control type.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<IDReferencePropertyAttribute()>
<TypeConverterAttribute("System.Web.UI.WebControls.ControlIDConverter, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ControlId As String
Visual Basic (Usage) Copy Code
Dim instance As WebComboIntegrationSettings
Dim value As String

instance.ControlId = value

value = instance.ControlId
C#
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the target server control ID to be integrated according to the specified control type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[IDReferencePropertyAttribute()]
[TypeConverterAttribute("System.Web.UI.WebControls.ControlIDConverter, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ISNet.Serialization.BinarySerializableAttribute()]
public string ControlId {get; set;}
Delphi
public read-write property ControlId: String;
JScript
NotifyParentPropertyAttribute()
DefaultValueAttribute()
DescriptionAttribute("Specifies the target server control ID to be integrated according to the specified control type.")
ISNet.Serialization.XmlSerializableAttribute()
IDReferencePropertyAttribute()
TypeConverterAttribute("System.Web.UI.WebControls.ControlIDConverter, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ControlId : String
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the target server control ID to be integrated according to the specified control type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[IDReferencePropertyAttribute()]
[TypeConverterAttribute("System.Web.UI.WebControls.ControlIDConverter, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property string* get_ControlId();
public: __property void set_ControlId(
   string* value
);
C++/CLI
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the target server control ID to be integrated according to the specified control type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[IDReferencePropertyAttribute()]
[TypeConverterAttribute("System.Web.UI.WebControls.ControlIDConverter, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property String^ ControlId {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboIntegrationSettings Class
WebComboIntegrationSettings Members


ControlType Property

[image]
Intersoft WebCombo Documentation
ControlType Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboIntegrationSettings Class : ControlType Property

Specifies the built-in control type to be integrated in the WebCombo's ResultBox.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Specifies the built-in control type to be integrated in the WebCombo's ResultBox.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ControlType As IntegrationControlType
Visual Basic (Usage) Copy Code
Dim instance As WebComboIntegrationSettings
Dim value As IntegrationControlType

instance.ControlType = value

value = instance.ControlType
C#
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies the built-in control type to be integrated in the WebCombo's ResultBox.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public IntegrationControlType ControlType {get; set;}
Delphi
public read-write property ControlType: IntegrationControlType;
JScript
DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
NotifyParentPropertyAttribute()
DescriptionAttribute("Specifies the built-in control type to be integrated in the WebCombo's ResultBox.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ControlType : IntegrationControlType
Managed Extensions for C++
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies the built-in control type to be integrated in the WebCombo's ResultBox.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property IntegrationControlType get_ControlType();
public: __property void set_ControlType(
   IntegrationControlType value
);
C++/CLI
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies the built-in control type to be integrated in the WebCombo's ResultBox.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property IntegrationControlType ControlType {
   IntegrationControlType get();
   void set (    IntegrationControlType value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboIntegrationSettings Class
WebComboIntegrationSettings Members


Enabled Property

[image]
Intersoft WebCombo Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboIntegrationSettings Class : Enabled Property

Specifies whether WebCombo should integrate the specified control as its ResultBox.

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Specifies whether WebCombo should integrate the specified control as its ResultBox.")>
<DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebComboIntegrationSettings
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies whether WebCombo should integrate the specified control as its ResultBox.")]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public bool Enabled {get; set;}
Delphi
public read-write property Enabled: Boolean;
JScript
NotifyParentPropertyAttribute()
DescriptionAttribute("Specifies whether WebCombo should integrate the specified control as its ResultBox.")
DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Enabled : boolean
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies whether WebCombo should integrate the specified control as its ResultBox.")]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property bool get_Enabled();
public: __property void set_Enabled(
   bool value
);
C++/CLI
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies whether WebCombo should integrate the specified control as its ResultBox.")]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property bool Enabled {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboIntegrationSettings Class
WebComboIntegrationSettings Members


WebComboRow Class

[image]
Intersoft WebCombo Documentation
WebComboRow Class
Members Example See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : WebComboRow Class

Represents the data row that belongs to WebCombo object.

Represents the data row that belongs to WebCombo object.

Object Model

WebComboRow Class

Syntax

Visual Basic (Declaration)
<DescriptionAttribute()>
<SerializableAttribute()>
Public Class WebComboRow
   Inherits ISNet.WebUI.NamedObjectBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebComboRow
C#
[DescriptionAttribute()]
[SerializableAttribute()]
public class WebComboRow : ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Delphi
public class WebComboRow = class(ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject)
JScript
DescriptionAttribute()
SerializableAttribute()
public class WebComboRow extends ISNet.WebUI.NamedObjectBase implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Managed Extensions for C++
[DescriptionAttribute()]
[SerializableAttribute()]
public __gc class WebComboRow : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
C++/CLI
[DescriptionAttribute()]
[SerializableAttribute()]
public ref class WebComboRow : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Example

The following example shows you how to add new row and cell to the WebCombo in Unbound mode.
C# Copy Code
private void WebCombo1_InitializeLayout(object sender, ISNet.WebUI.WebCombo.LayoutEventArgs e)
{
   WebComboColumn col = new WebComboColumn();

   WebComboRow row0 = new WebComboRow();
   WebComboCell cell0 = new WebComboCell("Text1");
   row0.Cells.Add(cell0);

   WebComboRow row1 = new WebComboRow();
   WebComboCell cell1 = new WebComboCell("Text2");
   row1.Cells.Add(cell1);

   WebCombo1.Columns.Add(col);
   WebCombo1.Rows.Add(row0);
   WebCombo1.Rows.Add(row1);
}

Remarks

WebComboRow provides advanced configurations for users to create WebCombo in Unbound mode. When a multiple-column WebCombo works in Unbound mode, you can dynamically add new rows and cells to the WebCombo on server postback.

Users can use Cells property to add WebComboCell(s) on WebCombo. However, before creating cell(s) users need to create row(s) first (Shown in the example above). Users can also use CustomObjectAttributes property to assign custom attributes that they want to render along with the row's tag.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebCombo.WebComboRow

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboRow Members
ISNet.WebUI.WebCombo Namespace

Tasks

How-to: Add rows to WebCombo
How-to: Add columns to WebCombo
How-to: Add item in unbound WebCombo from server side

Concepts

All-new, sleeker User Interface
Cleaner and reduced page output through built-in Default Style


WebComboRow Class Members

[image]
Intersoft WebCombo Documentation
WebComboRow Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebCombo Namespace : WebComboRow Class

The following tables list the members exposed by WebComboRow.

Public Constructors

 | Name | Description
public Constructor | WebComboRow Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | Cells | Gets the collection of the WebComboCell objects. Gets the collection of the WebComboCell objects.
public Property | Value | Returns the value of the row based on DataValueField. Returns the value of the row based on DataValueField.
Top

Public Methods

 | Name | Description
public Method | Clone | This method is not intended to be called directly. It is used internally for control developers.
public Method | CopyFrom | Overloaded.
public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | GetObjectData | Overridden.
public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | Reset | This method is not intended to be called directly. It is used internally for control developers.
public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | ToString |
Top

See Also

Reference

WebComboRow Class
ISNet.WebUI.WebCombo Namespace


WebComboRow Constructor

[image]
Intersoft WebCombo Documentation
WebComboRow Constructor
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboRow Class : WebComboRow Constructor

Initializes a new instance of the WebComboRow class.

Overload List

Overload | Description
WebComboRow Constructor() | Initializes a new instance of the WebComboRow class with no argument. The default constructor for the WebComboRow object.
WebComboRow Constructor(WebComboCell) | Initializes a new instance of the WebComboRow class with cell parameter. The constructor for WebComboRow object, given the WebComboCell object.
WebComboRow Constructor(Cells) | Initializes a new instance of the WebComboRow class with cells parameter. The default constructor for the WebComboRow object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboRow Class
WebComboRow Members


WebComboRow Constructor()

[image]
Intersoft WebCombo Documentation
WebComboRow Constructor()
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboRow Class > WebComboRow Constructor : WebComboRow Constructor()

Initializes a new instance of the WebComboRow class with no argument. The default constructor for the WebComboRow object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebComboRow()
C#
public WebComboRow()
Delphi
public WebComboRow();
JScript
public function WebComboRow();
Managed Extensions for C++
public: WebComboRow();
C++/CLI
public:
WebComboRow();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboRow Class
WebComboRow Members
Overload List


WebComboRow Constructor(WebComboCell)

[image]
Intersoft WebCombo Documentation
WebComboRow Constructor(WebComboCell)
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboRow Class > WebComboRow Constructor : WebComboRow Constructor(WebComboCell)

cell
The WebComboCell object to add.
Initializes a new instance of the WebComboRow class with cell parameter. The constructor for WebComboRow object, given the WebComboCell object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal cell As WebComboCell _
)
Visual Basic (Usage) Copy Code
Dim cell As WebComboCell

Dim instance As New WebComboRow(cell)
C#
public WebComboRow(
   WebComboCell cell
)
Delphi
public WebComboRow(
    cell: WebComboCell
);
JScript
public function WebComboRow(
   cell : WebComboCell
);
Managed Extensions for C++
public: WebComboRow(
   WebComboCell* cell
)
C++/CLI
public:
WebComboRow(
   WebComboCell^ cell
)

Parameters

cell
The WebComboCell object to add.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboRow Class
WebComboRow Members
Overload List


WebComboRow Constructor(Cells)

[image]
Intersoft WebCombo Documentation
WebComboRow Constructor(Cells)
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboRow Class > WebComboRow Constructor : WebComboRow Constructor(Cells)

cells
Initializes a new instance of the WebComboRow class with cells parameter. The default constructor for the WebComboRow object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal cells As Cells _
)
Visual Basic (Usage) Copy Code
Dim cells As Cells

Dim instance As New WebComboRow(cells)
C#
public WebComboRow(
   Cells cells
)
Delphi
public WebComboRow(
    cells: Cells
);
JScript
public function WebComboRow(
   cells : Cells
);
Managed Extensions for C++
public: WebComboRow(
   Cells* cells
)
C++/CLI
public:
WebComboRow(
   Cells^ cells
)

Parameters

cells

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboRow Class
WebComboRow Members
Overload List


WebComboRow Class Methods

[image]
Intersoft WebCombo Documentation
WebComboRow Class Methods
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : WebComboRow Class

For a list of all members of this type, see WebComboRow members.

Public Methods

 | Name | Description
public Method | Clone | This method is not intended to be called directly. It is used internally for control developers.
public Method | CopyFrom | Overloaded.
public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | GetObjectData | Overridden.
public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | Reset | This method is not intended to be called directly. It is used internally for control developers.
public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | ToString |
Top

See Also

Reference

WebComboRow Class
ISNet.WebUI.WebCombo Namespace


Clone Method

[image]
Intersoft WebCombo Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboRow Class : Clone Method

This method is not intended to be called directly. It is used internally for control developers.

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clone()
Visual Basic (Usage) Copy Code
Dim instance As WebComboRow

instance.Clone()
C#
public new void Clone()
Delphi
public procedure Clone();
JScript
public hide function Clone();
Managed Extensions for C++
public: new void Clone();
C++/CLI
public:
new void Clone();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboRow Class
WebComboRow Members


CopyFrom Method

[image]
Intersoft WebCombo Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboRow Class : CopyFrom Method

Overload List

Overload | Description
CopyFrom(WebComboRow) |
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboRow Class
WebComboRow Members


CopyFrom(WebComboRow) Method

[image]
Intersoft WebCombo Documentation
CopyFrom(WebComboRow) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboRow Class > CopyFrom Method : CopyFrom(WebComboRow) Method

objSource

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyFrom( _
   ByVal objSource As WebComboRow _
)
Visual Basic (Usage) Copy Code
Dim instance As WebComboRow
Dim objSource As WebComboRow

instance.CopyFrom(objSource)
C#
public void CopyFrom(
   WebComboRow objSource
)
Delphi
public procedure CopyFrom(
    objSource: WebComboRow
);
JScript
public function CopyFrom(
   objSource : WebComboRow
);
Managed Extensions for C++
public: void CopyFrom(
   WebComboRow* objSource
)
C++/CLI
public:
void CopyFrom(
   WebComboRow^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboRow Class
WebComboRow Members
Overload List


CopyFrom(Object) Method

[image]
Intersoft WebCombo Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboRow Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebComboRow
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)
Delphi
public procedure CopyFrom(
    objSource: TObject
); virtual;
JScript
public function CopyFrom(
   objSource : Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboRow Class
WebComboRow Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebCombo Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboRow Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebComboRow
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: TObject;
    cloneSourceValue: Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : Object,
   cloneSourceValue : boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   Object* objSource,
   bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   Object^ objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboRow Class
WebComboRow Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebCombo Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboRow Class : DeSerializeObjectData Method

type
info
context

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebComboRow
Dim type As Type
Dim info As SerializationInfo
Dim context As StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: Type;
    info: SerializationInfo;
    context: StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : Type,
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   Type* type,
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   Type^ type,
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboRow Class
WebComboRow Members


GetObjectData Method

[image]
Intersoft WebCombo Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboRow Class : GetObjectData Method

info
context

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebComboRow
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: SerializationInfo;
    context: StreamingContext
); override;
JScript
public override function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboRow Class
WebComboRow Members


IsEmpty Method

[image]
Intersoft WebCombo Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboRow Class : IsEmpty Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebComboRow
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()
Delphi
public function IsEmpty(): Boolean; virtual;
JScript
public function IsEmpty() : boolean;
Managed Extensions for C++
public: virtual bool IsEmpty();
C++/CLI
public:
virtual bool IsEmpty();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboRow Class
WebComboRow Members


Reset Method

[image]
Intersoft WebCombo Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboRow Class : Reset Method

This method is not intended to be called directly. It is used internally for control developers.

Syntax

Visual Basic (Declaration)
Public Shadows Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebComboRow

instance.Reset()
C#
public new void Reset()
Delphi
public procedure Reset();
JScript
public hide function Reset();
Managed Extensions for C++
public: new void Reset();
C++/CLI
public:
new void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboRow Class
WebComboRow Members


SerializeObjectData Method

[image]
Intersoft WebCombo Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboRow Class : SerializeObjectData Method

type
info
context

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebComboRow
Dim type As Type
Dim info As SerializationInfo
Dim context As StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: Type;
    info: SerializationInfo;
    context: StreamingContext
);
JScript
public function SerializeObjectData(
   type : Type,
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   Type* type,
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   Type^ type,
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboRow Class
WebComboRow Members


ToString Method

[image]
Intersoft WebCombo Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboRow Class : ToString Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WebComboRow
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Delphi
public function ToString(): String; override;
JScript
public override function ToString() : String;
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboRow Class
WebComboRow Members


WebComboRow Class Properties

[image]
Intersoft WebCombo Documentation
WebComboRow Class Properties
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : WebComboRow Class

For a list of all members of this type, see WebComboRow members.

Public Properties

 | Name | Description
public Property | Cells | Gets the collection of the WebComboCell objects. Gets the collection of the WebComboCell objects.
public Property | Value | Returns the value of the row based on DataValueField. Returns the value of the row based on DataValueField.
Top

See Also

Reference

WebComboRow Class
ISNet.WebUI.WebCombo Namespace


Cells Property

[image]
Intersoft WebCombo Documentation
Cells Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboRow Class : Cells Property

Gets the collection of the WebComboCell objects.

Gets the collection of the WebComboCell objects.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Gets the collection of the WebComboCell objects.")>
<NotifyParentPropertyAttribute(True)>
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute("setCells")>
<DefaultValueAttribute()>
Public ReadOnly Property Cells As Cells
Visual Basic (Usage) Copy Code
Dim instance As WebComboRow
Dim value As Cells

value = instance.Cells
C#
[DescriptionAttribute("Gets the collection of the WebComboCell objects.")]
[NotifyParentPropertyAttribute(true)]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setCells")]
[DefaultValueAttribute()]
public Cells Cells {get;}
Delphi
public read-only property Cells: Cells;
JScript
DescriptionAttribute("Gets the collection of the WebComboCell objects.")
NotifyParentPropertyAttribute()
PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute("setCells")
DefaultValueAttribute()
public function get Cells : Cells
Managed Extensions for C++
[DescriptionAttribute("Gets the collection of the WebComboCell objects.")]
[NotifyParentPropertyAttribute(true)]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setCells")]
[DefaultValueAttribute()]
public: __property Cells* get_Cells();
C++/CLI
[DescriptionAttribute("Gets the collection of the WebComboCell objects.")]
[NotifyParentPropertyAttribute(true)]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setCells")]
[DefaultValueAttribute()]
public:
property Cells^ Cells {
   Cells^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboRow Class
WebComboRow Members

Tasks

How-to: Add item in unbound WebCombo from server side

Concepts

Unbound Mode


Value Property

[image]
Intersoft WebCombo Documentation
Value Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboRow Class : Value Property

Returns the value of the row based on DataValueField. Returns the value of the row based on DataValueField.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<DescriptionAttribute("Returns the value of the row based on DataValueField.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
Public Property Value As String
Visual Basic (Usage) Copy Code
Dim instance As WebComboRow
Dim value As String

instance.Value = value

value = instance.Value
C#
[DefaultValueAttribute()]
[DescriptionAttribute("Returns the value of the row based on DataValueField.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public string Value {get; set;}
Delphi
public read-write property Value: String;
JScript
DefaultValueAttribute()
DescriptionAttribute("Returns the value of the row based on DataValueField.")
DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
public function get,set Value : String
Managed Extensions for C++
[DefaultValueAttribute()]
[DescriptionAttribute("Returns the value of the row based on DataValueField.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public: __property string* get_Value();
public: __property void set_Value(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[DescriptionAttribute("Returns the value of the row based on DataValueField.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
public:
property String^ Value {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboRow Class
WebComboRow Members


WebComboValueItem Class

[image]
Intersoft WebCombo Documentation
WebComboValueItem Class
Members See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : WebComboValueItem Class

Items contained in WebCombo multiple selection.

Object Model

WebComboValueItem Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class WebComboValueItem
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebComboValueItem
C#
[SerializableAttribute()]
public class WebComboValueItem : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebComboValueItem = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
SerializableAttribute()
public class WebComboValueItem extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[SerializableAttribute()]
public __gc class WebComboValueItem : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[SerializableAttribute()]
public ref class WebComboValueItem : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Remarks

WebCombo.NET provides strong multiple selection value support. The MultipleSelection feature allows you to insert an item, delete an item and highlight an item. This strong feature also include advanced settings to the ValueItem, such as: AllowBrowseAll, AllowNotInListText, AutoSelectFirstMatch, SeparatorChar.

In MultipleSelection feature, developers are allowed to obtain multiple values on client-side, programmatically add, change or delete an ValueItem, and more.

Users can insert a value item in MultipleSelection by placing the cursor in the position where you want to insert. Then, start typing and press Tab to select an item, and the new item will be properly inserted among other values. If you want to delete a value item, you can do it by using the Delete or Backspace key. You can highlight an item by selecting an item among multiple values and click the region of a valid item. If the clicked item is valid (that is, it has a Value), the item will be highlighted similar to the Microsoft Outlook® 2003 TextBox feature.

For the advanced settings of WebComboValueItem please read the properties in MultipleSelectionSettings.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebCombo.WebComboValueItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboValueItem Members
ISNet.WebUI.WebCombo Namespace


WebComboValueItem Class Members

[image]
Intersoft WebCombo Documentation
WebComboValueItem Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebCombo Namespace : WebComboValueItem Class

The following tables list the members exposed by WebComboValueItem.

Public Constructors

 | Name | Description
public Constructor | WebComboValueItem Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | Text | Gets or sets the text of the value item. Gets or sets the text of the value item.
public Property | Value | Gets or sets the value part of the item. Gets or sets the value part of the item.
Top

Public Methods

 | Name | Description
public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | GetObjectData | Overridden.
public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebComboValueItem Class
ISNet.WebUI.WebCombo Namespace


WebComboValueItem Constructor

[image]
Intersoft WebCombo Documentation
WebComboValueItem Constructor
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboValueItem Class : WebComboValueItem Constructor

Initializes a new instance of the WebComboValue Item class.

Overload List

Overload | Description
WebComboValueItem Constructor() | Initializes a new instance of the WebComboValueItem class with no argument. Constructs WebComboValueItem object without any parameters.
WebComboValueItem Constructor(String,String) | Initializes a new instance of the WebComboValueItem class with specified Text and Value parameters Constructs WebComboValueItem object by specifying the Text and Value parameters.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboValueItem Class
WebComboValueItem Members


WebComboValueItem Constructor()

[image]
Intersoft WebCombo Documentation
WebComboValueItem Constructor()
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboValueItem Class > WebComboValueItem Constructor : WebComboValueItem Constructor()

Initializes a new instance of the WebComboValueItem class with no argument. Constructs WebComboValueItem object without any parameters.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebComboValueItem()
C#
public WebComboValueItem()
Delphi
public WebComboValueItem();
JScript
public function WebComboValueItem();
Managed Extensions for C++
public: WebComboValueItem();
C++/CLI
public:
WebComboValueItem();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboValueItem Class
WebComboValueItem Members
Overload List


WebComboValueItem Constructor(String,String)

[image]
Intersoft WebCombo Documentation
WebComboValueItem Constructor(String,String)
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboValueItem Class > WebComboValueItem Constructor : WebComboValueItem Constructor(String,String)

text
_value
Initializes a new instance of the WebComboValueItem class with specified Text and Value parameters Constructs WebComboValueItem object by specifying the Text and Value parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String, _
   ByVal _value As String _
)
Visual Basic (Usage) Copy Code
Dim text As String
Dim _value As String

Dim instance As New WebComboValueItem(text, _value)
C#
public WebComboValueItem(
   string text,
   string _value
)
Delphi
public WebComboValueItem(
    text: String;
    _value: String
);
JScript
public function WebComboValueItem(
   text : String,
   _value : String
);
Managed Extensions for C++
public: WebComboValueItem(
   string* text,
   string* _value
)
C++/CLI
public:
WebComboValueItem(
   String^ text,
   String^ _value
)

Parameters

text
_value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboValueItem Class
WebComboValueItem Members
Overload List


Clone Method

[image]
Intersoft WebCombo Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboValueItem Class : Clone Method

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As WebComboValueItem
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()
Delphi
public function Clone(): TObject; virtual;
JScript
public function Clone() : Object;
Managed Extensions for C++
public: virtual Object* Clone();
C++/CLI
public:
virtual Object^ Clone();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboValueItem Class
WebComboValueItem Members


CopyFrom Method

[image]
Intersoft WebCombo Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboValueItem Class : CopyFrom Method

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboValueItem Class
WebComboValueItem Members


CopyFrom(Object) Method

[image]
Intersoft WebCombo Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboValueItem Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebComboValueItem
Dim objSource As Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   object objSource
)
Delphi
public procedure CopyFrom(
    objSource: TObject
); virtual;
JScript
public function CopyFrom(
   objSource : Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboValueItem Class
WebComboValueItem Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebCombo Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboValueItem Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebComboValueItem
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: TObject;
    cloneSourceValue: Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : Object,
   cloneSourceValue : boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   Object* objSource,
   bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   Object^ objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboValueItem Class
WebComboValueItem Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebCombo Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboValueItem Class : DeSerializeObjectData Method

type
info
context

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebComboValueItem
Dim type As Type
Dim info As SerializationInfo
Dim context As StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: Type;
    info: SerializationInfo;
    context: StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : Type,
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   Type* type,
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   Type^ type,
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboValueItem Class
WebComboValueItem Members


WebComboValueItem Class Methods

[image]
Intersoft WebCombo Documentation
WebComboValueItem Class Methods
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : WebComboValueItem Class

For a list of all members of this type, see WebComboValueItem members.

Public Methods

 | Name | Description
public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | GetObjectData | Overridden.
public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebComboValueItem Class
ISNet.WebUI.WebCombo Namespace


GetObjectData Method

[image]
Intersoft WebCombo Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboValueItem Class : GetObjectData Method

info
context

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebComboValueItem
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: SerializationInfo;
    context: StreamingContext
); override;
JScript
public override function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboValueItem Class
WebComboValueItem Members


IsEmpty Method

[image]
Intersoft WebCombo Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboValueItem Class : IsEmpty Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebComboValueItem
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()
Delphi
public function IsEmpty(): Boolean; virtual;
JScript
public function IsEmpty() : boolean;
Managed Extensions for C++
public: virtual bool IsEmpty();
C++/CLI
public:
virtual bool IsEmpty();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboValueItem Class
WebComboValueItem Members


Reset Method

[image]
Intersoft WebCombo Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboValueItem Class : Reset Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebComboValueItem

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboValueItem Class
WebComboValueItem Members


SerializeObjectData Method

[image]
Intersoft WebCombo Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboValueItem Class : SerializeObjectData Method

type
info
context

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebComboValueItem
Dim type As Type
Dim info As SerializationInfo
Dim context As StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: Type;
    info: SerializationInfo;
    context: StreamingContext
);
JScript
public function SerializeObjectData(
   type : Type,
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   Type* type,
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   Type^ type,
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboValueItem Class
WebComboValueItem Members


WebComboValueItem Class Properties

[image]
Intersoft WebCombo Documentation
WebComboValueItem Class Properties
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : WebComboValueItem Class

For a list of all members of this type, see WebComboValueItem members.

Public Properties

 | Name | Description
public Property | Text | Gets or sets the text of the value item. Gets or sets the text of the value item.
public Property | Value | Gets or sets the value part of the item. Gets or sets the value part of the item.
Top

See Also

Reference

WebComboValueItem Class
ISNet.WebUI.WebCombo Namespace


Text Property

[image]
Intersoft WebCombo Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboValueItem Class : Text Property

Gets or sets the text of the value item.

Gets or sets the text of the value item.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Gets or sets the text of the value item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As WebComboValueItem
Dim value As String

instance.Text = value

value = instance.Text
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Gets or sets the text of the value item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public string Text {get; set;}
Delphi
public read-write property Text: String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
NotifyParentPropertyAttribute()
DescriptionAttribute("Gets or sets the text of the value item.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Text : String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Gets or sets the text of the value item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Gets or sets the text of the value item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property String^ Text {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboValueItem Class
WebComboValueItem Members


Value Property

[image]
Intersoft WebCombo Documentation
Value Property
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace > WebComboValueItem Class : Value Property

Gets or sets the value part of the item.

Gets or sets the value part of the item.

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<DescriptionAttribute("Gets or sets the value part of the item.")>
Public Property Value As String
Visual Basic (Usage) Copy Code
Dim instance As WebComboValueItem
Dim value As String

instance.Value = value

value = instance.Value
C#
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Gets or sets the value part of the item.")]
public string Value {get; set;}
Delphi
public read-write property Value: String;
JScript
NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
DescriptionAttribute("Gets or sets the value part of the item.")
public function get,set Value : String
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Gets or sets the value part of the item.")]
public: __property string* get_Value();
public: __property void set_Value(
   string* value
);
C++/CLI
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Gets or sets the value part of the item.")]
public:
property String^ Value {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebComboValueItem Class
WebComboValueItem Members


BoundMode Enumeration

[image]
Intersoft WebCombo Documentation
BoundMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : BoundMode Enumeration

Value representing the bound mode of WebCombo.

Syntax

Visual Basic (Declaration)
Public Enum BoundMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As BoundMode
C#
public enum BoundMode : System.Enum
Delphi
public enum BoundMode = class(System.Enum)
JScript
public enum BoundMode extends System.Enum
Managed Extensions for C++
__value public enum BoundMode : public System.Enum
C++/CLI
public enum class BoundMode : public System.Enum

Members

Member | Description
AutoDetect | Automatically detect whether the WebCombo works in DataBound or Unbound mode.
ForceBound | Force the WebCombo works in DataBound mode.
ForceUnbound | Force the WebCombo works in UnBound mode.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebCombo.BoundMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISNet.WebUI.WebCombo Namespace


BoxPosition Enumeration

[image]
Intersoft WebCombo Documentation
BoxPosition Enumeration
Example See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : BoxPosition Enumeration

Value indicating where the status box is located. Enumerations for status of WebCombo control.

Syntax

Visual Basic (Declaration)
Public Enum BoxPosition
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As BoxPosition
C#
public enum BoxPosition : System.Enum
Delphi
public enum BoxPosition = class(System.Enum)
JScript
public enum BoxPosition extends System.Enum
Managed Extensions for C++
__value public enum BoxPosition : public System.Enum
C++/CLI
public enum class BoxPosition : public System.Enum

Members

Member | Description
Bottom | The status box position is on bottom of WebCombo.
Top | The status box position is on top of WebCombo.

Example

The following example shows you how to locate the box position on the bottom using code behind.
C# Copy Code
e.Layout.StatusBoxPosition = BoxPosition.Bottom;

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebCombo.BoxPosition

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISNet.WebUI.WebCombo Namespace


ButtonPosition Enumeration

[image]
Intersoft WebCombo Documentation
ButtonPosition Enumeration
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : ButtonPosition Enumeration

Value indicating the search button position on WebCombo.NET

Syntax

Visual Basic (Declaration)
Public Enum ButtonPosition
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ButtonPosition
C#
public enum ButtonPosition : System.Enum
Delphi
public enum ButtonPosition = class(System.Enum)
JScript
public enum ButtonPosition extends System.Enum
Managed Extensions for C++
__value public enum ButtonPosition : public System.Enum
C++/CLI
public enum class ButtonPosition : public System.Enum

Members

Member | Description
Left | The search button is on the left hand side of the combo.
Right | The search button is on the right hand side of the combo (Default value).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebCombo.ButtonPosition

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISNet.WebUI.WebCombo Namespace


ColLayout Enumeration

[image]
Intersoft WebCombo Documentation
ColLayout Enumeration
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : ColLayout Enumeration

Value indicating the column layout style of WebCombo. Enumerations for column layout.

Syntax

Visual Basic (Declaration)
Public Enum ColLayout
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ColLayout
C#
public enum ColLayout : System.Enum
Delphi
public enum ColLayout = class(System.Enum)
JScript
public enum ColLayout extends System.Enum
Managed Extensions for C++
__value public enum ColLayout : public System.Enum
C++/CLI
public enum class ColLayout : public System.Enum

Members

Member | Description
Auto | The column layout style is auto.
Fixed | The column layout style is fixed.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebCombo.ColLayout

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISNet.WebUI.WebCombo Namespace


ColumnType Enumeration

[image]
Intersoft WebCombo Documentation
ColumnType Enumeration
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : ColumnType Enumeration

Value representing the column type of WebCombo ColumnType Enumeration.

Syntax

Visual Basic (Declaration)
Public Enum ColumnType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ColumnType
C#
public enum ColumnType : System.Enum
Delphi
public enum ColumnType = class(System.Enum)
JScript
public enum ColumnType extends System.Enum
Managed Extensions for C++
__value public enum ColumnType : public System.Enum
C++/CLI
public enum class ColumnType : public System.Enum

Members

Member | Description
Custom | Cells that belong to a column with this setting can be fully customized from within runtime code. Cells that belong to a column with this setting can be fully customized from within runtime code.
Image | Cells that belong to a column with this setting will display only an image that specified in CellImage or its own Image property.Cells that belong to a column with this setting will display only an image that specified in WebGridColumn.CellImage or its own Image property.
ImageAndText | Cells that belong to a column with this setting will display an image that specified in CellImage or its own Image property and text.Cells that belong to a column with this setting will display an image that specified in WebGridColumn.CellImage or its own Image property and text.
Text | Cells that belong to a column with this setting will display only text. Cells that belong to a column with this setting will display only text.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebCombo.ColumnType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISNet.WebUI.WebCombo Namespace


EmptyAction Enumeration

[image]
Intersoft WebCombo Documentation
EmptyAction Enumeration
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : EmptyAction Enumeration

Value indicating the action to be performed when this WebCombo is selected while the specified ParentWebCombo has no value.

Syntax

Visual Basic (Declaration)
Public Enum EmptyAction
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As EmptyAction
C#
public enum EmptyAction : System.Enum
Delphi
public enum EmptyAction = class(System.Enum)
JScript
public enum EmptyAction extends System.Enum
Managed Extensions for C++
__value public enum EmptyAction : public System.Enum
C++/CLI
public enum class EmptyAction : public System.Enum

Members

Member | Description
PromptMessage | WebCombo will prompt a message if the ParentWebCombo contains no value (The default behavior).
ShowEmptyResult | WebCombo will show empty result if the ParentWebCombo contains no value.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebCombo.EmptyAction

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISNet.WebUI.WebCombo Namespace


EntryMode Enumeration

[image]
Intersoft WebCombo Documentation
EntryMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : EntryMode Enumeration

Value representing the entry behavior of WebCombo.NET

Syntax

Visual Basic (Declaration)
Public Enum EntryMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As EntryMode
C#
public enum EntryMode : System.Enum
Delphi
public enum EntryMode = class(System.Enum)
JScript
public enum EntryMode extends System.Enum
Managed Extensions for C++
__value public enum EntryMode : public System.Enum
C++/CLI
public enum class EntryMode : public System.Enum

Members

Member | Description
AutoComplete | This entry mode has same behavior as Default entry mode, but with text auto completion to first-matched item of the results. The AutoComplete mode behaves much like in traditional IE 4.x days which is still preferred by many end users today.
Default | The default entry behavior of WebCombo.NET
InstantLookup | This entry mode allows quick data input and has WebCombo validate it only on "Enter" or lost focus conditions. In case that the input data has perfect match in database, no resultbox will be shown.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebCombo.EntryMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISNet.WebUI.WebCombo Namespace


IntegrationControlType Enumeration

[image]
Intersoft WebCombo Documentation
IntegrationControlType Enumeration
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : IntegrationControlType Enumeration

Syntax

Visual Basic (Declaration)
Public Enum IntegrationControlType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As IntegrationControlType
C#
public enum IntegrationControlType : System.Enum
Delphi
public enum IntegrationControlType = class(System.Enum)
JScript
public enum IntegrationControlType extends System.Enum
Managed Extensions for C++
__value public enum IntegrationControlType : public System.Enum
C++/CLI
public enum class IntegrationControlType : public System.Enum

Members

Member | Description
Custom |
WebContextMenu |
WebTreeView |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebCombo.IntegrationControlType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISNet.WebUI.WebCombo Namespace


LoadMoreKeyGesture Enumeration

[image]
Intersoft WebCombo Documentation
LoadMoreKeyGesture Enumeration
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : LoadMoreKeyGesture Enumeration

Syntax

Visual Basic (Declaration)
Public Enum LoadMoreKeyGesture
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As LoadMoreKeyGesture
C#
public enum LoadMoreKeyGesture : System.Enum
Delphi
public enum LoadMoreKeyGesture = class(System.Enum)
JScript
public enum LoadMoreKeyGesture extends System.Enum
Managed Extensions for C++
__value public enum LoadMoreKeyGesture : public System.Enum
C++/CLI
public enum class LoadMoreKeyGesture : public System.Enum

Members

Member | Description
DownArrowKey |
PageDownKey |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebCombo.LoadMoreKeyGesture

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISNet.WebUI.WebCombo Namespace


Mode Enumeration

[image]
Intersoft WebCombo Documentation
Mode Enumeration
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : Mode Enumeration

Value representing the Combo mode of WebCombo.NET Enumerations for WebCombo's mode.

Syntax

Visual Basic (Declaration)
Public Enum Mode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As Mode
C#
public enum Mode : System.Enum
Delphi
public enum Mode = class(System.Enum)
JScript
public enum Mode extends System.Enum
Managed Extensions for C++
__value public enum Mode : public System.Enum
C++/CLI
public enum class Mode : public System.Enum

Members

Member | Description
MultipleColumns | WebCombo will display all columns in the DataSource. DataTextField field will always at the first position and its width is set to the width of control by default.
SingleColumn | The default value. WebCombo will work as a normal dropdownlist control. It will display the data according to the DataTextField and DataValueField. Other columns in DataSource will not be displayed.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebCombo.Mode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISNet.WebUI.WebCombo Namespace


NoResultFoundAction Enumeration

[image]
Intersoft WebCombo Documentation
NoResultFoundAction Enumeration
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : NoResultFoundAction Enumeration

Value indicating the action if the user has typed in a value and switched to another input, but no results found for the typed value.

Syntax

Visual Basic (Declaration)
Public Enum NoResultFoundAction
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As NoResultFoundAction
C#
public enum NoResultFoundAction : System.Enum
Delphi
public enum NoResultFoundAction = class(System.Enum)
JScript
public enum NoResultFoundAction extends System.Enum
Managed Extensions for C++
__value public enum NoResultFoundAction : public System.Enum
C++/CLI
public enum class NoResultFoundAction : public System.Enum

Members

Member | Description
FocusAndShowResultBox | The combo will get focus and result box will be displayed.
RevertSelection | The selection will be reverted and the text will be disappeared.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebCombo.NoResultFoundAction

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISNet.WebUI.WebCombo Namespace


ParentFilterMode Enumeration

[image]
Intersoft WebCombo Documentation
ParentFilterMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : ParentFilterMode Enumeration

Value indicating which key field of the parent WebCombo that should be used for filtering this WebCombo data.

Syntax

Visual Basic (Declaration)
Public Enum ParentFilterMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ParentFilterMode
C#
public enum ParentFilterMode : System.Enum
Delphi
public enum ParentFilterMode = class(System.Enum)
JScript
public enum ParentFilterMode extends System.Enum
Managed Extensions for C++
__value public enum ParentFilterMode : public System.Enum
C++/CLI
public enum class ParentFilterMode : public System.Enum

Members

Member | Description
UseDataTextField | The combo will filter the data based on DataTextField of parent WebCombo.
UseDataValueField | The combo will filter the data based on DataValueField of parent WebCombo.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebCombo.ParentFilterMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISNet.WebUI.WebCombo Namespace


SearchMode Enumeration

[image]
Intersoft WebCombo Documentation
SearchMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : SearchMode Enumeration

Value indicating the search icon mode of WebCombo.NET Enumerations for SearchIcon's mode.

Syntax

Visual Basic (Declaration)
Public Enum SearchMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SearchMode
C#
public enum SearchMode : System.Enum
Delphi
public enum SearchMode = class(System.Enum)
JScript
public enum SearchMode extends System.Enum
Managed Extensions for C++
__value public enum SearchMode : public System.Enum
C++/CLI
public enum class SearchMode : public System.Enum

Members

Member | Description
Graphic | The search icon of WebCombo is in graphic mode.
Text | The search icon of WebCombo is in text mode.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebCombo.SearchMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISNet.WebUI.WebCombo Namespace


TextboxMode Enumeration

[image]
Intersoft WebCombo Documentation
TextboxMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : TextboxMode Enumeration

Value indicating the text box mode on WebCombo.NET TextboxMode Enumeration.

Syntax

Visual Basic (Declaration)
Public Enum TextboxMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As TextboxMode
C#
public enum TextboxMode : System.Enum
Delphi
public enum TextboxMode = class(System.Enum)
JScript
public enum TextboxMode extends System.Enum
Managed Extensions for C++
__value public enum TextboxMode : public System.Enum
C++/CLI
public enum class TextboxMode : public System.Enum

Members

Member | Description
Editable | The textbox portion of the control is editable. This is the default value. The textbox portion of the control is editable. This is the default value.
ReadOnly | The textbox portion of the control is read only (not editable). The textbox portion of the control is read only (not editable).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebCombo.TextboxMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISNet.WebUI.WebCombo Namespace


DataSourceEventHandler Delegate

[image]
Intersoft WebCombo Documentation
DataSourceEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : DataSourceEventHandler Delegate

sender
e
Delegate that handles the InitializeDataSource event.Delegate that handles the WebCombo.InitializeDataSource event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataSourceEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataSourceEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataSourceEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataSourceEventHandler(
   object sender,
   DataSourceEventArgs e
)
Delphi
public delegate DataSourceEventHandler(
    sender: TObject;
    e: DataSourceEventArgs
);
JScript
public delegate DataSourceEventHandler(
   sender : Object,
   e : DataSourceEventArgs
)
Managed Extensions for C++
public: __gc __delegate void DataSourceEventHandler(
   Object* sender,
   DataSourceEventArgs* e
)
C++/CLI
public delegate void DataSourceEventHandler(
   Object^ sender,
   DataSourceEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataSourceEventHandler Members
ISNet.WebUI.WebCombo Namespace


LayoutEventHandler Delegate

[image]
Intersoft WebCombo Documentation
LayoutEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : LayoutEventHandler Delegate

sender
e
Delegate that handles the InitializeLayout event.Delegate that handles the WebCombo.InitializeLayout event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub LayoutEventHandler( _
   ByVal sender As Object, _
   ByVal e As LayoutEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New LayoutEventHandler(AddressOf HandlerMethod)
C#
public delegate void LayoutEventHandler(
   object sender,
   LayoutEventArgs e
)
Delphi
public delegate LayoutEventHandler(
    sender: TObject;
    e: LayoutEventArgs
);
JScript
public delegate LayoutEventHandler(
   sender : Object,
   e : LayoutEventArgs
)
Managed Extensions for C++
public: __gc __delegate void LayoutEventHandler(
   Object* sender,
   LayoutEventArgs* e
)
C++/CLI
public delegate void LayoutEventHandler(
   Object^ sender,
   LayoutEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutEventHandler Members
ISNet.WebUI.WebCombo Namespace


PostBackEventHandler Delegate

[image]
Intersoft WebCombo Documentation
PostBackEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : PostBackEventHandler Delegate

sender
e
Delegate that handles the InitializePostBack event.Delegate that handles the WebCombo.InitializePostBack event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub PostBackEventHandler( _
   ByVal sender As Object, _
   ByVal e As PostbackEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New PostBackEventHandler(AddressOf HandlerMethod)
C#
public delegate void PostBackEventHandler(
   object sender,
   PostbackEventArgs e
)
Delphi
public delegate PostBackEventHandler(
    sender: TObject;
    e: PostbackEventArgs
);
JScript
public delegate PostBackEventHandler(
   sender : Object,
   e : PostbackEventArgs
)
Managed Extensions for C++
public: __gc __delegate void PostBackEventHandler(
   Object* sender,
   PostbackEventArgs* e
)
C++/CLI
public delegate void PostBackEventHandler(
   Object^ sender,
   PostbackEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PostBackEventHandler Members
ISNet.WebUI.WebCombo Namespace


RowEventHandler Delegate

[image]
Intersoft WebCombo Documentation
RowEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : RowEventHandler Delegate

sender
e
Delegate that handles the InitializeRow event.Delegate that handles the WebCombo.InitializeRow event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub RowEventHandler( _
   ByVal sender As Object, _
   ByVal e As RowEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New RowEventHandler(AddressOf HandlerMethod)
C#
public delegate void RowEventHandler(
   object sender,
   RowEventArgs e
)
Delphi
public delegate RowEventHandler(
    sender: TObject;
    e: RowEventArgs
);
JScript
public delegate RowEventHandler(
   sender : Object,
   e : RowEventArgs
)
Managed Extensions for C++
public: __gc __delegate void RowEventHandler(
   Object* sender,
   RowEventArgs* e
)
C++/CLI
public delegate void RowEventHandler(
   Object^ sender,
   RowEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RowEventHandler Members
ISNet.WebUI.WebCombo Namespace


ValueChangedEventHandler Delegate

[image]
Intersoft WebCombo Documentation
ValueChangedEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebCombo Namespace : ValueChangedEventHandler Delegate

sender
e
The delegate that handles the ValueChanged event, which is invoked when the value of WebCombo control is changed.The delegate that handles the WebCombo.ValueChanged event, which is invoked when the value of WebCombo control is changed.

Syntax

Visual Basic (Declaration)
Public Delegate Sub ValueChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As ValueChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ValueChangedEventHandler(AddressOf HandlerMethod)
C#
public delegate void ValueChangedEventHandler(
   object sender,
   ValueChangedEventArgs e
)
Delphi
public delegate ValueChangedEventHandler(
    sender: TObject;
    e: ValueChangedEventArgs
);
JScript
public delegate ValueChangedEventHandler(
   sender : Object,
   e : ValueChangedEventArgs
)
Managed Extensions for C++
public: __gc __delegate void ValueChangedEventHandler(
   Object* sender,
   ValueChangedEventArgs* e
)
C++/CLI
public delegate void ValueChangedEventHandler(
   Object^ sender,
   ValueChangedEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ValueChangedEventHandler Members
ISNet.WebUI.WebCombo Namespace


Client-side References

Client-side References
Send Feedback
Intersoft WebCombo > Client-side References

Glossary Item Box

This section is designated to help user working with client-side references in WebCombo.

In This Section

WebCombo Global Functions

WebComboCell

WebComboClientSideEvents

WebComboLayout

WebComboRow

WebComboTextSet

WebComboColumn

WebCombo

WebComboLinkSettings

WebComboMultipleSelectionSettings

WebComboValueItem


WebCombo Global Functions
Send Feedback
Intersoft WebCombo > Client-side References > WebCombo Global Functions

Glossary Item Box

WebCombo Global Functions
wcGetComboById Description
Gets the WebCombo instance given the ID of the combo.

Parameters
id ( string )
The ID of the WebCombo instance.

Return Value
object (WebCombo)

Samples
Gets the combo instance by ID, using ISGetObject() is preferred.

var combo = wcGetComboById("WebCombo1");
alert(combo.GetRows().length);
wc_getValue Description
Gets the value of the WebCombo object given the ID of the combo.

Parameters
name ( string )
The ID of the WebCombo object.

Return Value
object

Samples
This sample alerts the value of the combo.

function getValue() {
// will return a value if an item has been selected.
alert( wc_getValue("WebCombo1"));
}

wc_setAdditionalFilters Description
Sets additional filters for a WebCombo instance.

Parameters
name ( string )
The ID of the WebCombo instance.
filters ( string )
The filter text to be applied.

Return Value
void

Samples
This sample shows how to filter the ContactName field to names that start with 'An'.

function setAdditionalFilter()
{
wc_setAdditionalFilters("WebCombo1", "[ContactName] LIKE 'An%'");
}

wc_getText Description
Gets the displayed text of the WebCombo object given the ID of the combo.

Parameters
name ( string )
The ID of the WebCombo instance.

Return Value
string

Samples
This sample alerts the text of the combo.

function getText() {
// will return the text if there is text displayed in the combo.
alert( wc_getText("WebCombo1"));
}


WebComboCell

WebComboCell
Send Feedback
Intersoft WebCombo > Client-side References > WebComboCell

Glossary Item Box

WebComboCell Properties

Row | Description Gets the Row object that owns this cell. ValueType object (WebComboRow) Default Value -
Position | Description Gets the position of the cell in the collection. ValueType integer Default Value -
Text | Description Gets or sets the text that will be displayed in the cell. ValueType string Default Value -
Tag | Description Gets or sets custom data for the cell object. ValueType string Default Value -
Value | Description Gets or sets the cell value. ValueType object Default Value -
Column | Description Gets the WebComboColumn object to which this cell belongs. ValueType object (WebComboColumn) Default Value -
Image | Description Gets or sets the image filename that is used to display image of an Image or ImageAndText Column. ValueType string Default Value -
TooltipText | Description Gets or sets the ToolTip text of the cell object. ValueType string Default Value -


WebComboClientSideEvents

WebComboClientSideEvents
Send Feedback
Intersoft WebCombo > Client-side References > WebComboClientSideEvents

Glossary Item Box

WebComboClientSideEvents Properties

OnBeforeRequest | Description Specifies the client-side function to be invoked when a request is about to be made. ValueType string Default Value -
OnResponse | Description Specifies the client-side function to be invoked when a response is returned from the server. ValueType string Default Value -
OnBeforeItemSelected | Description Specifies the client-side function to be invoked when an item is about to be selected. ValueType string Default Value -
OnAfterItemSelected | Description Specifies the client-side function to be invoked after an item is selected. This event is similar to the SelectedIndexChanged of a regular DropDownList control. ValueType string Default Value -
OnError | Description Specifies the client-side function to be invoked when an error response is received from the server. ValueType string Default Value -
OnLostFocus | Description Specifies the client-side function to be invoked when the the control loses its focus. ValueType string Default Value -
OnAddItem | Description Specifies the client-side function to be invoked when an item is about to be added. ValueType string Default Value -
OnUnhandledError | Description Specifies the client-side function to be invoked when an unhandled error happens. ValueType string Default Value -
OnInitialize | Description Specifies the client-side function to be invoked when WebCombo is being initialized. ValueType string Default Value -
OnMatchInstantLookup | Description Specifies the client-side function to be invoked when a perfect match is found when using InstantLookup EntryMode. ValueType string Default Value -
OnActionDispatched | Description Specifies the client-side function to be invoked when a successful response to an event is received from the server. ValueType string Default Value -
OnAfterResponseProcess | Description Specifies the client-side function to be invoked after a response is received from the server irregardless of an error happening or not. ValueType string Default Value -
OnKeyDown | Description Specifies the client-side function to be invoked when a keypress is made on the combo. ValueType string Default Value -
OnShowDropDown | Description Specifies the client-side function to be invoked when the result box of a combo is being shown. ValueType string Default Value -
OnValueItemContextMenu | Description Specifies the client-side function to be invoked when the context menu of a WebComboValueItem is about to be shown. This event will be invoked only when the MultipleSelection mode is enabled. ValueType string Default Value -
OnValueItemNotInList | Description Specifies the client-side function to be invoked after the combo loses its focus and when the entered value item is not in the result box list. ValueType string Default Value -


WebComboLayout

WebComboLayout
Send Feedback
Intersoft WebCombo > Client-side References > WebComboLayout

Glossary Item Box

WebComboLayoutSet Properties

Combo | Description A reference to the WebCombo object that contains the Layout. ValueType object (WebCombo) Default Value -
AlwaysShowResultBox | Description Specifies the top position adjustment for ResultBox object. ValueType boolean Default Value false
AlwaysShowHelpButton | Description Specifies whether the help button is displayed. ValueType boolean Default Value true
AlwaysShowSearchButton | Description Specifies whether the dropdown arrow button is displayed. ValueType boolean Default Value true
AlwaysShowColumnHeaders | Description Specifies whether the column headers is displayed when ComboMode is set to MultipleColumns. ValueType boolean Default Value true
ComboMode | Description Specifies the mode of the WebCombo control. ValueType string Default Value "SingleColumn"
SearchIconMode | Description Specifies the mode of search icon. ValueType string Default Value "Text"
StatusBoxPosition | Description Specifies the status box position. ValueType string Default Value "Top"
SearchImage | Description Specifies the image for search icon. ValueType string Default Value -
HelpImage | Description Specifies the image for Help. ValueType string Default Value "wc_help16.gif"
ItemHeight | Description Specifies the default item row height. ValueType string Default Value "20px"
ClientSideEvents | Description Represents ClientEvents object that hold list of client events ValueType object (WebComboClientEvents) Default Value -
AllowNavigationOnMouseWheel | Description Specifies whether navigation of records is allowed when moving the mouse wheel. ValueType boolean Default Value true
ColumnWidthDefault | Description Specifies the column width default. Only affected to MultipleColumns mode. ValueType string Default Value "100px"
TextSettings | Description Represents a TextSet object which contains text used in WebCombo control. ValueType object (TextSet) Default Value -
ScriptDirectory | Description Gets the WebCombo script directory path ValueType string Default Value "/CommonLibrary/WebCombo/V3_0_3000/"
ImagesDirectory | Description Gets the WebCombo's images directory path ValueType string Default Value "/CommonLibrary/Images/"
AdjustResultBoxTop | Description Specifies the top position adjustment for ResultBox object. ValueType integer Default Value 0
AdjustResultBoxLeft | Description Specifies the left position adjustment for ResultBox object. ValueType integer Default Value 0
AllowTextWrapping | Description Gets or sets whether overflow text will be wrapped to next line. If set to false, the overflow text will be truncated with ellipsis. ValueType boolean Default Value false
ResultBoxWidth | Description Gets or sets the width of the result box. Set this property to 0 for automatic width calculation. ValueType integer Default Value 0
ResultBoxHeight | Description Gets or sets the height of the result box. ValueType integer Default Value 200
StatusBoxVisible | Description Specifies whether the status box is visible. ValueType boolean Default Value true
AllowAddItem | Description Specifies whether item addition is allowed when input text doesn't match any list items. ValueType boolean Default Value false
TextBoxMode | Description Gets or sets the textbox mode of the control. ValueType string Default Value "Editable"
AlwaysShowAllRowsOnDropdown | Description Determines whether or not to display all rows when dropdown arrow is clicked. ValueType boolean Default Value false
BoundMode | Description Gets or sets the bound mode of WebCombo. ValueType string Default Value "AutoDetect"
EntryMode | Description Gets or sets the entry behavior of WebCombo. ValueType string Default Value "Default"
SearchButtonPosition | Description Gets or sets the location of the Search Button (Left or Right). ValueType string Default Value "Right"
FrameStyle | Description The style applied to the frame of the control. ValueType string Default Value -
TextBoxStyle | Description The style applied to the textbox control. ValueType string Default Value -
DropDownStyle | Description The style applied to the DropDown ValueType string Default Value -
RowStyle | Description The styles applied to row. ValueType string Default Value -
MoreButtonStyle | Description The style applied to more button. ValueType string Default Value -
ResultFrameStyle | Description The styles applied to result frame (the outer result box). ValueType string Default Value -
ResultBoxStyle | Description The sytle applied to result box (only the box that contain data) ValueType string Default Value -
StatusBoxStyle | Description The styles applied to status box. ValueType string Default Value -
HeaderStyle | Description The styles applied to columns header. ValueType string Default Value -
ColumnStyle | Description The styles applied to column. ValueType string Default Value -
SelectedRowStyle | Description The styles applied to selected row. ValueType string Default Value -
NoResultFoundAction | Description Specified the action when there is no matched result. ValueType string Default Value "RevertSelection"


WebComboRow

WebComboRow
Send Feedback
Intersoft WebCombo > Client-side References > WebComboRow

Glossary Item Box

WebComboRow Properties

Cells | Description Gets the collection of the WebGridCell objects. ValueType object (WebGridCells) Default Value -
Combo | Description Gets the WebCombo instance that owns the row. ValueType object (WebCombo) Default Value -
Position | Description Gets the ordinal position of the row object. ValueType integer Default Value -
Value | Description Returns the value of the row based on DataValueField. ValueType object Default Value -
RowElement | Description Returns the row element of the WebGridRow object. ValueType string Default Value -


WebComboTextSet

WebComboTextSet
Send Feedback
Intersoft WebCombo > Client-side References > WebComboTextSet

Glossary Item Box

WebComboTextSet Properties

LoadingText | Description Specifies the loading text. ValueType String Default Value "Loading..."
SearchText | Description Specifies the search text. ValueType String Default Value "Search for"
NoResultsText | Description Specifies the no results text. ValueType String Default Value "No results found."
RetrievedTextFormat | Description Specifies the retrieved text format. ValueType String Default Value "{retrieved} of {totalrows} retrieved."
HelpTitleText | Description Specifies the text that will appear when mouse is over the Help button. ValueType String Default Value "Help"
MoreTitleText | Description Specifies the text that will appear when mouse is over the More button. ValueType String Default Value "More records."
UnhandledErrorText | Description Specifies the text that will appear in the error box when an unhandled exception occured. ValueType String Default Value "Unhandled exception occurred. See following for details."
ParentEmptyPromptText | Description Specifies the text used for the prompt when ParentEmptyAction is set to PromptMessage. ValueType String Default Value "Please select a value for following WebCombo input: {0}"


WebComboColumn

WebComboColumn
Send Feedback
Intersoft WebCombo > Client-side References > WebComboColumn

Glossary Item Box

WebComboColumn Properties

Combo | Description Returns the WebCombo object that owns this column. ValueType object (WebCombo) Default Value -
HeaderText | Description Returns or sets the header text for the column. ValueType string Default Value -
Position | Description The ordinal position of the column. ValueType integer Default Value -
BaseFieldName | Description Returns or sets the base field name of the column. You should never set this property manually as it is populated automatically on DataBind. ValueType string Default Value -
Width | Description Specifies the width of the column. ValueType integer Default Value -
Hidden | Description Specifies whether the column should be displayed or hidden. ValueType boolean Default Value -
Bound | Description Specifies whether the column is bound to the DataColumn of DataSource. ValueType boolean Default Value -
ColumnType | Description Gets or sets the type of the column that determines how the column content will be rendered. ValueType string Default Value -
DataType | Description Gets or sets the data type of the column. ValueType string Default Value -
CellImage | Description Gets or sets the image filename that will be displayed in cells that belong to this column. ValueType string Default Value -
DataFormatString | Description Gets or sets the string format to use when rendering values. ValueType string Default Value -
Name | Description Gets or sets the name of the column. ValueType string Default Value -
RenderOnHidden | Description Specifies whether the column should be rendered when it is hidden. ValueType boolean Default Value -


WebCombo

WebCombo
Send Feedback
Intersoft WebCombo > Client-side References > WebCombo

Glossary Item Box

WebCombo Properties

ClassName | Description The ClassName of WebCombo. ValueType string Default Value -
Version | Description The Version of WebCombo. ValueType string Default Value -
MajorVersion | Description The Major Version of WebCombo. ValueType string Default Value -
RequiredFrameworkVersion | Description The minimum required WebUI.NET framework version in order to run WebCombo. ValueType string Default Value -
Text | Description The selected text of the WebCombo. ValueType string Default Value -
Value | Description The selected value of the WebCombo. ValueType string Default Value -
TextBoxLength | Description The size of the TextBox control. ValueType integer Default Value -
DropDownRows | Description The number of initial records retrieved by the WebCombo control. ValueType integer Default Value -
AutoLoad | Description Specifies whether the control should automatically make initial request on page load. ValueType boolean Default Value -
ShowErrorMessages | Description Specifies whether to show Error Messages. ValueType boolean Default Value -
Latency | Description Specifies the wait time after last key press in milliseconds before the control make data request. ValueType integer Default Value -
AllowAutoPostback | Description Specifies whether Postback will be automatically invoked when selected index is changed. ValueType boolean Default Value -
DataValueField | Description Gets or sets the field used as the value in WebCombo control. ValueType string Default Value -
DataTextField | Description Gets or sets the data field used to display the text in WebCombo control. ValueType string Default Value -
LayoutSettings | Description Gets the LayoutSettings object which is the central object that contain all the behaviors and styles for the whole WebCombo control. ValueType object (LayoutSettings) Default Value -
LinkSettings | Description Gets or Sets the LinkSettings object. ValueType object (LinkSettings) Default Value -
MultipleSelectionSettings | Description Gets or Sets the MultipleSelectionSettings object. ValueType object (MultipleSelectionSettings) Default Value -
AdditionalFiltersText | Description Gets or sets the additional filter text for WebCombo control. ValueType string Default Value -
AllowAutoQueryHandler | Description Specifies whether to allow WebCombo to automatically handle query request. ValueType boolean Default Value -
Columns | Description Gets the WebComboColumn object. ValueType object (WebComboColumn) Default Value -
AdditionalSearchFields | Description Gets or sets the additional data field used to match rows against user input. ValueType string Default Value -
AllowWildCardSearch | Description Specifies whether to allow wild card searching / fuzzy logic searching. ValueType boolean Default Value -
MinCharsToRequest | Description Gets or sets the minimum length of input character for requesting data retrieval. ValueType integer Default Value -
Name | Description Gets the WebCombo instance name. ValueType string Default Value -
LastAction | Description Gets the last action performed by the WebCombo. ValueType string Default Value -
TotalRetrievedRows | Description Gets the number of rows which have been retrieved by the WebCombo. ValueType integer Default Value -
TotalRows | Description Gets the number of all rows which should be loaded by WebCombo. ValueType integer Default Value -
FlyPostBackSettings | Description Gets the OnTheFly�?� PostBack settings utilized by WebCombo. ValueType object (FlyPostBack) Default Value -
ResultBoxShown | Description Determines whether the result box should be shown. ValueType boolean Default Value -
IsDirty | Description Determines whether WebCombo has been modified. ValueType boolean Default Value -
IsInProgress | Description Determines whether WebCombo is currently processing data. ValueType boolean Default Value -
IsMoreRequest | Description Determines whether WebCombo needs to perform more request. ValueType boolean Default Value -
NeedClearList | Description Determines NeedClearList value. ValueType boolean Default Value -
LastSelectedIndex | Description Gets the last selected index of last selected record. ValueType integer Default Value -
SelectedIndex | Description Gets the currently selected index of WebCombo record. ValueType integer Default Value -
ForceDropDown | Description Determines whether the dropdown should be displayed. ValueType boolean Default Value -
IsDataBound | Description Determines whether the combo is in unbound mode or bound mode. ValueType boolean Default Value -
UnboundDataInitialized | Description Gets the unbound data initialization. ValueType object Default Value -
InsertAtTop | Description Determines whether the previously added record should be inserted at the end of the collection or at the beginning of the collection. ValueType boolean Default Value -
LastError | Description Gets the last error message during WebCombo processing mode. ValueType string Default Value -
FoundPerfectMatch | Description Determines whether WebCombo successfully finds a perfect match record. ValueType boolean Default Value -
FastPostBack | Description Determines whether Fast PostBack should be performed. ValueType boolean Default Value -
SensitiveSearch | Description Determines whether case sensitive search mode should be performed. ValueType boolean Default Value -
TextObj | Description Gets the Text object of the WebCombo. ValueType object (INPUT HTML element) Default Value -
SearchObj | Description Gets the Search object of the WebCombo. ValueType object (SPAN HTML element) Default Value -

WebCombo Methods

SendCustomRequest Description
Invoke WebCombo's OnTheFly PostBack in order to perform custom actions from the client side and then respond the requested action at the server side

Parameters
-

Remarks
SendCustomRequest method will invoke server side InitializePostBack event.

Return Value
void

Samples
Invokes OnTheFly PostBack event.

function InvokeSendCustomRequest()
{
// Obtain WebCombo object
var combo = ISGetObject("WebCombo1");
// Invoke WebCombo's OnTheFly PostBack
combo.SendCustomRequest();
return true;
}
IsValueInRange Description
Determines whether the Value is in the list.

Parameters
-

Remarks
This method is quite useful in bound mode.

Return Value
boolean

Samples

function CustomFunction()
{
var combo = ISGetObject("WebCombo1");
alert( combo.IsValueInRange());
return true;
}

GetImagesFolder

Description
Gets the image directory of the WebCombo which has been defined using ImagesDirectory value.

Parameters

-

Remarks

-

Return Value
string

Samples
Obtain WebCombo's ImagesDirectory property value.

function GetImagesFolder()
{
// Obtain WebCombo object
var combo = ISGetObject("WebCombo1");
// Obtain WebCombo's ImagesDirectory property value
alert(combo.GetImagesFolder());
return true;
}

ShowDropDown

Description
Instructs WebCombo to show its DropDown symbol.

Parameters

-

Remarks

-

Return Value
void

Samples
Force WebCombo to show its DropDown symbol.

function CustomFunction()
{
// Obtain WebCombo object
var combo = ISGetObject("WebCombo1");
// Force WebCombo to show its DropDown symbol
combo.ShowDropDown();
return true;
}
HideDropDown

Description
Instructs WebCombo not to show its DropDown symbol.

Parameters

-

Remarks

-

Return Value
void

Samples
Force WebCombo not to show its DropDown symbol.

function CustomFunction()
{
// Obtain WebCombo object
var combo = ISGetObject("WebCombo1");
// Force WebCombo not to show its DropDown symbol
combo.HideDropDown();
return true;
}
SetSelectedIndex Description
Highlight a record in the WebCombo's records collection by inserting the record's index.

Parameters
i ( integer )
The index of the record (starting from zero)

Remarks

-

Return Value
void

Samples
Select the second record of the WebCombo's records.

function CustomFunction()
{
// Obtain WebCombo object
var combo = ISGetObject("WebCombo1");
// Select the second record of the WebCombo's records
combo.SetSelectedIndex(1);
return true;
}
SetSelectedRowByValue Description
Highlight a record in the WebCombo records collection by matching a string value.

Parameters
v ( string )
The value of the WebCombo's record in order to be looked up.

Remarks

-

Return Value
void

Samples
Highlight the record with key value = "ALFKI".

function CustomFunction()
{
// Obtain WebCombo object
var combo = ISGetObject("WebCombo1");
// Highlight the record with key value = "ALFKI"
combo.SetSelectedRowByValue("ALFKI");
return true;
}
SetText Description
Configure the WebCombo text.

Parameters
s ( string )
The WebCombo's Text (DataTextField) which is inserted.
sameValue ( boolean )
Determines whether the value of the correspond's text is the same with the text.
false

Remarks

Remember to invoke LoadValue() method after using SetText() method, in order to instruct WebCombo to fetch the Value of the correspond inserted Text from the server. The LoadValue() method is required for Bound mode, because when a new text is set, the WebCombo doesn't have the related Value in client side since the data has not been loaded. This method is not required for Unbound mode.

Return Value
void

Samples
Configure the WebCombo's text.

function CustomFunction()
{
// Obtain WebCombo object
var combo = ISGetObject("WebCombo1");
// Configure the WebCombo's text
combo.SetText("Condiments");

// required only for Bound mode, instructs the WebCombo
// to fetch the Value from server.
// this method is required for Bound mode because when
// a new text is set,
// the WebCombo doesn't have the related Value in
// client side since the data has not been loaded.
// this method is not required for Unbound mode.
combo.LoadValue();
return true;
}

LoadValue Description
Instructs the WebCombo to fetch the Value from server

Parameters
useSync ( boolean )
Determines whether the LoadValue method is performing the function synchronously or asynchronously. If the synchronous mode is used by inserting true value, then developers can obtain the direct value after the LoadValue method is invoked.
false

Remarks

Remember to invoke LoadValue() method after using SetText() method, in order to instruct WebCombo to fetch the Value of the correspond inserted Text from the server. The LoadValue() method is required for Bound mode, because when a new text is set, the WebCombo doesn't have the related Value in client side since the data has not been loaded. This method is not required for Unbound mode.

Return Value
void

Samples
Instructs the WebCombo to fetch the Value from server.

function CustomFunction()
{
// Obtain WebCombo object
var combo = ISGetObject("WebCombo1");
// Configure the WebCombo's text
combo.SetText("Condiments");
// required only for Bound mode, instructs the WebCombo
// to fetch the Value from server.
// this method is required for Bound mode because when
// a new text is set,
// the WebCombo doesn't have the related Value in
// client side since the data has not been loaded.
// this method is not required for Unbound mode.
combo.LoadValue();
return true;
}

SetValue Description
Configure the WebCombo's Value.

Parameters
v ( string )
The Value of the WebCombo to be inserted.

Remarks

-

Return Value
void

Samples
Configure the WebCombo's Value

function CustomFunction()
{
// Obtain WebCombo object
var combo = ISGetObject("WebCombo1");
// Configure the WebCombo's value
combo.SetValue("ALFKI");
return true;
}

GetTextBoxValue

Description
Obtains the value inside the TextBox portion of the WebCombo. The value inside the TextBox portion is NOT the WebCombo's Text (DataTextField).

Parameters

-

Remarks

-

Return Value
string

Samples
Gets the value inside the TextBox portion of the WebCombo. The value inside the TextBox portion is NOT the WebCombo's Text (DataTextField).

function CustomFunction()
{
// Obtain WebCombo object
var combo = ISGetObject("WebCombo1");
// Obtains the value inside the TextBox
// portion of the WebCombo
combo.GetTextBoxValue();
return true;
}
SetTextBoxValue Description
Sets the value inside the TextBox portion of the WebCombo. The value inside the TextBox portion is NOT the WebCombo's Text (DataTextField).

Parameters
v ( string )
The string or value that needs to be displayed in the TextBox portion of WebCombo.

Remarks

-

Return Value
void

Samples
Sets the value inside the TextBox portion of the WebCombo.

function CustomFunction()
{
// Obtain WebCombo object
var combo = ISGetObject("WebCombo1");
// Sets the value inside the TextBox
// portion of the WebCombo
combo.SetTextBoxValue("Please select the CustomerID");
return true;
}

ClearSelection

Description
Instructs WebCombo to clear any currently selected item.

Parameters

-

Remarks

-

Return Value
void

Samples
Instructs WebCombo to clear any currently selected item.

function CustomFunction()
{
// Obtain WebCombo object
var combo = ISGetObject("WebCombo1");
// Instructs WebCombo to clear any currently selected item
combo.ClearSelection();
return true;
}

NewRow Description
Instantiates a new row complete with its cells definitions.

Parameters
v ( string )
The KeyValue of the inserted string.

Remarks

-

Return Value
object (WebComboRow)

Samples
Instantiates a new row with NEWCUST as the KeyValue, containing cells with empty value.

function CustomFunction()
{
// obtain WebCombo object
var combo = ISGetObject("WebCombo1");

// get the WebCombo4's rows for addition
var rows = combo.GetRows();

// instantiate new row with NEWCUST as the KeyValue, containing cells with empty value
var newRow = combo.NewRow("NEWCUST");

// get the cells of the new row for value assignment
var cells = newRow.GetCells();

// write codes in the same way as in server-side object model, with similar object hierarchy.
cells.GetNamedItem("ContactName").Text = "New Customer";

// assign value to Address Cell
cells.GetNamedItem("Address").Text = "New Address";
cells.GetNamedItem("CustomerID").Text = "NEWCUST";

//add the newRow to the rows collection
rows.Add(newRow);

// instruct WebCombo to update the user interface accordingly to the changes in Rows object.
combo.UpdateUI();

alert("NEWCUST row added!");
return true;
}

GetSelectedValueItem

Description
Gets currently selected ValueItem.

Parameters

-

Remarks

-

Return Value
object (WebComboValueItem)

Samples
Get currently selected ValueItem

function CustomFunction()
{
var combo = ISGetObject("WebCombo1");
alert(combo.GetSelectedValueItem());
return true;
}

ClearSelectedValueItem

Description
Clear any currently selected ValueItem.

Parameters

-

Remarks

-

Return Value
void

Samples
Clear currently selected ValueItem

function CustomFunction()
{
var combo = ISGetObject("WebCombo1");
combo.ClearSelectedValueItem();
return true;
}
GetRows

Description
Gets WebComboRow object collection.

Parameters

-

Remarks

-

Return Value
object (WebComboRow) collection

Samples
Populate Row objects on demand

function CustomFunction()
{
// Obtain WebCombo object
var combo = ISGetObject("WebCombo1");
// populate Row objects on demand in order to access it
var rows = combo.GetRows();
var count = rows.length;

if (count > 20) count = 20;
for (var i=0; i<count; i++)
s += "Row " + i + " : " + "Value=" + rows[i].Value + " ";

alert("WebCombo1 has " + rows.length + " row(s). The rows are: " + s + " ...");
return true;
}
GetRowsCount

Description
Gets the number of loaded rows.

Parameters

-

Remarks

-

Return Value
integer

Samples
Gets the number of loaded rows.

function CustomFunction()
{
// Obtain WebCombo object
var combo = ISGetObject("WebCombo1");
// Show the number of loaded rows
alert(combo.GetRowsCount());
return true;
}

GetRow Description
Gets the WebComboRow object from a certain index.

Parameters
v ( integer )
The row index of the intended row (starting from zero).

Remarks

-

Return Value
object (WebComboRow)

Samples
Gets the first row.

function CustomFunction()
{
// Obtain WebCombo object
var combo = ISGetObject("WebCombo1");
// get WebComboRow at position 0
var row0 = combo.GetRow(0);

if (row0 != null)
{
// access to WebComboCell at position 0 of the row
var cell0 = row0.GetCell(0);
var cellElement = cell0.GetElement();

if (cellElement)
{
// change the html element's fore color style to Red
cellElement.style.color = "red";
alert("HTML Element of WebCombo2's Row 0, Cell0 found. The fore color has been changed to Red.");
combo.SetFocus();
combo.ShowDropDown();
}
}
}

GetSelectedRow

Description
Gets the WebComboRow object of the currently selected row.

Parameters

-

Remarks

-

Return Value
object (WebComboRow)

Samples
Gets the selected WebComboRow object.
function CustomFunction()
{
// Obtain WebCombo object
var combo = ISGetObject("WebCombo1");
// Gets the selected WebComboRow object
var row0 = combo.GetSelectedRow();
return true;

}

Disable

Description
Disable the WebCombo

Parameters

-

Remarks

-

Return Value
void

Samples
Disables WebCombo.

function CustomFunction()
{
// Obtain WebCombo object
var combo = ISGetObject("WebCombo1");
// Disable WebCombo
combo.Disable();
return true;

}

Enable

Description
Enable the WebCombo.

Parameters

-

Remarks

-

Return Value
void

Samples
Enables WebCombo.

function CustomFunction()
{
// Obtain WebCombo object
var combo = ISGetObject("WebCombo1");
// Enable WebCombo
combo.Enable();
return true;

}

SetFocus Description
Give the current WebCombo's a focus.

Parameters

Remarks
-

Return Value
void

Samples
Gives focus to WebCombo1.

function CustomFunction()
{
// Obtain WebCombo object
var combo = ISGetObject("WebCombo1");
// Give focus to WebCombo1
combo.SetFocus();
return true;

}
Show

Description
Show the WebCombo.

Parameters

-

Remarks

-

Return Value
void

Samples
Shows the WebCombo1.

function CustomFunction()
{
// Obtain WebCombo object
var combo = ISGetObject("WebCombo1");
// Show the WebCombo1
combo.Show();
return true;

}

Hide Description
Hides the WebCombo.

Parameters

Remarks
-

Return Value
void

Samples
Hides the WebCombo1.

function CustomFunction()
{
// Obtain WebCombo object
var combo = ISGetObject("WebCombo1");
// Hide the WebCombo1
combo.Hide();
return true;

}
AddItem Description
Add an item to the WebCombo's records collection.

Parameters
text ( string )
The text (DataTextField) part of the new data.

value ( string )

The value (DataValueField) of the new data.

columndata ( object (Array) )

The array containing the all the data in each columns.

Remarks

-

Return Value
void

Samples
Add an item to the WebCombo.

function DoAdd()
{
var combo = ISGetObject("WebCombo1");
var tblNew = document.getElementById("tblNew");
combo.AddItem(document.forms[0].txtContactName.value, document.forms[0].txtCustID.value, new Array(document.forms[0].txtContactName.value, document.forms[0].txtContactTitle.value, document.forms[0].txtCompanyName.value) );
tblNew.style.display = "none";
}
UpdateUI

Description
Instructs WebCombo to update the user interface accordingly to the changes in Rows object.

Parameters

-

Remarks

-

Return Value
void

Samples
Instructs WebCombo to update the user interface accordingly to the changes in Rows object.

function CustomFunction()
{
// get the WebCombo4's rows for addition
var rows = wc4.GetRows();

// instantiate new row with NEWCUST as the KeyValue, containing cells with empty value
var newRow = wc4.NewRow("NEWCUST");

var cells = newRow.GetCells();

// write codes in the same way as in server-side object model, with similar object hierarchy.

cells.GetNamedItem("ContactName").Text = "New Customer";

// assign value to Address Cell
cells.GetNamedItem("Address").Text = "New Address";
cells.GetNamedItem("CustomerID").Text = "NEWCUST";

//add the newRow to the rows collection
rows.Add(newRow);

// instruct WebCombo to update the user interface accordingly to the changes in Rows object.
wc4.UpdateUI();
alert("NEWCUST row added!");
}
GetLastAction

Description
Gets the last action performed by WebCombo.

Parameters

-

Remarks

-

Return Value
string

Samples
Gets the last action performed by WebCombo.

function CustomFunction()
{
var combo = ISGetObject("WebGrid1");
alert(combo.GetLastAction());
return true;
}
UpdateState

Description
Instructs WebCombo to update its current state.

Parameters

-

Remarks

-

Return Value
void

Samples
Utilizing UpdateState method

function CustomFunction()
{
var combo = ISGetObject("WebCombo1");
combo.UpdateState();
return true;
}

DoResize

Description
Instructs WebCombo to resize its current layout because of the changes in style.

Parameters

-

Remarks

-

Return Value
void

Samples
Utilizing DoResize method.

function CustomFunction()
{
var combo = ISGetObject("WebCombo1");
combo.DoResize();
return true;
}

UnhighlightRow Description
Unhighlights currently highlighted row.

Parameters
row ( object (WebComboRow) )
The WebComboRow type of the row

Remarks

-

Return Value
void

Samples
Unhighlight the 13th row

function CustomFunction()
{
var combo = ISGetObject("WebCombo1");
// get all rows
var rows = combo.GetRows();
// get the 13th row
var row = rows[12];
// highlight the 13th row
row.Select();
// unhighlight the 13th row
combo.UnhighlightRow(row);
return true;
}

InitializeUnboundMode

Description
Prepare the WebCombo in order to utilize UnBound mode

Parameters

-

Remarks

-

Return Value
void

Samples
Using InitializeUnboundMode method

function CustomFunction()
{
var combo = ISGetObject("WebCombo1");
combo.InitializeUnboundMode();
return true;
}
SetAdditionalFilters Description
Sets the additional filter constraints in order to filter the contents of the WebCombo

Parameters
s ( string )
The definition of the filter constraints

Remarks

-

Return Value
void

Samples
Configure additional filter in order to filter the contents of the WebCombo3

function OnCheckBoxClick()
{
var chkBox = document.getElementById("CheckBox1");
var combo2 = ISGetObject("WebCombo2");
var combo3 = ISGetObject("WebCombo3");

if (chkBox.checked)
{
if (combo2.Value == null || combo2.Value == "")
{
alert("Please select a category !");
chkBox.checked = false;
return;
}
else
{
combo3.SetAdditionalFilters("[CategoryID] = " + combo2.Value);
}
}
else
{
combo3.ClearAdditionalFilters();
}
}
ClearAdditionalFilters

Description
Clears any additional filters text which has been defined before using SetAdditionalFilters method

Parameters

-

Remarks

-

Return Value
void

Samples
Clear any additional filters defined on the WebCombo3

function OnCheckBoxClick()
{
var chkBox = document.getElementById("CheckBox1");
var combo2 = ISGetObject("WebCombo2");
var combo3 = ISGetObject("WebCombo3");

if (chkBox.checked)
{
if (combo2.Value == null || combo2.Value == "")
{
alert("Please select a category !");
chkBox.checked = false;
return;
}
else
{
combo3.SetAdditionalFilters("[CategoryID] = " + combo2.Value);
}
}
else
{
combo3.ClearAdditionalFilters();
}
}
SetMultipleValues Description
Sets the MultipleValues

Parameters
text ( string )
The text (DataTextField) part

value ( string )

The value (DataValueField) part

Remarks

-

Return Value
void

Samples
SetMultipleValues sample

function CustomFunction()
{
var combo = ISGetObject("WebCombo1");
combo.SetMultipleValues("Anne", "9");
return true;
}
GetMultipleValues

Description
Gets MultipleSelection values

Parameters

-

Remarks

-

Return Value
string

Samples
GetMultipleValues sample

function GetValues()
{
var combo = ISGetObject("WebCombo1");
var values = combo.GetMultipleValues();

if (values == null || values.length == 0)
{
alert("There are no values in WebCombo1!");
}
else
{
var s = "";
for(var i=0; i<values.length; i++)
{
var valueItem = values[i];
s += "Text='" + valueItem.Text + "'; Value='" + valueItem.Value + "'" + " ";
}
alert("Values entered in WebCombo1 are: " + s);
}
}
GetMultipleValuesText

Description
Gets MultipleValues text

Parameters

-

Remarks

-

Return Value
string

Samples
GetMultipleValuesText sample

function CustomFunction()
{
var combo = ISGetObject("WebCombo1");
alert(combo.GetMultipleValuesText());
return true;
}

GetMultipleValuesValue

Description
Gets MultipleValues value

Parameters

-

Remarks

-

Return Value
string

Samples
GetMultipleValuesValue sample

function CustomFunction()
{
var combo = ISGetObject("WebCombo1");
alert(combo.GetMultipleValuesValue());
return true;
}

RefreshValueItems

Description
Refresh the ValueItems list with the current one.

Parameters

-

Remarks

-

Return Value
void

Samples

function CustomFunction()
{
var combo = ISGetObject("WebCombo1");
combo.RefreshValueItems();
return true;
}

RefreshTextByValueItems

Description
Refresh the correspondent text of the textbox portion of the WebCombo given latest ValueItems.

Parameters

-

Remarks

-

Return Value

void

Samples

function CustomFunction()
{
var combo = ISGetObject("WebCombo1");
combo.RefreshTextByValueItems();
return true;
}


WebComboLinkSettings

WebComboLinkSettings
Send Feedback
Intersoft WebCombo > Client-side References > WebComboLinkSettings

Glossary Item Box

WebComboLinkSettings Properties

Enabled | Description Gets or sets whether the link feature should be enabled for this WebCombo instance ValueType boolean Default Value False
FilterDataMember | Description Gets or sets the data member within the DataSource which should be used for filtering during automatic lookup ValueType string Default Value -
ParentFilterMode | Description Gets or sets which key field of the parent WebCombo that should be used for filtering this WebCombo data ValueType string Default Value -
ParentWebComboID | Description Gets or sets the parent WebCombo's ID which this instance should be linked to ValueType string Default Value -
ResolvedParentWebComboID | Description Gets the resolved parent WebCombo ID ValueType string Default Value -
ParentWebCombo | Description Gets the parent WebCombo object ValueType object (WebCombo) Default Value -
ParentEmptyAction | Description Gets or sets the action to be performed when the user requests data for this WebCombo instance, but the specified ParentWebCombo(s) are still empty (no value selected) ValueType string Default Value -
SkipQueryTextField | Description Gets or sets the value indicating whether WebCombo should query the text based on the DataTextField ValueType string Default Value -


WebComboMultipleSelectionSettings

WebComboMultipleSelectionSettings
Send Feedback
Intersoft WebCombo > Client-side References > WebComboMultipleSelectionSettings

Glossary Item Box

WebComboMultipleSelectionSettings Properties

Enabled | Description Gets or sets whether the multiple selections feature should be enabled. ValueType boolean Default Value false
SeparatorChar | Description Gets or sets the separator character used to separate multiple values in the textbox. ValueType char Default Value ';'
ItemContextMenu | Description Gets or sets the Intersoft WebComboContextMenu object to be displayed when right clicking an item. ValueType - Default Value -
AllowNotInListText | Description Gets or sets whether WebCombo should accept text which is not in the list. ValueType boolean Default Value false
AutoSelectFirstMatch | Description Gets or sets whether WebCombo should automatically select first row of matched items against input text. ValueType boolean Default Value true
AllowBrowseAll | Description Gets or sets whether WebCombo should allow the user to browse all list by pressing Ctrl+Space key. ValueType boolean Default Value false


WebComboValueItem

WebComboValueItem
Send Feedback
Intersoft WebCombo > Client-side References > WebComboValueItem

Glossary Item Box

WebComboValueItem Properties

Text | Description Gets or sets the text of the value item. ValueType string Default Value -
Value | Description Gets or sets the value of the value item. ValueType string Default Value -
Position | Description Gets or sets the position of the value item. ValueType integer Default Value -
StartPos | Description Gets the start index character for the specified value item. ValueType integer Default Value -
EndPos | Description Gets the end index character for the specified value item. ValueType integer Default Value -
IsSelected | Description Specifies whether the specified value item is selected (highlighted). ValueType boolean Default Value -


Support and Community

Support and Community
See Also Send Feedback
Intersoft WebCombo > Support and Community

Glossary Item Box

Intersoft Solutions provides full product support for all controls available in WebUI Studio. This topic outlines a number of ways to get product support, get involved with the community, as well as obtaining product updates.

Blogs

Intersoft development team members and community leaders author a variety of blogs that target ASP.NET web development in general using the recommended guidelines and best practice. The blogs often discuss interesting topics such as database access and connectivity challenges, as well as samples, videos and latest development news.

Visit Intersoft WebUI Studio Blog.

Forums

The Intersoft Community Forums is the best place where you can post your questions and technical problems, as well as discussing on the latest application development trend around the WebUI Studio controls.

Blending the modern minimalist styling and lightweight user interface, Intersoft Community is designed to be your most resource-wealth technical community center. You can create a new thread to ask question or simply to start a discussion, reply other user's questions or rate your most favorite threads – everything you need for a productive forum activity.

Visit Intersoft Community Forums.

Support Center

Intersoft Support Center provides a wealth of product resources and literatures that help you quickly find the solutions to your problems. With the intuitive navigation, you can quickly navigate to a product page, read the tutorial, watch getting started videos, browse knowledge base and latest development blogs and more.

Visit Intersoft Support Center.

Feedback Center

Issues can sometimes be difficult to resolve, or irresolvable. Such situations arise because of bugs in the technology, difficulties applying the technology to particular scenarios, or lack of support for particular scenarios. This information is important to Intersoft, and can be provided via the Product Feedback Center in Intersoft Developer Network.

Intersoft Developer Network is a web-based portal for its customers to send feedback, work with support inquiries, manage development accounts and download licensed products. You can use the user credentials in the purchase receipt email that sent from Intersoft Accounts when you purchased the product.

Items posted on the Product Feedback Center are routed to the Intersoft team's internal database. Consequently, it is the most reliable way to get your feedback to the product feature owner. In addition, you can validate and track suggestions and bugs as well as vote on them, which helps the development team to prioritize issues and feature requests.

Contact Technical Support

Depending on the support level agreement (SLA) as part of the benefits that you received from your purchase, you can contact our technical support through various ways such as email or phone call. More comprehensive support levels such as instant messaging and real-time web-based chat support are also provided. Please visit Intersoft Support Level site to learn your support benefits and find out the most convenient way for you to contact us.

Checking for Product Updates

Intersoft WebUI Studio® includes an update manager application which allows you to easily download and install new updates. Product hotfixes are released on monthly basis to provide the most time-efficient enhancements and values to existing customers. To check, download and install for updates, simply launch Update Manager from Intersoft WebUI Studio program group.

The following illustration shows the Update Manager application interface.

Bug Reports

When submitting the bug report, make sure you have following information to avoid multiple communication roundtrip:

  • Product Edition (if applicable)
  • Full Product Version. E.g.: 4.0.7200
  • Browsers (with Full Version, including Service Packs or HotFixes if any)
  • Operating System (with Full Version, including Service Packs or HotFixes if any)
  • Development Environment Products
  • Development Environment Versions
  • Affected Machines: Development, Production Server or Both
  • Monitors: Single or Dual

You also might need to provide issue-specific information such as:

  • Current results/behaviors
  • Expected results/behaviors
  • Steps to reproduce
  • Working/Compilable samples

See Also

Product Support
Support Options


Bug Reports

Bug Reports
See Also Send Feedback
Intersoft WebCombo > Support and Community > Bug Reports

Glossary Item Box

Please submit any bugs or product issues to webcombosupport@intersoftpt.com

When submitting the bug report, make sure you have following information to avoid multiple communication roundtrip:

  • Product Edition (if applicable)
  • Full Product Version. E.g.: 4.0.7200
  • Browsers (with Full Version, including Service Packs or HotFixes if any)
  • Operating System (with Full Version, including Service Packs or HotFixes if any)
  • Development Environment Products
  • Development Environment Versions
  • Affected Machines: Development, Production Server or Both
  • Monitors: Single or Dual

You also might need to provide issue-specific information such as:

  • Current results/behaviors
  • Expected results/behaviors
  • Steps to reproduce
  • Working/Compilable samples

See Also

Product Support
Support Options
Support and Community


Support Options

Support Options
See Also Send Feedback
Intersoft WebCombo > Support and Community > Support Options

Glossary Item Box

WebCombo for ASP.NET is developed and fully supported by Intersoft Solutions Corp. The company provides several methods for registered customers to obtain technical supports.

Online Support

All of WebCombo users have free access to our online support at www.intersoftpt.com which includes latest product updates, bug fixes, FAQ, hundreds of Knowledge Base Articles.

Standard Email Support

You can also send email to webcombosupport@intersoftpt.com for product troubleshooting or bugs. Please provides information on the product version, operating system name and version as well as your development environment and its version. Your email will be answered shortly by our technical support team.

The turnaround time for standard email support is 72 hours (at the latest).

Before sending out your email, we highly recommend you to initially search for the information on locally installed Reference and Online Support.

Developer Network Support

The company provides a rich web-based forums for registered customers to discuss about the product. You may find information and answer to your questions in the forums, or simply posting your message in the forums and our technical support team will answer it in short time.

To access the Developer Network, please go to Intersoft website and click on Developer Network.

Login details are required to access Developer Network. Please refer to your original order receipt sent from Intersoft Accounts. If you do not get the automated order receipt, please contact accounts@intersoftpt.com

Priority Support Options

The new Priority Support option allows registered customers to obtain technical support via direct e-mail or telephone support from our Senior Support Engineer.

This option is designated for advanced customers who require faster response time. The inquiries types are mostly intermediate to advanced involving application-specific scenarios, minor feature requests, quick patches and more.

For more information about the Priority Support pricing and online purchase, please visit Intersoft Solutions web site at http://www.intersoftpt.com.

Phone Support

Phone Support is currently available only for registered customers who have purchased Priority Support. You can reach Technical Support through following numbers:

  • +62 21 25556680
  • +62 21 25556681
Please have your UserID ready when calling.

For pre-sales phone support, you may contact our Authorized Distributor at no costs.

See Also

Product Support
Support and Community
Bug Reports


Licensing

Licensing
See Also Send Feedback
Intersoft WebCombo > Licensing

Glossary Item Box

This topic provides links to information about the licensing mechanism in WebCombo which includes design-time licensing for development seat and application licensing for deployment. The link to the software license agreement is also provided in the sections below.

In This Section

License Agreement

Contains information about Software License Agreement for the end users.

Copyright Information

Provides information about the copyrights and trademarks of Intersoft Solutions products.

See Also

Product Support
Support and Community


Assembly Overview

ISNet.WebUI.WebCombo Assembly
See Also Send Feedback

Namespaces

Namespace | Description
ISNet.WebUI.WebCombo |


Getting Started - Intersoft WebCombo Documentation

Getting Started
Send Feedback


Introduction - Intersoft WebCombo Documentation

Introduction
Send Feedback


License Agreement

License Agreement
Send Feedback
Intersoft WebCombo > Licensing > License Agreement

Glossary Item Box

VERY IMPORTANT -- By installing the WebCombo 5 software (herein the 'SOFTWARE') developed by Intersoft Solutions Corp (hereinafter the 'VENDOR'), you are accepting the following License Agreement.

I. LICENSE AGREEMENT. This is a legal agreement between you (either an individual or a single entity) and VENDOR. By installing the SOFTWARE you are agreeing to be bound by the terms of this agreement. If you do not agree to the terms of this agreement, please kindly click the [CANCEL] icon to exit now. The installation process will be immediately terminated.

II. OWNERSHIP; GRANT OF LICENSE. This is a license agreement and NOT an agreement for sale. The VENDOR hereby grants to you, and you accept, a non-exclusive, non-transferable license to use, copy and modify the SOFTWARE only as authorized below.

III. PERMITTED USES. This LICENSE grants you the following rights:

A. The SOFTWARE is licensed per individual developer. You may make copies on more than one computer, as long as the use of the SOFTWARE is by the same developer. If you have purchased a "multi-pack" license, you may use a copy of the SOFTWARE identified in the multi-pack on the number of computers associated with the multi-pack (e.g. a five user multi-pack allows you to use the SOFTWARE on up to five computers concurrently or by five different developers, the ten user multi-pack on up to ten computers concurrently or by ten different developers). The SOFTWARE is in "use" on a computer when it is loaded into temporary memory (i.e. RAM) or installed into permanent memory (e.g. hard disk, CD-ROM, or other storage devise) of that computer. However, installation on a network server for the sole purpose of internal distribution to one or more other computer(s) shall not constitute "use" for which a separate license is required, provided you have a separate license for each computer to which the SOFTWARE is distributed.

B. Solely with respect to electronic documents included with the SOFTWARE, you may make a copy (either in hardcopy or electronic form) for each developer for which the Software has been licensed as described in Section III.A, above; provided, that such copies shall be used only by such developer for internal purposes and are not to be republished or distributed to any other third party.

C. Runtime and redistributable files. You may deploy your web applications using the SOFTWARE to any number of production server or clients with no additional charges. The SOFTWARE runtime files shouldn't be modified in any ways prior to deploying and all copyright notices should be retain.

IV. PROHIBITED USES. You may not, without the prior written permission of the VENDOR:

A. Disassemble, decompile or "unlock", decode or otherwise reverse translate or engineer, or attempt in any manner to reconstruct or discover any source code or underlying algorithms of SOFTWARE provided in object code form only.

B. Use, copy, modify, or merge copies of the SOFTWARE and any accompanying documents except as permitted in this LICENSE.

C. Transfer, rent, lease, or sublicense the SOFTWARE.

D. Separate the software programs comprising the SOFTWARE for use by more than one user at a time.

V. COPYRIGHT. All title and copyrights in and to the SOFTWARE (including but not limited to any images, photographs, animation, video, audio, music, text and "applets" incorporated into the SOFTWARE) and the accompanying printed materials are owned by the VENDOR or its suppliers. The SOFTWARE is protected by Indonesian copyright laws and international treaty provisions. All rights are reserved worldwide. You must treat the SOFTWARE like any other copyrighted material, except that you may, in addition to the copies permitted in this LICENSE, make one copy of the SOFTWARE solely for backup or archival purposes. No part of the accompanying printed materials may be reproduced, transmitted, transcribed, stored in any retrieval system, or translated into any language by any means without the express prior written permission of the VENDOR.

VI. TERMINATION

A. This LICENSE and your right to use the SOFTWARE will terminate immediately without notice from the VENDOR if you fail to comply with the terms and conditions of this LICENSE. Upon termination, you agree to destroy the SOFTWARE, including all accompanying documents and copies. This is in addition to and not in lieu of any criminal, civil or other remedies available to the VENDOR.

B. The VENDOR has the right to perform temporary or permanent TERMINATION to this LICENSE upon the detection of license violation described in Section III A. The SOFTWARE has implemented Installation Tracker which is used to increment the number of installations during the installation of SOFTWARE. Related to Section III A, the LICENSE will be temporarily or permanently terminated upon the detection of unauthorized transfer or distribution of the LICENSE to either private or public web site, or to ANY medium.

C. ANY VIOLATION TO THE COPYRIGHT, OR TO THIS LICENSE AGREEMENT, MAY RESULT IN SEVERE CIVIL AND CRIMINAL PENALTIES, AND WILL BE PROSECUTED TO THE MAXIMUM EXTENT POSSIBLE UNDER THE LAW.

VII. LIMITED WARRANTY.

A. The VENDOR warrants that the SOFTWARE will perform substantially in accordance with the accompanying printed materials or officially "online" documented materials for a period of thirty (30) days from the date of receipt. The VENDOR does not warranty that the SOFTWARE will be error-free.

B. Your exclusive remedy under the performance warranty set forth in Section X.A, shall be, at VENDOR's option, either (a) return of the purchase price paid, or (b) repair or replacement of the defective SOFTWARE. SOFTWARE purchased other than directly from the VENDOR shall be returned to the place it was purchased. This limited warranty is void if failure of the SOFTWARE has resulted from accident, abuse, or misapplication. Any replacement SOFTWARE will be warranted for the remainder of the original thirty (30) day period.


Copyright Information

Copyright Information
See Also Send Feedback
Intersoft WebCombo > Licensing > Copyright Information

Glossary Item Box

Information in this document, including URL and other Internet Web site references, is subject to change without notice. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Intersoft Solutions Corp.

Intersoft Solutions, Intersoft Solutions Logo, A Better Web Experience, WebUI.NET Framework, WebUI.NET Framework Logo, WebUI Studio.NET Family, WebCombo.NET, WebGrid.NET, WebGrid.NET Enterprise, WebInput.NET, WebUIControls.NET are either trademarks or registered trademarks of Intersoft Solutions Corporation.

Copyright © 2003-2011 Intersoft Solutions Corp. All rights reserved.

ActiveX, Internet Explorer, Microsoft, Visual Basic, Visual Basic .NET, Visual C# .NET, Visual C++ .NET, Visual Studio, Visual Studio .NET, Windows, Windows 95, Windows 98, Windows 2000, Windows Millennium Edition, Windows .NET server family, Windows NT, Windows XP and Windows Vista are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

The names of actual companies and products mentioned herein may be the trademarks or registered trademarks of their respective owners.

See Also

Licensing
License Agreement


a
about
after
against
all
along
also
although
am
among
an
and
are
as
at
be
became
because
been
being
between
but
by
can
caution
come
could
details
did
do
does
doing
done
during
each
early
far
finally
for
found
from
had
has
have
he
her
here
his
how
however
I
if
in
include
including
information
into
is
it
its
late
later
made
many
may
me
med
might
more
most
near
no
non
none
nor
not
note
of
off
on
only
or
other
over
saw
see
seen
several
she
since
so
some
such
than
that
the
their
them
then
there
these
they
this
those
through
tip
to
too
under
until
up
us
use
very
warning
was
we
were
when
where
which
while
who
with
you